What's New in the User's Guide?

  • The contents have been updated to include documentation for the latest cdma2000 application revisions, E1962B B.13 and E6702B B.06.

  • The contents have been updated for the E6702T Special High Data Rate cdma2000 Lab Application, revision T.03. If you have the E6702T, click here to learn how this guide applies to you: E6702T User Documentation .

Note: If you have an older cdma2000 application, then this guide will contain features that are not available in your application. Refer to the Release Notes to determine what these features are and to download the guide that is specific to your application.

Take Advantage of Your cdma2000/IS-95/AMPS Test and Lab Applications

  • Click on the links in the Contents box to find specific information about your test and lab applications.

  • For information on how to use the features that are common to the E1962B, E6702B and E6702T, see the 1xEV-DO online user's guide located at:

    http://wireless.agilent.com/rfcomms/refdocs/cdma2k/default.php

  • If you are unfamiliar with this product, or don't know where to find the information you need, see Getting Started with the cdma2000 Test and Lab Applications .


Legal Information

Acknowledgements

Microsoft ® is a U.S. registered trademark of Microsoft Corporation

Windows ® and MS Windows ® are U.S. registered trademarks of Microsoft Corporation.

Adobe ® Acrobat ® are trademarks of Adobe Systems Incorporated.

Notice

The hardware and/or software described in this document are furnished under a license and may be used or copied only in accordance with the terms of such license.

If software is for use in the performance of a U.S. Government prime contract or subcontract, Software is delivered and licensed as "Commercial computer software" as defined in DFAR 252.227-7014 (June 1995), or as a "commercial item" as defined in FAR 2.101(a) or as "Restricted computer software" as defined in FAR 52.227-19 (June 1987) or any equivalent agency regulation or contract clause. Use, duplication or disclosure of Software is subject to Agilent Technologies’ standard commercial license terms, and non-DOD Departments and Agencies of the U.S. Government will receive no greater than Restricted Rights as defined in FAR 52.227-19(c)(1-2) (June 1987). U.S. Government users will receive no greater than Limited Rights as defined in FAR 52.227-14 (June 1987) or DFAR 252.227-7015 (b)(2) (November 1995), as applicable in any technical data.

© Agilent Technologies, Inc. 2001


Call Processing

Call Processing

Last updated: July 27, 2007

This page provides links to descriptions of the numerous settings and operations available in the test set for base station emulation and call processing including: Test Set Operating Modes , Base Station Emulator Configurations , Call Processing Operation and General Information .

If you have trouble finding the information you need below, use the search field at the top of this page to search the contents of this guide. If you are new to using the test set, it may be helpful to review the Getting Started with Call Processing page.

Test Set Operating Modes

  • Active Cell Operating Mode
  • IS-2000 Test Operating Mode
  • AVC Test Operating Mode
  • CW Operating Mode
  • Cell Off Operating Mode

Base Station Emulator Configurations

  • Selecting an Operating Mode
  • Selecting a Cellular System Type
  • Setting Call Parms: Cell Band , RF Channel Number , Protocol Revisions , Radio Configuration , Service Option , Call Limit Mode , Call Drop Timer , Traffic Data Rate , Voice SO Mode
    • only for Lab Application : R-FCH Gating , F-FCH Frame Pattern Setup , Calling Party Number Parameters
  • Setting Reverse Closed Loop Power Control (Rvs Power Ctrl, Rvs Power Ctrl Transient Parm, etc.)
  • Setting Control Channel Parameters (BCCH/CCCH Data Rate, Paging Data Rate, etc.)
  • Setting Cell Parameters (SID, NID, MCC, MNC, Paging Data Rate, etc.)
  • Setting CDMA System Time Parameters (Date, Time, Leap Seconds, Local Time Offset, etc.)
  • Setting Access Parameters (Power Step, Number of Steps, Maximum Request Sequence, etc.)
  • Setting Enhanced Access Parameters (Power Step, Number of Steps, Maximum Request Sequence, etc.)
  • Setting Registration Parameters (Timer Based Registration State, Power Up Registration State, etc.)
  • Paging IMSI Setup (Paging MSIN, MCC, MNC, Status Request Query State, etc.)
  • Setting Hard Handoff Parameters
  • Setting External Trigger
  • Configuring Cell Power and AWGN Power Levels
  • Configuring Forward Channel Power Levels and Walsh Codes (Code Channel Levels, Walsh Code, etc.)
  • Configuring the TDSO Supplemental Channel Information (Data Rate, Data Source, Encoder Type, etc.)
  • Setting Authentication Parameters (A-Key, RAND, RANDU, RANDSSD, etc.)
  • Real-Time Vocoder
  • MEID / Enhanced PLCM

Call Processing Operation

  • Establishing an Active Link with the Mobile Station
  • Performing a Registration
  • Performing a Hard Handoff
  • Performing Soft/Softer Handoffs ( Lab Application Only )
  • Performing Multi-Unit Synchronization ( applicable to the lab application and to a test application with the required feature license )
  • Short Message Service/ Multimedia Service ( Lab Application Only )
  • Paging Channel MER Description ( Lab Application Only )
  • Forward Power Control ( Lab Application Only )
  • Hybrid Mode ( Lap Application Only )
  • Performing Authentications ( applicable to the lab application and to a test application with the required feature license )
  • Call Waiting ( Lab Application Only )

General Information

  • Mobile Reported Information
  • Forward Link Overview
  • Receiver Control
  • Expected Power
  • Settable Fields in Overhead Messages
  • Digital Bus Information ( applicable to the lab application and to a test application with the required feature license with rear panel digital bus only )


Measurements

Measurements

Last updated: July 27, 2006

The test set includes many measurements and instruments for testing your wireless device. This page provides links to measurement information including: Measurement Descriptions (how the measurement is performed by the test set, setup parameters, and the measurement results available), Adherence to Standards , Measurement Calibration and Amplitude Offset .

The Instrument Configuration Measurement Matrix shows which measurements are available for the various instrument configurations.

If you have trouble finding the information you need below, use the search field at the top of this page to search the contents of this guide.

Measurement Descriptions

  • Access Probe Power Measurement Description
  • Analog Transmit Power Measurement Description (only for AMPS test)

  • Audio Analyzer Measurement Description

    • Audio Analyzer Block Diagram
    • Audio Frequency Measurement Description
    • Audio Level Measurement Description
    • Distortion Measurement Description
    • SINAD Measurement Description

  • Channel Power Measurement Description
  • Code Channel Time/Phase Error Measurement Description
  • Data Throughput Monitor (Lab Application only)
  • Digital Average Power Measurement Description
  • DTMF Measurement Description (only for AMPS test)
  • Fast Device Tune Measurement Description ( Only applicable to the lab application or feature-licensed test application )
  • Frame Error Rate (FER) Measurement Description
  • Frequency Modulation (FM) Measurement Description (only for AMPS test)
  • Frequency Stability Measurement Description
  • Gated Power Measurement Description
  • Graphical Access Probe Power Measurement Description (Lab Application only)
  • Handoff Waveform Quality Measurement Description
  • Maximum/Minimum Power Measurement Description
  • Multi-Tone Audio Measurement Description
  • Paging Channel MER Description ( Lab Application Only )
  • Signaling Tone Measurement Description (only for AMPS test)
  • Spectrum Monitor Description
  • Swept Audio Measurements Description
  • TDSO Frame Error Rate Measurement Description
  • Time Response of Open Loop Power Control (TROLPC) Measurement Description
  • TX Dynamic Power Measurement Description
  • Tx Spurious Emissions Measurement Description
  • Waveform Quality/Code Domain Measurement Description
  • Wideband Data Deviation Measurement Description (only for AMPS test)

Adherence to Standards

  • Test Adherence to Standards

Measurement Calibration

  • Calibrating the Test Set

Amplitude Offset

  • Amplitude Offset


Manual Operation

Manual Operation

Last updated: November 10, 2006

This page provides links to information on using the test set from the front panel including: Test Set Configuration (such as amplitude offsets, GPIB and LAN ports), Base Station Emulator Configuration , Call Processing Operation (such as making a call, handoffs), Protocol Logging (Lab Application Only) , Data Channel Operation (Lab Application Only) , Making Measurements (how to use the measurements in general, and also how to perform a specific measurement or conformance test, see Performing Specific Measurements and TIA/EIA-98-E Tests Manually ) and General Manual Operation (such as Help Mode, which provides context-sensitive GPIB command syntax assistance, and Save and Recall Registers, which provide a way to return to frequently used setups).

If you have trouble finding the information you need below, use the search field at the top of this page to search the contents of this guide.

Test Set Configuration

  • How Do I Configure the Test Set for My Test System? (GPIB address, LAN IP address, Amplitude Offset, RF IN/OUT Port, etc.)
  • How Do I Configure the AUDIO OUT Port?
  • How Do I Configure Test Signals in CW Operating Mode?

Base Station Emulator Configuration

  • How Do I Change Call Parameters?
  • How Do I Change Cell Information?
  • How Do I Change AWGN Power Levels?
  • How Do I Change Generator Information?
  • How Do I Change F-FCH/Traffic Channel Parameters?
  • How Do I Change TDSO Supplemental Channel Information?
  • How Do I Change Test Set's Receiver Control Parameters?
  • How Do I Make a Fast Device Tune Measurement?

Call Processing Operation

  • General Procedures
    • How Do I Set Up a Call?
    • How Do I Perform a Hard Handoff?
    • How Do I End a Call?
  • Example Usage of Reverse CLPC Transient Mode
  • How Do I Use Real-Time Vocoder?
  • How Do I Perform MEID Verification?
  • How Do I Perform Authentication Tests?
    ( applicable to the lab application and to a test application with the required feature license )
  • How Do I Use R-FCH Gating for Talk Time Testing? (Lab Application only)
  • How Do I Perform Calling Party Number Verification? ( Lab Application Only )
  • Forward Power Control ( Lab Application Only )
    • How Do I Perform FPC Test (FPC Mode 000)?
    • How Do I Perform EIB Test (FPC Mode 011)?
  • Soft/Softer Handoff ( Lab Application Only )
    • General Procedures for Soft/Softer Handoff Tests
    • How Do I Make Soft/Softer Handoff Tests Regarding T_Add?
    • How Do I Make Soft/Softer Handoff Tests Regarding T_Comp?
    • How Do I Make Soft/Softer Handoff Tests Regarding T_Drop/T_TDrop?
    • How Do I Test Mobile Station (MS) Closed Loop Power Control (CLPC) Behavior in Soft/Softer Handoff?
  • Short Message Service/ Multimedia Service ( Lab Application Only )
    • Mobile-Terminated SMS Procedure
    • Mobile-Originated SMS Procedure
    • Logging SMS Messages (via WPA software)
    • Clearing the SMS Info/Status
    • Enabling the HTTP Interface
    • How to Send MMS Messages ?
  • Call Waiting ( Lab Application Only )
    • How Do I Perform Call Waiting Test?

Protocol Logging ( Lab Application Only )

  • Protocol Logging

Data Channel Operation ( Lab Application Only )

  • How Do I Set Up Data Channel Parameters?
  • How Do I Originate a Packet Data Connection From My Wireless Device?
  • How Do I Access the Data Counters?
  • How Do I Ping a Device From the Test Set?
  • How Do I Use the Data Throughput Monitor?
  • Packet Data Service Example Procedure (via Simple IP)
  • Packet Data Service Example Procedure (via Mobile IP)
  • How Do I Make Hybrid Mode AT/MS Tests?

Making Measurements

  • How Do I Make Measurements on a Mobile Station?
  • How Do I Change the Measurement Setup?
  • How Do I Turn Off a Measurement?
  • Performing Specific Measurements and TIA/EIA-98-E Tests Manually
  • How Do I Use the Spectrum Monitor?
  • Terminologies on the Test Set Adherence to Standard

General Manual Operation

  • Help Mode
  • Front Panel Connectors
  • Rear Panel Connectors
  • Remote/Local Mode
  • Printing Screens
  • Save and Recall Registers
  • Instrument Status Area
  • Preset Descriptions
  • Receiver Control


Programming

Programming

Last updated: July 27, 2006

The test set is programmable through the GPIB (General Purpose Interface Bus) located on the rear panel. This page provides links to documentation to help you program the test set including: Programming Guide and Comprehensive Example , Programming Examples for Individual Measurements and General Programming (including test system synchronization).

Programming Guide and Comprehensive Example

  • Programming: Getting Started Guide for cdma2000 Mobile Test : This guide provides a general approach to setting up a connection and obtaining measurement results programmatically. It gives an overview of how to configure the test set's base station emulator, perform key call processing operations, and perform measurements. The guide is built around a complete control program for testing a wireless device in a manufacturing environment. To download this complete control program, click here:
  • Control Program Example

Programming Examples for Individual Measurements

  • Programming an Access Probe Power Measurement
  • Programming an Analog Transmit Power Measurement (only for AMPS test)
  • Audio Analyzer Measurements
    • Programming an Audio Frequency Measurement
    • Programming an Audio Level Measurement
    • Programming a Distortion Measurement
    • Programming an SINAD Measurement
  • Programming a Channel Power Measurement
  • Programming a Code Channel Time/Phase Measurement
  • Programming a Digital Average Power Measurement
  • Programming a DTMF Measurement (only for AMPS test)
  • Programming a Fast Device Tune Measurement ( Only applicable to the lab application or feature-licensed test application )
  • Programming an FER (Frame Error Rate) Measurement
  • Programming a Frequency Modulation (FM) Measurement (only for AMPS test)
  • Programming a Frequency Stability Measurement
  • Programming a Gated Power Measurement
  • Programming a Graphical Access Probe Power Measurement (Lab Application only)
  • Programming a Handoff Waveform Quality Measurement
  • Programming a Maximum/Minimum Power Measurement
  • Programming a Multi-Tone Audio Measurement
  • Programming Paging Channel MER (Lab Application only)
  • Programming a Signaling Tone Measurement (only for AMPS test)
  • Programming the Spectrum Monitor
  • Programming a Swept Audio Measurement
  • Programming a TDSO Frame Error Rate Measurement
  • Programming a TROLP Measurement
  • Programming a TX Dynamic Power Measurement
  • Programming a Tx Spurious Emissions Measurement
  • Programming a Waveform Quality/Code Domain Measurement
  • Programming a Wideband Data Deviation Measurement (only for AMPS test)

General Programming

  • Preset Descriptions
  • Receiver Control
  • Status Subsystem Overview
  • Obtaining Measurement Results
  • Test System Synchronization
  • User Interface (UI) Log
  • Using GPIB Command Debug Mode


GPIB Commands

GPIB Commands

Last updated: June 19, 2007

This page provides links to all of the test set's GPIB subsystems. Select a subsystem link below for a description of the subsystem and links to all of the GPIB commands within that subsystem.

If you have trouble finding the information you need below, use the search field at the top of this page to search the contents of this guide.

GPIB Diagram Conventions

  • GPIB Command Conventions to understand how GPIB commands are represented in the diagrams.

Call Processing

  • CALL Subsystem to control the mobile and setup and control the cell.

Measurement Control

  • ABORt Subsystem to stop a measurement.
  • CALCulate Subsystem to perform data processing on measurement results.
  • FETCh? Subsystem or READ? Subsystem to get measurement results.
  • INITiate Subsystem or READ? Subsystem to start a measurement.
  • SETup Subsystem to configure a measurement.

Status

  • STATus Subsystem to communicate Test Set status.

IEEE 488.2 Common Commands

  • IEEE 488.2 Common Commands

Test Set Configuration

  • AFGenerator Subsystem
  • RFANalyzer Subsystem (not controlled as an instrument)
  • RFGenerator Subsystem (not controlled as an instrument)
  • CALibration Subsystem
  • DISPlay Subsystem
  • SYSTem Subsystem
  • Help Mode

Listing of Commands

For a complete list of the GPIB commands in this application: cdma2000/IS-95/AMPS Listing of Commands


Protocol Logging

Protocol Logging

Last updated: June 18, 2007

This section is only applicable to the lab application and to a test application with the required feature license.

If you have trouble finding the information you need below, use the search field at the top of this page to search the contents of this guide.

The E6702A/B Lab Application enables the test set to capture the exchange of control and data information between the test set and a mobile station. Captured information is forwarded to a software application that runs on a personal computer under the Windows operating system.

The software application is referred to as the WPA (Wireless Protocol Advisor). It is tailored for the capture, display, and analysis of message exchange protocols between the test set, emulating a base station, and a mobile station.

IMPORTANT
Most of the information necessary to establish a connection and to display, filter, store, print, and analyze the message exchange between the test set and a mobile station is accessible through the Help feature available on-line when the WPA application is running.

This on-line help is also available for download at:

http://www.agilent.com/find/e6584a/

Additional information, including PC operating system requirements and additional protocol logging reference information specific to the test set's Lab Application is listed below.

PC Operating System Requirements

Logging protocol messages requires an external PC with the following system requirements:

  • Protocol Logging Requirements

Starting and Stopping Protocol Logging

There are several ways to control the logging of signaling messages.

The primary method for starting and stopping is through features found in the WPA software.

The following information describes features available through the test set's remote and manual user interface for performing these functions:

  • Activating Protocol Logging From the Test Set

Example Usages of Protocol Logging

  • Protocol Logging During Ping
  • Logging SMS Messages

Related Topics

Settable Fields in Overhead Messages


Data Channel

Data Channel

Last updated: June 20, 2006

This section is only applicable to the lab application.

If you have trouble finding the information you need below, use the search field at the top of this page to search the contents of this guide.

The data channel function allows you to use the test set as an IP router, exchanging packet data between a cdma2000 wireless device and an external IP network via a packet data connection. The packet data services are primarily identified with an Service Option 33 (high speed packet data service option) in the cdma2000 lab application.

Data Channel Overview

  • Test Set Packet Data Network Emulation
  • Packet Data Connection Processing States

Data Channel Configuration

  • Packet Data Service Configurations
  • Data Channel Parameters

Data Channel Capabilities

  • Data Channel Capabilities Overview
  • Simple IP and Mobile IP
  • Hybrid Mode
  • Ping
  • Data Counters
  • Data Throughput Monitor
  • Data Channel Applications
  • Packet Data Service Example Procedure (via Simple IP)
  • Packet Data Service Example Procedure (via Mobile IP)

Troubleshooting Information

  • Packet Data Connection Troubleshooting

General Information

  • IP Address Requirements


Troubleshooting

Troubleshooting

Last updated: July 31, 2006

If you install application firmware on a test set with incompatible hardware, the test set may lock up. See Test Set Lockup During Power Up Sequence .

Some features may be inaccessible or may not perform to specifications without a hardware upgrade to your test set or a proper license. For more details, please see:

http://www.agilent.com/find/8960upgrades

Contact Information

  • Contact Us

Measurement Troubleshooting

  • Access Probe Power Troubleshooting
  • AFANalyzer Troubleshooting
  • Analog Transmit Power Troubleshooting (only for AMPS test)
  • Channel Power Measurement Troubleshooting
  • Code Channel Time/Phase Error Measurement Troubleshooting
  • Digital Average Power Troubleshooting
  • DTMF Troubleshooting (only for AMPS test)
  • Fast Device Tune Troubleshooting ( Only applicable to the lab application or feature-licensed test application )
  • Frame Error Rate Measurement Troubleshooting
  • Frequency Modulation (FM) Troubleshooting (only for AMPS test)
  • Frequency Stability Measurement Troubleshooting
  • Gated Power Measurement Troubleshooting
  • Graphical Access Probe Power Troubleshooting (Lab Application only)
  • Handoff Waveform Quality Measurement Troubleshooting
  • Maximum/Minimum Power Measurement Troubleshooting
  • Multi-Tone Audio Troubleshooting
  • Paging Channel Message Error Rate (MER) Troubleshooting (Lab Application only)
  • Signaling Tone Troubleshooting (only for AMPS test)
  • Spectrum Monitor Troubleshooting
  • Swept Audio Measurement Troubleshooting
  • TDSO Frame Error Rate Troubleshooting
  • Time Response of Open Loop Power Control (TROLPC) Troubleshooting
  • TX Dynamic Power Measurement Troubleshooting
  • Tx Spurious Emissions Measurement Troubleshooting
  • Waveform Quality Measurement Troubleshooting
  • Wideband Data Deviation Troubleshooting (only for AMPS test)

Call Processing and Data Channel Troubleshooting

  • Authentication Troubleshooting (Lab Application only)
  • Protocol Logging Troubleshooting (Lab Application only)
  • Packet Data Connection Troubleshooting (Lab Application only)

Others

  • Troubleshooting Setting Power Levels
  • Error Messages
  • Error Message Log
  • Integrity Indicator
  • User Interface (UI) Log
  • Using GPIB Command Debug Mode
  • Block Diagram
  • Calibrating the Test Set
  • 8960 Known Issues


Configuration

Configuration

Last updated: July 31, 2006

This page provides links to configuration information including: Configuration Information , Configuring the Test Set and Selecting an Application .

If you have trouble finding the information you need below, use the search field at the top of this page to search the contents of this guide.

Configuration Information

  • Obtaining Identification Information (*IDN)
  • Hardware Configuration Report

Configuring the Test Set

  • Display Brightness
  • Display Mode (Track/Fast)
  • Test Set Beeper
  • Timebase Description/Configuration
  • Configuring the Test Set's LAN
  • Configuring the Test Set's GPIB
  • Configuring System Time and Date
  • Amplitude Offset
  • Configuring the Test Set's AUDIO OUT port
  • Restart on Fatal Error

  • Calibrating the Test Set

Selecting an Application

  • Test Application Switching


Release Notes

Release Notes

Last updated: January 26, 2007

The links below list the features and functionality of the applications for each release of the firmware.

Features and Functionality

  • E1962B cdma2000/IS-95/AMPS Test Application Revision Information
  • E6702A/B/T cdma2000 Lab Application Revision Information

GPIB Commands

  • E1962B and E6702B Applications: GPIB Command Revision Information


Data Channel Applications

Data Channel Applications

Last updated: July 18, 2007

This section is only applicable to the lab application.

Data applications such as interactive and multimedia applications are appearing more often on wireless devices as data rates go up. The test set's data channel feature supports the following applications:

  • WAP Functional Test
  • HTTP Functional Test
  • FTP Functional Test
  • Base Station Emulation

WAP Functional Test

The test set's Data Channel facilitates the functional test of a Wireless Application Protocol (WAP) device such as a WAP-enabled mobile station.

Logging data during this process provides protocol data at useful points in the stack, which may help in debugging a cdma2000 wireless device.

Before you use the data channel for WAP functional test, you must have the following information:

  • an IP address valid for the subnet that you will connect the test set to
  • the valid subnet mask for that subnet
  • the default gateway for that network (not the same as the WAP gateway)
  • a valid IP address for the DUT
  • the default WAP gateway address (this may be required by thecdma2000 wireless device)

HTTP Functional Test

The data channel feature facilitates Hypertext Transfer Protocol (HTTP) via the wireless device. Typically this is done with a dial-up connection to an external PC using a cdma2000 wireless modem.

Before you use the Data channel for HTTP testing, you must have the following information:

  • an IP address valid for the subnet that you will connect the test set to
  • the valid subnet mask for that subnet
  • the default gateway for that network
  • a valid IP address for the modem or its controlling PC (even though the modem is the Device Under Test (DUT), typically a PC will be assigned the IP address)
  • a valid IP address for the HTTP server

FTP Functional Test

The Data Channel facilitates File Transfer Protocol (FTP) via the wireless device. Typically this is done with a dial-up connection to an external PC using a cdma2000 wireless modem.

With appropriate evaluation tools on the Control PC, you can measure the throughput of the modem. Many commercial FTP programs provide detailed information on transfer speed.

To empirically measure the throughput, the performance of the network must be known. For this reason, it is not recommended to perform this evaluation while connected to the Internet. A direct connection or Intranet connection should be used instead.

Before you use the Data channel for FTP testing, you must have the following information:

  • an IP address valid for the subnet that you will connect the test set to
  • the valid subnet mask for that subnet
  • the default gateway for that network
  • a valid IP address for the modem or its controlling PC (even though the modem is the Device Under Test (DUT), typically a PC will be assigned the IP address)
  • a valid IP address for the FTP server

Base Station Emulation

You can use the Data Channel and the test set to emulate a base station. This is particularly useful when you want to have a base station available, for example when demonstrating a wireless application, or when functionally testing wireless devices on a workbench. You may also want to vary key parameters of the cell, such as transmit power, and observe how the DUT performs.

Before you use the Data Channel for Base Station Emulation, you must have the following information:

  • an IP address valid for the subnet that you will connect the test set to
  • the valid subnet mask for that subnet
  • the default gateway for that network
  • a valid IP address for the DUT

Related Topics

Data Channel Capabilities Overview


Packet Data Connection Processing States

Packet Data Connection Processing States

Last updated: June 20, 2006

This section is only applicable to the lab application.

There are several key transitions during packet data connection processing lifecycle (see Packet Data Connection States and Transitions ).

Packet Data Connection States and Transitions

Packet Data Connection States Description

Once the test set completes a process (successfully or in error conditions) during packet data service (SO33 or SO33 (+F-SCH)) operation, the test set will always end up in one of the three stable states ("Idle", "Idle Dormant" or "Connected + Data") and display in the Active Cell status area on the test set's front panel.

NOTE
In the following description, the base station (BS) is interchangeable with the test set and the packet data serving node (PDSN) refers to either the internal or external PDSN depending upon your External PDSN State setting (see Data Channel Parameters ).

  • Idle: indicates there is no physical traffic channel (RF link) established between the MS and the BS and no logical PPP connection between the MS and the PDSN. In this case, the data connection status ( CALL:STATus[:STATe]:DATA? ) returns OFF. The test set will go to this state,
    • when the test set initially powers up or presets, or when the MS powers on and camps on the test set. This state remains until a packet data connection occurs.
    • when the test set sends a Release Order to the MS by pressing the F3 ( End Call ) on Call Control 1 of 3 menu, or receives a Release Order (ORDQ = 2) from the MS due to some reason (for example, when you exit the MS's web browser, or press the End Call key on the MS, or terminate the data connection in some MS-dependent manner).
  • Idle Dormant: indicates no physical traffic channel exists between the MS and the BS, but the PPP connection is maintained between the MS and the PDSN. In this case, the data connection status ( CALL:STATus[:STATe]:DATA? ) returns DORM (dormant).
    • The dormant state is an important advantage of the packet data service offering since it allows the MS's natural state to be dormancy, where the MS does not utilize any radio resources and has minimal power consumption. The subsequent sessions (when the MS comes out of dormancy) can be started without having to re-establish PPP link again and the connection time is faster.
    • The test set will transition from the connected state to dormant state when receiving a Release Order (ORDQ = 0) from the MS due to some reason (for example, the packet data inactivity timer times out, or other MS-dependent manner), or in response to pressing the F2 ( Force Dormant ) on the Data Channel menu (accessed by pressing F2 ( Data Channel Info ) on Call Control 3 of 3 menu) (see also CALL:FUNCtion:DATA:DORMant ). Note that if Force Dormant ( F2 ) operation results in a response of Release Order (ORDQ = 2) from the MS, the test set will transition to idle state and prompt with an error 'Force dormant failed due to MS messaging'.
    • The packet data connection can be reactivated from dormancy to the connected state when an IP packet arrives from the network destined to the mobile station (for example, file transfer over FTP, ping the MS from the test set, etc.).
  • Connected + Data: indicates a physical traffic channel exists between the MS and the BS, and a logical (PPP) connection is maintained between the MS and the PDSN. The test set will indicate this state when a packet data connection is successfully established (see How Do I Originate a Packet Data Connection From My Wireless Device? ). Packet data can be exchanged between the MS and the external network on the active packet data connection. In this case, the data connection status ( CALL:STATus[:STATe]:DATA? ) returns DCON (data connected). While in this state,
    • the test set will transition to dormant state when receiving a Release Order (ORDQ = 0) from the MS due to some reason (for example, the packet data inactivity timer times out, or other MS-dependent manner), or in response to pressing the F2 ( Force Dormant ) on the Data Channel menu (accessed by pressing F2 ( Data Channel Info ) on Call Control 3 of 3 menu).
    • the test set will transition to idle state if the F3 ( End Call ) on Call Control 1 of 3 menu is pressed, or a Release Order (ORDQ = 2) is received from the MS due to some reason (for example, when you exit the MS's web browser, or press the End Call key on the MS, or terminate the data connection in some MS-dependent manner). If you press the F2 ( Force Dormant ) and the MS responses with a Release Order (ORDQ = 2) instead of the expected Release Order (ORDQ = 0), the test set will also transition to idle state and prompt with an error 'Force dormant failed due to MS messaging'.

Related Topics

Test Set Packet Data Network Emulation


Data Channel Capabilities Overview

Data Channel Capabilities Overview

Last updated: June 21, 2006

This section is only applicable to the lab application.

The data channel function allows you to use the test set as an IP router, exchanging packet data between an external network and a cdma2000 wireless device with an Service Option 33 (SO33 or SO33 (+F-SCH), see Packet Data Service Options ) high speed packet data service connection.

The test set supports simple IP protocol with it's internal PDSN simulation. By working together with an external Mobile IP Simulator (MOB-IP-SIM) provided by the Software Concepts, Inc., the test set supports the mobile IP protocol tests (see Simple IP and Mobile IP ). IP data can be routed through an Ethernet port to/from a wireless device on the RF port, or the test set can serve files without requiring an external network. See Packet Data Service Example Procedure (via Simple IP) or Packet Data Service Example Procedure (via Mobile IP) for example procedures.

The data channel function is useful when the performance of applications such as music download, interactive and multimedia applications (see Data Channel Applications ) needs to be tested in a controlled environment. You can use tools such as Data Counters , Data Throughput Monitor or Wireless Protocol Advisor (WPA) software to monitor the effects of RF degradation on data transfer. The data rate can be changed while on a call (see Data Channel Parameters ). Cell power can be adjusted to simulate poor channel conditions and an AWGN (Additive White Gaussian Noise) noise source (see Configuring Cell Power and AWGN Power Levels ) can be added to the signal to simulate signal interference. The supplemental channel is also directly settable to a level relative to cell power ( Configuring Forward Channel Power Levels and Walsh Codes ). Lowering the power level on the forward supplemental channel will interrupt data flow, especially at the higher data rates.

Effects of data rate variations include unacceptably long file downloads, graphics images that take too long to display, and streaming video images freezing. Lost data stresses the mobile station application's ability to run correctly when there are long delays due to retransmission of data (observed via Data Counters ). Delayed data stresses the mobile stations' ability to buffer data while waiting for late packets to arrive.

The test set also provides a Ping tool to help check system interconnects.

To verify the current status of packet data connection, see Packet Data Connection Processing States .

Related Topics

Data Channel


Data Counters

Data Counters

Last updated: June 20, 2006

This section is only applicable to the lab application.

When a packet data connection is established (see How Do I Originate a Packet Data Connection From My Wireless Device? ), the test set keeps a count of the number of Radio Link Protocol (RLP) frames and Internet Protocol (IP) data units that are transferred on both the forward (network to wireless device) and reverse (wireless device to network) directions. The recorded information is displayed on the Counters table and the RLP Counters Info table.

Counters

The Counters table provides the following information:

  • IP Pkts and IP Bytes for Fwd Data (MS RX): indicates the number of IP packets and bytes transferred from the test set to the wireless device. When IP counters reach their maximum value, they remain at that value until cleared.
  • IP Pkts and IP Bytes for Rvs Data (MS TX): indicates the number of IP packets and bytes transferred from the wireless device to the test set. When IP counters reach their maximum value, they remain at that value until cleared.
  • RLP Frames and RLP Octets for Fwd Data (MS RX): indicates the total number of RLP frames and octets transferred from the test set to the wireless device. When RLP counters reach their maximum value, they automatically reset to zero and resume the count.
  • RLP Frames and RLP Octets for Rvs Data (MS TX): indicates the total number of RLP frames and octets transferred from the wireless device to the test set. When RLP counters reach their maximum value, they automatically reset to zero and resume the count.

To Clear the Counters

All counters shown in this table will be cleared when the Clear All Counters ( F3 ) key is pressed or the test set performs a power-up or full preset.

RLP Counters Information

The RLP Counters Info table provides more detailed information including:

  • RLP Control Frames (including SYNC frames, SYNC/ACK frames, ACK frames and NAK frames)
  • RLP data frames (including New frames, New octets, Retransmitted frames, Retransmitted Octets, NAKked frames and NAKked segments)
  • RLP Fill Frames
  • RLP Idle Frames
  • Unclassified Frames (including Error frames and Unknown frames)

To Clear the RLP Counters

All counters shown in this table will be cleared when the Clear RLP Counters ( F3 ) key is pressed or the test set performs a power-up or full preset. When the RLP counters reach their maximum value, they automatically reset to zero and resume the count.

Related Topics

Front Panel Operation: How Do I Access the Data Counters?

GPIB commands: CALL:COUNt


Packet Data Service Example Procedure (via Simple IP)

Packet Data Service Example Procedure (via Simple IP)

Last updated: July 18, 2007

This section is only applicable to the lab application.

The following procedure is an example of how to use the test set for IP packet data transfer over simple IP protocol. For example procedure using mobile IP protocol, see Packet Data Service Example Procedure (via Mobile IP) .

This procedure is to demonstrate how to access the test set's built-in web server via the RF interface over packet data service from a laptop computer (PC). A cdma2000 mobile station used as a wireless modem will be connected to the USB port on the PC running USB port software developed by the manufacturer of the mobile station.

The purpose of this procedure is to serve as an overview of the tasks required for a typical data channel application. If your particular application involves accessing internet or intranet sites via the test set's LAN interface, additional requirements such as getting through corporate firewalls may complicate setup procedures.

A. PC Setup

Install and Configure Device Driver

Install the USB and modem drivers provided by the wireless modem manufacturer. Connect the USB port from the wireless modem to the PC. When run for the first time, the software prompts the user for setup information. When properly configured, the PC will recognize the wireless modem on the USB (or other) port.

Configure the PC for a dial-up connection to the Internet via the wireless modem

The laptop has to be configured to include the wireless modem in its list of networks. The network dial-up connection properties must be configured according to the requirements of the wireless modem and the data port driver. When the PC is properly configured, the "Network and Dial-up Connections menu" should include the wireless modem in its list of connections.

In this example, on the PC running the Windows 2000, select the Network and Dialup Connections from the Control Panel. Select Local Area Connection icon, right click, and select Disable. Then select the Make New Connection icon, set up an internet connection with the new added modem (the connection is named as "Wireless Modem", for example).

B. Hardware Connections

There are many different configurations for testing wireless modems (or other wireless appliances such as WAP enabled mobile stations) data handling performance. See HTTP Functional Test for a diagram of the configuration used for this example.

RF (Wireless Modem to Test Set)

  1. Connect the wireless modem RF cable to the test set's RF In/Out port.

PC to Wireless Modem

  1. For this example, the USB port provides the connection. Connect the USB port from the wireless modem to the PC.

C. Test Set Setup

  1. Press the SYSTEM CONFIG key.
  2. Press the Instrument Setup ( F1 ) key, set up test set's LAN settings (see A. Configure instrument information and setup. ). For example,
    • Set LAN IP Address to 130.29.181.1
    • Set Subnet Mask to 255.255.0.0
    • Set Default Gateway to be blank (enter a 0 to make it blank)
    • Press F6 ( Close Menu ).
  3. Press the Call Setup key to go to the Call Setup screen on the test set.
  4. Press the Radio Config ( F11 ) key and select the radio configuration, for example, (Fwd3, Rvs3) , in which you would like to bring up the call.
  5. Press the FCH Service Option Setup ( F12 ) key, select SO33 (+F-SCH) in the Service Option for Fwd3, Rvs3 for this example.
  6. You may need to set some parameters that are required for your mobile station to find service. For example, Cell Band, Channel, SID, etc. See How Do I Set Up an IS-2000 Call? .
  7. Press the left More key to go to Call Control 3 of 3 menu.
  8. Press the Data Channel Info ( F2 ) key.
  9. Press the Data Channel Parameters ( F1 ) key. See How Do I Set Up Data Channel Parameters? .

    In this example the network consists of only two IP addresses, the PC and the Test Set. The DUT IP Address will be sent to the PC if you set the Internet Protocol (TCP/IP) Properties to "Obtain an IP address automatically" menu. You should set the DUT IP Address and the test set's IP address (set in step 2) unique and in the same subnet (see IP Address Requirements ). For example,
    • Set F-SCH Data Rate to 153.6 kbps
    • Set DUT IP Address to 130.29.181.2
    • Set the External PDSN State to Off (Indicating simple IP service). For mobile IP settings, see Packet Data Service Example Procedure (via Mobile IP) ).
    • Press F6 ( Close Menu ).
  10. To improve the data transfer speed, we recommend you set the Cell 1 F-SCH Level to -7 dB on the Code Channel Parameters menu (see How Do I Change Generator Information? ).

  11. Now, the test set setup are ready for a dial-up connection from the PC.

D. Functional Test

In order to test the functioning of the wireless modem, it must first complete a dial-up connection between the test set and the PC.

  1. Turn the wireless modem on and wait for a power-up registration. The mobile station information should appear in the Mobile Reported Information window after a successful registration. Otherwise, you may need to change some settings appropriate for your mobile station to find service. For example, Cell Band, Channel, SID, etc. See How Do I Set Up an IS-2000 Call? .
  2. On the PC (for example, Windows 2000), select Start, Settings, and Control Panel. In the Control Panel window double click Network and Dial-up Connections.
  3. Double click the icon labeled with "Wireless Modem" which is set up during the procedure (see Configure the PC for a dial-up connection to the Internet via the wireless modem )
  4. In the Dial-up Connection window, select the Dial button.
  5. Verify that a connection is active by looking for Connected + Data shown in the Active Cell field on the bottom center portion of the test set's screen. Now, you are ready for the demonstration to continue.

  6. Open the browser on the PC (for example, Internet Explorer). Enter the IP address of the test set in the PC browser Address window (in this example, http://130.29.181.1). The PC browser should display the test set's internal web server page:

  7. As data is transferred, monitor the Counters window (see Data Counters ). and the Data Throughput Monitor window (see Data Throughput Monitor ). These tools are useful for analyzing data transfer rates under various RF and call processing conditions.
  8. You can also use the Wireless Protocol Advisor (WPA) to log cdma2000 control and stack messages, PPP (Point-to-Point Protocol) packets, RLP frames, and IP (Internet Protocol) packets for analysis of the data channel. See Protocol Logging .

Related Topics

Simple IP and Mobile IP


Packet Data Service Example Procedure (via Mobile IP)

Packet Data Service Example Procedure (via Mobile IP)

Last updated: October 28, 2004

This section is only applicable to the lab application.

The following procedure is an example of how to use the test set and MOB-IP-SIM for IP packet data transfer using mobile IP protocol. For example procedure over simple IP protocol, see Packet Data Service Example Procedure (via Simple IP) .

This procedure is to demonstrate how to access the MOB-IP-SIM built-in web site from the mobile station via the RF interface using packet data service. The Wireless Protocol Advisor (WPA) can be used for logging the protocol messages during the packet data transfer.

The purpose of this procedure is to serve as an overview of the tasks required for a typical data channel application via the mobile IP connection. If your particular application involves accessing internet or intranet sites via the MOB-IP-SIM's LAN interface, additional requirements such as getting through corporate firewalls may complicate setup procedures.

  1. Ensure the mobile station is pre-programmed with known parameters.
  2. Refer to the MOB-IP-SIM technical manual to properly configure the MOB-IP-SIM (for example, IP address, subnet mask, etc.).
  3. Connect the mobile station support of mobile IP protocol to the test set's front panel RF IN/OUT connector. Connect the test set, the MOB_IP_SIM, and the PC running a web browser to a LAN. See Configuration for a Mobile IP Solution .
  4. Power on the test set. Press SYSTEM CONFIG , then press F1 ( Instrument Setup ), set the LAN IP Address , Subnet Mask , Default Gateway for the test set which are assigned by your network administrator. See IP Address Requirements .
  5. Select SO33 or SO33 (+F-SCH) for the selected Radio Config: (Fwd3, Rvs3), or (Fwd4, Rvs3) from the FCH Service Option Setup ( F12 on Call Parms 1 of 4 ).
  6. Set the test set to use external PDSN (See How Do I Set Up Data Channel Parameters? ):
    • Set the External PDSN IP Address to the same value of the MOB-IP-SIM you've set in step 1.
    • Set the External PDSN TCP Port to the default value (currently, the TCP port for the MOB_IP_SIM is fixed to 53613)
    • Set the External PDSN State to On
  7. If you would like log the protocol messages exchanged between the test set and the mobile station as data is transferred, set up the Wireless Protocol Advisor (WPA) (running on the PC) and start logging. See Protocol Logging .
  8. Power on the mobile station and wait for the mobile station to perform a power up registration. You may need to change some settings as required for your mobile station (such as Cell Band, Channel, SID, etc.) to allow the mobile station to find service. See How Do I Set Up an IS-2000 Call? .
  9. After the mobile station finds service, navigate to the web browser on the mobile station. Using the web browser, attempt to access the web site built in the MOB-IP-SIM. This step depends upon the mobile station implementation.
  10. Monitor the Active Cell call status (see Packet Data Connection Processing States ), the mobile station display, the Counters window (see Data Counters ), and the Data Throughput Monitor window (see Data Throughput Monitor ), as well as the WPA (if started) as data is transferred. These tools are useful for analyzing data transfer rates under various RF and call processing conditions.

Related Topics

Simple IP and Mobile IP


Simple IP and Mobile IP

Simple IP and Mobile IP

Last updated: November 10, 2006

This section is only applicable to the lab application.

  • What is Simple IP and Mobile IP?
  • How Does Test Set Support Simple IP and Mobile IP?

What is Simple IP and Mobile IP?

The IS-2000 network using SO33 (see Packet Data Service Configurations ) for high speed packet data transmission supports connections to the public network or a private network using either mobile IP or simple IP protocol.

A packet data session begins when the user invokes packet data service. A packet data session ends when the user or the network terminates packet data service. During a particular packet data session, the user may change locations (point of attachment).

  • For simple IP protocol, a wireless device must obtain a new IP address (and lose existing connections) every time it changes its point of attachment. That is, moving from the coverage area of one PDSN to another PDSN constitutes a change in packet data session because a new IP address is assigned by the new PDSN. A packet data session and a PPP session are concurrent in simple IP, that is, the existence of the packet data session is dependent upon a PPP session.
  • For mobile IP protocol, a wireless device is allowed to maintain the same IP address as it moves from link to link (network to network) and preserve existing connections during moves. That is, the packet data session can exist through several changes of the PPP session. The mobile IP allows the PPP session to be terminated and reestablished without the termination of the packet data session. A packet data session can span several PDSNs as long as the user continuously maintains mobility bindings at the Home Agent (the IP address is persistent).

How Does Test Set Support Simple IP and Mobile IP?

The test set supports simple IP protocol with it's internal PDSN simulation (see Test Set Packet Data Network Emulation and Packet Data Service Example Procedure (via Simple IP) ).

By working together with an external PDSN (MOB-IP-SIM) provided by the Software Concepts, Inc., the test set supports the mobile IP protocol tests required to ensure compliance with the TIA/EIA-IS-835 standard. The mobile IP protocol stack is implemented in the MOB-IP-SIM. For details on the MOB-IP-SIM functionality and configurations, see the MOB-IP-SIM technical manual available on the web:

http://www.softwareconceptsinc.net/MIP-5850.html

A typical connection diagram for a mobile IP solution is shown in Configuration for a Mobile IP Solution . An example procedure for establishing a packet data connection over Mobile IP is described in Packet Data Service Example Procedure (via Mobile IP) .

Configuration for a Mobile IP Solution

The External PDSN State is used to specify whether the PDSN simulation for packet data service is provided by the test set or by the external application (MOB-IP-SIM).

  • When the External PDSN State is set to Off, the mobile station's PPP connection is terminated by the test set, propagating the encapsulated IP packets directly to the ethernet interface (LAN port).
  • When the External PDSN State is set to On, the test set will forward the PPP octets delivered by RLP data to the external application (MOB-IP-SIM), which is responsible for actual termination of the PPP link and interpreting all protocol layers necessary to pass the end-to-end encapsulated IP packets directly onto the network (IP, UDP, MIP). See Packet Data Service Example Procedure (via Mobile IP) for an example setup.
    • When the external MOB-IP-SIM is to supply the PDSN simulation, you must specify the External PDSN IP Address and the External PDSN TCP Port , then turn the External PDSN State to On. The test set attempts to establish a packet data connection with the MOB-IP-SIM over its LAN Port at the specified External PDSN IP Address and External PDSN TCP Port.
    • When the external MOB-IP-SIM is providing PDSN service to mobile station for packet data transfer, the packet data counters (see Data Counters ) and Data Throughput Monitor (see Data Throughput Monitor ) provides a measure of the current (instantaneous), peak and average data rates in kilobits-per-second as well as the accumulations of IP packets and bytes both to and from the test set and the mobile station.
    • As the external MOB-IP-SIM only includes the logging of these higher protocols (IP, UDP, MIP), it cannot display those messages of the lower protocols (RLP and IS-2000 air interface). When the External PDSN State is set to On the test set will extract the IP packets from the PPP octets so they can be logged using the Wireless Protocol Adviser (WPA).
    • When the external MOB-IP-SIM is providing PDSN service to the mobile station, the mobile station's IP address is assigned by the MOB-IP-SIM. The setting of External PDSN IP Address is ignored and the ping to a DUT functionality does not work (see Ping ).

Related Topics

Packet Data Service Example Procedure (via Mobile IP)

Packet Data Service Example Procedure (via Simple IP)

CALL:DATA

Test Set Packet Data Network Emulation

How Do I Set Up Data Channel Parameters?


IP Address Requirements

IP Address Requirements

Last updated: June 20, 2007

This section is only applicable to the lab application.

Description

The test set provides a field for entering the IP Address for a wireless device being tested using the packet and CS (circuit switched) data channels.

There are two requirements for the DUT IP Address field:

  1. The network portion (see IP Address Formatting ) of the wireless device's DUT IP address must be the same as the network and subnet portion of the test set's LAN IP Address.
  2. The host portion of the wireless device's DUT IP address must be unique. (It should not be the same as any other host on the network or subnet that the test set is connected to.) In other words, DUT IP Address must be set to a different value in all test sets within the same network. Further, each DUT IP Address within the test set ( DUT IP Address , DUT IP Address 2 , etc.) must be set to a different value.

How Network Addresses Are Assigned

Network IDs are assigned by the NIC (Network Information Center). The network portion (first two bytes) of the class B address in the example above would be acquired from the NIC by a network administrator to avoid conflicts with other networks. The network administrator is then free to allocate subnets as needed since subnetting is not visible outside the network.

If you do not know the IP address the test set and/or DUT should be set to, or which unique host IDs are available, you should contact your network administrator.

How to Interpret IP Addresses

The network portion of the LAN IP Address depends on the address classification as shown below:

LAN IP Address Classification

Class A = 1.0.0.0 to 127.255.255.255
Class B = 128.0.0.0 to 191.255.255.255
Class C = 192.0.0.0 to 223.255.255.255
Class D = 224.0.0.0 to 247.255.255.255

An IP Address consists of a 4-byte (32 bit) number. Each byte is in a decimal form separated from other bytes by a dot. This is referred to as a "dotted decimal" format.

NOTE
The test set does not allow LAN IP Addresses in the range of 127.0.0.0 to 127.255.255.255 because these addresses are assigned for use as the Internet host loopback address.

The IP address class defines which bytes contain the network portion of the address. For Class A addresses, the first byte from the left identifies the network. For class B it is the first two bytes from the left, and for class C it is the first three bytes. Class D addresses are multicast, which are used when a datagram is directed to multiple hosts. See IP Address Formatting .

IP Address Formatting
Class | Byte 1 | Byte 2 | Byte 3 | Byte 4
A | Network | Host
B | Network |  | Host
C | Network |  |  | Host
D | Multicast

Determining the Test Set's Network Address

If the test set's LAN IP Address is set to 130.29.183.121, as shown below, the first two bytes represent the network portion since this is a Class B address.

If the test set is on a subnet, the Subnet Mask must be applied to determine the subnet address. This is done by performing bit-wise AND logic between the binary values of the LAN IP Address and Subnet Mask. See Applying the Subnet Address .

Applying the Subnet Address
LAN IP Address | 130 |  |  |  |  |  |  |  | 29 |  |  |  |  |  |  |  | 183 |  |  |  |  |  |  |  | 121
Subnet Mask | 255 |  |  |  |  |  |  |  | 255 |  |  |  |  |  |  |  | 255 |  |  |  |  |  |  |  | 0
Subnet Mask (Binary) | 1 | 1 | 1 | 1 | 1 | 1 | 1 | 1 | 1 | 1 | 1 | 1 | 1 | 1 | 1 | 1 | 1 | 1 | 1 | 1 | 1 | 1 | 1 | 1 | 0 | 0 | 0 | 0 | 0 | 0 | 0 | 0
LAN IP Address (Binary) | 1 | 0 | 0 | 0 | 0 | 0 | 1 | 0 | 0 | 0 | 0 | 1 | 1 | 1 | 0 | 1 | 1 | 0 | 1 | 1 | 0 | 1 | 1 | 1 | 0 | 1 | 1 | 1 | 1 | 0 | 0 | 1
Subnet Address (Binary) | 1 | 0 | 0 | 0 | 0 | 0 | 1 | 0 | 0 | 0 | 0 | 1 | 1 | 1 | 0 | 1 | 1 | 0 | 1 | 1 | 0 | 1 | 1 | 1 | 0 | 0 | 0 | 0 | 0 | 0 | 0 | 0
Subnet Address | Network130 |  |  |  |  |  |  |  | Network 29 |  |  |  |  |  |  |  | Subnet 183 |  |  |  |  |  |  |  | Host 0

As shown in the table above, the Subnet Mask splits the 16 bit host portion of the class B address into an 8-bit subnet ID and an 8-bit host ID.

In this example the DUT IP Address would need to be set to 130.29.183.XXX to match the test set's subnet ID. The host portion of the LAN IP Address is identified by the bits corresponding to the 0 bits in the Subnet Mask. Therefore, the last byte in the DUT IP Address must not be 121 or any address that corresponds with any other host on the subnet at 130.29.183.XXX

This setting is non-volatile (it persists across partial and full presets and power-cycling the test set).

Related Topics

How Do I Set Up Data Channel Parameters?


Test Set Packet Data Network Emulation

Test Set Packet Data Network Emulation

Last updated: October 28, 2004

This section is only applicable to the lab application.

  • Packet Data Service Overview
  • Network Reference Model
  • Packet Data Service Protocol Stacks
  • How Does Packet Data Service Work?
  • Standards References

Packet Data Service Overview

The packet data services in cdma200 system primarily identified with service option 33 (SO33) allow you to exchange data between the wireless devices and a remote server over an IP data network. Packet data service options provide a means of establishing and maintaining traffic channels for packet data service. SO33 is used to request packet data service through a packet data serving node (PDSN) supporting an internet standard Point-to-Point Protocol (PPP) interface to network layer protocols.

When a packet data connection is established, a wireless device can send or receive data through the test set's front panel RF connector, and the test set will route data through the rear panel LAN port to or from a packet data network.

Network Reference Model

In cdma2000 system, for all calls supporting packet data services, a Packet Data Serving Node (PDSN) exists that interfaces between the transmission of the data in the packet data network and the transmission of the data (via the Radio Access Network (RAN)) over the air interface. The PDSN interfaces to the base station (BS) through a Packet Control Function (PCF), which may or may not be co-located with the BS. See Network Reference Model for Packet Data Service .

When an SO33 packet data session is open, the test set will emulate the Base Station (BS), Base Station Controller (BSC), Mobile Switching Center (MSC), as well as the relevant functions of the following two entities ( Packet Control Function (PCF) and Packet Data Serving Node (PDSN) ) which are specified in 3GPP2 A.S0001-A Version 2.0, 3GPP2 Access Network Interfaces Interoperability Specification:

Network Reference Model for Packet Data Service

Packet Control Function (PCF)

One network entity that is emulated by the test set is the PCF which is to manage the relay of packets between the PDSN (see Packet Data Serving Node (PDSN) ) and the BS.

When an SO33 call is initiated, a physical traffic channel is assigned to the call, following normal service negotiation procedures. After the call transitions to the connected state, the PCF initiates the setting up of signaling and traffic connections between the PCF and the PDSN.

If the connection between the PCF and the PDSN was successful, a PPP (Point to Point Protocol) link layer connection between the wireless device and the PDSN is opened.

Packet Data Serving Node (PDSN)

Another network entity that is emulated by the test set is the PDSN. The PDSN is a specialized router that functions as an interface to the fixed networks (like the Internet). The PDSN establishes, maintains, and terminates link layer sessions and routes packet data between a wireless device and the network it is communicating with.

When an SO33 call is first connected, a PPP (Point to Point Protocol) link layer connection between a wireless device and the PDSN is opened. A physical traffic channel assignment allocates bandwidth to this connection, supporting data exchange between the wireless device and the BS.

The test set's internal PDSN emulation only supports simple IP protocol (see What is Simple IP and Mobile IP? ). The test set supports mobile IP protocol by working together with an external Mobile IP Simulator (MOB-IP-SIM) provided by the Software Concepts, Inc. (see Simple IP and Mobile IP ).

Packet Data Service Protocol Stacks

Service Option 33 Interface Protocols shows a simplified SO33 packet data service protocol stacks in the test set. The Radio Link Protocol (RLP) Type 3 and SO33 Physical Channel are explained here. For other communication protocols on the links between the mobile station and the PDSN via a base station/packet control function (BS/PCF), see the 3GPP2 C.S0017-0-2 standard.

Service Option 33 Interface Protocols

Radio Link Protocol (RLP) Type 3

Radio Link Protocol Type 3 (RLP) is a protocol that specifies how data is delivered over the RF link between the wireless device and the base station.

RLP provides an octet stream transport service over forward and reverse traffic channels. It operates on a featureless octet stream, delivering the octets in the order received. RLP is unaware of higher layer framing. That is, it does not concern itself with the framework of the data packets formed in IP and PPP.

When transferring data, RLP is a pure Negative AcKnowledge based (NAK-based) protocol. That is, the receiver does not acknowledge received data frames; it only requests the retransmission of data frames that were not received. When a frame is missing RLP responds by sending a NAK frame requesting retransmission. When a new or retransmitted frame is received it is placed in a storage buffer that manages sequential delivery of RLP frames to the upper layers.

There are three general types of frames sent by RLP:

  • Control (SYNC, SYNC/ACK, NAK) frames: The control frames are used to synchronize RLP data transfer between the wireless device and the base station. Once synchronized, RLP data frames can be transferred.
  • Data (New, Retransmitted) frames: The new data frames indicate the data frames being sent for the first time. The retransmitted data frames indicates the data frames being resent in response to received NAK control frames.
  • Fill and Idle frames: When RLP frames are carried as primary traffic and no RLP frames in the above listed types are available, an idle frame or a fill frame shall be generated and supplied if a Fundicated RLP frame is needed, and a Blank RLP frame shall be supplied if a Supplemental RLP frame is needed.

The test set keeps a running count of data and maintains a set of RLP frame counters. See Data Counters .

SO33 Physical Channel

The RLP specifies that RLP frames are carried on either the F/R FCH (Forward/Reverse Fundamental Channel), the F/R SCH (Forward/Reverse Supplemental Channel), or the F/R DCCH (Forward/Reverse Dedicated Control Channel). The test set does not support the F/R DCCH.

High speed operation uses a Supplemental Channel to increase the traffic channel's bandwidth. Forward high speed operation uses a Forward Supplemental Channel. Reverse high speed operation uses a Reverse Supplemental Channel. The mobile station requests reverse high speed operation and reports changes in the number of the Preferred Reverse Supplemental Channel Rate by sending a Supplemental Channel Request Message (SCRM) or a Supplemental Channel Request Mini Message (SCRMM). The base station controls both forward and reverse high speed operation by allocating Supplemental Channels for some time period via an Extended Supplemental Channel Assignment Message (ESCAM), or a Universal Handoff Direction Message (UHDM), or a Forward Supplemental Channel Assignment Mini Message (FSCAMM). The channels for the packet data service that can be assigned by the test set depends upon the packet data service option configuration. See Packet Data Service Options for details.

The SO33 relay layer protocol specifies that RLP can be carried as either primary traffic or secondary traffic. The test set configures the Mux Sublayer to carry RLP as primary traffic only. The test set supports the multiplex options including 0x1, 0x2, 0x3, 0x905, 0x909, 0x911, 0x921 for the SO33.

How Does Packet Data Service Work?

When a wireless device attempts to access or transfer data, for instance when a selection is made from a web browser on a mobile station, the mobile station must request an SO33 connection. If the test set is configured to one of the available packet data service options (see Packet Data Service Options ), that service option will be automatically connected if the service negotiation between the wireless device and the test set was successful.

When an SO33 packet data call is connected, a PPP (Point to Point Protocol) link layer connection between a wireless device and the PDSN is opened. A physical traffic channel assignment allocates bandwidth to this connection, supporting packet data exchange between the LAN port on the test set and the wireless device.

The data link layer connection is kept open by the wireless device and the PDSN (see Packet Data Serving Node (PDSN) ) only as long as is determined by PPP. Occurrences such as link quality failure, expiration of an idle-period timer, or administrative closing of the link (such as exiting the browser on the wireless device) will cause the data link layer connection to be closed. See also Packet Data Connection Processing States .

Standards References

For Service Option 33: Data Service Options for Spread Spectrum Systems: cdma2000 High Speed Packet Data Service Option 33, 3GPP2 C.S0017-0-2.12

For RLP: Data Service Options for Spread Spectrum Systems: Radio Link Protocol Type 3, 3GPP2 C.S0017-0-2.10

Related Topics

Packet Data Service Configurations


Data Channel Parameters

Data Channel Parameters

Last updated: November 14, 2006

This section is only applicable to the lab application.

The parameters for selecting Service Option 33 (SO33)

If you select Service Option 33 (SO33), the following parameters can be configured to support the data channel function. The parameters you specified will be displayed on the Data Channel Information screen.

  • SO33 Physical Channel Configuration

    There are four options for this setting:

    • FCH: Only fundamental channels are to be assigned. This is the default value to keep backward compatibility.
    • FCH + F-SCH: Only fundamental channels and the forward supplemental channel are to be assigned.
    • FCH + R-SCH: Only fundamental channels and the reverse supplemental channel are to be assigned.
    • FCH + SCH: Fundamental channels and supplemental channels are to be assigned, both forward and reverse.

    You can dynamically assign or unassign F-SCH or R-SCH when an SO33 data connection is established. (see CALL[:CELL]:SOPTion:SO33:CHANnel:CONFigure )

  • F-SCH Data Rate

    The F-SCH data rate (see How Do I Set Up Data Channel Parameters? and CALL:SCHannel[:FORWard]:DRATe[:SELected] ) can be changed while maintaining an SO33 data connection (with F-SCH channel being assigned). The test set will inform the mobile station of the new data rate with signaling, and wait for a reply from the mobile station. When the mobile station acknowledges the new rate, the test set will change the over-the-air data rate. If the mobile station does not acknowledge the new data rate, the test set will display an error message which indicates that the mobile station has rejected a data rate change and the data rate will not be changed.

    See also Packet Data Service Data Rates .

  • F-SCH Encoder Type (see CALL:SCHannel[:FORWard]:ENCoder )

  • R-SCH Data Rate

    The R-SCH data rate (see How Do I Set Up Data Channel Parameters? and CALL:SCHannel:REVerse:DRATe[:SELected] ) can be changed while maintaining an SO33 data connection (with R-SCH channel being assigned). The test set will inform the mobile station of the new data rate with signaling, and wait for a reply from the mobile station. When the mobile station acknowledges the new rate, the test set will change the over-the-air data rate. If the mobile station does not acknowledge the new data rate, the test set will display an error message which indicates that the mobile station has rejected a data rate change and the data rate will not be changed.

    See Packet Data Service Data Rates

  • R-SCH Encoder Type (see CALL:SCHannel:REVerse:ENCoder )

  • DUT IP Address

    It is used to assign a valid IP address to wireless devices (see CALL:MS:IP:ADDRess ) when the External PDSN State is set to Off. It can be used to establish a packet data connection using Simple IP protocol (see Packet Data Service Example Procedure (via Simple IP) ) or used by Ping functionality ( Ping the DUT from the test set ).

    This setting has no effect when the External PDSN State is set to On where the DUT IP address is determined by the external MOB-IP-SIM. Moreover, the ping to a DUT functionality is disabled.

    The DUT IP Address and the test set's LAN IP address (see Configuring the Test Set's LAN ) should be unique and in the same subnet (see also IP Address Requirements ). The DUT IP Address setting is stored in nonvolatile RAM and will NOT be changed by a reset or by cycling the power.

The following parameters are used for controlling the test set to work with the external MOB-IP-SIM for mobile IP service.

  • External PDSN State

    It specifies whether the PDSN simulation is provided by the external (MOB-IP-SIM) or internal (test set). See also Setting Considerations for External PDSN State .

    • When the External PDSN State is set to Off , the test set's internal PDSN simulation is used and the mobile station's IP address is specified by the DUT IP Address . The mobile station's PPP connection is terminated by the test set, propagating the encapsulated IP packets directly to the test set's Ethernet interface.
    • When the External PDSN State is set to On , the external MOB-IP-SIM will provide PDSN service to the mobile stations, the test set will forward the PPP octets to the MOB-IP-SIM, which is responsible for actual termination of the PPP link. The MOB-IP-SIM will interpret all layers necessary to pass the end-to-end encapsulated IP packets directly onto the network (IP, UDP, MIP). See How Does Test Set Support Simple IP and Mobile IP? for details.

    GPIB Command: CALL:DATA:PDSNode:EXTernal:STATe

  • External PDSN IP Address

    It is used to specify the IP address of the external MOB-IP-SIM. You must specify a valid value (see CALL:DATA:PDSNode:EXTernal:IP:ADDRess ) before turning the External PDSN State to on. When the External PDSN State is off, this setting has no effect.

    The IP addresses for the external MOB-IP-SIM and the test set should be unique, but without the requirement of being within the same subnet.

    • If the External PDSN IP Address is set to the same value as the test set's LAN IP address (see Configuring the Test Set's LAN ), an error "Configuration error; External PDSN IP address cannot be the same as instrument LAN address" will be generated and the new setting value is rejected.
    • When the test set's LAN IP address is set to the same value as the External PDSN IP Address, the External PDSN IP Address will be set to undefined.

    Changing the External PDSN IP Address while the External PDSN State is On will cause a data call (if connected) to be dropped without an error prompt and the External PDSN State to be Off.

    The External PDSN IP Address value is stored in nonvolatile RAM and will NOT be changed by a reset, power cycle, or save/recall operations.

  • External PDSN TCP Port

    It is used to specify the TCP port of the external MOB-IP-SIM. You must specify a valid value ( CALL:DATA:PDSNode:EXTernal:TCP:PORT ) before turning the External PDSN State to on. When External PDSN State is off, this setting has no effect.

    Changing the External PDSN TCP Port while the External PDSN State is On will cause a data call (if connected) to be dropped without an error prompt and the External PDSN State to be Off.

    The External PDSN TCP Port value is stored in nonvolatile RAM and will NOT be changed by a reset, power cycle, or save/recall operations.

  • External PDSN Connect Timeout

    It is used to set the maximum amount of time (1 - 19 seconds) the test set will wait for an acknowledgment when trying to connect to the external PDSN (MOB-IP-SIM). See CALL:DATA:PDSNode:EXTernal:TIMeout[:CONNect] .

    If the external PDSN connect timeout timer expires or the external PDSN rejects the connection request, the test set will generate an error. When External PDSN State is off, this setting has no effect.

    The External PDSN Connect Timeout value is stored in nonvolatile RAM and will NOT be changed by a reset, power cycle, or save/recall operations.

    NOTE
    The External PDSN Connect Timeout is allowed to be set to the range of 0 to 19 seconds in the earlier E6706A firmware revisions (A.01 and A.02). However, you should not set the External PDSN Connect Timeout to zero. Otherwise, changing the External PDSN State to On will result in an error message indicating that the External PDSN is not available and the state will remain off.

    If the value is set to zero and you boot up into a newer version of firmware (E6706A A.02.10 and above), the value stored in NVRAM will be changed to one on power-up.

Setting Considerations for External PDSN State

  • Before turning the External PDSN State to on, you must firstly set the External PDSN State and External PDSN TCP Port parameters to match the values as required for the external MOB-IP-SIM.
  • The External PDSN State will be set to the default value (Off) by a full preset or power cycle.
  • The External PDSN State can be saved and recalled by the operation of Save and Recall Registers . Recalling the External PDSN State will, if the saved state is On, attempt to reconnect to the external PDSN (MOB-IP-SIM) at the currently specified External PDSN IP address and TCP port. The external PDSN IP address and TCP port can not be saved and recalled.
  • If the test set has a data connection with the external MOB-IP-SIM ( External PDSN State is on), changing the External PDSN State to Off will drop the current data connection without an error prompt.
  • If the test set has a data connection with the external MOB-IP-SIM ( External PDSN State is on), changing the External PDSN IP Address or the External PDSN TCP Port will drop the current data connection without an error prompt.
  • When the external MOB-IP-SIM is providing PDSN service to the mobile stations, the mobile station's IP address is assigned by the MOB-IP-SIM. The setting by DUT IP Address is ignored and the ping to DUT functionality is not available (see Ping the DUT from the test set ).

Parameters for selecting SO33 (+F-SCH)

If you select SO33 (+F-SCH), the following parameters can be configured to support the data channel function and the effect is same as SO33 if SO33 Physical Channel Configuration is set to FCH+F-SCH. However, F-SCH can't be unassigned in this case.

Related Topics

Manual Operation: How Do I Set Up Data Channel Parameters?


Ping

Ping

Last updated: January 5, 2007

This section is only applicable to the lab application.

Ping Description

Ping is a tool to help check system interconnects. The test set has a Ping feature that allows you to ping either the device under test (DUT) or an alternate address (see How Do I Ping a Device From the Test Set? ). It sends an IP datagram (technically an ICMP message: Internet Control Message Protocol) from the test set to the ping target, and expects a response from the target. You can define the size of the IP datagram. The default is 64 bytes. If a response is received it is recorded on the test set's display.

Ping is the simplest implementation of the Data Channel feature. If you are trying to debug a system that is not responding to a full network setup (for example a WAP setup), try pinging the DUT from a computer attached to the network. Experiment with very large packets, very long timeouts and continuous pings.

How to Read the Ping Results

If the connection is good, then the DUT will return a packet to the test set and the packet transfer information is displayed on the test set's screen. In the example below ping count was set to 1. Note that it took 2700 milliseconds to complete the ping.

Ping data passing between the test set and the mobile station can be logged using the Wireless Protocol Advisor (WPA). See Protocol Logging During Ping .

Operating Considerations

  • Ping is only available in Active Cell operating mode and the system type is set to IS-2000.
  • When pinging the DUT, a packet data connection (either with SO33 or SO33 (+ F-SCH) service option) must be in the connected or dormant state (see Packet Data Connection Processing States ). Your mobile station must support ping for you to be able to successfully ping the DUT IP Address. See Ping the DUT from the test set .
  • There are restrictions regarding IP Addresses that are valid for use. See IP Address Requirements for more information.
  • When the Ping originates from the test set and the target is the DUT, the Source Address in the Forward/Down direction is always 130.29.181.203, and the Destination Address in the Reverse/Up direction is the same value. See Method 1: Ping the Mobile Station from the Test Set for more information.
  • When External PDSN State is On , the operation to ping the DUT from the test set ( Ping the DUT from the test set ) will be rejected since the IP address of the DUT is decided by the external MOB-IP-SIM instead of the specified DUT IP Address on the test set (see Data Channel Parameters ).
  • Ping to a DUT in progress will be aborted when the External PDSN State changes to On.

Related Topics

How Do I Ping a Device From the Test Set?


Protocol Logging During Ping

Protocol Logging During Ping

Last updated: June 18, 2007

This section is only applicable to the lab applications.

Ping data passing between the test set and the mobile station can be logged using the Wireless Protocol Advisor (WPA) (see Protocol Logging ). The log results during ping depend on the method used. Here are several methods and descriptions of the log results.

  • Method 1: Ping the Mobile Station from the Test Set
  • Method 2: Ping an Alternate IP Address From the Test Set
  • Method 3: Using Ping From Other Devices
  • Ping Log

Method 1: Ping the Mobile Station from the Test Set

To capture a protocol log while pinging the mobile station from the test set, start a capture in the WPA and then follow the steps in Ping the DUT from the test set .

Looking at the Protocol Log

Note that the Source Address for the IP datagram in the Forward/Down direction is an unknown IP address (130.29.181.203). This is an internal address the test set uses to originate IP traffic from the test set to the mobile station.

See Ping Log for more information about the log.

Method 2: Ping an Alternate IP Address From the Test Set

To capture a protocol log while pinging an alternate IP address from the test set, start a capture in the WPA and then follow the steps in Ping an alternate address from the test set .

If your Alternate Ping Address is anything but the mobile station address, the test set's protocol logging does not log this ping. The test set's logging only captures messages exchanged between the test set and the mobile station. If you have a network logging device on your LAN, it will show that the source IP address is the test set's LAN IP address. If your Alternate Ping Address is the mobile station address, then the data is logged by the test set, and the Source Address for the datagram in the Forward/Down direction that contains the ping data is the same IP address as in Method 1.

Method 3: Using Ping From Other Devices

Any device on the network that has a ping feature can ping any other device, including the mobile station. For example, if you have a PC on the LAN that the test set is connected to, you can use ping from that PC to ping the mobile station.

Example procedure of pinging the mobile station from another device (e.g. a Windows PC):

  1. Start protocol logging. See Protocol Logging .
  2. Open a MS DOS command prompt on the PC.
  3. Type the following command

    ping xxx.xxx.xxx.xxx

    where xxx.xxx.xxx.xxx is the IP address of the mobile station.

  4. The ping should respond as normal.
  5. Stop logging.

In this case, the Source Address for the datagram in the For/Down direction that contains the ping data is the IP address of your PC.

Ping Log

The Ping can be logged using the Wireless Protocol Advisor (WPA) (see Protocol Logging ), and certain information can be derived from the log of the Ping.

  • "For/Down" in the "Direction" column of the WPA indicates that this is a forward/down link message and is therefore passing from the test set to the mobile station.
  • Ping is an Internet Control Message Protocol (ICMP) protocol message.
  • Message Type is Echo Message, which is the instruction to the peer layer at the destination address to generate an Echo Reply message.
  • The IP address of the mobile station is the Destination Address on the forward/down link datagram and is the Source Address on the reverse/up link datagram. The alternate address is an address within the test set that originated the Ping data packet.
  • The Type, Code, Checksum, Identifier and Sequence Number are all listed.

Related Topics

Ping


Packet Data Service Configurations

Packet Data Service Configurations

Last updated: November 14, 2006

This section is only applicable to the lab application.

The test set supports Service Option 33 (SO33) for high speed packet data transfer between a wireless device and a packet switched network so that you can test the performance of data applications such as music downloads, interactive and multimedia applications.

  • Packet Data Service Options
  • Packet Data Service Data Rates
  • Handoffs Available for Packet Data Services

Packet Data Service Options

The test set provides two packet data service options: SO33 and SO33 (+ F-SCH) which are available with the radio configurations 3 and above (see Service Option ). The forward and reverse traffic channels associated with the selected service options that are supported by the test set are different from the standard definition (see Channel Configurations for Packet Data Service Options ).

  • SO33: A packet data connection with the SO33 service option selected will cause the test set to establish the forward and reverse fundamental channels (F-FCH/R-FCH) for data transfer and assign the F-SCH channel, or R-SCH channel, or both, dynamically based on physical channel configuration.
  • SO33 (+ F-SCH): A packet data connection with the SO33 (+ F-SCH) service option selected will cause the test set to establish the F-FCH/R-FCH channels and then establish the F-SCH channel for high speed data transfer. The R-SCH channel is not available.

NOTE
In the real network, forward and reverse supplemental channels can be added to the fundamental (traffic) channel to increase bandwidth. The supplemental channel is requested by the mobile station when high speed operation is needed. The base station controls the duration of time that the supplemental channel is granted.

Channel Configurations for Packet Data Service Options
Channels | (Fwd3, Rvs3) |  | (Fwd4, Rvs3) |  | (Fwd5, Rvs4) a
 | SO33 | SO33 (+ F-SCH) | SO33 | SO33 (+ F-SCH) | SO33
F-FCH/R-FCH | Available | Available | Available | Available | Available
F-SCH | Available | Available | Available | Available | Available
R-SCH | Available | N/A | Available | N/A | Available
NOTE: a. The test set does not support SO33 (+ F-SCH) service option in radio configuration (Fwd5, Rvs4).

Considerations When Changing Service Options

Service Option can't be changed during a packet data connection between SO33(+F-SCH)/SO33 and any other service options, the test set does not make service negotiation, but rejects the service option change directly.

Packet Data Service Data Rates

The actual data rate for the packet data transfer depends on the radio configuration and the forward/reverse channels established (see Channel Configurations for Packet Data Service Options ):

  • The F-FCH data rate is fixed to Full either at 9.6 kbps or 14.4 kbps. See F-FCH and F-SCH Data Rates .
  • The F-SCH data rate can be changed by the F-SCH Data Rate parameter while maintaining an SO33 (with F-SCH channel being assigned) or SO33 (+F-SCH) data connection. See F-SCH Data Rate for details.
  • The R-SCH data rate can be changed by the R-SCH Data Rate parameter while maintaining an SO33 (with R-SCH channel being assigned) data connection. See R-SCH Data Rate for details.
F-FCH and F-SCH Data Rates
Fwd3, Rvs3 |  | Fwd4, Rvs3 |  | Fwd5, Rvs4
F-FCH (Traffic) | F-SCH | F-FCH (Traffic) | F-SCH | F-FCH (Traffic) | F-SCH
9.6 kbps (Full) | 9.6 kbps | 9.6 kbps (Full) | 9.6 kbps | 14.4 kbps (Full) | 14.4kbps
 | 19.2 kbps |  | 19.2 kbps |  | 28.8kbps
 | 38.4 kbps |  | 38.4 kbps |  | 57.6kbps
 | 76.8 kbps |  | 76.8 kbps |  | 115.2kbps
 | 153.6 kbps |  | 153.6 kbps |  | 230.4kbps
R-FCH and R-SCH Data Rates
Fwd3, Rvs3 |  | Fwd4, Rvs3 |  | Fwd5, Rvs4
R-FCH (Traffic) | R-SCH | R-FCH (Traffic) | R-SCH | R-FCH (Traffic) | R-SCH
9.6 kbps (Full) | 9.6 kbps | 9.6 kbps (Full) | 9.6 kbps | 14.4 kbps (Full) | 14.4kbps
 | 19.2 kbps |  | 19.2 kbps |  | 28.8kbps
 | 38.4 kbps |  | 38.4 kbps |  | 57.6kbps
 | 76.8 kbps |  | 76.8 kbps |  | 115.2kbps
 | 153.6 kbps |  | 153.6 kbps |  | 230.4kbps

NOTE
You can't set the data rate to 230.4kbps when R-SCH Encoder Type (see "CALL:SCHannel:REVerse:ENCoder" ) is turbo and Radio Configuration is (Fwd5, Rvs4).

Considerations When Changing F-SCH/R-SCH Data Rates

  • F-SCH/R-SCH Data Rates can be changed while maintaining a data connection. The test set will inform the mobile station of the new data rate with signaling, and wait for a reply from the mobile station. When the mobile station acknowledges the new rate, the test set will change the over-the-air data rate. If the mobile station does not acknowledge the new data rate, the test set will, instead, display an error indicating that the mobile station rejected a data rate change and the data rate will not be changed.

Handoffs Available for Packet Data Services

  • The test set supports hard handoffs, such as a change of RF channel or a change of PN Offset, during an SO33 or SO33 (+ F-SCH) data connection. See Performing a Hard Handoff .
  • The test set does not support soft handoffs during SO33 or SO33 (+ F-SCH) data connection.

Related Topics

Data Channel Parameters


Data Throughput Monitor

Data Throughput Monitor

Last updated: November 10, 2006

This section is only applicable to lab and protocol applications.

Description

What is Data Throughput?

The Data Throughput Monitor can analyze data transfer rates under various RF and call processing conditions. You can initiate the Data Throughput Monitor by pressing the Instrument selection key. It is displayed on the Measurement/Instrument screen (accessible using the MEASUREMENT key).

Data throughput is the rate of data transfer to and from a wireless device.

NOTE

This feature does not attempt to monitor application layer data throughput (FTP, HTTP, TELNET, etc.).

Four statistical results are available from the Data Throughput Monitor:

  • OTA Rx and OTA Tx

    OTA (Over the Air) throughput counts the data transmitted and received by the test set's protocol stack. The location of the measurement point in the protocol stack is dependent upon system type; this data could be a byte stream from RLP (Radio Link Protocol) or RLC (Radio Link Control) or PPP (point to point protocol). OTA throughput does not count physical layer overhead such a mid-amble, guard, or tail bits, or bits added by the encoding process.

  • IP Rx and IP Tx

    IP (Internet Protocol) throughput counts the data transmitted and received by the test set. It measures the IP data transferred between the external LAN connector and the protocol stack. It provides a measure of the IP data packets being transferred to/from the wireless device.

How is Data Throughput Displayed?

When the Data Throughput Monitor is selected and a data call is connected, the test set accumulates data throughput statistics. If a data call is disconnected, data accumulation is suspended until another connection is made and data accumulation continues. Data accumulation can be cleared by performing a measurement reset or clearing the graph.

The test set provides two tools to analyze data throughput:

  • Graphical trace
  • Summary table

Graphical trace

The graphical trace presents up to the most recent 600 seconds (10 minutes) of data throughput statistics. Each of the following color-coded traces can be turned on or off:

  • OTA Tx - (Over The Air Transmitted bits-per-second). This is the rate of link-layer bit transfer sent from the wireless device. In other words, OTA translates into RLP (Radio Link Protocol) in cdma2000 and 1xEV-DO, or RLC (Radio Link Control) protocol in W-CDMA and GPRS, or PPP in GSM. Tx refers to the reverse or uplink channel direction.
  • OTA Rx - (Over The Air Received bits-per-second). This is the rate of link-layer bit transfer received by the wireless device. In other words, OTA translates into RLP (Radio Link Protocol) in cdma2000 and 1xEV-DO, or RLC (Radio Link Control) protocol in W-CDMA and GPRS, or PPP in GSM. Rx refers to the forward or downlink channel direction.
  • IP Tx - Internet Protocol Transmitted. This is the rate of network-layer bit transfer sent by the wireless device. Tx refers to the reverse or uplink channel direction.
  • IP Rx - Internet Protocol Received. This is the rate of network-layer bit transfer received by the wireless device. Rx refers to the forward or downlink channel direction.

A marker can be assigned to each trace to display instantaneous numeric data throughput values. Markers can be used in conjunction with the Freeze Graph feature to analyze points of interest on traces.

Summary table

The summary table provides the latest statistics for the four monitored measurements. Each measurement is displayed with the following statistics:

  • Marker

    The data rate at the measurement's marker position in bits-per-second.

  • Current

    The measurement's instantaneous data in bits-per-second.

  • Average

    The measurement's average data rate in bits-per-second over the length of the data connection or since the last time the measurement was cleared.

  • Peak

    The measurement's peak data rate in bits-per-second over the length of the data connection or since the last time the measurement was cleared.

  • Data Transfer

    The measurement's total data throughput count, in bytes, over the length of the data connection or since the last time the measurement was cleared

Related Topics

Front Panel Operation: How Do I Use the Data Throughput Monitor?

GPIB commands: CALL:COUNt:DTMonitor (see CALL:COUNt )


Configuring Cell 2 Used for Soft/Softer Handoff

Configuring Cell 2 Used for Soft/Softer Handoff

Last updated: October 28, 2004

This section is only applicable to the lab application.

  • Cell 2 Overview
  • Configuring Cell 2 Power
  • Configuring Cell 2 PN Offset and Code Channels
  • Configuring Cell 2 Closed Loop Power Control

Cell 2 Overview

Supporting soft and softer handoffs in the test set requires simulation of a second CDMA base station simulator (Cell 2). Cell 2 is implemented with only the channels (see Generated Code Channel Information for Cell 1 and Cell 2 ) required to exercise the soft and softer handoff functionality of a CDMA mobile station. For more Cell 2 features in soft/softer handoff, see Cell 1 and Cell 2 Used in Soft/Softer Handoff .

Generated Code Channel Information for Cell 1 and Cell 2
Cell 1 Code Channels |  | Cell 2 Code Channels
IS-2000 System | IS-95 System | IS-2000 System | IS-95 System
F-Pilot | F-Pilot | F-Pilot | F-Pilot
F-Sync | F-Sync | F-FCH/Traffic | F-Traffic
F-Paging | F-Paging | F-OCNS | F-OCNS
F-QPCH | F-Traffic |  |
F-FCH/Traffic | F-OCNS |  |
F-SCH |  |  |
F-OCNS |  |  |

Configuring Cell 2 Power

Setting Cell 2 Power, such as power range, rules, current level and desired level) are similar to the Cell Power (cell 1) settings. The test set's total RF output power is a combination of the power of cell 1, cell 2 and AWGN power:
Total RF Power (dBm/1.23 MHz) = [Cell 1 Power + Cell 2 Power + AWGN Power] (dBm/1.23 MHz)
(see Configuring Cell Power and AWGN Power Levels for more information about cell power and AWGN power)

Front Panel Usage

For how to change Cell 2 power to verify the mobile station soft/softer handoff behavior, see .

Programming Usage

The test set includes commands to set the desired Cell 2 Power. You may also query the desired power level settings.

The test set also includes commands to query the current level of cell 2 power. This CALL:STATus command is query only. It returns a value indicating the test set's actual hardware settings and hardware status. Current hardware settings can differ from the desired level you've set, most frequently due to an error condition. When no error conditions exist, the commands used to set the desired level will return the same results as the commands used to query current level. For example, "CALL:CELL2:POWer?" will return the same value as "CALL:STATus:CELL2:POWer?" when no error conditions exist.

Generated Power Level Information
Parameter | Current Level | Desired Level
Cell 2 Power | CALL:STATus:CELL2:POWer:[AMPLitude][:SELected]? | CALL:CELL2:POWer

Configuring Cell 2 PN Offset and Code Channels

Setting Cell 2 code channel levels (such as current level, desired level, OCNS calculation) are similar to those for Cell 1. See Setting Code Channel Levels and Walsh Codes .

Front Panel Usage

To set the Cell 2 code channels from the front panel, see How Do I Change Generator Information? .

Programming Usage

The following table contains a list of GPIB commands controlling cell 2 code channels.

GPIB Commands for Setting/Querying Cell 2 Parameters
Parameters | Command | Purpose
Cell 2 PN Offset | CALL:CELL2:PNOFfset | Sets/queries the Cell 2 PN (pseudonoise) offset.
Cell 2 F-Pilot Level (relative to cell) | CALL:CELL2:PILot | Sets Cell 2 F-Pilot Level.
Cell 2 F-Traffic Level (IS-95 system) | CALL:CELL2:TRAFfic | Sets Cell 2 Traffic Level (IS-95).
Cell 2 F-FCH/Traffic Level (IS-2000 system) | CALL:CELL2:FCHannel | Sets Cell 2 F-FCH/Traffic Level (IS-2000).
Cell 2 Delay | CALL:CELL2:DELay | Sets Cell 2 Delay (baseband channel relative to Cell 1).
Cell 2 OCNS Level | CALL:CELL2:OCNSource | The Cell 2 F-OCNS/OCNS level is a calculated value and can only be queried. The F-OCNS value is calculated to provide a summing value that results in a total code channel value equalling 100% of cell 2 power.
 | CALL:STATus | Queries current level and states of Cell 2 Power, Cell 2 F-Pilot code channel, Cell 2 F-FCH/Traffic code channel and Cell 2 OCNS. Queries soft/softer handoff state.

Configuring Cell 2 Closed Loop Power Control

The Cell 2 closed loop power control, together with cell 1 closed loop power control, is used to verify that the mobile station responds correctly to more than one power control subchannel during soft/softer handoffs. See for details.

The closed loop power control bit patterns for Cell 2 (Cell 2 Rvs CLPC) are:

  • Active bits: indicates that the test set sends power control bits that raise or lower the power level of the mobile station depending on the received signal strength of the reverse channel.
  • Alternating bits: indicates that the test set sends alternating up/down (0/1) power control bits.
  • All Up bits: indicates that the test set sends all 0 (up) power control bits.
  • All Down bits: indicates that the test set sends all 1 (down) power control bits.
  • Alt20 Up/Down bits: indicates that the test set sends a periodic sequence of 20 up power control bits followed by 20 down power control bits.
  • Cell 1 bits: indicates that Cell 2 Rvs CLPC (cell 2 reverse closed loop power control) mode is set to the same mode as Cell 1 Rvs CLPC (cell 1 reverse closed loop power control). For Cell 1 Rvs CLPC, see Closed Loop Power Control .

The Cell 2 Rvs CLPC (cell 2 reverse closed loop power control) bit patterns can be set using the CALL:CELL2:CLPControl commands:

Related Topics

Configuring Cell Power and AWGN Power Levels


Calling Party Number Parameters

Calling Party Number Parameters

Last updated: June 20, 2006

This section is only applicable to the lab application.

Calling party number parameters can be specified and sent to the called mobile station so that you can evaluate the mobile station's behavior in response to the calling party number (for example, to see whether the mobile station displays the calling party's number as expected). There are two calling parties in the test set.

  • When you originate a call from the test set in a voice or loopback service option (see Service Option ), the information record of the calling party 1 is sent to the called mobile station via the Alert With Information Message (AWIM) identified by the RECORD_TYPE field with a value of 00000011. See How Do I Perform Calling Party Number Verification? for the detailed procedure.

    Calling Party 1 is also used for the Call Waiting test together with calling party 2.

    NOTE
    The calling party number parameters will not be sent to the mobile station when a call is connected in data service options, such as SO32 and SO33.

  • Calling party 2 is only applicable to the Call Waiting test, which is supported in voice service options only. In the test, calling party 1 and 2 parameters are specified and included in the Flash With Information Message (FWIM) or Extended Flash With Information Message (EFWIM) sent to the mobile station when there is a waiting call. See Call Waiting Parameters for details.

Parameters Description

When the test set is in the Active Cell operating mode with IS-2000 or IS-95 system type selected, the following calling party number parameters can be specified under the Calling Party Number Parameters menu by pressing F10 ( Calling Party Number Parms ) on the Call Parms 4 of 4 .

  • Calling Party Number Inclusion ( CALL:CPNumber:INCLusion ): specifies whether or not the calling party number information records are sent to the called mobile station. The definition and setup of parameters for calling party 1 and calling party 2 are totally same. If Include is selected, the five calling party 1 parameters can be specified and included in the AWIM message sent to the called mobile station. And in the Call Waiting test, calling party 1 and 2 parameters can be specified and included in the FWIM or EFWIM sent to the mobile station when there is a waiting call.
    • Calling Party Number (CHARi) ( CALL:CPNumber[1][:SELected] and CALL:CPNumber2[:SELected] ): indicates the ASCII representation of each character in the calling party number. Up to 20 characters from the set of 0123456789abc*# can be entered but up to 14 characters can be displayed. If the entered string is greater than 14 characters, only the first 11 entered characters followed by a "..." are displayed. The digits of 0-9 are entered from the DATA ENTRY keys and the characters of "abc*#" are entered from the new displayed softkeys on the right of the screen. If Calling Party 1 Number is set to the same value as Calling Party 2 Number, the change will be rejected and an error will be generated.
    • Number Type (NUMBER_TYPE) ( CALL:CPNumber[1]:TYPE and CALL:CPNumber2:TYPE ): specifies the type of number used for the calling party number. See Number Types
    • Number Plan (NUMBER_PLAN) ( CALL:CPNumber[1]:PLAN CALL:CPNumber2:PLAN ): specifies the numbering plan used for the calling party number. See Number Plan
    • Presentation Indicator (PI) ( CALL:CPNumber[1]:PRESentation[:INDicator] and CALL:CPNumber2:PRESentation[:INDicator] ): specifies whether or not to allow the calling party number displayed on the called mobile station's screen. See Presentation Indicators
    • Screening Indicator (SI) ( CALL:CPNumber[1]:SCReening[:INDicator] CALL:CPNumber2:SCReening[:INDicator] ): indicates how the calling number was screened. See Screening Indicators
    Number Types

    Parameter Values

    Description

    NUMBER_TYPE Field Value

    Unknown

    Unknown

    000

    International

    International number

    001

    National

    National number

    010

    Network

    Network-specific number

    011

    Subscriber

    Subscriber number

    100
    Abbreviated Abbreviated number

    110
    Number Plan

    Parameter Values

    Description

    NUMBER_PLAN Field Value

    Unknown

    Unknown

    0000

    ISDN/Telephony

    ISDN/Telephony numbering plan

    0001

    Data

    Data numbering plan

    0011

    Telex

    Telex numbering plan

    0100

    Private

    Private numbering plan

    1001
    Presentation Indicators

    Parameter Values

    Description

    PI Field Value

    Allowed

    Presentation Allowed

    00

    Restricted

    Presentation restricted

    01

    Number not Aail

    Number not available

    10
    Screening Indicators

    Parameter Values

    Description

    SI Field Value

    User No Screen

    User-provided, not screened

    0000

    User Verify Pass

    User-provided, verified and passed

    0001
    User Verify Fail User-provided, verified and failed 0011

    Network

    Network-provided

    0100

Related Topics

Manual Operation: How Do I Perform Calling Party Number Verification?

CALL:CPNumber

CALL:SSERvice:WAITing

Mobile Reported Information

Call Waiting

Call Waiting Parameters


Call Waiting

Call Waiting

Last updated: June 12, 2007

This section is only applicable to the lab application.

Call Waiting is a supplementary service in both wired and wireless systems. This feature allows you to perform Call Waiting tests required by 3GPP2 signalling conformance test specification.

In this test, the test set is able to:

  • Provide the second voice call to MS while the MS is already in a voice connection.
  • Provide two voice calls which share the same voice connection. The MS can switch the voice path back and forth between two calling parties.
  • Disconnect an active call when there is a waiting call. The voice connection is maintained in this case.
  • Disconnect a waiting call.

So, Call Waiting functionality provides you the awareness of a second calling party call while having a voice connection with calling party 1. It also enables you to put current call on hold and connect to the calling party 2, as well as to switch back from calling party 2 to calling party 1. (See Call Waiting State Transition for details.)

The first voice call between MS and test set is always bound to calling party 1, no matter the call is originated from MS or test set. When you originate a voice call from the test set, the information record of the calling party 1 is sent to the called MS via the Alert With Information Message (AWIM) or Extended Alert With Information Message (EAWIM) (only applicable to protocol revision 7 and above) . When there is a waiting call the test set will send a "Call Waiting Indicator" to MS via the Flash With Information Message (FWIM) or Extended Flash With Information Message (EFWIM) (only applicable to protocol revision 7 and above) identified by the RECORD_TYPE field with a value of 00010101. The "Call Waiting Indicator" is set to a "1" to indicate to MS that a call is waiting and set to a "0" if the waiting call is not answered by MS and disconnects.

Operating Considerations

Call Waiting is supported in the Active Cell operation mode, IS-2000 or IS-95 system type and all voice service options (SO1, SO3, SO17, SO68, or SO32768) selected for the current radio configurations.

Related Topics

Manual Operation: How Do I Perform Call Waiting Test?

CALL:CPNumber

CALL:SSERvice:WAITing

Call Waiting State Transition

Call Waiting Parameters

Calling Party Number Parameters


Call Waiting Parameters

Call Waiting Parameters

Last updated: May 10, 2006

This section is only applicable to the lab application.

In the Call Waiting test, the test set needs to simulate a second calling party. The parameters for calling party 2 (Calling Party 2 Number, Calling Party 2 Type, Calling Party 2 Plan, Calling Party 2 Presentation Indicator and Calling Party 2 Screening Indicator) are similar to those of calling party 1 (see Calling Party Number Parameters for details). But unlike calling party 1 related settings, calling party 2 related settings are only used in the Call Waiting test. During the test, calling party 1 and 2 parameters can be specified and included in the Flash With Information Message (FWIM) or Extended Flash With Information Message (EFWIM) (only applicable to protocol revision 7 and above) sent to the mobile station when there is a waiting call.

You can configure the Calling Party Number Parameters from the Calling Party Number Parms menu which is accessed by pressing F3 ( Call Waiting Info ) on Call Control 5 of 5 menu. The parameter settings are detailed in Parameters Description .

After setting, the parameters you set is displayed in the Call Waiting Information screen.

Related Topics

Manual Operation: How Do I Perform Call Waiting Test?

CALL:CPNumber

CALL:SSERvice:WAITing

Call Waiting

Calling Party Number Parameters


Call Waiting State Transition

Call Waiting State Transition

Last updated: November 14, 2006

This section is only applicable to the lab application.

Each calling party has three states in the Call Waiting test, they are defined as follows:

  • Idle - There is no voice call between MS and the calling party.

  • Waiting - The voice call from one calling party is waiting for an answer from MS while MS is already in a voice call with another calling party.

  • Active - There is a voice call established between MS and the calling party.

These states can be observed from the Call Waiting Information window or queried with CALL:SSERvice:WAITing:CPNumber[1]:STATus[:STATe]? and CALL:SSERvice:WAITing:CPNumber2:STATus[:STATe]? .

Many events can make calling parties to transfer states. All possible state transitions and the events cause them are described below. You can click on the blue letters for the detailed descriptions of the events.

A :

  • MS initiates a voice call and establishes a connection with calling party 1.

  • Execute " Originate Call " from the test set and establish a connection with MS.

B :

  • Execute " Connect Calling Party 1 " from the test set when the call with calling party 2 is already active, notify MS that calling party 1 is waiting.

C :

  • Execute " Connect Calling Party 2 " from the test set when the first call with calling party 1 is already active, notify MS that calling party 2 is waiting.

D :

  • MS switches between two calling parties by pressing SEND key (normally in green color) on MS.

E :

  • Execute " Disconnect Calling Party 1 " from the test set when it is waiting, notify MS that calling party 1 is no longer waiting.

  • Execute " Disconnect Calling Party 1 " from the test set when calling party 1 is active and calling party 2 is waiting, mute the voice path since there is no active calling party.

F :

  • Execute " Disconnect Calling Party 2 " from the test set when it is waiting, notify MS that calling party 2 is no longer waiting.

  • Execute " Disconnect Calling Party 2 " from the test set when calling party 2 is active and calling party 1 is waiting, mute the voice path since there is no active calling party.

G :

  • MS terminates a call and disconnects connections with both calling parties.

  • Execute " End Call " from the test set to disconnect connections with both calling parties.

Related Topics

Manual Operation: How Do I Perform Call Waiting Test?

CALL:CPNumber

CALL:SSERvice:WAITing

Call Waiting

Call Waiting Parameters

Calling Party Number Parameters


F-FCH Frame Pattern Setup

F-FCH Frame Pattern Setup

Last updated: October 28, 2004

This section is only applicable to the lab application.

The F-FCH/Traffic Frame Pattern Setup menu accessed by selecting the F-FCH Frame Pattern Setup ( F9 ) on Call Parms 4 of 4 provides the capability to specify the frame patterns to be sent on the forward traffic channel. It is available for both IS-95 system and IS-2000 system in Active Cell mode, as well as the IS-2000 Test mode.

A typical usage for specifying the frame pattern is for forward power control EIB test (see MS Reported Erasure Indicator Bit (EIB) Information ).

  • F-FCH/Traffic Frame Pattern State

    It is used to enable (On) or disable (Off) inserting error frames in the frame pattern to be sent on the F-Traffic (IS-95 system) or F-FCH (IS-2000 system).

    By default, it is set to Off indicating all good frames to be sent on the F-Traffic/F-FCH. When it is set to On, the test set will send the specified number of good frames ( F-FCH/Traffic Frame Pattern Good Frames ) and the specified number of bad frames ( F-FCH/Traffic Frame Pattern Bad Frames ) alternately on the F-Traffic/F-FCH when a call is connected.

    GPIB Command: CALL[:CELL[1]]:TRAFfic[:FORWard]:FPATtern:STATe

  • F-FCH/Traffic Frame Pattern Good Frames

    It is used to specify how many continuous good frames in the frame pattern are to be sent on the F-Traffic/F-FCH when a call is connected and the F-FCH/Traffic Frame Pattern State is On.

    The actual good frames generated in the frame pattern may be more than the specified value due to the signaling messages sent when Signaling Frame Quality is set to Good - Ignore Frame Pattern .

    GPIB Command: CALL[:CELL[1]]:TRAFfic[:FORWard]:FPATtern:GOOD

  • F-FCH/Traffic Frame Pattern Bad Frames

    It is used to specify how many continuous bad frames in the frame pattern are to be sent on the F-Traffic/F-FCH when a call is connected and the F-FCH/Traffic Frame Pattern State is On.

    GPIB Command: CALL[:CELL[1]]:TRAFfic[:FORWard]:FPATtern:BAD '

  • Signaling Frame Quality

    It is used to determine whether the signaling transmission is affected by the specified frame pattern when F-FCH/Traffic Frame Pattern State is on.

    Selecting Good - Ignore Frame Pattern indicates the test set will send good frames regardless of the specified good/bad frame pattern when signaling occurs. This may result in the actual good frames sent greater than the good frames specified by F-FCH/Traffic Frame Pattern Good Frames . For example, if a frame pattern with five bad frames followed by five good frames is specified and the Signaling Frame Quality state is set to on, when a signaling message (a good frame) occurs during F-FCH transmission, the actual frames sent to the MS will be five bad frames, six good frames.

    Selecting Bad - Follow Frame Pattern indicates the test set will always send good/bad frames as specified by the frame pattern even if signaling occurs. This may result in signaling corrupted if the signaling occurs on bad frames transmission. Since it is impossible to predict when signaling will occur so that it may result in a dropped call or other unpredictable things happening.

    GPIB Command: CALL[:CELL[1]]:TRAFfic[:FORWard]:FPATtern:SFQuality

    NOTE
    It is expected there is no signaling message sent during forward power control EIB test. Otherwise, the Signaling Frame Quality setting may have impact on the EIB test result. The actual number of good frames is greater than the specified good frames due to inserted signaling when Signaling Frame Quality is set to Good - Ignore Frame Pattern.

Related Topics

Manual Operation: Step 4: Set up F-FCH Frame Pattern


MS Reported FER Parameters

MS Reported FER Parameters

Last updated: October 28, 2004

This section is only applicable to the lab application.

The MS Reported FER Parms menu can be accessed in two ways:

  • select the MS Reported FER Info ( F1 ) on Call Control 4 of 4 , or
  • select the Forward Power Control ( F2 ) on the Call Control 4 of 4

These parameters are used to control FER reporting from the MS when FPC Mode is set to 000-Primary 800 .

  • Frame Interval of Report (Frames)

    It specifies the total number of F-FCH frames over which the MS is to count frame errors for periodic reporting of FER.

    This parameter can be changed at any time. It is converted according to Frame Interval of Report (Frames) and sent to the MS in the PWR_REP_FRAMES field in the System Parameters Message or MC-RR Parameters Message (while in idle), or the Power Control Parameters Message (after a call connected).

    When the Periodic Report Enable is set to On and the total number of frames received on the F-FCH (which is recorded in the TOT_FRAMES counter in the MS, see Background Information ) reaches this setting, the MS sends the Power Measurement Report Message (PMRM) to the test set and the FER results are displayed on MS Reported Frame Error Rate Information window. After sending a PMRM, the MS will set its TOT_FRAMES and BAD_FRAMES counters to zero.

    GPIB Command: CALL:MS:FERate:REPort:INTerval

    NOTE
    When the TOT_FRAMES reaches the Frame Interval of Report (Frames) setting, the MS sets both TOT_FRAMES and BAD_FRAMES counters to zero regardless of whether the PMRM is sent.

    Frame Interval of Report (Frames)

    Frame Interval of Report (Frames)

    PWR_REP_FRAMES

    Frame Interval of Report (Frames) = [2 (PWR_REP_FRAMES/2) * 5]

    5

    0

    7

    1

    10

    2

    14

    3

    20

    4

    28

    5

    40

    6

    56

    7

    80

    8

    113

    9

    160

    10

    226

    11

    320

    12

    452

    13

    640

    14

    905

    15

  • Frame Delay of Report (Frames)

    It specifies the delay period (in units of frames) that the MS waits after sending a PMRM before restarting frame counting for power control purpose.

    This parameter can be changed at any time. It is converted by the formula of [Frame Delay of Report (Frames) = PWR_REP_DELAY * 4 ] and sent to the MS in the PWR_REP_DELAY field in the System Parameters Message or the MC-RR Parameters Message (while in idle), or the Power Control Parameters Message (after a call connected).

    GPIB Command: CALL:MS:FERate:REPort:DELay

  • Periodic Report Enable

    It is used to enable (On) or disable (Off) the MS to generate periodic-PMRMs when the specified interval ( Frame Interval of Report (Frames) ) is reached.

    This parameter can be changed at any time. It is sent to the MS in the PWR_PERIOD_ENABLE field (On = 1, Off = 0) in the System Parameters Message or MC-RR Parameters Message (while in idle), or the Power Control Parameters Message (after a call connected).

    GPIB Command: CALL:MS:FERate:REPort:PERiod[:STATe] .

  • Threshold Report Enable

    It is used to enable (On) or disable (Off) the MS to generate threshold-based PMRMs when the detected bad frames reaches the specified threshold ( Bad Frame Threshold (Frames) ).

    This parameter can be changed at any time. It is sent to the MS in the PWR_THRESH_ENABLE field (On = 1, Off = 0) in the System Parameters Message or MC-RR Parameters Message (while in idle), or the Power Control Parameters Message (after a call connected).

    GPIB Command: CALL:MS:FERate:REPort:THReshold[:STATe]

  • Bad Frame Threshold (Frames)

    It specifies the number of bad frames detected by the MS on the F-FCH in a measurement period ( Frame Interval of Report (Frames) ) to trigger a threshold-based FER reporting.

    This parameter can be changed at any time. It is sent to the MS in the PWR_REP_DELAY field in the System Parameters Message or the MC-RR Parameters Message (while in idle), or the Power Control Parameters Message (after a call connected).

    When the Threshold Report Enable is set to On and the number of bad frames detected on the F-FCH (which is recorded in the BAD_FRAMES counter in the MS, see Background Information ) reaches this setting, the MS sends the PMRM to the test set and the FER results are displayed on the MS Reported Frame Error Rate Information screen. After sending a PMRM, the MS will set TOT_FRAMES and BAD_FRAMES counters to zero.

    GPIB Command: CALL:MS:FERate:REPort:THReshold:BAD

    NOTE
    When the TOT_FRAMES reaches the Frame Interval of Report (Frames) setting, the MS sets both TOT_FRAMES and BAD_FRAMES counters to zero regardless of whether the PMRM is sent.

Background Information

The MS maintains the following frame counters for the F-FCH:

  • A counter (TOT_FRAMES) for the total number of frames received on the F-FCH. The MS will increment the TOT_FRAMES counter by 1 for every received 20 ms frame on the F-FCH
  • A counter (BAD_FRAMES) for the number of bad frames detected on the F-FCH. If the received 20 ms frame is bad or one of the 5 ms frames (test set does not support 5 ms frames) is bad, the MS will increment BAD_FRAMES counter by 1.

To support the forward power control on the forward fundamental channel (F-FCH), the MS reports frame error rate statistics to the base station via Power Measurement Report Message (PMRM). If the base station enables periodic reporting (PWR_PERIOD_ENABLE equal to '1' ), the MS reports frame error rate statistics at specified intervals (that is, when TOT_FRAMES equal to [2 (PWR_REP_FRAMES/2) * 5]). If the test set enables threshold reporting (PWR_THRESH_ENABLE equal to '1' ), the MS reports frame error rate statistics when the frame error rate reaches a specified threshold (that is, when BAD_FRAMES equal to PWR_REP_THRESH). Also, periodic reporting and threshold-based reporting can be independently enabled or disabled by the base station.

After sending a PMRM, the MS will set both TOT_FRAMES and BAD_FRAMES counters to zero.

Related Topics

Manual Operation: Step 3: Set up FPC Parameters

GPIB Commands: CALL:MS:FERate


Forward Power Control Information

Forward Power Control Information

Last updated: November 5, 2004

This section is only applicable to the lab application.

When the F2 ( Forward Power Control ) on Call Control 4 of 4 menu is pressed, the Forward Power Control Information screen (see Forward Power Control Information ) is displayed to provide some useful results associated with forward power control (FPC) operation:

  • Inner/Outer Loop Power Control Information
  • MS Reported Frame Error Rate Information
  • MS Reported Erasure Indicator Bit (EIB) Information
  • Forward Power Control Parameters

Forward Power Control Information

Inner/Outer Loop Power Control Information

  • Current F-FCH/Traffic Level

    Indicates the average level of F-FCH (Ec/Ior) currently generated by the test set. When a call is connected with FPC mode set to 000-Primary 800,

    • it is updated at every 25 frames (each 20 ms) interval.
    • if this value is greater than the Current Maximum F-FCH Level , the Current F-FCH/Traffic Level will be clipped to the Current Maximum F-FCH Level, and no error is posted.
    • if this value is less than - 30 dB, the Current F-FCH/Traffic Level will be clipped to -30 dB, and no error is posted.

    GPIB Command: CALL:STATus:FCHannel[:CELL[1]][:LEVel][:SELected]?

  • MS Reported F-FCH Current Setpoint

    Indicates the outer loop Eb/Nt setpoint of the F-FCH last requested from the MS (see To Request an Outer Loop Report from the MS ) when a call is connected in FPC Mode set to 000-Primary 800 . The MS will send an Outer Loop Report Message in the FPC_FCH_CURR_SETPT field (in units of 0.125 dB) in response to the request. (MS Reported F-FCH Current Setpoint (dB) = FPC_FCH_CURR_SETPT * 0.125 dB).

    GPIB Command: CALL[:CELL]:FPControl:OLReport:FCHannel:SETPoint:CURRent?

To Request an Outer Loop Report from the MS

When a call is connected with FPC Mode set to 000-Primary 800 , the current outer loop Eb/Nt setpoint of the F-FCH can be requested from the MS by pressing the F4 ( Request Outer Loop Report ) or sending the CALL[:CELL]:FPControl:OLReport:REQuest command. The MS reported information is then displayed on the MS Reported F-FCH Current Setpoint field.

This request actually performs two actions, clearing the last retrieved results and then updating those results according to the MS's response. Note that if the test set does not receive an Outer Loop Report Message from the MS after a request, the MS Reported F-FCH Current Setpoint will be cleared and an error will be generated to indicate the error condition.

To Clear the Outer Loop Report Result

Whenever you press the F2 ( Clear Outer Loop Report ) on FPC Info 2 of 2 or send the CALL[:CELL]:FPControl:OLReport:CLEar command, the MS Reported F-FCH Current Setpoint result will be cleared.

MS Reported Frame Error Rate Information

To support the forward power control on the F-FCH in FPC mode 000-Primary 800 (see FPC Mode ), the MS reports frame error rate statistics to the test set via the Power Measurement Report Message (PMRM) when any of the following conditions exists:

  • the Threshold Report Enable is set to On and the number of bad frames detected on the F-FCH (which is recorded in the BAD_FRAMES counter in the MS, see Background Information ) reaches the specified Bad Frame Threshold (Frames) , or
  • the Periodic Report Enable is set to On and the total number of frames received on the F-FCH (which is recorded in the TOT_FRAMES counter in the MS, see Background Information ) reaches the specified Frame Interval of Report (Frames) .

When the test set receives a PMRM from the MS, the following results will be updated on the MS Reported Frame Error Rate Information window (see Forward Power Control Information ).

  • MS Reported FER

    Indicates the frame error rate, in percentage. It is calculated as: Bad Frames/Total Frames *100.

    GPIB Command: CALL:MS:FERate:REPort:RATio?

  • Bad Frames/Total Frames

    Bad Frames indicate the number of bad frames detected on the F-FCH by the MS and Total Frames indicate the total number of frames received on the F-FCH by the MS. They are corresponding to the ERRORS_DETECTED and PWR_MEAS_FRAMES fields in the PMRM reported from the MS.

    The maximum value of the ERRORS_DETECTED is 31. When the number of the detected bad frames exceeds 31, the ERRORS_DETECTED will remain at 31 or roll back to zero depending upon the mobile station's design.

    GPIB Commands: CALL:MS:FERate:REPort:BAD? and CALL:MS:FERate:REPort:TOTal?

To Clear the MS Reported Frame Error Rate Information

To clear the information on the MS Reported Frame Error Rate Information screen, press the F3 ( Clear MS Reported FER ) on FPC Info 2 of 2 menu or send CALL:MS:FERate:REPort:CLEar command.

MS Reported Erasure Indicator Bit (EIB) Information

When a call is connected with FPC Mode set to 011-EIB , the test set maintains a set of EIB counters. These EIB counters will keep track of how many good/bad frames that were sent from the test set as specified (see F-FCH Frame Pattern Setup ) are matched with the EIBs reported from the MS when the EIB counters are started (see To Start/Stop EIB Counters ). All these EIB counters can be queried with one command (see CALL[:CELL]:FPControl:EIBCount[:ALL]? ).

For details on how the MS reports EIBs in response to the received frame, see FPC Mode '011' .

NOTE
The actual good frames sent from the test set may be greater than the specified good frames. See Signaling Frame Quality for details.

  • Good Frames Matched: indicates how many good frames sent from the test set are reported as good frames by the MS. This counter is increased by one for each sent good frame when the corresponding EIB is reported as 0 (indicating good frame) by the MS.
  • Good Frames Not Matched: indicates how many good frames sent from the test set are reported as bad frames by the MS. This counter is increased by one for each sent good frames when the corresponding EIB is reported as 1 (indicating bad frame) by the MS.
  • Good Frames Not Received: indicates how many good frames sent from the test set are not received by the MS. This counter is increased by one for each sent good frame when the corresponding EIBs are not received from the MS.

    NOTE
    The standard specifies that the MS will turn off its transmitter when it receives 12 continuous bad frames and will turn on the transmitter again when it receives two good frames. When the MS's transmitter is turned off, the test set will not receive EIBs on the reverse power control sub-channel.

  • Bad Frames Matched: indicates how many bad frames sent from the test set are reported as bad frames by the MS. This counter is increased by one for each sent bad frame when the corresponding EIB is reported as 1 (indicating bad frame) by the MS.
  • Bad Frames Not Matched: indicates how many bad frames sent from the test set are reported as good frames by the MS. This counter is increased by one for each sent bad frames when the corresponding EIB is reported as 0 (indicating good frame) by the MS.
  • Bad Frames Not Received: indicates how many bad frames sent from the test set are not received by the MS. This counter is increased by one for each sent bad frame when the corresponding EIBs are not received from the MS.

    NOTE
    The standard specifies that the MS will turn off its transmitter when it receives 12 continuous bad frames and will turn on the transmitter when it receives two good frames. When the MS's transmitter is turned off, the test set will not receive EIBs on the reverse pilot channel.

  • F-FCH/Traffic Frame Pattern State:

    Indicates the corresponding state that you set from the F-FCH/Traffic Frame Pattern Setup menu. See F-FCH/Traffic Frame Pattern State .

  • Good/Bad Frames and Bad Frame Ratio:

    Indicates the good/bad frame pattern that you set from the F-FCH/Traffic Frame Pattern Setup menu. It corresponds to the settings of the F-FCH/Traffic Frame Pattern Good Frames and F-FCH/Traffic Frame Pattern Bad Frames .

    Bad Frame Ratio indicates the percentage of the bad frames in the specified frame pattern. It is equal to F-FCH/Traffic Frame Pattern Bad Frames / ( F-FCH/Traffic Frame Pattern Good Frames + F-FCH/Traffic Frame Pattern Good Frames ) * 100

  • Signaling Frame Quality:

    Indicates the corresponding state that you set from the F-FCH/Traffic Frame Pattern Setup menu. See Signaling Frame Quality .

To Start/Stop EIB Counters

To start the EIB counters, the FPC Mode must be set to 011- EIB .

When a call is connected and the F5 ( Start EIB Counters ) is pressed or the CALL[:CELL]:FPControl:EIBCount:STARt command is sent, all of the EIB counters are cleared to zeroes and then start to increment according to the received EIBs from the MS. The running count of these EIB counters can be monitored from the MS Reported Erasure Indicator Bit (EIB) Information window.

All of EIB counters will stop incrementing when the F5 ( Stop EIB Counters ) is pressed or the CALL[:CELL]:FPControl:EIBCount:STARt command is sent.

When the FPC Mode is changed from '011 - EIB' to any other FPC mode, or the call status is changed from Connected to Idle, the test set will suspend all of EIB counters and remain at the last values.

To Clear the MS Reported Erasure Indicator Bit (EIB) Information

To clear the results on the MS Reported Erasure Indicator Bit (EIB) Information window, press the F4 ( Clear EIB Counters ) on FPC Info 2 of 2 or send CALL[:CELL]:FPControl:EIBCount:CLEar command.

Forward Power Control Parameters

The Forward Power Control Parameters window (see Forward Power Control Information ) displays the parameter values that you set from the FPC Parameters menu (see FPC Parameters ) except that:

  • Current Maximum F-FCH Level

    Indicates the actual upper limit of F-FCH level (Ec/Ior) that the test set is allowed to be adjusted to in FPC mode 000-Primary 800 according to the forward power control from the MS. It may be different from what you set (see Maximum F-FCH Level ) due to an invalid set caused by the code level summation check (see Considerations When Setting Code Channel States and levels ). The Current FPC Maximum F-FCH Level is not available if the test set is not in FPC mode 000-Primary 800.

    GPIB Command: CALL:STATus:FPControl:FCHannel:LEVel:MAXimum?

  • External AWGN Power

    An external AWGN value is displayed when the test set is configured to generate faded forward channel signals with AWGN. This setup requires a rear panel digital bus connection to an external PC running Baseband Studio software. See Digital Bus Information for details.

Related Topics

Forward Power Control Overview


FPC Mode

FPC Mode

Last updated: October 28, 2004

This section is only applicable to the lab application.

When the Forward Power Control ( F2 ) on the Call Control 4 of 4 menu is selected, all of the parameters and operations relating to forward power control (FPC) are available from the FPC Info menu.

FPC Mode ( F3 ) is used to specify whether the FPC operation is enabled on the test set and what kind of FPC operating mode will be used on the mobile station (MS). When a call is connected in IS-2000 system with radio configuration (Fwd3, Rvs3) and above (see Radio Configuration ), the test set informs the MS of the FPC mode to be used via the FPC_MODE field in the Power Control Message . For more information on how the FPC works, see Forward Power Control Overview .

FPC Mode
FPC Mode | Description
Ignore FPC Bits | When selected, the test set will ignore the Power Control Bits (PCBs) on the reverse power control sub-channel no matter what is sent from the MS.
000 - Primary 800 | When selected, the test set sets the MS to use FPC mode '000' as specified in the standard. In this mode, the MS transmits the primary reverse power control subchannel at 800 bps data rate and the test set will adjust the forward fundamental channel level according to the PCBs received on the reverse power control sub-channel in the specified power step size.
011 - EIB | When selected, the test set sets the MS to use FPC mode '011' as specified in the standard. In this mode, the MS transmits the Erasure Indicator Bits (EIBs) on the reverse power control sub-channel. The test set checks the received EIBs on the reverse power control sub-channel against the corresponding frames sent from the test set, and keeps a record of matched/not matched/not received frames in the EIB counters.

Setting Considerations

  • The setting of FPC mode applies to IS-2000 system with radio configuration (Fwd3, Rvs3) and above in Active Cell operating mode.
  • A special FPC mode, Ignore FPC Bits, is provided by the test set for backward compatibility. It does not mean that there is an "Ignore FPC Bits" mode on the MS. The MS always works under one of the FPC modes ('000' through '110') as specified in the standard. When the test set is set to the "Ignore FPC Bits" mode, the mobile station will be directed to use FPC mode 000 and the test set will ignore the power control bits on the reverse power control sub-channel.
  • When FPC Mode is changed in a connected call and the MS responds with a MS reject order or test set does not receive the MS ack order in a specified timeframe (~ 1 s), an error will be generated to indicated the situation. In this case, the call is still maintained and the last setting of FPC mode is kept.
  • Changing FPC mode from any other mode to '000 - Primary 800' may be rejected due to an invalid code level summation check caused by the FPC maximum F-FCH Level setting. See Setting Considerations .
  • When FPC mode is changed from '011 - EIB' to any other mode, all of the EIB counters are suspended by the test set. See MS Reported Erasure Indicator Bit (EIB) Information .
  • The test set supports forward power control for the forward fundamental channel (F-FCH). The FPC_PRI_CHAN is fixed to 0 since the F-DCCH is supported by the test set.
  • The Cell 2 always operates in the "Ignore FPC Bits" mode if a soft/softer handoff is performed. That is, the test set does not adjust the Cell 2 traffic level in response to the power control bits on the reverse power control sub-channel.

Related Topics

GPIB Commands: CALL[:CELL]:FPControl:MODE

Manual Operation: Step 2: Set up FPC Mode


Forward Power Control

Forward Power Control

Last updated: October 28, 2004

This section is only applicable to the lab application.

  • Forward Power Control Overview
  • FPC Mode
  • FPC Parameters
  • MS Reported FER Parameters
  • F-FCH Frame Pattern Setup
  • Forward Power Control Information
    • Inner/Outer Loop Power Control Information
    • MS Reported Frame Error Rate Information
    • MS Reported Erasure Indicator Bit (EIB) Information
  • Manual Operation:
    • How Do I Perform FPC Test (FPC Mode 000)?


Forward Power Control Overview

Forward Power Control Overview

Last updated: June 20, 2006

This section is only applicable to the lab application.

  • What Is Forward Power Control?
  • How Does the Test Set Support FPC?

What Is Forward Power Control?

The forward power control (FPC) is available in IS-2000 system with radio configuration 3 (RC3) and above. Unlike the reverse power control which is used for the base station (BS) to control the reverse traffic channel power level (see Setting Reverse Closed Loop Power Control ), the FPC is used for the mobile station (MS) to control the forward traffic channel power level to achieve the target Frame Error Rate (FER). The MS accomplishes forward power control by transmitting the reverse power control sub-channel to the BS on the reverse pilot channel. The MS determines the information to send to the BS through inner and outer closed loop estimations.

There are several FPC modes defined in the standard and two of the FPC modes are described here:

FPC Mode '000'

When operating in FPC mode '000', the MS supports both the inner power control loop and the outer power control loop for Forward Traffic Channel power control (see Forward Power Control ).

  • In outer power control loop estimation, the MS adjusts the Eb/Nt setpoints to the Eb/Nt value necessary to achieve the target FER on the forward traffic channel. These setpoints are communicated to the BS either implicitly through the inner loop or explicitly through signaling messages. The differences between setpoints help the BS derive the appropriate transmit levels for the forward traffic channels that do not have inner loops.
  • In inner power control loop estimation, the MS compares the received Eb/Nt to the setpoint and determines the value of the power control bit to be sent to the BS on the reverse power control sub-channel.

Forward Power Control

FPC Mode '011'

When operating in FPC mode '011', the MS sets all of the power control bits on the reverse power control sub-channel during a 20 ms period to the Erasure Indicator Bits (EIB). The BS then adjusts the forward traffic channel power levels in response to the EIB report from the MS. Since this behavior is not interactive over the air interface, the exact algorithm of how the BS would do this is not specified in the standard.

The MS transmits the EIB at the second frame of the reverse traffic channel following the corresponding forward traffic channel data frame in which the EIB is determined.

  • The MS sets the EIB to '0' at the second frame of the reverse traffic channel following the detection of a good frame (20 ms frame) on the forward traffic channel.
  • The MS sets the EIB to '1' at the second frame of the reverse traffic channel following the detection of a bad frame (20 ms frame) on the forward traffic channel.

How Does the Test Set Support FPC?

In the Active Cell operating mode, when operating in IS-2000 system with (Fwd3, Rvs3) and above, the test set supports two standard FPC mode:

  • FPC Mode '000'
  • FPC Mode '011'

The test set also supports one non-standard FPC mode:

  • Ignore FPC Bits - this mode is supported for backward compatibility (see FPC Mode for details).

FPC Mode '000'

When a call is connected with the FPC mode set to 000 - Primary 800 (see FPC Mode ),

  • the test set will send various threshold parameters, such as target FER, initial/maximum/minimum outer loop Eb/Nt setpoint for F-FCH, etc. to the MS. These parameters are required for the inner and outer power control loops estimation of the MS. See FPC Parameters for details.
  • the MS transmits the power control information determined through inner and outer power control loop estimation to the test set on the 800 bps primary reverse power control sub-channel. The test set then adjusts the F-FCH power in the specified power step size according to the received power control bits from the MS ('0' indicating increase and '1' indicating decrease). You can monitor the change of the current F-FCH level from the Inner/Outer Loop Power Control Information window.
  • to evaluate the outer and inner power control loop performance of the MS, the test set allows you to:
    • request the MS to report the current outer loop Eb/Nt setpoint for F-FCH in the Outer Loop Report Message . These results can be monitored in the Inner/Outer Loop Power Control Information window.
    • control the MS to report the current FER in the Power Measurement Report Message periodically and/or when exceeding the specified threshold (see MS Reported FER Parameters ). These results can be monitored in the MS Reported Frame Error Rate Information window.

The F-FCH FER measured at the MS should be within the assigned target FER while not exceeding the specified F-FCH Eb/Nt limit. To make a more accurate evaluation on the MS performance, see Frame Error Rate (FER) Measurement Description .

For a complete operation procedure, see How Do I Perform FPC Test (FPC Mode 000)? .

FPC Mode '011'

When a call is connected with the FPC mode set to 011-EIB (see FPC Mode ),

  • the test set continuously sends frames as specified (for example, all good or alternating good/bad frames) to the MS on the F-FCH. See F-FCH Frame Pattern Setup .
  • when the EIB counters is started (see To Start/Stop EIB Counters ), the test set checks the received EIBs reported from the MS ('0' returned following the detection of a good frame and '1' returned following the detection of a bad frame) against the corresponding frames sent from the test set and keeps a running count of how many frames are matched, not matched and not received. These counters can be monitored from the MS Reported Erasure Indicator Bit (EIB) Information window.
  • for a complete operation procedure, see How Do I Perform EIB Test (FPC Mode 011)?

Key FPC Tests in TIA/EIA-98-E Supported by the Test Set

  • Testing 3.4.7 Demodulation of Forward Traffic Channel in Multipath Fading Channel with Closed Loop Power Control (FPC_MODE = '000')
  • Testing 3.4.9 Demodulation of Forward Traffic Channel in Multipath Fading Channel with Outer Loop Power Control and Closed Loop Power Control (FPC_MODE = `000')

Related Topics

FPC Mode


FPC Parameters

FPC Parameters

Last updated: October 28, 2004

This section is only applicable to the lab application.

When the Forward Power Control ( F2 ) on the Call Control 4 of 4 menu is selected, all of the parameters and operations relating to forward power control (FPC) are available from the FPC Info menu.

When the FPC Parameters ( F1 ) is selected, the following parameters can be specified in the Forward Power Control Parameters menu.

These parameters are used for the FPC operation when FPC Mode is set to 000-Primary 800 .

  • Maximum F-FCH Level

    Specifies the upper limit of the F-FCH level (Ec/Ior) that the test set can be adjusted to according to the forward power control by the MS when FPC Mode is set to 000-Primary 800 . See also Setting Considerations .

    GPIB Command: CALL[:CELL]:FPControl:FCHannel:LEVel:MAXimuml

  • FPC F-FCH Target FER

    Specifies the F-FCH target frame error rate used by the mobile station for the outer loop power control. This parameter is sent to the MS via the FPC_FCH_FER field in the Extended Channel Assignment Message (during all establishment) or in the Power Control Message (while a call is connected) (see FPC F-FCH Target FER ).

    GPIB Command: CALL[:CELL]:FPControl:FCHannel:FERate:TARGet

    FPC F-FCH Target FER

    FPC F-FCH Target FER %

    FPC_FCH_FER (Binary)

    0.2%

    00000

    0.5% - 10% (in units of 0.5%)

    00001 - 10100

    1% - 15% (in units of 1.0%)

    10101 - 11001

    18% - 30% (in units of 3.0%)

    111010 - 11110

    Reserved

    11111

  • FPC F-FCH Initial Setpoint (dB)

    Specifies the initial F-FCH outer loop Eb/Nt setpoint (in dB) for the F-FCH. This parameter is sent to the MS in the FPC_FCH_INIT_SETPT field (in units of 0.125 dB, therefore, FPC_FCH_INIT_SETPT = FPC F-FCH Initial Setpoint (dB) / 0.125) in the Extended Channel Assignment Message (during call establishment).

    If you change the setting when a call is connected, the new setting will not apply until next time the call is reestablished.

    GPIB Command: CALL[:CELL]:FPControl:FCHannel:SETPoint:INITial

  • FPC F-FCH Minimum Setpoint (dB)

    Specifies the minimum value of the outer loop Eb/Nt setpoint (in dB) for the F-FCH. This parameter is sent to the MS in the FPC_FCH_MIN_SETPT field (in units of 0.125 dB, therefore, FPC_FCH_MIN_SETPT = FPC F-FCH Minimum Setpoint (dB) / 0.125) of the Extended Channel Assignment Message (during call establishment), the Service Connect Message or the Power Control Message (while a call is connected). It can be changed when a call is connected and takes effect immediately.

    If it is set to 31.875 dB (FPC_FCH_MIN_SETPT = 11111111) when a call is connected, the test set will direct the MS to set this Eb/Nt setpoint to the current setpoint of the F-FCH used at the MS.

    GPIB Command: CALL[:CELL]:FPControl:FCHannel:SETPoint:MINimum

  • FPC F-FCH Maximum Setpoint (dB)

    Specifies the maximum value of the outer loop Eb/Nt setpoint (in dB) for the F-FCH. This parameter is sent to the MS in the FPC_FCH_MAX_SETPT field (in units of 0.125 dB, FPC_FCH_MAX_SETPT = FPC F-FCH Maximum Setpoint (dB) / 0.125) in the Extended Channel Assignment Message (during call establishment) or the Service Connect Message or the Power Control Message (while a call is connected). It can be changed when a call is connected and takes effect immediately.

    If it is set to 31.875 dB (FPC_FCH_MAX_SETPT = 11111111) while a call is connected, the test set will direct the MS to set this Eb/Nt setpoint to the current setpoint of the F-FCH used at the MS.

    GPIB Command: CALL[:CELL]:FPControl:FCHannel:SETPoint:MAXimum

    NOTE
    Setting the FPC F-FCH Initial Setpoint (dB) , FPC F-FCH Minimum Setpoint (dB) and FPC F-FCH Maximum Setpoint (dB) to the same value will disable the outer loop power control on the F-FCH. This can be observed by the value of the MS Reported F-FCH Current Setpoint in the Inner/Outer Loop Power Control Information window which is fixed to this value whenever the MS is requested to send an Outer Loop Report Message .

  • Forward Power Control Step Size

    Specifies the power control step size that the test set is to adjust the F-FCH level according to each power control bit received from the MS during the forward power control.

    GPIB Commands: CALL[:CELL]:FPControl:STEP

  • AWGN Power (dBm/1.23 MHz)

    See Configuring Cell Power and AWGN Power Levels .

Setting Considerations

  • When FPC Mode is set to 000-Primary 800 ,
    • the maximum F-FCH level must be set no less than the value of F-FCH Level (see Setting Code Channel Levels and Walsh Codes ). Changing Maximum F-FCH Level or F-FCH Level may be pended due to an invalid set resulted.
    • the maximum F-FCH level will take the place of F-FCH Level and be used in the code level summation check ( Considerations When Setting Code Channel States and levels ). That is, the Calculated OCNS Level is calculated based on the Maximum F-FCH Level instead of F-FCH Level. The actual allowed maximum value ( Current Maximum F-FCH Level ) may be different from what you set if an invalid set present.
    • if the Current F-FCH Level generated by the test set is greater than the Current Maximum F-FCH Level, the Current IS-2000 F-FCH Level will be clipped to the Current Maximum F-FCH Level, and no error is posted.
    • if the Current F-FCH Level generated by the test set is lower than -30 dB, the Current IS-2000 F-FCH Level generated by the test set will be clipped to the -30 dB, and no error is posted.

Related Topics

Manual Operation: Step 3: Set up FPC Parameters


Hybrid Mode

Hybrid Mode

Last updated: November 10, 2006

This section is only applicable to the lab application.

  • Overview
  • How Does Test Set Support Hybrid Mode AT/MS Tests?
    • Prerequisite Setup
    • General Test Procedure
    • Operating Considerations

NOTE
The terms of the access terminal (AT) and access network (AN) that are used in the IS-856 (1xEV-DO) system are equivalent to the terms of the mobile station (MS) and base station (BS) used in the IS-2000/IS-95 (CDMA) system.

Overview

In a wireless network that supports both the IS-2000/IS-95 (CDMA) and IS-856 (1xEV-DO) systems, a hybrid mode AT/MS is capable of:

  • acquiring both the IS-2000/IS-95 and IS-856 systems, and maintaining registration and overhead information on both types of system concurrently.

    A hybrid mode AT/MS on power-up will first try to search and acquire an IS-2000/IS-95 system and then acquire a collocated IS-856 system. Once acquiring, the AT registers to the IS-2000/IS-95 system and opens a session with the IS-856 system. It will then periodically monitor the IS-2000 paging channel and IS-856 control channel.

    Note that some hybrid mode AT/MSs are designed as primarily a CDMA device with 1xEV-DO capabilities. This kind of hybrid mode AT/MS will first try to search and acquire a CDMA system before searching for a collocated 1xEV-DO system. If CDMA service is not acquired first, the hybrid mode AT/MS will not try to acquire 1xEV-DO service, even if available.

  • supporting services on both the IS-2000/IS-95 and IS-856 systems.

    While operating on both the IS-2000/IS-95 and IS-856 systems, a hybrid mode AT/MS can connect services available on either system in response to an origination request or page match. The most advantage of hybrid mode AT/MS is able to monitor voice calls when in a 1xEV-DO data connection. Moreover, voice services takes a higher priority over packet data service. That is, the packet data being transferred will be pending and the voice call is serviced whenever there is a voice call.

    The hybrid mode AT/MS supports two operating modes: non-simultaneous voice and data (non-SVD) mode and SVD mode. The key difference between the non-SVD and the SVD modes is as follows:

    • For the AT/MS that supports non-SVD mode, whenever a voice call is received or originated on the IS-2000/IS-95 system while the AT having an active packet data transfer on the IS-856 system, the packet data being transferred will be pending on the IS-856 system. The packet data transfer will not resume on the IS-856 system until the voice call is terminated. To avoid wasting forward link capacity of the IS-856 system, the hybrid mode AT/MS sets the cover of the R-DRC channel to the null value shortly before tuning away to the IS-2000/IS-95 system (this stops forward packet transmission and causes the IS-856 data session to go dormant). When the voice call is terminated, the hybrid mode AT/MS returns to the IS-856 system and resumes the data session (coming out of dormancy).
    • For the AT/MS that supports SVD mode, when there is a dormant/active data connection on IS-856 system and a voice call is attempted, the AT/MS will establish the voice call on IS-2000 system and also transfer the packet data session from IS-856 system to IS-2000 system via dormancy. If the user application attempts to send data, it will trigger a service option 33 packet data connection while keeping the voice connection on the IS-2000 system.

      NOTE
      The test set does not support SVD operation.

  • supporting handoff of an existing packet data session between IS-2000 and IS-856 systems.

    NOTE
    The data session handoff are not supported by a hybrid mode AT/MS when operating on an IS-95 system.

    Since packet data service can be provided on either an IS-2000 system or an IS-856 system, a hybrid mode AT/MS is able to handoff an existing packet data connection across systems when the current connected system is unavailable. However, the preference of packet data service is given to the IS-856 system when both systems are available.

    • A hybrid mode AT/MS can handoff an active or dormant data connection from IS-856 system to IS-2000 system.

      This is because the AT periodically monitors the IS-2000 channel and has knowledge of both the IS-856 and IS-2000 channel conditions and the up-to-date IS-2000 overhead information. When IS-856 system is lost (for example, user drives out of the IS-856 system coverage) during an active or dormant data connection, the hybrid mode AT/MS will initiate an SO33 packet data connection on the IS-2000 system.

    • A hybrid mode AT/MS can handoff a dormant data session from IS-2000 system to IS-856 system, but does not support an active data session handoff from IS-2000 system to IS-856 system.

      When a packet data session is dormant on IS-2000 system, AT monitors for IS-856 system. Since the preference of packet data service is given to the IS-856 system, AT immediately hands off the dormant data session from IS-2000 system to IS-856 system when IS-856 system is available and found.

      The hybrid mode AT/MS does not support monitoring IS-856 system when IS-2000 traffic channel is active. Therefore, when the AT has an active packet data session on IS-2000 system, it stays on IS-2000 system (even if the IS-856 system is available) until data connection is terminated on IS-2000 system.

    • A hybrid mode AT/MS supports implicit handoff during origination. If AT fails to open IS-856 data connection for a few attempts, AT transfers the data session and originates on the IS-2000 system.

How Does Test Set Support Hybrid Mode AT/MS Tests?

  • Prerequisite Setup
  • General Test Procedure
  • Operating Considerations

Prerequisite Setup

To perform the functional test of the hybrid mode AT/MS, two test sets, one providing a CDMA network emulation and another one providing an 1xEV-DO network emulation, are required. A typical connection diagram for hybrid mode AT/MS test is shown in the figure below and followed with description.

  • Make sure you have two test sets available. The test set #1 running the E6702B lab application is to emulate an IS-2000/IS-95 system (CDMA) and the test set #2 running the E6706A lab application is to emulate an IS-856 system (1xEV-DO).
  • Have the two test sets synchronized on CDMA system time. For detailed procedure on how to get the two test sets synchronized, see Performing Multi-Unit Synchronization . Once the two test sets are synchronized, the trigger connection between the two test sets are not necessary but the 10 MHz REF connection should be kept.
  • Connect the two test sets' individual RF In/Out ports together to a lowloss resistive combiner and the output of the combiner is connected to the antenna port of the hybrid mode AT/MS.
  • If you want to log the messages exchanged between the hybrid mode AT/MS and test sets, a PC running the wireless protocol advisor (WPA) software is required to be connected to the same subnet of the two test sets. In addition, the PC can be installed as a WAP, FTP, HTTP server (depending upon your packet data application) for verifying your hybrid AT/MS packet data capabilities.

The following additional setups are required for hybrid mode AT/MS tests using mobile IP (MIP) (see tests 21-28 on Specific Procedures for Recommended Tests ).

  • An external mobile IP simulator (MOB-IP-SIM, provided by the Software Concepts, Inc.) is recommended to connect to the same subnet with the two test sets. The MOB-IP-SIM provides functions such as PDSN simulation, Home Agent, etc. to allow testing the hybrid mode AT/MS that uses mobile IP technology to provide seamless high speed data connections in a mobile environment. For details on the MOB-IP-SIM functionality and configurations, see the MOB-IP-SIM technical manual available on the web:

    http://www.softwareconceptsinc.net/MIP-5850.html

Now, the hardware connection is finished and you are ready to perform the hybrid mode AT/MS tests.

General Test Procedure

There are many test cases recommended by Qualcomm® to evaluate the hybrid mode AT/MS's capabilities (as described on Overview ). For details on these tests' definitions, see Recommended Functional Tests for Hybrid Mode AT/MS .

The general procedure for the hybrid mode AT/MS test is as follows:

  1. Make sure you have finished the Prerequisite Setup , especially ensure that the two test sets are synchronized on CDMA system time.
  2. Set the call parameters on the two test sets properly so that the hybrid mode AT/MS can successfully acquire both the IS-2000/IS-95 and IS-856 systems, get registered on the IS-2000/IS-95 system and open a session on the IS-856 system.

    NOTE
    Most ATs will immediately initiate a session with the IS-856 system (1xEV-DO) once they reach the idle state upon power-up. So you will see Session Open state is always shown on the test set #2 when the hybrid mode AT/MS has successfully acquired/negotiated on the IS-856 system (1xEV-DO).

  3. Change the parameters as required for each recommended test and verify the hybrid mode AT/MS's behavior.

For the detailed test procedure, see How Do I Make Hybrid Mode AT/MS Tests? .

Operating Considerations

  • Prior to making the hybrid mode AT/MS tests, make sure your AT/MS is correctly programmed to operate in the hybrid mode. Refer to your wireless device's technical manual for details on the configuration.
  • Prior to making the hybrid mode AT/MS tests, make sure you have made the proper connection and the two test sets are synchronized on CDMA system time. See Prerequisite Setup .
  • The two test sets should not operate on the same RF frequency. The RF frequency for each test set is determined by the Cell Band and Channel settings. You should set the test sets to match the parameters stored in the hybrid mode AT/MS.
  • The Preferred Control Channel Cycle Control must be set to AT Specified (from Call Control 2 of 3 , F2 Access Network Info , F1 Configurable Attribute Ctrl ). This allows the AT/MS to propose the PCCC attribute during the session negotiation to guarantee that the preferred 1xEV-DO control channel cycle offset does not overlap in time with the CDMA paging channel slot that the AT is required to use.
  • To ensure that the hybrid mode AT/MS can successfully acquire the systems, you may need to set the SID on the test set #1 (CDMA) and/or the Sector ID on the test set #2 (1xEV-DO) to match the parameters stored in the hybrid mode AT/MS.
  • To establish a packet data connection on IS-856 system, Default Packet Application must be firstly set on the test set #2 (1xEV-DO). For details on packet data applications on IS-856 system, see:

    1xEV-DO: Data Channel

  • To establish a packet data connection on IS-2000 system, service option 33 ( SO33 or SO33 (+F-SCH) ) must be firstly set on the test set #1 (CDMA). For details on packet data applications on IS-2000 system, see Data Channel .
  • The test set does not support simultaneous voice and data (SVD) operation. For details on the SVD and non-SVD operating modes, see Overview .

Related Topics

How Do I Make Hybrid Mode AT/MS Tests?


Recommended Functional Tests for Hybrid Mode AT/MS

Recommended Functional Tests for Hybrid Mode AT/MS

Last updated: June 20, 2006

This section is only applicable to the lab applications.

There are many test cases recommended by Qualcomm® for evaluating hybrid mode AT/MS capabilities as described in Hybrid Mode . The Test cases for hybrid mode AT/MS gives the simple definition for each test supported by the test sets. To perform these tests, see How Do I Make Hybrid Mode AT/MS Tests? .

These tests can be broadly divided into three categories:

  • The tests 1 - 4 are to verify that the hybrid mode AT/MS can acquire both the IS-2000/IS-95 (cdma2000) and the IS-856 (1xEV-DO) systems, and perform dual-idle monitoring of the paging channel of the IS-2000/IS-95 system and the control channel of the IS-856 system concurrently.
  • The tests 5 - 20 are to verify that the hybrid mode AT/MS can support services on both the IS-2000/IS-95 and IS-856 systems.
    • The tests 5 - 10 are to verify that the AT/MS can initiate/accept a voice call on the IS-2000/IS-95 system while in an active/dormant packet data connection or in idle state on the IS-856 system.
    • The tests 11 - 16 are to verify that the AT/MS can initiate/accept SMS services on the IS-2000/IS-95 system while in an active/dormant packet data connection or in idle state on IS-856 system.
    • The tests 17 - 20 are to verify that the AT/MS can establish a packet data connection on the IS-856 system, or on the IS-2000 system when IS-856 system is unavailable.
  • The tests 21 - 28 are related to the MIP operations of the hybrid mode AT/MS.
    • The tests 21 - 24 are to verify that the hybrid mode AT/MS can handoff the packet data connection between the IS-856 and IS-2000 system while using the AT/MS in MIP.
    • The tests 25 - 28 are to verify the fundamental MIP operations. For example, connect a MIP call using static or dynamic home IP address, perform a MIP to SIP fallback if MIP registration fails, etc.
Test cases for hybrid mode AT/MS
No. | Test Cases | Definition | Minimum Standards
1 | Hybrid mode system acquisition | This test will verify that a hybrid mode AT/MS first acquires the CDMA system and then acquires a collocated 1xEV-DO system specified in the AT roaming list. | A hybrid mode AT/MS should be able to first acquire a CDMA system followed by the collocated 1xEV-DO system. AT should be able to monitor the CDMA paging channel and 1xEV-DO control channel in the dual-idle state.
2 | 1xEV-DO power save mode | This test will verify that the hybrid mode AT/MS enters 1xEV-DO power save mode after failing to acquire a 1xEV-DO system, either during initial acquisition upon power up or after successful acquisition followed by losing the 1xEV-DO system. | AT should be able to enter power save mode after losing 1xEV-DO coverage. AT shall be able to periodically search for 1xEV-DO system while in power save mode.
3 | Preferred Control Channel Cycle (PCCC) negotiation | This test will verify that the AT and the AN successfully perform PCCC negotiation and the AT always proposes an appropriate PCCC to avoid potential collisions between mobile directed CDMA paging channel messages and 1xEV-DO control channel messages. The AT proposes PCCC attribute during the AT initiated phase of the session negotiation. | A hybrid mode AT/MS shall be able to successfully determine and negotiate a suitable PCCC in order to avoid potential collisions between the CDMA paging slot and the 1xEV-DO control channel.
4 | Dual-idle operation on CDMA and 1xEV-DO | This test will verify that the hybrid mode AT/MS performs dual-idle monitoring of the paging channel of the CDMA system and the control channel of the 1xEV-DO system concurrently. It also verifies that upon losing 1xEV-DO system during dual-idle operation, the hybrid mode AT/MS tries to reacquire the 1xEV-DO system; and upon losing the CDMA system during dual-idle operation, the hybrid mode AT/MS tries to reacquire the CDMA system. | After moving to an area where no 1xEV-DO signal is available but a good CDMA signal is available, AT shall try to reacquire 1xEVDO system while idle on CDMA system. After moving to a good hybrid coverage area with good CDMA and 1xEV-DO signal, AT shall be able to reacquire 1xEVDO and continue dual-idle operation.
5 | CDMA voice call origination in dual-idle state | This procedure verifies that the hybrid mode AT/MS can originate CDMA voice calls while in dual-idle state. | A hybrid mode AT/MS should be able to successfully originate CDMA voice calls in dual-idle state.
6 | CDMA voice call origination in dormant 1xEV-DO state | This procedure verifies that the hybrid mode AT/MS can originate CDMA voice calls while in CDMA idle and dormant 1xEV-DO state. | A hybrid mode AT/MS shall be able to successfully originate CDMA voice calls in dormant 1xEV-DO state.
7 | CDMA voice call origination in 1xEV-DO connected state | This test verifies that the hybrid mode AT/MS can originate CDMA voice calls while in 1xEV-DO connected state and at the end of the voice call gets into 1xEV-DO connected state if there is data to send. | A hybrid mode AT/MS shall be able to originate voice calls while in 1xEV-DO connected state.
8 | CDMA voice call termination in dual-idle state | This procedure verifies that the hybrid mode AT/MS can receive CDMA voice pages while in dual-idle state. | A hybrid mode AT/MS shall be able to successfully terminate CDMA voice calls in dual-idle state.
9 | CDMA voice call termination in CDMA idle/1xEV-DO dormant state | This procedure verifies that the hybrid mode AT/MS can receive CDMA voice pages while in 1xEV-DO dormant state. | A hybrid mode AT/MS shall be able to successfully terminate CDMA voice calls in CDMA idle/1xEV-DO dormant state.
10 | CDMA voice call termination in 1xEV-DO connected state | This test verifies that the hybrid mode AT/MS can receive CDMA voice pages while in 1xEV-DO connected state. | A hybrid mode AT/MS shall be able to receive CDMA voice pages while in 1xEV-DO connected state.
11 | SMS origination in dual-idle state | This procedure verifies that the hybrid mode AT/MS can originate SMS while in dual-idle state. | A hybrid mode AT/MS shall be able to successfully originate SMS in dual-idle state.
12 | SMS origination in CDMA idle/1xEV-DO dormant state | This procedure verifies that the hybrid mode AT/MS can originate SMS while in CDMA idle/1xEV-DO dormant state. | A hybrid mode AT/MS shall be able to successfully originate SMS in CDMA idle/1xEV-DO dormant states.
13 | SMS origination in 1xEV-DO connected state | This test verifies that the hybrid mode AT/MS can send CDMA SMS while in 1xEV-DO connected state. | A hybrid mode AT/MS shall be able to send CDMA SMS while in CDMA idle and 1xEV-DO connected states.
14 | SMS termination in dual-idle state | This procedure verifies that the hybrid mode AT/MS can receive SMS while in dual-idle state. | A hybrid mode AT/MS shall be able to successfully terminate SMS in dual-idle state.
15 | SMS termination in CDMA idle/1xEV-DO dormant state | This procedure verifies that the hybrid mode AT/MS can terminate SMS while in CDMA idle/1xEV-DO dormant state. | A hybrid mode AT/MS shall be able to successfully terminate SMS in CDMA idle/1xEV-DO dormant state.
16 | SMS termination in 1xEV-DO connected state | This test verifies that the hybrid mode AT/MS can receive CDMA SMS while in 1xEV-DO connected state. | A hybrid mode AT/MS shall be able to receive CDMA SMS while in CDMA idle and 1xEV-DO connected states.
17 | 1xEV-DO packet data call origination in dual-idle state | This test verifies that the hybrid mode AT/MS can originate 1xEV-DO packet data calls while in dual-idle state. | The hybrid mode AT/MS shall be able to originate 1xEV-DO packet data calls while in dual-idle state.
18 | 1xEV-DO packet data call reorigination in 1xEV-DO dormant state | This test verifies that the hybrid mode AT/MS can reoriginate 1xEV-DO packet data call while in 1xEV-DO dormant state. | The hybrid mode AT/MS shall be able to reoriginate 1xEV-DO packet data call and should be able to come out of dormant 1xEV-DO state into connected state.
19 | 1xEV-DO packet data call termination in 1xEV-DO dormant state | This test verifies that the hybrid mode AT/MS can receive 1xEV-DO packet data pages while in dormant state on 1xEV-DO. | The hybrid mode AT/MS shall be able to receive data pages while in CDMA idle/1xEV-DO dormant state.
20 | CDMA packet data call origination when 1xEV-DO service is unavailable | This test verifies that the hybrid mode AT/MS can originate a packet data call on CDMA when 1xEV-DO service is not available. | A hybrid mode AT/MS should be able to originate a packet data call on CDMA when 1xEV-DO service is not available.
21 | Active 1xEV-DO to CDMA data session handoffs | If a hybrid mode AT/MS moves out of the hybrid coverage area (where both CDMA and 1xEV-DO are present) to CDMA only coverage area while it has an active packet data session on 1xEV-DO system, AT should hand-down the active data session from 1xEV-DO to CDMA system. This test verifies the AT-AN ability to perform an active 1xEV-DO to CDMA data session handoffs with minimum interruption to the data session when both CDMA and 1xEV-DO use different PDSN's. | Hybrid AT should be able to hand-down an active 1xEV-DO data session to a CDMA system, if 1xEV-DO is lost and the time it takes to transfer the data session from 1xEV-DO to CDMA should conform to the carrier's requirement. Also data transfer should continue after PPP is resynced.
22 | Dormant 1xEV-DO to CDMA data session handoff | If a hybrid AT moves out of the hybrid coverage area (where both CDMA and 1xEV-DO are present) to CDMA only coverage area while it has a dormant packet data session on 1xEV-DO system, AT should handoff the dormant data session from 1xEV-DO to CDMA system. This test verifies the AT-AN ability to perform a dormant 1xEV-DO to CDMA data session handoff with minimum interruption to the data session when both CDMA and 1xEV-DO use different PDSN's. | A hybrid AT should be able to hand off a dormant 1xEV-DO data session to a CDMA system, if 1xEV-DO coverage is lost and the time it takes to transfer the data session from 1xEV-DO to CDMA should conform to the carrier's requirement. Also data transfer should continue after PPP is resynced.
23 | Dormant CDMA to 1xEV-DO data session handoff | If a hybrid AT moves from a CDMA only coverage area to a hybrid mode coverage area with a dormant data session on the CDMA system, AT will try to handoff the data session to 1xEV-DO system after acquiring it. This test verifies the AT-AN ability to perform a dormant CDMA to 1xEV-DO data session handoff without any interruption to the data session when both CDMA and 1xEV-DO use different PDSN's. | A hybrid AT should be able to hand off a dormant CDMA data session to a 1xEV-DO system, if AT moves back to 1xEV-DO coverage area and data transfer continues after ppp is resynced. Also the time it takes to transfer the data session from 1xEV-DO to CDMA should conform to the carrier's requirement.
24 | 1xEV-DO to CDMA to 1xEV-DO data session handback | If a hybrid AT moves from a 1xEV-DO coverage to CDMA only coverage area and back to a hybrid mode coverage area with a dormant data session on the CDMA system, AT will try to handoff the data session to 1xEV-DO system after acquiring it. This test verifies the AT-AN ability to perform a 1xEV-DO to CDMA to 1xEV-DO data session handback with minimum interruption to the data session when both CDMA and 1xEV-DO use different PDSN's. | A hybrid AT should be able to hand back a dormant CDMA data session to the 1xEV-DO system, if AT moves from 1xEV-DO coverage area to CDMA only coverage area and then back to hybrid coverage area and data transfer continues after ppp is resynced. Also the time it takes to transfer the data session from 1xEV-DO to CDMA and CDMA-1xEV-DO should conform to the carrier's handoff requirements.
25 | MIP call when using static home IP | A hybrid mode AT/MS should be able to successfully connect a MIP call while using a static Home address in AT MIP profile. | The hybrid mode AT/MS should be able to successfully connect a MIP call while using a static Home address in AT MIP profile.
26 | MIP call when using dynamic home IP | A hybrid mode AT/MS should be able to successfully connect a MIP call while using a dynamic Home address in AT MIP profile. | The hybrid mode AT/MS should be able to successfully connect a MIP call while using a dynamic Home address in AT MIP profile.
27 | MIP to SIP fallback if MIP call fails while trying packet data call on 1xEV-DO | A hybrid AT should be able to successfully fallback to SIP if MIP fails while trying to setup a packet data call from dual-idle state on 1xEV-DO. | Hybrid AT should be able to successfully fall back to SIP on 1xEV-DO if the MIP call fails on 1xEV-DO while trying to setup a packet data call from dual-idle state.
28 | MIP to SIP fallback if MIP call fails while trying packet data call on CDMA | A hybrid AT should be able to successfully fallback to SIP if MIP fails while trying to setup a packet data call from CDMA idle state on CDMA. | Hybrid AT should be able to successfully fall back to SIP on CDMA if the MIP call fails on CDMA while trying to setup a packet data call from CDMA idle state.

Related Topics

How Do I Make Hybrid Mode AT/MS Tests?


Generated Pilot Level Information

Generated Pilot Level Information

Last updated: October 28, 2004

This section is only applicable to the lab application.

The Generated Pilot Level Information table on the upper part of the Soft Handoff Information screen shows the current settings of Cell 1and Cell 2, which include the cell power, pilot power, PN Offset, and Pilot Strength for each cell. This is the actual signal being output to the mobile station. See Configuring Soft Handoff Parameters to access the Generated Pilot Level Information table.

The Generated Pilot Level Information table can assist you to verify the correct MS pilot reporting behavior (see Verifying MS Pilot Reporting Behavior in Soft/Softer Handoff ). For example, if the Generated Pilot Level Information table indicates that the Cell 2 Delta Power is stronger than T_Add (28 is the default value) multiplied by -0.5 dB, and the mobile station has not sent a Pilot Strength Measurement Message, a failure condition may exist with the mobile station. Send the pilot measurement request (see F. Send Pilot Meas Request ) and check the mobile reported Pilot Strength for Cell 2.

Description

The following information are displayed on the Generated Pilot Level Information table:

Total RF Power

The total RF power (I o ) is the sum of Cell 1 Power (Î or ), Cell 2 Power (Î or )and AWGN Power (I oc ). The Cell 1 Power (dBm/1.23 MHz), Cell 2 Power (dBm/1.23 MHz) and AWGN Power (dBm/1.23 MHz) are directly settable from the test set (see Configuring Cell Power and AWGN Power Levels and Configuring Cell 2 Power ).

Pilot Power

The Cell 1/2 Pilot Power (dBm/1.23 MHz) is the sum of the Cell 1 Power (Î or ) and Cell 1/2 F-Pilot Level (Pilot E c /I or ). The Cell 1/2 Power (dBm/1.23 MHz) and Cell 1/2 F-Pilot Level (dB) (see Configuring Soft Handoff Parameters ) are directly settable from the test set. The Cell 1/2 Pilot Power is to facilitate to calculate the Pilot Delta Power .

Pilot Delta Power

The Cell 1/2 Pilot Delta Power (dB) is the Cell 1/2 pilot level relative to the total RF power. It is equivalent to the Pilot E c /I o in the standard defined as the ratio of the combined pilot energy per PN chip to the total received power spectral density at the mobile station, including noise and other signals.

The Cell 1/2 Pilot Delta Power is not directly settable and calculated by subtracting the Pilot Power from the Total RF Power . See Total RF Power, Delta Power and Pilot Strength Calculation for details.

The Cell 1 Pilot Delta Power can be queried with the CALL:STATus:PILot[:CELL[1]][:LEVel]:RTTotal[:SELected]? and the Cell 2 Pilot Delta Power can be queried with the CALL:STATus:PILot:CELL2[:LEVel]:RTTotal[:SELected]? .

Pilot Strength

The Pilot Strength values is the value of Pilot Delta Power divided by -0.5 dB and rounded off to the nearest integer value. The test set converting the Pilot Delta Power to the Pilot Strength is to facilitate you to verify the correct mobile station pilot reporting behavior, which the mobile station reports pilot strength in units of -0.5 dB. These values should correspond to Pilot Strength values the mobile station reports in the Mobile Station Reported Pilot Level Information table (see Mobile Station Reported Pilot Level Information ).

The Cell 1 Pilot Strength can be queried with the CALL:STATus:PILot[:CELL[1]]:STRength[:SELected]? and the Cell 2 Pilot Strength can be queried with the CALL:STATus:PILot:CELL2:STRength[:SELected]? .

PN Offset

The PN Offset uniquely identifies each base station. The PN Offset values displayed in the Generated Power Level Information table can assist you to verify the correct mobile station reported PN Offset values in the Mobile Station Reported Pilot Level Information . The PN Offset values reported by the mobile station in the Mobile Station Reported Pilot Level Information table should correspond to these values.

The Cell 1/2 PN Offset can be changed either from the front panel (see How Do I Change Generator Information? ), or with CALL[:CELL[1]]:PNOFfest and CALL:CELL2:PNOFfset .

Settings That Effect the Generated Pilot Level Information Display

The following table is an example settings as specified in the standard. It also shows how to set on the test set to achieve the specified values. The Ioc, Traffic Ec/Ior, and Pilot Ec/Ior are all directly settable on the test set. For Ior/Ioc, which is the ratio of cell power to AWGN, you need to adjust Cell 1 Power (for Channel 1) and Cell 2 Power (for Channel 2) to achieve the correct levels relative to AWGN. Delta Power is then used to verify that all parameters are set correctly.

Test Parameters for Candidate Set Pilot Detection
Parameter in Standard | Channel 1 | Channel 2 | Equivalent Test Set Settings
Ior/Ioc (dB) | -3.1 | -0.1 | Set Cell 1 Power to -58.1 (AWGN Power + Ior/Ioc) Set Cell 2 Power to -55.1 (AWGN Power + Ior/Ioc)
Pilot Ec/Ior (dB) | -7 | -7 | Set Cell 1 Pilot Level to -7 dBSet Cell 2 Pilot Level to -7 dB
Traffic Ec/Ior (dB) | -7 | N/A | Set Cell 1 Traffic Level to -7 dB Set Cell 2 Traffic Level to the default (it does not matter)
Ioc (dBm/1.23 MHz) | -55 |  | Set AWGN Power to -55.
Pilot Ec/Io (dB) | -14 | -11 | Delta Power (calculated and displayed on the Generated Pilot Level Information)

Total RF Power, Delta Power and Pilot Strength Calculation

  • Cell 1 Power = -58.3 dBm/1.23 MHz (equivalent to 1.5488 E-6 mw)
  • Cell 2 Power = -55.1 dBm/1.23 MHz (equivalent to 3.0903 E-6 mw)
  • AWGN Power = -55 dBm/1.23 MHz (equivalent to 3.1623 E-6 mw)
  • Total RF Power = Cell 1 Power + Cell 2 Power + AWGN Power = 7.8014 E-6 mw (equivalent to -51.08 dBm/1.23 MHz)
  • Channel 1 Pilot Power = Cell 1 Power + Cell 1 Pilot Level = -58.1 + (-7) = -65.1 dBm/1.23 MHz
  • Channel 2 Pilot Power = Cell 2 Power + Cell 2 Pilot Level = -55.1 + (-7) = -62.1 dBm/1.23 MHz
  • Cell 1 Pilot Delta Power = Cell 1 Pilot Power - Total RF Power = -65.1 - (-51.08) = -14.02 dB
  • Cell 2 Pilot Delta Power = Cell 2 Pilot Power - Total RF Power = -62.1 - (-51.02) = -11.02 dB
  • Cell 1 Pilot Strength = Cell 1 Pilot Delta Power / (-0.5) = (-14.02)/ (-0.5) = ~ 28
  • Cell 2 Pilot Strength = Cell 2 Pilot Delta Power / (-0.5) = (-11.02)/ (-0.5) = ~ 22

Related Topics

Mobile Station Reported Pilot Level Information


R-FCH Gating

R-FCH Gating

Last updated: October 28, 2004

This section is only applicable to the lab application.

The cdma2000 system (as specified in IS-2000 standards) supports R-FCH gating in 1/8 data rate for radio configurations greater than 2, which can be enabled via the REV_FCH_GATING_MODE field of Extended Channel Assignment message sent to the mobile stations (MS). The MS in gated transmission is more effective to optimize the battery life than just lowering the transmission power.

The test set's support for the R-FCH gating mode is disabled (off) by default. It is available for the IS-2000 system with radio configurations (Fwd3, Rvs3) and above (see Radio Configuration ). If the test set's R-FCH gating mode is enabled (on) and the MS supports the gating mode, the MS will gate the R-FCH/R-Pilot Channel when transmitting at 1/8th rate (see R-FCH Gating ). If the R-FCH gating mode is enabled (on) and the MS reports that it does not support the R-FCH gating mode in either the Origination message or the Page Response message, the attempted call will be terminated and an error message will be posted by the test set.

The setting of the R-FCH gating mode is sent to the MS via the REV_FCH_GATING_MODE field of Extended Channel Assignment message during a call establishment (see Establishing an Active Link with the Mobile Station ). It can be changed only when the call status is IDLE.

By working together with Random (40% voice activity) traffic data rate (see Traffic Data Rate ), the test set's support for the R-FCH gating mode allows you to test the talk time (battery life) of the MS (see How Do I Use R-FCH Gating for Talk Time Testing? for example procedure).

R-FCH Gating
 |  | System Type = IS-2000 1
 |  | Radio Config = (Fwd3, Rvs3) or above 1
 |  | R-FCH gating mode =On
Service Option 1 | Traffic Data Rate 2 | Expected R-FCH gating
Loopback (SO2, 9 or 55) | Eighth | Always gated.
 | Full, Half, or Quarter | Never gated.
 | Random (40% Voice Activity) | Sometimes gated (R-FCH is gated during the periods when data is sent 60% of the time at 1/8th rate).
Service options other than loopback | Not applicable. | Sometimes gated (test set does not control the rate on the reverse link and therefore can not guarantee if the R-FCH/R-PICH will be gated).
1. For IS-95 system or IS-2000 system with radio configurations less than (Fwd3, Rvs3), the mobile station will be gated regardless of the R-FCH gating mode whenever the data rate is less than full rate (see Impact of the Test Set Configurations on R-FCH Gating Transmission for details) For details on service options, see Service Option . 2. For details on traffic data rate, see Traffic Data Rate .

Operating Considerations

  • The R-FCH gating mode can not be changed while the call status is connected. If a change to the gating mode is attempted while the call is connected, the new setting is rejected and an error message is generated.
  • The R-FCH gating mode setting only applies to the IS-2000 system with radio configurations (Fwd3, Rvs3) and above. For IS-95 system and IS-2000 system with radio configurations less than (Fwd3, Rvs3), the mobile station will be always gated regardless of the R-FCH gating mode whenever the data rate is less than full rate (see Impact of the Test Set Configurations on R-FCH Gating Transmission ).
  • If the R-FCH gating mode is enabled (on), the R-FCH/R-PICH will only actually be gated if the data rate on the R-FCH is 1/8th rate. See R-FCH Gating
  • The settings of R-FCH gating mode and traffic data rate (Random) also affect Expected Power .
  • When the R-FCH/R-PICH may be gating (always or sometimes gated as shown in R-FCH Gating ),
    • Channel Power measurement will be restricted to Normal speed (see Measurement Speed ).
    • Time Response of Open Loop Power Control (TROLP) measurement (see Time Response of Open Loop Power Control (TROLPC) Measurement Description ) can not be activated since it requires non-gated transmission on the reverse traffic link.
    • Initiating the TX spurious emissions measurement (see Tx Spurious Emissions Measurement Description ) will result in an error message indicating that the measurement requires non-gated transmission on the reverse traffic link.
    • Initiating the Digital Average Power measurement (see Digital Average Power Measurement Description ) will result in an error message indicating that the measurement result is not accurate for gated MS transmissions in radio configurations greater than 2.

Related Topics

GPIB Command: CALL[:CELL[1]]:FCHannel:REVerse:GATing

Manual Operation: How Do I Use R-FCH Gating for Talk Time Testing?


Performing Soft/Softer Handoffs with the Test Set

Performing Soft/Softer Handoffs with the Test Set

Last updated: October 28, 2004

This section is only applicable to the lab application.

  • Cell 1 and Cell 2 Used in Soft/Softer Handoff
  • Configuring Cell 2
  • Configuring Soft Handoff Parameters
  • Verifying MS Pilot Reporting Behavior in Soft/Softer Handoff
  • Verifying Mobile Station (MS) Closed Loop Power Control (CLPC) Behavior in Soft/Softer Handoffs

Cell 1 and Cell 2 Used in Soft/Softer Handoff

The test set has the ability to simulate either two individual base stations or one two way sectored base station (see Test Set Generators ), which allows testing of soft and softer handoff performance of a mobile station (see Verifying MS Pilot Reporting Behavior in Soft/Softer Handoff and Verifying Mobile Station (MS) Closed Loop Power Control (CLPC) Behavior in Soft/Softer Handoffs ).

  • Cell 1 (or Sector A) is a full cell that supports up to seven CDMA channels for call processing support. For more configuration information about Cell 1, see Forward Link Overview .
  • Cell 2 (or Sector B) is a partial cell that is implemented with only the channels required to exercise the soft and softer handoff functionality of a mobile station. For more configuration information about Cell 2, see Configuring Cell 2 Used for Soft/Softer Handoff .
  • Cell 2 / Sector B's Pilot source allows a CDMA mobile station to detect energy at another PN Offset and request a soft or softer handoff.
  • Once cell 2 has been detected, a soft or softer handoff between the two cells/sectors can be user initiated from the test set. See Enabling Soft/Softer Handoff .
  • Cells 1 and 2 have independent reverse link power controls and have individually settable Walsh code, PN Offsets. See Configuring Cell 2 Used for Soft/Softer Handoff .
  • Since Cell 2 does not have a Sync channel or a Paging channel, it is not possible for the mobile station to camp on Cell 2 or to be brought up on a call using only Cell 2 as the source.
  • The mobile station can move from a call on Cell 1 to a call with soft or softer handoff including Cell 1 and Cell 2. The mobile station may then return to a call with Cell 1 only. The mobile station is not allowed to continue with a connection to Cell 2 only.

Test Set Generators

Configuring Cell 2

See Configuring Cell 2 Used for Soft/Softer Handoff .

Configuring Soft Handoff Parameters

See Configuring Soft Handoff Parameters .

Verifying MS Pilot Reporting Behavior in Soft/Softer Handoff

When the mobile station detects that a pilot has crossed certain power level thresholds (such as T_Add, T_Comp, T_Drop, etc., see Configuring Soft Handoff Parameters ), the mobile station will send a Pilot Strength Measurement Message (PSMM) to the test set autonomously. The reported pilot level information is displayed in Mobile Station Reported Pilot Level Information table.

The following examples explain how these parameters affect the pilot reporting function of the mobile station.

T_Add Behavior

If the pilot strength of Cell 2 relative to the total RF power (see Pilot Delta Power ), exceeds T_Add (28 is the default value) multiplied by -0.5 dB, the mobile station will add the Cell 2 pilot to its Candidate set of pilots (see Pilot Sets ). It will also send a Pilot Strength Measurement Message to the test set to report the measured pilot level information (see Mobile Station Reported Pilot Level Information ).

See How Do I Make Soft/Softer Handoff Tests Regarding T_Add? for the example procedure to verify that the MS behaves correctly regarding T_Add.

T_Comp Behavior

If the pilot strength of Cell 2 (see Pilot Delta Power ) that is a member of the mobile station's Candidate set of pilots (see Pilot Sets ), relative to the total RF power, is stronger than Cell 1 currently in the mobile station's Active set (see Pilot Sets ) by at least T_Comp (5 is the default value) multiplied by 0.5 dB, the mobile station flags this event as "To Add" to assist the test set in determining when adding a pilot to the mobile station's Active set should be considered (soft/softer handoff). The Cell 2 pilot is added to the Active set of pilots when the soft/softer handoff is initiated (see Enabling Soft/Softer Handoff ). It will also send a Pilot Strength Measurement Message to the test set to report the measured pilot level information (see Mobile Station Reported Pilot Level Information ).

See How Do I Make Soft/Softer Handoff Tests Regarding T_Comp? for the example procedure to verify that the MS behaves correctly regarding T_Comp.

T_Drop/T_TDrop Behavior

If the pilot strength of Cell 2 (see Pilot Delta Power ) that is currently in the mobile station's Active set of pilots (see Pilot Sets ), relative to the total RF power, falls below the T_Drop (32 is the default value) multiplied by -0.5 dB threshold for the period of time specified by T_TDrop (3 is the default value, indicating 4 seconds), the mobile station flags this event as "To Drop" to assist the test set in determining when an Active set pilot should be dropped from its Active set. In the test set, the Cell 2 pilot is removed from the Active set of pilots when the soft/softer handoff is turned off (see Enabling Soft/Softer Handoff ). It will also send a Pilot Strength Measurement Message to the test set to report the measured pilot level information (see Mobile Station Reported Pilot Level Information ).

See How Do I Make Soft/Softer Handoff Tests Regarding T_Drop/T_TDrop? for the example procedure to verify that the MS behaves correctly regarding T_Drop/T_TDrop.

Verifying Mobile Station (MS) Closed Loop Power Control (CLPC) Behavior in Soft/Softer Handoffs

The test set supports two types of soft handoffs: Soft and Softer. The difference between these two handoff types consists of messaging that the test set sends to the mobile station regarding closed loop power control subchannel bit. This allows to test the mobile station's ability to respond correctly to more than one power control subchannels.

MS CLPC Behavior in Soft Handoff

When Soft is selected in the Soft Handoff Parameters menu Handoff Type field (see B. Set Up Soft/Softer Handoff Parameters ), and a soft handoff is initiated by selecting On in the Soft Handoff field (see D. Initiate the Soft or Softer Handoff ),

  • The test set sends the mobile station a Handoff Direction message with PWR_COMB_IND bit set to 0. This bit tells the mobile station that it will be receiving different power control bits from Cell 1 and Cell 2.
  • The mobile station is expected to perform a logical "or of downs" of power control bits received from both cells, which means the mobile station will increase its power level if and only if both power control bits are 0 (indicating up).

See Verifying MS CLPC Behavior in Soft Handoff for the example procedure to verify that the MS responds correctly to more than one power control subchannel based on "or of down" logic of the power control bits.

MS CLPC Behavior in Softer Handoff

When Softer is selected in the Soft Handoff Parameters menu Handoff Type field (see B. Set Up Soft/Softer Handoff Parameters ), and a softer handoff is initiated by selecting On in the Soft Handoff field ( D. Initiate the Soft or Softer Handoff ),

  • The test set sends the mobile station a Handoff Direction message with PWR_COMB_IND bit set to 1. This bit tells the mobile station that it will be receiving identical power control bits from both cells.
  • The mobile station shall use diversity combining of power control bits received from both cells and always select the stronger bits. It's NOT "or of downs" logic.
  • When testing the mobile station's ability to decide on the right power control bit during softer handoffs, it is valid to send different closed loop power control bits from each cell. The mobile station is required to determine the correct power control bit based on the stronger cell signal.

See Verifying MS CLPC Behavior in Softer Handoff for the example procedure to verify that the MS responds correctly to more than one power control subchannel based on diversity combining of power control bits.

Related Topics

Mobile Station Reported Pilot Level Information

Generated Pilot Level Information

General Procedures for Soft/Softer Handoff Tests

How Do I Make Soft/Softer Handoff Tests Regarding T_Add?

How Do I Make Soft/Softer Handoff Tests Regarding T_Comp?

How Do I Make Soft/Softer Handoff Tests Regarding T_Drop/T_TDrop?

How Do I Test Mobile Station (MS) Closed Loop Power Control (CLPC) Behavior in Soft/Softer Handoff?


Soft/Softer Handoff Concepts

Soft/Softer Handoff Concepts

Last updated: October 28, 2004

This section is only applicable to the lab application.

The CDMA system uses the soft/softer handoff technique to improve receptions when mobile stations move between cells/sectors (on cell/sector boundaries). (See Soft Handoff vs. Softer Handoff .)

Soft Handoff vs. Softer Handoff

Soft Handoff

Soft handoff is a "Make before break" handoff. That is, the mobile station (MS) is up on a call and moves from one base station (BS) to another, but the MS starts communicating with a new BS before terminating communications with the old BS.

  • Soft handoffs can only be used between BSs on the same frequency. The technique improves reception as MSs move between cells (on cell boundaries).
  • During soft handoff the MS actually communicates with more than one BS at a time, so that when it's time to move from the weaker BS to the stronger one, the MS is already in communication with the stronger one.
  • During a soft handoff, the mobile station receives independent closed loop power control bits from the two BSs and perform "Or of Downs" logic to determine how to adjust its power. That means the mobile station will increase its power level if and only if both power control bits from the two BSs are 0 (indicating up). If the power control bit from any base station equals to '1' (indicating down), the mobile station shall decrease its power.
    To learn more about how to use the test set to verify the MS behavior on independent closed loop power control from the two BSs, see Verifying Mobile Station (MS) Closed Loop Power Control (CLPC) Behavior in Soft/Softer Handoffs .

Softer Handoffs

A softer handoff occurs when the MS is communicating with two sectors of a cell. Softer handoff is identical to the soft handoff with the following exceptions.

  • The mobile station receives identical power control from both sectors and provides diversity combining of the power control bits to determine whether the BSs are sending an up bit or a down bit (ignore the weaker bits). It's NOT "or of downs" logic.
    To learn more about how to use the test set to verify the MS behavior on identical closed loop power control from two sectors, see Verifying Mobile Station (MS) Closed Loop Power Control (CLPC) Behavior in Soft/Softer Handoffs .

Key Parameters Involved in the Soft/Softer Handoff

The mobile station assists the base station in the handoff process by measuring and reporting the strengths of received pilots. It searches for pilots on the current CDMA Frequency Assignment to detect the presence of CDMA Channels and to measure their strengths. When the mobile station detects a pilot of sufficient strength that is not associated with any of the Forward Traffic Channels assigned to it, it sends a Pilot Strength Measurement Message or an Extended Pilot Strength Measurement Message to the base station. The base station can then assign a Forward Traffic Channel associated with that pilot to the mobile station and direct the mobile station to perform a handoff.

The following parameters effect the MS pilot strength reporting behavior. To learn more about how to use the test set to verify the MS behavior regarding these parameters, see Verifying MS Pilot Reporting Behavior in Soft/Softer Handoff .

  • T_ADD: As shown in T_Add, T_Comp and T_Drop , if a Pilot Channel E c /I 0 exceeds T_ADD, the MS notifies the BS. The new pilot is added to the Candidate Set. It is now a candidate to be considered for the Active Set. Default T_ADD value is 28 (in incremental units of -0.5 dB, so 28 corresponds to -14 dB).
  • T_COMP: As shown in T_Add, T_Comp and T_Drop , if Candidate Set Pilot Channel E c /I 0 exceeds lowest Active Set Pilot Channel E c /I 0 by 0.5xT_COMP, the MS notifies the BS. The BS adds the pilot to the Active Set (MS commences soft handoff with it). Default value for 0.5xT_COMP is 2.5 dB.
  • T_DROP and T_TDROP: As shown in T_Add, T_Comp and T_Drop , if a Pilot Channel E c /I 0 in the Active Set falls below T_DROP for a time T_TDROP, then the MS notifies the BS. The BS removes it from the Active Set. Default value for T_DROP is 32 (in incremental units of -0.5 dB, so 32 corresponds to -16 dB) and for T_TDROP is 3 (corresponds to 4 seconds).

T_Add, T_Comp and T_Drop

Pilot Sets

The pilot search parameters and the rules for Pilot Strength Measurement Message or Extended Pilot Strength Measurement Message transmission are expressed in terms of the following sets of pilots:

  • Active Set: The set of pilots associated with the Forward Traffic Channels assigned to the MS. Any BS that the MS is up on a call with (or in soft handoff with) is in the MS's "Active Set".
  • Candidate Set: The set of pilots that have been received with sufficient strength by the MS to be successfully demodulated, but have not been placed in the "Active Set" by the BS. MS has notified the BS that these strong pilots are present.
  • Neighbor Set: The pilots that are not currently in the Active Set or the Candidate Set and are likely candidates for handoff.

Related Topics

Performing Soft/Softer Handoffs with the Test Set


Performing Soft/Softer Handoffs

Performing Soft/Softer Handoffs

Last updated: October 28, 2004

This section is only applicable to the lab application.

  • Soft/Softer Handoff Concepts
  • Performing Soft/Softer Handoffs with the Test Set
  • Configuring Cell 2 Used for Soft/Softer Handoff
  • Configuring Soft Handoff Parameters
  • Generated Pilot Level Information
  • Mobile Station Reported Pilot Level Information


Configuring Soft Handoff Parameters

Configuring Soft Handoff Parameters

Last updated: October 28, 2004

This section is only applicable to the lab application.

The soft handoff functionality is accessible through the Soft Handoff Information screen by pressing the Soft Handoff Info ( F1 on the Call Control 2 of 3 menu) when the Operating Mode is Active Cell.

The Generated Pilot Level Information (see Generated Pilot Level Information ) and Mobile Station Reported Pilot Level Information (see Mobile Station Reported Pilot Level Information ) tables are displayed on the Soft Handoff Information screen, which can assist you to verify the mobile station soft/softer handoff behavior (see Verifying MS Pilot Reporting Behavior in Soft/Softer Handoff ).

Soft/Softer Handoff Parameters

The following parameters relating to the soft/softer handoff operation are settable when the Soft Handoff Parameters ( F2 on the Soft Info menu) is pressed. These parameters are included in the T_Add, T_Comp, T_Drop, T_TDrop, Soft_Slope, Add_Intercept and Drop_Intercept fields of System Parameters Message sent to the mobile station.

For the detailed front panel operation, see B. Set Up Soft/Softer Handoff Parameters .

  • Handoff Type ( CALL:SETup:SHANdoff:TYPe ): Indicates whether a soft or softer handoff is to be made. The soft/softer handoff is initiated when you turn soft/softer handoff state on (see Enabling Soft/Softer Handoff ).
  • Cell 1 F-Pilot Level (Channel 1 Pilot E c /I or in the standard): CALL[:CELL[1]]:PILOT[:SLEVel][:SELected] .
  • Cell 1 F-FCH/Traffic Level (Channel 1 Traffic E c /I or in the standard): CALL[:CELL[1]]:FCHannel[:FORWard][:SLEVel]<[:SELected]|DIGital2000> .
  • Cell 2 F-Pilot Level (Channel 2 Pilot E c /I or in the standard): CALL:CELL2:PILOT:LEVel[:SELected] .
  • Cell 2 F-FCH/Traffic Level (Channel 2 Pilot E c /I or in the standard): CALL:CELL2:FCHannel:LEVel[:SELected] .
  • T_Add: CALL[:CELL[1]]:SPARameter:TADD .
  • T_Drop: CALL[:CELL[1]]:SPARameter:TDRop .
  • T_Comp: CALL[:CELL[1]]:SPARameter:TCOMp .
  • T_TDrop: CALL[:CELL[1]]:SPARameter:TTDRop .
  • Soft_Slope: CALL[:CELL[1]]:SPARameter:SOFT[:SLOPe] .
  • Add_Intercept: CALL[:CELL[1]]:SPARameter:ADD[:INTercept]
  • Drop_Intercept: CALL[:CELL[1]]:SPARameter:DROP[:INTercept]
  • Cell 2 Delay (relative to Cell 1, in the unit of microsecond): CALL:CELL2:DELay
  • Clear Mobile Pilot Report: CALL:MS:REPorted:PILot:STRength:REPort:CLEar

There are slight differences between these parameter names when the System Type is changed between IS-2000 and IS-95. The commands, however, are the same for either system type.

Enabling Soft/Softer Handoff

After establishing a call between the test set's cell 1 and the mobile station, configuring cell 2 (power, PN offset, code channel level, etc., see Configuring Cell 2 Used for Soft/Softer Handoff ), and setting the Soft Handoff parameters (soft handoff type, cell 2 delay, etc., see Soft/Softer Handoff Parameters ) as desired, you may turn soft handoff state on (see D. Initiate the Soft or Softer Handoff and CALL:SETup:SHANdoff:ENABle ) to initiate the soft handoff. This causes the test set to send a Handoff Direction Message to the mobile station and the mobile station will try to demodulate the signal from cell 2.

Once you turn the soft/softer handoff on, either Soft or Softer is displayed at the bottom of the Mobile Station Reported Pilot Level Information window to indicate the current soft handoff type being made. You can also query the current soft/softer handoff state with CALL:STATus:SHANdoff? .

Related Topics

General Procedures for Soft/Softer Handoff Tests


Test Set SMS System Emulation

Test Set SMS System Emulation

Last updated: June 20, 2006

This section is only applicable to the lab application.

  • SMS Network Model
  • SMS Protocol Description
  • Test Set SMS Capabilities

SMS Network Model

The test set provides the SMS capabilities with the relevant behaviors of the following network entities.

  • BS (base station): represents the CDMA system infrastructure. It contains base station transceiver, the mobile switching center (MSC) required for network connection.
  • MC (message center): represents a generic SMS message center function which provides end-to-end connectivity between the mobile station (MS) and the SMS system.
  • TE (terminal equipment): represents a voice or data equipment connected either directly or indirectly to the message center. The test set emulates parts of its behavior.
  • PSTN (public switched telephone network)

SMS Protocol Description

SMS Protocol Stacks shows a simplified SMS protocol stack for the CDMA network carrying SMS. The procedures and messages used for exchanging short messages between the network and the mobile stations are defined in the 3GPP2 C.S0015 standard.

SMS Protocol Stacks

The CDMA system employs the Data Burst Message (with BURST_TYPE set to 0x00011) to carry the SMS messages between the mobile station and the base station.

For Mobile-Terminated SMS messages sent from the test set to the mobile station:

  • The test set's SMS teleservice layer is responsible for forming the teleservice messages by putting the user entered message (see Creating/Editing the Mobile-Terminated Message Contents ) to the CHARi field of the User Data subparameter and some user-settable parameters (see Setting Mobile-Terminated SMS Parameters ) to the appropriate fields of teleservice messages. Teleservice message fields are not the only fields that receive user-settable values. Some user settings are applied to transport layer parameters.
  • The SMS transport layer then includes the teleservice message contents in the Bearer Data parameter of transport layer messages.
  • The SMS relay layer is responsible for forming the Data Burst Message to be sent to the mobile station on the control channel (F-PCH or F-BCCH/F-CCCH) or the traffic channel (F-Traffic/F-FCH) via Link Layer, with BURST_TYPE field set to `000011', with MSG_NUMBER field set to 1, with NUM_MSGS field set to 1, with the NUM_FIELDS field set to the number of characters in the SMS transport layer message and with CHARi carrying the SMS transport layer messages.

For Mobile-Originated SMS messages sent from the mobile station to the test set, the test set's SMS relay layer is responsible for processing the Data Burst Messages (with the BURST_TYPE field set to `000011') received on the reverse access channel or traffic channel, then passed to the transport layer for further processing. The received SMS message contents and the related information are displayed in the Mobile-Originated Message window and the Mobile-Originated SMS Info window on the Short Message Service Information screen.

Test Set SMS Capabilities

To test the capabilities of mobile stations providing the SMS service and verify the correct operation of the mobile stations, you can control the test set to format, transmit and receive the SMS messages to and from the mobile stations. The test set supports:

  • Mobile-Terminated SMS Message Operation (sent from test set to MS, supporting both point-to-point and broadcast SMS messages)
  • Mobile-Originated SMS Message Operation (sent from MS to test set, supporting point-to-point SMS messages only)
  • Logging SMS Messages (via WPA software)
  • Supporting CDG Stage 2 SMS Tests

NOTE
The test set does not guarantee the functionality of the simultaneous Mobile-Terminated and Mobile-Originated SMS operations which may result in both messages not being properly handled (with non-typical SMS Status transitions) or may result in one message being processed as normal and the other message not being properly handled.

Related Topics

SMS Status Description


HTTP Interface for SMS - Introduction

HTTP Interface for SMS - Introduction

Last updated: June 20, 2006

This section is only applicable to the lab applications.

Introduction to HTTP

HTTP is the client/server based protocol used to deliver virtually all files and data on the World Wide Web. If you'd like more detailed descriptions of HTTP protocol, refer to Internet RFCs `HTTP/1.0 - RFC 1945' and `HTTP/1.1 - RFC 2616', which can be downloaded from

http://www.rfc-editor.org/rfc.html

When you use HTTP in a web browser, you enter the "address" for the web page you wish to view. These addresses can be generalized into the following format:

In this example, the web browser is the HTTP client and it uses the information in this address to open a connection to the HTTP server and send a request.

  • "http://" is the protocol specifier, telling the browser what protocol to use for the request.
  • <ip_address> is the IP address of the server.
  • [:<port>] is the port number on which to communicate with the server. The default port for HTTP is 80 and this will typically be used if no port number is specified in the address.
  • <request_URL> provides information to the server on the location of the resource that's being requested and can also be used to provide information to the resource.

HTTP Interface for SMS Verification

The test set can act as both the HTTP server and the HTTP client:

  • The test set acts as the HTTP server when you open a web browser (client), then send a request to the test set using the test set's IP address and a correctly configured request URL. See HTTP Interface Configuration for Mobile Terminated SMS for details.
  • The test set acts as the HTTP client when the mobile station originates SMS messages which are routed out by the test set's LAN port as HTTP request. See HTTP Interface Configuration for Mobile Originated SMS for details.

Related Topics

HTTP Interface Configuration for Mobile Terminated SMS


HTTP Interface Configuration for Mobile Originated SMS

HTTP Interface Configuration for Mobile Originated SMS

Last updated: June 20, 2006

This section is only applicable to the lab application.

If you wish to use the HTTP interface in the test set to route SMS messages originated from the mobile station to the destination such as PC or another test set, you must do the following:

  • Enable the Test Set's HTTP Interface
  • Specify the HTTP Output Interface Settings
  • Configure the Message URL

Enable the Test Set's HTTP Interface

You can enable the HTTP output interface in the test set via a GPIB command (see CALL:SMService:HTTProtocol:OUTPut ) or from the test set's front panel (see Enabling the HTTP Interface for Mobile Originated SMS ).

If the interface is not enabled, messages originated from a mobile station can not be routed over HTTP.

Specify the HTTP Output Interface Settings

In order to route SMS messages originated from the mobile station, you must specify the following HTTP output interface settings. All the settings can be changed from the test set's web page, see HTTP SMS Router Web-based Configuration Interface for more information.

HTTP Output Interface Settings Parameters

Parameter | Type | Default | Range
DUT Sender Address | String | 1000 | 2 - 20 character ASCII formatted string of BCD digits from 0-9, * and #
Output Destination IP Address | String | (Empty string) | Any valid IP address. E.g. "124.109.58.32"
Destination Port Number | Integer | 80 | 0-65534
Text Message URL | String | (Empty string) | 0 - 256 character ASCII formatted string
Binary Message URL | String | (Empty string) | 0 - 256 character ASCII formatted string
Request Method | Enum | GET | GET|POST

  • DUT Sender Address :

    It defines a phone number for the DUT connected to the test set.

  • Output Destination IP Address for Other Test Set :

    If you want to send SMS messages to other test set and are not using an SMS gateway, you need input the IP address of the other test set.

  • The following settings are only used when you want to send SMS messages to another entity for routing, such as an SMS gateway:

    • Alternative Device Destination (SMS Gateway) IP Address :

      It specifies the IP address of the PC on which that the receiving entity is running.

    • Destination Port :

      It is the TCP/IP port on which the receiving entity listens for web/HTTP requests.

    • Text Message URL :

      It defines the URL format for SMS text messages accepted by the receiving entity.

    • Binary Message URL :

      It defines the URL format for SMS binary messages accepted by the receiving entity.

    • Request Method :

      It defines HTTP request method the test set's HTTP interface is to use when sending SMS messages over HTTP.

Configure the Message URL

In order to configure the text and binary URLs for the test set's HTTP output interface, you must know the receiving entity's requirements. All configurations for tags are detailed in Message URL Tags . When a mobile originated message arrives at the test set, the tags in the message URL are replaced with the respective message content before the request URL is sent to the receiving entity. If the message is being sent directly to another test set, it is not necessary to configure the message URLs.

Message URL Tags

Tag | Replaced with
@@TEXT@@ | The ASCII text of a received text message (reformatted to meet URL escaping requirements). Should only be used for messages of which encoding is 7-bit ASCII, IA5, or GSM 7-bit default alphabet. It will return the same as the @@DATA@@ tag if used for binary messages.
@@DATA@@ | The message content as a string of hex characters. Should only be used for messages of which encoding is any encoding type other than 7-bit ASCII, IA5, or GSM 7-bit default alphabet. It will return the same as the @@TEXT@@ tag if used for 7-bit text messages.
@@NUMBER@@ | The destination phone number of the message.
@@SENDER@@ | The assigned originating phone number of the message. It should be one of the following two values:- Call-back number, if it is included in MO SMS, or - The number defined by the DUT Sender Address setting detailed in DUT Sender Address: , if Call-back Number is omitted in MO SMS.
@@TELESERVICE@@ | The teleservice type of the received message. This parameter is replaced with one of the following text strings if included in the format string:WPT | WMT | VMN | WAP | CATPT | Other.
@@PRIORITY@@ | The priority level of the received message. This parameter is replaced with one of the following text strings if included in the format string: None | Normal | Interactive | Urgent | Emergency.
@@MSGENCODING@@ | The message encoding of the received message. This parameter is replaced with one of the following text strings if included in the format string: Octet | EPM | ASCII7 | IA5 | UNICODE | Shift-JIS | Korean | KSC5601 | LatinHebrew | Latin | GSM7 | Other.

Example Message URL

Text Message URL:

Assuming an MS originated text SMS message with the following details has arrived at a test set from a connected DUT:

  • Destination number: 12345
  • Message Text: "This is a text message"
  • Call-back number: 6789

And assuming the text message URL format string has been configured as:

  • /?PhoneNumber=@@Number@@&Text=@@TEXT@@ &Sender=@@SENDER@@

The following URL request string will be sent by the test set to the receiving entity at the currently configured destination IP and Port number:

  • /?PhoneNumber=12345&Text=This%20is%20a%20text%20message &Sender=6789

Binary Message URL

Assuming a MO binary SMS message with the following details has arrived at an 8960 from a connected DUT:

  • Destination number: 54321
  • Message Content: 4F60597D (which means Chinese "Hello" encoded in UNICODE)
  • Message encoding: UNICODE

And assuming the Binary message URL format string has been previously been setup as:

  • /?PhoneNumber=@@NUMBER@@&Data=@@DATA@@&MsgEncoding= @@MSGENCODING&User=user535&Password=pass

The following URL request string will be sent by the 8960 to the receiving entity (other 8960, SMS gateway etc.) at the currently configured destination IP and Port number:

  • /?PhoneNumber=54321&Data=4F60597D&MsgEncoding=UNICODE &User=user535&Password=pass

Related Topics

Manual Operation: Enabling the HTTP Interface for Mobile Originated SMS

CALL:SMService

HTTP Interface for SMS - Introduction

HTTP SMS Router Web-based Configuration Interface


HTTP SMS Router Web-based Configuration Interface

HTTP SMS Router Web-based Configuration Interface

Last updated: June 20, 2006

This section is only applicable to the lab application.

This section explains how to use the web-based interface to configure the HTTP SMS Router for mobile originated SMS messages. You must have an active LAN connection to the test set in order to access its HTTP server and can access the HTML pages for configuration via any standard internet browser. This section includes:

  • Accessing the Web-Based HTTP SMS Router Interface
  • Change Configuration

Accessing the Web-Based HTTP SMS Router Interface

From an internet browser, enter http://x.x.x.x to access the test set homepage, where `x.x.x.x' is the IP address of the test set to which the mobile station is attached that is sending the mobile originated message. The test set's homepage is displayed in the browser window, as shown below.

You can open the HTTP SMS Router Current configuration page by clicking on SMS (circled in red in the figure above). The current HTTP Interface Settings are summarized on the Current Configuration page as shown below. See Change Configuration for information on changing these settings.

NOTE
You can't use the web-based interface to change both the HTTP Input interface and the HTTP Output interface. For instructions on changing these settings, see Enabling the HTTP Interface

Change Configuration

Click on the Change button from the HTTP SMS Router Current Configuration page to access the HTTP SMS Router Change Configuration page.

The HTTP SMS Router Change Configuration page, shown in the figure below, allows changes to be made to the HTTP Interface Settings. And the following parameters can be configured. For more detailed explanation of each of these parameters, see Specify the HTTP Output Interface Settings .

  • DUT Sender address
  • Other 8960 IP Address
  • Alternative Device Destination IP Address
  • Destination Port
  • Text Message URL
  • Binary Message URL
  • Request Method

After performing the procedure above, you can configure the interface successfully. But if any of the settings specified on the HTTP SMS Router Change Configuration page contain illegal values when the Apply Changes button is clicked, the HTTP SMS Router Configuration Error page is displayed. This page provides a description of the first error found when verifying the updated settings. Press the Back button to return to the HTTP SMS Router Change Configuration page to correct any errors.

Example Configuration Error Page

Related Topics

Manual Operation: Enabling the HTTP Interface for Mobile Originated SMS

HTTP Interface Configuration for Mobile Originated SMS


HTTP Interface Configuration for Mobile Terminated SMS

HTTP Interface Configuration for Mobile Terminated SMS

Last updated: June 20, 2006

This section is only applicable to the lab application.

If you wish to use the HTTP interface in the test set to route SMS messages to the mobile station attached to the test set, you must do the following:

  1. Enable the Test Set's HTTP Interface
  2. Specify the SMSC IP Address and Port
  3. Configure the Request URL

You also can determine the state of the last MT SMS message by sending an HTTP request. See State Determination for Sent Messages for details.

Enable the Test Set's HTTP Interface

You can enable the HTTP input interface in the test set via a GPIB command (see CALL:SMService:HTTProtocol:INPut ) or from the test set's front panel (see Enabling the HTTP Interface for Mobile Terminated SMS ).

If the interface is not enabled, HTTP SMS requests sent to the test set will be rejected and the HTTP error is returned to the client.

Specify the SMSC IP Address and Port

You can send SMS messages from several different types of clients to the test set such as SMS Gateway, another test set and internet browser. It is necessary to specify the IP Address and port number as follows:

  • IP Address/Host Name: The IP address of the test set receiving the messages. (See Configuring the Test Set's LAN for more information.)
  • Port number: 80.

NOTE
When configuring an SMS Gateway, these parameters apply to the SMSC configuration. In a test system with more than one test set, each test set may be thought of as a separate SMSC and configured as such in the gateway.

Configure the Request URL

When using the HTTP interface in the test set for sending SMS messages you must configure a request URL. The accepted format of the request URL is:

  • "/sms/send/?" must be specified at the beginning of the request URL in order for the test set to recognize the HTTP request as a request to send an SMS message.
  • The parameters and values provide the content of the SMS message as well as other information. All configurations for parameters and values are detailed in Request URL Parameters .

    • TEXT and DATA are mandatory parameters which must be included in the request URL. If any mandatory parameters are not present, "HTTP SMS request ignored; Missing mandatory parameter in request" will be generated on the test set.

      SMS Message Content Type | Mandatory Parameters
      7-bit text | TEXT
      8 or 16 bit data | DATA

      • With the exception of SENDER, Optional parameters may be set to an empty value which indicates the default value for optional parameters are used. For example, if parameter2 is an optional parameter, then the request URL can be /sms/send/?parameter1=value1& parameter2= &parameter3=value3.

      • For the SENDER optional parameter, if the parameter is included, it must be set to a sender address in the request URL. If you do not want to include a sender address with the message, leave out the SENDER parameter rather than setting it to an empty value.

    • Parameters in the request URL can be in any order.

    Request URL Parameters

    Parameter

    Type

    Use and expected value

    Inclusion
    TEXT | Mandatory | 0-112 character string of ASCII characters. (the length of TEXT values must not exceed 112 characters). | This parameter must be included in all HTTP requests to send ASCII based SMS messages. It must not be included in the same request as the DATA parameter outlined below.
    DATA Mandatory

    0-224a ASCII formatted hex characters (the length of DATA values must not exceed 224 characters).

    If the length of hex message is odd, or can't divide exactly by the length of the encoded character, the actual message sent to DUT will be padded with trailing "0"s (zeros) as necessary to make the message contain a whole number of encoded characters, and the error "SMS message padded with trailing zeros to define whole characters" will be generated on the test set.

    This parameter must be included in all HTTP requests to send binary SMS messages. It must not be present in the same request as the TEXT parameter outlined above.

    MSGENCODING

             Optional

    Set the encoding scheme for the user entered message contents. See Message Encoding .

    Default = ASCII7
    TELESERVICE | Optional | The teleservice type of the SMS message sent to the MS. See Teleservice . | Default = WMT
    PRIORITY

    Optional

             Set the priority level of the SMS message sent to the MS. See Priority . Default = Normal
    PRIVACY

    Optional

             Set the privacy level of the SMS message. See Privacy . Default = None

    UDI

    Optional

    Specify whether include the user entered message content in the SMS message sent to the mobile station. See Message (Optional User Data) .

    Default = Include

    SENDER

    Optional

    The phone number of the sending client as a 0 - 14 character ASCII formatted string of BCD digits from 0-9, * and #.

    Default = 1000

    MMTS

    Optional

    The More Messages to Send (MMTS) is used to indicate to the receiving entity if more messages are waiting in the service center to be sent to the phone after the current message. It should be 0 or 1. If it is set to 1, the MESSAGE_ID in Data Burst Message will be kept unchanged, so the mobile phone will concatenate the consecutive messages with same MESSAGE_ID to be a single SMS message. If it is set to 0, there is no more messages.It is valid only when the teleservice type of a SMS message is set to WAP. If the teleservice type is not WAP, MMTS will always be 0 regardless of the presence/value of this parameter.

    Default = 0
    MDMI

    Optional

             the Message Display Mode Inclusion (MDMI) determines if the Message Display Mode sub-parameter is sent for teleservice types. See MDMI . Default = Exclude
    MDM | Optional | Set the Message Display Mode which is used to indicate to the mobile station when to display the receive message. See MDM . | Default = 0

    IGNORELENLIMIT

    Optional

    The IGNORELENLIMIT is used to control if the limit of maximum length (TEXT 112 characters, DATA 224 characters) can be ignored.

    Should be either TRUE or FALSE. TRUE means the limit of maximum length in http interface can be ignored. This does not ensure SMS with arbitrary length can be sent without data loss on radio interface. If the SMS is too long, it may still be truncated according to 3GPP2 standard. FALSE means the limit of maximum length is TEXT 112/DATA 224 characters.

    Default = FALSE

  • When a text message is being submitted via the 'TEXT' parameter, HTTP URL escaping restrictions apply. It is only necessary for you to use the escape characters when building a request URL manually. If you are sending messages to the mobile station through either an SMS gateway or from another test set, the escaping is performed automatically. Characters that require escape characters when used in URLs are detailed in the following table.

    URL Escape Codes

    Decimal character code(s)

    7-bit US-ASCII representation

    URL Escape sequence

    0-31

    control characters

    %00 - %1F

    32

    SP

    %20

    34-38

    " # $ % &

    %22 - %26

    43

    +

    %2B

    44

    ,

    %2C

    47

    /

    %2F

    58-64

    : ; < = > ? @

    %3A - %40

    91-94

    [ \ ] ^

    %5B - %5E

    96

    `

    %60

    123-126

    { | }

    %7B - %7E

Example Request URL Strings

Text Message:

To send a text based SMS message with the following message details:

  • Originating number: 1001
  • Message text: "This is a simple text message"

You would format the HTTP request URL as follows:

/sms/send/?TEXT=This%20is%20a%20simple%20text%20message&SENDER=1001 ("20%" represents a space character.)

Binary Message:

To send a binary message with the following message details:

  • Originating number: 987654321
  • Message content: 140601AE02056A0045C60D036262632E636F2E756B2F6D6F62696C6500070103424243206D6F62696C652073697465000101
  • Teleservice type: WAP
  • Massage encoding: OCTET

You would format the HTTP request URL as follows:

/sms/send/?DATA=140601AE02056A0045C60D036262632E636F2E756B2F6D6F62696C6500070103424243206D6F62696C652073697465000101&TELESERVICE=WAP&MSGENCODING=Octet&SENDER=987654321

State Determination for Sent Messages

The state of the last MT SMS message (see SMS Status Description ) can be determined by sending an HTTP request to the test set (for example: "/sms/mtstate"). This can be done either by writing a simple program or by using an internet browser.

In the case of an Ack state being returned, if the mobile station sends an Ack cause code, then the body of the HTTP response shall also contain the value of the MS Ack cause code as well as the associated string. See MS Ack Cause Code & String for details.

Operation Considerations

  • It is not recommended that SMS messages are sent to the HTTP input interface in conjunction with sending SMS messages to a DUT via the test set MUI or RUI.

  • It is recommended to set the Slot Cycle Index to be no greater than 5 when sending MT HTTP SMS messages on common control channel.

  • If you want to do a stress test and send a lot of HTTP SMS messages to MS, it is recommended to establish a call connection and send HTTP SMS messages on traffic channel.

Related Topics

Manual Operation: Enabling the HTTP Interface

CALL:SMService

HTTP Interface for SMS - Introduction


Short Message Service Information

Short Message Service Information

Last updated: June 21, 2006

This section is only applicable to the lab application.

When the F5 ( Short Message Service ) on Call Control 3 of 3 menu is pressed, the Short Message Service Information screen (see Short Message Service Information Screen ) appears. It consists of five windows:

  • Mobile-Terminated Message
  • Mobile-Originated Message
  • Mobile-Terminated SMS Info
  • Mobile-Originated SMS Info
  • SMS Message Acknowledge Info

To clear the information on the SMS Status and the received SMS message, see Clearing the SMS Info/Status .

Short Message Service Information Screen

Mobile-Terminated Message

The Mobile-Terminated Message window is a scrolling display which allows viewing of the message contents you entered to be sent to the MS (see Creating/Editing the Mobile-Terminated Message Contents ).

Five rows, up to 80 user input characters can be displayed at a time. Four of the rows, each containing up to 20 characters, are used to show the message contents. One row shows the integer value of the Character Index and a cursor represented by a caret (^) pointing to the character specified by the Character Index (see Enter/Edit Message Contents ). Note that the character index value starts from 0 (zero).

The scrolling indicators (^ and v) are shown when more of the user input message is available both above and below the displayed portion of the message. To scroll the displayed portion of the message to view other portion of the message, change the setting in Character Index (see Enter/Edit Message Contents ).

Mobile-Originated Message

The Mobile-Originated Message window is to display the contents of the last received SMS message from the mobile station. The message can be displayed in ASCII or Hex format which is controlled by the setting of Display Format (see Display Control ). To clear the information shown in this window, see Clearing the SMS Info/Status .

The display is broken into 5 rows, each containing up to 20 characters, to allow for displaying a maximum of 100 characters at a time. If there are characters preceding the 1st row displayed, there will be a caret (^) shown on the upper-right of the window. If there are characters following the last row displayed, there will be a caret (v) shown on the lower-right of the window. To view the entire message, change the setting of Row Index (see Display Control ) to scroll the displayed portion of the message.

See also CALL:SMService:MORiginated:MESSage:ASCii? and CALL:SMService:MORiginated:MESSage:HEX? .

Mobile-Terminated SMS Info

This window displays the current parameter settings included in the SMS messages to be sent to the MS.

Some of these parameters are set from the Mobile-Terminated SMS Parameters menu (see Mobile-Terminated SMS Parameters ).

The Message Length (see CALL:SMService:MTERminated:MESSage:LENGth? ) indicates the length of the desired message in encoded characters to be sent to the mobile station. See How Does the Test Set Build the Mobile-Terminated Message? for details.

Mobile-Originated SMS Info

This window (see Short Message Service Information Screen ) displays the parameters included in the received SMS message sent from the MS. To clear the information in this window, see Clearing the SMS Info/Status .

  • SMS Support : shows the value you set in the SMS Support field of the Mobile-Originated SMS Parameters menu (see SMS Support Control ). See CALL:SMService:MORiginated:PROTocol .
  • Msg Count : indicates the number of the SMS messages received from the MS since last clear (see Clearing the SMS Info/Status ). See CALL:SMService:MORiginated:COUNt? .
  • Teleservice : indicates the teleservice of the received SMS message sent from the MS. Note that if the teleservice "Reserved for Carrier Specific Teleservices" is received, this result will be updated and all other SMS parameters of the received SMS message will be cleared and set to their default values. See CALL:SMService:MORiginated:TELeservice? .
  • Dest Addr : indicates the destination address of the SMS message received from the MS. Either ASCII or Hex display format is determined by the Display Format (Message/Addresses) setting (see Display Control ). The Dest Addr field allows for displaying up to 13 characters. If the address is greater than 13 characters, a "..." is included in the displayed string to indicate that the entire result is not displayed. To get a complete address, use CALL:SMService:MORiginated:DADDress:ASCii? or CALL:SMService:MORiginated:DADDress:HEX? .
  • Dest Addr Encod : indicates the encoding type of the destination address of the SMS message received from the MS. It reflects the DIGIT_MODE field of the Destination Address parameter in the SMS message. See CALL:SMService:MORiginated:DADDress:ENCoding? .
  • Priority : indicates the priority level of the SMS message received from the MS. It reflects the PRIORITY field in the received SMS message (see Priority Level Settings ). If no priority field is included in the received SMS message, the Undefined is displayed. See CALL:SMService:MORiginated:PRIority? .
  • Call-Back Num : indicates the call-back number of the SMS message received from the MS. It's represented in either ASCII or Hex format determined by the Display Format (Message/Addresses) setting (see Display Control ). Up to 13 characters are displayed. If the address is longer than 13 characters, a "..." is included in the displayed string to indicate that the entire result is not displayed. To get a complete address, use CALL:SMService:MORiginated:CBNumber:ASCii? or CALL:SMService:MORiginated:CBNumber:HEX? .
  • Call-Back Encod : indicates the encoding type of the call-back number of the SMS message received from the MS. It reflects the DIGIT_MODE field of the Call-Back Number parameter in the SMS message. See CALL:SMService:MORiginated:CBNumber:ENCoding? .
  • Msg Encoding : indicates the encoding type of the SMS message received from the MS. See Message Encoding for a list of encoding type. Note that "Other" corresponds to the value of "Reserved" for the MSG_ENCODING field in the standard 3GPP2 C.S0015-A. See CALL:SMService:MORiginated:MESSage:ENCoding? .
  • Msg Length : indicates the number of encoded characters in the last received SMS message from the MS. It represents the value of the NUM_FIELDS field of the User Data subparameter. See CALL:SMService:MORiginated:MESSage:LENGth? .
    The Msg Length and the Msg Encoding determine the number of characters in the Mobile-Originated Message window. For example: the received message is in UNICODE encoding type (identified by UNICODE shown in the Msg Encoding field) and the message length is 20 ( 20 shown in the Msg Length ). If Display Format (Message/Addresses) is set to Hex (see Display Control ), the number of characters of the received SMS message displayed in the Mobile-Originated Message window is 80 since 4 hex characters represent one UNICODE character (see Message Encoding ).

SMS Message Acknowledge Info

This window provides an indication of:

  • SMS Status: the current status of the SMS processing. See SMS Status Description for details.
  • MS Ack Cause Code: the value of the MS Ack cause code as well as the associated string (see MS Ack Cause Code & String ) upon receipt of an SMS acknowledgment from the MS (current Status shows MS Ack). If the Status shows other than 'MS Ack', this field will be empty.

To clear the information in this window, see Clearing the SMS Info/Status .

MS Ack Cause Code & String
MS Ack Cause Code | MS Ack Cause String
NAN | "" (Empty string)
0 | Address vacant
1 | Address translation failure
2 | Network resource shortage
3 | Network failure
4 | Invalid Teleservice ID
5 to 31 | Other network problem
32 | No page response
33 | Destination busy
34 | No acknowledgment
35 | Destination resource shortage
36, 48 to 63 | SMS delivery postponed
37 | Destination out of service
38 | Destination no longer at this address
39 to 47 | Other terminal problem
64 | Radio interface resource shortage
65 | Radio interface incompatibility
66 to 95 | Other radio interface problem
96 | Encoding problem
97 | SMS origination denied
98 | SMS termination denied
99 | Supplementary service not supported
100 | SMS not supported
101 | Reserved
102 | Missing expected parameter
103 | Missing mandatory parameter
104 | Unrecognized parameter value
105 | Unexpected parameter value
106 | User Data size error
107 to 255 | Other general problems

Related Topics

Mobile-Terminated SMS Message Operation


Logging SMS Messages

Logging SMS Messages

Last updated: June 21, 2006

This section is only applicable to the lab applications.

You can use the Wireless Protocol Advisor (WPA) to log the messages exchanged between the test set and the mobile station during SMS procedures. The log results can help you collect and interpret protocol messages, verify wireless device functionality, and troubleshoot protocol problems.

The general procedure for logging SMS Messages are:

  1. Connect the WPA to the Test Set
  2. Set Up the Wireless Protocol Advisor (WPA)
  3. Start the Logging
  4. Send SMS Messages . You can send Mobile-Terminated SMS messages (from the test set to mobile station) or Mobile-Originated SMS messages (from the mobile station to the test set). If desired, repeat the procedure to send several SMS messages.
  5. Stop the Logging
  6. Analyze Message Log

The following example is to demonstrate how to set up the WPA for SMS Logging. Two SMS messages, one of which is Point-to-Point SMS message and one of which is Broadcast SMS message, are sent from the test set to the mobile station. Two traffic overviews are set up in the WPA, one of which is for displaying the Point-to-Point SMS message decoding information and one of which is for displaying the Broadcast SMS message decoding information.

NOTE
To quickly learn how to use the WPA software for logging and analyzing the protocol messages transmitted between the test set and your wireless devices under test. For details on the features and capabilities of the WPA software, refer to the software online help.

Connect the WPA to the Test Set

Start the WPA in Real Time mode. Enter the test set IP address appropriately assigned to it, then click Connect. If WPA was configured before, WPA automatically tries to connect with the Test Set. Make sure the cdma2000 is checked on the Stacks/Streams field.

Set Up the Wireless Protocol Advisor (WPA)

You can set up the WPA to capture and display as much or little information as you want. For this example, the logging filter is defined to capture only Data Burst message for SMS. Two view filters are specified, one of which is configured to only display the Point-to-Point SMS messages and another is configured to display the Broadcast SMS messages.

Accessing Filters

All filters are accessed from the Measurement Setup view by clicking the Measurement Setup View button ( [image] ) on the menu bar, then double click the filter icon (for example, Log Filter, View Filter, etc.) to bring up the corresponding Filter editor you want to set up:

Test Set Message Filter Setup

The test set filter is useful for limiting the amount of data sent over the LAN connecting the test set and the WPA. To access the Test Set Message Filter, see Accessing Filters . You can keep the default settings to log the messages related with SMS.

Log Filter Setup

The log filter is useful for limiting what messages get captured in your log. In this example, we are using the log filter to limit the captured log to only contain Data Burst messages for Short Message Services. To access the Log Filter editor, see Accessing Filters . Set up the log filter as below.

View Filter Setup

The view filter has no effect on what messages are captured. It simply limits the messages that are visible on the WPA's traffic overview. The following example is to set up two traffic overviews. One is configured for displaying the Point-to-Point SMS message and another is for displaying the Broadcast SMS messages by setting their view filters. To access the View Filters, see Accessing Filters . Add another traffic overview by clicking the Add a Traffic Overview button ( [image] ) from the menu.

Set up the upper Traffic Overview to display the Point-to-Point SMS messages. Double click the upper View Filter icon, the Filter Editor appears. Set up the view filter as below.

Set up the lower Traffic Overview to display the Broadcast SMS messages. Double click the lower View Filter icon, the Filter Editor appears. Set up the view filter as below.

After finishing the setup, close the Measurement Setup view by clicking the Measurement Setup View button ( [image] ) on the menu bar again.

You can also easily add a new traffic overview anytime by clicking the Add a Traffic Overview button ( [image] ) from the menu and set up its View Filter by right-clicking your mouse in the traffic overview and selecting View Filter... command.

Start the Logging

Click the [image] button on the menu bar. Start the logging.

Send SMS Messages

For the step-by-step procedure for setting up the test set to capture the log, see Mobile-Terminated SMS Procedure and Mobile-Originated SMS Procedure .

In this example, send two short messages from the test set to the mobile station. Follow the procedure in Mobile-Terminated SMS Procedure , set the Service to Point To Point in STEP A, substep 5 if you want to send a Point-to-Point SMS message and set the Service to Broadcast in STEP A, substep 5 if you want to send a Broadcast SMS message.

If you want to send short messages from the mobile station to the test set, follow the procedure in Mobile-Originated SMS Procedure .

Stop the Logging

When you finished the logging, click the [image] button on the menu bar to stop the logging.

Analyze Message Log

The captured log allows you to determine exactly what is being exchanged between the test set and the mobile station and which channel is being used to carry the SMS messages. You can look in the decode of the captured message to verify all the parameters associated with that message.

In this example, the CaptureData:3 Traffic Overview is to display Point-to-Point SMS messages and the CaptureData:1 Traffic Overview is to display Broadcast SMS messages. To look in the decode of the captured message, double-click on a message. The selected message details including all the parameters associated with that message are displayed in the lower half of the Traffic Overview window.

You can copy the logged messages and decoding details to another application (for example, microsoft® Notepad) or save to a text file. See the WPA online help for detailed instruction.

A portion of the decoding information for a Point-to-Point SMS message sent via paging channel is shown below.

Related Topics

Mobile-Terminated SMS Procedure


Multimedia Service (MMS) Messages

Multimedia Service (MMS) Messages

Last updated: June 20, 2006

This section is only applicable to the lab applications .

  • Introduction
  • MMS Using the HTTP Interface
  • Related Topics

Introduction

The Multimedia Messaging Service (MMS) is a service to send and receive messages comprising a combination of rich media including text, sounds, images and video to MMS capable mobile stations. The test set allows you to test the MMS capability of your MS by working with an external MMSC/WAP Gateway emulator (such as NowSMS). For more information please refer to:

www.nowsms.com

In general, sending and receiving MMS messages include following steps:

  1. MMS message originated by MS1 is transmitted via IP data channels of the test set, then routed by WAP gateway to Multimedia Message Service Center (MMSC). MMS message is saved in the MMSC and waiting for being retrieved.
  2. MMSC notifies MS2 through SMSC with an SMS message that an MMS message is available for retrieval.
  3. After receiving the notification, MS2 retrieves the MMS message by setting up a high speed packet data service connection (SO33). See Packet Data Service Configurations for details.

The test set also supports MMS message transmission in Hybrid Mode . See MMS Message Transmission Based on Hybrid Mode System for details.

MMS Using the HTTP Interface

The HTTP interface in the test set provides a full IP based end-to-end test solution for MMS. The test set's IP data channels are used to send MMS messages between the mobile station and an MMS server. The MMS Notification is a mobile terminated SMS message. See HTTP Interface Configuration for Mobile Terminated SMS for more information.

Related Topics

Manual Operation: How to Send MMS Messages ?


HTTP SMS/MMS

HTTP SMS/MMS

Last updated: June 20, 2006

This section is only applicable to the lab application.

The HTTP Interface in the test set allows you to configure SMS message parameters and content, send and receive SMS messages using HTTP protocol. This interface is useful for SMS verification because HTTP protocol is used by most commercially available SMS Gateways. The HTTP interface also allows SMS Gateways to be configured as if the test set is a Short Message Service Center (SMSC), eliminating the need for custom external software to route messages to the correct test set. This emulation of an SMSC makes it possible to route messages directly from the HTTP output interface of one test set to the HTTP input interface of another test set. Additionally, the HTTP interface also facilitates MMS message transfer to and from a mobile station if used in conjunction with compatible MMSC (Multimedia Message Service Center) software.

For more information on this interface in the test set, see the following sections:

Manual Operation: Enabling the HTTP Interface , How to Send MMS Messages ?

HTTP Interface for SMS - Introduction

HTTP Interface Configuration for Mobile Terminated SMS

HTTP Interface Configuration for Mobile Originated SMS

HTTP SMS Router Web-based Configuration Interface

Multimedia Service (MMS) Messages

Scenarios for MMS Massage Transmission


Scenarios for MMS Massage Transmission

Scenarios for MMS Massage Transmission

Last updated: June 20, 2006

This section is only applicable to the lab applications .

MMS messages can be transmitted not only based on CDMA (IS-2000) system but also based on Hybrid Mode (IS-2000/IS-95 and IS-856) system. The scenarios that the test set can support are shown below:

MMS Messages Transmitted Based on IS-2000 System

1. Mobile-Terminated MMS Messages

  • The mobile station is first notified via SMS message that an MMS message is available for retrieval. Then a high speed packet data service connection (SO33(+F-SCH)) is required to set up to retrieve the MMS. The data rate can be changed up to 153.6kbps while on MMS transmission. To change the data rate see How Do I Set Up Data Channel Parameters? .
  • As data is transferred, monitor the Counters window (see Data Counters ) and the Data Throughput Monitor window (see Data Throughput Monitor ). These tools are useful for analyzing data transfer rates under various RF and call processing conditions.

2. Mobile-Originated MMS Messages

  • The mobile station originates an MMS message, then transmits it on an established packed data connection. When MMS message arrives at the MMSC, the MMSC will save it in the dedicated folder.
  • As data is transferred, monitor the Counters window (see Data Counters ) and the Data Throughput Monitor window (see Data Throughput Monitor ). These tools are useful for analyzing data transfer rates under various RF and call processing conditions.

3. End-to-End MMS Messages

  • The MMS message transmission supports end-to-end testing, the process is described as follows:

    • DUT1 originates an MMS message, then transmits it on an established packet data connection based on IS-2000 system to the MMSC.
    • When the MMS message arrives at the MMSC, the MMSC will send an MMS notification message under the mobile terminated SMS configuration to DUT2 ( HTTP Interface Configuration for Mobile Terminated SMS ).
    • As DUT2 is notified that an MMS message is available for retrieval, a high speed packet data service connection based on IS-2000 system is required to set up to retrieve the MMS message.
  • As data is transferred, monitor the Counters window (see Data Counters ) and the Data Throughput Monitor window (see Data Throughput Monitor ). These tools are useful for analyzing data transfer rates under various RF and call processing conditions.

MMS Message Transmission Based on Hybrid Mode System

  • The MMS message transmission based on hybrid mode (IS-2000/IS-95 and IS-856) system also supports end-to-end testing. It can improve the data rate by transmitting the MMS message based on IS-856 system, the process is described as follows:

    • DUT1 originates an MMS message, then transmits it based on IS-856 system to the MMSC.
    • When the MMS message arrives at the MMSC, the MMSC will send an MMS notification message under the mobile terminated SMS configuration to DUT2 ( HTTP Interface Configuration for Mobile Terminated SMS ).
    • As DUT2 is notified based on IS-2000/IS-95 system that an MMS message is available for retrieval, a high speed packet data service connection based on IS-856 system will be setup to retrieve the MMS message.
  • We can use tools such as Data Throughput Monitor and Wireless Protocol Advisor (WPA) software to monitor the effects of MMS transmission on data transfer.

Related Topics

Manual Operation: How to Send MMS Messages ?

Multimedia Service (MMS) Messages

Hybrid Mode


Mobile-Originated SMS Message Operation

Mobile-Originated SMS Message Operation

Last updated: October 28, 2004

This section is only applicable to the lab application.

NOTE
The test set does not guarantee the functionality of the simultaneous Mobile-Terminated (see Mobile-Terminated SMS Message Operation ) and Mobile-Originated SMS messages, which may result in both messages not being properly handled (with non-typical SMS Status transitions) or may result in one message being processed as normal and the other message not being properly handled.

You can send an SMS message from a mobile station to the test set. This is the Mobile-Originated SMS message. Only point-to-point message is available for the Mobile-Originated SMS messages.

The test set supports receiving an SMS message which was sent from the mobile station in three ways. See Receiving SMS Messages Sent from the Mobile Station .

When the test set receives a mobile originated SMS message, the message contents are displayed on the Mobile-Originated Message window and the parameters included in the received SMS message such as Teleservice, Message Encoding, etc., are displayed in the Mobile-Originated SMS Info window. You can control how the test set responds to a received SMS message and how the received message is displayed, see Setting Mobile-Originated SMS Parameters .

For front panel operation on sending a short message from the mobile station to the test set, see Mobile-Originated SMS Procedure .

Related Topics

Logging SMS Messages

Supporting CDG Stage 2 SMS Tests

SMS Status Description

Short Message Service Information

Mobile-Terminated SMS Message Operation


Setting Mobile-Originated SMS Parameters

Setting Mobile-Originated SMS Parameters

Last updated: October 28, 2004

This section is only applicable to the lab application.

You can control how the test set responds to a received SMS message and how the received message is displayed. These parameters are accessed from the Mobile-Originated SMS Parameter menu by pressing the F5 ( Short Message Service ) on Call Control 3 of 3 menu, then pressing the F3 ( Mobile-Orig SMS Parameters ).

  • SMS Support Control
  • Display Control
  • SMS Call Drop Timer Control

For detailed front panel operation, see Set up the Mobile-Originated SMS parameters .

SMS Support Control

SMS Support: Used to specify how the test set responds to a received SMS message. See CALL:SMService:MORiginated:PROTocol . It is provided to support some of the CDG Stage 2 8.2 Mobile Station Originated SMS Tests (see Supporting CDG Stage 2 SMS Tests ),.

  • Enabled: indicates that the test set provides reception and confirmation to the MS.
  • Disabled: indicates that the reception is denied by the test set. It's useful for CDG Stage 2 8.2.6 tests.
  • Not Supported: indicates that SMS is not supported by the test set. It's useful for CDG Stage 2 8.2.7 tests.
  • Unknown Destination Address: indicates that the destination address is unknown to the test set. It's useful for CDG Stage 2 8.2.5 tests.

NOTE
When the SMS Support is set to any value other than Enabled, the test set will still process the received SMS message (same as Enabled), but post an error message associated with the setting of SMS Support (see SMS Support Settings ) when an SMS message is received. The test set will inform the mobile station regarding an unknown destination address, or that short message origination has been denied, or that SMS is not supported by the base station.

SMS Support Settings
SMS Support Setting | Error Message
Enabled | no error message.
Disabled | SMS MS Originated message received. Origination denied due to current SMS receive Protocol (Disabled).
Not supported | SMS MS Originated message received. SMS not supported by Base Station due to current SMS Receive Protocol (Not-supported).
Unknown Destination Address | SMS MS Originated message received. SMS not supported by Base Station due to current SMS Receive Protocol (Unknown Destination Address).

Display Control

Row Index : Used to control the scrolling of the received message displayed in the Mobile-Originated Message window.

Display Format (Message/Addresses) : Specify whether ASCII or Hex format is used for displaying the received message contents in the Mobile-Originated Message window, as well as the call-back number (Call-Back Num) and the destination address (Dest Addr) in the Mobile-Originated SMS Info window.

  • If Auto is selected, the test set depends upon the message encoding of the received SMS message to determine the display mode of the Mobile-Originated Message window. If 7-bit ASCII, IA5, or GSM 7-bit default alphabet is shown in the Msg Encoding (see Mobile-Originated SMS Info ), ASCII mode is used. Otherwise, the Hex mode is used.
  • If Auto is selected, the display format for the Call-Back Num and the Dest Addr (see Mobile-Originated SMS Info ) is always ASCII.

SMS Call Drop Timer Control

The SMS Call Drop Timer setting (see CALL:SMService:MORiginated:DROP:TIMer[:STATe] ) determines whether the test set will start the SMS call drop timer

  • If it is set to On, the test set will start the timer. The test set will disconnect the call in service option SO6 or SO14 when an SMS message is not received within a fixed amount of time (about 5 seconds) since the call was established or when an Release Order from the MS is not received within a fixed amount of time (about 5 seconds) since the SMS message was received. See Test Set Behavior In Method 2 .

    It's desirable to turn on the SMS Call Drop Timer if you expect the test set to post an error and end the connection to clear any hanging query (SMS Status, etc.) when the mobile station should have sent an SMS message or disconnected the call but failed due to defect in mobile or issue in the link
  • If it is set to Off, the test set does not set a timer. The test set will maintain the connection waiting for an SMS message to be received or the call to be disconnected.

    It's useful to turn off the SMS Call Drop Timer when you are debugging or manually programming on the mobile station and do not want the test set to prematurely end the connection

NOTE
The SMS Call Drop Timer is different from the call drop timer which is accessed from the Call Drop Timer ( F10 ) on Call Parms 2 of 3 menu. The call drop timer indicates loss of reverse link. This timer also determines when the demodulation of the reverse link has been unsuccessful for a fixed period. See CALL:CONNected:DROP:TIMer[:STATe]<[:SELected]|:TA2000> .

Related Topics

Mobile-Originated SMS Message Operation


Receiving SMS Messages Sent from the Mobile Station

Receiving SMS Messages Sent from the Mobile Station

Last updated: October 28, 2004

This section is only applicable to the lab application.

The test set supports receiving short messages sent from the mobile station (MS) in three methods. Configurations Required for Receiving Mobile-Originated SMS Message summarizes the test set configurations required for each method. For details on front panel operation, see Mobile-Originated SMS Procedure .

Conf igurations Required for Receiving Mobile-Originated SMS Message

Methods

Call Status

Service Option

Message Type

Channel

Description

Method 1

Idle

Any value other than SO6 and SO14 (for example, SO1, SO2, SO3, SO9, SO33, etc.)

Point to Point

R-ACH
  • An SMS message is sent from the MS to the test set on the R-ACH (reverse access channel) via Data Burst Message. No call is established in this process.
  • If the message is too long for the R-ACH, the MS will attempt an SO6 or SO14 call to send an SMS message on the R-Traffic (reverse traffic channel) or R-FCH (reverse fundamental channel). The call will fail during service negotiation because the test set requires the MS to use the test set's service option setting. An error message appears for the error conditions. Use Method 2 (see below) for the long message.

See Method 1: Receiving an SMS message while in idle state (current service option is other than SO6/SO14). for front panel operation.

Method 2

Idle

SO6 or SO14

Point to Point

R-ACH or
R-Traffic (for IS-95 system)/R-FCH (for IS-2000 system)
  • If the message length is shorter than what is allowed on R-ACH, the MS will send the message on R-ACH. No call is established in this process. Same as Method 1 (see above).
  • If the message is too long for the R-ACH, the MS will attempt an SO6 or SO14 call to send an SMS message on the R-Traffic (reverse traffic channel) or R-FCH (reverse fundamental channel). See Test Set Behavior In Method 2 for details.

See Method 2: Receiving an SMS message while in idle state (current service option is SO6 or SO14) for front panel operation.

Method 3

Connected

Any value other than SO6 and SO14 (for example, SO1, SO2, SO3, SO9, SO33, etc.)

Point to Point

R-Traffic (for IS-95 system)/R-FCH (for IS-2000 system)

Establish a voice or data call (other than SO6/SO14 connection). An SMS message is sent from the MS to the test set on the R-Traffic (reverse traffic channel) or R-FCH (reverse fundamental channel) via Data Burst Message. The call remains connected when the MS has finished sending the SMS message unless you disconnect the call.

See Method 3: Receiving an SMS message while in a voice or data call. for front panel operation

Test Set Behavior In Method 2

Standards specify that the shorter messages are sent on the R-ACH (Reverse Access Channel) and the longer messages are sent on the R-Traffic (reverse traffic channel) or R-FCH (reverse fundamental channel).

If the MS supports automatically selecting channel to transmit the SMS message based on the message length, the test set supports receiving SMS messages either from the R-ACH or R-Traffic/R-FCH channel while the current service option is SO6 or SO14.

  • If the message length is shorter than what can be sent on R-ACH, the MS will send the message on R-ACH. No call is established in this process. Same as Method 1 (see Configurations Required for Receiving Mobile-Originated SMS Message ).
  • In the case of an MS Originate (MS initiated connection) with a current service option of SO6 or SO14, a call is established for the purpose of transferring an SMS message that is too long for the R-ACH.
    When the test set receives an MS Originate event when the current service option is SO6 or SO14 and the service option is accepted by the MS, the SMS Status will change to "Originating". The test set then expects the MS to transmit an SMS message. The call is expected to be terminated by the MS sending an Release Order when the MS has finished sending the SMS message. Errors may occur if the SMS messages or the Release Order from the MS is not received within the timeout periods (see SMS Call Drop Timer Control for details). The test set will ensure that the SMS Status changes to a terminal state (Idle, if call ended without SMS message being received, or Received, when SMS message received). See SMS Status Description for details.

Related Topics

Mobile-Originated SMS Message Operation


How Does the Test Set Build the Mobile-Terminated Message?

How Does the Test Set Build the Mobile-Terminated Message?

Last updated: October 28, 2004

This section is only applicable to the lab application.

The message contents you entered may be different from the message that is actually sent to the mobile station due to many factors. The following explains how the test set processes the messages to be sent to the mobile station.

  • User input message: The user input message is the SMS message that you entered in the Mobile-Terminated Message window (see Enter/Edit Message Contents ).
  • Desired message: The desired message is the user input message (possibly padded with '0's (zeros) due to the Message Encoding setting) repeated by the Message Repeat times (see Set Message Repeat ). The length of the desired message in encoded characters is displayed on Mobile-Terminated SMS Info window. See also Example of How the Settings Affect the Actual SMS Message .
  • Actual message: The actual message is the message that is actually sent to the MS. The actual SMS message is the desired message or the desired message truncated if the desired message is longer than the maximum length allowed by the current configurations.

    NOTE
    The maximum length allowed is determined by many factors such as the protocol standards, the channel the message is sent on, message overhead, how many optional parameters are included, etc. If the desired message is truncated before being sent to the MS, the error message "SMS send message truncated due to protocol to <n> characters (where n is the maximum allowed encoded characters)" will be generated.

Example of How the Settings Affect the Actual SMS Message

Assumed Settings:

 Interim Results

Actual Results

Message Encoding = UNICODE

Message Source = Hex

User Input Message Contents = "12345" (5 hex characters)

Message Repeat = 200

Assumed maximum allowed encoded characters is 19 UNICODE characters due to current protocol configuration.

User input message would be padded with "000" to make 2 UNICODE encoded characters.

Desired message would be "1234500012345000...1234500012345000" (8 hex characters, repeated 200 times)

Message Length (the length of desired message in encoded characters, see Mobile-Terminated SMS Info ) would be 400 (8 hex characters are represented by 2 UNICODE encoded characters)

The actual message sent to the mobile station would be "1234500012345000123450001234500012345000123450001234500012345000123450001234", truncated to result in 19 UNICODE encoded characters due to the current protocol configuration allowed.

Two error messages would result, "SMS message padded with trailing zeros to define whole characters" and "SMS send message truncated due to protocol to <n> characters where <n> would be 19)"

Related Topics

Creating/Editing the Mobile-Terminated Message Contents


Creating/Editing the Mobile-Terminated Message Contents

Creating/Editing the Mobile-Terminated Message Contents

Last updated: October 28, 2004

This section is only applicable to the lab application.

You can enter/edit the message contents to be sent to the mobile station (MS) from the Create/Edit menu which is accessed by pressing the F5 ( Short Message Service ) on Call Control 3 of 3 menu, and then pressing the F4 ( Create/Edit Message ). You can:

  • Set Message Source
  • Set Message Repeat
  • Enter/Edit Message Contents
  • Clear the Created Message

For details on front panel operation, see STEP B: Create/Edit the Mobile-Terminated Message Contents .

Set Message Source

Message Source ( F3 ): Select either ASCII or Hex data entry messages to be edited (see Enter/Edit Message Contents ) or included in the SMS message sent to the mobile station.

See also CALL:SMService:MTERminated:SOURce .

Set Message Repeat

Message Repeat ( F4 ): Set the number of times the user entered message will be repeated to build the actual message to be sent to the MS. See also CALL:SMService:MTERminated:MESSage:REPeat .

It provides a way to define a message that is longer than the maximum length allowed by the user input message (255 Ascii or 511 Hex) or construct a long string without having to enter a long string. The user input message is possibly padded with '0's (zeros) due to the setting of the Message Encoding (see Message Encoding ) before being repeated and the actual message transmitted may be truncated. See How Does the Test Set Build the Mobile-Terminated Message? for details.

Setting Message Repeat to '0' (zero) results in the SMS message being "" (null, 0 length) regardless of the user input message contents in the Mobile-Terminated Message window.

Enter/Edit Message Contents

Depending upon the setting of the Message Source ( F3 ), pressing F1 ( Enter/Edit SMS Message ) will bring up either Enter/Edit SMS Message (ASCII) menu or Enter/Edit SMS Message (HEX) menu where you can enter/edit the desired short text message, one input character at a time along with editing commands using the following settings. To enter a message with multiple characters at a time, use CALL:SMService:MTERminated:MESSage:ASCii or CALL:SMService:MTERminated:MESSage:HEX . The entered text messages are displayed in the Mobile-Terminated Message window.

  • Character Index : Specify the position at which the character will be entered or edited. It's also used to control the scrolling of the Mobile-Terminated Message window. The character index starts from '0' (indicating the first entered character). The current character index is identified by a character index cursor along with an integer value on the Mobile-Terminated Message window. It is changed along with the Data Entry Mode and Editing Commands selected.
  • Data Entry Mode : Specify whether the next input character is appended after, inserted in front of, or to replace the character pointed by the Character Index cursor (see Mobile-Terminated Message ).
  • Edit Commands: The following editing activities are available:
    • Clear to End: Clear the message contents from the character pointed by the Character Index cursor to the end of the message.
    • Backspace: Delete the character to the left of the character pointed by the Character Index cursor.
      NOTE

      The "<--" Key on the Data Entry of the test set which is typically used for backspace, has no effect on short message editing.

    • Delete Character: Delete the character pointed by the Character Index cursor.
  • A-Z, a-z, and 0-9, and Other Characters selection for Ascii entry
    0-9 and A-F selection for Hex entry
    • Each hex character is a 0-F value. Hex characters are represented by 4 bits.
    • The test set will support all 96 printable ASCII characters, except the DEL (decimal value 127) character. The DEL character will be treated like a non-printable character. Non-printable ASCII characters can not be input in ASCII entry (determined by the Message Source set to ASCII) and will be displayed as "*"for displayed ASCII characters.

Clear the Created Message

Clear Message ( F2 ): Clear the entire message displayed on the Mobile-Terminated Message window and set character index to 0.

NOTE
The test set provides two separate message entry/data storage: SMS message (ASCII) and SMS message (Hex). Clear Message only clears the active message entry which is determined by the setting of Message Source ( F3 ).

Related Topics

Mobile-Terminated SMS Message Operation


Mobile-Terminated SMS Message Operation

Mobile-Terminated SMS Message Operation

Last updated: October 28, 2004

This section is only applicable to the lab application.

NOTE
The test set does not guarantee the functionality of the simultaneous Mobile-Terminated and Mobile-Originated (see Mobile-Originated SMS Message Operation ) SMS messages, which may result in both messages not being properly handled (with non-typical SMS Status transitions) or may result in one message being processed as normal and the other message not being properly handled.

The Mobile-Terminated SMS messages are the short messages sent from the test set to the mobile station (MS). This simulates sending short messages from the network to the MS. Both point-to-point SMS and broadcast SMS messages can be sent from the test set to the MS. The test set allows you to:

  • Enter/format the short text messages from the test set to send to the intended destination mobile station. See Creating/Editing the Mobile-Terminated Message Contents .
  • Configure the short message as a point-to-point or a broadcast, specify the message encoding scheme, teleservice type, priority level, privacy level, etc. See Setting Mobile-Terminated SMS Parameters .
  • Deliver the messages either on the control channel (F-PCH or F-BCCH/F-CCCH) or the traffic channel (F-Traffic/F-FCH). See Sending an SMS Message to the Mobile Station .
  • Observe acknowledgment that the message was received by the mobile station. See SMS Message Acknowledge Info .

General Procedure

The general procedure for sending an SMS message to the mobile station is:

  1. Set up the parameters for the Mobile-Terminated SMS message (see Setting Mobile-Terminated SMS Parameters )
  2. Create/Edit the short message contents to be sent to the MS (see Creating/Editing the Mobile-Terminated Message Contents )
  3. Select an appropriate method to send short messages to the intended mobile station (see Sending an SMS Message to the Mobile Station )

For details on front panel operation, see Mobile-Terminated SMS Procedure .

Related Topics

Logging SMS Messages

Supporting CDG Stage 2 SMS Tests

SMS Status Description

Short Message Service Information

Mobile-Originated SMS Message Operation


Setting Mobile-Terminated SMS Parameters

Setting Mobile-Terminated SMS Parameters

Last updated: June 20, 2006

This section is only applicable to the lab application.

You can configure the following parameters (see Mobile-Terminated SMS Parameters ) from the Mobile-Terminated SMS Parameters menu which is accessed by pressing the F5 ( Short Message Service ) on Call Control 3 of 3 menu, then pressing the F2 ( Mobile-Term SMS Parameters ). Some of the parameters you have set are displayed in the Mobile-Terminated SMS Info window.

For details on front panel operation, see STEP A: Set Up the Mobile-Terminated SMS Parameters .

Mobile-Terminated SMS Parameters
Mobile-Terminated SMS Parameters on Test Set

Parameters in 3GPP2 C.S0015-A Standard

Description

Service

SMS_MSG_TYPE (3.4.1)

Set the SMS message type: Point to Point or Broadcast.

This setting affects the Data Burst Message (see SMS Protocol Description ) addressing used to send SMS messages under various conditions. See Mobile-Terminated SMS Addressing with Different Sending Methods for details.

GPIB Command: CALL:SMService:MTERminated:SERVice .

Teleservice

Teleservice Identifier (3.4.3.1)

IDENTIFIER field

Set the teleservice that will send the SMS message. It is useful for SMS point-to-point messages as specified in the Service field.

The teleservices supported by the test set are Paging (Wireless Paging Teleservice), Messaging (Wireless Messaging Teleservice (WMT)), Voice Mail (Voice Mail Notification Teleservice), WAP (Wireless Application Protocol) and CATPT (Card Application Toolkit Protocol Teleservice)

GPIB Command: CALL:SMService:MTERminated:TELeservice

Service Category

Service Category (3.4.3.2)

CATEGORY field

Set the service category which identifies the type of service supported by the SMS message. It is useful for SMS Broadcast messages specified by the Service setting. See Service Category Settings for a list of servcice categories supported by the test set.

GPIB Command: CALL:SMService:MTERminated:SCATegory

Originating Address

Address Parameter (3.4.3.3)

Specify the originating address to be supplied with the SMS message to the intended mobile station. It's useful for SMS point-to-point messages as specified in the Service field.

GPIB Command: CALL:CIDentity

Priority

Priority Indicator (4.5.9)

PRIORITY field

Set the priority level of the SMS message.

If NONE is selected, the optional Priority Indicator subparameter is not included in the SMS message sent to the MS. If other than NONE is selected, this setting will set the priority level of the SMS message (as listed in the Priority Level Settings ).

If teleservice type is WAP or CATPT, this parameter will not be transmitted OTA regardless of the presence/value of this parameter.

GPIB Command: CALL:SMService:MTERminated:PRIority

Privacy

Privacy Indicator (4.5.10)

PRIVACY field

Set the privacy level of the SMS message.

If NONE is selected, the optional Privacy Indicator subparameter is not included in the SMS message sent to the MS. If other than NONE is selected, this setting sets the privacy level of the SMS message (as shown in Privacy Level Settings ).

If teleservice type is WAP or CATPT, this parameter will not be transmitted OTA regardless of the presence/value of this parameter.

GPIB Command: CALL:SMService:MTERminated:PRIVacy

Voice Mail Count

Number of Messages (4.5.12)

MESSAGE_CT field

Set the number of the voice mail messages sent to the mobile station which represents the number of messages stored at the Voice Mail System. It is only useful for Voice Mail Notification teleservice selected by the Teleservice .

GPIB Command: CALL:SMService:MTERminated:VMNotify:COUNt

MS Message Alert

Alert on Message Delivery (4.5.13)

ALERT_PRIORITY field

Specify whehter the mobile station will alert the user (for example, beep or vibrating depending on the mobile station behavior) when it receives the message.

If NONE is selected, the optional Alert on Messge Delivery subparemeter is not included in the SMS message sent to the MS. If other than NONE is selected, this setting sets the alert level (as shown in MS Message Alert Settings ) used to distinguish different priorities of the message.

GPIB Command: CALL:SMService:MTERminated:ALERt

Message Encoding

User Data (4.5.2)

MSG_ENCODING field

Set the encoding scheme for the user entered message contents. See Message Encoding for details on each type of Encoding.

GPIB Command: CALL:SMService:MTERminated:MESSage:ENCoding

Message (Optional User Data)

User Data (4.5.2)

CHARi field

Specify whether include the user entered message content in the SMS message sent to the mobile station.

This setting is useful for the teleservices (other than WAP and CATPT) which have optional User Data subparameter. The User Data subparameter is mandatory for the WAP. See Teleservice .

When Included, the user entered message content (see Creating/Editing the Mobile-Terminated Message Contents ) is included in the optional User Data subparameter of the SMS message sent to the MS. When Excluded, the optional User Data subparameter is not sent to the MS.

GPIB Command: CALL:SMService:MTERminated:MESSage:UDATa

Call-Back Number

Call-Back Number (4.5.15)

Specify whether include the optional Call-Back number in the SMS message sent to the MS. The call-back number indicates the number to be dialed in reply to a received SMS message.

When Included, the test set use the setting of Originating Address as the optional Call-Back Number subparameter included in the SMS message sent to the MS. When Excluded, the optional Call-Back Number subparameter is not sent to the MS.

NOTE
The Originating Address is a mandatory parameter for the mobile-terminated SMS message. It's in addition to the optional call-back number subparameter. The test set uses the same setting for both parameters sent to the MS.

GPIB Command: CALL:SMService:MTERminated:CBNumber

MDMI

Message Display Mode Inclusion (4.5.16)

the Message Display Mode Inclusion (MDMI) determines if the Message Display Mode sub-parameter is sent for teleservice types where this sub-parameter is optional. It should be either "Include" or "Exclude".

MDM

Message Display Mode (4.5.16)

MSG_DISPLAY_MODE field

The Message Display Mode is used to indicate to the mobile station when to display the receive message. Only when MDMI is set to "Include", this parameter will be included in the message sent to mobile. Otherwise, this parameter will not be transmitted OTA. See Message Dispaly Mode Indicator Values for each value of the Message Display Mode Indicator which show the most significant two bits of the eight bits. The setting range of the Message Display Mode can be the integer 0-255:

  • If the integer 0-63 is input, `00' is filled in the MSG_DISPLAY_MODE field.
  • If the integer 64-127 is input, `01' is filled in the MSG_DISPLAY_MODE field.
  • If the integer 128-191 is input, `10' is filled in the MSG_DISPLAY_MODE field.
  • The integer 192-255 is reserved.

If teleservice type is WAP or CATPT, this parameter will not be transmitted OTA regardless of the presence/value of MDMI and MDM.

Mobile-Terminated SMS Addressing with Different Sending Methods
Methods for SMS Sending | Service Configuration
 | Point-to-Point | Broadcast
Method 1 (see Methods for Sending Mobile-Terminated SMS Message ) | Data Burst Message is addressed to the Paging IMSI (see CALL:PAGing:IMSI:TYPE ). | Data Burst Message is addressed to broadcast address.
Method 2 (see Methods for Sending Mobile-Terminated SMS Message ) | General Page Message is addressed to the Paging IMSI (see CALL:PAGing:IMSI:TYPE ). Data Burst Message is not addressed since it is sent via the traffic channel. | General Page Message is addressed to the Paging IMSI (see CALL:PAGing:IMSI:TYPE ). Data Burst Message is not addressed since it is sent via the traffic channel.
Method 3 (see Methods for Sending Mobile-Terminated SMS Message ) | Data Burst Message is not addressed since it is sent via the traffic channel. | Data Burst Message is not addressed since it is sent via the traffic channel.
Priority Level Settings
Priority Setting on the Test Set | PRIORITY Field Value (2 bits)
Normal | 00
Interactive | 01
Urgent | 10
Emergency | 11
Privacy Level Settings
Privacy Setting on the Test Set | PRIVACY Field Value (2 bits)
Not restricted | 00
Restricted | 01
Secret | 10
Confidential | 11
MS Message Alert Settings
MS Message Alert Settings on the Test Set | ALEAR_PRIORITY Field Value (2 bits)
MS Default | 00
Low | 01
Medium | 10
High | 11
Service Category Settings
Service Catetory Settings on the Test Set | CATEGORY Field Value (16 bits)
0 - Unknown | 0x0000
1 - Broadcast Emergency | 0x0001
2 - Administrative | 0x0002
3 - Maintenance | 0x0003
4 - General News - Local | 0x0004
5 - General News - Regional | 0x0005
6 - General News - National | 0x0006
7 - General News - Intl | 0x0007
8 - Bus/Fin News - Local | 0x0008
9 - Bus/Fin News - Regional | 0x0009
10 - Bus/Fin News - National | 0x000A
11 - Bus/Fin News - Intl | 0x000B
12 - Sports News - Local | 0x000C
13 - Sports News - Regional | 0x000D
14 - Sports News - National | 0x000E
15 - Sports News - Intl | 0x000F
16 - Entertain News - Local | 0x0010
17 - Entertain News - Regional | 0x0011
18 - Entertain News - National | 0x0012
19 - Entertain News - Intl | 0x0013
20 - Local Weather | 0x0014
21 - Area Traffic Report | 0x0015
22 - Local Flight Schedules | 0x0016
23 - Restaurant | 0x0017
24 - Lodgings | 0x0018
25 - Retail Directory | 0x0019
26 - Advertisements | 0x001A
27 - Stock Quotes | 0x001B
28 - Employee Opportunities | 0x001C
29 - Medical/Health/Hospitals | 0x001D
30 - Technology News | 0x001E
31 - Multi-category | 0x001F
Message Dispaly Mode Indicator Values
MSG_DISPLAY_MODE | FUNCTION
`00' | Immediate Display: The mobile station is to display the received message as soon as possible.
`01' | Mobile default setting: The mobile station is to display the received message based on a pre-defined mode in the mobile station.
`10' | User Invoke: The mobile station is to display the received message based on the mode selected by the user.
`11' | Reserved

Message Encoding

Message Encoding is used to set the encoding scheme for the user entered message contents. It is useful only when the Message (Optional User Data) is "Included" (see Message (Optional User Data) ). The message encoding determines the number of bits necessary to send an encoded character for each encoding type. An encoded character may take multiple hex or ASCII characters to represent. For example, a UNICODE encoded character takes 2 ASCII or 4 hex characters to represent. The user entered message contents (see Creating/Editing the Mobile-Terminated Message Contents ) is possibly padded with trailing '0's (zeros) as necessary to match the indicated "expected Input characters (ASCII)" or "expected input characters (Hex)" as shown in Message Encoding See How Does the Test Set Build the Mobile-Terminated Message? for examples.

NOTE
If the test set pads the user input message with '0's to match the expected Input characters as shown in Message Encoding , an error "SMS message padded with trailing zeros to define whole characters" is generated.

Message Encoding

Message Encoding Settings 1

Bits Per Encoded Character

Expected Inputcharacters (Ascii)

Expected Inputcharacters (Hex) 3

MSG_ENCODING field value

(see 9.1 in TIA TSB-58-F)

Octet 4

8

any number

an even number

00000

7-Bit ASCII

7

any number

an even number

00010

IA5

7

any number

an even number

00011

UNICODE

16

an even number 2

a multiple of four

00100

Shift-JIS

8 or 16 5

any number

an even number

00101

Korean

8 or 16 5

any number

an even number

00110

Latin/Hebrew

8

any number

an even number

00111

Latin

8

any number

an even number

01000

GSM 7-Bit

7

any number

an even number

01001

KSC5601 (Korean)

8

NA

a multiple of four

10000

1. UNICODE is a fixed 2-byte encoding method intended as an international character encoding scheme. Shift-JIS is a variable 1-2 byte non-modal encoding method widely implemented in Japan and used for the encoding of Kanji, Kana and Latin character sets. Korean is a variable 1-2 byte encoding method widely used in Korea.

2. When Message Source is set to ASCII (see Set Message Source ) and Message Encoding is set to UNICODE (see Message Encoding ), the user input message will be padded with a trailing "0" (zero) if the number of user input characters is in odd number. See Example of How the Settings Affect the Actual SMS Message for examples.

3. When Message Source is set to Hex (see Set Message Source ), the message is possibly padded with 1 to 3 trailing '0's (zeros). See Example of How the Settings Affect the Actual SMS Message for examples.

4. The Octet encoding type is unspecified in the 3GPP2 C.S0015-A standards. While some mobile stations use ASCII encoding, others may use a different encoding or may not implement the Octet encoding type at all. Consequently, using `Octet' encoding to send ASCII User Data to a mobile station may cause the mobile station to display the message using a different character set or not display a message at all.

5. The test set assumes that Shift-JIS and Korean always use 8 bits/character.

Related Topics

Mobile-Terminated SMS Message Operation


Sending an SMS Message to the Mobile Station

Sending an SMS Message to the Mobile Station

Last updated: October 28, 2004

This section is only applicable to the lab application.

After you've created the short text message (see Creating/Editing the Mobile-Terminated Message Contents ), and properly specified the Mobile-Terminated SMS parameters (see Setting Mobile-Terminated SMS Parameters ) as desired, you can direct the test set to send a short message to the mobile station whether it is idle or engaged in a voice or data call.

  • Delivery Modes Description
  • Mobile-Terminated Message Timeout

Delivery Modes Description

The test set provides three methods to send an SMS message. Methods for Sending Mobile-Terminated SMS Message summarizes the differences among these methods. For details on front panel operation, see STEP C: Send an SMS Message to the Mobile Station .

M ethods for Sending Mobile-Terminated SMS Message

Methods

Call Status

Service Option

Message Type

Channel

Description

Method 1

Idle

Any value

Broadcast *

PCH

No call is established in this process. The test set supports transmitting broadcast SMS message on the PCH (paging channel) using a Data Burst Message.

To achieve this, make sure the MS has camped on the test set and the current Call Status is Idle, pressing the Send Message ( F1 ) will send the SMS message to the MS on the PCH.

See Method 1: Sending an SMS message while in idle state for front panel operation.

Point to Point

PCH or F-CCCH

No call is established in this process. A Point to Point SMS message can be sent to the MS using a Data Burst Message either on the PCH (paging channel) or on the F-CCCH (forward common control channel) depending upon which control channel is configured (see Control Channel Configuration ).

To achieve this, make sure the MS has camped on the test set and the current Call Status is Idle, pressing the Send Message ( F1 ) will send the SMS message to the MS on the specified control channel.

See Method 1: Sending an SMS message while in idle state for front panel operation.

Method 2

Idle

SO6 or SO14

Point to Point, or Broadcast

F-Traffic (for IS-95 system)/F-FCH (for IS-2000 system)

A call is established. The SMS message is sent on the F-Traffic (forward traffic channel) (for IS-95 system) or F-FCH (forward fundamental channel) (for IS-2000 system) using a Data Burst Message. Then the call is automatically terminated.

To achieve this, make sure that the Call Status is Idle and the current service option is set to SO6 or SO14 , then establish a temporary connection and send a message by pressing the F3 ( Originate Call ). Observe the state changes of the call processing status (see Instrument Status Area ) and the SMS Status (see SMS Message Acknowledge Info ).

See Method 2: Sending an SMS message via a temporary SO6 or SO14 connection. for front panel operation

Method 3

Connected

Any value other than SO6 and SO14. (for example, SO1, SO2, SO3, SO9, SO33, etc.)

Point to Point, or Broadcast

F-Traffic (for IS-95 system/F-FCH (for IS-2000 system)

An SMS message is sent to the MS on the F-Traffic (forward traffic channel) (for IS-95 system) or F-FCH (forward fundamental channel) (for IS-2000 system) using a Data Burst Message. The call remains connected after the message is sent. This simulates a user receiving a text message while having a conversation.

To achieve this, establish a call with Service Option other than SO6 and SO14 selected. When the Call Status changes to Connected , press the Send Message ( F1 ).

See Method 3: Sending an SMS message while in a voice or data call. for front panel operation.

* The test set does not support transmitting broadcast SMS message on forward broadcast control channel (F-BCCH) if F-BCCH is configured for use by the test set (see Operating Considerations ).

NOTE
Standards specify that shorter messages are sent on the control channel and longer messages are sent on the traffic channel. The test set does not support changing the channel based on the message length when sending an SMS message to the mobile station and will truncate the message as necessary for the current configuration (see How Does the Test Set Build the Mobile-Terminated Message? ).

Mobile-Terminated Message Timeout

When an SMS message is sent to the mobile station, the test set will wait for the acknowledgment from the mobile station which is displayed in the SMS Message Acknowledge Info window. If an SMS Acknowledge Message is received before the timeout period expires, the SMS Status will change to MS Ack. Otherwise, an error message is generated and the SMS Status will change to MS Not Acknowledged. See SMS Status Description for details.

  • For Method 1, the timeout period depends upon the Max Slot Cycle Index of the mobile station (see Mobile Reported Information ) and the test set fixed setting (about 15 second). This maximum timeout can be about 2 minutes, when Max Slot Cycle Index of the mobile station is 7.
  • For method 2, the timer will not be started until after the traffic channel is established, then wait for the fixed setting (about 15 second).
  • For Method 3, the timeout period will be the test set fixed setting (about 15 second).

Related Topics

SMS Status Description


Short Message Service/ Multimedia Service

Short Message Service/ Multimedia Service

Last updated: June 20, 2006

This section is only applicable to the lab application.

The Short Message Service (SMS) as specified in the 3GPP2 C.S0015-A provides a means for exchanging of short messages between the mobile stations and the network. The test set can simulate an SMS system which provides for the transmission of short messages to, or reception of short messages from an intended mobile station, and the return of acknowledgments and error messages. The HTTP Interface in the test set allows you to configure SMS message parameters and content, send and receive SMS messages using HTTP protocol. Additionally, the HTTP interface also facilitates MMS message transfer to and from a mobile station if used in conjunction with compatible MMSC (Multimedia Message Service Center) software.

An application note is available for download at: http://cp.literature.agilent.com/litweb/pdf/5989-0157EN.pdf

Agilent Short Message Service Testing Using the E6702B cdma2000 Test Set

Test Set SMS Capabilities

  • Test Set SMS System Emulation
  • Mobile-Terminated SMS Message Operation
    • Setting Mobile-Terminated SMS Parameters
    • Creating/Editing the Mobile-Terminated Message Contents
    • Sending an SMS Message to the Mobile Station
  • Mobile-Originated SMS Message Operation
    • Receiving SMS Messages Sent from the Mobile Station
    • Setting Mobile-Originated SMS Parameters
  • Supporting CDG Stage 2 SMS Tests

Test Set HTTP SMS/MMS

  • HTTP SMS/MMS

SMS/MMS Operation Procedures

  • SMS Operation Procedures
  • How to Send MMS Messages ?

General Information

  • Short Message Service Information


SMS Status Description

SMS Status Description

Last updated: June 21, 2006

This section is only applicable to the lab application.

The SMS operations, such as Mobile-Terminated SMS operation, Mobile-Originated Operation, etc., are associated with the state transitions (see SMS State Transition Diagram ). These states can be observed from the SMS Message Acknowledge Info window or queried with CALL:SMService:STATus[:STATe]? .

The SMS status can help you determine the status of the SMS processing, and verify whether the SMS events were successful. The possible states include SMS Transitory States and SMS Terminal States . The test set will always end up in a terminal state once the test set completes a process (successfully or in error conditions).

SMS Transitory States

The following SMS states are transitory states that the test set remain in momentarily during transitions to a terminal state.

  • Paging - The test set is in the process of paging the MS to establish an SO6 or SO14 connection to send an SMS message.
  • Sending - The test set is in the process of sending an SMS message to the MS.
  • Waiting - The test set has sent an SMS message to the MS and is waiting for an acknowledgment from the MS.
  • Originating - The MS is originating a connection in SO6 or SO14. The expectation is that the MS will be sending an SMS message once a connection is established. (See method 2 in Receiving SMS Messages Sent from the Mobile Station )

SMS Terminal States

The following SMS states are terminal states that the test set is stabilized in for a substantial length of time.

  • Idle - The SMS state will be idle when power-up, preset, or Clear SMS Info/Status (see Clearing the SMS Info/Status ) is performed or when an attempt to send or receive an SMS message failed.
  • MS Ack - The SMS message sent by the test set has been acknowledged by the MS.
  • MS Not Acknowledged - The SMS message sent by the test set was not acknowledged by the MS before timeout (see Mobile-Terminated Message Timeout ).
  • Broadcast Sent - The test set finished sending a broadcast SMS message.
  • Received - An SMS message has been received by the test set from the MS, including when a message is received and rejected by test set due to the setting of Protocol Support (see SMS Support Control ).

SMS State Transition Diagram

Related Topics

SMS (Short Message Service) State Synchronization

Short Message Service Information

Test System Synchronization Overview

Call Processing Event Synchronization

Call Processing State Synchronization


Supporting CDG Stage 2 SMS Tests

Supporting CDG Stage 2 SMS Tests

Last updated: October 28, 2004

This section is only applicable to the lab applications.

The test set supports the following SMS tests as specified in the CDG Stage 2 standard.

Short Message Service Tests
CDG Stage 2 Tests | Supported by E6702A?
8.1 Mobile Station Terminated SMS Tests (see Performing CDG Stage 2 SMS Tests: 8.1 and 8.3 Tests for operation procedures)
8.1.1 Paging Channel SMS Delivery Procedures | Yes
8.1.2 SMS Delivery Procedures when Message Too Large for Paging Channel | Yes
8.1.3 Traffic Channel SMS Delivery Procedures | Yes
8.1.4 Delivery of Maximum Length Message | Yes
8.1.5 Reserved | Yes
8.1.6 SMS Delivery Error - Mobile Station Short Message Buffer Full | Yes
8.1.7 Voice Mail Notification | Yes
8.2 Mobile Station Originated SMS Tests (see Performing CDG Stage 2 SMS Tests: 8.2 Mobile Station Originated SMS Tests for operation procedures)
8.2.1 Access Channel SMS Delivery | Yes
8.2.2 SMS Delivery when Message too large for Access Channel | Yes
8.2.3 Traffic Channel SMS Delivery | Yes
8.2.4 Reserved | Yes
8.2.5 Unknown Destination Address | Yes
8.2.6 MS Originated SMS Disabled | Yes
8.2.7 SMS Not Supported by Base Station | Yes
8.3 Broadcast SMS Tests (see Performing CDG Stage 2 SMS Tests: 8.1 and 8.3 Tests for operation procedures)
8.3.1 Broadcast SMS Delivery | Yes

Related Topics

Mobile-Terminated SMS Procedure


Performing Multi-Unit Synchronization

Performing Multi-Unit Synchronization

Last updated: June 13, 2007

This section is only applicable to the lab application and to a test application with the required feature license.

  • Overview
  • Synchronization Connection Setup
  • Synchronization Configuration Requirements
  • Synchronization Parameters Description
  • Synchronization Information and Annuciator
  • Operating Consideration

Overview

Multiple test sets either running the cdma2000 test/lab application or the 1xEV-DO test/lab application can be synchronized on the CDMA system time. It is very useful for Hybrid Mode AT/MS tests which requires two test sets, one running the cdma2000 test/lab application and another one running the 1xEV-DO test/lab application to be synchronized.

During the synchronization, the test set providing CDMA system time and 2 seconds trigger signal is called Sync Server while the test set initiates the synchronization and requests the Sync Server to provide CDMA system time is called Sync Client. The test set can act as either a Sync Client or a Sync Server at a time. If as a Sync Server, the test set can process multiple Sync Clients' sync requests.

Prior to the synchronization, the test sets must be properly connected (see Synchronization Connection Setup ) and configured (see Synchronization Configuration Requirements ). When the synchronization is initiated by the Sync Client (see Sync To External Server ). the following procedure is automatically performed.

  1. The Sync Client sends a sync request to the Sync Server through the LAN.
  2. When receiving the sync request , the Sync Server sends its CDMA system time to the Sync Client. If any error occurs, the Sync Server responds an error to the Sync Client.
  3. If the Sync Client receives the response with CDMA system time, it sets its CDMA system time to the received CDMA system time when next 2-second trigger occurs. Once the synchronization completes, the two test sets are synchronized on the CDMA system time within 1 us (see CDMA System Time and Synchronization Information ). The synchronization remains until an event that causes the loss of the synchronization occurs.

    If the Sync Client receives a response with errors or does not receive any response within 3 seconds, the Sync Client posts an error message and the synchronization fails.

Data Source Reset functionality provides a way to reset the data source of Loopback Service Option (SO2, SO9, SO55) on every second boundary of CDMA system time. This functionality can cooperate with Mult-Unit time synchronization to do some tests by using two momentums, for example: soft handoff, mobile receiver diversity, etc. The Data Source Reset is only applicable to the lab application.

Synchronization Connection Setup

The following diagram demonstrates an example of synchronization connection for two test sets.

  • Connect one test set's 10 MHz REF IN to another one's 10 MHz REF OUT connector directly, or connect both test sets' 10 MHz REF IN connector to an external instrument that provides 10 MHz timebase signal.
  • Connect the Sync Server's TRIG OUT to the Sync Client's TRIG IN connector.
  • Connect the two test sets to the LAN using a standard LAN cable, or directly connect them using a crossover LAN cable.

Synchronization Connection Setups for Two Test Sets

Synchronization Configuration Requirements

Prior to the synchronization, you should properly configure the test sets as shown in the table below. For detailed procedure, see How Do I Perform Multi-Unit Synchronization? .

Setting Requirements on the Sync Client and Sync Server
Settings | Sync Client |  | Sync Server
 | Test Set (E6702B) | Test Set (E6706A) | Test Set (E6702B) | Test Set (E6706A)
Operating Mode | Active Cell or IS-2000 Test | Active Cell or IS-856 Test | Active Cell or IS-2000 Test | Active Cell or IS-856 Test
System Type | IS-2000 or IS-95 | IS-856 | IS-2000 or IS-95 | IS-856
Ext 8960 IP Addr | Must be set to LAN IP address of the Sync Server. |  | Does not matter.
Call Status | Idle |  | Does not matter.
External Trigger | Does not matter. |  | 2 seconds (see Setting External Trigger )

Synchronization Parameters Description

  • Ext 8960 IP Addr

    Sets the IP address of the Sync Server on the Sync Client. It must be same as the LAN IP Address of the test set acting as the Sync Server.

    GPIB Command: SYSTem:COMMunicate:LAN:EXTernal:ADDRess

  • Sync To External Server

    Initiates the synchronization and sends a sync request to the Sync Server at the address specified by Ext 8960 IP Addr .

    Prior to this action, make sure that you have finished the configurations as shown on Setting Requirements on the Sync Client and Sync Server .

    GPIB Command: SYSTem:COMMunicate:LAN:EXTernal:SYNChronize

  • Clear Sync Indications

    Clears all synchronization indications including Sync Annuciators , Client Sync Indication and Server Sync Indication .

    GPIB Command: SYSTem:COMMunicate:LAN:EXTernal:SYNChronize:INDication:CLEar

  • LSO Data Reset (This function is only applicable to the lab application.)

    Reset the data source of Loopback Service Options (SO2, SO9, SO55) of two momentums on every even second boundary of CDMA time.

    GPIB Command: CALL[:CELL]:SOPTion:LOOPback:DSOurce:RESet[:STATe]

Synchronization Information and Annuciator

The Local Synchronization Information window and the Sync Annuciator at the left corner of test set screen provide helpful information about the synchronization operation. A typical display for a successful synchronization between two test sets is shown below.

CDMA System Time and Synchronization Information

  • Client Sync Indication

    Indicates whether the test set has successfully completed a synchronization when acting as a Sync Client.The possible sync indications as a Sync Client are: Operation Complete , Attempting Sync , or null string (no sync).

  • Server Sync Indication

    Indicates whether the test set has successfully completed a synchronization when acting as a Sync Server. The possible sync indications as a Sync Server are: Operation Complete , Processing Sync Request , or null string (no sync).

  • Ext 8960 IP Addr (Server)

    Indicates the IP address of the Sync Server specified by Ext 8960 IP Addr .

  • Sync Annuciators

    • C OPC : Indicates that the test set has successfully completed a synchronization when acting as a Sync Client.
    • S OPC : Indicates that the test set has successfully completed a synchronization when acting as a Sync Server.
    • CS OPC : Indicates that the test set has successfully completed a synchronization when acting as a Sync Client and then successfully completed a synchronization when acting as a Sync Server. In this case, Operation Complete will be shown on both the Client Sync Indication and Server Sync Indication fields of this test set.
    • Null (no sync).

    GPIB Command: SYSTem:STATus:COMMunicate:LAN:EXTernal:SYNChronize:INDication?

Operating Consideration

In order to perform the synchronization successfully, you must follow the Synchronization Connection Setup to set up the physical connection correctly and follow Synchronization Configuration Requirements to configure the test sets correctly before performing the synchronization.

After the synchronization is done successfully, the followings reasons can cause the loss of synchronization between the test sets.

  • The CDMA system time in the Sync Client or Sync Server is changed.
  • The CDMA system time in the Sync Client or Sync Server is affected by performing Actions caused uncertainty:

Related Topics

Setting CDMA System Time Parameters

GPIB Commands: CALL:STATus , CALL:CSTime , SYSTem:COMMunicate and SYSTem:STATus

Manual Operation How Do I Perform Multi-Unit Synchronization?


Digital Bus Information

Digital Bus Information

Last updated: June 18, 2007

This section is only applicable to the lab application and to a test application with the required feature license with rear panel digital bus.

Description

A test set equipped with cdma2000, 1xEV-DO or W-CDMA lab applications can perform mobile station tests that require faded signals. The test set must be equipped with a rear panel that includes a connector labeled Digital Bus.

NOTE
For detailed setup and operating instructions pertaining to faded signal generation, refer to

E5515C Fading Solution Application Guide

It can be downloaded at http://cp.literature.agilent.com/litweb/pdf/1000-1894.pdf .

When a faded signal from the test set is needed, the forward baseband signal path from the Test Set is diverted to a PC running Baseband Studio software. This software is capable of digitally adding fading patterns requested by the user.

Fader Setup

Baseband Studio software also controls the test set's call parameters and digital bus signal path switching modes. The status of the various digital bus parameters and the controls themselves are made available by selecting Digital Bus Info from the Call Control screen.

  • Baseband Studio Summary - The current values in use for baseband signal level adjustments.
  • Digital Bus Summary - The current data and clock rates for the modulation type of the faded signal.

With the Digital Bus Information screen displayed, the following fading parameters are displayed:

The Bbio Control menu provides three settings:

  • Digital Bus Path - Must be Internal for non-faded signal operation.

  • ALC Mode - Must be Closed Loop for non-faded signal operation.

  • Calibrate Open Loop ALC - Used to generate calibration tables that are needed when ALC Mode is Open Loop.

IMPORTANT
The Digital Bus Path and ALC Mode fields are controlled by the Baseband Studio software when a faded signal is generated by the test set. The only time these field settings will need to be manually changed is during certain diagnostic routines. Refer to the Installation Note (E5515-90243) shipped with the Option 504 kit for instructions on performing diagnostic tests.

Related Topics

How Do I Perform FPC Test (FPC Mode 000)?


Mobile Station Reported Pilot Level Information

Mobile Station Reported Pilot Level Information

Last updated: October 28, 2004

This section is only applicable to the lab application.

The Mobile Station Reported Pilot Level Information table on the upper part of the Soft Handoff Information screen shows the information the mobile sends to the test set in the Pilot Strength Measurement Message (PSMM) to assist in the soft handoff.

When a connection is established between the test set and the mobile station, the mobile station reports the measured pilot level information to the test set by the PSMM. The PSMM contains a pilot strength record for each pilot from which the timing reference is derived. Each pilot strength record consists of three fields: the PILOT_PN_PHASE parameter (PN Offset * 64), the PILOT_STRENGTH field, and the KEEP field.

When the PSMM is received by the test set, the PSMM contents are displayed in the Mobile Station Reported Pilot Level Information table for up to three pilot channels (up to six pilot channels can be retrieved using the CALL:MS:REPorted:PILot:STRength command).

Description

The following information are displayed on the Mobile Station Reported Pilot Level Information table:

  • PN Status: It shows Cell 1 and Cell 2 pilots' current Pilot Sets status (Active or Candidate) or the transition status from one set to another set (To Add or To Drop). See Verifying MS Pilot Reporting Behavior in Soft/Softer Handoff for details.
  • Keep Status: It corresponds to the KEEP field in the PSMM. The mobile shall set this bit to 0 if the handoff drop timer (specified by T_TDrop, see Soft/Softer Handoff Parameters ) has expired; otherwise the bit shall be set to 1.
  • PN Phase: It corresponds to the PILOT_PN_PHASE field in the PSMM. Since the mobile station derives its time reference from Cell 1 of the test set, the Cell 1 PN Phase is equal to 64 x Cell 1 PN Offset. The test set allows you to set Cell 2 Delay (relative to Cell 1) from 0 to 16 chips (see Soft/Softer Handoff Parameters ), the Cell 2 PN Phase should be equal to (Cell 2 Delay + 64 x Cell 2 PN Offset).
    For example, if the Cell 1 Pilot PN Offset is 15, the Cell 1 Pilot PN Phase will be (15x64 = 960) PN chips. If the Cell 2 Pilot PN Offset is 28 and the Cell 2 Delay is set to 12.21 us (15 chips), the Cell 2 PN Phase will be (28 x 64 + 15 = 1807) PN chips.
  • Pilot Strength: It corresponds to the PILOT_STRENGTH field in the PSMM. The mobile station searcher is used to compute the strength of a received pilot by measuring the ratio of the pilot energy per chip (Ec) to the total received spectral density (Io) (noise and signals) at the current CDMA frequency. The mobile station reports pilot strength in units of -0.5 dB. These values should correspond to values that the base station reports in the Generated Pilot Level Information table.
  • PN Offset: It is an offset index of the timing of the cell's short codes relative to system time and uniquely identify each simulated cell site to the mobile station (0 through 511 inclusive). These values should correspond to values the base station reports in the Generated Pilot Level Information table.
  • Pilot Strength Request Time Stamp: It reports the time that the last Pilot Measurement Request Order (PMRO) was sent from the test set to the mobile station by pressing the Send Pilot Meas Request (F5 ) key.
  • Pilot Strength Report Time Stamp: It reports the time that the last Pilot Strength Measurement Message (PSMM) was received at the test set from the mobile station.
  • Handoff Status: It indicates the current soft handoff state. The possible results are Soft, Softer or None (see CALL:STATus:SHANdoff? ). The 'Soft' is displayed when a call is connected and the mobile is in soft handoff (Handoff Type is set to Soft and Soft Handoff is set to On). The 'Softer' is displayed when a call is connected and the mobile is in softer handoff (Handoff Type is set to Softer and Soft Handoff is set to On). Otherwise, 'None' is displayed. See Enabling Soft/Softer Handoff .

Updating the Mobile Station Reported Pilot Level Information

There are two methods to cause the mobile station to send the PSMM for updating the Mobile Station Reported Pilot Level Information table:

  • One method is the mobile station will autonomously send a PSMM to the test set when it detects that a pilot has crossed certain power level thresholds. See Verifying MS Pilot Reporting Behavior in Soft/Softer Handoff .
  • Another method is the test set sends a request to the mobile station through Pilot Measurement Request Order (PMRO). When the mobile station receives a PMRO it responds with a PSMM. A PMRO (Pilot Measurement Request Order) is sent to the mobile station by pressing the Send Pilot Meas Request (F5 ) key (See F. Send Pilot Meas Request or CALL:MS:REPorted:PILot:STRength:REQuest[:IMMediate] ) or as a side-effect of any signaling that effects the mobile station's active set of pilots. This would include turning soft handoff on or off, changing the soft handoff type (soft or softer), or bringing up a call.

When a PMRO is sent to the mobile station by pressing the Send Pilot Meas Request (F5 ) key, the Mobile Station Reported Pilot Level Information table is cleared and the Pilot Strength Request Time Stamp is updated. When the PSMM is received by the test set, the Pilot Strength Report Time Stamp is updated and the new PSMM results are displayed.

You can clear the Mobile Station Reported Pilot Level Information table using CALL:MS:REPorted:PILot:STRength:REPort:CLEar command. See E. Clear Mobile Pilot Report for front panel operation.

NOTE
A call must be connected (Active Cell, Connected state) before the test set displays the Send Pilot Meas Request (F5 ) key.

NOTE
The test set does not send any handoff messages (Extended Handoff Direction Message, Universal Handoff Direction Message or General Handoff Direction Message) in response to the mobile station's PSMM.

Related Topics

Verifying MS Pilot Reporting Behavior in Soft/Softer Handoff


How Do I Access the Data Counters?

How Do I Access the Data Counters?

Last updated: October 28, 2004

This section is only applicable to the lab application.

The test set's data channel features include counters that increment as RLP (Radio Link Protocol) and IP (Internet Protocol) data is transferred to/from a wireless device (see Data Counters ).

There are two tables that provide RLP and IP frame counts. The first is labeled Counters and is accessed as follows:

  1. Press the CALL SETUP key.
  2. Press the left More key until screen 3 of 3 is displayed.
  3. Press the Data Channel ( F2 ) key.

    The Counters table is shown at the bottom of the Data Channel screen.

  4. (Optional) To clear the information in the Counters table, press the Clear All Counters ( F3 ). The counters will also be cleared when the test set cycles power or full presets.
  5. Press the RLP Counters Info ( F4 ) key, a more detailed RLP counters information table is displayed.
  6. (Optional) To clear the information in the RLP Counters Information table, press the Clear RLP Counters ( F3 ). The counters will also be cleared when the test set cycles power or full presets.

Related Topics

Data Counters


How Do I Perform Calling Party Number Verification?

How Do I Perform Calling Party Number Verification?

Last updated: June 20, 2006

This section is only applicable to the lab application.

This example is to verify that a mobile station shall:

  • display the calling party 1 number (CPN) when the calling party 1 presentation indicator (PI) field of the CPN information record is set to '00' (Presentation Allowed)
  • not display the CPN but shall indicate the CPN is restricted when the PI field of the CPN information record is set to '01' (Presentation Restricted)
  • not display the CPN but shall indicate the CPN is not available when the PI field of the CPN information record is set to '10' (Number Not Available)

Procedure

  1. Press the Call Setup key.
  2. Verify that the Operating Mode ( F1 ) is set to Active Cell and the System Type ( F2 ) is set to IS-2000 for this example.
  3. Press the More key on the lower right side of the test set until 4 of 4 of the Call Parms menu is displayed.
  4. Press the F10 ( Calling Party Number Parms ). The Calling Party Number Parameters menu is displayed. See Parameters Description for details.
    • Set the Calling Party Number Inclusion to Include .
    • Set the Calling Party 1 Presentation Indicator to Allowed .
    • If required, select the Calling Party 1 Number and enter a desired value. Up to 20 characters from the set of 0123456789abc*# can be entered. The digits of 0-9 are entered from the DATA ENTRY keys and the characters of "abc*#" are entered from the newly displayed softkeys on the right of the screen. Note that if the length of the entered string is greater than 14 characters, only the first 11 entered characters followed by a "..." are displayed in the Calling Party 1 Number field after your setting. Use the GPIB command ( CALL:CPNumber[1][:SELected] ) to query the whole string.
    • If required, select other parameters and set to the desired value. In this example, the default settings are used.
  5. (Optional) To capture a protocol log for further analysis, start a capture in the Wireless Protocol Advisor (WPA) software (see Protocol Logging ) and then perform the following steps.
  6. Set up a call from the test set to the mobile station in a voice or loopback service option. See How Do I Set Up a Call? .
  7. Observe the mobile station's screen. Verify that the mobile station receives and displays the calling party 1 number.
  8. End the call.
  9. If you start a WPA capture in step 5, verify that the test set sends an Alert With Information Message with the calling party number information record with the PI field set to '00' (Presentation Allowed). An example log file is shown as below.
  10. Repeat steps 4 through 9, except that
    • in step 4, set the Calling Party 1 Presentation Indicator to Restricted .
    • in step 7, verify the mobile station does not display the CPN and that it indicates the CPN is restricted.
    • in step 9, verify that the test set sends an Alert With Information Message with the Calling Party Number information record with the PI field set to '01' (Presentation Restricted).
  11. Repeat steps 4 through 9, except that
    • in step 4, set the Calling Party 1 Presentation Indicator to Number Not Avail .
    • in step 7, verify the mobile station does not display the CPN and that it indicates the CPN is not available.
    • in step 9, verify that the test set sends an Alert With Information Message with the Calling Party Number information record with the PI field set to '10' (Number Not Available).

Related Topics

Calling Party Number Parameters


How Do I Perform Call Waiting Test?

How Do I Perform Call Waiting Test?

Last updated: June 12, 2007

This section is only applicable to the lab application.

There are two typical test scenarios using Call Waiting functionality in the test set which are specified in 3GPP2 C.S0043-0 Version 1.0. These two scenarios verify all possible state transitions described in Call Waiting State Transition .

  • Test scenario 1 is to simulate switching the voice call between two calling parties.
  • Test scenario 2 is to simulate rejecting the second call when the test set has been in a voice call.

The procedures are detailed below:

Call Waiting Test Scenario 1

  1. Press the Call Setup key.

  2. Verify that the Operating Mode ( F1 ) is set to Active Cell and the System Type ( F2 ) is set to IS-2000 or IS-95 .

  3. Press the FCH Service Option Setup ( F12 ) key and set a voice service option (such as SO1, SO3, SO17, SO68, or SO32768) for the current radio configuration.

  4. Press the More key on the lower left side of the test set until 5 of 5 of the call control menu is displayed.

  5. Press the F3 ( Call Waiting Info ), then press the F1 ( Calling Party Number Parms ). The Calling Party Number Parameters menu is displayed. See Parameters Description for parameter setting instruction.

    • Set the Calling Party Number Inclusion to Include .

    • Leave other settings to the default values. You also can change them if desired.

      NOTE
      Don't set the calling party 1 and calling party 2 to the same values, otherwise. the setting will be rejected with an error posted.

  6. (Optional) To capture a protocol log for further analysis, start a capture in the Wireless Protocol Advisor (WPA) software (see Protocol Logging ) and then perform the following steps.

  7. Press the Originate Call ( F3 ) to establish a voice call between calling party 1 and the MS. The first voice call between MS and test set is always bound to calling party 1, no matter the call is originated from MS or test set. Check for Connected in the Active Cell status field, it should be always in connected status during the Call Waiting test. And the Calling Party 1 Status is changed to Active .

  8. Press the Connect Calling Party 2 ( F5 ) to inform the MS that there is a waiting call. Now the Calling Party 2 Status is changed to Waiting .

  9. If you start a WPA capture in step 5, verify that the test set sends a Flash With Information Message or an Extended Flash With Information Message (only applicable to protocol revision 7 and above) with CALL_WAITING_INDICATOR field set to `1' to inform the MS that there is a waiting call to be answered.

  10. Press the SEND button (normally in green color) on MS to put calling party 1 on hold and connect to calling party 2. Now the Calling Party 1 Status is changed to Waiting and the Calling Party 2 Status is changed to Active .

  11. Verify that a voice path is established between the MS and calling party 2.

  12. Press the SEND again on MS to put calling party 2 on hold and reconnect the voice path with calling party 1. Now the Calling Party 1 Status is changed to Active and the Calling Party 2 Status is changed to Waiting again.

  13. Press the Disconnect Calling Party 1 ( F4 ) to end the call with calling party 1. The Calling Party 1 Status is changed to Idle .

  14. Verify that the voice path is mute since there no active calling party.

  15. Press the SEND again in the MS. Verify that an voice path is established between the MS and calling party 2. Now the Calling Party 2 Status is changed to Active .

  16. Press the Connect Calling Party 1 ( F4 ) to inform the MS that there is a waiting call. Now the Calling Party 1 Status is changed to Waiting .

  17. Press the End Call (F3) to end the call with two calling parties. Check for Idle in the Active Cell status field and the Call Waiting Status field.

Calling Party Test Scenario 2

  1. Perform steps 1 through 9 as described in Calling Party Test Scenario 1 procedure.

  2. Do not answer this call at the MS. Press the Disconnect Calling Party 2 ( F5 ) to disconnect call from calling party 2. The Calling Party 2 Status is changed to Idle .

  3. If you start a WPA capture, verify that the test set sends a Flash With Information Message or an Extended Flash With Information Message with CALL_WAITING_INDICATOR field set to `0' to inform the MS that the waiting call has gone away.

Related Topics

CALL:CPNumber

CALL:SSERvice:WAITing

Call Waiting

Calling Party Number Parameters

Call Waiting Parameters

Call Waiting State Transition


How Do I Set Up Data Channel Parameters?

How Do I Set Up Data Channel Parameters?

Last updated: November 10, 2006

This section is only applicable to the lab application.

  1. Press the CALL SETUP key.
  2. Press the More key on the left side of the display 3 of 3 is displayed.
  3. Press the Data Channel Info ( F2 ) key.
  4. Press the Data Channel Parameters (F1 ) key.

Data Channel Parameters

Related Topics

Data Channel Parameters


How Do I Use the Data Throughput Monitor?

How Do I Use the Data Throughput Monitor?

Last updated: October 29, 2004

This section is only applicable to the lab applications.

Description

The following procedure illustrates typical usage of the data throughput monitor.

Accessing the Monitor Controls

  1. Press the Instrument selection key.
  2. Select Data Throughput Monitor .

    The data throughput monitor is displayed with the default settings as shown above. The Swap Window Positions ( F5 ) is displayed only when another measurement or instrument is active.

    Once the data throughput monitor is selected, it can be accessed by pressing the MEASUREMENT key, followed by the Swap Window Positions ( F5 ) key if necessary.

  3. Set the axis control as needed for your testing situation using the Axis Control ( F1 ) key to access the Time Span ( F1 ), Start Data Rate ( F2 ) Stop Data Rate ( F3 ) keys. For example, if you expect data rates to exceed the default value of 100 kbps, press the ( F1 ) key followed by the ( F3 ) key and enter a new value in the Stop Data Rate field using the DATA ENTRY keys.
  4. Press the Return ( F6 ) key to exit the Axis Control menu.
  5. Select the traces you would like to display by pressing the Trace Control ( F2 ) key followed by the Trace Display ( F1 ) key. To select a trace, turn the value to On. There are four color-coded traces and any combination can be selected:
    • OTA Tx - (Over The Air Transmitted bits-per-second). This is the rate of link-layer bit transfer sent from the wireless device. In other words, OTA translates into RLP (Radio Link Protocol) in cdma2000, or RLC (Radio Link Control) protocol in WCDMA and GPRS, or PPP in GSM. Tx refers to the reverse or uplink channel direction.
    • OTA Rx - (Over The Air Received bits-per-second). This is the rate of link-layer bit transfer received by the wireless device. In other words, OTA translates into RLP (Radio Link Protocol) in cdma2000, or RLC (Radio Link Control) protocol in WCDMA and GPRS, or PPP in GSM. Rx refers to the forward or downlink channel direction.
    • IP Tx - Internet Protocol Transmitted. This is the rate of network-layer bit transfer sent by the wireless device. Tx refers to the reverse or uplink channel direction.
    • IP Rx - Internet Protocol Received. This is the rate of network-layer bit transfer received by the wireless device. Rx refers to the forward or downlink channel direction.

    By default, the OTA Tx and OTA Rx traces are the only traces turned on.

  6. Press the Return ( F6 ) key to exit the Trace Control menu.

  7. Establish a data connection with the mobile.

    The Data Throughput Monitor will begin displaying numerical and graphical information. The numerical information pertains to the period of time beginning with the establishment of the first data connection, and the graphical traces represent up to 600 seconds of the latest data throughput statistics.

  8. Set a marker.

    Using the Trace Control menu, select a marker by pressing the corresponding F2 , F3 , F4 , or F5 keys followed by the Data Entry key labeled ON.

    Press the Return ( F6 ) key.

    After allowing the monitor to accumulate throughput for at least one minute, change the Time Span to 50 seconds (see step 3 above). This will expand the graphical view to improve resolution.

    Press the Return ( F6 ) key.

  9. Freeze the graph.

    Press the Freeze Graph (F4) key.

    Turn the knob to adjust the position of the marker. Marker results will be displayed in the summary table

  10. Press the Return ( F6 ) key to exit the Trace Control menu.
  11. Press the Resume Graph ( F4 ) key to display the most recent trace data.
  12. Press the Clear Graph ( F3 ) key to reset the traces and the numeric counters.

Changing Data Rates

Data throughput can be analyzed under various call processing and RF conditions. This section illustrates the steps required to change data rates.

It is assumed that the data throughput monitor is displayed and a data call is connected.

  1. Press the CALL SETUP key.
  2. Change the data rate (see Related Topics).
  3. Press the MEASUREMENT key.

Related Topics

How Do I Set Up Data Channel Parameters?


How Do I Perform FPC Test (FPC Mode 000)?

How Do I Perform FPC Test (FPC Mode 000)?

Last updated: November 5, 2004

This section is only applicable to the lab application.

  • General Procedure for FPC Operation (FPC_Mode 000)
  • Testing 3.4.7 Demodulation of Forward Traffic Channel in Multipath Fading Channel with Closed Loop Power Control (FPC_MODE = '000')
  • Testing 3.4.9 Demodulation of Forward Traffic Channel in Multipath Fading Channel with Outer Loop Power Control and Closed Loop Power Control (FPC_MODE = `000')

General Procedure for FPC Operation (FPC_Mode 000)

Step 1: Access FPC Info menus

  1. Press the Call Setup key.
  2. Press the left-side of More key until the Call Control 4 of 4 menu is displayed.
  3. Select the Forward Power Control ( F2 ). The FPC Info menu is displayed and all of the parameters and operations relating to forward power control can be accessed.

Step 2: Set up FPC Mode

  1. On FPC Info 1 of 2 , press the F3 ( FPC Mode ).
  2. Set the FPC Mode to 000-Primary 800 .

Step 3: Set up FPC Parameters

  1. On FPC Info 1 of 2 , press the F1 ( FPC Parameters ).
  2. Set the following parameters as desired. For example,
    • Set the Maximum F-FCH Level to -3 dB .
    • Set the F-FCH Target FER to 1.0% .
    • Set the F-FCH Initial Setpoint to 8 dB .
    • Set the F-FCH Minimum Setpoint to 2 dB .
    • Set the F-FCH Maximum Setpoint to 16 dB .
    • Set the F-FCH Step Size to 0.5 dB .
  3. Press the F6 ( Close Menu ).

NOTE
Some of these parameters (such as target FER, minimum/maximum setpoint, etc. see FPC Parameters for details) can also be changed after a call has been established (after step 5).

Step 4: Set up code channel levels

  1. If required, follow the procedure of How Do I Change Generator Information? and set the F-Pilot Level, F-FCH Level to the desired.

Step 5: Establish a call

  1. Establish a call in radio configuration (Fwd3, Rvs3) or above with loopback service option (such as SO2, 9, or 55). See How Do I Set Up a Call? for detailed procedure.

Step 6: Set up cell power, multi-path fading and external AWGN

To generate faded forward channel signals with AWGN, the test set requires a rear panel digital bus connecting to an external PC running Baseband Studio software. For detailed setup and operating instructions pertaining to faded signal generation, refer to Digital Bus Information .

Step 7: Request the Outer Loop Report from MS

  1. On FPC Info 1 of 2 , press the F4 ( Request Outer Loop Report ).
  2. Observe the MS reported F-FCH current setpoint (Eb/Nt) value on the Inner/Outer Loop Power Control Information window.

Step 8: Set up MS Reported FER

  1. On FPC Info 1 of 2 , press the F2 ( MS Reported FER Parms ).

  2. To make a periodic-based FER reporting from MS, set the following parameters:

    • Set the Frame Interval of Report (Frames) to the desired value (for example, 640 )
    • Set Periodic Report Enable to On .

    To make a threshold-based FER reporting from MS, set the following parameters:

    • Set the Bad Frame Threshold (Frames) to the desired value (for example, 3)
    • Set the Threshold Report Enable to On .

  3. Press the F6 ( Close Menu ).
  4. Observe the MS Reported Frame Error Rate Information window. You will see the value of the MS Reported FER will be updated either periodically or when the detected bad frames exceeds the specified threshold.

Step 9: Initiate Frame Error Rate measurement

To make a more accurate evaluation on the performance of the MS FPC, perform the Frame Error Rate measurement. Follow the general procedure of Measuring Frame Error Rate (FER) and set the parameters as required for your test.

Step 10: Repeat steps 6 - 9

  1. Repeat steps 6 -8, change the cell power, external AWGN power and channel simulator configuration and then observe the measurement results.

Step 11: (Optional) Clear the MS reported results

  1. To clear the MS reported outer loop report results shown on the Inner/Outer Loop Power Control Information window:

    • On FPC Info 2 of 2, press the F2 ( Clear Outer Loop Report ).

    To clear the MS reported FER results shown on the MS Reported Frame Error Rate Information window:

    • On FPC Info 2 of 2, press the F3 ( Clear MS Reported FER ).

Testing 3.4.7 Demodulation of Forward Traffic Channel in Multipath Fading Channel with Closed Loop Power Control (FPC_MODE = '000')

This test requires faded signals with AWGN, which the test set must be equipped with a rear panel digital bus connecting to an external PC running Baseband Studio software. See Digital Bus Information for details.

This test examines the performance of forward power control by measuring the differences between the mobile station's received FER and the assigned target FER while not exceeding the specified Traffic Eb/Nt limits. This test will be performed on F-FCH (20 ms frame). The test set does not support tests on F-DCCH.

To perform the tests as specified in the standard, follow the procedures as describe in the General Procedure for FPC Operation (FPC_Mode 000) and change some settings per standard requirements. An example settings required for test 4 of 3.4.7 test is given in Settings required to change for test 4 of 3.4.7

Settings required to change for test 4 of 3.4.7

Settings Specified in the Standard

Equivalent Settings on the Test Set

Parameters

Values

Step 2: Set up FPC Mode

FPC_MODE | 000 | Set FPC Mode to 000-Primary 800 .

Step 3: Set up FPC Parameters

Maximum F-FCH Ec/Ior (dB) | -3 | Set the Maximum F-FCH Level to -3.00 dB .
FPC_FCH_FER (%) | 1 | Set the FPC F-FCH Target FER to 1% .

FPC_FCH_INIT_SETPT

10.3
(assuming US PCS band is used)

Set the FPC F-FCH Initial Setpoint to 10.3 dB .

Set the FPC F-FCH Minimum Setpoint to 10.3 dB .

Set the FPC F-FCH Maximum Setpoint to 10.3 dB .

Note that setting the initial/minimum/maximum setpoints to the same value will effectively disable the outer loop power control. This also indicates the current outer loop Eb/Nt setpoint will be fixed to the 10.3 dB.

FPC_FCH_MIN_SETPT

10.3
(assuming US PCS band is used)

FPC_FCH_MAX_SETPT

10.3
(assuming US PCS band is used)
PWR_CNTL_STEP (dB)

0.5

Set the FPC F-FCH Step Size to 0.5 dB .

Step 4: Set up code channel levels

Pilot Ec/Ior (dB)

-7

Set the Cell 1 F-Pilot Level to -7.00 dB. Note that the default setting on the test set is -7 dB.

Traffic Ec/Ior (dB)

-14.8 (for Band class 1- US PCS)

Set the Cell 1 F-F-FCH/Trffic Level to -14.8 dB.

Step 6: Set up cell power, multi-path fading and external AWGN

On the test set,

  • Set the Cell 1 Power to -55 dBm/1.23 MHz. Note that Î or /Ioc is the ratio of Cell Power to AWGN equal to 4 dB. Since the Ioc is the value of AWGN equal to -59 dBm/1.23 MHz) so the Cell Power is the value of (Ioc + Ior/Ioc) equal to -55 dBm/1.23 MHz.

On the external channel simulator,

  • Set the multi-path fading simulation as specified in standard channel simulator configuration 3.
  • Set the external AWGN to -59 dBm/1.23 MHz.

For detailed setup and operating instructions pertaining to faded signal generation, see Digital Bus Information .

Step 9: Initiate Frame Error Rate measurement

On the Frame Error Rate Setup menu,

  • Set the Confidence Level to 95%.
  • Set the FER Requirement to 1.5% (change the setting as required for your test).
  • Set the Eb/Nt Limit to 10.8 dB (change the setting as required for your test).
  • Set the Minimum Frame Count to 350 frames (change the setting as required for your test).

Testing 3.4.9 Demodulation of Forward Traffic Channel in Multipath Fading Channel with Outer Loop Power Control and Closed Loop Power Control (FPC_MODE = `000')

This test requires faded signals with AWGN, which the test set must be equipped with a rear panel digital bus connecting to an external PC running Baseband Studio software. See Digital Bus Information for details.

This test examines the performance of slow power control (outer loop power control) by checking the average Traffic Eb/Nt at the test set under a given frame error constraint and channel simulator configuration. This test will be performed on F-FCH (20 ms frame) in FPC mode 000. The test set does not support tests on F-DCCH

To perform the tests as specified in the standard, follow the procedures as described in the General Procedure for FPC Operation (FPC_Mode 000) and change some settings per standard requirements. An example settings required for test 5 of 3.4.9 test is given in Settings required to change for test 5 of 3.4.9

Settings required to change for test 5 of 3.4.9

Settings Specified in the Standard

Equivalent Settings on the Test Set

Parameters

Values

Step 2: Set up FPC Mode

FPC_MODE | 000 | Set FPC Mode to 000-Primary 800.

Step 3: Set up FPC Parameters

Maximum F-FCH Ec/Ior (dB) | -3 | Set the Maximum F-FCH Level to -3.00 dB .
FPC_FCH_FER (%) | 1 | Set the FPC F-FCH Target FER to 1% .

FPC_FCH_INIT_SETPT (dB)

6
(assuming US PCS band is used)

Set the FPC F-FCH Initial Setpoint to 6 dB .

FPC_FCH_MIN_SETPT (dB)

0
(assuming US PCS band is used)

Set the FPC F-FCH Minimum Setpoint to 0 dB .

FPC_FCH_MAX_SETPT (dB)

31.875
(assuming US PCS band is used)

Set the FPC F-FCH Maximum Setpoint to 31.875 dB .
PWR_CNTL_STEP (dB)

0.5

Set the FPC F-FCH Step Size to 0.5 dB .

Step 4: Set up code channel levels

Pilot Ec/Ior (dB)

-7

Set the Cell 1 F-Pilot Level to -7.00 dB. Note that the default setting on the test set is -7 dB.

Traffic Ec/Ior (dB)

-16.88 (for Band class 1- US PCS)

Set the Cell 1 F-F-FCH/Trffic Level to -16.88 dB.
It is set based on the formula of

which corresponds to the situation of channel simulator configuration 1, FCH Eb/Nt = 6 dB (for test 5, Band Class 1), FCH_CHip_Bit = 1228800/9600, Î or /Ioc = 8 dB.

Step 6: Set up cell power, multi-path fading and external AWGN

On the test set,

  • Set the Cell 1 Power to -55 dBm/1.23 MHz. Note that Î or /Ioc is the ratio of Cell Power to AWGN equal to 8 dB. Since the Ioc is the value of AWGN equal to -63 dBm/1.23 MHz) so the Cell Power is the value of (Ioc + Ior/Ioc) equal to -55 dBm/1.23 MHz.

On the external channel simulator,

  • Set the multi-path fading simulation as required in standard channel simulator configuration 1.
  • Set the external AWGN to -63 dBm/1.23 MHz.

For detailed setup and operating instructions pertaining to faded signal generation, see Digital Bus Information .

Step 9: Initiate Frame Error Rate measurement

On the Frame Error Rate Setup menu,

  • Set the Confidence Level to 95%.
  • Set the FER Requirement to 1.5% (change the setting as required for your test).
  • Set the Eb/Nt Limit to 6.5 dB (change the setting as required for your test).
  • Set the Minimum Frame Count to 500 (change the setting as required for your test).

Related Topics

Forward Power Control


How Do I Perform EIB Test (FPC Mode 011)?

How Do I Perform EIB Test (FPC Mode 011)?

Last updated: October 28, 2004

This section is only applicable to the lab application.

Step 1: Access Forward Power Control menus

  1. Press the Call Setup key.
  2. Press the left-side of More key until the Call Control 4 of 4 menu is displayed.
  3. Select the Forward Power Control ( F2 ). The FPC Info menu is displayed and all of the parameters and operations relating to forward power control can be accessed.

Step 2: Set up FPC Mode

  1. On FPC Info 1 of 2 , press the F3 ( FPC Mode ).
  2. Set the FPC Mode to 011-EIB .

Step 3: Establish a call

  1. Establish a call in radio configuration (Fwd3, Rvs3) or above with loopback service option (such as SO2, 9, or 55). See How Do I Set Up a Call? for detailed procedure.

Step 4: Set up F-FCH Frame Pattern

  1. Press the right-side of More key until the Call Parms 4 of 4 menu is displayed.
  2. On Call Parms 4 of 4 , press the F9 ( F-FCH Frame Pattern Setup ).
  3. On the F-FCH/Traffic Frame Pattern Setup menu, set the following parameters as desired. For example,
    • Set the F-FCH/Traffic Frame Pattern Good Frames to 50 (or other values as desired).
    • Set the F-FCH/Traffic Frame Pattern Bad Frames to 50 (or other values as desired).
    • Set the Signaling Frame Quality to Good-Ignore Frame Pattern .
    • Set the F-FCH/Traffic Frame Pattern State to On .
    • Press the F6 ( Close Menu ).

      The test set starts to send a sequence of good and bad frames (alternating 50 good and 50 bad 20 ms frames in this example) to the mobile station on the F-FCH.

      NOTE
      It is expected there is no signaling message sent during forward power control EIB test. Otherwise, the Signaling Frame Quality setting may have impact on the EIB test result. See Signaling Frame Quality for details.

Step 4: Start the EIB test

  1. On FPC Info 1 of 2 , press the F5 ( Start EIB Counters ). The test set starts to check the received EIBs reported from the mobile station against the corresponding frames sent from the test set to the mobile station and keep a record of matched/not matched/not received good/bad frames).

Step 5: Observe the MS Reported EIB results

  1. Observe the MS Reported Erasure Indicator Bit (EIB) Information window and verify how many good/bad frames sent from the test set are matched with the frames received by the mobile station base on the MS reported EIBs. See MS Reported Erasure Indicator Bit (EIB) Information for details.
  2. (Optional) Change the Cell 1 Power, or add the AWGN power, you will see the number of not matched frames may increase.

Step 6: Stop the EIB test

  1. On FPC Info 1 of 2 , press the F5 ( Stop EIB Counters ). The test set stops to record the matched/not matched/not received good/bad frames.

Step 7: (Optional) Clear the EIB Counters

  1. To clear the EIB test results shown on the MS Reported Erasure Indicator Bit (EIB) Information window:

    • On FPC Info 2 of 2, press the F4 ( Clear EIB Counters ).

Related Topics

Forward Power Control


How Do I Perform a Graphical Access Probe Power Measurement?

How Do I Perform a Graphical Access Probe Power Measurement?

Last updated: October 28, 2004

This section is only applicable to the lab application.

A. Register the Mobile Station.

  1. Connect the mobile station to the test set's front panel RF IN/OUT connector and power it on.
  2. Wait for the mobile station to perform a power-up registration after it has found service. When a registration has completed, the Mobile Reported Information window will display the registration data received from the mobile station.
  3. If the mobile station does not automatically registered, perform the procedures (see How Do I Set Up a Call? , but pressing the Register the mobile ( F5 ) instead of the Originate Call (F3 ) key).

B. Turn Timer-Based Registration Off.

  1. Press the CALL SETUP key.
  2. Press the More key on the left side of the display until 2 of 3 is displayed.
  3. Press the Cell Info (F2) key.
  4. Press the Registration Parameters (F4) key.
  5. Select Off from the Timer Based Registration State menu.

C. Turn Call Limit On.

  1. Press the More key on the right side of the display until 2 of 3 is displayed.
  2. Press the Call Limit Mode (F11) key.
  3. Select On from the Call Limit Mode menu.

D. Set Up Access Probe Power Parameters.

  1. Press the Measurement selection key.
  2. Scroll down the menu and select Graphical Access Probe Power from the list.
  3. Press the Graphical Access Probe Pwr Setup (F1) key.
  4. Set up test parameters.
  5. Press the Close Menu (F6) key

E. Arm the Measurement

  1. Press the Start Single key.

F. Page the Mobile Station

  1. Press the More key on the left side of the display until 2 of 2 is displayed
  2. Press the Originate Call (F3 ) key to page the mobile station.

G. Set Up the Graphical View

  1. Press the More key on the left side of the display until 1 of 2 is displayed
  2. Press the Graph Control (F2 ) key.
  3. Set up the Graph Start Time (F3 ) and Graph Span (F5 )
  4. Set up the Marker Position (F2 key)
  5. Press the Marker Mode (F1 ) key, select Delta. Then press the Marker Delta (F2) k ey and adjust the marker position.

Related Topics

Graphical Access Probe Power Measurement Description


Enabling the HTTP Interface

Enabling the HTTP Interface

Last updated: June 20, 2006

This section is only applicable to the lab application.

This section contains the following:

  • Enabling the HTTP Interface for Mobile Terminated SMS
  • Enabling the HTTP Interface for Mobile Originated SMS

Enabling the HTTP Interface for Mobile Terminated SMS

  1. Press the Call Setup key to access the Call Setup screen.
  2. Go to menu ( 4 of 5 ) of the Call Control menu by pressing the More key on the lower left corner of the test set.
  3. Select Short Message Service by pressing the softkey F5 .
  4. Go to SMS Control 2 to 2 , then select HTTP Setup ( F4 ). The SMS HTTP Setup menu appears.
  5. Select HTTP SMS Input State . The Input State menu appears.
  6. Select On .

Enabling the HTTP Interface for Mobile Originated SMS

  1. Press the Call Setup key to access the Call Setup screen.
  2. Go to menu ( 4 of 5 ) of the Call Control menu by pressing the More key on the lower left corner of the test set.
  3. Select Short Message Service by pressing the softkey F5 .
  4. Go to SMS Control 2 to 2, then select HTTP Setup ( F4 ). The SMS HTTP Setup menu appears.
  5. Select HTTP SMS Output State . The Output State menu appears.
  6. Select On .

Related Topics

HTTP Interface Configuration for Mobile Terminated SMS


How Do I Make Hybrid Mode AT/MS Tests?

How Do I Make Hybrid Mode AT/MS Tests?

Last updated: November 10, 2006

This section is only applicable to the lab applications.

  • General Procedure
  • Specific Procedures for Recommended Tests

General Procedure

  1. Make sure you have finished the pre-requisite setups, especially ensure that the two test sets are synchronized on CDMA system time. For details, see Prerequisite Setup .
  2. Set up the test set #1 running the E6702B cdma2000 lab application to allow the hybrid mode AT/MS to acquire the IS-2000 or IS-95 system successfully. In the following example, IS-2000 system is used.
    • Set the Cell Band ( F8 on Call Parms 1 of 3 ) and Channel ( F9 on Call Parms 1 of 3 ) to match your AT/MS's configuration for IS-2000 system.
    • Set the SID (from Call Control 2 of 4 , F2 Cell Info , F2 Cell Parameters ) for your AT/MS if required.
    • Set the Cell Power ( F7 on Call Parms 1 of 3 ) to a proper value (for example, -50 dBm/1.23 MHz ).
    • Set all other parameters to the default values (for example, Active Cell operating mode, IS-2000 system type, etc.).
  3. Set up the test set #2 running the E6706A 1xEV-DO lab application to allow the hybrid mode AT/MS to acquire the IS-856 system successfully.
    • Set the Cell Band ( F8 on Call Parms 1 of 3 ) and the Channel ( F9 on Call Parms 1 of 3 ) to match your AT/MS's configuration for IS-856 system. Note that the RF frequency determined by bands and channels for IS-856 system must be different from that of the IS-2000/IS-95 system.
    • Set the Session Application Type to Default Packet Application (from Call Parms 1 of 3 , F10 Application Config ).
    • Set the Preferred Control Channel Cycle Control to AT Specified (from Call Control 2 of 3 , F2 Access Network Info , F1 Configurable Attribute Ctrl ). This allows the AT/MS to propose the PCCC value during the session negotiation to guarantee that the preferred 1xEV-DO control channel cycle offset does not overlap in time with the CDMA paging channel slot that the AT/MS is required to use.
    • Set the Cell Power ( F7 on Call Parms 1 of 3 ) to a proper value (for example, -50 dBm/1.23 MHz ).
    • Set the Session Close ( F12 on Call Parms 2 of 3 ) to a larger value (see Session Close ) as required.

      NOTE
      To prevent the session from unexpected closing when the AT stays on the test set #1 (for example, a voice call) longer than the default value (3 minutes), it is recommended to set the Session Close to a larger value prior to perform the tests 5 - 10 as shown on Specific Procedures for Recommended Tests .

    • All other parameters can be set to the default value (for example, Active Cell operating mode, IS-856 system type, etc.).
  4. (Optional) If you would like to log the protocol messages exchanged between the test sets and the hybrid mode AT/MS, set up the Wireless Protocol Advisor (WPA) and start logging. See Protocol Logging for details.
  5. Power up the hybrid mode AT/MS and verify that AT/MS first acquires and registers on the IS-2000 system (test set #1), and then acquires and opens a session on the IS-856 system (test set #2).

    On test set #1, you will see the hybrid mode AT/MS's reported registration data is shown in the Mobile Station Information window. The test set # 1 goes to idle state.

    On test set #2, you will see that the hybrid mode AT/MS establishes an open session on IS-856 system and is assigned a UATI. The AT/MS related information is shown on the Access Terminal Information windows.

    NOTE
    Most ATs will immediately initiate a session once they reach the idle state upon power-up. So you will see Session Open state is always shown on the test set #2 when the hybrid mode AT/MS has successfully negotiated with the IS-856 system (1xEV-DO).

  6. When the hybrid mode AT/MS has successfully acquired both systems, you are ready to perform the following recommended tests.

Specific Procedures for Recommended Tests

NOTE
Prior to performing the tests, you should verify that:

  • the test set #1 (CDMA) can provide voice and SMS services.
  • the packet data services can be provided by both test set #1 (CDMA) and test set #2 (1xEV-DO) but the precedence is given to test set #2. That is, the packet data session is established on test set #2 (1xEV-DO) while both 1xEV-DO and CDMA signal exist. Only when the 1xEV-DO signal (test set #2) is unavailable the packet data session is established on test set #1 (CDMA) if properly set up.

Perform the following procedures to make the functional tests of the hybrid mode AT/MS as recommended by Qualcomm®.

  1. Make sure that the hybrid mode AT/MS has successfully acquired both test sets, registered on the test set #1 (CDMA) and opened a session on the test set #2 (1xEV-DO). If not, perform the General Procedure .

  2. Follow the instructions as described in the table below to perform the recommended tests that are supported by the test sets. These tests can be broadly divided into three categories:

    • The tests 1 - 4 are to verify that the hybrid mode AT/MS can acquire both the IS-2000/IS-95 (cdma2000) and the IS-856 (1xEV-DO) systems, and perform dual-idle monitoring of the paging channel of the IS-2000/IS-95 system and the control channel of the IS-856 system concurrently.
    • The tests 5 - 20 are to verify that the hybrid mode AT/MS can support services on both the IS-2000/IS-95 and IS-856 systems.
      • The tests 5 - 10 are to verify that the AT/MS can initiate/accept a voice call on the IS-2000/IS-95 system while in an active/dormant packet data connection or in idle state on the IS-856 system.
      • The tests 11 - 16 are to verify that the AT/MS can initiate/accept SMS services on the IS-2000/IS-95 system while in an active/dormant packet data connection or in idle state on IS-856 system.
      • The tests 17 - 20 are to verify that the AT/MS can establish a packet data connection on the IS-856 system, or on the IS-2000 system when IS-856 system is unavailable.
    • The tests 21- 28 are related to the MIP operations of the hybrid mode AT/MS.
      • The tests 21 - 24 are to verify that the hybrid mode AT/MS can handoff the packet data connection between the IS-856 and IS-2000 system while using the AT/MS in MIP.
      • The tests 25 - 28 are to verify the fundamental MIP operations. For example, connect a MIP call using static or dynamic home IP address, perform a MIP to SIP fallback if MIP registration fails, etc.

    For details on these tests' definitions, see Recommended Functional Tests for Hybrid Mode AT/MS .

    Instructions for Recommended Test Cases
    Test No. Instructions

    1

    To verify that the hybrid mode AT/MS periodically (based on the Slot Cycle Index) tunes away to IS-2000/IS-95 system for monitoring its paging channel slot while having an open session on IS-856 system:

    • Make sure that the Timer Based Registration State is set to On on the test set #1.
    • Verify that the AT/MS makes registrations on test set #1 periodically which indicates the AT/MS will monitor the paging channel slot while having an open session on IS-856 system. This can be observed from the updated registration data in the Mobile Station Information window.

    2

    To verify that the hybrid mode AT/MS enters 1xEV-DO power save mode after failing to acquire a 1xEV-DO system:

    • On test set #2, press the Close Session ( F7 on Call Parms 1 of 3 ) to close the current open session (go to Idle state), and then set the Cell Power ( F7 on Call Parms 1 of 3 ) to Off to simulate that the 1xEV-DO system is unavailable.
    • You should see that the hybrid mode AT/MS can not automatically re-open a session and the test set # 2 stays at Idle state.

    3

    To verify that the hybrid mode AT/MS always proposes an appropriate PCCC during the session negotiation:

    • Change the AT/MS's MIN using your specific service programming tool. You can not change the MIN from the test set. The PCCC value varies based on the MIN of the hybrid mode AT/MS.
    • Observe the Access Network Information screen on the test set #2. You should see that the Preferred Control Channel Cycle Control value proposed by hybrid mode AT/MS is changed along with the change of the MIN and is updated after a successful session negotiation. The session is then successfully re-opened again.

    4

    To verify the hybrid mode AT/MS's behavior when it moves to a location where no 1xEV-DO signal is available but a good CDMA signal is available, and when it moved back where both signals were available:

    • On test set #2, press the Close Session ( F7 on Call Parms 1 of 3 ) to close the current open session, and then set the Cell Power ( F7 on Call Parms 1 of 3 ) to Off to simulate that the 1xEV-DO system is unavailable.
    • You should see that the hybrid mode AT/MS can not automatically re-open a session and the test set # 2 stays at Idle state.
    • On test set #2, set the Cell Power ( F7 on Call Parms 1 of 3 ) back to -50 dBm to simulate that the 1xEV-DO signal is available again.
    • Wait for a while, you should see that the AT/MS will re-acquire the 1xEV-DO system and open a session on the test set #2.
    • The hybrid mode AT/MS remains registered on the test set #1 during above operations.

    To verify the hybrid mode AT/MS's behavior when it moves to a location where no CDMA signal is available but a good 1xEV-DO signal is available, and when it moved back where both signals were available:

    • On test set #1, set the Cell Power ( F7 on Call Parms 1 of 3 ) to Off to simulate that the CDMA signal is unavailable.
    • On test set #1, press the Clear MS Capabilities & Info ( F5 on Call Control 2 of 5 ) to clear the AT/MS's last registration data in the Mobile Station Information window.
    • On test set #1, press Register Mobile ( F5 on Call Control 1 of 5 ) to force the hybrid mode AT/MS to make a registration.
    • The Mobile Station Information window on test set #1 should remain empty because AT/MS can not register to the CDMA system (no CDMA signal is available).
    • On test set #1, set the Cell Power ( F7 on Call Parms 1 of 3 ) back to -50 dBm to simulate that the CDMA signal is available again. The hybrid mode AT/MS will try to register on the test set #1 and the registration data will be shown on the Mobile Station Information window.
    • The hybrid mode AT/MS remains keeping an open session on the test set #2 during above operations.

    5

    To verify that the hybrid mode AT/MS can originate CDMA voice calls in dual-idle state, make an AT/MS originated voice call. The key steps include:

    • On test set #1, set the service option for the radio configuration in which you would like to bring up the call to a voice service option. For example, SO3 is configured for the Radio Config (Fwd 3, Rvs 3) .
    • Originate a voice call from the AT. For example, entering a phone number and pressing SEND on the AT.
    • When the voice call is successfully established, Connected is shown on the test set #1. During the above operations, the test set #2 remains keeping an open session with the AT.
    • Terminate the voice call from the AT/MS (for example, press the End on the AT) or from the test set by pressing the End Call ( F3 on Call Control 1 of 5) . When the voice call is successfully ended, test set #1 returns to Idle state. During the above operations, the test set #2 remains keeping an open session with the AT/MS.

    For details on how to make a CDMA voice call, see Related Topics .

    6

    To verify that the hybrid mode AT/MS can originate CDMA voice calls while in CDMA idle and 1xEV-DO dormant state, perform the following procedure:

    • Originate a packet data call from the AT/MS to the test set #2. See Related Topics for an example procedure which uses the AT/MS as wireless modem for a packet data connection. The example procedure varies depending upon your data applications.
    • When a packet data connection is successfully established, Connected is shown on the test set #2.
    • On test set #2, press the F2 ( Force Dormant ) on the Call Control 1 of 3 menu to make the AT/MS go dormant. You should see that the test set #2 displays Dormant state.
    • Follow the procedure for test 5 to make an AT/MS originated voice call. Verify that the voice call is successfully connected on the test set #1. Any data transfer is not allowed while during a voice call. The test set #2 remains at Dormant state during voice call operations. Only when the voice call is ended, the data transfer can be re-started on the test set #2 if there is data to send.

    7

    To verify that the hybrid mode AT/MS can originate CDMA voice calls while in CDMA idle and connected 1xEV-DO state, the procedure is similar to that of 6 except that:

    • You do not need to make the AT/MS go dormant before originating a voice call.
    • Originate a voice call from the AT/MS while in an active 1xEV-DO packet data connection.
      Verify that the current packet data connection will go dormant on the test set #2 when a voice call is connected on the test set #1. Any data transfer is not allowed while during a voice call. The test set #2 remains at Dormant state during a voice call. Only when the voice call is ended, the packet data connection will re-established on test set #2 if there's data to transmit (for example, start a ping session). For details on a Ping procedure, see Related Topics .

    8

    To verify that the hybrid mode AT/MS can receive CDMA voice pages in dual-idle state, the procedure is similar to that of the test 5 except that the voice call is originated from the test set #1 instead of from the AT/MS:

    • Press the Originate Call ( F3 on Call Control 1 of 5 ) to page the AT/MS from the test set #1. When the AT/MS answers the voice page, the voice call is connected and the test set #1 displays Connected state. The AT/MS remains keeping an open session with the test set #2 during the voice call operation.

    9

    To verify that the hybrid mode AT/MS can receive CDMA voice pages while in 1xEV-DO dormant state, the procedure is similar to that of the test 6 except that the voice call is originated from the test set #1 instead of from the AT/MS:

    • Press the Originate Call ( F3 on Call Control 1 of 5 ) to page the AT/MS from the test set #1. When the AT/MS answers the voice page, the test set #1 goes to Connected state. The AT/MS remains dormant on the test set #2 during a voice call. Any data transfer is not allowed while during a voice call. Only when the voice call is ended, the packet data connection can re-established on test set #2 if there's data to transmit.

    10

    To verify that the hybrid mode AT/MS can receive CDMA voice pages in 1xEV-DO connected state, this procedure is similar to the procedure of the test 7 except that the voice call is originated from the test set #1 instead of from the AT:

    • Press the Originate Call ( F3 on Call Control 1 of 5 ) to page the AT/MS from the test set #1. When the AT/MS answers the voice page, the test set #1 goes to Connected state and the data session on the test set #2 will enter into Dormant state. Only when the voice call is ended, the packet data connection can re-established on test set #2 if there's data to transmit.

    11

    To verify that the hybrid mode AT/MS can originate an SMS while in dual-idle state, send a short message from the AT/MS to the test set #1. The key steps include:

    • Create a short message on the AT/MS and then send to the test set #1.
    • Verify that the short message is successfully received by the test set #1 and displayed on the Short Message Service Information screen. The AT/MS remains keeping an open session with the test set #2.

    For details on AT/MS originated SMS procedure, see Related Topics .

    12

    To verify that the hybrid mode AT/MS can originate an SMS in 1xEV-DO dormant state, the procedure is similar to that of the test 6 except that an AT/MS originated SMS takes the place of AT/MS originated voice call.

    For details on AT/MS originated SMS procedure, see Related Topics .

    Verify that the short message is successfully received by the test set #1 and displayed on the Short Message Service Information screen. The AT/MS remains keeping a dormant data session on the test set #2.

    13

    To verify that the hybrid mode AT/MS can originate SMS while in 1xEV-DO connected state, the procedure is similar to that of the test 7 except that an AT/MS originated SMS takes the place of AT/MS originated voice call.

    For details on AT/MS originated SMS procedure, see Related Topics .

    Verify that the short message is successfully received by the test set #1 and displayed on the Short Message Service Information screen. Because the SMS is typically short-lived and would only cause brief interruptions to the 1xEV-DO service, the packet data connection may continue to remain active on the test set #2 or go dormant if the time allowed to spend on SMS service expires. The data transfer (for example, a ping operation) can be re-started after the SMS service.

    14

    To verify that the hybrid mode AT/MS can receive SMS while in dual-idle state, the procedure is similar to that of the test 11 except that an AT/MS terminated SMS takes the place of AT/MS originated SMS.

    For details on AT/MS terminated SMS procedure, see Related Topics .

    Verify that the short message is successfully received by the AT/MS and displayed on the AT/MS's screen. The AT/MS remains keeping an open session with the test set #2

    15

    To verify that the hybrid mode AT/MS can receive SMS in 1xEV-DO dormant state, the procedure is similar to that of the test 12 except that an AT/MS terminated SMS takes the place of AT/MS originated SMS.

    For details on AT/MS terminated SMS procedure, see Related Topics .

    Verify that the short message is successfully received by the AT/MS and displayed on the AT/MS's screen. The AT/MS remains keeping a dormant data session on the test set #2.

    16

    To verify that the hybrid mode AT/MS can receive SMS while in 1xEV-DO connected state, the procedure is similar to that of the test 13 except that an AT/MS terminated SMS takes the place of AT/MS originated SMS.

    For details on AT/MS terminated SMS procedure, see Related Topics .

    Verify that the short message is successfully received by the AT/MS and displayed on the AT/MS's screen. Because the SMS is typically short-lived and would only cause brief interruptions to the 1xEV-DO service, the packet data connection may continue to remain active on the test set #2 or go dormant if the time allowed to spend on SMS service expires. The data transfer (for example, a ping operation) can be re-started after the SMS service.

    17

    To verify that the hybrid mode AT/MS can originate 1xEV-DO packet data calls while in dual-idle state, perform the following procedure:

    • Originate a packet data connection from the AT/MS and verify that data can be transferred over test set #2. See Related Topics for an example procedure which uses AT/MS as a wireless modem for a packet data connection on 1xEV-DO system. The example procedure varies depending upon your data applications.

    18

    To verify that the hybrid mode AT/MS can re-originate 1xEV-DO packet data call while in 1xEV-DO dormant state, perform the following procedure:

    • When a packet data connection has established on test set #2 (if not, see the procedure of test 17 ), press the F2 ( Force Dormant ) on the Call Control 1 of 3 menu to make the AT/MS go dormant. The Dormant state should be shown on test set #2.
    • Make an AT/MS originated packet data connection. For example, start a ping session from the PC which is using AT/MS as a modem to the test set's built-in HTTP server. The Connected state should be shown on the test set #2, which indicates a successful packet data connection established.

    19

    To verify that the hybrid mode AT/MS can receive 1xEV-DO packet data pages while in dormant state on 1xEV-DO, the procedure is similar to that of the test 18 except that:

    • Make an AT/MS terminated packet data connection. For example, start a ping session from the test set #2 to the AT/MS. For detailed ping procedure, see Related Topics . You should see that the test set #2 returns to Connected state, which indicates a successful packet data connection established.

    20

    To verify that the hybrid mode AT/MS can originate a packet data call on CDMA when 1xEV-DO service is not available, perform the following procedure:

    • On test set #2, press the Close Session ( F7 on Call Parms 1 of 3 ) to close the current open session, and then set the Cell Power ( F7 on Call Parms 1 of 3 ) to Off to simulate that thee 1xEV-DO system is unavailable.
    • You should see that the hybrid mode AT/MS can not re-open a session and will go to power save mode on 1xEV-DO system.
    • Set up a packet data call and verify that the packet data connection is established on test set #1. Note that you must set the service option to SO33 or SO33 (+ F-SCH) on test set #1 before the hybrid mode AT/MS can initiate a packet data connection on IS-2000 system. For an example procedure of the packet data connection on IS-2000 system, see Related Topics . The example procedure varies depending upon your data applications.

    21 - 28

    The tests 21 - 28 require the external MOB-IP-SIM to provide MIP simulation. Refer to Prerequisite Setup to properly connect the external MOB-IP-SIM for these tests.

    To make the two test sets work with the MOB-IP-SIM for packet data handoff, the following key parameters should be properly set:

    • On test set #1, a service option 33 should be properly configured for the selected radio configuration. Either SO33 or SO33 (+ F-SCH) is required for a packet data connection on IS-2000 system.
    • On test set #2, the Default Packet Application should be configured as the session application. This is required for a packet data connection on IS-856 system.
    • On both test sets,
      • set the call parameters that are required for the hybrid mode AT/MS to acquire the IS-2000 and IS-856 systems successfully. For details, see General Procedure .
      • set the LAN IP addresses to make the two test sets in the same subnet. On each test set, set its LAN IP Address , Subnet Mask , Default Gateway from the Instrument Setup menu (accessing by SYSTEM CONFIG -> F1 Instrument Setup ) that are assigned by your network administrator.
      • set them to be able to work with the external MOB-IP-SIM. On each test set, set the External PDSN IP Address and External PDSN TCP Port matching your MOB-IP-SIM's configuration, and then turn the External PDSN State to on. This indicates the MOB-IP-SIM will be used to provide MIP functions.
      • Refer to the MOB-IP-SIM technical manual to properly configure the MOB-IP-SIM (for example, IP address, subnet mask, etc.) for MIP operations.

    NOTE
    To simplify the packet data handoff functional tests, the two test sets are set to share the same PDSN simulated by the MOB-IP-SIM. This guarantees that the same IP address is assigned to the hybrid mode AT/MS for seamless data session handoffs between the two networks. It further reduces any latency due to PPP re-sync on handoffs.

    21

    To verify that the hybrid mode AT/MS is able to hand off an active data session from 1xEV-DO to CDMA system when 1xEV-DO system is unavailable, perform the following key steps:

    • Verify that you've finished the setups as described in 21 - 28 and the hybrid mode AT/MS has successfully registered on the test set #1 and opened a session on the test set #2.
    • Make a packet data connection on test set #2 through the external MOB-IP-SIM. See Related Topics for an example MIP based packet data connection on 1xEV-DO system.
    • On test set #2, set the Cell Power ( F7 on Call Parms 1 of 3 ) to Off to simulate that the AT/MS moves out of the 1xEV-DO coverage.
    • Verify that the hybrid mode AT/MS will hand off the packet data connection from test set #2 to test set #1. The data transfer (if you are downloading a large file) can be continued through the test set # 1 after a small delay. You should see that Connected state is shown on test set #1 and Idle state is shown on test set #2.

    22

    To verify that the hybrid mode AT/MS is able to hand off a dormant data session from 1xEV-DO to CDMA system when 1xEV-DO system is unavailable, the procedure is similar to that of the test 21 except that:

    • Let the hybrid mode AT/MS go dormant by pressing the F2 ( Force Dormant ) on the Call Control 1 of 3 menu on test set #2. Then turn the Cell Power on the test set #2 to off to simulate that the AT/MS moves out of the 1xEV-DO coverage.
    • Start a data transfer (for example, start a ping session from the PC which is using the AT/MS as a modem). Verify that the data connection is made on test set #1. This indicates that the data session is handed off from 1xEV-DO to CDMA system.

    23

    To verify that the hybrid mode AT/MS is able to hand off a dormant data session from CDMA to 1xEV-DO system when 1xEV-DO system is available again, perform the following key steps:

    • Verify that you've finished the setups as described in 21 - 28 and the hybrid mode AT/MS has successfully registered on the test set #1 and opened a session on the test set #2.
    • On test set #2, press the Close Session ( F7 on Call Parms 1 of 3 ) to close the current open session, and then set the Cell Power ( F7 on Call Parms 1 of 3 ) to Off to emulate that the AT/MS is at CDMA-only coverage.
    • Make a packet data connection on test set #1 through the external MOB-IP-SIM. See Related Topics for an example MIP based packet data connection on IS-2000 system.
    • Let the AT/MS go dormant by pressing the F2 ( Force Dormant ) on the Call Control 1 of 3 menu on the test set #1.
    • On test set #2, set the Cell Power ( F7 on Call Parms 1 of 3 ) back to -50 dBm to simulate that the AT/MS moves back to the hybrid coverage (both systems are available).
    • Verify that the hybrid mode AT/MS acquires the 1xEV-DO system and opens a session on test set #2.
    • Start a ping session. Verify that the data connection is made on test set #2, which indicates the data session is handed off from CDMA to 1xEV-DO system. This is because the packet data service takes the precedence on 1xEV-DO system when both systems are available).

    24

    To verify that the hybrid mode AT/MS is able to perform a 1xEV-DO to CDMA to 1xEV-DO data session hand off when the hybrid mode AT/MS moves from a hybrid coverage area to CDMA only coverage area and then back to a hybrid mode coverage area, you can refer to the procedure of the tests 21 and 23 . The key points to perform this test is:

    • To simulate that the AT/MS moves from a 1xEV-DO coverage to CDMA only coverage area, set the Cell Power ( F7 on Call Parms 1 of 3 ) to Off on test set #2.
    • To simulate that the AT/MS moves from the CDMA only coverage area back to a hybrid mode coverage, set the Cell Power ( F7 on Call Parms 1 of 3 ) back to -50 dBm on the test set #2.

    25 - 28

    These tests are to verify the most fundamental MIP behavior of the hybrid mode AT/MS, such as making an MIP call, MIP to SIP fallback operations if an MIP registration fails.

    To perform these tests, you are required to set the AT/MS properly in the AT/MS MIP profile using a service programming tool. For details, see your AT/MS's technical manual. Also, you should properly set the MOB-IP-SIM to support these MIP tests. For details on the MOB-IP-SIM functionality and configurations, see the MOB-IP-SIM technical manual.

Related Topics

Hybrid Mode

Recommended Functional Tests for Hybrid Mode AT/MS

Test Set #2 (1xEV-DO) Related Procedures:

  • To establish a packet data connection (using SIP) on test set #2 (1xEV-DO), see:

    1xEV-DO: Packet Data Service Example Procedure (via Simple IP)

  • To establish a packet data connection (using MIP) on test set #2 (1xEV-DO), see:

    1xEV-DO: Packet Data Service Example Procedure (via Mobile IP)

  • To ping the hybrid mode AT/MS from the on test set #2 (1xEV-DO), see:

    1xEV-DO: How Do I Ping a Device From the Test Set?

Test Set #1 (CDMA) Related Procedures:

  • To establish a voice call on test set #1 (CDMA), see How Do I Set Up a Call? .
  • To perform an AT/MS originated SMS on test set #1 (CDMA), see Mobile-Originated SMS Procedure .
  • To perform an AT/MS terminated SMS on test set #1 (CDMA), see Mobile-Terminated SMS Procedure .
  • To establish a CDMA packet data connection (using SIP) on test set #1 (CDMA), see Packet Data Service Example Procedure (via Simple IP) .
  • To establish a CDMA packet data connection (using MIP) on test set #1 (CDMA), see Packet Data Service Example Procedure (via Mobile IP) .
  • To ping the hybrid mode AT/MS from the on test set #1 (CDMA), see How Do I Ping a Device From the Test Set? .


Measuring Paging Channel Message Error Rate (MER)

Measuring Paging Channel Message Error Rate (MER)

Last updated: October 28, 2004

This section is only applicable to the lab application.

The Paging Channel MER is used to evaluate how well the mobile station demodulates the paging channel in an AWGN (no fading or multipath) environment.

  • General Procedure
  • Testing 3.3.2 Demodulation of Slotted Mode Paging Channel

General Procedure

NOTE
It's recommended that you follow the steps in the order described below to ensure valid results. If you vary the test procedure, you may get the unexpected results. See Paging Channel MER Procedures for details.

  1. Connect the mobile station's antenna output to the test set's front panel RF IN/OUT connector and power them on.
  2. Press the blue SHIFT key and then the green Preset key to full reset the test set.
  3. Power on the mobile station and wait for the mobile station to perform a power up registration. The mobile station information should appear in the Mobile Reported Information window after a successful registration. Otherwise, perform the steps 1 through 9 in How Do I Set Up an IS-2000 Call? to set up the parameters required for the mobile station to find services.
  4. Turn off the timer based registration (see D. Registration Parameters )
  5. Press the Call Setup key.
  6. Press the More key on the lower left side of the test set two times until of the Call Control 3 of 3 menu is displayed.
  7. Press the F6 ( Paging Channel MER ), go to Paging MER menu.
  8. Press the F1 ( Paging Channel MER Parms ) to access the Paging Channel MER Parameters menu. Use the knob and DATA ENTRY keys to set the parameters as needed for your test situation (see Paging Channel MER Parameters ). For example,
    • Set the Max Slot Cycle Index to 0 .
    • Set the F-QPCH State to On .
    • Set the AWGN Power (dBm/1.23 MHz) to -54.00 .
    • Press the F6 ( Close Menu ) when finishing the setups.

    NOTE
    It is recommended that you set up the parameters associated with the MER test prior to initiating the MER test procedure. The test set provides a warning message if key settings are changed during the test. However, the test set does not block the changes or cause the MER test procedure to be aborted.

  9. Press the F6 ( Close Menu ) when finishing the setups
  10. (Optional) Press the F5 ( Clear MER Procedure Parms ). This action will clear the results shown in the Paging Channel Message Error Rate window.
  11. Press the F3 ( Originate Call ) to establish a call. Verify that the call has established by checking for Connected in the Active Cell field.
  12. Press the F2 ( Start MER Procedure ). The Paging MER test procedure starts only when a call is established. See Paging Channel MER Procedures for details.
  13. Press the F3 ( End Call ) to disconnect the call. This ensures that the mobile station will listen to the paging channel.
  14. Press the F4 ( Audit Order ), select On . This causes the test set to start sending Audit Order messages on the paging channel.
  15. Wait for the enough time you'd like to have the MER test procedure run. Standard specifies "at least 2 minutes and until sufficient confidence is ensured".
  16. Press the F4 ( Audit Order ), select Off . This causes the test set to stop sending Audit Order messages on the paging channel.
  17. Press the F3 ( Originate Call ) to establish a call. Verify that the call has established by checking for Connected in the Active Cell field.
  18. Press the F2 ( End MER Procedure ). The Paging MER test procedure can be ended only when a call is established.
  19. Observe the Paging MER results shown in the Paging Channel Message Error Rate window and evaluate the mobile station performance of the demodulation of the paging channel. A typical display is shown below.
  20. (Optional) If required, press the F3 ( End Call ) to disconnect the call.
  21. Turn the timer based registration back to on (see D. Registration Parameters ).

Testing 3.3.2 Demodulation of Slotted Mode Paging Channel

This test examines the mobile station demodulation performance of the Paging Channel in an AWGN (no fading or multipath) environment, and the figure of merit is determined by the message error rate (MER). Since the MS is operating in slotted mode, this test also makes sure the mobile station wakes up in time so that it does not miss the beginning of its assigned slots on the Paging Channel.

The MER is measured only for 9600 bps data rate. If the mobile station supports the Quick Paging Channel, then this test shall be performed with the Quick Paging Channel enabled.

To perform the tests as specified in the standard, follow the procedures as describe in the General Procedure . You need to set the following settings (as listed in Settings in Step 8 ) in step 8 per standard requirements (see Terminologies on the Test Set Adherence to Standard for the mappings of menus/softkeys on the test set's front panel to the parameter settings as specified in the standard).

Settings in Step 8
Settings Specified in the Standard |  | Equivalent Settings on the Test Set
Parameters | Values |
MAX_SLOT_CYCLE_INDEX | 0 | Set the Max Slot Cycle Index to 0 .
Paging Data Rate (bps) | 9600 | Set the Paging Data Rate to Full .
Quick Paging Data Rate (bps) | 4800 | If the mobile station support Quick Paging Channel: Set the F-QPCH State to On . Set the F-QPCH Data Rate to Full .
Pilot Ec/Ior (dB) | -7 | Set the Cell 1 F-Pilot Level to -7.00 dB.
Sync Ec/Ior (dB) | -16 | Set the Cell 1 F-FCH/Traffic Level to -16.00 dB.
Quick Paging Ec/Ior (dB) | -10 | Set the F-QPCH Relative to Pilot Level to -3 dB . The Quick Paging Ec/Ior is the ratio of Quick Paging Level to Cell Power. It equals the F-QPCH Relative to Pilot Level plus the Cell 1 F-Pilot Level .
Paging Ec/Ior (dB) | Test 1:-16.2 Test 2: -10.7 | Set the Cell 1 F-Paging Level to - 16.20 dB (for test 1) or -10.70 dB (for test 2).
Ioc (dBm/1.23 MHz) | Test 1:-54 Test 2: -48.5 | Set the AWGN Power (dBm/1.23 MHz) to -54.00 (for test 1) or -48.50 (for test 2).
Î or /Ioc (dB) | Test 1:-1 Test 2: -6.5 | Set Cell 1 Power ( F7 on the Call Parms 1 of 3 ) to -55.00 dBm/1.23 MHz for both tests. Î or /Ioc is the ratio of Cell Power to AWGN. It is not directly settable. Normally, the Ioc has been specified. You need to set Cell Power to the value of (Ioc + Ior/Ioc) to achieve this setting.
Paging Eb/Nt (dB) | Test 1: 3.9 Test 2: 3.9 | Observe the F-Paging Eb/Nt value in the Paging Channel Message Error Rate window. The Paging Eb/Nt is not directly settable. It is calculated based on other specified parameters.
QPCH Eb/Nt (dB) | Test 1: 13.1 Test 2: 7.6 | Observe the F-QPCH Eb/Nt value in the Paging Channel Message Error Rate window. The QPCH Eb/Nt is not directly settable. It is calculated based on other specified parameters.

Related Topics

Paging Channel MER Description


How to Send MMS Messages ?

How to Send MMS Messages ?

Last updated: June 20, 2006

This section is only applicable to the lab applications.

You can send MMS messages in different scenarios:

  • 1. Mobile-Terminated MMS Messages
  • 2. Mobile-Originated MMS Messages
  • 3. End-to-End MMS Messages

The tests can be implemented by following the general steps and some specific configurations below:

STEP A: Set Up the Test System

STEP B: Install the Software to Simulate MMSC/WAP Gateway

STEP C: Configure the Test Set

STEP D: Send MMS Message

STEP A: Set Up the Test System

You should set up the test system consist of PC, test set(s), mobile station(s) according to different Scenarios for MMS Massage Transmission .

STEP B: Install the Software to Simulate MMSC/WAP Gateway

An MMSC emulated by an external software (such as NowSMS provided by Now Wireless Limited.) is required for MMS tests. You can download and get its functionality and configuration manual on the web:

http://www.nowsms.com

STEP C: Configure the Test Set

  1. Configure the test set's IP address. If you send end-to-end MMS messages, you should configure different IP addresses for two test sets.

  2. Press the Call Setup key.

  3. Verify that the Operating Mode ( F1 ) is set to Active Cell and the System Type ( F2 ) is set to IS-2000 for this example.
  4. Press the Data Config ( F11 ) to set radio configuration is (Fwd3, Rvs3) or above.

  5. Press the FCH Service Option Setup ( F12 ) to set service option for the selected radio configuration (such (Fwd3, Rvs3))is SO33(+F-SCH)/SO33 . If you select SO33(+F-SCH) you could change the F-SCH Data Rate .

  6. If you select SO33(+F-SCH) you could change the F-SCH Data Rate .
    • Press the Call Setup key.
    • Press the More key on the lower left side of the test set until 4 of 5 of the Call Control menu is displayed.
    • Press the Data Channel Information ( F2 ), then press the Data Channel Parameters ( F1 ) to set F-SCH Data Rate to 76.8kbps.

  7. Setup HTTP SMS State:

    • Press the Call Setup key.
    • Press the More key on the lower left side of the test set until 4 of 5 of the Call Control menu is displayed.
    • Press the Short Message Service ( F5 ), then go to SMS Control menu 2 of 2 .
      • For 1. Mobile-Terminated MMS Messages press the HTTP Setup ( F4 ), then set HTTP SMS Input State to on .
      • For 2. Mobile-Originated MMS Messages press the HTTP Setup ( F4 ), then set HTTP SMS Output State to on .
      • For 3. End-to-End MMS Messages , set the HTTP SMS Input State of the test set 1 to on and the HTTP SMS Output State of the test set 2 to on .

  8. Setup the Mobile Station:

    • Press the Menu , then select the Message .
    • Select the Message Setting , then MMSC Domain according to your mobile station's configuration guide.
    • Key in the IP address of MMS server PC.

STEP D: Send MMS Message

  • For 1. Mobile-Terminated MMS Messages .

    • Open the web interface of NowSMS/MMS (for more information please refer to www.nowsms.com ).
    • Select an attached file such as .jpg file from the PC and send it to the mobile station.
    • View the MMS message received by the mobile station.

  • For 2. Mobile-Originated MMS Messages

    • Create an MMS message with the mobile station such as take a picture with it.
    • Send the MMS message according to the mobile station's guide to the PC.
    • Check the dedicated file under NowSMS in the PC to see the received MMS message.

  • For 3. End-to-End MMS Messages

    • Create an MMS message with the mobile station 1 such as take a picture with it.
    • Send the MMS message according to the mobile station 1's guide to the mobile station 2.
    • view the MMS message received by the mobile station 2.

Related Topics

Scenarios for MMS Massage Transmission

Multimedia Service (MMS) Messages


How Do I Originate a Packet Data Connection From My Wireless Device?

How Do I Originate a Packet Data Connection From My Wireless Device?

Last updated: October 28, 2004

This section is only applicable to the lab application.

An SO33 or SO33 (+ F-SCH) call enables high speed packet data transfer.

Establishing the Data Connection

  1. Connect the test set's rear panel LAN PORT to a LAN or a PC running a server application. (See Data Channel Applications )
  2. Connect a web enabled wireless device to the test set's front panel RF IN/OUT connector. If the wireless device is functioning as a modem in your test setup and a PC will be running the web browser, connect the wireless device to a PC. See Data Channel Applications .
  3. Set up the test set such as Cell Band, Channel, SID, etc. for your wireless devices if required.
  4. Select SO33 or SO33 (+F-SCH) in the FCH Service Option Setup menu (Call Parms 1 of 4, F12 ).
  5. Enter the mobile station IP address (See How Do I Set Up Data Channel Parameters? ).
  6. Turn on power to the mobile station.
  7. After the mobile station finds service, navigate to the web browser on the wireless device or a PC using wireless device as modem. Using the web browser, attempt to access a web site on the PC running a server application.
  8. The Active Cell status area should show Connected + Data (see Packet Data Connection Processing States ) indicating a successful packet data connection. Observe the wireless device display, the RLP counters (see How Do I Access the Data Counters? ) as well as the Data Throughout Monitor screen ( Data Throughput Monitor ) to evaluate your mobile station data application performance as data is transferred.

Related Topics

Packet Data Service Configurations


How Do I Ping a Device From the Test Set?

How Do I Ping a Device From the Test Set?

Last updated: October 28, 2004

This section is only applicable to the lab application.

You can use the Ping feature to check the system interconnect:

  • To check the interconnect between the test set and the DUT (such as a wireless device), use Ping the DUT from the test set .
  • To check the interconnect between the test set and a PC (such as a remote server running the data applications), use Ping an alternate address from the test set .

Ping the DUT from the test set

  1. From the test set front panel, press the CALL SETUP key.
  2. Press the Operating Mode ( F1 ) and set it to Active Cell .
  3. Press the System Type ( F2 ) and set it to Active Cell .
  4. Press the left More key two times until Call Control 3 of 3 is displayed.
  5. Press the Data Channel Info ( F2 ) key.
  6. Press the Data Channel Parameters ( F1 ) key.
  7. Enter the DUT IP address.

    NOTE
    The DUT's IP address must be on the same subnet as the test set's IP Address. See IP Address Requirements .

  8. Press F6 ( Close Menu ) to close the Data Channel Parameters menu.
  9. Press F6 ( Return ), go back to Call Control 3 of 3 menus.
  10. Press the Ping ( F3 ) key.
  11. Press the Ping Setup ( F1 ) key and verify that Device to Ping is set to DUT . If required, set the Ping Count , Timeout , and Packet Size .
  12. Establish a packet data connection (see How Do I Originate a Packet Data Connection From My Wireless Device? ). For example, access the internet from the mobile station's web browser.
  13. Press Start Ping ( F3 ) key when the Active Cell status area indicates Connected +Data or Idle Dormant .

Ping an alternate address from the test set

  1. From the test set front panel, press the CALL SETUP key.
  2. Press the Operating Mode ( F1 ) and set it to Active Cell .
  3. Press the System Type ( F2 ) and set it to Active Cell .
  4. Press the left More key two times until Call Control 3 of 3 is displayed.
  5. Select Ping Setup( F1 ) .
  6. Set the Alternate Ping Address to your desired target IP address.
  7. Set Device to Ping to Alternate .
  8. Select Start Ping( F3 ) .

Related Topics

Ping


How Do I Use R-FCH Gating for Talk Time Testing?

How Do I Use R-FCH Gating for Talk Time Testing?

Last updated: October 28, 2004

This section is only applicable to the lab application.

A method for testing mobile station's talk time is proposed by the test 2.1 of the CDG Stage 4 test standard (CDG 35). This test measures talk time of a mobile station by exhausting its fully charged battery in a long loopback call to the base station. The test procedure employs loopback and relies on simulating the typical 40% voice activity (see also Traffic Data Rate ).

Test Procedure

  1. Fully charge the mobile station battery using its normal charger. Ensure the mobile station's back lighting is disabled or set to the minimum. Do not attach the diagnostic monitor during the test. Ensure the mobile station is in an environment with a stabilized ambient temperature of 25°C.
  2. Connect the mobile station to the test set's front panel RF IN/OUT connector.
  3. Connect an external PC to the test set.
  4. Set up the test set with the following parameters (see also How Do I Change Call Parameters? ):
    • Press CALL SETUP . The Call Parms and Call Control menus are displayed on both sides of the screen.
    • Set System Type ( F2 ) to IS-2000.
    • Set Radio Config ( F11 on the Call Parms 1 of 4 ) to (Fwd3, Rvs3) .
    • Select FCH Service Option Setup ( F12 ) (Call Parms 1 of 4) , set Service Option for Fwd3, Rvs3 to SO2 (Loopback) . (varies the setting according to your mobile station)
    • Set the Traffic Data Rate ( F12 on the Call Parms 2 of 4 ) to Random (40% Voice Activity) . See Traffic Data Rate .
    • Set the R-FCH Gating ( F7 on the Call Parms 3 of 4 ) to On . See R-FCH Gating .
    • Set Cell Power (( F7 on the Call Parms 1 of 4 ) to -75 dBm/1.23 MHz .
    • Set the F-Pilot Level to -7.00 dB, and set the F-FCH/Traffic Level to -15 dB (see How Do I Change Generator Information? ).
  5. Page the MS by pressing the Originate Call ( F3 ). Verify that the Connected is in the Active Cell status field.
  6. Have the external software running on the PC to control the test, including:
    • Start the talk time timer in the external software to measure call duration.
    • Have the external software automatically change the cell power of the test set such that the mobile station is controlled to a specific transmit power profile as specified in the standard (see Mobile Station Transmit Power Statistics (Preliminary )(Suburban Topography) for an example profile of suburban topology). Power control should occur as follows:
      • Control the mobile station transmit power at 0 dBm.
      • The mobile station's transmit power will have a nominal dwell time of 2 seconds per each percent of probability. For example, if probability is 3.00% then the dwell time shall be 6.00 seconds.
      • At the end of each dwell time, control the mobile station at the next higher transmit power level.
      • Once the mobile station power has reached maximum power (typical is 23 dBm), control the mobile station to dwell at that power level twice.
      • Control the mobile station to decrement the transmit power in an analogous fashion until the minimum power level of -50 dBm is reached.
      • When the minimum mobile station power is reached, control the mobile station to dwell at that power level twice.
    • Have the external software continue by alternately increasing and decreasing mobile station transmit power.
    • Continue the call until the MS's battery is exhausted and the call is dropped.
    • Stop the talk time timer in the external software and record the call duration.

Minimum Standard: Measured talk-time for the mobile station shall be recorded along with data on the type and nominal capacity of the battery used. Data obtained in this test provides the expected talk time in realistic field conditions. Real talk times experienced in the field may vary due to factors such as talk patterns and actual CDMA signal conditions.

Mobile Station Transmit Power Statistics (Preliminary )(Suburban Topography)
Transmit Level (dBm) | Probability | Transmit Level (dBm) | Probability | Transmit Level (dBm) | Probability
23 | 1.81% | -2 | 4.07% | -27 | 0.16%
22 | 1.45% | -3 | 4.09% | -28 | 0.14%
21 | 1.08% | -4 | 4.07% | -29 | 0.14%
20 | 0.90% | -5 | 4.01% | -30 | 0.13%
19 | 0.72% | -6 | 3.90% | -31 | 0.12%
18 | 0.60% | -7 | 3.75% | -32 | 0.11%
17 | 0.48% | -8 | 3.57% | -33 | 0.10%
16 | 0.50% | -9 | 3.35% | -34 | 0.09%
15 | 0.57% | -10 | 3.11% | -35 | 0.08%
14 | 0.68% | -11 | 2.85% | -36 | 0.06%
13 | 0.83% | -12 | 2.57% | -37 | 0.05%
12 | 1.01% | -13 | 2.16% | -38 | 0.05%
11 | 1.23% | -14 | 1.90% | -39 | 0.04%
10 | 1.47% | -15 | 1.65% | -40 | 0.03%
9 | 1.73% | -16 | 1.41% | -41 | 0.02%
8 | 2.01% | -17 | 1.19% | -42 | 0.02%
7 | 2.29% | -18 | 1.00% | -43 | 0.02%
6 | 2.57% | -19 | 0.82% | -44 | 0.02%
5 | 2.85% | -20 | 0.67% | -45 | 0.02%
4 | 3.11% | -21 | 0.54% | -46 | 0.02%
3 | 3.35% | -22 | 0.43% | -47 | 0.02%
2 | 3.57% | -23 | 0.34% | -48 | 0.02%
1 | 3.75% | -24 | 0.26% | -49 | 0.02%
0 | 3.90% | -25 | 0.20% | -50 | 0.02%
-1 | 4.01% | -26 | 0.17% |  |

The average mobile station power from the above profile is 11.5 mW (10.6 dBm).

Probability Distribution of Mobile Station Transmit Power (Suburban Topography)

Related Topics

R-FCH Gating


General Procedures for Soft/Softer Handoff Tests

General Procedures for Soft/Softer Handoff Tests

Last updated: October 28, 2004

This section is only applicable to the lab application.

A. Establish a call.

  1. Connect the mobile station to the Test Set.
  2. Make a call (see How Do I Set Up a Call? ).

B. Set Up Soft/Softer Handoff Parameters

  1. Press the CALL SETUP key.
  2. Press the More key on the left side of the display until 2 of 3 is displayed.
  3. Press the Soft Handoff Info ( F1 ) key to display the Generated Pilot Level Information and Mobile Station Reported Pilot Level Information tables. See Generated Pilot Level Information and Mobile Station Reported Pilot Level Information .
  4. Press the Soft Handoff Parameters (F2 ) key (see Soft/Softer Handoff Parameters ), set the parameters as needed. For example, Handoff Type (Soft or Softer), Cell 1 and Cell 2 Pilot Level, etc. To display more Soft Handoff Parameters (such as Cell 2 Delay, etc.), turn the knob

    NOTE
    The F-Pilot Level field is corresponding to the Pilot Ec/Ior parameter in the TIA/EIA-98E standard and the F-FCH/Traffic Level field corresponding to the Traffic Ec/Ior parameter.

    Cell 2 Delay is relative to cell 1. It is set in units of microseconds (us), with a maximum of 13.02 microseconds (16 PN chips). It defaults to 12.21 us (15 chips).

  5. Press the Close Menu (F6 ) key.

C. Set the Cell 2 Power and AWGN Power

NOTE
The Cell Power field is corresponding to the Î or parameter in the TIA/EIA-98E standard and the AWGN Power field corresponding to the I oc parameter.

  1. Press the Cell 2 Power ( F1 ) key and enter a desired value (for example, -55 dBm/1.23 MHz). The Cell 2 pilot information is displayed in the Generated Pilot Level Information table (see Generated Pilot Level Information ).
  2. Press the AWGN Power ( F3 ) key and enter a desired value (in this example, set to Off).

D. Initiate the Soft or Softer Handoff

  1. Press the Soft Handoff (F4 ) key and select On from the table.

    The Mobile Station Reported Pilot Level Information table (see Mobile Station Reported Pilot Level Information ) should now show Cell 2, identified by a pilot PN offset of 36 in this example, as an Active pilot.

E. Clear Mobile Pilot Report

  1. Press the Soft Handoff Parameters (F2 ) key.

  2. Scroll down the list of parameters. Highlight and select Clear Mobile Pilot Report .

  3. Highlight Yes in the Clear Now? menu and press the knob.
  4. Press the Close Menu (F6 ) key.

F. Send Pilot Meas Request

  1. Press the Send Pilot Meas Request (F5 ) key.

NOTE
A call must be connected (Active Cell, Connected state) before the test set will display the Send Pilot Meas Request softkey.

Related Topics

Soft/Softer Handoff Parameters


How Do I Test Mobile Station (MS) Closed Loop Power Control (CLPC) Behavior in Soft/Softer Handoff?

How Do I Test Mobile Station (MS) Closed Loop Power Control (CLPC) Behavior in Soft/Softer Handoff?

Last updated: October 28, 2004

This section is only applicable to the lab application.

When the mobile station is in a soft or softer handoff, there are two power control subchannels affecting closed loop power control. The difference between the soft and softer handoff types consists of messaging that the test set sends to the mobile station regarding closed loop power control subchannel bit (see Verifying Mobile Station (MS) Closed Loop Power Control (CLPC) Behavior in Soft/Softer Handoffs ).

Testing the mobile station's ability to respond correctly to more than one power control subchannel is shown by the following two examples.

  • Verifying MS CLPC Behavior in Soft Handoff
  • Verifying MS CLPC Behavior in Softer Handoff

Verifying MS CLPC Behavior in Soft Handoff

With this test setup, the mobile station is expected to perform an "or of down" logic function on the closed loop power control bits (the mobile station increases its power level if and only if the power control bits from both cells are indicating up).

  1. Establish a call (see A. Establish a call. ) with the Cell 1 Power set to -55 dBm/1.23 MHz.
  2. Set the Soft Handoff Parameters (T_Add, T_Comp, T_Drop, etc.) to the defaults (see B. Set Up Soft/Softer Handoff Parameters ) (Handoff Type is Soft )and make sure the Soft Handoff ( F4 ) state is Off .

    NOTE
    The F-Pilot Level field corresponds to the Pilot Ec/Ior parameter in the TIA/EIA-98E standard and the F-FCH/Traffic Level field corresponds to the Traffic Ec/Ior parameter.

  3. Clear the Mobile Station Reported Pilot Level Information table (see E. Clear Mobile Pilot Report ).
  4. Set the Cell 2 Power ( F1 ) to -50 dBm/1.23 MHz and set the AWGN Power ( F3 ) to Off (see C. Set the Cell 2 Power and AWGN Power ).

    NOTE
    The Cell Power field corresponds to the Î or parameter in the TIA/EIA-98E standard and the AWGN Power field corresponds to the I oc parameter in the TIA/EIA-98E standard.

  5. Observe the Delta Power results in the Generated Pilot Level Information table, and the PN Status and Handoff Status in the Mobile Station Reported Pilot Level Information table.
  6. Set the Soft Handoff (F4 ) to On (see D. Initiate the Soft or Softer Handoff ). Observe the changes on the Mobile Station Reported Pilot Level Information table, the Handoff Status should indicate Soft and the PN Status of Cell 1 and Cell 2 should indicate Active.

    NOTE
    Selecting Soft in the Handoff Type causes the PWR_COMB_IND bit in the Handoff Direction Message to be set to a '0' and the Handoff Direction Message is sent to the mobile station when the Soft Handoff (F4 ) is set to On .

  7. Select Channel Power measurement by pressing the Measurement Selection key and observe the measurement results (see Measuring Channel Power ).
  8. Press the More key on the right side of the screen until 2 of 3 is displayed.
  9. Change the Cell 1 and Cell 2 closed loop power control mode and observe the Channel Power measurement results:
    • Set Cell 1 Rvs CLPC ( F7 ) to All Down bits and set Cell 2 Rvs CLPC ( F8 ) to Active bits . The mobile station's output power is expected to decrease, observe the Channel Power measurement results.
    • Set Cell 1 Rvs CLPC ( F7 ) to All Up bits and set Cell 2 Rvs CLPC ( F8 ) to All Up bits . The mobile station's output power is expected to increase, observe the Channel Power measurement result.
    • Set Cell 1 Rvs CLPC ( F7 ) to Active bits and set Cell 2 Rvs CLPC ( F8 ) to All Down bits . The mobile station's output power is expected to decrease, observe the Channel Power measurement results.

Verifying MS CLPC Behavior in Softer Handoff

With this test setup, the mobile station is expected to perform diversity combining of power control bits (ignore the weaker bits). In this example, since the Cell 2 power is stronger than Cell 1 power, the mobile station should follow the Cell 2 Closed Loop Power Control.

  1. Establish a call (see A. Establish a call. ) with the Cell 1 Power set to -55 dBm/1.23 MHz.
  2. Press the Soft Handoff Parameters (F2 ) key, set the Handoff Type to Softer (see B. Set Up Soft/Softer Handoff Parameters ).
  3. Clear the Mobile Station Reported Pilot Level Information table (see E. Clear Mobile Pilot Report ).
  4. Set the Cell 2 Power ( F1 ) to -50 dBm/1.23 MHz and set the AWGN Power ( F3 ) to Off (see C. Set the Cell 2 Power and AWGN Power ).

    NOTE
    The Cell Power field corresponds to the Î or parameter in the TIA/EIA-98E standard and the AWGN Power field corresponds to the I oc parameter in the TIA/EIA-98E standard.

  5. Observe the Delta Power results in the Generated Pilot Level Information table, and the PN Status and Handoff Status in the Mobile Station Reported Pilot Level Information table.
  6. Set the Soft Handoff (F4 ) to On (see D. Initiate the Soft or Softer Handoff ). Observe the changes on the Mobile Station Reported Pilot Level Information table, the Handoff Status should indicate Softer and the PN Status of Cell 1 and Cell 2 should indicate Active.

    NOTE
    Selecting Softer in the Handoff Type causes the PWR_COMB_IND bit in the Handoff Direction Message to be set to a '1' and the Handoff Direction Message is sent to the mobile station when the Soft Handoff (F4 ) is set to On .

  7. Select Channel Power measurement by pressing the Measurement Selection key and observe the measurement results (see Measuring Channel Power ).
  8. Press the More key on the right side of the screen until 2 of 3 is displayed.
  9. Change the Cell 1 and Cell 2 closed loop power control mode and observe the Channel Power measurement results:
    • Set Cell 1 Rvs CLPC ( F7 ) to All Down bits and set Cell 2 Rvs CLPC ( F8 ) to Active bits . The mobile station's output power is expected to maintained at the expected power level, observe the Channel Power measurement results.
    • Set Cell 1 Rvs CLPC ( F7 ) to Active bits and set Cell 2 Rvs CLPC ( F8 ) to All Down bits . The mobile station's output power is expected to decrease, observe the Channel Power measurement result.
    • Set Cell 1 Rvs CLPC ( F7 ) to Active bits and set Cell 2 Rvs CLPC ( F8 ) to All Up bits . The mobile station's output power is expected to increase, observe the Channel Power measurement results.

Related Topics

Verifying Mobile Station (MS) Closed Loop Power Control (CLPC) Behavior in Soft/Softer Handoffs


How Do I Make Soft/Softer Handoff Tests Regarding T_Add?

How Do I Make Soft/Softer Handoff Tests Regarding T_Add?

Last updated: October 28, 2004

This section is only applicable to the lab application.

With this test setup, the mobile station is expected to send a Pilot Strength Measurement Message (PSMM) to the base station when the Cell 2 Pilot Strength crosses the T_ADD threshold (28 is the default, indicates -14 dB relative to the total RF power) and the Cell 2 pilot (Pilot Offset 36) is flagged as a "Candidate" (see T_Add Behavior for description).

  1. Establish a call (see A. Establish a call. ) with the Cell 1 Power set to -55 dBm/1.23 MHz.
  2. Set the Soft Handoff Parameters to the defaults (see B. Set Up Soft/Softer Handoff Parameters ) and make sure the Soft Handoff ( F4 ) is Off .

    NOTE
    The F-Pilot Level field corresponds to the Pilot Ec/Ior parameter in the TIA/EIA-98E standard and the F-FCH/Traffic Level field corresponds to the Traffic Ec/Ior parameter in the TIA/EIA-98E standard.

  3. Clear the Mobile Station Reported Pilot Level Information table (see E. Clear Mobile Pilot Report ).
  4. Set the Cell 2 Power ( F1 ) to -65 dBm/1.23 MHz and set the AWGN Power ( F3 ) to Off (see C. Set the Cell 2 Power and AWGN Power ). This results in the Cell 2 Pilot Strength (35, -17.5dB) below T_Add (28, -14dB). No Pilot Strength Measurement Message (PSMM) is expected to send from the mobile station.

    NOTE
    The Cell Power field is corresponding to the Î or parameter in the TIA/EIA-98E standard and the AWGN Power field corresponding to the I oc parameter in the TIA/EIA-98E standard.

  5. Press the Cell 2 Power ( F1 ), slowly turn the knob until it is set to -60 dBm/1.23 MHz. This causes the Cell 2 Pilot Strength (26, -13 dB) to above the T_ADD (28, -14 dB) threshold for soft handoff.
  6. Observe the Mobile Station Reported Level Information display. The mobile station should have sent a Pilot Strength Measurement Message (PSMM) to the base station since the Cell 2 Pilot Strength crosses the T_ADD threshold. The test set flags the Cell 2 pilot (Pilot Offset 36) as a "Candidate" when the reported Pilot Strength crosses T_ADD.

    If the Generated Pilot Level Information display, which shows the actual pilot strength and PN offset transmitted by the test set, indicates that the Cell 2 Pilot Strength crosses T_Add threshold (28, -14 dB) and the mobile station has not sent a PSMM, a failure condition may exist with the mobile station. Send the pilot measurement request by pressing the Send Pilot Meas Request ( F5 ) key (see F. Send Pilot Meas Request ) and compare the mobile reported pilot information to the actual information in the Generated Pilot Level Information display.

Related Topics

General Procedures for Soft/Softer Handoff Tests


How Do I Make Soft/Softer Handoff Tests Regarding T_Comp?

How Do I Make Soft/Softer Handoff Tests Regarding T_Comp?

Last updated: October 28, 2004

This section is only applicable to the lab application.

With this test setup, the mobile station is expected to send a Pilot Strength Measurement Message (PSMM) to the base station when the Cell 2 Pilot Strength exceeds the T_Comp (5 is the default value) threshold and the Cell 2 pilot (Pilot Offset 36) is flagged as "To Add" (see T_Comp Behavior for description). The Cell 2 pilot is added to the Active set of pilots when the soft handoff is initiated.

  1. Establish a call (see A. Establish a call. ) with the Cell 1 Power set to -55 dBm/1.23 MHz.
  2. Set the Soft Handoff Parameters to the defaults (see B. Set Up Soft/Softer Handoff Parameters ) and make sure the Soft Handoff ( F4 ) is Off .

    NOTE
    The F-Pilot Level field is corresponding to the Pilot Ec/Ior parameter in the TIA/EIA-98E standard and the F-FCH/Traffic Level field corresponding to the Traffic Ec/Ior parameter.

  3. Clear the Mobile Station Reported Pilot Level Information display (see E. Clear Mobile Pilot Report ).
  4. Set the Cell 2 Power ( F1 ) to -60 dBm/1.23 MHz and set the AWGN Power ( F3 ) to Off (see C. Set the Cell 2 Power and AWGN Power ). This causes the Cell 2 Pilot Strength (26, -13 dB) to above the T_ADD (28, -14 dB) threshold. Observe the Mobile Station Reported Level Information display. The Cell 2 pilot (Pilot Offset 36) should be flagged as a "Candidate" since the reported Pilot Strength crosses T_ADD.

    NOTE
    The Cell Power field is corresponding to the Î or parameter in the TIA/EIA-98E standard and the AWGN Power field corresponding to the I oc parameter.

  5. Press the Cell 2 Power ( F1 ), slowly turn the knob until it is set to -52 dBm/1.23 MHz. This causes the Cell 2 pilot level to exceed the T_COMP threshold.
  6. Observe the Mobile Station Reported Level Information display. The mobile station should have sent a Pilot Strength Measurement Message (PSMM) to the base station since the Cell 2 Pilot Strength is stronger than Cell 1 Pilot Strength (24, -12 dB) by more than T_Comp (5). The test set flags the Cell 2 pilot (Pilot Offset 36) as "To Add" when the reported Pilot Strength crosses T_Comp threshold.

    If the Generated Pilot Level Information display, which shows the actual pilot strength and PN offset transmitted by the test set, indicates that the Cell 2 Pilot Strength is stronger than Cell 1 Pilot Strength by at least T_Comp (5 indicating 2.5 dB), and the mobile station has not sent a Pilot Strength Measurement Message, a failure condition may exist with the mobile station. Send the pilot measurement request by pressing the Send Pilot Meas Request ( F5 ) key (see F. Send Pilot Meas Request ) and compare the mobile reported pilot information to the actual information in the Generated Pilot Level Information display.

  7. At this point a soft handoff should be established with Cell 2. Press the Soft Handoff (F4 ) key and set the Soft Handoff State to On .
  8. Observe the Mobile Station Reported Level Information display. Both Cell 1 and Cell 2 pilots should be Active and current Handoff Status is Soft. This indicates that a soft handoff has been established with Cell 2 and Cell 1 as active set pilot and traffic channels.

Related Topics

General Procedures for Soft/Softer Handoff Tests


How Do I Make Soft/Softer Handoff Tests Regarding T_Drop/T_TDrop?

How Do I Make Soft/Softer Handoff Tests Regarding T_Drop/T_TDrop?

Last updated: October 28, 2004

This section is only applicable to the lab application.

With this test setup, the mobile station is expected to send a Pilot Strength Measurement Message (PSMM) to the base station when the Cell 2 Pilot Strength falls below the T_Drop threshold (32 is the default, indicating - 16 dB relative to the total RF power) for the period of time specified by T_TDrop (3 is the default, indicating 4 seconds), and the Cell 2 pilot (Pilot Offset 36) is flagged as a "To Drop" (see T_Drop/T_TDrop Behavior for description). The Cell 2 pilot is removed from the Active set of pilots when the soft handoff is ended.

  1. Establish a call (see A. Establish a call. ) with the Cell 1 Power set to -55 dBm/1.23 MHz.
  2. Set the Soft Handoff Parameters to the defaults (see B. Set Up Soft/Softer Handoff Parameters ) and make sure the Soft Handoff ( F4 ) is Off .

    NOTE
    The F-Pilot Level field is corresponding to the Pilot Ec/Ior parameter in the TIA/EIA-98E standard and the F-FCH/Traffic Level field corresponding to the Traffic Ec/Ior parameter.

  3. Clear the Mobile Station Reported Pilot Level Information display (see E. Clear Mobile Pilot Report ).
  4. Set the Cell 2 Power ( F1 ) to -52 dBm/1.23 MHz and set the AWGN Power ( F3 ) to Off (see C. Set the Cell 2 Power and AWGN Power ). This causes the Cell 2 pilot level to exceed the T_COMP threshold.

    NOTE
    The Cell Power field is corresponding to the Î or parameter in the TIA/EIA-98E standard and the AWGN Power field corresponding to the I oc parameter.

  5. Press the Soft Handoff (F4 ) key and set the Soft Handoff State to On .
  6. Observe the Mobile Station Reported Level Information display. Both Cell 1 and Cell 2 pilots should be Active and current Handoff Status is Soft. This indicates that a soft handoff has been established with Cell 2 and Cell 1 as active set pilot and traffic channels.
  7. Press the Cell 2 Power ( F1 ), slowly turn the knob until it decreases to -66 dBm/1.23 MHz (in this example). This causes the Cell 2 pilot level to below the T_Drop threshold.
  8. Wait 5 seconds. Observe the Mobile Station Reported Level Information display. The mobile station should have sent a Pilot Strength Measurement Message (PSMM) to the base station since the Cell 2 Pilot Strength falls below the T_Drop threshold for the period of time specified by T_TDrop. The test set flags the Cell 2 pilot (Pilot Offset 36) as a "To Drop" when the reported Pilot Strength is below T_Drop.

    If the Generated Pilot Level Information display, which shows the actual pilot strength and PN offset transmitted by the test set, indicates that the Cell 2 Pilot Strength falls below T_Drop threshold (32, -16 dB) and the mobile station has not sent a PSMM, a failure condition may exist with the mobile station. Send the pilot measurement request by pressing the Send Pilot Meas Request ( F5 ) key (see F. Send Pilot Meas Request ) and compare the mobile reported pilot information to the actual information in the Generated Pilot Level Information display.

  9. End the soft handoff. Press the Soft Handoff (F4 ) key and set the Soft Handoff State to Off .
  10. Observe the Mobile Station Reported Level Information display. The Cell 2 pilots should be removed from the display and current Handoff Status is None. This indicates that a soft handoff has ended and the connection only with Cell 1 as active set pilot and traffic channel.

Related Topics

General Procedures for Soft/Softer Handoff Tests


Clearing the SMS Info/Status

C learing the SMS Info/Status

Last updated: October 28, 2004

This section is only applicable to the lab application.

To clear the information shown on the SMS Message Acknowledge Info window and the information about the received SMS message shown on the Mobile-Originated Message and Mobile-Terminated SMS Info windows, press the F5 ( Clear SMS Info/Status ) which is accessed as follows:

  1. Press the Call Setup key.
  2. Press the More key on the lower left side of the test set two times until 3 of 3 of the Call Control menu is displayed.
  3. Press the F5 ( Short Message Service ), go to SMS Control menu.
  4. Press the F5 ( Clear SMS Info/Status ).

Related Topics

Short Message Service Information


Mobile-Originated SMS Procedure

Mobile-Originated SMS Procedure

Last updated: October 28, 2004

This section is only applicable to the lab applications.

  • General Procedure
  • Performing CDG Stage 2 SMS Tests: 8.2 Mobile Station Originated SMS Tests

General Procedure

:This section describes general procedures for Mobile-Originated SMS tests. You can send an SMS message from the mobile station to the test set via the R-ACH (reverse access channel) or the R-Traffic (reverse traffic) channel. The test set supports receiving an SMS message in the following three ways (see Receiving SMS Messages Sent from the Mobile Station for the differences).

  • Method 1: Receiving an SMS message while in idle state (current service option is other than SO6/SO14).
  • Method 2: Receiving an SMS message while in idle state (current service option is SO6 or SO14)
  • Method 3: Receiving an SMS message while in a voice or data call.

Method 1: Receiving an SMS message while in idle state (current service option is other than SO6/SO14).

  1. If you would like log the protocol messages exchanged between the test set and the mobile station, set up the Wireless Protocol Advisor (WPA) and start logging. See Logging SMS Messages .
  2. Connect the mobile station to the test set.
  3. Power on the mobile station and wait for the mobile station to perform a power up registration. The mobile station information should appear in the Mobile Reported Information window after a successful registration. Otherwise, perform the steps 1 through 9 in How Do I Set Up an IS-2000 Call? to have the mobile station registered.
    Make sure the current call status is Idle and the current service option is other than SO6 and SO14 (for example, SO3).

    NOTE
    The test set behaves differently with service option set to other than SO6 and SO14 and with service option set to SO6 or SO14 when the mobile station attempts to send a long message. See the following step 9 and the step 9 in the procedure of Method 2: Receiving an SMS message while in idle state (current service option is SO6 or SO14) for the differences.

  4. Press the Call Setup key.
  5. Press the More key on the lower left side of the test set two times until 3 of 3 of the Call Control menu is displayed.
  6. Press the F5 ( Short Message Service ). The Short Message Service Information screen appears.
  7. (Optional) Follow the procedure of Set up the Mobile-Originated SMS parameters , set up the Mobile-Originated SMS parameters as desired (see Setting Mobile-Originated SMS Parameters for parameters description). For example, to perform the CDG Stage 2 8.2.6 test, you need to set the SMS Support to Disabled .
  8. (Optional) To clear the last received SMS message, press the F5 ( Clear SMS Info/Status ). See Clearing the SMS Info/Status .
  9. From the mobile station, send an SMS message to any address. This step depends upon the mobile station implementation. If the MS supports automatically selecting a channel to transmit the SMS message based on the message length,
    • the MS will send the message on the R-ACH (reverse access channel) if the message length is allowed for the R-ACH. No call is established in this process. Or,
    • the MS will attempt to originate an SO6 or SO14 call and send the message on the reverse traffic channel if the message length is longer than what is allowed for the R-ACH. If it does so while the test set service option is other than SO6 or SO14, however, service negotiation between the test set and the MS will fail, the call will not be completed, and an error message will be generated. Use Method 2: Receiving an SMS message while in idle state (current service option is SO6 or SO14) to send a long message.
  10. Observe the SMS Message Acknowledge Info window for indications that the test set has received the message. Observe the Mobile-Originated Message window for the received message contents. Observe the Mobile-Originated SMS Info window for the parameters included in the received message.
  11. (Optional) Follow the procedure of Set up the Mobile-Originated SMS parameters , set up the Mobile-Originated SMS parameters as desired. For example, change the display format (ASCII or Hex) for the received message contents in the Mobile-Originated Message window or scroll the display for viewing long messages by changing the Row Index setting. See Setting Mobile-Originated SMS Parameters for parameter descriptions.
  12. If you are capturing a log, stop logging.

Method 2: Receiving an SMS message while in idle state (current service option is SO6 or SO14)

  1. If you would like log the protocol messages exchanged between the test set and the mobile station, set up the Wireless Protocol Advisor (WPA) and start logging. See Logging SMS Messages .
  2. Connect the mobile station to the test set.
  3. Power on the mobile station and wait for the mobile station to perform a power up registration. The mobile station information should appear in the Mobile Reported Information window after a successful registration. Otherwise, perform the steps 1 through 9 in How Do I Set Up an IS-2000 Call? to have the mobile station registered.
    Make sure the current service option is set to SO6 and SO14 (see step 7 in How Do I Set Up an IS-2000 Call? ).
  4. Pressing the Call Setup key.
  5. Press the More key on the lower left side of the test set two times until 3 of 3 of the Call Control menu is displayed.
  6. Press the F5 ( Short Message Service ). The Short Message Service Information screen appears.
  7. (Optional) Follow the procedure of Set up the Mobile-Originated SMS parameters , set up the Mobile-Originated SMS parameters as desired (see Setting Mobile-Originated SMS Parameters for parameters description). For example, to perform the CDG Stage 2 8.2.6 test, you need to set the SMS Support to Disabled .
  8. (Optional) To clear the last received SMS message, see Clearing the SMS Info/Status .
  9. From the mobile station, send an SMS message with any address to the test set. This step depends upon the mobile station implementation. If the MS supports automatically selecting a channel to transmit the SMS message based on the message length, the message is sent:
    • via the R-ACH (reverse access channel) if the message length is allowed by the R-ACH. No call is established in this process. Same as Method 1. Or,
    • via the R-Traffic (reverse traffic channel) if the message length is longer than what is allowed by the R-ACH. An SO6 or SO14 connection is established during the SMS sending. The call is then automatically disconnected when the message is sent.

    NOTE
    Standards specify that the shorter messages are sent on the R-ACH (Reverse Access Channel) and the longer messages are sent on the reverse Traffic Channel while in SO6 or SO14 service option.

  10. Observe the SMS Message Acknowledge Info window for indications that the test set has received the message. Observe the Mobile-Originated Message window for the received message contents. Observe the Mobile-Originated SMS Info window for the parameters included in the received message.
  11. (Optional) Follow the procedure of Set up the Mobile-Originated SMS parameters , set up the Mobile-Originated SMS parameters as desired. For example, change the display format (ASCII or Hex) for the received message contents in the Mobile-Originated Message window or scroll the display for viewing long messages by changing the Row Index setting. See Setting Mobile-Originated SMS Parameters for parameter descriptions.
  12. If you are capturing a log, stop logging.

Method 3: Receiving an SMS message while in a voice or data call.

  1. If you would like log the protocol messages exchanged between the test set and the mobile station, set up the Wireless Protocol Advisor (WPA) and start logging. See Logging SMS Messages .
  2. Connect the mobile station to the test set.
  3. Establish a voice or data call. Follow the procedure in How Do I Set Up an IS-2000 Call? . Make sure that the service option is set to any value other than SO6 and SO14 in step 7 (for example, SO2). Verify that the call has established by checking for Connected in the Active Cell field.
  4. Pressing the Call Setup key.
  5. Press the More key on the lower left side of the test set two times until 3 of 3 of the Call Control menu is displayed.
  6. Press the F5 ( Short Message Service ). The Short Message Service Information screen appears.
  7. (Optional) Follow the procedure of Set up the Mobile-Originated SMS parameters , set up the Mobile-Originated SMS parameters as desired (see Setting Mobile-Originated SMS Parameters for parameters description). For example, to perform the CDG Stage 2 8.2.6 test, you need to set the SMS Support to Disabled .
  8. To clear the last received SMS message, see Clearing the SMS Info/Status .
  9. (Optional) From the mobile station, send an SMS message with any address to the test set. This step depends upon the mobile station implementation.
  10. Observe the SMS Message Acknowledge Info window for indications that the test set has received the message. Observe the Mobile-Originated Message window for the received message contents. Observe the Mobile-Originated SMS Info window for the parameters included in the received message. The call remains connected unless you disconnect the call.
  11. (Optional) Follow the procedure of Set up the Mobile-Originated SMS parameters , set up the Mobile-Originated SMS parameters as desired. For example, change the display format (ASCII or Hex) for the received message contents in the Mobile-Originated Message window or scroll the display for viewing long messages by changing the Row Index setting. See Setting Mobile-Originated SMS Parameters for parameter descriptions.
  12. If you are capturing a log, stop logging.

Set up the Mobile-Originated SMS parameters

  1. Pressing the Call Setup key.
  2. Press the More key on the lower left side of the test set two times until 3 of 3 of the Call Control menu is displayed.
  3. Press the F5 ( Short Message Service ), go to SMS Control menu.
  4. Press the F3 ( Mobile-Orig SMS Parameters ). The Mobile-Originated SMS Parameters menu appears.
  5. Set the parameters as desired. See Setting Mobile-Originated SMS Parameters for the parameters description.
    1. Turn the knob to highlight a parameter and then press the knob.
    2. Enter a value or selection and press the knob.
  6. Press the F6 ( Close Menu ) key to go back to the SMS Control menu.

Performing CDG Stage 2 SMS Tests: 8.2 Mobile Station Originated SMS Tests

All of the tests as specified in the CDG Stage 2 8.2 Mobile Station Originated SMS Tests can follow the General Procedure . The special settings required for each test are listed in the Mobile-Terminated SMS Tests

Mobile-Terminated SMS Tests

CDG Stage 2 Tests

Specific Setting Required for the Test During the General Procedure

8.2 Mobile Station Originated SMS Tests

8.2.1 Access Channel SMS Delivery

Use method 1 to send the short message from the mobile station to the test set.

8.2.2 SMS Delivery when Message too large for Access Channel

Use method 1 to attempt to send a long message from the mobile station to the test set and expect an error "CDMA call processing error; service option and radio configuration change failed due to MS messaging" prompted by the test set. Then try to use the method 2 to send this long message and make sure that the message is successfully received by the test set.

8.2.3 Traffic Channel SMS Delivery

Use method 3 to send the short message from the mobile station to the test set.

8.2.4 Reserved

8.2.5 Unknown Destination Address

Use method 1 or 2. In step 7, follow the procedure Set up the Mobile-Originated SMS parameters and:

  • set SMS Support to Unknown Dest

8.2.6 MS Originated SMS Disabled

Use method 1 or 2. In step 7, follow the procedure Set up the Mobile-Originated SMS parameters and:

  • set SMS Support to Disabled

8.2.7 SMS Not Supported by Base Station

Use method 1 or 2. In step 7, follow the procedure Set up the Mobile-Originated SMS parameters and:

  • set SMS Support to Not Supported

Related Topics

Logging SMS Messages


Mobile-Terminated SMS Procedure

Mobile-Terminated SMS Procedure

Last updated: October 28, 2004

This section is only applicable to the lab applications.

  • General Procedure
  • Performing CDG Stage 2 SMS Tests: 8.1 and 8.3 Tests

General Procedure

This section describes general procedures for Mobile-Terminated SMS tests.

  • STEP A: Set Up the Mobile-Terminated SMS Parameters
  • STEP B: Create/Edit the Mobile-Terminated Message Contents
  • STEP C: Send an SMS Message to the Mobile Station
    • Method 1: Sending an SMS message while in idle state
    • Method 2: Sending an SMS message via a temporary SO6 or SO14 connection.
    • Method 3: Sending an SMS message while in a voice or data call.

      NOTE
      Standards specify that shorter messages are sent on the control channel and longer messages are sent on the traffic channel. The test set does not support changing the channel based on the message length and will truncate the message to be sent to the mobile station as necessary for the current configuration (see How Does the Test Set Build the Mobile-Terminated Message? ).

STEP A: Set Up the Mobile-Terminated SMS Parameters

  1. Press the Call Setup key.
  2. Press the More key on the lower left side of the test set two times until 3 of 3 of the Call Control menu is displayed.
  3. Press the F5 ( Short Message Service ), go to SMS Control menu.
  4. Press the F2 ( Mobile-Term SMS Parameters ). The Mobile-Terminated SMS Parameters menu appears.
  5. Set the parameters as desired. See Setting Mobile-Terminated SMS Parameters for the parameters description. For example, set the Service to Point To Point for point-to-point SMS tests, or set the Service to Broadcast for broadcast SMS tests.
    1. Turn the knob to highlight a parameter and then press the knob.
    2. Enter a value or selection and press the knob.
  6. Press the F6 ( Close Menu ) to go back to the SMS Control menu. The parameters you've set in step 5 are displayed in the Mobile-Terminated SMS Info window. See Mobile-Terminated SMS Info for details.

STEP B: Create/Edit the Mobile-Terminated Message Contents

  1. Press the F4 ( Create/Edit Message ) on the SMS Control menu. The Create/Edit menu appears.
  2. Press the F3 ( Message Source ). You can select either ASCII or HEX data entry format.
  3. (Optional) Clear the message contents currently in the Mobile-Terminated Message window by pressing the F2 ( Clear Message ).
  4. Based on the setting of Message Source ( F3 ) in step 2, the F1 softkey is labeled as either Enter/Edit SMS ASCII Message or Enter/Edit SMS Hex Message . Press the F1 , the Enter/Edit SMS Message menu for the selected message source appears.
  5. Enter/edit the message contents as desired. For more information about the editing commands, see Enter/Edit Message Contents . The contents you entered appear in the Mobile-Terminated Message window.
    For example, you want to send a message to the mobile station with the contents of "Let's have lunch at 12:00." Assuming ASCII is selected in the Message Source ( F3 ).
    1. Turn the knob to highlight the A-Z and then press the knob. Select the L and then Done by using the knob.
    2. Turn the knob to highlight the a-z and then press the knob. Select the e , t , s , space , h , a , v , e , space , l , u , n , c , h , a , t , space , and then Done by using the knob .
    3. Turn the knob to highlight the 0-9 and then press the knob. Select the 1 , 2 , 0 , 0 , . (period) and then Done by using the knob.
    4. To insert the : (colon) between 2 and 0, turn and knob to highlight the Character Index and then press the knob. Turn the knob counterclockwise until the caret (^) is positioned at the 2 or current Character Index value is 20, then press the knob. Turn the knob to highlight the Other Characters and then press the knob. Select the : (colon) and then Done by using the knob.
    5. To insert the ' (apostrophe) between t and s, turn and knob to highlight the Character Index and then press the knob. Turn the knob counterclockwise until the caret (^) is positioned at the character t or current Character Index value is 2, then press the knob. Turn the knob to highlight the Other Characters and then press the knob. Select the ' (apostrophe) and then Done by using the knob.
    6. If you want to delete some characters due to wrong editing, highlight the Edit Command and then select Delete or Backspace command.

      NOTE
      The "<--" and the numeric keys on the DATA ENTRY field of the test set's front panel have no effect on short message editing.

    7. Press the F6 ( Close Menu ). Now, you've finished the message contents editing.
  6. (Optional) If you want to send a long message, you can simply set the Message Repeat ( F4 ) to repeat the message contents you've entered. See Set Message Repeat for details. You will notice that the Message Length in Mobile-Terminated SMS Info window varies with the Message Repeat ( F4 ) setting. The repeats of the message contents are not shown in Mobile-Terminated Message window.
  7. Press the F6 ( Return ) to go back to the SMS Control menu. Now, you are ready to send a short message to the mobile station.

STEP C: Send an SMS Message to the Mobile Station

You can send a short message to the mobile station whether it is idle or engaged in a voice or data call. The test set provides three methods for your choice (see Sending an SMS Message to the Mobile Station for details):

Method 1: Sending an SMS message while in idle state

  1. If you would like log the protocol messages exchanged between the test set and the mobile station, set up the Wireless Protocol Advisor (WPA) and start logging. See Logging SMS Messages .
  2. Connect the mobile station to the test set.
  3. Power on the mobile station and wait for the mobile station to perform a power up registration. The mobile station information should appear in the Mobile Reported Information window after a successful registration. Otherwise, perform the steps 1 through 9 in How Do I Set Up an IS-2000 Call? to have the mobile station registered. The current call status is Idle.
  4. Send an SMS message you've created in STEP B to the mobile station on the control channel, F-PCH or the F-CCCH being configured (see Control Channel Configuration ) while in Idle state.
    • Press the Call Setup key.
    • Press the More key on the lower left side of the test set two times until 3 of 3 of the Call Control menu is displayed.
    • Press the F5 ( Short Message Service ), go to SMS Control menu.
    • Press the F1 ( Send Message ).
  5. The test set will wait for the acknowledgment from the mobile station. Observe the SMS Message Acknowledge Info window for the indications, see SMS Message Acknowledge Info for details.
  6. Observe the display on the mobile station to confirm that the message(s) were received.
  7. If you are capturing a log, stop logging.

Method 2: Sending an SMS message via a temporary SO6 or SO14 connection.

  1. If you would like log the protocol messages exchanged between the test set and the mobile station, set up the Wireless Protocol Advisor (WPA) and start logging. See Logging SMS Messages .
  2. Connect the mobile station to the test set.
  3. Power on the mobile station and wait for the mobile station to perform a power up registration. The mobile station information should appear in the Mobile Reported Information window after a successful registration. Otherwise, perform the steps 1 through 9 in How Do I Set Up an IS-2000 Call? to have the mobile station registered. The current Call status is Idle.
  4. Set the service option for the current selected radio configurations to SO6 or SO14. See steps 6 and 7 in How Do I Set Up an IS-2000 Call? .
  5. Send an SMS message you've created in STEP B by establishing a call in SO6 or SO14:
    • Press the Call Setup key.
    • Press the More key on the lower left side of the test set two times until 3 of 3 of the Call Control menu is displayed.
    • Press the F5 ( Short Message Service ), go to SMS Control menu.
    • Press the More key, go to 2 of 2 of the SMS Control menu.
    • Press the F3 ( Originate Call ).
  6. Observe the state changes of the SMS Status in the SMS Message Acknowledge Info window and the call status in the Active Cell field. See SMS Status Description for details.
    • State changes in Active Cell field: Idle -> Paging -> Access Probe -> Connected -> Idle
    • State changes in SMS Status: Idle -> Paging -> Sending -> Waiting -> MS Ack

    NOTE
    You will notice that the call is automatically terminated when the test set receives the acknowledgment from the mobile station or after the period of the ~15 seconds since the connection (see Mobile-Terminated Message Timeout ).

  7. Observe the display on the mobile station to confirm that the message(s) were received.
  8. If you are capturing a log, stop logging.

Method 3: Sending an SMS message while in a voice or data call.

  1. If you would like log the protocol messages exchanged between the test set and the mobile station, set up the Wireless Protocol Advisor (WPA) and start logging. See Logging SMS Messages .
  2. Connect the mobile station to the test set.
  3. Establish a voice or data call (for example, SO3). Follow the procedure in How Do I Set Up an IS-2000 Call? . Make sure that the service option is set to any value other than SO6 and SO14. Verify that the call has established by checking for Connected in the Active Cell field.
  4. Send an SMS message you've created in STEP B to the mobile station while in a call.
    • Press the Call Setup key.
    • Press the More key on the lower left side of the test set two times until 3 of 3 of the Call Control menu is displayed.
    • Press the F5 ( Short Message Service ), go to SMS Control menu.
    • Press the F1 ( Send Message ).
  5. The test set will wait for the acknowledgment from the mobile station. Observe the SMS Message Acknowledge Info window for the indications, see SMS Message Acknowledge Info for details. The call remains connected unless you disconnect the call.
  6. Observe the display on the mobile station to confirm that the message(s) were received.
  7. If you are capturing a log, stop logging.

Performing CDG Stage 2 SMS Tests: 8.1 and 8.3 Tests

All of the tests as specified in the CDG Stage 2 8.1 Mobile Station Terminated SMS Tests and 8.3 Broadcast SMS Tests can follow the General Procedure . The special settings required for each test are listed in the Mobile-Terminated SMS Tests

Mobile-Terminated SMS Tests

CDG Stage 2 Tests

Specific Setting Required for the Test During the General Procedure

8.1 Mobile Station Terminated SMS Tests (for all 8.1x tests, set the Service to Point To Point in STEP A, substep 5)

8.1.1 Paging Channel SMS Delivery Procedures

In STEP C, use method 1 to send the short message to the mobile station.

8.1.2 SMS Delivery Procedures when Message Too Large for Paging Channel

In STEP C, use method 2 to send the short message to the mobile station.

NOTE
The test set does not support changing the channel based on the message length. You need to force the test set to send the short message to the mobile station over the traffic channel.

8.1.3 Traffic Channel SMS Delivery Procedures

In STEP C, use method 3 to send the short message to the mobile station.

8.1.4 Delivery of Maximum Length Message

In STEP C, use method 2 and 3 to send the short message to the mobile station.

NOTE
The maximum length allowed is determined by many factors such as the protocol standards, the channel the message is sent on, message overhead, how many optional parameters are included, etc. If the desired message is truncated before being sent to the MS, the error message "SMS send message truncated due to protocol to <n> characters (where n is the maximum length allowed)" will be generated.

8.1.5 Reserved

8.1.6 SMS Delivery Error - Mobile Station Short Message Buffer Full

Repeat the general procedure (with any method) to send a number of messages to the mobile station (typically 100 messages) until "35 Destination resource shortage" appears on the MS Ack Cause Code of the SMS Message Acknowledge Info window.

8.1.7 Voice Mail Notification

In STEP A, substep 5:

  • set Service to Point To Point
  • set Teleservice to Voice Mail
  • set Voice Mail Count to 99 (for test 1)
    set Voice Mail Count to 0 (for test 2)

After the procedure, you should see that the number of the voice mail messages on the mobile station screen is what you've set for the tests.

8.3 Broadcast SMS Tests

8.3.1 Broadcast SMS Delivery

You can perform the tests with the mobile station #1 which is configured to receive broadcast SMS first, then do the same tests on mobile station #2 which is not configured to receive broadcast SMS.

In STEP A, substep 5:

  • set Service to Broadcast
  • set Priority to Normal (for test 1)
    set Priority to Emergency (for test 2)

Verify that both mobile stations shall display broadcast message (Emergency). Mobile station #1 shall display broadcast message (Normal) but mobile station #2 does not. All received broadcast messages shall be correct and complete.

Related Topics

Mobile-Terminated SMS Message Operation


How Do I Perform Multi-Unit Synchronization?

How Do I Perform Multi-Unit Synchronization?

Last updated: June 18, 2007

This section is only applicable to the lab application and to a test application with the required feature license.

Multiple Sync Clients can synchronize to the same Sync Server at the same time. The following procedure provides an example of how to make a synchronization between two test sets. It assumes that the test set running the E6702B cdma2000 lab application acts as a Sync Client and another one running the E6706A 1xEV-DO lab application acts as a Sync Server.

Prior to the following procedure, make sure you have finished the synchronization connection between the two test sets (see Synchronization Connection Setup ).

General Procedure

Step 1: Configure the Sync Server

Step 2: Configure the Sync Client

Step 3: Perform the synchronization between two test sets

Step 1: Configure the Sync Server

  1. Press the SYSTEM CONFIG key.
  2. Press the Instrument Setup (F1) key and set up the LAN IP Address if it is empty.
  3. Press the CALL SETUP key.
  4. Verify that the Operating Mode ( F1 ) is set to Active Cell and System Type ( F2 ) is set to IS-2000 for this example.
  5. Verify the External Trigger is set to 2 s.

    Go to Call Control 2 of 5 (Lab Application) or Call Control 2 of 3 (Test Application), press the Generator Info ( F3 ), and then press the External Trigger ( F4 ). For details, see How Do I Change Generator Information? .

  6. Press the More key until Call Control 2 of 5 (Lab Application) or Call Control 2 of 3 (Test Application) is displayed.
  7. Press Cell Info ( F2 ) key.
  8. Press CDMA System Time/Sync Info ( F5 ) key.
  9. Press CDMA System Time Parms ( F1 ) key.
  10. Set CDMA system time parameters by using the knob and DATA ENTRY keys.

Step 2: Configure the Sync Client

  1. Press the CALL SETUP key.
  2. Verify that the Operating Mode ( F1 ) is set to Active Cell or and System Type is set to IS-2000 ( F2 ) for this example.
  3. Make sure that test set is idle state.
  4. Press the More key until Call Control 2 of 5 (Lab Application) or Call Control 2 of 3 (Test Application) is displayed.
  5. Press Cell Info ( F2 ) key.
  6. Press CDMA System Time/Sync Info ( F5 ) key.
  7. Press Clear Sync Indications ( F4 ) to clear the last synchronization event information.
  8. Press Ext 8960 IP Add r ( F2 ) key and input the number with DATA ENTRY keys to set the external Sync Server's IP address.

Step 3: Perform the synchronization between two test sets

  1. Press Sync To External Server ( F3 ) on the test set that acts as Sync Client to initiates the synchronization.
  2. A typical synchronization result on the Sync Client and the Sync Server is shown below.
  3. After finishing the synchronization:
    • If desired, press Return key ( F6 ) on the left side of display to close the CDMA System Time and Synchronization Information window.

Related Topics

Performing Multi-Unit Synchronization

Setting CDMA System Time Parameters

GPIB Commands: CALL:CSTime , CALL:STATus , SYSTem:COMMunicate , SYSTem:STATus


CALL:CCHannel

CALL:CCHannel

Last updated: July 18, 2007

GPIB Command Conventions

  • CALL:CCHannel:AUDit:STATe

CALL:CCHannel:AUDit:STATe

Function

Sets/queries whether to enable the test set to transmits Audit Order messages. When it is set to ON, the test set is forced to send continuous Audit Order messages to the mobile station on the paging channel (F-PCH). See Paging Channel MER Procedures .

Setting

 Range: 1|ON|0|OFF

Query

Range: 1|0

*RST Setting

 0 (OFF)

Requirements

Lab Application Revision: B.01 and above

Programming Example

OUTPUT 714;"CALL:CCHannel:AUDit:STATe ON"
!Enable the test set to transmit the Audit Orders.


CALL:CELL2:CLPControl

CALL:CELL2:CLPControl

Last updated: July 18, 2007

GPIB Command Conventions

  • CALL:CELL2:CLPControl:REVerse:MODE

CALL:CELL2:CLPControl:REVerse:MODE

Function

Sets/queries the Cell 2 Rvs CLPC (reverse CDMA channel closed loop power control) mode. To set Cell 1 Rvs CLPC mode for the lab application, see CALL[:CELL[1]]:CLPControl:REVerse:MODE<[:SELected]|:TA2000> .

Power control modes for Cell 2 closed loop power control support the soft/softer handoff feature. The interaction between Cell 1 and Cell 2 power control modes is as follows:

  • During a softer handoff, the power control sub-channels on both Cell 1 and Cell 2 transmit Cell 1 power control mode.
  • During a soft handoff, the power control sub-channel on Cell 1 transmits Cell 1 power control mode and the power control sub-channel on Cell 2 transmits Cell 2 power control mode.
  • During test mode, ACTive power control mode is not available and the power control modes for Cell 1 and Cell 2 are independently selectable.

Selecting between soft/softer handoffs is performed using the CALL:SETup:SHANdoff:TYPe command.

Closed loop power control modes are defined as follows:

  • During ACTive power control mode (available only when Operating Mode is Active Cell), the power control sub-channel will send power control bits that raise or lower the power level of the mobile station depending on the received signal strength of the reverse channel.
  • During UP power control mode, the test set sends all 0 (up) power control bits.
  • During DOWN power control mode, the test set sends all 1 (down) power control bits.
  • During ALTernate power control mode, the test set sends alternating up/down power control bits.
  • During ALT20 power control mode, the test set sends a periodic seqence of 20 up power control bits followed by 20 down power control bits.
  • During CELL1 power control mode, Cell 2 Rvs CLPC (cell 2 reverse closed loop power control) mode is set to the same mode as Cell 1 Rvs CLPC (cell 1 reverse closed loop power control). When the cell 1 CLPC turns to the transient mode (see Reverse CLPC Transient Modes ), the cell 2 is also in the transient mode.

Setting

Range: ACTive|UP|DOWN|ALTernating|ALT20|CELL1

Query

Range: ACT|UP|DOWN|ALT|ALT20|CELL1

*RST Setting

 ACTive

Requirements

Lab Application Revision: A.01 and above

Programming Example

OUTPUT 714;"CALL:CELL2:CLPCONTROL:REVERSE:MODE ALTERNATING"
!Sets the Cell 2 closed loop power control mode to alternating up/down bits.

NOTE
To set the Cell 2 Rvs CLPC (reverse closed loop power control) step size, see CALL[:CELL]:CLPControl:REVerse:STEP .

Related Topics

CALL:CLPControl (Cell 1 reverse closed loop power control settings)


CALL:COUNt

CALL:COUNt

Last updated:June 6, 2007

GPIB Command Conventions

  • CALL:COUNt:CLEar:MS[:ALL]
  • CALL:COUNt:CLEar:MS:IP
  • CALL:COUNt:CLEar:MS:RLP
  • CALL:COUNt:MS:IP[:ALL]?
  • CALL:COUNt:MS:IP:RX?
  • CALL:COUNt:MS:IP:TX?
  • CALL:COUNt:MS:RLP:RX[:TOTal]?
  • CALL:COUNt:MS:RLP:RX:ACK?
  • CALL:COUNt:MS:RLP:RX:DATA:NEW?
  • CALL:COUNt:MS:RLP:RX:DATA:REXMitted?
  • CALL:COUNt:MS:RLP:RX:FILL?
  • CALL:COUNt:MS:RLP:RX:IDLE?
  • CALL:COUNt:MS:RLP:RX:NAK?
  • CALL:COUNt:MS:RLP:RX:NAKKed?
  • CALL:COUNt:MS:RLP:RX:SACK?
  • CALL:COUNt:MS:RLP:RX:SYNC?
  • CALL:COUNt:MS:RLP:TX[:TOTal]?
  • CALL:COUNt:MS:RLP:TX:ACK?
  • CALL:COUNt:MS:RLP:TX:DATA:NEW?
  • CALL:COUNt:MS:RLP:TX:DATA:REXMitted?
  • CALL:COUNt:MS:RLP:TX:ERRor?
  • CALL:COUNt:MS:RLP:TX:FILL?
  • CALL:COUNt:MS:RLP:TX:IDLE?
  • CALL:COUNt:MS:RLP:TX:NAK?
  • CALL:COUNt:MS:RLP:TX:NAKKed?
  • CALL:COUNt:MS:RLP:TX:SACK?
  • CALL:COUNt:MS:RLP:TX:SYNC?
  • CALL:COUNt:MS:RLP:TX:UNKNown?
  • CALL:COUNt:DTMonitor:CLEar
  • CALL:COUNt:DTMonitor<:OTATx|:OTARx|:IPTX|:IPRX>:DRATe?
  • CALL:COUNt:DTMonitor<:OTATx|:OTARx|:IPTX|:IPRX>:DISPlay:STATe
  • CALL:COUNt:DTMonitor<:OTATx|:OTARx|:IPTX|:IPRX>:TRACe?
  • CALL:COUNt:DTMonitor<:OTATx|:OTARx|:IPTX|:IPRX>:TRACe:HISTory:UNUMber?
  • CALL:COUNt:DTMonitor[:ALL]:TRACe:HISTory?
  • CALL:COUNt:DTMonitor[:ALL]:DISPlay:SPAN:TIME
  • CALL:COUNt:DTMonitor[:ALL]:DISPlay:DRATe<:STARt|:STOP>

CALL:COUNt:CLEar:MS[:ALL]

Function

 Clears all IP and RLP data counters. See Data Counters .

Requirements

Lab Application Revision: A.02 and above

Programming Example

OUTPUT 714;"CALL:COUNt:CLEar:MS:ALL" !Clears all data counters.

CALL:COUNt:CLEar:MS:IP

Function

 Clears the data counters for the IP (Internet Protocol) packets and bytes on the forward and reverse channels.

Requirements

Lab Application Revision: A.02 and above

Programming Example

OUTPUT 714;"CALL:COUNt:CLEar:MS:IP" !Clears the IP counters.

CALL:COUNt:CLEar:MS:RLP

Function

 Clears the data counters for the RLP (Radio Link Protocol) frames and octets on the forward and reverse channels. See RLP Counters Information .

Requirements

Lab Application Revision: A.02 and above

Programming Example

OUTPUT 714;"CALL:COUNt:CLEar:MS:RLP" !Clears the RLP counters.

CALL:COUNt:MS:IP[:ALL]?

Function

Queries the number of IP (Internet Protocol) packets and bytes transferred between the test set and the wireless device on both the forward and reverse channels. Results are returned in the following order:

1. Forward packets
2. Forward bytes
3. Reverse packets
4. Reverse bytes

When IP counters reach their maximum value, they remain at that value until cleared.

See Counters .

Query

Range: 0 to 9999999999, 9.91 E+37

Resolution: 1

Requirements

Lab Application Revision: A.02 and above

Programming Example

OUTPUT 714;"CALL:COUNt:MS:IP:ALL?" !Queries the packet and byte count on the forward and reverse channels

CALL:COUNt:MS:IP:RX?

Function

Queries the number of IP (Internet Protocol) packets and bytes transferred between the wireless device and the test set on the forward channel. Results are returned in the following order:

1. Packets
2. Bytes

When IP counters reach their maximum value, they remain at that value until cleared.

See Data Counters .

Query

Range: 0 to 9999999999, 9.91 E+37

Resolution: 1

Requirements

Lab Application Revision: A.02 and above

Programming Example

OUTPUT 714;"CALL:COUNt:MS:IP:RX?"
!Queries the IP packet and byte count on the forward channel.

CALL:COUNt:MS:IP:TX?

Function

Queries the number of IP (Internet Protocol) packets and bytes transferred between the wireless device and the test set on the reverse channel. Results are returned in the following order:

1. Packets
2. Bytes

When IP counters reach their maximum value, they remain at that value until cleared.

See Data Counters .

Query

Range: 0 to 9,999,999,999, 9.91 E+37

Resolution: 1

Requirements

Lab Application Revision: A.02 and above

Programming Example

OUTPUT 714;"CALL:COUNt:MS:IP:TX?" !Queries the IP packet and byte count on the reverse channel.

CALL:COUNt:MS:RLP:RX[:TOTal]?

Function

Queries the total number of frames and octets received by the RLP (Radio Link Protocol) on the forward channel. Results are returned in the following order:

1. Frames
2. Octets

When RLP counters reach their maximum value, they automatically reset to zero and resume the count.

See Data Counters .

Query

Range: 0 to 9999999999, 9.91 E+37

Resolution: 1

Requirements

Lab Application Revision: A.02 and above

Programming Example

OUTPUT 714;"CALL:COUNt:MS:RLP:RX?" !Queries the total number of frames and octets received by RLP on forward channel.

CALL:COUNt:MS:RLP:RX:ACK?

Function

Queries the number of ACK control frames received by the RLP (Radio Link Protocol) on the forward channel.

When RLP counters reach their maximum value, they automatically reset to zero and resume the count.

See Data Counters .

Query

Range: 0 to 9999999999, 9.91 E+37

Resolution: 1

Requirements

Lab Application Revision: A.02 and above

Programming Example

OUTPUT 714;"CALL:COUNt:MS:RLP:RX:ACK?" !Queries the forward channel ACK frame counts.

CALL:COUNt:MS:RLP:RX:DATA:NEW?

Function

Queries the number of new data frames and octets (data being sent for the first time) received by the RLP (Radio Link Protocol) on the forward channel. Results are returned in the following order:

1. Frames.
2. Octets.

When RLP counters reach their maximum value, they automatically reset to zero and resume the count.

See Data Counters .

Query

Range: 0 to 9999999999, 9.91 E+37

Resolution: 1

Requirements

Lab Application Revision: A.02 and above

Programming Example

OUTPUT 714;"CALL:COUNt:MS:RLP:RX:DATA:NEW?" !Queries forward channel new data frame count.

CALL:COUNt:MS:RLP:RX:DATA:REXMitted?

Function

Queries the number of retransmitted data frames and octets received by the RLP (Radio Link Protocol) on the forward channel. Results are returned in the following order:

1. Frames.
2. Octets.

When RLP counters reach their maximum value, they automatically reset to zero and resume the count.

See Data Counters .

Query

Range: 0 to 9999999999, 9.91 E+37

Resolution: 1

Requirements

Lab Application Revision: A.02 and above

Programming Example

OUTPUT 714;"CALL:COUNt:MS:RLP:RX:DATA:REXMitted?" !Queries forward channel retransmitted data frame count.

CALL:COUNt:MS:RLP:RX:FILL?

Function

Queries the number of fill frames received by the RLP (Radio Link Protocol) on the forward channel.

When RLP counters reach their maximum value, they automatically reset to zero and resume the count.

See Data Counters .

Query

Range: 0 to 9999999999, 9.91 E+37

Resolution: 1

Requirements

Lab Application Revision: A.02 and above

Programming Example

OUTPUT 714;"CALL:COUNt:MS:RLP:RX:FILL?" !Queries the forward channel FILL frame count.

CALL:COUNt:MS:RLP:RX:IDLE?

Function

Queries the number of idle frames received by the RLP (Radio Link Protocol) on the forward channel.

When RLP counters reach their maximum value, they automatically reset to zero and resume the count.

See Data Counters .

Query

Range: 0 to 9999999999, 9.91 E+37

Resolution: 1

Requirements

Lab Application Revision: A.02 and above

Programming Example

OUTPUT 714;"CALL:COUNt:MS:RLP:RX:IDLE?" !Queries the forward channel IDLE frame count.

CALL:COUNt:MS:RLP:RX:NAK?

Function

Queries the number of NAK control frames received by the RLP (Radio Link Protocol) on the forward channel.

When RLP counters reach their maximum value, they automatically reset to zero and resume the count.

See Data Counters .

Query

Range: 0 to 9999999999, 9.91 E+37

Resolution: 1

Requirements

Lab Application Revision: A.02 and above

Programming Example

OUTPUT 714;"CALL:COUNt:MS:RLP:RX:NAK?" !Queries the forward channel NAK frame count.

CALL:COUNt:MS:RLP:RX:NAKKed?

Function

Queries the number of data frames that have had retransmission requested in a NAK control frame on the forward channel. Results are returned in the following order:

1. Frames
2. Segments

When RLP counters reach their maximum value, they automatically reset to zero and resume the count.

See Data Counters .

Query

Range: 0 to 9999999999, 9.91 E+37

Resolution: 1

Requirements

Lab Application Revision: A.02 and above

Programming Example

OUTPUT 714;"CALL:COUNt:MS:RLP:RX:NAKKed?" !Queries the forward channel NAKKED frame and segment counts.

CALL:COUNt:MS:RLP:RX:SACK?

Function

Queries the number of SYNC/ACK control frames received by the RLP (Radio Link Protocol) on the forward channel.

When RLP counters reach their maximum value, they automatically reset to zero and resume the count.

See Data Counters .

Query

Range: 0 to 9999999999, 9.91 E+37

Resolution: 1

Requirements

Lab Application Revision: A.02 and above

Programming Example

OUTPUT 714;"CALL:COUNt:MS:RLP:RX:SACK?" !Queries the forward channel SACK frame count.

CALL:COUNt:MS:RLP:RX:SYNC?

Function

Queries the number of SYNC control frames received by the RLP (Radio Link Protocol) on the forward channel.

When RLP counters reach their maximum value, they automatically reset to zero and resume the count.

See Data Counters .

Query

Range: 0 to 9999999999, 9.91 E+37

Resolution: 1

Requirements

Lab Application Revision: A.02 and above

Programming Example

OUTPUT 714;"CALL:COUNt:MS:RLP:RX:SYNC?" !Queries the forward channel SYNC frame count.

CALL:COUNt:MS:RLP:TX[:TOTal]?

Function

Queries the total number of frames and octets received by the RLP (Radio Link Protocol) on the reverse channel. Results are returned in the following order:

1. Frames
2. Octets

When RLP counters reach their maximum value, they automatically reset to zero and resume the count.

See Data Counters .

Query

Range: 0 to 9999999999, 9.91 E+37

Resolution: 1

Requirements

Lab Application Revision: A.02 and above

Programming Example

OUTPUT 714;"CALL:COUNt:MS:RLP:TX?"
!Queries the total number of frames and octets received by RLP on received channel.

CALL:COUNt:MS:RLP:TX:ACK?

Function

Queries the number of ACK control frames received by the RLP (Radio Link Protocol) on the reverse channel.

When RLP counters reach their maximum value, they automatically reset to zero and resume the count.

See Data Counters .

Query

Range: 0 to 9999999999, 9.91 E+37

Resolution: 1

Requirements

Lab Application Revision: A.02 and above

Programming Example

OUTPUT 714;"CALL:COUNt:MS:RLP:TX:ACK?"
!Queries the reverse channel ACK frame count.

CALL:COUNt:MS:RLP:TX:DATA:NEW?

Function

Queries the number of new data frames and octets (data being sent for the first time) received by the RLP (Radio Link Protocol) on the reverse channel. Results are returned in the following order:

1. Frames.
2. Octets.

When RLP counters reach their maximum value, they automatically reset to zero and resume the count.

See Data Counters .

Query

Range: 0 to 9999999999, 9.91 E+37

Resolution: 1

Requirements

Lab Application Revision: A.02 and above

Programming Example

OUTPUT 714;"CALL:COUNt:MS:RLP:TX:DATA:NEW?"
!Queries the reverse channel new data frame count.

CALL:COUNt:MS:RLP:TX:DATA:REXMitted?

Function

Queries the number of retransmitted data frames and octets received by the RLP (Radio Link Protocol) on the reverse channel. Results are returned in the following order:

1. Frames.
2. Octets.

When RLP counters reach their maximum value, they automatically reset to zero and resume the count.

See Data Counters .

Query

Range: 0 to 9999999999, 9.91 E+37

Resolution: 1

Requirements

Lab Application Revision: A.02 and above

Programming Example

OUTPUT 714;"CALL:COUNt:MS:RLP:TX:DATA:REXMitted?"
!Queries the reverse channel retransmitted data frame count.

CALL:COUNt:MS:RLP:TX:ERRor?

Function

Queries the number of error frames received by the RLP (Radio Link Protocol) on the reverse channel.

When RLP counters reach their maximum value, they automatically reset to zero and resume the count.

See Data Counters .

Query

Range: 0 to 9999999999, 9.91 E+37

Resolution: 1

Requirements

Lab Application Revision: A.02 and above

Programming Example

OUTPUT 714;"CALL:COUNt:MS:RLP:TX:ERRor?"
!Queries the reverse channel error frame count.

CALL:COUNt:MS:RLP:TX:FILL?

Function

Queries the number of fill frames received by the RLP (Radio Link Protocol) on the reverse channel.

When RLP counters reach their maximum value, they automatically reset to zero and resume the count.

See Data Counters .

Query

Range: 0 to 9999999999, 9.91 E+37

Resolution: 1

Requirements

Lab Application Revision: A.02 and above

Programming Example

OUTPUT 714;"CALL:COUNt:MS:RLP:TX:FILL?"
!Queries the reverse channel FILL frame count.

CALL:COUNt:MS:RLP:TX:IDLE?

Function

Queries the number of idle frames received by the RLP (Radio Link Protocol) on the reverse channel.

When RLP counters reach their maximum value, they automatically reset to zero and resume the count.

See Data Counters .

Query

Range: 0 to 9999999999, 9.91 E+37

Resolution: 1

Requirements

Lab Application Revision: A.02 and above

Programming Example

OUTPUT 714;"CALL:COUNt:MS:RLP:TX:IDLE?"
!Queries the reverse channel IDLE frame count.

CALL:COUNt:MS:RLP:TX:NAK?

Function

Queries the number of NAK frames received by the RLP (Radio Link Protocol) on the reverse channel.

When RLP counters reach their maximum value, they automatically reset to zero and resume the count.

See Data Counters .

Query

Range: 0 to 9999999999, 9.91 E+37

Resolution: 1

Requirements

Lab Application Revision: A.02 and above

Programming Example

OUTPUT 714;"CALL:COUNt:MS:RLP:TX:NAK?"
!Queries the reverse channel NAK frame count.

CALL:COUNt:MS:RLP:TX:NAKKed?

Function

Queries the number of data frames that have had retransmission requested in a NAK control frame on the reverse channel. Results are returned in the following order:

1. Frames
2. Segments

When RLP counters reach their maximum value, they automatically reset to zero and resume the count.

See Data Counters .

Query

Range: 0 to 9999999999, 9.91 E+37

Resolution: 1

Requirements

Lab Application Revision: A.02 and above

Programming Example

OUTPUT 714;"CALL:COUNt:MS:RLP:TX:NAKKed?"
!Queries the reverse channel NAKKED frame count.

CALL:COUNt:MS:RLP:TX:SACK?

Function

Queries the number of SYNC/ACK control frames received by the RLP (Radio Link Protocol) on the reverse channel.

When RLP counters reach their maximum value, they automatically reset to zero and resume the count.

See Data Counters .

Query

Range: 0 to 9999999999, 9.91 E+37

Resolution: 1

Requirements

Lab Application Revision: A.02 and above

Programming Example

OUTPUT 714;"CALL:COUNt:MS:RLP:RX:SACK?"
!Queries the reverse channel SACK frame count.

CALL:COUNt:MS:RLP:TX:SYNC?

Function

Queries the number of SYNC control frames received by the RLP on the reverse channel.

When RLP counters reach their maximum value, they automatically reset to zero and resume the count.

See Data Counters .

Query

Range: 0 to 9999999999, 9.91 E+37

Resolution: 1

Requirements

Lab Application Revision: A.02 and above

Programming Example

OUTPUT 714;"CALL:COUNt:MS:RLP:TX:SYNC?"
!Queries the reverse channel SYNC frame count.

CALL:COUNt:MS:RLP:TX:UNKNown?

Function

Queries the number of unknown frames received by the RLP (Radio Link Protocol) on the reverse channel.

When RLP counters reach their maximum value, they automatically reset to zero and resume the count.

See Data Counters .

Query

Range: 0 to 9999999999, 9.91 E+37

Resolution: 1

Requirements

Lab Application Revision: A.02 and above

Programming Example

OUTPUT 714;"CALL:COUNt:MS:RLP:TX:UNKNown?"
!Queries the reverse channel unknown frame count.

CALL:COUNt:DTMonitor:CLEar

Function

This command clears all traces from the data throughput monitor display and resets the numeric summary table values to zero.

Requirements

 Lab Application Revision: B.00 and above

Programming Example

OUTPUT 714;"CALL:COUNt:DTMonitor:CLEar"
!Clears all Data Throughput Monitor results.

CALL:COUNt:DTMonitor<:OTATx|:OTARx|:IPTX|:IPRX>:DRATe?

Function

This query returns the summary table values (except for Marker) for any of the four traces:

  • OTA Tx

  • OTA Rx

  • IP Tx

  • IP Rx

The query results for each trace will be returned in a comma-separated string with values in the following order:

  • Average data throughput (bps)

  • Current data throughput (bps)

  • Peak data throughput (bps)

  • Total data transfer (bytes)

Query

Range: 0 to 9999999999, 9.91 E+37

Resolution: 1

Requirements

 Lab Application Revision: B.00 and above

Programming Examples

OUTPUT 714;"CALL:COUNt:DTMonitor:OTATx:DRATe? !Queries OTA Tx summary

OUTPUT 714;"CALL:COUNt:DTMonitor:OTARx:DRATe? !Queries OTA Rx summary

OUTPUT 714;"CALL:COUNt:DTMonitor:IPTX:DRATe? !Queries IP Tx summary

OUTPUT 714;"CALL:COUNt:DTMonitor:IPRX:DRATe? !Queries IP Rx summary

CALL:COUNt:DTMonitor<:OTATx|:OTARx|:IPTX|:IPRX>:DISPlay:STATe

Function

This command sets which data throughput traces are displayed.

Setting

Range: 1|ON|0|OFF
*RST Setting

OTA Tx - ON

OTA Rx - ON

IP Tx - OFF

IP RX - OFF

Requirements

 Lab Application Revision: B.00 and above

Programming Example

OUTPUT 714;"CALL:COUNt:DTMonitor:IPTX:DISPlay:STATe ON"
!Turns the IP TX display state ON.

CALL:COUNt:DTMonitor<:OTATx|:OTARx|:IPTX|:IPRX>:TRACe?

Function

This query returns 600 comma-separated trace values for spreadsheet plotting. These values represent the most recent 10 minute trace data collection period.

NOTE
If the graph is frozen (see Accessing the Monitor Controls ), this command will not return values representative of the graph. If you would like to see the graph this command will return values for, resume the graph then query the trace values.

Trace values can be obtained for any of the four traces:

  • OTA Tx

  • OTA Rx

  • IP Tx

  • IP Rx

Query

Range: 0 to 9999999999, 9.91 E+37

Resolution: 1

Requirements

 Lab Application Revision: B.00 and above

Programming Examples

OUTPUT 714;"CALL:COUNt:DTMonitor:OTATx:TRACe?"
!Queries OTA Tx trace data

CALL:COUNt:DTMonitor<:OTATx|:OTARx|:IPTX|:IPRX>:TRACe:HISTory:UNUMber?

Function

This query returns 600 comma-separated trace values for the last 10-minute trace data collection period captured since the data throughput monitor was enabled or cleared. To find out how many 10-minute periods have elapsed, see CALL:COUNt:DTMonitor[:ALL]:TRACe:HISTory?

These values represent the most recent 10 minutes of trace value collection. Trace values can be obtained for any of the four traces:

  • OTA Tx

  • OTA Rx

  • IP Tx

  • IP Rx

Query

Range: 0 to 9999999999, 9.91 E+37

Resolution: 1

Requirements

 Lab Application Revision: B.00 and above

Programming Examples

OUTPUT 714;"CALL:COUNt:DTMonitor[:ALL]:TRACe:HISTory:UNUMber?"
!Queries OTA Tx trace data

CALL:COUNt:DTMonitor[:ALL]:TRACe:HISTory?

Function

This query returns the number of 10-minute trace data collection periods since the last time the monitor was enabled or cleared.

Query

Range: 0 to 2,147,483,647 10-minute periods, 9.91 E+37

Resolution: 1

Requirements

 Lab Application Revision: B.00 and above

Programming Examples

OUTPUT 714;"CALL:COUNt:DTMonitor:TRACe:HISTory?"
!Queries the number of 10-minute collection periods

CALL:COUNt:DTMonitor[:ALL]:DISPlay:SPAN:TIME

Function

This command sets the time span (x-axis) for the data throughput monitor graphical display.

Setting

Range: 5 to 600 seconds

Query

Range: 5 to 600 seconds
*RST Setting 600 seconds

Requirements

 Lab Application Revision: B.00 and above

Programming Example

OUTPUT 714;"CALL:COUNt:DTMonitor:ALL:DISPlay:SPAN:TIME 100"
!Sets the data throughput monitor time span to 100 seconds.

CALL:COUNt:DTMonitor[:ALL]:DISPlay:DRATe<:STARt|:STOP>

Function

This command sets the data rate range (y-axis) for the data throughput monitor graphical display.

Setting

Start Range: 0 to 4999 kbps
Stop Range: 1 to 5000 kbps

Query

Start Range: 0 to 4999 kbps
Stop Range: 1 to 5000 kbps
*RST Setting

Start: 0 kbps
Stop: 100 kbps

Requirements

 Lab Application Revision: B.00 and above

Programming Example

OUTPUT 714;"CALCulate:COUNt:DTMonitor:ALL DISPlay:DRATe:STOP 50"
!Sets the data throughput monitor range to stop at 50 kbps.


CALL:CPNumber

CALL:CPNumber

Last updated: June 6, 2007

GPIB Command Conventions

  • CALL:CPNumber:INCLusion
  • CALL:CPNumber[1][:SELected]
  • CALL:CPNumber[1]:PLAN
  • CALL:CPNumber[1]:PRESentation[:INDicator]
  • CALL:CPNumber[1]:SCReening[:INDicator]
  • CALL:CPNumber[1]:TA2000
  • CALL:CPNumber[1]:TYPE
  • CALL:CPNumber2[:SELected]
  • CALL:CPNumber2:PLAN
  • CALL:CPNumber2:PRESentation[:INDicator]
  • CALL:CPNumber2:SCReening[:INDicator]
  • CALL:CPNumber2:TA2000
  • CALL:CPNumber2:TYPE

CALL:CPNumber:INCLusion

Function

Sets/queries whether to include the calling party number information record to the called mobile station.

When "INCLude" is selected, the calling party number information record set by following commands will take effect: CALL:CPNumber[1][:SELected] , CALL:CPNumber[1]:PLAN , CALL:CPNumber[1]:PRESentation[:INDicator] , CALL:CPNumber[1]:SCReening[:INDicator] , CALL:CPNumber[1]:TYPE , CALL:CPNumber2[:SELected] , CALL:CPNumber2:PLAN , CALL:CPNumber2:PRESentation[:INDicator] , CALL:CPNumber2:SCReening[:INDicator] , CALL:CPNumber2:TYPE . Calling party 2 related settings are only used in call waiting test.

Setting

 Range: INCLude| EXCLude

Query

Range: INCL|EXCL

*RST Setting

EXCL

Requirement

Lab Application Revision: 04040116 (preliminary release)

Lab Application Revision: B.11 and above: support calling party 2 parameters.

Programming Example

OUTPUT 714;"CALL:CPNumber:INCLusion INCLude"
!Set to include the calling party number[1] to the called mobile station and also include calling party number 2 in call waiting test.

CALL:CPNumber[1][:SELected]

Function

Sets/queries the ASCII representation of each character of the calling party number.

It is displayed on the called mobile station's screen when "ALLowed" is selected by CALL:CPNumber[1]:PRESentation[:INDicator] .

Setting

 Range: 0 to 20 characters enclosed by quotes, each character from the set of 0123456789abc*#

Query

Range: same as setting

*RST Setting

"5099214001"

Requirement

Lab Application Revision: 04040116 (preliminary release)

Programming Example

OUTPUT 714;"CALL:CPNumber '#0123456789*'"
!Sets the calling party[1] number to #0123456789*.

CALL:CPNumber[1]:PLAN

Function

Sets/queries the numbering plan used for the calling party[1] number. See Parameters Description for details.

This setting is useful only when INCLude is selected by CALL:CPNumber:INCLusion .

Setting

Range: UNKNown|ISDN|DATA|TELex|PRIVate

Query

Range: UNKN|ISDN|DATA|TEL|PRIV

*RST Setting

 UNKN

Requirement

Lab Application Revision: 04040116 (preliminary release)

Programming Example

OUTPUT 714;"CALL:CPNumber:PLAN PRIVate"
!Set the numbering plan for calling party[1] number to private.

CALL:CPNumber[1]:PRESentation[:INDicator]

Function

Sets/queries the presentation indicator (PI) used for the calling party[1] number. See Parameters Description for details.

This setting takes effect only when INCLude is selected by CALL:CPNumber:INCLusion .

Setting

Range: ALLowed|RESTricted|NNAVailable

Query

 Range: ALL|REST|NNAV

*RST Setting

ALL

Requirement

Lab Application Revision: 04040116 (preliminary release)

Programming Example

OUTPUT 714;"CALL:CPNumber:PRESentation RESTricted"
!Set the presentation indicator of Calling Party[1] Number to restricted.

CALL:CPNumber[1]:SCReening[:INDicator]

Function

Sets/queries the screening indicator (SI) for the calling party[1] number. See Parameters Description for details.

This setting takes effect only when INCLude is selected by CALL:CPNumber:INCLusion .

Setting

Range: UNSCreened|UVPassed|NVFailed|NETWork

Query

Range: UNSC|UVP|UVF|NETW

*RST Setting

UNSC

Requirement

Lab Application Revision: 04040116 (preliminary release)

Programming Example

OUTPUT 714;"CALL:CPNumber:SCReening NETWork"
!Set the screening indicator of calling party[1] number to network.

CALL:CPNumber[1]:TA2000

Function

Sets/queries the ASCII representation of each character of the calling party[1] number in the fast switching application.

It is displayed on the called mobile station's screen when "ALLowed" is selected by CALL:CPNumber[1]:PRESentation[:INDicator] .

Setting

Range: 0 to 20 characters enclosed by quotes, each character from the set of 0123456789abc*#

Query

Range: same as setting

*RST Setting

 "5099214001"

Requirement

Lab Application Revision: 04040116 (preliminary release)

Programming Example

OUTPUT 714;"CALL:CPNumber:TA2000 '#0123456789*'"
!Sets the calling party[1] number to #0123456789*.

CALL:CPNumber[1]:TYPE

Function

Sets/queries the number type of the calling party[1] number. See Parameters Description for details.

This setting takes effect only when INCLude is selected by CALL:CPNumber:INCLusion .

Setting

 Range: UNKNown|INATional|NATional|NETWork|SUBScirber|ABBReviated

Query

Range: UNKN|INAT|NAT|NETW|SUBS|ABBR

*RST Setting

UNKN

Requirement

Lab Application Revision: 04040116 (preliminary release)

Programming Example

OUTPUT 714;"CALL:CPNumber:TYPE NATional"
!Set the number type of calling party[1] number to national.

CALL:CPNumber2[:SELected]

Function

Sets/queries the ASCII representation of each character of the calling party2 number.

It is displayed on the called mobile station's screen when "ALLowed" is selected by CALL:CPNumber[1]:PRESentation[:INDicator] .

Setting

Range: 0 to 20 characters enclosed by quotes, each character from the set of 0123456789abc*#

Query

Range: same as setting

*RST Setting

 "5099214002"

Requirement

Lab Application Revision: B.04 and above

Programming Example

OUTPUT 714;"CALL:CPNumber2 '#0123456789*'"
!Sets the calling party 2 number to #0123456789*.

CALL:CPNumber2:PLAN

Function

Sets/queries the numbering plan used for the calling party2 number. See Parameters Description for details.

This setting is useful only when INCLude is selected by CALL:CPNumber:INCLusion .

Setting

Range: UNKNown|ISDN|DATA|TELex|PRIVate

Query

Range: UNKN|ISDN|DATA|TEL|PRIV

*RST Setting

UNKN

Requirement

 Lab Application Revision: B.04 and above

Programming Example

OUTPUT 714;"CALL:CPNumber2:PLAN PRIVate"
!Set the numbering plan for calling party 2 number to private.

CALL:CPNumber2:PRESentation[:INDicator]

Function

Sets/queries the presentation indicator (PI) used for the calling party2 number. See Parameters Description for details.

This setting takes effect only when INCLude is selected by CALL:CPNumber:INCLusion .

Setting

Range: ALLowed|RESTricted|NNAVailable

Query

Range: ALL|REST|NNAV

*RST Setting

ALL

Requirement

Lab Application Revision: B.04 and above

Programming Example

OUTPUT 714;"CALL:CPNumber2:PRESentation RESTricted"
!Set the presentation indicator of Calling Party 2 Number to restricted.

CALL:CPNumber2:SCReening[:INDicator]

Function | Sets/queries the screening indicator (SI) for the calling party2 number. See Parameters Description for details. This setting takes effect only when INCLude is selected by CALL:CPNumber:INCLusion .
Setting | Range: UNSCreened|UVPassed|NVFailed|NETWork
Query | Range: UNSC|UVP|UVF|NETW
*RST Setting | UNSC
Requirement | Lab Application Revision: B.04 and above
Programming Example

CALL:CPNumber2:TA2000

Function

Sets/queries the ASCII representation of each character of the calling party2 number in the fast switching application.

It is displayed on the called mobile station's screen when "ALLowed" is selected by CALL:CPNumber2:PRESentation[:INDicator] .

Setting

Range: 0 to 20 characters enclosed by quotes, each character from the set of 0123456789abc*#

Query

Range: same as setting

*RST Setting

"5099214002"

Requirement

Lab Application Revision: B.04 and above

Programming Example

OUTPUT 714;"CALL:CPNumber2:TA2000 '#0123456789*'"
!Sets the calling party 2 number to #0123456789*.

CALL:CPNumber2:TYPE

Function

Sets/queries the number type of the calling party number. See Parameters Description for details.

This setting takes effect only when INCLude is selected by CALL:CPNumber:INCLusion .

Setting

Range: UNKNown|INATional|NATional|NETWork|SUBScirber|ABBReviated

Query

Range: UNKN|INAT|NAT|NETW|SUBS|ABBR

*RST Setting

UNKN

Requirement

Lab Application Revision: B.04 and above

Programming Example

OUTPUT 714;"CALL:CPNumber2:TYPE NATional"
!Set the number type of calling party 2 number to national.

Related Topics

Manual Operation: How Do I Perform Calling Party Number Verification? How Do I Perform Call Waiting Test?

Calling Party Number Parameters


CALL:SSERvice:WAITing

CALL:SSERvice:WAITing

Last updated: June 7, 2007

GPIB Command Conventions

  • CALL:SSERvice:WAITing:CPNumber[1]:CONNect
  • CALL:SSERvice:WAITing:CPNumber[1]:DCONnect
  • CALL:SSERvice:WAITing:CPNumber[1]:STATus[:STATe]?
  • CALL:SSERvice:WAITing:CPNumber2:CONNect
  • CALL:SSERvice:WAITing:CPNumber2:DCONnect
  • CALL:SSERvice:WAITing:CPNumber2:STATus[:STATe]?

CALL:SSERvice:WAITing:CPNumber[1]:CONNect

Function

Connect call with calling party 1. This immediate action is only applicable when calling party 1 status is Idle and calling party 2 status is Active. See Call Waiting State Transition for details.

Requirement

Lab Application Revision: B.04 and above

Programming Example

OUTPUT 714;"CALL:SSERvice:WAITing:CPNumber:CONNect"

CALL:SSERvice:WAITing:CPNumber[1]:DCONnect

Function

 Disconnect call with calling party 1. This immediate action is only applicable when calling party 1 status is Active or Waiting. See Call Waiting State Transition for details.

Requirement

Lab Application Revision: B.04 and above

Programming Example

OUTPUT 714;"CALL:SSERvice:WAITing:CPNumber:DCONnect"

CALL:SSERvice:WAITing:CPNumber[1]:STATus[:STATe]?

Function

Queries the current status of the voice call between calling party 1 and the MS. See Call Waiting State Transition for details.

Query

Range: IDLE|WAITing|ACTive

*RST Setting

IDLE

Requirement

 Lab Application Revision: B.04 and above

Programming Example

OUTPUT 714;"CALL:SSERvice:WAITing:CPNumber:STATus[:STATe]?"

!Returns the current voice call state of calling party 1.

CALL:SSERvice:WAITing:CPNumber2:CONNect

Function

Connect call with calling party 2. This immediate action is only applicable when calling party 1 status is Active and calling party 2 status is Idle. See Call Waiting State Transition for details.

Requirement

Lab Application Revision: B.04 and above

Programming Example

OUTPUT 714;"CALL:SSERvice:WAITing:CPNumber2:CONNect"

CALL:SSERvice:WAITing:CPNumber2:DCONnect

Function

 Disconnect call with calling party 2. This immediate action is only applicable when calling party 2 status is Active or Waiting. See Call Waiting State Transition for details.

Requirement

Lab Application Revision: B.04 and above

Programming Example

OUTPUT 714;"CALL:SSERvice:WAITing:CPNumber2:DCONnect"

CALL:SSERvice:WAITing:CPNumber2:STATus[:STATe]?

Function

 Queries the current status of the voice call between calling party 2 and the MS. See Call Waiting State Transition for details.

Query

Range: IDLE|WAITing|ACTive

*RST Setting

IDLE

Requirement

 Lab Application Revision: B.04 and above

Programming Example

OUTPUT 714;"CALL:SSERvice:WAITing:CPNumber2:STATus[:STATe]?"

!Returns the current voice call state of calling party 2.

Related Topics

Manual Operation: How Do I Perform Call Waiting Test?

Call Waiting

Calling Party Number Parameters


CALL:DATA

CALL:DATA

Last updated: June 6, 2007

GPIB Command Conventions

  • CALL:DATA:PING[:ALL]?
  • CALL:DATA:PING:ICOunt?
  • CALL:DATA:PING:PACKets:RX?
  • CALL:DATA:PING:PACKets:TX?
  • CALL:DATA:PING:PLOSs?
  • CALL:DATA:PING:SETup:ALTernate:IP:ADDRess
  • CALL:DATA:PING:SETup:COUNt
  • CALL:DATA:PING:SETup:DEVice
  • CALL:DATA:PING:SETup:PACKet[:SIZE]
  • CALL:DATA:PING:SETup:TIMeout
  • CALL:DATA:PING:STARt
  • CALL:DATA:PING:STOP
  • CALL:DATA:PING:TIME[:AVERage]?
  • CALL:DATA:PING:TIME:MAXimum?
  • CALL:DATA:PING:TIME:MINimum?
  • CALL:DATA:PDSNode:EXTernal:IP:ADDRess
  • CALL:DATA:PDSNode:EXTernal:STATe
  • CALL:DATA:PDSNode:EXTernal:TCP:PORT
  • CALL:DATA:PDSNode:EXTernal:TIMeout[:CONNect]

CALL:DATA:PING[:ALL]?

Function

This command returns the following results: packets transmitted, packets received, percent packets lost, minimum round trip time (in seconds), average round trip time (in seconds), maximum round trip time (in seconds).

This command will return 9.91 E+37 if the ping results are not available.
Requirements Lab Application Revision: A.02 and above

Programming Example

OUTPUT 714;"CALL:DATA:PING:ALL?"

ENTER 714;Pxmit,Prcvd,Plost,Min_time,Avg_time,Max_time

CALL:DATA:PING:ICOunt?

Function

This command queries the value that is available when the query is received.
Requirements Lab Application Revision: A.02 and above

Programming Example

OUTPUT 714;"CALL:DATA:PING:ICOUNT?"

CALL:DATA:PING:PACKets:RX?

Function

This command queries the number of packets received from the device being tested or from the alternate device if CALL:DATA:PING:SETup:DEVice is set to ALTernate.

This command will return 9.91 E+37 if the ping results are not available.
Requirements Lab Application Revision: A.02 and above

Programming Example

OUTPUT 714;"CALL:DATA:PING:PACKETS:RX?"

!Queries the number of packets received from the device being tested.

CALL:DATA:PING:PACKets:TX?

Function

This queries the number of packets transmitted from the test set.

This command will return 9.91 E+37 if the ping results are not available.
Requirements Lab Application Revision: A.02 and above

Programming Example

OUTPUT 714;"CALL:DATA:PING:PACKETS:TX?"

!Queries the number of packets transmitted from the test set.

CALL:DATA:PING:PLOSs?

Function

This command queries the percentage of packets lost during the ping session.

This command will return 9.91 E+37 if the ping results are not available.
Requirements Lab Application Revision: A.02 and above

Programming Example

OUTPUT 714;"CALL:DATA:PING:PLOSS?" !Queries the percentage of lost packets.

CALL:DATA:PING:SETup:ALTernate:IP:ADDRess

Function

This sets/queries the alternate internet protocol (IP) address. This address will be used as the address to ping instead of the device under test if the CALL:DATA:PING:SETup:DEVice command is set to ALT.

Setting

Range: IP v4 address in dotted decimal format.

Query

Same as setting.
Requirements Lab Application Revision: A.02 and above

Programming Example

OUTPUT 714;"CALL:DATA:PING:SETUP:ALTERNATE:IP:ADDRESS `192.168.16.57'"

CALL:DATA:PING:SETup:COUNt

Function

This command set/queries the number of ping IP messages sent for each uninterrupted invocation of the CALL:DATA:PING:STARt command.

Setting

Range: 1 to 1000

Query

Range: 1 to 1000
Requirements Lab Application Revision: A.02 and above

*RST Setting

 10

Programming Example

OUTPUT 714;"CALL:DATA:PING:SETUP:COUNT 20"

CALL:DATA:PING:SETup:DEVice

Function

This command sets/queries which device address is used in the ping IP packets, the address of the device under test, or the address of an alternate device.

Setting

Range: DUT|ALTernate

Query

Range: DUT|ALT
Requirements Lab Application Revision: A.02 and above

*RST Setting

 DUT

Programming Example

OUTPUT 714;"CALL:DATA:PING:SETUP:DEVice ALT"

CALL:DATA:PING:SETup:PACKet[:SIZE]

Function

This command sets/queries the number of bytes sent by the test set in each ping packet.

Setting

Range: 8 to 4076

Resolution: 1

Query

 Same as setting
Requirements Lab Application Revision: A.01 and above

*RST Setting

 64 bytes

Programming Example

OUTPUT 714;"CALL:DATA:PING:SETup:PACKet 10"

CALL:DATA:PING:SETup:TIMeout

Function

This command sets or queries how long the test set will wait before ending a ping session.

This command will return 9.91 E+37 if the ping results are not available.

Setting

Range: 1 to 100 seconds

Query

Range: 1 to 100 seconds
Requirements Lab Application Revision: A.01 and above

*RST Setting

 5 seconds

Programming Example

OUTPUT 714;"CALL:DATA:PING:SETUP:TIMEOUT 10"

CALL:DATA:PING:STARt

Function

This command starts a ping session.
Requirements Lab Application Revision: A.01 and above

Programming Example

OUTPUT 714;"CALL:DATA:PING:START"

CALL:DATA:PING:STOP

Function

This command immediately stops a ping session. The ping results will not include counts for any ping message that has not yet received a response.
Requirements Lab Application Revision: A.01 and above

Programming Example

OUTPUT 714;"CALL:DATA:PING:STOP"

CALL:DATA:PING:TIME[:AVERage]?

Function

This command queries the average round trip time (in seconds) for a series of pings.

This command will return 9.91 E+37 if the CALL:FUNCtion:DATA:TYPE command is not set to IPData, or if ping results are not available.
Requirements Lab Application Revision: A.01 and above

Programming Example

OUTPUT 714;"CALL:DATA:PING:TIME:AVERAGE?"

CALL:DATA:PING:TIME:MAXimum?

Function

This command queries the maximum round trip time (in seconds) for a series of pings.

This command will return 9.91 E+37 if the CALL:FUNCtion:DATA:TYPE command is not set to IPData, or if ping results are not available.
Requirements Lab Application Revision: A.01 and above

Programming Example

OUTPUT 714;"CALL:DATA:PING:TIME:MAXIMUM?"

CALL:DATA:PING:TIME:MINimum?

Function

This command queries the minimum round trip time (in seconds).

This command will return 9.91 E+37 if the CALL:FUNCtion:DATA:TYPE command is not set to IPData, or if ping results are not available.
Requirements Lab Application Revision: A.01 and above

Programming Example

OUTPUT 714;"CALL:DATA:PING:TIME:MINIMUM?"

CALL:DATA:PDSNode:EXTernal:IP:ADDRess

Function

Sets/queries the IP address of external PDSN (MOB-IP-SIM). It will not take effect until the CALL:DATA:PDSNode:EXTernal:STATe is set to ON. See External PDSN IP Address for details.

This setting is stored in the nonvolatile RAM, and will not be changed by a reset or cycling power of the test set.

Setting

Range: 15 characters formatted as follows: A.B.C.D or "" (empty string)
The range of values for A = 0 to 126 and 128 to 223. The range of values for B,C, D = 0 to 255 (no embedded spaces).
("0.0.0.0", "0" or "" (an empty string) will set the external PDSN IP address to be undefined)

Query

Range: same as setting

*RST Setting
  • "" (empty string when shipped from the factory)
  • the value last set and stored in the nonvolatile RAM

Requirements

Lab Application Revision: B.01 and above

Programming Example

OUTPUT 714;"CALL:DATA:PDSNode:EXTernal:IP:ADDRess '130.29.179.220'"
!Sets the External PDSN IP Address to 130.29.179.220.

CALL:DATA:PDSNode:EXTernal:STATe

Function

Sets/queries whether to use the external PDSN simulation (MOB-IP-SIM) by setting the state to On or use the internal PDSN simulation (test set) by setting the state to Off.

You must specify a valid IP address ( CALL:DATA:PDSNode:EXTernal:IP:ADDRess ) and a valid TCP port ( CALL:DATA:PDSNode:EXTernal:TCP:PORT ) for the external PDSN (MOB-IP-SIM) before changing the external PDSN state to on. See External PDSN State for details.

Setting

Range: 1|ON|0|OFF

Query

same as setting

*RST Setting

 0 (OFF)

Requirements

Lab Application Revision: B.01 and above

Programming Example

OUTPUT 714;"CALL:DATA:PDSNode:EXTernal:STATe ON"
!Sets to use the External PDSN.

CALL:DATA:PDSNode:EXTernal:TCP:PORT

Function

Sets/queries the TCP port of the external PDSN (MOB-IP-SIM) which is used by the test set to set up the control connection with the external MOB-IP-SIM. It will not take effect until the CALL:DATA:PDSNode:EXTernal:STATe is set to ON. See External PDSN TCP Port .

This setting is stored in nonvolatile RAM, and will not be changed by a reset or cycling power of the test set.

Setting

Range: 0 to 65535
Resolution: 1

Query

Range: same as setting

*RST Setting
  • 53613 (when shipped from the factory)
  • the value last set and stored in the nonvolatile RAM

Requirements

Lab Application Revision: B.01 and above

Programming Example

OUTPUT 714;"CALL:DATA:PDSNode:EXTernal:TCP:PORT 53600"
!Sets the External PDSN TCP port to 53600.

CALL:DATA:PDSNode:EXTernal:TIMeout[:CONNect]

Function

Sets/queries the maximum amount of time the test set will wait to connect to the external PDSN (MOB-IP-SIM). It will not take effect until the CALL:DATA:PDSNode:EXTernal:STATe is set to ON. See External PDSN Connect Timeout for details.

This setting is stored in nonvolatile RAM, and will not be changed by a reset or cycling power of the test set.

Setting

Range: 1 to 19 seconds
Resolution: 1 second

Query

Range: same as setting

*RST Setting
  • 2 (when shipped from the factory)
  • the value last set and stored in the nonvolatile RAM

Requirements

Lab Application Revision: B.02 and above
Lab Application Revision: B.03.10 and above, value range changed from 0 - 19 seconds to 1 - 19 seconds.

Programming Example

OUTPUT 714;"CALL:DATA:PDSNode:EXTernal:TIMeout 10S"
!Sets the External PDSN timeout to 10 seconds.


CALL:CELL2:DELay

CALL:CELL2:DELay

Last updated:July 18, 2007

GPIB Command Conventions

  • CALL:CELL2:DELay

CALL:CELL2:DELay

Function

This command sets the time delay used during transmission of the Cell 2 baseband channels. The delay is relative to Cell 1.

The amount of delay is limited to 16 PN chips. Settings are limited to increments of 813.8 ns (1/(1.2288 e+06) =813.8ns).

Unlike other time values, this command sets seconds and query returns micro-seconds instead of seconds.

Setting

Range: 0 to 13.02 us (0 to 16 PN chips)

Resolution: 813.8 ns.

Query

Range: Same as setting range.

Resolution: 813.8 ns.

*RST Setting

 12.21 us (15 chips)

Requirements

Lab Application Revision: A.01 and above

Programming Example

OUTPUT 714;"CALL:CELL2:DELAY 0.000003 S"
!Requests a Cell 2 delay of 3 microseconds. The test set will round this value to the nearest PN increment, and the setting will be 3.26 microseconds.


CALL:DORMant

CALL:DORMant

Last updated: June 6, 2007

GPIB Command Conventions

  • CALL:DORMant[:STATe]?

CALL:DORMant[:STATe]?

Function

Queries whether or not the packet data connection is in dormant state.

  • If the packet data connection is in dormant state, the query immediately returns a 1.
  • If the packet data connection is in any other stable state (Idle or Connected + Data), the query immediately returns a 0.
  • If the data change arm timer is armed (see CALL:DCONnected:ARM:STATe? ) and then this is queried, the query will hang until either the data change arm timer is disarmed or the data connection status changes.

See also Packet Data Connection Processing States .

Query

Range: 0|1

*RST Setting

0

Requirements

Lab Application Revision: B.02 and above

Programming Example

OUTPUT 714;"CALL:DORMant?"
!Queries whether the packet data connection is in dormant state.


CALL:CELL2:FCHannel

CALL:CELL2:FCHannel

Last updated:July 18, 2007

GPIB Command Conventions

  • CALL:CELL2:FCHannel[:SLEVel][:SELected]
  • CALL:CELL2:FCHannel:LEVel[:SELected]
  • CALL:CELL2:FCHannel:STATe[:SELected]
  • CALL:CELL2:FCHannel:WALSh

CALL:CELL2:FCHannel[:SLEVel][:SELected]

Function

The setting form of this command performs two functions: (1) sets the Cell 2 F-FCH/Traffic Level (forward fundamental channel), and (2) turns the FCH state to ON.

The query form of this command returns the FCH level.

The optional [:SELected] keyword in this command specifies that the frequency band being set/queried applies to the current system type. At this time there is only one system type choice, DIGital2000. Specifying DIGital2000 will have the same effect as using the optional [:SELected] keyword.

This command applies to the IS-2000 Cell 2 F-FCH/Traffic channel only. To make level changes to the IS-95 Cell 2 Traffic channel, see CALL:CELL2:TRAFfic

Setting

Range: 0 to -30 dB

Resolution: 0.01 dB

Query

Range: 0 to -30 dB

Resolution: 0.01 dB

*RST Setting

-15.6 dB

Requirements

Lab Application Revision: A.01 and above

Programming Example

OUTPUT 714;"CALL:CELL2:FCHANNEL:SLEVEL:DIGITAL2000 -10 dB"
!Sets the forward fundamental channel (FCH) state to ON and sets the level to -10 dB.

CALL:CELL2:FCHannel:LEVel[:SELected]

Function

Sets/queries the Cell 2 F-FCH/Traffic Level (forward fundamental channel).

The optional [:SELected] keyword in this command specifies that the frequency band being set/queried applies to the current system type. At this time there is only one system type choice, DIGital2000. Specifying DIGital2000 will have the same effect as using the optional [:SELected] keyword.

This command applies to the IS-2000 Cell 2 F-FCH/Traffic channel only. To make level changes to the IS-95 Cell 2 Traffic channel, see CALL:CELL2:TRAFfic

Setting

Range: 0 to -30 dB

Resolution: 0.01 dB

Query

Range: 0 to -30 dB

Resolution: 0.01 dB

*RST Setting

 -15.6 dB

Requirements

Lab Application Revision: A.01 and above

Programming Example

OUTPUT 714;"CALL:CELL2:FCHANNEL:LEVEL:SELECTED -10 dB"

CALL:CELL2:FCHannel:STATe[:SELected]

Function

Sets/queries the on/off state of the Cell 2 F-FCH/Traffic Level (forward fundamental channel).

The optional [:SELected] keyword in this command specifies that the frequency band being set/queried applies to the current system type. At this time there is only one system type choice, DIGital2000. Specifying DIGital2000 will have the same effect as using the optional [:SELected] keyword.

This command applies to the IS-2000 Cell 2 F-FCH/Traffic channel only. To make level changes to the IS-95 Cell 2 Traffic channel, see CALL:CELL2:TRAFfic

Setting

Range: 1|ON|0|OFF

Query

Range: 1|0

*RST Setting

ON

Requirements

Lab Application Revision: A.01 and above

Programming Example

OUTPUT 714;"CALL:CELL2:FCHANNEL:STATE:DIGITAL2000 OFF"
!Turns off the forward fundamental channel.

CALL:CELL2:FCHannel:WALSh

Function

Sets/queries the Cell 2 F-FCH/Traffic Walsh Code. The Walsh codes allowed for use with this command are part of a reserved codespace that has been created by fixing other code channels to pre-determined values. Reserving this codespace eliminates the possibility of conflicts that can arise with lower walsh code sets which are used in certain radio configurations.

Setting

Range: CODE10|CODE14|CODE26|CODE30|CODE42|CODE46|CODE58|CODE62

Query

Range: CODE10|CODE14|CODE26|CODE30|CODE42|CODE46|CODE58|CODE62

*RST Setting

CODE10

Requirements

Lab Application Revision: A.01 and above

Programming Example

OUTPUT 714;"CALL:CELL2:FCHANNEL:WALSH CODE14"
!Sets the forward fundamental channel walsh code to 14.

Related Topics

CALL:FCHannel (Cell 1 F-FCH/Traffic or Walsh Code settings)


CALL:FPControl

CALL:FPControl

Last updated: June 6, 2007

GPIB Command Conventions

  • CALL[:CELL]:FPControl:EIBCount[:ALL]?
  • CALL[:CELL]:FPControl:EIBCount:CLEar
  • CALL[:CELL]:FPControl:EIBCount:STARt
  • CALL[:CELL]:FPControl:EIBCount:STOP
  • CALL[:CELL]:FPControl:FCHannel:FERate:TARGet
  • CALL[:CELL]:FPControl:FCHannel:LEVel:MAXimuml
  • CALL[:CELL]:FPControl:FCHannel:SETPoint:INITial
  • CALL[:CELL]:FPControl:FCHannel:SETPoint:MAXimum
  • CALL[:CELL]:FPControl:FCHannel:SETPoint:MINimum
  • CALL[:CELL]:FPControl:MODE
  • CALL[:CELL]:FPControl:OLReport:CLEar
  • CALL[:CELL]:FPControl:OLReport:FCHannel:SETPoint:CURRent?
  • CALL[:CELL]:FPControl:OLReport:REQuest
  • CALL[:CELL]:FPControl:STEP

CALL[:CELL]:FPControl:EIBCount[:ALL]?

Function

Queries the F-FCH EIB test results. It is returned in a comma separated list in the order of Good Frames Matched, Good Frames Not Matched, Good Frames Not Received, Bad Frames Matched, Bad Frames Not Matched, Bad Frames Not Received. See MS Reported Erasure Indicator Bit (EIB) Information for details.

Query

Range: 0 to 2147483647
Resolution: 1

*RST Setting

0,0,0,0,0,0
Requirements Lab Application Revision: B.02 and above

Programming Example

OUTPUT 714;"CALL:FPControl:EIBCount?"

CALL[:CELL]:FPControl:EIBCount:CLEar

Function

This command clears all of the F-FCH EIB counters to zeroes. See To Clear the MS Reported Erasure Indicator Bit (EIB) Information for details.
Requirements Lab Application Revision: B.02 and above

Programming Example

OUTPUT 714;"CALL:FPControl:EIBCount:CLEar"
!Clears all of the EIB counters to zeroes.

CALL[:CELL]:FPControl:EIBCount:STARt

Function

This command starts to increment the F-FCH EIB counters. See To Start/Stop EIB Counters for details.
Requirements Lab Application Revision: B.02 and above

Programming Example

OUTPUT 714;"CALL:FPControl:EIBCount:STARt"
!Starts to increment the F-FCH EIB counters.

CALL[:CELL]:FPControl:EIBCount:STOP

Function

This command stops incrementing the EIB counters.
Requirements Lab Application Revision: B.02 and above

Programming Example

OUTPUT 714;"CALL:FPControl:EIBCount:STOP"
!Stops incrementing the F-FCH EIB counters.

CALL[:CELL]:FPControl:FCHannel:FERate:TARGet

Function

Sets/queries the target frame error rate on the F-FCH for the outer loop power control. See FPC F-FCH Target FER for details.

Setting

Range: 0.2 to 30 (in percent)
Resolution: variable (see below)

Query

Range: 0.2, 0.5 - 10 (in 0.5 increment), 11 - 15 (in 1.0 increment), 18 - 30 (in 3.0 increment)

*RST Setting

1 (in percent)
Requirements Lab Application Revision: B.02 and above

Programming Example

OUTPUT 714;"CALL:FPControl:FCHannel:FERate:TARGet"
!Sets target FER for outer loop power control

CALL[:CELL]:FPControl:FCHannel:LEVel:MAXimuml

Function

Sets/queries the upper limit of the F-FCH level (Ec/Ior) that the test set can be adjusted to according to the forward power control by the MS. See Maximum F-FCH Level for details.

Setting

Range: -30 to -2 dB
Resolution: 0.0001 dB

Query

Same as the settings

*RST Setting

-3 dB
Requirements Lab Application Revision: B.02 and above

Programming Example

OUTPUT 714;"CALL:FPControl:FCHannel:LEVel:MAXimum -10"
!Sets the upper limt of the F-FCH level to -10 dB
!according to the forward power control by MS.

CALL[:CELL]:FPControl:FCHannel:SETPoint:INITial

Function

Sets/queries the initial F-FCH outer loop Eb/Nt setpoint in dB. See FPC F-FCH Initial Setpoint (dB) for details.

Setting

Range: 0 to 31.875 dB
Resolution: 0.125 dB

Query

Same as the settings

*RST Setting

8 dB
Requirements Lab Application Revision: B.02 and above

Programming Example

OUTPUT 714;"CALL:FPControl:FCHannel:SETPoint:INITial 10"
!Sets the initial F-FCH outer loop Eb/Nt setpoint to 10 dB.

CALL[:CELL]:FPControl:FCHannel:SETPoint:MAXimum

Function

Sets/queries the maximum F-FCH outer loop Eb/Nt setpoint in dB. See FPC F-FCH Maximum Setpoint (dB) for details.

Setting

Range: 0 to 31.875 dB
Resolution: 0.125 dB

Query

Same as the settings

*RST Setting

16 dB
Requirements Lab Application Revision: B.02 and above

Programming Example

OUTPUT 714;"CALL:FPControl:FCHannel:SETPoint:MAXimum 10"
!Sets the maximum F-FCH outer loop Eb/Nt setpoint to 10 dB.

CALL[:CELL]:FPControl:FCHannel:SETPoint:MINimum

Function

Sets/queries the minimum F-FCH outer loop Eb/Nt setpoint in dB. See FPC F-FCH Minimum Setpoint (dB) for details.

Setting

Range: 0 to 31.875 dB
Resolution: 0.125 dB

Query

Same as the settings

*RST Setting

2 dB
Requirements Lab Application Revision: B.02 and above

Programming Example

OUTPUT 714;"CALL:FPControl:FCHannel:SETPoint:MINimum 10"
!Sets the minimum F-FCH outer loop Eb/Nt setpoint to 10 dB.

CALL[:CELL]:FPControl:MODE

Function

Sets/queries forward power control (FPC) mode to be used by the mobile station. See FPC Mode for details.

Setting

Range: IGNore|MODE000|MODE011

Query

Range: IGN|MODE000|MODE011

*RST Setting

IGN
Requirements Lab Application Revision: B.02 and above

Programming Example

OUTPUT 714;"CALL:FPControl:MODE MODE000"
!Sets to use the FPC mode 000.

CALL[:CELL]:FPControl:OLReport:CLEar

Function

This command clears all of results reported in Outer Loop Report Message by mobile station. See ?? for details.
Requirements Lab Application Revision: B.02 and above

Programming Example

OUTPUT 714;"CALL:FPControl:OLReport:CLEar"
!Clears the outer loop power control report.

CALL[:CELL]:FPControl:OLReport:FCHannel:SETPoint:CURRent?

Function

Queries the outer loop Eb/Nt setpoint of the F-FCH last retrieved from the moible station by sending the CALL[:CELL]:FPControl:OLReport:REQuest . See MS Reported F-FCH Current Setpoint for detilas.

Query

Range: 0 to 31.875 dB, 9.91E+37
Resolution: 0.125 dB

*RST Setting

9.91E+37
Requirements Lab Application Revision: B.02 and above

Programming Example

OUTPUT 714;"CALL:FPControl:OLReport:FCHannel:SETPoint:CURRent?"
!Queries the outer loop Eb/Nt setpoint of the F-FCH
!last retrieved from the moible station.

CALL[:CELL]:FPControl:OLReport:REQuest

Function

This command sends a request to the mobile station for reporting outer loop power control results which can then be queried with CALL[:CELL]:FPControl:OLReport:FCHannel:SETPoint:CURRent? . See To Request an Outer Loop Report from the MS for details.
Requirements Lab Application Revision: B.02 and above

Programming Example

OUTPUT 714;"CALL:FPControl:OLReport:REQuest"
!Requests the outer loop report from mobile station.

CALL[:CELL]:FPControl:STEP

Function

Sets/queries the power step size for forward power control (FPC). It is used to tells the test set how much to increase or decrease its output power in response to a power control bit from the mobile station. See Forward Power Control Step Size .

Setting

Range: DB1|DBHalf|DBQuarter
(DB1: 1 dB, DBHalf: 0.5 dB, DBQuarter: 0.25 dB)

Query

Range: DB1|DBH|DBQ

*RST Setting

 DBH (0.5 dB)
Requirements Lab Application Revision: B.02 and above

Programming Example

OUTPUT 714;"CALL:FPControl:STEP DB1"
!Sets FPC step size to 1 dB.


CALL:FUNCtion:DATA

CALL:FUNCtion:DATA

Last updated: June 6, 2007

GPIB Command Conventions

  • CALL:FUNCtion:DATA:DORMant

CALL:FUNCtion:DATA:DORMant

Function

Force Dormant causes the test set to release the physical connection (RF link), but attempt to maintain the PPP connection with the mobile station while there is an active packet data connection. It may result in the data connection state going to Dormant or Off depending upon mobile station's response. See Packet Data Connection Processing States .

If this command is executed when the current data connection is other than connected state ( CALL:STATus[:STATe]:DATA? ) or the service option is other than SO33 or SO33 (+ F-SCH), an error "+235,"Digital2000 call processing error; Force dormant requires SO33 and an established data connection" is generated and the operation will be rejected.

Requirements

 Lab Application Revision: B.02 and above

Programming Example

OUTPUT 714;"CALL:FUNCtion:DATA:DORMant"
!Force data connection to dormant state.


CALL:MS:FERate

CALL:MS:FERate

Last updated: June 6, 2007

GPIB Command Conventions

  • CALL:MS:FERate:REPort:BAD?
  • CALL:MS:FERate:REPort:CLEar
  • CALL:MS:FERate:REPort:DELay
  • CALL:MS:FERate:REPort:INTerval
  • CALL:MS:FERate:REPort:PERiod[:STATe]
  • CALL:MS:FERate:REPort:RATio?
  • CALL:MS:FERate:REPort:THReshold[:STATe]
  • CALL:MS:FERate:REPort:THReshold:BAD
  • CALL:MS:FERate:REPort:TOTal?

CALL:MS:FERate:REPort:BAD?

Function

Queries the number of bad frames detected on the forward fundamental channel (F-FCH) within the measurement period which is reported in the Power Measurement Report Message (PMRM) by the mobile station. If the number exceeds 31, the mobile station reports this result to 31. See MS Reported Frame Error Rate Information for details.

This result can be cleared by the CALL:MS:FERate:REPort:CLEar .

Query

Range: 0 to 31, 9.91E+37 (NAN)
Resolution: 1

*RST Setting

 9.91E+37

Requirements

Lab Application Revision: B.02 and above

Programming Example

OUTPUT 714;"CALL:MS:FERate:REPort:BAD?"
!Query the number of bad frames detected on the F-FCH
!within the measurement period by the mobile station.

CALL:MS:FERate:REPort:CLEar

Function

This command clears all of the results relating to MS reported frame error rate for forward power control (see MS Reported Frame Error Rate Information ) and sets these results to their default values. See also To Clear the MS Reported Frame Error Rate Information for details.

Requirements

Lab Application Revision: B.02 and above

Programming Example

OUTPUT 714;"CALL:MS:FERate:REPort:CLEar?"
!Clears MS reported FER results for FPC.

CALL:MS:FERate:REPort:DELay

Function

Sets/queries the delay period (in units of frames) that the mobile station waits for following a PMRM before restarting the frame counting for power control purpose. See Frame Delay of Report (Frames) for details.

Setting

Range: 0 to 124
Resolution: 4

Query

same as setting

*RST Setting

 56

Requirements

Lab Application Revision: B.02 and above

Programming Example

OUTPUT 714;"CALL:MS:FERate:REPort:DELay 40"
!Sets to wait for 40 frames following a PMRM before
!restarting the frame counting for FPC.

CALL:MS:FERate:REPort:INTerval

Function

Sets/queries the measurement period (that is, the total number of frames) over which the mobile station is to count frame errors for power control FER report. See Frame Interval of Report (Frames) for details.

Setting

Range: FRAMes5|FRAMes7|FRAMes10|FRAMes14|FRAMes20|FRAMes28|FRAMes40
|FRAMes56|FRAMes80|FRAMes113|FRAMes160|FRAMes226|FRAMes320|FRAMes452
|FRAMes640|FRAMes905

Query

Range: FRAM5|FRAM7|FRAM10|FRAM14|FRAM20|FRAM28|FRAM40|FRAM56
|FRAM80|FRAM113|FRAM160|FRAM226|FRAM320|FRAM452|FRAM640|FRAM905

*RST Setting

 FRAMes56

Requirements

Lab Application Revision: B.02 and above

Programming Example

OUTPUT 714;"CALL:MS:FERate:REPort:INTerval FRAMes80"
!Sets to measure 80 frames for a power control period reporting.

CALL:MS:FERate:REPort:PERiod[:STATe]

Function

Sets/queries whether to enable (On) or disable (Off) the periodic power measurement reporting (in the PMRM signaling) from the MS. The measurement period is specified by CALL:MS:FERate:REPort:INTerval . See Periodic Report Enable for details.

Setting

Range: 1|ON|0|OFF

Query

Range: 1|ON|0|OFF

*RST Setting

 0 (off)

Requirements

Lab Application Revision: B.02 and above

Programming Example

OUTPUT 714;"CALL:MS:FERate:REPort:PERiod ON"
!Enable period power measurement reporting.

CALL:MS:FERate:REPort:RATio?

Function

Queries the the frame error rate (in percentage) which is calculated based on the PMRM from the mobile station. See MS Reported FER for details.

This result can be cleared by the CALL:MS:FERate:REPort:CLEar .

Query

Range: 0 to 100 (in percent), 9.91E+37 (NAN)
Resolution: 0.0001

*RST Setting

 9.91E+37

Requirements

Lab Application Revision: B.02 and above

Programming Example

OUTPUT 714;"CALL:MS:FERate:REPort:RATio?"
!Query the frame error rate based on the PMRM reporting.

CALL:MS:FERate:REPort:THReshold[:STATe]

Function

Sets/queries whether to enable (On) or disable (Off) the threshold-based power measurement reporting (in the PMRM signaling) from the MS. The threshold is specified by CALL:MS:FERate:REPort:THReshold:BAD . See Threshold Report Enable for details.

Setting

Range: 1|ON|0|OFF

Query

Range: 1|ON|0|OFF

*RST Setting

 0 (off)

Requirements

Lab Application Revision: B.02 and above

Programming Example

OUTPUT 714;"CALL:MS:FERate:REPort:THReshold ON"
!Enable threshold-based power measurement reporting.

CALL:MS:FERate:REPort:THReshold:BAD

Function

Sets/queries the number of bad frames detected on the F-FCH before triggering a threshold-based PMRM by the mobile station. Use CALL:MS:FERate:REPort:THReshold[:STATe] to enable the threshold-based power measurment reporting in PMRM. See Bad Frame Threshold (Frames) for details.

Setting

Range: 1 to 31, 9.91E+37 (NAN)
Resolution: 1

Query

same as setting

*RST Setting

 5

Requirements

Lab Application Revision: B.02 and above

Programming Example

OUTPUT 714;"CALL:MS:FERate:REPort:THReshold:BAD 10"
!Sets the number of bad frame for threshold-based
!power measurement reporting to 10.

CALL:MS:FERate:REPort:TOTal?

Function

Queries the total number of frames received on the forward fundamental channel (F-FCH) within the measurement period which is reported in the Power Measurement Report Message (PMRM) by the mobile station. See MS Reported Frame Error Rate Information for details.

This result can be cleared by the CALL:MS:FERate:REPort:CLEar .

Query

Range: 0 to 1023, 9.91E+37 (NAN)
Resolution: 1

*RST Setting

 9.91E+37

Requirements

Lab Application Revision: B.02 and above

Programming Example

OUTPUT 714;"CALL:MS:FERate:REPort:TOTal?"
!Query the total number of frames received on the F-FCH
!within the measurement period by the mobile station.


CALL:MS:IP:ADDRess

CALL:MS:IP:ADDRess

Last updated: June 6, 2007

GPIB Command Conventions

  • CALL:MS:IP:ADDRess

CALL:MS:IP:ADDRess

Function

Sets/queries the DUT (Device Under Test) IP address for Ping functionality or a packet data connection when CALL:DATA:PDSNode:EXTernal:STATe is Off. See DUT IP Address for details.

This setting is stored in nonvolatile RAM and will NOT be changed by a reset, power cycle operations.

This setting has no effect if the external PDSN (MOB-IP-SIM) is used ( CALL:DATA:PDSNode:EXTernal:STATe set to on).

Setting

Range: 15 characters formatted as follows: A.B.C.D.
The range of values for A= 0 to 126 and 128 to 223. The range of values for B,C, D = 0 to 255 (no embedded spaces).

Query

Range: same as setting.

*RST Setting
  • 0.0.0.1 (when shipped from the factory)
  • the value last set and stored in the nonvolatile RAM

Requirements

Lab Application Revision: A.02 and above

Programming Example

OUTPUT 714;"CALL:MS:IP:ADDRess `130.29.179.219'"
!Sets the DUT IP Address to 130.29.179.219.


CALL:MS:REPorted:PILot:STRength

CALL:MS:REPorted:PILot:STRength

Last updated:June 6, 2007

GPIB Command Conventions

  • CALL:MS:REPorted:PILot:STRength:REQuest[:IMMediate]
  • CALL:MS:REPorted:PILot:STRength:REQuest:TIME?
  • CALL:MS:REPorted:PILot:STRength:REPort[:ALL]?
  • CALL:MS:REPorted:PILot:STRength:REPort:CLEar

CALL:MS:REPorted:PILot:STRength:REQuest[:IMMediate]

Function

Performs the Send Pilot Meas Request function. (See F. Send Pilot Meas Request for manual operation.)

If a call is connected the Pilot Measurement Request Order is sent to the mobile station. The Mobile Station Reported Pilot Level Information table is cleared and the Pilot Strength Request Time Stamp is updated to record the time the Pilot Measurement Request Order was sent. (The Pilot Strength Request Time Stamp can be retrieved using the CALL:MS:REPorted:PILot:STRength:REQuest:TIME? command.)

After the mobile station responds with a Pilot Strength Measurement Message, the contents of this message can be obtained using the CALL:MS:REPorted:PILot:STRength:REPort[:ALL]? command.

Requirements

Lab Application Revision: A.01 and above

Programming Example

OUTPUT 714;"CALL:MS:REPORTED:PILOT:STRENGTH:REQUEST"

CALL:MS:REPorted:PILot:STRength:REQuest:TIME?

Function

Returns the Pilot Strength Request Time Stamp.

This value is updated each time the Send Pilot Meas Request function is performed (see CALL:MS:REPorted:PILot:STRength:REQuest[:IMMediate] ) .

The Pilot Strength Request Time Stamp is returned in units of seconds derived from the hh.mm.ss.ss format shown on the front panel display.

Query

Range: 00:00:00:00 to 23:59:59:99 (hh.mm.ss.ss) converted to seconds.

Requirements

Lab Application Revision: A.01 and above

Programming Example

OUTPUT 714;"CALL:MS:REPORTED:PILOT:STRENGTH:REQUEST:TIME?"

CALL:MS:REPorted:PILot:STRength:REPort[:ALL]?

Function

Returns the contents of the latest Pilot Strength Measurement Message received by the test set. The mobile station can be ordered to send a Pilot Strength Measurement Message by sending the CALL:MS:REPorted:PILot:STRength:REQuest[:IMMediate] command.

For each query the test set will return a comma separated string with the first value representing the Pilot Strength Report Time Stamp. This value is updated each time a Pilot Strength Measurement Message is received by the test set. The Pilot Strength Report Time Stamp is returned in units of seconds derived from the hh.mm.ss.ss format shown on the front panel display.

Following the Pilot Strength Report Time Stamp is the actual Pilot Strength Measurement Message contents. The remaining comma-separated values will include up to six pilots, each with the following five fields:

  • PN Status
  • Keep Status
  • PN Phase
  • Pilot Strength
  • PN Offset

Query

Ranges:

  • (Pilot Strength Report Time Stamp). 00:00:00:00 to 23:59:59:99 (hh.mm.ss.ss) converted to seconds.
  • (PN Status) Active|Candidate|To_Add|To_Drop|Undefined
  • (Keep Status) 0.0 to 1.0, 9.91E37
  • (PN Phase) 0.0 to 32767.0, 9.91E37
  • (Pilot Strength) 0.0 to 63.0, 9.91E37
  • (PN Offset) 0.0 to 511.0, 9.91E37

Requirements

Lab Application Revision: A.01 and above

Programming Example

OUTPUT 714;"CALL:MS:REPORTED:PILOT:STRENGTH:REPORT?"
!Queries the contents of the Pilot Strength Measurement Message.

CALL:MS:REPorted:PILot:STRength:REPort:CLEar

Function

 Clears the contents of the Mobile Station Reported Pilot Level Information table. (See E. Clear Mobile Pilot Report for manual operation.)

Requirements

Lab Application Revision: A.01 and above

Programming Example

OUTPUT 714;"CALL:MS:REPORTED:PILOT:STRENGTH:REPORT:CLEAR"


CALL:MS:RSParameter

CALL:MS:RSParameter

Last updated: October 28, 2004

Diagram Conventions

CALL:MS:RSParameter:PAG3?

Function

Queries the total number of paging channel messages received by the mobile station. It's updated by retrieving from the mobile station's PAG_3 register at the completion of the Paging Channel MER test. See Paging Channel MER Results for details.

This result can be cleared by the CALL:PAGing:MERRor:PROCedure:PARameter:CLEar . .

Query

Range: 0 to 65535, 9.91E+37 (NAN)
Resolution: 1

*RST Setting

 9.91E+37 (NAN)

Requirements

Lab Application Revision: B.01 and above

Programming Example

OUTPUT 714;"CALL:MS:RSParameter:PAG3?"
!Query the total number of paging channel messages received by the mobile station.


CALL:CELL2:OCNSource

CALL:CELL2:OCNSource

Last updated: July 18, 2007

GPIB Command Conventions

  • CALL:CELL2:OCNSource:LEVel[:SELected]?
  • CALL:CELL2:OCNSource:STATe[:SELected]?
  • CALL:CELL2:OCNSource:WALSh[:SELected]

CALL:CELL2:OCNSource:LEVel[:SELected]?

Function

Queries the calculated level of the Cell 2 OCNS (orthogonal channel noise simulator) Level.

If the contribution of OCNS is calculated to be -30 dB or less, the OCNS state is turned off.

The optional [:SELected] keyword in this command specifies that the OCNS level being queried applies to the current system type.

The OCNS level is a calculated value used to balance the relative power levels of the following channels to sum to 100%:

  • Cell 2 OCNS
  • Cell 2 Pilot (PICH)
  • Cell 2 Fundamental (FCH)

Query

Range: 0 to -20 dB, NAN

Resolution: 0.01 dB

*RST Setting

 NAN

Requirements

Lab Application Revision: A.01 and above

Programming Example

OUTPUT 714;"CALL:CELL2:OCNSOURCE:LEVEL?" !Queries the Cell 2 calculated OCNS level.

CALL:CELL2:OCNSource:STATe[:SELected]?

Function

Queries the on/off state of the Cell 2 OCNS (orthogonal channel noise simulator) Level.

If the contribution of OCNS is calculated to be -30 dB or less, the OCNS state is turned off.

The optional [:SELected] keyword in this command specifies that the OCNS on/off state being queried applies to the current system type.

The OCNS level is a calculated value used to balance the relative power levels of the following channels to sum to 100%:

  • Cell 2 OCNS
  • Cell 2 Pilot (PICH)
  • Cell 2 Fundamental (FCH)

Setting

Range: 1|0

*RST Setting

1 (on)

Requirements

Lab Application Revision: A.01 and above

Programming Example

OUTPUT 714;"CALL:CELL2:OCNSOURCE:STATE?"

CALL:CELL2:OCNSource:WALSh[:SELected]

Function

Sets/queries the Walsh code used for the Cell 2 OCNS (orthogonal channel noise simulator).

The optional [:SELected] keyword in this command specifies that the OCNS Walsh code being set/queried applies to the current system type.

The Walsh codes allowed for use with this command are part of a reserved codespace that has been created by fixing other code channels to pre-determined values. Reserving this codespace eliminates the possibility of conflicts that can arise with lower walsh code sets which are used in certain radio configurations.

Setting

Range: CODE5|CODE13|CODE21|CODE29|CODE37|CODE45|CODE53|CODE61

Query

Range: 5|13|21|29|37|45|53|61

*RST Setting

 CODE53

Requirements

Lab Application Revision: A.01 and above

Programming Example

OUTPUT 714;"CALL:CELL2:OCNSOURCE:WALSH CODE13" !Sets the OCNS channel walsh code to 13.

Related Topics

CALL:OCNSource (Cell 1 F-OCNS settings)


CALL:CELL2:PILot

CALL:CELL2:PILot

Last updated: July 18, 2007

GPIB Command Conventions

  • CALL:CELL2:PILOT[:SLEVel][:SELected]
  • CALL:CELL2:PILOT:LEVel[:SELected]
  • CALL:CELL2:PILOT:STATe[:SELected]

CALL:CELL2:PILOT[:SLEVel][:SELected]

Function

The setting form of this command performs two functions: (1) sets the Cell 2 F-Pilot (forward pilot channel) level, and (2) turns the Cell 2 F-Pilot state to ON.

The query form returns the Cell 2 F-Pilot level.

The optional [:SELected] keyword in this command specifies that the pilot channel state and level being set/queried applies to the current system type. See CALL[:CELL]:SYSTem[:TYPE] to query or change the current system type.

Setting

Range: 0 to -20 dB

Resolution: 0.01 dB

Query

Range: 0 to -20 dB

Resolution: 0.01 dB

*RST Setting

-7 dBm

Requirements

Lab Application Revision: A.01 and above

Programming Example

OUTPUT 714;"CALL:CELL2:PILOT:SLEVel -20"
!Sets the Cell 2 F-Pilot state to ON and sets the level to -20 dB.

CALL:CELL2:PILOT:LEVel[:SELected]

Function

Sets/queries the Cell 2 F-Pilot (forward pilot channel) level.

The optional [:SELected] keyword in this command specifies that the pilot level being set/queried applies to the current system type.

Setting

Range: 0 to -20 dB

Resolution: 0.01 dB

Query

Range: 0 to -20 dB

Resolution: 0.01 dB

*RST Setting

 -7 dB

Requirements

Lab Application Revision: A.01 and above

Programming Example

OUTPUT 714;"CALL:CELL2:PILOT:LEVEL -20"

CALL:CELL2:PILOT:STATe[:SELected]

Function

Sets/queries the Cell 2 F-Pilot (forward pilot channel) state.

The optional [:SELected] keyword in this command specifies that the pilot state being set/queried applies to the current system type.

Setting

Range: 1|ON|0|OFF

Query

Range: 1|0

*RST Setting

1 (on)

Requirements

Lab Application Revision: A.01 and above

Programming Example

OUTPUT 714;"CALL:CELL2:PILOT:STATE OFF"

Related Topics

CALL:PILot (Cell 1 F-Pilot settings)


CALL:PLOGging

CALL:PLOGging

Last updated: June 6, 2007

GPIB Command Conventions

  • CALL:PLOGging:STARt
  • CALL:PLOGging:STOP
  • CALL:PLOGging:STATus? or CALL:PLOGging:STATe?
  • CALL:PLOGging:CONNected?
  • CALL:PLOGging:ACTive?
  • CALL:PLOGging:DONE?

CALL:PLOGging:STARt

Function

This command will cause the test set to transition to the Active logging state. Once in the Active Logging state the test set can begin forwarding messages to the protocol logging software.

The protocol logging software must be in real-time mode (not post-capture mode) and a real-time logging session must be connected before transition to the Active logging state is possible.

A real-time logging session is connected by entering the IP Address of the test set in the Tools, Configuration window found in the protocol logging software. When a real-time logging session is connected, the test set's front panel logging annunciator will display Logging:Idle (see the Idle description in CALL:PLOGging:STATus? or CALL:PLOGging:STATe? .)

After the transition from the Idle to Active logging state has occurred, the test set's front paned logging annunciator will appear as Logging:Active .

NOTE
The test set can also be transitioned to the Active logging state by clicking on the REC (record) button located in the protocol logging software (Wireless Protocol Advisor).
Requirements Lab Application Revision: A.01 and above
Test Application Revision: B.13 and above

Programming Example

 OUTPUT 714;"CALL:PLOGGING:START"
!Starts protocol logging.

CALL:PLOGging:STOP

Function

This command will cause the test set to transition to the Idle logging state.

The test set must be in the Active state before transition to the Idle logging state is possible.

After the transition from the Active to the Idle logging state, the test set's front panel logging annunciator will appear as Logging:Idle .

NOTE
The test set can also be transitioned to the Idle logging state by clicking on the STOP button located in the protocol logging software (Wireless Protocol Advisor).

Requirements

Lab Application Revision: A.01 and above
Test Application Revision: B.13 and above

Programming Example

 OUTPUT 714;"CALL:PLOGGING:STOP"
!Stops protocol logging.

CALL:PLOGging:STATus? or CALL:PLOGging:STATe?

Function

This command queries the status of the test set's protocol logging data source. The logging status can be viewed on the test set front panel's logging annunciator.

Possible query results are:

  • DISC (Disconnected) - There is no real-time protocol logging session established between the test set and the protocol logging software.
  • IDLE - A real-time protocol logging session has been established between the test set and the protocol logging software, but protocol logging is not currently taking place.
  • ACT (Active) - Both a real-time session and a logging session have been established and data is being captured by the protocol logging software.
  • STRTG (Starting) - This is a transitional state while the protocol logging software attempts to start logging test set protocol messages.
  • STPG (Stopping) - This is a transitional state while the protocol logging software attempts to stop logging test set protocol messages.

Query

 Range: DISC|IDLE|ACT|STRTG|STPG

Requirements

Lab Application Revision: A.01 and above

Programming Example

 OUTPUT 714;"CALL:PLOGGING:STATe?"!Queries the protocol logging state.

CALL:PLOGging:CONNected?

Function

This query returns an integer value of 1 if the status of the test set's protocol logging data source is either:

  • IDLE - A real-time protocol logging session has been established between the test set and the protocol logging software, but protocol logging is not currently taking place.
  • ACT (Active) - Both a real-time session and a logging session have been established and data is being captured by the protocol logging software.

See CALL:PLOGging:STATus? or CALL:PLOGging:STATe? .

If the state of the test set's protocol logging data source is not one of the above, this query will "hang" until a transition to one of these states occurs, or a bus timeout or device clear terminates the query attempt.

Query

 Range: 1

Requirements

Lab Application Revision: A.01 and above
Test Application Revision: B.13 and above

Programming Example

 OUTPUT 714;"CALL:PLOGGING:CONN?"!Queries the connected state.

CALL:PLOGging:ACTive?

Function

This query returns an integer value of 1 if the status of the test set's protocol logging data source is:

  • ACT (Active) - Both a real-time session and a logging session have been established and data is being captured by the protocol logging software.

See CALL:PLOGging:STATus? or CALL:PLOGging:STATe? .

If the state of the test set's protocol logging data source is not Active, this query will "hang" until a transition to the Active state occurs, or a bus timeout or device clear terminates the query attempt.

Query

 Range: 1

Requirements

Lab Application Revision: A.01 and above
Test Application Revision: B.13 and above

Programming Example

 OUTPUT 714;"CALL:PLOGGING:ACT?"!Queries the Active state.

CALL:PLOGging:DONE?

Function

This query returns an integer value of 1 if the status of the test set's protocol logging data source is either:

  • DISC (Disconnected) - There is no real-time protocol logging session established between the test set and the protocol logging software.
  • IDLE - A real-time protocol logging session has been established between the test set and the protocol logging software, but protocol logging is not currently taking place.

See CALL:PLOGging:STATus? or CALL:PLOGging:STATe? .

If the state of the test set's protocol logging data source is not one of the above, this query will "hang" until a transition to one of these states occurs, or a bus timeout or device clear terminates the query attempt.

Query

 Range: 1

Requirements

Lab Application Revision: A.01 and above
Test Application Revision: B.13 and above

Programming Example

 OUTPUT 714;"CALL:PLOGGING:DONE?"!Queries the done (logging) state.


CALL:CELL2:PNOFfset

CALL:CELL2:PNOFfset

Last updated: July 18, 2007

GPIB Command Conventions

  • CALL:CELL2:PNOFfest

CALL:CELL2:PNOFfest

Function

Sets/queries the Cell 2 PN (pseudonoise) offset. The Cell 2 PN offset is the timing of the cell's short codes relative to system time. Cell 1 PN offset and Cell 2 PN offset uniquely identify each simulated cell site to the mobile station. The PN offsets of Cell 1 and Cell 2 cannot be set to the same value.

Changing the Cell 2 PN offset while on a call but not in a soft or softer handoff will result in an update to the system parameters and notification to the mobile station through transmission of the Neighbor List Update Message.

Changing the Cell 2 PN offset while on a call and with a soft or softer handoff on will result in a handoff. Prior to the handoff the Neighbor List Update Message will be sent with updated values for PILOT_INC and NGHBR_PN.

The Cell 2 PN offset is also used to generate the list of neighbor PN offsets (NGHBR_PN) that is transmitted to the mobile station. The neighbor list is determined using the following rules:

  • The Cell 1 PN offset (PILOT_PN) will not appear in the neighbor list.
  • The increment between neighbor PN offsets in the neighbor list (PILOT_INC) will equal the greatest common factor, less than 16, of the Cell 1 and Cell 2 PN offsets.
  • The first neighbor PN offsets shall equal the Cell 2 PN offset.

The Cell 1 PN offset determines the contents of the PILOT_PN message field transmitted in the Neighbor List Message, Extended Neighbor List Message, IS-2000 System Parameters Message, IS-2000 Extended Neighbor List Message.

The Cell 1 PN offset also contributes to determining the contents of the PILOT_INC and NGHBR_PN message fields used to determine the neighbor list of PN offsets and transmitted in the messages listed above.

This command may take up to 2 seconds to complete.

Setting

Range: 0 to 511

Query

Range: 0 to 511

*RST Setting

36

Requirements

Lab Application Revision: A.01 and above

Programming Example

OUTPUT 714;"CALL:CELL2:PNOFFSET 333" sets the Cell 2 PN offset to 333.

Related Topics

CALL:PNOFfset (Cell 1 pilot PN offset settings)


CALL:CELL2:POWer

CALL:CELL2:POWer

Last updated: July 18, 2007

GPIB Command Conventions

  • CALL:CELL2:POWer[:SAMPlitude][:SELected]
  • CALL:CELL2:POWer:AMPLitude[:SELected]
  • CALL:CELL2:POWer:STATe[:SELected]

CALL:CELL2:POWer[:SAMPlitude][:SELected]

Function

The setting form of this command performs two functions: (1) sets the Cell 2 Power and (2) turns the Cell 2 Power on/off state to on. The query form returns the Cell 2 Power level (including compensation for amplitude offset) or NAN.

The optional [:SELected] keyword in this command specifies that the Cell 2 Power level being set or queried applies to the current system type. The current system type can be changed using the CALL[:CELL]:SYSTem[:TYPE] command.

Cell 1 Power (see CALL:POWer ), Cell 2 Power, and AWGN (see CALL:AWGNoise ) are absolute power levels and make up the total forward channel RF output power (see CALL:STATus:TOTal:POWer[:AMPLitude][:SELected]? ).

The return value for this query is not necessarily the cell 2 power level being transmitted by the test set at the moment this command is processed by the test set. It may return a value that the test set has been requested to transmit, but that has been pended or delayed for some reason. See Troubleshooting Setting Power Levels for possible causes. To query the cell 2 power level the test set is transmitting at the moment the command is sent, use the CALL:STATus:CELL[1]:POWer:[AMPLitude][:SELected]? command.

Setting

Range:

  • CDMA: -170 dBm/1.23 MHz to 37 dBm/1.23 MHz (-120 dBm/1.23MHz to -13 dBm/1.23 MHz actual hardware range with amplitude offset = 0) (see Cell Power, AWGN Power and Total RF Power Ranges )

Resolution: 0.01 dB

Query

Range: Same as setting range.

Resolution: 0.01 dB

*RST Setting
  • CDMA: -55 dBm/1.23 MHz, Off

Requirements

Lab Application Revision: A.01 and above

Programming Example

OUTPUT 714;"CALL:CELL2:POWER:SAMPLITUDE -30"
!Sets the Cell 2 Power state to ON and sets the level to -30 dBm.

CALL:CELL2:POWer:AMPLitude[:SELected]

Function

Sets/queries the Cell 2 Power level (including compensation for amplitude offset). See CALL:CELL2:POWer[:SAMPlitude][:SELected] .

Setting

Range:

  • CDMA: -170 dBm/1.23 MHz to 37 dBm/1.23 MHz (-120 dBm/1.23MHz to -13 dBm/1.23 MHz actual hardware range with amplitude offset = 0) (see Cell Power, AWGN Power and Total RF Power Ranges )

Resolution: 0.01 dB

Query

Range: Same as setting range.

Resolution: 0.01 dB

*RST Setting
  • CDMA: -55 dBm/1.23 MHz

Requirements

Lab Application Revision: A.01 and above

Programming Example

OUTPUT 714;"CALL:CELL2:POWER:AMPLITUDE -30"
!Sets the Cell 2 Power level to -30 dBm.

CALL:CELL2:POWer:STATe[:SELected]

Function

Sets/queries the Cell 2 Power state. See CALL:CELL2:POWer[:SAMPlitude][:SELected]

Setting

Range: 1|ON|0|OFF

Query

Range: 1|0

*RST Setting

ON

Requirements

Lab Application Revision: A.01 and above

Programming Example

OUTPUT 714;"CALL:CELL2:POWER:STATE OFF" !Turns off Cell 2 Power.

Related Topics

CALL:POWer (Cell 1 power settings )


CALL:SMService

CALL:SMService

Last updated: June 7, 2007

GPIB Command Conventions

  • CALL:SMService:ARM[:IMMediate]
  • CALL:SMService:ARM:STATe?
  • CALL:SMService:ARM:TIMeout
  • CALL:SMService:BSENt[:STATe]?
  • CALL:SMService:CLEar
  • CALL:SMService:END
  • CALL:SMService:HTTProtocol:INPut
  • CALL:SMService:HTTProtocol:OUTPut
  • CALL:SMService:IDLE[:STATe]?
  • CALL:SMService:MSACk[:STATe]?
  • CALL:SMService:MSNack[:STATe]?
  • CALL:SMService:RECeived[:STATe]?
  • CALL:SMService:SEND
  • CALL:SMService:STATus[:STATe]?
  • CALL:SMService:MORiginated:CBNumber:ASCii?
  • CALL:SMService:MORiginated:CBNumber:ENCoding?
  • CALL:SMService:MORiginated:CBNumber:HEX?
  • CALL:SMService:MORiginated:COUNt?
  • CALL:SMService:MORiginated:DADDress:ASCii?
  • CALL:SMService:MORiginated:DADDress:ENCoding?
  • CALL:SMService:MORiginated:DADDress:HEX?
  • CALL:SMService:MORiginated:DROP:TIMer[:STATe]
  • CALL:SMService:MORiginated:MESSage:ASCii?
  • CALL:SMService:MORiginated:MESSage:ENCoding?
  • CALL:SMService:MORiginated:MESSage:HEX?
  • CALL:SMService:MORiginated:MESSage:LENGth?
  • CALL:SMService:MORiginated:PRIority?
  • CALL:SMService:MORiginated:PROTocol
  • CALL:SMService:MORiginated:TELeservice?
  • CALL:SMService:MTERminated:ALERt
  • CALL:SMService:MTERminated:CBNumber
  • CALL:SMService:MTERminated:SOURce
  • CALL:SMService:MTERminated:MDMode
  • CALL:SMService:MTERminated:MDMode:INCLusion
  • CALL:SMService:MTERminated:MESSage:ASCii
  • CALL:SMService:MTERminated:MESSage:ENCoding
  • CALL:SMService:MTERminated:MESSage:HEX
  • CALL:SMService:MTERminated:MESSage:LENGth?
  • CALL:SMService:MTERminated:MESSage:REPeat
  • CALL:SMService:MTERminated:MESSage:UDATa
  • CALL:SMService:MTERminated:MSACk:CCODe[:INDex]?
  • CALL:SMService:MTERminated:MSACk:CCODe:STRing?
  • CALL:SMService:MTERminated:PRIority
  • CALL:SMService:MTERminated:PRIVacy
  • CALL:SMService:MTERminated:SCATegory
  • CALL:SMService:MTERminated:SERVice
  • CALL:SMService:MTERminated:TELeservice
  • CALL:SMService:MTERminated:VMNotify:COUNt

CALL:SMService:ARM[:IMMediate]

Function

Sets (arms) the SMS status change detector. Arming this detector allows the control program to tell the test set that it is expecting a change in the state of an SMS processing, prior to initiating the state change. See SMS Status Change Detector for details.

This is an overlapped command, and therefore has a Pending Operation Flag (POF) associated with it. See Call Processing Event Synchronization for more information about the behavior of overlapped commands.

Requirements

Lab Application Revision: B.00 and above

Programming Example

OUTPUT 714;"CALL:SMService:ARM"
!Arms the SMS status change detector.

CALL:SMService:ARM:STATe?

Function

Queries the arm state of the SMS status change detector. This command never hangs and immediately returns a one if the detector is armed, or a zero if the detector is not armed. See SMS Status Change Detector .

Query

Range: 1|0

*RST Setting

0

Requirements

Lab Application Revision: B.00 and above

Programming Example

OUTPUT 714;"CALL:SMService:ARM:STATe?"
!Query the arm state of the SMS status change detector.

CALL:SMService:ARM:TIMeout

Function

Sets/queries the amount of time that the test set will wait for an SMS status change detector to become disarmed. See SMS Status Change Detector Timeout for details.

Default setting units are seconds. To set timeout time in units other than seconds, include an optional unit specifier in the command string.

Setting

Range: 0 to 100 seconds
Resolution: 0.1 seconds

Query

Same as setting

*RST Setting

10 seconds

Requirements

Lab Application Revision: B.00 and above

Programming Example

OUTPUT 714;"CALL:SMService:ARM:TIMeout 3"
!Sets the SMS staus change detector timeout time to 3 seconds.

OUTPUT 714;"CALL:SMService:ARM:TIMeout 500 MS"
!Sets the SMS staus change detector timeout time to 500 milliseconds.

CALL:SMService:BSENt[:STATe]?

Function

Queries whether or not the SMS processing is in the 'Broadcast Sent' terminal state (see SMS Status Description ).

The query will hang as long as the SMS processing is in a transitory state. See SMS (Short Message Service) State Synchronization for details.

Query

Range: 0 |1

*RST Setting

0

Requirements

Lab Application Revision: B.00 and above

Programming Example

OUTPUT 714;"CALL:SMService:BSENt?"
!Query whether or not the SMS processing in the Broadcast Sent state.

CALL:SMService:CLEar

Function

 Clears the last received SMS message from the mobile station (MS), as well as the SMS processing status and the MS acknowledgment information. See Clearing the SMS Info/Status .

Requirements

Lab Application Revision: B.00 and above

Programming Example

OUTPUT 714;"CALL:SMService:CLEar"
!Clear the SMS information received from the MS,
!and the current SMS processing status.

CALL:SMService:END

Function

This command causes the test set to end the SMS Send ( CALL:SMService:SEND ) currently in process. See methods 1 and 3 described in Sending an SMS Message to the Mobile Station .

This command does not apply to the SMS message sent via Originate Call ( CALL:ORIGinate ). See method 2 described in Sending an SMS Message to the Mobile Station .

If the test set receives an SMS End command while processing an SMS Send (an SMS message is being transmitted on the traffic channel or control channel), the test set will immediately discontinue the SMS signaling. Any SMS Message or Acknowledgments that were in transit may be lost.

Requirements

Lab Application Revision: B.00 and above

Programming Example

OUTPUT 714;"CALL:SMService:END"
!End the SMS Send command currently in process.

CALL:SMService:HTTProtocol:INPut

Function | Enable/Disenble the HTTP input interface for MT SMS
Setting | Range: 0|OFF |1|ON
Query | Range: 0 |1
*RST Setting | OFF
Requirements | Lab Application Revision: B.04 and above
Programming Example OUTPUT 714;"CALL:SMService:HTTProtocol:INPut ON" !Enables the HTTP input interface for mobile terminated SMS

CALL:SMService:HTTProtocol:OUTPut

Function | Enable/Disenble the HTTP output interface for MO SMS
Setting | Range: 0|OFF |1|ON
Query | Range: 0 |1
*RST Setting | OFF
Requirements | Lab Application Revision: B.04 and above
Programming Example OUTPUT 714;"CALL:SMService:HTTProtocol:OUTPut ON" !Enables the HTTP output interface for mobile originated SMS

CALL:SMService:IDLE[:STATe]?

Function

Queries whether or not the SMS processing is in the 'idle' terminal state (see SMS Status Description ).

The query will hang as long as the SMS processing is in a transitory state. See SMS (Short Message Service) State Synchronization for details.

Query

Range: 0 |1

*RST Setting

0

Requirements

Lab Application Revision: B.00 and above

Programming Example

OUTPUT 714;"CALL:SMService:IDLE?"
!Query whether or not the SMS processing in the Idle state.

CALL:SMService:MSACk[:STATe]?

Function

Queries whether or not the SMS processing is in the 'MS Ack' terminal state (see SMS Status Description ).

The query will hang as long as the SMS processing is in a transitory state. See SMS (Short Message Service) State Synchronization for details.

Query

Range: 0 |1

*RST Setting

0

Requirements

Lab Application Revision: B.00 and above

Programming Example

OUTPUT 714;"CALL:SMService:MSACk?"
!Query whether or not the SMS processing in the MS Ack state.

CALL:SMService:MSNack[:STATe]?

Function

Queries whether or not the SMS processing is in the 'MS Nack' terminal state (see SMS Status Description ).

The query will hang as long as the SMS processing is in a transitory state. See SMS (Short Message Service) State Synchronization for details.

Query

Range: 0 |1

*RST Setting

0

Requirements

Lab Application Revision: B.00 and above

Programming Example

OUTPUT 714;"CALL:SMService:MSNack?"
!Query whether or not the SMS processing in the MS Nack state.

CALL:SMService:RECeived[:STATe]?

Function

Queries whether or not the SMS processing is in the 'Received' terminal state (see SMS Status Description ).

The query will hang as long as the SMS processing is in a transitory state. See SMS (Short Message Service) State Synchronization for details.

Query

Range: 0 |1

*RST Setting

0

Requirements

Lab Application Revision: B.00 and above

Programming Example

OUTPUT 714;"CALL:SMService:RECeived?"
!Query whether or not the SMS processing in the Received state.

CALL:SMService:SEND

Function

This command causes the test set to send an SMS message to the mobile station. It's used by the methods 1 and 2 ( Sending an SMS Message to the Mobile Station ).

This is an overlapped command, and therefore has a Pending Operation Flag (POF) associated with it. See Call Processing Event Synchronization for more information about the behavior of overlapped commands.

Requirements

Lab Application Revision: B.00 and above

Programming Example

OUTPUT 714;"CALL:SMService:SEND"
!Sends a short message to the mobile station.

CALL:SMService:STATus[:STATe]?

Function

Queries the current status of the SMS processing. See SMS Status Description for details.

Query

Range: IDLE|SEND|WAIT|MSAC|MSN|BSEN|PAG|ORIG|REC

*RST Setting

IDLE

Requirements

Lab Application Revision: B.00 and above

Programming Example

OUTPUT 714;"CALL:SMService:STATus?"
!Query the status of SMS processing.

CALL:SMService:MORiginated:CBNumber:ASCii?

Function

Queries the call-back number of the received SMS message from the mobile station. The returned string is represented in ASCII format.

This result is also available on the Mobile-Originated SMS Info .

Query

Range: returns a string containing up to 255 characters and each character is

  • from the set of 0123456789*# if the Call-Back Number Encoding is DTMF (see CALL:SMService:MORiginated:CBNumber:ENCoding? ).
  • from the ASCII character set if the Call-Back Number Encoding is ASC8 ( CALL:SMService:MORiginated:CBNumber:ENCoding? ).

*RST Setting

"" (null string)

Requirements

Lab Application Revision: B.00 and above

Programming Example

OUTPUT 714;"CALL:SMService:MORiginated:CBNumber:ASCii?"
!Returns the call-back number of the received SMS message in ASCII format.

CALL:SMService:MORiginated:CBNumber:ENCoding?

Function

Queries the encoding of the call-back number of the received SMS message sent from the mobile station. This result determines how the call-back number is interpreted (see CALL:SMService:MORiginated:CBNumber:ASCii? and CALL:SMService:MORiginated:CBNumber:HEX? ).

This result is also available on the Mobile-Originated SMS Info .

Query

Range: DTMF|ASC8|NDEF

*RST Setting

NDEF

Requirements

Lab Application Revision: B.00 and above

Programming Example

OUTPUT 714;"CALL:SMService:MORiginated:CBNumber:ENCoding?"
!Returns the encoding of the call-back number of the received SMS message.

CALL:SMService:MORiginated:CBNumber:HEX?

Function

Queries the call-back number of the SMS message received from the mobile station. The returned string is represented in Hex format.

This result is also available on the Mobile-Originated SMS Info .

Query

Range: returns a string containing up to 511 hex characters

  • If the Call-Back Number Encoding is DTMF (queried by CALL:SMService:MORiginated:CBNumber:ENCoding? ), the returned string will contain the hex representation of symbols from the set of 0123456789*#; "0" will be represented as hex A, "*" will be represented as hex B and "#" will be represented as hex C; for all other symbols, the hex character is the same as the DTMF symbol.
  • If the Call-Back Number Encoding is ASC8 (queried by CALL:SMService:MORiginated:CBNumber:ENCoding? ), the returned string will contain hex representation of symbols from the ASCII character set, two hex characters for each ASCII symbol.

*RST Setting

"" (null string)

Requirements

Lab Application Revision: B.00 and above

Programming Example

OUTPUT 714;"CALL:SMService:MORiginated:CBNumber:HEX?"
!Returns the call-back number of the received SMS message in Hex format.

CALL:SMService:MORiginated:COUNt?

Function

Queries the number of SMS messages received by the test set from the mobile station. This result increments by one each time an SMS message is successfully received from the MS and wraps around to 0 (zero) when the maximum value is reached. It can also be cleared to 0 (zero) by CALL:SMService:CLEar .

This result is also available on the Mobile-Originated SMS Info .

Query

Range: 0 to 65535

Resolution: 1

*RST Setting

0

Requirements

Lab Application Revision: B.00 and above

Programming Example

OUTPUT 714;"CALL:SMService:MORiginated:COUNt?"
!Returns the number of the SMS messages received from the mobile station.

CALL:SMService:MORiginated:DADDress:ASCii?

Function

Queries the destination address of the SMS message received from the mobile station. The returned string is represented in ASCII format.

This result is also available on the Mobile-Originated SMS Info .

Query

Range: returns a string containing up to 255 characters and each character is:

  • from the set of 0123456789*# if the Destination Address Encoding is DTMF (see CALL:SMService:MORiginated:DADDress:ENCoding? ).
  • from the ASCII character set if the Destination Address Encoding is ASC8 (see CALL:SMService:MORiginated:DADDress:ENCoding? ).

*RST Setting

""(null string)

Requirements

Lab Application Revision: B.00 and above

Programming Example

OUTPUT 714;"CALL:SMService:MORiginated:DADDresss:ASCii?"
!Returns the destination address of the received SMS message in ASCII format.

CALL:SMService:MORiginated:DADDress:ENCoding?

Function

Queries the encoding of the destination address of the received SMS message sent from the mobile station. This result determines how the Destination Address is interpreted (see CALL:SMService:MORiginated:DADDress:ASCii? and CALL:SMService:MORiginated:DADDress:HEX? ).

See also Mobile-Originated SMS Info .

Query

Range: DTMF|ASC8|NDEF

*RST Setting

NDEF

Requirements

Lab Application Revision: B.00 and above

Programming Example

OUTPUT 714;"CALL:SMService:MORiginated:DADDress:ENCoding?"
!Returns the encoding of the destination address of the received SMS message.

CALL:SMService:MORiginated:DADDress:HEX?

Function

Queries the destination address of the SMS message received from the mobile station. The returned string is represented in Hex format.

This result is also available on the Mobile-Originated SMS Info .

Query

Range: returns a string containing up to 511 hex characters.

  • If the Destination Address Encoding is DTMF (queried by CALL:SMService:MORiginated:DADDress:ENCoding? ), the returned string will contain the hex representation of symbols from the set of 0123456789*#; "0" will be represented as hex A, "*" will be represented as hex B and "#" will be represented as hex C; for all other symbols, the hex character is the same as the DTMF symbol.
  • If the Destination Address Encoding is ASC8 (queried by CALL:SMService:MORiginated:DADDress:ENCoding? ), the returned string will contain hex representation of symbols from the ASCII character set, two hex characters for each ASCII symbol.

*RST Setting

"" (null string)

Requirements

Lab Application Revision: B.00 and above

Programming Example

OUTPUT 714;"CALL:SMService:MORiginated:DADDress:HEX?"
!Returns the destination address of the received SMS message in Hex format.

CALL:SMService:MORiginated:DROP:TIMer[:STATe]

Function

Sets/queries the state of SMS call drop timer. This timer determines whether the test set will disconnect a call in service option SO6 or SO14 if an SMS message or MS disconnect is not received after a fixed amount of time (~ 5 seconds) since the call was established or an SMS message was received. See SMS Call Drop Timer Control for details.

Setting

Range: 1|ON|0|OFF

Query

Range: 1|0

*RST Setting

ON

Programming Example

OUTPUT 714;"CALL:SMService:MORiginated:DROP:TIMer 0"
!Disable the SMS Call Drop Timer.

CALL:SMService:MORiginated:MESSage:ASCii?

Function

Queries the contents of the received SMS message from the mobile station. This result is also available on the Mobile-Originated Message .

The returned string is represented in ASCII format and impacted by the value of the Message Encoding ( CALL:SMService:MORiginated:MESSage:ENCoding? ).

  • If the Message Encoding is ASC7, IA5, or GSM7, this string will contain ASCII characters.
  • If the Message Encoding is any value other than ASC7, IA5, and GSM7, all characters are either 8 or 16 bits. 16-bit characters will be interpreted as two-8 bit characters. The 8-bit characters with the first (most significant) bit set will be treated like non-printable ASCII characters and represented as '*' characters.

Query

Range: Returns a string containing up to 255 characters from the ASCII character set.

*RST Setting

"" (null string)

Requirements

Lab Application Revision: B.00 and above

Programming Example

OUTPUT 714;"CALL:SMService:MORiginated:MESSage:ASCii?"
!Returns the contents of the received SMS message in ASCII format.

CALL:SMService:MORiginated:MESSage:ENCoding?

Function

Queries the encoding of the received SMS message sent from the mobile station. See Message Encoding for a list of encoding type. This result is also available on the Mobile-Originated SMS Info .

The message encoding determines how the Message contents are interpreted (see CALL:SMService:MORiginated:MESSage:ASCii? and CALL:SMService:MORiginated:MESSage:HEX? ). It also impacts the Message Length ( CALL:SMService:MORiginated:MESSage:LENGth? ).

Query

Range: OCT|EPM|ASC7|IA5|UNIC|SJIS|KOR|KSC5601|LHEB|LAT|GSM7|OTH|NDEF

*RST Setting

NDEF

Programming Example

OUTPUT 714;"CALL:SMService:MORiginated:MESSage:ENCoding?"
!Query the encoding of the received SMS message sent from the mobile station.

CALL:SMService:MORiginated:MESSage:HEX?

Function

Queries the contents of the received SMS message from the mobile station. See also Mobile-Originated Message .

The returned string is represented in Hex format and impacted by the value of the Message Encoding ( CALL:SMService:MORiginated:MESSage:ENCoding? ).

  • If the Message Encoding is ASC7, IA5, or GSM7, each 7-bit character is converted to 8 bits by adding a padding "0" bit to the beginning (most-significant bit) of each character, then each 8-bit character is converted to 2 hex characters from the set of '0123456789ABCDEF'.
  • If the Message Encoding is any value other than ASC7, IA5, and GSM7, all characters are either 8 or 16 bits. Each character is then converted to 2 or 4 hex characters.

Query

Range: returns a string containing up to 511 hex characters from the set of 0123456789ABCDEF

*RST Setting

"" (null string)

Requirements

Lab Application Revision: B.00 and above

Programming Example

OUTPUT 714;"CALL:SMService:MORiginated:MESSage:HEX?"
!Returns the contents of the received SMS message in Hex format.

CALL:SMService:MORiginated:MESSage:LENGth?

Function

Queries the number of encoded characters in the last received SMS messages from the mobile station. This result depends upon the message encoding type (see CALL:SMService:MORiginated:MESSage:ENCoding? ).

See Mobile-Originated SMS Info for details.

Query

Range: 0 to 255, 9.91E+37

Resolution: 1.0

*RST Setting

9.91E+37 (NAN)

Requirements

Lab Application Revision: B.00 and above

Programming Example

OUTPUT 714;"CALL:SMService:MORiginated:MESSage:LENGth?"
!Returns the number of encoded characters in the last
!received SMS messages from the mobile station.

CALL:SMService:MORiginated:PRIority?

Function

Queries the priority level of received SMS message from the mobile station. NONE is returned if no priority field is included in the received SMS message.

See Mobile-Originated SMS Info for details.

Query

Range: NORM|INT|URG|EMER|NONE

*RST Setting

NONE

Requirements

Lab Application Revision: B.00 and above

Programming Example

OUTPUT 714;"CALL:SMService:MORiginated:PRIority?
!Query the priority level of the received SMS message from the mobile station.

CALL:SMService:MORiginated:PROTocol

Function

Sets/queries how the test set responds to a received SMS message. See SMS Support Control for details.

Setting

Range: ENABled|DISabled|NSUPported|UDADdress

Query

Range: ENAB|DIS|NSUP|UDAD

*RST Setting

ENABled

Requirements

Lab Application Revision: B.00 and above

Programming Example

OUTPUT 714;"CALL:SMService:MORiginated:PROTocol NSUPported"
!Set the test set to indicate to the MS that SMS is not supported.

CALL:SMService:MORiginated:TELeservice?

Function

Queries the teleservice type of the received SMS message from the mobile station. See also Mobile-Originated SMS Info .

Query

Range: EPES|WPAG|WMES|VMN|WAP|RCSP |OTH|NDEF|CATP

  • EPES - Extended Protocol Enhanced Service
  • WPAG - Wireless Paging Teleservice
  • WMES- Wireless Messaging Teleservice
  • VMN - Voice Mail Notification
  • WAP - Wireless Application Protocol
  • RCSP - Reserved for Carrier Specific Teleservices
  • OTH - Other (this value is returned for the teleservices specified in the standard but not supported by the test set, or indicated as "Reserved" in the standard)
  • NDEF - Undefined

*RST Setting

 NDEF

Requirements

Lab Application Revision: B.00 and above

Programming Example

OUTPUT 714;"CALL:SMService:MTERminated:TELeservice WPAG
!Sets the teleservice to Wireless Paging Teleservice.

CALL:SMService:MTERminated:ALERt

Function

Sets/queries whether the mobile station will alert the user (for example, beep or vibrating depending upon the mobile station's behavior) when it receivers the message from the test set.

See MS Message Alert for details.

Setting

Range: NONE|MSDefault|LOW|MEDium|HIGH

Query

Range: NONE|MSD|LOW|MED|HIGH

*RST Setting

 MSD

Requirements

Lab Application Revision: B.00 and above

Programming Example

OUTPUT 714;"CALL:SMService:MTERminated:ALERt LOW"
!Set to alert the user with low level when the MS receives an SMS message.

CALL:SMService:MTERminated:CBNumber

Function

Sets/queries whether to include the Call-Back Number subparameter in the SMS message sent to the mobile station. See Call-Back Number for details.

Setting

Range: INCLude|EXCLude

Query

Range: INCL|EXCL

*RST Setting

EXCL

Requirements

Lab Application Revision: B.00 and above

Programming Example

OUTPUT 714;"CALL:SMService:MTERminated:CBNumber INCLude"
!Set to include the Call-Back Number in the SMS message.

CALL:SMService:MTERminated:SOURce

Function

Sets/queries whether the ASCII short message (defined by CALL:SMService:MTERminated:MESSage:ASCii ) or the HEX short message (defined by CALL:SMService:MTERminated:MESSage:HEX ) will be included in the SMS message sent to the mobile station.

See also Set Message Source .

Setting

Range: ASCii|HEX

Query

Range: ASC|HEX

*RST Setting

ASC

Requirements

Lab Application Revision: B.00 and above

Programming Example

OUTPUT 714;"CALL:SMService:MTERminated:SOURce HEX"
!Set the Hex SMS message to be sent to the mobile station.

CALL:SMService:MTERminated:MDMode

Function

Sets/queries the message display mode. Only when MDMI ( CALL:SMService:MTERminated:MDMode:INCLusion ) is set to "Include", this parameter will be included in the message sent to mobile. Otherwise, this parameter will not be transmitted OTA. See Message Dispaly Mode Indicator Values for each value of the Message Display Mode Indicator which show the most significant two bits of the eight bits. The setting range of the Message Display Mode can be the integer 0-255:

  • If the integer 0-63 is input, `00' is filled in the MSG_DISPLAY_MODE field.
  • If the integer 64-127 is input, `01' is filled in the MSG_DISPLAY_MODE field.
  • If the integer 128-191 is input, `10' is filled in the MSG_DISPLAY_MODE field.
  • The integer 192-255 is reserved.

Setting

Range: 0-255 integer value.

Query

Range: same as settings.

*RST Setting

 0

Requirements

Lab Application Revision: B.04 and above

Programming Example

OUTPUT 714;"CALL:SMService:MTERminated:MDMode 64"
!Set the mobile station to display the received message based on a pre-defined mode in the mobile station".

CALL:SMService:MTERminated:MDMode:INCLusion

Function

Sets/queries whether to send the Message Display Mode sub-parameter for teleservice types (defined by CALL:SMService:MTERminated:TELeservice ). See MDMI .

Setting

Range: INCLude|EXCLude

Query

Range: INCL|EXCL

*RST Setting

EXCL

Requirements

Lab Application Revision: B.04 and above

Programming Example

OUTPUT 714;"CALL:SMService:MTERminated:MDMode:INCLusion INCLude"
!Set to display the Message Display Mode.

CALL:SMService:MTERminated:MESSage:ASCii

Function

Sets/queries the Mobile-Terminated SMS ASCII message content. The ASCII message is included in the SMS message to be sent to the mobile station when the message source is ASCII (determined by the CALL:SMService:MTERminated:SOURce ) and the message content is included (determined by the CALL:SMService:MTERminated:MESSage:UDATa ). The message contents will be displayed in the Mobile-Terminated Message .

Setting

Range: 0-255 ASCII characters, enclosed by quotes.

Query

Range: same as settings.

*RST Setting

"ABCDEFGHIGKLMNOPQRSTUVWXYZ"

Requirements

Lab Application Revision: B.00 and above

Programming Example

OUTPUT 714;"CALL:SMService:MTERminated:MESSage:ASCii 'I Have arrived!'"
!Set the message content (in ASCII format) to "I have arrived!".

CALL:SMService:MTERminated:MESSage:ENCoding

Function

Sets/queries the encoding scheme used for the SMS message to be sent to the mobile station. See Message Encoding for details.

Setting

Range: OCTet|ASCii7|IA5|UNICode|SJIS|KSC5601|KORean|LHEBrew|LATin|GSM7

Query

Range: OCT|ASC7|IA5|UNIC|SJIS|KSC5601|KOR|LHEB|LAT|GSM7

*RST Setting

 ASC7

Requirements

Lab Application Revision: B.00 and above

Programming Example

OUTPUT 714;"CALL:SMService:MTERminated:MESSage:ENCoding UNICode"
!Set the encoding type as UNICode, indicating 16 bits per encoded character.

CALL:SMService:MTERminated:MESSage:HEX

Function

Sets/queries the Mobile-Terminated SMS Hex message content. The Hex message is included in the SMS message to be sent to the mobile station when the message source is Hex (determined by the CALL:SMService:MTERminated:SOURce ) and the message content is included (determined by the CALL:SMService:MTERminated:MESSage:UDATa ). The contents will be displayed in the Mobile-Terminated Message .

Setting

Range: 0-511 hex characters, enclosed by quotes.

Query

Range: same as settings.

*RST Setting

"4142434445464748494A4B4C4D4E4F505152535455565758595A"

Requirements

Lab Application Revision: B.00 and above

Programming Example

OUTPUT 714;"CALL:SMService:MTERminated:MESSage:HEX '0123456789ABCEEF'"
!Set the message content (in Hex format) to "0123456789ABCEEF"

CALL:SMService:MTERminated:MESSage:LENGth?

Function

Queries the length of the desired message in encoded characters. It is based on the Message Encoding, Message Source, and Message Repeat. This result is available on the Mobile-Terminated SMS Info window.

See How Does the Test Set Build the Mobile-Terminated Message? for details.

Query

Range: 0 to 65025
Resolution: 1

*RST Setting

 26

Requirements

Lab Application Revision: B.00 and above

Programming Example

OUTPUT 714;"CALL:SMService:MTERminated:MESSage:LENGth?
!Query the length of the desired message in encoded characters.

CALL:SMService:MTERminated:MESSage:REPeat

Function

Sets/queries the number of times the user entered message contents (plus any padding if necessary) will be repeated to make the desired message sent to the MS. See Set Message Repeat .

Setting

Range: 0 to 255

Resolution: 1

Query

Range: same as setting

*RST Setting

1

Requirements

Lab Application Revision: B.00 and above

Programming Example

OUTPUT 714;"CALL:SMService:MTERminated:MESSage:REPeat 5"
!Set the number of repeat times for the user input message to 5.

CALL:SMService:MTERminated:MESSage:UDATa

Function

Sets/queries whether the user entered message contents is included in the optional User Data subparameter of the SMS messages sent to the mobile station. The User Data subparameter is mandatory and always included when the teleservice is WAP regardless of this setting, but this setting controls whether or not the User Data is included when the teleservice is other than WAP ( CALL:SMService:MTERminated:TELeservice ).

See Message (Optional User Data) for details.

Setting

Range: INCLude|EXCLude

Query

Range: INCL|EXCL

*RST Setting

 INCL

Requirements

Lab Application Revision: B.00 and above

Programming Example

OUTPUT 714;"CALL:SMService:MTERminated:MESSage:UDATa INCL"
!Set to include the user entered message in the SMS message.

CALL:SMService:MTERminated:MSACk:CCODe[:INDex]?

Function

Queries the MS Ack cause code upon receipt of an SMS acknowledgment from the mobile station. 'NAN' is returned when the SMS Status is any value other than 'MS Ack'. See SMS Message Acknowledge Info for details.

Query

Range: 0 to 255 (see MS Ack Cause Code & String for description), NAN (9.91E+37)

*RST Setting

NAN

Requirements

Lab Application Revision: B.00 and above

Programming Example

OUTPUT 714;"CALL:SMService:MTERminated:MSACk:CCODe?"
!Query the SMS ACK cause code.

CALL:SMService:MTERminated:MSACk:CCODe:STRing?

Function

Queries the MS Ack cause string corresponding to the MS Ack cause code. See SMS Message Acknowledge Info for details.

Query

Range: see MS Ack Cause String column in MS Ack Cause Code & String

*RST Setting

"" (null string)

Requirements

Lab Application Revision: B.00 and above

Programming Example

OUTPUT 714;"CALL:SMService:MTERminated:MSACk:CCODe:STRing?"
!Query the string of the SMS ACK cause code.

CALL:SMService:MTERminated:PRIority

Function

Sets/queries the priority level of the SMS messages. See Priority .

Setting

Range: NONE | NORMal | INTeractive | URGent | EMERgency

Query

Range: NONE | NORM | INT | URG | EMER

*RST Setting

NORM

Requirements

Lab Application Revision: B.00 and above

Programming Example

OUTPUT 714;"CALL:SMService:MTERminated:PRIority EMERgency"
!Set the SMS priority level to Emergency.

CALL:SMService:MTERminated:PRIVacy

Function

Sets/queries the privacy level of the SMS messages. See Privacy .

Setting

Range: NONE|NORestriction|RESTrict|CONFidential|SECRet

Query

Range: NONE|NOR|REST|CONF|SECR

*RST Setting

NONE

Requirements

Lab Application Revision: B.00 and above

Programming Example

OUTPUT 714;"CALL:SMService:MTERminated:PRIVacy CONFidential"
!Set the SMS privacy level to confidential.

CALL:SMService:MTERminated:SCATegory

Function

Sets/queries the service category of the Mobile-Terminated SMS message. It's useful when CALL:SMService:MTERminated:SERVice is set to BROadcast. See Service Category .

Setting

Range: 0- 31 (see Service Category Settings for service category description)
Resolution: 1

Query

Same as settings

*RST Setting

1

Requirements

Lab Application Revision: B.00 and above

Programming Example

OUTPUT 714;"CALL:SMService:MTERminated:SCATegory 3"
!Set the service category to General News - Local.

CALL:SMService:MTERminated:SERVice

Function

Sets/queries the Mobile-Terminated SMS message type, either point-to-point or broadcast. See Service for details.

Setting

Range: PTPoint|BROadcast

Query

Range: PTP|BRO

*RST Setting

PTP

Requirements

Lab Application Revision: B.00 and above

Programming Example

OUTPUT 714;"CALL:SMService:MTERminated:SERVice PTP"
!Set the Mobile-Terminated SMS message type to point-to-point.

CALL:SMService:MTERminated:TELeservice

Function

Sets/queries the teleservice that will send the SMS message. It's useful for the point-to-point message specified by the CALL:SMService:MTERminated:SERVice .

See also Teleservice .

Setting

Range: WPAGing|WMESsaging|WAP|VMNotify|CATPt

Query

Range: WPAG|WMES|WAP| VMN|CATP

*RST Setting

WMES

Requirements

Lab Application Revision: B.00 and above

Lab Application Revision: B.04 and above: support CATPT

Programming Example

OUTPUT 714;"CALL:SMService:MTERminated:TELeservice WPAG"
!Sets the teleservice to Wireless Paging Teleservice.

CALL:SMService:MTERminated:VMNotify:COUNt

Function

Sets/queries the number of the voice mail messages sent to the mobile station. It is useful only when the VMN teleservice is selected by CALL:SMService:MTERminated:TELeservice .

See also Voice Mail Count .

Setting

Range: 0 - 99

Resolution: 1

Query

Range: same as setting

*RST Setting

0

Requirements

Lab Application Revision: B.00 and above

Programming Example

OUTPUT 714;"CALL:SMService:MTERminated:VMNotify:COUNt 5"
!Sets the voice mail message counts to 5.


CALL:SPARameter

CALL:SPARameter

Last updated: June 7, 2007

GPIB Command Conventions

  • CALL[:CELL[1]]:SPARameter:TADD
  • CALL[:CELL[1]]:SPARameter:TDRop
  • CALL[:CELL[1]]:SPARameter:TCOMp
  • CALL[:CELL[1]]:SPARameter:TTDRop
  • CALL[:CELL[1]]:SPARameter:SOFT[:SLOPe]
  • CALL[:CELL[1]]:SPARameter:ADD[:INTercept]
  • CALL[:CELL[1]]:SPARameter:DROP[:INTercept]

CALL[:CELL[1]]:SPARameter:TADD

Function

Sets/queries T_Add.

T_Add is the pilot detection threshold used by a mobile station to trigger the sending of a Pilot Strength Measurement Message and to trigger the transfer of a pilot from the Neighbor Set or Remaining Set to the Candidate Set. A pilot should transfer from the mobile station's Neighbor Set or Remaining Set to the Candidate Set when the detected pilot strength exceeds T_Add multiplied by -0.5 dB relative to total RF power.

The value of this parameter is used in the IS-95 System Parameters Message, IS-2000 System Parameters Message, and the In-Traffic System Parameters Message.

When this value is changed the test set will increment the CONFIG_MSG_SEQ parameter and send the updated System Parameters Message. If a call is connected, an In-Traffic System Parameters Message is sent.

Setting

Range: 0 to 63

Query

Range: 0 to 63

*RST Setting

 28

Requirements

Lab Application Revision: A.01 and above

Programming Example

OUTPUT 714;"CALL:CELL:SPAR:TADD 26" sets T_ADD to 26.

CALL[:CELL[1]]:SPARameter:TDRop

Function

Sets/queries T_Drop.

T_Drop is the pilot drop threshold parameter. This value is used by mobile stations to start a handoff drop timer for pilots in the Active Set and Candidate Set. If the power level of an Active set pilot is observed to fall below the T_Drop multiplied by -0.5 dB threshold for the period of time specified by CALL[:CELL[1]]:SPARameter:TTDRop the mobile station will send a Pilot Strength Measurement Message indicating the pilot status is "to drop".

When this value is changed the test set will increment the CONFIG_MSG_SEQ parameter and send the updated System Parameters message. If a call is connected, an In-Traffic System Parameters message shall be sent.

Setting

Range: 0 to 63

Query

Range: 0 to 63

*RST Setting

 32

Requirements

Lab Application Revision: A.01 and above

Programming Example

OUTPUT 714;"CALL:CELL:SPAR:TDROP 30" !sets T_DROP to 30.

CALL[:CELL[1]]:SPARameter:TCOMp

Function

Sets/queries T_Comp.

T_Comp is the Active Set versus Candidate Set comparison threshold. Mobile stations send a Pilot Strength Measurement Message when the strength of a pilot in the Candidate Set exceeds that of a pilot in the Active Set by this margin multiplied by 0.5 dB.

When this value is changed the test set will perform the standard operation for updating the contents of the system parameter messages.

Setting

Range: 0 to 15

Query

Range: 0 to 15

*RST Setting

 5

Requirements

Lab Application Revision: A.01 and above

Programming Example

OUTPUT 714;"CALL:CELL:SPAR:TCOM 6" sets T_Comp to 6.

CALL[:CELL[1]]:SPARameter:TTDRop

Function

Sets/queries T_Tdrop.

T_Tdrop is a base station controlled parameter that specifies the duration of the timer that mobile station's use to remove pilots from the Active or Candidate sets. If the power level of an Active set pilot is observed to fall below the T_Drop threshold for the time interval indicated by T_Tdrop (4 seconds when T_Tdrop = 3) the mobile station will send a Pilot Strength Measurement Message indicating the Active pilot status is "to drop".

When this value is changed the test set will perform the standard operation for updating the contents of the system parameter messages. If a call is connected, an In-Traffic System Parameters message shall be sent.

Setting

Range: 0 to 15

Query

Range: 0 to 15

*RST Setting

 3

Requirements

Lab Application Revision: A.01 and above

Programming Example

OUTPUT 714;"CALL:CELL:SPAR:TTDR 4" sets T_Tdrop to 4.

CALL[:CELL[1]]:SPARameter:SOFT[:SLOPe]

Function

Sets/queries Soft_Slope.

Soft_Slope allows the setting of the SOFT_SLOPE parameter in the IS-95 Extended System Parameters Message and the IS-2000 Extended System Parameters Message.

When this setting's value is changed, the test set will perform the normal operation of updating the system parameters. If a call is connected, an In-Traffic System Parameters message shall be sent.

Setting

Range: 0 to 63

Query

Range: 0 to 63

*RST Setting

 0

Requirements

Lab Application Revision: A.01 and above

Programming Example

OUTPUT 714;"CALL:CELL:SPAR:SOFT 1" sets Soft_Slope to 1.

CALL[:CELL[1]]:SPARameter:ADD[:INTercept]

Function

Sets/queries Add_Intercept.

Add_Intercept allows the setting of the ADD_INTERCEPT parameter in the IS-95 Extended System Parameters Message and the IS-2000 Extended System Parameters Message.

When this setting's value is changed, the test set will perform the normal operation of updating the system parameters.

Setting

Range: -32 to 31

Query

Range: -32 to 31

*RST Setting

 0

Requirements

Lab Application Revision: A.01 and above

Programming Example

OUTPUT 714;"CALL:CELL:SPAR:ADD 1" sets Add_Intercept to 1.

CALL[:CELL[1]]:SPARameter:DROP[:INTercept]

Function

Sets/queries Drop_Intercept.

Drop_Intercept allows the setting of the DROP_INTERCEPT parameter in the IS-95 Extended System Parameters Message and the IS-2000 Extended System Parameters Message.

When this setting's value is changed, the test set will perform the normal operation of updating the system parameters. If a call is connected, an In-Traffic System Parameters message shall be sent.

Setting

Range: -32 to 31

Query

Range: -32 to 31

*RST Setting

 0

Requirements

Lab Application Revision: A.01 and above

Programming Example

OUTPUT 714;"CALL:CELL:SPAR:DROP 1" sets Drop_Intercept to 1.


CALL:CELL2:TRAFfic

CALL:CELL2:TRAFfic

Last updated: June 6, 2007

Diagram Conventions

  • CALL:CELL2:TRAFfic[:SLEVel]<[:SELected]|DIGital95>
  • CALL:CELL2:TRAFfic:LEVel<[:SELected]|DIGital95>
  • CALL:CELL2:TRAFfic:STATe<[:SELected]|DIGital95>
  • CALL:CELL2:TRAFfic:WALSh

CALL:CELL2:TRAFfic[:SLEVel]<[:SELected]|DIGital95>

Function

The setting form of this command performs two functions: (1) sets the Cell 2 Traffic Level, and (2) turns the traffic channel state to ON.

The query form of this command returns the traffic channel level.

NOTE
This command applies to the System Type IS-95 Cell 2 traffic channel only. To make level changes to the System Type IS-2000 Cell 2 fundamental channel, see CALL:CELL2:FCHannel .

Setting

Range: 0 to -30 dB

Resolution: 0.01 dB

Query

Range: 0 to -30 dB

Resolution: 0.01 dB

*RST Setting

-15.6 dB

Requirements

Lab Application Revision: A.01 and above

Programming Example

OUTPUT 714;"CALL:CELL2:TRAFfic:SLEVEL:DIGITAL95 -10 dB"
!Sets the Cell 2 Traffic Level state to ON and sets the level to -10 dB.

CALL:CELL2:TRAFfic:LEVel<[:SELected]|DIGital95>

Function

Sets/queries the Cell 2 Traffic Level.

NOTE
This command applies to the System Type IS-95 traffic channel only. To make level changes to the System Type IS-2000 fundamental channel, see CALL:CELL2:FCHannel .

Setting

Range: 0 to -30 dB

Resolution: 0.01 dB

Query

Range: 0 to -30 dB

Resolution: 0.01 dB

*RST Setting

 -15.6 dB

Requirements

Lab Application Revision: A.01 and above

Programming Example

OUTPUT 714;"CALL:CELL2:TRAFfic:LEVEL:SELECTED -10 dB"

CALL:CELL2:TRAFfic:STATe<[:SELected]|DIGital95>

Function

Sets/queries the on/off state of the Cell 2 Traffic Level.

NOTE
This command applies to the System Type IS-95 Cell 2 traffic channel only. To make level changes to the System Type IS-2000 Cell 2 fundamental channel, see CALL:CELL2:FCHannel .

Setting

Range: 1|ON|0|OFF

Query

Range: 1|0

*RST Setting

ON

Requirements

Lab Application Revision: A.01 and above

Programming Example

OUTPUT 714;"CALL:CELL2:TRAFfic:STATE:DIGITAL95 OFF"
!Turns off the forward traffic channel.

CALL:CELL2:TRAFfic:WALSh

Function

Sets/queries the Cell 2 Traffic Walsh Code used for the DIGital95 (IS-95) traffic channel.

NOTE
This command applies to the System Type IS-95 Cell 2 traffic channel only. To make Walsh Code changes to the System Type IS-2000 Cell 2 fundamental channel, see CALL:CELL2:FCHannel .

Setting

Range: CODE10|CODE14|CODE26|CODE30|CODE42|CODE46|CODE58|CODE62

Query

Range: CODE10|CODE14|CODE26|CODE30|CODE42|CODE46|CODE58|CODE62

*RST Setting

CODE10

Requirements

Lab Application Revision: A.01 and above

Programming Example

OUTPUT 714;"CALL:CELL2:TRAFfic:WALSH CODE14"
!Sets the forward traffic channel walsh code to 14.

Related Topics

CALL:TRAFfic (Cell 1 IS-95 Traffic channel settings )


FETCh:GAPPower?

FETCh:GAPPower?

Last updated: June 7, 2007

GPIB Command Conventions

  • FETCh:GAPPower[:ALL][:RANGe20]?
  • FETCh:GAPPower[:ALL]:RANGe60?
  • FETCh:GAPPower:ICOunt?
  • FETCh:GAPPower:INTegrity?
  • FETCh:GAPPower:INTegrity20?
  • FETCh:GAPPower:INTegrity60?
  • FETCh:GAPPower:RTPRevious[:RANGe19]?
  • FETCh:GAPPower:RTPRevious:RANGe59?
  • FETCh:GAPPower:TIME[:RANGe19]?
  • FETCh:GAPPower:TIME:RANGe59?

FETCh:GAPPower[:ALL][:RANGe20]?

Function

Queries the graphical access probe power measurement results.

This measurement returns results in the following order: integrity, followed by a comma-separated list of access probe power results for the expected number of access probes displayed in the Measurement Progress Indicator field (see Graphical Access Probe Power Measurement Results )

If the graphical access probe power measurement consisted of less than 20 access probes, the query results will be padded with NAN's (9.91 E37) to make the number of results equal 20.

If the test set does not receive the expected number of access probes and no timeouts have been set up this command will hang indefinitely.

Query

Integrity

  • Range: 0 to 23 (see Integrity Indicator )

    Resolution: 1

Access probes

  • Range: -100 to 100 dBm, 9.91 E+37

  • Resolution: 0.0000001 dBm

Requirements

Lab Application Revision: A.01 and above

Programming Example

OUTPUT 714;"FETCh:GAPPower?"

!Queries the integrity result and power levels for up to 20 graphical access probe power measurements.

FETCh:GAPPower[:ALL]:RANGe60?

Function

Queries the graphical access probe power measurement results.

This measurement returns results in the following order: integrity, followed by a comma-separated list of access probe power results for the expected number of access probes displayed in the Measurement Progress Indicator field (see Graphical Access Probe Power Measurement Results )

If the graphical access probe power measurement consisted of less than 60 access probes, the query results will be padded with NAN's (9.91 E37) to make the number of results equal 60.

If the test set does not receive the expected number of access probes and no timeouts have been set up this command will hang indefinitely.

Query

Integrity

  • Range: 0 to 23 see Integrity Indicator

    Resolution: 1

Access probes

  • Range: -100 to 100 dBm, 9.91 E+37

  • Resolution: 0.0000001 dBm

Requirements

Lab Application Revision: A.02 and above

Programming Example

OUTPUT 714;"FETCh:GAPPower:RANGe60?"

!Queries the integrity result and power levels for up to 60 graphical access probe power measurements.

FETCh:GAPPower:ICOunt?

Function

Queries the intermediate count of access probe measurements displayed in the Measurement Progress Indicator field (see Graphical Access Probe Power Measurement Results ).

Query

Range: 0 to 999

Resolution: 1

Requirements

Lab Application Revision: A.01 and above

Programming Example

OUTPUT 714;"FETCh:GAPPower:ICOunt?"

!Queries the current number of access probes in the measurement progress indicator field.

FETCh:GAPPower:INTegrity?

Function

Queries the graphical access probe power overall measurement integrity indicator.

Zero indicates all access probes were normal. If the result of this query is non-zero it applies to the last non-zero integrity indicator.

See Integrity Indicator for information about non-zero integrity results.

Query

Range: 0 through 23

Resolution: 1

Requirements

Lab Application Revision: A.01 and above

Programming Example

OUTPUT 714;"FETCh:GAPPower:INTegrity?"

!Queries the overall integrity indicator for the graphical access probe power measurement.

FETCh:GAPPower:INTegrity20?

Function

For each graphical access probe power measurement, queries the first 20 individual graphical access probe power measurement integrity indicators.

Twenty values will be returned. If the graphical access probe power measurement consisted of less than 20 access probes, the query results will be padded with integrity indicators of 1, which means no results were available.

See Integrity Indicator for information about non-zero integrity results.

Query

Range: 20 integers each ranging in value from 0 through 23

Resolution: 1

Requirements

Lab Application Revision: A.01 and above

Programming Example

OUTPUT 714;"FETCh:GAPPower:INTegrity20?"

!Queries up to 20 access probe measurement integrity indicators.

FETCh:GAPPower:INTegrity60?

Function

For each graphical access probe power measurement, queries up to all 60 individual graphical access probe power measurement integrity indicators.

Sixty values will be returned. If the graphical access probe power measurement consisted of less than 60 access probes, the query results will be padded with integrity indicators of 1, which means no results were available.

See Integrity Indicator for information about non-zero integrity results.

Query

Range: 60 integers each ranging in value from 0 through 23

Resolution: 1

Requirements

Lab Application Revision: A.02 and above

Programming Example

OUTPUT 714;"FETCh:GAPPower:INTegrity60?"
!Queries up to 60 access probe measurement integrity indicators.

FETCh:GAPPower:RTPRevious[:RANGe19]?

Function

For each graphical access probe power measurement cycle, queries each access probe power measurement's delta power value relative to the previous access probe (there will be no delta for the first measurement).

Nineteen values will be returned. If the last graphical access probe power measurement cycle consisted of less than 20 access probes, the query results will be padded with NAN's (9.91 E+37), which means no results were available.

Query

Range: 19 real numbers

Resolution: 0.0000001 dB

Requirements

Lab Application Revision: A.01 and above

Programming Example

OUTPUT 714;"FETCh:GAPPower:RTPRevious?"

!Queries relative to previous power level values for the first 19 access probes except the first.

FETCh:GAPPower:RTPRevious:RANGe59?

Function

For each graphical access probe power measurement cycle, queries each access probe power measurement's delta power value relative to the previous access probe (there will be no delta for the first measurement).

Fifty nine values will be returned. If the last graphical access probe power measurement cycle consisted of less than 60 access probes, the query results will be padded with NAN's (9.91 E37), which means no results were available.

Query

Range: 60 real numbers

Resolution: 0.0000001 dB

Requirements

Lab Application Revision: A.02 and above

Programming Example

OUTPUT 714;"FETCh:GAPPower:RTPRevious:RANGe59?"

!Queries relative to previous power level values for all access probes except the first.

FETCh:GAPPower:TIME[:RANGe19]?

Function

For each graphical access probe power measurement, queries each access probe's time offset relative to the first access probe (there will be no time offset measurement for the first access probe).

Nineteen values will be returned. If the last graphical access probe power measurement cycle consisted of less than 20 access probes, the query results will be padded with NAN's (9.91 E37), which means no results were available.

Query

Range: 19 real numbers

Resolution: 0.01 seconds

Requirements

Lab Application Revision: A.01 and above

Programming Example

OUTPUT 714;"FETCh:GAPPower:TIME?"

!Queries the time offset values for the first 19 access probes except the first.

FETCh:GAPPower:TIME:RANGe59?

Function

For each graphical access probe power measurement cycle, queries each access probe's time offset relative to the first access probe (there will be no time offset measurement for the first access probe).

Fifty nine values will be returned. If the last graphical access probe power measurement cycle consisted of less than 60 access probes, the query results will be padded with NAN's (9.91 E37), which means no results were available.

Query

Range: 59 real numbers

Resolution: 0.01 seconds

Requirements

Lab Application Revision: A.02 and above

Programming Example

OUTPUT 714;"FETCh:GAPPower:TIME:RANGe59?"

!Queries the time offset values for all access probes except the first.


SETup:GAPPower

SETup:GAPPower

Last updated: October 28, 2004

NOTE
The Access Probe Power Setup parameters (see CALL:APARameter ) directly affect graphical access probe power measurements.

To limit a call attempt to the access attempt state, see CALL:CONNected .

Diagram Conventions

SETup:GAPPower:TIMeout[:STIMe]

Function

The setting form of this command performs two functions: (1) sets the graphical access probe power measurement's timeout (see Timeouts ) value, and (2) sets the graphical access probe power measurement's timeout STATe to 1 (on).

The query form returns the graphical access probe power measurement's timeout value.

Setting

Range: 0.1 to 999.9 seconds

Resolution: 0.1 second

Query

Range: 0.1 to 999.9

*RST Setting

10 seconds, on

Requirements

Lab Application Revision: A.01 and above

Programming Example

OUTPUT 714;"SETUP:GAPPOWER:TIMEOUT:STIME 5"
!Sets timeout state to ON and sets the timeout time to 5 seconds.

SETup:GAPPower:TIMeout:STATe

Function

Sets/queries the graphical access probe power measurement's timeout (see Timeouts ) state.

Setting

Range: 1|ON|0|OFF

Query

Range: 1|0

*RST Setting

0 (off)

Requirements

Lab Application Revision: A.01 and above

Programming Example

OUTPUT 714;"SETUP:GAPPOWER:TIMEOUT:STATE ON"

SETup:GAPPower:TIMeout:TIME

Function

Sets/queries the graphical access probe power measurement's timeout (see Timeouts ) setting to be used when the timeout state is set to ON.

Setting

Range: 0.1 to 999.9 seconds

Resolution: 0.1 second

Query

Range: 0.1 to 999.9

*RST Setting

10 seconds

Requirements

Lab Application Revision: A.01 and above

Programming Example

OUTPUT 714;"SETUP:GAPPOWER:TIMEOUT:TIME 5"


SYSTem:STATus

SYSTem:STATus

Last updated: June 7, 2007

GPIB Command Conventions

  • SYSTem:STATus:COMMunicate:LAN:EXTernal:SYNChronize:INDication?

SYSTem:STATus:COMMunicate:LAN:EXTernal:SYNChronize:INDication?

Function

Queries the information about the last sychronization event when the test sets executes Sync To External Sync Server or receives Sync Process Request message.

  • COC: Indicates the synchronization operation was completed in the test set that act as Sync Client.
  • SOC: Indicates the synchronization operation was completed in the test set that act as Sync Server.
  • CSOC: Indicates the synchronization operation was completed in the test set that acts as Sync Client first and then as Sync Server.

Query

Range: UNKN|COC|SOC|CSOC

Requirements

Lab Application Revision: B.03 or above

Programming Example

OUTPUT 714;"SYSTEM:STATUS:COMMUNICATE:LAN:EXTERNAL:SYNCHRONIZE:INDICATION?"


Graphical Access Probe Power Measurement Description

Graphical Access Probe Power Measurement Description

Last updated: October 28, 2004

This section is only applicable to the lab application.

  • How is a Graphical Access Probe Power measurement made?
  • Graphical Access Probe Power Measurement Parameters
  • Graphical Access Probe Power Measurement Results
  • Input Signal Requirements
  • Key TIA/EIA-98-E Tests Using the Graphical Access Probe Power Measurement
  • Calibrating the Graphical Access Probe Power Measurement

How is a Graphical Access Probe Power measurement made?

The graphical access probe power measurement consists of a series of up to 60 channel power measurements, each triggered by a rise in RF power detected on the test set's RF input. The measurement trigger threshold is approximately -45 dBm/1.23 MHz.

Access probe sequences are transmitted by the mobile station during registrations or mobile station originated calls. Access probe sequences consist of a series of RF power "steps" which increase in power according to the step size setting until the maximum number of steps is reached or the call processing event completes, for example when the call connects.

Each graphical access probe power measurement cycle is initiated by a GPIB INIT command or by pressing the START SINGLE key. During a measurement cycle the following events can trigger access probe power measurements:

  • Registrations (including power-up and timer based)
  • Mobile station originated calls (pressing the SEND key on the mobile station)
  • Test Set originated calls (pressing the Originate Call key on the test set).

When a graphical access probe power measurement is initiated, the test set calculates the number of access probes expected from parameters set up in the Graphical Access Probe Power Setup menu (see Graphical Access Probe Power Measurement Parameters ) assuming that Call Limit Mode is turned on (see C. Turn Call Limit On. ). Pressing the MEASUREMENT RESET key will clear the display.

Considerations when making Graphical Access Probe Power measurements

Graphical access probe power measurements do not run concurrently with any other measurements. If any measurement(s) are open when graphical access probe power is opened, they will automatically be closed.

When a call is originated from the test set, and call limit is on, the call processing state of the test set remains in a non-idle state (usually Access Probe or Registering) after the graphical access probe measurement has completed. Before attempting the next measurement, the End Call (F3) key must be pressed or a GPIB command to end the origination must be sent before attempting the next measurement.

Changing the number of steps and step size will affect the power level displayed if more than one access probe is transmitted by the mobile station. However, the number of access probes transmitted depends on whether or not the test set responds by acknowledging the access request, thereby ending the access attempt. To view the full access probe sequence, you must prevent the test set from responding to the mobile station access probe request by turning the Call Limit Mode on (key F10 in Call Parms, 2 of 3 screen). For the GPIB command syntax, see CALL:CONNected:LIMit[:STATe]<[:SELected]|:TA2000> .

NOTE
It is recommended that you always turn the Call Limit Mode on when measuring access probe power. The easiest way to induce access probes from the mobile station is to page the mobile station. If you do not have call limit mode set to on, the call connection will complete, which clears the access probe power result from the measurement screen. Set call limit mode back to off when you have finished measuring access probe power.

When the mobile station performs any type of registration, an access probe power measurement will likely be triggered. Registrations can occur on mobile station power-up, depending on how the mobile station is programmed. Registrations may be requested by the test set at pre-determined time intervals, which will periodically cause the access probe power measurement to update. To control timer based registrations, access the Registration Parameters menu (see D. Registration Parameters ). For GPIB syntax information on timer-based registrations, see CALL:REGister:TIMer:STATe .

NOTE
It is recommended that you always turn the Timer Based Registration State off when measuring access probe power since the registration events can trigger access probe power measurements to update during a measurement cycle.

Graphical Access Probe Power Measurement Parameters

The parameters shown in the Graphic Access Probe Power Setup menu are different according to the current access channel configured (see Control Channel Configuration ):

  • When the current access channel is R-ACH, the parameters such as Nominal Power, Nominal Power Extended, Initial Power, Power Step, Number of Steps, Maximum Response Sequence and Preamble Size will be displayed. See Setting Access Parameters for details on these parameters:
  • When the current access channel is R-EACH, the parameters such as EACH Nominal Power, EACH Initial Power, EACH Power Step, EACH Number of Steps and Maximum Response Sequence will be displayed. See Setting Enhanced Access Parameters for details on these parameters.
  • Measurement Timeout - (see Timeouts ). The access probe power measurement will remain armed indefinitely until the maximum number of access probes is received, unless the measurement timeout is On or the measurement is reset.

Graphical Access Probe Power Measurement Results

Each measurement is displayed in both a tabular and a bar graph format. See Graphical Access Probe Power Measurement Display .

Graphical Access Probe Power Measurement Display

Graphical Display

The graphical display shows an access probe power bar graph covering a time span of up to 120 seconds from the first access probe. Access probe power is displayed using yellow bars on the graph and the graph can display up to 60 access probes, labeled 0 through 59. Power levels are displayed in units of dBm/1.23 MHz.

NOTE
The number of access probes equals Number of Steps plus 1. For example, when Number of Steps is set to 3, the display shows 4 yellow bars in one access probe sequence.

NOTE
If the absolute power level of an access probe falls below the range of the graph, the value will cause the bar to be invisible (it will clip). The correct value for the absolute power level will be displayed in the table at the bottom of the display.

The graphical display is accessed by the Graph Control softkey (see G. Set Up the Graphical View ). The F5 Graph Span softkey is used to adjust the view window. The view window can be adjusted to include a view of the entire 120 second range, or reduced to include only the access probes or access probe sequences of particular interest. If Graph Span is set to display only a portion of the 120 second time period, the F3 Graph Start Time field can be used to move the Graph Span window.

Two markers are available on the graphical display:

  • Position Marker.
    The Position Marker can be moved when the F1 Marker Mode is set to Position. This selection is made automatically if the F2 Marker Position field is adjusted. When Marker Mode is set to position, the position marker can be positioned at each access probe power measurement across the current span of the graph. Measurement results that correspond with the Position Marker are displayed above the graph (the two values to the right of the "Mkr" annunciator) and become highlighted in the table whenever the Marker Mode is not turned off.
  • Delta Marker.
    The Delta Marker is available when the F1 Marker Mode is set to Delta. This selection will toggle the F2 softkey label to Marker Delta. When the Marker Delta field is adjusted the delta between the Position Marker and the Delta Marker can be easily observed. Measurement results that correspond with the Position Marker and the Delta Marker are displayed above the graph (the two values to the right of the "Mkr" and Delta annunciators, respectively) and become highlighted in the table whenever the Marker Mode is set to Delta.

Tabular Display

A table below the graphical display lists the following measurement results for up to 60 access probes:

  • An access probe number indexed to each marker position.
  • The absolute power of each access probe measurement in units of dBm/1.23 MHz.
  • The delta power between adjacent access probes.
  • The time that each access probe arrived relative to the first access probe.

The table has the capacity to display 20 access probes. To scroll through the table adjust the Position or Delta Marker position field.

Measurement Progress Indicator

A measurement progress indicator in the lower left portion of the display continually updates the ratio of access probes received to the number of access probes expected. Each access probe power measurement cycle ends when the expected number of access probes have been received, the measurement times out, or the measurement is aborted or reset.

NOTE
If there is a measurement problem associated with an access probe, a non-zero integrity indicator (see Integrity Indicator ) will be displayed below the table and the access probe's power measurement will appear in reverse video (black text on a white background).

Input Signal Requirements

The graphical access probe power measurement meets or exceeds specifications when the following input signal requirements are met:

  • The frequency of the signal being measured must be within the range of 412 MHz to 483 MHz, 800 MHz to 960 MHz, or 1.7 GHz to 2.0 GHz, and be within 100 kHz of the expected frequency.
  • The average power level of the signal at the RF IN/OUT connector must be between -61 dBm to +37 dBm. The test set can autorange to a signal that is within +/- 9 dB of the expected input level (see RFANalyzer:AUTO:POWer[:SELected]? ).

Key TIA/EIA-98-E Tests Using the Graphical Access Probe Power Measurement

  • Same as the tests supported by Access Probe Power Measurement (see Key TIA/EIA-98-E Tests Performed Using the Access Probe Power Measurement )

Calibrating the Graphical Access Probe Power Measurement

The graphical access probe power measurement is automatically calibrated during a channel power calibration. Follow the channel power calibration schedule and the graphical access probe power measurement will be properly calibrated. Refer to Calibrating the Test Set for a description of channel power calibration.

Related Topics

How Do I Perform a Graphical Access Probe Power Measurement?

Programming a Graphical Access Probe Power Measurement

Graphical Access Probe Power Troubleshooting

Test Adherence to Standards

Channel Power Measurement Description


Paging Channel MER Description

Paging Channel MER Description

Last updated: June 20, 2006

This section is only applicable to the lab application.

  • How is the Paging Channel's Message Error Rate (MER) measured?
  • Paging Channel MER Procedures
  • Paging Channel MER Parameters
  • Paging Channel MER Results
  • Key TIA/EIA-98-E Tests Using Paging MER

How is the Paging Channel's Message Error Rate (MER) measured?

The Paging Channel MER test is used to evaluate how well the mobile station demodulates the paging channel in an AWGN (no fading or multipath) environment.

  • There are two types of Paging Channel MER tests specified in the EIA/TIA-98E standard: 3.3.1 demodulation of non-slotted mode paging channel and 3.3.2 demodulation of slotted mode paging channel . The test set only supports measuring MER for slotted mode paging channel.
  • The EIA/TIA-98E standard specifies two alternative methods for determining Paging Channel MER. The first method (as shown in Paging Channel MER Calculation - Based on Message Counts ) involves counting the messages sent to the mobile and comparing that count against the number of messages the mobile receives. The second technique (as shown in Paging Channel MER Calculation - Based on Test Time ) involves estimating the number of message sent to the mobile station (as opposed to counting them) and comparing the estimate against the number of messages the mobile received. The test set uses the first method for determining the Paging Channel MER. However, you can estimate the Paging Channel MER with the second method.

During the Paging Channel MER test (see Paging Channel MER Procedures ), the test set continuously sends messages on the paging channel that are addressed to the recently registered mobile station and keeps a running count of the paging channel messages in the F-Paging Messages parameter (see Paging Channel MER Results ). The mobile station records how many messages are received and keeps a running count of the received messages in the PAG_3 parameter of the mobile station's internal register. At the end of the test procedure, the test set retrieves the value of the mobile station's PAG_3 parameter and stores the value in the test set's MS PAG_3 parameter (see Paging Channel MER Results ). The Slotted Paging Channel MER is then calculated based on the formula as shown in Paging Channel MER Calculation - Based on Message Counts

Paging Channel MER Calculation - Based on Message Counts

Paging Channel MER Calculation - Based on Test Time

NOTE
If the Paging MER is estimated based on the test time, it recommends to use script programming and need to:
1. set the Max Slot Cycle Index to 0 (see Setting Cell Parameters ).
2. strictly follow the procedure (see Paging Channel MER Procedures ).

Paging Channel MER Procedures

All parameters and results relating to the Paging Channel MER test are accessed from the Paging MER menu by pressing the F6 ( Paging Channel MER ) on Call Control 3 of 3 menu. For details on front panel operation, see Measuring Paging Channel Message Error Rate (MER) .

NOTE
It's recommended that you follow the steps in the order described below to ensure valid results. If you vary the test procedure you may get the unexpected results.

  1. Verify that the test set is configured to provide paging channels (see Control Channel Configuration )
  2. Turn off the timer based registration (see D. Registration Parameters ).
  3. Set up the Paging Channel MER parameters (see Paging Channel MER Parameters for details).

    NOTE
    It is recommended that you set up the parameters associated with the paging MER test prior to initiating the test procedure. The test set provides a warning message ( MER Proc Warning ) if key settings are changed during the test. However, the test set does not block the changes or cause the paging MER test procedure to be aborted.

  4. Establish a call (see How Do I Set Up a Call? ).
    A call must be established prior to proceeding to the next step since starting the MER procedure requires the exchange of the signaling via the traffic/fundamental channel.
  5. Start the MER Procedure (see CALL:PAGing:MERRor:PROCedure:STARt ).
    When the MER procedure is started, the test set will set its internal counters (the F-Paging Messages and the Paging MER Test Time) to their default values and set the PAG_3 parameter in the mobile station's register to zero via Set Parameter Message (STPM) (see Messaging associated with Paging MER Test ). When the mobile station successfully responds to the STPM, the test set will update its internal MS PAG_3 parameter to zero. Now, the test set's internal counter (F-Paging Messages) are ready to increment for each message sent on the Paging Channel addressed to the currently registered mobile station. Also the test set's internal timer (Paging MER Test Time) starts counting.
  6. Disconnect the call (see How Do I End a Call? ).
    This ensures counting the messages that the mobile station should demodulate since the mobile station does not listen to the paging channel when a call is established.

    It's recommended that you wait for a few seconds (depending upon your mobile station design) before proceeding to the next step. This ensures that the mobile station is ready to monitor the paging channel.
  7. Set Audit Order to On (see CALL:CCHannel:AUDit:STATe ).
    This causes the test set to start sending Audit Order (see Messaging associated with Paging MER Test ) messages on the paging channel which do not require a Layer 2 acknowledgment.

    NOTE
    The timer may not reflect the duration of the time when the mobile station is demodulating the paging channel if you did not end the call in step 6.

    NOTE
    If a different mobile station registers when the Audit Order turns on, the test set will send the Audit Order messages to the newly registered mobile station but the F-Paging Messages counter does not reset. This may cause the invalid MER results.

  8. Wait the desired time you'd like to have the MER test procedure run. The standard specifies "at least 2 minutes and until sufficient confidence is ensured".
  9. Set Audit Order to Off. (see CALL:CCHannel:AUDit:STATe ).
    This causes the test set to stop sending Audit Order messages on the paging channel.
  10. Establish a call (originating from the mobile station).
    A call must be established prior to proceeding to the next step since stopping the MER procedure requires the exchange of the signaling via the traffic/fundamental channel.

    It is recommended that you originate the call from the mobile station. This can avoid additional messages sent on the paging channel to result in the different MER results got from the message count based calculation and the timer based estimation or result in the mismatched paging message counting in the mobile station's register and the test set's counter due to mobile station missing the paging channel messages.
  11. Stop the MER procedure (see CALL:PAGing:MERRor:PROCedure:STOP ).
    When the MER procedure is stopped, the test set internal message counters (F-Paging Messages) stop incrementing. Also the test set's internal timer (Paging MER Test Time) stops counting (no longer increments). The test set sends Retrieve Parameters Messag e (RTPM) (see Messaging associated with Paging MER Test ) to the mobile station to retrieve the value of PAG_3 in the mobile station's internal register and updates its MS PAG_3 parameter based on the received Parameters Response Message (PRSM) (see Messaging associated with Paging MER Test ) from the mobile station. The Slotted Paging Channel MER is then calculated based on the formula as shown in Paging Channel MER Calculation - Based on Message Counts
  12. Monitor the test results. All related results should be displayed on the Paging Channel Message Error Rate window (see Paging Channel MER Results ).
  13. (optional) Disconnect the call.
  14. (optional) Clear the counters and results associated with Paging MER test (see CALL:PAGing:MERRor:PROCedure:PARameter:CLEar ).

    NOTE
    It does not clear the counters (such as PAG_3) in the mobile station's internal register.

  15. Turn the timer based registration back to on (see D. Registration Parameters ).
Messaging associated with Paging MER Test
Messages | Description
Retrieve Parameters Message (RTPM) | The test set sends this message to request the mobile station to report its current value for the PAG_3 parameter.
Parameters Response Message (PRSM) | The mobile station sends this message (in response to the RTPM) to report the values of its parameters and indicate parameters that are not supported.
Set Parameters Message (STPM) | The test set uses this message to set the mobile station's settable parameters (for example, PAG_3).
Mobile Station Reject Order | The mobile station shall send this message with REJECTED_PARAM_ID (for each PARAMETER_ID not set) if the mobile can not set the parameters specified by PARAMETER_ID fields in the STPM.
Audit Order (ORDM) | The test set will send the Audit Order messages addressed to the most recently registered mobile station when the Audit Order turns on. See Paging Channel MER Procedures .

Paging Channel MER Parameters

The key parameters relating to Paging MER test are accessed from the Paging Channel MER Parms ( F1 ) under Paging MER menu. See Measuring Paging Channel Message Error Rate (MER) for front panel operation.

  • Cell 1 F-Pilot Level: See Configuring Forward Channel Power Levels and Walsh Codes .
  • Cell 1 F-Sync Level: See Configuring Forward Channel Power Levels and Walsh Codes .
  • Cell 1 F-Paging Level: See Configuring Forward Channel Power Levels and Walsh Codes .
  • Paging Data Rate: See Control Channel Parameters (F-PCH/R-ACH) .
  • Max Slot Cycle Index: See Setting Cell Parameters .
  • F-QPCH State: See Control Channel Parameters (F-PCH/R-ACH) .
  • F-QPCH Relative to Pilot Level: See Control Channel Parameters (F-PCH/R-ACH) .
  • F-QPCH Data Rate: See Control Channel Parameters (F-PCH/R-ACH) .
  • AWGN Power: See Configuring Cell Power and AWGN Power Levels .

Paging Channel MER Results

The following results are available on the Paging Channel Message Error Rate window when the Paging Channel MER procedure ends.

  • Slotted Paging Channel MER ( CALL:STATus:PAGing:MERRor:RATio[:SLOTed]? ): indicates how well the mobile station demodulates the paging channel under the current test conditions. It is expressed as a percentage and calculated based on the formula as shown in Paging Channel MER Calculation - Based on Message Counts
  • MS PAG_3 ( CALL:MS:RSParameter:PAG3? ): indicates the total number of paging channel messages received by the mobile station. It is obtained by retrieving from the mobile station's PAG_3 register. See Paging Channel MER Procedures for details.
  • F-Paging Messages ( CALL:STATus:PAGing:MERRor:MESSages? ): indicates the total number of paging channel messages sent to the mobile station during the test. Intermediate F-Paging Messages results are periodically available on the front panel display, but are not available programmatically through the GPIB command. See Paging Channel MER Procedures for details on when the counting starts and stops.
  • Paging MER Test Time ( CALL:STATus:PAGing:MERRor:TIME? ): indicates the length of the Paging MER test time in seconds. See Paging Channel MER Procedures for when the counting starts and stops.
  • F-Paging E b /N t ( CALL:STATus:PAGing:EBNTotal? ): the ratio of energy per bit for the paging channel to noise power spectral density. It's available only when Cell 1 Power, AWGN Power and F-Paging Channel states are on. See F-Paging/Paging Eb/Nt for detail on how it is calculated.
  • F-QPCH E b /N t ( CALL:STATus:QPCHannel:EBNTotal? ): the ratio of energy per bit for the quick paging channel to noise power spectral density. It's available when the states of F-QPCH level, Cell power and AWGN power are on. See F-QPCH Eb/Nt for detail on how it is calculated.

  • MER Proc Warning

    Indicates error or warning conditions that have occurred during the Paging MER test procedure. The error is updated as the condition occurs and does not wait for the Control Channel FER test procedure to be completed. Only the last error condition that occurred is displayed.

    These error conditions are provided to aid in understanding the Paging MER results when they are non-available (NAN) and to indicate when the results may be questionable. See CALL:STATus:PAGing:MERRor:PROCedure:WARNing? .

Key TIA/EIA-98-E Tests Using Paging MER

  • Testing 3.3.2 Demodulation of Slotted Mode Paging Channel

Related Topics

Measuring Paging Channel Message Error Rate (MER)


Protocol Logging Requirements

Protocol Logging Requirements

Last updated: June 18, 2007

This section is only applicable to the lab application and to a test application with the required feature license.

The Lab Application enables the test set to log protocol messages. Protocol messages are forwarded to the Wireless Protocol Advisor (WPA) software, which is required for message display and analysis. This software is included with the lab application and will run on PCs that meet the following system requirements:

Summary of Requirements for the Wireless Protocol Advisor

NOTE
These requirements are subject to change or addition without notice. Always refer to the product web page for the latest information.

  • PC Operating System:
    • Microsoft® Windows® 98
    • Microsoft® Windows® NT 4 SP3/4/5
    • Microsoft® Windows® 2000
    • Microsoft® Windows® XP
  • 300 MHz Pentium or equivalent recommended
  • 128 MB RAM recommended
  • 250 MB available disk space required for installation
  • 100 MB available disk space recommended for storing logged information
  • Video resolution minimum 800 by 600 pixels with at least 256 colors
  • LAN or WAN card must be installed and connected to a network


Activating Protocol Logging From the Test Set

Activating Protocol Logging From the Test Set

Last updated: June 18, 2007

This section is only applicable to the lab application and to a test application with the required feature license.

Once a connection is established between the PC running the WPA (Wireless Protocol Advisor) and the test set, a logging session can be activated (or deactivated) by selecting the start (or stop) softkey from the test set's front panel or by sending GPIB commands that perform the same functions:

NOTE
The WPA software performs the same start/stop functions when the REC (RECord) button is selected. Refer to the WPA on-line Help for details.

Test Set Control of Protocol Logging

If a PC with the WPA software has not yet connected with the test set, an error message will be generated if an attempt is made to start protocol logging. Exactly one PC/WPA can be connected to a test set at one time.

Front Panel Control of Protocol Logging

  1. Press the CALL SETUP key to go to the Call Setup screen.
  2. Press the left More key two times, go to Call Control 3 of 3 .
  3. Press Protocol Logging ( F1 ).
  4. Press Start Protocol Logging ( F1 ) to begin logging.

Remote Control of Protocol Logging

The GPIB command to control Protocol Logging is CALL:PLOGging .


Programming a Graphical Access Probe Power Measurement

Programming a Graphical Access Probe Power Measurement

Last updated: October 28, 2004

This section is only applicable to the lab application.

This section provides an example of how to make graphical access probe power measurements via GPIB.

The following program example assumes that the mobile station's antenna output is connected to the RF IN/OUT connector, and the mobile station has found service.

The basic procedure to measure access probe power remotely is:

  1. Turn the graphical access probe power measurement timeout timer on using the SETup:GAPPower command. If the timeout timer is not turned on, and an access probe is not received, the measurement will hang on the FETCh? command indefinitely. Use the "FETCh:GAPPower[:ALL][:RANGe20]?" command to obtain the measurement results.

  2. Turn on the mobile station and perform a registration (wait for power-on or send CALL:REGister ).
  3. Turn call limit on (see CALL:CONNected:LIMit[:STATe]<[:SELected]|:TA2000> ).
  4. Set up initial power, step size, number of steps, and the maximum number of access probes for requests and responses ( see CALL:APARameter ).
  5. Turn off timer-based registrations (see CALL:REGister:TIMer:STATe ).
  6. Initiate the access probe power measurement using the INITiate<:measurement mnemonic>[:ON] . The <measurement mnemonic> for graphical access probe power measurements is GAPP.
  7. Perform a page or mobile station originated call.
  8. Monitor the measurement progress indicator.
  9. Use the FETCh:GAPPower[:ALL][:RANGe20]? command to obtain the measurement results.

Programming Example

10    RE-SAVE "c:\roadhog\programs\gapp.txt"
20    !This program measures a graphical access probe power sequence
30    !See "Access Probe Output Power" in TIA/EIA-98-D for specifications and standards
40    A=714
50    OUTPUT A;"*CLS"
60    CLEAR SCREEN
70    !***Specify call parameters***
80    Systype$="DIGITAL2000"
90    Band$="USPCS"
100   Channel=525
110   Sid=331
120   Nid=1
130   Radio_config$="F3R3"
140   Service_opt$="SO2"
150   !
160   !***Specify test parameters***
170   Loss_frequency$="836 MHZ,881 MHZ"
180   Expected_loss$="-2,-2"
190   Acc_prb_steps=8
200   Acc_prb_size=1
210   Max_resp_seq=1
220   Ior=-55
230   Pilot=-7
240   Paging_ch=-12
250   Sync=-16
260   Traffic=-15.5
270   !
280   !***Set up bus and measurement timeouts***
290   ON TIMEOUT 7,20 CALL Timeout
300   OUTPUT A;"SETUP:GAPP:TIMEOUT:STIME 30 S"
310   OUTPUT A;"SYST:COMM:GPIB:DEB:STAT ON"
320   !
330   !***Return test set to IDLE call processing state***
340   OUTPUT A;"CALL:STATUS?"
350   ENTER A;Call_status$
360   IF Call_status$="IDLE" THEN GOTO 400
370   OUTPUT 714;"CALL:END"
380   WAIT 2
390   !
400   !***Set up path loss***
410   OUTPUT A;"SYSTEM:CORRECTION:SFREQUENCY ";Loss_frequency$
420   OUTPUT A;"SYSTEM:CORRECTION:SGAIN ";Expected_loss$
430   !
440   !***Set up access/paging parameters***
450   OUTPUT A;"CALL:OPER:MODE CALL" !Active cell  operating mode
460   OUTPUT A;"CALL:BAND ";Band$
470   OUTPUT A;"CALL:CHAN ";Channel
480   OUTPUT A;"CALL:POW ";Ior
490   OUTPUT A;"CALL:SID ";Sid
500   OUTPUT A;"CALL:NID ";Nid
510   OUTPUT A;"CALL:RCON ";Radio_config$
520   OUTPUT A;"CALL:PROT PREV6"
530   OUTPUT A;"CALL:PAG ";Paging_ch
540   OUTPUT A;"CALL:PAG:DRAT FULL"
550   OUTPUT A;"CALL:PIL ";Pilot
560   OUTPUT A;"CALL:SYNC ";Sync
570   OUTPUT A;"CALL:FCH ";Traffic
580   !
590   PRINT "Press continue when the mobile station has found service and registered"
600   PAUSE
610   CLEAR SCREEN
620   !
630   !***Turn call limit on***
640   OUTPUT A;"CALL:CONNECTED:LIMIT 1"
650   !
660   !***Set up measurement parameters***
670   OUTPUT A;"CALL:APARAMETER:POWER:STEP ";Acc_prb_size     !Power Step
680   OUTPUT A;"CALL:APARAMETER:POWER:STEP:COUNT ";Acc_prb_steps !Number of Steps
690   OUTPUT A;"CALL:APARAMETER:SEQUENCE:RESPONSE ";Max_resp_seq !Maximum response
700                                                              !sequence
710   !
720   !***Turn off timer-based registrations***
730   OUTPUT A;"CALL:REGISTER:TIMER:STATE OFF"
740   PRINT "WAITING FOR REGISTRATIONS TO COMPLETE"
750   WAIT 3
751   CLEAR SCREEN
760   !
770   !***Initiate the Graphical Access Probe Power measurement***
780   OUTPUT A;"INIT:GAPP"
790   PRINT "GAPP MEASUREMENT INITIATED"
800   !
810   !***Page the mobile station***
820   DISP "Paging mobile station..."
830   OUTPUT A;"CALL:ORIG"
840   DISP "Measuring Graphical Access Probe Power"
850   !
860   !***Check measurement progress indicator***
870   Total_probes=(Acc_prb_steps+1)*Max_resp_seq
880   PRINT "Total number of expected access probes = ";Total_probes
890   LOOP
900     OUTPUT A;"FETCH:GAPP:ICOUNT?"
910     ENTER A;Prog_ind
920     DISP "Received access probe ";Prog_ind;" of";Total_probes
930     WAIT .25
940   EXIT IF Prog_ind=Total_probes
950   END LOOP
960   !
970   !***Query measurement results***
980   DIM Access_probe(20)
990   DIM Gapp_meas$[500]
1000  OUTPUT A;"FETCH:GAPP?"
1010  ENTER A;Gapp_meas$
1020  Separator$="," !GAPP measurements are returned in a comma-separated string
1030  First_acc_probe=POS(Gapp_meas$,Separator$) !Find the first comma, which separates
1040                                             !the integrity indicator from the
1050                                             !first access probe measurement
1060  Integrity=VAL(Gapp_meas$[1;First_acc_probe-1]) !Convert the ascii integrity
1070                                                 !characters to a numeric value
1080  PRINT "Integrity Indicator = ";Integrity
1090  FOR I=1 TO Total_probes
1100    Acc_probe_mkr=First_acc_probe+((I-1)*17) !Set up a marker that will jump
1110                                             !to each comma in the ascii string
1120    Access_probe(I)=VAL(Gapp_meas$[Acc_probe_mkr+1;Acc_probe_mkr+16]) !Convert
1130                                             !ascii to a numeric value
1140    PRINT "Access probe ";I-1;" measurement is ";Access_probe(I);" dBm/1.23 MHz"
1150  NEXT I
1160  DISP "Test complete"
1170  !
1180  !***Return to default call processing states***
1190! OUTPUT A;"CALL:END"
1200 !OUTPUT A;"CALL:CONNECTED:LIMIT 0"
1210 !OUTPUT A;"CALL:REGISTER:TIMER:STATE ON"
1220  END
1230  !
1240 Timeout: SUB Timeout
1250    PRINT "Program timed out"
1260    CLEAR 7
1270    CLEAR 714
1280  SUBEND

Related Topics

Graphical Access Probe Power Measurement Description


Programming Paging Channel MER

Programming Paging Channel MER

Last updated: October 28, 2004

This section provides an example of how to measure paging channel's message error rate (MER) via GPIB. The basic procedure is as follows:

  1. Set up the call parameters required for the mobile station to find the service.
  2. Turn on the mobile station and perform a registration (wait for power-on or send CALL:REGister ).
  3. Set up the paging channel MER parameters required for the test.
  4. Turn off timer-based registrations using CALL:REGister:TIMer:STATe command.
  5. Establish a call.
  6. Start the paging channel MER Procedure using CALL:PAGing:MERRor:PROCedure:STARt
  7. Disconnect the call.
  8. Turn on Audit Order using CALL:CCHannel:AUDit:STATe command.
  9. Wait the desired time you'd like to have the MER test procedure run. The standard specifies "at least 2 minutes and until sufficient confidence is ensured".
  10. Turn off Audit Order using CALL:CCHannel:AUDit:STATe command.
  11. Establish a call.
  12. Stop the paging channel MER Procedure using CALL:PAGing:MERRor:PROCedure:STOP command.
  13. Obtain the measurement results using CALL:STATus:PAGing:MERRor commands (see Paging Channel MER Results for more information).
  14. (Optional) Disconnect the call and turn the timer-based registration back to on.

Programming Example

10 !This program measures paging channel message error rate.
20 !3.3.2 Demodulation of Slotted Mode Paging Channel
40 COM Testset
50 Testset=714
60 !
70 DISP "Testing Demodulation of Slotted Mode Paging Channel"
80 !
90 !***Varial call parameters (MS specific, change as needed)***
100 Systype$="DIGITAL2000"     !Cell System Type
110 Band$="USPCs"     !Cell band
120 Channel=525     !RF channel
130 Sid=2     !System Identification
140 Nid=1     !Network Identification
150 Radio_config$="F3R3"     !Radio Configuration
160 So$="SO2"     !Service Option
170 !
180 !***Specify test parameters***
190 Ior=-55      !Cell power
200 Iawgn1=-54      !AWGN power for test 1
210 Iawgn2=-48.5      !AWGN power for test 2
220 Ipch1=-16.2      !Paging channel level for test 1
230 Ipch2=-10.7      !Paging channel level for test 2
240 Ipich=-7      !Pilot channel level
250 Isync=-16      !Sync channel level
260 Iqpch_pich=-3
270 !Quick paging channel relative to pilot
280 !
290 !***Set up call parameters***
300 OUTPUT Testset;"CALL:SYSTEM ";Systype$
310 !Sets System Type
320 OUTPUT Testset;"CALL:BAND ";Band$
330 !Sets Cell Band for selected System Type
340 OUTPUT Testset;"CALL:CHAN ";Channel
350 !Sets RF Channel for selected System Type and Cell Band
360 OUTPUT Testset;"CALL:POW ";Ior
370 !Sets and turns on Cell Power
380 OUTPUT Testset;"CALL:SID ";Sid
390 !Sets System Identification
400 OUTPUT Testset;"CALL:NID ";Nid
410 !Sets Network Identification
420 OUTPUT Testset;"CALL:RCONFIG ";Radio_config$
430 OUTPUT Testset;"CALL:SOPTION ";So$
440 !Sets service option for selected System Type and Radio Configuration
450 !
460 !***Set up test parameters***
470 OUTPUT Testset;"CALL:PAGING:SCINDEX:MAX 0"
480 !Set max slot cycle index.
490 OUTPUT Testset;"CALL:PAGING:DRATE FULL"
500 !Set paging channel data rate to 9600 bps.
510 OUTPUT Testset;"CALL:QPCH:STATE 1"
520 !If the MS supports quick paging channel,
530 !set quick paging channel state to on.
540 OUTPUT Testset;"CALL:QPCH:DRATE HALF"
550 !Set quick paging channel data rate to 4800 bps.
560 OUTPUT Testset;"CALL:PILOT ";Ipich
570 !Set pilot level (Ec/Ior).
580 OUTPUT Testset;"CALL:SYNC ";Isync
590 !Set sync channel level (Ec/Ior).
600 OUTPUT Testset;"CALL:QPCH:LEVEL:RTPILOT ";Iqpch_pich
610 !Set quick paging channel level relative to pilot channel.
620 !
630 !***Set up test parameters for test 1***
640 !when perform test 2, comments the parameters
650 OUTPUT Testset;"CALL:AWGN:POWER ";Iawgn1
660 !Set AWGN power for test 1
670 OUTPUT Testset;"CALL:PAG ";Ipch1
680 !Set paging channel level for test 1
690 !
700 !To perform test 2, comment the parameter setup for test 1 above
710 !and un-comment the parameter setup for test 2 below
720 !
730 !***Set up test parameters specific to test 2***
740 !when perform test 1, comments the parameters
750 !OUTPUT Testset;"CALL:AWGN:POWER ";Iawgn2
760 !Set AWGN power for test 2
770 !OUTPUT Testset;"CALL:PCH ";Ipch2
780 !Set paging channel level for test 2
800 !
810 !***MS Registration***
830 PRINT "Turn on mobile station...press continue when it has registered"
840 PAUSE
850 CLEAR SCREEN
860 GOSUB Register
870       !
880 !***Set test conditions***
890 OUTPUT Testset;"CALL:REGISTER:TIMER:STATE 0"
900 !Turn off timer based registration.
910 OUTPUT Testset;"CALL:PAGING:MERROR:PROC:PARAMETER:CLEAR"
920 !Clears the Paging Channel Message Error Rate screen.
930 !
940 !***Establish a call***
950 GOSUB Connect
960 PRINT
970       !
980 !***Start the Test Procedure***
990 PRINT "Start MER Procedure"
1000 OUTPUT Testset;"CALL:PAGing:MERRor:PROCedure:STARt"
1010 !
1020 !***Disconnect the call***
1030 !This ensures counting the messages on the paging channel.
1040 !The mobile station does not listen to the paging channel
1050 !when a call is established
1060 OUTPUT Testset;"CALL:END"
1070 !
1080 !***Set Audit Order to on***
1090 PRINT "Turn on Audit Order"
1100 OUTPUT Testset;"CALL:CCHannel:AUDit:STATe 1"
1110 !Enable the test set to start sending Audit Order message
1120 PRINT "Sending Audit Order Message is in progress,Pls. Wait..."
1130 WAIT 120
1140 !The standard specifies to waint at least 2 minutes and
1150 !until sufficient confidence is ensured.
1160 !
1170 !***Set Audit Order to off***
1180 PRINT "Turn off Audit Order"
1190 OUTPUT Testset;"CALL:CCHannel:AUDit:STATe 0"
1200 !The test set stop sending Audit Order message.
1210 !
1220 !***Establish a call***
1230 GOSUB Connect
1240 PRINT
1250 !
1260 !***Stop the Test Procedure***
1270 PRINT "Stop MER Test Procedure"
1280 OUTPUT Testset;"CALL:PAGing:MERRor:PROCedure:STOP"
1290 !
1300 !***Obtain and display Paging Channel MER results***
1310       !DIM Err_msg$[4096]
1320 OUTPUT Testset;"CALL:STATUS:PAGing:MERRor:PROCedure:WARNing?"
1330 !Query error conditions that occur during Paging MER test.
1340 ENTER Testset;Err_msg$
1350 !
1360 !
1370 IF Err_msg$<>"""""" THEN
1390  PRINT "MER Procedure Warning Message is ";Err_msg$
1410 ELSE
1430  PRINT "Paging Channel MER Results"
1440  OUTPUT Testset;"CALL:STATUS:PAGing:MERRor:RATio?"
1450  !Query the Paging Channel MER result, in percentage.
1460  ENTER Testset;P_mer
1470  PRINT "Slotted Paging Channel MER Ratio= ";P_mer
1480  OUTPUT Testset;"CALL:MS:RSParameter:PAG3?"
1490  !Query the number of paging channel messages received by MS.
1500  ENTER Testset;Ms_pag3
1510  PRINT "MS PAG_3 (F-Paging messages received by MS)= ";Ms_pag3
1520  OUTPUT Testset;"CALL:STATUS:PAGing:MERRor:MESSages?"
1530  !Query the number of paging channel messages sent from test set.
1540  ENTER Testset;Pag_msgs
1550  PRINT "F-Paging messages sent from the test set= ";Pag_msgs
1560  OUTPUT Testset;"CALL:STATus:PAGing:MERRor:TIME?"
1570  !Query paging MER test time in seconds.
1580  ENTER Testset;Test_time
1590  PRINT "Paging MER Test Time = ";Pag_msgs
1600  OUTPUT Testset;"CALL:STATus:PAGing:EBNTotal?"
1610  !Query F-Paging Eb/Nt.
1620  ENTER Testset;Pag_ebnt
1630  PRINT "F-Paging Eb/Nt = ";Pag_ebnt
1640  OUTPUT Testset;"CALL:STATus:QPCH:EBNTotal?"
1650  !Query F-QPCH Eb/Nt.
1660  ENTER Testset;Q	pch_ebnt
1670  PRINT "F-QPCH Eb/Nt = ";Qpch_ebnt
1690 END IF
1700 !
1710 GOTO End_program
1720       !
1730 !**********************************************
1740 ! Establish a CALL
1750 !**********************************************
1760  Connect:!
1770  !***Page the mobile station***
1800           !
1810     Connect_tries=0
1820     PRINT "Paging mobile station..."
1830     LOOP
1840          OUTPUT Testset;"CALL:ORIG"
1850          !Pages the mobile station
1860          OUTPUT Testset;"CALL:CONNECTED:STATE?"
1861          !Queries for connected/idle state
1870          ENTER Testset;Call_connected
1880          Connect_tries=Connect_tries+1
1890          IF NOT Call_connected THEN
1900              OUTPUT Testset;"CALL:END"
1910              WAIT .2
1920              END IF
1930          EXIT IF Call_connected OR Connect_tries=5
1940     END LOOP
1950     IF NOT Call_connected THEN
1960          PRINT "Call attempt failed"
1970     ELSE
1980          PRINT "Call connected"
1990     END IF
2010     RETURN
2030 !
2040 !**********************************************
2050 ! REGISTER MOBILE
2060 !**********************************************
2070  Register:!
2080 !
2090     PRINT "Register MS on Test Set"
2100     OUTPUT Testset;"CALL:MS:REPORTED:CLEAR:ALL"
2101     !Clear MS reported database of any previous registration data
2110     OUTPUT Testset;"CALL:REG"
2120     Reg_timer=TIMEDATE
2130     LOOP
2140     !This loop tests for the begining of registration
2150        OUTPUT Testset;"CALL:MS:REP:ESN:HEX?"
2160        ENTER Testset;Esn$
2170        Reg_time=TIMEDATE-Reg_timer
2190        EXIT IF LEN(Esn$)>3 OR Reg_time>30
2200     END LOOP
2220     IF Reg_time>30 THEN
2221     !Set for 30 seconds for registration time out
2230         PRINT "Registration Timed Out, Check Phone Setup"
2240         GOTO End_program
2250     END IF
2270     PRINT "Mobile Registration Complete"
2280     PRINT
2290     RETURN
2340 !
2350 !****************************************************
2380  End_program:!
2390      !
2400     OUTPUT Testset;"CALL:END"
2410     PRINT
2420     PRINT "End of Program"
2430     END

Related Topics

Paging Channel MER Description


SMS (Short Message Service) State Synchronization

SMS (Short Message Service) State Synchronization

Last updated: November 10, 2006

This section is only applicable to the lab application.

There are several specialized commands available to help you determine the state of the SMS processing, and verify that SMS events were successful.

SMS Status Query Summary
Query | Description | Suggested Usage
CALL:SMService:STATus[:STATe]? | Queries the current SMS processing state. Immediately returns the states: IDLE | SEND | WAIT | MSAC | MSN | BSEN |PAG | ORIG | REC. See SMS Status Description . | Use to verify the current SMS processing state.
CALL:SMService:BSENt[:STATe]? | Queries whether or not the SMS Status is in the Broadcast Sent state. Immediately returns 1 or 0, or waits for a state change if the SMS Status Change Detector is armed. See SMS Terminal States Queries . | Use with the SMS Status Change Detector to verify that your attempt to send an Broadcast SMS message was successful.
CALL:SMService:IDLE[:STATe]? | Queries whether or not the SMS Status is in the idle state. Immediately returns 1 or 0, or waits for a state change if the SMS Status Change Detector is armed. See SMS Terminal States Queries . | Use with the SMS Status Change Detector to verify that your attempt to end the SMS operation was successful.
CALL:SMService:MSACk[:STATe]? | Queries whether or not the SMS Status is in the MS Ack state. Immediately returns 1 or 0, or waits for a state change if the SMS Status Change Detector is armed. See SMS Terminal States Queries . | Use with the SMS Status Change Detector to verify that your attempt to send an SMS message from the test set to the MS was successful.
CALL:SMService:MSNack[:STATe]? | Queries whether or not the SMS Status is in the MS Nack state. Immediately returns 1 or 0, or waits for a state change if the SMS Status Change Detector is armed. See SMS Terminal States Queries . | Use with the SMS Status Change Detector to verify that your attempt to send an SMS message from the test set to the MS longer than the timeout was successful.
CALL:SMService:RECeived[:STATe]? | Queries whether or not the SMS Status is in the RECeived state. Immediately returns 1 or 0, or waits for a state change if the SMS Status Change Detector is armed. See SMS Terminal States Queries . | Use with the SMS Status Change Detector to verify that your attempt to send an SMS message from the mobile station to the test set was successful.

SMS Status Description

The CALL:SMService:STATus[:STATe]? query returns the current SMS processing states. These states may also be displayed on the front panel screen (see SMS Message Acknowledge Info ). The possible states include transitory states and terminal states, see SMS Status Description for details.

SMS Terminal States Queries

Several specialized query commands ( CALL:SMService:BSENt[:STATe]? , CALL:SMService:IDLE[:STATe]? , CALL:SMService:MSACk[:STATe]? , CALL:SMService:MSNack[:STATe]? and CALL:SMService:RECeived[:STATe]? ) are available to help you determine whether the test set is in the expected SMS terminal state. It's most useful in conjunction with the SMS Status Change Detector .

  • If the SMS status change detector is not armed and the SMS status is in a terminal state, these queries immediately return 0 or 1.
  • If the SMS status change detector is armed or the call processing is in a transitory state, the query hangs until the change detector is disarmed and the SMS state reaches a terminal state. The query returns 1 or 0 as soon as a terminal state is reached.

SMS Status Change Detector

The SMS status change detector is useful when you expect a change in the SMS processing state, and want to know when it is complete. The SMS status change detector is used in conjunction with the SMS Terminal States Queries .

Arming the SMS State Change Detector

The SMS status change detector is automatically armed by the test set when an SMS operations originating from the test set are requested. You do not need to explicitly arm the SMS status change detector. The following SMS operations originated from the test set will automatically arm the SMS status change detector:

  • CALL:SMService:SEND : send an SMS message (Mobile-Terminated SMS message) from the test set to the MS. See Methods 1 and 2 as described in the Sending an SMS Message to the Mobile Station .
  • CALL:ORIGinate : send an SMS message (Mobile-Terminated SMS message) from the test set to the MS while current Call Status is Idle and current service option is SO6 or SO14. See method 3as described in the Sending an SMS Message to the Mobile Station .

    NOTE
    In this case, the CALL:ORIGinate is used to establish a temporary connection to transmit the SMS message on the Traffic channel. Both SMS status change detector and the Call State Change Detector are involved during SMS operation. Moreover, the Call state change detector will be rearmed immediately after the call status change detector is disarmed (when a connection is established, or failed) so that you can make a Connected/Idle Query .

  • CALL:SMService:END : end sending an SMS message sent by the CALL:SMService:SEND . It does not abort the SMS sending initiated by CALL:ORIGinate .

You only need to arm the SMS Status change detector (using CALL:SMService:ARM[:IMMediate] ) to hold off the SMS terminal state queries when you are sending an SMS message from the mobile station.

Disarming the SMS status Change Detector

The SMS status change detector becomes disarmed when any of the following conditions have been met:

  • the SMS status changes from the initial terminal state to a new terminal state
  • the SMS status changes from the initial transitory state to any terminal state
  • the change detector timeout expiring ( SMS Status Change Detector Timeout )

When the change detector is disarmed, the SMS Terminal States Queries returns 1 or 0 as soon as a terminal state is reached.

SMS Status Change Detector Timeout

The SMS status change detector includes a timeout to prevent the SMS status from staying in a transitory state forever. It limits the amount of time that the test set will wait for an SMS state change. The timer begins when the change detector is armed or rearmed when already armed. The timeout is user-settable, but the user setting is only useful when sending an Mobile-Originated SMS message. The duration of this timeout is set using the CALL:SMService:ARM:TIMeout command and should be greater than the maximum amount of time the control program needs to wait between arming the SMS status change detector and the SMS operation starting. If the timer expires, the change detector is disarmed. For Mobile-Terminated SMS messages, the timeout is automatically set to 60 seconds by the test set.

Example 1: Mobile Originated SMS Message - Arming the Change Detector

The following example illustrates the use of the SMS status change detector along with the SMS received state query to synchronize a controlling application with an SMS processing state change during a mobile station originated SMS operation.

When the CALL:SMService:ARM command is received by the test set, the detector becomes armed and configures the test set to hold off on returning a result for the CALL:SMService:RECeived? query until the detector is disarmed by one of the three events described above.

10 OUTPUT 714;"CALL:SMService:ARM:TIMeout 20S"
20 !Sets the time out time to 20 seconds.
30 OUTPUT 714;"CALL:SMService:ARM"
40 !Arm the change detector.
50 DISP "Send an SMS message from mobile station. Continue when done."
60 PAUSE
70 OUTPUT 714;"CALL:SMService:RECeived?"
80 !The SMS received state query.
90 ENTER 714;Sms_received
100  IF Sms_received=1 THEN
110     DISP "The test set has received the short message."
120     WAIT 2
130  ELSE
140     DISP "The test set did not receive the short message."
150     WAIT 2
160  END IF
170 END

Related Topics

Test System Synchronization Overview


E6702A/B/T cdma2000 Lab Application Revision Information

E6702A/B/T cdma2000 Lab Application Revision Information

Last updated: July 11, 2007

This document describes the features in the Agilent Technologies cdma2000 Lab Application releases. This document contains the original features, as well as enhancements that have been added over time.

CAUTION
You may need to upgrade the hardware in your test set before installing the application firmware described here. If you install application firmware on a test set with incompatible hardware, the following may occur:

  • Your test set may lock up (see Test Set Lockup During Power Up Sequence ).
  • The application may not run.
  • Some features in the application may be inaccessible, or may not perform to specifications.

To determine if a hardware upgrade is required for your testing needs, please review the hardware requirement information at:

http://www.agilent.com/find/8960upgrades

  • T.03.08 Special Release (E6702T) - July 2007
  • B.06.08 Release - July 2007
  • T.01.19 Special Release (E6702T) - May 2007
  • B.05.19 Release - May 2007
  • T.01.17 Special Release (E6702T) - March 2007
  • B.05.17 Release - March 2007
  • T.01.12 Special Release (E6702T) - December 2006
  • B.05.12 Release - December 2006
  • T.00.09 Special Release (E6702T) - August 2006
  • B.04.16 Release - July 2006
  • T.00.04 Special Release (E6702T) - May 2006
  • B.03.21 Release - January 2006
  • B.03 Beta Release - August 2005
  • B.02.19 Release - December 2004
  • B.01.28 Release - April 2004
  • B.01.16 Release - December 2003
  • A.03.12 Release - June 2003
  • A.02.20 Release - February 2003
  • A.01.20 Release - July 2002

T.03.08 Special Release (E6702T) - July 2007

The E6702T can only be loaded onto an E5515C with Special cdma2000 Lab Application Hardware (or a test set with the equivalent hardware upgrades). Loading the E6702T onto an E5515B or E5515C without the appropriate hardware upgrades will cause the test set to lock up.

Note, the Special High Data Rate Hardware required to support the E6702T meets the E6702B measurement parametric specifications in a temperature range of 25 ° C +/- 5 ° C, and has an operating temperature range of 0 to 35 ° C.

The features and functionality offered in this special release are identical to those offered in the B.06.08 Release - July 2007 , with the following key exceptions:

  • You must use the new LAN 2 PORT for transferring data to the test set.

For information on how to use these E6702T features, see E6702T User Documentation .

For information on how to use the features that are common to the E6702B and E6702T, see the cdma2000 online user's guide located at:

http://wireless.agilent.com/rfcomms/refdocs/cdma2k/default.php

B.06.08 Release - July 2007

Summary of GPIB command changes for this release: GPIB Changes for E1962B B.13, E6702B B.06 - July 2007

This release includes all of the features and functionality present in the E1962B cdma2000 Mobile Test Application B.13.08 Release - July 2007 . The unique features of the E6702B Lab Application are indicated below.

For information on how to use the features that are common to the E6702B and E6702T, see the cdma2000 online user's guide located at:

http://wireless.agilent.com/rfcomms/refdocs/cdma2k/default.php

Hardware Requirements

http://www.agilent.com/find/8960upgrades

Base Station Emulation

  • Support Data Source Reset

    Data Source Reset functionality provides a way to reset the data source of Loopback Service Option on every even second boundary of CDMA system time. This functionality can cooperate with Multi-Unit Synchronization feature to test two units soft handoff and mobile receiver diversity verification without coherence setting. See Synchronization Parameters Description for details.

T.01.19 Special Release (E6702T) - May 2007

This is a maintenance release to resolve known issues. The features offered in this release are identical to those offered in the T.01.17 Special Release (E6702T) - March 2007 .

B.05.19 Release - May 2007

This is a maintenance release to resolve known issues. The features offered in this release are identical to those offered in the B.05.17 Release - March 2007 .

T.01.17 Special Release (E6702T) - March 2007

The functionality present in the T.01.15 special release is identical to that in the T.01.15 special release (see T.01.12 Special Release (E6702T) - December 2006 ).

B.05.17 Release - March 2007

The functionality present in the B.05.15 release is identical to that in the B.05.12 release (see B.05.12 Release - December 2006 and GPIB Changes for E1962B B.12, E6702B B.05 - December 2006 ).

T.01.12 Special Release (E6702T) - December 2006

The E6702T can only be loaded onto an E5515C with Special cdma2000 Lab Application Hardware (or a test set with the equivalent hardware upgrades). Loading the E6702T onto an E5515B or E5515C without the appropriate hardware upgrades will cause the test set to lock up.

Note, the Special High Data Rate Hardware required to support the E6702T meets the E6702B measurement parametric specifications in a temperature range of 25 ° C +/- 5 ° C, and has an operating temperature range of 0 to 35 ° C.

The features and functionality offered in this special release are identical to those offered in the B.05.12 Release - December 2006 , with the following key exceptions:

  • You must use the new LAN 2 PORT for transferring data to the test set.

For information on how to use these E6702T features, see E6702T User Documentation .

A downloadable version of the Online User's Guide (CHM Help File) that is specific to this release is available at:

http://www.home.agilent.com/upload/cmc_upload/All/E1962B_B12_E6702B_B05_E6702T_T01_Ref_Guide.chm

NOTE
To properly view the CHM Help File, you must Save it to your desktop. For Windows XP, you must also then right-click on the file and select Properties >> Unblock .

B.05.12 Release - December 2006

The most current documentation for the cdma2000 applications is the Online User's Guide located at:

http://wireless.agilent.com/rfcomms/refdocs/cdma2k/

Summary of GPIB command changes for this release: GPIB Changes for E1962B B.12, E6702B B.05 - December 2006

A downloadable version of the Online User's Guide (CHM Help File) that is specific to this release is available at:

http://www.home.agilent.com/upload/cmc_upload/All/E1962B_B12_E6702B_B05_E6702T_T01_Ref_Guide.chm

NOTE
To properly view the CHM Help File, you must Save it to your desktop. For Windows XP, you must also then right-click on the file and select Properties >> Unblock .

NOTE
After installing this firmware release, you must run the Digital Average Power calibration. Ensure that your test set has warmed up at least 30 minutes and that no power is present at the front panel RF connectors before performing any calibrations.

Hardware Requirements

http://www.agilent.com/find/8960upgrades

Base Station Emulation

  • AWS Band

    AWS Band (Band Class 15) has been added to the list of supported bands. See CALL:BAND and CALL:SETup:BAND:[:SELected] .

  • Support for Service Option 33 reverse supplemental channel

    The test set can demodulate and decode the forward/reverse supplemental channel in Service Option 33. You can test, verify or develop the forward/reverse data application on forward/reverse link, such as Email, FTP upload, MMS upload, etc. See Packet Data Service Configurations for details.

Enhancements

  • The Fast Device Tune measurement is now supported on the RF OUT ONLY port, and includes a complete front panel user interface. See How Do I Make a Fast Device Tune Measurement? .

T.00.09 Special Release (E6702T) - August 2006

The features and functionality offered in this special release are identical to those offered in the B.04.16 Release - July 2006 .

B.04.16 Release - July 2006

Summary of GPIB command changes for this release: GPIB Changes for E1962B B.11.06, E6702B B.04.16 - July 2006

This firmware revision includes all features in the E1962B cdma2000 Mobile Test Application B.11.06 Release - July 2006 and E6702B cdma2000 Lab Application B.03.21 Release - January 2006 .

A downloadable version of the Online User's Guide (CHM Help File) that is specific to this release is available at:

http://www.home.agilent.com/upload/cmc_upload/All/E1962B_B11_E6702B_B04_E6702T_T00_Ref_Guide.chm

NOTE
To properly view the CHM Help File, you must Save it to your desktop. For Windows XP, you must also then right-click on the file and select Properties >> Unblock .

Hardware Requirements

http://www.agilent.com/find/8960upgrades

Base Station Emulation

  • Support for HTTP SMS/MMS

    • The HTTP Interface in the test set allows you to configure SMS message parameters and content, send and receive SMS messages using HTTP protocol. The HTTP interface allows SMS Gateways to be configured as if the test set is a Short Message Service Center (SMSC), eliminating the need for custom external software to route messages to the correct test set. This emulation of an SMSC makes it possible to route messages directly from the HTTP output interface of one test set to the HTTP input interface of another test set. Additionally, the HTTP interface also facilitates MMS message transfer to and from a mobile station if used in conjunction with compatible MMSC (Multimedia Message Service Center) software. See HTTP SMS/MMS for details.

    • A new teleservice CATPT (Card Application Toolkit Protocol Teleservice) is added. See CALL:SMService:MTERminated:TELeservice for details. (It is also applicable to the existing SMS.)

    • The message display mode is added to the Mobile-Terminated SMS Parameters. See CALL:SMService:MTERminated:MDMode for details. (It is also applicable to the existing SMS.)

  • Support for Call Waiting

    Call Waiting functionality provides you the awareness of a second calling party call while having a voice connection with calling party 1. It also enables you to put current call on hold and connect to the calling party 2, as well as to switch back from calling party 2 to calling party 1.

T.00.04 Special Release (E6702T) - May 2006

The E6702T can only be loaded onto an E5515C with Special cdma2000 Lab Application Hardware (or a test set with the equivalent hardware upgrades). Loading the E6702T onto an E5515B or E5515C without the appropriate hardware upgrades will cause the test set to lock up.

Note, the Special High Data Rate Hardware required to support the E6702T meets the E6702B measurement parametric specifications in a temperature range of 25 ° C +/- 5 ° C, and has an operating temperature range of 0 to 35 ° C.

The features and functionality offered in this special release are identical to those offered in the B.03.21 Release - January 2006 , with the following key exceptions:

  • You must use the new LAN 2 PORT for transferring data to the test set.

For information on how to use these E6702T features, see E6702T User Documentation .

B.03.21 Release - January 2006

Summary of GPIB command changes for this release: GPIB Changes for E1962B B.10, E6702B B.03.10 - December 2005

This firmware revision includes all features in the E1962B cdma2000 Mobile Test Application B.10.11 Release - January 2006 and E6702B cdma2000 Lab Application B.03 Beta Release - August 2005 .

A downloadable version of the Online User's Guide (CHM Help File) that is specific to this release is available at:

http://www.home.agilent.com/upload/cmc_upload/All/E1962B_B10_E6702B_B0310_Ref_Guide.chm

NOTE
To properly view the CHM Help File, you must Save it to your desktop. For Windows XP, you must also then right-click on the file and select Properties >> Unblock .

Hardware Requirements

http://www.agilent.com/find/8960upgrades

Other Features/Enhancements

  • The value range of the External PDSN Connect Timeout is changed from 0 - 19 seconds to 1 - 19 seconds. See External PDSN Connect Timeout . If the value is set to zero in the earlier version of firmware and you boot up into a newer version of firmware, the value stored in NVRAM will be changed to one second on power-up.

B.03 Beta Release - August 2005

This is a pre-release firmware. A pre-release is early firmware that has not been fully qualified.

A downloadable version of the Online User's Guide (CHM Help File) that is specific to this release is available at:

http://www.home.agilent.com/upload/cmc_upload/All/E1962B_E6702B_Ref_Guide.chm

NOTE
To properly view the CHM Help File, you must Save it to your desktop. For Windows XP, you must also then right-click on the file and select Properties >> Unblock .

Summary of GPIB command changes for this release: E1962B and E6702B Applications: GPIB Command Revision Information

This firmware revision includes all features in E1962B CDMA2000 Mobile Test Application B.09.14 Release - April 2005 and following new features unique to the E6702B.

Hardware Requirements

http://www.agilent.com/find/8960upgrades

Base Station Emulation

  • Support for settable CDMA system time.

    The test set can emulates the base station to allows you to set the CDMA system time parameters that are sent to the mobile station. The mobile station uses them to calculate time-based data applications. The settable system time is also used in multiple test sets synchronization. See Setting CDMA System Time Parameters for details.

  • Support multiple test sets synchronization.

    The multiple test sets either running the E6702B cdma2000 lab application or the E6706A 1xEV-DO lab application can be synchronized on the CDMA system time. This feature is very useful for Hybrid Mode AT/MS tests. See Performing Multi-Unit Synchronization for details.

  • Support hybrid mode.

    Two test sets can simulate a wireless network that supports a IS-2000/IS95 (CDMA) and a IS-856 (1xEV-DO) system to perform the function test of the hybrid mode AT/MS. See Hybrid Mode for details.

B.02.19 Release - December 2004

Summary of GPIB command changes for this release: E1962B and E6702B Applications: GPIB Command Revision Information

This firmware revision includes all of the new features added in the E1962B B.08.20 Release - December 2004 and the following new features unique to the E6702B:

A downloadable version of the Online User's Guide (CHM Help File) that is specific to this release is available at:

http://www.home.agilent.com/upload/cmc_upload/All/E1962B_B09_E6702B_B02_Ref_Guide.chm

NOTE
To properly view the CHM Help File, you must Save it to your desktop. For Windows XP, you must also then right-click on the file and select Properties >> Unblock .

Hardware Requirements

http://www.agilent.com/find/8960upgrades

Base Station Emulation

  • Support for forward power control (FPC) functionality

    The test set supports two standard FPC mode (000 - Primary 800 and 011 - EIB) and one non-standard FPC mode (Ignore FPC Bits). The FPC functionality is used for the mobile station to control the forward traffic channel power level to achieve the target Frame Error Rate (FER). All of the FPC related information, such as parameter settings, displayed results, operations, etc., can be accessed from the Forward Power Control .

  • Support for new rear panel Digital Bus

    To generate faded forward channel signals with AWGN, the test set must be equipped with a rear panel Digital Bus connecting to an external PC running Baseband Studio software. See Digital Bus Information for details.

  • Support for R-FCH gating mode

    When the test set's R-FCH gating mode is enabled and the mobile station supports the gating mode, the mobile station will gate the R-FCH/R-Pilot channel when transmitting at 1/8th data rate. See R-FCH Gating for details.

  • Support for calling party number settings

    With these settings, you can evaluate the mobile station's behavior in response to the specified calling party number (CPN) parameters (for example, to see whether the mobile station displays the calling party's number as expected). See Calling Party Number Parameters for details.

  • Support for F-FCH frame pattern setup

    This feature provides the capability to specify the frame patterns to be sent on the forward traffic channel. A typical usage for specifying the frame pattern is for forward power control EIB test. See F-FCH Frame Pattern Setup ).

  • Enhancements to the data channel functionality

    • Support for packet data service Dormant state

      The dormant state is an important advantage of the packet data service offering since it allows the mobile station's natural state to be dormancy, where the mobile station does not utilize any radio resources and has minimal power consumption. The subsequent sessions (when the mobile station comes out of dormancy) can be started without having to re-establish PPP link again and the connection time is faster. See Packet Data Connection Processing States for details.

    • A new setting, External PDSN Connect Timeout , is added to the Data Channel Parameters menu. See Data Channel Parameters for details.

Measurements

  • Changes to the Frame Error Rate Measurement
    • A new parameter, Minimum Frame Count , is added to the Frame Error Rate Setup menu. See FER Measurement Parameters for details.
    • The value of the FER Requirement setting is extended from the range of 0.1% to 15% to the range of 0.1% to 30%.
    • When the test set is configured to generate faded signals, which requires a rear panel digital bus connection to an external PC running Baseband Studio software, an external AWGN value is displayed on the FER measurement screen. See FER Measurement Results Specific to Lab Application for details.
    • When the FPC mode 000-Primary 800 is enabled on the test set (see FPC Mode ). another new parameter, Eb/Nt Limit , is added to the Frame Error Rate Setup menu (see FER Measurement Parameters ). Also, four new measurement results (Average Eb/Nt, Maximum Eb/Nt, Minimum Eb/Nt and Eb/Nt pass/fail) are available. See FER Measurement Results Specific to Lab Application for details.

B.01.28 Release - April 2004

The functionality present in this release is identical to that in the B.01.16 Release - December 2003 .

Hardware Requirements

http://www.agilent.com/find/8960upgrades

Resolved Known Issues

  • TDSO measurement at 153.6 kbps inaccurate.

See 8960 Known Issues for more information

B.01.16 Release - December 2003

This firmware revision includes all of the new features added in the E1962B B.07.15 release (see B.07.15 release - December 2003 ) and the following new features unique to the E6702B:

Hardware Requirements

http://www.agilent.com/find/8960upgrades

Base Station Emulation

  • Short Message Service (SMS) - The test set can simulate an SMS system which provides for the transmission of short messages to, or reception of short messages from an intended mobile station, and the return of acknowledgments and error messages. All of the SMS tests specified in the CDG Stage 2 standard are supported by the test set. See Short Message Service/ Multimedia Service for details.
  • Data Throughput Monitor - This feature provides you an intuitive graph view to analyze data transfer rates for IP data packets that are exchanged between a data enabled wireless device connected to the test set's front panel RF port and a server connected to the test set's rear panel LAN port. See Data Throughput Monitor for details.
  • Support of Mobile IP - The test set provides an interface to work together with an external Mobile IP Simulator (MOB-IP-SIM) purchased from the Software Concepts, Inc. The MOB-IP-SIM provides the mobile IP protocol stacks and the test set supports the mobile IP protocol tests as specified in the TIA/EIA-IS-835 standard. See Simple IP and Mobile IP for details.
  • Paging Channel Message Error Rate (MER) - This measurement is used to evaluate how well the mobile station demodulates the paging channel in an AWGN (no fading or multipath) environment. The test set supports measuring MER for slotted mode paging channel, as specified in the EIA/TIA-98E standard: 3.3.2 demodulation of slotted mode paging channel . See Paging Channel MER Description for details.

A.03.12 Release - June 2003

Hardware Requirements

http://www.agilent.com/find/8960upgrades

Features

This firmware revision includes the radioOne , calibration signal, which was previously available only with the E1962B Test Application, B.06.30 release. See B.06.42 release - June 2003 .

In addition, data rate changes can now be made while maintaining a Service Option 33 (High Speed Packet Data) call. See Packet Data Service Data Rates .

A.02.20 Release - February 2003

This firmware revision includes all of the new features added in the E1962B cdma2000 Mobile Test Application, B.06.20 release, except for the radioOne , calibration signal. The unique features of E6702A added in this release include:

Hardware Requirements

http://www.agilent.com/find/8960upgrades

Data Channel

The data channel provides support for Service Option 33, a high speed packet data service. With this feature, a data enabled wireless device connected to the test set's front panel RF port can exchange IP data packets with a server connected to the test set's rear panel LAN port. Depending on the selected service option and data rate, data can be carried on both the F-FCH (Forward Fundamental Channel) and the F-SCH (Forward Supplemental Channel).

Ping, a utility that provides a simple IP connection check, is also supported.

Graphical Access Probe Power Enhancements

With this firmware revision, the Graphical Access Probe Power measurement has the added capability to display a sequence of up to 60 access probes. Originally, 20 access probes could be displayed.

The time span can now be adjusted to display access probes measured within a specified time period beginning with the first access probe. The span length can be specified to any value from 5 to 120 seconds.

Two markers provide the added capability to display relative (delta) power levels between any two access probes.

A table below the Graphical Access Probe Power graph displays the absolute power level of each access probe, along with the delta power relative to each previous probe. The elapsed (delta) time period between the first access probe and each subsequent probe is also displayed. This table can be scrolled to display any portion of the access probe sequence.

Protocol Logging Features

The E6582A Wireless Protocol Advisor is now capable of logging the following:

  • Forward Supplemental Channel messages
  • Forward/Reverse IP messages
  • Forward/Reverse PPP messages
  • Forward/Reverse RLP messages

A.01.20 Release - July 2002

These are the original features of the E6702A. This firmware release includes all of the features of the E1962B cdma2000 Mobile Test Application, B.04 release and the following features unique to the E6702A.

Hardware Requirements

http://www.agilent.com/find/8960upgrades

Protocol Logging Features

With the E6582A Wireless Protocol Advisor running on an external PC connected to the test set protocol messages can be logged, filtered, decoded, and saved to file to provide detailed information regarding signaling between the test set and a cdma2000 device. Timestamping of messages and identification of specified signaling events allows analysis of the timing and nature of signaling events.

Graphical Access Probe Power

The graphical access probe power measurement consists of measuring a series of channel power measurements triggered by a rise in RF power detected on the test set's RF input. This measurement is performed with the test set's call limit mode feature turned on. By inhibiting the connection of a call, the cdma2000 device transmits its maximum number of access probes.

Each measurement is displayed in a bar graph with a maximum of 20 access probes displayed at one time.

FER Measurement Enhancements

The FER (Frame Error Rate) measurement includes three new measurement results provided to identify the types of errors counted by this measurement. The three types of errors now identified are:

  • Forward Erasures. The number of frames the cdma2000 device was not able to decode.
  • Mobile Errors. The number of frames that the cdma2000 device sent to the test set that the test set was able to decode but that contained errors.
  • Reverse Erasures. The number of frames that the cdma2000 device sent to the test set but the test set was not able to decode.

Soft/Softer Handoffs

Soft or Softer handoffs can now be performed because of the addition of another simulated cell (base station). The second cell provides pilot, fundamental, and OCNS channels with settable power levels on the pilot and fundamental channels and settable Walsh codes on the fundamental and OCNS channels. Pilot strength levels are displayed in dB and in units specified in test standards that express power in -0.5 dB increments relative to total cell power.

In addition, a timing delay feature has been introduced that delays the cell 2 timing relative to cell 1 by up to 16 PN chips (13.02 microseconds).

All parameters needed to control pilot detection thresholds are provided in the soft handoff parameters setup.

A softkey has also been added that sends the Pilot Measurement Request Order message to the mobile station, allowing the immediate retrieval of pilot strength and status information at any time during a call, regardless of whether a soft handoff is on or off. Timestamping of pilot strength requests and reports is displayed in a table along with current status information.


Settable Fields in Overhead Messages

Settable Fields in Overhead Messages

Last updated: November 14, 2006

This section is only applicable to the lab application.

The test set communicates with a mobile station under test through messages formatted according to IS-95 or IS-2000 standards.

The overhead messages listed below have message fields which are directly or indirectly settable by the user. Overhead message fields not listed below are either specified by the standard or have been fixed to a suitable default value by the test set.

  • IS-95 Sync Channel Messages (P_REV < = 4)
  • IS-95 Paging Channel Overhead Messages (P_REV < = 4)
    • System Parameters Message Settable Fields
    • Extended System Parameters Message Settable Fields
    • Access Parameters Message Settable Fields
    • CDMA Channel List Message Settable Fields
    • Neighbor List Message Settable Fields
    • Extended Neighbor List Message
  • IS-2000 Sync Channel Messages (P_REV > = 6)
  • IS-2000 Paging Channel Overhead Messages (P_REV > = 6)
    • System Parameters Message Settable Fields
    • Extended System Parameters Message Settable Fields
    • Access Parameters Message Settable Fields
    • CDMA Channel List Message Settable Fields
    • Neighbor List Message Settable Fields
    • Extended Neighbor List Message
  • IS-2000 Primary Broadcast Control Channel Overhead Messages (P_REV > = 7)
    • ANSI-41 System Parameters Message Settable Fields
    • MC-RR Parameters Message Settable Messages
    • Enhanced Access Parameters Message Settable Fields
    • Extended CDMA Channel List Message
    • Universal Neighbor List Message Settable Fields

IMPORTANT
The General Page Message is included with Overhead Messages if it does not contain Page Records. If the General Page Message contains Page Records it is included with the Mobile Station Directed messages.

IS-95 Sync Channel Messages (P_REV < = 4)

Sync Channel Message Settable Fields
Field | Default Value (decimal) | Test Set Field Name | Test Set Field Location
P_REV | 4 (95-B) | Protocol Rev | Protocol Rev softkey (Call Parms 1 of 3: F10)
MIN_P_REV | 4 (95-B) | Protocol Rev | Protocol Rev softkey (Call Parms 1 of 3: F10)
SID | 331 | System ID | Call Setup Screen, Call Control 2 of 3: Cell Information, Cell Parameters
NID | 1 | Network ID | Call Setup Screen, Call Control 2 of 3: Cell Information, Cell Parameters
PILOT_PN | 12 | Cell 1 (or 2) PN Offset | Call Setup Screen, Call Control 2 of 3: Generator Information, Code Channel Parameters
PRAT | 9600 (Full) | Paging Data Rate | Call Setup Screen, Call Control 2 of 3: Cell Information, Cell Parameters
CDMA_FREQ | Current Band Channel | Channel | Channel softkey (Call Parms 1 of 3: F9)

IS-95 Paging Channel Overhead Messages (P_REV < = 4)

System Parameters Message Settable Fields
Field | Default Value (decimal) | Test Set Field Name | Test Set Field Location
PILOT_PN | 12 | Cell 1 (or 2) PN Offset | Call Setup Screen, Call Control 2 of 3: Generator Information, Code Channel Parameters
SID | 331 | System ID | Call Setup Screen, Call Control 2 of 3: Cell Information, Cell Parameters
NID | 1 | Network ID | Call Setup Screen, Call Control 2 of 3: Cell Information, Cell Parameters
BASE_ID | 39 | Base ID | Call Setup Screen, Call Control 2 of 3: Cell Information, Cell Parameters
MAX_SLOT_CYCLE_INDEX | 1 | Max Slot Cycle Index | Call Setup Screen, Call Control 2 of 3: Cell Information, Cell Parameters
REG_PRD | 29 | Registration Period | Call Setup Screen, Call Control 2 of 3: Cell Information, Registration Parameters
T_ADD | 28 | T_Add | Call Setup Screen, Call Control 2 of 3: Soft Handoff Info, Soft Handoff Parameters
T_DROP | 32 | T_Drop | Call Setup Screen, Call Control 2 of 3: Soft Handoff Info, Soft Handoff Parameters
T_COMP | 5 | T_Comp | Call Setup Screen, Call Control 2 of 3: Soft Handoff Info, Soft Handoff Parameters
T_TDROP | 3 | T_TDrop | Call Setup Screen, Call Control 2 of 3: Soft Handoff Info, Soft Handoff Parameters
Extended System Parameters Message Settable Fields
Field | Default Value (decimal) | Test Set Field Name | Test Set Field Location
PILOT_PN | 12 | Cell 1 (or 2) PN Offset | Call Setup Screen, Call Control 2 of 3: Generator Information, Code Channel Parameters
MCC | 310 | Cell MCC | Call Setup Screen, Call Control 2 of 3: Cell Information, Cell Parameters
IMSI_11_12 | 0 | Cell MNC | Call Setup Screen, Call Control 2 of 3: Cell Information, Cell Parameters
P_REV | 4 (95-B) | Protocol Rev | Protocol Rev softkey (Call Parms 1 of 3: F10)
MIN_P_REV | 4 (95-B) | Protocol Rev | Protocol Rev softkey (Call Parms 1 of 3: F10)
Access Parameters Message Settable Fields
Field | Default Value (decimal) | Test Set Field Name | Test Set Field Location
PILOT_PN | 12 | Cell 1 (or 2) PN Offset | Call Setup Screen, Call Control 2 of 3: Generator Information, Code Channel Parameters
NOM_PWR | 0 | Nominal Power | Call Setup Screen, Call Control 2 of 3: Cell Information, Access Parameters
INIT_PWR | 0 | Initial Power | Call Setup Screen, Call Control 2 of 3: Cell Information, Access Parameters
PWR_STEP | 3 | Power Step | Call Setup Screen, Call Control 2 of 3: Cell Information, Access Parameters
NUM_STEP | 3 | Number of Steps | Call Setup Screen, Call Control 2 of 3: Cell Information, Access Parameters
PAM_SZ | 10 | Preamble Size | Call Setup Screen, Call Control 2 of 3: Cell Information, Access Parameters
MAX_REQ_SEQ | 1 | Maximum Request Sequence | Call Setup Screen, Call Control 2 of 3: Cell Information, Access Parameters
MAX_RSP_SEQ | 1 | Maximum Response Sequence | Call Setup Screen, Call Control 2 of 3: Cell Information, Access Parameters
NOM_PWR_EXT | 0 | Nominal Power Extended | Call Setup Screen, Call Control 2 of 3: Cell Information, Access Parameters
CDMA Channel List Message Settable Fields
Field | Default Value (decimal) | Test Set Field Name | Test Set Field Location
PILOT_PN | 12 | Cell 1 (or 2) PN Offset | Call Setup Screen, Call Control 2 of 3: Generator Information, Code Channel Parameters
CDMA_FREQ | Current Band Channel | Channel | Channel softkey (Call Parms 1 of 3: F9)
Neighbor List Message Settable Fields
Field | Default Value (decimal) | Test Set Field Name | Test Set Field Location
PILOT_PN | 12 | Cell 1 (or 2) PN Offset | Call Setup Screen, Call Control 2 of 3: Generator Information, Code Channel Parameters
Extended Neighbor List Message
Field | Default Value (decimal) | Test Set Field Name | Test Set Field Location
PILOT_PN | 12 | Cell 1 (or 2) PN Offset | Call Setup Screen, Call Control 2 of 3: Generator Information, Code Channel Parameters

IS-2000 Sync Channel Messages (P_REV > = 6)

Sync Channel Message Settable Fields
Field | Default Value (decimal) | Test Set Field Name | Test Set Field Location
P_REV | 6 (IS-2000-0) | Protocol Rev | Protocol Rev softkey (Call Parms 1 of 3: F10)
MIN_P_REV | 6 (IS-2000-0) | Protocol Rev | Protocol Rev softkey (Call Parms 1 of 3: F10)
SID | 331 | System ID | Call Setup Screen, Call Control 2 of 3: Cell Information, Cell Parameters
NID | 1 | Network ID | Call Setup Screen, Call Control 2 of 3: Cell Information, Cell Parameters
PILOT_PN | 12 | Cell 1 (or 2) PN Offset | Call Setup Screen, Call Control 2 of 3: Generator Information, Code Channel Parameters
PRAT | 0 (full-rate) | Paging Data Rate | Call Setup Screen, Call Control 2 of 3: Cell Information, Cell Parameters
CDMA_FREQ | Current Band Channel | Channel | Channel softkey (Call Parms 1 of 3: F9)
EXT_CDMA_FREQ | Current Band Channel | Channel | Channel softkey (Call Parms 1 of 3: F9)
If P_REV > = 7 (IS-2000-A), include the following fields:
SR1_BCCH_NON_TD_INCL | 1 | Control Channel Configuration | Call Setup Screen, Call Control 2 of 3: Cell Info, Control Channel Parameters
SR1_BRAT_NON_TD | 1 | F-BCCH Data Rate | Call Setup Screen, Call Control 2 of 3: Cell Info, Control Channel Parameters
SR1_CRAT_NON_TD | 1 (fixed by the test set) | F-BCCH Data Rate | Call Setup Screen, Call Control 2 of 3: Cell Info, Control Channel Parameters
SR1_BCCH_CODE_CHAN_NON_TD | 1 (fixed by the test set) | F-BCCH Data Rate | Call Setup Screen, Call Control 2 of 3: Cell Info, Control Channel Parameters

IS-2000 Paging Channel Overhead Messages (P_REV > = 6)

The test set transmits these overhead messages on the paging channel (F-PCH) or primary broadcast control channel (F-BCCH) depending upon the current control channels.

System Parameters Message Settable Fields
Field | Default Value (decimal) | Test Set Field Name | Test Set Field Location
PILOT_PN | 12 | Cell 1 (or 2) PN Offset | Call Setup Screen, Call Control 2 of 3: Generator Information, Code Channel Parameters
SID | 331 | System ID | Call Setup Screen, Call Control 2 of 3: Cell Information, Cell Parameters
NID | 1 | Network ID | Call Setup Screen, Call Control 2 of 3: Cell Information, Cell Parameters
BASE_ID | 39 | Base ID | Call Setup Screen, Call Control 2 of 3: Cell Information, Cell Parameters
MAX_SLOT_CYCLE_INDEX | 0 | Max Slot Cycle Index | Call Setup Screen, Call Control 2 of 3: Cell Information, Cell Parameters
POWER_UP_REG | 1 (On) | Power Up Registration State | Call Setup Screen, Call Control 2 of 3: Cell Information, Registration Parameters
REG_PRD | 0 (Off), Timer 29 | Registration Period | Call Setup Screen, Call Control 2 of 3: Cell Information, Registration Parameters
T_ADD | 28 | T_Add | Call Setup Screen, Call Control 2 of 3: Soft Handoff Info, Soft Handoff Parameters
T_DROP | 32 | T_Drop | Call Setup Screen, Call Control 2 of 3: Soft Handoff Info, Soft Handoff Parameters
T_COMP | 5 | T_Comp | Call Setup Screen, Call Control 2 of 3: Soft Handoff Info, Soft Handoff Parameters
T_TDROP | 3 | T_TDrop | Call Setup Screen, Call Control 2 of 3: Soft Handoff Info, Soft Handoff Parameters
Extended System Parameters Message Settable Fields
Field | Default Value (decimal) | Test Set Field Name | Test Set Field Location
PILOT_PN | 12 | Cell 1 (or 2) PN Offset | Call Setup Screen, Call Control 2 of 3: Generator Information, Code Channel Parameters
MCC | 310 (or fixed to '1111111111' if Escape Mode = On) | Cell MCC | Call Setup Screen, Call Control 2 of 3: Cell Information, Cell Parameters
IMSI_11_12 | 0 (or fixed to '1111111' if Escape Me = On) | Cell MNC | Call Setup Screen, Call Control 2 of 3: Cell Information, Cell Parameters
P_REV | 6 (IS-2000-0) | Protocol Rev | Protocol Rev softkey (Call Parms 1 of 3: F10)
MIN_P_REV | 6 (IS-2000-0) | Protocol Rev | Protocol Rev softkey (Call Parms 1 of 3: F10)
SOFT_SLOPE | 0 | Soft_Slope | Call Setup Screen, Call Control 2 of 3: Soft Handoff Info, Soft Handoff Parameters
ADD_INTERCEPT | 0 | Add_Intercept | Call Setup Screen, Call Control 2 of 3: Soft Handoff Info, Soft Handoff Parameters
DROP_INTERCEPT | 0 | Drop_Intercept | Call Setup Screen, Call Control 2 of 3: Soft Handoff Info, Soft Handoff Parameters
QPCH_SUPPORTED | 0 | F-QPCH State | Call Setup Screen, Call Control 2 of 3: Cell Information, Cell Parameters
QPCH_RATE (indicator rate) | 1 (QPCH indicator rate = 9600 bps) | F-QPCH Data Rate (F-QPCH data rate has one-on-one mapping to the indicator rate, that is, Full = 4800 bps QPCH data rate = 9600 bps QPCH indicator rate; Half = 2400 bps QPCH data rate = 4800 bps QPCH indicator rate) | Call Setup Screen, Call Control 2 of 3: Cell Information, Cell Parameters
QPCH_POWER_LEVEL_PAGE | 010 (-3 dB) | F-QPCH Relative to Pilot Level | Call Setup Screen, Call Control 2 of 3: Cell Information, Cell Parameters
RLGAIN_TRAFFIC_PILOT | 0 | RL Traffic to Pilot Gain | Call Setup Screen, Call Control 2 of 3: Cell Information, Cell Parameters
Access Parameters Message Settable Fields
Field | Default Value (decimal) | Test Set Field Name | Test Set Field Location
PILOT_PN | 12 | Cell 1 (or 2) PN Offset | Call Setup Screen, Call Control 2 of 3: Generator Information, Code Channel Parameters
NOM_PWR | 0 | Nominal Power | Call Setup Screen, Call Control 2 of 3: Cell Information, Access Parameters
INIT_PWR | 0 | Initial Power | Call Setup Screen, Call Control 2 of 3: Cell Information, Access Parameters
PWR_STEP | 3 | Power Step | Call Setup Screen, Call Control 2 of 3: Cell Information, Access Parameters
NUM_STEP | 3 | Number of Steps | Call Setup Screen, Call Control 2 of 3: Cell Information, Access Parameters
PAM_SZ | 10 | Preamble Size | Call Setup Screen, Call Control 2 of 3: Cell Information, Access Parameters
MAX_REQ_SEQ | 1 | Maximum Request Sequence | Call Setup Screen, Call Control 2 of 3: Cell Information, Access Parameters
MAX_RSP_SEQ | 1 | Maximum Response Sequence | Call Setup Screen, Call Control 2 of 3: Cell Information, Access Parameters
NOM_PWR_EXT | 0 | Nominal Power Extended | Call Setup Screen, Call Control 2 of 3: Cell Information, Access Parameters
CDMA Channel List Message Settable Fields
Field | Default Value (decimal) | Test Set Field Name | Test Set Field Location
PILOT_PN | 12 | Cell 1 (or 2) PN Offset | Call Setup Screen, Call Control 2 of 3: Generator Information, Code Channel Parameters
CDMA_FREQ | Current Band Channel | Channel | Channel softkey (Call Parms 1 of 3: F9)
Neighbor List Message Settable Fields
Field | Default Value (decimal) | Test Set Field Name | Test Set Field Location
PILOT_PN | 12 | Cell 1 (or 2) PN Offset | Call Setup Screen, Call Control 2 of 3: Generator Information, Code Channel Parameters.
Extended Neighbor List Message
Field | Default Value (decimal) | Test Set Field Name | Test Set Field Location
PILOT_PN | 12 | Cell 1 (or 2) PN Offset | Call Setup Screen, Call Control 2 of 3: Generator Information, Code Channel Parameters

IS-2000 Primary Broadcast Control Channel Overhead Messages (P_REV > = 7)

The test set supports the following overhead messages carried on the primary broadcast control channel (F-BCCH) when the protocol revision (P_REV) is no less than 7. The test set does not support the remaining F-BCCH overhead messages.

ANSI-41 System Parameters Message Settable Fields
Field | Default Value (decimal) | Test Set Field Name | Test Set Field Location
PILOT_PN | 12 | Cell 1 (or 2) PN Offset | Call Setup Screen, Call Control 2 of 3: Generator Information, Code Channel Parameters
SID | 331 | System ID | Call Setup Screen, Call Control 2 of 3: Cell Information, Cell Parameters
NID | 1 | Network ID | Call Setup Screen, Call Control 2 of 3: Cell Information, Cell Parameters
BASE_ID | 39 | Base ID | Call Setup Screen, Call Control 2 of 3: Cell Information, Cell Parameters
POWER_UP_REG | 1 (On) | Power Up Registration State | Call Setup Screen, Call Control 2 of 3: Cell Information, Registration Parameters
REG_PRD | 1 (On), Timer 29 (=12.16 s) | Timer Based Registration State, Registration Period | Call Setup Screen, Call Control 2 of 3: Cell Information, Registration Parameters
MC-RR Parameters Message Settable Messages
Field | Default Value (decimal) | Test Set Field Name | Test Set Field Location
PILOT_PN | 12 | Cell 1 (or 2) PN Offset | Call Setup Screen, Call Control 2 of 3: Generator Information, Code Channel Parameters
BASE_ID | 39 | Base ID | Call Setup Screen, Call Control 2 of 3: Cell Information, Cell Parameters
P_REV | 7 (IS-2000-A) | Protocol Rev | Protocol Rev softkey (Call Parms 1 of 3: F10)
MIN_P_REV | 6 (IS-2000-A) | Protocol Rev | Protocol Rev softkey (Call Parms 1 of 3: F10)
T_ADD | 28 | T_Add | Call Setup Screen, Call Control 2 of 3: Soft Handoff Info, Soft Handoff Parameters
T_DROP | 32 | T_Drop | Call Setup Screen, Call Control 2 of 3: Soft Handoff Info, Soft Handoff Parameters
T_COMP | 5 | T_Comp | Call Setup Screen, Call Control 2 of 3: Soft Handoff Info, Soft Handoff Parameters
T_TDROP | 3 | T_TDrop | Call Setup Screen, Call Control 2 of 3: Soft Handoff Info, Soft Handoff Parameters
SOFT_SLOPE | 0 | Soft_Slope | Call Setup Screen, Call Control 2 of 3: Soft Handoff Info, Soft Handoff Parameters
ADD_INTERCEPT | 0 | Add_Intercept | Call Setup Screen, Call Control 2 of 3: Soft Handoff Info, Soft Handoff Parameters
DROP_INTERCEPT | 0 | Drop_Intercept | Call Setup Screen, Call Control 2 of 3: Soft Handoff Info, Soft Handoff Parameters
MCC | 310 (or fixed to '1111111111' if Escape Mode = On) | Cell MCC | Call Setup Screen, Call Control 2 of 3: Cell Information, Cell Parameters
IMSI_11_12 | 0 (or fixed to '1111111' if Escape Mode = On) | Cell MNC | Call Setup Screen, Call Control 2 of 3: Cell Information, Cell Parameters
MAX_SLOT_CYCLE_INDEX | 0 | Max Slot Cycle Index | Call Setup Screen, Call Control 2 of 3: Cell Information, Cell Parameters
PWR_REP_THRESH | 0 | Bad Frame Threshold (Frames) | See MS Reported FER Parameters .
PWR_REP_FRAME | 7 (= 56 frames) | Frame Interval of Report (Frames)
PWR_THRESH_ENABLE | 0 | Threshold Report Enable
PWR_PERIOD_ENABLE | 0 | Period Report Enable
PWR_REP_DELAY | 14 (= 56 frames) | Frame Delay of Report (Frames)
FCCCH_RATE | 0 (=9.6 kbps, 20 ms frame) | F-CCCH Data Rate | Call Setup Screen, Call Control 2 of 3: Cell Info, Control Channel Parameters
FCCCH_CODE_RATE | 1 (= 1/2 code rate) | F-CCCH Data Rate | Call Setup Screen, Call Control 2 of 3: Cell Info, Control Channel Parameters
QPCH_SUPPORTED | 0 | F-QPCH State | Call Setup Screen, Call Control 2 of 3: Cell Information, Cell Parameters
QPCH_RATE (indicator rate) | 1 (QPCH indicator rate = 9600) | F-QPCH Data Rate (F-QPCH data rate has one-on-one mapping to the indicator rate, that is, Full = 4800 bps QPCH data rate = 9600 bps QPCH indicator rate; Half = 2400 bps QPCH data rate = 4800 bps QPCH indicator rate) | Call Setup Screen, Call Control 2 of 3: Cell Information, Cell Parameters
QPCH_POWER_LEVEL_PAGE | 010 (-3 dB) | F-QPCH Relative to Pilot Level | Call Setup Screen, Call Control 2 of 3: Cell Information, Cell Parameters
RLGAIN_TRAFFIC_PILOT | 0 | RL Traffic to Pilot Gain | Call Setup Screen, Call Control 2 of 3: Cell Information, Cell Parameters
Enhanced Access Parameters Message Settable Fields
Field | Default Value (decimal) | Test Set Field Name | Test Set Field Location
PILOT_PN | 12 | Cell 1 (or 2) PN Offset | Call Setup Screen, Call Control 2 of 3: Generator Information, Code Channel Parameters
MAX_REQ_SEQ | 1 | Maximum Request Sequence | Call Setup Screen, Call Control 2 of 3: Cell Information, Enhanced Access Parms
MAX_RSP_SEQ | 1 | Maximum Response Sequence | Call Setup Screen, Call Control 2 of 3: Cell Information, Enhanced Access Paramus
RLGAIN_COMMON_PILOT | 0 | RL Gain Common To Pilot | Call Setup Screen, Call Control 2 of 3: Cell Information, Enhanced Access Paramus
IC_THRESH | 7 | Interference Correction Threshold | Call Setup Screen, Call Control 2 of 3: Cell Information, Enhanced Access Paramus
IC_MAX | 7 | Interference Correction Maximum | Call Setup Screen, Call Control 2 of 3: Cell Information, Enhanced Access Paramus
EACH_NOM_PWR | 0 | EACH Nominal Power | Call Setup Screen, Call Control 2 of 3: Cell Information, Enhanced Access Paramus
EACH_INIT_PWR | 0 | EACH Initial Power | Call Setup Screen, Call Control 2 of 3: Cell Information, Enhanced Access Paramus
EACH_PWR_STEP | 3 | EACH Power Step | Call Setup Screen, Call Control 2 of 3: Cell Information, Enhanced Access Paramus
EACH_NUM_STEP | 3 | EACH Number of Steps | Call Setup Screen, Call Control 2 of 3: Cell Information, Enhanced Access Paramus
EACH_BA_RATES_SUPPORTED | 0xC0 (=9.6 kbps, 20 ms frame) | EACH Data Rate Supported | Call Setup Screen, Call Control 2 of 3: Cell Information, Enhanced Access Paramus
NOM_PWR_EXT | 0 | Nominal Power Extended | Call Setup Screen, Call Control 2 of 3: Cell Information, Enhanced Access Paramus
Extended CDMA Channel List Message
Field | Default Value (decimal) | Test Set Field Name | Test Set Field Location
PILOT_PN | 12 | Cell 1 (or 2) PN Offset | Call Setup Screen, Call Control 2 of 3: Generator Information, Code Channel Parameters
CDMA_FREQ | Current Band Channel | Channel | Channel softkey (Call Parms 1 of 3: F9)
Universal Neighbor List Message Settable Fields
Field | Default Value (decimal) | Test Set Field Name | Test Set Field Location
PILOT_PN | 12 | Cell 1 (or 2) PN Offset | Call Setup Screen, Call Control 2 of 3: Generator Information, Code Channel Parameters.

Related Topics

Protocol Revisions

Setting Enhanced Access Parameters

Setting Control Channel Parameters

Setting Cell Parameters

Setting Access Parameters

Setting Registration Parameters


Packet Data Connection Troubleshooting

Packet Data Connection Troubleshooting

Last updated: November 10, 2006

This section is only applicable to the lab application.

Possible Setup Issues

Packet data connection is a wireless device (such as a MS supporting packet data services) initiated procedure.

  • Before trying to establish a packet data connection, you must make sure that the following settings properly configured:
    • Cell band, channel and System ID must be set to the proper values for your wireless devices so that it can successfully camp on the test set (see How Do I Set Up a Call? ).
    • Packet Data Service Options must be set to SO33 or SO33 (+F-SCH).
  • If the test set's internal PDSN (providing simple IP protocol) is used for packet data connection, you must properly set a DUT IP Address for your wireless device and make sure the External PDSN State is set to Off (see Data Channel Parameters ). For an example packet data connection procedure using Simple IP protocol, refer to Packet Data Service Example Procedure (via Simple IP) .
  • If the external MOB-IP-SIM is used to supply the PDSN simulation (providing Mobile IP protocol),
    • the MOB-IP-SIM must be properly configured. See How Does Test Set Support Simple IP and Mobile IP? .
    • you must properly specify the External PDSN IP Address and the External PDSN TCP Port , then turn the External PDSN State to On from the test set.
    • see Packet Data Service Example Procedure (via Mobile IP) for an example Packet Data Connection procedure with Mobile IP.
  • If your data channel application does not seem to be working, try pinging the device. Also, The test set has a ping feature, and so do most computer operating systems. See Ping for more information.
  • Ping does not work: Verify that your device supports ping. The device must be in a packet data connection in order for ping to work. This may require that you initiate a data transfer from the mobile station. Also, Ping and Data Channel are only available in Active Cell operating mode with IS-2000 system type selected.
  • Ping log has an unknown IP address: If you log a Ping that originated from the test set, the Ping forward link Source Address and the reverse link Destination Address have a fixed value of 130.29.181.203. This is because the test set uses an internal address to originate IP data from the test set to the mobile station. See Protocol Logging During Ping for more information.

Other Considerations

  • While on a packet data connection, changing service option may cause the data connection dropped. See Considerations When Changing Service Options .
  • While on a packet data connection, you can change F-SCH data rate but may be rejected by the MS. See Considerations When Changing F-SCH/R-SCH Data Rates .
  • To check the current status of the packet data connection, see Packet Data Connection Processing States .
  • You must properly set the External PDSN State which determines whether the PDSN simulation for packet data service is provided by the test set (using Simple IP protocol) or by the external application (MOB-IP-SIM) (using Mobile IP protocol). See Setting Considerations for External PDSN State .
  • When the external MOB-IP-SIM is providing PDSN service to the mobile stations, the mobile station's IP address is assigned by the MOB-IP-SIM. The setting by DUT IP Address is ignored and the Ping the DUT from the test set functionality is not available.
  • While on a packet data connection, you can perform hard handoffs, but can not make soft handoffs. See Handoffs Available for Packet Data Services .
  • Use Ping function to verify the system interconnect.

Related Topics

Data Channel


Graphical Access Probe Power Troubleshooting

Graphical Access Probe Power Troubleshooting

Last updated: October 28, 2004

This section is only applicable to the lab application.

Possible Setup Issues

If the Graphical Access Probe Power measurement is currently selected all other measurements are disabled.

The input signal must conform to Input Signal Requirements .

The graphical access probe power measurement becomes armed when the START SINGLE key is pressed or the INITiate GPIB command is sent. At that time, the test set calculates the number of expected access probes based on number of steps and maximum request or response sequence parameters.

If a registration occurs before a call is attempted, the measurement will disarm before the mobile station has finished sending access probes. This is because the test set does not distinguish between access probes occurring as a result of registrations, for example, and call attempts.

Graphical access probe power measurement results are affected by the Amplitude Offset value. Use the SYSTem:CORRection:GAIN command to determine offset values.

Graphical access probe power measurements are triggered by a rise in RF power that crosses approximately -55 dBm.

Clipping of Access Probes

The Graphical Access Probe Power measurement has a range of 15 dB. If the Power Step and Number of Steps are set up such that the mobile station transmits access probes greater than 15 dB from the first access probe, it will appear that the mobile station is transmitting a lower power level than expected.

To avoid this measurement inaccuracy, limit the Power Step and Number of Steps to yield no greater than 15 dB of change from the first (lowest power) access probe to the highest power access probe.

Interpreting Integrity Indicator values

See Integrity Indicator .

If over range (5) is returned the input power has exceeded the test set's internal sampler maximum value during some part of the sampling or the input power has exceeded the calibrated range of the test set's power detector.

If under range (6) is returned the measurement result is below the expected input power level. Under range is also indicated if the input power is below the calibrated range of the test set's power detector.

If the signal has both over range and under range conditions, only the over range (5) will be indicated.

Related Topics

Integrity Indicator


Paging Channel Message Error Rate (MER) Troubleshooting

Paging Channel Message Error Rate (MER) Troubleshooting

Last updated: October 28, 2004

This section is only applicable to the lab application.

Possible Setup Issues

  • It's recommended that you strictly follow the procedures described in the Paging Channel MER Procedures to ensure valid results. If you vary the test procedure, you may get the unexpected results.
  • It is recommended that you set up the parameters associated with the Paging MER test prior to initiating the MER test procedure. The test set provides a warning message if key settings are changed during the test. However, the test set does not block the changes or cause the MER test procedure to be aborted

  • Starting the MER procedure is executed when a call is established since the Set Parameter Message (STPM) is delivered on the traffic channel.

  • Stoping the MER procedure is executed when a call is established since the Retrieve Parameters Message (RTPM) and Parameters Response Message (PRSM) are delivered on the traffic channel

  • MER Proc Warning ( CALL:STATus:PAGing:MERRor:PROCedure:WARNing? ) indicates error or warning conditions that have occurred during the Paging MER test procedure. These conditions will result in the Paging MER results non-available or invalid at the completion of the test. It's provided to aid in understanding the Paging MER results when they are non-available and to indicate when the results may be questionable.

Related Topics

Paging Channel MER Description


Protocol Logging Troubleshooting

Protocol Logging Troubleshooting

Last updated: June 18, 2007

This section is only applicable to the lab application and to a test application with the required feature license.

Possible Setup Issues

  • The test set must be connected via a LAN or WAN to a PC running the E6582A/E6584A Wireless Protocol Advisor (WPA) software. Check connections, installation of software, IP addresses and gateway addresses.
  • A session must be activated. Check the Logging: status area on the test set's front panel. It should appear as: Logging:Idle .
  • If messages are not appearing on the PC, make sure the pause button is not selected. This would appear as a green arrow through two vertical bars next to the RECord button.

Related Topics

Protocol Logging


Getting Started with Call Processing

Getting Started with Call Processing

Last updated: June 20, 2006

While in operating modes other than CW (see Test Set Operating Modes ), the test set includes a base station emulator which allows you to establish a connection between the test set and your wireless device. The base station emulator can be configured by changing various parameters. You can then perform many call processing operations and measurements.

To learn more about the parameters available for configuring the base station emulator, see Base Station Emulator Configurations .

To learn more about what call processing operations you can perform using the test set, see Call Processing Operation .

For general technology information to help you become more familiar with the cdma2000 system, see General Information .

TO RETURN TO THE MAIN CALL PROCESSING PAGE, click here: Call Processing .


Configuring the Test Set's AUDIO OUT port

Configuring the Test Set's AUDIO OUT port

Last updated: October 28, 2004

Description

The AUDIO OUT connector on the test set's front panel can be configured to carry one of two signals:

  • Audio Generator
  • FM Demod

By default, the AUDIO OUT connector is configured to carry the output from the built in audio generator. This signal is typically used to stimulate a system to measure its audio performance. When the audio generator's signal is selected for output at the front panel AUDIO OUT connector, use the AFGenerator commands to control the signal.

When testing AMPS systems, it may be useful to configure the AUDIO OUT connector to carry the analog FM Demod signal. This provides the demodulated FM signal for external analysis and baseband processing. Fixed bandwidth bandpass, expandor, and de-emphasis filters can be selected to control the FM Demod signal. When the FM Demod signal is selected for output at the front panel AUDIO OUT connector, use the SYSTem:AUDio:OUTPut commands to control the signal.

For front panel operation, to select the signal source for output to the AUDIO OUT connector, press System Config hardkey, then select Audio Out Port ( F1 ) on the System Config Screen (2 of 2).

Programmatically, to select the signal source for output to the AUDIO OUT connector, use the SYSTem:AUDio:OUTPut:SOURce commands.

Example

OUTPUT 714;"SYSTem:AUDio:OUTPut:SOURce AFGenerator" !Selects Audio Generator signal for output
                                                    !at the front panel AUDIO OUT port.

NOTE
Refer to the Technical Specifications in the Application Datasheet for specifications of the AUDIO OUT connector. There will be no guaranteed performance for the signal present at the AUDIO OUT connector when FM Demod signal is selected for output.

Related Topics

How Do I Configure the AUDIO OUT Port?


Restart on Fatal Error

Restart on Fatal Error

Last updated: June 20, 2006

Description

The Restart on Fatal Error feature provides the ability to configure the test set to automatically restart when a fatal error occurs. Restart on Fatal Error does not apply when a fatal error occurs during the test set's power up sequence.

The Restart on Fatal Error State is retained regardless of whether the test set is restarted manually or through the Restart on Fatal Error feature. The test set's default setting for the Restart on Fatal Error State is Off. If the Restart on Fatal Error State is set to On and a fatal error occurs, the test set prints the fatal error condition on the test set's front panel. The test set then waits 25 seconds before restarting.

The following error message is then displayed on the test set's front panel once the test set completes its power up sequence: " Warning; 8960 has been restarted after a non-recoverable error occurred. " All errors in the error/event queue can be queried using the command SYSTem:ERRor? .

Configurable Parameters

Restart on Fatal Error State is the only parameter that needs to be configured to allow the test set to restart if a fatal error is encountered. The command to set this parameter is SYSTem:FATal:ERRor:RESTart .

How Do I Configure the Test Set to Restart State?

The following procedure details how to configure the test set to automatically restart if a fatal error is encountered during operation.

  1. Press SYSTEM CONFIG .
  2. Press Instrument Setup ( F1 ).
  3. Scroll down and highlight the Restart on Fatal Error State parameter.
  4. Press the knob to change the state to On as shown in the figure below.

Related Topics

SYSTem:FATal:ERRor:RESTart


Test Set Beeper

Test Set Beeper

Last updated: October 28, 2004

Description

This parameter allows you to change the beeper state to on or off. A beep will indicate error conditions caused during manual or remote operation of the test set.

A 100 ms, 1.24 kHz audible tone (beep) is generated when an error message is logged and the beeper state is set to on. If two errors are generated in quick succession, two beeps are generated to indicate that more than one error has been logged.

The beeper state can be manually set in the Instrument Setup window found in the SYSTEM CONFIG screen.

Example

OUTPUT 714;"SYSTEM:BEEPER:STATE OFF"

Related Topics

SYSTem:BEEPer


Display Brightness

Display Brightness

Last updated: October 28, 2004

Description

This parameter allows you to adjust the brightness of the test set's display. The test set's display screen has two brightness settings:

  • medium brightness
  • high brightness

Example

OUTPUT 714;"DISPLAY:BRIGHTNESS MEDIUM" ! sets screen brightness to medium.

Related Topics

DISPlay


Display Mode (Track/Fast)

Display Mode (Track/Fast)

Last updated: October 28, 2004

Description

There are two display modes to select from when operating the test set remotely.

  • Display mode fast
  • Display mode track

Fast Mode

When operating remotely, there is often no need for the display to be updated as measurements are made. Using the fast display mode will increase the speed of the test set when it is operated remotely.

Fast mode is designed for remote use only. The test set returns to track mode if you change to manual operation.

  • No screen or menu items are visible (except error messages).
  • Error messages will be displayed in their normal location.
  • "This instrument is being operated remotely" will be displayed at the bottom of the screen.

Example

OUTPUT 714;"DISPLAY:MODE FAST" !Selects fast mode

Track Mode

The track display mode is used to allow users to see what the test set is doing while it is being controlled remotely. Track mode is the default mode of the test set.

  • Any changes made remotely will be updated on the screen if that screen is displayed.
  • The error message window will be displayed as required when an error occurs.

Example

OUTPUT 714;"DISPLAY:MODE TRACK"!Selects track mode

Writing Messages to the Display

The capability to write up to four 30-character lines of text to the front panel display for operator messages is available when the display is in Fast Mode . This feature can be used to control the flow of software running on an external controller by pressing softkeys on the test set's front panel.

For example, by displaying a message that prompts the operator to press a front panel softkey and then monitoring that softkey through status register bits, the programmer can design code that starts measurements, stops measurements, or branches to a selected routine or function without the need for access to the external computer's keyboard.

The GPIB commands for writing messages to the display are found in the DISPlay:OPERator:MESSage table.

The status bit register GPIB commands and bit definitions for monitoring the test set's sofkeys are found in the STATus:OPERation:KEYPressed Register Bit Assignments table.

Related Topics

DISPlay


Configuring the Test Set's GPIB

Configuring the Test Set's GPIB

Last updated: October 28, 2004

Description

The GPIB address is an integer between 0 and 30. The test set comes with a default address of 14 and may be set/queried using the SYSTem subsystem or manually through the system configuration screen by selecting the parameter and changing the number with the knob or the keypad.

The GPIB address is a non-volatile parameter. The GPIB address is not affected by any reset operation and can only be changed by direct access to the parameter itself.

Related Topics

SYSTem:COMMunicate


Hardware Configuration Report

Hardware Configuration Report

Last updated: October 28, 2004

Description

You can generate a list of the test set's hardware configuration over the LAN or GPIB.

The LAN query is the easiest and most direct way to query the test set's hardware configuration. This method uses your web browser to display a formatted report.

The GPIB query returns an unformatted character string that must be buffered and saved to an HTML file to provide formatted text.

LAN Query

  1. Refer to the SYSTEM CONFIG screen to determine the LAN address.
  2. Open a web browser and enter <LAN address>/iconfig. For example, if your LAN address is 130.2.2.147, you would enter:

    130.2.2.147/iconfig

  3. The web browser will then display formatted text. A partial list of the hardware configuration information is shown below:

GPIB Query

Use the following Basic example as a model to store the test set's configuration as an HTML file.

GPIB Example:

10    DIM Buf1$[20000],Buf2$[20000] ! This is the minimum space for the arrays
20    OUTPUT 714;"SYSTEM:CONFIGURE:INFORMATION:HARDWARE:VERBOSE?"
30    ENTER 714;Buf1$,Buf2$
40    CREATE "HW.htm",1              ! Create an HTML file
50    ASSIGN @File TO "HW.htm"
60    OUTPUT @File;Buf1$,Buf2$
70    END

In the future, the hardware configuration report may increase in length. More space would then need to be allocated for the arrays.

Display the HTML file using a web browser or HTML text editor.

Related Topics

SYSTem:CONFigure


Obtaining Identification Information (*IDN)

Obtaining Identification Information (*IDN)

Last updated: October 28, 2004

Description

Test set information is returned from a *IDN? query. The *IDN? query provides information about the Manufacturer, Model Number, Serial Number, and Firmware Revision. *IDN? is defined in IEEE Std. 488.2-1992, 10.14.

Test Set Information

*IDN? query returns identification information as a comma separated string.

DIM A$[100]
OUTPUT 714;"*IDN?" !returns manufacturer,model number, serial number and "0"
                   !separated by commas
ENTER 714;A$
PRINT A$           !prints, for example "Agilent Technologies, 8960 Series 10 E5515B,
                   !US38020105,0
  • Agilent Technologies is the manufacturer.
  • Printable ASCII characters excluding comma and semicolon up to a 25-character string.
    Model number example: 8960 Series 10 E5515B
  • Printable ASCII characters excluding comma and semicolon up to a 10-character string.
    Serial number example: US00000123
  • Printable ASCII characters excluding comma and semicolon up to a 20-character string.
    Firmware revision example: 0

NOTE
The *IDN? query will always indicate that the firmware revision is zero. SYSTem:APPLication[:CURRent]:REVision? is the recommended way to query the firmware revision.

Related Topics

Hardware Configuration Report


Configuring the Test Set's LAN

Configuring the Test Set's LAN

Last updated: June 20, 2006

Description

LAN IP Address

CAUTION
Always verify that the test set is responding to a new LAN IP Address by pinging the test set. If the test set does not respond to the ping, cycle power. This will ensure that the test set will respond to the new LAN IP Address.

The LAN address is a character string with a maximum of 15 characters and a format of A.B.C. D where A is between 0 and 223 (excluding 127, which is assigned for use as the Internet host loopback address), and B, C, and D are between 0 and 255. No embedded spaces are allowed. The address may be manually set/viewed in the system configuration screen. The LAN address can be set/queried using the SYSTem subsystem.

The LAN address is a non-volatile parameter. The LAN address is not affected by any reset operation and can only be changed by direct access to the parameter itself.

NOTE
If the LAN address is set to a different network class, the subnet mask will change to the default net mask for the new network class.

For convenience the DATA port on the front panel may be configured as a LAN port. When an RJ45 jumper cable, (part number E5515-61160) is connected from the LAN PORT on the rear panel, to the ETHERNET TO FRONT PANEL port also on the rear panel, the user has LAN access from the front panel of the test set. Without the RJ45 jumper cable, the test set connection to a LAN is the rear-panel, LAN PORT connector.

LAN Default Gateway

The LAN router, (default gateway), is a character string with a maximum of 15 characters and a format of A, B, C, D, where A is between 0 and 223 , and B, C, and D are between 0 and 255, no embedded spaces are allowed. If the default gateway is set to a format not allowed with the LAN address or the subnet mask that have been selected, the default gateway will be set to a null string, indicated by a blank field on the test set display. The address may be manually set/viewed in the system configuration screen. The LAN default gateway can be set/queried using the SYSTem subsystem.

The LAN default gateway is the address of a router that routes messages between networks and or subnets. If this value is not specified, LAN communications will be limited to the network and subnet specified by the LAN IP address and the subnet mask. Your network administrator will know if a default gateway is needed and if so, the address of the router. If the default gateway address is not needed by your network, it may be disabled by entering any of the following values: "0" (zero), "" (null string), "0.0.0.0"

The LAN default gateway is a non-volatile parameter. The LAN default gateway is not affected by any reset operation and can only be changed by direct access to the parameter itself.

LAN Subnet Mask

The LAN subnet mask address is a character string with a maximum of 15 characters and a format of A, B, C, D, where A , B, C, and D are between 0 and 255. No embedded spaces are allowed. The address may be manually set/viewed in the system configuration screen. The LAN subnet mask address can be set/queried using the SYSTem subsystem.

The subnet mask number combined with the IP address identifies which network and subnet your computer is on. Contact your system administrator for the correct subnet mask for your network.

The subnet mask determines the boundaries between the subnet ID and the host ID.

The LAN subnet mask is a non-volatile parameter. The LAN subnet mask is not affected by any reset operation and can only be changed by direct access to the parameter itself or by changes to the LAN IP Address.

NOTE
If the LAN address is set to a different network class, the subnet mask will change to the default net mask for the new network class.

The subnet mask number is obtained from your network administrator.

Related Topics

How Do I Configure the Test Set for My Test System?


Amplitude Offset

Amplitude Offset

Last updated: November 10, 2006

Description

Amplitude offsets compensate for loss or gain between the test set's RF IN/OUT front panel connector and the mobile station's RF connector.

To access the amplitude offset feature, press the SYSTEM CONFIG key, followed by the RF IN/OUT Amptd Offset ( F5 ) key.

Amplitude offset settings are preserved during power cycles or instrument preset.

Setting Up Amplitude Offsets and Frequency Points

Up to 20 frequency points can be assigned an amplitude offset. Negative amplitude offset values should be entered when there is a loss through the RF cabling and test fixtures and positive values should be entered when there is a gain.

The RF IN/OUT Amplitude Offset table displays the current (on/off) state of the amplitude offset feature. There are also 20 rows for entering frequencies and 20 rows for entering corresponding offset values. To enter values in the table use the RF IN/OUT Amplitude Offset Setup menu.

To set up amplitude offsets remotely, one comma-separated string is sent to set up frequency points and another comma-separated string assigns the corresponding amplitudes.

GPIB Commands

OUTPUT 714;"SYSTEM:CORRECTION:SFREQUENCY 1710.2 MHZ,1805.2 MHZ,1784.8 MHZ,1879.8 MHZ"
!sets the first 4 frequencies in the amplitude offset table.

OUTPUT 714;"SYSTEM:CORRECTION:SGAIN -2.55,-3.12,-3.68,-4.23"
!sets the first 4 amplitude offsets in the amplitude offset table.

Turning amplitude offsets on/off

When the RF IN/OUT Amplitude Offset State is on, all offsets that are not individually turned off are applied and the word "Offset" appears in the Instrument Status Area of the test set's display.

If the RF IN/OUT Amplitude Offset State is off, none of the amplitude offsets are applied.

GPIB Command

OUTPUT 714;"SYSTEM:CORRECTION:STATE ON"
!Sets the RF IN/OUT Amplitude Offset State to On

NOTE
If the RF IN/OUT Amplitude Offset State is turned off , none of the amplitude offsets are on, even if values are entered for the individual offsets.

Examples of Amplitude Offset Behavior

When the amplitude offset table entries accurately represent the loss in all components (cabling, connectors, and test fixturing) in the signal path between the test set and the mobile station, the test set will make the necessary adjustments in both receiver and transmitter measurements.

Mobile Station Receiver Example

When you set a transmit power level, the test set uses the amplitude offset value to adjust the power so that the test set's transmit power level refers to the power level received at the mobile station.

As shown in Amplitude Offset Mobile Station Receiver Example , with the test set's transmit power set to -85 dBm and a -3 dB amplitude offset the actual power level transmitted from the test set will be automatically offset to -82 dBm. With a 3 dB loss in the signal path the mobile station will receive -85 dBm, the actual setting.

Amplitude Offset Mobile Station Receiver Example

Mobile Station Transmitter Example

When you measure power from the mobile station, the displayed and queried values are offset to show the level at the mobile station.

As shown in Amplitude Offset Mobile Station Transmitter Example , with the mobile station transmitting 12 dBm and a -3 dB amplitude offset is entered, the measured power at the test set would be 9 dBm. The displayed power level is automatically adjusted to 12 dBm to show the level at the mobile station.

If the expected power, which can be set manually or automatically is 12 dBm, the test set's internal hardware adjusts itself to receive 9 dBm which is the actual power from the mobile station after 3 dB loss in the network.

Amplitude Offset Mobile Station Transmitter Example

Amplitude Offsets Between Frequency Settings

If mobile station testing is performed at frequencies that do not have amplitude offsets assigned to them, the test set will estimate an amplitude offset based on the nearest settings. For example, the following screen shows five amplitude offsets for frequencies ranging from 890.2 MHz to 1710.2 MHz.

RF IN/OUT Amplitude Offset Setup

For test frequencies between the lowest (890.2 MHz) and highest (1710.2 MHz) frequency points that are not entered in the table, the test set will calculate offsets using piece-wise linear interpolation.

The graph shown in Amplitude Offset Interpolation is a conceptual representation of the test set's amplitude offset configuration using the settings from the RF IN/OUT Amplitude Offset table in RF IN/OUT Amplitude Offset Setup . Each of the five points are shown on a non-scaled frequency versus amplitude offset graph. At a test frequency of 890.4 MHz, which is midway between point number one (-1 dB) and point number two (-2 dB) the test set applies an offset of -1.5 dB. Be aware that since amplitude offsets are in units of dB, this piece-wise linear interpolation does not produce a linear transition from point to point.

Amplitude Offset Interpolation

If testing is done outside the range of frequencies bounded by the lowest and highest frequency entries, the test set simply uses the amplitude offset that is paired with the nearest frequency point.

IMPORTANT
It is highly recommended that amplitude offsets are set up for each test frequency. This eliminates inaccuracies due to the mismatch between the test set's linear interpolation and the actual frequency response of the RF path between the test set and mobile station.

Related Topics

SYSTem:CORRection


Test Application Name

Test Application Name

Last updated: October 28, 2004

Description

The following queries give you details about the application name. To query or switch applications you must use the application's name as it appears in the catalog (without regard to case).

  • To query the name of the all applications installed in the test set use this GPIB query.

OUTPUT 714;"SYSTEM:APPLICATION:CATALOG:NAME?"

  • To query the name of the selected application (running or not) use this GPIB query.

OUTPUT 714;"SYSTEM:APPLICATION:SELECT:NAME?"
  • To query the name of the currently running application use this GPIB query.

OUTPUT 714;"SYSTEM:APPLICATION:CURRENT:NAME?"

  • To query the number of applications installed in the test set use this GPIB query.

OUTPUT 714;"SYSTEM:APPLICATION:CATALOG:NAME:COUNT?"

The application names can also be displayed in the Application Setup menu on the test set's display.

Related Topics

SYSTem:APPLication


Test Application Revisions and Licenses

Test Application Revisions and Licenses

Last updated: June 20, 2006

Description

Different revisions of the applications in your test set provide different capabilities. The selected application revision is loaded after the next application switch or power cycle of the test set. Once you select a revision the revision does not change unless you select another revision.

You can query the selected revision, all available revisions, and the total count of available revisions for a selected application. These queries are helpful when selecting revisions but are not usually necessary when switching applications.

NOTE
The Agilent E1960A GSM Mobile Test Application revisions prior to A.04.00 do not support application switching. If you select a revision prior to A.04.00 you will not have a path to switch back to later revisions.

If you accidentally switch to a non-supported revision, use the firmware upgrade process to load firmware with the correct revision.

Application Revision Queries and Commands

These are commands to query revision information or select a revision.

  • To query a selected application revision (running or not) use this GPIB command:

OUTPUT 714;"SYSTEM:APPLICATION:SELECT:REVISION? `AMPS/136 MOBILE TEST'"
  • To query the revision of the application currently running use this GPIB command:

OUTPUT 714;"SYSTEM:APPLICATION:CURRENT:REVISION?"
  • To query all of the revisions available for a application use this GPIB command:

OUTPUT 714;"SYSTEM:APPLICATION:CATALOG:REVISION? `AMPS/136 MOBILE TEST'"
  • To select a revision of an application use this GPIB command:

OUTPUT 714;"SYSTEM:APPLICATION:SELECT:REVISION `GSM mobile test','A.04.01'"

    After switching to a different revision of your application, you may need to calibrate the test set. See the on-line reference guide for your application for more information.

  • To query the number of revisions for a specified application:

OUTPUT 714;"SYSTEM:APPLICATION:CATALOG:REVISION:COUNT? `GSM MOBILE TEST'"

Application License Status Query

The application license status can be queried for a particular application and revision using the following GPIB query:

OUTPUT 714;"SYSTEM:APPLICATION:CATALOG:LICENSE? `GSM mobile test','A.04.01'"

This query returns one of the following:

  • "LIC" - This revision of application appears to have a LICense. The application may have been developed before licensing and therefore needs no license.
  • "NLIC" - This application does not appear to have a license. Selecting a Not LICensed revision will result in an error +130.
  • "PART" - Some PART of the application does not appear to have a license.
  • "UNKN" - This application has UNKNown license status.

You can also query a list of all licensed applications, formats and features using the following GPIB query:

OUTPUT 714;"SYSTem:APPLication:CATalog:LICense:APPLication:ALL?"

NOTE
If you switch to a not licensed revision the test set will reboot to the SYSTEM CONFIG screen. You will be unable to select any other screen or make any measurements. Query or view the Application Setup menu to determine the licensed versions of applications available.

Revision and license information can be viewed and selected from the SYSTEM CONFIG screen, by selecting the Application Setup menu. Revisions are shown with their license status. After the revision number is a letter. That letter indicates the revision license status; Licensed "L", Not Licensed "N", or Unknown "U".

  • "L"- This revision of application appears to have a License. The application may have been developed before licensing and therefore needs no license.
  • "N" - This application does not appear to have a license. Selecting a Not licensed revision will result in an error +130.
  • "P" - Some Part of the application does not appear to have a license.
  • "U" - This application has Unknown license status.

Related Topics

Test Application Switching


Configuring System Time and Date

Configuring System Time and Date

Last updated: October 28, 2004

Description

The test set provides the following time and date settings:

  • Time

    This field provides entry of the local time in hours and minutes.

    The Universal Coordinated Time field will track changes made to the Time field.

  • Date

    This field provides entry of the local date.

  • Universal Coordinated Time (UTC)

    Also known as Zulu, Greenwich Mean Time, or UCT, this field provides entry of universal time in hours and minutes.

    The Time field will track changes made to the Universal Coordinated Time (UTC) field.

  • Universal Coordinated Time (UTC) Date
  • Time Zone

    The Time Zone field provides entry of a time offset to the universal coordinated time (UTC). Based on each new time zone setting and the current UTC, a new local time value is calculated and automatically entered into the Time field.

These features are accessed by pressing the SYSTEM CONFIG hardkey followed by the Instrument Setup ( F1 ) softkey.

Related Topics

SYSTem:DATE


Test Application Switching

Test Application Switching

Last updated: June 20, 2006

Description

Different radio formats (such as GSM, AMPS, CDMA 2000 or TIA/EIA 136) can be tested when additional applications are purchased from Agilent Technologies. The test set allows you to switch between different applications. A reboot is necessary to make a newly selected application functional. The reboot happens automatically when the you tell the test set to switch applications. Switching to another application takes about one minute.

Some radio formats are combined as fast switching applications. Switching formats in a fast switching application takes less than 2 seconds.

Application Switching GPIB Command

In order to switch to another application use this GPIB command:

OUTPUT 714;"SYSTEM:APPLICATION:SELECT:NAME `GSM MOBILE TEST'"

Sending this command causes the test set to reboot.

Application Revision and Licensing

Each application must have a valid license and revision to function. Licensed revisions of applications are available from Agilent Technologies.

It may take several seconds before revision, model, and name information is returned.

Application Switching Programming Example

This program example shows you how to switch to the GSM Mobile Test Application.

  1. Query the list of application names to get exact spelling of the GSM Mobile Test Application. This is not necessary if you already know the exact name.
  2. Query the test set to get a list of all revisions for "GSM Mobile Test." This is not necessary if you are not changing revisions.
  3. Select a revision of "GSM Mobile Test." This is required if you are changing revisions.
  4. Select the GSM test application. This will switch applications and cause the test set to reboot.

10    OUTPUT 714;"SYSTEM:APPLICATION:CATALOG:NAME?"
20    !Queries all of the application names
30    ENTER 714;N$
40    PRINT "The CATALOG names that are loaded are ";N$
50    OUTPUT 714;"SYSTEM:APPLICATION:CATALOG:REVISION? `GSM MOBILE TEST'"
60    !Queries all revisions of GSM MOBILE TEST
70    ENTER 714;Cat_rev$
80    PRINT "The revisions for the GSM Mobile Test Application are ";Cat_rev$
90    OUTPUT 714;"SYSTEM:APPLICATION:SELECT:REVISION `GSM MOBILE TEST','A.04.01'"
100   !Selects a revision
110   OUTPUT 714;"SYSTEM:APPLICATION:SELECT:NAME `GSM MOBILE TEST'"
120   !Switches the application to GSM MOBILE TEST
130   END

Related Topics

Test Application Revisions and Licenses


Timebase Description/Configuration

Timebase Description/Configuration

Last updated: October 28, 2004

Description

The time base source is selected by the test set, either an internal time base or an external source (if a suitable signal is detected) is used as the reference oscillator. If a 10 MHz +/- 100 ppm signal, that has an input level from 0 to +13 dBm is connected to the 10 MHz REF IN connector on the rear panel, the test set will automatically select the external timebase.

You can read the status window at the bottom of the test set display for the EXT REF indicator, or query the test set to verify if it is using an external time base or an internal time base. You may also query the test set to verify if the time base is locked. The reference oscillator functionality is controlled through the SYSTEM subsystem.

Example:

OUTPUT 714;"SYSTEM:ROSCILLATOR[:TIMEBASE]?" !returns INT or EXT
                                            !(internal or external) timebase.
OUTPUT 714;"SYSTEM:ROSCILLATOR:LOCKED?" !returns 1 or 0 (locked or unlocked)
                                        !condition for timebase

Related Topics

SYSTem:ROSCillator


Block Diagram

Block Diagram

Last updated: July 31, 2006

Description

RF Interface Module

Input and output signals are routed through the RF Interface module. The RF Interface module consists of:

  • A directional bridge for sampling incoming power.
  • Hybrid power splitters which create 4 bidirectional ports (two receiver ports and two source ports). The directional bridge couples power to the Power Detector.
  • RF amplifiers.
  • Video gain circuits.
  • Fast and thermal power detectors.

The RF Interface module provides two identical RF Source path connections to the In/Out port of the instrument. There is about 25 dB of isolation between the two source paths. There is about 35 dB of isolation between the source paths and either receiver path. The RFIO module has nominally 23 dB of insertion loss in the source path. A temperature sensing circuit facilitates compensation for path loss variation with temperature.

The source signals can be looped back through the input signal path to cross-calibrate the Measurement Downconverter and the Power Detector.

The sampled input power from the directional bridge can be amplified by as many as two 18 dB range amplifiers and then can be directed to the fast detector or the thermal detector. The input power to the fast detector is detected by a diode detector that is part of a feedback loop. The input to the thermal detector is measured in a bridge using a pair of RMS thermal detectors in a feedback loop.

Signal Downconversion

The test set's downconversion receiver section has two downconversion modules; a Measurement Downconversion Module for making measurements, and a Demodulation Downconversion Module for maintaining the radio link.

Demodulation Downconverter Module

The Demodulation Downconverter module is used as part of the demodulation receiver that maintains the radio link.

Measurement Downconverter Module

The Measurement Downconverter module provides high quality (wide dynamic range, spurious free) signals to the Analog To Digital Converter module's measurement sampler input.

The Measurement Downconverter module is designed for very high performance operation to ensure accurate and repeatable measurement results. The Measurement Downconverter module contains two downconversion stages, two local oscillators, and a logarithmic IF envelope detector . Both first and second LO synthesizers are tunable. The first LO is used when tuning to the RF input frequency, and the second LO is used when setting second IF frequency, which is fed to the measurement sampler on the Analog To Digital Converter module.

Link Subsystem

The Link Subsystem maintains the radio link for all CDMA formats. The Link Subsystem has two parts:

  • Protocol Processor
  • Optional Link Subsystem hardware

The Protocol Processor module is responsible for maintaining the radio link between the test set and the mobile station under test. The primary tasks of the Protocol Processor module are:

  • Generating the protocol messaging necessary for the forward channel and sending that protocol stream to the test set's RF source for transmission to the mobile station.
  • Decoding the protocol messaging received from the mobile station under test on the reverse channel.
  • Computing measurement results which are associated with data bits contained within the mobile stations messaging, such as bit error ratio and frame error rate.

The optional Link Subsystem hardware provides additional signaling link control for CDMA signaling formats. These include:

  • Layer 1 digital signal processing.
  • Providing I/Q baseband signals which are sent to the I/Q modulator in the RF Source

Analog To Digital Converter Module

Following the Measurement Downconverter and Demodulation Downconverter IF 1 is the Analog to Digital Converter module. The purpose of the Analog to Digital Converter module is to convert the downconverted analog signals into digital data streams which can be processed by the Digital Signal Processing module.

In order to maintain the radio link of non-CDMA formats, the downconversion path through the Demodulation Downconverter module has a dedicated A/D conversion path.

To optimize measurement throughput, the fast RF power detector also has a single dedicated A/D path. This allows power measurements, in many cases, to be made concurrently with other measurements. The two outputs from the Measurement Downconverter module and the Audio In signal share a single multiplexed A/D path.

The outputs of the various analog to digital converters on the Analog to Digital Converter module share a common data bus with the Digital Signal Processing module.

Digital Signal Processing Module

The Digital Signal Processing (DSP) module is responsible for a variety of tasks within the overall test set architecture. These tasks are:

  • Demodulate data from the radio under test (data received from the Demodulation Downconverter module) and sending the demodulated data bits to the Protocol Processor module.
  • For some systems, perform audio measurements using audio information sent to the DSP module from the Protocol Processor module.
  • Execute a variety of signal processing algorithms to perform measurements on the radio system of the currently loaded TA (data received from the power detector ADC, the measurement ADC and, in some cases, data received from the Demodulation Downconverter ADC).

The DSP processor communicates with the Host Processor and the Protocol Processor, as well as controlling the configuration and synchronization of the Analog To Digital Converter module.

Host Processor Module

The Host Processor module is responsible for a variety of tasks within the overall test set architecture. These tasks include:

  • Control of the manual user interface (MUI).
  • Executing commands and processing data received from the LAN interface.
  • Executing commands and processing data received from the GPIB interface.
  • Controlling hard disk access.
  • Control of all RF and audio hardware modules.
  • Routing measurement results received form the Digital Signal Processing and Protocol Processor modules to the appropriate output device (display, GPIB, LAN, serial, etc.).

Voltmeter/Counter

Voltmeter

The voltmeter is used to measure internal voltages for instrument self-diagnostics.

Frequency Counter

The Frequency Counter is used to measure external frequencies from the front panel Audio IN, High or Low BNC connectors, and to measure internal signals for diagnostics. The external input can receive a signal between 20 Hz and 50 MHz, with a level from 25 mV to 8 V rms.

Audio Section

Audio Analysis Path

Externally applied audio signals can be analyzed through the test set's DSP module for such characteristics as AC level, SINAD, or distortion.

The audio signal to be analyzed is input to the test set using the front panel Audio IN High/Low connectors. The signal is then routed to the Analog To Digital Converter module's measurement sampler for analysis by the DSP module.

The Audio In connector accepts signals from 20 Hz to 15 KHz, at input levels from 10 mV to 20 V peak.

Audio 1 Path

The Audio 1 path provides analog baseband signals used for frequency modulation of the test set's RF sources. Up to four separate audio sources may be summed together in any combination to provide the composite Audio 1 output. These include the external FM input, internal direct digital synthesis (DDS,) regenerated SAT, and audio echo input.

The external FM input accepts an externally supplied audio signal with a peak voltage between 0.25 and 2 V peak.

The internal DDS generates low distortion audio signals from DC to 20 KHz with 0.1 Hz resolution. One to four signals may be generated and internally summed, with independent level control of each waveform.

The SAT regeneration circuit outputs a signal which is phase-locked to a received SAT signal. This is useful for testing situations where the test set needs to emulate a mobile station.

The audio echo input is used for retransmitting the received audio after a selectable time delay, to check both radio transmit and receive paths simultaneously.

For most applications, only one or two of these Audio 1 path sources are enabled at any given time.

Audio 2 Path

The Audio 2 path provides a secondary means for sending analog baseband signals to the FM modulator. Audio 2 contains only one source, a DDS similar to that used for Audio 1.

Typically, the Audio 2 path DDS is used for cases where multiple signals must be summed together with the lowest possible distortion. Another potential use of Audio 2 would be to obtain higher output levels than Audio 1 is capable of (up to twice as much), assuming the two outputs are set to the same frequency and phase, and then summed together at the Baseband Generator module.

Audio 2 is rarely used in practice because the DDS used for Audio 2 is the same DDS that is used for the front panel audio output.

Audio Out Path

Any one of four inputs may be coupled to the front panel audio output connector. These include a 4 channel DDS (shared with Audio 2), receiver discriminator audio from the Demodulation Downconverter module, audio echo from the Analog To Digital Converter module, and audio vocoder.

The front panel output is capable of providing signal levels up to 9 V peak into > 600 ohm loads, and up to 0.8 V peak into an 8 ohm load (e.g. speaker). The output level is calibrated for all modes except discriminator audio,
The discriminator audio has an uncalibrated volume control provided due to the high tolerances involved.

Typically the DDS mode is used to feed the MIC input of a radio, or it may simply be used as a general purpose low distortion function generator.

Audio echo can be selected to route the received audio to the front panel audio output connector.

RF Sources

The test set has up to two identical RF sources. The RF sources are used to provide analog or digitally modulated RF carriers for use in parametric testing of mobile stations encompassing a variety of cellular radio formats. In general, the sources have a frequency range of 292 MHz to 2.7 GHz and an amplitude range of -10 dBm to -127 dBm.

The RF sources consist of a Synthesized Signal Generator module followed by a Vector Output module and an RF Attenuator module. Baseband modulation information is supplied to the RF sources from a Baseband Generator module preceded by an Audio Section module.

Baseband Generators

The purpose of the Baseband Generator module is to provide, for the modulation type currently in effect, properly formatted baseband signals to the modulation circuits on the RF Source modules.

The Baseband Generator performs several functions related to the generation and processing of these base-band modulation signals. These are:

  • Transform data and clock signals from the Protocol Processor module into base-band analog I/Q modulation signals for the I/Q modulator in the Vector Output module
  • Transform data from the Protocol Processor module into baseband FSK modulation for the FM modulator in the Signal Generator module
  • Provide baseband FM path source selection, gain adjustment and summing node for analog FM signals from the Audio module and internally generated baseband FSK signals which are output to the FM modulator in the Signal Generator module
  • Transform burst and adjacent timeslot signals from the Protocol Processor module into baseband burst modulation signals for the burst modulator in the Vector Output module


Setting Access Parameters

Setting Access Parameters

Last updated: October 28, 2004

The Access Channel (R-ACH) is used by the mobile station to initiate communication with the base station or to respond to a mobile station directed messages. When the test set supports Access Channels (R-ACH) (see Control Channels Configuration ), the following access parameters can be specified and included in the Access Parameters Message ( Settable Fields in Overhead Messages ) sent to the mobile station on the Paging Channel.

If the mobile station uses Enhanced Access Channels (R-EACH) to initiate communication with the test set or to respond to a mobile station directed messages, the test set should be configured to support R-EACH (see Setting Enhanced Access Parameters for details).

IS-2000/IS-95 Access Parameters

The following access parameters are displayed under the Access Parameters menu (see C. Access Parameters or Enhanced Access Parameters ) when the following two conditions exist:

  1. The Operating Mode field is set to Active Cell (see Active Cell Operating Mode ) or Cell Off, and
  2. IS-2000 or IS-95 is selected in the System Type field.
  • Nominal Power (NOM_PWR in the standards): an offset to the mobile station open loop power estimate to accommodate maximum transmit power of the cell. This parameter affects the initial access probe power level by introducing correction factors to the open loop estimate calculated by the mobile station. See CALL[:CELL]:APARameter:POWer:NOMinal[:OFFset] .
  • Nominal Power Extended (NOM_PWR_EXT in the standards): an offset to the mobile station open loop power estimate to accommodate maximum transmit power of the cell. It is not applied in some band such as band classes 0 and 3. This parameter affects the initial access probe power level by introducing correction factors to the open loop estimate calculated by the mobile station. See CALL[:CELL]:APARameter:POWer:NOMinal:EXTended .
  • Initial Power (INIT_PWR in the standards): an offset to the mobile station open loop power estimate for the first access probe in the access probe sequence. This parameter affects the initial access probe power level by introducing correction factors to the open loop estimate calculated by the mobile station. See CALL[:CELL]:APARameter:POWer:INITial .
  • Power Step (PWR_STEP in the standards). This parameter specifies the step increase in mobile station transmit power between each access probe within an access probe sequence. See CALL[:CELL]:APARameter:POWer:STEP[:LEVel] .
  • Number of Steps (NUM_STEP in the standards): This parameter specifies the number of steps in one access probe sequence. See CALL[:CELL]:APARameter:POWer:STEP:COUNt .
  • Maximum Request Sequence (MAX_RESP_SEQ in the standard): This parameter specifies the maximum number of access probe sequences for an access channel request (see CALL[:CELL]:APARameter:SEQuence:REQuest[:MAXimum] ).
  • Maximum Response Sequence (MAX_RSP_SEQ in the standard): This parameter specifies the maximum number of access probe sequences the mobile station will transmit in response to a paging channel request (see CALL[:CELL]:APARameter:SEQuence:RESPonse[:MAXimum] ).
  • Preamble Size (PAM_SZ in the standards). (see CALL[:CELL]:APARameter:PREamble )

Related Topics

GPIB Commands: CALL:APARameter

Manual Operation: C. Access Parameters or Enhanced Access Parameters


Active Cell Operating Mode

Active Cell Operating Mode

Last updated: March 9, 2005

Active Cell mode is the test set's default operating mode, and is used to emulate a base station transceiver in a real network. Over-the-air signaling between the mobile station and the base station emulator is used for call origination, handoffs, and other operations that simulate in-service mobile interaction.

When Active Cell is selected, and a call is connected, the test set is able to automatically handle most operations required for measurements such as demodulation of the reverse channel, tuning to the correct frequency, adjusting the receiver for the expected power from the mobile station, and automatically triggering on events related to signaling protocol. Measurements can be selected by pressing the Measurement selection hardkey.

To select an operating mode for test set, see Selecting an Operating Mode .

Active Cell Features

The basic features provided by active cell operating mode are:

  • Call setup and disconnection, both mobile station originated and test set originated (paging).
  • Hard handoffs between different systems, frequency bands and physical RF channels.
  • Soft/Softer handoffs ( cdma2000 Lab Application only ).
  • Voice echoing through the mobile's earpiece.
  • Service option negotiation during access or call connected states.
  • Mobile station reported information, such as mobile station parameters.
  • Closed loop power control.
  • Registration controls (zone-based, timer-based, and power up registration control). See Setting Registration Parameters .
  • Status Request Query controls. See Paging IMSI Setup .
  • Change of code channel parameters (PN offset, code channel levels, code channel walsh codes). See Configuring Forward Channel Power Levels and Walsh Codes .
  • Selection of radio configuration (available for IS-2000 system). See Radio Configuration .
  • Selection of service options (voice echo or data loopback). See Service Option .
  • Automatic or manual frequency control and power ranging of the test set's receiver. See Receiver Control .

  • Voice echo time delay controls. See Configuring the Forward Fundamental/Traffic Channel (F-FCH/Traffic) .

  • Selection of audio tones (echo or variable vocoded tones) for voice service options. See Configuring the Forward Fundamental/Traffic Channel (F-FCH/Traffic) .
  • Selection of signal for output at front-panel AUDIO OUT connectors. See Configuring the Test Set's AUDIO OUT port .

Related Topics

IS-2000 Test Operating Mode

AVC Test Operating Mode

CW Operating Mode

CALL:OPERating

CALL:SYSTem

CALL:STATus:CELL:SYSTem[:TYPE]?


Authentication Information Screen

Authentication Information Screen

Last updated: June 20, 2006

This section is only applicable to the lab application and to a test application with the required feature license.

The Authentication Information screen provides the detailed test results for the Global Challenge, Unique Challenge and SSD Update when performed, as well as the authentication parameters associated with the last authentication.

To access the Authentication Information screen, press the Authentication ( F2 ) on the Call Control 3 of 3 (in the Test Application) or Call Control 3 of 5 (in the Lab Application). It consists of four windows:

  • Global Challenge Information
  • Unique Challenge Information
  • SSD Update Information
  • Authentication Parameters

Global Challenge Information

The Global Challenge Information window provides the detailed test results associated with a Global Challenge Operation .

  • Global Challenge Type

    Indicates the type of the Global Challenge authentication that is performed. It is determined according to the access channel messages received. It can be Origination, Page Response, Data Burst, or Registrations (such as Power Up, Timer based, Zone based registrations) Global Challenge.

    GPIB Command: CALL:SECurity:AUTHenticate:GCHallenge:TYPE?

  • Global Challenge Overall Result

    Indicates the overall pass/fail result for the Global Challenge authentication that is performed. The Global Challenge result indicates Pass only when all of the AUTHR, RANDC, Call History and AUTH_MODE results are Pass (see Result values (pass/fail) ).

    GPIB Command: CALL:SECurity:AUTHenticate:GCHallenge:RESult?

  • Expected values

    This column provides the global challenge authentication data calculated and maintained by the test set. They are compared with the Received values to verify whether the global challenge authentication passes or fails.

    • Expected AUTHR (Hex)

      Indicates the value of authentication response AUTHR, which is calculated by the test set in the same manner that the MS does, but using its internal stored parameters such as SSD_A value, RAND, etc. See Computation of AUTHR .

      GPIB Command: CALL:SECurity:AUTHenticate:GCHallenge:RESPonse:EXPected?

    • Expected RANDC (Hex)

      Indicates the eight most significant bits (first two hexadecimal digits) of the RAND you specified on the Global Challenge Random (RAND) (Hex) field.

      GPIB Command: CALL:SECurity:AUTHenticate:GCHallenge:CRANdom:EXPected?

    • Expected Call History (COUNT)

      Indicates the expected value of call history parameter. It is empty (non-available) when the test set powers up or fully preset.

      When the Global Challenge is set to On, each time a registration is performed, the test set compares the received COUNT with the Expected COUNT to determine the COUNT pass/fail result. After the comparison, the test set will set the Expected COUNT value to the Received COUNT value for the next global challenge.

      NOTE
      The Expected COUNT is empty (non-available) in the first registration global challenge. The COUNT result indicates Fail until the next registration when an Expected COUNT value is available.

      When Global Challenge is set to On, each time a call is established, the test set sends a Parameter Update Order message to the MS. Upon receiving the Parameter Update Order message, the MS increases its internal stored COUNT value by one. If the test set receives the Parameter Update Confirmation Order message from the MS, the test set increases its internal stored COUNT value by one.

      NOTE
      The test set does not prompt a warning message if the MS rejects the Parameter Update Order message or the test set fails to receive the response before timeout expires. This may cause the next global challenge authentication fails due to the mismatched COUNT values stored in the test set and MS.

      GPIB Command: CALL:SECurity:AUTHenticate:GCHallenge:CHIStory:EXPected?

    • Expected AUTH_MODE: Indicates the authentication mode specified in the test set. When the Global Challenge is set to On, this value equals 1. When the Global Challenge is set to Off, this value equals 0 (zero).

      GPIB Command: CALL:SECurity:AUTHenticate:GCHallenge:MODE:EXPected?

  • Received values

    This column provides the global challenge authentication data received in the Registration Message , Origination Message , Page Response Message , or the Data Burst Message from the MS. They are used to compare with the Expected values to verify whether the global challenge authentication passes or fails.

    • Received AUTHR (Hex)

      Indicates the value of authentication response AUTHR, calculated by the MS using the Auth_Signature procedure with its internal stored parameters such as the SSD_A, ESN, IMSI_S1 or Dialed Digits, and RAND as the input parameters. See Computation of AUTHR .

      GPIB Command: CALL:SECurity:AUTHenticate:GCHallenge:RESPonse:RECeived?
    • Received RANDC (Hex)

      Indicates the eight most significant bits of the RAND which is obtained in the Access Parameters Message or ANSI-41 RAND Message from the test set.

      GPIB Command: CALL:SECurity:AUTHenticate:GCHallenge:CRANdom:RECeived?

    • Received Call History (COUNT)

      Indicates the value of call history parameter (COUNT), which is a modulo-64 event counter maintained by the MS used for clone detection. It is updated by the MS when a Parameter Update Order is received. See Expected Call History (COUNT) for details.

      GPIB Command: CALL:SECurity:AUTHenticate:GCHallenge:CHIStory:RECeived?

    • Received AUTH_MODE: Indicates the authentication mode used by the MS.

      GPIB Command: CALL:SECurity:AUTHenticate:GCHallenge:MODE:RECeived?

  • Result values (pass/fail)

    This column provides the pass/fail.result for each global challenge authentication data: AUTHR, RANDC, COUNT and AUTH_MODE, indicating whether each received value matches the expected value. The Global Challenge Overall Result indicates Pass only when all of these results indicate Pass.

    GPIB Command: CALL:SECurity:AUTHenticate:GCHallenge:RESPonse:RESult? , CALL:SECurity:AUTHenticate:GCHallenge:CRANdom:RESult? , CALL:SECurity:AUTHenticate:GCHallenge:CHIStory:RESult? , CALL:SECurity:AUTHenticate:GCHallenge:MODE:RESult?

Unique Challenge Information

The Unique Challenge Information window provides the detailed test results associated with a Unique Challenge Operation .

  • Unique Challenge Type

    Indicates the type of the Unique Challenge authentication. It is determined according to the channel on which the Authentication Challenge Message is set. It can be Paging Channel, Control Channel or Traffic Channel Unique Challenge.

    • If the Unique Challenge Operation is performed in idle state, the Authentication Challenge Message is sent on the paging channel if the current control channel is F-PCH/R-ACH or on the common control channel if the current control channel is F-BCCH/F-CCCH/R-EACH (see Control Channel Configuration ).
    • If the Unique Challenge Operation is performed while in a call, the Authentication Challenge Message is sent on the traffic channel.

    GPIB Command: CALL:SECurity:AUTHenticate:UCHallenge:TYPE?

  • Unique Challenge Result

    Indicates the pass/fail result of the associated Unique Challenge authentication. It indicates Pass when the AUTHU Result is Pass.

    GPIB Command: CALL:SECurity:AUTHenticate:UCHallenge:RESult?

  • Expected AUTHU CALL:SECurity:AUTHenticate:UCHallenge:RESPonse:RESult?

    Indicates the value of AUTHU, which is calculated by the test set in the same manner that the MS does, but using its internal stored parameters (RANDU, SSD_A, ESN, IMSI_S1 and IMSI_S2). See Computation of AUTHU .

    GPIB Command: CALL:SECurity:AUTHenticate:UCHallenge:RESPonse:EXPected?

  • Received AUTHU

    Indicates the value of AUTHU, which is calculated by the MS using the Auth_Signature procedure with its internal stored parameters (RANDU, SSD_A, ESN, IMSI_S1 and IMSI_S2). It is sent to the test set in the Authentication Challenge Response Message during a Unique Challenge Operation .

    GPIB Command: CALL:SECurity:AUTHenticate:UCHallenge:RESPonse:RECeived?

  • AUTHU Result

    Indicates whether the Received AUTHU matches the Expected AUTHU . If the values match, the AUTHU result indicates Pass. Otherwise, the result is Fail.

    GPIB Command: CALL:SECurity:AUTHenticate:UCHallenge:RESPonse:RESult?

SSD Update Information

The SSD Update Information window provides the detailed test results associated with an SSD Update Operation .

  • SSD Update Type - Indicates the type of the SSD Update operation. It is determined according to the channel on which the SSD Update Message is sent. It can be Paging Channel, Control Channel or Traffic Channel SSD Update.
    • If the SSD Update Operation is performed in idle state, the SSD Update Message is sent on the paging channel if the current control channel is F-PCH/R-ACH or on the common control channel if the current control channel is F-BCCH/F-CCCH/R-EACH (see Control Channel Configuration ).
    • If the SSD Update Operation is performed while in a call, the SSD Update Message is sent on the traffic channel.

    GPIB Command: CALL:SECurity:AUTHenticate:SUPDate:TYPE?

  • SSD Update Result: Indicates whether the SSD Update Operation is performed successfully.

    GPIB Command: CALL:SECurity:AUTHenticate:SUPDate:RESult?

Authentication Parameters

This window provides the authentication parameters that are used by the test set to calculate the expected AUTHR, expected AUTHU, or the AUTHBS for the related authentication operations. The A-Key, RAND, RANDU, RANDSSD can be set from the Setting Authentication Parameters menu.

  • A-Key/Check Digits (Dec)

    Indicates the A-Key you entered on the test set (see A-Key (Dec) ) and the Check Digits generated by the test set.

    • If the current Cell Band is not Korean PCS and the ESN is reported on the Mobile Reported Information screen, the test set will generate the correct 6 decimal check digits based on the A_Key and ESN using the CAVE algorithm.
    • If the current Cell Band is not Korean PCS and the ESN is not available, the check digits will be Null.
    • If the current Cell Band is Korean PCS, the test set will generate the correct 6 decimal check digits based on the A_key using LGIC algorithm.
    • If the current Cell Band is not Korean PCS, the check digits will be regenerated whenever the A_Key or the ESN is updated.
    • Switching the Cell Band between Korean PCS and other bands results in the check digits regenerated.

    The check digits are part of the A-Key and provide a method for checking A-Key validity. For example, compare the check digits generated by the test set with the last 6 digits of the MS's A-Key. If they do not match, one of the A-Key is invalid.

    GPIB Command: CALL:SECurity:AUTHenticate:SUPDate:AKEY , CALL:SECurity:AUTHenticate:SUPDate:CDIGits? )

  • SSD_A = 0

    When the SSD_A value in the test set is zero, the SSD_A=0 indicates True. Otherwise, it will be False.

    • When the test set powers up or fully presets, or whenever you enter a new A-Key value (see A-Key (Dec) ) into the test set, the SSD_A value in the test set is initialized to zero and SSD_A=0 indicates True.
    • When an SSD Update Operation is successfully performed, SSD_A is updated to a new value and the SSD_A=0 indicates False.

    GPIB Command: CALL:SECurity:AUTHenticate:SSDA:ZERO?

  • RAND (Hex)Indicates the random challenge data used in the Global Challenge Operation . It is corresponding to what you set on the Global Challenge Random (RAND) (Hex) field.

    GPIB Command: CALL:SECurity:AUTHenticate:GCHallenge:RANDom

  • RANDU (Hex)

    Indicates the random challenge data used in the Unique Challenge Operation . It is corresponding to what you set on the Unique Challenge Random (RANDU) (Hex) field.

    GPIB Command: CALL:SECurity:AUTHenticate:UCHallenge:RANDom

  • RANDSSD (Hex)

    Indicates the random data used in SSD Update Operation . It is corresponding to what you set on the SSD Update Random (RANDSSD) (Hex) field.

    GPIB Command: CALL:SECurity:AUTHenticate:SUPDate:RANDom

  • ESN (Hex)

    Indicates the MS's electronic serial number (ESN) obtained via MS registration (see Mobile Reported Information ). Authentication procedures rely on ESN to generate valid A-Keys and other values used for checking the validity of the SSD_A.

    GPIB Command: CALL:MS:REPorted:ESNumber:HEX?

  • IMSI_S2/IMSI_S1 (Dec)

    An IMSI_S, a 10-digit (34-bit) number, consists of 3- and 7-digit parts that are called IMSI_S2 and IMSI_S1 respectively.

    The IMSI_S2 and IMSI_S1 are used for AUTHR, AUTHU and AUTHBS calculations during the Global Challenge Operation , Unique Challenge Operation , and SSD Update Operation .

    IMSI_S is derived from the IMSI. When the MS registers to the test set, the IMSI is displayed on the Mobile Reported Information screen. When an IMSI has ten or more digits, IMSI_S is equal to the last ten digits. When an IMSI has fewer than ten digits, the least significant digits of IMSI_S are equal to the IMSI and zeros are added to the most significant side to obtain a total of ten digits.

    GPIB Command: CALL:STATus:PAGing:IMSI:S1? , CALL:STATus:PAGing:IMSI:S2?

Related Topics

Authentication Overview

Setting Authentication Parameters

How Do I Perform Authentication Tests?

Authentication Troubleshooting

CALL:SECurity


Performing Authentications

Performing Authentications

Last updated: June 20, 2006

This section is only applicable to the lab application and to a test application with the required feature license.

  • Authentication Overview
  • Setting Authentication Parameters (A-Key, RAND, RANDU, etc.)
  • Authentication Information Screen
    • Global Challenge Information
    • Unique Challenge Information
    • SSD Update Information
    • Authentication Parameters
  • How Do I Perform Authentication Tests?
  • Authentication Troubleshooting
  • GPIB Command CALL:SECurity


Authentication Overview

Authentication Overview

Last updated: June 20, 2006

This section is only applicable to the lab application and to a test application with the required feature license.

  • Overview
  • Global Challenge Operation
  • Unique Challenge Operation
  • SSD Update Operation

Overview

Authentication is the process by which information is exchanged between a mobile station (MS) and a base station (BS) for the purpose of confirming the identity of the MS. A successful outcome of the authentication process occurs only when it can be demonstrated that the MS and BS possess identical sets of Shared Secret Data (SSD).

The SSD is a 128-bit pattern stored in the MS and known by the BS. SSD consists of two 64-bit subsets: SSD_A used for authentication procedures and SSD_B used to support voice privacy and message encryption.

NOTE
The test set does not support voice privacy and message encryption. So, only the SSD_A is useful in the test set.

The SSD_A value is not directly accessible either from the test set display or via GPIB commands. This is compliant with the authentication standard.

The Authentication Key (A-Key) Generation, SSD Generation and Update, Authentication Signature Calculation procedures as specified in the standard, are implemented in the test set to support for the authentication tests. Also, the test set can automatically apply the appropriate encryption algorithm to these procedures according to the current Cell Band, LGIC algorithm for Korean PCS band and CAVE algorithm for all other bands.

The test set supports the following authentication operations:

  • Global Challenge Operation (using Authentication Signature procedure to calculate AUTHR)
  • Unique Challenge Operation (using Authentication Signature procedure to calculate AUTHR)
  • SSD Update Operation (using SSD generation procedure to generate SSD_A_NEW and Authentication Signature procedure to calculate AUTHBS)

The parameters used during authentication tests are described in the Setting Authentication Parameters . The Authentication Information Screen provides the authentication results associated with these operations. For detailed operating procedures, see How Do I Perform Authentication Tests? .

Global Challenge Operation

The Global Challenge is a type of authentication implemented in the authentication sub-layer of LAC (Link Access Control layer) (see 3GPP2 C.S0004-A-2 standard), which can be viewed as related to access. It is used to verify that the MS can successfully perform a registration, origination, paging response with authentication parameters that match the values expected by the test set.

The following figure illustrates the primary message flow during a Global Challenge operation.

Global Challenge Message Flow

  1. Activate the authentication mode by setting the Global Challenge ( F2 ) to On . The test set will signal the MS to go into authentication mode (AUTH = 01) and use the specified RAND value for authentication when registrations, call originations, pages or data bursts are performed.
    • if the current control channel is F-PCH/R-ACH (see Control Channel Configuration ), the test set sends the Access Parameters Message with the authentication parameters (AUTH = 01, RAND = Global Challenge Random (RAND) (Hex) ) to the MS.
    • if the current control channel is F-BCCH/F-CCCH/R-EACH (see Control Channel Configuration ), the test set sends the MC-RR Parameters Message with SENDING_RAND = 01 and the ANSI-41 RAND Message with RAND = Global Challenge Random (RAND) (Hex) to the MS.
  2. The MS calculates the value of AUTHR using the Auth_Signature procedure with its internal stored ESN, IMSI_S1 or Dialed Digits, the SSD_A, and the received RAND as the input parameters (see Computation of AUTHR ).
    Computation of AUTHR
  3. The MS may send the Registration Message (while performing a registration), or the Origination Message (while originating a call), or the Page Response Message (while responding to a page), or the Data Burst Message (such as sending an SMS) to the test set that contains the authentication parameters (AUTHR, RANDC, COUNT, and AUTH_MODE). See Received values for their description.

    NOTE
    The TMSI Assignment Completion Message , PACA Cancel Message , Device Information Message and Security Mode Request Message are not supported in the test set.

  4. Upon receiving any of these messages, the test set calculates the value of AUTHR in the same manner that the MS does, but using its internal stored SSD_A value, ESN, IMSI_S1 or last six digits of MS Called Party Number, and the RAND as the input parameters.
  5. The test set compares its calculated AUTHR to that received from the MS. The test set also compares the received RANDC to the expected RANDC (the first 8 bits of the specified RAND), as well as the received COUNT and AUTH_MODE to the expected values. Only all of these comparisons match, the authentication passes. The test set then displays these authentication results on the Global Challenge Information window.

    NOTE
    The authentication result does not impact the normal call processing (registration, call connection). For example, a call can be connected even if the authentication fails. Please note that this behavior is different from the standard, but provides more flexibility to perform other MS tests in the event that the authentication test fails.

Unique Challenge Operation

The Unique Challenge operation is initiated by the test set and can be performed either in idle state or in a call. It is used to test the MS's ability to send the test set a parameter that indicates it has SSD_A identical to that of the test set.

The following figure illustrates the primary message flow of a Unique Challenge operation.

Unique Challenge Message Flow

  1. Start the Unique Challenge operation by pressing the Unique Challenge ( F3 ) key either in idle state or in a call.
  2. The test set sends the Authentication Challenge Message with the specified RANDU (see Unique Challenge Random (RANDU) (Hex) ) to the MS either on the control channel or the traffic channel.
  3. Upon receiving the Authentication Challenge Message , the MS calculates the AUTHR using the Auth_Signature procedure with its internal stored ESN, IMSI_S1, IMSI_S2, the SSD_A, and the received RANDU as the input parameters (see Computation of AUTHU ), and then sends the Authentication Challenge Response Message including the AUTHU parameter to the test set.
    Computation of AUTHU
  4. Upon receiving the Authentication Challenge Response Message , the test set calculates the value of AUTHR in the same manner that the MS does, but using its internal stored SSD_A value, ESN, IMSI_S1, IMSI_S2, and the RANDU.
  5. The test set compares its calculated AUTHU to the value received from the MS. If the values match, the unique challenge authentication passes. The test set then displays these results on the Unique Challenge Information window.

    NOTE
    The authentication result does not impact the normal call processing (registration, call connection). For example, a call can be connected even if the authentication fails. Please note that this behavior is different from the standard, but provides more flexibility to perform other MS tests in the event that the authentication test fails.

SSD Update Operation

The SSD update is initiated by the test set and can be performed either in idle state or in a call. It is used to test the MS's ability to synchronize SSD_A with the test set and ensures that the MS and the test set have identical copies of SSD_A.

The following figure illustrates the primary message flow of an SSD Update operation.

SSD Update Message Flow

  1. Start the SSD update by pressing the SSD Update ( F4 ) either in idle state or in a call.
  2. The test set sends the SSD Update Message including the specified RANDSSD parameter (see SSD Update Random (RANDSSD) (Hex) ) to the MS either on the control channel or the traffic channel.
  3. Both MS and test set calculate a new SSD result (SSD_A_NEW) using the SSD_Generation procedure with the RANDSSD, its internal stored ESN and A-Key as the input parameters (See Computation of SSD ).
    Computation of SSD
  4. The MS also selects a 32-bit random number RANDBS and sends it to the test set in a Base Station Challenge Order message .
  5. Both MS and test set calculate the AUTHBS using the Auth_Signature procedure with the RANDBS, its internal stored ESN and IMSI_S1, and its generated SSD_A_New as the input parameters (See Computation of AUTHBS ).
    Computation of AUTHBS
  6. The test set sends its computed AUTHBS in a Base Station Challenge Confirmation Order message to the MS.
  7. Upon receiving the Base Station Challenge Confirmation Order message, the MS compares the received AUTHBS to its internally calculated value. If the values match, the MS executes the SSD_Update procedure to set SSD_A to SSD_A_NEW and then send an SSD Update Confirmation Order message to the test set, indicating successful completion of the SSD update. If the values do not match, the MS discards SSD_A_NEW and then sends an SSD Update Rejection Order message to the test set, indicating unsuccessful completion of the SSD update. The SSD Update result is displayed on SSD Update Information Window screen (See SSD Update Information )

Related Topics

Setting Authentication Parameters

Authentication Information Screen

How Do I Perform Authentication Tests?

Authentication Troubleshooting

CALL:SECurity


Setting Authentication Parameters

Setting Authentication Parameters

Last updated: November 14, 2006

This section is only applicable to the lab application and to a test application with the required feature license.

All of the parameters used during authentication operations can be configured from the Authen Ctrl menu. To access the Authen Ctrl menu, press the Authentication ( F2 ) on the Call Control 3 of 3 (in the Test Application) or Call Control 3 of 5 (in the Lab Application).

  • A-Key (Dec)

    It is used to enter the MS's A-Key value into the test set. A-Key is a secret, 64-bit pattern stored in the mobile station (MS). It is used to generate/update the MS's Shared Secret Data (SSD).

    The A-Key value is entered as a 20 decimal digits. When you enter a value into the A_key field, the test set initializes its internal SSD_A to all zeroes (SSD_A=0 indicates True) and generates a 6 decimal check digits, which are displayed on the Authentication Parameters window.

    The Global Challenge Operation and Unique Challenge Operation require the SSD_A value in the test set and the MS to be identical, which can be performed in either of the following ways:

    • Initialize SSD_A in both the test set and MS to zeroes by changing their A-Keys. It is recommended that you set the A-Keys in the test set and MS to the same values. However, any valid A-Keys (even different) will work since entering an A-Key will set the SSD_A to zero.
    • If you can not change MS's A-Key, but you know what it is, enter the exact A-Key on the test set, then perform SSD Update Operation to synchronize the SSD_A values between the test set and MS. If you even do not know the MS's A-Key, try the zero value, since A-Key in many mobile stations is initially programmed to zero until re-programmed by the service provider. You must set this field to the value of the A-key that is stored in the MS. Otherwise, the SSD Update Operation will fail.

    GPIB Command: CALL:SECurity:AUTHenticate:SUPDate:AKEY

  • Global Challenge Random (RAND) (Hex)

    Sets the 32-bit random challenge data (entered as an 8-digit hexadecimal value) used to calculate the AUTHR during Global Challenge Operation .

    • When the Global Challenge is set to On, this value is sent to the MS in the Access Parameters Message or the ANSI-41 RAND Message .
    • When the Global Challenge is set to Off, this value is stored in the test set. It will not sent to the MS until the Global Challenge is set to On.

    NOTE
    The RAND value, whenever set, is immediately applied in the test set. It is possible that the test set and MS use the different RANDs in a Global Challenge, since the MS may send its stored RANDC to the test set before the test set sends an Access Parameter Message or ANSI-41 RAND Message with the changed RAND value to the MS. In this case, the Global Challenge may fail.

    GPIB Command: CALL:SECurity:AUTHenticate:GCHallenge:RANDom

  • Unique Challenge Random (RANDU) (Hex)

    Sets the 24-bit random challenge data (entered as a 6-digit hexadecimal value) used to calculate the AUTHU during Unique Challenge Operation . It is sent to the MS in the Authentication Challenge Message when you start the Unique Challenge operation (see Unique Challenge ).

    GPIB Command: CALL:SECurity:AUTHenticate:UCHallenge:RANDom

  • SSD Update Random (RANDSSD) (Hex)

    Sets the 56-bit random challenge data (entered as a 14-digit hexadecimal value) used to calculate the AUTHBS during SSD Update Operation . It is sent to the MS in the SSD Update Message when you start the SSD operation (see SSD Update ).

    GPIB Command: CALL:SECurity:AUTHenticate:SUPDate:RANDom

  • Timer Based Registration State

    Enable or disable the timer based registrations. See Performing a Registration for details.

    When the Global Challenge is turned on, the Global Challenge Operation is repeated for every new registration.

  • Global Challenge

    When it is set to On, the test set signals the MS to go into authentication mode when the registrations, call originations, pages or data bursts are performed. See Global Challenge Operation for details.

    GPIB Command: CALL:SECurity:AUTHenticate:GCHallenge:ENABle

  • Unique Challenge

    Starts the Unique Challenge Operation .

    GPIB Command: CALL:SECurity:AUTHenticate:UCHallenge:STARt

  • SSD Update

    Starts the SSD Update Operation .

    GPIB Command: CALL:SECurity:AUTHenticate:SUPDate:STARt

  • Clear Authen Results

    Clears the authentication results displayed on the Global Challenge Information , Unique Challenge Information and SSD Update Information windows.

    GPIB Command: CALL:SECurity:AUTHenticate:CLEar[:ALL]

Related Topics

Authentication Overview

Authentication Information Screen

To Set Authentication Parameters or to Access Authentication Information Screen

Authentication Troubleshooting

CALL:SECurity


AVC Test Operating Mode

AVC Test Operating Mode

Last updated: October 28, 2004

Analog Voice Channel (AVC) test mode provides a forward voice channel for operating AMPS mobiles in test mode. This allows you to get the mobile transmitting on an AVC and test many functions in the mobile without the need to register or page the mobile.

AVC Test Mode Operation

When the test set's operating mode is AVC test mode:

  • No over the air signaling is available.
  • Changes to the test set's AVC channel assignment occur immediately.
  • When the test set's AVC channel is changed, the base station emulator is automatically reconfigured to receive the corresponding reverse AVC signal from the mobile. If needed, you can disable this operation by selecting manual receiver frequency control. See Receiver Control .
  • Changes to the MS TX Level automatically set the expected analog input power. If needed, you can disable this operation by selecting manual receiver power control. See Receiver Control .
  • SAT modulation of the test set's forward AVC can be turned on or off, and can be set to any of the three color code frequencies.
  • Internal FM of the forward AVC is available for various audio frequency tests.
  • An external FM source can be used to provide addition frequency modulation of the forward AVC.
  • The demodulated FM signal can be selected to output to the front-panel AUDIO OUT port for external analysis and baseband processing. See Configuring the Test Set's AUDIO OUT port .

Forward Channel FM Operation

Frequency modulation of the forward channel in AVC test mode is a combination of the SAT, internal FM, and external FM settings. No wideband data is present.

To meet specifications, the total peak FM deviation cannot exceed 20 kHz. Limitations for each FM source are as follows:

  • SAT - can be turned on or off, and has three color code selections: SAT1 (5970 Hz), SAT2 (6000 Hz), SAT3 (6030 Hz). Peak deviation is fixed at 2 kHz.
  • Internal FM - can be turned on or off, has a rate range of 100 Hz to 20 kHz, and a peak deviation range of 0 Hz to 20 kHz.
  • External FM - uses the test set's rear-panel FM Mod In port to connect an external modulation source. The fixed peak deviation for a 100 Hz to 20 kHz tone is 20 kHz/Volt.

AVC Test Mode Operation Using Automated Receiver Control

The following procedure demonstrates the use of AVC test mode where the base station emulator's RF generator frequency, measurement receiver frequency, and expected input power are automatically set by the call control settings used. This is the most common way to use test mode because it requires less individual configuration of call parameters.

This procedure provides general programming steps, but is not written around any specific test requirements. Some of the settings shown are the default power up settings for AVC Test mode.

Putting the mobile in analog test mode at the correct channel number and power setting is the responsibility of the user.

  1. Select AVC Test mode.
    OUTPUT 714;"CALL:OPERating:MODE AVCT"
  2. Turn on the base station emulator's RF Generator and set the output level to -50 dBm.
    OUTPUT 714;"CALL:POWer -50"
  3. Set the AVC channel number to 777.
    OUTPUT 714;"CALL:SETup:AVC 777"
  4. Set the MS TX Level to two (2). (This is the mobile's power level setting, not the expected power in dBm.)
    OUTPUT 714;"CALL:SETup:MS:ANALog:TXLevel:CELLular 2"
  5. Turn the forward channel AVC SAT on.
    OUTPUT 714;"CALL:AVCTest:AVC:SATone:STATe ON"
  6. Set the SAT color code to SAT1 (5970 Hz).
    OUTPUT 714;"CALL:SETup:AVC:SATone SAT1"
  7. Turn on internal FM, and set the deviation to 8.0 kHz and the rate to 1004 Hz.
    OUTPUT 714;"CALL:FM:INTernal 8 KHZ;INT:FREQuency 1004 HZ"

    If you do not want internal FM on, use the FM State command to turn it off:
    OUTPUT 714;"CALL:FM:INTernal:STATe OFF"

  8. Turn external FM off.
    OUTPUT 714;"CALL:FM:EXTernal:STATe OFF"
  9. Connect the mobile's antenna port to the test set's RF IN/OUT port and put the mobile in analog test mode, transmitting at power level two on channel 777.

If your mobile's audio is not muted, you should hear a 1004 Hz tone out of its speaker. If you have an acoustic or direct connection to the mobile's audio output, you can make audio measurements through the test set's AUDIO IN connections. See Audio Analyzer Measurement Description .

You can also make analog transmit power and frequency stability measurements on the mobile's reverse channel carrier. If you modulate your mobile's carrier, you can measure the frequency modulation characteristics. See Analog Transmit Power Measurement Description , Frequency Stability Measurement Description , and Frequency Modulation (FM) Measurement Description .

AVC Test Mode Operation Using Manual Receiver Control

Note: Changing the operating mode affects manual receiver control parameters. See Effects on Receiver Control When Changing Operating Mode .

The following procedure demonstrates the use of AVC test mode where the base station emulator's RF generator frequency, measurement receiver frequency, and expected input power are manually configured. Manual control is not commonly used in production testing, but is provided to allow the measurement receiver and RF generator to be used to perform tests where automated control may not be used; such as when tuning the receiver to make measurements outside of the cellular band during AMPS testing.

This procedure provides general programming steps, but is not written around any specific test requirements. Some of the settings shown are the default power up settings for AVC Test mode.

Putting the mobile in analog test mode at the correct channel number and power setting is the responsibility of the user.

  1. Select AVC Test mode.
    OUTPUT 714;"CALL:OPERating:MODE AVCT"
  2. Turn on the base station emulator's RF Generator and set the output level to -50 dBm.
    OUTPUT 714;"CALL:POWer -50"
  3. Set the base station emulator's RF generator to 893.310 MHz; the forward channel frequency for channel 777.
    OUTPUT 714;"CALL:RFGenerator:FREQuency 893.310 MHZ"
  4. Enable manual receiver frequency control and tune the measurement receiver to 848.31 MHz (reverse channel 777).
    OUTPUT 714;"RFANalyzer:MANual:MEASurement 848.310 MHZ"
  5. Enable manual control of the receiver's expected analog input level power setting.
    OUTPUT 714;"RFANalyzer:CONTrol:POWer:AUTO OFF"
  6. Set the expected input level value to correspond to mobile station power level two.
    OUTPUT 714;"RFANalyzer:MANual:ANALog:POWer 28 DBM"
  7. Turn the forward channel AVC SAT on.
    OUTPUT 714;"CALL:AVCTest:AVC:SATone:STATe ON"
  8. Set the SAT color code to SAT1 (5970 Hz).
    OUTPUT 714;"CALL:SETup:AVC:SATone SAT1"
  9. Turn on internal FM, and set the deviation to 8.0 kHz and the rate to 1004 Hz.
    OUTPUT 714;"CALL:FM:INTernal 8 KHZ;INT:FREQuency 1004 HZ"

    If you do not want internal FM on, use the FM State command to turn it off:
    OUTPUT 714;"CALL:FM:INTernal:STATe OFF"

  10. Turn external FM off.
    OUTPUT 714;"CALL:FM:EXTernal:STATe OFF"
  11. Connect the mobile's antenna port to the test set's RF IN/OUT port and put the mobile in analog test mode, transmitting at power level two and channel 777.

If your mobile's audio is not muted, you should hear a 1004 Hz tone out of the speaker. If you have an acoustic or direct connection to the mobile's audio output, you can make audio measurements through the test set's AUDIO IN connections. See Audio Analyzer Measurement Description .

You can also make analog transmit power and frequency stability measurements on the mobile's reverse channel carrier. If you modulate your mobile's carrier, you can measure the frequency modulation characteristics. See Analog Transmit Power Measurement Description , Frequency Stability Measurement Description , and Frequency Modulation (FM) Measurement Description .

Related Topics

Active Cell Operating Mode


Call Drop Timer

Call Drop Timer

Last updated: October 28, 2004

The call drop timer can be enabled (turned on) or disabled (turned off).

Once a call is established, if the call drop timer is enabled, the call drop timer is started.

When the call drop timer is turned on, if the test set is unable to correctly decode the reverse link for a period of 5 seconds, the call drop timer expires and the test set drops the call connection without signaling (and transitions to the Idle state).

If the test set is able to decode the reverse signal, the call drop timer is reset.

Related Topics

GPIB Command: CALL:CONNected:DROP:TIMer[:STATe]<[:SELected]|:TA2000>

Manual Operation: How Do I Change Call Parameters?


Call Limit Mode

Call Limit Mode

Last updated: October 28, 2004

Call limit mode can be enabled (turned on) or disabled (turned off).

When call limit mode is on, the test set will not respond to any access probes from the mobile station (during events such as paging the mobile station, originating a call from the mobile station, etc.). This forces the mobile station to repeatedly send access probes. It's useful for access probe power measurements (see Access Probe Power Measurement Description ).

IMPORTANT
You can not establish a call when call limit mode is on.

Related Topics

GPIB Command: CALL:CONNected:LIMit[:STATe]<[:SELected]|:TA2000>

Manual Operation: How Do I Change Call Parameters?


Configuring the F-BCCH/F-CCCH Control Channels

Configuring the F-BCCH/F-CCCH Control Channels

Last updated: December 20, 2004

This section is only applicable to the lab application and to a test application with the required feature license.

The Forward Broadcast Control channel (F-BCCH) and the Forward Common Control channel (F-CCCH) defined in the IS-2000 standards (for P_REV > 6) are used for transmission of overhead and control information from a base station to the mobile stations.

The test set supports F-BCCH and F-CCCH capabilities when current control channel is F-BCCH/F-CCCH (see Setting Control Channel Parameters for details).

The parameters relating to the F-BCCH/F-CCCH are configured using the CALL:BCCHannel and CALL:CCCHannel subsystem commands.

Settable F-BCCH/F-CCCH Parameters

  • F-BCCH Level and State (F-BCCH Ec/Ior): See Configuring Forward Channel Power Levels and Walsh Codes .
  • F-CCCH Level and State (F-CCCH Ec/Ior): See Configuring Forward Channel Power Levels and Walsh Codes .
  • F-BCCH Data Rate: See Control Channel Parameters (F-BCCH/F-CCCH/R-EACH) for details.
    BCCH_Chip_Bit
    F-BCCH Data Rate BCCH_Chip_Bit

    BCCH_Chip_Bit (dB)

             Comments
    4.8 kbps, Half | 256 | 24.08 | BCCH_Chip_Bit is the number of PN chips per Broadcast Control Channel bit. For Spreading Rate 1, BCCH_Chip_Bit is equal to 64 x v where v equals 1 when the data rate is 19200 bps, v equals 2 when the data rate is 9600 bps, and v equals 4 when the data rate is 4800 bps. It is used for F-BCCH E b /N t calculation (see F-BCCH Eb/Nt and F-CCCH Eb/Nt ).
    9.6 kbps, Half | 128 | 21.07
    19.2 kbps, Half | 64 | 18.06
  • F-CCCH Data Rate: See Control Channel Parameters (F-BCCH/F-CCCH/R-EACH) for details.
    FCCCH_Chip_Bit
    F-CCCH Data Rate FCCCH_Chip_Bit

    FCCCH_Chip_Bit (dB)

             Comments
    9.6 kbps, 20 ms, Quarter | 128 | 21.07 | FCCCH_Chip_Bit is the number of PN chips per Forward Common Control Channel bit. For Spreading Rate 1, FCCCH_Chip_Bit is equal to 32 x v where v equals 1 when the data rate is 38400 bps, v equals 2 when the data rate is 19200 bps, and v equals 4 when the data rate is 9600 bps. It is used for F-CCCH E b /N t calculation (see F-BCCH Eb/Nt and F-CCCH Eb/Nt ).
    9.6 kbps, 20 ms, Half | 128 | 21.07
    19.2 kbps, 20 ms, Half | 64 | 18.06

F-BCCH E b /N t and F-CCCH E b /N t

The F-BCCH E b /N t ( CALL:STATus:BCCHannel:EBNTotal? ) and F-CCCH E b /N t ( CALL:STATus:CCCHannel:EBNTotal? ) are calculated values (see Example ). They are available only when Cell 1 Power, AWGN Power and F-Paging Channel states are on and determined by:

Equivalent to:

F-BCCH E b /N t (dB) = F-BCCH Level (dB) + Cell Power (dBm/1.23 MHz) + BCCH_Chip_Bit (dB) - AWGN Power (dBm/1.23 MHz)

F-CCCH E b /N t (dB) = F-CCCH Level (dB) + Cell Power (dBm/1.23 MHz) + FCCCH_Chip_Bit (dB) - AWGN Power (dBm/1.23 MHz)

  • See Configuring Cell Power and AWGN Power Levels for Cell Power and AWGN Power settings. Note that for Lab Application , when Cell 2 Power is on, the AWGN power consists of the AWGN power and the Cell 2 power if their states are on.
  • See Settable F-BCCH/F-CCCH Parameters for F-BCCH Level and F-CCCH Level settings.
  • See BCCH_Chip_Bit for BCCH_Chip_Bit value which is determined by F-BCCH Data Rate.
  • See FCCCH_Chip_Bit for FCCCH_Chip_Bit value which is determined by F-CCCH Data Rate.

Example

Assuming,

Cell Power = -55 dBm/1.23 MHz
AWGN Power = -54 dBm/1.23 MHz
F-BCCH Level = -15.2 dB
F-CCCH Level = -12 dB
F-BCCH Data Rate = 9.6 kbps, corresponding to 21.07 dB
F-CCCH Data Rate = 9.6 kbps, corresponding to 21.07 dB

then,

F-BCCH E b /N t (dB) = (-15.2) + (-55) + (21.07) - (-54) = 4.87 dB
F-CCCH E b /N t (dB) = (-12) + (-55) + (21.07) - (-54) = 8.07 dB

Fixed F-BCCH/F-CCCH Parameters

The following key parameters relating to F-BCCH/F-CCCH are fixed by the test set.

  • SR1_NON_TD_FREQ_NON_TD (included in the Sync Channel Message) is fixed to 0:
  • SR1_CRAT_NON_TD (included in the Sync Channel Message) is fixed to 0 indicating 1/2 code rate for F-BCCH.
  • SR1_BCCH_CODE_CHAN_NON_TD (included in the Sync Channel Message) is fixed to 1 indicating F-BCCH code channel number 1 (with spread rate 64).
  • FCCCH_CODE_CHAN (included in the MC-RR Parameter Message) is fixed to 33 indicating F-CCCH code channel number 33 (with spread rate 64 or 128).

Operating Considerations

  • The F-BCCH/F-CCCH/R-EACH control channels are available only for protocol revision greater than six. See Control Channels Configuration .
  • The test set only supports one primary broadcast control channel (F-BCCH). It does not support broadcast pages, broadcast SMS.
  • The test set only supports one forward common control channel (F-CCCH) and a subset of data rate as defined in the standard. See F-CCCH Data Rate .

Related Topics

Setting Control Channel Parameters

Configuring Forward Channel Power Levels and Walsh Codes

How Do I Change Generator Information?

Protocol Revisions

Settable Fields in Overhead Messages


Setting Control Channel Parameters

Setting Control Channel Parameters

Last updated: May 9, 2005

This section is only applicable to the lab application and to a test application with the required feature license.

  • Overview
  • Control Channel Configuration
  • Control Channel Parameters (F-BCCH/F-CCCH/R-EACH)
  • Control Channel Parameters (F-PCH/R-ACH)
  • Operating Considerations

Overview

When the test set is set to the protocol revision 7 (IS-2000-A) or above (see Protocol Revisions ), either the pair of forward paging/reverse access (F-PCH/R-ACH) control channels or the set of the forward broadcast/forward common control/reverse enhanced access (F-BCCH/F-CCCH/R-EACH) control channels can be selected and used for the transmission of overhead and control information to or from the mobile station. This is different from the test set with protocol revisions 6 (IS-2000-0) or less which only supports the F-PCH/R-ACH control channels.

The test set with F-BCCH/F-CCCH channels configuration will send overhead messages on the primary F-BCCH (see IS-2000 Primary Broadcast Control Channel Overhead Messages (P_REV > = 7) ) and the mobile station directed messages (such as General Page message, etc. ) on the F-CCCH. See also Settable Fields in Overhead Messages .

To access the Control Channel Parameters menu from the front panel, see A. Control Channel Parameters .

Control Channels Configuration

IS-2000 System IS-95 System

Protocol Rev 1

7 (IS-2000-A) 6 (IS-2000-0) All Supported
Current control channels

F-BCCH/F-CCCH/R-EACH, or

F-PCH/R-ACH

 F-PCH/R-ACH
  1. See Protocol Revisions for details.

Control Channel Configuration

The Control Channel Configuration ( CALL[:CELL]:PROTocol:CCHannel:CONFigure ) setting applies to protocol revision 7 (IS-2000-A) or above and is used to specify which forward common control channels are generated by the test set and which access channel is expected to be used by the mobile station. When the F-BCCH/F-CCCH/R-EACH is selected, the parameters relating to the F-BCCH/F-CCCH channels are displayed in the Control Channel Parameters menu. When the F-PCH/R-ACH is selected, the paging channel related parameters are shown. Also, this selection will toggle the F3 softkey label to Access Parameters (see Setting Access Parameters ) or Enhanced Access Parms (see Setting Enhanced Access Parameters ) and update the Cell Information screen to display the current control channels information.

Changing this setting may be rejected and will revert to the previous value.

The F-PCH/R-ACH is the only pair of control channels available for protocol revision less than seven.

Control Channel Parameters (F-BCCH/F-CCCH/R-EACH)

When the F-BCCH/F-CCCH/R-EACH is selected, the following parameters relating to the F-BCCH/F-CCCH channels are displayed in the Control Channel Parameters menu:

  • F-BCCH Data Rate: specifies the data rate, convolutional encoding rate and also predetermines the F-BCCH slot size used for the F-BCCH. These parameters are included in the SR1_BRAT_NON_TD and SR1_CRAT_NON_TD fields in the Sync Channel Message (see IS-2000 Sync Channel Messages (P_REV > = 6) ) sent to the mobile station. See also Configuring the F-BCCH/F-CCCH Control Channels .
    GPIB Command: CALL[:CELL]:BCCHannel:DRATe
    F-BCCH Data Rate

    F-BCCH Data Rate Setting

    Data Rate

             Code Rate 1 Frame Size 2 Slot Size 3

    4.8 kbps, Half

    4.8 kbps

    1/2

    40 ms

    160 ms

    9.6 kbps, Half

    9.6 kbps

    1/2

    40 ms

    80 ms

    19.2 kbps, Half

    19.2 kbps

    1/2

    40 ms

    40 ms
    1. The test set only supports 1/2 rate F-BCCH encoding rate.
    2. The frame size for the F-BCCH is fixed to 40 ms by the standard.
    3. The slot size is determined by the settings of data rate and code rate with one-one-one mapping.
  • F-CCCH Data Rate: specifies the data rate, frame size, convolutional code rate and also predetermines the slot size and the Walsh Code used for the F-CCCH. These parameters are sent to the mobile station via the FCCCH_RATE and FCCCH_CODE_RATE fields in the MC-RR Parameter Message ( MC-RR Parameters Message Settable Messages ). See also Configuring the F-BCCH/F-CCCH Control Channels .
    GPIB Command: CALL[:CELL]:CCCHannel:DRATe
    F-CCCH Data Rate

    F-CCCH Data Rate Setting

    Data Rate

             Code Rate Frame Size Slot Size 1

    9.6 kbps, 20 ms, Quarter

    9.6 kbps

    1/4

    20 ms

    80 ms

    9.6 kbps, 20 ms, Half

    9.6 kbps

    1/2

    20 ms

    80 ms

    19.2 kbps, 20 ms, Half

    19.2 kbps

    1/2

    20 ms

    80 ms
    1. The slot size for the F-CCCH is fixed to 80 ms by the standard.
  • F-QPCH State: Specifies whether or not to transmit the forward quick paging channel (QPCH). It's included in the QPCH_SUPPORTED field in the MC-RR Parameter Message ( MC-RR Parameters Message Settable Messages ) sent to the mobile station. See also Configuring the Forward Quick Paging Channel (F-QPCH) ).
    GPIB Command: CALL:QPCHannel:STATe[:SELected]
  • F-QPCH Relative to Pilot Level: Specifies the QPCH level relative to the pilot level. It's included in the QPCH_POWER_LEVEL_PAGE field in the MC-RR Parameter Message ( MC-RR Parameters Message Settable Messages ) sent to the mobile station. See also Configuring the Forward Quick Paging Channel (F-QPCH) .
    GPIB Command: CALL:QPCHannel:LEVel:RTPilot[:SELected]
  • F-QPCH Data Rate: Specifies the QPCH data rate. It is converted to the QPCH indicator rate and then included in the QPCH_RATE in the MC-RR Parameter Message ( MC-RR Parameters Message Settable Messages ) sent to the mobile station. See also Configuring the Forward Quick Paging Channel (F-QPCH) .
    GPIB Command: CALL:QPCHannel:DRATe
    Quick Paging Channel Data Rate

    F-QPCH Data Rate Setting

    QPCH Data Rate

    Indicator Data Rate (QPCH_RATE)

    Full

    4.8 kbps

    9.6 kbps

    Half

    2.4 kbps

    4.8 kbps

Control Channel Parameters (F-PCH/R-ACH)

When the F-PCH/R-ACH is selected, the following paging channel parameters can be set from the Control Channel Parameters menu:

  • Paging Data Rate: Specifies the paging channel data rate. It is included in the PRAT field in the Sync Channel Message (see Settable Fields in Overhead Messages ) sent to the mobile station. This setting applies to the F-PCH whenever it's available. See also Configuring the Forward Paging Channel (F-Paging/Paging) .
    GPIB Command: CALL:PAGing:DRATe
    F-PCH Data Rate

    Paging Data Rate Setting

    PCH Data Rate (PRAT)

    Full

    9.6 kbps

    Half

    4.8 kbps
  • F-QPCH State, F-QPCH Relative to Pilot Level, and F-QPCH Data Rate: These settings are same as the corresponding settings on Control Channel Parameters (F-BCCH/F-CCCH/R-EACH) with the exception of the Extended System Parameter Message ( Extended System Parameters Message Settable Fields ) used. Moreover, the F-QPCH is not available for IS-95 system.

Operating Considerations

  • The change of Control Channels Configuration setting may affect the code level summation check (see Other Settings That Affect Code Channel Levels and States ) since it may change the control channels generated and result in an invalid set due to the new control channels. If the change of Control Channels Configuration setting is rejected, the setting will revert to the previous value and an error "Control Channels Configuration setting rejected due to invalid code channel set with new control channels." will be posted.
  • The test set only supports one primary broadcast control channel (F-BCCH) when F-BCCH/F-CCCH/R-EACH is selected. In this case, the test set does not support broadcast SMS ( Delivery Modes Description ) since the IS-2000 standard specifies that the broadcast SMS can not be sent on the primary F-BCCH.
  • The test set supports transmitting point-to-point SMS message on the forward common control channel (F-CCCH) while it is generated in idle state. See Delivery Modes Description .
  • The test set only supports 1/2 code rate of F-BCCH and does not support 1/4 code rate F-BCCH as specified in the standard. See F-BCCH Data Rate
  • The test set supports a subset of F-CCCH data rates, encoding types, and frame sizes that are defined in the standard. See F-CCCH Data Rate
  • The test set supports F-BCCH overhead messages (see IS-2000 Primary Broadcast Control Channel Overhead Messages (P_REV > = 7) ) required for the new release A (P_REV = 7) functionality. The F-CCCH supports the Mobile Station Directed Messages (such as General Page Message, Status Request Message, etc. that are carried on the Paging Channel for P_REV= 6) with some format changes as required for P_REV = 7. In addition, the test set uses the message defined in the earlier version of the standard if the message is sufficient for the operation (for example, continue to use existing General Page message instead of new Universal Page message).
  • The test set will page the mobile station either via F-CCCH or F-PCH in slotted mode unless the mobile station has registered as non-slotted. The test set will use the lesser value of a mobile station reported Slot Cycle Index (see Mobile Reported Information ) and a settable Max Slot Cycle Index (see Setting Cell Parameters ), for slotted mode paging.

Related Topics

Manual Operation: A. Control Channel Parameters


Cell Band

Cell Band

Last updated: June 18, 2007

The test set's base station emulator provides a selection of cell bands.

Cell Bands
Cell Band | Programming Mnemonic | C.S0002-A Band Class | Forward Link Frequency Range (MHz) | Reverse Link Frequency Range (MHz)
US Cellular | USCellular | 0 (800 MHz Band) | 860 - 894 | 815 - 849
US PCS | USPCs | 1 (1900 MHz Band) | 1930 - 1990 | 1850 - 1910
Japan CDMA | JCDMa | 3 (JTACS Band) | 832 - 870 | 887 - 925
Korean PCS | KPCS | 4 (Korean PCS Band) | 1840-1870 | 1750-1780
NMT-450 | NMT450 | 5 (450 MHz Band) | 420 - 494 | 410 - 484
IMT-2000 | IMT2000 | 6 (2 GHz Band) | 2110 - 2170 | 1920-1980
Secondary 800 | SECondary800 | 10 (Secondary 800 MHz Band) | 851 - 869, 935 - 940 | 806 - 824, 896 - 901
US PCS 1900 | USPCs1900 | 14 (1900 MHz Band) | 1930 - 1995 | 1850 - 1915
AWS | AWService | 15 (AWS Band) | 2110 - 2155 | 1710 - 1755

Cell band can be changed at any time. Changing cell band initiates an implicit handoff (see Performing a Hard Handoff ).

Related Topics

GPIB Command: CALL:BAND

Manual Operation: How Do I Change Call Parameters?


RF Channel Number

RF Channel Number

Last updated: June 18, 2007

The range of RF channels available varies by cell bands.

CDMA Channel Number to CDMA Frequency Assignment
Cell Band | Channel Number | Preferred Channel Number | Center Frequency for Forward Channel N (MHz) | Center Frequency for Reverse Channel N (MHz)
US Cellular | 1-799 | 384 | 0.03*N+870.000 | 0.03*N+825.000
 | 991-1023 |  | 0.03*(N-1023)+870.000 | 0.03*(N-1023)+825.000
 | 1024-1323 |  | 0.030*(N-1024) + 860.040 | 0.030*(N-1024) + 815.040
US PCS | 0-1199 | 525 | 1930.000+0.05*N | 1850.000+0.05*N
Japan Cellular | 1-799 | 76 | 0.0125*N+860.000 | 0.0125*N+915.000
 | 801-1039 |  | 0.0125*(N-800)+843.000 | 0.0125*(N-800)+898.000
 | 1041-1199 |  | 0.0125*(N-1040)+832.000 | 0.0125*(N-1040)+887.000
 | 1201-1600 |  | 0.0125*(N-1200)+838.000 | 0.0125*(N-1200)+893.000
Korean PCS | 0-599 | 325 | 1840.000+0.05*N | 1750.000+0.05*N
NMT-450 | 1-400 | 210 | 0.025*(N-1)+460.000 | 0.025*(N-1)+450.000
 | 472-871 |  | 0.025*(N-472)+420.000 | 0.025*(N-472)+410.000
 | 1039-1473 |  | 0.020*(N-1024)+461.000 | 0.020*(N-1024)+451.000
 | 1536-1715 |  | 0.025*(N-1536)+489.000 | 0.025*(N-1536)+479.000
 | 1792-2016 |  | 0.020*(N-1792)+489.000 | 0.020*(N-1792)+479.000
IMT-2000 | 0-1199 | 525 | 2110.000+0.05*N | 1920.000+0.05*N
Secondary 800 | 0-719 | 820 | 0.025*N+851.000 | 0.025*N+806.000
 | 720-919 |  | 0.025*(N-720)+935.000 | 0.025*(N-720)+896.000
US PCS 1900 | 0-1299 | 525 | 1930.000+0.05*N | 1850.000+0.05*N
AWS | 0 - 899 | 300 | 2110.000+0.05*N | 1710.000+0.05*N

Channel can be changed at any time. Changing channel initiates an implicit handoff (see Performing a Hard Handoff ).

Related Topics

GPIB Command: CALL:CHANnel

Manual Operation: How Do I Change Call Parameters?


Setting Cell Parameters

Setting Cell Parameters

Last updated: June 20, 2006

The test set's base station emulator provides control over the cell parameters described below. Most of these parameters are sent to the mobile station via Extended System Parameter message or MC-RR Parameter message (see Settable Fields in Overhead Messages ).

To access cell parameters using the test set's front panel, see B. Cell Parameters .

IS-2000/IS-95 Cell Parameters

The following cell parameters are displayed under the Cell Parameters menu when the following two conditions exist:

  1. The Operating Mode field is set to Active Cell (see Active Cell Operating Mode ), IS-2000 Test, or Cell Off, and
  2. If Active Cell is the current operation mode, IS-2000 or IS-95 is selected in the System Type field.
  • System ID (SID): A number uniquely identifying a wireless system. See also CALL[:CELL]:SIDentity )
  • Network ID (NID): A number uniquely identifying a network within a wireless system. See also CALL[:CELL]:NIDentity .
  • Escape Mode: See CALL[:CELL]:ESCape[:MODE] .
  • Cell MCC: A part of the International mobile station identification (IMSI) identifying the home country. See also CALL[:CELL]:MCCode<[:SELected]|:TA2000> .
  • Cell MNC: A part of the IMSI identifying the home network within the home country. See also CALL[:CELL]:MNCode .
  • Max Slot Cycle Index. (see CALL:PAGing:SCINdex[:MAXimum] )
  • RL Traffic to Pilot Gain (RLGAIN_TRAFFIC_PILOT): See CALL[:CELL]:RLGain[:TTPilot] . This setting is only for IS-2000 system RC3 and above. It is used to range the test set's receiver (see Equation C ).
  • Paging Data Rate ( CALL:PAGing:DRATe ): This parameter is shown in this menu when IS-95 system is selected. To set this parameter in IS-2000 system, see Setting Control Channel Parameters .
  • Base ID ( CALL:BIDentity ): It represents the identification number of the base station. It can be changed at any time and sent to the mobile station in the next overhead messages ( System Parameters Message , or ANSI-41 System Parameters Message , or MC-RR Parameters Message ). The mobile station may use this parameter together with other overhead message parameters (such as SID, NID, etc.) to identify the presence of a particular User Zone.

Related Topics

Settable Fields in Overhead Messages


Cell Off Operating Mode

Cell Off Operating Mode

Last updated: October 28, 2004

Cell Off operating mode and Active Cell operating mode share the same settings. However, there is no signaling generated by the test set during Cell Off operating mode regardless of the settings. All settings are deferred until the Active Cell operating mode is used.

Related Topics

Active Cell Operating Mode


Setting Reverse Closed Loop Power Control

Setting Reverse Closed Loop Power Control

Last updated: October 28, 2004

The reverse closed loop power control parameter determines what power control bits are sent to the mobile station to cause the mobile station increase or decrease its output power. The test set provides two kinds of closed loop power control (CLPC):

  • Reverse CLPC Steady-state Modes
  • Reverse CLPC Transient Modes
    • Setting Reverse CLPC Transient Parameters
    • Starting the Reverse CLPC Transient

Reverse CLPC Steady-state Modes

The test set normally uses reverse CLPC steady-state modes to control the mobile station output power unless you initiate the reverse CLPC transient modes (see Reverse CLPC Transient Modes ).

The reverse CLPC steady-state modes as listed in table below are accessed from the Rvs Power Ctrol ( F7 ) on the Call Parms 2 of 4 menu. See How Do I Change Call Parameters? for front panel operation. For related GPIB commands, see CALL[:CELL[1]]:CLPControl:REVerse:MODE<[:SELected]|:TA2000> .

Reverse CLPC steady-state Modes
Setting | Description
Active Bits | The test set actively determines if the mobile station is transmitting at a power level that is too high or too low (based on the expected mobile power, see Automatic Receiver Control ), and responds by sending the appropriate up or down power control bit.
Alternating Bits | The test set sends alternating "up" (0) and "down" (1) power control bits to the mobile station regardless of its output power.
All Up Bits
The test set sends continuous "up" power control bits (0's) to the mobile station regardless of its output power.
All Down Bits | The test set sends continuous "down" power control bits (1's) to the mobile station regardless of its output power.
Alternating 20 Bits (for lab application only) | The test set sends a periodic sequence of 20 up power control bits followed by 20 down power control bits to the mobile station regardless of its output power.

IMPORTANT
In order for the test set to successfully decode signalling from the mobile station, the signal level into the test set's RF IN/OUT connector must be within 9 dB of the expected input power based on the power transmitted from the test set and open loop estimate (see Automatic Receiver Control ). When reverse CLPC is set to All Up Bits or All Down Bits, the mobile station's power may not be within the required range, and all signalling will fail. Before attempting any signalling between the test set and the mobile station, you must either set Reverse Closed Loop Power to Active Bits, or manually range the Receiver Power to the level that the mobile station is currently transmitting based on the reverse CLPC setting (see Manual Receiver Control in Active Cell Operating Mode ).

Reverse CLPC Transient Modes

The reverse CLPC steady-state modes (see Reverse CLPC Steady-state Modes ) can be temporarily interrupted in order to insert a number of the user-defined power control bits as specified by the Rvs Power Ctrl Transient Parm ( F8 ) on the Call Parms 4 of 4 menu. This is called reverse CLPC transient. The test set returns to the reverse CLPC steady-state modes after the completion of the reverse CLPC transient.

For example, if the Transient Mode is set to Down (see Setting Reverse CLPC Transient Parameters ) and the Rvs Power Ctrol ( F7 ) is set to All Up bits (see Reverse CLPC Steady-state Modes ), the number of down power control bits as specified by the Transient Number of Steps field will be sent to the mobile station when the F7 ( Start Rvs Power Ctrl Transient ) is pressed. After the completion of transient transmission, the test set will then resume sending continuous up power control bits.

NOTE
For lab application, the reverse CLPC transient settings for cell 1 also impact the Cell 2 closed loop power control if the Cell2 reverse CLPC is set to track Cell1 bits ( CALL:CELL2:CLPControl:REVerse:MODE ).

Setting Reverse CLPC Transient Parameters

The reverse CLPC transient parameters are accessed from the Rvs Power Ctrl Transient Parm ( F8 ) on the Call Parms 4 of 4 menu. See How Do I Change Call Parameters? .

  • Transient Mode ( CALL[:CELL[1]]:CLPControl:REVerse:TRANsient:MODE ): specifies the number and direction of the ramp(s) of the reverse CLPC transient.
    • Up indicates one up ramp of power control transient. When F7 ( Start Rvs Power Ctrl Transient) is pressed, the test set will send the number of "up" power control bits (0's) as specified by the Transient Number of Steps to the mobile station on the forward power control subchannel.
    • Down indicates one down ramp of power control transient. When F7 ( Start Rvs Power Ctrl Transient) is pressed, the test set will send the number of "down" power control bits (1's) as specified by the Transient Number of Steps to the mobile station on the forward power control subchannel.
    • Up-Down-Up indicates three ramps of power control transient (one up ramp, followed by one down ramp and then followed by one up ramp). When F7 ( Start Rvs Power Ctrl Transient) is pressed, the test set will send the number of "up" power control bits (0's) as specified by the Transient Number of Steps , then followed by the same number of power down bits (1's) and then followed by the same number of power up bits (0's) again to the mobile station.
  • Transient Number of Steps ( CALL[:CELL[1]]:CLPControl:REVerse:TRANsient:SPRamp ): specifies the number of power control bits that will be inserted into each ramp (slope) of the reverse CLPC transient. The Pwr Ctrl Size ( F8 on Call Parms 2 of 4 ) is used to specify how much the mobile station increases or decreases its power per each received power control bit (see ( CALL[:CELL]:CLPControl:REVerse:STEP ). If the Transient Mode is set to Up_Down_Up then the total number of power control bits during reverse CLPC transient will be three times the value of this setting.

Starting the Reverse CLPC Transient

When a forward traffic/fundamental channel (forward power control subchannel) is present (for example, during a call connection), pressing the F7 ( Start Rvs Power Ctrl Transient) or sending the CALL[:CELL[1]]:CLPControl:REVerse:TRANsient:STARt causes a request for transmission of a power control transient as specified by the Rvs Power Ctrl Transient Parm ( F8 ).

NOTE
If any of the measurements (such as Handoff Waveform Quality, Waveform Quality + Code Domain, Code Channel Time/Phase Error, Time Response of Open Loop Power Control and Tx Dynamic Power) are running at the time the power control transient transmission starts the measurement will be closed and its operation aborted.

None of the measurements listed above will be able to start (become initiated) while the transient transmission is in progress.

During the power control transient,

  • the test set will emit a trigger signal (a positive TTL pulse with a width of about 1.25 ms) coincident with the transmission of the first power control bit in each transient. This trigger will be available on the TRIG OUT port of the test set's rear panel if the Ext Trigger ( F4 on the Gen Info menu) is set to FDEPendent (see Setting External Trigger ). This trigger can be used for the synchronization of external measurement instrument or trigger the test set's internal Spectrum Monitor instrument (see Example Usage of Reverse CLPC Transient Mode ).
  • the test set can accept and process any command immediately after starting a power control transient (while the transient is still being transmitted). However, The reverse CLPC transient is not guaranteed to be completed when the next user command is processed.
  • the test set can accept up to two reverse CLPC transient start requests in addition to the one currently being transmitted (total of 3). When a currently transmitting transient has completed the next transient in the queue will be transmitted.
  • the test set returns to the reverse CLPC steady-state mode after the completion of the transient transmission.
  • you can change the reverse CLPC steady-state mode while a transient is being transmitted. The newly selected reverse CLPC steady-state mode will be used when the transient (and any other queued transients) are completely transmitted.
  • if the forward traffic/fundamental channel (forward power control subchannel) is lost while transmitting a transient then the current power control transient will not be completely transmitted, and any enqueued transient requests will be removed from the queue and will not be transmitted.

NOTE
If there is no forward traffic/fundamental channel present (no power control subchannel), pressing F7 ( Start Rvs Power Ctrl Transient) does nothing (no error, no trigger).

Related Topics

Example Usage of Reverse CLPC Transient Mode


Configuring Forward Channel Power Levels and Walsh Codes

Configuring Forward Channel Power Levels and Walsh Codes

Last updated: October 28, 2004

  • Overview of Forward Code Channels Configuration
  • Setting Code Channel Levels and Walsh Codes
  • Current Level and Desired Level
  • Considerations When Setting Code Channel States and levels
  • Other Settings That Affect Code Channel Levels and States

Overview of Forward Code Channels Configuration

The test set provides controls over the forward channel levels and walsh codes. There are separate settings for each of the channel levels and states for IS-95 and IS-2000 system if supported for that protocol revision (see Protocol Revisions ).

In addition to the walsh codes and power levels that can be set or queried for the forward code channels, some channels also have other settings, such as F-FCH/Traffic channel data rate, etc. Forward Code Channels for IS-2000 and IS-95 Systems provides you the reference to the configuration information relating to the specific code channels.

Forward Code Channels for IS-2000 and IS-95 Systems
IS-2000 System |  | IS-95 System | How to Set the Related Parameters
P_REV > = 7 | P_REV = 6 | P_REV < 6
F-Pilot | F-Pilot | Pilot | Configuring the Forward Pilot Channel (F-Pilot/Pilot) (PN Offset setting information also included)
F-Sync | F-Sync | Sync | Configuring the Forward Sync Channel (F-Sync/Sync)
F-Paging | F-Paging | Paging | Configuring the Forward Paging Channel (F-Paging/Paging)
F-BCCH |  |  | Configuring the F-BCCH/F-CCCH Control Channels
F-CCCH |  |
F-QPCH | F-QPCH |  | Configuring the Forward Quick Paging Channel (F-QPCH)
F-FCH | F-FCH | Traffic | Configuring the Forward Fundamental/Traffic Channel (F-FCH/Traffic)
F-SCH | F-SCH |  | Configuring the TDSO Supplemental Channel Information
F-OCNS | F-OCNS | OCNS | Configuring the Forward Orthogonal Channel Noise Simulator (F-OCNS/OCNS)

Setting Code Channel Levels and Walsh Codes

To set code channel levels and walsh codes (in addition to the F-QPCH) from the front panel operation, see How Do I Change Generator Information? . To set the F-QPCH levels, see A. Control Channel Parameters

The code channel levels and walsh codes you specified will be displayed in Generated Code Channel Information (for Test Application) window. To understand the differences between current level and desired level, see Current Level and Desired Level .

To set/query the code channel levels/states with GPIB commands, see Summary of GPIB Commands for Code Channel Levels .

Generated Code Channel Information (for Test Application)

For the lab application , the test set has the ability to simulate two individual base stations, referred as Cell 1 and Cell 2 (see Generated Code Channel Information (for Lab Application) ). The Cell 1 used in the lab application is identical to the Cell used in the test application. For more information about Cell 2 code channels, see Configuring Cell 2 Used for Soft/Softer Handoff .

For the lab application , when a call is connected in FPC mode 000 (see FPC Mode ), the maximum FPC F-FCH level given indicates the upper limit of the F-FCH level (Ec/Ior) that the test set can be adjusted to according to the forward power control by the mobile station. See FPC Parameters for details.

Generated Code Channel Information (for Lab Application)

Current Level and Desired Level

The test set allows you to set the relative power level (Ec/Ior) for all code channels (desired level) except for OCNS (orthogonal channel noise simulator). The relative power of the channels that are being generated at any given time must sum to 100% of the cell power. The OCNS Level is a calculated value used to balance the relative power levels to sum to 100% (see Configuring Cell Power and AWGN Power Levels ).

The relative power levels and states all have an associated "current" query-only result. The current result shows what is actually being generated by the test set at any given time. The code channel levels that you set (desired level) may differ from the current levels in the following situations:

  • In Active Cell, any of the "On" channel states are not currently being generated due to the state of the call processing. For example, Current Traffic Level will be NAN when a call is not connected and will match that of the desired Traffic Level value when a call is connected.
  • The associated code channel is never generated in the current test set state. For example, the F-BCCH is not generated in protocol revision 7 when current control channel is set to F-PCH/R-ACH (see Control Channels Configuration for details). In this case, the Current F-BCCH Level will be NAN regardless if its state is On or Off.
  • Because the relative power levels of the different channels must add up to a 100% of the cell power, the test set performs an error checking of the code channel levels, called code level summation check. When any code channel level and state changed violates the rules (see Considerations When Setting Code Channel States and levels ) and results in an invalid set, a persistent error message is posted. In this case, the `Current' values will reflect the actual signals being generated (which will be the last set of valid channel levels you specified). In addition to the code channel levels/states, some other settings when changed also affect the code level summation check and may result in an invalid set (see Other Settings That Affect Code Channel Levels and States ).

Summary of GPIB Commands for Code Channel Levels

Parameter

 Current Level Desired Level

F-Pilot (Ec/Ior)

CALL:STATus:PILot[:CELL[1]][:LEVel][:RTCell][:SELected]?

CALL[:CELL[1]]:PILOT:LEVel[:SELected]

F-Sync (Ec/Ior)

CALL:STATus:SYNC[:LEVel][:SELected]?

CALL:SYNC:LEVel[:SELected]

F-Paging
(Ec/Ior)

CALL:STATus:PAGing[:LEVel][:SELected]?

CALL:PAGing:LEVel[:SELected]

F-BCCH (Ec/Ior)
(IS-2000 system and P_REV>6)

CALL:STATus:BCCHannel[:LEVel]<[:SELected]|:DIGital2000>?

CALL[:CELL]:BCCHannel[:SLEVel]<[:SELected]|:DIGital2000>

F-CCCH (Ec/Ior)
(IS-2000 system and P_REV>6)

CALL:STATus:CCCHannel[:LEVel]<[:SELected]|:DIGital2000>?

CALL[:CELL]:CCCHannel[:SLEVel]<[:SELected]|:DIGital2000>

F-QPCH (Ec/Ior) (IS-2000 system only)

CALL:STATus:QPCHannel[:LEVel][:RTCell][:SELected]?

CALL: QPCHannel:LEVel[:RTCell][:SELected]? (query only)

F-FCH/Traffic
(Ec/Ior) *

CALL:STATus:FCHannel[:CELL[1]][:LEVel][:SELected]?

CALL[:CELL[1]]:TRAFfic[:FORWard]:LEVel<[:SELected]|DIGital95>

F-SCH (Ec/Ior)
(IS-2000 system only)

CALL:STATus:SCHannel[:FORWard][:LEVel][:SELected]?

CALL:SCHannel[:FORWard]:LEVel[:SELected]

F-OCNS (Ec/Ior) *

CALL:STATus:OCNSource[:CELL[1]][:LEVel][:SELected]? (current)

CALL[:CELL[1]]:OCNSource:LEVel[:SELected]? (calculated)

Max F-FCH
(Ec/Ior)
(Lab application and IS-2000 system only) **

 CALL:STATus:FPControl:FCHannel:LEVel:MAXimum?

CALL[:CELL]:FPControl:FCHannel:LEVel:MAXimuml

* For the lab application , when a call is connected in FPC mode 000 (see FPC Mode ), the current F-FCH/Traffic level and the current OCNS level reflect the average of F-FCH Level and the average of F-OCNS Level since last updated (the update rate is about 500 ms).

  • if the Current F-FCH Level generated by the test set is greater than the Current Maximum F-FCH Level, the Current F-FCH Level will be clipped to the Current Maximum F-FCH Level, and no error is posted.
  • if the Current F-FCH Level generated by the test set is lower than -30 dB, the Current F-FCH Level generated by the test set will be clipped to the -30 dB, and no error is posted.

** For the lab application , when the test set is in FPC mode 000, the maximum F-FCH level given indicates the upper limit of the F-FCH level (Ec/Ior) that the test set can be adjusted to according to the forward power control by the mobile station. See FPC Parameters for details

Considerations When Setting Code Channel States and levels

  • Any code channel levels (except OCNS) that are ON must be no less than - 30 dB relative to Total RF Power ( Configuring Cell Power and AWGN Power Levels ).
  • When OCNS level (calculated or current) is - 40 dB or less relative to Cell Power, the associated OCNS Level is turned off.
  • When a code channel level/state changed results in an invalid set (i.e., the sum of the code channels + OCNS is above 100% of the cell power), a persistent error message is posted and the last valid values and states are used until the set becomes valid again.
  • (For lab application and IS-2000 system only) when FPC mode is set to '000', the Maximum F-FCH Level (see FPC Parameters ) instead of the F-FCH Level will be used in the code level summation check. Moreover, the Maximum F-FCH Level must be no less than the F-FCH Level. Any invalid set will result in the current Maximum F-FCH Level different from the Maximum F-FCH Level you specified (see Current Level and Desired Level ).
  • If a channel state is set to ON, the behavior will be different for Test Mode and Active Cell mode. In Active Cell mode, if the channel state parameter is ON, the channel will be generated according to the protocol state machine. For example, if the traffic (fundamental) channel state parameter is ON, the fundamental channel will be generated when a call is established and will not be generated anytime Call Status is Idle. In Test Mode, if the channel state is ON, the channel is being generated.

Other Settings That Affect Code Channel Levels and States

In addition to the change of code channel levels/states, the following settings also affect the code level summation check (see Current Level and Desired Level ) and may result in a rejection of the new setting due to an invalid set present.

  • the rate set determined by the setting of the IS-2000 Radio Configuration and IS-95 Service Option.
  • the setting of code channel data rate such as F-FCH data rate if this channel is being generated. See Control Channel Parameters (F-BCCH/F-CCCH/R-EACH) .
  • the change of protocol revision that may change the control channels generated. For example, when the protocol revision is changed from 6 (IS-2000-0) to 7 (IS-2000-A), it may result in new control channels (F-BCCH/F-CCCH) generated if control channel configuration is set to F-BCCH/F-CCCH/R-EACH. See Operating Considerations for IS-2000 Protocol Revisions .
  • the change of control channel configuration setting in protocol revision 7. For example, when the control channel configuration is changed from F-PCH/R-ACH to F-BCCH/F-CCCH/R-EACH, the F-BCCH and F-CCCH channels will take the place of the F-PCH to be involved in the code level summation check and may result in an invalid set. See Operating Considerations .
  • (for lab application only) the change of the FPC mode setting (see FPC Parameters ). For example, when the FPC mode is changed from other modes to 000, the Maximum F-FCH Level will take the place of the F-FCH level and be involved in the code level summation check that may result in an invalid set.

Related Topics

How Do I Change Generator Information?

A. Control Channel Parameters

Configuring Cell Power and AWGN Power Levels

Troubleshooting Setting Power Levels

Configuring Cell 2 Used for Soft/Softer Handoff ( Lab Application Only )


Setting CDMA System Time Parameters

Setting CDMA System Time Parameters

Last updated: June 20, 2006

CDMA System Time Overview

CDMA System Time Parameters and Information

Operating Consideration

CDMA System Time Overview

The CDMA system time is the time reference used by the IS2000/IS95 (CDMA) and IS856 (1xEV-DO) system. It is synchronous to UTC (Coordinated Universal Time) time except for leap seconds and uses the same time origin as GPS (Global Positioning System) time. All base stations use the same system time and all mobile stations use the same system time, offset by the propagation delay from the base station to the mobile station.

The test set emulating a base station to allow you to set the CDMA system time parameters that are sent to the mobile station in a Sync Channel Message . The mobile station uses them to calculate its local time and verify time-based data applications, such as alarms, meeting schedules, etc. The CDMA system time is also used in multiple test sets synchronization. (See Performing Multi-Unit Synchronization )

CDMA System Time Parameters and Information

  • CDMA System Time

    The CDMA system time consists of two portions: CDMA System Time (Date) and CDMA System Time (Time) which are set from the CDMA System Time Parameters menu and displays on CDMA System Time Information window.

    The CDMA system time in the test set starts at what you set (or internal RTC time when shipped from the factory) and keeps going. It is corresponding to the UTC time without the leap seconds. The CDMA system time is maintained in the test set and not affected by full preset and save/recall operations.

    The CDMA system time is updated on CDMA System Time Information window every two seconds. To get more accurate CDMA system time running in the test set, you can use CALL[:CELL]:CSTime:DATE? or CALL[CELL]:CSTime:TIME? query commands which has one second resolution.

    • CDMA System Time (Date) is the date portion of the CDMA system time and can be set any date from January 6, 1980 to January 5, 2080.
    • CDMA System Time (Time) is the time portion of CDMA system time and can be set any time of the day. The value of this setting must be an even number. Any odd number you enter is rounded up to an even number automatically.

    GPIB Command: CALL[:CELL]:CSTime:DATE and CALL[:CELL]:CSTime:TIME

  • Leap Seconds

    Specifies the leap seconds that is used by CDMA Local Time calculation. It is stored in the test set's non-volatile RAM and not affected by the power cycle, full preset or Save/Recall operations.

    GPIB Command: CALL[:CELL]:CSTime:LOCal:LEAP

  • Local Time Offset (hh.mm)

    Specifies the local time offset from CDMA system time. It is also used by CDMA Local Time calculation. The value of this setting must be hours or half-hours. Otherwise, the test set rounds it up the closest hour or half-hour. It is stored in the test set's non-volatile RAM and not affected by the power cycle, full preset or Save/Recall operations.

    GPIB Command: CALL[:CELL]:CSTime:LOCal:OFFSet:[SELected] or CALL[:CELL]:CSTime:LOCal:OFFSet:TA2000

  • Daylight Savings Time Indicator

    Specifies whether the daylight saving time takes effect. It isn't used by CDMA Local Time calculation. It is stored in the test set's non-volatile RAM and not affected by the power cycle, full preset or Save/Recall operations.

    GPIB Command: CALL[:CELL]:CSTime:DSTime

  • CDMA Local Time

    The CDMA Local Time is consists of two portions: CDMA Local Time (Date) and CDMA Local Time (Time) which are calculated based on the following formula and shown on the CDMA System Time Information window.

    CDMA Local Time = CDMA System Time (Date) + CDMA System Time (Time) - Leap Seconds + Local Time Offset

    Once the mobile station synchronizes to the test set, the time displayed on the mobile station's screen should be same as the CDMA Local Time that shown on the test set. It is used to verify whether the date displayed on the mobile station is correct.

    • CDMA Local Time (Date) is the date portion of CDMA system local time.
    • CDMA Local Time (Time) is the time portion of CDMA system local time.

    GPIB Command: CALL:STATus:CSTime:LOCal:DATE? and CALL:STATus:CSTime:LOCal:TIME?

NOTE
After the mobile station finds the service and registers in the test set, if Local Time Offset and Leap Seconds are changed, the CDMA local time displayed on test set is updated immediately.

However, since these parameters are only sent in the Sync Channel Message , the local time displayed on the mobile station's screen may not be updated immediately until a Sync Channel Message is received.

Operating Consideration

  • The CDMA System Time (Date) and the CDMA System Time (Time) is only available when current System Type is IS-95 or IS-2000 and the Operating Mode is Active Cell or IS-2000 Test Mode .
  • The CDMA System Time (Date) and the CDMA System Time (Time) can only be set when the test set is idle state.
  • When the Operation Mode is set to IS-2000 Test Mode and Test Mode ESN is set to " 0xFFFFFFFF ", the CDMA System Time is set to the nearest even second of the system time rather than "1980-1-06 00:00:00".
  • There is +/- 1 second uncertainty for CDMA System Time when performing the following actions.

    Actions caused uncertainty:

    • Perform the power up in the test set.
    • Perform the Channel Power Calibration, Open Loop ALC Calibration or Average Power Calibration (See CALibration Subsystem ).
    • Change the Digital Bus Path Control (See Digital Bus Information ).
    • Change the Test Mode ESN from/to 0xFFFFFFFF while the Operating Mode is IS-2000 Test Mode .
    • Switch the 8960 Format (See Test Application Switching ).
    • Switch the Operating Mode between Active Cell and IS-2000 Test Mode while Test Mode ESN is 0xFFFFFFFF.

Related Topics

Manual Operation E. CDMA System Time Parameters

GPIB Commands CALL:CSTime , CALL:STATus


CW Operating Mode

CW Operating Mode

Last updated: June 20, 2006

Description

When in CW operating mode, the test set operates like a signal generator. The basic features provided by CW operating mode are:

  • No over the air signaling is used. Therefore there is no synchronization between the mobile station and test set.
  • No demodulation or channel decoding is available.
  • No automatic receiver control is provided. Expected CW power, measurement receiver frequency, and uplink receiver frequency are available as manual settings only.

    Manual receiver control settings made while using the CW operating mode can affect manual receiver settings made in other operating modes. When changing operating modes and using manual receiver settings, always verify that the manual receiver settings are correct for the new operating mode.

  • Any one of three test signals can be generated while analyzing another signal (at the same frequency or at a different frequency). No interaction exists between these controls.
  • All test set measurements are available while in CW operating mode. However, measurements requiring protocol triggering cannot be made. Immediate triggering should be used for most measurements because no overhead signaling is occurring. Protocol triggering will timeout or report an integrity indicator other than zero.

Test Signals Description

The test set in CW operating mode provides any one of three test signals: CW (no modulation), AM (fixed 56% amplitude modulation), and DSB-SC (dual side-band suppressed carrier). An example usage of the test signals is for calibrating mobile stations that use Qualcomm's radioOne™ Zero Intermediate Frequency (Zero IF) architecture.

You can select any one of three signals with adjustable power level and frequency for output to the currently selected front panel RF connector.

  • With CW test signal selected (the default setting), the test set provides an unmodulated carrier. With either AM or DSB-SC test signal selected, the test set will modulate the signal as shown in the following figure.
  • For any of the test signals selected, the output power level is controlled by the Cell Power ( F7 ). The Cell Power refers to the power found in the entire signal including sidebands if applicable.
  • For any of the test signals selected, the frequency is adjusted by changing the RF Gen Freq ( F8 ).
    • With the CW or AM signal selected, the RF Gen Freq setting represents the center frequency of the signal (fc).
    • With the DSB-SC signal selected, the RF Gen Freq setting represents the frequency of the lower sideband signal (fL). The upper sideband (fh) is 20 kHz above the RF Gen Freq setting, that is fh = fL+20 kHz.

Programming Usages

Using the following commands to control each function for CW operating mode:

  • Select CW operating mode: CALL[:CELL]:OPERating:MODE
  • Select a test signal for output: CALL[:CELL[1]]:WAVeform:TYPE:CW
  • Set the cell power output level to be transmitted by the test set: CALL:POWer
  • Set the RF generator frequency: CALL[:CELL]:RFGenerator:FREQuency
  • Set the expected CW power level to be received by the test set: RFANalyzer:CW:EXPected:POWer
  • Set the measurement receiver frequency: RFANalyzer:MANual:MEASurement[:MFRequency]

Operating Considerations

  • Changing the operating mode affects manual receiver control parameters. See Effects on Receiver Control When Changing Operating Mode .
  • See Calibrating the Test Set .

Related Topics

How Do I Configure Test Signals in CW Operating Mode?


Setting Enhanced Access Parameters

Setting Enhanced Access Parameters

Last updated: December 20, 2004

This section is only applicable to the lab application and to a test application with the required feature license.

When the test set is configured to support Enhanced Access Channels (R-EACH) (see Control Channels Configuration ), the test set monitors the R-EACH used by the mobile station to initiate communication with the test set or to respond to a mobile station directed messages.

The test set only supports a single R-EACH channel in Basic Access Mode (see Fixed IS-2000 Enhanced Access Parameters ).

Enhanced Access Channel Structure

The R-EACH transmission consists of one or more sequences of one or more enhanced access probes. Each enhanced access probe in basic access mode consists of an R-EACH preamble followed by enhanced access data. The enhanced access data is transmitted with a R-Pilot channel as shown below.

IS-2000 Enhanced Access Parameters

The test set allows you to specify the following enhanced access parameters which are included in the Enhanced Access Parameters Message ( Enhanced Access Parameters Message Settable Fields ) sent to the mobile station on the Primary Broadcast Control Channel (F-BCCH).

  • Maximum Request Sequence (MAX_REQ_SEQ): This parameter specifies the maximum number of access probe sequences a mobile station is to transmit for an enhanced access channel request.
    GPIB Command: CALL[:CELL]:APARameter:SEQuence:REQuest[:MAXimum] ).
  • Maximum Response Sequence (MAX_RSP_SEQ): This parameter specifies the maximum number of access probe sequences a mobile station is to transmit in response to a paging request.
    GPIB Command: CALL[:CELL]:APARameter:SEQuence:RESPonse[:MAXimum] ).
  • RL Gain Common to Pilot (RLGAIN_COMMON_PILOT): This parameter specifies the gain adjustment of the R-EACH relative to the reverse pilot channel. It is used by the mobile station to determine what initial level to set the R-EACH. The RLGAIN_COMMON_PILOT multiplied by 0.125 is converted to dB value. See Equation B for details on how this parameter is used.
    GPIB Command: CALL[:CELL]:PARameter:EACCess:RLGain:CTPilot .
  • Interference Correction Threshold (IC_THRESH): This setting specifies the threshold level (in units of 1 dB) at which the interference correction begins to be applied for the mobile station output power. The negative value of this setting is used by the mobile station to calculate the open loop power and by the test set to calculate the expected mobile power. See Base Equation for details on how this parameter is used.
    GPIB Command: CALL[:CELL]:PARameter:EACCess:ICORrection:THReshold .
  • Interference Correction Maximum (IC_MAX): This setting specifies the maximum interference correction that can be applied for the R-EACH when calculating the mobile station output power. The IC_MAX is in units of 1 dB. See Base Equation for details on how this parameter is used.
    GPIB Command: CALL[:CELL]:PARameter:EACCess:ICORrection[:MAXimum] .
  • EACH Nominal Power (EACH_NOM_PWR): This parameter specifies the nominal transmit power offset for the R-EACH, in units of 1 dB. It is the correction factor to be used by a mobile station in the open loop power estimate (see Base Equation for details).
    GPIB Command: CALL[:CELL]:PARameter:EACCess:POWer:NOMinal .
  • EACH Initial Power (EACH_INIT_PWR): This parameter specifies the initial power offset for the R-EACH, in units of 1 dB. It is the correction factor to be used by a mobile station in the open loop power estimate for the initial transmission on R-EACH (see Base Equation for details).
    GPIB Command: CALL[:CELL]:PARameter:EACCess:POWer:INITial
  • EACH Power Step (EACH_PWR_STEP): This parameter specifies the power increment (in units of 1 dB) that a mobile station is to transmit between successive enhanced access probes in an access probe sequence for the R-EACH.
    GPIB Command: CALL[:CELL]:PARameter:EACCess:POWer:STEP[:LEVel] .
  • EACH Number of Steps (EACH_NUM_STEP): This parameter specifies the number of enhanced access probes that a mobile station is to transmit in a single access probe sequence.
    GPIB Command: CALL[:CELL]:PARameter:EACCess:POWer:STEP:COUNt .
  • EACH Rate Supported (EACH_BA_RATES_SUPPORTED): This setting is used to specify the data rates that the mobile station can send on the R-EACH. The test set directs the mobile station to use the indicated data rate for the R-EACH (see R-EACH Rate Supported ). This setting also affects the expected mobile power ranging when the R-EACH is enabled (see Expected Power ).
    GPIB Command: CALL[:CELL]:PARameter:EACCess:DRATe[:SUPPorted]
    R-EACH Rate Supported

    R-EACH Rate Supported Setting

    Data Rate

             Frame Length

    Comments

    9.6 kbps, 20 ms

    9.6 kbps

    20 ms

    When a single data rate is selected, the test set directs the mobile station to use the indicated data rate on the R-EACH.

    19.2 kbps, 20 ms

    19.2 kbps

    20 ms

    All Rates, 20 ms

    9.6 kbps and 19.2 kbps

    20 ms

    When more than one rate is allowed, multiple bits of the EACH_BA_RATES_SUPPORTED field are set and the mobile station will determine the data rate to be used according to the standards. In this case the test set can not know which rate will be used at any given time.

Fixed IS-2000 Enhanced Access Parameters

The following parameters (included in the Enhanced Access Parameters Message ) are fixed by the test set.

Fixed Settings for R-EACH
Settings | Fixed Value | Description
ACCESS_MODE | 000 | Indicates the test set only supports Basic Access mode (`000') and forces the mobile station to use Basic Access mode for the R-EACH.
NUM_EACH_BA | 0 | Indicates the test set only supports one R-EACH in Basic Access Mode.
EACH_PREAMBLE_ENABLED | 1 | Indicates the test set will include EACH preambles related information in the Enhanced Access Parameters message.
EACH_PREAMBLE_NUM_FRAC | 0 | Indicates the test set forces the mobile station to send one fractional preamble prior to the R-EACH access data.
EACH_PREAMBLE_FRAC_DURATION | 15 (20 ms) | Indicates the duration of a fractional preamble (in units of 1.25 ms) sent by the mobile station is 20 ms (determined by this value plus one times 1.25 ms).
EACH_PREAMBLE_OFF_DURATION | 0 (0 ms) | Indicates the fractional preamble gated-off duration (in units of 1.25 ms) on an R-EACH. The test set forces the mobile station to generate fractional preamble without gating.
EACH_PREAMBLE_ADD_DURATION | 0 (0 ms) | Indicates the additional preamble duration (in units of 1.25 ms) on an R-EACH. The test set forces the mobile station not to generate additional preamble.

Related Topics

GPIB Commands: CALL:PARameter:EACCess

Manual Operation: C. Access Parameters or Enhanced Access Parameters


Configuring the Forward Fundamental/Traffic Channel (F-FCH/Traffic)

Configuring the Forward Fundamental/Traffic Channel (F-FCH/Traffic)

Last updated: June 12, 2007

The following parameters can be configured for the F-FCH channel (for IS-2000 system) or F-Traffic channel (for IS-95 system).:

Settable F-FCH/Traffic Parameters

  • Level and state. See CALL[:CELL[1]]:FCHannel[:FORWard][:SLEVel]<[:SELected]|DIGital2000> and Configuring Forward Channel Power Levels and Walsh Codes .
  • Walsh code (call status state must be idle). See CALL[:CELL[1]]:FCHannel[:FORWard]:WALSh .
  • Data Rate (applies when a loopback service option (SO2, 9, or 55) is selected.) See Traffic Data Rate .
  • Voice SO Mode (applies when a voice service option (SO1, 3, 17, 68 or 32768) is selected). See Voice SO Mode and CALL[:CELL[1]]:FCHannel[:FORWard]:SOURce .
  • Echo Delay (applies when Voice SO Mode is set to voice echo, see Voice SO Mode ). See CALL[:CELL[1]]:TRAFfic[:FORWard]:SOURce:ECHO .
  • RL Traffic to Pilot Gain (RLGAIN_TRAFFIC_PILOT) (for IS-2000 system RC3 and above): see Setting Cell Parameters .

Operating Considerations

Both fundamental channel (IS-2000 system) and traffic channel (IS-95 system) use the same command CALL[:CELL[1]]:TRAFfic[:FORWard]:DRATe to set the data rate.

When changing F-FCH/Traffic Walsh codes, the call processing state must be idle.

If the data rate is changed while a voice service option (SO1, SO3, SO17, SO68 or SO32768) is selected, the data rate value will be stored for use when a loopback service option is selected.

If the audio tone is changed while a loopback service option is selected, the audio tone value will be stored for use when a voice service option is selected.

If the echo delay time is changed while the audio tone is not voice echo, the delay time value will be stored for use when audio tone is set to voice echo.

Parameters can be queried from the test set regardless of the state of the test set.

Related Topics

Manual Operation: How Do I Change F-FCH/Traffic Channel Parameters?

GPIB Commands: CALL:FCHannel (for IS-2000 System Type) or CALL:TRAFfic (for IS-95 System Type)


Traffic Data Rate

Traffic Data Rate

Last updated: October 28, 2004

The traffic data rate determines the rate used on the fundamental channel (FCH ) (for IS-2000 system) and traffic channel (IS-95 system) when a call is established in a loopback (with service options SO2, SO9, or SO55) (see Service Option ). It can be changed at any time.

To configure the data rate for supplemental channel (SCH), see Configuring the TDSO Supplemental Channel Information .

Traffic Data Rate in Loopback Service Options

Traffic Data Rate

IS-95 System

IS-2000 System

SO2

 SO9 (Fwd1, Rvs1) (Fwd2, Rvs2) (Fwd3, Rvs3) (Fwd4, Rvs3) (Fwd5, Rvs4)
Full | 9.6 kbps | 14.4 kbps | 9.6 kbps | 14.4 kbps | 9.6 kbps | 14.4 kbps
Half | 4.8 kbps | 7.2 kbps | 4.8 kbps | 7.2 kbps | 4.8 kbps | 7.2 kbps
Quarter | 2.4 kbps | 3.6 kbps | 2.4 kbps | 3.6 kbps | 2.7 kbps | 3.6 kbps
Eighth | 1.2 kbps | 1.8 kbps | 1.2 kbps | 1.8 kbps | 1.5 kbps | 1.8 kbps
Random (40% Voice Activity)

Random (40% Voice Activity) is used to simulate a typical usage of mobile station with 40% voice activity, which 40% of the transmitted frames carry voice data at greater than eighth data rate. To simulate 40% voice activity, the data is sent at random rate but the distribution is controlled such that 28% of the time is at full rate, 6% of the time is at half rate, 6% of the time is at quarter rate, and remaining 60% of the time is at eighth rate. The Random (40% Voice Activity) data rate setting is useful for MS's talk time test in R-FCH gating mode (see R-FCH Gating ).

When Random (40% Voice Activity) traffic data rate is selected, the test set will use fixed ranging, and range the receiver to Quarter rate expected power (see Reverse Traffic Channel Data Rate Determination ).

Setting Considerations

  • The traffic data rate setting is applied only when a call is established in loopback service options (such as SO2, SO9, or SO55). If a non-loopback service option (see Service Option ) is selected, the data rate setting is stored until a loopback service option is active.
  • When a call is established in an SO32 or SO33, the fundamental data data is fixed to the Full rate.
  • If R-FCH gating mode is enabled (on), the R-FCH/R-PICH will only actually be gated if the data rate on the R-FCH is eighth rate. See R-FCH Gating .
  • The traffic data rate setting impacts the estimation of the Expected Power .

Related Topics

GPIB Command: CALL[:CELL[1]]:TRAFfic[:FORWard]:DRATe

Manual Operation: How Do I Change F-FCH/Traffic Channel Parameters?


Setting Hard Handoff Parameters

Setting Hard Handoff Parameters

Last updated: October 28, 2004

The test set's base station emulator provides control over the hard handoff parameters described below. This allows several parameters to be changed without a handoff attempt until the Execute Handoff key is selected. For more information about the hard handoffs, see Performing a Hard Handoff .

Hard Handoff Parameters

The following list of handoff parameters are displayed under the Handoff Setup menu when the following two conditions exist:

  1. The Operating Mode field is set to Active Cell (see Active Cell Operating Mode ) or Cell Off, and
  2. IS-2000 or IS-95 is selected in the System Type (see Selecting a Cellular System Type ) field.
  • Handoff System Type: CALL:SETup:SYSTem[:TYPE]<[:SELected]|[:TA2000]>
  • Handoff Cell Band: CALL:SETup:BAND:[:SELected]
  • Handoff Channel: CALL:SETup:CHANnel[:SELected][:SELected]

If the IS-95 is selected in the Handoff System Type field, the following parameters are also available:

  • IS-95 Protocol: CALL[:CELL]:PROTocol:DIGital95
  • IS-95 Service Option: CALL[:CELL]:SOPTion[:SELected][:SELected]
  • IS-95 Cell Power: CALL[:CELL[1]]:POWer[:SAMPlitude][:SELected]
  • IS-95 Cell 2 Power ( lab application only ): CALL:CELL2:POWer[:SAMPlitude][:SELected]

If AMPS is selected in the System Type (see Selecting a Cellular System Type ), or if AMPS is selected as the current Handoff System Type, these handoff parameters will appear under the Handoff Setup menu:

  • Analog Voice Channel. CALL:SETup:AVC[:CHANnel][:SELected]
  • MS TX Level. CALL:SETup:MS:ANALog:TXLevel[:SELected]
  • SAT Color Code. CALL:SETup:AVC:SATone[:CCODe]

Related Topics

How Do I Perform a Hard Handoff?

Configuring Soft Handoff Parameters ( Lab Application only )


MEID / Enhanced PLCM

MEID / Enhanced PLCM

Last updated: June 20, 2006

Mobile Equipment Identifier (MEID) is a newly designed way to uniquely identify the mobile stations (MS) due to ESN exhaustion. In the Active Cell operating mode and IS-2000 system, the test set supports to test an MEID-equipped MS. The MEID related information either reported or retrieved during MS registration can be observed from the Mobile Reported Information screen. Also, you can establish a call between the test set and an MEID-equipped MS using the Public Long Code Mask (PLCM) determined by the specified PLCM Type .

MEID Support

The MEID Support setting is used to enable ( On ) or disable ( Off ) the test set to support of MEID and Enhanced PLCM tests for an MEID-equipped MS.

  • When the MEID Support is set to On ,
    • and an MEID-equipped MS is detected during registration ( MEID Supported indicates Yes), the test set sends the Status Request Message to retrieve the MEID value from the MS no matter what the Status Request Query setting is. Upon receiving the Status Response Message with MEID value, the test set displays the MEID result on the Mobile Reported Information screen (see MEID ). You can also retrieve the MEID value from the MS by pressing the F3 ( Query MEID ) or using CALL:MS:REPorted:MEIDentifier:QUERy command.
    • the test set can establish a call with an MEID-equipped MS using the Public Long Code Mask (PLCM) determined by the specified PLCM type. See PLCM Type for details.
    • the test set can not establish a call with an ESN-equipped MS.
  • When the MEID Support is set to Off ,
    • the test set does not send the Status Request Message to an MEID-equipped MS to retrieve its MEID value. Also, you can not retrieve the MEID value from the MS by pressing the F3 ( Query MEID ). The MEID-equipped MS only registers to the test set using pseudo-ESN which is derived from its MEID value. The pseudo-ESN reported from the MS is displayed on the Mobile Reported Information screen (see ESN ).
    • the test set can establish a call with an MEID-equipped MS using the Public Long Code Mask (PLCM) derived from the pseudo-ESN value.
  • You can not change the MEID Support setting when a call is established.

GPIB Command: CALL[:CELL]:MEIDentifier:SUPPort[:ENABle]

PLCM Type

The PLCM Type determines how an MEID-equipped MS generates its public long code mask (PLCM).

  • It is available only when the MEID Support is set to On .
  • It is sent to the MS via the PLCM_TYPE field in the MEID Extended Channel Assignment Message during a call establishment or in the MEID Universal Handoff Direction Message during an implicit handoff caused by the change of this setting.
    Public Long Code Mask Type
    PLCM Type Description PLCM_TYPE (binary)

    ESN Based

    PLCM derived from ESN

    0000

    BS Assigned

    PLCM specified by the base station

    0001

    MEID Based

    PLCM derived from MEID

    0100
  • The test set can establish a call with an MEID-equipped MS using the Public Long Code Mask (PLCM) generated based on the specified PLCM Type . If ESN Based or BS Assigned is selected, a call can be established regardless of MEID value. If MEID Base d is selected, a call can be established only when the MEID value is successfully reported or retrieved ( MEID ).
  • While a call other than SO32+SCH or SO32+F-SCH is established, changing the PLCM Type setting results in an implicit handoff (see also Performing a Hard Handoff ). However, if the PLCM Typ e is changed from ESN Based or BS Assigned to MEID Based and the MEID value is empty due to a MEID query failure during registration, the call will be dropped. If the MEID results are empty due to cleared by pressing the F5 ( Clear MS & Capability Info ) on Call Control 2 of 3 or using CALL:MS:REPorted:CLEar command, the previously stored MEID value will be used and the handoff may succeed.
  • You can not change the PLCM Type while an SO32+SCH or SO32+F-SCH call is established.
  • If any of the measurements (Frame Error Rate, Waveform Quality + Code Domain, Handoff Waveform Quality and Code Channel Time/Phase Error) are running, changing the PLCM Type causes these measurements aborted and restarted.

GPIB Command: CALL[:CELL]:PLCMask:TYPE

Related Topics

How Do I Perform MEID Verification?


Configuring the Forward Orthogonal Channel Noise Simulator (F-OCNS/OCNS)

Configuring the Forward Orthogonal Channel Noise Simulator (F-OCNS/OCNS)

Last updated: October 28, 2004

The F-OCNS/OCNS channel parameters are configured using the following call processing subsystem functions and commands:

  • CALL:OCNSource

To set the parameters using the test set's front panel, see How Do I Change Generator Information? .

Settable F-OCNS/OCNS Parameters

  • Walsh code.

Fixed F-OCNS/OCNS Parameters

  • F-OCNS level (calculated value based on summation of all other code channels).

  • OCNS_CCI_SUPPORTED is fixed at 0.

  • NUM_OCNS is fixed at 1.

GPIB Examples:

Setting F-OCNS Walsh code

OUTPUT 714;"CALL:OCNSOURCE:WALSH CODE5"

would set the F-OCNS Walsh code to 10. See CALL[:CELL[1]]:OCNSource:WALSh[:SELected] .

Querying F-OCNS level

OUTPUT 714;"CALL:OCNSOURCE:LEVEL?"

would query the last F-OCNS calculation. See CALL[:CELL[1]]:OCNSource:LEVel[:SELected]? .

Operating Considerations

The F-OCNS/OCNS level is a calculated value and can only be queried.

The F-OCNS value is calculated to provide a summing value that results in a total code channel value equalling 100% of cell power. If the current desired code channel levels do not allow for a valid OCNS calculation an error message will be displayed.

Related Topics

Configuring Forward Channel Power Levels and Walsh Codes


Selecting an Operating Mode

Selecting an Operating Mode

Last updated: October 28, 2004

To select an operating mode for the test set over front panel, see How Do I Set Up a Call? .

The test set's operating mode is selected using the CALL:OPERating call processing subsystem commands.

Available Operating Modes

The following operating modes are displayed under the Operating Mode menu.

  • Active Cell Operating Mode
  • IS-2000 Test Operating Mode
  • AVC Test Operating Mode
  • CW Operating Mode
  • Cell Off Operating Mode


Paging IMSI Setup

Paging IMSI Setup

Last updated: June 20, 2006

The Paging IMSI Setup provides a quicker way to page the mobile station if the mobile station's IMSI is known without first being obtained through a power-up registration ( Performing a Registration ).

To access Paging IMSI Setup menu from the front panel, press the Paging IMSI Setup ( F4 ) key on Call Control 1 of 3 menu and set the parameters required by the mobile station paging type.

NOTE
When the mobile station registers or is connected on a call, the Paging IMSI information is automatically entered into the Paging IMSI Setup fields. This information is retained through test set presets but not retained through power up cycles.

Paging IMSI Parameters

The following paging IMSI parameters are displayed under the Paging IMSI Setup menu when the following two conditions exist:

  1. The Operating Mode field is set to Active Cell or Cell Off, and
  2. IS-2000 or IS-95 is selected in the System Type field.
  • Paging Type - See CALL:PAGing:IMSI:TYPE .
  • Paging MSIN - See CALL:PAGing:IMSI:MSIN .
  • Paging MCC - See CALL:PAGing:IMSI:MCC .
  • Paging MNC - See CALL:PAGing:IMSI:MNC .

The Paging IMSI is made up of Paging MNC, Paging MCC, Paging MSIN and Paging Type, which is used to page the mobile when the test set is in the IS-95 or IS-2000 system. Since the MNC and/or MCC are optional, the Paging Type tells the test set how to page the mobile (use MNC and/or MCC or neither).

In addition to the direct setting, the Paging IMSI is also indirectly updated (overwritten) when a new MSIN are reported by the mobile station ( CALL:MS:REPorted<:MCC|:MEID|:MIN1|:MIN2|:MNC|MSIN> ) after a successful registration. Therefore, the value of Paging IMSI is determined by whether a direct user setting of Paging IMSI or a automatic updating based on the reported MSIN happened most recently.

  • Status Request Query

    When the Status Request Query is set to 'On', each time a new mobile station registers with the test set, the test set will send Status Request Messages to request the mobile station to report its band classes, the operating mode for each band class, the max EIRP (if the operating mode is CDMA) for each band class, as well as the power control information. The test set then displays these information on the MS Operating Mode , Band Class , Max EIRP and Power Control Step fields on the Mobile Reported Information screen. The test set does not request the mobile station to report these information when the Status Request Query is set to 'Off'. This reduces the mobile station registration time.

    Note that the test set sends the Status Request Message to an MEID-equipped mobile station for its MEID value no matter what the Status Request Query state is when the MEID Support is On.

    GPIB Command: CALL:MS:REPorted:REQuest[:ENAble]

  • Max EIRP

    The test set needs to know the maximum EIRP (effective isotropic radiated power) of the mobile station to perform receiver ranging properly. When the Status Request Query state is set to Off and the MS Database is cleared, then the default Max EIRP setting ( CALL:MS:REPorted:EIRPower:DEFault ) will be used for connections in any band class.

Related Topics

Performing a Registration


Configuring the Forward Paging Channel (F-Paging/Paging)

Configuring the Forward Paging Channel (F-Paging/Paging)

Last updated: October 28, 2004

The F-Paging/Paging channel parameters are configured using the CALL:PAGing subsystem commands.

Settable F-Paging/Paging Parameters

  • F-Paging Level and State: see How Do I Change Generator Information? and CALL:PAGing[:SLEVel][:SELected] .
  • Paging Data Rate ( CALL:PAGing:DRATe ): see A. Control Channel Parameters (for IS-2000 system) or B. Cell Parameters (for IS-95 system).
    Paging_Chip_Bit
    Paging Data Rate Paging_Chip_Bit

    Paging_Chip_Bit (dB)

             Comments
    Full (9600 bps) | 128 | 21.07 | Paging_Chip_Bit is the number of PN chips per Paging Channel bit, equal to 128 × v where v equals 1 when the paging data rate is 9600 bps and v equals 2 when the data rate is 4800 bps. It is used for F-Paging E b /N t calculation (see F-Paging/Paging Eb/Nt ).
    Half (4800 bps) | 256 | 24.08
  • Max Slot Cycle Index: see B. Cell Parameters and CALL:PAGing:SCINdex[:MAXimum]

Fixed F-Paging/Paging Parameters

The F-Paging/Paging Walsh code is fixed at code channel number 1.

F-Paging/Paging E b /N t

The F-Paging E b /N t is a calculated value (see Example ). It's available only when Cell 1 Power, AWGN Power and F-Paging Channel states are on and determined by:

Equivalent to:

F-Paging E b /N t (dB) = F-Paging Level (dB) + Cell Power (dBm/1.23 MHz) + Paging_Chip_Bit (dB) - AWGN Power (dBm/1.23 MHz)

  • See Configuring Cell Power and AWGN Power Levels for Cell Power and AWGN Power settings. Note that for Lab Application , when Cell 2 Power is on, the AWGN power consists of the AWGN power and the Cell 2 power if their states are on.
  • See Settable F-Paging/Paging Parameters for F-Paging Level settings.
  • See Paging_Chip_Bit for Paging_Chip_Bit value which is determined by Paging Data Rate.

Example

Assuming,

Cell Power = -55 dBm/1.23 MHz
AWGN Power = -54 dBm/1.23 MHz
F-Paging Level = -12 dB
Paging Data Rate = Full (9600 bps), corresponding to 21.07 dB

then,

F-Paging E b /N t (dB) = (-12) + (-55) + (21.07) - (-54) = 8.07 dB

GPIB Examples:

Setting the F-Paging state and level (complex command)

OUTPUT 714;"CALL:PAG -12 DB"

would set the F-Paging state on and set the level to -12 dB. See CALL:PAGing[:SLEVel][:SELected] .

Setting the F-Paging data rate

OUTPUT 714;"CALL:PAGING:DRATE HALF"

would set the F-Paging data rate to half-rate. See CALL:PAGing:DRATe .

Operating Considerations

The Walsh code number for the F-Paging channel is fixed at code 1 of the Walsh 64 set.

The test set will page the mobile station in slotted mode unless the mobile station has registered as non-slotted. The test set will use the lesser value of a mobile station reported Slot Cycle Index (see Mobile Reported Information ), or a settable Max Slot Cycle Index (see Setting Cell Parameters ), for slotted mode paging.

For IS-2000 system, when F-QPCH State is `On' (see Configuring the Forward Quick Paging Channel (F-QPCH) ), the test set will generate the quick paging channel regardless of whether the mobile supports quick paging or not. If the mobile does not support quick paging, the mobile will simply "not listen" for the quick paging channel. Since quick paging is an addition to normal paging, mobiles that don't support quick paging will still respond to the normal page

Related Topics

Configuring Forward Channel Power Levels and Walsh Codes


Configuring the Forward Pilot Channel (F-Pilot/Pilot)

Configuring the Forward Pilot Channel (F-Pilot/Pilot)

Last updated: October 28, 2004

The F-Pilot/Pilot parameters are configured using the following call processing subsystem functions and commands:

  • CALL:PILot
  • CALL[:CELL[1]]:PNOFfest

To set the parameters using the test set's front panel, see How Do I Change Generator Information? .

Settable F-Pilot/Pilot Parameters

  • level.
  • state.
  • PN Offset

Fixed F-Pilot/Pilot Parameters

  • F-Pilot/Pilot Walsh code is fixed at code channel number 0.

GPIB Examples:

Setting the F-Pilot State and Level (complex command)

OUTPUT 714;"CALL:PIL -8 DB"

would set the F-Pilot state on and set the level to -8 dB. See CALL[:CELL[1]]:PILOT[:SLEVel][:SELected] .

Querying the F-Pilot Level

OUTPUT 714;"CALL:PIL:LEVel?"

would query the last setting that was made to the F-Pilot level. See CALL[:CELL[1]]:PILOT:LEVel[:SELected] .

Operating Considerations

The Walsh code number for the F-Pilot channel is fixed at code 0 of the Walsh 64 set.

Related Topics

How Do I Change Generator Information?


Protocol Revisions

Protocol Revisions

Last updated: December 17, 2004

The test set's base station emulator supports the protocol revisions listed in Protocol Revisions The protocol revision supported by the test set is selected from Protocol Rev ( F10 ) on Call Parms 1 of 4 menu and sent to the mobile station in the P_REV and MIN_P_REV fields of some overhead messages (see Settable Fields in Overhead Messages ). The protocol revision used by the mobile station (MOB_P_REV) is sent to the test set via the Registration Message (during registration), or the P age Response Message (in response to a paging request from the test set), or the Origination Message (when initiating a call from the mobile station). It is displayed on the Mobile Station Information screen (see Mobile Reported Information ) after a successful registration or connection.

NOTE
The protocol revision supported by your mobile station (MOB_P_REV) should be no less than the protocol revisions configured on the test set (P_REV). Otherwise, the mobile station can not camp on the test set.

NOTE
For IS-2000 system, the protocol revision 7 (IS-2000-A) functionality is available in a lab application (E6702B revision B.02 and above) but requires an additional feature license in a test application (E1962B revision B.08 and above). If the protocol revision 7 (IS-2000-A) is selected when the required feature license is not available in your test application, an error message is generated and the feature will not be activated. To find out how to acquire the required license, visit:

http://www.agilent.com/find/8960upgrades

Protocol Revisions
System Type | Protocol Rev (P_REV and MIN_P_REV) | Programming Mnemonics | Description
IS-2000 | 7 (IS-2000-A) | PREVision7 | Supports mobile stations operating in the IS-2000 system with the enhanced capabilities. See Key Enhancements for Protocol Revisions 7 (IS-2000-A) Relative to Protocol Revision 6 (IS-2000-0) .
 | 6 (IS-2000-0) | PREVision6 | Supports most of the mobile stations operating in the IS-2000 system.
IS-95 System | 4 (IS-95B) | D95B | Supports most of the mobile stations operating in the IS-95 system.
 | 3 (ARIB T-53) | AT53 | Supports the earlier mobile stations with Protocol Revision 3 and Band Class 3 (Japan CDMA)
 | 3 (TSB74) | TBS74 | Supports the earlier mobile stations with Protocol Revision 3 and Band Class other than Band Class 3 (Japan CDMA).
 | 1 (J-STD-008) | JSTD8 | Supports the earlier mobile stations with Protocol Revision 1 and Band Class 1 (US PCS).
 | 1 (Korean PCS) | KPCS | Supports the earlier mobile stations with Protocol Revision 1 and Band Class 4 (Korean PCS)

Key Enhancements for Protocol Revisions 7 (IS-2000-A) Relative to Protocol Revision 6 (IS-2000-0)

  • Support for new control channels (F-BCCH/F-CCCH/R-EACH): See Setting Control Channel Parameters .
  • Support for new overhead messages: See "IS-2000 Primary Broadcast Control Channel Overhead Messages (P_REV > = 7)" .

Operating Considerations for IS-2000 Protocol Revisions

  • If IS-2000 protocol revision is changed while a call is connected, the call is dropped with no signaling to the mobile station.
  • The change of protocol revision between 6 (IS-2000-0) and 7 (IS-2000-A) may affect the code level summation check (see Other Settings That Affect Code Channel Levels and States ) and result in the change of the generated control channels (see Control Channels Configuration ). The change of protocol revision may be rejected due to an invalid set and an error will be posted to indicate the issue.
  • The test set configured with protocol revision 7 (IS-2000-A) supports a subset of the new release A functionality as specified in the IS-2000 standards (C.S0002-A V6.0 to C.S0005-A V6.0).
    • The test set supports new control channels such as F-BCCH, F-CCCH, and R-EACH but does not support Reservation Access mode and the associated channels (R-CCCH, F-CPCCH, and F-CACH), the Power Controlled Access mode, and the Time Diversity and the associated channels (F-TDPCH and F-APICH).
    • The test set supports new F-BCCH overhead messages (see IS-2000 Primary Broadcast Control Channel Overhead Messages (P_REV > = 7) ) required for the new release A (P_REV = 7) functionality. The F-CCCH supports the Mobile Station Directed Messages (such as General Page Message, Status Request Message, etc. that are carried on the Paging Channel for P_REV= 6) with some format changes as required for P_REV >= 7. In addition, the test set uses the existing message if a previous protocol revision (P_REV = 6) message is sufficient for the operation (for example, continue to use existing General Page message instead of new Universal Page message).

Related Topics

GPIB Command: CALL:PROTocol

Manual Operation: How Do I Change Call Parameters?

Setting Control Channel Parameters

Setting Enhanced Access Parameters

Settable Fields in Overhead Messages

Mobile Reported Information

SYSTem:APPLication:CATalog:LICense:APPLication:ALL?


Configuring Cell Power and AWGN Power Levels

Configuring Cell Power and AWGN Power Levels

Last updated: July 4, 2006

  • General Description
  • Front Panel Operation Summary
  • GPIB Commands Summary
  • Cell Power, AWGN Power and Total RF Power Ranges
  • Rules for Setting Power Levels and Amplitude Offsets

General Description

The test set's base station emulator provides control over the following RF power levels:

  • Cell Power: Î or is defined in C.S0011 as the received power spectral density of the Forward Channel as measured at the mobile station antenna connector. The Forward Channel is defined as a CDMA Channel from a base station to mobile stations. The Forward Channel contains one or more code channels that are transmitted on a CDMA frequency assignment using a particular pilot PN offset (see Configuring Forward Channel Power Levels and Walsh Codes ). If you have accounted for path loss (see Amplitude Offset ) between the test set output port and the mobile station antenna connector, then cell power is equivalent to Î or .
  • AWGN (Additive White Gaussian Noise) Power: I oc is defined in C.S0011 as the power spectral density of a band-limited white noise source (simulating interference from other cells) as measured at the mobile station antenna connector. If you have accounted for path loss, then AWGN power is equivalent to I oc .
  • Total RF Power: The total RF power is the sum of cell power and AWGN power. I o is defined in C.S0011 as the total received power spectral density, including signal and interference, as measured at the mobile station antenna connector. If you have accounted for path loss, then total RF power is equivalent to I o .

Front Panel Operation Summary

To access the cell power parameter using the test set's front panel, see How Do I Change Call Parameters? .

To access the AWGN power parameter using the test set's front panel, see How Do I Change AWGN Power Levels? .

These power levels are displayed in the Generated Power Level Information table (see Generated Power Level Information (for Test Application) ).

Generated Power Level Information (for Test Application)

For the lab application , the test set has the ability to simulate two individual base stations, referred as Cell 1 power and Cell 2 power. The total RF power consists of Cell 1 power, Cell 2 power and the AWGN power if their states are on (see Generated Power Level Information (for Lab Application) ). The Cell 1 power used in the lab application is identical to the Cell power used in the test application. For more information about Cell 2 power which is only available in the lab application, see Configuring Cell 2 Used for Soft/Softer Handoff .

For the lab application , an external AWGN value is displayed when the test set is configured to generate faded forward channel signals with AWGN. This setup requires a rear panel digital bus connection to an external PC running Baseband Studio software. See Digital Bus Information for details.

Generated Power Level Information (for Lab Application)

GPIB Commands Summary

The test set includes commands to set the desired cell power and AWGN power levels. You may also query what you've set these desired power levels to, as well as query what the total RF power will be based on your desired cell power and AWGN power levels. See RF Power Levels .

The test set also includes commands to query the current level of cell power, AWGN power, and total RF power. See RF Power Levels . These CALL:STATus commands are query only. They return values that indicate the test set's actual hardware settings and hardware status. Actual hardware settings can differ from the desired level you've set. When no error conditions exist, the commands used to set the desired level will return the same results as the commands used to query current level. For example, "CALL:AWGNoise:POWer?" will return the same value as "CALL:STATus:AWGNoise:POWer?" when no error conditions exist.

RF Power Levels
Parameter | Current Level | Desired Level
Cell Power | CALL:STATus:CELL[1]:POWer:[AMPLitude][:SELected]? | CALL[:CELL[1]]:POWer[:SAMPlitude][:SELected]
AWGN Power | CALL:STATus:AWGNoise[:INTernal]:POWer[:AMPLitude][:SELected]? | CALL:AWGNoise[:INTernal]:POWer[:SAMPlitude]<[:SELected]|:DIGital2000|:DIGital95>
Total RF Power | CALL:STATus:TOTal:POWer[:AMPLitude][:SELected]? | CALL:TOTal:POWer[:AMPLitude][:SELected]? (query only)

Cell Power, AWGN Power and Total RF Power Ranges

The range of values that you can set these power levels to differs from the actual hardware range of the source. This is due to compensation for path loss between the test set RF output port and the mobile station antenna connector (see Amplitude Offset ).

For example, if you enter a value of -30 dBm for desired CW cell power, this indicates that you want -30 dBm of power at the mobile station antenna connector. So, if you have indicated an amplitude offset of -3.5 dB exists between the test set's RF In/Out port and the mobile station antenna connector, the source will actually have to output -26.5 dB in order to deliver -30 dB to the mobile station's antenna connector. Thus, with an amplitude offset of -3.5 dB, the settable range of CW cell power is -130.5 dB to -13.5 dB. The actual power range at a given time is defined by adding the value of the associated amplitude offset to the actual hardware range. If you select an invalid combination of power levels and amplitude offsets, an error message will appear.

Range of Power Levels
Parameter | Actual Hardware Range with Amplitude Offset = 0 (RF In/Out Port) | Actual Hardware Range with Amplitude Offset = 0 (RF Out Only Port) | Setting (or Query) Range
Cell Power (AMPS, CW) | -127 dBm to -10 dBm | -119 dBm to -2 dBm | -177 dBm to +40 dBm
Cell Power (DIG95, DIG2000) | -120 dBm/1.23 MHz to -13 dBm/1.23 MHz | -115 dBm/1.23 MHz to -5 dBm/1.23 MHz | -170 dBm/1.23 MHz to +37 dBm/1.23 MHz
AWGN Power (DIG95, DIG2000) | -120 dBm/1.23 MHz to -15 dBm/1.23 MHz | -115 dBm/1.23 MHz to -7 dBm/1.23 MHz | -170 dBm/1.23 MHz to +35 dBm/1.23 MHz
Total RF Power | -120 dBm/1.23 MHz to -10.88 dBm/1.23 MHz | -115 dBm/1.23 MHz to -2.88 dBm/1.23 MHz | -170 dBm/1.23 MHz to +42 dBm/1.23 MHz

NOTE
When the cdma2000 lab application is installed and selected, the test set has the ability to simulate two individual base stations, referred as Cell 1 Power and Cell 2 Power. The Cell 1 Power used in the lab application is identical to the Cell Power used in the test application. For more information on Cell 2 which is only available in the lab application, see Configuring Cell 2 Used for Soft/Softer Handoff .

Rules for Setting Power Levels and Amplitude Offsets

  • The difference between cell power and AWGN power must not be more than 20 dB when both power states are set to ON.
  • The total RF power and amplitude offset must not set the source outside its valid hardware range.

Related Topics

How Do I Change Call Parameters?

How Do I Change AWGN Power Levels?

Configuring Forward Channel Power Levels and Walsh Codes

Troubleshooting Setting Power Levels

Configuring Cell 2 Used for Soft/Softer Handoff

Terminologies on the Test Set Adherence to Standard


Configuring the Forward Quick Paging Channel (F-QPCH)

Configuring the Forward Quick Paging Channel (F-QPCH)

Last updated: October 28, 2004

The quick paging channel (for IS-2000 system only) is sent by the test set to inform the slotted mode mobile stations, operating in the idle state, whether to monitor the paging channel (F-PCH) or the forward common control channel (F-CCCH). Quick paging feature if supported by the mobile station will further conserve battery power beyond the savings achieved by slotted mode operation.

Settable F-QPCH Parameters

The F-QPCH related parameters are sent to the mobile station over the Extended System Parameter Message or MC-RR Parameter Message depending upon current control channel. See Setting Control Channel Parameters for details about the following parameters.

  • F-QPCH State: See CALL:QPCHannel:STATe[:SELected] .

    To access the GPIB command for Curr F-QPCH State (displayed in the Cell Parameters table), see CALL:STATus:QPCHannel:STATe[:SELected]? .

  • F-QPCH Relative to Pilot Level ( CALL: QPCHannel[:SLEVel]:RTPilot[:SELected] .): See Control Channel Parameters (F-BCCH/F-CCCH/R-EACH) .

    To access the GPIB command for Curr F-QPCH Level (Rel to Pilot) (displayed in the Cell Parameters table), see CALL:STATus:QPCHannel[:LEVel]:RTPilot[:SELected]? .

  • F-QPCH Data Rate ( CALL:QPCHannel:DRATe ): When the QPCH data rate is set to FULL (4.8 kbps), the QPCH indicator rate is 9.6 kbps (corresponding to the value of QPCH_RATE field in Extended System Parameter message or MC-RR Parameter Message set to 1). When the QPCH data rate is set to Half (2.4 kbps), the QPCH indicator rate is 4.8 kbps (corresponding to the value of the QPCH_RATE field set to 0).

    QPCH_Chip_Bit
    F-QPCH Data Rate QPCH_Chip_Bit

    QPCH_Chip_Bit (dB)

             Comments
    Full (4800 bps) | 256 | 24.08 | QPCH_Chip_Bit is the number of PN chips per Quick Paging Channel bit. For Spreading Rate 1, QPCH_Chip_Bit is equal to 256 x v where v equals 1 when the data rate is 4800 bps and v equals 2 when the data rate is 2400 bps. It is used for F-QPCH E b /N t calculation (see F-QPCH Eb/Nt ).
    Half (2400 bps) | 512 | 27.09

  • QPCH Indicator bits (applied only when the test set's operating mode is IS-2000 test mode): See CALL:D2KTest:QPCHannel:INDicator[:PAGing] .

Fixed F-QPCH Parameters

  • QPCH_CCI_SUPPORTED is fixed at 0.

  • NUM_QPCH is fixed at 1.

  • The F-QPCH Walsh code is fixed at code channel number 80 with walsh length 128.

F-QPCH E b /N t

The F-Paging E b /N t is a calculated value (see Example ). It's available only when Cell 1 Power, AWGN Power and F-QPCH Channel states are on and determined by:

Equivalent to:

F-QPCH E b /N t (dB) = F-Pilot Level (dB) + F-QPCH Relative to Pilot Level (dB) + Cell Power (dBm/1.23 MHz) + QPCH_Chip_Bit (dB) - AWGN Power (dBm/1.23 MHz)

  • See Configuring Cell Power and AWGN Power Levels for Cell Power and AWGN Power settings. Note that for Lab Application , when Cell 2 Power is on, the AWGN power consists of the AWGN power and the Cell 2 power if their states are on.
  • See Settable F-QPCH Parameters for F-QPCH Level settings.
  • See Configuring Forward Channel Power Levels and Walsh Codes for F-Pilot Level settings.
  • See QPCH_Chip_Bit for QPCH_Chip_Bit value which is determined by F-QPCH Data Rate.

Example

Assuming,

Cell Power = -55 dBm/1.23 MHz
AWGN Power = -54 dBm/1.23 MHz
F-Pilot Level = -7 dB
F-QPCH Relative to Pilot Level = -3 dB
F-QPCH Data Rate = Full (4800 bps), corresponding to 24.08 dB

then,

F-QPCH E b /N t (dB) = (-7) + (-3) + (-55) + 24.08 - (-54) = 13.08 dB

GPIB Examples:

Setting F-QPCH Level (relative to pilot channel level)

OUTPUT 714;"CALL:QPCH:RTP -3 DB"

would set the F-QPCH state on and set the level, relative to the forward channel pilot, to -3 dB. See CALL: QPCHannel[:SLEVel]:RTPilot[:SELected] .

Querying F-QPCH Level (relative to cell power level)

OUTPUT 714;"CALL:QPCH:LEVel?"

would query the last F-QPCH relative to cell power level setting. See CALL: QPCHannel:LEVel[:RTCell][:SELected]? .

Operating Considerations

The Walsh code number for the QPCH channel is fixed at code 80 from the Walsh 128 set.

When the QPCH state is on, the test set will send out slotted quick pages (single mode) regardless of the mobile station's ability to support quick paging. If the mobile station does not support quick paging, the presence of quick pages should not affect its ability to respond to normal pages.

When the QPCH state is on (see CALL:QPCHannel:STATe[:SELected] ), the OCNS (see Configuring the Forward Orthogonal Channel Noise Simulator (F-OCNS/OCNS) ) is calculated based on the channel power when QPCH is present in the signal. When the QPCH state is off, the output power is not fully calibrated.

Related Topics

Setting Control Channel Parameters


Radio Configuration

Radio Configuration

Last updated: October 28, 2004

The radio configuration is a set of forward traffic channel and reverse traffic channel transmission formats that are characterized by physical layer parameters such as data rates, modulation characteristics, and spreading rates. The traffic channel may consist of one or more code channels such as fundamental channel, supplemental channel.

The test set's base station emulator provides five radio configuration selections for IS-2000 system. The radio configuration specifies the base data rate and service options supported (see Service Option ).

Radio Configurations
Radio Config | Programming Mnemonic | C.S0002-A Standard |  | Test Mode in TIA/EIA-98-E
 |  | Forward Traffic Channel Radio Configuration | Reverse Traffic Channel Radio Configuration
(Fwd1, Rvs1) | F1R1 | RC1 | RC1 | 1
(Fwd2, Rvs2) | F2R2 | RC2 | RC2 | 2
(Fwd3, Rvs3) | F3R3 | RC3 | RC3 | 3
(Fwd4, Rvs3) | F4R3 | RC4 | RC3 | 4
(Fwd5, Rvs4) | F5R4 | RC5 | RC4 | 5
The traffic channel may consist of one or more code channels such as fundamental channel, supplemental channel.

Radio Configuration can be changed at any time, but is not applicable till next connection if having connected.

Related Topics

GPIB Command: CALL:RCONfig

Manual Operation: How Do I Change Call Parameters?


Receiver Control

Receiver Control

Last updated: February 1, 2007

  • Automatic Receiver Control
  • Manual Receiver Control in Active Cell Operating Mode
  • Manual Receiver Control in IS-2000 Test Operating Mode
  • Manual Receiver Control in AVC Test Operating Mode
  • Manual Receiver Control in CW Operating Mode
  • Under Range/Over Range Errors
  • Effects on Receiver Control When Changing Operating Mode

The test set's receiver includes two frequency downconverters:

  • Measurement downconverter
  • Demodulation downconverter

The Demodulation downconverter is used to establish and maintain the call (RF link) between the mobile station and test set, while the Measurement downconverter is optimized for measurements.

Refer to the Block Diagram for a description of the Signal Downconversion paths.

Automatic Receiver Control

By default, the test set automatically tunes to the correct frequencies for making measurements and maintaining a call. Also, the test set adjusts attenuation settings according to the power level that should be present at the RF IN/OUT port given the current settings. This power level is referred to as the Expected Power ( Expected Power ), and the current value for Expected Power is displayed on many of the transmitter power measurement screens (for example, the measurement screen for digital average power, channel power, and access probe power).

When operating in Active Cell Operating Mode, with IS-2000 or IS-95 selected as the System Type, Expected Power is derived essentially from the Cell Power setting according to open loop power control behavior, but Expected Power is also offset by other settings such as:

  • Access Parameters
  • Data Rate
  • Encoder Type

Tune frequencies are derived from the Channel field setting.

In some instances you may want to control the test set's receiver settings manually rather than allowing the test set to automatically control them. This ability is referred to as manual receiver control.

Manual Receiver Control in Active Cell Operating Mode

For front panel operation, see How Do I Change Test Set's Receiver Control Parameters? .

Manual receiver power

When manual receiver power control is selected, an additional field is displayed below Rcvr Power Ctrl. That field is labeled Receiver Power, and when it is displayed automatic power control is disabled. The test set will adjust its attenuation to receive a signal at the level indicated by the Receiver Power field.

When the selected System Type is IS-2000 or IS-95 (cdma systems), the Receiver Power field is set programmatically using the RFANalyzer:MANual:POWer[:SELected] command.

When reverse power control (Rvs Power Ctrl) is set to Active bits, closed loop power control will drive the mobile station's transmitted power to the power level set in the Receiver Power field. To effectively disable closed loop power control and inhibit the test set's ability to drive the mobile station power level to the manually set Receiver Power, select alternating bits in the Rvs Power Ctrl field. With alternating bits selected in the Rvs Power Ctrl field, cell power level changes will control the mobile station's power level according to open loop power control behavior.

When the selected System Type is AMPS, the Receiver Power field is set programmatically using the RFANalyzer:MANual:ANALog:POWer[:SELected] commands. The mobile station power level will continue to be controlled by the Anl MS TX Level field setting.

Measurement downconverter frequency

When a frequency is entered in the Meas Frequency field, the selection labeled Auto is replaced by a manual receiver control tune frequency. The receiver will no longer be tuned according to the channel number entered in the Channel field (for IS-2000 or IS-95) or the ACC Channel (for AMPS).

The measurement receiver frequency commands used to manually tune the test set's measurement downconverter input signal path (see Block Diagram ) are:

  • RFANalyzer:CONTrol:MEASurement:FREQuency:AUTO (to turn manual mode on/off)

  • RFANalyzer:MANual:MEASurement[:MFRequency] (to specify a frequency and turn manual mode on)

  • RFANalyzer:MANual:MEASurement:FREQuency (to specify a frequency)

Demodulation downconverter frequency

In Active Cell operating mode, there is no access to manual control of the demodulation receiver frequency. (Refer to the Block Diagram for a description of the Signal Downconversion paths.)

Manual Receiver Control in IS-2000 Test Operating Mode

For front panel operation, see How Do I Change Test Set's Receiver Control Parameters? .

Manual receiver power

When manual receiver power control is selected, automatic power control is disabled and an additional field is displayed. That field is labeled Receiver Power. The test set will adjust its attenuation to receive a signal at the level indicated by the Receiver Power field.

The Receiver Power field is set programmatically using the RFANalyzer:MANual:POWer[:SELected] command.

In test mode the mobile station can be programmed to respond to closed loop power control bits. If the mobile station is responding to power control bits, and with alternating bits selected in the Rvs Power Ctrl field, cell power level changes will control the mobile station's power level according to open loop power control behavior.

Measurement downconverter frequency

When a frequency is entered in the Meas Frequency field, the selection labeled Auto is replaced by a manual receiver control tune frequency. The receiver will no longer be tuned according to the channel number entered in the Channel field.

The measurement receiver frequency commands used to manually tune the test set's measurement downconverter input signal path are:

  • RFANalyzer:CONTrol:MEASurement:FREQuency:AUTO (to turn manual mode on/off)

  • RFANalyzer:MANual:MEASurement[:MFRequency] (to specify a frequency and turn manual mode on)

  • RFANalyzer:MANual:MEASurement:FREQuency (to specify a frequency)

Demodulation downconverter frequency

When a frequency is entered in the Rvs Link Freq field, the selection labeled Auto is replaced by a manual receiver control tune frequency. In manual mode, the receiver's demodulation downconverter will no longer be tuned according to the channel number entered in the Channel field.

The commands used to manually tune the test set's demodulation downconverter input signal path are:

  • RFANalyzer:CONTrol:UPLink:FREQuency:AUTO (to turn manual mode on/off)

  • RFANalyzer:MANual:UPLink[:MFRequency] (to specify a frequency and turn manual mode on)

  • RFANalyzer:MANual:UPLink:FREQuency (to specify a frequency)

NOTE
Manual control of the demodulation receiver frequency is rarely needed. Use the measurement receiver when manual receiver frequency control is required.

Manual Receiver Control in AVC Test Operating Mode

For front panel operation, see How Do I Change Test Set's Receiver Control Parameters? .

Manual receiver power

When manual receiver power control is selected, automatic power control is disabled and an additional field is displayed. That field is labeled Receiver Power. The test set will adjust its attenuation to receive a signal at the level indicated by the Receiver Power field.

The Receiver Power field is set programmatically using the RFANalyzer:MANual:ANALog:POWer[:SELected] command.

In test mode the mobile station can be programmed to respond to closed loop power control bits. If the mobile station is responding to power control bits, and with alternating bits selected in the Rcvr Power Ctrl field, cell power level changes will control the mobile station's power level according to open loop power control behavior.

Measurement downconverter frequency

When a frequency is entered in the Meas Frequency field, the selection labeled Auto is replaced by a manual receiver control tune frequency. The receiver will no longer be tuned according to the channel number entered in the AVC Channel field.

The commands used to manually tune the test set's measurement downconverter input signal path are:

  • RFANalyzer:CONTrol:MEASurement:FREQuency:AUTO (to turn manual mode on/off)

  • RFANalyzer:MANual:MEASurement[:MFRequency] (to specify a frequency and turn manual mode on)

  • RFANalyzer:MANual:MEASurement:FREQuency (to specify a frequency)

Demodulation downconverter frequency

When a frequency is entered in the Rvs Link Freq field, the selection labeled Auto is replaced by a manual receiver control tune frequency. In manual mode, the receiver's demodulation downconverter will no longer be tuned according to the channel number entered in the AVC Channel field.

The commands used to manually tune the test set's demodulation downconverter input signal path are:

  • RFANalyzer:CONTrol:UPLink:FREQuency:AUTO (to turn manual mode on/off)

  • RFANalyzer:MANual:UPLink[:MFRequency] (to specify a frequency and turn manual mode on)

  • RFANalyzer:MANual:UPLink:FREQuency (to specify a frequency)

NOTE
Manual control of the demodulation receiver frequency is rarely needed. Use the measurement receiver when manual receiver frequency control is required.

Manual Receiver Control in CW Operating Mode

For front panel operation, see How Do I Change Test Set's Receiver Control Parameters? .

Manual receiver power

When the Receiver Control softkey is selected, a menu drops down that includes a setting for Expected CW Power. The test set will adjust its attenuation to receive a signal at the level indicated by the Expected CW Power.

For CW operating mode, the Expected CW Power from the mobile station is set manually using the RFANalyzer:CW:EXPected:POWer commands.

Measurement downconverter frequency

When the Receiver Control softkey is selected, a menu drops down that includes a setting for Measurement Frequency.

The commands used to manually tune the test set's measurement downconverter input signal path are:

  • RFANalyzer:CONTrol:MEASurement:FREQuency:AUTO (to turn manual mode on/off)

  • RFANalyzer:MANual:MEASurement[:MFRequency] (to specify a frequency and turn manual mode on)

  • RFANalyzer:MANual:MEASurement:FREQuency (to specify a frequency)

Demodulation downconverter frequency

When the Receiver Control softkey is selected, a menu drops down that includes a setting for Uplink Frequency.

The commands used to manually tune the test set's demodulation downconverter input signal path are:

  • RFANalyzer:CONTrol:UPLink:FREQuency:AUTO (to turn manual mode on/off)

  • RFANalyzer:MANual:UPLink[:MFRequency] (to specify a frequency and turn manual mode on)

  • RFANalyzer:MANual:UPLink:FREQuency (to specify a frequency)

NOTE
Manual control of the demodulation receiver frequency is rarely needed. Use the measurement receiver when manual receiver frequency control is required.

Under Range/Over Range Errors

The test set uses the expected power level to establish a range of acceptable input levels into its receivers. If the received signal is above or below the acceptable range, an Over Range or an Under Range message is displayed and the integrity value for the measurement is set to 5 or 6 (respectively). Refer to Integrity Indicator for details about the integrity values.

You can set the expected power level beyond the capability of the test set's hardware because expected power is intended to reflect the potential range of RF power at the mobile station . This range of RF power is meant to accommodate the use of a gain or loss network between the mobile station and the test set. See Amplitude Offset for details about amplitude offset.

The upper and lower limits of expected power provide boundaries for the combination of amplitude offset and expected power. For example: in Active Cell Operation Mode if you set expected power to +52 dBm and the amplitude offset to -3 dB, the calculated receiver power will be +49 dBm, but the test set shall be set to +30 dBm, the upper limit of the hardware. If the calculated value of receiver power goes below -79 dB, the lower limit of the hardware, the test set shall be set to -79 dB.

Effects on Receiver Control When Changing Operating Mode

After selecting the operating mode and setting one or more receiver controls to manual, the receiver control settings remain as you set them until you change operating mode. Changing operating mode (except for CW which defaults to manual) causes some or all receiver parameters to return to automatic control.

Related Topics

RFANalyzer

Expected Power

CW Operating Mode

AVC Test Operating Mode

IS-2000 Test Operating Mode


Setting Registration Parameters

Setting Registration Parameters

Last updated: October 28, 2004

The test set's base station emulator provides control over the registration parameters described below. To set registration parameters using the test set's front panel, see D. Registration Parameters .

IS-2000/IS-95 Registration Parameters

The following registration parameters are displayed under the Registration Parameters menu when the following two conditions exist:

  1. The Operating Mode field is set to Active Cell (see Active Cell Operating Mode ) or Cell Off, and
  2. IS-2000 or IS-95 is selected in the System Type field.
  • Timer Based Registration State (see CALL:REGister:TIMer:STATe )
  • Registration Period (see CALL:REGister:TIMer:RPERiod )
  • Power Up Registration State (see CALL:REGister:PUP[:STATe] )


Service Option

Service Option

Last updated: June 13, 2007

Service options specify the service capabilities of the IS-95 or IS-2000 system. Each service option is identified by a unique service option number which may be used for standard services such as voice, data, or short message services, as well as for proprietary (non-standard) services such as SO32768 specific to Qualcomm Inc.

The test set base station emulator supports the following service options for the selected system type and/or radio configuration (see Radio Configuration ).

Service Options
Service Option Setup | Description | IS-95 System | IS-2000 System
 |  |  | (Fwd1, Rvs1) | (Fwd2, Rvs2) | (Fwd3, Rvs3) | (Fwd4, Rvs3) | (Fwd5, Rvs4)
SO1 (Voice) | Basic Variable Rate Voice Service (8 kbps) | x | x |  | x | x |
SO2 (Loopback) | Mobile Station Loopback (8 kbps) | x | x |  | x | x |
SO3 (Voice) | Enhanced Variable Rate Codec (EVRC) Voice Service (8 kbps) | x | x |  | x | x |
SO6 (SMS) | Short Message Services (Rate Set 1) | x | x |  | x | x |
SO9 (Loopback) | Mobile Station Loopback (13 kbps) | x |  | x |  |  | x
SO14 (SMS) | Short Message Services (Rate Set 2) | x |  | x |  |  | x
SO17 (Voice) | High Rate Voice Service (13 kbps) | x |  | x |  |  | x
SO32 (+F-SCH) * | Test Data Service Option (TDSO) |  |  |  | x | x |
SO32 (+ SCH) * | Test Data Service Option (TDSO) |  |  |  | x | x |
SO33 * | cdma2000 High Speed Packet Data Service, Internet or ISO Protocol Stack |  |  |  | x | x | x
SO33 (+F-SCH) * | cdma2000 High Speed Packet Data Service, Internet or ISO Protocol Stack |  |  |  | x | x |
SO55 (Loopback) | Loopback Service Option (LSO) |  | x | x | x | x | x
SO68 (Voice) | EVRC-B Voice Service (8 kbps) | x | x |  | x | x |
SO32768 (Voice) | Proprietary Service Option (Qualcomm Inc.) | x |  | x |  |  | x
* The service option is only applicable in Lab Application.

Setting Considerations

The current service option is determined by the current system type and the current radio configuration.

When a call is being connected, changing the service option for the current radio configuration for the IS-2000 system will be rejected. If the service option is changed for a non-current radio configuration for IS-2000 system, the new value is stored until the associated radio configuration is active.

The test set does not negotiate service options during a call establishing (the call is originated either from the test set or from the mobile station). If the mobile station rejects or tries to negotiate a different service option other than the test set proposed (set by FCH Service Option Setup ( F12 ) on Call Parms 1 of 4), the test set will generate an error and not establish the call.

For SO1, SO3, SO17, SO68 or SO32768 connection, the test set will generate data on the forward traffic channel from the specified voice source (see Voice SO Mode ).

For SO2, SO9 or SO55 connection, the test set commands the mobile station to go into loopback using the specified traffic data rate (see Traffic Data Rate ).

The SO32 (+F-SCH) and the SO32 (+SCH) are service options primarily used for testing supplemental channel. See What is a TDSO (Test Data Service Option) FER (Frame Error Rate) measurement? for details. If a call is established with Service Options SO32(+F-SCH)" or SO32(+SCH), the test set will establish an F-FCH with SO32 service option using a full rate fixed data pattern of all `1's and assume full rate R-FCH (SO32) for the purposes of receiver ranging (the Traffic Data Rate does not apply in SO32(+F-SCH) service option). See Reverse Traffic Channel Data Rate Determination . The F-SCH and/or R-SCH is then established with SO32 service option according to the F-SCH and or R-SCH parameters (see Configuring the TDSO Supplemental Channel Information ).

The SO33 and SO33 (+F-SCH) packet data service options are only available in the lab application. See Packet Data Service Configurations for details.

Related Topics

GPIB Command: CALL:SOPTion

Manual Operation: How Do I Change Call Parameters?


Configuring the Forward Sync Channel (F-Sync/Sync)

Configuring the Forward Sync Channel (F-Sync/Sync)

Last updated: November 10, 2006

The F-Sync/Sync channel parameters are configured using the CALL:SYNC subsystem commands. To set the parameters using the test set's front panel, see How Do I Change Generator Information?

Settable F-Sync/Sync Parameters

  • level.
  • state.

Fixed F-Sync/Sync Parameters

The F-Sync/Sync Walsh code is fixed at code channel number 32.

GPIB Examples:

Setting the F-Sync State and Level (complex command)

OUTPUT 714;"CALL:SYNC -16 DB"

would set the F-Sync state on and set the level to -16 dB. See CALL:SYNC[:SLEVel][:SELected] .

Querying the F-Sync Level

OUTPUT 714;"CALL:SYNC:LEVel?"

would query the last setting that was made to the F-Sync level. See CALL:SYNC:LEVel[:SELected] .

Operating Considerations

The Walsh code number for the F-Sync channel is fixed at code 32 of the Walsh 64 set.

There are some format changes for Sync Channel message sent to the mobile station on the Sync channel as required for different protocol revisions. See Settable Fields in Overhead Messages .

Related Topics

How Do I Change Generator Information?


Selecting a Cellular System Type

Selecting a Cellular System Type

Last updated: October 28, 2004

To select a cellular system type using the test set's front panel, see How Do I Set Up a Call? .

The mobile station's cellular system type is selected using the CALL[:CELL]:SYSTem[:TYPE] call processing subsystem commands.

Available System Types

The following system types are displayed under the System Type menu when the Operating Mode is set to Active Cell (see Active Cell Operating Mode ) or Cell Off.

  • IS-2000 (CALL:SYSTem DIGital2000)
  • IS-95 (CALL:SYSTem DIGital95)
  • AMPS (CALL:SYSTem AMPS)


Configuring the TDSO Supplemental Channel Information

Configuring the TDSO Supplemental Channel Information

Last updated: November 1, 2004

The forward and reverse supplemental channels (F-SCH and R-SCH) are used for high speed data transfer in IS-2000 system. The test set supports the supplemental channels when the service option ( Service Option ) is set to the test data service option (TDSO): SO32 (+F-SCH) or SO32 (+ SCH) in Radio Config (Fwd3, Rvs3) or Radio Config (Fwd4, Rvs3).

  • When a call is connected with SO 32 (+ F-SCH) service option, only F-SCH channel is established.
  • When a call is connected with SO 32 (+ SCH) service option, both F-SCH and R-SCH channels will be established.

NOTE
For lab application, the supplemental channels are also available for packet data service. See Packet Data Service Configurations .

The test set allows you to set the TDSO supplemental channel parameters regardless of the service option currently selected. However, the supplemental channel parameters are not applied until the supplemental channels are available. The F-SCH information and/or R-SCH information you've set are displayed on the TDSO Supplemental Channel Information screen when they are applied.

Almost all of the parameters associated with the F-SCH and R-SCH channels are accessed from the TDSO supplemental channel information menus (see How Do I Change TDSO Supplemental Channel Information? ) or using the CALL:SCHannel commands. To set the F-SCH power level, see How Do I Change Generator Information? .

TDSO F-SCH and R-SCH Parameters

Channels

Parameters

(Fwd3, Rvs3)

(Fwd4, Rvs3)

SO32 (+ F-SCH)

SO32 (+ SCH)

SO32 (+ F-SCH)

SO32 (+ SCH)

F-SCH

Data Rate

CALL:SCHannel[:FORWard]:DRATe:RCONfig3

CALL:SCHannel[:FORWard]:DRATe:RCONfig4

Encoder Type

CALL:SCHannel[:FORWard]:ENCoder

CALL:SCHannel[:FORWard]:ENCoder

Data Source

CALL:SCHannel:TDSOption:DSOurce

CALL:SCHannel:TDSOption:DSOurce

Fixed Pattern

CALL:SCHannel:TDSOption:FPATtern

CALL:SCHannel:TDSOption:FPATtern

R-SCH

Data Rate

N/A

CALL:SCHannel:REVerse:DRATe:RCONfig3

N/A

CALL:SCHannel[:FORWard]:DRATe:RCONfig4

Encoder Type

CALL:SCHannel:REVerse:ENCoder

CALL:SCHannel:REVerse:ENCoder

Service Configuration Max Rate

CALL:SCHannel:REVerse:DRATe:MAXimum

CALL:SCHannel:REVerse:DRATe:MAXimum

NOTE:

  • The F-SCH Walsh code is fixed at code channel number 3.
  • To set the reverse link gain traffic to pilot for R-SCH, see RL Traffic to Pilot Gain (RLGAIN_TRAFFIC_PILOT) on Setting Cell Parameters .

IMPORTANT
The F-SCH Parameters menu allows for the selection of PRBS or Fixed Pattern data source. This choice is also applied to the reverse supplemental channel. PRBS data is required and is the only data source supported if you are making any of the code domain measurements on the reverse supplemental channel. If PRBS data is not selected, the code domain power results (see Waveform Quality/Code Domain Measurement Description ) will not display distinct code channels with the expected spreading factors.

Related Topics

How Do I Change TDSO Supplemental Channel Information?


IS-2000 Test Operating Mode

IS-2000 Test Operating Mode

Last updated: October 28, 2004

When the test set is in IS-2000 Test operating mode (as opposed to Active Cell operating mode) it is necessary for the mobile station under test to be capable of independently performing operations that normally occur through over-the-air signaling. This capability is referred to as test mode and is usually accomplished using commands which are sent to the mobile station from a system controller (usually a personal computer) through a proprietary digital interface. For more details on IS-2000 Test operating mode, see the product note:

  • Agilent Technologies E1962A IS-2000 Test Mode Requirements for Mobile Stations

NOTE
The Agilent Technologies E1962A IS-2000 Test Mode Requirements for Mobile Stations product note is also applicable to the E1962B test application with the E5515C test set in IS-2000 Test operating mode.

To make measurements on the reverse channel in test mode, the mobile station must first synchronize to the test set's forward pilot channel and demodulate the sync and paging channels. This is consistent with normal system acquisition procedures and results in the mobile station reaching the mobile station idle state. In active cell operating mode, the mobile station at this point would autonomously perform a power-up registration after entering the idle state. A call could then be initiated, using over-the-air call processing, and the fundamental channel would be established and maintained according to the applicable message protocol.

However, in test mode the test set and mobile station are directed to the same FCH (fundamental channel) by the system controller or through manual user interfaces without over-the-air call processing.

Forward CDMA channels available in test mode

In test mode, the test set can be configured to transmit a forward channel that emulates a base station operating in radio configuration (RC) 1, 2, 3, 4 or 5. See Forward Link Overview .

Related Topics

Active Cell Operating Mode


Voice SO Mode

Voice SO Mode

Last updated: June 12, 2007

Voice SO mode determines the source of traffic data to be sent on the forward traffic channel (F-Traffic) (for IS-95 system) or the forward fundamental channel (F-FCH) (for IS-2000 system) to the mobile station (MS) when any of the voice service options (SO1, SO3, SO17, SO68, and SO32768) (see Service Option ) is active.

If the current service option is other than voice service options (SO1, SO3, SO17, SO68, and SO32768), the setting of the Voice SO mode will be stored and applied when a voice service option is active.

Voice SO Mode
Voice SO Mode | Description
Voice echo | In echo mode the test set sends on the F-Traffic/F-FCH a copy of the frames it receives on the R-Traffic/R-FCH. This is referred to as "echo" mode since the sound captured by the mobile station's microphone are sent to the test set and then returned to the MS to be produced in the MS's speaker. The delay between the receipt of a frame on the R-FCH and its subsequent retransmission on the F-FCH can be set by the Echo Delay (see CALL[:CELL[1]]:TRAFfic[:FORWard]:SOURce:ECHO ).
400 Hz tone | This selection causes a vocoded 400 Hz tone to be sent on the F-Traffic/F-FCH to the MS.
1 KHz tone | This selection causes a vocoded 1 kHz tone to be sent on the F-Traffic/F-FCH to the MS.
Swept audio | This selection causes a vocoded repeatedly swept tone rising from 0 Hz to 3.0 kHz over 3 seconds to be sent on the F-Traffic/F-FCH to the MS. It is intended to be used for functional test and not as a portion of any audio quality tests.
Multi-Tone | This selection is used to generate multiple audio tones simultaneously. It is used in conjunction with the multi-tone audio measurement while operating in downlink audio mode. This causes downlink audio generator tones to be encoded and gets placed on the F-Traffic/F-FCH channels. See Downlink Audio Mode for details.
Real-Time Vocoder | In real-time vocoder mode, the test set real-timely encodes the analog audio signal applied at the test set's AUDIO IN connector using the appropriate vocoder algorithm (depending upon the selected voice service option) and then sends the encoded audio frames to the mobile station on the F-Traffic/F-FCH. Also, the test set can simultaneously decodes the encoded audio frames that is received on the R-Traffic/R-FCH using the appropriate vocoder algorithm (depending upon the selected voice service option) and then converts to an analog signal output at the test set's AUDIO OUT connector. See Real-Time Vocoder for details.
Null Frames | This selection causes minimal energy frames to be sent on the F-Traffic/F-FCH. It is intended to be used with the multi-tone audio measurement while operating in uplink audio mode. See Uplink Audio Mode for details.

Setting Considerations

  • All of the measurements except for the multi-tone audio measurement become unavailable when the Voice SO Mode is set to Multi-Tone or Null Frame . This is because many of the DSP resources are consumed for producing the audio signal and running the vocoder so there are not enough left to perform other measurements.
  • When the Voice SO Mode is set to Real-Time Vocoder , all of the measurements and instruments except for the Frame Error Rate measurement, Audio Generator and Data throughput Monitor, are unavailable. This is because many of the DSP resources are consumed to meet the real-time requirements for vocoder frame delivery or analog audio generation.

Related Topics

GPIB Command:
CALL[:CELL[1]]:TRAFfic[:FORWard]:SOURce (for IS-95 system)
CALL[:CELL[1]]:FCHannel[:FORWard]:SOURce (for IS-2000 system)

Manual Operation: How Do I Change F-FCH/Traffic Channel Parameters?


Performing a Hard Handoff

Performing a Hard Handoff

Last updated: June 20, 2006

The test set provides two alternative methods for performing hard handoffs, implicit and explicit.

An explicit handoff allows several handoff parameters to be changed without a handoff attempt. Before performing an explicit handoff, you must first specify the handoff parameters from the Handoff Setup menu (see Setting Hard Handoff Parameters ). A handoff attempt is performed only when the Execute Handoff key is pressed. See How Do I Perform a Hard Handoff? .

An implicit handoff is simply a side effect of changing a parameter and a handoff attempt is performed immediately. For example, when you enter a new channel number in the Channel field or select a new Cell Band , the setting is immediately applied and the MS is directed to the new band or channel.When in the IS-95 or IS-2000 system, changing the following parameters results in an implicit handoff:

  • Cell Band ( Cell Band )
  • Channel ( RF Channel Number )
  • PN Offset ( How Do I Change Generator Information? )
  • PLCM Type (only for IS-2000 system and MEID-equipped MS, see PLCM Type )

Related Topics

Setting Hard Handoff Parameters

How Do I Perform a Hard Handoff?

Performing Soft/Softer Handoffs with the Test Set ( Lab Application only )


Performing a Registration

Performing a Registration

Last updated: June 20, 2006

Registration is the process by which the mobile station notifies the test set of its status, identification, slot cycle, and other characteristics so that the test set can efficiently page the mobile station when establishing a mobile station terminated call ( Establishing an Active Link with the Mobile Station ).

Registering a mobile station can be performed when the mobile station has found service with the test set's base station emulator in active cell operating mode. When a registration has completed, the Mobile Station Information window will display the registration data received from the mobile station. See Mobile Reported Information for a description of registration data received from the mobile station.

Registration Types

The test set supports the following types of registrations:

  • Zone-based registration, also referred to as "forced" registration by pressing F5 ( Send Register ) on Call Control 1 of 3 menu or sending CALL:REGister[:IMMediate] command.
  • Timer-based registration: the mobile station registers when a timer expires. The test set provides a setting for the time interval between registrations. See Setting Registration Parameters .
  • Power-up registration: The mobile station registers when it powers on. Mobile stations perform a power-up registration the first time service is found after being powered on.

    Power-up registration can be disabled (see Setting Registration Parameters ) if the mobile station's IMSI is known and directly specified using Paging IMSI Setup . This provides a quicker way to page the mobile station without waiting for the mobile station first being registered.

Operation Considerations

Each time a new mobile station (determined by identifying a different ESN) registers with the test set, the test set will request the mobile station to report its band classes, the operating mode for each band class, and the max EIRP (if the operating mode is CDMA) for each band class. These results are referred to as Status Request Information. This is done during registrations only if the information had been previously cleared and status requests are enabled ( Paging IMSI Setup ). The Status Request Information results take a amount of time to be updated.

Each time a new mobile station (determined by identifying a different ESN) registers with the test set, some of mobile station capabilities results (such as FCH/DCCH Capability Information, F-SCH Capability Information, R-SCH Capability Information. see CALL:MS:REPorted:CAPability ) will not automatically reported to the test set until being queried by executing ( Call Control 2 of 3 -> F6 ( MS Capability Info ) -> F1 ( Query Mobile Capability Info ), or CALL:MS:REPorted:CAPability:QUERy ). The MS Capabilities Information results take a amount of time to be updated. These results are cleared if another new mobile determined by identifying a different ESN) registers with the test set or directly cleared by executing ( Call Control 2 of 3 -> F5 ( Clear MS & Capability Info )), or CALL:MS:REPorted:CLEar ).

Related Topics

Manual Operation: How Do I Set Up an IS-2000 Call? and D. Registration Parameters

GPIB Command: CALL:REGister


Real-Time Vocoder

Real-Time Vocoder

Last updated: June 12, 2007

  • Overview
  • Setting Real-Time Vocoder Parameters
  • Real-Time Vocoder Headroom Information
  • Operating Consideration

Overview

The real-time vocoder functionality allows you to perform the functional test for the analog voice capability of the mobile station. When the test set is configured in real-time vocoder mode (see Voice SO Mode ),

  • the test set can real-timely encode the analog audio signal applied at the test set's AUDIO IN connector using the appropriate vocoder algorithm (depending upon the selected voice service option) and then sends the encoded audio frames to the mobile station on the F-Traffic/F-FCH. See A Simplified Signal Flow for Real-Time Encoding .
  • Also, the test set can simultaneously decode the encoded audio frames that is received on the R-Traffic/R-FCH using the appropriate vocoder algorithm (depending upon the selected voice service option) and then converts to an analog signal output at the test set's AUDIO OUT connector. See A Simplified Signal Flow for Real-Time Decoding .

A Simplified Signal Flow for Real-Time Encoding

A Simplified Signal Flow for Real-Time Decoding

Setting Real-Time Vocoder Parameters

The following parameters can be set from the Real-Time Vocoder Parameters menu. To access the Real-Time Vocoder Parameters menu, see How Do I Use Real-Time Vocoder? .

  • Expected Audio In Peak Voltage

    Sets the peak voltage of the analog audio signal that is applied at the test set's AUDIO IN connector when the test set is in the real-timer vocoder mode (see Voice SO Mode ). It is used to adjust the audio input path gain for real-time encoding. Whenever you change this setting, it is not applied until the test set is set to the real-timer vocoder mode.

    GPIB command: CALL:RTVocoder:INPut:VOLTage[:EXPected]

  • Maximum Audio Out Peak Voltage

    Sets the maximum peak voltage of the analog audio signal that is expected to output at the test set's AUDIO OUT connector when the test set is in the real-timer vocoder mode (see Voice SO Mode ). Whenever you change this setting, it is not applied until the test set is set to the real-time vocoder mode.

    Setting this value makes the test set adjust the audio output path gain to achieve the desired audio output level at the test set's AUDIO OUT port. However, the actual output signal also depends on the voice signal decoded from the received R-FCH/R-Traffic voice data. The decoded signal may not be normalized to DAC (Digital to Analog Converter) full scale range. So it is possible that the final signal level is lower than the configured level.

    GPIB command: CALL:RTVocoder:OUTPut:VOLTage[:MAXimum]

  • Encoder Data Rate Mode

    Sets how to select the encoding data rate to produce the encoded data frames.

    • When Auto is selected, the test set determines the encoding data rate based on the received signal level.
    • When Fixed is selected, the test set uses the encoding data rate set by Encoder Data Rate .
    • When Limited is selected, the test set uses the encoding data rate no greater than the setting of Encoder Data Rate .

    GPIB Command: CALL:RTVocoder:ENCoder:DRATe:MODE

  • Encoder Data Rate

    Sets the encoding data rate used when the Encoder Data Rate Mode is set to Fixed or the maximum encoding data rate used when the Encoder Data Rate Mode is set to Limited .

    GPIB Command: CALL:RTVocoder:ENCoder:DRATe

    NOTE
    This setting is only applied to the encoder. The decoder uses the data rate specified in the voice traffic data from the mobile station.

Real-Time Vocoder Headroom Information

The following results are displayed on the Real-Time Vocoder Information window when a voice call (SO1, SO9, or SO32768) is established and the test set is in the real-timer vocoder mode (see Voice SO Mode ).

  • Encoder Headroom

    Indicates the headroom of the audio samples to the full scale of the ADC (Analog to Digital Converter). This result is updated at about one second period and calculated as follows:

    Encoder Headroom (dB) = 20 *Log ((ADC positive full scale - ADC negative full scale) / (maximum encoder input sample - minimum encoder input sample)

    When the input signal is over-range, the headroom is clipped to zero.

    GPIB command: CALL:RTVocoder:ENCoder:HEADroom?

  • Decoder Headroom

    Indicates the headroom of the decoded data samples to the full scale of the DAC (Digital to Analog Converter). This result is updated at about one second period and calculated as follows:

    Decoder Headroom (dB) = 20 *Log ((DAC positive full scale - DAC negative full scale) / (maximum decoder output sample - minimum decoder output sample)).

    GPIB command: CALL:RTVocoder:DECoder:HEADroom?

Operating Consideration

  • The following setting is required to use with the real-time vocoder:
    • The Operation Mode field must be Active Cell .
    • The System Type field must be IS-95 or IS-2000.
    • The Service Option must be one of voice service options such as SO1, SO3, SO17, SO68 or SO32768 (see Service Option ).
  • When the Voice SO Mode is set to Real-Time Vocoder , all of the measurements and instruments except for the Frame Error Rate measurement, Audio Generator and Data throughput Monitor, are unavailable. This is because many of the DSP resources are consumed to meet the real-time requirements for vocoder frame delivery or analog audio generation.
  • When the Voice SO Mode is set to Real-Time Vocoder , you can not change the audio source parameters such as output level and the source to be routed to the AUDIO OUT connector (see AFGenerator Subsystem ).
  • If an error message is displayed "Voice service option mode cannot be set to real-time vocoder due to lack of hardware support", please visit www.agilent.com/find/8960upgrades for the required hardware.
  • The Real-Time Vocoder Encoder Headroom is clipped to 0 when the input signal is over range.

Related Topics

How Do I Use Real-Time Vocoder?


Establishing an Active Link with the Mobile Station

Establishing an Active Link with the Mobile Station

Last updated: November 15, 2006

Before an Active Link with the mobile station can be established, the Operating Mode must be Active Cell and the mobile station must find service and register (see Performing a Registration ). When the CALL SETUP key is pressed, the Mobile Station Information window is displayed. This window will display information about the mobile station if the mobile station has registered (see Mobile Reported Information ).

After a mobile station has registered, an active link (call) can be attempted (the call is originated either from the test set or from the mobile station). The display will indicate the current call processing state at the bottom of the screen. If the call is successful, it will display Connected . If the call is unsuccessful, an error message will be displayed and the call processing state will return to Idle .

NOTE
The test set does not negotiate service options during a call establishing. If the mobile station rejects or tries to negotiate a different service option other than the test set proposed (set by FCH Service Option Setup ( F12 ) on Call Parms 1 of 4 , see Service Option ), the test set will generate an error and not establish the call.

Simple Call Flow

The following diagrams illustrate the key steps and messaging to establish a call between the mobile station (MS) and test set in IS-95 or IS-2000 system.

Click on the blue text for more information on that topic.

Programming Examples

Mobile station originated call (a call is originated from the mobile station to the test set): see Mobile Station initiated connection .

Mobile station terminated call (a call is originated from the test set to the mobile station): see Test Set initiated connection

Related Topics

Manual Operation: How Do I Set Up a Call?

GPIB Commands: CALL:ORIGinate


Expected Power

Expected Power

Last updated: June 12, 2007

The expected power is the mobile station output power that should be present at the test set's RF IN/OUT port. It is used to range the test set's receiver. The valid range for expected power is from -69 dBm to the maximum output power allowed for the mobile station which is the Max EIRP reported on the Call Setup screen in the Mobile Reported Information window.

In CW operating mode, you must specify the CW expected power that the test set should range its receiver to (see Receiver Control ).

In active cell mode (IS-2000 or IS-95 system) or IS-2000 Test mode, by default, receiver power control is set to auto (see Receiver Control ). In this mode, expected power is used to set the measurement and demodulation receiver power ranges. Expected power is calculated by the test set, and is displayed on many of the transmitter power measurement screens such as the digital average power, the channel power, and the access probe power.

Expected power is determined based on the open loop power equation of the mobile station and the parameter values such as Cell Power, Access Parameters, Enhanced Access Parameters, Data Rate, etc.

The calculation of expected power varies according to the state of the call connection, which reverse channels being transmitted by the mobile station, etc. See Expected Power Calculations for details.

Expected Power Calculations

IS-95 System

IS-2000 System
Radio Config = (Fwd1, Rvs1), (Fwd2, Rvs2) 1

IS-2000 System
Radio Config = (Fwd3, Rvs3), (Fwd4, Rvs3), (Fwd5, Rvs4) 1

Access Channel Type 2

R-ACH

R-ACH

R-EACH

R-ACH

R-EACH

Active Cell Connection Status

Idle

Equation A
(R-ACH)

Equation B
(R-EACH with R-Pilot)

Equation A
(R-ACH)

Equation B
(R-EACH with R-Pilot)

Connected

Equation A
(Reverse traffic channel 3 )

Equation C
(Reverse traffic channel 4 with R-Pilot)

IS-2000 Test Mode

Not Applicable

Equation A
(Reverse traffic channel 3 )

Equation C
(Reverse traffic channel 4 with R-Pilot)
  1. See Radio Configuration for details.
  2. Access Channel Type indicates if the test set is configured for R-ACH or R-EACH when protocol revision is greater than six (see Setting Control Channel Parameters for details).
  3. Reverse traffic channel represents R-FCH in Radio Config = (Fwd1, Rvs1), (Fwd2, Rvs2).
  4. Reverse traffic channel represents R-FCH and/or R-SCH in Radio Config = (Fwd3, Rvs3), (Fwd4, Rvs3), (Fwd5, Rvs4). The R-SCH is only added if the test set is configured to recieve R-SCH, for example, IS-2000 Service Option is SO32 (+SCH) or SO33 (with R-SCH channel being assigned).

NOTE
Any calculation in the following sections that indicates X (dBm) = Y (dBm) + Z (dBm) implicitly means: converting Y and Z to Watts firstly, then adding Y and Z in Watts, and finally converting to dBm value for X.

Base Equation

The different equations used to determine the mobile station output power and therefore the expected power share a common base formula and some common parameters. The base equation used by these different calculations is:

Base Power (dBm) = - mean input power (dBm) + offset power + interference correction + access correction , where:

  • mean input power = Total RF Power (for IS-95 or IS-2000 system) (see Configuring Cell Power and AWGN Power Levels ).
  • offset power varies depending upon the reverse channels available for different setups (see Offset Power in Different Configurations as specified by the standard)
  • interference correction = min(max(IC_THRESH - E c /I o , 0), IC_MAX)
    The interference correction is the adjustment made to correct for interference. The actual values used for IC_THRESH and IC_MAX vary between the different equations (see Equation A , Equation B , Equation C ). The E c /I o (dB) is the ratio of the combined pilot energy per chip, E c , to the total received power spectral density (noise and signals), I o . The test set determines the E c /I o by:
    • E c /I o = Absolute F-Pilot level (dBm) - Total RF Power (dBm), where Absolute F-Pilot level (dBm) = F-Pilot level (dB) + Cell Power (dBm) (see Setting Code Channel Levels and Walsh Codes and Configuring Cell Power and AWGN Power Levels ). Note that when in soft/softer handoff, the Absolute F-Pilot level (dBm) will be the maximum of Absolute Cell1 F-Pilot Level and Absolute Cell2 F-Pilot Level
  • access correction varies depending on which access channel (R-ACH or R-EACH) is currently configured. The general equation is:
    access corrections = nominal power + initial power + (PWR_LVL * power step size)
    The (PWR_LVL * power step size) component is always 0 since the test set assumes the 1st access probe (corresponding to PWR_LVL equal to 0) of the access or enhanced access probe sequence for calculation. Therefore,
    • When R-ACH is currently configured,
      access corrections = Nominal Power + Initial Power - 16 * Nominal Power Extended
      (Nominal Power, Initial Power and Nominal Power Extended are settable on the test set, see Setting Access Parameters ).
    • When R-EACH is currently configured,
      access corrections = EACH Nominal Power + EACH Initial Power
      (EACH Nominal Power and EACH Initial Power are settable on the test set, see IS-2000 Enhanced Access Parameters )
Offset Power in Different Configurations

Band Class

Reverse Channels

Offset Power

US Cellular, Japan CDMA, NMT-450, Secondary 800

Access Channel
Reverse Traffic Channel (RC1, RC2) 1

-73

Enhanced Access Channel
Reverse Traffic Channel (RC3, RC4 ) 1

-81.5

US PCS, Korean PCS, IMT-2000, US PCS 1900, AWS

Access Channel
Reverse Traffic Channel (RC1, RC2) 1

-76

Enhanced Access Channel
Reverse Traffic Channel (RC3, RC4) 1

-84.5
  1. The RC1 through RC4 refer to the radio configuration for reverse traffic channels. See Radio Configuration for details.

Equation A

See Expected Power Calculations for when this equation is used.

Expected Power (dBm) = Base Power (dBm) + RLGAIN_ADJ , with the following requirements when calculating Base Power (see Base Equation ):

  • interference correction: IC_THRESH = -7 and IC_MAX = 7 (these values are fixed by the standard)
  • access corrections = access corrections for R-ACH or R-EACH depending on whichever is currently configured (see Control Channel Configuration ).
  • RLGAIN_ADJ = 0 (fixed by the test set) (RLGAIN_ADJ only applies to reverse traffic channel)

Equation B

See Expected Power Calculations for when this equation is used.

The R-EACH in basic access mode (the only mode currently supported by the test set) consists of an R-EACH preamble followed by enhanced access data (see Enhanced Access Channel Structure ). The test set does not range expected power for the enhanced access preamble. The test set ranges the expected power for the R-EACH data portion (R-EACH Data and R-Pilot) and is calculated as:

Expected Power (dBm) = R-Pilot power (dBm) + R-EACH power (dBm) , where,

R-Pilot power (dBm) = Base Power, with the following requirements when calculating Base Power (see Base Equation ):

  • interference correction: IC_THRESH = - Interference Correction Threshold and IC_MAX = Interference Correction Maximum (Interference Correction Threshold and Interference Correction Maximum are settable on the test set, see IS-2000 Enhanced Access Parameters )
  • access corrections = access corrections for R-EACH

R-EACH power (dBm) = R-Pilot (dBm) + 0.125 * (Nominal Common Attribute Gain + RL Gain Common to Pilot), where,

  • Nominal Common Attribute Gain = Nominal_Reverse_Common_Channel_Attribute_Gain[Data Rate, Frame Length] (see Nominal Reverse Common Channel Attribute Gain (supported by the test set)
    For Data Rate and Frame Length setting, see R-EACH Rate Supported . Note that if multiple rates are supported, the highest supported rate is used for the calculation but the test set will not display the expected power level on the access probe power measurement.
  • RL Gain Common to Pilot (see IS-2000 Enhanced Access Parameters )

Nominal Reverse Common Channel Attribute Gain (supported by the test set)
Data Rate | Frame Length | Nominal_Reverse_Common_Channel_Attribute_Gain
9.6 kbps | 20 ms | 30
19.2 kbps | 20 ms | 50

Equation C

See Expected Power Calculations for when this equation is used.

Which reverse traffic channels contain power varies during Initial Channel Assignment state and Connected state, as shown below

The expected power for each of these states is as follows:

  • Initial Channel Assignment state consists of a traffic channel preamble (R-Pilot only) followed by a combination of signaling and null frames on the traffic channel (R-FCH). Null frames consist of the R-Pilot and eighth rate traffic channel. Traffic channel signaling consists of the R-Pilot and full rate traffic channel. Expected Power will be ranged for traffic channel signaling (full rate) which is the highest level expected during the Initial Channel Assignment state:

    Expected Power (dBm) = R-Pilot (dBm) + R-FCH [full rate] (dBm)
  • Connected state consists of the R-Pilot and the final reverse traffic channel at the final data rate (R-FCH and/or R-SCH if configured). Note that the R-SCH power is only added if the test set is configured to receive R-SCH, for example, IS-2000 Service Option is SO32 (+ SCH).

    Expected Power (dBm) = R-Pilot (dBm) + R-FCH [final rate] (dBm) + R-SCH [final rate] (dBm)

The power of each of the reverse channels is calculated as follows

R-Pilot (dBm) = Base Power + RLGAIN_ADJ, with the following requirements when calculating Base Power (see Base Equation ):

  • interference correction:
    • When R-ACH is currently configured,
      IC_THRESH = -7 and IC_MAX = 7 (these values are fixed by the standard)).
    • When R-EACH is currently configured,
      IC_THRESH = - Interference Correction Threshold (settable on the test set, see IS-2000 Enhanced Access Parameters ) and IC_MAX = 7 (fixed by the standard)
  • access corrections = access corrections for R-ACH or R-EACH depending on whichever is currently configured
  • RLGAIN_ADJ = 0 (fixed by the test set) (RLGAIN_ADJ only applies to reverse traffic channel)

R-FCH or R-SCH (dBm) = R-Pilot (dBm) + 0.125 * (Nominal_Attribute_Gain[Data Rate, Frame Size, Coding Rate] - Multiple_Channel_Adjustment_Gain[R-FCH or R-SCH] + RL Traffic to Pilot Gain), (Note that this is a simplified equation since other elements in the equation as specified in the standard are fixed to zero by the test set), where:

  • Nominal_Attribute_Gain [Data Rate, Frame Size, Coding Rate]
    See Reverse Link Attribute Adjustment .
  • Multiple_Channel_Adjustment_Gain[R-FCH or R-SCH]:
    • If the test set is not configured to receive R-SCH (reverse channel contains R-FCH and R-Pilot),
      Multiple_Channel_Adjustment_Gain[R-FCH] = 0.
    • If the test set is configured to receive R-SCH (reverse channel contains R-FCH, R-SCH and R-Pilot),
      Multiple_Channel_Adjustment_Gain varies according to Pilot_Reference_Level (see Reverse Link Attribute Adjustment ):
      • If R-FCH has the highest Pilot_Reference_Level,
        Multiple_Channel_Adjustment_Gain [R-FCH] = 0
        Multiple_Channel_Adjustment_Gain [R-SCH] = Pilot_Reference_Level [R-FCH]- Pilot_Reference_Level[R-SCH]
      • If R-SCH has the highest Pilot_Reference_Level,
        Multiple_Channel_Adjustment_Gain [R-SCH] = 0
        Multiple_Channel_Adjustment_Gain [R-FCH] = Pilot_Reference_Level [R-SCH]- Pilot_Reference_Level[R-FCH]
  • RL Traffic to Pilot Gain (settable on the test set, see IS-2000/IS-95 Cell Parameters )

Reverse Link Attribute Adjustment
Data Rate 1
(kbps) 		Frame Size 2 Coding Nominal_Attribute_Gain Pilot_Reference_Level
1.5 20 ms Convolutional - 47 (no gating)
- 10 (R-FCH gating) 3 		0
2.7 | 20 ms | Convolutional | -22 | 0
4.8 | 20 ms | Convolutional | -2 | 0
9.6 | 20 ms | Convolutional | 30 | 0
1.8 20 ms Convolutional -42 (no gating)
-2 (R-FCH gating 3 ) 		3
3.6 | 20 ms | Convolutional | -13 | 3
7.2 | 20 ms | Convolutional | 15 | 3
14.4 | 20 ms | Convolutional | 44 | 3
19.2 | 20 ms | Convolutional | 50 | 1
38.4 | 20 ms | Convolutional | 60 | 11
76.8 | 20 ms | Convolutional | 72 | 21
153.6 | 20 ms | Convolutional | 84 | 36
307.2 | 20 ms | Convolutional | 96 | 54
28.8 | 20 ms | Convolutional | 56 | 11
57.6 | 20 ms | Convolutional | 72 | 18
115.2 | 20 ms | Convolutional | 80 | 32
230.4 | 20 ms | Convolutional | 88 | 46
19.2 | 20 ms | Turbo | 44 | 2
38.4 | 20 ms | Turbo | 56 | 10
76.8 | 20 ms | Turbo | 68 | 19
153.6 | 20 ms | Turbo | 76 | 33
307.2 | 20 ms | Turbo | 88 | 50
28.8 | 20 ms | Turbo | 52 | 9
57.6 | 20 ms | Turbo | 64 | 19
115.2 | 20 ms | Turbo | 76 | 29
230.4 | 20 ms | Turbo | 88 | 39
  1. See Reverse Traffic Channel Data Rate Determination for details on how the test set determines the reverse traffic channel data rate.
  2. The test set only supports 20 ms frames on reverse traffic channel.
  3. R-FCH gating mode is only available in Lab Application . See R-FCH Gating for details.

Reverse Traffic Channel Data Rate Determination
 | Service Option 1 | Initial Traffic Channel Assignment (Preamble Period) |  | Connected State
 |  | (Fwd3, Rvs3) (Fwd4, Rvs3) | (Fwd5, Rvs4) | (Fwd3, Rvs3) (Fwd4, Rvs3) | (Fwd5, Rvs4)
R-FCH 2 | SO1, SO3, SO17, SO68, SO32768, SO6, or SO14 | 9.6 kbps (the test set assumes Full rate) | 14.4 kbps (the test set assumes Full rate) | 2.7 kbps (the test set assumes Quarter rate) | 3.6 kbps (the test set assumes Quarter rate)
 | SO2, SO9, or SO55 |  |  | Depending upon the settings (see Traffic Data Rate ). Full = 9.6 kbps Half = 4.8 kbps Quarter = 2.7 kbps Eighth = 1.5 kbps If Random rate is set, the test set assumes Quarter rate (2.7 kbps) | Depending upon the settings (see Traffic Data Rate ): Full = 14.4 kbps Half = 7.2 kbps Quarter = 3.6 kbps Eighth = 1.8 kbps If Random rate is set, the test set assumes Quarter rate (3.6 kbps)
 | SO32 (+F-SCH) or SO32 (+SCH) |  |  | 9.6 kbps (the test set assumes Full rate) | 14.4 kbps (the test set assumes Full rate)
 | SO33, or SO33 (+F-SCH) |  |  | 9.6 kbps (the test set assumes Full rate) | 14.4 kbps (the test set assumes Full rate)
R-SCH | SO32 (+SCH) or SO33 | Not apply. |  | Depending upon the R-SCH data rate settings. When SO33 (+SCH) selected, see Configuring the TDSO Supplemental Channel Information and when SO33 selected see The parameters for selecting Service Option 33 (SO33) .
1. For details on service options, see Service Option . 2. In IS-2000 Test Mode, the test set will set expected power and range the receivers to expect a R-FCH at Full rate.

Related Topics

GPIB Commands: RFANalyzer:AUTO:POWer[:SELected]? (for Active Cell mode)


Setting External Trigger

Setting External Trigger

Last updated: October 28, 2004

External trigger type selects the trigger that is routed to the rear panel TRIG OUT port (see Rear Panel Connectors ). The triggers are based off of the internal clocks/references of the test set and are the same signals that are used to trigger the measurements and call processing functionality.

External Trigger Type
Trigger | Description
20 ms | Frame clock
26.67 ms | Sync channel frame (short code sequence rollover)
80 ms | Paging channel slot
2 s | Even second clock
FDEPendent | Function Dependent. The frequency and timing of trigger depends upon the set of measurements (such as Handoff Waveform Quality, Waveform Quality + Code Domain, Code Channel Time/Phase Error, Time Response of Open Loop Power Control and Tx Dynamic Power. See Triggering of Measurements .) and trigger generating operations that are currently being performed by the test set (for example, the trigger is produced coincident with the transmission of the first power control bit in a closed loop power control transient. See Starting the Reverse CLPC Transient .).

External trigger type can be changed at any time.

In addition to the user selected external trigger type, there is also a fixed external trigger that is always present at the BASEBAND I/O port, which triggers each time a power control bit is generated.

Related Topics

GPIB Command: CALL:TRIGger

Manual Operation: How Do I Change Generator Information?


Forward Link Overview

Forward Link Overview

Last updated: October 28, 2004

The "Forward Link" refers to a radio link for the transmission of signals from the test set to a mobile station while the "Reverse Link" refers to a radio link for the transmission of signals from a mobile station to the test set.

This section summarizes the forward link channels supported by the test set in Active Cell operating mode and the key concepts relating to the forward link.

Forward Link Power

When Active Cell are selected in the Operation Mode field, the signals transmitted by the test set include:

  • Cell (Cell 1) Power: It is comprised of all of the enabled code channel power levels ( Forward Code Channels ). An Orthogonal Channel Noise Simulator (OCNS) which is used to simulate additional users on the forward link, is automatically enabled when the sum of the levels of all the enabled forward link physical channels is less than the cell power setting.
  • Cell 2 Power ( Lab Application only , see Configuring Cell 2 Used for Soft/Softer Handoff )
  • AWGN Power: It can be summed into the forward link signal to simulate interference from other cells when enabled

The Cell 1 Power is combined with the Cell 2 Power and the AWGN Power, if enabled, to form the total RF power. See Configuring Cell Power and AWGN Power Levels for details.

Forward Code Channels

The forward link consists of a number of physical channels (identified by their walsh codes) which vary in IS-2000 system and IS-95 system. The test set allows you to control the individual code channels, such as the walsh code, power level, data rate, etc., see Configuring Forward Channel Power Levels and Walsh Codes for details.

Closed Loop Power Control

The test set also transmits the power control sub-channel which is used in conjunction with open loop power control to control power levels transmitted from the mobile station. See Setting Reverse Closed Loop Power Control for details.

Data Rates and Data Patterns

Data rates available on the FCH (fundamental channel) depend on the RC (radio configuration). See Traffic Data Rate . The data pattern sent on FCH is fixed to 215-1 PRBS.

To set the data rates and data patterns for SCH (supplemental channel), see Configuring the TDSO Supplemental Channel Information .

Related Topics

Configuring Forward Channel Power Levels and Walsh Codes


Front Panel Connectors

Front Panel Connectors

Last updated: October 28, 2004

Description

AUDIO IN

The input to the audio analyzer is a floating input differential amplifier. Both the AUDIO IN High and AUDIO IN Low BNC connectors should be connected to provide noise immunity. Refer to the Technical Specifications in the Application Datasheet for more information.

AUDIO OUT

This BNC connector accesses the test set's Audio Generator and FM Demod signals. The Audio Generator is used to stimulate a system to measure audio performance characteristics. The FM Demod allows the user to access the demodulated FM signal for external analysis and baseband processing. Refer to the Technical Specifications in the Application Datasheet for more information.

NOTE
There will be no guaranteed performance for the signal present at the AUDIO OUT connector when FM Demod signal is selected for output.

DATA

This RJ-45 connector provides front panel access to the rear panel LAN connection. This connector is used for downloading firmware upgrades, or new test applications into the test set. No other types of communication are possible with the LAN port.

The the DATA connector on the front panel is connected internally to the ETHERNET TO FRONT PANEL connector on the rear panel. In order to use the front panel DATA connector, connect the rear panel LAN PORT, to the rear panel ETHERNET TO FRONT PANEL connector with the LAN jumper cable.

The LAN jumper cable, part number E5515-61160, is supplied with the test set.

DVM

Not functional for this release.

RF IN/OUT

This Type-N connector is the default path for all RF signals out of the test set, and is always used as the RF input. Refer to the Technical Specifications in the Application Datasheet for more information. See also RF OUT ONLY .

RF OUT ONLY

NOTE
This port cannot be used with the E1960A GSM test application or with the GSM personality in a test application suite (such as the E1985A GSM_AMPS/136_GPRS suite).

This Type-N connector is an optional path for all RF signals out of the test set. It is intended to be used for duplexed testing. Front panel selection of this port is provided by the RF Output Port ( F6 ) control on the System Config screen, and by the RFGenerator:OUTPut[:DESTination] IO/OUT command. The same amplitude offsets and output power settings are used for either selected port (RF IN/OUT or RF OUT ONLY). Refer to the Technical Specifications in the Application Datasheet for more information.

Related Topics

How Do I Configure the AUDIO OUT Port?


Help Mode

Help Mode

Last updated: October 28, 2004

Description

This section explains:

  • What is Help Mode?
  • How do I use the help mode?

What is Help Mode?

The help mode implemented in your test set provides context sensitive GPIB command syntax assistance. When you put the test set into help mode, the test set displays the GPIB command syntax necessary to perform an action remotely for each action you perform from the front panel.

For example, if you put the test set into help mode and then select the test set's GPIB address, the GPIB command syntax for changing it remotely appears in the bottom left hand corner of the test set's screen.

NOTE
Operating the test set in Help Mode does not prevent you from changing parameters from the front panel. The parameters you change while in Help Mode are applied just as they would be normally.

How do I use the help mode?

  1. Put the test set into help mode by pressing the HELP key on the front panel.

    The Help annunciator should now be displayed in the bottom of the screen.

  2. Navigate to the screen and perform the action for which you would like to know the GPIB command syntax. For example, you could navigate to the Audio Generator instrument, and select Frequency ( F3 ). The GPIB command syntax to perform this action remotely appears in the bottom left of the screen.

    Refer to the user documentation on each command for more information.


Preset Descriptions

Preset Descriptions

Last updated: October 28, 2004

Description

The test set is capable of accepting several different preset commands.

At no time during a preset operation, does transmit power exceed the last user setting of the transmit power. The input power is not set to any value lower than the last user setting of the input power. This is to avoid power spikes on the output and possible receiver damage on the input during transitions associated with preset operations.

Partial Preset

Partial preset saves setup time because measurement setup parameters remain unchanged. This is the recommended way to place the test set in a known condition.

When you fast switch between formats in a fast switching test application the test set behaves as if a partial preset has occurred. The table below lists some key partial preset results.

Example

OUTPUT 714;"SYSTEM:PRESET3" !Command for a partial preset when user in
                            !remote operation.

SYSTEM:PRESET3 is the recommended command for a partial preset operation. The SYSTEM:PRESET[1] command is not recommended for use at this time.

Press the green Preset key on the front panel to perform a partial preset.

Partial Preset Behavior
Function | Partial Preset Result
Trigger Arm | no change
Measurement parameters | no change
Calibration data | no change
Enable registers | no change
Positive Transition Filter registers | no change
Negative Transition Filter registers | no change
Contents of RAM | no change
Contents of output queue | no change
Contents of error queue | no change
Maskable Message Display State | no change
Operating Mode | Active Cell
Measurements | aborted and inactivated
Measurement results | NAN
Measurement integrity indicator | 1 = no result available
Transmit Power State | ON
Cell Activated State | ON
Call in progress | aborted
Call Control Status | Idle
Call Counters | cleared
Call Error Counters | cleared
SACCH | cleared
Pending Service request | not cleared

Full Preset

A full preset requires you to select new measurements and configure their parameters. If measurement parameters do not need to be changed, use a partial preset to save time.

Example

OUTPUT 714;"*RST" !Recommended command for a full preset, sets trigger arm to single.

OUTPUT 714;"SYSTEM:PRESET2" !Command for a full preset, sets trigger arm to continuous.

The *RST common command is the recommended command for a full preset operation.

NOTE
Transmit power is not set to OFF during a full preset, transmit power is set to the default value.

Full Preset Behavior
Function | Full Preset Result
Trigger Arm | Continuous (manual operation full preset or SYSTEM:PRESET2 command)
Trigger Arm | Single (remote operation full preset, *RST command)
Measurement Parameters | all set to defaults
Maskable Message Display State | On (manual operation full preset)
Maskable Message Display State | Off (remote operation full preset)

Status Preset

The STATUS:PRESET command sets the status system as defined in "SCPI 1995 Volume 2: Command Reference" section 20.7. All of the enable registers are set to 0, all PTR registers are set to 1, and all NTR registers are set to 0.

Example

OUTPUT 714;"STATUS:PRESET" !Presets the STATus subsystem.

Related Topics

SYSTem:PRESet


Instrument Status Area

Instrument Status Area

Last updated: November 10, 2006

Description

The instrument status area is found on the bottom center of the test set's display.

Status Area of the Test Set Display

Background

You can initiate more than one measurement at a time with the test set. The test set's display can show a maximum of 2 measurements. When 3 or more measurements are initiated, or the MEASUREMENT screen is not displayed, the Background annunciator reminds you that measurements are active but not displayed.

<Operating Mode> Status

The call processing status and the operating modes are displayed in this area. This area may change (depending on the application that is active) in order to provide application specific information.

Sys Type

The current system type is displayed in this area. This area may change (depending on the application that is active). It might be IS-856 (for 1xEV-DO), IS-95 , IS-2000 , GSM , GPRS , EGPRS , FDD (for W-CDMA), IS-136 , DIG-136 .

External Device Connection

This annunciator is only applicable to the GSM/GPRS/EGPRS and W-CDMA/HSDPA lab applications. When the test set is connected to another test set using an External Device Connection, this area contains ExtDev . Otherwise, this area is blank. For details, see the related links under Related Topics.

Logging

This annunciator indicates whether or not your lab application is connected to Wireless Protocol Advisor. When your lab application is connected to Wireless Protocol Advisor Logging: Active is displayed, when your Lab Application is not connected to Wireless Protocol Advisor Logging: Idle is displayed. If your Application is a test application, this area is blank.

Sync Annunciators

These annunciators indicate whether the test set has successfully completed a synchronization. This annunciator can contain " C OPC ", " S OPC " or " CS OPC ". For details, see the related links under Related Topics.

DBUS - INT

This annunciator turns on when Option 004 hardware is installed and the application is a cdma2000, 1xEV-DO, or W-CDMA lab application that supports this functionality. For details, see the related links under Related Topics.

Shift

This annunciator indicates that the blue SHIFT key has been pressed, and that the next key you press performs the shifted function indicated, also in blue.

Int Ref/Ext Ref

When the internal time base is used (there is no suitable external time base connected to the rear panel 10MHz REF IN connector), Int Ref turns on. When a suitable external time base is connected to the rear panel 10MHz REF IN connector, Ext Ref turns on.

Offset

This annunciator indicates that the Amplitude Offset state is set to On. For details, see the related links under Related Topics.

R L T S

This annunciator indicates the state of four different conditions of the test set:

  • Remote annunciator. ` R ' turns on when the test set is operated remotely.
  • Listen annunciator. ` L ' turns on when the test set is listening to a command.
  • Talk annunciator. ` T ' turns on when the test set is providing information over GPIB.
  • SRQ annunciator. ` S ' turns on when an SRQ is active.

Help

When the Help functionality is active, this annunciator turns on. Use the HELP hardkey to activate/deactivate the Help functionality. When the help functionality is active, when you select a setting the associated GPIB command is displayed at the bottom of the screen.

Physical Layer Subtype

This area is applicable to the 1xEV-DO applications. It indicates the current Physical Layer Subtype, either PLSub0 (Physical Layer Subtype 0) or PLSub2 (Physical Layer Subtype 2). For details, see the related links under Related Topics.

Application Type

This area is applicable to the 1xEV-DO applications. It indicates the current application being used, such as FTAP , RTAP , FETAP , RETAP , or DPkt . For details, see the related links under Related Topics.

Related Topics

Logging: Protocol Logging

Sync Annunciators: Performing Multi-Unit Synchronization

DBUS-INT: Digital Bus Information

Offset: Amplitude Offset


Mobile Reported Information

Mobile Reported Information

Last updated: June 20, 2006

The mobile station notifies the test set of its characteristics during registration (see Performing a Registration ). When the mobile station is successfully registered to the test set, the following registration data is displayed on the Mobile Station Information screen. The registration data is updated each time a new mobile station (with a different ESN) is registered. You can also clear these registration data by pressing the F5 ( Clear MS & Capability Info ) on Call Control 2 of 3 or using CALL:MS:REPorted:CLEar command.

NOTE
The Band Class , MS Operating Mode , Max EIRP and Minimum Power Control Step are not reported by the mobile station when the Status Request Query is off.

ESN

Electronic Serial Number. It is a 32-bit number assigned by the mobile station manufacturer, uniquely identifying the mobile station equipment. The mobile stations reports this information to the test set in the Registration Message .

When an MEID-equipped mobile station registers, a pseudo-ESN is reported and displayed on ESN field. The mobile station uses the following rules to derive pseudo-ESN from MEID:

  • The upper 8 bits of pseudo-ESN are set to 0x80.
  • The lower 24 bits of pseudo-ESN are the 24 least significant bits of the SHA-1 digest of the MEID.

MCC

Mobile Country Code. It is a part of the E.212 IMSI identifying the home country. The mobile stations reports this information to the test set in the Registration Message .

MNC

Mobile Network Code. It is a part of the E.212 IMSI identifying the home network within the home country. The mobile stations reports this information (if supported) to the test set in the Registration Message .

MSIN

Mobile Station Identification Number. It is a part of the IMSI identifying the mobile subscriber identity. The mobile stations reports this information to the test set in the Registration Message .

Slot Class

A mobile station can be either "Slotted" or "Non-Slotted". It is part of the mobile station's Station Class Mark information. The mobile stations reports this information to the test set in the Registration Message .

Slot Cycle Index

Indicates the programmed slot cycle index of the mobile station. The allowed range is 0 - 7. The slot cycle index defines how often the mobile station will "wake up" and check the paging channel. The formula for the time associated with the index is 2^(slot cycle index) x 1.28 seconds. The minimum time period is 1.28 seconds. The maximum value is 163.84 seconds. The mobile stations reports this information to the test set in the Registration Message .

The maximum slot cycle index allowed by the test set can be specified (see Setting Cell Parameters

Protocol Revision

Indicates the highest protocol revision supported by the mobile station. IS-95A = P_REV 1, J-STD-008 = P_REV 2, TSB-74 = P_REV 3, IS-95B = P_REV 4&5, IS-2000-0 = P_REV 6, IS-2000-A = P_REV 7.

The highest protocol revision supported by the test set can be specified (see Protocol Revisions ).

Band Class

Indicates the band classes supported by the mobile station, such as US Cellular, US PCS, Korean PCS, Japan CDMA, and IMT-2000. This information is obtained by querying the mobile station with a Status Request Message after the test set receives the mobile registration message . When the Status Request Query is set to Off, the test set does not request the mobile station to report its band classes during registration.

The Band Class supported by the test set can be specified (see Cell Band ).

MS Operating Mode

Indicates whether the mobile station supports CDMA only or both CDMA and AMPS (Dual Mode). This information is obtained by querying the mobile station with a Status Request Message after the test set receives the mobile registration message . When the Status Request Query is set to Off, the test set does not request the mobile station to report the operating mode for each band class during registration.

Max EIRP

Mobile MAX_EIRP (Maximum Effective Isotropic Radiated Power) expressed in dBW (MAX_EIRP= -7 dBW). This information is obtained by querying the mobile station with a Status Request Message after the test set receives the mobile registration message . When the Status Request Query is set to Off, the test set does not request the mobile station to report the max EIRP (if the MS operating mode is CDMA) for each band class during registration. See also CALL:MS:REPorted<:EIRPower|:ESNumber> .

Register Type

Indicates the type of registration the mobile station sent. This is indicated in the registration message from the mobile station. The test set supports Power Up, Timer Based, and Zone Based registrations. The mobile stations reports this information to the test set in the Registration Message .

You can control the test set to support the power up registration and timer-based registration (see Setting Registration Parameters ).

QPCH Supported

Indicates if the mobile station supports the Quick Paging Channel (IS-2000 only). The mobile stations reports this information to the test set in the Registration Message .

You can control the test set to support QPCH (see Setting Control Channel Parameters ).

Enhance RC Supported

Indicates if the mobile station supports Enhanced Radio Configurations (that is, RC Class 2 which consists of RC 3 and RC 4 for the Reverse Traffic Channel, and RC 3, RC 4 and RC 5 for the Forward Traffic Channel). The mobile stations reports this information to the test set in the Registration Message .

Minimum Power Control Step

Indicates the minimum closed loop power control step size. IS-95B and IS-2000 support steps of 1 dB, 0.5 dB and 0.25 dB. The mobile station is only required to support 1 dB and can optionally support 0.5 and 0.25 dB steps. This information is obtained by querying the mobile station with a Status Request Message after the test set receives the mobile registration message . When the Status Request Query is set to Off, the test set does not request the mobile station to report this information during registration.

MS Called Party Number

This is the number the user dialed into the mobile station when a mobile originated call is established with the test set.

MEID Supported

Indicates whether the mobile station is an ESN-equipped or an MEID-equipped equipment. It is included in the bit 4 of Station Class Mark (SCM) in the mobile registration message . The value of 1 indicates an MEID-equipped mobile station while zero indicates an ESN-equipped mobile station.

When an MEID-equipped mobile station is detected ( Yes ) and the MEID Support is set to On , the test set will send a Status Request Message to the MS to retrieve its MEID value and then display the result on the MEID field.

GPIB Command: CALL:MS:REPorted:MEIDentifier:SUPPorted?

MEID

Mobile Equipment Identifier. It is a 56-bit number assigned by the mobile station manufacturer, uniquely identifying the mobile station. It is designed as an alternative to ESN (32-bit number) due to ESN exhaustion.

When an MEID-equipped mobile station is detected ( MEID Supported indicates Yes) and the MEID Support is set to On , the test set will send a Status Request Message to retrieve the MEID value from the MS no matter what the Status Request Query setting is. The MS returns its MEID in the Status Response Message . When the MEID Support is set to Off , the test set does not send Status Request Message to an MEID-equipped MS and only pseudo-ESN is reported on ESN field.

The MEID result is displayed in two formats:

  • MEID (Hex): 14 digit hexadecimal number, where the first 8 digits representing the manufacturer code and the last 6 digits representing the serial number.
  • MEID (Dec): 18 digit decimal number, where the first 10 decimal digits are the equivalent of the first 8 hexadecimal digits representing the manufacturer code and the last 8 decimal digits are the equivalent of the last 6 hexadecimal digits representing the serial number.

GPIB Command:

  • CALL:MS:REPorted:MEIDentifier:[:DECimal]?
  • CALL:MS:REPorted:MEIDentifier:HEX?

Related Topics

Performing a Registration

GPIB Commands: CALL:MS:REPorted


How Do I Perform Authentication Tests?

How Do I Perform Authentication Tests?

Last updated: June 20, 2006

This section is only applicable to the lab application and to a test application with the required feature license.

  • Prerequisites
  • Perform SSD Update : SSD Update is used to test the MS's ability to synchronize SSD_A with the test set and ensures that the MS and the test set have identical SSD_A. It is recommended that you perform an SSD Update prior to performing the global challenge or unique challenge operations. For global challenge and unique challenge authentications to pass, you must make sure the SSD_A stored in the test set is identical to the SSD_A stored in the MS.
  • Perform Global Challenge : Global Challenge is used to verify that the MS can successfully perform a registration, origination, paging response with authentication parameters that match the values expected by the test set.
  • Perform Unique Challenge : Unique Challenge is used to test the MS's ability to send the test set a parameter that indicates it has SSD_A identical to that of the test set.
  • Perform 3GPP2 C.S0043-0 V1.0 Authentication Tests

Prerequisites

  1. Register the MS.

    Make sure the mobile station (MS) camps onto the test set and has completed power up registration. Registration provides the test set with the MS's ESN, IMSI, etc., which are required in the global challenge, unique challenge, and SSD update authentication procedures. When the MS registers to the test set, the registration data is displayed on the Mobile Reported Information screen. You may need to set some call parameters (such as Cell Band, Channel, System ID, etc.) that are necessary to allow MS to register to the test set (see How Do I Set Up a Call? ).

  2. Initialize the A-Key in the MS and test set to the same value.

    For global challenge or unique challenge authentications to pass, you must make sure the SSD_A stored in the test set is identical to the SSD_A stored in the MS.You can perform either of the following ways:

    • If you can change MS's A-Key, initialize SSD_A in both the test set and MS to zeroes by changing their A-Keys since entering an A-Key will set the SSD_A to zero. It is recommended that you set the A-Keys in the test set and MS to the same values and then Perform SSD Update procedure.
      • On the Authentication Parameters menu, enter a valid number (1 to 20 digits) into A-Key (Dec) field. The SSD_A=0 displays True on the Authentication Parameters window on the Authentication Information screen, indicating that the SSD_A value in the test set initialized to zero. Also, the six Check Digits is generated for the entered A-Key and displayed on the Authentication Information screen. See To Set Authentication Parameters or to Access Authentication Information Screen for detailed procedure.
      • On the MS's display, enter the identical sequence of A-Key digits followed by the six Check Digits.
    • If you can not change MS's A-Key, but you know what it is, enter the most significant 20 digits (without check digits) of the MS's A-Key on the test set, then Perform SSD Update to synchronize the SSD_A values between the test set and MS. If you even do not know the MS's A-Key, try the zero value, since A-Key in many mobile stations is initially programmed to zero until re-programmed by the service provider.

Perform SSD Update

The following procedure is to show you how to perform SSD Update on the control channel while in idle state or on the traffic channel while in a call.

  1. Make sure you have finished the Prerequisites .
  2. Follow the procedure To Set Authentication Parameters or to Access Authentication Information Screen , then press the Authentication Parameters ( F1 ) Key on the Authen Ctrl menu.
    • set the RANDSSD parameter to the desired value. You may skip this step if the default value will be used.
    • Set the Timer Based Registra0tion State to Off.

      NOTE
      It is recommended that the Timer Based Registration State is turned off to avoid potential confliction between the registrations and the SSD Update.

  3. Press the SSD Update ( F4 ) key on the Authen Ctrl 1 of 2 menu. The test set sends the SSD Update Message to the MS and starts the SSD update operation. For details on the message flow, see SSD Update Operation .
  4. Observe the SSD Update Information window and verify that the SSD update on paging channel is successful. After a successful SSD Update, the SSD_A=0 will be False indicating the SSD_A is no longer zero. If the test fails, verify that you've set the A-Key on the MS and test set to the same value. and then repeat the procedure. A typical display is shown below.
  5. Establish a call. For example, set the service option properly (such as SO2) and then press the Originate Call ( F3 ) on the Authen Ctrl 2 of 2 menu. If required, follow the procedure How Do I Set Up a Call? .
  6. Repeat steps 3 and 4. Verify that the SSD update on traffic channel is successful. A typical display is shown as below.
  7. End the call.

Perform Global Challenge

The following procedure is to verify that the MS can successfully perform a registration, origination, paging response with authentication parameters that match the values expected by the test set:

  1. Ensure that the MS and the test set have identical SSD_A. See Perform SSD Update .
  2. Follow the procedure To Set Authentication Parameters or to Access Authentication Information Screen , then press Authentication Parameters ( F1 ) Key on the Authen Ctrl 1 of 2 menu.
    • set the RAND parameter to the desired value. You may skip this step if the default value will be used.
    • Set the Timer Based Registration State to On .
  3. On the Authen Ctrl 1 of 2 menu, set the Global Challenge ( F2 ) to On . The test set will signal the MS to go into authentication mode and use the specified RAND value for authentication when registrations, call originations, pages or data bursts are performed. For details on the message flow, see Global Challenge Operation .
  4. Wait for the first timer based registration to complete.
  5. When the test set receives the Registration Message , a Registration Global Challenge is implemented.
  6. Observe the Global Challenge Information window and verify whether the registration passes or fails the authentication. If the test fails, check the pass/fail result of each parameter to see which parameters do not match expected values. For details on these results description, see Global Challenge Information .

    NOTE
    The Expected COUNT is empty (non-available) when the test set powers up or fully preset. The COUNT result indicates Fail in the first registration with authentication because the Expected COUNT value is not available until the next registration.

  7. Originate a call from the MS. For example, set the service option properly (such as SO3), and then enter a dialed number on the phone and press SEND.
  8. When the test set receives the Origination Message , an Origination Global Challenge is implemented.
  9. Observe the Global Challenge Information window and verify whether the origination passes or fails the authentication. A typical display is shown below.
  10. End the call.
  11. Paging the MS from the test set. For example, set the service option properly (such as SO2) and then press the Originate Call ( F3 ) on the Authen Ctrl 2 of 2 menu. If required, follow the procedure How Do I Set Up a Call? .
  12. When the test set receives the Page Response Message , a Page Response Global Challenge is implemented.
  13. Observe the Global Challenge Information window and verify whether the page response passes or fails the authentication. A typical display is shown below.
  14. End the call.

    NOTE
    The authentication result does not impact the normal call processing (registration, call connection). For example, a call can be connected even if the authentication fails. Please note that this behavior is different from the standard, but provides more flexibility to perform other MS tests in the event that the authentication test fails.

Perform Unique Challenge

The following procedure is to show you how to perform a Unique Challenge on the control channel while in idle state or on the traffic channel while in a call.

  1. Ensure that the MS and the test set have identical SSD_A. See Perform SSD Update .
  2. Follow the procedure To Set Authentication Parameters or to Access Authentication Information Screen , then press Authentication Parameters ( F1 ) Key on the Authen Ctrl 1 of 2 menu.
    • set the RANDU parameter to the desired value. You may skip this step if the default value will be used.
    • Set the Timer Based Registration State to Off .

      NOTE
      It is recommended that the Timer Based Registration State is turned off to avoid potential confliction between the registrations and the Unique Challenge.

  3. Press the Unique Challenge ( F3 ) key on the Authen Ctrl 1 of 2 menu. The test set sends the Authentication Challenge Message with the specified RANDU to the MS and starts the Unique Challenge operation. For details on the message flow, see Unique Challenge Operation .
  4. Observe the Unique Challenge Information window and verify whether the Unique Challenge on paging channel is successful. A typical display is shown below.
  5. Establish a call. For example, set the service option properly (such as SO2) and then press the Originate Call ( F3 ) on the Authen Ctrl 2 of 2 menu. If required, follow the procedure How Do I Set Up a Call? .
  6. Repeat steps 3 and 4. Verify that the Unique Challenge on traffic channel is successful. A typical display is shown as below.
  7. End the call.

    NOTE
    The authentication result does not impact the normal call processing (registration, call connection). For example, a call can be connected even if the authentication fails. Please note that this behavior is different from the standard, but provides more flexibility to perform other MS tests in the event that the authentication test fails.

To Set Authentication Parameters or to Access Authentication Information Screen

  1. Press the Call Setup key.
  2. Press the left More key, go to Call Control 3 of 5 (in the Lab Application) or Call Control 3 of 3 (in the Test Application).
  3. Press the Authentication ( F2 ) key, the Authen Ctrl menu is displayed.
    • To set the A-Key, RAND, RANDU, RANDSSD values, press the Authentication Parameters ( F1 ) key.
    • To start the Global Challenge authentication, set the Global Challenge ( F2 ) key to On .
    • To start the Unique Challenge authentication, press the Unique Challenge ( F3 ) key.
    • To start the SSD Update procedure, press the SSD Update ( F4 ) key.
    • To clear the results shown on the Global Challenge Information, Unique Challenge Information, and SSD Update Information windows, press the Clear Anthen Results ( F5 ) key.
    • To force the MS make a registration or page the MS, press the left More key. On the Authen Ctrl 2 of 2 , press the Register Mobile ( F6 ) or Originate Call ( F3 ) key.

Perform 3GPP2 C.S0043-0 V1.0 Authentication Tests

To perform the 3GPP2 C.S0043 "7.1 Shared Secret Data (SSD) initialized when A-Key is Changed" test, follow the procedure as described in Perform Global Challenge and Perform Unique Challenge .

To perform the 3GPP2 C.S0043 "7.2 Shared Secret Data Update" test, follow the procedure as described in the Perform SSD Update .

Related Topics

Authentication Overview

Setting Authentication Parameters

Authentication Information Screen

Authentication Troubleshooting

CALL:SECurity


How Do I Change AWGN Power Levels?

How Do I Change AWGN Power Levels?

Last updated: October 28, 2004

To access the AWGN power parameter and display the Generated Power Level Information table:

  1. Press the CALL SETUP key.
  2. Press the More key on the left side of the display.
  3. Press the Generator Info ( F3 ) key.
  4. Press the AWGN Power ( F3 ) key.
  5. Set the desired AWGN levels by using the knob and numeric keys.


How Do I Change Call Parameters?

How Do I Change Call Parameters?

Last updated: October 28, 2004

  1. Press the CALL SETUP key.
  2. On the Call Parms 1 of 4 menu press any key.
  3. Highlight a selection and press the knob. Enter a value. For example, you can set the cell power, cell band, channel, protocol revision, radio configuration, service option.
  4. Press the More key for additional call parameters (for example closed loop power control mode, traffic/fundamental channel data rate, call drop timer, call limit mode, receiver power control, etc.).


How Do I Use Real-Time Vocoder?

How Do I Use Real-Time Vocoder?

Last updated: June 20, 2006

The following procedure provides an example usage of Real-Time Vocoder. It is assumed that a mobile station's antenna output is connected to the test set's RF IN/OUT connector, an external audio source (such as a microphone) is connected to the test set's AUDIO IN port, and an external audio receiver (such as a loudspeaker) is connected to the test set's AUDIO OUT port.

General Procedure

  1. Press the blue SHIFT key and then the green Preset key to fully reset the test set.
  2. Follow the procedure described in How Do I Set Up a Call? to establish a voice call. (In this example, System Type is IS-2000 , Operating Mode is Active Cell and Service Option is SO17 ).
  3. Press the More key on the lower right side of the display until Call Parms 3 of 4 is displayed.
  4. Set the Voice SO Mode ( F11 ) to Real-Time Vocoder .
  5. Press the More key on the lower left side of the display until Call Control 3 of 3 (in Test Application) or Call Control 3 of 5 (in Lab Application) is displayed.
  6. Select Real-Time Vocoder ( F1 ).
  7. Select Real-Time Vocoder Parms ( F1 ). The Real-Time Vocoder Parameters menu is displayed. Set the parameters as desired and then press the Close Menu ( F6 ) key when finish the setting.
  8. Speak into the mobile station. Verify that the voice is heard from the loudspeaker. The voice encoded by the mobile station is sent to the test set over the RF link. The test set then demodulates, decodes the signal and converts it to an analog signal output to the AUDIO OUT connector. The signal is then played by the loudspeaker.
  9. Speak over the microphone. Verify that the voice is heard from the mobile station's speaker. The analog voice signal inputs to the test set over the Audio In connector. The test set samples, encodes the signal, and modulates it onto the RF link. The mobile station when receiving the RF signal, then demodulates, decodes, and converts the signal into an analog audio output to its speaker.
  10. A typical display during real-time vocoder operation is shown below. For an explanation of the encoder headroom and decoder headroom results, see Real-Time Vocoder Headroom Information .

Related Topics

Real-Time Vocoder


How Do I Change Cell Information?

How Do I Change Cell Information?

Last updated: June 20, 2006

The cell information includes several types of parameters:

  • A. Control Channel Parameters
  • B. Cell Parameters
  • C. Access Parameters or Enhanced Access Parameters
  • D. Registration Parameters
  • E. CDMA System Time Parameters

A. Control Channel Parameters

To change the control channel parameters, follow the procedure below.

1. Select the Control Channel Parameters menu.

  1. Press the CALL SETUP key.
  2. Press the More key until you reach Control 2 of 5 menu (Lab Application) or Control 2 of 3 menu (Test Application)
  3. Select the Cell Info ( F2 ).
  4. Select the Control Channel Parameters ( F1 ). The Control Channel Parameters menu is displayed.

2. Set a control channel parameter.

  1. Highlight the Control Channel Configuration and press the knob.
    • If IS-2000 is currently selected in the System Type ( F2 ) and 7 (IS-2000-A) is selected in the Protocol Rev ( F10 ), either F-PCH/R-ACH or F-BCCH/F-CCCH/R-EACH can be selected.

      NOTE
      The selection of the Control Channel Configuration is only available for protocol revision 7 and above. See Protocol Revisions for details.

      • When F-BCCH/F-CCCH/R-EACH is selected, the F-BCCH/F-CCCH related parameters are displayed in the Control Channel Parameters menu. Also, the F3 softkey is labeled as Enhanced Access Parms (see C. Access Parameters or Enhanced Access Parameters for details) and the Cell Information screen is updated with the F-BCCH/F-CCCH/R-EACH related information.
      • When F-PCH/R-ACH is selected, the paging channel related parameters are displayed in the Control Channel Parameters menu. Also, the F3 softkey is labeled to Access Parameters (see C. Access Parameters or Enhanced Access Parameters for details) and the Cell Information screen is updated with the F-PCH/R-ACH related information.
    • If IS-2000 is currently selected in the System Type ( F2 ) and 6 (IS-2000-0) is selected in the Protocol Rev ( F10 ), the paging channel related parameters are displayed in the Control Channel Parameters menu.
  2. Turn the knob to highlight a parameter and then press the knob.
  3. Enter a value or selection and press the knob.
  4. Press the Close Menu ( F6 ) key.
  5. Press the Return ( F6 ) key.

B. Cell Parameters

To change the cell parameters, follow the following procedure.

1. Select the Cell Parameters menu.

  1. Press the CALL SETUP key.
  2. Press the More key until you reach Call Control 2 of 5 (in Lab Application) or Call Control 2 of 3 (in Test Application).
  3. Press the Cell Info ( F2 ) key.
  4. Press the Cell Parameters ( F2 ) key.

2. Set a cell parameter.

  1. Turn the knob to highlight a parameter and then press the knob.
  2. Enter a value or selection and press the knob.
  3. Press the Close Menu ( F6 ) key.
  4. Press the Return ( F6 ) key.

C. Access Parameters or Enhanced Access Parameters

To change the access or enhanced access parameters, follow the procedure below.

1. Select the Access Parameters menu or the Enhanced Access Parameters menu.

  1. Press the CALL SETUP key.
  2. Press the More key until you reach Control 2 of 5 menu (Lab Application) or Control 2 of 3 menu (Test Application).
  3. Press the Cell Info ( F2 ) key.
  4. Depending upon the current selection of the control channel configuration (see A. Control Channel Parameters ), the F3 is labeled to Access Parameters or Enhanced Access Parms by which the Access Parameters or the Enhanced Access Parameters menu can be accessed.

2. Set an access parameter or an enhanced access parameter.

  1. Turn the knob to highlight a parameter and then press the knob.
  2. Enter a value or selection and press the knob.
  3. Press the Close Menu ( F6 ) key.
  4. Press the Return ( F6 ) key.

D. Registration Parameters

To change the registration parameters, follow the procedure below.

1. Select the Registration Parameters menu.

  1. Press the CALL SETUP key.
  2. Press the More key until you reach Control 2 of 5 menu (Lab Application) or Control 2 of 3 menu (Test Application).
  3. Press the Cell Info ( F2 ) key until you reach Control 2 of 5 menu (Lab Application) or Control 2 of 3 menu (Test Application).
  4. Press the Registration Parameters ( F4 ) key.

2. Set a registration parameter.

  1. Turn the knob to highlight a parameter and then press the knob.
  2. Enter a value or selection and press the knob.
  3. Press the Close Menu ( F6 ) key.
  4. Press the Return ( F6 ) key.

E. CDMA System Time Parameters

To change the CDMA system time, follow the procedure below.

1. Select the CDMA System Time Parameters menu

  1. Press the CALL SETUP key.
  2. Press the More key until you reach Control 2 of 5 menu (Lab Application) or Control 2 of 3 menu (Test Application).
  3. Press the Cell Info ( F2 ) key.
  4. Press the CDMA System Time / Sync Info ( F5 ) key.
  5. Press the CDMA System Time Parms ( F1 ) key.

2. Set CDMA System Time

  1. Turn the knob to highlight a parameter and then press the knob.
  2. Enter a value and press the knob.

    NOTE
    You can use a simple way to set the CDMA system time from the front panel. For example, to set the CDMA system time to January 1, 2002 2:00 PM, you can simply enter 2000.1.1 in the CDMA System Time (Date) field and enter 14 in the CDMA System Time (Time) field.

  3. Press the Close Menu ( F6 ) key.
  4. Press the Return ( F6 ) key.

Related Topics

Setting Control Channel Parameters

Setting Cell Parameters

Setting Access Parameters

Setting Enhanced Access Parameters

Setting Registration Parameters

Setting CDMA System Time Parameters


Example Usage of Reverse CLPC Transient Mode

Example Usage of Reverse CLPC Transient Mode

Last updated: October 28, 2004

You can use an external spectrum analyzer or the test set's internal Spectrum Monitor to observe the mobile station's response to the closed loop power control (CLPC).

  • If the test set's internal Spectrum Monitor is to be used, you need to connect the TRIG OUT port to the TRIG IN port on the test set's rear panel via a BNC cable. Set up the Spectrum Monitor in a zero span mode and set its trigger source to External. See How Do I Use the Spectrum Monitor? for details on the Spectrum Monitor setup.
  • If an external spectrum analyzer is to be used, you need to connect the TRIG OUT port on the test set's rear panel to the TRIG IN port of the spectrum analyzer via a BNC cable, then appropriately set up your spectrum analyzer for your test scenario. See Testing 4.4.4 Range of Closed Loop Power Control

Testing 4.4.4 Range of Closed Loop Power Control

Definition: The mobile station provides a closed loop adjustment to its open loop estimate. Adjustments are made in response to valid received power control bits. The range of the adjustment is defined by the difference between the maximum mobile station output power and the open loop estimate, and the difference between the minimum mobile station output power and the open loop estimate.

We recommend you use the test set and an external Spectrum Analyzer (for example, Agilent E4443A PSA) to make the tests. The general setup procedure is shown below. You may need to change some settings that are appropriate for your test scenario.

  1. Hardware Connection:
    • Connect the mobile station's antenna output to the power splitter; Connect one output end of the power splitter to the RF INPUT port of the PSA; Connect the other output end of the power splitter to the RF IN/OUT port on the test set's front panel.
    • Connect the TRIG OUT port on the test set's rear panel to the EXT TRIGGER INPUT port on the PSA's front panel via a BNC cable.
    • Connect the 10 MHz REF IN port on the test set's rear panel to the 10 MHz OUT (SWITCHED) port on the PSA's rear panel via a BNC cable.
  2. Press the blue SHIFT and then the green Preset key to full reset the test set.
  3. Establish a call with the following parameter settings (you need to change some settings as needed).
    • Press CALL SETUP to access Call Parms and Call Control menus.
    • Set Cell Band ( F8 on the Call Parms 1 of 4 ) to US PCS or others depending upon your mobile station.
    • Set Radio Config ( F11 on the Call Parms 1 of 4 ) to (Fwd1, Rvs1) .
    • Select FCH Service Option Setup ( F12 ) (Call Parms 1 of 4) , set Service Option for Fwd1, Rvs1 to SO2 (Loopback) .
    • Set Traffic Data Rate ( F12 on the Call Parms 2 of 4 ) to Full (indicating 9600 kbps), or other values required for your tests (Half indicating 4800 kbps, Quarter indicating 2400 kbps, Eighth indicating 1200 kbps).
    • Press Originate Call ( F3 ) to initiate a call. Verify that the Connected is in the Active Cell status field.
  4. Set Call Drop Timer to Off ( F10 on the Call Parms 2 of 4 menu) to keep the test set from drop the connection based on the very low output power level of the mobile station.
  5. Set Cell Power (Î or ) to -61 dBm/1.23 MHz ( F7 on the Call Parms 1 of 4 ) to yield an open loop output power, measured at the mobile station antenna connector, of -15 dBm (for US PCS band). It is variable due to the selected cell band).
  6. Set Pwr Ctrl Size ( F8 on the Call Parms 2 of 4 menu) to 1.0 dB power control step size. Change the setting as required for other tests.
  7. Set Rvs Power Ctrl ( F7 on the Call Parms 2 of 4 menu) to Alternating bits , which makes test set to transmit consecutive alternating '0' and '1' power control bits to the mobile station.
  8. Press the Rvs Power Ctrl Transient Parm ( F8 ) on the Call Parms 4 of 4 menu. See Setting Reverse CLPC Transient Parameters for details on the parameters.
    • Set the Transient Number of Steps to 100 .
    • Set the Transient Mode to Up-Down-Up .
    • Press the Close Menu ( F6 ) key.
  9. Set External Trigger Type ( F4 on the Gen Info menu) to FDEPendent (see How Do I Change Generator Information? ). For more details on the trigger sources, see Setting External Trigger .
  10. Set up the PSA: set its trigger source to use EXT FRONT (depending on your hardware connection); turn on the 10 MHz OUT timebase; set to use zero span mode, and set other parameters needed for your test scenario. See the PSA user's documents for details on the PSA setup.
  11. Go to Call Parms 4 of 4 menu, press the Start Rvs Power Ctrl Transient ( F2 ) key to start sending the closed loop power control bits as specified in step 10. Note that coincident with the transmission of the first power control bit of the transient the test set will output a trigger signal (a TTL rise based pulse with a width of about 1.25 ms.) to the TRIG OUT port on the test set's rear panel as specified in step 9. After completion of the transient transmitting, the closed loop power control returns to the Alternating bits mode as specified in step 7. See Reverse CLPC Transient Modes for details.
  12. Observe the measurement results from the PSA. A typical display is shown below.
  13. Repeat the procedures and change the settings as required for other tests.
  14. After finishing the measurements:
    • Turn the Call Drop Timer back to On .

Related Topics

Setting Reverse Closed Loop Power Control


How Do I Change Generator Information?

How Do I Change Generator Information?

Last updated: October 28, 2004

A. Select the Generator Info Menu

  1. Press the CALL SETUP key.
  2. Press the More key.
  3. Press the Generator Info ( F3 ) key.

B. Set Generator Information

  1. Press any Gen Info softkey ( F2 to F4 ) to select a parameter.
  2. Set the parameter by using the knob and numeric keys.
  3. Press the Return ( F6 ) key to exit the setting.

Related Topics

Setting External Trigger


How Do I Configure the AUDIO OUT Port?

How Do I Configure the AUDIO OUT Port?

Last updated: October 28, 2004

A. Select a signal to output at the AUDIO OUT port.

  1. Press the SYSTEM CONFIG key.
  2. Press the More key on the left side of the display for additional system parameters.
  3. Press the Audio Out Port ( F1 ) key.
  4. Turn the knob to highlight a selection and then press the knob.

NOTE
To facilitate the change of signal selection for output to the front-panel AUDIO OUT port while performing different tasks, you can also access the Audio Out Port settings from several other menus: Audio Generator control menu, Swept Audio Setup menu, Call Parms menu (2 of 3) in AVC Test operating mode, and Call Parms menu (2 of 3) in Active Cell operating mode with AMPS system selected. Changing the selection on one menu will be applied to all other menus.

NOTE
Selection of FM Demod signal routed to the front-panel AUDIO OUT port is useful only in AMPS system. There will be no guaranteed performance for the signal present at the Audio Out Port when FM Demod is selected for output.

B. Set FM Demod signal.

When FM Demod signal is selected for output to the front-panel AUDIO OUT port, a bandpass filter, expander circuit, and de-emphasis circuit can be individually inserted or bypassed in the FM Demod signal path.

  1. Press the SYSTEM CONFIG key.
  2. Press the More key.
  3. Press the FM Demod Setup ( F2 ) key.
  4. Turn the knob to highlight a selection and then press the knob.
  5. Enter a value or selection and press the knob.
  6. Press the Close Menu ( F6 ) key.

NOTE
If the FM Demod Setup settings are changed while the Audio Out Port selection is not FM Demod (see A. Select a signal to output at the AUDIO OUT port. ), the values will be stored for use when Audio Out Port is set to FM Demod.

Related Topics

Configuring the Test Set's AUDIO OUT port


How Do I Configure Test Signals in CW Operating Mode?

How Do I Configure Test Signals in CW Operating Mode?

Last updated: October 28, 2004

  1. Press the CALL SETUP key.
  2. Press the Operating Mode ( F1 ) key and set the operating mode to CW .
  3. Press the Test Signal ( F9 ) key to select a signal for output to the front panel RF connector currently selected. See Front Panel Connectors to select either RF IN/OUT or RF OUT ONLY connector.
  4. Select a test signal from the menu and confirm the selection by selecting Yes in the dialog box.
    NOTE

    Changing test signal requires several seconds to complete.

  5. Press the Cell Power ( F7 ) key and set the signal output power level to meet your testing needs.
  6. Press the RF Gen Freq ( F8 ) key and set the signal output center frequency to meet your testing needs.
  7. Press the Receiver Control ( F12 ) key and manually set the test set's receiver control parameters (such as expected CW power, measurement receiver frequency, and reverse link receiver frequency) to the desired values (see Manual Receiver Control in CW Operating Mode ).

Related Topics

CW Operating Mode

Receiver Control


How Do I End a Call?

How Do I End a Call?

Last updated: October 28, 2004

  1. Press the CALL SETUP key.
  2. Press the End Call ( F3 ) key, or end the call from the mobile.
  3. Check for Idle in the Active Cell status field.


How Do I Change F-FCH/Traffic Channel Parameters?

How Do I Change F-FCH/Traffic Channel Parameters?

Last updated: June 12, 2007

The forward fundamental/traffic channel parameters are spread under several menus on test set's front panel.

Setting F-FCH/Traffic Levels and Walsh Codes

To set the F-FCH/Traffic level and walsh code parameters, see How Do I Change Generator Information?

Setting F-FCH/Traffic Data Rate, Voice SO Mode, Echo Delay parameters

To access the Traffic Data Rate, Voice SO Mode, Echo Delay parameters:

  1. Press the CALL SETUP key.
  2. Press the More key on the right side to display 2 of 4 menu.
  3. Press the Traffic Data Rate ( F12 ) to select a value for the channel data rate.
  4. Press the More key again to display 3 of 4 menu.
  5. Press the Voice SO Mode ( F11 ) to select an audio source. Note this setting is applied only when a voice service option (SO1, SO3, SO17, SO68, or SO32768) is currently selected.
  6. Press Echo Delay ( F12 ) to set the echo delay time. Note this setting is useful only when Voice Echo is currently selected in step 5.

Related Topics

Configuring the Forward Fundamental/Traffic Channel (F-FCH/Traffic)


How Do I Perform a Hard Handoff?

How Do I Perform a Hard Handoff?

Last updated: June 20, 2006

  1. Establish a call. See How Do I Set Up a Call? .
  2. On the Call Setup screen, press the Handoff Setup ( F5 ) key.
  3. Change the handoff parameters to the desired value.
  4. Press the Execute Handoff (F5 ) key to initiate the handoff.
  5. Check for Connected in the Active Cell status field.

Related Topics

Performing a Hard Handoff


How Do I Make Measurements on a Mobile Station?

How Do I Make Measurements on a Mobile Station?

Last updated: October 28, 2004

A. Establish a call.

  1. Connect the mobile station to the Test Set.
  2. Make a call (see How Do I Set Up a Call? ).

B. Select measurements.

  1. Press the Measurement selection key.
  2. Highlight a measurement and press the knob.
  3. Repeat steps 1 and 2 to select additional measurements.

For detailed procedures for a particular measurement, see individual measurement procedures.


Measuring Access Probe Power

Measuring Access Probe Power

Last updated: December 12, 2006

  • General Procedure
  • Testing 4.4.1 Range of Open Loop Output Power
  • Testing 4.4.3 Access Probe Output Power

General Procedure

NOTE
Channel power calibration should be performed if the test set is being used for the first time or the operating environment has changed significantly since the last calibration was performed. The channel power calibration also calibrates the access probe power measurement. See Calibrating the Test Set for details.

  1. Connect the mobile station's antenna output to the test set's front panel RF IN/OUT connector and power them on.
  2. Press the blue SHIFT key and then the green Preset key to full reset the test set.
  3. Initialize the access probe power measurement:
    • Press the Measurement selection key.
    • Turn the knob to highlight the Access Probe Power measurement and press the knob.
  4. Press the Access Probe Power Setup ( F1 ) to access the Access Probe Power Setup menu. Use the knob and DATA ENTRY keys to set the measurement parameters as needed for your measurement situation. (Some parameters can also be set from the Access Parameters menu in step 3).

    NOTE
    If you wish to only capture the first access probe, set Trigger Arm to Single and press the START SINGLE key to start the measurement. When the Trigger Arm is set to Continuous , the test set will display the power level of the most recently measured access probe.

  5. Press the Close Menu ( F6 ) key.
  6. Set the test set to ignore all access attempts by setting Call Limit Mode to On ( F10 on the Call Parms 2 of 3 menu). See How Do I Change Call Parameters? for details.
    NOTE

    It is recommended that you always turn the call limit mode on when measuring access probe power. The easiest way to induce access probes from the mobile station is to page the mobile station. If you do not have call limit mode set to on, when you page the mobile station, the connection will complete, which clears the access probe power result from the measurement screen.

    Set call limit mode back to off when you have finished measuring access probe power.

  7. Set the Timer Based Registration State to Off (see D. Registration Parameters ). It is to prevent an access probe power measurement from being triggered by the unexpected mobile station registration.
  8. Set the access parameters (such as power step, number of steps, etc.) as needed for your test situation. See C. Access Parameters or Enhanced Access Parameters for details.
  9. Press the START SINGLE key if you set Trigger Arm to Single in step 4.
  10. Press the CALL SETUP key, then press the Originate Call ( F3 ) key.
  11. Press the MEASUREMENT key, observe the measurement results. A typical display is shown below.
  12. After finishing the measurements:
    • Press the End Call ( F3 on the Call Control 1 of 2 menu).
    • Turn the Call Limit Mode back to Off .
    • Turn the Timer Based Registration State back to On.
    • Turn the access probe power measurement off by pressing the Measurement selection key, selecting Access Probe Power , then Close Measurement ( F4 ).

      IMPORTANT
      If the access probe power measurement is on and waiting to measure a probe, all other measurements (except digital average power) will not be able to execute. It is therefore recommended that you turn off the access probe power measurement before attempting any other measurements.

Testing 4.4.1 Range of Open Loop Output Power

Definition: This test measures the range of the estimated open loop output power. The mobile station estimates its open loop mean output power from its mean input power.

The test set support both Access Channel and Enhanced Access Channel (see C. Access Parameters or Enhanced Access Parameters for procedure on how to configure).

The following test procedure is based on Access Channel and assumes that the mobile station is Class II and supports Band Class 1 (US PCS). You should change the settings as specified for other configurations. Unless otherwise stated, set all parameter settings to their defaults. For details on performing the steps below, see the General Procedure above.

  1. Connect the mobile station's antenna output to the test set's front panel RF IN/OUT connector and power them on.
  2. Press the blue SHIFT key and then the green Preset key to full reset the test set.
  3. Initialize the access probe power measurement:
    • Press the Measurement selection key.
    • Turn the knob to highlight the Access Probe Power measurement and press the knob.
  4. Press the Access Probe Power Setup ( F1 ) to access the Access Probe Power Setup menu. Use the knob and DATA ENTRY keys to set the measurement parameters as specified for the test.

    NOTE
    If you wish to only capture the first access probe, set Trigger Arm to Single and press the START SINGLE key to start the measurement. When the Trigger Arm is set to Continuous , the test set will display the power level of the most recently measured access probe. Observe the display changes.

  5. Press the Close Menu ( F6 ) key.
  6. Press the CALL SETUP key, set the Cell Band ( F8 ) to US PCS .
  7. Set the test set to ignore all access attempts by setting Call Limit Mode to On ( F10 on the Call Parms 2 of 3 menu).
  8. Set the Timer Based Registration State to Off (see D. Registration Parameters ) to prevent an access probe power measurement from being triggered by the unexpected mobile station registration.
  9. Set the access parameters as specified (see C. Access Parameters or Enhanced Access Parameters for details).
    • Set Preamble Size (PAM_SZ) to 15.
    • Set Maximum Response Sequence (MAX_RSP_SEQ) to 1.
  10. Set Cell Power (Î or ) ( F7 on the Call Parms 1 of 3 ) as specified:
    • Test 1: -25 dBm/1.23 MH
    • Test 2: -65 dBm/1.23 MH
    • Test 3: -97 dBm/1.23 MH (depending on Band Class)
  11. If you set the Trigger Arm to Single in step 4, press the START SINGLE key. If you set the Trigger Arm to Continuous , skip this step.
  12. Press the CALL SETUP key, then press the Originate Call ( F3 ) key.
  13. Press the MEASUREMENT key, observe the measurement results. A typical display is shown below.
  14. After finishing the measurements, press the CALL SETUP key, then press the End Call ( F3 ).
  15. Repeat the steps 10-14 for test 2 and test 3.
  16. After finishing all measurements:
    • Turn the Call Limit Mode back to Off .
    • Turn the Timer Based Registration State back to On.
    • Turn the access probe power measurement off by pressing the Measurement selection key, selecting Access Probe Power , then Close Measurement ( F4 ).

      IMPORTANT
      If the access probe power measurement is on and waiting to measure a probe, all other measurements (except digital average power) will not be able to execute. It is therefore recommended that you turn off the access probe power measurement before attempting any other measurements.

Testing 4.4.3 Access Probe Output Power

Definition: This test verifies the following Access Channel and Enhanced Access Channel parameters: nominal power offset, initial power offset, power increment between consecutive probes, number of access probes in one probe sequence, and the number of probe sequences in one mobile station page response access attempt.

The test set support both Access Channel and Enhanced Access Channel (see C. Access Parameters or Enhanced Access Parameters for procedure on how to configure).

The following test procedure is based on Access Channel and assumes that the mobile station is Class II and supports Band Class 1 (US PCS). You should change the settings as specified for other configurations. Unless otherwise stated, set all parameter settings to their defaults. For details on performing the steps below, see the General Procedure above.

  1. Connect the mobile station's antenna output to the test set's front panel RF IN/OUT connector and power them on.
  2. Press the blue SHIFT key and then the green Preset key to full reset the test set.
  3. Initialize the access probe power measurement:
    • Press the Measurement selection key.
    • Turn the knob to highlight the Access Probe Power measurement and press the knob.
  4. Press the Access Probe Power Setup ( F1 ) to access the Access Probe Power Setup menu. Use the knob and DATA ENTRY keys to set the measurement parameters as specified for the test.

    NOTE
    If you wish to only capture the first access probe, set Trigger Arm to Single and press the START SINGLE key to start the measurement. When the Trigger Arm is set to Continuous , the test set will display the power level of the most recently measured access probe. Observe the display changes.

  5. Press the Close Menu ( F6 ) key.
  6. Press the CALL SETUP key, set the Cell Band ( F8 ) to US PCS .
  7. Set Cell Power (Î or ) to -65 dBm/1.23 MHz ( F7 on the Call Parms 1 of 4 ) and Cell 1 F-Pilot Level to -5dB ( F3 on the Call Control 2 of 5 , then press F2 ).
  8. Set the test set to ignore all access attempts by setting Call Limit Mode to On ( F10 on the Call Parms 2 of 3 menu).
  9. Set the Timer Based Registration State to Off (see D. Registration Parameters ) to prevent an access probe power measurement from being triggered by the unexpected mobile station registration.
  10. Set the access parameters (such as initial power, power step, number of steps, etc.) as specified for the test (see C. Access Parameters or Enhanced Access Parameters for details).
    • Test 1: Set all parameters to the defaults.
    • Test 2: Set Nominal Power (NOM_PWR) to 3 dB, Initial Power (INIT_PWR) to 3 dB, Power Step (PWR_STEP) to 1 dB, Number of Steps (NUM_STEP) to 4, Maximum Response Sequence (MAX_RSP_SEQ) to 3.
  11. If you set the Trigger Arm to Single in step 4, press the START SINGLE key. If you set the Trigger Arm to Continuous , skip this step.
  12. Press the CALL SETUP key, then press the Originate Call ( F3 ) key.
  13. Press the MEASUREMENT key, observe the measurement results.
  14. After finishing the measurement, press the CALL SETUP key, then press the End Call ( F3 ).
  15. Repeat the above steps 10-14 for Test 2.
  16. After finishing all measurements:
    • Turn the Call Limit Mode back to Off .
    • Turn the Timer Based Registration State back to On .
    • Turn the access probe power measurement off by pressing the Measurement selection key, selecting Access Probe Power , then Close Measurement ( F4 ).

      IMPORTANT
      If the access probe power measurement is on and waiting to measure a probe, all other measurements (except digital average power) will not be able to execute. It is therefore recommended that you turn off the access probe power measurement before attempting any other measurements.

Related Topics

Access Probe Power Measurement Description


Measuring SINAD Sensitivity

Measuring SINAD Sensitivity

Last updated: October 28, 2004

The following procedure provides an example of how to manually make an SINAD sensitivity measurement.

The example procedure is assumed that the mobile's audio output is connected to the test set's front-panel AUDIO IN connectors and the mobile is on an analog voice channel (AVC) that is being modulated with a 1004 Hz tone at ± 8 kHz peak deviation. It is also assumed that the Cell Power from the test set is set to a minimum usable level (typically about -117 dBm).

General Procedure

A. Establish an AMPS call.

  1. Press the CALL SETUP key.
  2. Press the Operating Mode ( F1 ) key and set the operating mode to Active Cell .
  3. Press the System Type ( F2 ) key and select AMPS .
  4. Press the ACC Channel ( F9 ) key and set the appropriate RF channel number if necessary. (the default analog control channel is 333.)
  5. Press the Anl MS TX Level ( F10 ) key and set the mobile power level if necessary.
  6. Turn on power to the mobile station and wait for an indication that it has found analog service. ( It may be necessary to force the mobile station into Analog mode if it is a dual mode CDMA/AMPS phone .)
  7. Make a mobile station originated call (by entering a phone number and pressing SEND on the mobile station), or make a test set originated call (wait for the mobile station to perform a power up registration or press the Register Mobile ( F6 ) key to ask mobile station to register with test set, then press the Originate Call ( F3 ) key).
  8. Check for Connected in the Active Cell status field.

B. Set up the Audio Analyzer Instrument.

  1. Press the More key on the lower right side of the display (Call Parms) until 2 of 3 is displayed.
  2. Press the Int FM Dev ( F7 ) key and enter 8 KHz using the knob and DATA ENTRY keys.
  3. Press the Instrument Selection key.
  4. Turn the knob to highlight the Audio Analyzer from the list and press the knob.
  5. Press the Audio Analyzer Setup ( F1 ) key to access Audio Analyzer Setup menu.
  6. Make the following settings by using the knob and DATA ENTRY keys:
    • Set the SINAD/Distortion State to On
    • Set the Audio Frequency State to On
    • Set the Filter Type to C-Message
    • Set the Detector Type to RMS
    • Set the Expected Peak Voltage to meet your testing needs
    • Set the De-Emphasis State to Off

    NOTE
    You can also change all above settings as needed for your measurement situation.

    NOTE
    For statistical measurement results, highlight the Multi-Measurement Count parameter and press the ON key. The number of averages will default to 10.

  7. Press the Close Menu ( F6 ) key.

C. Observe the measurements results.

  1. Press the More key on the lower right side of the display (Call Parms) until 1 of 3 is displayed.
  2. Press the Cell Power ( F7 ) key and enter a minimum usable level (typically about -117 dBm) by using DATA ENTRY keys.
  3. Observe the SINAD measurement. It should be greater than 12 dB. A typical display is shown below.

The measurement results include:

  • Audio Level
  • Audio Frequency
  • SINAD
  • Distortion

Related Topics

SINAD Measurement Description


Measuring Code Channel Time/Phase Error

Measuring Code Channel Time/Phase Error

Last updated: October 28, 2004

  • General Procedure
  • Testing 4.3.2 Reverse Pilot Channel to Code Channel Time Tolerance
  • Testing 4.3.3 Reverse Pilot Channel to Code Channel Phase Tolerance

General Procedure

NOTE
Channel power calibration should be performed if the test set is being used for the first time or the operating environment has changed significantly since the last calibration was performed. The channel power calibration also calibrates the Code Channel Time/Phase Error measurement. See Calibrating the Test Set for details.

  1. Connect the mobile station's antenna output to the test set's front panel RF IN/OUT connector and power them on.
  2. Press the blue SHIFT key and then the green Preset key to full reset the test set.
  4. Establish a call with the mobile station with Radio Configuration ((Fwd3, Rvs3), or above) selected. (see How Do I Set Up an IS-2000 Call? ).
  5. Initialize the measurement:
    • Press the Measurement selection key.
    • Turn the knob to highlight the Code Channel Time/Phase Error measurement and press the knob.
  6. Press the Code Time/Phase Error Setup ( F1 ) key to access the Code Time/Phase Error Setup menu and set the measurement parameters as needed for your testing situations.

    For statistical measurement results, highlight the Multi-Measurement Count parameter and press the ON key (the number of averages will default to 10) or directly enter the value as desired.

    NOTE
    If the Trigger Arm is set to Continuous the measurement began executing as soon as you initialize the measurement in step 4. If single is selected in the Trigger Arm field, press the START SINGLE key to trigger each measurement.

  7. A typical display is shown below, observe the pass/fail result.
  8. You can change the time and phase limit settings as needed for your testing situations by using the Time Limit ( F3 ) and Phase Limit ( F4 ) keys.
  9. To display the numeric results for a code channel, press the Marker Position ( F2 ) and turn the knob to position the marker to the bar.
  10. After finishing the measurements:
    • If desired, turn the measurement off by pressing the Measurement selection key, selecting Code Channel Time/Phase Error , then Close Measurement ( F4 ).

Testing 4.3.2 Reverse Pilot Channel to Code Channel Time Tolerance

Definition: This test measures the permissible error in timing between the radiated Reverse Pilot Channel and the other code channels when operating with Radio Configurations 3 through 6.

Testing 4.3.3 Reverse Pilot Channel to Code Channel Phase Tolerance

Definition: This test measures the permissible error in RF phase between the radiated Reverse Pilot Channel and the other code channels when operating with Radio Configurations 3 through 6.

You can perform the above two tests with the following test procedure. It assumes that the mobile station supports Band Class 1 (US PCS) and Radio Configuration 3 or above. Unless otherwise stated, leave all parameter settings to the defaults. For details on performing the steps below, see the General Procedure above.

NOTE
Both tests can be made only when the call is established with radio configuration ((Fwd3, Rvs3), or above) selected.

  1. Connect the mobile station's antenna output to the test set's front panel RF IN/OUT connector and power them on.
  2. Press the blue SHIFT key and then the green Preset key to full reset the test set.
  3. Establish a call with the following parameter settings (some settings need change as specified for other tests).
    • Press CALL SETUP to access Call Parms and Call Control menus.
    • Set Cell Band ( F8 on the Call Parms 1 of 3 ) to US PCS .
    • Set Radio Config ( F11 on the Call Parms 1 of 3 ) to (Fwd3, Rvs3) .
    • Select FCH Service Option Setup ( F12 ) (Call Parms 1 of 3) , set Service Option for Fwd3, Rvs3 to SO2 .
    • Set Cell Power (Î or ) to -55 dBm/1.23 MHz ( F7 on the Call Parms 1 of 3 ).
    • Press Originate Call ( F3 ) to initiate a call. Verify that the Connected is in the Active Cell status field.
  4. Press the Measurement selection key, select the Code Channel Time/Phase Error measurement.
  5. Press the Code Time/Phase Error Setup ( F1 ) key to access the Code Time/Phase Error Setup menu and set the measurement parameters as needed, then press the Close Menu ( F6 ) key.
  6. Set the Time Limit ( F3 ) to 10 ns, or as needed.
  7. Set the Phase Limit ( F4 ) to 0.05 rad, or as needed.
  8. If single is selected in the Trigger Arm field, press the START SINGLE key to trigger each measurement. If the Trigger Arm is set to Continuous , you can skip this step.
  9. A typical display is shown below. Observe the pass/fail result.
  10. To display the numeric results for a code channel, press the Marker Position ( F2 ) and turn the knob to position the marker to the bar.
  11. If desired, after finishing the measurements, turn the measurement off by pressing the Measurement selection key, selecting Code Channel Time/Phase Error , then Close Measurement ( F4 ).

Related Topics

Code Channel Time/Phase Error Measurement Description


How Do I Make a Fast Device Tune Measurement?

How Do I Make a Fast Device Tune Measurement?

Last updated: December 20, 2006

NOTE
Before performing this measurement, ensure that the test set has been properly calibrated (see Calibrating the Test Set ).

Measuring Fast Device Tune

This measurement is only available in IS-2000 Test Operating Mode .

  1. Set the test set's receiver and generator control to manual mode:
    • Set RF Gen Freq Ctrl ( F12 on Call Parms 1 of 4 ) to Manual .
    • Set Rcvr Power Control ( F8 on Call Parms 3 of 4 ) to Manual (it is not necessary to set the Manual Power setting; it is not used by the measurement).
    • Select Meas Frequency ( F10 on call Parms 3 of 4 ) and press the front panel OFF ( MANUAL ) key (the particular frequency displayed is not used by the measurement).
  2. Press the Measurement selection key.
  3. Select the Fast Device Tune measurement.
  4. Select Fast Device Tune Setup ( F1 ) and set the measurement parameters as needed. Select Close Menu ( F6 ).
  5. Select Fast Device Tune MS TX/RX Parms ( F2 ), and configure the parameters as needed. Select Close Menu ( F6 ) and Return ( F6 ).
  6. Place your mobile into a test mode that causes it to transmit continuously at >20 dB below the power level of the first step in the MS TX Power Sequence.
  7. Press the START SINGLE key to initiate (arm) the measurement.
  8. Wait 2 seconds.
  9. Order your mobile to begin transmission of its MS TX Frequency/Power Series (the mobile should then increase its output power by more than 20 dB to reach the first step in the series, which triggers the measurement with an RF rise).

    IMPORTANT
    Do not send any GPIB commands to the test set or press any front panel keys until the measurement has completed.

  10. Select Graph Control ( F3 ). Set the axis control parameters as needed. Select Return ( F6 ).
  11. Select Marker ( F2 ) to turn on the marker on the graphical display.

A typical result is shown below:

Related Topics

Fast Device Tune Measurement Description


Measuring Channel Power

Measuring Channel Power

Last updated: October 28, 2004

  • General Procedure
  • Testing 4.4.6 Minimum Controlled Output Power

General Procedure

NOTE
Channel power calibration should be performed if the test set is being used for the first time or the operating environment has changed significantly since the last calibration was performed. See Calibrating the Test Set for details.

  1. Connect the mobile station's antenna output to the test set's front panel RF IN/OUT connector and power them on.
  2. Press the blue SHIFT key and then the green Preset key to full reset the test set.
  3. Establish a call with the mobile station (see How Do I Set Up a Call? ).
  4. Initialize the measurement:
    • Press the Measurement selection key.
    • Turn the knob to highlight the Channel Power measurement and press the knob.
  5. Press the Channel Power Setup ( F1 ) key to access the Channel Power Setup menu.
  6. Set the measurement parameters as needed for your measurement situation by using the knob and DATA ENTRY keys. Press the Close Menu ( F6 ) key to close the Setup window.

    NOTE
    For statistical measurement results, highlight the Multi-Measurement Count parameter and press the ON key or enter the number of the measurements. The number of averages will default to 10.

    NOTE
    If single is selected in the Trigger Arm field, press the START SINGLE key to trigger each measurement. If the Trigger Arm is set to Continuous the measurement began executing as soon as you initialize the measurement in step 4.

  7. A typical display is shown below.
  8. After finishing the measurements:
    • If desired, turn the measurement off by pressing the Measurement selection key, selecting Channel Power , then Close Measurement ( F4 ).

Testing 4.4.6 Minimum Controlled Output Power

Definition: The minimum controlled output power of the mobile station is the output power, measured at the mobile station antenna connector, when both closed loop and open loop power control indicate minimum output.

The following test procedure assumes that the mobile station supports Band Class 1 (US PCS). You should change the settings as specified for other configurations. Unless otherwise stated, leave all parameter settings to the defaults.

  1. Connect the mobile station's antenna output to the test set's front panel RF IN/OUT connector and power them on.
  2. Press the blue SHIFT and then the green Preset key to full reset the test set.
  3. Establish a call with the following parameter settings (you need to change some settings as needed).
    • Press CALL SETUP to access Call Parms and Call Control menus.
    • Set Cell Band ( F8 on the Call Parms 1 of 4 ) to US PCS .
    • Set Radio Config ( F11 on the Call Parms 1 of 4 ) to (Fwd1, Rvs1) .
    • Select FCH Service Option Setup ( F12 ) (Call Parms 1 of 4) , set Service Option for Fwd1, Rvs1 to SO2 (Loopback) .
    • Set Traffic Data Rate ( F12 on the Call Parms 2 of 4 ) to Full .
    • Press Originate Call ( F3 ) to initiate a call. Verify that the Connected is in the Active Cell status field.
  4. Press the Measurement selection key, select the Channel Power measurement.
  5. Press the Channel Power Setup ( F1 ) key to access the Channel Power Setup menu. Set the measurement parameters as needed. Press the Close Menu ( F6 ) key.
  6. Set the Call Drop Timer to Off ( F9 on the Call Parms 2 of 4 menu) to keep the test set from drop the connection based on the very low output power level of the mobile station.
  7. Set Cell Power (Î or ) to -25 dBm/1.23 MHz ( F7 on the Call Parms 1 of 4 ) to force the open loop power control estimate to the minimum output.
  8. Set the F-Pilot Level to -7.00 dB, and set the F-FCH/Traffic Level to -7.4 dB (see How Do I Change Generator Information? ).
  10. Set Rvs Power Ctrl ( F7 on the Call Parms 2 of 4 menu) to All Down bits , which makes test set to transmit continuous '1' power control bits to the mobile station to force the closed loop power control to the minimum output.
  11. If single is selected in the Trigger Arm field, press the START SINGLE key to trigger each measurement. If the Trigger Arm is set to Continuous the measurement began executing as soon as you initialize the measurement in step 8.
  12. Press the MEASUREMENT key, observe the measurement results.
  13. If Under Range is displayed, it indicates that the mobile station output power is below -61 dBm or is less than -9 dB below the expected power level of the receiver. To get the correct result, we recommend you manually control the test set's receiver (see How Do I Change Test Set's Receiver Control Parameters? ) and then observe the measurement results.
    • Press the Rcvr Power Ctrl ( F8 ) key (on Call Parms 3 of 4) and select Manual to manually set the receiver's expected power.
    • Press the Receiver Power ( F9 ) key (on Call Parms 3 of 4) and enter -61dBm (or as needed) by using the knob or numeric keys.
    • Repeat the steps 10-11. A typical display is shown below.
  14. After finishing the measurements:
    • Turn the Call Drop Timer back to On .
    • If desired, turn the measurement off by pressing the Measurement selection key, selecting Channel Power , then Close Measurement ( F4 ).

Related Topics

Channel Power Measurement Description


Measuring TX Spurious Emissions

Measuring TX Spurious Emissions

Last updated: October 28, 2004

  • General Procedure
  • Testing 4.5.1 Conducted Spurious Emissions

General Procedure

NOTE
Channel Power Calibration should be performed if the test set is being used for the first time or the operating environment has changed significantly since the last calibration was performed. The channel power calibration also calibrates the TX spurious emissions measurement. See Calibrating the Test Set for details.

  1. Connect the mobile station's antenna output to the test set's front panel RF IN/OUT connector and power them on.
  2. Press the blue SHIFT key and then the green Preset key to full reset the test set.
  3. Establish a call with the mobile station (see How Do I Set Up a Call? ).
  4. Initialize the measurement:
    • Press the Measurement selection key.
    • Turn the knob to highlight the Tx Spurious Emissions measurement and press the knob.
  5. Press the Tx Spurious Setup ( F1 ) key to access the Tx Spurious Emissions Setup menu.
  6. Set the measurement parameters as needed for your test situation by using the knob and DATA ENTRY keys. (The parameters such as Adjacent Limit and Alternate Limit which are available when Mask Control is set to Manual .)

    NOTE
    For statistical measurement results, highlight the Multi-Measurement Count parameter and press the ON key or directly enter the number of measurement counts. The number of averages will default to 10.

    NOTE
    If single is selected in the Trigger Arm field, press the START SINGLE key to trigger each measurement. If the Trigger Arm is set to Continuous the measurement began executing as soon as you initialize the measurement in step 4.

  7. Press the Close Menu ( F6 ) key. The numeric results will display by default.
  8. Press the Graph ( F3 ) key to display a graphical measurement results.
    • When viewing the graphical display, you can select Marker Position ( F4 ) and turn the knob to display the spurious emissions levels at each of the frequency offsets.
    • You can also press the Numeric ( F2 ) key to display the numeric results anytime.
  9. After finishing the measurements:
    • If desired, turn the measurement off by pressing the Measurement selection key, selecting Tx Spurious Emissions , then Close Measurement ( F4 ).

Testing 4.5.1 Conducted Spurious Emissions

Definition: Conducted spurious emissions are emissions at frequencies that are outside the assigned CDMA Channel, measured at the mobile station antenna connector. This test measures the spurious emissions during continuous transmission.

The test set does not support the Enhanced Access Channel tests. The following test procedure is for Access Channel and assumes that the mobile station supports Band Class 1 (US PCS). You should change the settings as specified for other configurations. Unless otherwise stated, leave all parameter settings to the defaults.

  1. Connect the mobile station's antenna output to the test set's front panel RF IN/OUT connector and power them on.
  2. Press the blue SHIFT and then the green Preset key to full reset the test set.
  3. Set the following access parameters (see C. Access Parameters or Enhanced Access Parameters ):
    • Set Nominal Power (NOM_PWR) to 7 dB.
    • Set Initial Power (INIT_PWR) to 15 dB.
    • Set Power Step (PWR_STEP) to 7 dB/step.
    • Set Number of Steps (NUM_STEP) to 15 (16 probes/sequence).
    • Set Maximum Response Sequence (MAX_RSP_PWR) to 15 sequences.
  4. Establish a call with the following parameter settings (some settings may change as needed).
    • Press CALL SETUP to access Call Parms and Call Control menus.
    • Set Cell Band ( F8 on the Call Parms 1 of 3 ) to US PCS .
    • Set Radio Config ( F11 on the Call Parms 1 of 3 ) to (Fwd1, Rvs1) .
    • Select FCH Service Option Setup ( F12 ) (Call Parms 1 of 3) , set Service Option for Fwd1, Rvs1 to SO2 (Loopback) .
    • Set Traffic Data Rate ( F12 on the Call Parms 2 of 3 ) to Full .
    • Press Originate Call ( F3 ) to initiate a call. Verify that the Connected is in the Active Cell status field.
  5. Set Cell Power (Î or ) to -104 dBm/1.23 MHz ( F7 on the Call Parms 1 of 3 ).
  7. Set Rvs Power Ctrl to All Up bits ( F7 on the Call Parms 2 of 3 menu) to transmit continuous '0' power control bits.
  8. Press the Measurement selection key, select the Tx Spurious Emissions measurement.
  9. Press the Tx Spurious Setup ( F1 ) key to access the Tx Spurious Emissions Setup menu. Set the measurement parameters as needed.
    • The Adjacent Limit and Alternate Limit settings default to -42 dB and -50 dB. You can change the value when Mask Control is set to Manual .
    • Set F-FCH/Traffic Level to -7.4 dB.
    • Set Trigger Arm to Single.
    • Press Close Menu ( F6 ).
  10. If single is selected in the Trigger Arm field, press the START SINGLE key to trigger each measurement. If the Trigger Arm is set to Continuous , skip this step.
  11. Press MEASUREMENT key, observe the measurement results (see General Procedure for details). The numeric results will be displayed by default. To display a graphical measurement results, press the Graph ( F3 ) key. When viewing the graphical display, you can select Marker Position ( F4 ) and turn the knob to display the spurious emissions levels at each of the frequency offsets.
  12. After finishing the measurements:
    • If desired, turn the measurement off by pressing the Measurement selection key, selecting Tx Spurious Emissions , then Close Measurement ( F4 ).

Related Topics

Tx Spurious Emissions Measurement Description


Measuring Digital Average Power

Measuring Digital Average Power

Last updated: June 20, 2006

  • General Procedure
  • Testing 4.4.5 Maximum RF Output Power

General Procedure

NOTE
Digital Average Power Calibration should be performed if the test set is being used for the first time or the operating environment has changed significantly since the last calibration was performed. See Calibrating the Test Set for details.

  1. Connect the mobile station's antenna output to the test set's front panel RF IN/OUT connector and power them on.
  2. Press the blue SHIFT key and then the green Preset key to full reset the test set.
  3. Establish a call with the mobile station (see How Do I Set Up a Call? ).
  4. Initialize the measurement:
    • Press the Measurement selection key.
    • Turn the knob to highlight the Digital Average Power measurement and press the knob.
  5. Press the Digital Average Power Setup ( F1 ) key to access the Digital Average Power Setup menu.
  6. Set the measurement parameters as needed for your test situation by using the knob and DATA ENTRY keys. Press the Close Menu ( F6 ) key to close the Setup window.

    NOTE
    For statistical measurement results, highlight the Multi-Measurement Count parameter and press the ON key or enter the number of the measurements to be averaged. The number of averages will default to 10.

    NOTE
    If single is selected in the Trigger Arm field, press the START SINGLE key to trigger each measurement. If the Trigger Arm is set to Continuous the measurement began executing as soon as you initialize the measurement in step 4.

  7. A typical display is shown below.
  8. After finishing the measurements:
    • If desired, turn the measurement off by pressing the Measurement selection key, selecting Digital Average Power , then Close Measurement ( F4 ).

Testing 4.4.5 Maximum RF Output Power

Definition: This test measures the maximum power that the mobile station transmits as measured at the mobile station antenna connector.

The test set does not support the Enhanced Access Channel test. The following procedure is for Access Channel test and assumes that the mobile station supports Band Class 1 (US PCS) and Spreading Rate 1. You should change the settings as specified for other configurations. Unless otherwise stated, leave all parameter settings to the defaults.

  1. Connect the mobile station's antenna output to the test set's front panel RF IN/OUT connector and power them on.
  2. Press the blue SHIFT and then the green Preset key to full reset the test set.
  3. Establish a call with the following parameter settings (you could change some settings as needed).
    • Press CALL SETUP to access Call Parms and Call Control menus.
    • Set Cell Band ( F8 on the Call Parms 1 of 3 ) to US PCS .
    • Set Radio Config ( F11 on the Call Parms 1 of 3 ) to (Fwd1, Rvs1) .
    • Select FCH Service Option Setup ( F12 ) (Call Parms 1 of 3) , set Service Option for Fwd1, Rvs1 to SO2 (Loopback) .
    • Set Traffic Data Rate ( F12 on the Call Parms 2 of 3 ) to Full .
    • Press Originate Call ( F3 ) to initiate a call. Verify that the Connected is in the Active Cell status field.
  4. Set Cell Power (Î or ) to -104 dBm/1.23 MHz ( F7 on the Call Parms 1 of 3 ).
  5. Set the F-Pilot Level to -7.00 dB, and set the F-FCH/Traffic Level to -7.4 dB (see How Do I Change Generator Information? ).
  7. Set Rvs Power Ctrl to All Up bits ( F7 on the Call Parms 2 of 3 menu) to transmit continuous '0' power control bits.
  8. Press the Measurement selection key, select the Digital Average Power measurement.
  9. Press the Digital Average Power Setup ( F1 ) key to access the Digital Average Power Setup menu. Set the measurement parameters as needed, then press the Close Menu ( F6 ) key.
  10. If single is selected in the Trigger Arm field, press the START SINGLE key to trigger each measurement. If the Trigger Arm is set to Continuous , you can skip this step.
  11. Press MEASUREMENT key, a typical display is shown below.
  12. After finishing the measurements:
    • If desired, turn the measurement off by pressing the Measurement selection key, selecting Digital Average Power , then Close Measurement ( F4 ).

Related Topics

Digital Average Power Measurement Description


Measuring TX Dynamic Power

Measuring TX Dynamic Power

Last updated: October 28, 2004

General Procedure

NOTE
Channel power calibration should be performed if the test set is being used for the first time or the operating environment has changed significantly since the last calibration was performed. The channel power calibration also calibrates the TX dynamic power measurement. See Calibrating the Test Set for details.

NOTE
The measurement is expected to only be used when Call Connection status is Idle since the mobile station must be in a test mode, otherwise it may not produce meaningful results.

  1. Connect the mobile station's antenna output to the test set's front panel RF IN/OUT connector and power it on.
  2. Place your mobile station in the test mode required for performing TX dynamic power. The mobile station should be set to transmit initial power at its maximum transmit power at the appropriate frequency for the test.
  3. Press the blue SHIFT key and then the green Preset key to full reset the test set.
  4. Set test set's receiver power control to Manual mode and set the test set's Manual Receiver Power and Meas Frequency (see How Do I Change Test Set's Receiver Control Parameters? ) to the initial power level and frequency at which the mobile station will transmit. (It should be the maximum power the mobile station will transmit)
  5. Initialize the measurement:
    • Press the Measurement selection key.
    • Turn the knob to highlight the TX Dynamic Power measurement and press the knob.

      IMPORTANT
      The TX dynamic power measurement does not run concurrently with any other measurements. If any measurements are running, they are closed when TX dynamic power measurement is initiated, and a message is displayed indicating that a measurement has been closed. Activating another measurement inactivates the TX dynamic power measurement.

      IMPORTANT
      If the TX dynamic power measurement is running at the time the power control transient transmission starts (see Starting the Reverse CLPC Transient ) the measurement will be closed and its operation aborted. Moreover, the TX dynamic power measurement will not be able to start (become initiated) while the transient transmission is in progress.

  6. Set the measurement parameters as needed for your test situation.
    • Press the TX Dynamic Power Setup ( F1 ) key to access the TX Dynamic Power Setup menu.
    • Set the Power Step Size , Number of Power Steps , and Power Step Time to match your mobile station's test mode. See TX Dynamic Power Measurement Parameters for details.
    • Press the Close Menu ( F6 ) key.
  7. Press the START SINGLE key to arm the TX Dynamic Power measurement.
  8. Via the mobile station test mode interface, command the mobile station to generate an RF Rise impulse to trigger the measurement. After that, the mobile station will transmit power according to its test mode defined output power profile.
    IMPORTANT

    Don't make any changes on the test set until the measurement is complete. Otherwise, it may cause the measurement to abort due to the missed trigger (see TX Dynamic Power Measurement Troubleshooting ).

  9. A typical display for the TX Dynamic Power measurement result is shown below.
  10. Set up the graph display:
    • Press the Graph Control (F2 ).
    • Press the Start Step ( F3 ) and Span ( F4 ) to adjust the graph view.
    • Press the Marker Position ( F1 ). The power result that corresponds with the marker position is displayed above the graph and is highlighted in the table below the graphical display. The marker position also controls the table scrolling.

Related Topics

TX Dynamic Power Measurement Description


Measuring DTMF

Measuring DTMF

Last updated: June 20, 2006

The performance test standard of DTMF is defined in the section 10.1 of TIA/EIA-690 standard.

Testing 10.1 Dual Tone Multifrequency (DTMF) Signaling

The following procedure demonstrates how to measure the DTMF signaling.

  1. Connect the mobile station's antenna output to the test set's front panel RF IN/OUT connector and power them on.
  2. Press the blue SHIFT key and then the green Preset key to full reset the test set.
  3. Establish a call with the mobile station (see How Do I Set Up an AMPS Call? ).
  4. Initialize the measurement:
    • Press the Measurement selection key.
    • Turn the knob to highlight the DTMF measurement and press the knob.
  5. Press the DTMF Setup ( F1 ) key to access the DTMF Setup menu.
  6. Set the measurement parameters as needed for your measurement situation by using the knob and DATA ENTRY keys. Press the Close Menu ( F6 ) key to close the Setup window.

    NOTE
    It is recommended to set the Trigger Arm field to be single in order to capture the stable DTMF characters. If single is selected in the Trigger Arm field, press the START SINGLE key to trigger each measurement. If the Trigger Arm is set to Continuous then the measurement began executing as soon as you initialized the measurement in step 4.

  7. Press the mobile station keypad to generate the DTMF symbols. A typical display is shown below.
  8. After finishing the measurements:
    • If desired, turn the measurement off by pressing the Measurement selection key, selecting DTMF , then Close Measurement ( F6 ) .

Related Topics

DTMF Measurement Description


Measuring Frame Error Rate (FER)

Measuring Frame Error Rate (FER)

Last updated: December 21, 2004

  • General Procedure
  • Testing 3.4.1 Demodulation of Forward Traffic Channel in AWGN (for forward fundamental channel test)
  • Testing 3.5.1 Receiver Sensitivity and Dynamic Range
  • Testing 3.4.7 Demodulation of Forward Traffic Channel in Multipath Fading Channel with Closed Loop Power Control (FPC_MODE = '000')
  • Testing 3.4.9 Demodulation of Forward Traffic Channel in Multipath Fading Channel with Outer Loop Power Control and Closed Loop Power Control (FPC_MODE = '000')

General Procedure

  1. Connect the mobile station's antenna output to the test set's front panel RF IN/OUT connector and power them on.
  2. Press the blue SHIFT key and then the green Preset key to full reset the test set.
  3. Establish a call with the mobile station with a loopback service option (SO2, SO9 or SO55) selected (see How Do I Set Up a Call? ).
  4. Initialize the measurement:
    • Press the Measurement selection key.
    • Turn the knob to highlight the Frame Error Rate measurement and press the knob.
  5. Press AWGN Power ( F3 ), use the knob and DATA ENTRY keys to enter -54 dBm/1.23 MHz , or as needed.
  6. Press the Frame Error Rate Setup ( F1 ) key to access the Frame Error Rate Setup menu.
  7. Use the knob and DATA ENTRY keys to set the measurement parameters as needed for your measurement situation. Press the Close Menu ( F6 ) key to close the settings.

    If single is selected in the Trigger Arm field, press the START SINGLE key to trigger each measurement. If the Trigger Arm is set to Continuous the measurement began executing as soon as you initialize the measurement in step 4.

  8. A typical display is shown below.
  9. After finishing the measurements, turn the measurement off if desired. Press the Measurement selection key, selecting Frame Error Rate , then Close Measurement ( F4 ).

Testing 3.4.1 Demodulation of Forward Traffic Channel in AWGN

Definition: This test evaluates how well the mobile station demodulates the Forward Traffic Channel in the presence of noise (simulated by AWGN). The performance of the demodulation of Forward Traffic Channel in an AWGN (no fading or multipath) environment is determined by the frame error rate (FER).

The following test procedure assumes that the mobile station supports Band Class 1 (US PCS) and only demonstrates the Test 1. You should change the settings as specified for other tests. Unless otherwise stated, leave all parameter settings to the defaults.

NOTE
The FER measurement is used for testing the forward fundamental channel . You can use TDSO FER measurement to perform the tests for forward supplemental channel . See Measuring TDSO (Test Data Service Option) Frame Error Rate (FER) .

  1. Connect the mobile station's antenna output to the test set's front panel RF IN/OUT connector and power them on.
  2. Press the blue SHIFT and then the green Preset key to full reset the test set.
  3. Establish a call with the following parameter settings (some settings may change as specified for each test).
    • Press CALL SETUP to access Call Parms and Call Control menus.
    • Set Cell Band ( F8 on the Call Parms 1 of 3 ) to US PCS .
    • Set Radio Config ( F11 on the Call Parms 1 of 3 ) to (Fwd1, Rvs1) .
    • Select FCH Service Option Setup ( F12 ) (Call Parms 1 of 3) , set Service Option for Fwd1, Rvs1 to SO2 (Loopback) .
    • Set Cell Power (Î or ) to -55 dBm/1.23 MHz ( F7 on the Call Parms 1 of 3 ).
    • Set Traffic Data Rate ( F12 on the Call Parms 2 of 3 ) to Full .
    • Press Originate Call ( F3 ) to initiate a call. Verify that the Connected is in the Active Cell status field.
  4. Press the Measurement selection key, select the Frame Error Rate measurement.
  5. Press F3, set AWGN Power (I oc ) to -54 dBm/1.23 MHz .
  6. Press F1 to access the Frame Error Rate Setup menu (some settings may change as specified for each test).
    • Set FER Requirement to 3.00%.
    • Set F-FCH/Traffic Level to -16.3 dB.
    • Set Trigger Arm to Single.
    • Press Close Menu ( F6 ).
  7. Press the START SINGLE key to begin the measurement.

    NOTE
    If the Trigger Arm is set to Continuous the measurement began executing as soon as you initialize the measurement in step 4. If single is selected in the Trigger Arm field, press the START SINGLE key to trigger each measurement.

  8. A typical display is shown below.
  9. Repeat the steps 3-8 with the settings as specified for each test.
  10. After finishing all of the tests, turn the measurement off if desired. Press the Measurement selection key, selecting Frame Error Rate , then Close Measurement ( F4 ).

Testing 3.5.1 Receiver Sensitivity and Dynamic Range

Definition: The RF sensitivity of the mobile station receiver is the minimum received power, measured at the mobile station antenna connector, at which the frame error rate (FER) does not exceed a specified value. The receiver dynamic range is the input power range at the mobile station antenna connector over which the FER does not exceed a specific value.

The following test procedure assumes that the mobile station supports Band Class 1 (US PCS). All settings for the Receiver Sensitivity test and the Dynamic Range test could be the same, except the cell power (Î or ) settings as shown below. Unless otherwise stated, leave all parameter settings to the defaults.

  1. Connect the mobile station's antenna output to the test set's front panel RF IN/OUT connector and power them on.
  2. Press the blue SHIFT and then the green Preset key to full reset the test set.
  3. Establish a call with the following parameter settings (some settings may change as specified for each test).
    • Press CALL SETUP to access Call Parms and Call Control menus.
    • Set Cell Band ( F8 on the Call Parms 1 of 3 ) to US PCS .
    • Set Radio Config ( F11 on the Call Parms 1 of 3 ) to (Fw1, Rvs1) .
    • Select FCH Service Option Setup ( F12 ) (Call Parms 1 of 3) , set Service Option for Fw1, Rvs 1 to SO2 (Loopback) .
    • Set Traffic Data Rate ( F12 on the Call Parms 2 of 3 ) to Full .
    • Press Originate Call ( F3 ) to initiate a call. Verify that the Connected is in the Active Cell status field.
  4. For Test 1: Receiver Sensitivity test, set Cell Power (Î or ) to -104 dBm/1.23 MHz ( F7 on the Call Parms 1 of 3 ).
    For Test 2: Dynamic Range test, set Cell Power (Î or ) to -25 dBm/1.23 MHz ( F7 on the Call Parms 1 of 3 )
  5. Press the Measurement selection key, select the Frame Error Rate measurement.
  6. Verify that AWGN Power (I oc ) ( F3 ) is OFF .
  7. Press F1 to access the Frame Error Rate Setup menu (some settings may change as specified for each test).
    • Set FER Requirement to 5.00%.
    • Set F-FCH/Traffic Level to -15.6 dB.
    • Set Trigger Arm to Single.
    • Press Close Menu ( F6 ).
  8. Press the START SINGLE key to begin the measurement.

    NOTE
    If the Trigger Arm is set to Continuous the measurement began executing as soon as you initialize the measurement in step 4. If single is selected in the Trigger Arm field, press the START SINGLE key to trigger each measurement.

  9. A typical display is shown below.
  10. Repeat the steps 4-9 for test 2.
  11. After finishing all of the tests, turn the measurement off if desired. Press the Measurement selection key, selecting Frame Error Rate , then Close Measurement ( F4 ).

Testing 3.4.7 Demodulation of Forward Traffic Channel in Multipath Fading Channel with Closed Loop Power Control (FPC_MODE = '000')

See How Do I Perform FPC Test (FPC Mode 000)? .

Testing 3.4.9 Demodulation of Forward Traffic Channel in Multipath Fading Channel with Outer Loop Power Control and Closed Loop Power Control (FPC_MODE = '000')

See How Do I Perform FPC Test (FPC Mode 000)? .

Related Topics

Frame Error Rate (FER) Measurement Description


Measuring Frequency Modulation

Measuring Frequency Modulation

Last updated: August 12, 2005

The performance test standards of frequency modulation are defined in the TIA/EIA-690 standard.

Testing 3.3.2.3 Modulation Deviation Limiting

Definition : Modulation Limiting refers to the ability of the transmitter circuits to prevent the transmitter from producing deviation in excess of rated system deviation.

The following procedure demonstrates how to measure the frequency modulation deviation limiting.

  1. Connect the mobile station's antenna output to the test set's front panel RF IN/OUT connector.
  2. Connect the mobile station's audio input to the test set's front panel AUDIO OUT and power on the test set.
  3. Press the blue SHIFT key and then the green Preset key to full reset the test set and power on the mobile station.
  4. Establish a call with the mobile station (see How Do I Set Up an AMPS Call? ).
  5. Initialize the measurement:
    • Press the Measurement selection key.
    • Turn the knob to highlight the Frequency Modulation measurement and press the knob.
  6. Press the Frequency Mod ( F1 ) key to access the Frequency Mod Setup menu.
  7. Set the measurement parameters as needed for your measurement situation by using the knob and DATA ENTRY keys.
    • Select Filter Type to be 50 Hz to 3 kHz.
    • Select Detector Type to be Peak +/- Max.

    NOTE
    For statistical measurement results, highlight the Multi-Measurement Count parameter and press the ON key or enter the number of the measurements. The number of averages is default to 10.

    NOTE
    If single is selected in the Trigger Arm field, press the START SINGLE key to trigger each measurement. If the Trigger Arm is set to Continuous then the measurement began executing as soon as you initialized the measurement in step 5.

  8. Press the Close Menu ( F6 ) key to close the Setup window.
  9. Enable audio generator in the test set.
    • Press the Instrument selection key.
    • Turn the knob to highlight the Audio Generator instrument and press the knob.
  10. Configure the audio generator output
    • Press the Frequency ( F3 ) key (on Call Control 1 of 2) to set the frequency of the generated signal to be 1 kHz
    • Press the Amplitude (F1) key (on Call Control 1 of 2) to adjust the amplitude of the generated signal until the peak FM Deviation is +/- 8 kHz.
    • A typical display is shown below
  11. Press the Amplitude ( F1 ) key to increase the audio output amplitude level by 20 dB in one step. A typical display for the measurement is shown below.
  12. Press the Frequency ( F3 ) key to vary the audio frequency between 300 Hz and 3000 Hz. Both the instantaneous peak and the steady state deviations at and after the time of increasing the signal level shall be observed. The results shall not exceed the rated system peak frequency deviation of +/-12 kHz at any audio frequency or reasonable change in input level. A typical display for the measurement is shown below.
  13. After finishing the measurements:
    • If desired, turn the instrument off by pressing the Instrument selection key, selecting Audio Generator , then Close Measurement ( F4 ) .
    • If desired, turn the measurement off by pressing the Measurement selection key, selecting Frequency Modulation, then Close Measurement ( F6 ) .

Related Topics

Frequency Modulation (FM) Measurement Description


Measuring Gated Power

Measuring Gated Power

Last updated: October 28, 2004

  • General Procedure
  • Testing 4.4.7 Standby Output Power and Gated Output Power

General Procedure

NOTE
Channel power calibration should be performed if the test set is being used for the first time or the operating environment has changed significantly since the last calibration was performed. The channel power calibration also calibrates the gated power measurement. See Calibrating the Test Set for details.

  1. Connect the mobile station's antenna output to the test set's front panel RF IN/OUT connector and power them on.
  2. Press the blue SHIFT key and then the green Preset key to full reset the test set.
  3. Establish a call with the mobile station (see How Do I Set Up a Call? ).
    • For IS-95 call, make sure the call is connected with a loopback service option (SO2 or SO9) selected before making the following measurements.
    • For IS-2000 call, make sure the call is connected with Radio Config set to (Fwd1, Rvs1) or (Fwd2, Rvs2), and FCH Service Option Setup set to a loopback service option (SO2 or SO9).
  4. Press the More key on the lower right side of the display (Call Parms) until 2 of 3 is displayed. Press the Traffic Data Rate key ( F12 ) key, then select Eighth.
  5. Initialize the measurement:
    • Press the Measurement selection key.
    • Turn the knob to highlight the Gated Power measurement and press the knob.
  6. Press the Gated Power Setup ( F1 ) key to access the Gated Power Setup menu.
  7. Set the measurement parameters as needed for your test situation by using the knob and DATA ENTRY keys. Press the Close Menu ( F6 ) key to close the Setup window.

    NOTE
    The default settings for gated power measurements include multi-measurement on with a 100 measurement count.

    NOTE
    If single is selected in the Trigger Arm field, press the START SINGLE key to trigger each measurement. If the Trigger Arm is set to Continuous the measurement began executing as soon as you initialize the measurement in step 4.

  8. Two types of the power versus time graph view are available after the test set analyzes measurement data. By default, the Rise/Fall View is displayed.The rise trace zooms in on the rising edge of the burst and the fall trace zooms in on the falling edge of the burst.
    • Observe the Pass/Fail results.
    • If you want to display the power level at a point along the Rise Trace, press the Rise Marker ( F3 ) key and turn the knob to select the desired points.
    • If you want to display the power level at a point along the Fall Trace, press the Fall Marker ( F4 ) key and turn the knob to select the desired points.
  9. If you want to display the full trace, press the Full/Zoom key ( F2 ). A typical display is shown below (The extreme left and right zoom positions equate to the rise and fall views.).
    • Press the Zoom Position ( F3 ) key, then turn the knob to select an area highlighted by a vertical bar on the full trace (the top graph) to zoom in. The zoom trace details the selected area on the low graph.
    • If you want to display the power level at a point along the zoom trace, press the Zoom Marker ( F4 ) key and turn the knob to select the desired points.
    • Press the Rise/Fall View ( F2 ) key if you want to return to Rise/Fall View.
  10. After finishing the measurements:
    • Turn the measurement off by pressing the Measurement selection key, selecting Gated Power , then Close Measurement ( F4 ).

Testing 4.4.7 Standby Output Power and Gated Output Power

The test set does not support the Standby Output Power test and only supports the Gated Output Power test for Radio Configuration 1 or 2.

Definition: The Gated Output Power test measures the time response of the mean output power for a gated-on power control group (1.25 ms).

The following procedure assumes that the mobile station supports Band Class 1 (US PCS). You should change the settings as specified for other configurations. Unless otherwise stated, leave all parameter settings to the defaults.

NOTE
This test can be made only when the call is established with radio configuration ((Fwd1, Rvs1), or (Fwd2, Rvs2)) and with 1/8 Data Rate selected.

  1. Connect the mobile station's antenna output to the test set's front panel RF IN/OUT connector and power them on.
  2. Press the blue SHIFT key and then the green Preset key to full reset the test set.
  3. Establish a call with the following parameter settings (some settings may change as specified for other tests).
    • Press CALL SETUP to access Call Parms and Call Control menus.
    • Set Cell Band ( F8 on the Call Parms 1 of 3 ) to US PCS .
    • Set Radio Config ( F11 on the Call Parms 1 of 3 ) to (Fwd1, Rvs1) .
    • Select FCH Service Option Setup ( F12 ) (Call Parms 1 of 3) , set Service Option for Fwd1, Rvs1 to SO2 .
    • Press Originate Call (F3 on the Call Control 1 of 3 ) to initiate a call. Verify that the Connected is in the Active Cell status field.
  4. Set Traffic Data Rate ( F12 on the Call Parms 2 of 3 ) to Eighth .
  5. Set Cell Power (Î or ) to -75 dBm/1.23 MHz ( F7 on the Call Parms 1 of 3 ).
  6. Set Rvs Power Ctrl to Alternating bits ( F7 on the Call Parms 2 of 3 menu) to send alternating '0' and '1' power control bits on the Forward Traffic Channel.
  7. Press the Measurement selection key, select the Gated Power measurement.
  8. Press the Gated Power Setup ( F1 ) key to access the Gated Power Setup menu. You could Set the measurement parameters as needed for your measurement situation.
    • Set Multi-Measurement Count to 100.
    • Set F-FCH/Traffic Level to -7.40 dB.
    • Set Trigger Arm to Single.
    • Press Close Menu ( F6 ).
  9. Press the START SINGLE key to trigger the measurement if single is selected in the Trigger Arm field. If the Trigger Arm is set to Continuous , skip this step.
  10. Press the MEASUREMENT key, observe the Pass/Fail results.Two types of the power versus time graph view are available after the test set analyzes measurement data (see steps 8-9 of the General Procedure for details).
  11. After finishing the measurements:
    • Turn the measurement off by pressing the Measurement selection key, selecting Gated Power , then Close Measurement ( F4 ).

Related Topics

Gated Power Measurement Description


Measuring Handoff Waveform Quality

Measuring Handoff Waveform Quality

Last updated: October 28, 2004

The reverse channel of cdma2000 differs from IS-95's because there are multiple channels transmitted on the reverse link due to its new introduced radio configurations (radio configuration 3 and above). To measure IS-95 style waveform quality of the pilot signal (single-coded rho), there is one very short period of time, (during a handoff) when only the pilot channel is transmitting. This measurement can be used to perform the tests as described in the TIA/EIA-98-E standard.

We recommend to use the Agilent's multi-coded rho measurement to perform the tests as specified in TIA/EIA-98-E standard (see Measuring Waveform Quality/Code Domain Power ) since it offers the best measure of performance for cdma2000 systems while multiple code channels are active and restores the ability to test the whole signal.

General Procedure

  1. Establish a call with the mobile station with Radio Config set to (Fwd3, Rvs3) or above (see How Do I Set Up an IS-2000 Call? ).
  2. Press the Measurement selection key.
  3. Turn the knob to highlight the Handoff Waveform Quality measurement and press the knob.
  4. Press the Handoff Waveform Quality Setup ( F1 ) key to access the Handoff Waveform Quality Setup menu.
  5. Set the measurement parameters as needed for your measurement situation.
  6. Press the Close Menu ( F6 ) key.

  7. Press the START SINGLE key. A typical display is shown below.

Each waveform quality measurement returns a number of measurements which includes numeric rho. In addition to rho, it also provides the following measurements, calculated from the same data:

  • Time Error
  • Carrier Feedthrough
  • Phase Error
  • Magnitude Error

Related Topics

Handoff Waveform Quality Measurement Description


Measuring Maximum/Minimum Power

Measuring Maximum/Minimum Power

Last updated: June 20, 2006

  • General Procedure
  • Testing 4.4.5 Maximum RF Output Power and 4.4.6 Minimum Controlled Output Power

General Procedure

NOTE
Both Digital Average Power Calibration and Channel Power calibration should be performed if the test set is being used for the first time or the operating environment has changed significantly since the last calibration was performed. See Calibrating the Test Set for details.

  1. Connect the mobile station's antenna output to the test set's front panel RF IN / OUT connector and power it on.
  2. Press the blue SHIFT key and then the green Preset key to full reset the test set.
  3. Establish a call with the mobile station (see How Do I Set Up a Call? ).
  4. Initialize the measurement:
    • Press the Measurement selection key.
    • Turn the knob to highlight the Maximum/Minimum Power measurement and press the knob.
  5. Set up parameters for the Maximum/Minimum power measurement as needed for your test situation.
    • Select Maximum Power Setup ( F2 ) to access the Maximum Power Setup menu. From this menu, you can configure the parameters required for the mobile station's maximum power test.
    • Select Minimum Power Setup ( F3 ) to access the Minimum Power Setup menu. From this menu, you can configure the parameters required for the mobile station's minimum controlled power test.
    • Press the Close Menu ( F6 ) key to close the measurement setup menus.

      NOTE
      The test set will temporarily use these settings for the maximum/minimum power measurements. When the measurement is finished, the test set returns to its pre-measurement settings (including Cell Power, F-FCH/Traffic Level, Pilot Level, Receiver Power Control, Reverse Power Control mode, and Call Drop Timer) which are set from the Call Parms menu (see How Do I Change Call Parameters? ).

  6. Press the START SINGLE key to trigger each measurement.
    A typical measurement result is shown as below.
  7. After finishing the measurements:
    • If desired, turn the measurement off by pressing the Measurement selection key, selecting Maximum/Minimum Power , then Close Measurement ( F4 ).

Testing 4.4.5 Maximum RF Output Power and 4.4.6 Minimum Controlled Output Power

The maximum RF output power of the mobile station which is originally measured with Measuring Digital Average Power , and the minimum controlled output power which is originally measured with Measuring Channel Power , can be performed with a single measurement, Maximum/Minimum Power measurement. It provides an automated way of measuring both the maximum and minimum output power of a CDMA mobile station.

The following test procedure assumes that the mobile station supports Band Class 1 (US PCS). You should change the settings as specified for other configurations. Unless otherwise stated, leave all parameter settings to the defaults.

  1. Connect the mobile station's antenna output to the test set's front panel RF IN / OUT connector and power it on.
  2. Press the blue SHIFT key and then the green Preset key to full reset the test set.
  3. Establish a call with the following parameter settings (you need to change some settings as needed for your test situation).
    • Press CALL SETUP to access Call Parms and Call Control menus.
    • Set Cell Band ( F8 on the Call Parms 1 of 4 ) to US PCS .
    • Set Radio Config ( F11 on the Call Parms 1 of 4 ) to (Fwd1, Rvs1) .
    • Select FCH Service Option Setup ( F12 ) (Call Parms 1 of 4) , set Service Option for Fwd1, Rvs1 to SO2 (Loopback) .
    • Set Traffic Data Rate ( F12 on the Call Parms 2 of 4 ) to Full .
    • Press Originate Call ( F3 ) to initiate a call. Verify that the Connected is in the Active Cell status field.
  4. Initialize the measurement:
    • Press the Measurement selection key.
    • Turn the knob to highlight the Maximum/Minimum Power measurement and press the knob.
  5. Set up parameters for the Maximum/Minimum power measurement. This step is optional since the test set has set the parameter default values (see step 5 of General Procedure ) to what are specified in the standard for 4.4.5 Maximum RF Output Power and 4.4.6 Minimum Controlled Output Power tests. Also a firmware routine programmed into the test set, provides an automated way of sending continuous '0' power control bits (All Up bits) during the maximum power measurement and sending continuous '1' power control bits (All Down bits) during the minimum power measurement (see Maximum/Minimum Power Measurement Parameters for details).
  6. Press the START SINGLE key to trigger the measurement.
    A typical measurement result is shown as below.
  7. If the measurement integrity indicator shows Under Range, it indicates that the mobile station output power is below -61 dBm or is less than -9 dB below or the expected power level of the receiver. To get the correct result, we recommend you manually control the test set's receiver and then observe the measurement results.
    • In step 5 of General Procedure , go to Minimum Power Setup menu. Set the Min Power Meas Receiver Power Control to Manual and set the Min Power Meas Power Receiver Power to -61 dBm (or as needed).
    • Press the Close Menu ( F6 ) key.
    • Press START SINGLE key. Observe the measurement results.
  8. After finishing the measurements:
    • If desired, turn the measurement off. Press the Measurement selection key, highlight Maximum/Minimum Power , then press Close Measurement ( F4 ).

Related Topics

Maximum/Minimum Power Measurement Description

Programming a Maximum/Minimum Power Measurement

Maximum/Minimum Power Measurement Troubleshooting

Measuring Channel Power

Measuring Digital Average Power


Measuring a Multi-tone Digital Audio

Measuring a Multi-tone Digital Audio

Last updated: June 20, 2006

There are two measurement modes for multi-tone audio measurement (see Multi-Tone Audio Measurement Description for details):

  • Downlink Audio measurement mode is used to test the analog signals presented at the AUDIO IN port of the test set so that the connectivity and performance of the analog signal handling components of the mobile station (such as speaker, decoder, etc.) can be verified. See General Procedure for Downlink Measurement for the example procedure.
  • Uplink Audio measurement mode is used to test the analog signals by decoding the speech frames received from the R-Traffic/R-FCH channel over the RF link so that the connectivity and performance of the analog signal handling components of the mobile station (such as microphone, encoder, etc.) can be verified. See General Procedure for Uplink Measurement for the example procedure.

General Procedure for Downlink Measurement

The procedure for downlink measurement mode assumes that the mobile station's antenna output is connected to the test set's front-panel RF IN/OUT connector, the analog audio from the mobile station's speaker is fed back to the test set's AUDIO IN port, and the mobile station supports SO17 service option.

A. Establish a voice call with the mobile station.

  1. Follow the procedures as described in How Do I Set Up an IS-2000 Call? to establish a voice call (with the service option set to SO17 in this example).

B. Set up the Voice SO Mode required for the downlink measurement.

  1. On the Call Parms 3 of 4 menu, press the Voice SO Mode ( F11 ) Key.
  2. Turn the knob to highlight the Multi-Tone and then press the knob.

C. Make the downlink measurement.

  1. Press the Measurement selection key.
  2. Turn the knob to highlight the Multi-tone Audio measurement and press the knob.
  3. Set up audio generator parameters for downlink test.
    • Press the F2 ( Multi-Tone Audio Generator Parms ) to access the MTA Generator menus.
    • Press the F1 ( Downlink Frequencies ). Set the Preset Frequencies To to Narrow in this example. You can change the setting as required for your test situation.
    • Press the F3 ( Downlink Levels ). Set the Multi-Tone Audio Total Level to 30% in this example. You can change the setting as required for your test situation.
    • Press the F6 ( Close Menu ).
    • Press the F6 ( Return ).
  4. Set up audio analyzer parameters for downlink test.
    • Press the F3 ( Multi-Tone Audio Analyzer Parms ).
    • Press the F2 ( MTAudio Analyzer Frequencies ). Set the Use Multi-Tone Audio Generator Frequencies to On .
    • Press the F6 ( Close Menu ).
    • Press the F6 ( Return ).
  5. Press the F1 ( Multi-tone Audio Setup ) to access the Multi-Tone Audio Setup menu. Use the knob and DATA ENTRY keys to set the measurement parameters as needed for your test situation. In this example,
    • Set the Multi-Measurement Count to 10 .
    • Set the Measurement Mode to Downlink Audio .
    • Set the Analyzer 0dB Reference Mode to Absolute .
    • Set the Analyzer Downlink Reference Level to 150 mV .
    • Set the Expected Audio In Peak Voltage to 1 V .
    • Set the Trigger Arm to Single .
    • Leave all other settings to the default values.
    • Press the F6 ( Close Menu ).

      NOTE
      If the Trigger Arm is set to Continuous the measurement began executing as soon as you initialize the measurement. If single is selected in the Trigger Arm field, you need to press the START SINGLE to trigger each measurement.

  6. Press the START SINGLE key to begin the measurement. A typical displays are shown below.

    NOTE
    If the measurement integrity field displays "Over Range", it indicates that the measured audio signal at AUDIO IN port is far above the expected input power. You should increase the Expected Audio In Peak Voltage setting. If the measurement integrity field displays "Under Range", it indicates that the measured audio signal at AUDIO IN port is far below the expected input power. You should decrease the Expected Audio In Peak Voltage setting. You can adjust the Expected Audio In Peak Voltage setting based on the value of Total Meas Audio Level which is shown in the Multi-Tone Audio Information table below the graph display.

    If the bar graph is too short or too high, decrease/increase the Analyzer Reference Level to adjust the height of the bars.

  7. If required, adjust the upper and lower level limits for each of the tones (the limits will be shown as green lines on the measurement results screen).
    • Press the F4 ( Multi-Tone Audio Level Limits ) to access the Multi-Tone Audio Level Limits menu.
    • Use the knob and the DATA ENTRY keys to set the limit levels for the selected tones. For example, set the Audio Tone 1 Level Lower Limit to -20 dB and set the Audio Tone 2 Level Lower Limit to 0 dB .
    • After the settings, press the F6 ( Close Menu ).
    • Press the START SINGLE key to begin the measurement. A typical displays are shown below.
      If any tone is outside of its upper and lower limit lines, the corresponding bar will be displayed in red. If the tone is within its upper and lower limit lines, the corresponding bar will be displayed in yellow.
  8. If required, adjust the graphic view.
    • Press the F6 ( Graph Control ).
    • Set the Marker Position ( F1 ) to the desired tone (for example, tone 2). The frequency/level settings for that tone, as well as the measured level are then displayed at the top of the graph.
    • The x-axis on the graphical display is labeled with the bar numbers 1 to 20 corresponding to the audio tones 1 to 20. The y-axis on the graphical display is scaled as 10 divisions (4dB/div) and defaults to be ranged from -30 dB to 10 dB. You can view the levels of particular interest such as above +10 dB or below -30 dB by adjusting the scale with the Graph Reference ( F2 ) and Span ( F3 ) softkeys.
    • After the settings, press the F6 (Return).
  9. If desired, turn the measurement off after finishing the measurements. Press the Measurement selection key, then select Close Measurement ( F4 ).

General Procedure for Uplink Measurement

The example procedure for the uplink measurement mode assumes that the analog audio sent from AUDIO OUT port of the test set's front-panel is fed to the mobile phone's microphone, the mobile station's antenna output is connected to the test set's front-panel RF IN/OUT connector, and the mobile station supports SO17 service option.

A. Establish a voice call with the mobile station.

  1. Follow the procedures as described in How Do I Set Up an IS-2000 Call? to establish a voice call (with the service option set to SO17 in this example).

B. Set up the Voice SO Mode required for the uplink measurement.

  1. On the Call Parms 3 of 4 menu, press the Voice SO Mode ( F11 ) Key.
  2. Turn the knob to highlight the Null Frames and then press the knob.

C. Make the uplink measurement.

  1. Press the Measurement selection key.
  2. Turn the knob to highlight the Multi-tone Audio measurement and press the knob.
  3. Press the F2 ( Multi-Tone Audio Generator Parms ) to access the MTA Generator menus.
    • Press the F2 ( Uplink Frequencies ). Set the Preset Frequencies To to Narrow in this example. You can change the setting as required for your test situation.
    • Press the F4 ( Uplink Levels ). Set the Multi-Tone Audio Total Level to 1.0 V in this example. You can change the setting as required for your test situation.
    • Press the F6 ( Close Menu ).
    • Press the F6 ( Return ).
  4. Set up audio analyzer parameters for uplink test.
    • Press the F3 ( Multi-Tone Audio Analyzer Parms ).
    • Press the F2 ( MTAudio Analyzer Frequencies ). Set the Use Multi-Tone Audio Generator Frequencies to On .
    • Press the F6 ( Close Menu ).
    • Press the F6 ( Return ).
  5. Press the F1 ( Multi-tone Audio Setup ) to access the Multi-Tone Audio Setup menu. Use the knob and DATA ENTRY keys to set the measurement parameters as needed for your test situation. In this example,
    • Set the Multi-Measurement Count to 10 .
    • Set the Measurement Mode to Uplink Audio .
    • Set the Analyzer 0dB Reference Mode to Absolute .
    • Set the Analyzer Uplink Reference Level to 50% .
    • Set the Trigger Arm to Single .
    • Leave all other settings to the default values.
    • Press the F6 ( Close Menu ).

      NOTE
      If the Trigger Arm is set to Continuous the measurement began executing as soon as you initialize the measurement. If single is selected in the Trigger Arm field, you need to press the START SINGLE to trigger each measurement.

  6. Press the START SINGLE key to begin the measurement. A typical displays are shown below.

    NOTE
    If the bar is too short or too high, decrease/increase the Analyzer Uplink Reference Level setting to adjust the height of the bars to your desired view.

  7. If required, adjust the upper and lower level limits for each of the tones (the limits will be shown as green lines on the measurement results screen)
    • Press the F4 ( Multi-Tone Audio Level Limits ) to access the Multi-Tone Audio Level Limits menu.
    • Use the knob and the DATA ENTRY keys to set the limit levels for the selected tones. For example, set the Audio Tone 1 Level Upper Limit to 0 dB and the Audio Tone 1 Level Lower Limit to -10 dB , set the Audio Tone 2 Level Upper Limit to 0 dB and the Audio Tone 2 Level Lower Limit to -20 dB .
    • After the settings, press the F6 ( Close Menu ).
    • Press the START SINGLE key to begin the measurement. A typical displays are shown below.
  8. If required, adjust the graphic view.
    • Press the F6 ( Graph Control ).
    • Set the Marker Position ( F1 ) to the desired tone (for example, tone 2). The frequency/level settings for that tone, as well as the measured level are then displayed at the top of the graph.
    • The x-axis on the graphical display is labeled with the bar numbers 1 to 20 corresponding to the audio tones 1 to 20. The y-axis on the graphical display is scaled as 10 divisions (4dB/div) and defaults to be ranged from -30 dB to 10 dB. You can view the levels of particular interest such as above +10 dB or below -30 dB by adjusting the scale with the Graph Reference ( F2 ) and Span ( F3 ) softkeys.
    • After the settings, press the F6 (Return).
  9. If desired, turn the measurement off after finishing the measurements. Press the Measurement selection key, then select Close Measurement ( F4 ).

Related Topics

Multi-Tone Audio Measurement Description


How Do I Change the Measurement Setup?

How Do I Change the Measurement Setup?

Last updated: October 28, 2004

A. Select a measurement.

  1. Press the Measurement selection key.
  2. Highlight a measurement to set up and press the knob.

B. Set up the measurement.

  1. Press the MEASUREMENT key.
  2. Press the Control ( F1 ) key to display the measurement's setup menu.
  3. Highlight a parameter and press the knob.

  4. Enter a value or selection and press the knob.

    NOTE
    For statistical measurement results, highlight the Multi-Measurement Count parameter and press the ON key. The number of averages will default to 10.

  5. Press the Close Menu ( F6 ) key.


Measuring Signaling Tone

Measuring Signaling Tone

Last updated: June 20, 2006

The performance test standard of signaling tone is defined in the section 3.3.5 of TIA/EIA-690 standard.

Testing 3.3.5 Signaling Tone

The following procedure demonstrates how to measure the signaling tone.

  1. Connect the mobile station's antenna output to the test set's front panel RF IN/OUT connector and power them on.
  2. Press the blue SHIFT key and then the green Preset key to full reset the test set.
  3. Establish a call with the mobile station (see How Do I Set Up an AMPS Call? ).
  4. Initialize the measurement:
    • Press the Measurement selection key.
    • Turn the knob to highlight the Signaling Tone measurement and press the knob.
  5. Press the Signaling Tone Setup ( F1 ) key to access the Signaling Tone Setup menu.
  6. Set the measurement parameters as needed for your measurement situation by using the knob and DATA ENTRY keys. Press the Close Menu ( F6 ) key to close the Setup window.

    NOTE
    For statistical measurement results, highlight the Multi-Measurement Count parameter and press the ON key or enter the number of the measurements. The number of averages is default to 10.

    NOTE
    If single is selected in the Trigger Arm field, press the START SINGLE key to trigger each measurement. If the Trigger Arm is set to Continuous then the measurement began executing as soon as you initialized the measurement in step 4.

  7. Press the Send Maintenance Order Message ( F11 ) key or press the Send Alert Order Message ( F12 ) key. The test set sends the maintenance order message or alert order message to the mobile station to turn on the signaling tone of the mobile station. The status of Active Cell in the bottom cell of screen is changed from Connected to Alerting.
  8. A typical display for single measurement is shown below.
  9. After finishing the measurements:
    • If desired, turn the measurement off by pressing the Measurement selection key, selecting Signaling Tone , then Close Measurement ( F6 ) .

Related Topics

Signaling Tone Measurement Description


Measuring TDSO (Test Data Service Option) Frame Error Rate (FER)

Measuring TDSO (Test Data Service Option) Frame Error Rate (FER)

Last updated: October 28, 2004

  • General Procedure
  • Testing 3.4.1 Demodulation of Forward Traffic Channel in AWGN (only for forward supplemental channel test)

General Procedure

  1. Connect the mobile station's antenna output to the test set's front panel RF IN/OUT connector and power them on.
  2. Press the blue SHIFT key and then the green Preset key to full reset the test set.
  3. Establish a call with the mobile station with the following settings (see How Do I Set Up a Call? ).
    • Press the Radio Config ( F11 ) key and select the radio configuration: (Fwd3, Rvs3) , or above.
    • Press the FCH Service Option Setup ( F12 ), select the service option for the selected radio configuration: SO32 (+F-SCH) or SO32 (+ SCH) , then press the Close Menu ( F6 ) key.
  4. Initialize the measurement:
    • Press the Measurement selection key.
    • Turn the knob to highlight the TDSO Frame Error Rate measurement and press the knob.
  5. Press AWGN Power ( F3 ), use the knob and DATA ENTRY keys to enter -54 dBm/1.23 MHz , or as needed.
  6. Press the TDSO FER Setup ( F1 ) key to access the TDSO FER Setup menu.
  7. Use the knob and DATA ENTRY keys to set the measurement parameters as needed for your measurement situation. Press the Close Menu ( F6 ) key to close the settings.

    NOTE
    If single is selected in the Trigger Arm field, press the START SINGLE key to trigger each measurement. If the Trigger Arm is set to Continuous the measurement began executing as soon as you initialize the measurement in step 4.

  8. A typical display is shown below.

Testing 3.4.1 Demodulation of Forward Traffic Channel in AWGN

The following test procedure assumes that the mobile station supports Band Class 1 (US PCS) and only demonstrates the Test 82. You should change the settings as specified for other tests. Unless otherwise stated, leave all parameter settings to the defaults.

NOTE
The TDSO FER measurement is used for testing the forward supplemental channel . You can use FER measurement to perform the tests for forward fundamental channel . See Measuring Frame Error Rate (FER) .

  1. Connect the mobile station's antenna output to the test set's front panel RF IN/OUT connector and power them on.
  2. Press the blue SHIFT key and then the green Preset key to full reset the test set.
  3. Establish a call with the following parameter settings (some settings may change as specified for each test).
    • Press CALL SETUP to access Call Parms and Call Control menus.
    • Set Cell Band ( F8 on the Call Parms 1 of 3 ) to US PCS .
    • Set Radio Config ( F11 on the Call Parms 1 of 3 ) to (Fw3, Rvs3) .
    • Select FCH Service Option Setup ( F12 ) (Call Parms 1 of 3) , set Service Option for Fw3, Rvs 3 to SO32 (+ F-SCH) .
    • Set Cell Power (Î or ) to -55 dBm/1.23 MHz ( F7 on the Call Parms 1 of 3 ).
    • Set F-SCH Data Rate to 19.2 kbps (see How Do I Change TDSO Supplemental Channel Information? )
    • Press Originate Call ( F3 ) to initiate a call. Verify that the Connected + Data is in the Active Cell status field.
  4. Press the Measurement selection key, select the Frame Error Rate measurement.
  5. Press F3, set AWGN Power (I oc ) to -54 dBm/1.23 MHz .
  6. Press F1 to access the TDSO FER Setup menu (some settings may change as specified for each test).
    • Set FER Requirement to 1.00%.
    • Set F-FCH/Traffic Level to -7.00 dB.
    • Set F-SCH Level to -13.6 dB.
    • Set Trigger Arm to Single.
    • Press Close Menu ( F6 ).
  7. Press the START SINGLE key to begin the measurement.

    NOTE
    If single is selected in the Trigger Arm field, press the START SINGLE key to trigger each measurement. If the Trigger Arm is set to Continuous the measurement began executing as soon as you initialize the measurement in step 4.

  8. A typical display is shown below.
  9. Repeat the steps 3-8 with the settings as specified for each test.

Related Topics

TDSO Frame Error Rate Measurement Description

Programming a TDSO Frame Error Rate Measurement

TDSO Frame Error Rate Troubleshooting


Measuring Time Response of Open Loop Power Control (TROLPC)

Measuring Time Response of Open Loop Power Control (TROLPC)

Last updated: October 28, 2004

  • General Procedure
  • Testing 4.4.2 Time Response of Open Loop Power Control

General Procedure

NOTE
Channel power calibration should be performed if the test set is being used for the first time or the operating environment has changed significantly since the last calibration was performed. The channel power calibration also calibrates the access probe power measurement. See Calibrating the Test Set for details.

  1. Connect the mobile station's antenna output to the test set's front panel RF IN/OUT connector and power them on.
  2. Press the blue SHIFT key and then the green Preset key to full reset the test set.
  3. Establish a call with the mobile station with a loopback service option (SO2, SO9, or SO55) and full data rated selected (see How Do I Set Up a Call? ).
  4. Initialize the measurement:
    • Press the Measurement selection key.
    • Turn the knob to highlight the Time Response of Open Loop Power Control measurement and press the knob.

      NOTE
      If any measurements are open during initiation of a TROLPC, the test set will automatically close them and display an error message indicating the last measurement that was closed.

  5. Press the Time Response of OLPC Setup ( F1 ) key to access the Time Response of OLPC Setup menu.
  6. Set the measurement parameters as needed for your measurement situation by using the knob and DATA ENTRY keys. Press the Close Menu ( F6 ) key to close the Setup window.
  7. Measuring TROLPC:
    • Select Start Meas Up ( F2 ), which automatically increases Cell Power by 20 dB and captures the resulting mobile station output power for 100 ms, or
    • Select Start Meas Down ( F3 ) which automatically decreases Cell Power by 20 dB and captures the resulting mobile station output power for 100 ms.
    • You may also select START SINGLE to start the measurement. The cell power will increase by 20 dB if Start Meas Up ( F2 ) was last performed (or if the test set is in a preset state), or decrease by 20 dB if Start Meas Down ( F3 ) was last performed.
    • Select Marker ( F4 ) and turn the knob to display power at points along the mobile station output power trace. If the test failed, next to the word "Fail," the first data point at which the test failed is displayed.

    NOTE
    As specified by TIA/EIA 98-E test standards, mobile station power level change is expressed in absolute terms. The delta expressions above the display indicate the direction of power changes.

  8. After finishing the measurements:
    • If desired, turn the measurement off by pressing the Measurement selection key, selecting Time Response of Open Loop Power Control , then Close Measurement ( F4 ).

Testing 4.4.2 Time Response of Open Loop Power Control

Definition: Following a step change in the mean input power, the mean output power of the mobile station changes as a result of the open loop power control. This test measures the open loop power control time response to a step change in the mean input power.

The following test procedure assumes that the mobile station supports Band Class 1 (US PCS) and only demonstrates the Test 1. You should change the settings as specified for other tests. Unless otherwise stated, leave all parameter settings to the defaults.

  1. Connect the mobile station's antenna output to the test set's front panel RF IN/OUT connector and power them on.
  2. Press the blue SHIFT and then the green Preset key to full reset the test set.
  3. Establish a call with the following parameter settings (some settings may change as specified for each test).
    • Press CALL SETUP to access Call Parms and Call Control menus.
    • Set Cell Band ( F8 on the Call Parms 1 of 3 ) to US PCS .
    • Set Radio Config ( F11 on the Call Parms 1 of 3 ) to (Fwd1, Rvs1) .
    • Select FCH Service Option Setup ( F12 ) (Call Parms 1 of 3) , set Service Option for Fwd1, Rvs1 to SO2 (Loopback) .
    • Set Traffic Data Rate ( F12 on the Call Parms 2 of 3 ) to Full .
    • Press Originate Call ( F3 ) to initiate a call. Verify that the Connected is in the Active Cell status field.
  4. Set Cell Power (Î or ) to -60 dBm/1.23 MHz ( F7 on the Call Parms 1 of 3 ).
  5. Set Rvs Power Ctrl to Alternating bits ( F7 on the Call Parms 2 of 3 menu) to send alternating '0' and '1' power control bits on the Forward Traffic Channel.
  6. Press the Measurement selection key and select the Time Response of Open Loop Power Control measurement.
  7. Press the Time Response of OLPC Setup ( F1 ) key to access the Time Response of OLPC Setup menu.
    • Set F-FCH/Traffic Level to -7.4 dB.
    • Press Close Menu ( F6 ).
  8. Measure the TROLPC and observe the Pass/Fail result:
    • Select Start Meas Up ( F2 ) which automatically increases Cell Power by 20 dB and captures the resulting mobile station output power for 100 ms, observe that the cell power transitions to -40 dBm/1.23 MHz and note the pass/fail result.
    • Select Start Meas Down ( F3 ) which automatically decreases Cell Power by 20 dB and captures the resulting mobile station output power for 100 ms, observe that the cell power transitions to -60 dBm/1.23 MHz and note the pass/fail result.
    • Select Start Meas Down ( F3 ) which automatically decreases Cell Power by 20 dB and captures the resulting mobile station output power for 100 ms, observe that the cell power transitions to -80 dBm/1.23 MHz and note the pass/fail result.
    • Select Start Meas Up ( F2 ) which automatically increases Cell Power by 20 dB and captures the resulting mobile station output power for 100 ms, observe that the cell power transitions to -60 dBm/1.23 MHz), and note the pass/fail result.
  9. After finishing the measurements:
    • If desired, turn the measurement off by pressing the Measurement selection key, selecting Time Response of Open Loop Power Control , then Close Measurement ( F4 ).

Related Topics

Time Response of Open Loop Power Control (TROLPC) Measurement Description


Measuring Wideband Data Deviation

Measuring Wideband Data Deviation

Last updated: June 20, 2006

The performance test standard of wideband data deviation is defined in the section 3.3.3 of TIA/EIA-690 standard.

Testing 3.3.3 Wideband Data

The following procedure demonstrates how to measure the wideband data.

  1. Connect the mobile station's antenna output to the test set's front panel RF IN/OUT connector and power them on.
  2. Press the blue SHIFT key and then the green Preset key to full reset the test set.
  3. Establish a call with the mobile station with (see How Do I Set Up an AMPS Call? ).
  4. Initialize the measurement:
    • Press the Measurement selection key.
    • Turn the knob to highlight the Wideband Data Deviation measurement and press the knob.
  5. Press the Wideband Data Deviation Setup ( F1 ) key to access the Wideband Data Deviation Setup menu.
  6. Set the measurement parameters as needed for your measurement situation by using the knob and DATA ENTRY keys. Press the Close Menu ( F6 ) key to close the settings.

    NOTE
    If single is selected in the Trigger Arm field, press the START SINGLE key to trigger each measurement. If the Trigger Arm is set to Continuous the measurement began to execute as soon as you initialize the measurement in step 4.

  7. Press the Anl MS TX Level ( F10 ) key to change the default value of Analogue MS TX Level, then the test set sends Analog MS TX Level Order message to the mobile station.

    NOTE
    If single is selected in the Trigger Arm field, you should change the value of Analogue MS TX Level quickly after pressing the START SINGLE key so that the test set captures the whole wideband data burst during the gate time period. Or you increase the value of gate time so that you have enough time to finish the following actions. If only part of wideband data burst is detected during the gate time, the data burst is not reported and is treated as if it was not detected. If the Trigger Arm is set to Continuous then the measurement began executing as soon as you initialized the measurement in step 4.

  8. A typical display is shown below.
  9. After finishing the measurements:
    • If desired, turn the measurement off by pressing the Measurement selection key, selecting Wideband Data Deviation , then Close Measurement ( F6 ).

Related Topics

Wideband Data Deviation Measurement Description


Measuring Waveform Quality/Code Domain Power

Measuring Waveform Quality/Code Domain Power

Last updated: October 28, 2004

  • General Procedure for Measuring Waveform Quality
  • General Procedure for Measuring Code Domain Power and Code Domain Power + Noise
  • Testing 4.1 Frequency Accuracy
  • Testing 4.3.1 Time Reference
  • Testing 4.3.4 Waveform Quality and Frequency Accuracy
  • Testing 4.3.5 Code Domain Power
  • Testing 4.4.9 Code Channel to Reverse Pilot Output Power Accuracy

NOTE
Channel Power Calibration should be performed if the test set is being used for the first time or the operating environment has changed significantly since the last calibration was performed. The channel power calibration also calibrates the Waveform Quality/Code Domain Power measurement. See Calibrating the Test Set for details.

General Procedure for Measuring Waveform Quality

  1. Connect the mobile station's antenna output to the test set's front panel RF IN/OUT connector and power them on.
  2. Press the blue SHIFT key and then the green Preset key to full reset the test set.
  3. Establish a call with the mobile station (see How Do I Set Up a Call? ).
  4. Initialize the measurement:
    • Press the Measurement selection key.
    • Turn the knob to highlight the Waveform Quality + Code Domain measurement and press the knob.
  5. Press the Waveform Quality Setup ( F1 ) key to access the Waveform Quality Setup menu.
  6. Set the measurement parameters as needed for your measurement situation by using the knob and DATA ENTRY keys. Press the Close Menu ( F6 ) key to close the Setup window.

    NOTE
    For statistical measurement results, highlight the Multi-Measurement Count parameter and press the ON key or directly enter the number of the measurements. The number of averages will default to 10.

    NOTE
    If single is selected in the Trigger Arm field, press the START SINGLE key to trigger each measurement. If the Trigger Arm is set to Continuous the measurement began executing as soon as you initialize the measurement in step 4.

  7. A typical display for the Waveform Quality measurement results is shown below.
  8. There are graphical measurement results available as a result of performing this measurement if the call is established with radio configuration (Fwd3, Rvs3) or above. Continue to perform the steps 4-8 in the following section General Procedure for Measuring Code Domain Power and Code Domain Power + Noise

General Procedure for Measuring Code Domain Power and Code Domain Power + Noise

NOTE
These measurements can be made only when the call is established with the radio configuration (Fwd3, Rvs3), or above selected.

  1. Establish a call with the mobile station with Radio Configuration ((Fwd3, Rvs3), or above) selected. (see How Do I Set Up an IS-2000 Call? ).
  2. Press the Measurement selection key.
  3. Turn the knob to highlight the Waveform Quality + Code Domain measurement and press the knob.
  4. Press the Code Domain Power ( F3 ) key. A typical display is shown below.
  5. Press the Graph Control key ( F6 ). Change the value in the Limit field. Note that both green lines, indicating the I and Q channel noise limits, move together.
  6. Press the Return key ( F6 ).
  7. Press the Code Domain Power + Noise ( F4 ) key. A typical display is shown below.
  8. Return to the numeric Rho display at any time by pressing the Numeric Rho key ( F2 ).
  9. After finishing the measurements:
    • If desired, turn the measurement off by pressing the Measurement selection key, selecting Waveform Quality + Code Domain , then Close Measurement ( F4 ).

Testing 4.1 Frequency Accuracy

Definition: Frequency accuracy is the ability of a mobile station transmitter to transmit at an assigned carrier frequency.

You can use the Testing 4.3.4 Waveform Quality and Frequency Accuracy to perform this test.

Testing 4.3.1 Time Reference

Definition: This test checks the accuracy of the mobile station time reference in static conditions as well as the mobile station time reference slew rate in dynamic conditions.

You can use the Testing 4.3.4 Waveform Quality and Frequency Accuracy to test the accuracy of the mobile station time reference in static conditions. But testing the mobile station time reference slew rate in dynamic conditions requires an external channel simulator.

Testing 4.3.4 Waveform Quality and Frequency Accuracy

Definition: The waveform quality factor, rho, is measured in this test. This test also encompasses the 4.1 Frequency Accuracy and 4.3.1 Time Reference (static only) tests.

The Waveform Quality measurement provided by the test set measures multi-coded waveform quality. It is much useful than the single-coded waveform quality as specified in standard. We recommend you use this measurement to perform the test. If you do want to perform the single-coded waveform quality, use the Handoff Waveform Quality measurement (see Handoff Waveform Quality Measurement Description ).

The following test procedure assumes that the mobile station supports Band Class 1 (US PCS). You should change the settings as specified for other configurations. Unless otherwise stated, leave all parameter settings to the defaults.

NOTE
This test measures rho, and also encompasses the 4.1 Frequency Accuracy and 4.3.1 Time Reference tests. You need change some settings as specified for the tests.

  1. Connect the mobile station's antenna output to the test set's front panel RF IN/OUT connector and power them on.
  2. Press the blue SHIFT key and then the green Preset key to full reset the test set.
  3. Establish a call with the following parameter settings (some settings may change as specified for each test).
    • Press CALL SETUP to access Call Parms and Call Control menus.
    • Set Cell Band ( F8 on the Call Parms 1 of 3 ) to US PCS .
    • Set Radio Config ( F11 on the Call Parms 1 of 3 ) to (Fwd3, Rvs3) .
    • Select FCH Service Option Setup ( F12 ) (Call Parms 1 of 3) , set Service Option for Fwd3, Rvs3 to SO2 .
    • Press Originate Call ( F3 ) to initiate a call. Verify that the Connected is in the Active Cell status field.
  4. Set Cell Power (Î or ) to -101 dBm/1.23 MHz ( F7 on the Call Parms 1 of 3 ).
  5. Set the F-Pilot Level to -7.00 dB, and set the F-FCH/Traffic Level to -7.4 dB (see How Do I Change Generator Information? ).
  7. Set Rvs Power Ctrl to Alternating bits ( F7 on the Call Parms 2 of 3 menu) to transmit alternating '0' and '1' power control bits on the Forward Traffic Channel.
  8. Press the Measurement selection key, select the Waveform Quality + Code Domain measurement.
  9. Press the Waveform Quality Setup ( F1 ) key to access the Waveform Quality Setup menu .
    • Set Trigger Arm to Single.
    • Press Close Menu ( F6 ).
  10. Press the START SINGLE key to begin the measurement.

    NOTE
    If the Trigger Arm is set to Continuous the measurement began executing as soon as you initialize the measurement in step 4. If single is selected in the Trigger Arm field, press the START SINGLE key to trigger each measurement.

  11. A typical display is shown below.
  12. After finishing the measurements:
    • If desired, turn the measurement off by pressing the Measurement selection key, selecting Waveform Quality + Code Domain , then Close Measurement ( F4 ).

Testing 4.3.5 Code Domain Power

Definition: Code domain power is the power in each code channel of a CDMA Channel. The CDMA time reference used in the code domain power test is derived from the Pilot Channel and is used as the reference for demodulation of all other code channels.

The following test procedure assumes that the mobile station supports Band Class 1 (US PCS). Unless otherwise stated, leave all parameter settings to the defaults.

NOTE
This test can be made only when the call is established with radio configuration ((Fwd3, Rvs3), or above) selected.

  1. Connect the mobile station's antenna output to the test set's front panel RF IN/OUT connector and power them on.
  2. Press the blue SHIFT key and then the green Preset key to full reset the test set.
  3. Establish a call with the following parameter settings (some settings may change as specified for each test).
    • Press CALL SETUP to access Call Parms and Call Control menus.
    • Set Cell Band ( F8 on the Call Parms 1 of 3 ) to US PCS .
    • Set Radio Config ( F11 on the Call Parms 1 of 3 ) to (Fwd3, Rvs3) .
    • Select FCH Service Option Setup ( F12 ) (Call Parms 1 of 3) , set Service Option for Fwd3, Rvs3 to SO2 .
    • Press Originate Call ( F3 ) to initiate a call. Verify that the Connected is in the Active Cell status field.
  4. Set Cell Power (Î or ) to -101 dBm/1.23 MHz ( F7 on the Call Parms 1 of 3 ).
  5. Set the F-Pilot Level to -7.00 dB, and set the F-FCH/Traffic Level to -7.4 dB (see How Do I Change Generator Information? ).
  6. Press the Measurement selection key, select the Waveform Quality + Code Domain measurement.
  7. Press the Waveform Quality Setup ( F1 ) key to access the Waveform Quality Setup menu .
    • Set Trigger Arm to Single.
    • Press Close Menu ( F6 ).
  8. Press the START SINGLE key to begin the measurement.

    NOTE
    If the Trigger Arm is set to Continuous the measurement began executing as soon as you initialize the measurement in step 4. If single is selected in the Trigger Arm field, press the START SINGLE key to trigger each measurement.

  9. Press the Numeric Rho ( F2 ) key, a typical display for numeric rho is shown below.
  10. Press the Code Domain Power ( F3 ) key, a typical graphic display is shown below and note the Pass/Fail result (see General Procedure for Measuring Code Domain Power and Code Domain Power + Noise for details).
  11. After finishing the measurements:
    • If desired, turn the measurement off by pressing the Measurement selection key, selecting Waveform Quality + Code Domain , then Close Measurement ( F4 ).

Testing 4.4.9 Code Channel to Reverse Pilot Output Power Accuracy

Definition: Code channel to Reverse Pilot Channel output power accuracy is the permissible error in mobile station mean output power between each of the radiated code channels and the Reverse Pilot Channel during steady state operation.

The test set does not support the Enhanced Access Channel test (as specified in 4.4.9.2.1). The following procedure is for the Code Channel Output Power for the Reverse Traffic Channel test (as specified in 4.4.9.2.2).

The test shall be performed for mobile stations that support the Reverse Pilot Channel. It assumes that the mobile station supports Band Class 1 (US PCS) and operation on the Reverse Fundamental Channel. You should change the settings as specified for other configurations. Unless otherwise stated, leave all parameter settings to the defaults.

NOTE
This test can be made only when the call is established with radio configuration ((Fwd3, Rvs3), or above) selected.

  1. Connect the mobile station's antenna output to the test set's front panel RF IN/OUT connector and power them on.
  2. Press the blue SHIFT key and then the green Preset key to full reset the test set.
  3. Establish a call with the following parameter settings (some settings may change as specified for each test).
    • Press CALL SETUP to access Call Parms and Call Control menus.
    • Set Cell Band ( F8 on the Call Parms 1 of 3 ) to US PCS .
    • Set Radio Config ( F11 on the Call Parms 1 of 3 ) to (Fwd3, Rvs3) .
    • Select FCH Service Option Setup ( F12 ) (Call Parms 1 of 3) , set Service Option for Fwd3, Rvs 3 to SO2 .
    • Set Traffic Data Rate ( F12 on the Call Parms 2 of 3 ) to Full .
    • Press Originate Call ( F3 ) to initiate a call. Verify that the Connected is in the Active Cell status field.
  4. Set Cell Power (Î or ) to -75 dBm/1.23 MHz ( F7 on the Call Parms 1 of 3 ).
  5. Set the F-Pilot Level to -7.00 dB, and set the F-FCH/Traffic Level to -7.4 dB (see How Do I Change Generator Information? ).
  7. Set Rvs Power Ctrl to Alternating bits ( F7 on the Call Parms 2 of 3 menu) to transmit alternating '0' and '1' power control bits on the Forward Traffic Channel.
  8. Press the Measurement selection key, select the Waveform Quality + Code Domain measurement.
  9. Press the Waveform Quality Setup ( F1 ) key to access the Waveform Quality Setup menu .
    • Set Trigger Arm to Single.
    • Press Close Menu ( F6 ).
  10. Press the START SINGLE key to begin the measurement.

    NOTE
    If the Trigger Arm is set to Continuous the measurement began executing as soon as you initialize the measurement in step 4. If single is selected in the Trigger Arm field, press the START SINGLE key to trigger each measurement.

  11. Press the Code Domain Power ( F3 ) key, observe the measurement results and note the Pass/Fail result (see General Procedure for Measuring Code Domain Power and Code Domain Power + Noise for details).
  12. After finishing the measurements:
    • If desired, turn the measurement off by pressing the Measurement selection key, selecting Waveform Quality + Code Domain , then Close Measurement ( F4 ).

Related Topics

Waveform Quality/Code Domain Measurement Description


How Do I Perform MEID Verification?

How Do I Perform MEID Verification?

Last updated: June 20, 2006

In the Active Cell operating mode and IS-2000 system, the test set supports to test the MEID-equipped mobile stations (MS). This example is to verify that an MEID-equipped MS can:

  • correctly tell the test set that it supports MEID (via Registration Message with MEID support indicator set to 1 in the Station Class Mask (SCM) field).
  • successfully respond to an MEID information request from an MEID-enabled test set. (Setting the MEID Support to on will enable the test set to support MEID. The test set will sends the Status Request Message to retrieve the MEID value from the MEID-equipped MS.)
  • successfully establish a call with an MEID-enabled test set using the public long code mask (PLCM) determined by the specified PLCM Type .
  • successfully perform an implicit handoff by changing the PLCM Type .
  • successfully establish a call with an MEID-disabled test set using the public long code mask (PLCM) derived from the pseudo-ESN. (Setting the MEID Support to off will disable the test set to support the MEID. The test set does not sends the Status Request Message to retrieve the MEID value from the MEID-equipped MS. The MEID-equipped MS only registers to the test set using pseudo-ESN so that PLCM for a call can only derive from the pseudo-ESN.)

Step A: Configure Call Parameters

  1. Press the Call Setup key.
  2. Verify that the Operating Mode ( F1 ) is set to Active Cell and the System Type ( F2 ) is set to IS-2000 .
  3. Set the parameters that are required for your MS to acquire the IS-2000 system. For example,
    • Set the Cell Band ( F8 ) on Call Parms 1 of 4 ) and Channel ( F9 on Call Parms 1 of 4 ) to match your MS's configuration for IS-2000 system.
    • Set the SID , NID as required for your MS from the Cell Parameters menu (see B. Cell Parameters for detailed procedure).

Step B: Enable Test Set to Support MEID/Enhanced PLCM

  1. Press the left More key until you reach the Call Control 3 of 3 (in Test Application) or the Call Control 3 of 5 (in Lab Application).
  2. Select the MEID/Enhanced PLCM ( F3 ).
  3. Set the MEID Support ( F1 ) to On . This is to enable the test set to support MEID tests.
  4. Set the PLCM Type ( F2 ) to MEID Based .

Step C: Register the Mobile Station.

  1. If there is data shown on Mobile Station Information screen, clear these data by pressing the F5 ( Clear MS & Capability Info ) on Call Control 2 of 3 (in Test Application) or Call Control 2 of 5 (in Lab Application).
  2. Power on the MS and wait for it to perform a power-up registration.
  3. When a registration has completed, the registration data (including MEID related information) reported/retrieved from the MS will be displayed on the Mobile Reported Information screen. During registration, the MS sends a Registration Message with SCM bit 4 (MEID support indicator) set to 1 (indicating that it supports MEID). Then the test set sends a Status Request Message with RECORD_TYPE = '00100111' to request MEID value. Verify that the MS responds with Status Response Message with RECORD_TYPE = '00100111', and set MEID_LEN and MEID fields properly.

Step D: Establish a Call.

  1. If required, set the service option for the radio configuration (for example, SO2 for Radio Config (Fwd3, Rvs3) ) in which you'd like to bring up the call.
  2. Select Originate Call ( F3 ) on MEID/PLCM 2 of 2 or make a MS originated call (by entering a phone number and pressing SEND on the MS).
  3. Check for Connected in the Active Cell status area indicating a call is successfully established. The test set sends MEID Extended Channel Assignment Message with PLCM_TYPE set to '0100' (corresponding to MEID Based you've set during Step B). When the call is successfully established, it indicates that the MS can use the PLCM determined by the specified PLCM Type .

Step E: Perform an Implicit Handoff.

  1. Change the PLCM Type ( F2 ) you've set in Step B to a different value (for example, ESN Based ).
  2. Observe the Active Cell status area. You should see the status changes from Connected to Handoff to Connected . The test set sends MEID Extended Universal Handoff Direction Message with PLCM_TYPE set to '0000' (corresponding to ESN Based you've changed to). The call is maintained, which indicates that the MS can use the PLCM determined by the specified PLCM Type .

Step F: Disable the Test Set to Support MEID and Verify the MS Behavior.

  1. End the call.
  2. Change the MEID Support ( F1 ) to Off .This is to disable the test set to support MEID. You should see that PLCM Type ( F2 ) and Query MEID ( F3 ) become invalid.
  3. Clear the registration data on Mobile Station Information screen by pressing the F5 ( Clear MS & Capability Info ) on Call Control 2 of 3 (in Test Application) or Call Control 2 of 5 (in Lab Application).
  4. Wait for the MS making a timer-based registration or press the Register Mobile ( F6 ) on Call Control 1 of 3 (in Test Application) or Call Control 1of 5 (in Lab Application) to force MS making a registration.
  5. When a registration has completed, you should see that no MEID value is displayed on the Mobile Reported Information screen although the MS reports that it supports MEID. This is because the test set does not send the Status Request Message to an MEID-equipped MS to retrieve its MEID value. Only pseudo-ESN is reported during MS registration. The MS sends a Registration Message with SCM bit 4 (MEID support indicator) set to 1 (indicating that it supports MEID), but no Status Request Message with RECORD_TYPE = '00100111' (MEID) is sent by the test set to retrieve MEID value.
  6. Establish a call and verify that a call is connected. This indicates that an MEID-equipped MS can establish a call with an MEID-disabled test set but use the PLCM derived from the pseudo-ESN instead of the specified PLCM Type. The test set sends Extended Channel Assignment Message (without any PLCM information included) during call establishment.

Step H: End the Test.

  1. If desired, end the call.
  2. Verify that the MEID Support ( F1 ) is set to Off if you plan to test an ESN-equipped MS. Otherwise, the call can not be established.

Related Topics

MEID / Enhanced PLCM


How Do I Change Test Set's Receiver Control Parameters?

How Do I Change Test Set's Receiver Control Parameters?

Last updated: July 4, 2006

In some instances you may want to control the test set's receiver settings manually rather than allowing the test set to automatically control them. This ability is referred to as manual receiver control (see Receiver Control ). There are some differences to change the test set's receiver control parameters while in different operating mode:

  • To Access Receiver Control Settings in Active Cell or Cell Off Operating Mode
  • To Access Receiver Control Settings in IS-2000 Test Operating Mode
  • To Access Receiver Control Settings in AVC Test Operating Mode
  • To Access Receiver Control Settings in CW Operating Mode

To Access Receiver Control Settings in Active Cell or Cell Off Operating Mode

  1. Press the CALL SETUP key.
  2. Press the More key until 3 of 3 is displayed.
  3. To set the receiver's expected power, press the Rcvr Power Ctrl ( F8 ) key and select Manual .
  4. Press the Receiver Power ( F9 ) key and enter a desired value by using the knob or numeric keys.
  5. To set the receiver's measurement downconverter tune frequency, press the Meas Frequency ( F10 ) key and enter a desired value to replace the Auto .

To Access Receiver Control Settings in IS-2000 Test Operating Mode

  1. Press the CALL SETUP key.
  2. Press the More key until 2 of 2 is displayed.
  3. To set the receiver's expected power, press the Rcvr Power Ctrl ( F8 ) key and select Manual .
  4. Press the Receiver Power ( F9 ) key and enter a desired value by using the knob or numeric keys.
  5. To set the receiver's measurement downconverter tune frequency, press the Meas Frequency ( F10 ) key and enter a desired value to replace the Auto .
  6. To set the receiver's demodulation downconverter tune frequency, press Rvs Link Freq ( F11 ) key and enter a desired value to replace the Auto .

NOTE
Manual control of the demodulation receiver frequency is rarely needed. Use the measurement receiver when manual receiver frequency control is required.

To Access Receiver Control Settings in AVC Test Operating Mode

  1. Press the CALL SETUP key.
  2. Press the More key until 3 of 3 is displayed.
  3. To set the receiver's expected power, press the Rcvr Power Ctrl ( F8 ) key and select Manual .
  4. Press the Receiver Power ( F9 ) key and enter a desired value by using the knob or numeric keys.
  5. To set the receiver's measurement downconverter tune frequency, press the Meas Frequency ( F10 ) key and enter a desired value to replace the Auto .
  6. To set the receiver's demodulation downconverter tune frequency, press Rvs Link Freq ( F11 ) key and enter a desired value to replace the Auto .

NOTE
Manual control of the demodulation receiver frequency is rarely needed. Use the measurement receiver when manual receiver frequency control is required.

To Access Receiver Control Settings in CW Operating Mode

  1. Press the CALL SETUP key.
  2. Press the Receiver Control ( F12 ) key.
  3. Turn the knob to highlight a selection and then press the knob.
  4. Enter a desired value by using the knob or numeric keys.


How Do I Set Up a Call?

How Do I Set Up a Call?

Last updated: June 20, 2006

  • How Do I Set Up an IS-2000 Call?
  • How Do I Set Up an IS-95 Call?
  • How Do I Set Up an AMPS Call?

How Do I Set Up an IS-2000 Call?

The Call Parms keys and Call Control keys provide access to the parameters needed to set up a call.

  1. Press the CALL SETUP key.
  2. Press the Operating Mode ( F1 ) key and set the operating mode to Active Cell .
  3. Press the System Type ( F2 ) key and select IS-2000.
  4. Press the Cell Band ( F8 ) key and select the band in which you would like to bring up the call.
  5. Press the Channel ( F9 ) key and set the RF channel number.
  6. Press the Radio Config ( F11 ) key and select the radio configuration in which you would like to bring up the call.
  7. Press the FCH Service Option Setup ( F12 ) key and set the service option for the radio configurations you plan on testing. See Service Option .

    NOTE
    SO55 (Service Option 55) is not supported by some mobile stations. If your mobile station does not support SO55 calls cannot be connected, and you will need to select a service option supported by the mobile station.

  8. Check the rest of the Call Parms settings by pressing the More key to display the 2 of 3 and 3 of 3 menus. You may also need to change cell settings such as SID (System Identification) to allow the mobile station to find service. See How Do I Change Cell Information? .
  9. Turn on power to the mobile station and wait for mobile station performing a registration. The registration data is displayed on the Mobile Reported Information screen after a successful registration.
  10. Make a mobile station originated call (by entering a phone number and pressing SEND on the mobile station handset); or, wait for the mobile station to perform a power up registration and press the Originate Call ( F3 ) key.
  11. Check for Connected in the Active Cell status field.

How Do I Set Up an IS-95 Call?

The Call Parms keys and Call Control keys provide access to the parameters needed to set up a call.

  1. Press the CALL SETUP key.
  2. Press the Operating Mode ( F1 ) key and set the operating mode to Active Cell .
  3. Press the System Type ( F2 ) key and select IS-95.
  4. Press the Cell Band ( F8 ) key and select the band in which you would like to bring up the call.
  5. Press the Channel ( F9 ) key and set the RF channel number.
  6. Press the Protocol Rev ( F10 ) key and set the protocol revision supported by the mobile station.
  7. Press the Service Option ( F12 ) key and select a service option for the call. See Service Option .
  8. Check the rest of the Call Parms settings by pressing the More key to display the 2 of 3 and 3 of 3 menus.
  9. You may need to change cell settings such as SID (System Identification) to allow the mobile station to find service. See How Do I Change Cell Information? .
  10. Turn on power to the mobile station and wait for an indication that it has found service.
  11. Make a mobile station originated call (by entering a phone number and pressing SEND on the mobile station handset), or wait for the mobile station to perform a power up registration and press the Originate Call ( F3 ) key.
  12. Check for Connected in the Active Cell status field.

How Do I Set Up an AMPS Call?

The Call Parms keys and Call Control keys provide access to the parameters needed to set up a call.

  1. Press the CALL SETUP key.
  2. Press the Operating Mode ( F1 ) key and set the operating mode to Active Cell .
  3. Press the System Type ( F2 ) key and select AMPS.
  4. You may need to change cell settings such as SID (System Identification) to allow the mobile station to find service. See How Do I Change Cell Information? .
  5. Turn on power to the mobile station and wait for an indication that it has found service.
  6. Make a mobile station originated call (by entering a phone number and pressing SEND on the mobile station handset), or wait for the mobile station to perform a power up registration and press the Originate Call ( F3 ) key.
  7. Check for Connected in the Active Cell status field.


How Do I Use the Spectrum Monitor?

How Do I Use the Spectrum Monitor?

Last updated: April 21, 2005

The following procedure shows a typical usage of the spectrum monitor in each of its two modes of operation; Swept Mode and Zero Span mode.

  1. Establish a call with the mobile.

    NOTE
    The spectrum monitor can also be used with any of the test set's test mode operating modes.

  2. Press the Instrument selection key.
  3. Select Spectrum Monitor .

    The spectrum monitor is displayed with the default settings as shown above. The center frequency is initially set at the expected frequency maintained by the test set's base station emulator. The Swap Window Positions ( F5 ) key is only displayed when other measurements are active at the same time as the spectrum monitor.

  4. Set the axis control as needed for your testing situation using the Frequency Span ( F1 ), Reference ( F2 ), and dB/div ( F3 ) keys. See Frequency Span, Resolution Bandwidth and Dynamic Range to find the valid Frequency Span entries while in swept mode. To set the reference level manually ( Auto is the default), press the Reference ( F2) key then use the DATA ENTRY keys to enter the value you want.
  5. Press the Trigger Setup ( F4 ) key to access the Trigger Setup menu.
  6. Set the trigger settings to meet your testing needs. For example:

    • If you want the Spectrum Monitor to sweep immediately and continuously, ensure that Trigger Arm ( F3 ) is set to Continuous .
    • If you want to use external triggering, so that the Spectrum Monitor is triggered from a signal applied to the TRIG IN connector on the test set's rear panel, set Trigger Source ( F1 ) to External .
    • Trigger Delay ( F2 ) allows you to specify the point, relative to the trigger event where samples are taken (a negative trigger delay value collects pre-trigger samples). The same trigger delay setting is used for swept mode and zero span mode.

  7. Res Bw allows you to set the resolution bandwidth. If you want the resolution bandwidth coupled with the with the Frequency Span , set this field to AUTO by pressing the gray DATA ENTRY softkey labeled ON , otherwise use the knob or the numeric DATA ENTRY softkeys to set the resolution bandwidth. See Frequency Span, Resolution Bandwidth and Dynamic Range to find the valid entries for the resolution bandwidth while in swept mode. Note that changing the resolution bandwidth does not modify the zero span resolution bandwidth setting.
  8. Press the Return ( F6 ) key to exit the Trigger Setup menu.
  9. Press the Display ( F6 ) key to access the display settings.

    A typical spectrum monitor trace display is shown above. In this case, the Display menu is open allowing you to access all of the display control settings using the ( F1 ) through ( F12 ) keys.

    The following list provides examples of some of the settings you may want to adjust:

    • Detection Method ( F2 ) determines the algorithm used to find the value that represents each frequency bin. See Detection Method for more information.

    • Peak Threshold ( F4 ) and Peak Excursion ( F5 ) set the peak threshold and peak excursion levels respectively. A peak is identified by using the peak threshold and peak excursion value. A point is only marked as a peak if it rises and falls more than the peak excursion value from the peak threshold value.

    • Marker Mode ( F8 ) sets the mode of the active marker. Position mode activates a single frequency marker. Delta mode freezes the active marker at its current location and uses it as a reference marker. A second marker is created at the position of the reference marker and is used as a delta marker, reporting any change in amplitude or frequency from that of the reference marker.

    • Peak Search ( F10 ) moves the active marker to the highest peak on the spectrum monitor display, returning the numeric amplitude and frequency values.

    • Marker -> Expected Freq ( F11 ) sets the base station emulator's expected frequency to the frequency of the active marker.

    • Marker -> Expected Power ( F12 ) sets the base station emulator's expected power level to the amplitude of the active marker.

    A typical swept mode spectrum monitor display is shown above. In this case, the active marker is marker 1, which is set to Delta mode.

  10. Press the Return ( F6 ) key to exit the Display menu.
  11. To set the spectrum monitor to zero span mode, press the Frequency Span ( F1 ) key and use the numeric DATA ENTRY keys to enter a value of 0 MHz , or use the down-arrow key to reduce the span to zero.

    A typical zero span mode spectrum monitor display is shown above. Like swept mode, the Y-axis represents absolute amplitude. However, the X-axis now represents time rather than frequency.

  12. Press the Trigger Setup ( F6 ) key. In zero span mode, additional trigger setup controls are available to you:
    • If you want to change the view window over which you are looking at the signal, use the Time Span ( F8 ) and Time Offset ( F9 ) keys. The measurement is made for the duration of the time span, beginning at the time defined by the trigger event plus the trigger delay plus the time offset.
    • If you want to change the resolution bandwidth, press the Zero Span RBW ( F7 ) key and select a value. (To measure the total power of a signal you must select a resolution bandwidth greater than or equal to the signal bandwidth.) See Frequency Span, Resolution Bandwidth and Dynamic Range to find the valid entries for the resolution bandwidth while in zero span mode. Note that changing the zero span resolution bandwidth does not modify the swept mode resolution bandwidth.

    A typical zero span mode spectrum monitor display showing a bursted signal. The viewing window has been adjusted to zoom in on a single burst.

    If the temperature of the test set drifts outside the calibrated temperature range of the spectrum monitor, a Measurement Uncalibrated message is displayed. To calibrate the spectrum monitor for the current temperature, press the Calibrate Measurement ( F11 ) key on the Trigger Setup menu.

Related Topics

Spectrum Monitor Description


How Do I Configure the Test Set for My Test System?

How Do I Configure the Test Set for My Test System?

Last updated: October 28, 2004

A. Configure instrument information and setup.

  1. Press the SYSTEM CONFIG key.
  2. Press the Instrument Setup ( F1 ) key.
  3. Adjust an instrument setting.
  4. Press the Close Menu ( F6 ) key.

CAUTION
Always verify that the test set is responding to a new LAN IP Address by pinging the test set. If the test set does not respond to the ping, cycle power. This will ensure that the test set will respond to the new LAN IP Address.

B. Set amplitude offsets.

  1. Press the SYSTEM CONFIG key.
  2. Press the RF IN/OUT Amptd Offset ( F5 ) key.
  3. Press the RF IN/OUT Amptd Offset Setup ( F2 ) key.
  4. Enter the amplitude offset for the test frequencies you use.
  5. Press the Close Menu ( F6 ) key.

C. Check message log.

  1. From any System Config screen, press the Message Log ( F7 ) key and view the message log.
  2. Press the Return ( F12 ) key.

Related Topics

Display Brightness

Configuring the Test Set's GPIB

Configuring the Test Set's LAN

Test Set Beeper

Test Application Switching

Amplitude Offset

Error Message Log


How Do I Change TDSO Supplemental Channel Information?

How Do I Change TDSO Supplemental Channel Information?

Last updated: October 28, 2004

A. Select the TDSO Service Option.

  1. Press the CALL SETUP key.
  2. Press the Radio Config ( F11 ) key and select the radio configuration (Fwd3, Rvs3) or (Fwd4, Rvs3).
  3. Press the FCH Service Option Setup ( F12 ) key and set the service option for the selected radio configuration (Fwd3, Rvs3) or (Fwd4, Rvs3) to SO32 (+ F-SCH) or SO32 (+ SCH).

B. Set the TDSO Supplemental Channel Information.

  1. Press the More key on the left side of the display.
  2. Press the TDSO SCH Info ( F4 ) key.

    NOTE
    The TDSO supplemental channel parameters are accessible regardless of the service option currently selected, but the parameter settings are stored for use when the service option is set to SO32 (+ F-SCH) or SO32 (+ SCH).

  3. Set the forward supplemental channel parameters.
    • Press the F-SCH Parameters ( F2 ) key.
    • Change the parameters as needed using the knob and/or keypad.
    • Press the Close Menu ( F6 ) key.
  4. Set the reverse supplemental channel parameters.
    • Press the R-SCH Parameters ( F4 ) key.
    • Change the parameters as needed using the knob and/or keypad.
    • Press the Close Menu ( F6 ) key.
  5. Press the Return ( F6 ) key.

Setting F-SCH Levels

To set the F-SCH level, see How Do I Change Generator Information? .

Related Topics

Configuring the TDSO Supplemental Channel Information


How Do I Turn Off a Measurement?

How Do I Turn Off a Measurement?

Last updated: October 28, 2004

  1. Press the Measurement selection key.
  2. Use the knob to highlight the measurement you want to turn off.
  3. Press Close Measurement ( F4 ).
  4. Press Close Menu ( F6 ).


Printing Screens

Printing Screens

Last updated: October 28, 2004

Printing and Saving Screen Images

The test set's local area network (LAN) connection can be used to dump the currently-displayed screen image into a personal computer's web browser. The computer must either be connected to an existing LAN or have a LAN adapter installed that can be connected directly to the test set.

Computer Requirements for LAN Communications with the Test Set

The computer used to capture screen images from the test set must meet the following requirements:

  • 10 Base-T, IEEE 802.3 compliant, ethernet network interface using TCP/IP protocol and configured to run in half-duplex mode.
  • Windows 95, 98, 2000 or NT 4.0 (Windows 95, Windows 98, Windows 2000 and Windows NT 4.0 are U.S. registered trademarks of Microsoft Corporation.)

Test Set to Computer Connections

The test set's LAN connection can be made at either the rear-panel LAN PORT or at the front-panel DATA port. When using the DATA port, be sure to have the factory supplied jumper cable installed between the rear-panel LAN PORT and the ETHERNET TO FRONT PANEL port.

Connections from the test set to the computer must be made using the correct type of LAN cable:

  • If the test set is being connected to the computer through an existing network, use a standard LAN cable.
  • If the test set is being connected directly to the computer's LAN adapter, use a crossover LAN cable (such as the one shipped with the test set or with an older test application upgrade kit).

Capturing the Screen Image

  1. Press the test set's SYSTEM CONFIG key to display the test set's LAN settings, and record the LAN IP Address for use later in this procedure.
  2. Start a web browser application on your computer.
  3. Display the test set screen that you want to capture.
  4. Enter the following address/location into your web browser: http://<lan address>/display.htm
    where <lan address> is the LAN IP address of the test set .
  5. Within a few seconds, the test set's screen image appears in your browser. If the image does not appear on your browser within 30 seconds, refer to Test Your LAN Connections and Configuration by "Pinging" the Test Set below.
  6. To print the image, select File , Print .
  7. To save the file:
    1. Select File , or right-click on the image, and select Save As or Save Picture As .
    2. Enter the desired file name and directory path for saving the image as a GIF file.

The image can now be retrieved from your directory and used as needed.

Test Your LAN Connections and Configuration by "Pinging" the Test Set

Perform this operation only if you were not successful in downloading the test set screen image into your browser.

  1. Display the Command Prompt window on your computer. This is typically done in the Microsoft Windows operating system by selecting Start -> Programs -> Command Prompts .
  2. At the command prompt, enter the following command: ping <lan address>. The <lan address> is the test set's LAN IP address. (The command prompt does not have to be at the root (c:\) level before entering the command.)

    This example shows what should happen when you enter the ping command for a test set with the LAN IP address of 111.22.333.44. The test set should reply back to the Command Prompt screen indicating that data was received.
  3. If the message " Request Timed Out " is displayed instead of a reply from the test set, try entering the command again. If the request times out again, your LAN connections are incorrect and/or your LAN settings for the two devices do not match.

Troubleshooting LAN Connections

If your web browser did not display the test set's screen, or you could not "ping" your test set from your browser, refer to the following information to find the cause and fix the problem.

Try Altering Connections

  • If you are using the test set's front panel DATA port, make sure the jumper between the rear-panel LAN PORT and ETHERNET TO FRONT PANEL port is in place; or try connecting directly to the rear-panel LAN PORT.
  • Try using a different type of LAN cable. If you were using a crossover cable, try using a standard LAN cable; if using a standard LAN cable, try using a crossover cable. If this doesn't fix the problem, be sure to replace the cable with the type recommended in Test Set to Computer Connections above.

Reconfigure the Computer and Test Set LAN Settings

If the test set's image is still not displayed on your web browser, and the ping command still indicates that the test set is not communicating with the computer, you need to verify that the LAN settings for the computer and the test set are compatible. The following sections provide general guidelines in getting the LAN settings configured for both instruments to communicate with each other.

Perform the configuration in the following order:

  1. Configure the computer's LAN settings.
  2. Restart Windows on the computer to start using the new LAN configuration.
  3. Configure the test set's LAN settings to work with the computer's settings. (It is important that the computer be configured and re-started before configuring the test set's LAN settings.)
  4. Turn the test set off and back on to make sure it finds the computer's newly-configured LAN card on power up.

LAN Setting Guidelines

  • It is highly recommended that the Subnet Mask be set to 255.255.248.0 for the test set and the computer when using a direct computer-to-test set connection.
  • The first three groups of numbers for the LAN IP Address of the test set and the computer must match. Example; if the test set's LAN IP Address is set to 130.29.189.33, the computer's LAN IP address must begin with 130.29.189.

    The number in the fourth group of digits in the computer's and test set's LAN IP Addresses must NOT match. Example; if the test set is set to LAN IP Address 130.29.189.33, set the computer's LAN IP Address to 130.29.183.34 (or 130.29.183.77, 130.29.183.42...- just so the last number is not also set to 33). The last entry in the IP Address must not be >254 or 0.

Changing the LAN Setting on Your Computer

Network configuration procedures vary between operating systems. You may have to refer to your computer's help system, or your LAN adapter card's documentation, for assistance.

Perform the following steps to alter the network settings for most PCs using a Microsoft Windows operating system.

Access the Network Settings

  1. Double-click on the My Computer icon on the Windows desk top.
  2. Double-click on the Control Panel icon.
  3. Double-click on the Network icon.
  4. Select the TCP/IP -> [your Ethernet network adapter] entry from the list of components. Note: Do not select TCP/IP Dial-Up Adapter settings if present.
  5. Select Properties to access the TCP/IP settings screen.
Accessing Your Computer's LAN Settings

Set the IP Address and Subnet Mask

  1. Select the IP Address tab on the TCP/IP Properties screen.
  2. Select Specify an IP Address .
  3. Enter the IP Address for the computer. Remember, the last entry in the IP Address must not be >254 or 0.
  4. Enter the Subnet Mask (255.255.248.0).
Specifying the Computer's IP Address and Subnet Mask

Remove Any Gateway Setting

  1. Select the Gateway tab.
  2. If present, remove any existing setting.
  3. Click OK until you have closed the Network settings window.
Accessing the Gateway Setting

Restart Windows

Depending on your LAN network adapter, your computer may or may not apply the network configuration changes as they are made. It is import that you restart Windows NOW to make sure new LAN settings are in effect when you try to connect to the test set.

Changing the LAN Settings on Your Test Set

  1. Press the SYSTEM CONFIG key on the test set to display the current LAN settings.
  2. Press the F1 ( Instrument Setup ) key.

    NOTE
    Changing the LAN IP Address may alter the Subnet Mask setting. Therefore, change the LAN IP Address first, then change the Subnet Mask. Also, The last entry in the IP Address must not be >254 or 0.

  3. Turn the knob to highlight the setting you want to change.
  4. Press the knob to select the setting.
  5. Enter the new value using the keypad, and press the knob to complete the setting.
  6. Turn the test set off and back on to start using the new settings.

Related Topics

Configuring the Test Set's LAN


Rear Panel Connectors

Rear Panel Connectors

Last updated: November 10, 2006

Description

BASEBAND I/O

Four pins are functional on this connector:

  • I channel (pin 9)
  • Q channel (pin 26)
  • Ground
  • Ground

CLK IN

Not functional for this release.

COUNTER IN

Not functional for this release.

DATA IN

Not functional for this release.

DATA VALID IN

Not functional for this release.

ETHERNET TO FRONT PANEL

This RJ-45 connector is used with a separate LAN jumper cable to connect the front panel DATA connector to the rear panel LAN PORT.

The the DATA connector on the front panel is connected internally to the ETHERNET TO FRONT PANEL connector on the rear panel. In order to use the front panel DATA connector the user must connect the rear panel LAN PORT, to the rear panel ETHERNET TO FRONT PANEL connector with the LAN jumper cable.

The LAN jumper cable, part number E5515-61160, is supplied with the test set.

EXT INTERFACE CONTROL

Not functional for this release.

EXT SIG GEN/FRAME SYNCH

Not functional for this release.

FM MOD IN

This BNC connector allows you to use an external signal to frequency modulate the test set's RF generator. It has a fixed sensitivity of 20 KHz/volt, and a frequency range of 100Hz to 20 KHz.

GPIB

This GPIB connector allows test set control with compatible devices.

LAN PORT

This RJ-45 connector provides connection for downloading firmware upgrades, or new test applications into the test set. No other types of communication are possible with the LAN port.

PRINTER

Not functional for this release.

SERIAL 1

Not functional for this release.

SERIAL 2

Not functional for this release.

SERIAL 3

Not functional for this release.

TEST SET SYNCH IN

Not functional for this release.

TEST SET SYNCH OUT

Not functional for this release.

TIMEBASE ADJUST

This is the timebase adjust cover. Removing this screw allows access for timebase adjustment.

TRIG IN

This BNC connector provides the capability for you to trigger measurements or instruments from an external source. Setting the Trigger Source setting to External for measurements or instruments which support this feature causes the measurement or instrument to trigger when a positive-going TTL compatible pulse is applied to this connector. Currently, the only measurement or instrument which supports this feature is the Spectrum Monitor.

TRIG OUT

This BNC connector allows you to synchronize the test set to other equipment via a trigger signal.

VGA OUT

This DB-15 connector allows you to simultaneously route the test set's display to another monitor.

10 MHZ REF IN

This BNC connector accepts an external 10 MHz timebase signal. The nominal input impedance is 50 ohm. This version of test set can only accept a 10 MHz timebase signal.

10 MHZ REF OUT

This BNC connector provides a 10 MHz timebase signal to external test equipment. The accuracy of this signal is determined by the timebase used. The nominal output impedance is 50 ohm with a typical level of 0.5 V rms.

Related Topics

Configuring the Test Set's LAN

Configuring the Test Set's GPIB

Triggering of Measurements

Setting External Trigger

Timebase Description/Configuration


Remote/Local Mode

Remote/Local Mode

Last updated: October 28, 2004

Description

Remote Mode

When the test set is operated remotely, all of the keys on the front panel of the test set are disabled (except the LOCAL key and the power switch). During remote operation the test set is controlled by the Remote User Interface, (RUI).

Any open menus are be closed, and any manual entries are be aborted when the test set transitions from local mode to remote mode.

The remote annunciator (R) will appear in the Instrument Status Area of the test set's display indicating that the test set is in remote mode.

When the test set is in remote mode press the LOCAL key on the front panel in order to gain manual control.

Local Mode

During local mode all front panel keys and the knob are enabled. During local operation the test set is controlled by the Manual User Interface, (MUI).

The remote annunciator (R) is turned off when the test set is operated in local mode.

Related Topics

Configuring the Test Set's GPIB


Save and Recall Registers

Save and Recall Registers

Last updated: April 21, 2005

Description

The test set provides up to five save/recall registers . Each register is identified by a number (1-5).

This section details the following:

  • Recalling Saved Registers
  • Deleting Saved Registers
  • Settings that are Saved
  • Settings that are not Saved
  • Saving Current Settings to a Register

Recalling Saved Registers

Press the Register recall hardkey.

Use the knob to scroll to a register that is labeled Full and press the knob.

When a register is recalled, the test set will clear all active measurements and display the Call Setup Screen. Registers can only be recalled in the format they were saved in. For example, in a fast switching application, a register that is saved in a specific format must also be recalled in that same format. If a register is attempted to be recalled in a format other than the one it was saved in, the following error will occur:

CAUTION
If the test set has had hardware options installed since the last time a registers were saved, delete the registers and re-save them. Failure to perform this step could result in a non-recoverable firmware "assert" when performing a register recall.

Deleting Saved Registers

Pressing the DELETE hardkey will display a menu indicating which registers have been saved (they are labeled "Full").

Use the knob to scroll to a register and press the knob. Select Yes to confirm the selection.

Settings that are Saved

All functions and parameters that have an associated static state or settable value will be saved. For example:

  • Cell parameters (System ID, Network ID, etc.)
  • Call control parameters (System Type, Operating Mode, etc.)
  • Measurement setup parameters (Trigger Arm state, Measurement Timeout, etc.)
  • Call Parms (Cell Power, Cell Band, etc.)

Settings that are not Saved

Functions that trigger immediate actions, such as originating a call or calibrating a measurement are not saved.

Settings saved in non-volatile memory (settings that are unchanged when power is cycled or the test set is preset) are not saved. For example:

  • LAN IP Address
  • Date/Time
  • RF IN/OUT Amplitude Offset
  • All other settings on the Instrument Setup menu on the System Config screen.
  • Measurement results
  • Call status
  • Active measurements

Read-only call processing results such as Mobile Station Information tables are not saved.

Saving Current Settings to a Register

To save the current state of the test set, press the SAVE hardkey.

A menu will be displayed that shows the status of all five registers. If the register status is "Full", the register has had instrument settings saved to it. If the register status is "Empty", it does not currently contain any instrument settings.

Use the knob to scroll to a register and press the knob. If the selected register is currently Full, select Yes in the Overwrite Save Reg? window and it will be overwritten.

CAUTION
When a test set application is upgraded using the 8960 File Utility Program, the new revision of the application will not automatically retain save/recall registers from the old revision. Prior to the application upgrade, it is recommended that you record the critical settings (such as call setup information) from registers that you will want to re-save after the test application upgrade.

Related Topics

SYSTem:REGister


Getting Started with the cdma2000 Test and Lab Applications

Getting Started with the cdma2000 Test and Lab Applications

Last updated: June 20, 2006

This online user's guide provides detailed information about your application's features and functionality, as well as how to use these features to test your wireless device.

The Contents box provides access to all of the information contained within this online user's guide. The following is a description of these Contents topics, as well as links to getting started information for many of the topics.

  • Call Processing : Describes how to configure the test set's base station emulator and perform key call processing operations.
  • Measurements : Describes the measurements and instruments available within your application. Provides a list of which key conformance tests are supported by the test set.
  • Manual Operation : Describes how to configure the test set and perform call processing operations and measurements from the front panel.
  • Programming : Describes how to configure the test set and perform call processing operations and measurements by remote program.
  • GPIB Commands : Provides details on all of the GPIB syntax available to control the test set by remote program.
  • Protocol Logging ( lab application only ): Describes how to capture the exchange of data and control information between the test set and wireless device.
  • Data Channel ( lab application only ): Describes how to use the test set as an IP router, exchanging data between your wireless device and remote servers.
  • Troubleshooting : Provides troubleshooting information for performing measurements and key call processing events. Includes a test set block diagram.
  • Configuration : Describes how to set amplitude offsets, switch between applications, and configure the test set (such as GPIB and LAN ports).
  • Fast Switching : Explains how to use fast switching test and lab applications.
  • Release Notes : Lists the features and functionality of the applications for each release of the firmware.
  • Downloadable Manuals : Provides a portable version of this online user's guide, which you may download to your computer.

For pricing and availability, brochures and datasheets for the applications, visit the product page:

  • E1962B cdma2000/IS-95/AMPS Mobile Test Application


ABORt

ABORt

Last updated: July 18, 2007

GPIB Command Conventions

  • ABORt[:ALL]
  • ABORt<:measurement mnemonic>

ABORt[:ALL]

Function

Stops all measurements that are active.

If the trigger arm is set to single, the measurements will go to the idle state.

If the trigger arm is set to continuous, the measurements will re-arm and initiate again.

See Measurement States .

Programming Example

OUTPUT 714;"ABORt" !Aborts all active measurements in progress.

ABORt<:measurement mnemonic>

Function

Stops the selected measurement if it is active.

If the trigger arm is set to single, the measurements will go to the idle state.

If the trigger arm is set to continuous the measurements will re-arm and initiate again.

See Measurement States .

Setting

Range

  • AFANalyzer - AF Analyzer measurement

  • ATXPower - Analog Transmitter Power measurement

  • CAPPower - Access Probe Power measurement

  • CCTPhase - Code Channel Time/Phase error measurement

  • CFDTune - Fast Device Tune measurement

  • CFERror - Frame Error Rate measurement

  • CMAudio - Multi-Tone Audio measurement

  • CMMPower - Maximum / Minimum Power measurement

  • CPOWer - Channel Power measurement

  • CTDPower - TX Dynamic Power measurement

  • CTXSpurious - TX Spurious Emissions measurement

  • DTMF - Dual Tone Multi-Frequency measurement

  • FSTability - Frequency Stability measurement

  • FM - Frequency Modulation measurement

  • GAPPower - Graphical Access Probe Power measurement (only applicable to the lab application)

  • GPOWer - Gated Power measurement

  • HWQuality - Handoff Waveform Quality measurement

  • SAUDio - Swept Audio measurement

  • SMONitor - Spectrum Monitor measurement

  • STONe - Signaling Tone measurement

  • TFERror - TDSO Frame Error Rate measurement

  • TROPower - Time Response of Open Loop Power Control measurement

  • WQUality - Waveform Quality measurement

  • WDDeviation - Wideband Data Deviation measurement

Programming Example

OUTPUT 714;"ABORt:WQUality" !Aborts the waveform quality/code domain power measurements.


ABORt Subsystem

ABORt Subsystem

Last updated: October 28, 2004

Description

The ABORt command causes a measurement cycle in progress to stop. If the measurement is not being continuously armed (trigger arm set to single) , the measurement will remain in the idle state after this event. If the measurement is being continuously armed (trigger arm set to continuous), a new measurement cycle will begin after ABORt. If an ABORt command is issued from any measurement state other than measuring, the command is ignored.

Other Commands that Execute an ABORt Action

INITiate:<meas> will execute an ABORt:<meas> as part of the INITiate:<meas> command.

READ:<meas>? will execute an ABORt:<meas> action that aborts just one trigger sequence and then combines the INITiate and FETCh? commands.

Syntax Diagram and Command Descriptions

ABORt


AFGenerator

AFGenerator

Last updated: July 18, 2007

GPIB Command Conventions

  • AFGenerator:COUPling
  • AFGenerator:FREQuency
  • AFGenerator:PULSe[:STATe]
  • AFGenerator:VOLTage[:SAMPlitude]
  • AFGenerator:VOLTage:AMPlitude
  • AFGenerator:VOLTage:STATe

AFGenerator:COUPling

Function

 Sets the output of the audio generator to be ac or dc coupled to the front-panel AUDIO OUT port.
Setting

Range: AC or DC
Query

Range: AC|DC
*RST setting DC

Programming Example

OUTPUT 714;"AFGENERATOR:COUPling AC" !Sets the audio generator coupling to AC.

AFGenerator:FREQuency

Function

 Sets/queries the frequency of the audio generator. The units (HZ|KHZ|MHZ|GHZ) are optional. If no units are specified, then units default to HZ.
Setting

Range: 1 Hz to 20 kHz

Resolution:0 .1 HZ
Query

Range: 1 Hz to 20 kHz

Resolution: 0.1 Hz
*RST setting 1 kHz

Programming Example

OUTPUT 714;"AFGENERATOR:FREQUENCY 1000" !Sets the audio generator frequency to 1000 Hz.

AFGenerator:PULSe[:STATe]

Function

Sets/queries the audio generator pulse state.

The pulse state must be on when the test set's audio generator is used for audio stimulation during a decoded audio measurement.

When the state is on, the audio signal from the test set is pulsed at a 10 Hz rate with a 50% duty cycle.

Setting | Range: 0 | OFF | 1 |ON

Query

Range: 0|1
*RST setting | 0 (off)

Programming Example

OUTPUT 714;"AFGENERATOR:PULSE ON" !Sets the audio generator pulse to ON.

AFGenerator:VOLTage[:SAMPlitude]

Function

 Sets /queries the amplitude of the audio generator in volts and turns the state to on. The units (V|mV) are optional. If no units are specified, then units default to V.
Setting

Range: 0 to 9 V pk.

Resolution:

  • 0.5 mV pk. <= 1 V pk. output
  • 5 mV pk. > 1 V pk. output
Query

Range: 0 to 9 V pk.

Resolution:

  • 0.5 mV pk. <= 1 V pk. output
  • 5 mV pk. > 1 V pk. output
*RST setting 0 V

Programming Example

OUTPUT 714;"AFGENERATOR:VOLTAGE 2.1" !Sets the state to on and the output
                                     !voltage to 2.1 volts.

AFGenerator:VOLTage:AMPlitude

Function

 Sets/queries the amplitude for the audio generator when the audio generator state is on. The units (V|mV) are optional. If no units are specified, then units default to V.
Setting

Range: 0 to 9 V pk.

Resolution:

  • 0.5 mV pk. <= 1 V pk. output
  • 5 mV pk. > 1 V pk. output
Query

Range: 0 to 9 V pk.

Resolution:

  • 0.5 mV pk. <= 1 V pk. output
  • 5 mV pk. > 1 V pk. output
*RST setting 0 V

Programming Example

OUTPUT 714;"AFGENERATOR:VOLTAGE:AMPLITUDE 1.414" !Sets the audio generator output
                                                 !voltage to 1.414 volts peak.

AFGenerator:VOLTage:STATe

Function

 Sets/queries the audio generator state
Setting | 0 | OFF | 1 |ON

Query

0|1
*RST setting | 0 (off)

Programming Example

OUTPUT 714;"AFGENERATOR:VOLTAGE:STATE ON" !Set the audio generator state to ON.


AFGenerator Subsystem

AFGenerator Subsystem

Last updated: October 28, 2004

Description

The AFGenerator subsystem is used to control an audio source which can be routed to the AUDIO OUT port on the test set's front panel (see also SYSTem:AUDio:OUTPut:SOURce ).

Syntax Diagram and Command Descriptions

AFGenerator


CALCulate Subsystem

CALCulate Subsystem

Last updated: October 28, 2004

Description

The CALCulate subsystem is used to perform data processing on the measurement results. For example in the Spectrum Monitor the CALCulate subsystem uses the markers to find the peaks and read back their values.

Syntax Diagram and Command Descriptions

CALCulate:SMONitor


CALCulate:SMONitor

CALCulate:SMONitor

Last updated: July 18, 2007

GPIB Command Conventions

  • CALCulate:SMONitor:MARKer:ALL:STATe
  • CALCulate:SMONitor:MARKer[<n>] :AMPLitude?
  • CALCulate:SMONitor:MARKer[<n>]:FREQuency
  • CALCulate:SMONitor:MARKer[<n>] :MODE
  • CALCulate:SMONitor:MARKer:PEAK:EXCursion[:LEVel]
  • CALCulate:SMONitor:MARKer[<n>] :PEAK:MAXimum
  • CALCulate:SMONitor:MARKer:PEAK:THReshold[:LEVel]
  • CALCulate:SMONitor:MARKer[<n>] [:SET]:EXPected:POWer
  • CALCulate:SMONitor:MARKer[<n>] [:SET]:EXPected:FREQuency
  • CALCulate:SMONitor:MARKer[<n>]:STATe
  • CALCulate:SMONitor:MARKer[<n>]:TIME

CALCulate:SMONitor:MARKer:ALL:STATe

Function

This command determines whether all markers are turned on or turned off.
Setting

Range: 1|ON|0|OFF

Query

Range: 1|ON|0|OFF
*RST Setting OFF

Programming Example

OUTPUT 714;"CALCulate:SMONitor:MARKer:ALL:STATe 1"

!Turns on all markers.

CALCulate:SMONitor:MARKer[<n>] :AMPLitude?

Function

This query returns the amplitude for marker <n>, where <n> is a number 1 through 3. When no marker number is specified, marker 1 is used.

If you are using delta marker mode, the result is the delta marker amplitude result. (See CALCulate:SMONitor:MARKer[<n>] :MODE .)

Query

Range

  • Position Mode: -180 dBm to +37 dBm

  • Delta Mode: -200 dB to +200 dB

Resolution: 0.01 dB

Programming Example

OUTPUT 714;"CALCulate:SMONitor:MARKer2:AMPLitude?" !Returns the amplitude of marker 2.

CALCulate:SMONitor:MARKer[<n>]:FREQuency

Function

This command sets/queries the frequency of marker <n>. where <n> is a number 1 through 3. When no marker number is specified, marker 1 is used.

If you are using delta marker mode, this command sets/queries the offset frequency of the delta marker. (See CALCulate:SMONitor:MARKer[<n>] :MODE .)
Query

Range:

  • Position Mode

    Range: This is dependent on the settings of the center frequency and the frequency span. The markers frequency range is therefore equal to the center frequency +/- half the frequency span.

    Resolution: 0.001 MHz

  • Delta Mode:

    Range: The range is dependent on the center frequency, the frequency span and the position of the reference marker.

    Resolution: 0.001 MHz

Programming Example

OUTPUT 714;"CALCulate:SMONitor:MARKer:FREQuency?"

!Queries the frequency of marker 1.

CALCulate:SMONitor:MARKer[<n>] :MODE

Function

This command sets the mode of the marker.

Position mode activates a single frequency marker at the center frequency.

Delta mode freezes the marker at its current location and uses it as a reference marker. A second marker is created at the position of the reference marker and is used a delta marker.

Setting

Range: POSition|DELTa|OFF

Query

Range: POS|DELT|OFF
*RST Setting Off

Programming Example

OUTPUT 714;"CALCulate:SMONitor:MARKer:MODE DELT"

!Sets a reference marker and creates a delta marker.

CALCulate:SMONitor:MARKer:PEAK:EXCursion[:LEVel]

Function

This command sets the peak excursion level. A peak is identified by using the peak threshold and peak excursion value. A point is only marked as a peak if it rises and falls more than the peak excursion value from the peak threshold value. Setting this command to DEFault sets it to 6 dB.
Setting

Range: 1 to 100 dB | DEFault

Resolution: 0.1 dB

Query

Range: 1 to 100 dBResolution: 0.1 dB
*RST Setting

6 dB

Programming Example

OUTPUT 714;"CALCulate:SMONitor:MARKer:PEAK:EXCursion 20DB"

!Sets the peak excursion level to 20 dB.

CALCulate:SMONitor:MARKer[<n>] :PEAK:MAXimum

Function

This command moves the specified marker <n> (1 to 3) to the highest peak value. If no marker <n> is specified, then marker 1 is moved.

An error message is returned if no peaks were found in the trace.

Programming Example

OUTPUT 714;"CALCulate:SMONitor:MARKer2:PEAK:MAXimum"

!Moves marker 2 to the highest peak value on the selected trace.

CALCulate:SMONitor:MARKer:PEAK:THReshold[:LEVel]

Function

This command sets peak threshold level. A peak is identified by using the peak threshold and peak excursion value. A point is only marked as a peak if it rises and falls more than the peak excursion value from the peak threshold value. Setting this command to DEFault sets it to -90 dBm.
Setting

Range: -120 to +37 dBm | DEFault

Resolution: 0.1

Query

Range: -120 to +37 dBmResolution: 0.1
*RST Setting

-90 dBm

Programming Example

OUTPUT 714;"CALCulate:SMONitor:MARKer:PEAK:THReshold:LEVel 10DBM"

CALCulate:SMONitor:MARKer[<n>] [:SET]:EXPected:POWer

Function

This command sets the base station emulator's expected power to the amplitude of the specified marker.

There are three markers <n> (1 to 3) that can be set. If no <n> is specified, marker 1 is used.

Programming Example

OUTPUT 714;"CALCulate:SMONitor:MARKer2:EXPected:POWer"

CALCulate:SMONitor:MARKer[<n>] [:SET]:EXPected:FREQuency

Function

This command sets the base station emulator's expected frequency to the frequency of the specified marker.

There are three markers <n> (1 to 3) that can be set. If no <n> is specified, marker 1 is used.

Programming Example

OUTPUT 714;"CALCulate:SMONitor:MARKer3:EXPected:FREQuency"

CALCulate:SMONitor:MARKer[<n>]:STATe

Function

This command sets which markers are turned on.

There are three markers <n> (1 to 3) that can be set. If no <n> is specified, marker 1 is used.
Setting

Range: 1|ON|0|OFF

Query

Range: 1|ON|0|OFF
*RST Setting OFF

Programming Example

OUTPUT 714;"CALCulate:SMONitor:MARKer2:STATE 1" !Turns on marker 2.

CALCulate:SMONitor:MARKer[<n>]:TIME

Function

This command sets/queries the time at marker <n>. where <n> is a number 1 through 3. When no marker number is specified, marker 1 is used.

If you are using delta marker mode, this command sets/queries the delta offset time. (See CALCulate:SMONitor:MARKer[<n>] :MODE .)
Setting

Range: -50 ms to 10070 ms
Resolution: 0.25 us

Query

Range: -50 ms to 10070 ms
Resolution: 0.25 us
*RST Setting 5 ms

Programming Example

OUTPUT 714;"CALCulate:SMONitor:MARKer2:TIME 30" !Places marker 2 at 30 ms.


CALibration

CALibration

Last updated: July 18, 2007

GPIB Command Conventions

  • CALibration:BMOFfset?
  • CALibration:CPOWer?
  • CALibration:DAPower?
  • CALibration:IQ[1]?
  • CALibration:IQ2?
  • CALibration:DATE
  • CALibration:SMONitor

CALibration:BMOFfset?

Function

Initiates Burst Modulator Offset DAC calibration for RF source 1. See Calibrating the Test Set .

It takes about fifty seconds to complete. It can't be aborted except by cycling the power switch.

When this calibration has completed, a value is returned to indicate the success or failure of calibration.

Requirements

 Test Application Revision: A.03 and above
Lab Application Revision: A.01 and above

Query

Range

  • 0 = Pass
  • -340 = Fail

Programming Example

OUTPUT 714;"CALibration:BMOFfset?"
!Initiates Burst Modulator Offset DAC calibration for RF source 1
!and returns a value (0 or -340) after completing the calibration.

CALibration:CPOWer?

Function

Initiates IF level calibration used by access probe power and channel power measurements.

No other GP-IB commands are processed until this calibration has completed.

Query

Range

  • 0 = Calibration passed
  • 1 = Channel power calibration failed due to temperature drift. Wait for temperature to stabilize.
  • 2 = Channel power calibration failed due to oven temperature out of range.
  • 3 = Channel power calibration failed due to loopback switch problem.
  • 7 = Channel power calibration failed due to source level problem.
  • -340 = Calibration failed

Programming Example

OUTPUT 714;"CALibration:CPOWer?"
!Initiates the IF level calibration process and queries the pass/fail result.

CALibration:DAPower?

Function

Initiates digital average power measurement calibration.

RF power must not be applied to the test set's front panel RF IN/OUT connector during calibration.

Digital average power measurement calibration will take about 10 minutes.

Power must be cycled when digital average power measurement calibration has completed.

No other GP-IB commands are processed until this calibration has completed.

Query

Range

  • 0 = Calibration passed
  • 1 = Digital average power calibration failed due to temperature drift. Wait for temperature to stabilize.
  • 2 = Digital average power calibration failed due to oven temperature out of range.
  • 3 = Digital average power calibration failed due to loopback switch problem.
  • -340 = Calibration failed

Programming Example

OUTPUT 714;"CALibration:DAPower?"
!Initiates the digital average power measurement calibration process and queries the pass/fail result.

CALibration:IQ[1]?

Function

Sets/queries the calibration of the IQ modulator for RF generator 1. It takes some time to complete calibration and can't be aborted except by cycling the power switch.

  • Calibrates the IQ modulator for RF generator 1.
  • Returns a value indicating success or failure of calibration.

Query

Range

  • 0 = Pass
  • -340 = Fail

Programming Example

OUTPUT 714;"CALibration:IQ1?"
!Performs a calibration of the IQ modulator for RF generator 1 and returns 0 or -340

NOTE
When the calibration is done the test set display will display:

IQ Calibration completed successfully for modulator 1.

CALibration:IQ2?

Function

Sets/queries the calibration of the IQ modulator for RF generator 2. It takes some time to complete calibration and can't be aborted except by cycling the power switch.

  • Calibrates the IQ modulator for RF generator 2.
  • Returns a value indicating success or failure of calibration.

Query

Range

  • 0 = Pass
  • -340 = Fail

Programming Example

OUTPUT 714;"CALibration:IQ2?"
!Performs a calibration of the IQ modulator for RF generator 2 and returns 0 or -340

NOTE
When the calibration is done the test set display will display:

IQ Calibration completed successfully for modulator 2.

CALibration:DATE

Function

Sets/queries the date of the last system calibration done to the test set; not the IQ calibration date. Returns a comma separated list YYYY,MM,DD in that order.
Setting

Sets the system calibration date.

Range

  • Year = 0000 to 9999

  • Month = 01 to 12

  • Day = 01 to 31

Query

Returns the date when system calibration was performed.

Range

  • Year = 0000 to 9999

  • Month = 1 to 12

  • Day = 1 to 31

Programming Example

OUTPUT 714;"CALibration:DATE 1999,01,04"
!Sets the date of the last system calibration year, month and day.

CALibration:SMONitor

Function

Starts the spectrum monitor calibration routine. It is important that no power is applied to the RF IN/OUT connector during calibration.

Query

Range: 0 through 10, and -340

  • 0 (Spectrum Monitor calibration completed successfully)
  • 1 (Spectrum Monitor calibration failed due to temperature drift. Wait for temperature to stabilize)
  • 2 (Spectrum Monitor calibration failed due to oven out of range)
  • 3 (Spectrum Monitor calibration failed due to loopback switch problem)
  • 4 (Spectrum Monitor calibration failed due to under range condition)
  • 5 (Spectrum Monitor calibration failed due to over range condition)
  • 6 (Spectrum Monitor calibration failed due to correlation problem)
  • 7 (Spectrum Monitor calibration failed due to source level problem)
  • 8 (Spectrum Monitor calibration failed due to IF filter coefficient problem)
  • 9 (Spectrum Monitor calibration failed due to IF frequency response problem)
  • 10 (Spectrum Monitor calibration failed due to waveform quality problem)
  • -340 (Spectrum Monitor calibration failed)

Programming Example

OUTPUT 714;"CALibration:SMONitor?" !Queries the spectrum monitor calibration.

See Also

  • CALibration Subsystem


CALibration Subsystem

CALibration Subsystem

Last updated: October 28, 2004

Calibration Strategy

Various calibration routines must be run to ensure measurement accuracy. The type of calibration and appropriate intervals for performing calibrations vary with each test application. See Calibrating the Test Set for more information.

Syntax Diagram and Command Descriptions

CALibration


CALL:ACC

CALL:ACC

Last updated: July 18, 2007

GPIB Command Conventions

  • CALL:ACC[:CHANnel][:SELected]
  • CALL:ACC[:CHANnel]:CELLular

CALL:ACC[:CHANnel][:SELected]

Function

 Specifies the RF channel number of the analog control channel (cellular band is inferred).

Setting

 range: 1 to 799, 991 to 1023

Query

range: 1 to 799, 991 to 1023

*RST Setting

333

Programming Example

OUTPUT 714;"CALL:ACC:CHANNEL:SELECTED 799" !Sets the analog control channel to 799.

CALL:ACC[:CHANnel]:CELLular

Function

Specifies the RF channel number of the analog control channel (cellular band is specified).

Setting

range: 1 to 799, 991 to 1023

Query

range: 1 to 799, 991 to 1023

*RST Setting

 333

Programming Example

OUTPUT 714;"CALL:ACC:CHANNEL:CELLULAR 991" !Set cell band analog control channel to 991.


CALL:APARameter

CALL:APARameter

Last updated: July 18, 2007

GPIB Command Conventions

  • CALL[:CELL]:APARameter:POWer:INITial
  • CALL[:CELL]:APARameter:POWer:NOMinal[:OFFset]
  • CALL[:CELL]:APARameter:POWer:NOMinal:EXTended
  • CALL[:CELL]:APARameter:POWer:STEP[:LEVel]
  • CALL[:CELL]:APARameter:POWer:STEP:COUNt
  • CALL[:CELL]:APARameter:PREamble
  • CALL[:CELL]:APARameter:SEQuence:REQuest[:MAXimum]
  • CALL[:CELL]:APARameter:SEQuence:RESPonse[:MAXimum]

CALL[:CELL]:APARameter:POWer:INITial

Function

Sets/queries the initial power correction the mobile station will apply to the open loop equation to adjust power during system access (when transmitting the initial access probe in an access probe sequence). See also Setting Access Parameters .

Setting

Range: -16 to 15 dB

Resolution: 1 dB

Query

Range: -16 to 15 dB

Resolution: 1 dB

*RST Setting

 0 dB

Programming Example

OUTPUT 714;"CALL:APARameter:POWer:INITial -10"
!Sets the initial power to -10 dB.

CALL[:CELL]:APARameter:POWer:NOMinal[:OFFset]

Function

Sets/queries the nominal power offset. This offset value serves as a correction factor to the open loop power control equation. See also Setting Access Parameters .

Setting

Range: -8 to 7 dB with nominal power extended set to 0 (false). See CALL[:CELL]:APARameter:POWer:NOMinal:EXTended .

Resolution: integer

Query

Range: -8 to 7 dB with nominal power extended set to 0 (false). See CALL[:CELL]:APARameter:POWer:NOMinal:EXTended .

Resolution: integer

*RST Setting

 0 dB

Programming Example

OUTPUT 714;"CALL:APARameter:POWer:NOMinal -5"
!Sets the nomiinal power offset to -5 dB.

CALL[:CELL]:APARameter:POWer:NOMinal:EXTended

Function

Sets/queries extended nominal power. See also Setting Access Parameters .

Setting this parameter to 1 (true) introduces a -16 dB offset to the open loop power control correction range. The extended nominal power range is from -24 dB to -9 dB inclusive.

With this parameter set to 0 (false) the open loop power control correction range is -8 dB to 7 dB. See CALL[:CELL]:APARameter:POWer:NOMinal[:OFFset] .

Setting

Range: 1|ON|0|OFF

Query

Range: 1|0

*RST Setting

 0

Programming Example

OUTPUT 714;"CALL:APARameter:POWer:NOMinal:EXTended ON"

CALL[:CELL]:APARameter:POWer:STEP[:LEVel]

Function

Sets/queries the power increase between each mobile station access probe in an access probe sequence. See also Setting Access Parameters .

Setting

Range: 0 to 7 dB per step

Resolution: integer

Query

Range: 0 to 7 dB per step

Resolution: integer

*RST Setting

 3 dB

Programming Example

OUTPUT 714;"CALL:APARameter:POWer:STEP 5"
!Sets the power step size to 5 dB per step.

CALL[:CELL]:APARameter:POWer:STEP:COUNt

Function

Sets/queries the maximum number of power level steps in an access probe sequence. See also Setting Access Parameters .

Setting

Range: 0 to 7

Query

Range: 0 to 7

*RST Setting

 3

Programming Example

OUTPUT 714;"CALL:APARameter:POWer:STEP:COUNt 5"
!Sets the number of access probes in a single access probe sequence to 5.

CALL[:CELL]:APARameter:PREamble

Function

Sets/queries the access parameters message preamble length. The access channel preamble length is expressed in units of 20 millisecond frames. See also Setting Access Parameters .

Setting

Range: 0 to 15

Resolution: integer

Query

Range: 0 to 15

Resolution: integer

*RST Setting

 10

Programming Example

OUTPUT 714;"CALL:APARameter:PREamble 5"
!Sets the preamble size to 5.

CALL[:CELL]:APARameter:SEQuence:REQuest[:MAXimum]

Function

Sets/queries the maximum request sequence, which is the number of access probe sequences the mobile station will transmit per access channel (ACH) or enhanced channel (EACH) request (for example, autonomous access attempt by mobile station such as a mobile originated call).

See also Setting Access Parameters and Setting Enhanced Access Parameters .

Setting

Range: 1 to 15

Resolution: integer

Query

Range: 1 to 15

Resolution: integer

*RST Setting

 1

Programming Example

OUTPUT 714;"CALL:CELL:APARAMETER:SEQUENCE:REQUEST:MAXIMUM 5"
!Sets the maximum number of access probes the mobile station will
!transmit per access channel request to 5.

CALL[:CELL]:APARameter:SEQuence:RESPonse[:MAXimum]

Function

Sets/queries the maximum response sequence, which is the maximum number of access probe sequences the mobile station will transmit per access channel (ACH) or enhanced access channel (EACH) response to a base station message (such as a page).

See also Setting Access Parameters and Setting Enhanced Access Parameters .

Setting

Range: 1 to 15

Resolution: integer

Query

Range: 1 to 15

Resolution: integer

*RST Setting

 1

Programming Example

OUTPUT 714;"CALL:CELL:APARAMETER:SEQUENCE:RESPONSE:MAXIMUM 5"
!Sets the maximum number of access probes the mobile station will
!transmit per access channel response to 5.


CALL:AVCTest

CALL:AVCTest

Last updated: July 18, 2007

GPIB Command Conventions

  • CALL:AVCTest:AVC:SATone:STATe

CALL:AVCTest:AVC:SATone:STATe

Function

 Turns SAT on or off. Applies only in AVC test mode. In active cell mode SAT state is not controlled by the user.

Setting

Range: 1|ON|0|OFF

Query

Range: 1|0

*RST Setting

1 (on)

Programming Example

OUTPUT 714;"CALL:AVCTEST:AVC:SATONE:STATE 0" !Turns the supervisory audio tone off.


CALL:AWGNoise

CALL:AWGNoise

Last updated: July 18, 2007

GPIB Command Conventions

  • CALL:AWGNoise[:INTernal]:POWer[:SAMPlitude]<[:SELected]|:DIGital2000|:DIGital95>
  • CALL:AWGNoise[:INTernal]:POWer:AMPLitude<[:SELected]|:DIGital2000|:DIGital95>
  • CALL:AWGNoise[:INTernal]:POWer:STATe<[:SELected]|:DIGital2000|:DIGital95>

CALL:AWGNoise[:INTernal]:POWer[:SAMPlitude]<[:SELected]|:DIGital2000|:DIGital95>

Function

The setting form of this command performs two functions: (1) sets the additive white gaussian noise (AWGN) level and (2) turns the AWGN on/off state to on. The query form returns the AWGN power level or NAN.

The optional [:SELected] keyword in this command specifies that the AWGN power level being queried applies to the current system type.

AWGN and cell power (see CALL:POWer ) are absolute power levels and make up the total forward channel RF output power.

The return value for this query is not necessarily the AWGN power level being transmitted by the test set at the moment this command is processed by the test set. It may return a value that the test set has been requested to transmit, but that has been pended or delayed for some reason. See Troubleshooting Setting Power Levels for possible causes. To query the AWGN power level the test set is transmitting at the moment the command is sent, use the CALL:STATus:AWGNoise[:INTernal]:POWer[:AMPLitude][:SELected]? command.

Setting

Range:

  • -170 dBm/1.23 MHz to +35 dBm/1.23 MHz, 9.91 E+37
    (-120 dBm/1.23MHz to -15 dBm/1.23 MHz actual hardware range with amplitude offset = 0)

    The actual power range is defined by adding the value of the associated Amplitude Offset to the range shown above. See Cell Power, AWGN Power and Total RF Power Ranges .

Resolution: 0.01 dB

Query

Range: Same as setting range.

Resolution: 0.01 dB

*RST Setting

 -54 dBm/1.23MHz

Programming Example

OUTPUT 714;"CALL:AWGNOISE:POWER:SAMPLITUDE -30" !Sets the AWGN power level to -30 dBM/1.23 MHz and turns the state on.

CALL:AWGNoise[:INTernal]:POWer:AMPLitude<[:SELected]|:DIGital2000|:DIGital95>

Function

Sets/queries the additive white gaussian noise (AWGN) level.

The optional [:SELected] keyword in this command specifies that the AWGN power level being queried applies to the current system type.

AWGN and cell power (see CALL:POWer ) are absolute power levels and make up the total forward channel RF output power.

The return value for this query is not necessarily the AWGN power level being transmitted by the test set at the moment this command is processed by the test set. It may return a value that the test set has been requested to transmit, but that has been pended or delayed for some reason. See Troubleshooting Setting Power Levels for possible causes. To query the AWGN power level the test set is transmitting at the moment the command is sent, use the CALL:STATus:AWGNoise[:INTernal]:POWer[:AMPLitude][:SELected]? command.

Setting

Range:

  • -170 dBm/1.23 MHz to +35 dBm/1.23 MHz, 9.91 E+37
    (-120 dBm/1.23MHz to -15 dBm/1.23 MHz actual hardware range with amplitude offset = 0)

    The actual power range is defined by adding the value of the associated Amplitude Offset to the range shown above. See Cell Power, AWGN Power and Total RF Power Ranges .

Resolution: 0.01 dB

Query

Range: Same as setting range.

Resolution: 0.01 dB

*RST Setting

 -54 dBm

Programming Example

OUTPUT 714;"CALL:AWGNOISE:POWER:AMPLITUDE -30" !Set the AWGN level to -30 dBM/1.25 MHz.

CALL:AWGNoise[:INTernal]:POWer:STATe<[:SELected]|:DIGital2000|:DIGital95>

Function

Sets/queries the additive white gaussian noise (AWGN) state.

The return value for this query is not necessarily the AWGN power state at the moment this command is processed by the test set. This command may return a state that has been requested of the test set, but that has been pended or delayed for some reason. See Troubleshooting Setting Power Levels for possible causes. To query the AWGN power state of the test set at the moment, use the CALL:STATus:AWGNoise[:INTernal]:POWer:STATe[:SELected]? command.

The optional [:SELected] keyword in this command specifies that this query applies to the current system type.

Setting

Range: 1|ON|0|OFF

Query

Range: 1|0

*RST Setting

OFF

Programming Example

OUTPUT 714;"CALL:AWGNOISE:POWER:STATE:SELECTED ON" !Turns on AWGN.


CALL:BAND

CALL:BAND

Last updated: July 18, 2007

GPIB Command Conventions

  • CALL[:CELL]:BAND<[:SELected]|:DIGital2000|:DIGital95>

CALL[:CELL]:BAND<[:SELected]|:DIGital2000|:DIGital95>

Function

Sets/queries a frequency band for the specified system type. See Cell Band .

The optional [:SELected] keyword in this command specifies that the frequency band being set/queried applies to the current system type.

Setting

Range: IMT2000|JCDMa|KPCS |NMT450|SECondary800|USCellular|USPCs|USPCs1900|AWService

Query

Range: IMT2000|JCDM|KPCS|NMT450|SEC800|USC|USPC|USPC1900|AWS

*RST Setting

USPCs

Requirements

Test Application Revision: B.03.00: Added secondary 800 MHz band, deleted China Cellular band.

Test Application Revision: B.11: Added US PCS 1900 band.

Test Application Revision: B.12: Added AWS band.

Programming Example

OUTPUT 714;"CALL:BAND KPCS" !Selects the Korean PCS cell band.


CALL:BCCHannel

CALL:BCCHannel

Last updated: July 18, 2007

GPIB Command Conventions

  • CALL[:CELL]:BCCHannel[:SLEVel]<[:SELected]|:DIGital2000>
  • CALL[:CELL]:BCCHannel:DRATe
  • CALL[:CELL]:BCCHannel:LEVel<[:SELected]|:DIGital2000>
  • CALL[:CELL]:BCCHannel:STATe<[:SELected]|:DIGital2000>

CALL[:CELL]:BCCHannel[:SLEVel]<[:SELected]|:DIGital2000>

Function

The setting form of this command performs two functions: (1) sets the forward broadcast control channel (F-BCCH) level, and (2) turns the F-BCCH on/off state to ON. The query form returns the F-BCCH level. See Configuring Forward Channel Power Levels and Walsh Codes .

The optional [:SELected] keyword in this command specifies that the F-BCCH level and state being set/queried applies to the current system type ( CALL:STATus:CELL:SYSTem[:TYPE]? ).

Setting

 Range: 0 to -20 dB
Resolution: 0.0001 dB

Query

Range: same as setting

*RST Setting

 -15.2 dB

Requirements

Test Application Revision: B.08 and above, with the required feature license

Lab Application Revision: B.02 and above

Programming Example

OUTPUT 714;"CALL:BCCHannel -10"
!Sets F-BCCH state to on and its level to -10 dB.

CALL[:CELL]:BCCHannel:DRATe

Function

Sets/queries the coding rate, frame size and data rate of the forward broadcast control channel (F-BCCH). See F-BCCH Data Rate .

Setting

Range: H40Bps4800|H40Bps9600|H40Bps19200

H40Bps4800 - Half (1/2) code rate, 40 ms frame size, 4800 bps data rate
H40Bps9600 - Half (1/2) code rate, 40 ms frame size, 9600 bps data rate
H40Bps19200 - Half (1/2) code rate, 40 ms frame size, 19200 bps data rate

Query

Range: H40B4800|H40B9600|H40B19200

*RST Setting

H40Bps9600

Requirements

Test Application Revision: B.08 and above, with the required feature license

Lab Application Revision: B.02 and above

Programming Example

OUTPUT 714;"CALL:BCCHannel:DRATe H40Bps4800"
!Sets the F-BCCH data rate to 4.8 kbps
!with 1/2 code rate and 40 ms frame size.

CALL[:CELL]:BCCHannel:LEVel<[:SELected]|:DIGital2000>

Function

Sets/queries the F-BCCH level. See Current Level and Desired Level

The optional [:SELected] keyword in this command specifies that the F-BCCH level and state being set/queried applies to the current system type ( CALL:STATus:CELL:SYSTem[:TYPE]? ).

Setting

 Range: 0 to -20 dB
Resolution: 0.0001 dB

Query

Range: same as setting

*RST Setting

 -15.2 dB

Requirements

Test Application Revision: B.08 and above, with the required feature license

Lab Application Revision: B.02 and above

Programming Example

OUTPUT 714;"CALL:BCCHannel:LEVel -10"
!Sets F-BCCH level to -10 dB

CALL[:CELL]:BCCHannel:STATe<[:SELected]|:DIGital2000>

Function

Sets/queries the forward F-BCCH channel on/off state. See Current Level and Desired Level .

The optional [:SELected] keyword in this command specifies that the F-BCCH level and state being set/queried applies to the current system type ( CALL:STATus:CELL:SYSTem[:TYPE]? ).

Setting

 Range: 1|ON|0|OFF

Query

Range: 1|0

*RST Setting

 1 (on)

Requirements

Test Application Revision: B.08 and above, with the required feature license

Lab Application Revision: B.02 and above

Programming Example

OUTPUT 714;"CALL:BCCHannel:STATe OFF"
!Sets the F-BCCH channel state to off.


CALL:BIDentity

CALL:BIDentity

Last updated: July 18, 2007

GPIB Command Conventions

  • CALL[:CELL]:BIDentity

CALL[:CELL]:BIDentity

Function

Sets/queries the base station identification number (Base ID). See Setting Cell Parameters .

Setting

Range: 0 to 65535

Query

Range: 0 to 65535

*RST Setting

39

Requirements

Test Application Revision: B.10 or above

Lab Application Revision: B.03.10 or above

Programming Example

OUTPUT 714;"CALL:BIDentity 200"
!Sets base station identification to 200.


CALL:CCCHannel

CALL:CCCHannel

Last updated: July 18, 2007

GPIB Command Conventions

  • CALL[:CELL]:CCCHannel[:SLEVel]<[:SELected]|:DIGital2000>
  • CALL[:CELL]:CCCHannel:DRATe
  • CALL[:CELL]:CCCHannel:LEVel<[:SELected]|:DIGital2000>
  • CALL[:CELL]:CCCHannel:STATe<[:SELected]|:DIGital2000>

CALL[:CELL]:CCCHannel[:SLEVel]<[:SELected]|:DIGital2000>

Function

The setting form of this command performs two functions: (1) sets the forward common control channel (F-CCCH) level, and (2) turns the F-CCCH on/off state to ON. The query form returns the F-CCCH level. See Current Level and Desired Level .

The optional [:SELected] keyword in this command specifies that the F-CCCH level and state being set/queried applies to the current system type ( CALL[:CELL]:SYSTem[:TYPE] ).

Setting

 Range: 0 to -20 dB
Resolution: 0.0001 dB

Query

Range: same as setting

*RST Setting

 -12.0 dB

Requirements

Test Application Revision: B.08 and above, with the required feature license

Lab Application Revision: B.02 and above

Programming Example

OUTPUT 714;"CALL:CCCHannel -10"
!Sets F-CCCH state to on and its level to -10 dB.

CALL[:CELL]:CCCHannel:DRATe

Function

Sets/queries the coding rate, frame size and data rate of the forward common control channel (F-CCCH). See F-CCCH Data Rate .

Setting

Range: Q20Bps9600|H20Bps9600|H20Bps19200

Q20Bps9600 - Quarter (1/4) code rate, 20 ms frame size, 9600 bps data rate
H20Bps9600 - Half (1/2) code rate, 20 ms frame size, 9600 bps data rate
H20Bps19200 - Half (1/2) code rate, 20 ms frame size, 19200 bps data rate

Query

Range: Q20B9600|H20B9600|H20B19200

*RST Setting

H20Bps9600

Requirements

Test Application Revision: B.08 and above, with the required feature license

Lab Application Revision: B.02 and above

Programming Example

OUTPUT 714;"CALL:CCCHannel:DRATe H20B19200"
!Sets the F-CCCH data rate to 9.6 kbps
!with 1/2 code rate and 20 ms frame size.

CALL[:CELL]:CCCHannel:LEVel<[:SELected]|:DIGital2000>

Function

Sets/queries the F-CCCH level. See Current Level and Desired Level

The optional [:SELected] keyword in this command specifies that the F-CCCH level and state being set/queried applies to the current system type ( CALL[:CELL]:SYSTem[:TYPE] ).

Setting

 Range: 0 to -20 dB
Resolution: 0.0001 dB

Query

Range: same as setting

*RST Setting

 -12.0 dB

Requirements

Test Application Revision: B.08 and above, with the required feature license

Lab Application Revision: B.02 and above

Programming Example

OUTPUT 714;"CALL:CCCHannel:LEVel -10"
!Sets F-CCCH level to -10 dB

CALL[:CELL]:CCCHannel:STATe<[:SELected]|:DIGital2000>

Function

Sets/queries the F-CCCH channel on/off state. See Current Level and Desired Level .

The optional [:SELected] keyword in this command specifies that the F-CCCH level and state being set/queried applies to the current system type ( CALL[:CELL]:SYSTem[:TYPE] ).

Setting

 Range: 1|ON|0|OFF

Query

Range: 1|0

*RST Setting

 1 (on)

Requirements

Test Application Revision: B.08 and above, with the required feature license

Lab Application Revision: B.02 and above

Programming Example

OUTPUT 714;"CALL:CCCHannel:STATe OFF"
!Sets the F-CCCH channel state to off.


CALL:CHANnel

CALL:CHANnel

Last updated: July 18, 2007

GPIB Command Conventions

  • CALL:CHANnel[:SELected][:SELected]

CALL:CHANnel[:SELected][:SELected]

Function

Sets/queries the physical channel number for the specified system type and specified cell band. See RF Channel Number .

The first optional [:SELected] mnemonic specifies that the channel being set/queried applies to the current system type (see CALL[:CELL]:SYSTem[:TYPE] ). To set (make current) a system type, use the CALL:SYSTem commands.

The second optional [:SELected] mnemonic specifies that the channel being set/queried applies to the current cell band.

Note: If the current system type evaluates to DIGital95, cell band IMT2000 does not apply and attempting to specify IMT2000 as the DIGital95 cell band will cause an instrument error.

Specifying a non-current band when setting a channel number will cause the test set to store the channel number for use when the specified band is made current. Also, specifying a non-current band when querying a channel number will return a stored channel number that is not the current channel the test set is transmitting.

To set (make current) a frequency band or query the current frequency band, use the CALL:BAND command.

Setting

Range (depending on selected system type and band class):

  • IMT2000: 0 to 1199

  • JCDMa (Japanese CDMA): 1 to 799, 801 to 1039, 1041 to 1199

  • KPCS (Korean PCS): 0 to 599

  • NMT450: 1 to 400, 472to 871, 1039 to 1473, 1536 to 1715, 1792 to 2016

  • SECondary800 (secondary 800 MHz band): 0 to 919

  • USCellular (U.S. Cellular): 1 to 799, 991 to 1023, 1024 to 1323

  • USPCs (U.S. PCS): 0 to 1199

  • USPCs1900: 0 to 1299

  • AWService: 0 to 899

Resolution: 1

Query

Same as setting.

*RST Setting
  • [:SELected]: 525 (because *RST causes the cell band to be set to US PCS)
  • IMT2000: 525
  • JCDMa: 76
  • KPCS: 325
  • NMT450: 210
  • SECondary800: 820
  • USCellular: 384
  • USPCs: 525
  • USPCs1900: 525
  • AWService: 300

Requirements

Test Application Revision: B.03 and above: Added secondary 800 MHz band, deleted China cellular band;
Test Application Revision: B.10 and above: channel range of USCellular extended to include 1024 to 1323

Lab Application Revision: B.01 and above

Lab Application Revision: B.03.10 and above: channel range of USCellular extended to include 1024 to 1323

Test Application Revision: B.11 and above: Support USPCs1900 channels

Lab Application Revision: B.04 and above: Support USPCs1900 channels

Test Application Revision: B.12 and above: Support AWService channels

Lab Application Revision: B.05 and above: Support AWService channels

Programming Example

OUTPUT 714;"CALL:CHANNEL?"
!Queries the channel number of the currently selected system and band.

OUTPUT 714;"CALL:CHANNEL 384"
!Sets the channel number of the currently selected system and band.

OUTPUT 714;"CALL:CHANNEL:DIGital2000:KPCS 384"
!Sets the channel number for the Digital 2000 system and Korean PCS band to 384. If this system and
!band are not current the value 384 is stored and will be transmitted when Digital 2000 and Korean
!PCS are current.


CALL:CIDentity

CALL:CIDentity

Last updated: June 6, 2007

GPIB Command Conventions

  • CALL:CIDentity

CALL:CIDentity

Function

Sets/queries the originating address to be supplied with the SMS message to the mobile station. It also sets Call-Back Number value when the Call-Back Number subparameter is included in the SMS message to be sent to the mobile station (determined by the CALL:SMService:MTERminated:CBNumber )

Setting

Range: 0 to 14 characters enclosed by quotes, each character from the set of 0123456789#*

Query

Range: same as setting

*RST Setting

"5099214001"

Requirements

Test Application Revision: B.07 and above

Lab Application Revision: B.00 and above

Programming Example

OUTPUT 714;"CALL:CIDentity '#0123456789*'"
!Sets the SMS originating address to #0123456789*.


CALL:CLPControl

CALL:CLPControl

Last updated: June 6, 2007

GPIB Command Conventions

  • CALL[:CELL[1]]:CLPControl:REVerse:MODE<[:SELected]|:TA2000>
  • CALL[:CELL[1]]:CLPControl:REVerse:TRANsient:MODE
  • CALL[:CELL[1]]:CLPControl:REVerse:TRANsient:SPRamp
  • CALL[:CELL[1]]:CLPControl:REVerse:TRANsient:STARt
  • CALL[:CELL]:CLPControl:REVerse:STEP

CALL[:CELL[1]]:CLPControl:REVerse:MODE<[:SELected]|:TA2000>

Function

Sets/queries the Cell 1 Rvs CLPC (reverse CDMA channel closed loop power control) mode. To set Cell 2 Rvs CLPC mode for the lab application, see CALL:CELL2:CLPControl:REVerse:MODE .

  • When ACTive is selected (only available when Operating Mode is Active Cell), the test set will send power control bits that raise or lower the power level of the mobile station depending on the received signal strength of the reverse channel.
  • When UP is selected, the test set sends all 0 (up) power control bits.
  • When DOWN is selected, the test set sends all 1 (down) power control bits.
  • When ALTernating is selected, the test set sends alternating up (0)/down (1) power control bits.
  • When ALT20 ( available only in Lab Application ) is selected, the test set sends a periodic sequence of 20 up power control bits followed by 20 down power control bits.

    NOTE
    In a fast switching application (such as E1985E), the :SELect, :TA856 and :TA2000 format mnemonics access the single shared setting value. It is recommended to use the CALL:CLPControl:REVerse:MODE (without any format mnemonic) to set the reverse closed loop power control mode.

Setting

Test Application Range: ACTive|UP|DOWN|ALTernating

Lab Application Range: ACTive|UP|DOWN|ALTernating|ALT20

Query

 Same as setting.

*RST Setting

 ACTive

Requirements

Test Application Revision: B.07 and above: Added [:SELected]
and TA2000 mnemonics

Lab Application Revision: B.01 and above: Added [:SELected]
and TA2000 mnemonics

Programming Example

OUTPUT 714;"CALL:CLPControl:REVerse:MODE ALTernating"
!Sets the closed loop power control mode to alternating up, down bits.

CALL[:CELL[1]]:CLPControl:REVerse:TRANsient:MODE

Function

Sets/queries the reverse closed loop power control transient modes which determine the number and direction of the ramp(s) of the power control transient. See Setting Reverse CLPC Transient Parameters for details.

Setting

Range: UP|DOWN|UDUP

Query

 Same as setting.

*RST Setting

 UP

Requirements

Test Application Revision: B.07 and above

Lab Application Revision: B.01 and above

Programming Example

OUTPUT 714;"CALL:CLPControl:REVerse:TRANsient:MODE UDUP"
!Sets the closed loop power control transient mode to 3 ramps,up-down-up.

CALL[:CELL[1]]:CLPControl:REVerse:TRANsient:SPRamp

Function

Sets/queries the number of power control steps per ramp of the reverse closed loop power control transient. If the CALL[:CELL[1]]:CLPControl:REVerse:TRANsient:MODE is set to UDUP then the total transient steps will be three times of this setting. See Setting Reverse CLPC Transient Parameters .

Setting

Range: 2 to 400
Resolution: 1

Query

same as setting

*RST Setting

 20

Requirements

Test Application Revision: B.07 and above

Lab Application Revision: B.01 and above

Programming Example

OUTPUT 714;"CALL:CLPCONTROL:REVerse:TRANsient:SPRamp 100"
!Sets the closed loop power control transient steps per ramp to 100.

CALL[:CELL[1]]:CLPControl:REVerse:TRANsient:STARt

Function

Starts the closed loop power control transient transmission. See Starting the Reverse CLPC Transient for details.

Use CALL:STATus:CLPControl[:CELL[1]]:REVerse:TRANsient:STATe? to verify whether the closed loop power control transient is being transmitted.

Requirements

Test Application Revision: B.07 and above

Lab Application Revision: B.01 and above

Programming Example

OUTPUT 714;"CALL:CLPCONTROL:REVerse:TRANsient:STARt"
!Starts the closed loop power control transient transmission.

CALL[:CELL]:CLPControl:REVerse:STEP

Function

Sets/queries the Rvs CLPC (reverse closed loop power control) step size. This setting tells the mobile station how much to increase or decrease its output power in response to a power control bit.

NOTE
For the lab application, both Cell 1 and Cell 2 use this command to set the Rvs CLPC step size.

Setting

Range: DB1|DBHalf|DBQuarter
(DB1: 1 dB, DBHalf: 0.5 dB, DBQuarter: 0.25 dB)

Query

Range: DB1|DBH|DBQ

*RST Setting

 DB1 (1 dB)

Programming Example

OUTPUT 714;"CALL:CLPCONTROL:REVerse:STEP DBQuarter"
!Sets the closed loop power control step size to 0.25 dB.

Related Topics

CALL:CELL2:CLPControl ( Lab Application Only )


CALL:CONNected

CALL:CONNected

Last updated: June 6, 2007

GPIB Command Conventions

  • CALL:CONNected[:STATe]?
  • CALL:CONNected:ARM[:IMMediate]
  • CALL:CONNected:ARM:STATe?
  • CALL:CONNected:DROP:TIMer[:STATe]<[:SELected]|:TA2000>
  • CALL:CONNected:LIMit[:STATe]<[:SELected]|:TA2000>
  • CALL:CONNected:TIMeout

CALL:CONNected[:STATe]?

Function

Queries the connected/disconnected state of the call. A one is returned if the call is in the connected state. A zero is returned if the call is in the idle (disconnected) state. If the call is in any state other than connected or idle, the query will hang until the call state transitions to the connected or idle state.

When used in conjunction with the CALL:CONNected:ARM and CALL:CONNected:TIMeout commands, the CALL:CONNected:STATe? command allows the control program to synchronize to call connection/disconnection. See Connected/Idle Query and Call State Change Detector .

Query

Range: 0|1

*RST Setting

0

Programming Example

OUTPUT 714;"CALL:CONNected?" !Returns 1 if call is connected, 0 if call is idle.

CALL:CONNected:ARM[:IMMediate]

Function

Sets (arms) the call-state-change detector. Arming this detector allows the control program to tell the test set that it is expecting a change in the state of a call, prior to initiating the state change.

Once armed, the detector remains armed until there is a call state change to Idle or Connected from one of the transitory states, nor is it disarmed by any transitions from Idle to Idle or Connected to Connected.

When used in conjunction with the CALL CONNected:STATe? and the CALL:CONNected: TIMeout commands, the CALL:CONNected:ARM command allows the control program to synchronize with call processing state changes. See Call State Change Detector .

Programming Example

OUTPUT 714;"CALL:CONNected:ARM" !Arms the call-state-change detector.

CALL:CONNected:ARM:STATe?

Function

Queries the arm state of the call-state-change detector. This command never hangs and immediately returns a one if the detector is armed, or a zero if the detector is not armed. See Call State Change Detector .

Query

Range: 1|0

*RST Setting

0

Programming Example

OUTPUT 714;"CALL:CONNected:ARM:STATe?" !Returns arm state of the call-state-change detector.

CALL:CONNected:DROP:TIMer[:STATe]<[:SELected]|:TA2000>

Function

Sets/queries the call drop timer. The call drop timer indicates loss of reverse link. This timer also determines when the demodulation of the reverse link has been unsuccessful for a fixed period.The call drop timer is actually a counter that counts bad frames. The counter counts for 250 consecutive bad frames (which takes about 5 seconds). The counter is reset whenever a good frame is received.

Setting

Range: 1|ON|0|OFF

Query

Range: 1|0

*RST Setting

ON

Programming Example

OUTPUT 714;"CALL:CONNected:DROP:TIMer 0"

CALL:CONNected:LIMit[:STATe]<[:SELected]|:TA2000>

Function

When call limit mode is on, the test set will not respond to the access probe for origination or page responses from the mobile. For either a base station page or mobile station origination, this command forces the mobile to repeatedly send access probes.

NOTE
In a fast switching application, the :TA2000 format and :TA856 mnemonics access the single shared setting value while the :WCDMA format mnemonic accesses a separate setting value used only by the WCDMA format.

If you do not add any format mnemonic as the suffix, the command is sent to the current active format.

Setting

Range: 1|ON|0|OFF

Query

Range: 1|0

*RST Setting

OFF

Programming Example

OUTPUT 714;"CALL:CONNected:LIMit ON"

CALL:CONNected:TIMeout

Function

Sets/queries the maximum time the test set will wait for a hanging CALL:CONNected:STATe? query to complete. Default setting units are seconds. To set timeout time in units other than seconds, include an optional unit specifier in the command string.

A timeout timer is started whenever the call-state-change detector becomes armed or gets rearmed when already armed. The duration of the timeout is set using this command and should be greater than the maximum amount of time the control program needs to wait between arming the call-state-change detector and the connect/disconnect operation starting. Once the process starts and the call state has moved to one of the transitory states, the protocol timers take over and prevent the call state from staying in a transitory state forever. See Call Processing State Synchronization .

Setting

Range: 0 to 100 seconds
Resolution: 0.1 seconds

Query

Range: 0 to 100 seconds
Resolution: 0.1 seconds

*RST Setting

10 seconds

Programming Example

OUTPUT 714;"CALL:CONNected:TIMeout 3"
!Sets the CALL:CONNected:STATe? query timeout time to 3 seconds.

OUTPUT 714;"CALL:CONNected:TIMeout 500 MS"
!Sets the CALL:CONNected:STATe? query timeout time to 500 milliseconds.


CALL:CONTrol

CALL:CONTrol

Last updated: June 6, 2007

GPIB Command Conventions

  • CALL[:CELL]:CONTrol:DOWNlink:FREQuency:AUTO

CALL[:CELL]:CONTrol:DOWNlink:FREQuency:AUTO

Function

Sets/queries whether the user or the base station emulator is in control of the RF generator's CDMA forward channel frequency setting. If set to on (1), the base station emulator is in control and the frequency will automatically be set by the test set. This is done by mapping the selected CDMA physical channel number to a frequency as defined in applicable standards.

If set to off (0), the forward channel frequency is directly settable. Refer to CALL:RFGenerator to set the CDMA forward channel frequency.

Setting

Range: 1|ON|0|OFF

Query

 Range: 1|0

*RST Setting

1 (auto)

Programming Example

OUTPUT 714;"CALL:CELL:CONTROL:DOWNLINK:FREQUENCY:AUTO OFF"
!Enables manual frequency setting.


CALL:CSTime

CALL:CSTime

Last updated: June 6, 2007

GPIB Command Conventions

  • CALL[:CELL]:CSTime:DATE
  • CALL[:CELL]:CSTime:DSTime
  • CALL[:CELL]:CSTime:LOCal:LEAP
  • CALL[:CELL]:CSTime:LOCal:OFFSet:[SELected]
  • CALL[:CELL]:CSTime:LOCal:OFFSet:TA2000
  • CALL[:CELL]:CSTime:TIME

CALL[:CELL]:CSTime:DATE

Function

Sets/queries the date portion of the CDMA system time, which is corresponding to UTC time (Universal Coordinated Time) without the leap seconds and is sent to the mobile station in the Sync Channel Message (SCHM) .

It is not impacted by full preset operations.

Setting

Range: from January 6, 1980 to January 5, 2080

  • <year> 1980 to 2080
  • <month> 1 to 12 (the number 1 corresponds to January)
  • <day> 1 to the number of days in the month specified by the <month> parameter

Query

Range: January 6, 1980 to January 5, 2096

  • <year> 1980 to 2096
  • <month> 1 to 12 (the number 1 corresponds to January)
  • <day> 1 to the number of days in the month specified by the <month> parameter
  • -1, -1, -1 (When the Operating Mode is not Active Cell or IS-2000 Test Mode or the System Type is not in IS-95 or IS-2000 )

Requirement

Test Application revision: B.10 and above

Lab Application revision: B.03 and above

*RST Setting

CDMA system time keeps going and is not affected by *RST.

Programming Example

OUTPUT 714;"CALL:CSTime:DATE 2005,8,1"
!Sets the date to August 1, 2005.
OUTPUT 714;"CALL:CSTime:DATE?"
!Returns +2005,+8,+1 if the date in the test set happens to be August 2, 2005 when queired.

CALL[:CELL]:CSTime:DSTime

Function

Sets/queries the daylight saving time status that is sent to the mobile station in the Sync Channel Message (SCHM) . It is not included in the CDMA Local Time calculation (See CALL:STATus:CSTime:LOCal:TIME? ).

It is not impacted by power cycle, full preset or Save/Recall operations.

Setting

Range: ON(1) | OFF(0)

Query

Range: same as setting

Requirement

Test Application revision: B.10 and above

Lab Application revision: B.03 and above

*RST Setting

OFF (when shipped form the factory)

What you set is stored in the NVRAM and is not affected by *RST.

Programming Example

OUTPUT 714;"CALL:CSTIME:DSTIME ON"
!Enables daylight saving time.

CALL[:CELL]:CSTime:LOCal:LEAP

Function

Sets/queries the number of leap seconds since the start of CDMA system time. The value of leap seconds is sent to the mobile station in the Sync Channel Message (SCHM) and is used to calculate the local time. See CALL:STATus:CSTime:LOCal:TIME? .

It is not impacted by power cycle, full preset or Save/Recall operations.

Setting

Range: 0 to 255

Resolution: 1 second

Query

Range: same as setting

Requirement

Test Application revision: B.10 and above

Lab Application revision: B.03 and above

*RST Setting

 0 (when shipped form the factory),

What you set is stored in the NVRAM and is not affected by *RST.

Programming Example

OUTPUT 714;"CALL:CSTIME:LOCAL:LEAP 231"
!Sets the leap seconds to 231 seconds.

CALL[:CELL]:CSTime:LOCal:OFFSet:[SELected]

Function

Sets/queries the offset of local time from CDMA system time, which will be sent to the mobile station in the Sync Channel Message (SCHM) and is used to calculate the local time. See CALL:STATus:CSTime:LOCal:TIME? . The value must be hours or half-hours, otherwise, the new value will be rounded to the nearest hour or half-hour.

It is not impacted by power cycle, full preset or Save/Recall operations.

Setting

Range: -16.00 to 15.30

<hour> -16 to 15

<minute> 0 to 59

Resolution: 30 minutes

Query

Range: same as setting

Requirement

Test Application revision: B.10 and above

Lab Application revision: B.03 and above

*RST Setting

00.00 (when shipped form the factory).

This feature is not affected by test set preset.

Programming Example

OUTPUT 714;"CALL:CSTime:LOCal:OFFSet 2,0"
!Sets local time offset to 2 hours.

CALL[:CELL]:CSTime:LOCal:OFFSet:TA2000

Function

Sets/queries the offset of local time from CDMA system time, which will be sent to the mobile station in the Sync Channel Message (SCHM) . The value must be hours or half-hours, otherwise, the new value will be rounded to the nearest hour or half-hour.

It is not impacted by power cycle, full preset or Save/Recall operations.

Setting

Range: -16.00 to 15.30

  • <hour> -16 to 15

  • <minute> 0 to 59

Resolution: 30 minutes

Query

Range: same as setting

Requirement

Test Application revision: B.10 and above

Lab Application revision: B.03 and above

*RST Setting

00.00 (when shipped form the factory).

CDMA system time keeps going and is not affected by *RST.

Programming Example

OUTPUT 714;"CALL:CSTime:LOCal:OFFSet:TA2000 2,0"
!Sets local time offset to 2 hours.

CALL[:CELL]:CSTime:TIME

Function

Sets/queries the time portion of the CDMA system time, which is corresponding to UTC time (Universal Coordinated Time) without the leap seconds and is sent to the mobile station in the Sync Channel Message ( SCHM ).

It is not impacted by power cycle, full preset operations.

NOTE

The value of CDMA System Time (Time) queried by remote user interface (RUI) has 1 second resolution. It is different from that displays in the CDMA System Time Information window where the time is updated every two seconds.

Setting

Range:

  • <hour> 0 to 23
  • <minute> 0 to 59
  • <second> 0 to 59

Resolution: 2 seconds

Query

Range:

  • <hour> 0 to 23
  • <minute> 0 to 59
  • <second> 0 to 59
  • -1, -1, -1 (When the Operating Mode is not Active Cell or IS-2000 Test Mode or the System Type is not in IS-95 or IS-2000 )

Resolution: 1 second

Requirement

Test Application revision: B.10 and above

Lab Application revision: B.03 and above

*RST Setting

CDMA system time keeps going and is not affected by *RST.

Programming Example

OUTPUT 714;"CALL:CSTIME:TIME 23,10,10"
!Sets the time portion of CDMA System Time to 23:10:10.


CALL:D2KTest

CALL:D2KTest

Last updated: June 6, 2007

GPIB Command Conventions

  • CALL:D2KTest:EIRPower[:MAXimum]
  • CALL:D2KTest:ESNumber:HEX
  • CALL:D2KTest:QPCHannel:INDicator[:PAGing]

CALL:D2KTest:EIRPower[:MAXimum]

Function

Sets/queries the test mode maximum EIRP (Effective Isotropic Radio Power). The unit defaults to dBm. It may be set in units of dBm or dBW. This parameter is displayed on the test set's front panel in units of dBW.

The test set will adjust its receiver power range expecting a normal open loop power control response from the mobile station. However, when cell power is lowered the expected power to the test set's receiver will not increase beyond max EIRP.

If an amplitude offset is turned on (see SYSTem:CORRection:[:SGAin] ), the test set will automatically adjust the max EIRP value to correct for path loss.

Setting

Range: 0 to +40 dBm (-30 to +10 dBW)

Resolution: 1 dBm

Query

Range: 0 to +40 dBm

Resolution: 1 dBm

*RST Setting

 +23 dBm

Programming Example

OUTPUT 714;"CALL:D2KTest:EIRPower -2DBW" !Sets the mobile station max EIRP to -2 dBW.

CALL:D2KTest:ESNumber:HEX

Function

Sets/queries the test mode ESN (Electronic Serial Number).

Setting

Range: Up to eight characters containing alphanumerics 0123456789ABCDEF or NULL

Query

Range: String of up to eight characters containing alphanumerics 0123456789ABCDEF or NULL

*RST Setting

 "00000000"

Programming Example

OUTPUT 714;"CALL:D2KTEST:ESNUMBER:HEX 'ABCD1234'" !Sets the mobile station's ESN to ABCD1234.

CALL:D2KTest:QPCHannel:INDicator[:PAGing]

Function

Sets/queries the QPCH (Quick Paging Channel) paging indicators. Setting this parameter to ALL1 will cause the slotted mode mobile station operating in the idle state to monitor the paging channel during each assigned slot. When this parameter is set to ALL0 the mobile station will not monitor the paging channel.

Note: QPCH configuration change indicators are not settable. The test set will always transmit configuration change indicators as 0 bits.

Setting

Range: ALL0|ALL1

Query

Range: ALL0|ALL1

*RST Setting

 ALL0

Programming Example

OUTPUT 714;"CALL:D2KTEST:QPCH:IND ALL0" !Sets the paging indicators to 0 (off).


CALL:DCONnected

CALL:DCONnected

Last updated: June 6, 2007

GPIB Command Conventions

  • CALL:DCONnected[:STATe]
  • CALL:DCONnected:ARM[:IMMediate]
  • CALL:DCONnected:ARM:STATe?
  • CALL:DCONnected:TIMeout

CALL:DCONnected[:STATe]

Function

Queries whether the test data connection ((SO32 (+F-SCH) or SO32 (+ SCH)) or the packet data connection (SO33 or SO33 (+F-SCH)) is in the connected state.

For test data connection (see Call Processing State Synchronization ).

  • If the data connection is in the connected state (Connected +Data), the query immediately returns a 1.
  • If the data connection is in any other stable state (Idle), the query immediately returns a 0.
  • If the data change arm timer is armed (see CALL:DCONnected:ARM:STATe? ) and then this is queried, the query will hang until either the data change arm timer is disarmed or the data connection status changes.

For the packet data connection (for lab application only, see Packet Data Connection Processing States ).

  • If the packet data connection is in the connected state (Connected +Data), the query immediately returns a 1.
  • If the packet data connection is in any other stable state (Idle or Idle Dormant), the query immediately returns a 0.
  • If the data change arm timer is armed (see CALL:DCONnected:ARM:STATe? ) and then this is queried, the query will hang until either the data change arm timer is disarmed or the data connection status changes.

Query

Range: 0|1

*RST Setting

0

Programming Example

OUTPUT 714;"CALL:DCONNECTED:STATE?"
!Queries whether the data connection is in connected state.

CALL:DCONnected:ARM[:IMMediate]

Function

Sets (arms) the call-state-change detector. Arming this detector allows the control program to tell the test set that it is expecting a change in the state of a call, prior to initiating the state change.

Once armed, the detector remains armed until there is a data status change or the arm detector timer times out (determined by CALL:DCONnected:TIMeout ). It is not disarmed by any transitions from idle to idle or from connected to connected. See Call State Change Detector .

This is an overlapped command, and therefore has a Pending Operation Flag (POF) associated with it. See Call Processing Event Synchronization for more information about the behavior of overlapped commands.

Programming Example

OUTPUT 714;"CALL:DCONNECTED:ARM:IMMEDIATE" !Arms the call-state-change detector.

CALL:DCONnected:ARM:STATe?

Function

Queries the arm state of the data-state-change detector. This command never hangs and immediately returns a one if the detector is armed, or a zero if the detector is not armed. See also CALL:DCONnected:ARM[:IMMediate] and CALL:DCONnected:TIMeout .

See Call State Change Detector for details.

Query

Range: 1|0

*RST Setting

0

Programming Example

OUTPUT 714;"CALL:DCONNECTED:ARM:STATE?"
!Returns arm state of the call-state-change detector.

CALL:DCONnected:TIMeout

Function

Sets/queries the maximum time the test set will wait for a hanging query to complete (such as CALL:DCONnected[:STATe] or CALL:DORMant[:STATe]? ). Default setting units are seconds. To set timeout time in units other than seconds, include an optional unit specifier in the command string.

A timeout timer is started whenever the data-state-change detector becomes armed or gets rearmed when already armed. The duration of this timeout should be greater than the maximum amount of time the control program needs to wait between arming the data-state-change detector and the connect/disconnect operation starting. Once the process starts and the data channel's state has moved to one of the transitory states, the protocol timers take over and prevent the data channel's state from staying in a transitory state forever. See Call Processing State Synchronization .

Setting

Range: 0 to 100 seconds
Resolution: 0.1 seconds

Query

Range: 0 to 100 seconds
Resolution: 0.1 seconds

*RST Setting

10 seconds

Programming Example

OUTPUT 714;"CALL:DCONNECTED:TIMEOUT 3"
!Sets the CALL:DCONnected:STATe? query timeout time to 3 seconds.

OUTPUT 714;"CALL:DCONNECTED:TIMEOUT 500 MS"
!Sets the Sets the CALL:DCONnected:STATe? query timeout time to 500 milliseconds.


CALL Subsystem

CALL Subsystem

Last updated: June 20, 2006

Description

The CALL subsystem handles all setup, control, and query functions for call processing. This includes mobile station (MS) and Base Station (cell) functions.

Syntax Diagrams and Command Descriptions

CALL:ACC | CALL:MNCode
CALL:APARameter | CALL:MS:ANALog
CALL:AVCTest | CALL:MS:FERate ( Lab Application Only )
CALL:AWGNoise | CALL:MS:IP:ADDRess ( Lab Application Only )
CALL:BAND | CALL:MS:REPorted
CALL:BCCHannel | CALL:NIDentity
CALL:BIDentity | CALL:OCNSource
CALL:CCCHannel | CALL:OPERating
CALL:CCHannel ( Lab Application Only ) | CALL:ORIGinate
CALL:CELL2:CLPControl ( Lab Application Only ) | CALL:PAGing
CALL:CELL2:DELay ( Lab Application Only ) | CALL:PARameter:EACCess
CALL:CELL2:FCHannel ( Lab Application Only ) | CALL:PILot
CALL:CELL2:OCNSource ( Lab Application Only ) | CALL:PLCMask
CALL:CELL2:PILot ( Lab Application Only ) | CALL:PNOFfset
CALL:CELL2:PNOFfset ( Lab Application Only ) | CALL:POWer
CALL:CELL2:POWer ( Lab Application Only ) | CALL:PLOGging ( Lab Application Only )
CALL:CELL2:TRAFfic ( Lab Application Only ) | CALL:PROTocol
CALL:CHANnel | CALL:QPCHannel
CALL:CIDentity | CALL:RCONfig
CALL:CLPControl | CALL:REGister
CALL:CONNected | CALL:RFGenerator
CALL:CONTrol | CALL:RLGain
CALL:COUNt ( Lab Application Only ) | CALL:RTVocoder
CALL:CPNumber ( Lab Application Only ) | CALL:SCHannel
CALL:CSTime | CALL:SECurity
CALL:D2KTest | CALL:SETup
CALL:DATA ( Lab Application Only ) | CALL:SIDentity
CALL:DCONnected | CALL:SMService ( Lab Application Only )
CALL:DORMant ( Lab Application Only ) | CALL:SOPTion
CALL:END | CALL:SPARameter ( Lab Application Only )
CALL:ESCape | CALL:SSERvice:WAITing ( Lab Application Only )
CALL:FCHannel | CALL:STATus
CALL:FM | CALL:SYNC
CALL:FPControl ( Lab Application Only ) | CALL:SYSTem
CALL:FUNCtion:DATA ( Lab Application Only ) | CALL:TOTal:POWer
CALL:HANDoff | CALL:TRAFfic
CALL:MCCode | CALL:TRIGger
CALL:MEIDentifier | CALL:WAVeform


CALL:END

CALL:END

Last updated: June 6, 2007

GPIB Command Conventions

  • CALL:END

CALL:END

Function

Disconnects any calls or connections in progress. Aborts any outstanding registrations or base station pages in progress as well as mobile station originations.

Programming Example

OUTPUT 714;"CALL:END"


CALL:ESCape

CALL:ESCape

Last updated: June 6, 2007

GPIB Command Conventions

  • CALL[:CELL]:ESCape[:MODE]

CALL[:CELL]:ESCape[:MODE]

Function

Sets/queries CDG escape mode. When escape mode is on, the test set is configured as a base station that sends (in its overhead messages) all 1's in the messaging fields used to signal mobile country code (MCC) and mobile network code (MNC). A mobile station that supports escape mode will respond by assuming MCC/MNC compatibility and perform registrations using only the mobile station identification number (MSIN).

Setting

Range: 1|ON|0|OFF

Query

Range: 0|1

*RST Setting

 0 (off)

Programming Example

OUTPUT 714;"CALL:CELL:ESCAPE:MODE 1" !Sets CDG escape mode on.


CALL:FCHannel

CALL:FCHannel

Last updated: June 6, 2007

GPIB Command Conventions

  • CALL[:CELL[1]]:FCHannel[:FORWard][:SLEVel]<[:SELected]|DIGital2000>
  • CALL[:CELL[1]]:FCHannel[:FORWard]:LEVel<[:SELected]|DIGital2000>
  • CALL[:CELL[1]]:FCHannel[:FORWard]:STATe<[:SELected]|DIGital2000>
  • CALL[:CELL[1]]:FCHannel[:FORWard]:WALSh
  • CALL[:CELL[1]]:FCHannel[:FORWard]:SOURce
  • CALL[:CELL[1]]:FCHannel[:FORWard]:SOURce:ECHO
  • CALL[:CELL[1]]:FCHannel:REVerse:GATing

CALL[:CELL[1]]:FCHannel[:FORWard][:SLEVel]<[:SELected]|DIGital2000>

Function

The setting form of this command performs two functions: (1) sets the (Cell 1) F-FCH/Traffic Level (forward fundamental channel), and (2) turns the FCH state to ON.

The query form of this command returns the FCH level.

The optional [:SELected] keyword in this command specifies that the frequency band being set/queried applies to the current system type. At this time there is only one system type choice, DIGital2000. Specifying DIGital2000 will have the same effect as using the optional [:SELected] keyword.

Setting

Range: 0 to -30 dB

Resolution: 0.01 dB

Query

Range: 0 to -30 dB

Resolution: 0.01 dB

*RST Setting

-15.6 dB

Programming Example

OUTPUT 714;"CALL:FCHANNEL:SLEVEL:DIGITAL2000 -10 dB"
!Sets the forward fundamental channel (FCH) state to ON and sets the level to -10 dB.

CALL[:CELL[1]]:FCHannel[:FORWard]:LEVel<[:SELected]|DIGital2000>

Function

Sets/queries the (Cell 1) F-FCH/Traffic Level (forward fundamental channel).

The optional [:SELected] keyword in this command specifies that the frequency band being set/queried applies to the current system type. At this time there is only one system type choice, DIGital2000. Specifying DIGital2000 will have the same effect as using the optional [:SELected] keyword.

Setting

Range: 0 to -30 dB

Resolution: 0.01 dB

Query

Range: 0 to -30 dB

Resolution: 0.01 dB

*RST Setting

 -15.6 dB

Programming Example

OUTPUT 714;"CALL:FCHANNEL:LEVEL:SELECTED -10 dB"

CALL[:CELL[1]]:FCHannel[:FORWard]:STATe<[:SELected]|DIGital2000>

Function

Sets/queries the on/off state of the (Cell 1) F-FCH/Traffic Level (forward fundamental channel).

The optional [:SELected] keyword in this command specifies that the frequency band being set/queried applies to the current system type. At this time there is only one system type choice, DIGital2000. Specifying DIGital2000 will have the same effect as using the optional [:SELected] keyword.

Setting

Range: 1|ON|0|OFF

Query

Range: 1|0

*RST Setting

ON

Programming Example

OUTPUT 714;"CALL:FCHANNEL:STATE:DIGITAL2000 OFF"
!Turns off the forward fundamental channel.

CALL[:CELL[1]]:FCHannel[:FORWard]:WALSh

Function

Sets/queries the Walsh code used for the (Cell 1) F-FCH/Traffic Walsh Code. The Walsh codes allowed for use with this command are part of a reserved code space that has been created by fixing other code channels to pre-determined values. Reserving this code space eliminates the possibility of conflicts that can arise with lower walsh code sets which are used in certain radio configurations.

Setting

Range: CODE10|CODE14|CODE26|CODE30|CODE42|CODE46|CODE58|CODE62

Query

Range: CODE10|CODE14|CODE26|CODE30|CODE42|CODE46|CODE58|CODE62

*RST Setting

CODE10

Programming Example

OUTPUT 714;"CALL:FCHANNEL:WALSH CODE14"
!Sets the forward fundamental channel walsh code to 14.

CALL[:CELL[1]]:FCHannel[:FORWard]:SOURce

Function

Sets/queries the source of voice data to be sent on the forward fundamental channel in IS-2000 system. To set the source of voice data to be sent on the forward traffic channel in IS-95 system, use CALL[:CELL[1]]:TRAFfic[:FORWard]:SOURce .

See Voice SO Mode for details.

Setting

Range: ECHO|HZ400|HZ1000|SWEPt|MULTitone|RTVocoder|NFRames

Query

Range: ECHO|HZ400|HZ1000|SWEP|MULT|RTV|NFR

*RST Setting

ECHO

Requirements

Test Application Revision: B.06 or above
Test Application Revision: B.08 or above: Added MULTitone and NFRames
Test Application Revision: B.10 or above: Added RTVocoder

Lab Application Revision: A.02 or above
Lab Application Revision: B.02 or above: Added MULTitone and NFRames
Lab Application Revision: B.03.10 or above: Added RTVocoder

Programming Example

OUTPUT 714;"CALL:FCHannel:SOURce HZ400" !Sets the audio tone to 400Hz.

CALL[:CELL[1]]:FCHannel[:FORWard]:SOURce:ECHO

Function

Sets/queries the time period between when you talk into the mobile station and when you hear your voice echoed back. It is applied only when "ECHO" audio tone (see CALL[:CELL[1]]:FCHannel[:FORWard]:SOURce ) is selected for the current voice service option.

The delay time period can be specified as Short, Medium, and Long. The Short setting results in as shorted delay as possible. The medium setting results in about one second of delay. The Long setting results in approximately two seconds of delay.

Setting

Range: SHORt|MEDium|LONG

Query

Range: SHOR|MED|LONG

*RST Setting

MEDium

Requirements

 Test Application Revision: B.06.00 or above

Programming Example

OUTPUT 714;"CALL:FCHannel:SOURce:ECHO SHORt" !Sets the echo delay time to SHORt.

CALL[:CELL[1]]:FCHannel:REVerse:GATing

Function

Sets/queries the state of reverse fundamental channel (R-FCH) gating mode. ON indicates the gating mode is enabled. However, the R-FCH is actually be gated only if the data rate on the R-FCH is 1/8th rate. See R-FCH Gating for details.

Setting

Range: 1|ON|0|OFF

Query

Range: 1|0

*RST Setting

0 (OFF)

Requirements

 Lab Application Revision: B.02 and above

Programming Example

OUTPUT 714;"CALL:FCHannel:REVerse:GATing ON"
!Turns on the R-FCH gating mode.

Related Topics

CALL:CELL2:FCHannel


CALL:FM

CALL:FM

Last updated: June 6, 2007

GPIB Command Conventions

  • CALL:FM:EXTernal:STATe
  • CALL:FM:INTernal[:SDEViation]
  • CALL:FM:INTernal:DEViation
  • CALL:FM:INTernal:FREQuency
  • CALL:FM:INTernal:STATe

CALL:FM:EXTernal:STATe

Function

Sets/queries the external FM input (on or off). The FM deviation is fixed at 20 kHz/volt with a 1 volt maximum input voltage. You must make sure that the sum of the three FM sources (internal FM, external FM, and SAT) do not exceed 20 kHz deviation. The performance of the signal is not specified beyond 20 kHz deviation.

While in active cell mode, the internal and external FM states parameters will be overridden and FM turned off temporarily by the call processing state machine during wideband signaling with the mobile station. Querying during this temporary state will return user defined values. This command applies in active cell mode while on an AVC, and in AVC test mode.

Setting

 Range: 1|ON|0|OFF

Query

 Range: 1|0

*RST Setting

0 (off)

Programming Example

OUTPUT 714;"CALL:FM:EXTERNAL:STATE ON" !Turns on the external FM input.

CALL:FM:INTernal[:SDEViation]

Function

Sets/queries the internal FM source's deviation and automatically sets the internal FM state to ON. This is "complex" command.

Setting

Range: 0 to 20 kHz

Resolution: 0.1 Hz

Query

Range: 0 to 20 kHz

Resolution: 0.1 Hz

*RST Setting

Internal FM: OFF

Internal FM: OFF

Programming Example

OUTPUT 714;"CALL:FM:INTERNAL:SDEVIATION 10 kHz" !Sets internal FM deviation to 10 kHz and
                                                     !automatically turns on the internal FM
                                                     !source.

CALL:FM:INTernal:DEViation

Function

Sets/queries the internal FM source's deviation. When querying the internal FM deviation, the current setting of this parameter will always be returned regardless of the setting for the internal FM state.

You must make sure that the sum of the three FM sources (internal FM, external FM, and SAT) do not exceed 20 kHz deviation. The performance of the signal is not specified beyond 20 kHz deviation.

This command applies in active cell mode while on an AVC, and in AVC test mode.

Setting

Range: 0 to 20 kHz

Resolution: 0.1 Hz

Query

Range: 0 to 20 kHz

Resolution: 0.1 Hz

*RST Setting

8 kHz

Programming Example

OUTPUT 714;"CALL:FM:INTERNAL:DEVIATION 10 KHZ" !Sets internal FM deviation to 10 kHz.

CALL:FM:INTernal:FREQuency

Function

Sets/queries the frequency of the internal FM source. Applies in active cell mode while on an AVC, and in AVC test mode.

Setting

Range: 20 Hz to 20 kHz

Resolution: 0.1 Hz

Query

Range: 20 Hz to 20 kHz

Resolution: 0.1 Hz

*RST Setting

1004 Hz

Programming Example

OUTPUT 714;"CALL:FM:INTERNAL:FREQUENCY 60 HZ" !Sets the internal FM source's frequency to
                                                    !60 Hz.

CALL:FM:INTernal:STATe

Function

Sets/queries the internal FM source (on or off).

While in active cell mode, the internal and external FM states parameters will be overridden and FM turned off temporarily by the call processing state machine during wideband signaling with the mobile station. Querying during this temporary state will return user defined values. This command applies in active cell mode while on an AVC, and in AVC test mode.

Setting

Range: 1|ON|0|OFF

Query

Range: 1|0

*RST Setting

0 (off)

Programming Example

OUTPUT 714;"CALL:FM:INTERNAL:STATE ON" !Turns on the internal FM source.


CALL:HANDoff

CALL:HANDoff

Last updated: June 6, 2007

GPIB Command Conventions

  • CALL:HANDoff[:IMMediate]

CALL:HANDoff[:IMMediate]

Function

Initiates a handoff to:

  • the handoff system type selected by the CALL:SETup:SYSTem[:TYPE]<[:SELected]|[:TA2000]> command.

  • the handoff frequency band selected by the CALL:SETup:BAND:[:SELected] command.

  • the handoff physical channel selected by the CALL:SETup:CHANnel[:SELected][:SELected] command.

A handoff will occur within the current system if the current cell system type (see CALL:SYSTem ) is the same as the current handoff system type (see CALL:SETup:SYSTem[:TYPE]<[:SELected]|[:TA2000]> ).

Programming Example

OUTPUT 714;"CALL:HANDOFF:IMMEDIATE" !initiates a handoff.


CALL:MCCode

CALL:MCCode

Last updated: June 6, 2007

GPIB Command Conventions

  • CALL[:CELL]:MCCode<[:SELected]|:TA2000>

CALL[:CELL]:MCCode<[:SELected]|:TA2000>

Function

Sets/queries the mobile country code (MCC).

This parameter can be set any time and will be sent out in the next overhead message.

When escape mode is on (see CALL:ESCape command description), this parameter is not used.

Setting

Range: 0 to 999

Resolution: 1

Query

Same as setting.

*RST Setting

 310

Programming Example

OUTPUT 714;"CALL:CELL:MCCODE 310"
!Sets the mobile country code to 310.


CALL:MEIDentifier

CALL:MEIDentifier

Last updated: June 6, 2007

GPIB Command Conventions

  • CALL[:CELL]:MEIDentifier:SUPPort[:ENABle]

CALL[:CELL]:MEIDentifier:SUPPort[:ENABle]

Function

Enable (On) or disable (Off) the test set to support of MEID and Enhanced PLCM tests for an MEID-equipped mobile station. See MEID Support for details.

Setting

 Range: 1|ON|0|Off

Query

Range: 1|0

*RST Setting

Off (0)
Requirement

Test Application Revision: B.10 and above

Lab Application Revision: B.03.10 and above

Programming Example

OUTPUT 714;"CALL:MEIDentifier:SUPPort ON"
!Enables the test set to support of MEID related tests.


CALL:MNCode

CALL:MNCode

Last updated: June 6, 2007

GPIB Command Conventions

  • CALL[:CELL]:MNCode

CALL[:CELL]:MNCode

Function

Sets/queries the mobile network code (MNC, also referred to as IMSI_11_12 or cell network code).

This parameter can be set any time and will be sent out in the next overhead message.

When escape mode is on (see the CALL:ESCape command description), this parameter is not used.

Setting

Range: 0 to 99

Resolution: 1

Query

Same as settting.

*RST Setting

0

Programming Example

OUTPUT 714;"CALL:CELL:MNCODE 10" !Sets the mobile network code to 10.


CALL:MS:ANALog

CALL:MS:ANALog

Last updated: June 6, 2007

GPIB Command Conventions

  • CALL:MS:ANALog:ALERt[:IMMediate]
  • CALL:MS:ANALog:ALERt:SEQuential
  • CALL:MS:ANALog:ALERt:WAIT
  • CALL:MS:ANALog:ALERt:DONE?
  • CALL:MS:ANALog:ALERt:OPComplete?
  • CALL:MS:ANALog:MAINtenance[:IMMediate]
  • CALL:MS:ANALog:MAINtenance:SEQuential
  • CALL:MS:ANALog:MAINtenance:WAIT
  • CALL:MS:ANALog:MAINtenance:DONE?
  • CALL:MS:ANALog:MAINtenance:OPComplete?
  • CALL:MS:ANALog:TXLevel[:IMMediate]

CALL:MS:ANALog:ALERt[:IMMediate]

Function

Send an alert message to tell the mobile station to turn on signaling tone and set the mobile station into a alerting mode.

This command is used in active cell operating mode.

Requirement

Test Application Revision: B.09 and above

Lab Application Revision: B.03 and above

Programming Example

OUTPUT 714;"CALL:MS:ANALog:ALERt"
!Send an alert message to mobile station.

CALL:MS:ANALog:ALERt:SEQuential

Function

See Call Processing Event Synchronization

This command is used in active cell operating mode.

Requirement

Test Application Revision: B.09 and above

Lab Application Revision: B.03 and above

Programming Example

OUTPUT 714;"CALL:MS:ANALog:ALERt:SEQuential"

CALL:MS:ANALog:ALERt:WAIT

Function

See Call Processing Event Synchronization

This command is used in active cell operating mode.

Requirement

Test Application Revision: B.09 and above

Lab Application Revision: B.03 and above

Programming Example

OUTPUT 714;"CALL:MS:ANALOG:ALERT:WAIT"

CALL:MS:ANALog:ALERt:DONE?

Function

See Call Processing Event Synchronization

This command is used in active cell operating mode.

Query

Range: 1|0

Requirement

Test Application Revision: B.09 and above

Lab Application Revision: B.03 and above

Programming Example

OUTPUT 714;"CALL:MS:ANALog:ALERt:DONE?"

CALL:MS:ANALog:ALERt:OPComplete?

Function

See Call Processing Event Synchronization

This command is used in active cell operating mode.

Query

Range: 1

Requirement

Test Application Revision: B.09 and above

Lab Application Revision: B.03 and above

Programming Example

OUTPUT 714;"CALL:MS:ANALog:ALERt:OPComplete?"

CALL:MS:ANALog:MAINtenance[:IMMediate]

Function

Send an maintenance message to tell the mobile station to turn on signaling tone and set the mobile station into a maintenance mode.

This command is used in active cell operating mode.

Requirement

Test Application Revision: B.09 and above

Lab Application Revision: B.03 and above

Programming Example

OUTPUT 714;"CALL:MS:ANALog:MAINtenance"
!Send an maintenance message to mobile station.

CALL:MS:ANALog:MAINtenance:SEQuential

Function

See Call Processing Event Synchronization

This command is used in active cell operating mode.

Requirement

Test Application Revision: B.09 and above

Lab Application Revision: B.03 and above

Programming Example

OUTPUT 714;"CALL:MS:ANALog:MAINtenance:SEQuential"

CALL:MS:ANALog:MAINtenance:WAIT

Function

See Call Processing Event Synchronization

This command is used in active cell operating mode.

Requirement

Test Application Revision: B.09 and above

Lab Application Revision: B.03 and above

Programming Example

OUTPUT 714;"CALL:MS:ANALog:MAINtenance:WAIT"

CALL:MS:ANALog:MAINtenance:DONE?

Function

See Call Processing Event Synchronization

This command is used in active cell operating mode.

Query

Range: 1|0

Requirement

Test Application Revision: B.09 and above

Lab Application Revision: B.03 and above

Programming Example

OUTPUT 714;"CALL:MS:ANALog:MAINtenance:DONE?"

CALL:MS:ANALog:MAINtenance:OPComplete?

Function

See Call Processing Event Synchronization

This command is used in active cell operating mode.

Query

Range: 1

Requirement

Test Application Revision: B.09 and above

Lab Application Revision: B.03 and above

Programming Example

OUTPUT 714;"CALL:MS:ANALog:MAINtenance:OPComplete?"

CALL:MS:ANALog:TXLevel[:IMMediate]

Function

Sets/queries the mobile station transmit level while on an analog voice channel.

This command is used in active cell operating mode to immediately change the mobile level while on an AVC.

Setting

Range: 0 to 7

MS TX Level 0: expected power, 36 dBm*
MS TX Level 1: expected power, 32 dBm
MS TX Level 2: expected power, 28 dBm
MS TX Level 3: expected power, 24 dBm
MS TX Level 4:expected power, 20 dBm
MS TX Level 5: expected power, 16 dBm
MS TX Level 6: expected power, 12 dBm
MS TX Level 7: expected power, 8 dBm

*all values for MS TX level assume 0 dB antenna gain

*RST Setting

 2

Requirement

Test Application Revision: B.09 and above

Lab Application Revision: B.03 and above

Programming Example

OUTPUT 714;"CALL:MS:ANALog:TXLevel 5"
!Sets mobile station AVC transmit power level to 5 (expected power 16 dBm).


CALL:MS:REPorted<:BCLass|:BWType>

CALL:MS:REPorted<:BCLass|:BWType>

Last updated: June 6, 2007

GPIB Command Conventions

  • CALL:MS:REPorted:PILot:STRength:REQuest[:IMMediate]
  • CALL:MS:REPorted:PILot:STRength:REQuest:TIME?
  • CALL:MS:REPorted:PILot:STRength:REPort[:ALL]?
  • CALL:MS:REPorted:PILot:STRength:REPort:CLEar

CALL:MS:REPorted:BCLass?

Function

This query returns up to three concatenated mobile station reported frequency band classes (frequency bands supported by the mobile station).

Each band that is included in the returned string is right-justified within an 8-character slot. Each 8-character slot is followed by a comma and a space until the last band is sent. The last band in the string will not have an appended comma and a space. The return values for CALL:MS:REPorted:OPERating:MODE? and CALL:MS:REPorted:EIRPower[:MAXimum]? will consist of an operating mode and a maximum EIRP for each band returned by this command.

Unless the Status Request Query is set to "OFF" by the command , each time a new mobile station registers with the test set, the test set will have the mobile station report band classes, mobile station reported operating mode for each band class, and mobile station reported max EIRP (if the operating mode is CDMA) for each band class. These results are referred to as Status Request Information.

Query

Range: US Cell, Jpn Cell, Kor PCS, US PCS, IMT-2000, US PCS 1900, AWS, null

*RST Setting

 Null

Programming Example

OUTPUT 714;"CALL:MS:REPORTED:BCLASS?"
!when sent to a mobile station supporting US cellular and US PCS bands, returns the string:

!"<sp>US<sp>Cell,<sp><sp><sp>US<sp>PCS".

!Note: string is 16 characters (8 per band) plus a comma and space separating the two bands.

CALL:MS:REPorted:BWType?

Function

Queries station class mark bandwidth support for AMPS mobile.

Query

Range: BWT20|BWT25|UNKN

*RST Setting

UNKN

Programming Example

OUTPUT 714;"CALL:MS:REPORTED:BWTYPE?"


CALL:MS:REPorted:CAPability

CALL:MS:REPorted:CAPability

Last updated: June 6, 2007

GPIB Command Conventions

  • CALL:MS:REPorted:CAPability:CCHannel:DEDicated[:SUPPort]?
  • CALL:MS:REPorted:CAPability:CCHannel:DEDicated:FRAMe[:SIZE]?
  • CALL:MS:REPorted:CAPability:CCHannel:DEDicated:FORWard:RCONfig?
  • CALL:MS:REPorted:CAPability:CCHannel:DEDicated:REVerse:RCONfig?
  • CALL:MS:REPorted:CAPability:FCHannel[:SUPPort]?
  • CALL:MS:REPorted:CAPability:FCHannel:FRAMe:MS5[:SUPPort]?
  • CALL:MS:REPorted:CAPability:FCHannel:FORWard:RCONfig?
  • CALL:MS:REPorted:CAPability:FCHannel:REVerse:RCONfig?
  • CALL:MS:REPorted:CAPability:QUERy
  • CALL:MS:REPorted:CAPability:SCHannel:FORWard[:SUPPort]?
  • CALL:MS:REPorted:CAPability:SCHannel:FORWard:CONVolution[:SUPPort]?
  • CALL:MS:REPorted:CAPability:SCHannel:FORWard:CONVolution:DRATe1[:MAXimum]?
  • CALL:MS:REPorted:CAPability:SCHannel:FORWard:CONVolution:DRATe2[:MAXimum]?
  • CALL:MS:REPorted:CAPability:SCHannel:FORWard:COUNt?
  • CALL:MS:REPorted:CAPability:SCHannel:FORWard:RCONfig?
  • CALL:MS:REPorted:CAPability:SCHannel:FORWard:TURBo[:SUPPort]?
  • CALL:MS:REPorted:CAPability:SCHannel:FORWard:TURBo:DRATe1[:MAXimum]?
  • CALL:MS:REPorted:CAPability:SCHannel:FORWard:TURBo:DRATe2[:MAXimum]?
  • CALL:MS:REPorted:CAPability:SCHannel:REVerse[:SUPPort]?
  • CALL:MS:REPorted:CAPability:SCHannel:REVerse:CONVolution[:SUPPort]?
  • CALL:MS:REPorted:CAPability:SCHannel:REVerse:CONVolution:DRATe1[:MAXimum]?
  • CALL:MS:REPorted:CAPability:SCHannel:REVerse:CONVolution:DRATe2[:MAXimum]?
  • CALL:MS:REPorted:CAPability:SCHannel:REVerse:COUNt?
  • CALL:MS:REPorted:CAPability:SCHannel:REVerse:RCONfig?
  • CALL:MS:REPorted:CAPability:SCHannel:REVerse:TURBo[:SUPPort]?
  • CALL:MS:REPorted:CAPability:SCHannel:REVerse:TURBo:DRATe1[:MAXimum]?
  • CALL:MS:REPorted:CAPability:SCHannel:REVerse:TURBo:DRATe2[:MAXimum]?

CALL:MS:REPorted:CAPability:CCHannel:DEDicated[:SUPPort]?

Function

This query only command returns the mobile station's capability to support a dedicated control channel (DCCH), as reported by the mobile station.

Query

Range: YES|NO|UNKN

*RST Setting

 UNKN

Programming Example

OUTPUT 714;"CALL:MS:REPORTED:CAPABILITY:CCHANNEL:DEDICATED:SUPPPORT?"

CALL:MS:REPorted:CAPability:CCHannel:DEDicated:FRAMe[:SIZE]?

Function

This query only command returns the mobile station's capability to support different frame sizes on the dedicated control channel (DCCH), as reported by the mobile station.

Returned values are 5 millisecond only, 20 milliseconds only, 5 or 20 milliseconds not dynamic, 5 or 20 milliseconds dynamic, or unknown.

Query

Range: 5MS|20MS|NDYN|DYN|UNKN

*RST Setting

 UNKN

Programming Example

OUTPUT 714;"CALL:MS:REPORTED:CAPABILITY:CCHANNEL:DEDICATED:FRAME:SIZE?"

CALL:MS:REPorted:CAPability:CCHannel:DEDicated:FORWard:RCONfig?

Function

This query only command returns the mobile station's capability to support forward dedicated control channels, as reported by the mobile station.

This query returns a comma-separated string of any combination of 3, 4, 5, or null.

Query

Range: 3|4|5|null

*RST Setting

 null

Programming Example

OUTPUT 714;"CALL:MS:REPORTED:CAPABILITY:CCHANNEL:DEDICATED:FORWARD:RCONFIG?"

CALL:MS:REPorted:CAPability:CCHannel:DEDicated:REVerse:RCONfig?

Function

This query only command returns the mobile station's capability to support reverse dedicated control channels, as reported by the mobile station.

This query returns a comma-separated string of any combination of 3, 4, 5, or null.

Query

Range: 3|4|5|null

*RST Setting

 null

Programming Example

OUTPUT 714;"CALL:MS:REPORTED:CAPABILITY:CCHANNEL:DEDICATED:REVERSE:RCONFIG?"

CALL:MS:REPorted:CAPability:FCHannel[:SUPPort]?

Function

This query only command returns the mobile station's capability to support a fundamental channel, as reported by the mobile station.

Query

Range: YES|NO|UNKN

*RST Setting

 UNKN

Programming Example

OUTPUT 714;"CALL:MS:REPORTED:CAPABILITY:FCHANNEL?"

CALL:MS:REPorted:CAPability:FCHannel:FRAMe:MS5[:SUPPort]?

Function

This query only command returns the mobile station's capability to support a fundamental channel with 5 ms frames, as reported by the mobile station.

Query

Range: YES|NO|UNKN

*RST Setting

 UNKN

Programming Example

OUTPUT 714;"CALL:MS:REPORTED:CAPABILITY:FCHANNEL:FRAME:MS5:SUPPORT?"

CALL:MS:REPorted:CAPability:FCHannel:FORWard:RCONfig?

Function

This query only command returns the mobile station's capability to support radio configurations on the forward fundamental radio channel, as reported by the mobile station.

This query returns a comma-separated string of any combination of 1, 2, 3, 4, 5, or null.

Query

Range: 1|2|3|4|5|null

*RST Setting

 null

Programming Example

OUTPUT 714;"CALL:MS:REPORTED:CAPABILITY:FCHANNEL:FORWARD:RCONFIG?"

CALL:MS:REPorted:CAPability:FCHannel:REVerse:RCONfig?

Function

This query only command returns the mobile station's capability to support radio configurations on the reverse fundamental radio channel, as reported by the mobile station.

This query returns a comma-separated string of any combination of 1, 2, 3, 4, 5, or null.

Query

Range: 1|2|3|4|5|null

*RST Setting

 null

Programming Example

OUTPUT 714;"CALL:MS:REPORTED:CAPABILITY:FCHANNEL:REVERSE:RCONFIG?"

CALL:MS:REPorted:CAPability:QUERy

Function

This command causes the test set to obtain the queriable mobile station capability results.

This command is only applicable to active cell mode in the IS-2000 system.

Query

 N/A

*RST Setting

 N/A

Programming Example

OUTPUT 714;"CALL:MS:REPORTED:CAPABILITY:QUERY"
!obtains queriable mobile station capability results from the mobile station.

CALL:MS:REPorted:CAPability:SCHannel:FORWard[:SUPPort]?

Function

This query only command returns the mobile station's capability to support a forward supplemental channel (SCH), as reported by the mobile station.

Query

Range: YES|NO|UNKN

*RST Setting

 UNKN

Programming Example

OUTPUT 714;"CALL:MS:REPORTED:CAPABILITY:SCHANNEL:FORWARD:SUPPPORT?"

CALL:MS:REPorted:CAPability:SCHannel:FORWard:CONVolution[:SUPPort]?

Function

This query only command returns the mobile station's capability to support convolutional coding on the forward supplemental channel, as reported by the mobile station.

Query

Range: YES|NO|UNKN

*RST Setting

 UNKN

Programming Example

OUTPUT 714;"CALL:MS:REPORTED:CAPABILITY:SCHANNEL:FORWARD:CONVOLUTION:SUPPORT?"

CALL:MS:REPorted:CAPability:SCHannel:FORWard:CONVolution:DRATe1[:MAXimum]?

Function

This query only command returns the mobile station's maximum convolutional coder data rate on the forward supplemental channel for rate set 1, as reported by the mobile station.

Query

Range: BPS9600|BPS19200|BPS76800|BPS153600|BPS307200|UNKN

*RST Setting

 UNKN

Programming Example

OUTPUT 714;"CALL:MS:REPORTED:CAPABILITY:SCHANNEL:FORWARD:CONVOLUTION:DRATE1:MAXIMUM?"

CALL:MS:REPorted:CAPability:SCHannel:FORWard:CONVolution:DRATe2[:MAXimum]?

Function

This query only command returns the mobile station's maximum convolutional coder data rate on the forward supplemental channel for rate set 2, as reported by the mobile station.

Query

Range: BPS14400|BPS28800|BPS57600|BPS230400|UNKN

*RST Setting

 UNKN

Programming Example

OUTPUT 714;"CALL:MS:REPORTED:CAPABILITY:SCHANNEL:FORWARD:CONVOLUTION:DRATE2:MAXIMUM?"

CALL:MS:REPorted:CAPability:SCHannel:FORWard:COUNt?

Function

This query only command returns the mobile station's capability to support multiple forward supplemental channels, as reported by the mobile station.

Query

Range: 0|1|2, 9.91 E+37

*RST Setting

 9.91 E+37

Programming Example

OUTPUT 714;"CALL:MS:REPORTED:CAPABILITY:SCHANNEL:FORWARD:COUNT?"

CALL:MS:REPorted:CAPability:SCHannel:FORWard:RCONfig?

Function

This query only command returns the mobile station's capability to support forward supplemental channel radio configurations, as reported by the mobile station.

This query returns a comma-separated string of any combination of 3, 4, 5, or null.

Query

Range: 3|4|5|null

*RST Setting

 null

Programming Example

OUTPUT 714;"CALL:MS:REPORTED:CAPABILITY:SCHANNEL:FORWARD:RCONFIG?"

CALL:MS:REPorted:CAPability:SCHannel:FORWard:TURBo[:SUPPort]?

Function

This query only command returns the mobile station's capability to support the forward supplemental channel turbo coder, as reported by the mobile station.

Query

Range: YES|NO|UNKN

*RST Setting

 UNKN

Programming Example

OUTPUT 714;"CALL:MS:REPORTED:CAPABILITY:SCHANNEL:FORWARD:TURBO:SUPPORT?"

CALL:MS:REPorted:CAPability:SCHannel:FORWard:TURBo:DRATe1[:MAXimum]?

Function

This query only command returns the mobile station's maximum turbo coder data rate on the forward supplemental channel for rate set 1, as reported by the mobile station.

Query

Range: BPS9600|BPS19200|BPS76800|BPS153600|BPS307200|UNKN

*RST Setting

 UNKN

Programming Example

OUTPUT 714;"CALL:MS:REPORTED:CAPABILITY:SCHANNEL:FORWARD:TURBO:DRATE1:MAXIMUM?"

CALL:MS:REPorted:CAPability:SCHannel:FORWard:TURBo:DRATe2[:MAXimum]?

Function

This query only command returns the mobile station's maximum turbo coder data rate on the forward supplemental channel for rate set 2, as reported by the mobile station.

Query

Range: BPS14400|BPS28800|BPS57600|BPS230400|UNKN

*RST Setting

 UNKN

Programming Example

OUTPUT 714;"CALL:MS:REPORTED:CAPABILITY:SCHANNEL:FORWARD:TURBO:DRATE2:MAXIMUM?"

CALL:MS:REPorted:CAPability:SCHannel:REVerse[:SUPPort]?

Function

This query only command returns the mobile station's capability to support the reverse supplemental channel, as reported by the mobile station.

Query

Range: YES|NO|UNKN

*RST Setting

 UNKN

Programming Example

OUTPUT 714;"CALL:MS:REPORTED:CAPABILITY:SCHANNEL:REVERSE:SUPPORT?"

CALL:MS:REPorted:CAPability:SCHannel:REVerse:CONVolution[:SUPPort]?

Function

This query only command returns the mobile station's capability to support convolutional coding on the reverse supplemental channel, as reported by the mobile station.

Query

Range: YES|NO|UNKN

*RST Setting

 UNKN

Programming Example

OUTPUT 714;"CALL:MS:REPORTED:CAPABILITY:SCHANNEL:REVERSE:CONVOLUTION:SUPPORT?"

CALL:MS:REPorted:CAPability:SCHannel:REVerse:CONVolution:DRATe1[:MAXimum]?

Function

This query only command returns the mobile station's maximum convolutional coder data rate on the reverse supplemental channel for rate set 1, as reported by the mobile station.

Query

Range: BPS9600|BPS19200|BPS76800|BPS153600|BPS307200|UNKN

*RST Setting

 UNKN

Programming Example

OUTPUT 714;"CALL:MS:REPORTED:CAPABILITY:SCHANNEL:REVERSE:CONVOLUTION:DRATE1:MAXIMUM?"

CALL:MS:REPorted:CAPability:SCHannel:REVerse:CONVolution:DRATe2[:MAXimum]?

Function

This query only command returns the mobile station's maximum convolutional coder data rate on the reverse supplemental channel for rate set 2, as reported by the mobile station.

Query

Range: BPS14400|BPS28800|BPS57600|BPS230400|UNKN

*RST Setting

 UNKN

Programming Example

OUTPUT 714;"CALL:MS:REPORTED:CAPABILITY:SCHANNEL:REVERSE:CONVOLUTION:DRATE2:MAXIMUM?"

CALL:MS:REPorted:CAPability:SCHannel:REVerse:COUNt?

Function

This query only command returns the mobile station's capability to support multiple reverse supplemental channels, as reported by the mobile station.

Query

Range: 0|1|2, 9.91 E+37

*RST Setting

 9.91 E+37

Programming Example

OUTPUT 714;"CALL:MS:REPORTED:CAPABILITY:SCHANNEL:REVERSE:COUNT?"

CALL:MS:REPorted:CAPability:SCHannel:REVerse:RCONfig?

Function

This query only command returns the mobile station's capability to support reverse supplemental channel radio configurations, as reported by the mobile station.

This query returns a comma-separated string of any combination of 3, 4, 5, or null.

Query

Range: 3|4|5|null

*RST Setting

 null

Programming Example

OUTPUT 714;"CALL:MS:REPORTED:CAPABILITY:SCHANNEL:REVERSE:RCONFIG?"

CALL:MS:REPorted:CAPability:SCHannel:REVerse:TURBo[:SUPPort]?

Function

This query only command returns the mobile station's capability to support the reverse supplemental channel turbo coder, as reported by the mobile station.

Query

Range: YES|NO|UNKN

*RST Setting

 UNKN

Programming Example

OUTPUT 714;"CALL:MS:REPORTED:CAPABILITY:SCHANNEL:REVERSE:TURBO:SUPPORT?"

CALL:MS:REPorted:CAPability:SCHannel:REVerse:TURBo:DRATe1[:MAXimum]?

Function

 This query only command returns the mobile station's maximum turbo coder data rate on the reverse supplemental channel for rate set 1, as reported by the mobile station.

Query

Range: BPS9600|BPS19200|BPS76800|BPS153600|BPS307200|UNKN

*RST Setting

 UNKN

Programming Example

OUTPUT 714;"CALL:MS:REPORTED:CAPABILITY:SCHANNEL:REVERSE:TURBO:DRATE1:MAXIMUM?"

CALL:MS:REPorted:CAPability:SCHannel:REVerse:TURBo:DRATe2[:MAXimum]?

Function

 This query only command returns the mobile station's maximum turbo coder data rate on the reverse supplemental channel for rate set 2, as reported by the mobile station.

Query

Range: BPS14400|BPS28800|BPS57600|BPS230400|UNKN

*RST Setting

 UNKN

Programming Example

OUTPUT 714;"CALL:MS:REPORTED:CAPABILITY:SCHANNEL:REVERSE:TURBO:DRATE2:MAXIMUM?"


CALL:MS:REPorted:CLEar

CALL:MS:REPorted:CLEar

Last updated: June 6, 2007

GPIB Command Conventions

  • CALL:MS:REPorted:CLEar[:ALL]

CALL:MS:REPorted:CLEar[:ALL]

Function

Clears the mobile station (MS) registration data displayed on the Mobile Reported Information as well as the queriable MS capability information (see CALL:MS:REPorted:CAPability ).

Once cleared, the Mobile Reported Information data is updated during the next registration and the MS capability information should be re-queried with CALL:MS:REPorted:CAPability:QUERy command.

Programming Example

OUTPUT 714;"CALL:MS:REPORTED:CLEAR:ALL"


CALL:MS:REPorted:CPCLass

CALL:MS:REPorted:CPCLass

Last updated: June 6, 2007

GPIB Command Conventions

  • CALL:MS:REPorted:CPCLass?

CALL:MS:REPorted:CPCLass?

Function

Queries the mobile reported power class as part of the station class mark (SCM) for IS-95 and IS-2000 mobiles.

Used only in active cell operating mode and IS-95/IS-2000 systems.

Query

Range: 1, 2, 3, or 9.91 E+37

*RST Setting

9.91 E+37

Programming Example

OUTPUT 714;"CALL:MS:REPORTED:PCLASS:SELECTED?" !Returns the MS reported power class.


CALL:MS:REPorted:CTXType

CALL:MS:REPorted:CTXType

Last updated: June 6, 2007

GPIB Command Conventions

  • CALL:MS:REPorted:CTXType?

CALL:MS:REPorted:CTXType?

Function

Queries the mobile reported transmission mode for IS-95, cdma2000 systems.

Query

Range: CONT|DISC|UNKN

*RST Setting

UNKN

Programming Example

OUTPUT 714;"CALL:MS:REPORTED:CTXTYPE?"


CALL:MS:REPorted:DUAL

CALL:MS:REPorted:DUAL

Last updated: June 6, 2007

GPIB Command Conventions

  • CALL:MS:REPorted:DUAL[:MODE]?

CALL:MS:REPorted:DUAL[:MODE]?

Function

Queries the mobile reported operating mode for IS-95, cdma2000 systems.

Query

Range: CDMA ONLY|DUAL MODE|NULL

*RST Setting

NULL

Programming Example

OUTPUT 714;"CALL:MS:REPORTED:DUAL?"


CALL:MS:REPorted

CALL:MS:REPorted

Last updated: June 18, 2007

The CALL:MS:REPorted commands allow you to access information reported by the mobile station.

Syntax Diagrams and Command Descriptions

CALL:MS:REPorted<:BCLass|:BWType>

CALL:MS:REPorted:CAPability

CALL:MS:REPorted:CLEar

CALL:MS:REPorted:CPCLass

CALL:MS:REPorted:CTXType

CALL:MS:REPorted:DUAL

CALL:MS:REPorted<:EIRPower|:ESNumber>

CALL:MS:REPorted<:MCC|:MEID|:MIN1|:MIN2|:MNC|MSIN>

CALL:MS:REPorted<:ONUMber|:OPERating>

CALL:MS:REPorted:PILot:STRength ( Lab Application Only )
CALL:MS:REPorted<:PCLass|:PCONtrol|:PNUMber|:PREVision>
CALL:MS:REPorted:QPCHannel


CALL:MS:REPorted<:EIRPower|:ESNumber>

CALL:MS:REPorted<:EIRPower|:ESNumber>

Last updated: June 6, 2007

GPIB Command Conventions

  • CALL:MS:REPorted:EIRPower[:MAXimum]?
  • CALL:MS:REPorted:EIRPower:DEFault
  • CALL:MS:REPorted:ESNumber[:DECimal]?
  • CALL:MS:REPorted:ESNumber:HEX?

CALL:MS:REPorted:EIRPower[:MAXimum]?

Function

This query returns, in units of dBW, up to three concatenated mobile station reported maximum EIRP (effective isotropic radiated power).

Each Max EIRP value that is included in the returned string is right-justified within an 8-character slot. Each 8-character slot is followed by a comma and a space until the last Max EIRP value is sent. The last Max EIRP value in the string will not have an appended comma and a space. Each Max EIRP value that is included in the returned string will correspond, by its position in the string, with the position of each band class in the string returned by the command CALL:MS:REPorted:BCLass? .

Unless the Status Request Query is set to "OFF" by the command CALL:MS:REPorted:REQuest[:ENAble] , each time a new mobile station registers with the test set, the test set will have the mobile station report band classes, mobile station reported operating mode for each band class, and mobile station reported max EIRP (if the operating mode is CDMA) for each band class. These results are referred to as Status Request Information.

When the Status Request Query is set to "OFF" and the MS Database is cleared, then the Max EIRP set by the command CALL:MS:REPorted:EIRPower:DEFault will be used for all band class connections

In IS-2000 test mode, the Max EIRP is set using CALL:D2KTest:EIRPower[:MAXimum] .

*RST Setting

 Null

Programming Example

OUTPUT 714;"CALL:MS:REPorted:EIRPower?" !when sent to a mobile station supporting US cellular (analog operating mode) and US PCS (CDMA operating mode) bands, might return something similar to the following string:

"<null substring>,<sp>-50<sp><sp><sp><sp><sp>".

Note that this string consists of a leading comma and space denoting a null substring, followed by the maximum EIRP for the second band, US PCS (CDMA operating mode).

CALL:MS:REPorted:EIRPower:DEFault

Function

Set/queries the default Max EIRP (effective isotropic radiated power) to be assumed when mobile station's MAX_EIRP for the current band class is not in the mobile station database.

The mobile station contains a list of band classes it supports and an operating mode and MAX_EIRP value for each supported band class. This information is referred to as Status Request Information. If a mobile station registers with the test set whose ESN is different from the ESN stored in the mobile station database and the Status Request Query is set to "ON" by the command CALL:MS:REPorted:REQuest[:ENAble] , then test set will query the mobile station for its Status Request Information.

The MAX_EIRP is used to estimate the mobile station's output at higher power levels. If a MAX_EIRP value for the current band class is not present in the mobile station database then the default Max EIRP will be used to estimate the mobile station's output power.

NOTE
This parameter is displayed on the test set's front panel in units of dBW (see Paging IMSI Setup ). It may be set and queried over the remote interface in units of dBm or dBW. The default units for this setting are dBm on the remote interface.

Requirements

 Test Application Revision: B.06.00 or above

Setting

Range: 0 to +40 dBm (-30 to +10 dBW)

Resolution: 1 dBm

Query

Range: 0 to +40 dBm

Resolution: 1 dBm

*RST Setting

+23 dBm

Programming Example

OUTPUT 714;"CALL:MS:REPorted:EIRPower:DEFault 10" !Sets the Max EIRP for the phone to 10 dBm.

CALL:MS:REPorted:ESNumber[:DECimal]?

Function

Queries the decimal formatted version of the electronic serial number as a string. The string is formatted as a three digit manufacturers code followed by a hyphen "-", and followed by a six digit serial number. Used only in active cell operating mode.

Requirements

 Test Application Revision: B.06.00 or above

Query

 Range: 000-000000 to 255-14777215, or null

*RST Setting

null

Programming Example

OUTPUT 714;"CALL:MS:REPorted:ESNumber?" !Queries the decimal value of the ESN.

CALL:MS:REPorted:ESNumber:HEX?

Function

Queries the hexadecimal formatted version of the electronic serial number. Returns a string of hexadecimal characters. Used only in active cell operating mode.

Query

 Range: 0x00000000 to 0xFFFFFFFF, or null

*RST Setting

null

Programming Example

OUTPUT 714;"CALL:MS:REPorted:ESNumber:HEX?" !Queries the Hexadecimal value of the ESN.


CALL:MS:REPorted<:MCC|:MEID|:MIN1|:MIN2|:MNC|MSIN>

CALL:MS:REPorted<:MCC|:MEID|:MIN1|:MIN2|:MNC|MSIN>

Last updated: June 6, 2007

GPIB Command Conventions

  • CALL:MS:REPorted:MCCode?
  • CALL:MS:REPorted:MEIDentifier:[:DECimal]?
  • CALL:MS:REPorted:MEIDentifier:HEX?
  • CALL:MS:REPorted:MEIDentifier:QUERy
  • CALL:MS:REPorted:MEIDentifier:SUPPorted?
  • CALL:MS:REPorted:MIN1:HEX?
  • CALL:MS:REPorted:MIN2:HEX?
  • CALL:MS:REPorted:MNCode?
  • CALL:MS:REPorted:MSINumber?

CALL:MS:REPorted:MCCode?

Function

Queries the mobile country code (MCC), as reported by the mobile station.

Query

Range:

  • '0' to '999' (up to 3 digits from the set of 0123456789, enclosed by quotes)
  • '' (null string)

*RST Setting

 '' (null string)

Programming Example

OUTPUT 714;"CALL:MS:REPORTED:MCCODE?"

CALL:MS:REPorted:MEIDentifier:[:DECimal]?

Function

Queries the MEID value in decimal format. It is returned as a string. See MEID for details.

Query

Range:

  • '' (Null) (when a MEID is not reported)
  • 19 characters in the form of "xxxxxxxxxx-xxxxxxxx", where the x's are characters from the set 0123456789

*RST Setting

 '' (null string)
Requirement

Test Application Revision: B.10 and above

Lab Application Revision: B.03.10 and above

Programming Example

OUTPUT 714;"CALL:MS:REPorted:MEIDentifier?"
!Queries the decimal value of the MEID.

CALL:MS:REPorted:MEIDentifier:HEX?

Function

Queries the MEID value reported by the mobile station in hexadecimal format. It is returned as a string. See MEID for details.

Query

Range:

  • '' (Null) (when a MEID is not reported)
  • '0x00000000000000' to '0xFFFFFFFFFFFFFF' (0x plus 14 characters from the set 0123456789ABCDEF)

*RST Setting

 '' (null string)
Requirement

Test Application Revision: B.10 and above

Lab Application Revision: B.03.10 and above

Programming Example

OUTPUT 714;"CALL:MS:REPorted:MEIDentifier:HEX?"
!Queries the hexadecimal value of the MEID.

CALL:MS:REPorted:MEIDentifier:QUERy

Function

Commands an MEID-equipped mobile station to report its MEID value. See MEID / Enhanced PLCM .
Requirement

Test Application Revision: B.10 and above

Lab Application Revision: B.03.10 and above

Programming Example

OUTPUT 714;"CALL:MS:REPorted:MEIDentifier:QUERy"
!Commands the MS to report its MEID value.

CALL:MS:REPorted:MEIDentifier:SUPPorted?

Function

Queries whether the MS is an MEID-equipped or an ESN-equipped equipment. See MEID Supported for details.

Query

Range: YES|NO|UNKN

  • YES (MEID-equipped MS)
  • NO (ESN-equipped MS)
  • UNKN (when a MEID Indicator is not reported)

*RST Setting

UNKN

Requirement

Test Application Revision: B.10 and above

Lab Application Revision: B.03.10 and above

Programming Example

OUTPUT 714;"CALL:MS:REPorted:MEIDentifier:SUPPorted?"
!Queries whether MS supports of MEID or not.

CALL:MS:REPorted:MIN1:HEX?

Function

Queries the 24 bits of the mobile identification number that represent the mobile station's 7 digit phone number. Returns a string of hexadecimal characters.

When the MS registers, the MS sends a 34 bit Mobile Identification Number that is divided into MIN1 (24 bits) representing the MS's 7 digit phone number and MIN2 (10 bits) representing the 3 digit area code. When the 34 bit Mobile Identification Number value is received by the test set, Paging Phone Number, MIN1 and MIN2 will be updated.

Used only in Active Cell mode and AMPS system.

Query

Range:

  • '0x000000' to '0xFFFFFF' (0x plus 6 characters from the set of 0123456789ABCDEF, enclosed by quotes)
  • '' (null string)

*RST Setting

 '' (null string)

Programming Example

OUTPUT 714;"CALL:MS:REPORTED:MIN1:HEX?"
!Returns the MIN1 value.

CALL:MS:REPorted:MIN2:HEX?

Function

Queries the 10 bits of the mobile identification number that represent the mobile station's 3 digit area. Returns a string of hexadecimal characters. Used only in active cell operating mode.

When the MS registers, the MS sends a 34 bit Mobile Identification Number that is divided into MIN1 (24 bits) representing the MS's 7 digit phone number and MIN2 (10 bits) representing the 3 digit area code. When the 34 bit Mobile Identification Number value is received by the test set, Paging Phone Number, MIN1 and MIN2 will be updated.

Used only in Active Cell mode and AMPS system.

Query

Range:

  • '0x000' to '0x3FF' (0x plus 3 characters from the set of 0123456789ABCDEF, enclosed by quotes)
  • '' (null string)

*RST Setting

'' (null string)

Programming Example

OUTPUT 714;"CALL:MS:REPORTED:MIN2:HEX?"

CALL:MS:REPorted:MNCode?

Function

Queries the mobile network code (MNC), as reported by the mobile station.

Query

Range:

  • '0' to '999' (up to 3 digits from the set of 0123456789, enclosed by quotes)
  • '' (null string)

*RST Setting

 '' (null string)

Programming Example

OUTPUT 714;"CALL:MS:REPORTED:MNCODE?"

CALL:MS:REPorted:MSINumber?

Function

Queries the mobile station reported mobile station identification number.

Query

Range: returns up to 10 digits string enclosed by quotes, each digits from the set of 0123456789

*RST Setting

 '' (null string)

Programming Example

OUTPUT 714;"CALL:MS:REPORTED:MSINUMBER?"


CALL:MS:REPorted<:ONUMber|:OPERating>

CALL:MS:REPorted<:ONUMber|:OPERating>

Last updated: June 6, 2007

GPIB Command Conventions

  • CALL:MS:REPorted:ONUMber?
  • CALL:MS:REPorted:OPERating:MODE?

CALL:MS:REPorted:ONUMber?

Function

Queries the phone number the mobile station dialed in a mobile originated call. Used only in active cell mode. Returns a string of up to 16 digits.

Query

Range: up to 16 digits: 0 through 9, *, #, or null

*RST Setting

null

Programming Example

OUTPUT 714;"CALL:MS:REPorted:ONUMber?" !Returns the phone number the mobile dialed.

CALL:MS:REPorted:OPERating:MODE?

Function

This query returns up to three concatenated mobile station reported operating modes.

Each operating mode that is included in the returned string is right-justified within an 8-character slot. Each 8-character slot is followed by a comma and a space until the last band is sent. The last band in the string will not have an appended comma and a space. Each operating mode that is included in the returned string will correspond, by its position in the string, with the position of each band class in the string returned by the command CALL:MS:REPorted:BCLass? .

Unless the Status Request Query is set to "OFF" by the command CALL:MS:REPorted:REQuest[:ENAble] , each time a new mobile station registers with the test set, the test set will have the mobile station report band classes, mobile station reported operating mode for each band class, and mobile station reported Max EIRP (if the operating mode is CDMA) for each band class. These results are referred to as Status Request Information.

Query

Range: DualMode|CDMA|Analog|N-Analog|W-Analog|Null

*RST Setting

 Null

Programming Example

OUTPUT 714;"CALL:MS:REPorted:OPERating:MODE? !when sent to a mobile station supporting US cellular and US PCS bands, might return something similar to the following string:

"<sp><sp>Analog,<sp><sp><sp><sp><sp>CDMA".

Note that this string consists of 16 characters (8 for each band) plus a comma and space separating the two operating mode.


CALL:MS:REPorted<:PCLass|:PCONtrol|:PNUMber|:PREVision>

CALL:MS:REPorted<:PCLass|:PCONtrol|:PNUMber|:PREVision>

Last updated: June 6, 2007

GPIB Command Conventions

  • CALL:MS:REPorted:PILot:STRength:REQuest[:IMMediate]
  • CALL:MS:REPorted:PILot:STRength:REQuest:TIME?
  • CALL:MS:REPorted:PILot:STRength:REPort[:ALL]?
  • CALL:MS:REPorted:PILot:STRength:REPort:CLEar

CALL:MS:REPorted:PCLass[:SELected]?

Function

Queries the mobile reported power class as part of the station class mark (SCM) for the active (that is the selected) radio format.

Used only in active cell operating mode and AMPS system.

Query

Range: 1 through 8, 9.91 E+37

*RST Setting

9.91 E+37

Programming Example

OUTPUT 714;"CALL:MS:REPorted:PCLass?" !Returns the MS reported power class.

CALL:MS:REPorted:PCONtrol:STEP[:MINimum]?

Function

Queries the mobile reported minimum power control step size.

The actual power control step size used by the mobile during closed loop power control is set using the CALL[:CELL]:CLPControl:REVerse:STEP command. The mobile reported minimum power control step size indicates the smallest step the mobile is capable of making during closed loop power control.

Query

Range: DB1|DBH|DHQ|UNKN

*RST Setting

DB1

Programming Example

OUTPUT 714;"CALL:MS:REPorted:PCONtrol:STEP?"

CALL:MS:REPorted:PNUMber?

Function

Queries the mobile station reported phone number. When the mobile station registers, the 34 bit mobile identification number (MIN) is used to set the MS reported phone number and paging phone number. If the MIN does not translate into a valid phone number, set the ms reported phone number and paging phone number to 0000000000. Used only in active cell operating mode and AMPS system.

Query

Range: Up to 10 characters 0 through 9, or null

*RST Setting

null

Programming Example

OUTPUT 714;"CALL:MS:REPorted:PNUMber?" !Returns the phone number of the mobile.

CALL:MS:REPorted:PREVision?

Function

Queries the mobile reported protocol revision. The values returned have the following definitions:

0 = Null String
1 = J_STD-008 (if CELL:BAND? returns USPC) or
Korean PCS (if CELL:BAND? returns KPCS)
2 = Null String
3 = TSB-74 (if CELL:BAND? returns USC) or ARIB_T53 (if CELL:BAND? returns JCDM
4 = IS-95B
5 = IS-95B plus
6 = IS-2000 Rev0
7 = Null string

Query

Range: 0 to 7, 9.91 E+36

*RST Setting

9.91 E+36

Programming Example

OUTPUT 714;"CALL:MS:REPorted:PREVision?"


CALL:MS:REPorted:QPCHannel

CALL:MS:REPorted:QPCHannel

Last updated: June 6, 2007

GPIB Command Conventions

  • CALL:MS:REPorted:QPCHannel[:SUPPort]?

CALL:MS:REPorted:QPCHannel[:SUPPort]?

Function

Queries whether the mobile supports quick paging. When the test set's quick paging channel state is on it will send out slotted quick pages.

Query

Range: YES|NO|UNKN

*RST Setting

 CLEARED

Programming Example

OUTPUT 714;"CALL:MS:REPorted:QPCHannel?"


CALL:MS:REPorted<:RCONfig|:REGistration|:REQuest|:REVision>

CALL:MS:REPorted<:RCONfig|:REGistration|:REQuest|:REVision>

Last updated: June 6, 2007

GPIB Command Conventions

  • CALL:MS:REPorted:RCONfig:ENHanced[:SUPPort]?
  • CALL:MS:REPorted:REGistration[:TYPE]?
  • CALL:MS:REPorted:REQuest[:ENAble]
  • CALL:MS:REPorted:REVision:ANALog?

CALL:MS:REPorted:RCONfig:ENHanced[:SUPPort]?

Function

 Queries whether or not the mobile station supports enhanced radio configurations, as reported by the mobile station. If the mobile station supports any radio configuration in radio configuration class 2, this mobile station reported result will be YES.

Query

Range: YES|NO|UNKN

*RST Setting

 UNKN

Programming Example

OUTPUT 714;"CALL:MS:REPorted:RCONfig:ENHanced?"

CALL:MS:REPorted:REGistration[:TYPE]?

Function | Queries the type of registration that was last received by the test set, as reported by the mobile station.
Query | Range: ZONE|TIMER|POWERUP|POWERDOWN|PARAMETERCHANGE |ORDERED|DISTANCE|USERZONE|CLEARED
*RST Setting | CLEARED
Programming Example OUTPUT 714;"CALL:MS:REPorted:REGistration?"

CALL:MS:REPorted:REQuest[:ENAble]

Function

Set/queries whether or not the status request queries will be performed to determine the capabilities of the phone whenever a registration, page request, or origination operation is conducted if that information does not already exist in the mobile station database. Used only in active cell operating mode.

Unless the Status Request Query is set to "OFF", each time a new mobile station registers with the test set, the test set will have the mobile station reported band classes, mobile station reported operating mode for each band class, and mobile station reported max EIRP (if the operating mode is CDMA) for each band class. These results are referred to as Status Request Information.

The test set needs to know the maximum EIRP (effective isotropic radiated power) of the mobile station to perform receiver ranging properly. When the Status Request Query is set to "OFF" and the MS Database is cleared, then the Max EIRP set by the command CALL:MS:REPorted:EIRPower:DEFault will be used for all band class connections.

Requirements

 Test Application Revision: B.06.00 or above

Setting

Range: 1|ON|0|OFF

Query

Range: 1|0

*RST Setting

 1 (ON)

Programming Example

OUTPUT 714;"CALL:MS:REPorted:REQuest OFF" !Set the Status Request Query to OFF.

CALL:MS:REPorted:REVision:ANALog?

Function

 Queries the analog mobile reported protocol version that the mobile station supports. Used only in active cell operating mode.
Query Range: 0 to 3, 9.91E+37

Protocol Version:
0 (TIA/EIA-553/IS-54-A MS)
1 (TIA/EIA 627 dual-mode MS)
2 (IS-95 dual mode MS)
3 (TIA/EIA-136 dual-mode MS)
9.91E+37

*RST Setting

9.91 E+37

Programming Example

OUTPUT 714;"CALL:MS:REPorted:REVision:ANALog?"


CALL:MS:REPorted<:SCINdex|:SCLass>

CALL:MS:REPorted<:SCINdex|:SCLass>

Last updated: June 6, 2007

GPIB Command Conventions

  • CALL:MS:REPorted:SCINdex?
  • CALL:MS:REPorted:SCLass?

CALL:MS:REPorted:SCINdex?

Function

 Queries the mobile reported slot cycle index, as reported by the mobile station.

Query

Range: 0 to 7, 9.91 E+37

*RST Setting

 9.91 E+37

Programming Example

OUTPUT 714;"CALL:MS:REPorted:SCINdex?"

CALL:MS:REPorted:SCLass?

Function

Queries the mobile reported slot class, as reported by the mobile station. The test set will page the mobile station in slotted mode unless the mobile station has registered as non-slotted (NSL).

Query

Range: SLOT|NSL|UNKN

*RST Setting

UNKN

Programming Example

OUTPUT 714;"CALL:MS:REPorted:SCLass?"


CALL:MS:REPorted:TXType

CALL:MS:REPorted:TXType

Last updated: June 6, 2007

GPIB Command Conventions

  • CALL:MS:REPorted:TXType?

CALL:MS:REPorted:TXType?

Function

Queries the mobile reported discontinuous transmission support as part of the station class mark (SCM) for AMPS systems.

Query

Range: CONT|DISC|UNKN

*RST Setting

UNKN

Programming Example

OUTPUT 714;"CALL:MS:REPorted:TXType?"


CALL:NIDentity

CALL:NIDentity

Last updated: June 6, 2007

GPIB Command Conventions

  • CALL[:CELL]:NIDentity

CALL[:CELL]:NIDentity

Function

Sets/queries the network ID (NID).

This parameter can be set any time and will be sent out in the next overhead message.

Setting

Range: 0 to 65535

Query

Range: 0 to 65595

*RST Setting

1

Programming Example

OUTPUT 714;"CALL:CELL:NIDENTITY 3056" !Sets the network identifier to 3056.


CALL:OCNSource

CALL:OCNSource

Last updated: June 6, 2007

GPIB Command Conventions

  • CALL[:CELL[1]]:OCNSource:LEVel[:SELected]?
  • CALL[:CELL[1]]:OCNSource:STATe[:SELected]?
  • CALL[:CELL[1]]:OCNSource:WALSh[:SELected]

CALL[:CELL[1]]:OCNSource:LEVel[:SELected]?

Function

Queries the calculated level of the (Cell 1) F-OCNS (orthogonal channel noise simulator).

If the contribution of OCNS is calculated to be -30 dB or less, the OCNS state is turned off.

The optional [:SELected] keyword in this command specifies that the OCNS level being queried applies to the current system type.

The OCNS level is a calculated value used to balance the relative power levels of the following channels to sum to 100%:

  • OCNS
  • Paging (PCH)
  • Pilot (PICH)
  • Sync (SCH)
  • Fundamental (FCH)
  • Supplemental (SCH)
  • Quick Paging (QPCH)

Query

Range: 0 to -20 dB, NAN

Resolution: 0.01 dB

*RST Setting

 NAN

Programming Example

OUTPUT 714;"CALL:OCNSOURCE:LEVEL?" !Queries the (Cell 1)calculated OCNS level.

CALL[:CELL[1]]:OCNSource:STATe[:SELected]?

Function

Queries the on/off state of the (Cell 1) F-OCNS (orthogonal channel noise simulator).

If the contribution of OCNS is calculated to be -30 dB or less, the OCNS state is turned off.

The optional [:SELected] keyword in this command specifies that the OCNS on/off state being queried applies to the current system type.

The OCNS level is a calculated value used to balance the relative power levels of the following channels to sum to 100%:

  • OCNS
  • Paging (PCH)
  • Pilot (PICH)
  • Sync (SCH)
  • Fundamental (FCH)
  • Supplemental (SCH)
  • Quick Paging (QPCH)

If the contribution of OCNS is calculated to be -30 dB or less, the OCNS state is turned off.

Setting

Range: 1|0

*RST Setting

1 (on)

Programming Example

OUTPUT 714;"CALL:OCNSOURCE:STATE?" !Queries the current on/off state of (Cell 1) OCNS.

CALL[:CELL[1]]:OCNSource:WALSh[:SELected]

Function

Sets/queries the (Cell 1) F-OCNS (orthogonal channel noise simulator) Walsh Code.

The optional [:SELected] keyword in this command specifies that the OCNS Walsh code being set/queried applies to the current system type.

The Walsh codes allowed for use with this command are part of a reserved code space that has been created by fixing other code channels to predetermined values. Reserving this codespace eliminates the possibility of conflicts that can arise with lower walsh code sets which are used in certain radio configurations.

Setting

Range: CODE5|CODE13|CODE21|CODE29|CODE37|CODE45|CODE53|CODE61

Query

Range: 5|13|21|29|37|45|53|61

*RST Setting

 CODE53

Programming Example

OUTPUT 714;"CALL:OCNSOURCE:WALSH CODE13" !Sets the (Cell 1) OCNS channel to walsh code 13.

Related Topics

CALL:CELL2:OCNSource ( Lab Application only )


CALL:OPERating

CALL:OPERating

Last updated: June 6, 2007

GPIB Command Conventions

  • CALL[:CELL]:OPERating:MODE

CALL[:CELL]:OPERating:MODE

Function

Sets/queries the operating mode of the base station emulator. If a call is in progress during a change in operating mode it will be dropped.

CALL (also called Active Cell mode) is the default operating mode. In CALL mode, signaling between the mobile station and the base station emulator is used for call origination, handoffs, and other operations that simulate in-service mobile interaction. When CALL is selected, closed loop power control will be automatically set to its active mode. See CALL[:CELL[1]]:CLPControl:REVerse:MODE<[:SELected]|:TA2000> for closed loop power control commands.

D2KTest (also called IS-2000 Test) mode commands the test set to transmit a forward CDMA channel with no call processing capability. In this mode, a mobile station that complies with IS-2000 test mode will camp on to the forward channel. The test set will continually send an F-FCH on the user entered Walsh code, which the mobile station can use to make FER measurements. The mobile station must begin transmitting the R-FCH before reverse link measurements can be made.

AVCTest mode generates a forward analog voice channel to make measurements on mobiles in analog test mode. The SAT can be turned on or off in this mode. Internal and external FM are available. There is no over-the-air signaling available.

CW mode makes the test set operate like a signal generator with level (cell power) and frequency (RF generator frequency) control. No reverse demodulation or decoding is available. No over-the-air signaling is available.

OFF (also called Cell Off) mode share the same settings with Active Cell operating mode. However, there is no over-the-air signaling available. All settings are deferred until the Active Cell operating mode is used.

Setting

 Range: AVCTest|CALL|D2KTest|CW|OFF

Query

Range: AVCT|CALL|D2KT|CW|OFF

*RST Setting

CALL

Programming Example

OUTPUT 714;"CALL:OPERating:MODE D2KTest" !Selects IS-2000 test mode.


CALL:ORIGinate

CALL:ORIGinate

Last updated: June 6, 2007

GPIB Command Conventions

  • CALL:ORIGinate
  • CALL:ORIGinate:DONE?
  • CALL:ORIGinate:OPComplete?
  • CALL:ORIGinate:SEQuential
  • CALL:ORIGinate:WAIT

CALL:ORIGinate

Function

Generates a page attempt to the mobile station.

If the call attempt fails, the test set will return to the idle call processing state.

NOTE
In lab application, this command can also be used for sending SMS messaging during an SO6 or SO14 connection. See method 2 in Sending an SMS Message to the Mobile Station .

Programming Example

OUTPUT 714;"CALL:ORIGINATE" !pages the mobile station

CALL:ORIGinate:DONE?

Function

 See Call Processing Event Synchronization

Query

Range: 1|0

Programming Example

OUTPUT 714;"CALL:ORIGINATE:DONE?"

CALL:ORIGinate:OPComplete?

Function

 See Call Processing Event Synchronization

Query

Range: 1

Programming Example

OUTPUT 714;"CALL:ORIGINATE:OPCOMPLETE?"

CALL:ORIGinate:SEQuential

Function

See Call Processing Event Synchronization

Programming Example

OUTPUT 714;"CALL:ORIGINATE:SEQUENTIAL"

CALL:ORIGinate:WAIT

Function

 See Call Processing Event Synchronization

Programming Example

OUTPUT 714;"CALL:ORIGINATE:WAIT"


CALL:PAGing

CALL:PAGing

Last updated: June 6, 2007

GPIB Command Conventions

  • CALL:PAGing[:SLEVel][:SELected]
  • CALL:PAGing:DRATe
  • CALL:PAGing:IMSI:TYPE
  • CALL:PAGing:IMSI:MCC
  • CALL:PAGing:IMSI:MNC
  • CALL:PAGing:IMSI:MSIN
  • CALL:PAGing:LEVel[:SELected]
  • CALL:PAGing:PNUMber
  • CALL:PAGing:SCINdex[:MAXimum]
  • CALL:PAGing:STATe[:SELected]
  • CALL:PAGing:MERRor:PROCedure:PARameter:CLEar
  • CALL:PAGing:MERRor:PROCedure:STARt
  • CALL:PAGing:MERRor:PROCedure:STOP

CALL:PAGing[:SLEVel][:SELected]

Function

The setting form of this command performs two functions: (1) sets the PCH (forward paging channel) level, and (2) turns the PCH on/off state to ON.

The query form returns the PCH level.

The optional [:SELected] keyword in this command specifies that the PCH level and state being set/queried applies to the current system type. See CALL[:CELL]:SYSTem[:TYPE] to query or change the current system type.

Setting

 Range: 0 to -20 dB

Query

Range: 0 to -20 dB, NAN

*RST Setting

 -12 dB

Programming Example

OUTPUT 714;"CALL:PAGING:SLEVEL:SELECTED -10"

CALL:PAGing:DRATe

Function

Sets/queries the forward paging channel (PCH) data rate. FULL indicates 9.6 kbps and HALF indicates 4.8 kbps.

Setting

 Range: FULL|HALF

Query

Range: FULL|HALF

*RST Setting

FULL

Programming Example

OUTPUT 714;"CALL:PAGING:DRATE HALF"
!Sets the PCH data rate to 4.8 kbps.

CALL:PAGing:IMSI:TYPE

Function

Sets/queries the international mobile subscriber identity IMSI type.

This parameter will be overwritten when a new MSIN (Mobile Station Identification Number) is reported by the mobile station during registration.

Setting

Range: ALL|MCMS|MNMS|MSIN

MCMS = mobile country code (MCC) + mobile station identification number (MSIN)
MNMC = mobile network code (MNC) + mobile station identification number (MSIN)
MSIN = mobile station identification number (MSIN) only.

Query

Range: ALL|MCMS|MNMS|MSIN

*RST Setting

ALL

Programming Example

OUTPUT 714;"CALL:PAGING:IMSI:TYPE MCMS"

CALL:PAGing:IMSI:MCC

Function

Sets/queries the mobile country code.

This parameter will be overwritten when a new MSIN (Mobile Station Identification Number) is reported by the mobile station during registration. If paging MCC is reported by the mobile station and there are fewer digits than expected, the test set will assume leading zeroes.

Setting

Range: 3 digit string, enclosed by quotes

Query

 same as setting

*RST Setting

 310

Programming Example

OUTPUT 714;"CALL:PAGING:IMSI:MCC '222'"

CALL:PAGing:IMSI:MNC

Function

Sets/queries the mobile network code.

This parameter will be overwritten when a new MSIN (Mobile Station Identification Number) is reported by the mobile station during registration. If paging MNC is reported by the mobile station and there are fewer digits than expected, the test set will assume leading zeroes.

Setting

Range: 2 digit string, enclosed by quotes

Query

same as setting

*RST Setting

 00

Programming Example

OUTPUT 714;"CALL:PAGING:IMSI:MNC '10'"

CALL:PAGing:IMSI:MSIN

Function

Sets/queries the mobile country code.

This parameter will be overwritten when a new MSIN (Mobile Station Identification Number) is reported by the mobile station during registration. If paging MSIN is reported by the mobile station and there are fewer digits than expected, the test set will assume leading zeroes.

Setting

Range: 10 digit string, enclosed by quotes

Query

same as setting

*RST Setting

 5099214001

Programming Example

OUTPUT 714;"CALL:PAGING:IMSI:MSIN '5099213572'"
!sets the paging IMSI MSIN to 5099213572.

CALL:PAGing:LEVel[:SELected]

Function

Sets/queries the paging level.

The optional [:SELected] keyword in this command specifies that the paging channel level being set/queried applies to the current system type. See CALL[:CELL]:SYSTem[:TYPE] to query or change the current system type.

Setting

 Range: 0 to -20 dB

Query

Range: 0 to -20 dB, NAN

*RST Setting

 -12 dB

Programming Example

OUTPUT 714;"CALL:PAGING:LEVEL:SELECTED -10"

CALL:PAGing:PNUMber

Function

Sets/queries the paging phone number. When the mobile station registers, the 34 bit mobile identification number (MIN) is used to set the MS reported phone number and paging phone number. If the MIN does not translate into a valid phone number, the ms reported phone number and paging phone number are set to 0000000000. This setting is overwritten when the phone number is updated.

When setting the paging number, the value is entered as a string (not as a numeric entry). Be sure to enclose the paging number in single quotes.

Setting

 Range: up to 10 characters: 0 through 9, or null, enclosed by quotes

Query

same as setting

*RST Setting

null

Programming Example

OUTPUT 714;"CALL:PAGING:PNUMBER '8005551212'"
!Set the paging number to 8005551212.

CALL:PAGing:SCINdex[:MAXimum]

Function

Sets/queries the maximum slot cycle index.

The test set will page the mobile station using slotted mode unless the mobile station has registered as non-slotted. The test set will use the lesser value of maximum slot cycle index or CALL:MS:REPorted:SCINdex? for slotted paging.

Setting

Range: 0 to 7

Query

Range: 0 to 7

*RST Setting

 1

Programming Example

OUTPUT 714;"CALL:PAGING:SCINDEX 2"

CALL:PAGing:STATe[:SELected]

Function

Sets/queries the forward paging channel on/off state.

The optional [:SELected] keyword in this command specifies that the paging channel state being set/queried applies to the current system type. See CALL[:CELL]:SYSTem[:TYPE] to query or change the current system type.

Setting

 Range: 1|ON|0|OFF

Query

Range: 1|0

*RST Setting

 1 (on)

Programming Example

OUTPUT 714;"CALL:PAGING:STATE:DIGITAL2000 OFF"
!Sets the IS-2000 paging on/off state to off.

CALL:PAGing:MERRor:PROCedure:PARameter:CLEar

Function

This command is used to clear the paging channel MER results which include:

  • Slotted Paging Channel MER ( CALL:STATus:PAGing:MERRor:RATio[:SLOTed]? )
  • MS PAG_3 ( CALL:MS:RSParameter:PAG3? )
  • F-Paging Messages ( CALL:STATus:PAGing:MERRor:MESSages? )
  • Paging MER Test Time ( CALL:STATus:PAGing:MERRor:TIME? )
  • MER Proc Warning ( CALL:STATus:PAGing:MERRor:PROCedure:WARNing? )

See Paging Channel MER Results for details.

Requirements

Lab Application Revision: B.01 and above

Programming Example

OUTPUT 714;"CALL:PAGing:MERRor:PROCedure:PARameter:CLEar"
!Clear the Paging MER results and counters.

CALL:PAGing:MERRor:PROCedure:STARt

Function

This command is used to start the Paging MER test procedure. It's valid only when a call is established and paging channel is active.

See Paging Channel MER Procedures for details.

Requirements

Lab Application Revision: B.01 and above

Programming Example

OUTPUT 714;"CALL:PAGing:MERRor:PROCedure:STARt"
!Start the Paging MER test procedure.

CALL:PAGing:MERRor:PROCedure:STOP

Function

This command is used to stop the Paging MER test procedure after which the Slotted Paging MER ( CALL:STATus:PAGing:MERRor:RATio[:SLOTed]? ) is calculated. It's valid only when a call is established and the Paging MER test procedure is still in progress (initiated by the CALL:PAGing:MERRor:PROCedure:STARt ).

See Paging Channel MER Procedures for details.

Requirements

Lab Application Revision: B.01 and above

Programming Example

OUTPUT 714;"CALL:PAGing:MERRor:PROCedure:STOP"
!Stop the Paging MER test procedure.


CALL:PARameter:EACCess

CALL:PARameter:EACCess

Last updated: June 6, 2007

GPIB Command Conventions

  • CALL[:CELL]:PARameter:EACCess:DRATe[:SUPPorted]
  • CALL[:CELL]:PARameter:EACCess:ICORrection[:MAXimum]
  • CALL[:CELL]:PARameter:EACCess:ICORrection:THReshold
  • CALL[:CELL]:PARameter:EACCess:POWer:INITial
  • CALL[:CELL]:PARameter:EACCess:POWer:NOMinal
  • CALL[:CELL]:PARameter:EACCess:POWer:STEP[:LEVel]
  • CALL[:CELL]:PARameter:EACCess:POWer:STEP:COUNt
  • CALL[:CELL]:PARameter:EACCess:RLGain:CTPilot

CALL[:CELL]:PARameter:EACCess:DRATe[:SUPPorted]

Function

Sets/queries the coding rate, frame size and data rate that the test set directs the mobile station to transmit on the enhanced access channel. See IS-2000 Enhanced Access Parameters .

Setting

Range: Q20Bps9600|Q20Bps19200|Q20All

Q20Bps9600 - Quarter (1/4) code rate, 20 ms frame size, 9600 bps data rate
Q20Bps19200 - Quarter (1/4) code rate, 20 ms frame size, 19200 bps data rate
Q20All - Quarter (1/4) code rate, 20 ms frame size, 9600 bps and 19200 bps data rates

Query

Range: Q20B9600|Q20B19200|Q20A

*RST Setting

Q20Bps9600

Requirements

Test Application Revision: B.08 and above, with the required feature license

Lab Application Revision: B.02 and above

Programming Example

OUTPUT 714;"CALL:PARameter:EACCess:DRATe Q20Bps19200"
!Sets the R-EACH data rate to 19.2 kbps
!in 20 ms frame size and 1/4 code rate.

CALL[:CELL]:PARameter:EACCess:ICORrection[:MAXimum]

Function

Sets/queries the maximum interference correction (IC_MAX) that can be applied for the R-EACH. See also IS-2000 Enhanced Access Parameters .

Setting

Range: 0 to 15 dB

Resolution: 1 dB

Query

Range: same as setting

*RST Setting

 7 dB

Requirements

Test Application Revision: B.08 and above, with the required feature license

Lab Application Revision: B.02 and above

Programming Example

OUTPUT 714;"CALL:PARameter:EACCess:ICORrection 10"
!Sets the maximum interference correction to 10.

CALL[:CELL]:PARameter:EACCess:ICORrection:THReshold

Function

Sets/queries the threshold level (IC_THRESHOLD) at which the interference correction begins to be applied for the mobile station output power. See also IS-2000 Enhanced Access Parameters .

Setting

Range: 0 to 15 dB

Resolution: 1 dB

Query

Range: same as setting

*RST Setting

 7 dB

Requirements

Test Application Revision: B.08 and above, with the required feature license

Lab Application Revision: B.02 and above

Programming Example

OUTPUT 714;"CALL:PARameter:EACCess:ICORrection:THReshold 5"
!Sets the interference correction threshold level to 5 (-5 dB).

CALL[:CELL]:PARameter:EACCess:POWer:INITial

Function

Sets/queries the initial power correction for the enhanced access channel. See also IS-2000 Enhanced Access Parameters .

Setting

Range: -16 to 15 dB

Resolution: 1 dB

Query

Range: same as setting

*RST Setting

 0 dB

Requirements

Test Application Revision: B.08 and above, with the required feature license

Lab Application Revision: B.02 and above

Programming Example

OUTPUT 714;"CALL:PARameter:EACCess:POWer:INITial -10"
!Sets the initial power to -10 dB.

CALL[:CELL]:PARameter:EACCess:POWer:NOMinal

Function

Sets/queries the nominal power offset for the enhanced access channel. See also IS-2000 Enhanced Access Parameters .

Setting

Range: -16 dB to 15 dB

Resolution: 1 dB

Query

Range: same as setting

*RST Setting

 0 dB

Requirements

Test Application Revision: B.08 and above, with the required feature license

Lab Application Revision: B.02 and above

Programming Example

OUTPUT 714;"CALL:PARameter:EACCess:POWer:NOMinal -5"
!Sets the nomiinal power offset to -5 dB.

CALL[:CELL]:PARameter:EACCess:POWer:STEP[:LEVel]

Function

Sets/queries the power increase that the mobile station is to transmit between successive access probes in an access probe sequence for the R-EACH. See IS-2000 Enhanced Access Parameters .

Setting

Range: 0 to 7 dB per step

Resolution: 1 dB

Query

Range: same as setting

*RST Setting

 3 dB

Requirements

Test Application Revision: B.08 and above, with the required feature license

Lab Application Revision: B.02 and above

Programming Example

OUTPUT 714;"CALL:PARameter:EACCess:POWer:STEP 2"
!Sets the power step size to 2 dB per step.

CALL[:CELL]:PARameter:EACCess:POWer:STEP:COUNt

Function

Sets/queries the number of enhanced access probes that a mobile station is to transmit in a single access probe sequence. See IS-2000 Enhanced Access Parameters .

Setting

Range: 0 to 15

Resolution: integer

Query

Range: same as setting

*RST Setting

 3

Requirements

Test Application Revision: B.08 and above, with the required feature license

Lab Application Revision: B.02 and above

Programming Example

OUTPUT 714;"CALL:PARameter:EACCess:POWer:STEP:COUNt 5"
!Sets the number of enhanced access probes
!in a single access probe sequence to 5.

CALL[:CELL]:PARameter:EACCess:RLGain:CTPilot

Function

Sets/queries the gain adjustment (RLGAIN_COMMON_PILOT) of the enhanced access channel (R-EACH) relative to the reverse pilot channel (R-Pilot). It times 0.125 to convert to dB. See IS-2000 Enhanced Access Parameters .

Setting

Range: -32 to +31 (corresponding to -4 dB to 3.875 dB)

Resolution: 1

Query

Range: same as setting

*RST Setting

 0

Requirements

Test Application Revision: B.08 and above, with the required feature license

Lab Application Revision: B.02 and above

Programming Example

OUTPUT 714;"CALL:PARameter:EACCess:RLGain:CTPilot 8"
!Sets the R-EACH relative to R-Pilot to 8 (corresponding to 1 dB).


CALL:PILot

CALL:PILot

Last updated: June 6, 2007

GPIB Command Conventions

  • CALL[:CELL[1]]:PILOT[:SLEVel][:SELected]
  • CALL[:CELL[1]]:PILOT:LEVel[:SELected]
  • CALL:PILOT:STATe[:SELected]

CALL[:CELL[1]]:PILOT[:SLEVel][:SELected]

Function

The setting form of this command performs two functions: (1) sets the (Cell 1) F-Pilot (forward pilot channel) level, and (2) turns the (Cell 1) F-Pilot state to ON.

The query form returns the (Cell 1) F-Pilot level.

The optional [:SELected] keyword in this command specifies that the (Cell 1) F-Pilot channel state and level being set/queried applies to the current system type. See CALL[:CELL]:SYSTem[:TYPE] to query or change the current system type.

Setting

Range: 0 to -20 dB

Resolution: 0.01 dB

Query

Range: 0 to -20 dB

Resolution: 0.01 dB

*RST Setting

-7 dB

Programming Example

OUTPUT 714;"CALL:PILOT:SLEVel -20"
!Sets the cell(Cell 1) pilot state to ON and sets the level to -20 dB.

CALL[:CELL[1]]:PILOT:LEVel[:SELected]

Function

Sets/queries the (Cell 1) F-Pilot level.

The optional [:SELected] keyword in this command specifies that the (Cell 1) F-Pilot level being set/queried applies to the current system type. See CALL[:CELL]:SYSTem[:TYPE] to query or change the current system type.

Setting

Range: 0 to -20 dB

Resolution: 0.01 dB

Query

Range: 0 to -20 dB

Resolution: 0.01 dB

*RST Setting

 -7 dB

Programming Example

OUTPUT 714;"CALL:PILOT:LEVEL -20"

CALL:PILOT:STATe[:SELected]

Function

Sets/queries the (Cell 1) F-Pilot (forward pilot channel) state.

The optional [:SELected] keyword in this command specifies that the (Cell 1) F-Pilot state being set/queried applies to the current system type. See CALL[:CELL]:SYSTem[:TYPE] to query or change the current system type.

Setting

Range: 1|ON|0|OFF

Query

Range: 1|0

*RST Setting

1 (on)

Programming Example

OUTPUT 714;"CALL:PILOT:STATE OFF"

Related Topics

CALL:CELL2:PILot ( Lab Application only )


CALL:PLCMask

CALL:PLCMask

Last updated: June 6, 2007

GPIB Command Conventions

  • CALL[:CELL]:PLCMask:TYPE

CALL[:CELL]:PLCMask:TYPE

Function

Sets/queries the public long code mask (PLCM) type, based on which an MEID-equipped MS derives its PLCM. See PLCM Type for details.

Setting

Range: ESN | BS | MEID

  • ESN (ESN Based)
  • BS (BS Assigned)
  • MEID (MEID Based)

Query

Range: same as setting

*RST Setting

ESN

Requirement

Test Application Revision: B.10 and above

Lab Application Revision: B.03.10 and above

Programming Example

OUTPUT 714;"CALL:PLCMask:TYPE MEID"
!Sets PLCM Type to MEID based.


CALL:PNOFfset

CALL:PNOFfset

Last updated: June 6, 2007

GPIB Command Conventions

  • CALL[:CELL[1]]:PNOFfest

CALL[:CELL[1]]:PNOFfest

Function

Sets/queries the Cell 1 pseudonoise (PN) offset. The Cell 1 PN offset is the timing of the cell's short codes relative to system time. Cell 1 PN offset and Cell 2 PN offset uniquely identify each simulated cell site to the mobile station.

Changing the Cell 1 PN offset while on a call will result in a hard handoff to the new PN offset.

The Cell 1 PN offset is also used to generate the list of neighbor PN offsets (NGHBR_PN) that is transmitted to the mobile station. The neighbor list is determined using the following rules:

  • The Cell 1 PN offset (PILOT_PN) will not appear in the neighbor list.
  • The increment between neighbor PN offsets in the neighbor list (PILOT_INC) will equal the greatest common factor, less than 16, of the Cell 1 and Cell 2 PN offsets.
  • At least one of the neighbor PN offsets shall equal the Cell 2 PN offset.

The Cell 1 PN offset determines the contents of the PILOT_PN message field transmitted in the Neighbor List Message, Extended Neighbor List Message, IS-2000 System Parameters Message, IS-2000 Extended Neighbor List Message, and the Neighbor List Update Message.

The Cell 1 PN offset also contributes to determining the contents of the PILOT_INC and NGHBR_PN message fields used to determine the neighbor list of PN offsets and transmitted in the messages listed above.

This command may take up to 2 seconds to complete.

Setting

Range: 0 to 511

Query

Range: 0 to 511

*RST Setting

12

Programming Example

OUTPUT 714;"CALL:PNOFfset 333" !Sets the PN offset to 333.

Related Topics

CALL:CELL2:PNOFfset ( Lab Application only )


CALL:POWer

CALL:POWer

Last updated: June 6, 2007

GPIB Command Conventions

  • CALL[:CELL[1]]:POWer[:SAMPlitude][:SELected]
  • CALL[:CELL[1]]:POWer:AMPLitude[:SELected]
  • CALL[:CELL[1]]:POWer:STATe[:SELected]

CALL[:CELL[1]]:POWer[:SAMPlitude][:SELected]

Function

The setting form of this command performs two functions: (1) sets the Cell Power level and (2) turns the cell power on/off state to on. The query form returns the Cell Power level (including compensation for amplitude offset) or NAN.

The optional [:SELected] keyword in this command specifies that the Cell Power level being set or queried applies to the current system type. The current system type can be changed using the CALL[:CELL]:SYSTem[:TYPE] command.

Cell Power and AWGN (see CALL:AWGNoise ) are absolute power levels and make up the total forward channel RF output power.

The return value for this query is not necessarily the cell power level being transmitted by the test set at the moment this command is processed by the test set. It may return a value that the test set has been requested to transmit, but that has been pended or delayed for some reason. See Troubleshooting Setting Power Levels for possible causes. To query the cell power level the test set is transmitting at the moment the command is sent, use the CALL:STATus:CELL[1]:POWer:[AMPLitude][:SELected]? command.

Setting

Range:

  • CDMA: -170 dBm/1.23 MHz to +37 dBm/1.23 MHz, 9.91 E+37
    (-120 dBm/1.23MHz to -13 dBm/1.23 MHz actual hardware range with amplitude offset = 0)

    The actual power range is defined by adding the value of the associated Amplitude Offset to the range shown above. See Cell Power, AWGN Power and Total RF Power Ranges .
  • AMPS: -177 to +40 dBm (-127 to -10 dBm actual hardware range with amplitude offset = 0)

Resolution: 0.01 dB

Query

Range: Same as setting range.

Resolution: 0.01 dB

*RST Setting
  • CDMA: -55 dBm/1.23 MHz
  • AMPS: -50 dBm

Programming Example

OUTPUT 714;"CALL:CELL:POWER:SAMPLITUDE -30"
!Sets the cell power state to ON and sets cell power level to -30 dBm.

CALL[:CELL[1]]:POWer:AMPLitude[:SELected]

Function

Sets/queries the cell power level (including compensation for amplitude offset).

The optional [:SELected] keyword in this command specifies that the cell power level being set or queried applies to the current system type. The current system type can be changed using the CALL[:CELL]:SYSTem[:TYPE] command.

Cell Power and AWGN (see CALL:AWGNoise ) are absolute power levels and make up the total forward channel RF output power.

The return value for this query is not necessarily the cell power level being transmitted by the test set at the moment this command is processed by the test set. It may return a value that the test set has been requested to transmit, but that has been pended or delayed for some reason. See Troubleshooting Setting Power Levels for possible causes. To query the cell power level the test set is transmitting at the moment the command is sent, use the CALL:STATus:CELL[1]:POWer:[AMPLitude][:SELected]? command.

Setting

Range:

  • CDMA: -170 dBm/1.23 MHz to +37 dBm/1.23 MHz, 9.91 E+37
    (-120 dBm/1.23MHz to -13 dBm/1.23 MHz actual hardware range with amplitude offset = 0)

    The actual power range is defined by adding the value of the associated Amplitude Offset to the range shown above. See Cell Power, AWGN Power and Total RF Power Ranges .
  • AMPS: -177 to +40 dBm (-127 to -10 dBm actual hardware range with amplitude offset = 0)

Resolution: 0.01 dB

Query

Range: Same as setting range.

Resolution: 0.01 dB

*RST Setting
  • CDMA: -55 dBm/1.23 MHz
  • AMPS: -50 dBm

Programming Example

OUTPUT 714;"CALL:CELL:POWER:AMPLITUDE -30"
!Sets the cell power level -30 dBm.

CALL[:CELL[1]]:POWer:STATe[:SELected]

Function

Sets/queries the cell power state.

The return value for this query is not necessarily the cell power state at the moment this command is processed by the test set. This command may return a state that has been requested of the test set, but that has been pended or delayed for some reason. See Troubleshooting Setting Power Levels for possible causes. To query the cell power state of the test set at the moment, use the CALL:STATus:CELL[1]:POWer:STATe[:SELected]? command.

The optional [:SELected] keyword in this command specifies that this query applies to the current system type. The current system type can be changed using the CALL[:CELL]:SYSTem[:TYPE] command.

Setting

Range: 1|ON|0|OFF

Query

Range: 1|0

*RST Setting

1 (ON)

Programming Example

OUTPUT 714;"CALL:CELL:POWER:STATE OFF" !Turns off cell power.

Related Topics

CALL:CELL2:POWer ( Lab Application only )


CALL:PROTocol

CALL:PROTocol

Last updated: June 6, 2007

GPIB Command Conventions

  • CALL[:CELL]:PROTocol[:SELected]
  • CALL[:CELL]:PROTocol:DIGital95
  • CALL[:CELL]:PROTocol:DIGital2000
  • CALL[:CELL]:PROTocol:CCHannel:CONFigure

CALL[:CELL]:PROTocol[:SELected]

Function

Sets/queries the protocol standard for the selected System Type.

NOTE
An additional feature license is required to enable the setting of PREV7 (for IS-2000 system) in a licensed test application, see Protocol Revisions .

Setting

Range: PREVision6|PREVision7|TSB74|JSTD8|D95B|AT53|KPCS

Query

Range: PREV6|PREV7|TSB74|JSTD8|D95B|AT53|KPCS

*RST Setting

 PREV6 (IS-2000-0)

Requirements

Test Application Revision: B.08 and above, with the required feature license: added PREV7.

Lab Application Revision: B.02 and above: added PREV7.

Programming Example

OUTPUT 714;"CALL:PROTocol PREV6"
!Selects protocal revision 6
!assuming current system type is IS-2000.

CALL[:CELL]:PROTocol:DIGital95

Function

Sets/queries the protocol standard for the IS-95 System Type. See Protocol Revisions .

Setting

Range: TSB74|JSTD8|D95B|AT53|KPCS

Query

Range: TSB74|JSTD8|D95B|AT53|KPCS

*RST Setting

 D95B (IS-95B)

Programming Example

OUTPUT 714;"CALL:PROTocol:DIGital95 KPCS"
!Selects Korean PCS for IS-95 system.

CALL[:CELL]:PROTocol:DIGital2000

Function

Sets/queries the protocol standard for the IS-2000 System Type.

NOTE
An additional feature license is required to enable the setting of PREV7 in a licensed test application, see Protocol Revisions .

Setting

Range: PREVision6|PREVision7

Query

Range: PREV6|PREV7

*RST Setting

 PREV6

Requirements

Test Application Revision: B.08 and above, with the required feature license: added PREV7.

Lab Application Revision: B.02 and above: added PREV7.

Programming Example

OUTPUT 714;"CALL:PROTocol:DIGital2000 PREV6"
!Selects PREV6 explicitly for the IS-2000 system.

CALL[:CELL]:PROTocol:CCHannel:CONFigure

Function

Sets/queries which control channels are generated and which access channel is expected by the test set when protocol revision is greater than 6 ( see CALL[:CELL]:PROTocol:DIGital2000 ). BCEChannel indicates F-BCCH/F-CCCH/R-EACH control channels are active and PACHannel indicates F-PCH/R-ACH control channels are active. See Setting Control Channel Parameters for details.

Setting

Range: BCEChannel|PACHannel

Query

Range: BCEC|PACH

*RST Setting

 BCEChannel

Requirements

Test Application Revision: B.08 and above, with the required feature license

Lab Application Revision: B.02 and above

Programming Example

OUTPUT 714;"CALL:PROTocol:CCHannel:CONFigure BCEChannel"
!Selects F-BCCH/F-CCCH/R-EACH as control channels for PREV7.


CALL:QPCHannel

CALL:QPCHannel

Last updated: June 6, 2007

GPIB Command Conventions

  • CALL:QPCHannel:DRATe
  • CALL: QPCHannel:LEVel[:RTCell][:SELected]?
  • CALL: QPCHannel[:SLEVel]:RTPilot[:SELected]
  • CALL:QPCHannel:LEVel:RTPilot[:SELected]
  • CALL:QPCHannel:STATe[:SELected]

CALL:QPCHannel:DRATe

Function

Sets/queries the forward quick paging channel (F-QPCH) data rate. FULL indicates 4.8 kbps (indicator rate is 9.6 kbps) and HALF indicates 2.4 kbps (indicator rate is 4.8 kbps). See Setting Control Channel Parameters .

Setting

 Range: FULL|HALF

Query

Range: FULL|HALF

*RST Setting

FULL

Requirements

Lab Application Revision: B.01 and above

Test Application Revision: B.07 and above

Programming Example

OUTPUT 714;"CALL:QPCHannel:DRATe HALF"
!Sets the F-QPCH data rate to 2.4 kbps.

CALL: QPCHannel:LEVel[:RTCell][:SELected]?

Function

Queries the forward quick paging channel (QPCH) level relative to the cell power level.

The optional [:SELected] keyword in this command specifies that the frequency band being set/queried applies to the current system type.

The QPCH channel is slotted (pulsed). When the state of the QPCH is on, OCNS is calculated based on the channel power when QPCH is present in the signal. When QPCH is not present, the output power is not fully calibrated.

Query

Range: 0 to -15 dB, NAN

Resolution: 0.01 dB

*RST Setting

-10 dB

Programming Example

OUTPUT 714;"CALL:QPCHannel:LEVel?"

CALL: QPCHannel[:SLEVel]:RTPilot[:SELected]

Function

The setting form of this command performs two functions: (1) sets the forward quick paging channel (QPCH) level relative to the pilot level, and (2) turns the QPCH state to ON.

The query form returns the QPCH level relative to the pilot level.

The optional [:SELected] keyword in this command specifies that the frequency band being set/queried applies to the current system type.

The QPCH channel is slotted (pulsed). When the state of the QPCH is on (see CALL:QPCHannel:STATe[:SELected] ), OCNS is calculated based on the channel power when QPCH is present in the signal. When the QPCH state is off, the output power is not fully calibrated.

Query

Range: +2 to -5 dB

Resolution: integer

*RST Setting

-3 dB

Programming Example

OUTPUT 714;"CALL:QPCHannel:RTPilot?"
! Sets the QPCH level state to on and
!queries the QPCH level relative to the pilot power.

CALL:QPCHannel:LEVel:RTPilot[:SELected]

Function

Sets/queries the forward quick paging channel (QPCH) level relative to the pilot level.

The optional [:SELected] keyword in this command specifies that the frequency band being set/queried applies to the current system type.

The QPCH channel is slotted (pulsed). The test set adjusts OCNS (orthogonal channel noise simulator) to an appropriate level for the periods of time when the slotted QPCH signal is pulsed on. When QPCH is pulsed off, the output level will not be fully calibrated.

Query

Range: +2 to -5 dB

Resolution: integer

*RST Setting

 -3 dB

Programming Example

OUTPUT 714;"CALL:QPCHannel:LEVEL:RTPilot?"
!Queries the QPCH level relative to the pilot level.

CALL:QPCHannel:STATe[:SELected]

Function

Sets/queries the forward quick paging channel's (QPCH) state. When the state of the forward QPCH channel is on, the test set will transmit it even if the mobile station does not support QPCH.

The QPCH channel is slotted (pulsed). The test set adjusts OCNS (orthogonal channel noise simulator) to an appropriate level for the periods of time when the slotted QPCH signal is pulsed on. When QPCH is pulsed off, the output level will not be fully calibrated.

Setting

Range: 1|ON|0|OFF

Query

Range: 1|0

*RST Setting

0 (off)

Programming Example

OUTPUT 714;"CALL:QPCHannel:STATe ON" !Turns on the quick paging channel.


CALL:RCONfig

CALL:RCONfig

Last updated: June 7, 2007

GPIB Command Conventions

  • CALL[:CELL]:RCONfig

CALL[:CELL]:RCONfig

Function

Sets/queries the current radio configuration. See Radio Configuration .

The radio configuration specifies the base data rate and service options supported.

Data rates for the F-FCH can be set using the CALL:TRAFfic commands. Data rates for the F-SCH can be set using the CALL:SCHannel commands.

Radio configurations are often referred to in a shorthand terms. These terms are:

  • RC1 (for F1R1)
  • RC2 (for F2R2)
  • RC3 (for F3R3)
  • RC4 (for F4R3)
  • RC5 (for F5R4)

Setting

Range: F1R1|F2R2|F3R3|F4R3|F5R4

Query

Range: F1R1|F2R2|F3R3|F4R3|F5R4

*RST Setting

 F3R3

Programming Example

OUTPUT 714;"CALL:CELL:RCONFIG F1R1" !Sets the radio configuration to RC1.


CALL:REGister

CALL:REGister

Last updated: June 7, 2007

GPIB Command Conventions

  • CALL:REGister[:IMMediate]
  • CALL:REGister[:IMMediate]:DONE?
  • CALL:REGister[:IMMediate]:OPComplete?
  • CALL:REGister[:IMMediate]:SEQuential
  • CALL:REGister[:IMMediate]:WAIT
  • CALL:REGister:PUP[:STATe]
  • CALL:REGister:TIMer[:SRPeriod]
  • CALL:REGister:TIMer:RPERiod
  • CALL:REGister:TIMer:STATe

CALL:REGister[:IMMediate]

Function

 Generates a zone based (forced) registration. See Performing a Registration .

Programming Example

OUTPUT 714;"CALL:REGister"

CALL:REGister[:IMMediate]:DONE?

Function

See Call Processing Event Synchronization .

Query

Range: 1|0

Programming Example

OUTPUT 714;"CALL:REGister:DONE?"

CALL:REGister[:IMMediate]:OPComplete?

Function

See Call Processing Event Synchronization .

Query

Range: 1

Programming Example

OUTPUT 714;"CALL:REGister:OPComplete?"

CALL:REGister[:IMMediate]:SEQuential

Function

See Call Processing Event Synchronization .

Programming Example

OUTPUT 714;"call:register:SEQuential"

CALL:REGister[:IMMediate]:WAIT

Function

See Call Processing Event Synchronization .

Programming Example

OUTPUT 714;"CALL:REGISTER:WAIT"

CALL:REGister:PUP[:STATe]

Function

Sets/queries the power-up registration enable state.

Requirements

 Test Application Revision: B.06.00 or above

Setting

Range: 1|ON|0|OFF

Query

Range: 1|0

*RST Setting

1 (on)

Programming Example

OUTPUT 714;"CALL:REGister:PUP OFF" !Disable power-up registration.

CALL:REGister:TIMer[:SRPeriod]

Function

Sets the time between time based registrations and turns the timer based registration state to on.

The value is not the actual time. The registration period is used in the following equation to determine the time between registrations:

time between registrations = [integer portion of 2 (reg_period/4) ] x 0.08 seconds

Setting

Range: 29 to 85

Resolution: integer

Query

Range: 29 to 85

*RST Setting

 29 (12 seconds)

Programming Example

OUTPUT 714;"CALL:REGister:TIMer 35"
!Turns the timer's state on, and sets the registration period to 35.

CALL:REGister:TIMer:RPERiod

Function

Sets the time between time based registrations (when timer based registration is on). The value is not the actual time. The registration period is used in the following equation to determine the time between registrations.time between registrations = [integer portion of 2 (reg_period/4) ] x 0.08 seconds

Setting

Range: 29 to 85

Resolution: integer

Query

Range: 29 to 85

*RST Setting

29 (12 seconds)

Programming Example

OUTPUT 714;"CALL:REGister:TIMer:RPERiod 35" !Sets the registration period to 35.

CALL:REGister:TIMer:STATe

Function

Sets the state of timer based registrations.

Setting

Range: 1|ON|0|OFF

Query

Range: 1|0

*RST Setting

1 (on)

Programming Example

OUTPUT 714;"CALL:REGister:TIMer:STATe OFF" !Turns off the timer based registration.


CALL:RFGenerator

CALL:RFGenerator

Last updated: June 7, 2007

GPIB Command Conventions

  • CALL[:CELL]:RFGenerator:FREQuency

CALL[:CELL]:RFGenerator:FREQuency

Function

Sets/queries the RF generator forward channel frequency. This setting is only used with AVCTest, D2KTest, and CW operating modes. If no units are specified the setting defaults to Hz.

The test set will tune to the specified frequency when in CW operating mode (set with CALL[:CELL]:OPERating:MODE command) or when in AVCTest or D2KTest operating mode (set with CALL[:CELL]:OPERating:MODE command) and the forward link frequency control is set to Manual with CALL:CONTrol command.

Setting

Range: 292 MHz to 2700 MHz
Resolution: 0.1 Hz

Query

Range: 292 MHz to 2700 MHz
Resolution: 0.1 Hz

*RST Setting

851 MHz

Programming Example

OUTPUT 714;"CALL:CELL:RFGENERATOR:FREQUENCY 450 MHZ"
!Sets the RF Gen frequency to 450 MHz.


CALL:RLGain

CALL:RLGain

Last updated: June 7, 2007

GPIB Command Conventions

  • CALL[:CELL]:RLGain[:TTPilot]

CALL[:CELL]:RLGain[:TTPilot]

Function

Sets/queries reverse link, traffic-to-pilot level (RLGAIN_TRAFFIC_PILOT) gain. This setting applies to R-FCH and/or R-SCH (if the test set is configured to recieve R-SCH, for example, IS-2000 Service Option is SO32 (+SCH).).

RLGAIN_TRAFFIC_PILOT is sent in an overhead message to the mobile station and is used by the mobile station to adjust the reverse traffic channel level, relative to the reverse channel pilot. This parameter applies only when the current radio configuration is greater than 2.

Each integer translates into a 1/8 dB step.

Setting

Range: -32 to +31

Resolution: integer

Query

Range: -32 to+31

Resolution: integer

*RST Setting

 0

Programming Example

OUTPUT 714;"CALL:RLGain 8"


CALL:RTVocoder

CALL:RTVocoder

Last updated: June 7, 2007

GPIB Command Conventions

  • CALL:RTVocoder:DECoder:HEADroom?
  • CALL:RTVocoder:ENCoder:DRATe
  • CALL:RTVocoder:ENCoder:DRATe:MODE
  • CALL:RTVocoder:ENCoder:HEADroom?
  • CALL:RTVocoder:INPut:VOLTage[:EXPected]
  • CALL:RTVocoder:OUTPut:VOLTage[:MAXimum]

CALL:RTVocoder:DECoder:HEADroom?

Function

Queries the headroom of the decoded data samples to the full scale of the DAC (Digital to Analog Converter). See Real-Time Vocoder Headroom Information .
Query

Range: 0.0 to 100 dB, 9.91E+37 (NAN)

Resolution: 0.1 dB
*RST Setting 9.91E+37 (NAN)
Requirement Test Application Revision: B.10 and above
Lab Application Revision: B.03.10 and above

Programming Example

OUTPUT 714;"CALL:RTVocoder:DECoder:HEADroom?"
!Queries decoder headroom.

CALL:RTVocoder:ENCoder:DRATe

Function

Sets/queries the encoding data rate when the CALL:RTVocoder:ENCoder:DRATe:MODE is set to FIXed and the maximum encoding data rate when the CALL:RTVocoder:ENCoder:DRATe:MODE is set to LIMited. See Setting Real-Time Vocoder Parameters .
Setting | Range: FULL|HALF|QUARter|EIGHth
Query | Range: FULL|HALF|QUAR|EIGH
*RST Setting | FULL
Requirement Test Application Revision: B.10 and above
Lab Application Revision: B.03.10 and above

Programming Example

OUTPUT 714;"CALL:RTVocoder:ENCoder:DRATe FULL"
!Sets encoder data rate to FULL.

CALL:RTVocoder:ENCoder:DRATe:MODE

Function

Sets/queries how to select the encoding data rate to produce the encoded data frames. See Setting Real-Time Vocoder Parameters .
Setting | Range: AUTO|FIXed| LIMited
Query | Range: AUTO| FIX|LIM
*RST Setting | AUTO
Requirement Test Application Revision: B.10 and above
Lab Application Revision: B.03.10 and above

Programming Example

OUTPUT 714;"CALL:RTVocoder:ENCoder:DRATe:MODE FIXed"
!Sets encoder data rate mode to fixed mode.

CALL:RTVocoder:ENCoder:HEADroom?

Function

Queries the headroom of the audio samples to the full scale of the ADC (Analog to Digital Converter). See Real-Time Vocoder Headroom Information .
Query

Range: 0.0 to 100 dB, 9.91E+37 (NAN)

Resolution: 0.1 dB
*RST Setting 9.91E+37 (NAN)
Requirement Test Application Revision: B.10 and above
Lab Application Revision: B.03.10 and above

Programming Example

OUTPUT 714;"CALL:RTVocoder:ENCoder:HEADroom?"
!Queries encoder headroom.

CALL:RTVocoder:INPut:VOLTage[:EXPected]

Function

Sets/queries the peak voltage of the analog audio signal that is applied at the test set's AUDIO IN connector. The units (V|mV) are optional. If no units are specified, then units default to V. See Setting Real-Time Vocoder Parameters .

Setting

Range: 0.001 to 2.0 V

Resolution: 1 mV
Query

Range: 0.001 to 2.0 V

Resolution: 1 mV
*RST Setting 2.0 V
Requirement Test Application Revision: B.10 and above
Lab Application Revision: B.03.10 and above

Programming Example

OUTPUT 714;"CALL:RTVocoder:INPut:VOLTage 350mV"
!Sets the peak level of Audio In signal to 350 mV.

CALL:RTVocoder:OUTPut:VOLTage[:MAXimum]

Function

Sets/queries the maximum audio peak output level that is produced on the test set's AUDIO OUT connector according to the voice data received on the R-Traffic/R-FCH channel. The units (V|mV) are optional. If no units are specified, then units default to V. See Setting Real-Time Vocoder Parameters .

Setting

Range: 0.0 to 5.0 V

Resolution: 0.1 mV

Query

Range: 0.0 to 5.0 V

Resolution: 0.1 mV

*RST Setting

0.0 V
Requirement Test Application Revision: B.10 and above
Lab Application Revision: B.03.10 and above

Programming Example

OUTPUT 714;"CALL:RTVocoder:OUTPut:VOLTage 350MV"
!Sets the peak level of AUDIO OUT signal to 350 mV.


CALL:SCHannel

CALL:SCHannel

Last updated: June 7, 2007

GPIB Command Conventions

  • CALL:SCHannel[:FORWard][:SLEVel][:SELected]
  • CALL:SCHannel[:FORWard]:LEVel[:SELected]
  • CALL:SCHannel[:FORWard]:STATe[:SELected]
  • CALL:SCHannel[:FORWard]:DRATe[:SELected]
  • CALL:SCHannel[:FORWard]:DRATe:RCONfig3
  • CALL:SCHannel[:FORWard]:DRATe:RCONfig4
  • CALL:SCHannel[:FORWard]:DRATe:RCONfig5
  • CALL:SCHannel[:FORWard]:ENCoder
  • CALL:SCHannel:REVerse:DRATe:MAXimum
  • CALL:SCHannel:REVerse:DRATe[:SELected]
  • CALL:SCHannel:REVerse:DRATe:RCONfig3
  • CALL:SCHannel:REVerse:DRATe:RCONfig4
  • CALL:SCHannel:REVerse:DRATe:RCONfig5
  • CALL:SCHannel:REVerse:ENCoder
  • CALL:SCHannel:TDSOption:DSOurce
  • CALL:SCHannel:TDSOption:FPATtern

CALL:SCHannel[:FORWard][:SLEVel][:SELected]

Function

The setting form of this command performs two functions: (1) sets the level of the forward supplemental channel (F-SCH), and (2) turns the state of the F-SCH on.

The query form of this command returns the requested level of the F-SCH.

The optional [:SELected] keyword in this command specifies that the F-SCH level being set/queried applies to the current system type. At this time there is only one system type choice, DIGital2000. Specifying DIGital2000 will have the same effect as using the optional [:SELected] keyword.

Setting

Range: 0 to -20 dB

Resolution: 0.01 dB

Query

Range: 0 to -20 dB

Resolution: 0.01 dB

*RST Setting

-15.6 dB

Requirements

 Test Application Revision: B.03.00: Added optional [:FORWard]

Programming Example

OUTPUT 714;"CALL:SCHANNEL:FORWARD:SLEVEL:SELECTED -10"
!Sets the cell's forward supplemental channel state to on and the level to -10 dB.

CALL:SCHannel[:FORWard]:LEVel[:SELected]

Function

Sets/queries the level of the forward supplemental channel (F-SCH).

The optional [:SELected] keyword in this command specifies that the F-SCH level being set/queried applies to the current system type. At this time there is only one system type choice, DIGital2000. Specifying DIGital2000 will have the same effect as using the optional [:SELected] keyword.

Setting

Range: 0 to -20 dB

Resolution: 0.01 dB

Query

Range: 0 to -20 dB

Resolution: 0.01 dB

*RST Setting

-15.6 dB

Requirements

Test Application Revision: B.03.00: Added optional [:FORWard]

Programming Example

OUTPUT 714;"CALL:SCHANNEL:FORWARD:LEVEL:SELECTED -10"

CALL:SCHannel[:FORWard]:STATe[:SELected]

Function

Sets/queries the on/off state of the forward supplemental channel (F-SCH).

The optional [:SELected] keyword in this command specifies that the F-SCH state being set/queried applies to the current system type. At this time there is only one system type choice, DIGital2000. Specifying DIGital2000 will have the same effect as using the optional [:SELected] keyword.

Setting

Range: 1|ON|0|OFF

Query

Range: 1|0

*RST Setting

ON

Requirements

Test Application Revision: B.03.00: Added optional [:FORWard]

Programming Example

OUTPUT 714;"CALL:SCHANNEL:FORWARD:STATE:SELECTED OFF"
!Turns off the forward supplemental channel.

CALL:SCHannel[:FORWard]:DRATe[:SELected]

Function

Sets/queries the data rate of the forward supplemental channel (F-SCH) for the currently selected radio configuration.

To find out which radio configuration is currently selected, see
CALL:RCONfig
.

Entering a data rate that is not included in the radio configuration's set of valid entries will cause the test set to generate an error message.

Setting

Range: BPS9600|BPS14400|BPS19200|BPS28800|BPS38400|BPS57600|

BPS76800|BPS115200|BPS153600|BPS230400

Query

Range: BPS9600|BPS14400|BPS19200|BPS28800|BPS38400|BPS57600|BPS76800|

BPS115200|BPS153600|BPS230400

*RST Setting

BPS9600

Requirements

Test Application Revision: B.03.00: Added optional [:FORWard]

Programming Example

OUTPUT 714;"CALL:SCHANNEL:FORWARD:DRATE?"
!Queries the data rate for the currently selected radio configuration

CALL:SCHannel[:FORWard]:DRATe:RCONfig3

Function

Sets/queries the data rate of the radio configuration 3 (RC3) forward supplemental channel (F-SCH) in bits per second.

Setting

Range: BPS9600|BPS19200|BPS38400|BPS76800|BPS153600

Query

Range: BPS9600|BPS19200|BPS38400|BPS76800|BPS153600

*RST Setting

BPS9600

Requirements

Test Application Revision: B.03.00: Added optional [:FORWard]

Programming Example

OUTPUT 714;"CALL:SCHANNEL:FORWARD:DRATE:RCONFIG3 BPS38400"

CALL:SCHannel[:FORWard]:DRATe:RCONfig4

Function

Sets/queries the data rate of the radio configuration 4 (RC4) forward supplemental channel (F-SCH) in bits per second.

Setting

Range: BPS9600|BPS19200|BPS38400|BPS76800|BPS153600

Query

Range: BPS9600|BPS19200|BPS38400|BPS76800|BPS153600

*RST Setting

BPS9600

Requirements

Test Application Revision: B.03.00: Added optional [:FORWard]

Programming Example

OUTPUT 714;"CALL:SCHANNEL:FORWARD:DRATE:RCONFIG4 BPS76800"

CALL:SCHannel[:FORWard]:DRATe:RCONfig5

Function

Sets/queries the data rate of the radio configuration 5 (RC5) forward supplemental channel (F-SCH) in bits per second.

Setting

Range: BPS14400|BPS28800|BPS57600|BPS115200|BPS230400

Query

Range: BPS14400|BPS28800|BPS57600|BPS115200|BPS230400

*RST Setting

BPS14400

Requirements

Test Application Revision: B.03.00: Added optional [:FORWard]

Programming Example

OUTPUT 714;"CALL:SCHANNEL:FORWARD:DRATE:RCONFIG5 BPS57600"

CALL:SCHannel[:FORWard]:ENCoder

Function

Sets/queries which encoder is used for the forward supplemental data.

If the F-SCH data rate has been set to the base rate for the current radio configuration (base rates are data rates below 19.2 kbps), the convolutional encoder is used regardless of this parameter setting.

The current radio configuration is selected by the
CALL:RCONfig
command.

Setting

Range: TURBo|CONVolution

Query

Range: TURB|CONV

*RST Setting

CONVolution

Requirements

Test Application Revision: B.03.00: Added optional [:FORWard]

Programming Example

OUTPUT 714;"CALL:SCHANNEL:FORWARD:ENCODER TURBO"
!Sets the F-SCH encoder to turbo mode.

CALL:SCHannel:REVerse:DRATe:MAXimum

Function

Sets/queries the service configuration maximum data rate of the reverse supplemental channel (R-SCH). It applies to the service option SO32 (+ SCH) data call. "X8" indicates the maximum data rate of the R-SCH is 76.8 kbps and "X16" indicates the maximum data rate of the R-SCH is 153.6 kbps.

The R-SCH service configuration maximum data rate can not be changed while a call is connected. Otherwise, the test set will generate an error message.

The R-SCH service configuration maximum data rate can not be less than the R-SCH data rate (
CALL:SCHannel:REVerse:DRATe[:SELected]
). Otherwise, the test set will generate an error message but the setting change is not rejected.

Setting

Range: X8|X16

  •
X8 - indicates the maximum data rate of the R-SCH is 76.8 kbps
    •

  •

X16 - indicates the maximum data rate of the R-SCH is 153.6 kbps
    •

Query

Range: X8|X16

*RST Setting

X16

Requirements

Test Application Revision: B.08 and above

Lab Application Revision: B.02 and above

Programming Example

OUTPUT 714;"CALL:SCHannel:REVerse:DRATe:MAXimum X16"
!Sets the R-SCH max data rate to 153.6 kbps.

CALL:SCHannel:REVerse:DRATe[:SELected]

Function

Sets/queries the data rate of the reverse supplemental channel (R-SCH) for the currently selected radio configuration.

To find out which radio configuration is currently selected, see
CALL:RCONfig
.

Entering a data rate that is not included in the radio configuration's set of valid entries will cause the test set to generate an error message.

Entering a data rate that is greater than the R-SCH service configuration maximum data rate (
CALL:SCHannel:REVerse:DRATe:MAXimum
) will cause the test set to generate an error message but the setting change is not rejected.

Setting

Range: BPS9600|BPS19200|BPS38400|BPS76800|BPS15360| BPS14400|BPS28800|BPS57600|BPS115200|BPS230400

Query

Range: BPS9600|BPS19200|BPS38400|BPS76800|BPS15360| BPS14400|BPS28800|BPS57600|BPS115200|BPS230400

*RST Setting

BPS9600

Requirements

Test Application Revision: B.03.00

Programming Example

OUTPUT 714;"CALL:SCHANNEL:REVERSE:DRATE?"
!Queries the data rate for the R-SCH of the currently selected radio configuration.

CALL:SCHannel:REVerse:DRATe:RCONfig3

Function

Sets/queries the data rate of the radio configuration 3 (RC3) reverse supplemental channel (R-SCH) in bits per second.

Entering a data rate that is greater than the R-SCH service configuration maximum data rate (
CALL:SCHannel:REVerse:DRATe:MAXimum
) will cause the test set to generate an error message but the setting change is not rejected.

Setting

Range: BPS9600|BPS19200|BPS38400|BPS76800|BPS153600

Query

Range: BPS9600|BPS19200|BPS38400|BPS76800|BPS153600

*RST Setting

BPS9600

Requirements

Test Application Revision: B.03.00

Programming Example

OUTPUT 714;"CALL:SCHANNEL:REVERSE:DRATE:RCONFIG3 BPS38400"

CALL:SCHannel:REVerse:DRATe:RCONfig4

Function

Sets/queries the data rate of the radio configuration 4 (RC4) reverse supplemental channel (R-SCH) in bits per second.

Entering a data rate that is greater than the R-SCH service configuration maximum data rate (
CALL:SCHannel:REVerse:DRATe:MAXimum
) will cause the test set to generate an error message but the setting change is not rejected.

Setting

Range: BPS9600|BPS19200|BPS38400|BPS76800|BPS153600

Query

Range: BPS9600|BPS19200|BPS38400|BPS76800|BPS153600

*RST Setting

BPS9600

Requirements

Test Application Revision: B.03.00

Programming Example

OUTPUT 714;"CALL:SCHANNEL:REVERSE:DRATE:RCONFIG4 BPS76800"

CALL:SCHannel:REVerse:DRATe:RCONfig5

Function

Sets/queries the data rate of the radio configuration 5(RC5) reverse supplemental channel (R-SCH) in bits per second.

Entering a data rate that is greater than the R-SCH service configuration maximum data rate (
CALL:SCHannel:REVerse:DRATe:MAXimum
) will cause the test set to generate an error message but the setting change is not rejected.

Setting

Range: BPS14400|BPS28800|BPS57600|BPS115200|BPS230400

Query

Range: BPS14400|BPS28800|BPS57600|BPS115200|BPS230400

*RST Setting

BPS14400

Requirements

Test Application Revision: B.05.

Lab Application Revision: B.12.

Programming Example

OUTPUT 714;"CALL:SCHANNEL:REVERSE:DRATE:RCONFIG5 BPS115200"

CALL:SCHannel:REVerse:ENCoder

Function

Sets/queries which encoder is used for the reverse supplemental data.

Changes to reverse encoder while an R-SCH is established in Active Cell status will be rejected with an execution error. Changes to reverse encoder when not in Active Cell status will be stored and applied when an R-SCH is established.

If the SCH data rate has been set to the base rate for the current radio configuration (base rates are data rates below 19.2 kbps), the convolutional encoder is used regardless of this parameter setting.

The current radio configuration is selected by the
CALL:RCONfig
command.

Setting

Range: TURBo|CONVolution

Query

Range: TURB|CONV

*RST Setting

CONVolution

Requirements

Test Application Revision: B.03.00

Programming Example

OUTPUT 714;"CALL:SCHANNEL:REVERSE:ENCODER TURBO"
!Sets the R-SCH encoder to turbo mode.

CALL:SCHannel:TDSOption:DSOurce

Function

Sets/queries whether fixed pattern data (FPAT) or a pseudorandom bit sequence (PRBS) is sent on the forward and reverse supplemental channels (F-SCH and R-SCH) when using an SO32 Service Option (test data service option (TDSO)).

IMPORTANT

PRBS data is required if you are making any of the code domain measurements on the reverse supplemental channel.

If fixed data is selected, the
CALL:SCHannel:TDSOption:FPATtern
 command determines the fixed data pattern that is used.

If you attempt to set the F-SCH TDSO data source while a data connection is established, an error will be generated and the setting rejected.

Setting

Range: FPATtern|PRBS

Query

Range: FPAT|PRBS

*RST Setting

PRBS (Prior to B.06.00, the default was FPAT)

Requirements

Test Application Revision: B.03.00

Programming Example

OUTPUT 714;"CALL:SCHANNEL:TDSOPTION:DSOURCE PRBS"

CALL:SCHannel:TDSOption:FPATtern

Function

Sets/queries the fixed pattern data (FPAT) that is sent on the forward supplemental channel when using Service Option 032 (test data service option (TDSO)).

Setting

Range: 00 to FF (hexadecimal)

Query

Range: 00 to FF (hexadecimal)

*RST Setting

96

Requirements

Test Application Revision: B.03.00

Programming Example

OUTPUT 714;"CALL:SCHANNEL:TDSOPTION `FF'" !sets the fixed data pattern to all 1's.


CALL:SECurity

CALL:SECurity

Last updated: June 7, 2007

GPIB Command Conventions

  • CALL:SECurity:AUTHenticate:CLEar[:ALL]
  • CALL:SECurity:AUTHenticate:GCHallenge:CHIStory:EXPected?
  • CALL:SECurity:AUTHenticate:GCHallenge:CHIStory:RECeived?
  • CALL:SECurity:AUTHenticate:GCHallenge:CHIStory:RESult?
  • CALL:SECurity:AUTHenticate:GCHallenge:CRANdom:EXPected?
  • CALL:SECurity:AUTHenticate:GCHallenge:CRANdom:RECeived?
  • CALL:SECurity:AUTHenticate:GCHallenge:CRANdom:RESult?
  • CALL:SECurity:AUTHenticate:GCHallenge:ENABle
  • CALL:SECurity:AUTHenticate:GCHallenge:MODE:EXPected?
  • CALL:SECurity:AUTHenticate:GCHallenge:MODE:RECeived?
  • CALL:SECurity:AUTHenticate:GCHallenge:MODE:RESult?
  • CALL:SECurity:AUTHenticate:GCHallenge:RANDom
  • CALL:SECurity:AUTHenticate:GCHallenge:RESPonse:EXPected?
  • CALL:SECurity:AUTHenticate:GCHallenge:RESPonse:RECeived?
  • CALL:SECurity:AUTHenticate:GCHallenge:RESPonse:RESult?
  • CALL:SECurity:AUTHenticate:GCHallenge:RESult?
  • CALL:SECurity:AUTHenticate:GCHallenge:TYPE?
  • CALL:SECurity:AUTHenticate:SSDA:ZERO?
  • CALL:SECurity:AUTHenticate:SUPDate:AKEY
  • CALL:SECurity:AUTHenticate:SUPDate:CDIGits?
  • CALL:SECurity:AUTHenticate:SUPDate:RANDom
  • CALL:SECurity:AUTHenticate:SUPDate:RESult?
  • CALL:SECurity:AUTHenticate:SUPDate:STARt
  • CALL:SECurity:AUTHenticate:SUPDate:TYPE?
  • CALL:SECurity:AUTHenticate:UCHallenge:RANDom
  • CALL:SECurity:AUTHenticate:UCHallenge:RESPonse:EXPected?
  • CALL:SECurity:AUTHenticate:UCHallenge:RESPonse:RECeived?
  • CALL:SECurity:AUTHenticate:UCHallenge:RESPonse:RESult?
  • CALL:SECurity:AUTHenticate:UCHallenge:RESult?
  • CALL:SECurity:AUTHenticate:UCHallenge:STARt
  • CALL:SECurity:AUTHenticate:UCHallenge:TYPE?

CALL:SECurity:AUTHenticate:CLEar[:ALL]

Function

 This command clears all authentication results displayed on the Global Challenge Information, Unique Challenge Information and SSD Update Information windows. See Clear Authen Results .

Requirements

Test Application Revision: B.10 and above with the required feature license

Lab Application Revision: B.03.10 and above

Programming Example

OUTPUT 714;"CALL:SECurity:AUTHenticate:CLEar"
!Clears all authentication results.

CALL:SECurity:AUTHenticate:GCHallenge:CHIStory:EXPected?

Function

Queries the value of Expected Call History (COUNT) associated with the last global challenge operation. See Global Challenge Information .

Query

Range: 0 to 63, 9.91E+37 (NAN)

Resolution: 1

*RST Setting

 9.91E+37 (NAN)

Requirements

Test Application Revision: B.10 and above with the required feature license

Lab Application Revision: B.03.10 and above

Programming Example

OUTPUT 714;"CALL:SECurity:AUTHenticate:GCHallenge:CHIStory:EXPected?"
!Queries expected COUNT value.

CALL:SECurity:AUTHenticate:GCHallenge:CHIStory:RECeived?

Function

 Queries the value of Received Call History (COUNT) associated with the last global challenge operation. See Global Challenge Information .

Query

Range: 0 to 63, 9.91E+37 (NAN)

Resolution: 1

*RST Setting

 9.91E+37 (NAN)

Requirements

Test Application Revision: B.10 and above with the required feature license

Lab Application Revision: B.03.10 and above

Programming Example

OUTPUT 714;"CALL:SECurity:AUTHenticate:GCHallenge:CHIStory:RECeived?"
!Queries the received COUNT value.

CALL:SECurity:AUTHenticate:GCHallenge:CHIStory:RESult?

Function

Queries the pass/fail result of the Call History (COUNT) associated with the last global challenge operation. If the received COUNT equals to the expected COUNT, Pass is returned. See Global Challenge Information .

Query

Range: PASS|FAIL|UNKN

*RST Setting

 UNKN (no result available)

Requirements

Test Application Revision: B.10 and above with the required feature license

Lab Application Revision: B.03.10 and above

Programming Example

OUTPUT 714;"CALL:SECurity:AUTHenticate:GCHallenge:CHIStory:RESult?"
!Queries COUNT pass/fail result.

CALL:SECurity:AUTHenticate:GCHallenge:CRANdom:EXPected?

Function

Queries the value of Expected RANDC associated with the last global challenge operation. See Global Challenge Information .

Query

Range:

  • "" (null string)
  • "00" to "FF" (The return string is always 2 characters from the set 0123456789ABCDEF)

*RST Setting

 "" (null string)

Requirements

Test Application Revision: B.10 and above with the required feature license

Lab Application Revision: B.03.10 and above

Programming Example

OUTPUT 714;"CALL:SECurity:AUTHenticate:GCHallenge:CRANdom:EXPected?"
!Queries the Expected RANDC value.

CALL:SECurity:AUTHenticate:GCHallenge:CRANdom:RECeived?

Function

Queries the value of Received RANDC associated with the last global challenge operation. See Global Challenge Information .

Query

Range:

  • "" (null string)
  • "00" to "FF" (The return string is always 2 characters from the set 0123456789ABCDEF)

Requirements

Test Application Revision: B.10 and above with the required feature license

Lab Application Revision: B.03.10 and above

*RST Setting

 "" (null string)

Programming Example

OUTPUT 714;"CALL:SECurity:AUTHenticate:GCHallenge:CRANdom:Received?"
!Queries the Received RANDC value.

CALL:SECurity:AUTHenticate:GCHallenge:CRANdom:RESult?

Function

Queries the pass/fail result of the RANDC associated with the last global challenge operation. If the received RANDC equals to the expected RANDC, Pass is returned. See Global Challenge Information .

Query

Range: PASS|FAIL|UNKN

*RST Setting

 UNKN (no result available)

Requirements

Test Application Revision: B.10 and above with the required feature license

Lab Application Revision: B.03.10 and above

Programming Example

OUTPUT 714;"CALL:SECurity:AUTHenticate:GCHallenge:CRANdom:RESult?"
!Queries RANDC pass/fail result.

CALL:SECurity:AUTHenticate:GCHallenge:ENABle

Function

Sets/Queries whether the Global Challenge is required when the registrations, call originations, pages or data bursts are performed. See Global Challenge for details.

Setting

Range: 1|ON|0|OFF

Query

Range:1|0

*RST Setting

 0 (OFF)

Requirements

Test Application Revision: B.10 and above with the required feature license

Lab Application Revision: B.03.10 and above

Programming Example

OUTPUT 714;"CALL:SECurity:AUTHenticate:GCHallenge:ENABle ON"
!Enables global challenge operation.

CALL:SECurity:AUTHenticate:GCHallenge:MODE:EXPected?

Function

Queries the value of Expected AUTH_MODE associated with the last global challenge operation. See Global Challenge Information .

Query

Range: 0, 1, 9.91E+37 (NAN)

Resolution: 1.0

*RST Setting

 9.91E+37 (NAN)

Requirements

Test Application Revision: B.10 and above with the required feature license

Lab Application Revision: B.03.10 and above

Programming Example

OUTPUT 714;"CALL:SECurity:AUTHenticate:GCHallenge:MODE:EXPected?"
!Queries the expected AUTH_MODE.

CALL:SECurity:AUTHenticate:GCHallenge:MODE:RECeived?

Function

Queries the value of Received AUTH_MODE associated with the last global challenge operation. See Global Challenge Information .

Query

Range: 0, 1, 9.91E+37 (NAN)

Resolution: 1.0

*RST Setting

 9.91E+37 (NAN)

Requirements

Test Application Revision: B.10 and above with the required feature license

Lab Application Revision: B.03.10 and above

Programming Example

OUTPUT 714;"CALL:SECurity:AUTHenticate:GCHallenge:MODE:RECeived?"
!Queries the received AUTH_MODE.

CALL:SECurity:AUTHenticate:GCHallenge:MODE:RESult?

Function

Queries the pass/fail result of the AUTH_MODE associated with the last global challenge operation. If the received AUTH_MODE equals to the expected AUTH_MODE, Pass is returned. See Global Challenge Information .

Query

Range: PASS|FAIL|UNKN

*RST Setting

 UNKN (no result available)

Requirements

Test Application Revision: B.10 and above with the required feature license

Lab Application Revision: B.03.10 and above

Programming Example

OUTPUT 714;"CALL:SECurity:AUTHenticate:GCHallenge:MODE:RESult?"
!Queries AUTH_MODE pass/fail result.

CALL:SECurity:AUTHenticate:GCHallenge:RANDom

Function

Sets/queries the RAND value used during the Global Challenge operation. See Global Challenge Random (RAND) (Hex) .

Setting

Range: "0" to "FFFFFFFF" (1 to 8 characters from the set 0123456789ABCDEF)

Query

Range: "00000000" to "FFFFFFFF" (The return string is always 8 characters from the set 0123456789ABCDEF)

*RST Setting

 "34A2B05F"

Requirements

Test Application Revision: B.10 and above with the required feature license

Lab Application Revision: B.03.10 and above

Programming Example

OUTPUT 714;"CALL:SECurity:AUTHenticate:GCHallenge:RANDom '123'"
!Sets the RAND value to 123.

CALL:SECurity:AUTHenticate:GCHallenge:RESPonse:EXPected?

Function

Queries the value of Expected AUTHR associated with the last global challenge operation. See Global Challenge Information .

Query

Range:

  • "" (null string)
  • "00000" to "FFFFF" (The return string is always 5 characters from the set 0123456789ABCDEF)

Requirements

Test Application Revision: B.10 and above with the required feature license

Lab Application Revision: B.03.10 and above

*RST Setting

 "" (null string)

Programming Example

OUTPUT 714;"CALL:SECurity:AUTHenticate:GCHallenge:RESPonse:EXPected?"
!Queries the Expected AUTHR value.

CALL:SECurity:AUTHenticate:GCHallenge:RESPonse:RECeived?

Function

Queries the value of Received AUTHR associated with the last global challenge operation. See Global Challenge Information .

Query

Range:

  • "" (null string)
  • "00000" to "FFFFF" (The return string is always 5 characters from the set 0123456789ABCDEF)

Requirements

Test Application Revision: B.10 and above with the required feature license

Lab Application Revision: B.03.10 and above

*RST Setting

 "" (null string)

Programming Example

OUTPUT 714;"CALL:SECurity:AUTHenticate:GCHallenge:RESPonse:EXPected?"
!Queries the Received AUTHR value.

CALL:SECurity:AUTHenticate:GCHallenge:RESPonse:RESult?

Function

Queries the pass/fail result of the AUTHR associated with the last global challenge operation. If the received AUTHR equals to the expected AUTHR, Pass is returned. See Global Challenge Information .

Query

Range: PASS|FAIL|UNKN

*RST Setting

 UNKN (no result available)

Requirements

Test Application Revision: B.10 and above with the required feature license

Lab Application Revision: B.03.10 and above

Programming Example

OUTPUT 714;"CALL:SECurity:AUTHenticate:GCHallenge:RESPonse:RESult?"
!Queries AUTHR pass/fail result.

CALL:SECurity:AUTHenticate:GCHallenge:RESult?

Function

Queries the overall pass/fail result associated with the last Global Challenge operation performed. Pass is returned only when all of the CALL:SECurity:AUTHenticate:GCHallenge:CHIStory:RESult? , CALL:SECurity:AUTHenticate:GCHallenge:CRANdom:RESult? , CALL:SECurity:AUTHenticate:GCHallenge:MODE:RESult? and CALL:SECurity:AUTHenticate:GCHallenge:RESPonse:RESult? return Pass.

See Global Challenge Information .

Query

 Range: FAIL|PASS|UNKN

*RST Setting

 UNKN (no result available)

Requirements

Test Application Revision: B.10 and above with the required feature license

Lab Application Revision: B.03.10 and above

Programming Example

OUTPUT 714;"CALL:SECurity:AUTHenticate:GCHallenge:RESult?"
!Returns overall pass/fail result for global challenge.

CALL:SECurity:AUTHenticate:GCHallenge:TYPE?

Function

Queries the type of Global Challenge authentication that is performed. It is determined according to the access channel messages received. See Global Challenge Information .

  • DBUR for Data Burst Message
  • ORIG for Origination Message
  • PAGE for Page Responses Message
  • For a registration, the Global Challenge Type is set according to the REG_TYPE field (binary) included in the Registration Message .
    • REG_TYPE = 0000: TIM (Timer Registration)
    • REG_TYPE = 0001: PUP (Power-up Registration)
    • REG_TYPE = 0010: ZONE (Zone Registration)
    • REG_TYPE = 0011: PDOW (Power-down Registration)
    • REG_TYPE = 0100: PCR (Parameter Change Registration)
    • REG_TYPE = 0101: ORD (Ordered Registration)
    • REG_TYPE = 0110: DIST (Distance Registration)
    • REG_TYPE = 0111: UZON (User-zone Registration)
  • UNKN for other messages

Query

Range: ORIG | DBUR | PAGE | ZONE | TIM | PUP | PDOW | PCR | ORD | DIST | UZON | UNKN

*RST Setting

 UNKN (no result available)

Requirements

Test Application Revision: B.10 and above with the required feature license

Lab Application Revision: B.03.10 and above

Programming Example

OUTPUT 714;"CALL:SECurity:AUTHenticate:GCHallenge:TYPE?"
!Queries global challenge type.

CALL:SECurity:AUTHenticate:SSDA:ZERO?

Function

Queries whether the SSD_A value equals zero. If the SSD_A is set to zero, '1' is returned indicating True, otherwise '0' is returned indicating False. See Authentication Parameters

The value of SSD_A is not directly accessible.

Query

Range: 0 (False) | 1 (True)

Requirements

Test Application Revision: B.10 and above with the required feature license

Lab Application Revision: B.03.10 and above

Programming Example

OUTPUT 714;"CALL:SECurity:AUTHenticate:SSDA:ZERO?"
!Quries whether SSD_A value equals zero.

CALL:SECurity:AUTHenticate:SUPDate:AKEY

Function

Sets/queries A-key in the test set. See A-Key (Dec) for details.

Setting

Range: "0" to "18446744073709551615" (1 to 20 characters from the set 0123456789)

Query

Range: "00000000000000000000" to "18446744073709551615" (The return string is always 20 characters from the set 0123456789)

*RST Setting

 "00000000000000000000"

Requirements

Test Application Revision: B.10 and above with the required feature license

Lab Application Revision: B.03.10 and above

Programming Example

OUTPUT 714;"CALL:SECurity:AUTHenticate:SUPDate:AKEY '1'"
!Sets A-Key value to 1.

CALL:SECurity:AUTHenticate:SUPDate:CDIGits?

Function

Queries the check digits in decimal format. The check digits provides a check method for A-Key validity. See A-Key/Check Digits (Dec) for details.

Query

Range:

  • "000000" to "999999" (The return string is always 6 characters from the set 0123456789)
  • "" (null string)

*RST Setting

 "" (null string)

Requirements

Test Application Revision: B.10 and above with the required feature license

Lab Application Revision: B.03.10 and above

Programming Example

OUTPUT 714;"CALL:SECurity:AUTHenticate:SUPDate:CDIGits?"
!Queries the A-Key's check digits.

CALL:SECurity:AUTHenticate:SUPDate:RANDom

Function

Sets/queries the RANDSSD value used during the SSD Update operation. See SSD Update Random (RANDSSD) (Hex) .

Setting

Range: "0" to "FFFFFFFFFFFFFF" (1 to 14 characters from the set 0123456789ABCDEF)

Query

Range: "00000000000000" to "FFFFFFFFFFFFFF" (The return string is always 14 characters from the set 0123456789ABCDEF)

*RST Setting

 "4D18EEAA05895C"

Requirements

Test Application Revision: B.10 and above with the required feature license

Lab Application Revision: B.03.10 and above

Programming Example

OUTPUT 714;"CALL:SECurity:AUTHenticate:SUPDate:RANDom 'AA'"
!Sets RANDU value to AA.

CALL:SECurity:AUTHenticate:SUPDate:RESult?

Function

Queries the pass/fail result associated with the last SSD update operation performed. See SSD Update Information .

Query

 Range: FAIL|PASS|UNKN

*RST Setting

 UNKN (no result available)

Requirements

Test Application Revision: B.10 and above with the required feature license

Lab Application Revision: B.03.10 and above

Programming Example

OUTPUT 714;"CALL:SECurity:AUTHenticate:SUPDate:RESult?"
!Queries whether SSD Update passes.

CALL:SECurity:AUTHenticate:SUPDate:STARt

Function

Starts the SSD Update Operation .

Requirements

Test Application Revision: B.10 and above with the required feature license

Lab Application Revision: B.03.10 and above

Programming Example

OUTPUT 714;"CAALL:SECurity:AUTHenticate:SUPDate:STARt"
!Starts the SSD update operation.

CALL:SECurity:AUTHenticate:SUPDate:TYPE?

Function

Queries the type of the SSD Update operation. It can be performed on the paging channel or common control channel while in the idle state or on the traffic channel while in a call. See SSD Update Information .

Query

Range: PCH|CCCH|TCH|UNKN

Requirements

Test Application Revision: B.10 and above with the required feature license

Lab Application Revision: B.03.10 and above

Programming Example

OUTPUT 714;"CALL:SECurity:AUTHenticate:SUPDate:TYPE?"
!Queries the type of SSD update operation.

CALL:SECurity:AUTHenticate:UCHallenge:RANDom

Function

Sets/queries the RANDU value used during the Unique Challenge operation. See Unique Challenge Random (RANDU) (Hex) .

Setting

Range: "0" to "FFFFFF" (1 to 6 characters from the set 0123456789ABCDEF)

Query

Range: "000000" to "FFFFFF" (The return string is always 6 characters from the set 0123456789ABCDEF)

*RST Setting

 "5375DF"

Requirements

Test Application Revision: B.10 and above with the required feature license

Lab Application Revision: B.03.10 and above

Programming Example

OUTPUT 714;"CALL:SECurity:AUTHenticate:UCHallenge:RANDom 'AB'"
!Sets the RANDU value to AB.

CALL:SECurity:AUTHenticate:UCHallenge:RESPonse:EXPected?

Function

Queries the value of Expected AUTHU associated with the last unique challenge operation. See Unique Challenge Information .

Query

Range:

  • "" (null string)
  • "00000" to "FFFFF" (The return string is always 5 characters from the set 0123456789ABCDEF)

*RST Setting

 "" (null string)

Requirements

Test Application Revision: B.10 and above with the required feature license

Lab Application Revision: B.03.10 and above

Programming Example

OUTPUT 714;"CALL:SECurity:AUTHenticate:UCHallenge:RESPonse:EXPected?"
!Queries the value of expected AUTHU.

CALL:SECurity:AUTHenticate:UCHallenge:RESPonse:RECeived?

Function

Queries the value of Received AUTHU associated with the last unique challenge operation. See Unique Challenge Information .

Query

Range:

  • "" (null string)
  • "00000" to "FFFFF" (The return string is always 5 characters from the set 0123456789ABCDEF)

*RST Setting

 "" (null string)

Requirements

Test Application Revision: B.10 and above with the required feature license

Lab Application Revision: B.03.10 and above

Programming Example

OUTPUT 714;"CALL:SECurity:AUTHenticate:UCHallenge:RESPonse:RECeived?"
!Queries the value of received AUTHU.

CALL:SECurity:AUTHenticate:UCHallenge:RESPonse:RESult?

Function

Queries the pass/fail result of the AUTHU (Unique Challenge Response) associated with the last unique challenge operation. If the received AUTHU equals to the expected AUTHU, Pass is returned. See Unique Challenge Information .

Query

Range: PASS|FAIL|UNKN

*RST Setting

 UNKN (no result available)

Requirements

Test Application Revision: B.10 and above with the required feature license

Lab Application Revision: B.03.10 and above

Programming Example

OUTPUT 714;"CALL:SECurity:AUTHenticate:UCHallenge:RESPonse:RESult?"
!Queries the pass/fail result of AUTHU.

CALL:SECurity:AUTHenticate:UCHallenge:RESult?

Function

Queries the pass/fail result associated with the last Unique Challenge operation performed. Pass is returned only when the CALL:SECurity:AUTHenticate:UCHallenge:RESPonse:RESult? returns Pass. See Unique Challenge Information .

Query

 Range: FAIL|PASS|UNKN

*RST Setting

 UNKN (no result available)

Requirements

Test Application Revision: B.10 and above with the required feature license

Lab Application Revision: B.03.10 and above

Programming Example

OUTPUT 714;"CALL:SECurity:AUTHenticate:UCHallenge:RESult?"
!Queries whehter Unique Challenge operation passes.

CALL:SECurity:AUTHenticate:UCHallenge:STARt

Function

Starts the Unique Challenge Operation .

Requirements

Test Application Revision: B.10 and above with the required feature license

Lab Application Revision: B.03.10 and above

Programming Example

OUTPUT 714;"CALL:SECURITY:AUTHENTICATE:UCHALLENGE:START"

CALL:SECurity:AUTHenticate:UCHallenge:TYPE?

Function

Queries the type of the Unique Challenge operation. It can be performed on the paging channel or common control channel while in the idle state or on the traffic channel while in a call. See Unique Challenge Information .

Query

Range: PCH|CCCH|TCH|UNKN

Requirements

Test Application Revision: B.10 and above with the required feature license

Lab Application Revision: B.03.10 and above

Programming Example

OUTPUT 714;"CALL:SECurity:AUTHenticate:UCHallenge:TYPE?"
!Queries the type of the Unique Challenge operation.


CALL:SETup

CALL:SETup

Last updated: June 7, 2007

GPIB Command Conventions

  • CALL:SETup:AVC[:CHANnel][:SELected]
  • CALL:SETup:AVC[:CHANnel]:CELLular
  • CALL:SETup:AVC:SATone[:CCODe]
  • CALL:SETup:BAND:[:SELected]
  • CALL:SETup:CHANnel[:SELected][:SELected]
  • CALL:SETup:HANDoff[:IMMediate]
  • CALL:SETup:MS:ANALog:TXLevel[:SELected]
  • CALL:SETup:MS:ANALog:TXLevel:CELLular
  • CALL:SETup:SHANdoff:ENABle
  • CALL:SETup:SHANdoff:TYPe
  • CALL:SETup:SYSTem[:TYPE]<[:SELected]|[:TA2000]>

CALL:SETup:AVC[:CHANnel][:SELected]

Function

Sets/queries the RF channel number of the analog voice channel.

During active cell operating mode, this setting does not take affect until a call is originated on the AVC or a handoff occurs to a new AVC. This setting takes effect immediately during AVC Test operating mode.

Setting

Range: 1 through 799, 991 through 1023, 9.91 E+37

Query

Range: 1 through 799, 991 through 1023, 9.91 E+37

*RST Setting

300

Programming Example

OUTPUT 714;"CALL:SETUP:AVC:CHANNEL:SELECTED 799" !Set the AVC to channel 799.

CALL:SETup:AVC[:CHANnel]:CELLular

Function

Sets/queries the RF channel number of the analog voice channel, specifying the cellular band (800 MHz).

During active cell operating mode, this setting does not take affect until a call is originated on the AVC or a handoff occurs to a a new AVC. This setting takes effect immediately during AVC Test operating mode. PCS band analog operation is currently not supported.

Setting

Range: 1 through 799, 991 through 1023, 9.91 E+37

Query

Range: 1 through 799, 991 through 1023, 9.91 E+37

*RST Setting

300

Programming Example

OUTPUT 714;"CALL:SETUP:AVC:CHANNEL:CELLULAR 799" !Set the AVC to cell band channel 799.

CALL:SETup:AVC:SATone[:CCODe]

Function

Sets/queries the supervisory audio tone's color code (frequency).

In active cell mode, this command sets/queries the SAT color code (frequency) to be used on the next handoff.

In test mode, this command sets/queries the current SAT color code (frequency).

Setting

Range: SAT1|SAT2|SAT3

SAT1 = 5970 Hz
SAT2 = 6000 Hz
SAT3 = 6030 Hz

Query

Range: SAT1|SAT2|SAT3

*RST Setting

SAT2

Programming Example

OUTPUT 714;"CALL:SETUP:AVC:SATONE:CCODE SAT1" !Sets the SAT frequency to 5970 Hz.

CALL:SETup:BAND:[:SELected]

Function

Sets/queries the frequency band that the mobile station will be handed off to. To set or query the frequency band for a call (the current frequency band), use the CALL[:CELL]:BAND<[:SELected]|:DIGital2000|:DIGital95> commands.

Frequency bands are: IMT2000, Japan CDMA (JCDM), Korean PCS (KPCS), NMT450, Secondary 800 MHz band (SEC800), U.S. Cellular (USC), and U.S. PCS (USPC).

Handoff frequency bands are associated with a handoff system type. The CALL:SETup:SYSTem[:TYPE]<[:SELected]|[:TA2000]> command determines the current handoff system type.

The optional [:SELected] keyword in this command specifies that the handoff frequency band being set/queried applies to the current handoff system type.

To initiate (execute) a handoff, see the CALL:HANDoff command description.

Setting

Range:

  • DIGital2000|IMT2000|JCDMa|KPCS |NMT450|SECondary800|USCellular|USPCs |USPCs1900|AWService

Query

Range:

  • DIG2000|IMT2000|JCDM|KPCS |NMT450|SEC800|USC|USPC|USPC1900|AWS

*RST Setting

USPCs

Requirements

Test Application Revision: B.03.00: Added secondary 800 MHz band, deleted China cellular band.

Test Application Revision: B.11: Added US PCS 1900 MHz band.

Test Application Revision: B.12: Added AWS Band.

Programming Example

OUTPUT 714;"CALL:SETUP:BAND KPCS"
!Sets the handoff frequency band to Korean PCS cell band for handoffs to the IS-2000 system type.

CALL:SETup:CHANnel[:SELected][:SELected]

Function

Sets/queries the handoff physical channel. To set or query the physical channel for a call (the current physical channel), use the CALL:CHANnel[:SELected][:SELected] commands.

The handoff physical channel number is associated with a handoff system type and a handoff cell band.

The first optional [:SELected] keyword in this command specifies that the channel being set/queried applies to the current handoff system type. See CALL:SETup:SYSTem[:TYPE]<[:SELected]|[:TA2000]> to query or change the current handoff system type.

The second optional [:SELected] keyword in this command specifies that the channel being set/queried applies to the current handoff cell band. See CALL:SETup:BAND:[:SELected] to query or change the current handoff cell band.

Note: If the current system type evaluates to DIGital95, handoff cell band IMT2000 does not apply and attempting to specify IMT2000 as the DIGital95 handoff cell band will cause an instrument error.

Specifying a non-current handoff system type or handoff cell band when setting a channel number will cause the test set to store the channel number. Specifying a non-current handoff system type or handoff cell band when querying a channel number will return a stored channel number that is not current.

To initiate a hard handoff to a physical channel, see the CALL:HANDoff command description.

Setting

Range (depending on selected system type):

  • IMT2000: 0 to 1199

  • JCDM (Japanese CDMA): 1 to 799, 801 to 1039, 1041 to 1199

  • KPCS (Korean PCS): 0 to 599

  • NMT450: 1 to 400, 472 to 871, 1039 to 1473, 1536 to 1715, 1792 to 2016

  • SECondary800 (secondary 800 MHz band): 0 to 919

  • USC (US Cellular): 1 to 799, 991 to 1023, 1024 to 1323

  • USPC (US PCS): 0 to 1199

  • USPC1900: 0 to 1299

  • AWService: 0 to 899

Query

Range (depending on selected system type):

  • IMT2000: 0 to 1199

  • JCDM (Japanese CDMA): 1 to 799, 801 to 1039, 1041 to 1199

  • KPCS (Korean PCS): 0 to 599

  • NMT450: 1 to 400, 472 to 871, 1039 to 1473, 1536 to 1715, 1792 to 2016

  • SEC800 (secondary 800 MHz band): 0 to 919

  • USC (US Cellular): 1 to 799, 991 to 1023, 1024 to 1323

  • USPC (US PCS): 0 to 1199

  • USPC1900: 0 to 1299

  • AWService: 0 to 899

*RST Setting

Channel 525 (US PCS band)

Requirements

Test Application Revision: B.03 and above: Added secondary 800 MHz band, deleted China cellular band

Test Application Revision: B.10 and above: channel range of USCellular extended to include 1024 to 1323

Test Application Revision: B.11 and above: Added US PCS 1900 MHz Band

Test Application Revision: B.12 and above: Added AWS Band

Lab Application Revision: B.01 and above

Lab Application Revision: B.03.10 and above: channel range of USCellular extended to include 1024 to 1323

Lab Application Revision: B.04 and above: Added US PCS 1900 MHz Band

Lab Application Revision: B.05 and above: Added AWS Band

Programming Example

OUTPUT 714;"CALL:SETUP:CHANNEL?"
!Queries the channel number of the current handoff system and band.

OUTPUT 714;"CALL:SETUP:CHANNEL 384"
!Sets the channel number of the current handoff system and band.

OUTPUT 714;"CALL:SETUP:CHANNEL:DIGital2000:KPCS 384"
!Sets the handoff channel number for the IS-2000 system and Korean PCS band to 384. If this system
!and band are not being handed off to, the value 384 is stored and will be transmitted when Digital
!2000 and Korean PCS are handed off to.

CALL:SETup:HANDoff[:IMMediate]

Function

Initiates a handoff within the current system or between systems.

Programming Example

OUTPUT 714;"CALL:SETUP:HANDOFF:IMMEDIATE"

CALL:SETup:MS:ANALog:TXLevel[:SELected]

Function

Sets/queries the mobile power level to be used when originating a call on an AVC, or when performing a handoff to an AVC in the selected band, when in active cell operating mode.

In AVC Test operating mode, this command immediately changes the expected analog MS TX level.

Setting

Range: 0 to 7

MS TX Level 0: expected power, 36 dBm*
MS TX Level 1: expected power, 32 dBm
MS TX Level 2: expected power, 28 dBm
MS TX Level 3: expected power, 24 dBm
MS TX Level 4:expected power, 20 dBm
MS TX Level 5: expected power, 16 dBm
MS TX Level 6: expected power, 12 dBm
MS TX Level 7: expected power, 8 dBm

*all values for MS TX level assume 0 dB antenna gain

Query

Range: 0 to 7

*RST Setting

 2

Programming Example

OUTPUT 714;"CALL:SETUP:MS:ANALOG:TXLEVEL:SELECTED 5"
!Sets the handoff transmit power level to 5.

CALL:SETup:MS:ANALog:TXLevel:CELLular

Function

Sets/queries the mobile power level to be used when originating a call on an AVC, or when performing a handoff to an AVC in the cellular (800 MHz) band, when in active cell operating mode.

In AVC Test operating mode, this command immediately changes the expected analog MS TX level.

Setting

Range: 0 to 7

MS TX Level 0: expected power, 36 dBm*
MS TX Level 1: expected power, 32 dBm
MS TX Level 2: expected power, 28 dBm
MS TX Level 3: expected power, 24 dBm
MS TX Level 4:expected power, 20 dBm
MS TX Level 5: expected power, 16 dBm
MS TX Level 6: expected power, 12 dBm
MS TX Level 7: expected power, 8 dBm

*all values for MS TX level assume 0 dB antenna gain

Query

Range: 0 to 7

*RST Setting

 2

Programming Example

OUTPUT 714;"CALL:SETUP:MS:ANALOG:TXLEVEL:CELLULAR 5"
!Sets the handoff transmit power level to 5 in the cellular band.

CALL:SETup:SHANdoff:ENABle

Function

 This command instructs the test set to enter a soft or softer handoff.

If a call is connected when the soft/softer handoff enable command is sent, the test set will send a channel assignment message to the mobile station attempting to enter the soft or softer type handoff. (Soft or Softer handoff is selected by the CALL:SETup:SHANdoff:TYPe command.)

If the call connected state is idle when the soft/softer handoff enable command is sent, an initial assignment into a soft or softer handoff state will be attempted upon call origination. (If the current System Type is IS-95, the mobile station will be assigned to a fundamental channel on Cell 1 initially, then redirected to the soft or softer handoff state after the call is connected.)

Setting

Range: 0 (False)|1 (True)

Query

Range: same as setting.

*RST Setting

 0 (False)

Requirements

Lab Application Revision: A.01 and above

Programming Example

OUTPUT 714;"CALL:SETUP:SHANDOFF:ENABLE 1" !Enables soft/softer handoff

CALL:SETup:SHANdoff:TYPe

Function

 This command specifies the type of handoff (soft or softer) that is desired when the CALL:SETup:BAND:[:SELected] command is sent. If a call is connected in the soft/softer handoff state, a change to the soft/softer handoff type will send a channel assignment message to the mobile station informing it of the new soft/softer handoff condition.

Setting

Range: SFT (Soft)|SFTR (Softer)

Query

Range: same as setting.

*RST Setting

 SFT (Soft)

Requirements

Lab Application Revision: A.01 and above

Programming Example

OUTPUT 714;"CALL:SETUP:SHANDOFF:TYPE SFT" !Specifies soft handoff.

CALL:SETup:SYSTem[:TYPE]<[:SELected]|[:TA2000]>

Function

Sets/queries the system type that will the mobile station will be handed off to when the CALL:HANDoff command is used.

If handoff system type is the same as active cell system type (see CALL:SYSTem ), the mobile station will be handed off within the current system. If handoff system type is different than active cell system type, the call will be handed off to the system indicated by this command.

If the active system type is AMPS, handoffs to other system types are not allowed.

If the active system type is DIGital95, handoffs to DIGital2000 are not allowed.

Setting

Range: AMPS|DIGital2000|DIGital95

Query

Range: same as setting.

*RST Setting

 DIG2000

Programming Example

OUTPUT 714;"CALL:SETUP:SYSTEM:TYPE DIG2000" !Selects IS-2000 as the handoff system type.


CALL:SIDentity

CALL:SIDentity

Last updated: June 7, 2007

GPIB Command Conventions

  • CALL[:CELL]:SIDentity

CALL[:CELL]:SIDentity

Function

Sets/queries the system identification number. Use the CALL[:CELL]:SIDentity:CDMA command when the current system type is DIG2000 or DIG95. Use the CALL[:CELL]:SIDentity:AMPS command when the current system type is AMPS.

Setting

Range: 0 to 32767

Query

Range: 0 to 32767

*RST Setting

331

Programming Example

OUTPUT 714;"CALL:CELL:SIDENTITY 231"
!Sets the system identifier to 231.


CALL:SOPTion

CALL:SOPTion

Last updated: June 12, 2007

GPIB Command Conventions

  • CALL[:CELL]:SOPTion[:SELected][:SELected]
  • CALL[:CELL]:SOPTion:LOOPback:DSOurce:RESet[:STATe]
  • CALL[:CELL]:SOPTion:SO33:CHANnel:CONFigure

CALL[:CELL]:SOPTion[:SELected][:SELected]

Function

Sets/queries the service option for the system type and radio configuration specified by command parameters. See Service Option .

The first optional [:SELected] keyword in this command specifies that the service option being set/queried applies to the current system type. See CALL[:CELL]:SYSTem[:TYPE] to query or change the current system type.

The second optional [:SELected] keyword in this command specifies that the service option being set/queried applies to the current radio configuration. This keyword only applies in situations where DIGital2000 is the selected system type, since no other system type uses radio configurations. To set (make current) a radio configuration or query the current radio configuration, use the CALL:RCONfig command.

Note: If the current system type evaluates to DIGital95, radio configurations (RCONfig 1-5) do not apply and attempting to specify a radio configuration will cause an error. For example, SO 33 can be selected only when the current radio configuration is RCONfig3, RCONfig4, or RCONfig5.

Specifying a non-current radio configuration when setting a service option will cause the test set to store that service option for use when the specified radio configuration is current.

Specifying a non-current radio configuration when querying a service option will return a stored service option that is not the current service option.

To set (make current) a radio configuration or query the current radio configuration, use the CALL:RCONfig command.

  • SO1 = SO1(Voice) (Prior to B.06.00, it is SO1(Echo))
  • SO2 = SO2 (Loopback)
  • SO3 = SO3 (Voice) (Prior to B.06.00, it is SO3(Echo))
  • SO6 = SO6 (SMS), 9.6 kbps SMS on the Traffic Channel (for IS-95 system) or Fundamental Channel (for IS-2000 system) ( lab application only )
  • SO9 = SO9 (Loopback)
  • SO14 = SO14 (SMS), 14.4 kbps SMS on the Traffic Channel (for IS-95 system) or Fundamental Channel (for IS-2000 system) ( lab application only )
  • SO17 = SO17 (Voice) (Prior to B.06.00, it is SO17(Echo))
  • SO55 = SO55 (Loopback)
  • SO32768 = SO32768 (Voice) (Prior to B.06.00, it is SO32768(Echo))
  • SOFS32 = SO32 (+ F-SCH), SO32 with Forward Supplemental Channel only (SO32 is the cdma2000 Test Data Service Option (TDSO))
  • SOS32 = SO32 (+ SCH), SO32 with both Forward and Reverse Supplemental Channels
  • SO33 = SO33 High Speed Packet Data with Forward and Reverse Fundamental Channels only ( lab application only ) (see Packet Data Service Configurations )
  • SOFS33 = SO33 (+ F-SCH), High Speed Packet Data for Forward and Reverse Fundamental Channels with Forward Supplemental Channel ( lab application only )
  • SO68 = SO68 (Voice), The Enhanced Variable Rate Codec B (EVRC-B).

Setting

Range: SO1|SO2|SO3|SO6|SO9|SO14|SO17|SO55|SO32768|SOFS32|SOS32 |SO33|SOFS33|SO68 depending on system type and radio configuration.

Query

same as settings.

*RST Setting

SO2 when system type is DIGital95 or when system type is DIGital2000 and radio configuration RCONfig1, RCONfig3, or RCONfig4 are selected.

SO17 when system type is DIGital2000 and radio configuration RCONfig2 or RCONfig5 are selected.

Requirements

Test Application Revision: B.03 and above: Added SOFS32, SOS32
Lab Application Revision: A.02 and above: Added SOFS33, SO33
Lab Application Revision: B.00 and above: Added SO6, SO14

Programming Example

OUTPUT 714;"CALL:CELL:SOPTION?"
!Queries the service option of the currently selected system type and radio configuration.

OUTPUT 714;"CALL:CELL:SOPTION SO3"
!Selects service option 3 for the currently selected system type and radio configuration.

OUTPUT 714;"CALL:CELL:SOPTION:DIGital2000:RCONFIG3 SO3"
!Sets the service option for the digital 2000 system and radio configuration 3 to service option 3.
!If this system and radio configuration are not current, service option 3 is stored and will be
!used when digital 2000 and radio configuration 3 are current.

OUTPUT 714;"CALL:CELL:SOPTION SO33"
!Selects service option 33 for the currently selected system type and radio configuration.

OUTPUT 714;"CALL:CELL:SOPTION:DIGital2000:RCONFIG3 SO33"
!Sets the service option for the digital 2000 system and radio configuration 3 to service option 33.
!If this system and radio configuration are not current, service option 33 is stored and will be
!current when digital 2000 and radio configuration 3 are current.

CALL[:CELL]:SOPTion:LOOPback:DSOurce:RESet[:STATe]

Function

 When this setting is set to on, the

Setting

Range: 1|ON|0|OFF

Query

Range: 1|0

*RST Setting

OFF

Programming Example

OUTPUT 714;"CALL:SOPTion:LOOPback:DSOurce:RESet ON"

CALL[:CELL]:SOPTion:SO33:CHANnel:CONFigure

Function

Configure the physical channel for SO33. When the IS-2000 Service Option is SO33 and the data connection is established, the setting is used to assign or unassign either F-SCH or R-SCH or both.

  • FCHannel represents FCH: only fundamental channels are to be assigned.
  • FCFSchannel represents FCH + F-SCH: only fundamental channels and forward supplemental channel are to be assigned.
  • FCRSchannel represnets FCH + R-SCH: only fundamental channels and reverse supplemental channel are to be assigned.
  • FCSChannel represents FCH + SCH: fundamental channels and supplemental channels to be assigned, both forward and reverse.

Setting

Range: FCHannel|FCFSchannel|FCRSchannel|FCSChannel

Query

same as settings

*RST Setting

FCHannel

Requirements

 Lab Application Revision: B.05 and above.

Programming Example

OUTPUT 714;"CALL:SOPTion:SO33:CHANnel:CONFigure FCH"
!Sets the physical channels for SO33 to be only fundamental channels.

Related Topics

Service Option


CALL:STATus

CALL:STATus

Last updated: June 7, 2007

NOTE
The CALL:STATus commands are query only. They return values that indicate the test set's actual hardware settings. Actual hardware settings can differ from settings you have entered, most frequently due to an error condition. See Troubleshooting Setting Power Levels for possible causes. When no error conditions exist, the commands used to enter values will return the same results as the commands used to query actual hardware settings. For example, "CALL:AWGNoise:POWer?" will return the same value as "CALL:STATus:AWGNoise:POWer?" when no error conditions exist.

GPIB Command Conventions

  • CALL:STATus[:STATe][:VOICe]?
  • CALL:STATus[:STATe]:DATA?
  • CALL:STATus:AVC:[:CHANnel]?
  • CALL:STATus:AVC:SATone[:CCODe]?
  • CALL:STATus:CELL:SYSTem[:TYPE]?
  • CALL:STATus:CLPControl[:CELL[1]]:REVerse:TRANsient:STATe?
  • CALL:STATus:LOOPback?
  • CALL:STATus:MS:ANALog:TXLevel?
  • CALL:STATus:MSPeed[:CPOWer]?
  • CALL:STATus:SHANdoff?
  • CALL:STATus:AWGNoise[:INTernal]:POWer[:AMPLitude][:SELected]?
  • CALL:STATus:AWGNoise[:INTernal]:POWer:STATe[:SELected]?
  • CALL:STATus:CELL[1]:POWer:[AMPLitude][:SELected]?
  • CALL:STATus:CELL[1]:POWer:STATe[:SELected]?
  • CALL:STATus:CELL2:POWer:[AMPLitude][:SELected]?
  • CALL:STATus:CELL2:POWer:STATe[:SELected]?
  • CALL:STATus:BCCHannel[:LEVel]<[:SELected]|:DIGital2000>?
  • CALL:STATus:BCCHannel:STATe<[:SELected]|:DIGital2000>?
  • CALL:STATus:BCCHannel:EBNTotal?
  • CALL:STATus:CCCHannel[:LEVel]<[:SELected]|:DIGital2000>?
  • CALL:STATus:CCCHannel:STATe<[:SELected]|:DIGital2000>?
  • CALL:STATus:CCCHannel:EBNTotal?
  • CALL:STATus:CSTime:LOCal:DATE?
  • CALL:STATus:CSTime:LOCal:TIME?
  • CALL:STATus:FPControl:FCHannel:LEVel:MAXimum?
  • CALL:STATus:FCHannel[:CELL[1]][:LEVel][:SELected]?
  • CALL:STATus:FCHannel[:CELL[1]]:STATe[:SELected]?
  • CALL:STATus:FCHannel:CELL2:LEVel[:SELected]?
  • CALL:STATus:FCHannel:CELL2:STATe[:SELected]?
  • CALL:STATus:OCNSource[:CELL[1]][:LEVel][:SELected]?
  • CALL:STATus:OCNSource[:CELL[1]]:STATe[:SELected]?
  • CALL:STATus:OCNSource:CELL2:LEVel[:SELected]?
  • CALL:STATus:OCNSource:CELL2:STATe[:SELected]?
  • CALL:STATus:PAGing[:LEVel][:SELected]?
  • CALL:STATus:PAGing:STATe[:SELected]?
  • CALL:STATus:PAGing:EBNTotal?
  • CALL:STATus:PAGing:MERRor:MESSages?
  • CALL:STATus:PAGing:MERRor:PROCedure:WARNing?
  • CALL:STATus:PAGing:MERRor:RATio[:SLOTed]?
  • CALL:STATus:PAGing:MERRor:TIME?
  • CALL:STATus:PAGing:IMSI:S1?
  • CALL:STATus:PAGing:IMSI:S2?
  • CALL:STATus:PILot[:CELL[1]][:LEVel][:RTCell][:SELected]?
  • CALL:STATus:PILot[:CELL[1]][:LEVel]:RTTotal[:SELected]?
  • CALL:STATus:PILot[:CELL[1]]:STATe[:SELected]?
  • CALL:STATus:PILot[:CELL[1]]:STRength[:SELected]?
  • CALL:STATus:PILot:CELL2[:LEVel:][:RTCell][:SELected]?
  • CALL:STATus:PILot:CELL2[:LEVel]:RTTotal[:SELected]?
  • CALL:STATus:PILot:CELL2:STATe[:SELected]?
  • CALL:STATus:PILot:CELL2:STRength[:SELected]?
  • CALL:STATus:QPCHannel:EBNTotal?
  • CALL:STATus:QPCHannel[:LEVel][:RTCell][:SELected]?
  • CALL:STATus:QPCHannel[:LEVel]:RTPilot[:SELected]?
  • CALL:STATus:QPCHannel:STATe[:SELected]?
  • CALL:STATus:SCHannel[:LEVel][:SELected]?
  • CALL:STATus:SCHannel[:FORWard]:EBNTotal?
  • CALL:STATus:SCHannel[:FORWard]:STATe[:SELected]?
  • CALL:STATus:SCHannel[:FORWard]:SYNChronized?
  • CALL:STATus:SCHannel:FORWard:ASSigned?
  • CALL:STATus:SCHannel:FORWard:ENCoder?
  • CALL:STATus:SCHannel:REVerse:ASSigned?
  • CALL:STATus:SCHannel:REVerse:ENCoder?
  • CALL:STATus:SYNC[:LEVel][:SELected]?
  • CALL:STATus:SYNC:STATe[:SELected]?
  • CALL:STATus:TOTal:POWer[:AMPLitude][:SELected]?
  • CALL:STATus:TOTal:POWer:STATe[:SELected]?
  • CALL:STATus:TRAFfic[:CELL[1]][:LEVel][:SELected]?
  • CALL:STATus:TRAFfic[:CELL[1]]: EBNTotal?
  • CALL:STATus:TRAFfic[:CELL[1]]:STATe[:SELected]?
  • CALL:STATus:TRAFfic:CELL2:LEVel[:SELected]?
  • CALL:STATus:TRAFfic:CELL2:STATe[:SELected]?

CALL:STATus[:STATe][:VOICe]?

Function

Queries the status of the call. Status can be idle, paging, call (alerting), connected, access probe, releasing, handoff, or registering. See Call Processing State Synchronization .

Query

Range: IDLE|PAG|CALL|CONN|APR|REL|HAND|REG

*RST Setting

 IDLE

Programming Example

OUTPUT 714;"CALL:STATUS?"
!Returns the current call processing state.

CALL:STATus[:STATe]:DATA?

Function

Queries the status of the data connection in test data service options (SO32 (+ F-SCH) or SO32 (+ SCH)) (see Call Processing State Synchronization ) or for the packet data connection in service options (SO33 or SO33 (+F-SCH)) (see Packet Data Connection Processing States ). Status returned can be off (Idle), dormant (DORM), or data connected (DCON) while DORM state is only available for packet data connection.

Query

Test Application Range: OFF|DCON

Lab Application Range: OFF|DORM|DCON

*RST Setting

 OFF

Requirements

Test Application Revision: B.02 and above
Lab Application Revision: B.02 and above: Added DORM

Programming Example

OUTPUT 714;"CALL:STATus:DATA?" !Returns the current data connection state.

CALL:STATus:AVC:[:CHANnel]?

Function

Queries the active channel number when connected on an analog voice channel. Only used in active cell operating mode.

Query

Range: 1 through 799, 991 through 1023, 9.91 E+37

*RST Setting

 9.91E37 (*RST disconnects the call, so the mobile is no longer on an AVC.)

Programming Example

OUTPUT 714;"CALL:STATUS:AVC:CHANNEL?"

CALL:STATus:AVC:SATone[:CCODe]?

Function

Queries the active supervisory audio tone Freudians when connected on an analog voice channel. Only used in active cell operating mode.

Query

Range: SAT1|SAT2|SAT3|UNKN

SAT1 = 5970 Hz
SAT2 = 6000 Hz
SAT3 = 6030 Hz

*RST Setting

 UNKN (*RST disconnects the call, so the mobile is no longer on an AVC.)

Programming Example

OUTPUT 714;"CALL:STATUS:AVC:SATONE:CCODE?"

CALL:STATus:CELL:SYSTem[:TYPE]?

Function

Queries the current system type that the test set is currently emulating.

When the test set is in active cell operating mode (see CALL:OPERating ) the current system type is selected by the CALL:SYSTem command.

When the test set is in any test mode operating mode (see CALL:OPERating ) or CW operating mode this command will return the corresponding system type.

Query

Range: DIG2000|CW|AMPS|DIG95

*RST Setting

 DIG2000

Programming Example

OUTPUT 714;"CALL:STATUS:CELL:SYSTEM:TYPE?"

CALL:STATus:CLPControl[:CELL[1]]:REVerse:TRANsient:STATe?

Function

Queries whether or not the closed loop power control transient is currently being transmitted on the reverse power control sub-channel.

The closed loop power control transient is started using the CALL[:CELL[1]]:CLPControl:REVerse:TRANsient:STARt .

See Starting the Reverse CLPC Transient for details.

Query

Range: 1|0

*RST Setting

 0 (Off)

Programming Example

OUTPUT 714;"CALL:STATUS:CLPControl:REVerse:TRANsient:STATe?"

CALL:STATus:LOOPback?

Function

Queries the current loopback mode.

Loopback mode indicates if the selected service option is currently SO2, SO9 or SO55 (loopback) and a call is connected in the current system. (The test set does not attempt to verify that data is actually being looped back by the mobile station when responding to this query).

Loopback mode is set using the CALL:SOPTion command.

Query

Range: 1|0

*RST Setting

 0 (Off)

Programming Example

OUTPUT 714;"CALL:STATUS:LOOPBACK?"

CALL:STATus:MS:ANALog:TXLevel?

Function

Queries the power level setting of the mobile on an active analog voice channel. Only used in active cell operating mode.

Query

Range: 0 to 7, 9.91E+37

MS TX Level 0: expected power, 36 dBm*
MS TX Level 1: expected power, 32 dBm
MS TX Level 2: expected power, 28 dBm
MS TX Level 3: expected power, 24 dBm
MS TX Level 4:expected power, 20 dBm
MS TX Level 5: expected power, 16 dBm
MS TX Level 6: expected power, 12 dBm
MS TX Level 7: expected power, 8 dBm

*all values for MS TX level assume 0 dB antenna gain

*RST Setting

 9.91E37 (*RST disconnects the call, so the mobile is no longer on an AVC.)

Programming Example

OUTPUT 714;"CALL:STATUS:MS:ANALOG:TXLEVEL?"

CALL:STATus:MSPeed[:CPOWer]?

Function

Queries the current measurement speed being used by the channel power measurement. This speed may differ from the setting specified by the SETup:CPOWer:MSPeed command. See Measurement Speed .

Query

Range: NORM|FAST|VFAS

*RST Setting

 NORM

Requirements

Test Application Revision: B.07 and above: Added VFAS
Lab Application Revision: B.01 and above: Added VFAS

Programming Example

OUTPUT 714;"CALL:STATUS:MSPEED:CPOWER?"

CALL:STATus:SHANdoff?

Function

Queries the current soft/softer handoff state.

The soft handoff states are:.

  • Soft - A link is present and the mobile station is in a soft handoff
  • Softer - A link is present and the mobile station is in a softer handoff
  • None - Neither soft nor softer handoff states are present

Query

Range: SFT|SFTR|NONE

*RST Setting

 NONE

Requirements

Lab Application Revision: A.01 and above

Programming Example

OUTPUT 714;"CALL:STATUS:SHANDOFF?"

CALL:STATus:AWGNoise[:INTernal]:POWer[:AMPLitude][:SELected]?

Function

Queries the current power level of the additive white Gaussian noise (AWGN) source for the currently selected system type.

The optional [:SELected] keyword in this command specifies that the AWGN power level being queried applies to the current system type (see CALL:STATus:CELL:SYSTem[:TYPE]? ).

AWGN power level is set using the CALL:AWGNoise commands.

See Cell Power, AWGN Power and Total RF Power Ranges for more information about desired versus current power levels.

Query

Range:

  • -170 dBm/1.23 MHz to +35 dBm/1.23 MHz, NAN (this is the range of settings accepted, see Cell Power, AWGN Power and Total RF Power Ranges for the actual hardware range of the source)
  • 9.91 E+37 (NAN) is returned if CALL:STATus:AWGNoise[:INTernal]:POWer:STATe[:SELected]? is OFF

Resolution: 0.01 dB

*RST Setting

 9.91 E+37 (NAN)

Programming Example

OUTPUT 714;"CALL:STATUS:AWGNOISE:POWER:AMPLITUDE?"
!Queries the current AWGN power for the current system type.

CALL:STATus:AWGNoise[:INTernal]:POWer:STATe[:SELected]?

Function

Queries the current on/off state of the additive white Gaussian noise (AWGN) source for the currently selected system type.

The optional [:SELected] keyword in this command specifies that the AWGN power level being queried applies to the current system type (see CALL:STATus:CELL:SYSTem[:TYPE]? ).

AWGN power level on/off state is set using the CALL:AWGNoise commands.

See Cell Power, AWGN Power and Total RF Power Ranges for more information about desired versus current power levels.

Query

Range: 1|0

*RST Setting

 0 (Off)

Programming Example

OUTPUT 714;"CALL:STATUS:AWGNOISE:POWER:STATE:SELECTED?"

CALL:STATus:CELL[1]:POWer:[AMPLitude][:SELected]?

Function

Queries the current Cell 1 Power for the selected system type.

The optional [:SELected] keyword in this command specifies that the cell power level being queried applies to the current system type (see CALL:STATus:CELL:SYSTem[:TYPE]? ).

Cell 1 power is set using the CALL:POWer commands.

See Cell Power, AWGN Power and Total RF Power Ranges for more information about desired versus current power levels.

Query

Range:

  • -170 dBm/1.23 MHz to +37 dBm/1.23 MHz, NAN (this is the range of settings accepted, see Cell Power, AWGN Power and Total RF Power Ranges for the actual hardware range of the source)
  • 9.91 E+37 (NAN) is returned if CALL:STATus:CELL[1]:POWer:STATe[:SELected]? is OFF

Resolution: 0.01 dB

*RST Setting

-55.0 dBm/1.23 MHz

Programming Example

OUTPUT 714;"CALL:STATUS:CELL:POWER?"

CALL:STATus:CELL[1]:POWer:STATe[:SELected]?

Function

Queries the state of Cell 1 Power for the currently selected system type.

The optional [:SELected] keyword in this command specifies that the power state being queried applies to the current system type (see CALL:STATus:CELL:SYSTem[:TYPE]? ).

Cell 1 power state is set using the CALL:POWer commands.

See Cell Power, AWGN Power and Total RF Power Ranges for more information about desired versus current power levels.

Query

Range: 1|0

*RST Setting

 0 (Off)

Programming Example

OUTPUT 714;"CALL:STATUS:CELL:POWER:STATE:SELECTED?"

CALL:STATus:CELL2:POWer:[AMPLitude][:SELected]?

Function

Queries the current Cell 2 Power for the selected system type.

The optional [:SELected] keyword in this command specifies that the cell 2 power level being queried applies to the current system type (see CALL:STATus:CELL:SYSTem[:TYPE]? ).

Cell 2 power is set using the CALL:CELL2:POWer commands.

See Cell Power, AWGN Power and Total RF Power Ranges for more information about desired versus current power levels.

Query

Range:

  • -170 dBm/1.23 MHz to +37 dBm/1.23 MHz, NAN (this is the range of settings accepted, see Cell Power, AWGN Power and Total RF Power Ranges for the actual hardware range of the source)
  • 9.91 E+37 (NAN) is returned if CALL:STATus:CELL2:POWer:STATe[:SELected]? is OFF

Resolution: 0.01 dB

*RST Setting

9.91 E+37 (NAN)

Requirements

Lab Application Revision: A.01 and above

Programming Example

OUTPUT 714;"CALL:STATUS:CELL2:POWER:AMPLITUDE:SELECTED?"

CALL:STATus:CELL2:POWer:STATe[:SELected]?

Function

Queries the state of Cell 2 Power for the currently selected system type.

The optional [:SELected] keyword in this command specifies that the power state being queried applies to the current system type (see CALL:STATus:CELL:SYSTem[:TYPE]? ).

Cell 2 power state is set using the CALL:CELL2:POWer commands.

See Cell Power, AWGN Power and Total RF Power Ranges for more information about desired versus current power levels.

Query

Range: 1|0

*RST Setting

 0 (Off)

Requirements

Lab Application Revision: A.01 and above

Programming Example

OUTPUT 714;"CALL:STATUS:CELL2:POWER:STATE:SELECTED?"

CALL:STATus:BCCHannel[:LEVel]<[:SELected]|:DIGital2000>?

Function

Queries the current broadcast control channel (F-BCCH) level for the currently selected system type. See Current Level and Desired Level for details.

The optional [:SELected] keyword in this command specifies that the F-BCCH level being queried applies to the current system type (see CALL:STATus:CELL:SYSTem[:TYPE]? ).

Query

Range: 0 to -20 dB or,
9.91 E+37 (returned when CALL:STATus:BCCHannel:STATe<[:SELected]|:DIGital2000>? is OFF)

Resolution: 0.0001 dB

*RST Setting

 9.91 E+37

Requirements

Test Application Revision: B.08 and above, with the required feature license

Lab Application Revision: B.02 and above

Programming Example

OUTPUT 714;"CALL:STATus:BCCHannel?"

CALL:STATus:BCCHannel:STATe<[:SELected]|:DIGital2000>?

Function

Queries the current broadcast control channel (F-BCCH) state for the currently selected system type. See Current Level and Desired Level for details.

The optional [:SELected] keyword in this command specifies that the F-BCCH state being queried applies to the current system type (see CALL:STATus:CELL:SYSTem[:TYPE]? ).

Query

Range: 1|0

*RST Setting

 0 (Off)

Requirements

Test Application Revision: B.08 and above, with the required feature license

Lab Application Revision: B.02 and above

Programming Example

OUTPUT 714;"CALL:STATus:BCCHannel:STATe?"

CALL:STATus:BCCHannel:EBNTotal?

Function

Queries the result of F-BCCH Eb/Nt (the ratio of energy per bit for the F-BCCH channel to noise power spectral density).

Query

Range: -30 to 30 dB, 9.91 E+37

Resolution: 0.001 dB

*RST Setting

 9.91 E+37 (NAN)

Requirements

Lab Application Revision: B.02 and above

Programming Example

OUTPUT 714;"CALL:STATUS:BCCHannel:EBNTotal?"

CALL:STATus:CCCHannel[:LEVel]<[:SELected]|:DIGital2000>?

Function

Queries the current common control channel (F-CCCH) level for the currently selected system type. See Current Level and Desired Level for details.

The optional [:SELected] keyword in this command specifies that the F-CCCH level being queried applies to the current system type (see CALL:STATus:CELL:SYSTem[:TYPE]? ).

Query

Range: 0 to -20 dB or,
9.91 E+37 (returned when CALL:STATus:CCCHannel:STATe<[:SELected]|:DIGital2000>? is OFF)

Resolution: 0.0001 dB

*RST Setting

 9.91 E+37

Requirements

Test Application Revision: B.08 and above, with the required feature license

Lab Application Revision: B.02 and above

Programming Example

OUTPUT 714;"CALL:STATus:CCCHannel?"

CALL:STATus:CCCHannel:STATe<[:SELected]|:DIGital2000>?

Function

Queries the current common control channel (F-CCCH) state for the currently selected system type. See Current Level and Desired Level for details.

The optional [:SELected] keyword in this command specifies that the F-CCCH state being queried applies to the current system type (see CALL:STATus:CELL:SYSTem[:TYPE]? ).

Query

Range: 1|0

*RST Setting

 0 (Off)

Requirements

Test Application Revision: B.08 and above, with the required feature license

Lab Application Revision: B.02 and above

Programming Example

OUTPUT 714;"CALL:STATus:CCCHannel:STATe?"

CALL:STATus:CCCHannel:EBNTotal?

Function

Queries the result of F-CCCH Eb/Nt (the ratio of energy per bit for the F-CCCH channel to noise power spectral density).

Query

Range: -30 to 30 dB, 9.91 E+37

Resolution: 0.001 dB

*RST Setting

 9.91 E+37 (NAN)

Requirements

Lab Application Revision: B.02 and above

Programming Example

OUTPUT 714;"CALL:STATUS:CCCHannel:EBNTotal?"

CALL:STATus:CSTime:LOCal:DATE?

Function

Queries the date portion of the CDMA Local time. It is the same date displayed in the mobile station. The value of setting is calculated with the following formula:

CDMA Local Time (Date) = Date (CDMA System Time (Date) + CDMA System Time (Time) - Leap Second + Local Time Offset)

After the mobile station finds the service and registers in the test set, if the Local Time Offset and the Leap Seconds are changed, the time displayed on the mobile station can not be updated immediately since these parameters are only sent in the Sync Channel Message . Therefore the time in the mobile station doesn't match that in the test set until the Sync Channel Message is received.

Query

Range: from January 6, 1980 to January 5, 2096. It is returned in three comma-separated values, in the order of <year>, <month> and <date> where

  • <year> 1980 to 2096
  • <month> 1 to 12 (the number 1 corresponds to January)
  • <day> 1 to the number of days in the month specified by the <month> parameter
  • -1,-1,-1 (When the Operating Mode is not Active Cell or IS-2000 Test Mode or the System Type is not in IS-95 or IS-2000 )

Requirement

Test Application revision: B.10 and above

Lab Application revision: B.03 and above

Programming Example

OUTPUT 714;"CALL:STATUS:CSTIME:LOCAL:DATE?" !Queries the date portion of CDMA local time.

CALL:STATus:CSTime:LOCal:TIME?

Function

Queries the time portion of the CDMA Local time. It is the same time displayed on the mobile station. The time format is <hour>.<minute>.<second>. The value of setting is calculated with the following formula:

CDMA Local Time (Time) = Time (CDMA System Time (Date) + CDMA System Time (Time) - Leap Second + Local Time Offset)

When the call is connected and the Local Time Offset and the Leap Seconds are changed, the time displayed on the mobile station can not be updated immediately since these parameters are only sent in the Sync Channel Message . Therefore the time in the mobile station doesn't match that in the test set until the Sync Channel Message is received.

Query

Range: any time of a day. It is returned in three comma-separated values, in the order of <hour>,<minute>,<second> where

  • <hour> 0 to 23
  • <minute> 0 to 59
  • <second> 0 to 59
  • -1,-1,-1 (When the Operating Mode is not Active Cell or IS-2000 Test Mode or the System Type is not in IS-95 or IS-2000 )

Requirement

Test Application revision: B.10 and above

Lab Application revision: B.03 and above

Programming Example

OUTPUT 714;"CALL:STATUS:CSTIME:LOCAL:TIME?"!Queries the time portion of CDMA local time.

CALL:STATus:FPControl:FCHannel:LEVel:MAXimum?

Function

Queries the actual upper limit of F-FCH level (Ec/Ior) that the test set is allowed to be adjusted to according to the forward power control (FPC). See Current Maximum F-FCH Level .

The maximum F-FCH level for FPC is set using the CALL[:CELL]:FPControl:FCHannel:LEVel:MAXimuml command.

Query

Range: -30 to -2 dB, 9.91 E+37

Resolution: 0.0001 dB

*RST Setting

9.91 E+37

Requirements

Lab Application Revision: B.02 and above

Programming Example

OUTPUT 714;"CALL:STATUS:FPControl:FCHannel:LEVel:MAXimum?"
!Query the current maximum FPC F-FCH level.

CALL:STATus:FCHannel[:CELL[1]][:LEVel][:SELected]?

Function

Queries the current cell (1) forward fundamental channel (FCH) level.

The optional [:SELected] keyword in this command specifies that the fundamental channel level being queried applies to the current system type (see CALL:STATus:CELL:SYSTem[:TYPE]? ).

The forward fundamental channel level is set using the CALL:FCHannel commands.

See Configuring Forward Channel Power Levels and Walsh Codes for more information.

Query

Range: 0 to 30 dB, 9.91 E+37

Resolution: 0.01 dB

*RST Setting

 9.91 E+37

Programming Example

OUTPUT 714;"CALL:STATUS:FCHANNEL:LEVEL?"

CALL:STATus:FCHannel[:CELL[1]]:STATe[:SELected]?

Function

Queries the current cell (1) forward fundamental channel (FCH) on/off state.

The optional [:SELected] keyword in this command specifies that the fundamental channel state being queried applies to the current system type (see CALL:STATus:CELL:SYSTem[:TYPE]? ).

The forward fundamental channel on/off state is set using the CALL:FCHannel commands.

See Configuring Forward Channel Power Levels and Walsh Codes for more information.

Query

Range: 1|0

*RST Setting

 0 (Off)

Programming Example

OUTPUT 714;"CALL:STATUS:FCHANNEL:STATE:DIGITAL2000?"

CALL:STATus:FCHannel:CELL2:LEVel[:SELected]?

Function

Queries the current cell 2 forward fundamental channel (FCH) level.

The optional [:SELected] keyword in this command specifies that the fundamental channel level being queried applies to the current system type (see CALL:STATus:CELL:SYSTem[:TYPE]? ).

The cell 2 forward fundamental channel level is set using the CALL:CELL2:FCHannel commands. See Configuring Cell 2 PN Offset and Code Channels for more information.

Query

Range: 0 to 30 dB, 9.91 E+37

Resolution: 0.01 dB

*RST Setting

 9.91 E+37

Requirements

Lab Application Revision: A.01 and above

Programming Example

OUTPUT 714;"CALL:STATUS:FCHANNEL:CELL2:LEVEL?"

CALL:STATus:FCHannel:CELL2:STATe[:SELected]?

Function

Queries the current cell 2 forward fundamental channel (FCH) on/off state.

The optional [:SELected] keyword in this command specifies that the fundamental channel state being queried applies to the current system type (see CALL:STATus:CELL:SYSTem[:TYPE]? ).

The cell 2 forward fundamental channel on/off state is set using the CALL:CELL2:FCHannel commands. See Configuring Cell 2 PN Offset and Code Channels for more information.

Query

Range: 1|0

*RST Setting

 0 (Off)

Requirements

Lab Application Revision: A.01 and above

Programming Example

OUTPUT 714;"CALL:STATUS:FCHANNEL:CELL2:STATE:DIGITAL2000?"

CALL:STATus:OCNSource[:CELL[1]][:LEVel][:SELected]?

Function

Queries the cell (1) orthogonal channel noise source (OCNS) level for the selected system type.

The optional [:SELected] keyword in this command specifies that the OCNS channel level being queried applies to the current system type (see CALL:STATus:CELL:SYSTem[:TYPE]? ).

The OCNS level is set using the CALL:OCNSource commands.

See Configuring Forward Channel Power Levels and Walsh Codes for more information.

Query

Range: 0 to -20 dB, 9.91 E+37

Resolution: 0.01 dB

*RST Setting

 9.91 E+37

Programming Example

OUTPUT 714;"CALL:STATUS:OCNSOURCE:LEVEL:SELECTED?"

CALL:STATus:OCNSource[:CELL[1]]:STATe[:SELected]?

Function

Queries the current cell (1) on/off state of the orthogonal channel noise simulator channel (OCNS).

The OCNS channel on/off state is set using the CALL:OCNSource commands. See Configuring Forward Channel Power Levels and Walsh Codes for more information.

The optional [:SELected] keyword in this command specifies that the OCNS channel state being queried applies to the current system type (see CALL:STATus:CELL:SYSTem[:TYPE]? ).

Query

Range: 1|0

*RST Setting

 0 (Off)

Programming Example

OUTPUT 714;"CALL:STATUS:OCNS:STATE:SELECTED?"

CALL:STATus:OCNSource:CELL2:LEVel[:SELected]?

Function

Queries the cell 2 orthogonal channel noise source (OCNS) level for the selected system type.

The OCNS level is set using the CALL:CELL2:OCNSource commands. See Configuring Cell 2 PN Offset and Code Channels for more information.

The optional [:SELected] keyword in this command specifies that the OCNS channel level being queried applies to the current system type (see CALL:STATus:CELL:SYSTem[:TYPE]? ).

Query

Range: 0 to -20 dB, 9.91 E+37

Resolution: 0.01 dB

*RST Setting

 9.91 E+37

Requirements

Lab Application Revision: A.01 and above

Programming Example

OUTPUT 714;"CALL:STATUS:OCNSOURCE:CELL2:LEVEL:SELECTED?"

CALL:STATus:OCNSource:CELL2:STATe[:SELected]?

Function

Queries the current cell 2 on/off state of the orthogonal channel noise simulator channel (OCNS).

The OCNS channel on/off state is set using the CALL:CELL2:OCNSource commands. See Configuring Cell 2 PN Offset and Code Channels for more information.

The optional [:SELected] keyword in this command specifies that the OCNS channel state being queried applies to the current system type (see CALL:STATus:CELL:SYSTem[:TYPE]? ).

Query

Range: 1|0

*RST Setting

 0 (Off)

Requirements

Lab Application Revision: A.01 and above

Programming Example

OUTPUT 714;"CALL:STATUS:OCNS:CELL2:STATE:SELECTED?"

CALL:STATus:PAGing[:LEVel][:SELected]?

Function

Queries the current paging level for the currently selected system type.

The forward paging channel level is set using the CALL:PAGing commands. See Configuring Forward Channel Power Levels and Walsh Codes for more information.

The optional [:SELected] keyword in this command specifies that the paging level being queried applies to the current system type (see CALL:STATus:CELL:SYSTem[:TYPE]? ).

Query

Range: 0 to -20 dB, 9.91 E+37

Resolution: 0.01 dB

*RST Setting

 9.91 E+37

Programming Example

OUTPUT 714;"CALL:STATUS:PAGING:LEVEL:SELECTED?"

CALL:STATus:PAGing:STATe[:SELected]?

Function

Queries the current paging level state for the currently selected system type.

The forward paging channel level is set using the CALL:PAGing commands. See Configuring Forward Channel Power Levels and Walsh Codes for more information.

The optional [:SELected] keyword in this command specifies that the paging state being queried applies to the current system type (see CALL:STATus:CELL:SYSTem[:TYPE]? ).

Query

Range: 1|0

*RST Setting

 0 (Off)

Programming Example

OUTPUT 714;"CALL:STATUS:PAGING:STATE:SELECTED?"

CALL:STATus:PAGing:EBNTotal?

Function

Queries the ratio of energy per bit for the paging channel to noise power spectral density. See Paging Channel MER Results .

Query

Range: -30.0 to 30.0 dB, 9.91 E+37

Resolution: 0.001 dB

*RST Setting

 9.91 E+37

Requirements

Test Application Revision: B.07 and above

Lab Application Revision: B.01 and above

Programming Example

OUTPUT 714;"CALL:STATUS:PAGing:EBNTOTAL?"
!Query the Paging Channel Eb/Nt.

CALL:STATus:PAGing:MERRor:MESSages?

Function

Queries the total number of the paging channel messages which have been sent to the mobile station during the Paging Channel MER procedure. See Paging Channel MER Results for details.

When the count of paging channel messages reaches its maximum, it will roll over to zero and an error message is generated.

The paging channel messages counter is cleared to zero by the CALL:PAGing:MERRor:PROCedure:PARameter:CLEar .

Query

Range: 0 to 65535

Resolution: 1

*RST Setting

0

Requirements

Lab Application Revision: B.01 and above

Programming Example

OUTPUT 714;"CALL:STATUS:PAGing:MERRor:MESSages?"
!Returns the total number of paging channel messages sent to the mobile station.

CALL:STATus:PAGing:MERRor:PROCedure:WARNing?

Function

Queries the error or warning conditions that have occurred during the Paging Channel MER procedure. The error is updated as the condition occurs and does not wait for the Paging MER test procedure to be completed. Only the last error condition that occurred is returned. The error or warning condition can be cleared by the CALL:PAGing:MERRor:PROCedure:PARameter:CLEar . See Paging Channel MER Results for details.

Query

Range:

  • "" (null string, indicates no error)
  • "MS values exceed test set values"
  • "Overflow of paging message counter"
  • "MER settings changed during procedure"
  • "MS values not received"
  • "Paging message counter equals zero"

*RST Setting

"" (null string, indicates no error)

Requirements

Lab Application Revision: B.01 and above

Programming Example

OUTPUT 714;"CALL:STATUS:PAGing:MERRor:PROCedure:WARNing?"
!Query the error conditions that occur during Paging MER test.

CALL:STATus:PAGing:MERRor:RATio[:SLOTed]?

Function

Queries the Slotted Paging Channel MER result, in percentage. It is used to evaluate how well the mobile station demodulates the paging channel in an AWGN (no fading or multipath) environment. The Paging Channel MER result can be cleared by the CALL:PAGing:MERRor:PROCedure:PARameter:CLEar . See Paging Channel MER Results for details.

Query

Range: 0.0 to 100.0, 9.91E+37
Resolution: 0.0001

*RST Setting

9.91E+37 (NAN)

Requirements

Lab Application Revision: B.01 and above

Programming Example

OUTPUT 714;"CALL:STATUS:PAGing:MERRor:RATio?"
!Query the Paging Channel MER result, in percentage.

CALL:STATus:PAGing:MERRor:TIME?

Function

Queries the length of the test time (in seconds) associated with Paging MER. See Paging Channel MER Results for details.

When the timer reaches its maximum, it will roll over to zero and no error message is generated. This result can be cleared to zero by the CALL:PAGing:MERRor:PROCedure:PARameter:CLEar .

Query

Range: 0.0 to 85000.0 seconds
Resolution: 0.02 seconds

*RST Setting

0

Requirements

Lab Application Revision: B.01 and above

Programming Example

OUTPUT 714;"CALL:STATUS:PAGing:MERRor:TIME?"
!Query the Paing MER test time.

CALL:STATus:PAGing:IMSI:S1?

Function

Queries the IMSI_S1 value. See IMSI_S2/IMSI_S1 (Dec) for details.

Query

Range:

  • "" (null string)
  • "0000000" to "9999999" (The return string is always 7 characters from the set 0123456789)

*RST Setting

 "" (null string)

Requirements

Test Application Revision: B.10 and above

Lab Application Revision: B.03.10 and above

Programming Example

OUTPUT 714;"CALL:STATUS:PAGing:IMSI:S1?"

CALL:STATus:PAGing:IMSI:S2?

Function

Queries the IMSI_S2 value. See IMSI_S2/IMSI_S1 (Dec) for details.

Query

Range:

  • "" (null string)
  • "000" to "999" (The return string is always 3 characters from the set 0123456789)

*RST Setting

 "" (null string)

Requirements

Test Application Revision: B.10 and above

Lab Application Revision: B.03.10 and above

Programming Example

OUTPUT 714;"CALL:STATUS:PAGing:IMSI:S2?"

CALL:STATus:PILot[:CELL[1]][:LEVel][:RTCell][:SELected]?

Function

Queries the current cell 1 forward pilot level (relative to the cell 1 power) for the currently selected system type.

Forward pilot level (relative to cell power) is set using the CALL:PILot commands. See Configuring Forward Channel Power Levels and Walsh Codes for more information.

The optional [:SELected] keyword in this command specifies that the pilot level being queried applies to the current system type (see CALL:STATus:CELL:SYSTem[:TYPE]? ).

Query

Range: -10 to 0 dB, 9.91 E+37

Resolution: 0.01 dB

*RST Setting

 9.91 E+37

Programming Example

OUTPUT 714;"CALL:STATUS:PILOT:LEVEL?"

CALL:STATus:PILot[:CELL[1]][:LEVel]:RTTotal[:SELected]?

Function

Queries the calculated cell 1 forward pilot level (relative to the total RF power) for the currently selected system type.

It's the Cell 1 Pilot Delta Power value displayed in the Generated Pilot Level Information table (see Generated Pilot Level Information ).

The optional [:SELected] keyword in this command specifies that the pilot level being queried applies to the current system type (see CALL:STATus:CELL:SYSTem[:TYPE]? ).

Query

Range: -40 to 0 dB, 9.91 E+37

Resolution: 0.01 dB

*RST Setting

 9.91 E+37

Requirements

Lab Application Revision: A.01 and above

Programming Example

OUTPUT 714;"CALL:STATus:PILot:RTTotal?"

CALL:STATus:PILot[:CELL[1]]:STATe[:SELected]?

Function

Queries the current cell (1) forward channel pilot state for the currently selected system type.

Forward pilot on/off state is set using the CALL:PILot commands. See Configuring Forward Channel Power Levels and Walsh Codes for more information.

The optional [:SELected] keyword in this command specifies that the pilot state being queried applies to the current system type (see CALL:STATus:CELL:SYSTem[:TYPE]? ).

Query

Range: 1|0

*RST Setting

 0 (Off)

Programming Example

OUTPUT 714;"CALL:STATUS:PILOT:STATE:SELECTED?"

CALL:STATus:PILot[:CELL[1]]:STRength[:SELected]?

Function

Queries the cell 1 pilot strength for the currently selected system type. It's expressed in a number value that is expected in a Pilot Strength Measurement Message from the mobile station.

It's the Cell 1 Pilot Strength value displayed in the Generated Pilot Level Information table (see Generated Pilot Level Information ).

The optional [:SELected] keyword in this command specifies that the pilot level being queried applies to the current system type (see CALL:STATus:CELL:SYSTem[:TYPE]? ).

Query

Range: 0 to 63.0 dB, 9.91 E+37

Resolution: 0.01 dB

*RST Setting

 9.91 E+37

Requirements

Lab Application Revision: A.01 and above

Programming Example

OUTPUT 714;"CALL:STATus:PILot:STRength?"

CALL:STATus:PILot:CELL2[:LEVel:][:RTCell][:SELected]?

Function

Queries the current cell 2 forward pilot level (relative to the cell 2 power) for the currently selected system type.

Forward pilot level is set using the CALL:CELL2:PILot commands. See Configuring Cell 2 PN Offset and Code Channels for more information.

The optional [:SELected] keyword in this command specifies that the pilot level being queried applies to the current system type (see CALL:STATus:CELL:SYSTem[:TYPE]? ).

Query

Range: -10 to 0 dB, 9.91 E+37

Resolution: 0.01 dB

*RST Setting

 9.91 E+37

Requirements

Lab Application Revision: A.01 and above

Programming Example

OUTPUT 714;"CALL:STATus:PILot:CELL2?"

CALL:STATus:PILot:CELL2[:LEVel]:RTTotal[:SELected]?

Function

Queries the calculated cell 2 forward pilot level (relative to the total RF power) for the currently selected system type.

It corresponds to the Cell 2 Pilot Delta Power displayed in the Generated Pilot Level Information table (see Generated Pilot Level Information ).

The optional [:SELected] keyword in this command specifies that the pilot level being queried applies to the current system type (see CALL:STATus:CELL:SYSTem[:TYPE]? ).

Query

Range: -40 to 0 dB, 9.91 E+37

Resolution: 0.01 dB

*RST Setting

 9.91 E+37

Requirements

Lab Application Revision: A.01 and above

Programming Example

OUTPUT 714;"CALL:STATus:PILot:CELL2:RTTotal?"

CALL:STATus:PILot:CELL2:STATe[:SELected]?

Function

Queries the current cell 2 forward channel pilot state for the currently selected system type.

Forward pilot on/off state is set using the CALL:CELL2:PILot commands. See Configuring Cell 2 PN Offset and Code Channels for more information.

The optional [:SELected] keyword in this command specifies that the pilot state being queried applies to the current system type (see CALL:STATus:CELL:SYSTem[:TYPE]? ).

Query

Range: 1|0

*RST Setting

 0 (Off)

Requirements

Lab Application Revision: A.01 and above

Programming Example

OUTPUT 714;"CALL:STATUS:PILOT:CELL2:STATE:SELECTED?"

CALL:STATus:PILot:CELL2:STRength[:SELected]?

Function

Queries the cell 2 pilot strength for the currently selected system type. It's expressed in a number value that is expected in a Pilot Strength Measurement Message from the mobile station.

It's the Cell 2 Pilot Strength value displayed in the Generated Pilot Level Information table (see Generated Pilot Level Information ).

The optional [:SELected] keyword in this command specifies that the pilot level being queried applies to the current system type (see CALL:STATus:CELL:SYSTem[:TYPE]? ).

Query

Range: 0 to 63.0 dB, 9.91 E+37

Resolution: 0.01 dB

*RST Setting

 9.91 E+37

Requirements

Lab Application Revision: A.01 and above

Programming Example

OUTPUT 714;"CALL:STATus:PILot:CELL2:STRength?"

CALL:STATus:QPCHannel:EBNTotal?

Function

Queries the ratio of energy per bit for the forward quick paging channel (QPCH) to noise power spectral density. See Paging Channel MER Results for details on how it is calculated.

Query

Range: -30.0 to 30.0 dB, 9.91 E+37

Resolution: 0.001 dB

*RST Setting

 9.91 E+37

Requirements

Test Application Revision: B.07 and above

Lab Application Revision: B.01 and above

Programming Example

OUTPUT 714;"CALL:STATUS:QPCHannel:EBNTotal?"
!Query the quick paging channel Eb/Nt.

CALL:STATus:QPCHannel[:LEVel][:RTCell][:SELected]?

Function

Queries the current forward quick paging channel (QPCH) level, relative to the cell power level.

The forward quick paging channel level is set using the CALL:QPCHannel commands. See Configuring Forward Channel Power Levels and Walsh Codes for more information.

The optional [:SELected] keyword in this command specifies that the quick paging channel level being queried applies to the current system type (see CALL:STATus:CELL:SYSTem[:TYPE]? ).

Query

Range: 0 to -15 dB, 9.91 E+37

Resolution: 0.01 dB

*RST Setting

 9.91 E+37

Programming Example

OUTPUT 714;"CALL:STATUS:QPCHANNEL:LEVEL:RTCELL:DIGITAL2000?"

CALL:STATus:QPCHannel[:LEVel]:RTPilot[:SELected]?

Function

Queries the current forward quick paging channel (QPCH) level, relative to the pilot level.

The forward quick paging channel level is set using the CALL:QPCHannel commands. See Configuring Forward Channel Power Levels and Walsh Codes for more information.

The optional [:SELected] keyword in this command specifies that the quick paging channel level being queried applies to the current system type (see CALL:STATus:CELL:SYSTem[:TYPE]? ).

Query

Range: +2 to -5 dB, 9.91 E+37

Resolution: integer

*RST Setting

 9.91 E+37

Programming Example

OUTPUT 714;"CALL:STATUS:QPCHANNEL:LEVEL:RTPILOT:SELECTED?"

CALL:STATus:QPCHannel:STATe[:SELected]?

Function

Queries the current on/off state of the forward quick paging channel (QPCH).

When the QPCH is set to off, the current QPCH level will be set to 9.91 E+37.

The forward quick paging channel on/off state is set using the CALL:QPCHannel commands. See Configuring Forward Channel Power Levels and Walsh Codes for more information.

The optional [:SELected] keyword in this command specifies that the quick paging channel state being queried applies to the current system type (see CALL:STATus:CELL:SYSTem[:TYPE]? ).

Query

Range: 1|0

*RST Setting

 0 (Off)

Programming Example

OUTPUT 714;"CALL:STATUS:QPCHANNEL:STATE?"

CALL:STATus:SCHannel[:LEVel][:SELected]?

Function

Queries the current forward supplemental channel (SCH) level.

The forward supplemental channel on/off state is set using the CALL:SCHannel commands. See Configuring Forward Channel Power Levels and Walsh Codes for more information.

The optional [:SELected] keyword in this command specifies that the supplemental channel state being queried applies to the current system type (see CALL:STATus:CELL:SYSTem[:TYPE]? ).

Query

Range: 1|0

*RST Setting

 0 (Off)

Requirements

Test Application Revision: B.07 and above: Added optional [:FORWard]
Lab Application Revision: B.01 and above: Added optional [:FORWard]

Programming Example

OUTPUT 714;"CALL:STATUS:SCHANNEL:STATE?"

CALL:STATus:SCHannel[:FORWard]:EBNTotal?

Function

Queries the energy per bit to total noise (E b /N t ) in the supplemental channel. See Configuring Forward Channel Power Levels and Walsh Codes for more information.

Query

Range: -30 to 30 dB, 9.91 E+37

Resolution: 0.01 dB

*RST Setting

 9.91 E+37

Requirements

Test Application Revision: B.07 and above: Added optional [:FORWard]
Lab Application Revision: B.01 and above: Added optional [:FORWard]

Programming Example

OUTPUT 714;"CALL:STATUS:SCHANNEL:EBNTOTAL?"

CALL:STATus:SCHannel[:FORWard]:STATe[:SELected]?

Function

Queries the current on/off state of the forward supplemental channel (SCH).

The forward supplemental channel on/off state is set using the CALL:SCHannel commands. See Configuring Forward Channel Power Levels and Walsh Codes for more information.

The optional [:SELected] keyword in this command specifies that the supplemental channel state being queried applies to the current system type (see CALL:STATus:CELL:SYSTem[:TYPE]? ).

Query

Range: 1|0

*RST Setting

 0 (Off)

Requirements

Test Application Revision: B.07 and above: Added optional [:FORWard]
Lab Application Revision: B.01 and above: Added optional [:FORWard]

Programming Example

OUTPUT 714;"CALL:STATUS:SCHANNEL:STATE?"

CALL:STATus:SCHannel[:FORWard]:SYNChronized?

Function

Queries the if the data on the F-SCH is synchronized when in SO32 (TDSO). This is primarily used by the TDSO FER measurement. The returned setting is NSCH (no F-SCH assigned), NSYN (not synchronized), or SYNC (synchronized.

The forward supplemental channel on/off state is set using the CALL:SCHannel commands.

Query

Range: NSCH|NSYN|SYNC

*RST Setting

 NSCH

Requirements

Test Application Revision: B.07 and above: Added optional [:FORWard]
Lab Application Revision: B.01 and above: Added optional [:FORWard]

Programming Example

OUTPUT 714;"CALL:STATUS:SCHANNEL:SYNCHRONIZED"

CALL:STATus:SCHannel:FORWard:ASSigned?

Function

 Queries if the forward supplemental channel (F-SCH) is assigned or not.

Query

Range: 0|1

*RST Setting

 0 (off)

Requirements

Lab Application Revision: B.05.12 and above

Programming Example

OUTPUT 714;"CALL:STATus:SCHannel:FORWard:ASSigned?"

CALL:STATus:SCHannel:FORWard:ENCoder?

Function

 Queries the current encoder which is used for the forward supplemental channel.

Query

Range: TURB|CONV

*RST Setting

 CONV

Requirements

Lab Application Revision: B.05.12 and above

Programming Example

OUTPUT 714;"CALL:STATus:SCHannel:FORWard:ENCoder?"

CALL:STATus:SCHannel:REVerse:ASSigned?

Function

 Queries if the reverse supplemental channel (R-SCH) is assigned or not.

Query

Range: 0|1

*RST Setting

 0 (off)

Requirements

Lab Application Revision: B.05.12 and above

Programming Example

OUTPUT 714;"CALL:STATus:SCHannel:REVerse:ASSigned?"

CALL:STATus:SCHannel:REVerse:ENCoder?

Function

 Queries the current encoder which is used for the reverse supplemental channel.

Query

Range: TURB|CONV

*RST Setting

 CONV

Requirements

Lab Application Revision: B.05.12 and above

Programming Example

OUTPUT 714;"CALL:STATus:SCHannel:REVerse:ENCoder?"

CALL:STATus:SYNC[:LEVel][:SELected]?

Function

Queries the current forward sync channel level for the currently selected system type.

The forward sync channel level is set using the CALL:SYNC commands. See Configuring Forward Channel Power Levels and Walsh Codes for more information.

The optional [:SELected] keyword in this command specifies that the sync level being queried applies to the current system type (see CALL:STATus:CELL:SYSTem[:TYPE]? ).

Query

Range: 0 to -20 dB, 9.91 E+37

Resolution: 0.01 dB

*RST Setting

 9.91 E+37

Programming Example

OUTPUT 714;"CALL:STATUS:SYNC:LEVEL:SELECTED?"

CALL:STATus:SYNC:STATe[:SELected]?

Function

Queries the current sync channel level state for the currently selected system type.

The forward sync channel level on/off state is set using the CALL:SYNC commands. See Configuring Forward Channel Power Levels and Walsh Codes for more information.

The optional [:SELected] keyword in this command specifies that the sync state being queried applies to the current system type (see CALL:STATus:CELL:SYSTem[:TYPE]? ).

Query

Range: 1|0

*RST Setting

 0 (Off)

Programming Example

OUTPUT 714;"CALL:STATUS:SYNC:STATE:SELECTED?"

CALL:STATus:TOTal:POWer[:AMPLitude][:SELected]?

Function

Queries the total RF power of the currently selected system type being transmitted by the test set. The total RF power is equal to the sum of the cell power and AWGN settings.

The optional [:SELected] keyword in this command specifies that the total power level being queried applies to the current system type (see CALL:STATus:CELL:SYSTem[:TYPE]? ).

See Cell Power, AWGN Power and Total RF Power Ranges for more information about desired versus current power levels.

Query

Range:

  • -170 dBm/1.23 MHz to +42 dBm/1.23 MHz (this is the range of settings accepted, see Cell Power, AWGN Power and Total RF Power Ranges for the actual hardware range of the source)
  • 9.91 E+37 (NAN) is returned if CALL:STATus:TOTal:POWer:STATe[:SELected]? is OFF

Resolution: 0.01 dB

*RST Setting

 -55.00 dBm

Programming Example

OUTPUT 714;"CALL:STATUS:TOTAL:POWER?"

CALL:STATus:TOTal:POWer:STATe[:SELected]?

Function

Queries the current total RF power state for the currently selected system type.

This query will return a 1 (on) if either current Cell 1 Power, Cell 2 Power, or current AWGN ( CALL:AWGNoise ) power states are on.

The optional [:SELected] keyword in this command specifies that the power state being queried applies to the current system type (see CALL:STATus:CELL:SYSTem[:TYPE]? ).

See Cell Power, AWGN Power and Total RF Power Ranges for more information about desired versus current power levels.

Query

Range: 1|0

*RST Setting

 1 (on)

Programming Example

OUTPUT 714;"CALL:STATUS:TOTAL:POWER:STATE?"

CALL:STATus:TRAFfic[:CELL[1]][:LEVel][:SELected]?

Function

Queries the current cell (1) forward traffic channel level.

The cell 1 forward traffic channel level is set using the CALL[:CELL[1]]:TRAFfic[:FORWard]:LEVel<[:SELected]|DIGital95> commands. See Configuring Forward Channel Power Levels and Walsh Codes for more information.

The optional [:SELected] keyword in this command specifies that the traffic channel level being queried applies to the current system type (see CALL:STATus:CELL:SYSTem[:TYPE]? ).

Query

Range: 0 to 30 dB, 9.91 E+37

Resolution: 0.01 dB

*RST Setting

 9.91 E+37

Programming Example

OUTPUT 714;"CALL:STATUS:FCHANNEL:LEVEL?"

CALL:STATus:TRAFfic[:CELL[1]]: EBNTotal?

Function

Queries the energy per bit to total noise (E b /N t ) in the F-Traffic/F-FCH channel.

If a call is not connected, this command will return 9.91 E+37.

Query

Range: -30.00 to +30.00 dB, 9.91 E+37

Resolution: 0.01 dB

*RST Setting

 9.91 E+37

Programming Example

OUTPUT 714;"CALL:STATUS:TRAFfic:EBNTOTAL?"

CALL:STATus:TRAFfic[:CELL[1]]:STATe[:SELected]?

Function

Queries the current cell (1) forward traffic channel on/off state.

The forward traffic channel on/off state is set using the CALL[:CELL[1]]:TRAFfic[:FORWard]:STATe<[:SELected]|DIGital95> commands. See Configuring Forward Channel Power Levels and Walsh Codes for more information.

The optional [:SELected] keyword in this command specifies that the traffic channel state being queried applies to the current system type (see CALL:STATus:CELL:SYSTem[:TYPE]? ).

Query

Range: 1|0

*RST Setting

 0 (Off)

Programming Example

OUTPUT 714;"CALL:STATUS:TRAFfic:STATE?"

CALL:STATus:TRAFfic:CELL2:LEVel[:SELected]?

Function

Queries the current cell 2 forward traffic channel level.

The optional [:SELected] keyword in this command specifies that the traffic channel level being queried applies to the current system type (see CALL:STATus:CELL:SYSTem[:TYPE]? ).

The cell 2 forward traffic channel level is set using the CALL:CELL2:TRAFfic:LEVel<[:SELected]|DIGital95> commands. See Configuring Cell 2 PN Offset and Code Channels for more information.

Query

Range: 0 to 30 dB, 9.91 E+37

Resolution: 0.01 dB

*RST Setting

 9.91 E+37

Requirements

Lab Application Revision: A.01 and above

Programming Example

OUTPUT 714;"CALL:STATUS:TRAFFIC:CELL2:LEVEL?"

CALL:STATus:TRAFfic:CELL2:STATe[:SELected]?

Function

Queries the current cell 2 forward traffic channel on/off state. See Configuring Cell 2 PN Offset and Code Channels for more information.

The optional [:SELected] keyword in this command specifies that the traffic channel state being queried applies to the current system type (see CALL:STATus:CELL:SYSTem[:TYPE]? ).

Query

Range: 1|0

*RST Setting

 0 (Off)

Requirements

Lab Application Revision: A.01 and above

Programming Example

OUTPUT 714;"CALL:STATUS:TRAFFIC:CELL2:STATE?"


CALL:SYNC

CALL:SYNC

Last updated: June 7, 2007

GPIB Command Conventions

  • CALL:SYNC[:SLEVel][:SELected]
  • CALL:SYNC:LEVel[:SELected]
  • CALL:SYNC:STATe[:SELected]

CALL:SYNC[:SLEVel][:SELected]

Function

The setting form of this command performs two functions: (1) sets the SYNC (synchronization channel) level, and (2) turns the SYNC state to ON.

The query form of this command returns the SYNC level for the current system type.

The optional [:SELected] keyword in this command specifies that the SYNC level and state being set/queried applies to the current system type. See CALL[:CELL]:SYSTem[:TYPE] to query or change the current system type.

Setting

Range: 0 to -20 dB

Resolution: 0.01 dB

Query

Range: 0 to -20 dB

Resolution: 0.01 dB

*RST Setting

-16 dB

Programming Example

OUTPUT 714;"CALL:SYNC:SLEVel -16"
!Sets the SYNC state to ON and sets the level to -16 dB.

CALL:SYNC:LEVel[:SELected]

Function

Sets/queries the forward SYNC (synchronization channel) level.

The optional [:SELected] keyword in this command specifies that the SYNC level being set/queried applies to the current system type. See CALL[:CELL]:SYSTem[:TYPE] to query or change the current system type.

Setting

Range: 0 to -20 dB

Resolution: 0.01 dB

Query

Range: 0 to -20 dB

Resolution: 0.01 dB

*RST Setting

-16 dB

Programming Example

OUTPUT 714;"CALL:SYNC:LEVEL -16" !Set the SYNC channel level to -16 dB.

CALL:SYNC:STATe[:SELected]

Function

Sets/queries the SYNC (synchronization channel) state.

The optional [:SELected] keyword in this command specifies that the SYNC state being set/queried applies to the current system type. See CALL[:CELL]:SYSTem[:TYPE] to query or change the current system type.

Setting

Range: 1|ON|0|OFF

Query

Range: 1|0

*RST Setting

ON

Programming Example

OUTPUT 714;"CALL:SYNC:STATE OFF" !Turns off the SYNC channel.


CALL:SYSTem

CALL:SYSTem

Last updated: June 7, 2007

GPIB Command Conventions

  • CALL[:CELL]:SYSTem[:TYPE]

CALL[:CELL]:SYSTem[:TYPE]

Function

 Sets/queries the active cell system type.

Setting

Range: AMPS|DIGital2000|DIGital95

Query

Range: AMPS|DIG2000|DIG95

*RST Setting

 DIGital2000

Programming Example

OUTPUT 714;"CALL:CELL:SYSTEM:TYPE DIG2000" !Sets the system type to DIGital2000.


CALL:TOTal:POWer

CALL:TOTal:POWer

Last updated: June 7, 2007

GPIB Command Conventions

  • CALL:TOTal:POWer[:AMPLitude][:SELected]?
  • CALL:TOTal:POWer:STATe[:SELected]?

CALL:TOTal:POWer[:AMPLitude][:SELected]?

Function

Queries the total RF power settings for the current system type.

Total RF power is the sum of cell power level and AWGN power level.

The optional [:SELected] keyword in this command specifies that this query applies to the current system type.

The return value for this query is not necessarily the power level being transmitted by the test set at the moment this command is processed by the test set. It may return a value that the test set has been requested to transmit, but that has been pended or delayed for some reason. See Troubleshooting Setting Power Levels for possible causes. To query the power level the test set is transmitting at the moment the command is sent, use the CALL:STATus:TOTal:POWer[:AMPLitude][:SELected]? command.

Query

Range:

  • -170 dBm/1.23 MHz to +42 dBm/1.23 MHz, 9.91 E+37
    (-120 dBm/1.23MHz to -10.88 dBm/1.23 MHz actual hardware range with amplitude offset = 0)

    The actual power range is defined by adding the value of the associated Amplitude Offset to the range shown above. See Cell Power, AWGN Power and Total RF Power Ranges .

Resolution: 0.01 dB

*RST Setting

-55 dBm (this is a calculated value and its default will depend of the defaults of those parameters it is calculated from.)

Programming Example

OUTPUT 714;"CALL:TOTAL:POWER:AMPLITUDE?"

CALL:TOTal:POWer:STATe[:SELected]?

Function

Queries the total RF power state for the current system type.

The total RF power state is 1 (on) if either cell power or AWGN power is on.

The return value for this query is not necessarily the total power state at the moment this command is processed by the test set. This command may return a state that has been requested of the test set, but that has been pended or delayed for some reason. See Troubleshooting Setting Power Levels for possible causes. To query the power state of the test set at the moment, use the CALL:STATus:TOTal:POWer:STATe[:SELected]? command.

The optional [:SELected] keyword in this command specifies that this query applies to the current system type.

Query

Range: 1|0

*RST Setting

 1 (on)

Programming Example

OUTPUT 714;"CALL:TOTAL:POWER:STATE?"


CALL:TRAFfic

CALL:TRAFfic

Last updated: June 7, 2007

GPIB Command Conventions

  • CALL[:CELL[1]]:TRAFfic[:FORWard][:SLEVel]<[:SELected]|DIGital95>
  • CALL[:CELL[1]]:TRAFfic[:FORWard]:LEVel<[:SELected]|DIGital95>
  • CALL[:CELL[1]]:TRAFfic[:FORWard]:STATe<[:SELected]|DIGital95>
  • CALL[:CELL[1]]:TRAFfic[:FORWard]:WALSh
  • CALL[:CELL[1]]:TRAFfic[:FORWard]:DRATe
  • CALL[:CELL[1]]:TRAFfic[:FORWard]:SOURce
  • CALL[:CELL[1]]:TRAFfic[:FORWard]:SOURce:ECHO
  • CALL[:CELL[1]]:TRAFfic[:FORWard]:FPATtern:BAD
  • CALL[:CELL[1]]:TRAFfic[:FORWard]:FPATtern:GOOD
  • CALL[:CELL[1]]:TRAFfic[:FORWard]:FPATtern:STATe
  • CALL[:CELL[1]]:TRAFfic[:FORWard]:FPATtern:SFQuality

CALL[:CELL[1]]:TRAFfic[:FORWard][:SLEVel]<[:SELected]|DIGital95>

Function

The setting form of this command performs two functions: (1) sets the (Cell 1) F-Traffic (forward traffic channel) level, and (2) turns the traffic channel state to ON.

The query form of this command returns the traffic channel level.

NOTE
This command applies to the IS-95 traffic channel only. To make level changes to the IS-2000 fundamental channel, see CALL[:CELL[1]]:FCHannel[:FORWard][:SLEVel]<[:SELected]|DIGital2000> .

Setting

Range: 0 to -30 dB

Resolution: 0.01 dB

Query

Range: 0 to -30 dB

Resolution: 0.01 dB

*RST Setting

-15.6 dB

Programming Example

OUTPUT 714;"CALL:TRAFfic:SLEVEL:DIGITAL95 -10 dB"
!Sets the forward traffic channel state to ON and sets the level to -10 dB.

CALL[:CELL[1]]:TRAFfic[:FORWard]:LEVel<[:SELected]|DIGital95>

Function

Sets/queries the level of the (Cell 1) F-Traffic (forward traffic channel).

NOTE
This command applies to the IS-95 traffic channel only. To make level changes to the IS-2000 fundamental channel, see CALL[:CELL[1]]:FCHannel[:FORWard]:LEVel<[:SELected]|DIGital2000> .

Setting

Range: 0 to -30 dB

Resolution: 0.01 dB

Query

Range: 0 to -30 dB

Resolution: 0.01 dB

*RST Setting

 -15.6 dB

Programming Example

OUTPUT 714;"CALL:TRAFfic:LEVEL:SELECTED -10 dB"

CALL[:CELL[1]]:TRAFfic[:FORWard]:STATe<[:SELected]|DIGital95>

Function

Sets/queries the on/off state of the (Cell 1) F-Traffic (forward traffic channel).

NOTE
This command applies to the IS-95 traffic channel only. To make on/off state changes to the IS-2000 fundamental channel, see CALL[:CELL[1]]:FCHannel[:FORWard]:STATe<[:SELected]|DIGital2000> .

Setting

Range: 1|ON|0|OFF

Query

Range: 1|0

*RST Setting

ON

Programming Example

OUTPUT 714;"CALL:TRAFfic:STATE:DIGITAL95 OFF"
!Turns off the forward traffic channel.

CALL[:CELL[1]]:TRAFfic[:FORWard]:WALSh

Function

Sets/queries the Walsh code used for the DIGital95 (Cell 1) F-Traffic (forward traffic channel).

Setting

Range: CODE10|CODE14|CODE26|CODE30|CODE42|CODE46|CODE58|CODE62

Query

Range: CODE10|CODE14|CODE26|CODE30|CODE42|CODE46|CODE58|CODE62

*RST Setting

CODE10

Programming Example

OUTPUT 714;"CALL:TRAFfic:WALSH CODE14"
!Sets the forward traffic channel walsh code to 14.

CALL[:CELL[1]]:TRAFfic[:FORWard]:DRATe

Function

Sets/queries the TCH (traffic channel) or FCH (fundamental channel) data rates which are applied when a loopback service option (SO2, 9, or 55) ( CALL:SOPTion ) is selected. See Traffic Data Rate for details.

Setting

Test Application Range: EIGHth|QUARter|HALF|FULL

Lab Application Range: EIGHth|QUARter|HALF|FULL|RANDom40

Query

Test Application Range: EIGH|QUAR|HALF|FULL

Lab Application Range: EIGH|QUAR|HALF|FULL|RAND40

*RST Setting

Full

Requirements

Test Application Revision: B.01 or above

Lab Application Revision: B.02 or above: Added RANDom40

Programming Example

OUTPUT 714;"CALL:TRAFfic:DRATe HALF"
!Sets the data rate to half.

CALL[:CELL[1]]:TRAFfic[:FORWard]:SOURce

Function

Sets/queries the source of voice data to be sent on the forward traffic channel in IS-95 system. To set the source of voice data to be sent on the forward fundamental channel in IS-2000 system, use CALL[:CELL[1]]:FCHannel[:FORWard]:SOURce .

See Voice SO Mode for details.

Setting

Range: ECHO|HZ400|HZ1000|SWEPt|MULTitone|RTVocoder|NFRames

Query

Range: ECHO|HZ400|HZ1000|SWEP|MULT|RTV|NFR

*RST Setting

ECHO

Requirements

Test Application Revision: B.06 or above
Test Application Revision: B.08 or above: Added MULTitone and NFRames
Test Application Revision: B.10 or above: Added RTVocoder

Lab Application Revision: A.02 or above
Lab Application Revision: B.02 or above: Added MULTitone and NFRames
Lab Application Revision: B.03.10 or above: Added RTVocoder

Programming Example

OUTPUT 714;"CALL:TRAFfic:SOURce HZ400"
!Sets the audio tone to 400Hz.

CALL[:CELL[1]]:TRAFfic[:FORWard]:SOURce:ECHO

Function

Sets/queries the time period between when you talk into the mobile station and when you hear your voice echoed back. It is applied only when "ECHO" audio tone is selected for the current voice service option (see CALL[:CELL[1]]:TRAFfic[:FORWard]:SOURce ).

The delay time period can be specified as Short, Medium, and Long. The Short setting results in a delay as short as possible. The medium setting results in about one second of delay. The Long setting results in approximately two seconds of delay.

Requirements

 Test Application Revision: B.06.00 or above

Setting

Range: SHORt|MEDium|LONG

Query

Range: SHOR|MED|LONG

*RST Setting

MEDium

Programming Example

OUTPUT 714;"CALL:TRAffic:SOURce:ECHO SHORt" !Sets the echo delay time to SHORt.

CALL[:CELL[1]]:TRAFfic[:FORWard]:FPATtern:BAD

Function

Sets/queries the number of continuous bad frames in the frame pattern to be sent on the F-Traffic/F-FCH when a call is connected and CALL[:CELL[1]]:TRAFfic[:FORWard]:FPATtern:STATe is set to On. See F-FCH/Traffic Frame Pattern Bad Frames for details.

Setting

Range: 1 to 300
Resolution: 1

Query

Range: 1 to 300
Resolution: 1

*RST Setting

3
Requirements Lab Application Revision: B.02 and above

Programming Example

OUTPUT 714;"CALL:TRAFfic:FPATtern:BAD 5"
!Sets the bad frames in the frame pattern to 5.

CALL[:CELL[1]]:TRAFfic[:FORWard]:FPATtern:GOOD

Function

Sets/queries the number of continuous good frames in the frame pattern to be sent on the F-Traffic/F-FCH when a call is connected and CALL[:CELL[1]]:TRAFfic[:FORWard]:FPATtern:STATe is set to On. See F-FCH/Traffic Frame Pattern Good Frames for details.

Setting

Range: 0 to 100
Resolution: 1

Query

Range: 0 to 100
Resolution: 1

*RST Setting

3
Requirements Lab Application Revision: B.02 and above

Programming Example

OUTPUT 714;"CALL:TRAFfic:FPATtern:GOOD 5"
!Sets the good frames in the frame pattern to 5.

CALL[:CELL[1]]:TRAFfic[:FORWard]:FPATtern:STATe

Function

Sets/queries whether to enable (On) or disable (Off) inserting error frames in the frame pattern to be sent on the F-Traffic/F-FCH. When it is enabled (On), the test set will send alternative good/bad frames as specified by CALL[:CELL[1]]:TRAFfic[:FORWard]:FPATtern:GOOD and CALL[:CELL[1]]:TRAFfic[:FORWard]:FPATtern:BAD on the F-TCH/F-FCH. See F-FCH/Traffic Frame Pattern State .

Setting

Range: 1|ON|0|OFF

Query

Range: 1|0

*RST Setting

0 (OFF)
Requirements Lab Application Revision: B.02 and above

Programming Example

OUTPUT 714;"CALL:TRAFfic:FPATtern:STATe ON"
!Sets the frame pattern state to on.

CALL[:CELL[1]]:TRAFfic[:FORWard]:FPATtern:SFQuality

Function

Sets/queries whether the signaling transmission is affected by the specified frame pattern when CALL[:CELL[1]]:TRAFfic[:FORWard]:FPATtern:STATe is on. See Signaling Frame Quality for details.

When it is set to Good, the test set will send good frames regardless of the specified good/bad frame pattern when signaling occurs. This may result in the actual sent good frames greater than the good frames specified by CALL[:CELL[1]]:TRAFfic[:FORWard]:FPATtern:GOOD .

When it is set to Bad, the test set will always send good/bad frames as specified in frame pattern even if signaling occurs. This may result in signaling corrupted if the signaling occurs on bad frames transmission.

Setting

Range: GOOD|BAD

Query

Range: GOOD|BAD

*RST Setting

GOOD
Requirements Lab Application Revision: B.02 and above

Programming Example

OUTPUT 714;"CALL:TRAFfic:FPATtern:SFQuality GOOD"
!Sets to send good frames for signaling transmission.


CALL:TRIGger

CALL:TRIGger

Last updated: June 7, 2007

GPIB Command Conventions

  • CALL:TRIGger[:OUTPut]:TYPE<[:SELected]|:TA2000>

CALL:TRIGger[:OUTPut]:TYPE<[:SELected]|:TA2000>

Function

Sets/queries the trigger signal that is routed to the TRIG OUT rear panel connector. See Setting External Trigger .

Setting

Range:

  • MS20 (20 ms)
  • MS27 (26.67 ms)
  • MS80 (80 ms)
  • MS2000 (2 s)
  • FDEPendent (a TTL rise based pulse with a width of about 1.25 ms)

Query

 Range: MS20|MS27|MS80|MS2000|FDEP

*RST Setting

 MS2000 (2 seconds)

Requirements

Test Application Revision: B.07 and above: Added [:SELected]
and TA2000 mnemonics, and FDEPendent setting/query

Lab Application Revision: B.01 and above: Added [:SELected]
and TA2000 mnemonics, and FDEPendent setting/query

Programming Example

OUTPUT 714;"CALL:TRIGger:TYPE MS27"
!Sets the external trigger signal to 26.67 ms.


CALL:WAVeform

CALL:WAVeform

Last updated: June 7, 2007

GPIB Command Conventions

  • CALL[:CELL[1]]:WAVeform:TYPE:CW

CALL[:CELL[1]]:WAVeform:TYPE:CW

Function

Sets/queries the type of test signals to be output to the currently selected front-panel RF connector while in CW operating mode. See CW Operating Mode for details.

The test signals include:

  • CW generates an unmodulated continuous sine waveform signal.
  • AM generates an amplitude modulated signal with 56% depth and 20 kHz modulation rate.
  • DSB generates a dual side-band suppressed carrier signal with 20 kHz spacing between the two carriers.

When in CW operating mode, switching test signals requires a few seconds. A few seconds of delay is also encountered when changing operating modes if the current test signal is not CW.

Requirements

 Test Application Revision: B.06.00 or above

Setting

Range: CW|AM|DSB

Query

Range: CW|AM|DSB

*RST Setting

CW

Programming Example

OUTPUT 714;"CALL:WAVeform:TYPE:CW AM" !Sets the test singal to AM.


IEEE 488.2 Common Commands

IEEE 488.2 Common Commands

Last updated: February 14, 2007

Description

*CLS

The *CLS, clear status command, is defined in "IEEE Std 488.2-1992", 10.3. If an error message is currently posted on the test set's display, this command also closes the error message.

*ESE

The *ESE, standard event status enable command, is defined in "IEEE Std 488.2-1992", 10.10.

*ESE?

The *ESE?, standard event status enable query, is defined in "IEEE Std 488.2-1992", 10.11.

*ESR?

The *ESR?, standard event status register query, is defined in "IEEE Std 488.2-1992 ",10.12.

*IDN?

The *IDN?, identification query, is defined in "IEEE Std 488.2-1992", 10.14.*IDN? is used to retrieve information about the test set in ASCII format.

*IDN?, returns ASCII codes 32 through 126 excluding comma and semicolon in four comma separated fields. Field 1 returns the manufacturer, field 2 returns the instrument model number, field 3 returns the serial number, field 4 returns 0.

*OPC

The *OPC, operation complete command, is defined in "IEEE 488.2-1992", 10.18. *OPC causes the test set to continuously sense the No Operation Pending flag. When the No Operation Pending flag becomes TRUE, the OPC event bit in the standard event status register (ESR) is set to indicate that the state of all pending operations is completed. The *OPC common command is not recommended for use as an overlapped command.

*OPC?

The *OPC?, operation complete query, is defined in "IEEE Std 488.2-1992", 10.19. The *OPC? query allows synchronization between the controller and the test set using either the message available (MAV) bit in the status byte, or a read of the output OPC?. The *OPC? query does not effect the OPC event bit in the Standard Event Status Register (ESR). The *OPC? common command is not recommended for use as an overlapped command.

*OPT?

The *OPT?, option identification query, is defined in "IEEE Std 488.2-1992", 10.20. Each option will have a unique name, that name will be retuned with the query.

*RST

The *RST, full preset command, is defined in "IEEE Std 488.2-1992", 10.32. *RST is the recommended command when performing a full preset on the test set. A *RST restores the majority of settings to their default values.

  • *RST sets trigger arm to single
  • PRESet2 sets trigger arm to continuous

*SRE

The *SRE, service request enable command, is defined in "IEEE Std 488.2-1992", 10.34. The parameter range for this command is 0 through 255.

*SRE?

The *SRE?, service request enable query, is defined in "IEEE Std 488.2-1992", 10.35. Values returned by this query range from 0 through 255.

*STB?

The *STB?, read status byte query, is defined in "IEEE Std 488.2-1992", 10.36. Values returned by this query range from 0 through 255.

*TST?

The test set's implementation of *TST? does not follow the "IEEE Std 488.2-1992" section 10.38 definition. Rather, the test set's implementation is as described in the "Verifying the Test Set" (Self Test) topic in the Related Topics below. Values returned by this query are 0 (pass) and -330 (fail).

*WAI

The *WAI, wait-to-continue command, is defined in "IEEE Std 488.2-1992", 10.39. The *WAI command prevents the test set from executing any further commands or queries until all pending operation flags are false. The *WAI common command is not recommended for use as an overlapped command.

Related Topics

Call Processing Event Synchronization


DISPlay

DISPlay

Last updated: August 28, 2007

GPIB Command Conventions

  • DISPlay:BRIGhtness
  • DISPlay:MESSage:MASKable:STATe
  • DISPlay:MODE
  • DISPlay:WINDow:ERRor:CLEar
  • DISPlay:OPERator:MESSage

DISPlay:BRIGhtness

Function

Sets/queries the test set's display brightness.

A display backlight dimming feature lowers the display brightness after approximately 10 minutes without any manual user interaction with the test set. See Display Backlight Dimming .

Setting

Range: MEDium | HIGH

Query

Range: MED | HIGH

Factory setting

HIGH (this parameter is not affected by any reset operation and can only be changed by direct user access)

Programming Example

OUTPUT 714;"DISPLAY:BRIGHTNESS MEDIUM" !Sets display brightness to medium.

DISPlay:MESSage:MASKable:STATe

Function

Blocks maskable messages from appearing on the test set display screen but not from the Message Log. Maskable messages are reported to the Message Log in either state. See Error Messages .

Setting

Range: 1|On|0|Off

Query

Range: 1|On|0|Off
Factory setting

1|On

Programming Example

OUTPUT 714;"DISPLAY:MESSAGE:MASKABLE:STATE OFF"
!Prevents certain messages from appearing on the display.

DISPlay:MODE

Function

Sets/queries the test set's display mode.

See Display Mode (Track/Fast) for a description of fast and track display modes.

Setting

 Range: FAST | TRACK

Query

 Range: FAST | TRAC
*RST setting TRACK

Programming Example

OUTPUT 714;"DISPLAY:MODE FAST" !Sets display mode to fast.

DISPlay:WINDow:ERRor:CLEar

Function

Clears the error message from the display screen but not from the Message Log.

Programming Example

OUTPUT 714;"DISPLAY:WINDOW:ERROR:CLEAR" !Clears an error message from the display.

DISPlay:OPERator:MESSage

Function

 Allows the operator to enter up to four messages, each up to 30 characters in length. These messages will be printed to the display when the command is sent and DISPlay:MODE is set to FAST.

Setting

1|2 |3|4

1=uppermost field, 4=lowermost field
Factory setting Each message is initialized to a null string. Nothing will be displayed until one or more of the four GPIB messages is sent to the test set.

Programming Example

OUTPUT 714;"DISP:OPER:MESS1`Press F6 to stop test'"
!Writes the message "Press F6 to stop test" to the uppermost display field.


DISPlay Subsystem

DISPlay Subsystem

Last updated: October 28, 2004

Description

The DISPlay subsystem is used to configure the test set's display mode or display brightness . Use of the DISPlay subsystem is not required to set or query any data or results.

Display Backlight Dimming

The test set's display brightness parameter has two settings at this time, high and medium. The life of the display's backlight will be maximized when brightness is set to medium. The test set has an auto dimming feature that will lower the display brightness automatically if approximately 10 minutes pass without a key being pressed on the test set's front panel. The display will return to the brightness level shown in the Display Brightness field when the test set is set to local and any front panel key is pressed. There is no other user control for this feature.

Syntax Diagram and Command Descriptions

DISPlay


FETCh:AFANalyzer

FETCh:AFANalyzer

Last updated: June 7, 2007

GPIB Command Conventions

  • FETCh:AFANalyzer[:ALL]?
  • FETCh:AFANalyzer:DISTortion[:AVERage]?
  • FETCh:AFANalyzer:DISTortion:ALL?
  • FETCh:AFANalyzer:DISTortion:MINimum?
  • FETCh:AFANalyzer:DISTortion:MAXimum?
  • FETCh:AFANalyzer:DISTortion:MINimum?
  • FETCh:AFANalyzer:DISTortion:SDEViation?
  • FETCh:AFANalyzer:FREQuency[:AVERage]?
  • FETCh:AFANalyzer:FREQuency:ALL?
  • FETCh:AFANalyzer:FREQuency:MAXimum?
  • FETCh:AFANalyzer:FREQuency:MINimum?
  • FETCh:AFANalyzer:FREQuency:SDEViation?
  • FETCh:AFANalyzer:ICOunt?
  • FETCh:AFANalyzer:INTegrity?
  • FETCh:AFANalyzer:SINAD[:AVERage]?
  • FETCh:AFANalyzer:SINAD:ALL?
  • FETCh:AFANalyzer:SINAD:MAXimum?
  • FETCh:AFANalyzer:SINAD:MINimum?
  • FETCh:AFANalyzer:SINAD:SDEViation?
  • FETCh:AFANalyzer:VOLTage[:AVERage]?
  • FETCh:AFANalyzer:VOLTage:ALL?
  • FETCh:AFANalyzer:VOLTage:MAXimum?
  • FETCh:AFANalyzer:VOLTage:MINimum?
  • FETCh:AFANalyzer:VOLTage:SDEViation?

FETCh:AFANalyzer[:ALL]?

Function

Queries the AF analyzer measurements.

Measurement results are returned in the following order: integrity, average audio level, average SINAD, average distortion.

Query

Average analog audio level

  • Range: 0 to 20 volts, 9.91 E+37

  • Resolution: The lesser of 4 significant digits or 10 uV

Average SINAD

  • Range:-99 to 99 dB, 9.91 E+37

  • Resolution: 0.01 dB

Average audio distortion

  • Range: 0 to 99%, 9.91 E+37

  • Resolution: 0.01%

Programming Example

OUTPUT 714;"FETCH:AFANALYZER:ALL?"
!Returns integrity, average audio level, average SINAD,and average audio distortion.

FETCh:AFANalyzer:DISTortion[:AVERage]?

Function

Queries the average audio distortion measurement.

Query

Average audio distortion

  • Range: 0 to 99%, 9.91 E+37

  • Resolution: 0.01%

Programming Example

OUTPUT 714;"FETCH:AFANALYZER:DISTORTION:AVERAGE?"

FETCh:AFANalyzer:DISTortion:ALL?

Function

Queries the audio distortion measurements.

The measurement results are returned in the following order: minimum distortion, maximum distortion, average distortion, standard deviation distortion.

Query

Miniumum, maximum, and average audio distortion:

  • Range: 0 to 99%, 9.91 E+37

  • Resolution: 0.01%

Standard deviation audio distortion:

  • Range: 0 to 99%, 9.91 E+37

  • Resolution: 0.001%

Programming Example

OUTPUT 714;"FETCH:AFANALYZER:DISTORTION:ALL?"
!Returns mininum, maximum, average, and standard deviation audio distortion.

FETCh:AFANalyzer:DISTortion:MAXimum?

Function

Queries the maximum audio distortion.

Query

Range: 0 to 99%, 9.91 E+37

Resolution: 0.01%

Programming Example

OUTPUT 714;"FETCH:AFANALYZER:DISTORTION:MAXIMUM?"

FETCh:AFANalyzer:DISTortion:MINimum?

Function

Queries the minimum audio distortion.

Query

Range: 0 to 99%, 9.91 E+37

Resolution: 0.01%

Programming Example

OUTPUT 714;"FETCH:AFANALYZER:DISTORTION:MINIMUM?"

FETCh:AFANalyzer:DISTortion:SDEViation?

Function

Queries the standard deviation audio distortion.

Query

Range: 0 to 99%, 9.91 E+37

Resolution: 0.001%

Programming Example

OUTPUT 714;"FETCH:AFANALYZER:DISTORTION:SDEVIATION?"

FETCh:AFANalyzer:FREQuency[:AVERage]?

Function

Queries the average audio frequency measurement.

Query

Average audio frequency

  • Range: 0 to 99999 Hz, 9.91 E+37

  • Resolution: 0.1 Hz

Programming Example

OUTPUT 714;"FETCH:AFANALYZER:FREQUENCY:AVERAGE?"

FETCh:AFANalyzer:FREQuency:ALL?

Function

Queries the audio frequency measurements.

The measurement results are returned in the following order: minimum frequency, maximum frequency, average frequency, standard deviation frequency.

Query

Miniumum, maximum, and average audio frequency:

  • Range: 0 to 99999 Hz, 9.91 E+37

  • Resolution: 0.1 Hz

Standard deviation audio frequency:

  • Range: 0 to 99999 Hz, 9.91 E+37

  • Resolution: 0.01 Hz

Programming Example

OUTPUT 714;"FETCH:AFANALYZER:FREQUENCY:ALL?"
!Returns mininum, maximum, average, and standard deviation audio frequency.

FETCh:AFANalyzer:FREQuency:MAXimum?

Function

Queries the maximum audio frequency.

Query

Range: 0 to 99999 Hz, 9.91 E+37

Resolution: 0.1 Hz

Programming Example

OUTPUT 714;"FETCH:AFANALYZER:FREQUENCY:MAXIMUM?"

FETCh:AFANalyzer:FREQuency:MINimum?

Function

Queries the minimum audio frequency.

Query

Range: 0 to 99999 Hz, 9.91 E+37

Resolution: 0.1 Hz

Programming Example

OUTPUT 714;"FETCH:AFANALYZER:FREQUENCY:MINIMUM?"

FETCh:AFANalyzer:FREQuency:SDEViation?

Function

Queries the standard deviation audio frequency.

Query

Range: 0 to 99999 Hz, 9.91 E+37

Resolution: 0.01 Hz

Programming Example

OUTPUT 714;"FETCH:AFANALYZER:FREQUENCY:SDEVIATION?"

FETCh:AFANalyzer:ICOunt?

Function

Queries the intermediate count of measurements completed in a multi-measurement.

Query

Range: 0 to 999

Programming Example

OUTPUT 714;"FETCH:AFANALYZER:ICOUNT?"

FETCh:AFANalyzer:INTegrity?

Function

Queries the measurement integrity indicator for the last AF analyzer measurement completed.

Zero indicates a normal measurement. See Integrity Indicator for information about non-zero integrity results.

Query

Range: 1 through 16

Programming Example

OUTPUT 714;"FETCH:AFANalyzer:INTegrity?"
!Query the inegrity indicator for the AF analyzer results.

FETCh:AFANalyzer:SINAD[:AVERage]?

Function

Queries the average SINAD measurement.

Query

Average SINAD

  • Range:-99 to 99 dB, 9.91 E+37

  • Resolution: 0.01 dB

Programming Example

OUTPUT 714;"FETCH:AFANALYZER:SINAD:AVERAGE"

FETCh:AFANalyzer:SINAD:ALL?

Function

Queries the SINAD measurements.

Measurement results are returned in the following order: minimim SINAD, maximum SINAD, average SINAD, and standard deviation SINAD.

Query

Minimum, maximum, average SINAD:

  • Range: -99 to 99 dB, 9.91 E+37

  • Resolution: 0.01 dB

Standard deviation SINAD

  • Range: -99 to 99 dB, 9.91 E+37

  • Resolution: 0.001 dB

Programming Example

OUTPUT 714;"FETCH:AFANALYZER:SINAD:ALL?"
!Returns mininum, maximum, average, and standard deviation SINAD.

FETCh:AFANalyzer:SINAD:MAXimum?

Function

Queries the maximum SINAD measurements.

Query

Range: -99 to 99 dB, 9.91 E+37

Resolution: 0.01 dB

Programming Example

OUTPUT 714;"FETCH:AFANALYZER:SINAD:MAXIMUM?"

FETCh:AFANalyzer:SINAD:MINimum?

Function

Queries the minimum SINAD measurements.

Query

Range: -99 to 99 dB, 9.91 E+37

Resolution: 0.01 dB

Programming Example

OUTPUT 714;"FETCH:AFANALYZER:SINAD:MINIMUM?"

FETCh:AFANalyzer:SINAD:SDEViation?

Function

Queries the standard deviation SINAD measurements.

Query

Range: 0 to 99 dB, 9.91 E+37

Resolution: 0.001 dB

Programming Example

OUTPUT 714;"FETCH:AFANALYZER:SINAD:SDEVIATION?"

FETCh:AFANalyzer:VOLTage[:AVERage]?

Function

Queries the average audio level measurement.

Query

Range: 0 to 20 volts, 9.91 E+37

Resolution: the lesser of 4 significant digits or 10 uV

Programming Example

OUTPUT 714;"FETCH:AFANALYZER:VOLTAGE:AVERAGE"

FETCh:AFANalyzer:VOLTage:ALL?

Function

Queries the audio level measurements.

Measurement results are returned in the following order: minimum audio level, maximum audio level, average audio level, standard deviation audio level.

Query

Range: 0 to 20 V, 9.91 E+37

Resolution: 4 significant digits

Programming Example

OUTPUT 714;"FETCH:AFANALYZER:VOLTAGE:ALL?"
!Returns minimum, maximum, average, and standard deviation audio level.

FETCh:AFANalyzer:VOLTage:MAXimum?

Function

Queries the maximum audio level measurement.

Query

Range: 0 to 20 V, 9.91 E+37

Resolution: 4 significant digits

Programming Example

OUTPUT 714;"FETCH:AFANALYZER:VOLTAGE:MAXIMUM?"

FETCh:AFANalyzer:VOLTage:MINimum?

Function

Queries the minimum audio level measurement.

Query

Range: 0 to 20 V, 9.91 E+37

Resolution: 4 significant digits

Programming Example

OUTPUT 714;"FETCH:AFANALYZER:VOLTAGE:MAXIMUM?"

FETCh:AFANalyzer:VOLTage:SDEViation?

Function

Queries the standard deviation audio level measurement.

Query

Range: 0 to 20 V, 9.91 E+37

Resolution: 4 significant digits

Programming Example

OUTPUT 714;"FETCH:AFANALYZER:VOLTAGE:SDEVIATION?"


FETCh:ATXPower

FETCh:ATXPower

Last updated: June 7, 2007

GPIB Command Conventions

  • FETCh:ATXPower[:ALL]?
  • FETCh:ATXPower:ICOunt?
  • FETCh:ATXPower:INTegrity?
  • FETCh:ATXPower:POWer[:AVERage]?
  • FETCh:ATXPower:POWer:ALL?
  • FETCh:ATXPower:POWer:MAXimum?
  • FETCh:ATXPower:POWer:MINimum?
  • FETCh:ATXPower:POWer:SDEViation?

FETCh:ATXPower[:ALL]?

Function

Queries the average analog transmitter power measurement. The query returns integrity, and average analog power.

Query

Range: -100 dBm to +100 dBm

Resolution: 0.01 dB

Programming Example

OUTPUT 714;"FETCH:ATXPOWER:ALL?" !Returns integrity and average analog power.

FETCh:ATXPower:ICOunt?

Function

Queries the intermediate count of measurements completed in a multi-measurement.

Query

Range: 0 to 999

Programming Example

OUTPUT 714;"FETCH:ATXPOWER:ICOUNT?"

FETCh:ATXPower:INTegrity?

Function

Queries the measurement integrity indicator for the last analog transmitter power measurement completed.

Zero indicates a normal measurement. See Integrity Indicator for information about non-zero integrity results.

Query

Range: 1 through 16

Programming Example

OUTPUT 714;"FETCh:ATXPower:INTegrity?"
!Query the integrity indicator for the analog TX power measurement.

FETCh:ATXPower:POWer[:AVERage]?

Function

Queries the average analog transmitter power.

Query

Range: -100 to 100 dBm

Resolution: 0.01 dB

Programming Example

OUTPUT 714;"FETCH:ATXPOWER:POWER:AVERAGE?"

FETCh:ATXPower:POWer:ALL?

Function

Queries the analog transmitter power measurements.

Measurement results are returned in the following order: minimum analog power, maximum analog power, average analog power, standard deviation analog power.

Query

Minimum, maximum, and average analog power:

  • Range: -100 to 100 dBm

  • Resolution: 0.01 dB

Standard deviation analog power:

  • Range: 0 to 100 dB

  • Resolution: 0.001 dB

Programming Example

OUTPUT 714;"FETCH:ATXPOWER:POWER:ALL?"
!Returns mininum, maximum, average, and standard deviation analog power.

FETCh:ATXPower:POWer:MAXimum?

Function

Queries the maximum analog transmitter power.

Query

Range: -100 to 100 dBm

Resolution: 0.01 dB

Programming Example

OUTPUT 714;"FETCH:ATXPOWER:POWER:MAXIMUM?"

FETCh:ATXPower:POWer:MINimum?

Function

Queries the minimum analog transmitter power.

Query

Range: -100 to 100 dBm

Resolution: 0.01 dB

Programming Example

OUTPUT 714;"FETCH:ATXPOWER:POWER:MINIMUM?"

FETCh:ATXPower:POWer:SDEViation?

Function

Queries the standard deviation analog transmitter power.

Query

Range: 0 to 100 dB

Resolution: 0.001 dB

Programming Example

OUTPUT 714;"FETCH:ATXPOWER:POWER:SDEVIATION?"


FETCh:CAPPower

FETCh:CAPPower

Last updated: June 7, 2007

GPIB Command Conventions

  • FETCh:CAPPower[:ALL]?
  • FETCh:CAPPower:INTegrity?

FETCh:CAPPower[:ALL]?

Function

Queries the access probe power measurement results.

This query returns an integrity indicator followed by the most recent access probe power measurement result (if results are available).

Query

  • Range: -100 to 100 dBm, 9.91 E+37

  • Resolution: 0.01 dBm

Programming Example

OUTPUT 714;"FETCH:CAPPower:ALL?" !Returns integrity, access probe power measurement.

FETCh:CAPPower:INTegrity?

Function

Queries the measurement integrity indicator for the last access probe power measurement completed.

Zero indicates a normal measurement. See Integrity Indicator for information about non-zero integrity results.

Query

Range: 0 through 23

Programming Example

OUTPUT 714;"FETCH:CAPPower:INTegrity?"
!Queries the integrity indicator for the most recent access probe power result.


FETCh:CCTPhase

FETCh:CCTPhase

Last updated: June 7, 2007

GPIB Command Conventions

  • FETCh:CCTPhase[:ALL]?
  • FETCh:CCTPhase:ICOunt?
  • FETCh:CCTPhase:CDTPhase[:ALL]?
  • FETCh:CCTPhase:CDTPhase:BIN?
  • FETCh:CCTPhase:CDTPhase:COUNt[:BIN]?

FETCh:CCTPhase[:ALL]?

Function

Queries the code channel time and phase error measurement results.

This measurement returns results in the following order: integrity, time error pass/fail result, phase error pass/fail result.

Query

Integrity

  • Range: 0 to 23 see Integrity Indicator

  • Resolution: 1

Time error pass/fail result

  • Range: 0 to 1 (0 = passed, 1 = failed), 9.91 E+37

Phase error pass/fail result

  • Range: 0 to 1 (0 = passed, 1 = failed), 9.91 E+37

Programming Example

OUTPUT 714;"FETCH:CCTPHASE:ALL?"
!Returns integrity, time error pass/fail result, phase error pass/fail result.

FETCh:CCTPhase:ICOunt?

Function

Queries the intermediate count of measurements completed in a multi-measurement.

To set up multi-measurements, see SETup:CCTPhase:COUNt[:SNUMber] .

Query

Range: 0 to 999

Programming Example

OUTPUT 714;"FETCH:CCTPHASE:ICOUNT?"

FETCh:CCTPhase:CDTPhase[:ALL]?

Function

Queries the code domain time and phase error measurement results.

This measurement returns 64 measurement results. For each bin containing measurement data, four results are returned in the following order: Walsh code, spread factor, time error (in seconds), and phase error (in radians). These results are followed by four 9.91 E+37 results for each bin that does not contain data (for a total of 64 results).

Query

Walsh code

  • Range: 0 to 15, 9.91 E+37

  • Resolution: 1

Spread factor

  • Range: 2, 4, 8, 16, 9.91 E+37

Time error

  • Range: -100.0 to +100.0 ns, 9.91 E+37

  • Resolution: 0.1

Phase error

  • Range: -1.00 to +1.00 radians, 9.91 E+37

  • Resolution: 0.01 radians

Programming Example

OUTPUT 714;"FETCH:CCTPHASE:CDTPHASE:ALL?"
!Returns Walsh code, spread factor, time error, and phase error for up to 16 bins.

FETCh:CCTPhase:CDTPhase:BIN?

Function

Queries the code domain time and phase error measurement results for a specific bin. A bin represents one bar on the measurement graph. The bars on the graph (bins) are numbered left to right, 0 to a maximum of 15. Unused bins will return four entries of 9.91 E+37 per bin.

Bin 0 will always return a time error of zero, and a phase error of zero.

This measurement returns results in the following order: Walsh code, spread factor, time error (in seconds), phase error (in radians).

Query

Walsh code

  • Range: 0 to 15, 9.91 E+37

  • Resolution: 1

Spread factor

  • Range: 2, 4, 8, 16, 9.91 E+37

  • Resolution: 1

Time error

  • Range: -100.0 to +100.0 ns, 9.91 E+37

  • Resolution: 0.1

Phase error

  • Range: -1.00 to +1.00 radians, 9.91 E+37

  • Resolution: 0.01 radians

Programming Example

OUTPUT 714;"FETCH:CCTPHASE:CDTPHASE:COUNT?" !Returns number of bins containing measurement data.
OUTPUT 714;"FETCH:CCTPHASE:CDTPHASE:BIN 0?"
!Returns Walsh code, spread factor, time error, and phase error for bin 0.

FETCh:CCTPhase:CDTPhase:COUNt[:BIN]?

Function

Returns the number of bins containing measurement data. A bin represents one bar on the measurement graph. The bars on the graph (bins) are numbered left to right, 0 to a maximum of 15.

Query

 Range: 0 to 16

Programming Example

OUTPUT 714;"FETCH:CCTPHASE:CDTPHASE:COUNT:BIN?"


FETCh:CFDTune

FETCh:CFDTune

Last updated: June 7, 2007

GPIB Command Conventions

  • FETCh:CFDTune[:ALL]?
  • FETCh:CFDTune:INTegrity?

FETCh:CFDTune[:ALL]?

Function

Queries the fast device tune (FDT) measurement results.

Results are returned in the following order:

  • Integrity
  • Number of Frequency Steps
  • Number of Power Steps
  • Number of MS TX power steps measured (in most cases, it equals Number of Frequency Steps multiplied by Number of Power Steps )
  • Comma-separated list of 400 MS Tx Power results. 400 results are always returned; if the test set measured fewer than 400 power steps from the mobile, the remaining values are NANs (9.91E+37). The power results for the first frequency in the MS TX Frequency Sequence are returned first, then the power results for the second frequency in the MS TX Frequency Sequence, etc., followed by NANs if fewer than 400 points were measured.

See Fast Device Tune Measurement Results .

Query

Integrity

  • Range: 0 to 31 see Integrity Indicator

  • Resolution: 1

Frequency Step Count

  • Range: 1 to 20, 9.91 E+37 (NAN)

  • Resolution: 1

Power Step Count

  • Range: 1 to 20, 9.91 E+37 (NAN)

  • Resolution: 1

Number of Steps in MS Tx Power Results

  • Range: 1 to 400, 9.91 E+37 (NAN)

  • Resolution: 1

MS Tx Power Results Array

  • Range: -100.00 to +100.00 dBm, 9.91 E+37 (NAN)

  • Resolution: 0.01 dBm

Requirements

Test Application Revision: B.11 and above.

Lab Application Revision: B.04 and above.

Programming Example

OUTPUT 714;"FETCh:CFDTune:ALL?"

!Returns integrity, Frequency Step Count, Power Step Count, Number of Steps in MS Tx Power Results, followed by a comma-separated list of 400 MS Tx Power results Array.

FETCh:CFDTune:INTegrity?

Function

Queries the measurement integrity indicator for the fast device tune measurement.

Zero indicates a normal measurement. See Integrity Indicator for information about non-zero integrity results.

Query

Range: 0 through 31

Requirements

Test Application Revision: B.11 and above.

Lab Application Revision: B.04 and above.

Programming Example

OUTPUT 714;"FETCh:CFDTune:INTegrity?"
!Queries the inegrity indicator for the fast device tune results.


FETCh:CFERror

FETCh:CFERror

Last updated: June 7, 2007

GPIB Command Conventions

  • FETCh:CFERror[:ALL]?
  • FETCh:CFERror:EBNTotal[:AVERage]?
  • FETCh:CFERror:EBNTotal:MAXimum?
  • FETCh:CFERror:EBNTotal:MINimum?
  • FETCh:CFERror:EBNTotal:FAIL?
  • FETCh:CFERror:ERASures:FORWard?
  • FETCh:CFERror:ERASures:REVerse?
  • FETCh:CFERror:ERRors[:MS]?

FETCh:CFERror[:ALL]?

Function

Queries the frame error rate measurement results.

This measurement returns up to 5 results in the following order: integrity, confidence limit pass/fail result, frame error ratio, frame error count, frames tested.

See FER Measurement Results .

Query

Integrity

  • Range: 0 to 16 see Integrity Indicator

  • Resolution: 1

Confidence limit pass/fail result

  • Range: 0 to 3 (0 = passed, 1 = failed, 2 = max frames, 9.91 E+37)

  • Resolution: 1

Frame error ratio

  • Range: 0.00 to 100.00, 9.91 E+37

  • Resolution: 0.01 %

Frame error count

  • Range: 0 to 10,000,000, 9.91 E+37

  • Resolution: 1 frame

Frames tested

  • Range: 0 to 10,000,000, 9.91 E+37

  • Resolution: 1 frame

Programming Example

OUTPUT 714;"FETCh:CFERror?"
!Returns integrity, confidence limit pass/fail result,
!frame error ratio, frame error count, frames tested.

FETCh:CFERror:EBNTotal[:AVERage]?

Function

Queries the average value of the F-FCH Eb/Nt (the energy per bit to total noise) during the FER measurement when FPC mode 000 is enabled on the test set. It is used to determine the Eb/Nt Pass/Fail result (see FETCh:CFERror:EBNTotal:FAIL? ).

See FER Measurement Results Specific to Lab Application .

Query

  • Range: -30.00 to +42.00 dB, 9.91 E+37

  • Resolution: 0.01

Requirements

Lab Application Revision: B.02 and above

Programming Example

OUTPUT 714;"FETCh:CFERror:EBNTotal?"
!Returns the average value of F-FCH Eb/Nt.

FETCh:CFERror:EBNTotal:MAXimum?

Function

Queries the maximum value of the F-FCH Eb/Nt (the energy per bit to total noise) during the FER measurement when FPC mode 000 is enabled on the test set.

See FER Measurement Results Specific to Lab Application .

Query

  • Range: -30.00 to +42.00 dB, 9.91 E+37

  • Resolution: 0.01

Requirements

Lab Application Revision: B.02 and above

Programming Example

OUTPUT 714;"FETCh:CFERror:EBNTotal:MAXimum?"
!Returns the maximum value of F-FCH Eb/Nt.

FETCh:CFERror:EBNTotal:MINimum?

Function

Queries the minimum value of the F-FCH Eb/Nt (the energy per bit to total noise) during the FER measurement when FPC mode 000 is enabled on the test set.

See FER Measurement Results Specific to Lab Application .

Query

  • Range: -30.00 to +42.00 dB, 9.91 E+37

  • Resolution: 0.01

Requirements

Lab Application Revision: B.02 and above

Programming Example

OUTPUT 714;"FETCh:CFERror:EBNTotal:MINimum?"
!Returns the minimum value of F-FCH Eb/Nt.

FETCh:CFERror:EBNTotal:FAIL?

Function

Queries the Eb/Nt pass/fail result for the FER measurement when FPC mode 000 is enabled on the test set. If the average Eb/Nt ( FETCh:CFERror:EBNTotal[:AVERage]? ) is no greater than the specified Eb/Nt limit ( SETup:CFERror:EBNTotal[:LIMit] ), '0' will be returned to indicate that the mobile station has passed the Eb/Nt limit for the FER test. Otherwise, '1' will be returned to indicate that the mobile station has failed the Eb/Nt limit for the FER test.

When the test set is not in FPC mode 000, this query returns 'NAN'.

See FER Measurement Results Specific to Lab Application .

Query

Range: 0 (Pass), 1 (Fail), 9.91 E+37 (NAN)

Requirements

Lab Application Revision: B.02 and above

Programming Example

OUTPUT 714;"FETCh:CFERror:EBNTotal:FAIL?"
!Returns the Eb/Nt pass/fail result.

FETCh:CFERror:ERASures:FORWard?

Function

Queries the forward channel frame erasure count.

This measurement result is the number of frames the mobile station was not able to decode.

Query

  • Range: 0 to 10,000,000, 9.91 E+37

  • Resolution: 1 frame

Programming Example

OUTPUT 714;"FETCh:CFERror:ERASures:FORWard?"
!Returns the number of forward frame erasures.

FETCh:CFERror:ERASures:REVerse?

Function

Queries the reverse channel frame erasure count.

This measurement result is the number of frames the test set could not decode.

In loopback mode, the reverse link should be transmitted at a power level that does not introduce frame errors. Reverse erasures could be caused by poor transmitted signal quality from the mobile station.

Query

  • Range: 0 to 10,000,000, 9.91 E+37

  • Resolution: 1 frame

Programming Example

OUTPUT 714;"FETCh:CFERror:ERASures:REVerse?"
!Returns the number of reverse channel frame erasures.

FETCh:CFERror:ERRors[:MS]?

Function

Queries the number of frames that were determined by the test set to contain frame errors. The test set performs a bit-by-bit comparison between the transmitted vs. received data to check each frame received in loopback mode. The mobile station either reported these frames as error free or detected errors but thought it had corrected them.

Query

  • Range: 0 to 10,000,000, 9.91 E+37

  • Resolution: 1 frame

Programming Example

OUTPUT 714;"FETCh:CFERror:ERRors?"
!Returns the number of Mobile Errors.


FETCh:CPOWer

FETCh:CPOWer

Last updated: June 7, 2007

GPIB Command Conventions

  • FETCh:CPOWer[:ALL]?
  • FETCh:CPOWer:ICOunt?
  • FETCh:CPOWer:INTegrity?
  • FETCh:CPOWer:MAXimum?
  • FETCh:CPOWer:MINimum?

FETCh:CPOWer[:ALL]?

Function

Queries the channel power measurement result.

This query returns an integrity indicator followed by a channel power measurement result (if results are available).

If the multi-measurement state is on, the result represents the average of a number of channel power measurements. Multi-measurement state, by default, is off. To set up multi-measurements, see SETup:CPOWer:COUNt[:SNUMber] .

Query

  • Range: -100 to 100 dBm, 9.91 E+37

  • Resolution: 0.01 dBm

Programming Example

OUTPUT 714;"FETCH:CPOWER:ALL?" !Returns integrity, channel power measurement.

FETCh:CPOWer:ICOunt?

Function

Queries the intermediate count of measurements completed in a multi-measurement.

To set up multi-measurements, see SETup:CPOWer:COUNt[:SNUMber] .

Query

Range: 0 to 999

Programming Example

OUTPUT 714;"FETCH:CPOWER:ICOUNT?" !Returns the intermediate count of channel power multi-measurements.

FETCh:CPOWer:INTegrity?

Function

Queries the measurement integrity indicator for the last channel power measurement completed.

Zero indicates a normal measurement. See Integrity Indicator for information about non-zero integrity results.

Query

Range: 0 through 23

Programming Example

OUTPUT 714;"FETCH:CPOWER:INTegrity?"
!Queries the integrity indicator for the channel power results.

FETCh:CPOWer:MAXimum?

Function

Queries the maximum result in a multiple channel power measurements.

The multi-measurement state is off by default. To set up multi-measurements, see SETup:CPOWer:COUNt[:SNUMber] .

This query returns the same channel power result as FETCh:CPOWer:MINimum? and FETCh:CPOWer[:ALL]? if the multi-measurement state is off.

Query

  • Range: -100 to 100 dBm, 9.91 E+37

  • Resolution: 0.01 dBm

Requirements

Test Application Revision: B.06.30 and above

Lab Application Revision: A.03 and above

Programming Example

OUTPUT 714;"FETCh:CPOWer:MAXimum?"
!Returns the maximum result of multiple channel power measurements.

FETCh:CPOWer:MINimum?

Function

Queries the minimum result of multiple channel power measurements.

Multi-measurement state is off by default. To set up multi-measurements, see SETup:CPOWer:COUNt[:SNUMber] .

This query returns the same channel power result as FETCh:CPOWer:MAXimum? and FETCh:CPOWer[:ALL]? if the multi-measurement state is off.

Query

  • Range: -100 to 100 dBm, 9.91 E+37

  • Resolution: 0.01 dBm

Requirements

Test Application Revision: B.06.30 and above

Lab Application Revision: A.03 and above

Programming Example

OUTPUT 714;"FETCh:CPOWer:MINimum?"
!Returns the minimum result of multiple channel power measurements.


FETCh:CTXSpurious

FETCh:CTXSpurious

Last updated: June 7, 2007

GPIB Command Conventions

  • FETCh:CTXSpurious[:ALL]?
  • FETCh:CTXSpurious:ICOunt?
  • FETCh:CTXSpurious:MASK[:FAIL]?

FETCh:CTXSpurious[:ALL]?

Function

Queries the TX spurious emissions measurement results.

This measurement returns results in the following order: integrity, TX spurious emissions pass/fail result, lower adjacent channel (-0.885 or -1.25 MHz) average TX spurious emissions, upper adjacent channel (+0.885 or +1.25 MHz) average TX spurious emissions, lower alternate channel (-1.98 MHz) average TX spurious emissions, upper alternate channel (+1.98 MHz) average TX spurious emissions.

Query

Integrity

  • Range: 0 to 23 see Integrity Indicator

  • Resolution: 1

TX spurious emissions pass/fail result

  • Range: 0 to 1 (0 = passed, 1 = failed), 9.91 E+37

Lower adjacent channel spurious emissions

  • Range: 0.00 to -70.00 dBc, 9.91 E+37

  • Resolution: 0.01 dBc

Upper adjacent channel spurious emissions

  • Range: 0.00 to -70.00 dBc, 9.91 E+37

  • Resolution: 0.01 dBc

Lower alternate channel spurious emissions

  • Range: 0.00 to -70.00 dBc, 9.91 E+37

  • Resolution: 0.01 dBc

Upper alternate channel spurious emissions

  • Range: 0.00 to -70.00 dBc, 9.91 E+37

  • Resolution: 0.01 dBc

Programming Example

OUTPUT 714;"FETCH:CTXSPURIOUS?"

FETCh:CTXSpurious:ICOunt?

Function

Queries the intermediate count of measurements completed in a multi-measurement.

The multi-measurement state, by default, is off. To set up multi-measurements, see SETup:CTXSpurious:COUNt[:SNUMber] .

Query

Range: 0 to 999

Programming Example

OUTPUT 714;"FETCH:CTXSPURIOUS:ICOUNT?"

FETCh:CTXSpurious:MASK[:FAIL]?

Function

Queries the pass/fail indicator. Pass/fail results are based on fixed limit lines on display. Limit lines are determined by currently selected frequency band.

Query

Range: 0 (Pass)|1(Fail), 9.91 E+37

Programming Example

OUTPUT 714;"FETCH:CTXSPURIOUS:MASK:FAIL?"


FETCh:DAPower

FETCh:DAPower

Last updated: June 7, 2007

GPIB Command Conventions

  • FETCh:DAPower[:ALL]?
  • FETCh:DAPower:ICOunt?
  • FETCh:DAPower:INTegrity?

FETCh:DAPower[:ALL]?

Function

Queries a digital average power measurement result.

This query returns an integrity indicator followed by a digital average power measurement result (if results are available).

If the multi-measurement state is on, the result represents the average of a number of digital average power measurements. Multi-measurement state, by default, is off. To set up multi-measurements, see SETup:DAPower:COUNt[:SNUMber] .

Query

  • Range: -100 to 100 dBm, 9.91 E+37

  • Resolution: 0.01 dB

Programming Example

OUTPUT 714;"FETCH:DAPOWER:ALL?" !Returns integrity, average transmit power.

FETCh:DAPower:ICOunt?

Function

Queries the intermediate count of measurements completed in a multi-measurement.

The multi-measurement state, by default, is off. To set up multi-measurements, see SETup:DAPower:COUNt[:SNUMber]

Query

Range: 0 to 999

Programming Example

OUTPUT 714;"FETCH:DAPOWER:ICOUNT?"

FETCh:DAPower:INTegrity?

Function

Queries the measurement integrity indicator for the last digital average power measurement completed.

Zero indicates a normal measurement. See Integrity Indicator for information about non-zero integrity results.

Query

Range: 1 through 16

Programming Example

OUTPUT 714;"FETCH:DAPOWER:INTegrity?"
!Queries the inegrity indicator for the average digital tranmit power results.


FETCh? Subsystem

FETCh? Subsystem

Last updated: July 4, 2006

Description

The FETCh? query is a function that allows users to query results from a measurement that was previously INITiated or READ. It does NOT begin a measurement. If no measurement is in progress it will return the integrity and measurement values from the last measurement made, or return an integrity of No Result Available and results of NAN. If a measurement is in process, the query will hang until the results are available, or the measurement fails or times out. The exact results returned with a FETCh? will depend on the specific measurement. A measurement may have a number of different results or combination of results for a FETCh?. The FETCh? queries are intended to be used to provide overlapped operation access to measurement results from the test set. When used along with SETup and INITiate commands , FETCh? is the primary way for the user to retrieve measurement results. In order to use the test set's concurrent test capabilities the overlapped commands of INITiate and FETCh? must be used. Overlapped commands allow the user to send commands and not wait for completion.

Syntax Diagrams and Command Descriptions

FETCh:AFANalyzer (Audio Frequency Analyzer measurements)

FETCh:ATXPower (Analog Transmitter Power measurements)

FETCh:CAPPower (Access Probe Power measurements)

FETCh:CCTPhase (Code Channel Time/Phase Error measurements)

FETCh:CFDTune (Fast Device Tune measurements) ( only applicable to the lab application or feature-licensed test application )

FETCh:CFERror (Frame Error Rate measurements)
FETCh:CMAudio (Multi-Tone Audio measurements)

FETCh:CMMPower (Maximum/Minimum Power measurements)

FETCh:CPOWer (Channel Power measurements)

FETCh:CTDPower (TX Dynamic Power measurements)

FETCh:CTXSpurious (TX Spurious Emissions measurements)

FETCh:DAPower (Digital Average Power measurements)

FETCh:DTMF (Dual Tone Multiple Frequency measurements)

FETCh:FM (Frequency Modulation measurements)

FETCh:FSTability (Frequency Stability measurements)

FETCh:GAPPower? (Graphic Access Probe Power measurements) ( Lab Application Only )

FETCh:GPOWer (Gated Power measurements)

FETCh:HWQuality (Handoff Waveform Quality measurements)
FETCh:SAUDio (Swept Audio measurements)

FETCh:SMONitor (Spectrum Monitor measurements)

FETCh:STONe (Signaling Tone measurements)

FETCh:TFERror (TDSO Frame Error Rate measurements)

FETCh:TROPower (Time Response of Open Loop Power Control measurements)

FETCh:WDDeviation (Wideband Data measurements)

FETCh:WQUality (Waveform Quality/Code Domain Power measurements)


FETCh:CTDPower

FETCh:CTDPower

Last updated: June 7, 2007

GPIB Command Conventions

  • FETCh:CTDPower[:ALL]?
  • FETCh:CTDPower:COUNt[:STEP]?
  • FETCh:CTDPower:INTegrity?

FETCh:CTDPower[:ALL]?

Function

Queries the TX dynamic power measurement result.

This query returns 101 comma-separated values, in the order of an integrity value, followed by 100 power results. If the dynamic power measurement consists of less than 100 measurement steps (determined by FETCh:CTDPower:COUNt[:STEP]? ), the query results will be padded with NAN's (9.91 E+37), which means no results were available.

Query

  • Integrity

    • Range: 0 to 23 (see Integrity Indicator )

    • Resolution: 1

  • Power result for each measurement step

    • Range: -100.00 to 100.00 dBm, 9.91 E+37
    • Resolution: 0.01 dB

Requirements

Test Application Revision: B.07 and above.

Lab Application Revision: B.01 and above.

Programming Example

OUTPUT 714;"FETCh:CTDPower?"
!Returns integrity, power values for all measurement steps.

FETCh:CTDPower:COUNt[:STEP]?

Function

Queries the number of measurement steps that test set should expect mobile station to make. The number of power steps is specified with SETup:CTDPower:STEP:COUNt which should match the mobile station's test mode. The returned value should be the number specified plus one.

Query

Range: 1 to 100

Requirements

Test Application Revision: B.07 and above.

Lab Application Revision: B.01 and above.

Programming Example

OUTPUT 714;"FETCh:CTDPower:COUNt?"
!Returns the number of dynamic power measurement steps.

FETCh:CTDPower:INTegrity?

Function

Queries the measurement integrity indicator for the TX dynamic power measurement.

Zero indicates a normal measurement. See Integrity Indicator for information about non-zero integrity results.

Query

Range: 0 through 23

Requirements

Test Application Revision: B.07 and above.

Lab Application Revision: B.01 and above.

Programming Example

OUTPUT 714;"FETCh:CTDPower:INTegrity?"
!Queries the integrity indicator for the TX dynamic power results.


FETCh:DTMF

FETCh:DTMF

Last updated: June 7, 2007

GPIB Command Conventions

  • FETCh:DTMF[:ALL]?
  • FETCh:DTMF:CHARacter? <num value>
  • FETCh:DTMF:COUNt[:CHARacter]?
  • FETCh:DTMF:INTegrity?

FETCh:DTMF[:ALL]?

Function

Queries the DTMF measurement.

The measurement results return in the following order: Integrity, Number of characters, then 16 sets of 9 comma-separated values in the following order: Character n Symbol, Character n Low Tone Frequency, Character n Low Tone Frequency Error, Character n Low Tone Phase Deviation, Character n High Tone Frequency, Character n High Tone Frequency Error, Character n High Tone Phase Deviation, Character n On Time, Character n Off Time.

Query

Integrity

  • Range: 0 to 25 see Integrity Indicator

  • Resolution: 1

Number of characters

  • Range: 0 to 16

  • Resolution: 1

Character n Symbol

  • Range: 0 to 15, 9.91 E+37

    The result is a numeric real result corresponding to actual character result 0 to 9, A, B, C, D, * and # respectively.

Character n Low Tone Frequency

  • Range: 0 Hz to 999 Hz, 9.91 E+37

Character n Low Tone Frequency Error

  • Range: -99 Hz to 99 Hz, 9.91 E+37

Character n Low Tone Phase Deviation

  • Range: 0 to 9 Radians, 9.91 E+37

Character n High Tone Frequency

  • Range: 0 to 2,000 Hz, 9.91 E+37

Character n High Tone Frequency Error

  • Range: -99 to 99 Hz, 9.91 E+37

Character n High Tone Phase Deviation

  • Range: 0 to 9 Radians, 9.91 E+37

Character n On Time

  • Range: 0 to 6,000 ms, 9.91 E+37

Character n Off Time

  • Range: 0 to 6,000 ms, 9.91 E+37

Requirement

Test Application Revision: B.09 and above

Lab Application Revision: B.03 and above

Programming Example

OUTPUT 714;"FETCh:DTMF?"

FETCh:DTMF:CHARacter? <num value>

Function

Queries the DTMF characters in measurement. A numeric parameter from 0 to 15 must be provided to specify the data that are returned. The range of the parameter is from 0 to 15 (inclusive). The parameter value outside the range of 0 through 15 results in illegal parameter errors.

The measurement results return 9 comma-separated values for each character in the following order: Character n Symbol, Character n Low Tone Frequency, Character n Low Tone Frequency Error, Character n Low Tone Phase Deviation, Character n High Tone Frequency, Character n High Tone Frequency Error, Character n High Tone Phase Deviation, Character n On Time, Character n Off Time.

Query

Integrity

  • Range: 0 to 25 see Integrity Indicator

  • Resolution: 1

Character n Symbol

  • Range: 0 to 15, 9.91 E+37

    The result is a numeric real result corresponding to actual character result 0 to 9, A, B, C, D, * and # respectively.

Character n Low Tone Frequency

  • Range: 0 Hz to 999 Hz, 9.91 E+37

Character n Low Tone Frequency Error

  • Range: -99 Hz to 99 Hz, 9.91 E+37

Character n Low Tone Phase Deviation

  • Range: 0 to 9 Radians, 9.91 E+37

Character n High Tone Frequency

  • Range: 0 to 2,000 Hz, 9.91 E+37

Character n High Tone Frequency Error

  • Range: -99 to 99 Hz, 9.91 E+37

Character n High Tone Phase Deviation

  • Range: 0 to 9 Radians, 9.91 E+37

Character n On Time

  • Range: 0 to 6,000 ms, 9.91 E+37

Character n Off Time

  • Range: 0 to 6,000 ms, 9.91 E+37

Requirement

Test Application Revision: B.09 and above

Lab Application Revision: B.03 and above

Programming Example

OUTPUT 714;"FETCh:DTMF:CHARacter? 4"
!Returns the 9 comma-separated values charactering the fifth character measured in the measurement.

FETCh:DTMF:COUNt[:CHARacter]?

Function

Queries the number of DTMF characters detected before the end of the gate time. If the number of detected characters is greater than 16, the result is set to 16. If no character has been detected, the result is 0.

Query

  • Range: 0 to 16

  • Resolution: 1

Requirement

Test Application Revision: B.09 and above

Lab Application Revision: B.03 and above

Programming Example

OUTPUT 714;"FETCh:DTMF:COUNt?"

FETCh:DTMF:INTegrity?

Function

Queries the measurement integrity indicator for the last DTMF measurement completed.

Zero indicates a normal measurement. See Integrity Indicator for information about non-zero integrity results.

Query

Range: 1 to 25

Requirement

Test Application Revision: B.09 and above

Lab Application Revision: B.03 and above

Programming Example

OUTPUT 714;"FETCh:DTMF:INTegrity?" !Request measurement results.
!Query the integrity indicator for the DTMF result.


FETCh:FM

FETCh:FM

Last updated: June 7, 2007

GPIB Command Conventions

  • FETCh:FM[:ALL]?
  • FETCh:FM:DEViation[:AVERage]?
  • FETCh:FM:DEViation:ALL?
  • FETCh:FM:DEViation:MAXimum?
  • FETCh:FM:DEViation:MINimum?
  • FETCh:FM:DEViation:SDEViation?
  • FETCh:FM:DISTortion[:AVERage]?
  • FETCh:FM:DISTortion:ALL?
  • FETCh:FM:DISTortion:MAXimum?
  • FETCh:FM:DISTortion:MINimum?
  • FETCh:FM:DISTortion:SDEViation?
  • FETCh:FM:FREQuency[:AVERage]?
  • FETCh:FM:FREQuency:ALL?
  • FETCh:FM:FREQuency:MAXimum?
  • FETCh:FM:FREQuency:MINinum?
  • FETCh:FM:FREQuency:SDEViation?
  • FETCh:FM:ICOunt?
  • FETCh:FM:INTegrity?

FETCh:FM[:ALL]?

Function

Queries the FM measurement. Returns integrity, average FM deviation, and average FM distortion.

Query

FM deviation

  • Range: 0 to 99 kHz, 9.91 E+37

  • Resolution: 0.001 kHz

FM distortion

  • Range: 0 to 100%, 9.91 E+37

  • Resolution: 0.1%

Programming Example

OUTPUT 714;"FETCh:FM?" !Returns integrity, average FM deviation and average FM distortion.

FETCh:FM:DEViation[:AVERage]?

Function

Queries the average FM deviation.

Query

Range: 0 to 99 kHz, 9.91 E+37

Resolution: 0.001 kHz

Programming Example

OUTPUT 714;"FETCh:FM:DEViation?"

FETCh:FM:DEViation:ALL?

Function

Queries the FM deviation measurements.

Measurement results are returned in the following order: mininum deviation, maximum deviation, average deviation, standard deviation deviation.

Query

Minimum, maximum, average FM deviation

  • Range: 0 to 99 kHz, 9.91 E+37

  • Resolution: 0.001 kHz

Standard deviation FM deviation

  • Range: 0 to 99 kHz, 9.91 E+37

  • Resolution: 0.0001 kHz

Programming Example

OUTPUT 714;"FETCh:FM:DEViation:ALL?"
!Returns mininum, maximum, average, and standard deviation FM deviation.

FETCh:FM:DEViation:MAXimum?

Function

Queries the maximum FM deviation measurement.

Query

Range: 0 to 99 kHz, 9.91 E+37

Resolution: 0.001 kHz

Programming Example

OUTPUT 714;"FETCh:FM:DEViation:MAXimum?"

FETCh:FM:DEViation:MINimum?

Function

Queries the minimum FM deviation measurement.

Query

Range: 0 to 99 kHz, 9.91 E+37

Resolution: 0.001 kHz

Programming Example

OUTPUT 714;"FETCh:FM:DEViation:MINimum?"

FETCh:FM:DEViation:SDEViation?

Function

 Queries the standard deviation FM deviation measurement.

Query

Range: 0 to 99 kHz, 9.91 E+37

Resolution: 0.0001

Programming Example

OUTPUT 714;"FETCh:FM:DEViation:SDEViation?"

FETCh:FM:DISTortion[:AVERage]?

Function

Queries the average FM distortion measurement.

Query

Range: 0 to 100%, 9.91 E+37

Resolution: 0.1%

Programming Example

OUTPUT 714;"FETCh:FM:DISTortion?"

FETCh:FM:DISTortion:ALL?

Function

Queries the FM distortion measurements.

Measurement results are returned in the following order: minimum distortion, maximum distortion, average distortion, standard deviation distortion.

Query

Minimum, maximum, average FM distortion

  • Range: 0 to 100%, 9.91 E+37

  • Resolution: 0.1%

Standard deviation FM distortion

  • Range: 0 to 100%, 9.91 E+37

  • Resolution: 0.01%

Programming Example

OUTPUT 714;"FETCh:FM:DISTORTION:ALL?"
!Returns minimum, maximum, average, and standard deviation FM distortion.

FETCh:FM:DISTortion:MAXimum?

Function

Queries the maximum FM distortion measurement.

Query

Range: 0 to 100%, 9.91 E+37

Resolution: 0.1%

Programming Example

OUTPUT 714;"FETCh:FM:DISTortion:MAXimum?"

FETCh:FM:DISTortion:MINimum?

Function

Queries the minimum FM distortion measurement.

Query

Range: 0 to 100%, 9.91 E+37

Resolution: 0.1%

Programming Example

OUTPUT 714;"FETCh:FM:DISTortion:MINimum"

FETCh:FM:DISTortion:SDEViation?

Function

Queries the standard deviation FM distortion measurement.

Query

Range: 0 to 100%, 9.91 E+37

Resolution: 0.01%

Programming Example

OUTPUT 714;"FETCh:FM:DISTortion:SDEViation?"

FETCh:FM:FREQuency[:AVERage]?

Function

Queries the average audio frequency measurement.

Query

Average audio frequency

  • Range: 0 to 99999 Hz, 9.91 E+37

  • Resolution: 0.1 Hz

Programming Example

OUTPUT 714;"FETCh:FM:FREQuency?"

FETCh:FM:FREQuency:ALL?

Function

Queries the audio frequency measurements.

The measurement results are returned in the following order: minimum frequency, maximum frequency, average frequency, standard deviation frequency.

Query

Miniumum, maximum, and average audio frequency:

  • Range: 0 to 99999 Hz, 9.91 E+37

  • Resolution: 0.1 Hz

Standard deviation audio frequency:

  • Range: 0 to 99999 Hz, 9.91 E+37

  • Resolution: 0.01 Hz

Programming Example

OUTPUT 714;"FETCh:FM:FREQuency:ALL?"
!Returns mininum, maximum, average, and standard deviation audio frequency.

FETCh:FM:FREQuency:MAXimum?

Function

Queries the maximum audio frequency.

Query

Range: 0 to 99999 Hz, 9.91 E+37

Resolution: 0.1 Hz

Programming Example

OUTPUT 714;"FETCh:FM:FREQuency:MAXimum?"

FETCh:FM:FREQuency:MINinum?

Function

Queries the minimum audio frequency.

Query

Range: 0 to 99999 Hz, 9.91 E+37

Resolution: 0.1 Hz

Programming Example

OUTPUT 714;"FETCh:FM:FREQuency:MINimum?"

FETCh:FM:FREQuency:SDEViation?

Function

Queries the standard deviation audio frequency.

Query

Range: 0 to 99999 Hz, 9.91 E+37

Resolution: 0.01 Hz

Programming Example

OUTPUT 714;"FETCh:FM:FREQuency:SDEViation?"

FETCh:FM:ICOunt?

Function

Queries the intermediate count of measurements completed in a multi-measurement.

Query

Range: 0 to 99

Programming Example

OUTPUT 714;"FETCh:FM:ICOunt?"

FETCh:FM:INTegrity?

Function | Queries the measurement integrity indicator for the last FM measurement completed. Zero indicates a normal measurement. See Integrity Indicator for information about non-zero integrity results.
Query | Range: 1 through 16
Programming Example OUTPUT 714;"FETCh:FM:INTegrity?" !Query the integrity indicator for the FM result.


FETCh:FSTability

FETCh:FSTability

Last updated: June 7, 2007

  • FETCh:FSTability[:ALL]?
  • FETCh:FSTability:FERRor[:WORSt]?
  • FETCh:FSTability:FERRor:ALL?
  • FETCh:FSTability:FERRor:AVERage?
  • FETCh:FSTability:FERRor:MAXimum?
  • FETCh:FSTability:FERRor:MINimum?
  • FETCh:FSTability:FREQuency[:AVERage]?
  • FETCh:FSTability:FREQuency:ALL?
  • FETCh:FSTability:FREQuency:MAXimum?
  • FETCh:FSTability:FREQuency:MINimum?
  • FETCh:FSTability:FREQuency:SDEViation?
  • FETCh:FSTability:ICOunt?
  • FETCh:FSTability:INTegrity?

GPIB Command Conventions

FETCh:FSTability[:ALL]?

Function

Queries the full results of a frequency stability measurement. Returns integrity, worst-case frequency error, and average frequency.

Query

Worst-case frequency error:

  • Range: -500 to 500 parts per million (ppm)

  • Resolution: 0.01 ppm

Average frequency:

  • Range: 100 E+6 to 3 E+9 Hz

  • Resolution: 0.01 ppm

Programming Example

OUTPUT 714;"FETCH:FSTABILITY:ALL?"
!Returns integrity, worst-case frequency error, and average frequency.

FETCh:FSTability:FERRor[:WORSt]?

Function

Queries the worst case frequency stability measurement during a multi-measurement.

Query

Range: -500 to 500 parts per million (ppm)

Resolution: 0.01 ppm

Programming Example

OUTPUT 714;"FETCH:FSTABILITY:FERROR:WORST?"

FETCh:FSTability:FERRor:ALL?

Function

Queries the full results of a frequency stability .

Measurement results are returned in the following order: minimum frequency error, maximum frequency error, average frequency error, worst-case frequency error.

Query

Maximum, minimum frequency error:

  • Range: -500 E+3 to 500 E+3 Hz

  • Resolution: 1 Hz

Average frequency error:

  • Range: -500 E+3 to 500 E+3 Hz

  • Resolution: 1 Hz

Worst-case frequency error:

  • Range: -500 to 500 parts per million (ppm)

  • Resolution: 0.01

Programming Example

OUTPUT 714;"FETCH:FSTABILITY:FERROR:ALL?"
!Returns minimum, maximum, average, and worst-case frequency error.

FETCh:FSTability:FERRor:AVERage?

Function

Queries the average frequency error measurement.

Query

Range: -500 E+3 to 500 E+3 Hz

Resolution: 1 Hz

Programming Example

OUTPUT 714;"FETCH:FSTABILITY:FERROR:AVERAGE?"

FETCh:FSTability:FERRor:MAXimum?

Function

Queries the maximum frequency error measurement of a multi-measurement.

Query

Range: -500 E+3 to 500 E+3 Hz

Resolution: 1 Hz

Programming Example

OUTPUT 714;"FETCH:FSTABILITY:FERROR:MAXIMUM?"

FETCh:FSTability:FERRor:MINimum?

Function

Queries the minimum frequency error measurement of a multi-measurement.

Query

Range: -500 E+3 to 500 E+3 Hz

Resolution: 1 Hz

Programming Example

OUTPUT 714;"FETCH:FSTABILITY:FERROR:MINIMUM" !.

FETCh:FSTability:FREQuency[:AVERage]?

Function

Queries the frequency stability average frequency of a multi-measurement.

Query

Range: 100 E+6 to 3 E+9 Hz

Resolution: 1 Hz

Programming Example

OUTPUT 714;"FETCH:FSTABILITY:FREQUENCY:AVERAGE?"

FETCh:FSTability:FREQuency:ALL?

Function

Queries the frequency stability frequency measurement.

Measurement results are returned in the following order: minimum frequency, maximum frequency, average frequency, and standard deviation frequency.

Query

Minimum, maximum, average frequency:

  • Range: 100 E+6 to 3 E+9

  • Resolution: 1 Hz

Standard deviation frequency:

  • Range: 0 to 500 E+3 Hz

  • Resolution: 0.1 Hz

Programming Example

OUTPUT 714;"FETCH:FSTABILITY:FREQUENCY:ALL?"
!Returns minimum, maximum, average, and standard deviation frequency.

FETCh:FSTability:FREQuency:MAXimum?

Function

Queries the frequency stability maximum frequency of a multi-measurement.

Query

Range: 100 E+6 to 3 E+9

Resolution: 1 Hz

Programming Example

OUTPUT 714;"FETCH:FSTABILITY:FREQUENCY:MAXIMUM?"

FETCh:FSTability:FREQuency:MINimum?

Function

Queries the frequency stability minimum frequency of a multi-measurement.

Query

Range: 100 E+6 to 3 E+9

Resolution: 1 Hz

Programming Example

OUTPUT 714;"FETCH:FSTABILITY:FREQUENCY:MINIMUM?"

FETCh:FSTability:FREQuency:SDEViation?

Function

Queries the frequency stability frequency standard deviation of a multi-measurement.

Query

Range: 0 to 500 E+3 Hz

Resolution: 0.1 Hz

Programming Example

OUTPUT 714;"FETCH:FSTABILITY:FREQUENCY:SDEVIATION?"

FETCh:FSTability:ICOunt?

Function

Queries the intermediate count of measurements completed in a multi-measurement.

Query

Range: 0 to 999

Programming Example

OUTPUT 714;"FETCH:FSTABILITY:ICOUNT?"

FETCh:FSTability:INTegrity?

Function

Queries the measurement integrity indicator for the last frequency stabilty measurement completed.

Zero indicates a normal measurement. See Integrity Indicator for information about non-zero integrity results.

Query

Range: 1 through 16

Programming Example

OUTPUT 714;"FETCH:FSTABILITY:INTEGRITY"
!Returns the integrity indicator for the frequency stability measurement.


FETCh:GPOWer

FETCh:GPOWer

Last updated: June 7, 2007

GPIB Command Conventions

  • FETCh:GPOWer[:ALL]?
  • FETCh:GPOWer:ICOunt?
  • FETCh:GPOWer:MASK[:FAIL]?
  • FETCh:GPOWer:MASK:OFFSet?
  • FETCh:GPOWer:TRACe?

FETCh:GPOWer[:ALL]?

Function

Queries the gated power measurement results.

This measurement returns results in the following order: integrity, gated power pass/fail result.

Query

Integrity

  • Range: 0 to 23 ( see Integrity Indicator )

  • Resolution: 1

Gated Power pass/fail result

  • Range: 0 to 1 (0 = passed, 1 = failed), 9.91 E+37

Programming Example

OUTPUT 714;"FETCH:GPOWER?"

FETCh:GPOWer:ICOunt?

Function

Queries the intermediate count of measurements completed in a multi-measurement.

The multi-measurement state, by default, is off. To set up multi-measurements, see SETup:GPOWer:COUNt[:SNUMber] .

Query

Range: 0 to 999

Programming Example

OUTPUT 714;"FETCH:GPOWER:ICOUNT?"

FETCh:GPOWer:MASK[:FAIL]?

Function

Queries the pass/fail results of the gated power measurement. If any measurement data points fail to meet the requirements of the mask shown on the test set's display, the measurement will fail.

Query

 Range: 0 to 1 (0 = passed, 1 = failed), 9.91 E+37

Programming Example

OUTPUT 714;"FETCH:GPOWER:MASK:FAIL?"

FETCh:GPOWer:MASK:OFFSet?

Function

Queries the offset (in seconds) of the test limit mask from its default position. For example, a return value of 2.0 E-6 indicates the pass/fail status of the measurement was determined by comparing measured data with a test limit mask moved 2 microseconds to the right of its default location.

Query

Range: -10 to +10 µs, 9.91 E+37

Programming Example

OUTPUT 714;"FETCH:GPOWER:MASK:OFFSET?"

FETCh:GPOWer:TRACe?

Function

Queries the relative power data points across the display trace. Query returns 5,265 comma-separated values, each corresponding to a point in time across the trace. Data point 222 corresponds with time = 0 on the trace. See How is a Gated Power Measurement Made? for time values corresponding to all other data points.

Query

Range: +10 to -45 dB, 9.91 E+37

Resolution: 0.01

Programming Example

OUTPUT 714;"FETCH:GPOWER:TRACE?"


FETCh:HWQuality

FETCh:HWQuality

Last updated: June 7, 2007

GPIB Command Conventions

  • FETCh:HWQuality[:ALL]?

FETCh:HWQuality[:ALL]?

Function

Queries the handoff waveform quality measurements.

Measurement results are returned in the following order: integrity, rho, frequency error, time error, carrier feedthrough, phase error, magnitude error.

Query

Integrity

  • Range: 0 to 16

  • Resolution: 1

Rho

  • Range: 0.000 to 1.000, 9.91 E+37

  • Resolution: 0.001

Frequency Error

  • Range: -9999.0 to 9999.0 Hz, 9.91 E+37

  • Resolution: 0.1 Hz

Time Error

  • Range: -99.99 E-6 to 99.99 E-6 s, 9.91 E+37

  • Resolution: 0.01 E-6 s

Carrier Feedthrough

  • Range: -100 to 0.0 dB, 9.91 E+37

  • Resolution: 0.1

Phase Error

  • Range: 0.00 to 359.99 degrees

  • Resolution: 0.01

Magnitude Error

  • Range: 0 to 100%, 9.91 E+37

  • Resolution: 0.01

Programming Example

OUTPUT 714;"FETCH:HWQUALITY:ALL?"
!Returns integrity, rho, frequency error, time error, carrier feedthrough, phase error,
!magnitude error, EVM.


FETCh:CMMPower

FETCh:CMMPower

Last updated: June 7, 2007

GPIB Command Conventions

  • FETCh:CMMPower[:ALL]?
  • FETCh:CMMPower:INTegrity?
  • FETCh:CMMPower:INTegrity:MAXPower?
  • FETCh:CMMPower:INTegrity:MINPower?
  • FETCh:CMMPower:MAXPower?
  • FETCh:CMMPower:MINPower?

FETCh:CMMPower[:ALL]?

Function

Queries the maximum and minimum power measurement results.

This query returns an integrity indicator followed by the maximum power measurement result and the minimum controlled power measurement result.

Query

Integrity:

  • Range: 0 to 23 (see Integrity Indicator )

  • Resolution: 1

Maximum power:

  • Range: -100.00 to 100.00 dBm, 9.91 E+37
  • Resolution: 0.01 dB

Minimum power:

  • Range: -100.00 to 100.00 dBm/1.23MHz, 9.91 E+37
  • Resolution: 0.01 dB

Requirements

Test Application Revision: B.07 and above

Lab Application Revision: B.01 and above

Programming Example

OUTPUT 714;"FETCh:CMMPower?"
!Returns integrity value, maximum and minimum power measurement results.

FETCh:CMMPower:INTegrity?

Function

Queries the measurement integrity indicator for overall measurement.

Zero indicates both maximum power and minimum power results were normal. If the result of this query is non-zero it applies to the last non-zero integrity indicator, either caused by the maximum power result ( FETCh:CMMPower:INTegrity:MAXPower? ) or the minimum power result ( FETCh:CMMPower:INTegrity:MINPower? ).

See Integrity Indicator for information about non-zero integrity results.

Query

  • Range: 0 to 23

  • Resolution: 1

Requirements

Test Application Revision: B.07 and above

Lab Application Revision: B.01 and above

Programming Example

OUTPUT 714;"FETCH:CMMPower:INTegrity?"
!Queries the integrity indicator for the maximum and minimum power results.

FETCh:CMMPower:INTegrity:MAXPower?

Function

Queries the measurement integrity indicator for the maximum power result.

Zero indicates the maximum power results were normal. See Integrity Indicator for information about non-zero integrity results.

Query

Range: 0 through 23

Requirements

Test Application Revision: B.07 and above

Lab Application Revision: B.01 and above

Programming Example

OUTPUT 714;"FETCh:CMMPower:INTegrity:MAXimum?"
!Returns the measurement integrity indicator for the maximum power.

FETCh:CMMPower:INTegrity:MINPower?

Function

Queries the measurement integrity indicator for the minimum power result.

Zero indicates the minimum power results were normal. See Integrity Indicator for information about non-zero integrity results.

Query

Range: 0 through 23

Requirements

Test Application Revision: B.07 and above

Lab Application Revision: B.01 and above

Programming Example

OUTPUT 714;"FETCh:CMMPower:INTegrity:MINPower?"
!Returns the measurement integrity indicator for the minimum power.

FETCh:CMMPower:MAXPower?

Function

Queries the maximum power measurement results.

Query

  • Range: -100 to 100 dBm, 9.91 E+37

  • Resolution: 0.01 dB

Requirements

Test Application Revision: B.07 and above

Lab Application Revision: B.01 and above

Programming Example

OUTPUT 714;"FETCh:CMMPower:MAXPower?"
!Returns the maximum power result.

FETCh:CMMPower:MINPower?

Function

Queries the minimum power measurement results.

Query

  • Range: -100 to 100 dBm/1.23MHz, 9.91 E+37

  • Resolution: 0.01 dB

Requirements

Test Application Revision: B.07 and above

Lab Application Revision: B.01 and above

Programming Example

OUTPUT 714;"FETCh:CMMPower:MINPower?"
!Returns the minimum power result.


FETCh:CMAudio

FETCh:CMAudio

Last updated: June 7, 2007

GPIB Command Conventions

  • FETCh:CMAudio[:ALL]?
  • FETCh:CMAudio:DISTortion[:AVERage]?
  • FETCh:CMAudio:FREQuency[:AVERage]?
  • FETCh:CMAudio:ICOunt?
  • FETCh:CMAudio:INTegrity?
  • FETCh:CMAudio:LEVel?
  • FETCh:CMAudio:LEVel:LIMit:FAIL?
  • FETCh:CMAudio<:SINad|:SNDRatio>[:AVERage]?
  • FETCh:CMAudio:VOLTage[:AVERage]?

FETCh:CMAudio[:ALL]?

Function

This query returns an integrity indicator followed by a comma separated list containing the measured average audio levels (in units of dB) for each of the 20 audio tones. The query returns NAN (9.91E+37) for any audio tone that is turned off.

For downlink audio measurements, the audio tones are turned off and on by SETup:CMAudio:GENerator:FREQuency:DOWNlink:PRESet . For uplink audio measurements, the audio tones can be turned off and on by SETup:CMAudio:GENerator:FREQuency:Uplink:PRESet , SETup:CMAudio:GENerator:FREQuency:Uplink:ALL[:SVALue] , or SETup:CMAudio:GENerator:LEVel:UPLink:ALL[:SAMPlitude] .

Query

Range: -100 to +100 dB or 9.91E+37 (NAN)
Resolution: 0.1 dB

Requirement

 Test Application Revision: B.08 and above
Lab Application Revision: B.02 and above

Programming Example:

OUTPUT 714;"FETch:CMAudio?"
!Returns integrity, average audio level for 20 tones.

FETCh:CMAudio:DISTortion[:AVERage]?

Function

This query returns the average distortion for audio tone one for the multi-tone audio measurement. The SINAD/Distortion state must be on (see SETup:CMAudio:SDIStortion:STATe ) for this result to be returned.

Query

  • Range: 0 to 99%, 9.91 E+37

  • Resolution: 0.01%

Requirement

 Test Application Revision: B.08 and above
Lab Application Revision: B.02 and above

Programming Example

OUTPUT 714;"FETch:CMAudio:DISTortion?"
!Returns the average distortion result for audio tone 1.

FETCh:CMAudio:FREQuency[:AVERage]?

Function

This query returns the average frequency measurement result for audio tone one for the multi-tone audio measurement. The SINAD/Distortion state must be on (see SETup:CMAudio:SDIStortion:STATe ) for this result to be returned.

Query

  • Range: 0 to 99999 Hz, 9.91 E+37

  • Resolution: 0.01 Hz

Requirement

 Test Application Revision: B.08 and above
Lab Application Revision: B.02 and above

Programming example

OUTPUT 714;"FETch:CMAudio:FREQuency:AVERage?"
!Returns the average frequency measurement result for audio tone 1.

FETCh:CMAudio:ICOunt?

Function | This query returns the intermediate count of measurements completed in a multi-measurement. To set up multi-measurements, see SETup:CMAudio:COUNt[:SNUMber] .
Query | Range: 1 to 999 Resolution: 1
Requirement | Test Application Revision: B.08 and above Lab Application Revision: B.02 and above
Programming example OUTPUT 714;"FETCh:CMAudio:ICOunt?" !Returns the intermediate count of multi-tone !audio multi-measurements completed.

FETCh:CMAudio:INTegrity?

Function

 This query returns the integrity indicator for the last multi-tone audio measurement completed. Zero indicates a normal measurement. See Integrity Indicator for descriptions of non-zero integrity indicators.

Query

Range: 0 to 23 (see Integrity Indicator )
Resolution: 1

Requirement

 Test Application Revision: B.08 and above
Lab Application Revision: B.02 and above

Programming example

OUTPUT 714;"FETCh:CMAudio:INTegrity?"
!Returns the integrity indicator for the measurement

FETCh:CMAudio:LEVel?

Function

This query returns a comma separated list containing the measured average audio levels (in units of dB) for each of the 20 audio tones. The query returns NAN (9.91E+37) for any audio tone that is turned off. See FETCh:CMAudio[:ALL]? for details.

Query

Range: -100 to +100 dB or 9.91E+37 (NAN)
Resolution: 0.1 dB

Requirement

 Test Application Revision: B.08 and above
Lab Application Revision: B.02 and above

Programming example

OUTPUT 714;"FETCh:CMAudio:LEVel?"
!Returns the measured average audio levels
!for each of the 20 tones.

FETCh:CMAudio:LEVel:LIMit:FAIL?

Function

This query returns a pass/fail result indicating whether the multi-tone audio measured level exceeds the mask limits as specified by SETup:CMAudio:LEVel:ALL:LIMit:LOWer and SETup:CMAudio:LEVel:ALL:LIMit:UPPer . If any tone failed the mask limit, '1' will be returned.

Query

 0: Pass
1: Fail
9.91E+37 (NAN): results can not be determined

Requirement

 Test Application Revision: B.08 and above
Lab Application Revision: B.02 and above

Programming example

OUTPUT 714;"FETCh:CMAudio:LEVel:LIMit:FAIL?"
!Returns pass/fail results for the measurement.

FETCh:CMAudio<:SINad|:SNDRatio>[:AVERage]?

Function

This query returns the average SINAD measurement result for audio tone one for the multi-tone audio measurement. The SINAD/Distortion state must be on (see SETup:CMAudio:SDIStortion:STATe ) for this result to be returned for audio tone one.

Query

  • Range:-99 to 99 dB, 9.91 E+37

  • Resolution: 0.01 dB

Requirement

 Test Application Revision: B.08 and above
Lab Application Revision: B.02 and above

Programming example

OUTPUT 714;"FETCh:CMAudio:SINad?"
!Returns the average SINAD result for audio tone 1.

FETCh:CMAudio:VOLTage[:AVERage]?

Function

This query returns the total average measured audio level. The value is returned in Vrms when the measurement mode is downlink and in percentage (%) when the measurement mode is uplink. (See SETup:CMAudio:MEASurement:MODE .) When the SINAD/Distortion state is on ( SETup:CMAudio:SDIStortion:STATe ). this result is the average audio level for audio tone one.

Query

Downlink

  • Range: 5 mVrms to 14.1 Vrms
  • Resolution: 0.1 mVrms

Uplink

  • Range: 0 to 70%
  • Resolution: 0.1%

Requirement

 Test Application Revision: B.08 and above
Lab Application Revision: B.02 and above

Programming example

OUTPUT 714;"FETCh:CMAudio:VOLTage?"
!Returns the total average measured audio level.


FETCh:SAUDio

FETCh:SAUDio

Last updated: June 7, 2007

GPIB Command Conventions

  • FETCh:SAUDio[:ALL]?
  • FETCh:SAUDio:DISTortion[:AVERage]?
  • FETCh:SAUDio:DISTortion:MAXimum?
  • FETCh:SAUDio:DISTortion:MINimum?
  • FETCh:SAUDio:DISTortion:SDEViation?
  • FETCh:SAUDio:ICOunt?
  • FETCh:SAUDio:INTegrity?
  • FETCh:SAUDio:SINAD[:AVERage]?
  • FETCh:SAUDio:SINAD:MAXimum?
  • FETCh:SAUDio:SINAD:MINimum?
  • FETCh:SAUDio:SINAD:SDEViation?
  • FETCh:SAUDio:VOLTage[:AVERage]?
  • FETCh:SAUDio:VOLTage:MAXimum?
  • FETCh:SAUDio:VOLTage:MINimum?
  • FETCh:SAUDio:VOLTage:SDEViation?

FETCh:SAUDio[:ALL]?

Function

This query returns the swept audio measurement results. This query returns results in the following order: integrity indicator, average swept audio level and average distortion for the first frequency point, average swept audio level and average distortion for the second frequency point, and so on. The number of frequency points is determined with the SETup:SAUDio:FREQuency:POINts command.

For frequencies above 10 kHz, this measurement returns 9.91 E+37.

Query

Integrity indicator

  • Range: See Integrity Indicator .
  • Resolution: 1

Average audio level

  • Range: 1 mV to 20 V, 9.91 E+37
  • Resolution: the lesser of 4 significant digits or 10 uV

Average distortion

  • Range: 0 to 99.9%, 9.91 E+37
  • Resolution: 0.01%

FETCh:SAUDio:DISTortion[:AVERage]?

Function

This query returns a comma separated list of the audio distortion measured at each frequency point in the sweep. The number of frequency points is determined with the SETup:SAUDio:FREQuency:POINts command.

For frequencies above 10 kHz, this measurement returns 9.91 E+37.

Query

Average audio distortion

  • Range: 0 to 99.9%, 9.91 E+37

  • Resolution: 0.01%

FETCh:SAUDio:DISTortion:MAXimum?

Function | This query returns a comma separated list of the maximum audio distortion measured at each frequency point in the sweep. The number of frequency points is determined with the SETup:SAUDio:FREQuency:POINts command. For frequencies above 10 kHz, this measurement returns 9.91 E+37.
Query | Range: 0 to 99.9%, 9.91 E+37 Resolution: 0.01%

FETCh:SAUDio:DISTortion:MINimum?

Function | This query returns a comma separated list of the minimum audio distortion measured at each frequency point in the sweep. For frequencies above 10 kHz, this measurement returns 9.91 E+37.
Query | Range: 0 to 99.9%, 9.91 E+37 Resolution: 0.01%

FETCh:SAUDio:DISTortion:SDEViation?

Function | This query returns a comma separated list of the standard deviation audio distortion measured at each frequency point in the sweep. The number of frequency points is determined with the SETup:SAUDio:FREQuency:POINts command. For frequencies above 10 kHz, this measurement returns 9.91 E+37.
Query | Range: 0 to 99.9%, 9.91 E+37 Resolution: 0.001%

FETCh:SAUDio:ICOunt?

Function | This query returns the intermediate count of swept audio multi-measurements completed. The total measurement count is the number of measurements specified in with the multi-measurement count command, SETup:SAUDio:COUNt[:SNUMber] , times the number of frequency points specified with the SETup:SAUDio:FREQuency:POINts . Therefore, when completing a 5 point sweep with multi-measurements turned off, the measurement will return 5 not 1. See also SETup:SAUDio:ICOunt:MAXimum?
Query | Range: 1 to 999 x 60 Resolution: 1

FETCh:SAUDio:INTegrity?

Function | This query returns the integrity indicator for the last swept audio measurement completed. Zero indicates a normal measurement. See Integrity Indicator for descriptions of non-zero integrity indicators.
Query | Range: See Integrity Indicator . Resolution: 1

FETCh:SAUDio:SINAD[:AVERage]?

Function

This query returns a comma separated list of the average SINAD measured at each frequency point in the sweep. The number of frequency points is determined with the SETup:SAUDio:FREQuency:POINts command.

Query

Average SINAD

  • Range: -99.99 to 99.99 dB, 9.91 E+37

  • Resolution: 0.01 dB

FETCh:SAUDio:SINAD:MAXimum?

Function | This query returns a comma separated list of the maximum SINAD measured at each frequency point in the sweep. The number of frequency points is determined with the SETup:SAUDio:FREQuency:POINts command.
Query | Range: -99.99 to 99.99 dB, 9.91 E+37 Resolution: 0.01 dB

FETCh:SAUDio:SINAD:MINimum?

Function | This query returns a comma separated list of the minimum SINAD measured at each frequency point in the sweep. The number of frequency points is determined with the SETup:SAUDio:FREQuency:POINts command.
Query | Range: -99.99 to 99.99 dB, 9.91 E+37 Resolution: 0.01 dB

FETCh:SAUDio:SINAD:SDEViation?

Function | This query returns a comma separated list of the standard deviation of SINAD measured at each frequency point in the sweep. The number of frequency points is determined with the SETup:SAUDio:FREQuency:POINts command.
Query | Range: 0 to 99.99 dB, 9.91 E+37 Resolution: 0.001 dB

FETCh:SAUDio:VOLTage[:AVERage]?

Function | This query returns a comma separated list of the average swept audio level measured at each frequency point in the sweep. The number of frequency points is determined with the SETup:SAUDio:FREQuency:POINts command. Value is returned in units of V.
Query | Range: 1 mV to 20, 9.91 E+37 Resolution: 4 significant digits

FETCh:SAUDio:VOLTage:MAXimum?

Function | This query returns a comma separated list of the maximum audio voltage measured at each frequency point in the sweep. The number of frequency points is determined with the SETup:SAUDio:FREQuency:POINts command.
Query | Range: 1 mV to 20 V, 9.91 E+37 Resolution: 4 significant digits

FETCh:SAUDio:VOLTage:MINimum?

Function | This query returns a comma separated list of minimum audio voltage measured at each frequency point in the sweep. The number of frequency points is determined with the SETup:SAUDio:FREQuency:POINts command.
Query | Range: 1 mV to 20 V, 9.91 E+37 Resolution: 4 significant digits

FETCh:SAUDio:VOLTage:SDEViation?

Function | This query returns a comma separated list of the standard deviation of audio voltage measured at each point in the sweep. The number of frequency points is determined with the SETup:SAUDio:FREQuency:POINts command.
Query | Range: 1 mV to 20 V, 9.91 E+37 Resolution: 4 significant digits


FETCh:SMONitor

FETCh:SMONitor

Last updated: June 7, 2007

GPIB Command Conventions

  • FETCh:SMONitor[:ALL]?
  • FETCh:SMONitor:INTegrity?
  • FETCh:SMONitor:TRACe?

FETCh:SMONitor[:ALL]?

Function

Returns one integrity indicator value followed by 401 points representing the amplitude results (in dBm) of the trace data for the last spectrum monitor measurement performed.

See Integrity Indicator for descriptions of non-zero integrity indicators.

Query

Integrity Indicator

  • Range: See Integrity Indicator
  • Resolution: 1

Trace Data

  • Range:
    • For spans of 125 kHz and 500 kHz
      • frequency of point: within the current span ( relative to the center frequency)
      • amplitude of point: -50 to +55 dB
    • For all other spans
      • frequency of point: within the current span ( relative to the center frequency)
      • amplitude of point: ( reference level -60 dB) to +55 dB

FETCh:SMONitor:INTegrity?

Function | Returns the integrity indicator value for the last spectrum monitor measurement performed. Zero indicates a normal result. See Integrity Indicator for descriptions of non-zero integrity indicators.
Query | Range: See Integrity Indicator . Resolution: 1

FETCh:SMONitor:TRACe?

Function

 Queries the spectrum monitor and returns 401 points representing the amplitude results (in dBm) of the trace data.

Query

Range:

  • For spans of 125 kHz and 500 kHz

    • frequency of point: within the current span (relative to the center frequency)
    • amplitude of point: -50 to +55 dB

  • For all other spans

    • frequency of point: within the current span (relative to the center frequency)
    • amplitude of point: (reference level - 60 dB) to +55 dB


FETCh:STONe

FETCh:STONe

Last updated: June 7, 2007

GPIB Command Conventions

  • FETCh:STONe[:ALL]?
  • FETCh:STONe:DEViation:PPEak[:AVERage]?
  • FETCh:STONe:DEViation:PPEak:ALL?
  • FETCh:STONe:DEViation:PPEak:MINimum?
  • FETCh:STONe:DEViation:PPEak:MAXimum?
  • FETCh:STONe:DEViation:PPEak:SDEViation?
  • FETCh:STONe:DEViation:NPEak[:AVERage]?
  • FETCh:STONe:DEViation:NPEak:ALL?
  • FETCh:STONe:DEViation:NPEak:MINimum?
  • FETCh:STONe:DEViation:NPEak:MAXimum?
  • FETCh:STONe:DEViation:NPEak:SDEViation?
  • FETCh:STONe:FREQuency[:AVERage]?
  • FETCh:STONe:FREQuency:ALL?
  • FETCh:STONe:FREQuency:MINinum?
  • FETCh:STONe:FREQuency:MAXimum?
  • FETCh:STONe:FREQuency:SDEViation?
  • FETCh:STONe:FERRor[:AVERage]?
  • FETCh:STONe:FERRor:ALL?
  • FETCh:STONe:FERRor:MINinum?
  • FETCh:STONe:FERRor:MAXimum?
  • FETCh:STONe:FERRor:SDEViation?
  • FETCh:STONe:ICOunt?
  • FETCh:STONe:INTegrity?

FETCh:STONe[:ALL]?

Function

Queries the signaling tone measurements.

Measurement results are returned in the following order: integrity, positive peak deviation, negative peak deviation, frequency error and frequency.

When multi-measurement is enabled, the average positive peak deviation, average negative peak deviation, average frequency error and average frequency from all the measurements are returned.

Query

Integrity

  • Range: 0 to 23 see Integrity Indicator

Average positive peak deviation

  • Range: -20 to 20 kHz, 9.91 E+37

Average negative peak deviation

  • Range: -20 to 20 kHz, 9.91 E+37

Average frequency error

  • Range: -10,000 Hz to 10,000 Hz, 9.91 E+37

Average frequency

  • Range: 0 to 20,000 Hz, 9.91 E+37

Requirement

Test Application Revision: B.09 and above

Lab Application Revision: B.03 and above

Programming Example

OUTPUT 714;"FETCh:STONe?"
!Returns integrity, positive peak deviation, negative peak deviation, frequency error and frequency.

FETCh:STONe:DEViation:PPEak[:AVERage]?

Function

Queries the positive peak frequency deviation of carrier caused by the signaling tone generated by the mobile station.

When multi-measurement is enabled, the average positive peak frequency deviation of carrier from all the measurements is returned.

Query

Range: -20 kHz to 20 kHz, 9.91 E+37

Requirement

Test Application Revision: B.09 and above

Lab Application Revision: B.03 and above

Programming Example

OUTPUT 714;"FETCh:STONe:DEViation:PPEak?" !Returns positive peak deviation of carrier.

FETCh:STONe:DEViation:PPEak:ALL?

Function

Queries the positive peak deviations of Signaling Tone measurements.

Measurement results are returned in the following order: minimum positive peak deviation, maximum positive peak deviation, average positive peak deviation and standard deviation of positive peak deviation.

When multi-measurement is not enabled, the minimum positive peak deviation, maximum positive peak deviation and standard deviation of positive peak deviation are the same as the average positive peak deviation.

Query

Minimum, maximum, average positive peak deviation and standard deviation of positive peak deviation

  • Range: -20 to 20 kHz, 9.91 E+37

Requirement

Test Application Revision: B.09 and above

Lab Application Revision: B.03 and above

Programming Example

OUTPUT 714;"FETCh:STONe:DEViation:PPEak:ALL?"
!Returns mininum, maximum, average, and standard deviation of positive peak deviation.

FETCh:STONe:DEViation:PPEak:MINimum?

Function

Queries the minimum value of all positive peak deviation measurements made during the multi-measurement period.

When multi-measurement is not enabled, the result is the same as average positive peak deviation.

Query

Range: -20 to 20 kHz, 9.91 E+37

Requirement

Test Application Revision: B.09 and above

Lab Application Revision: B.03 and above

Programming Example

OUTPUT 714;"FETCh:STONe:DEViation:PPEak:MINimum?"
!Returns mininum positive peak deviation during the multi-measurement period.

FETCh:STONe:DEViation:PPEak:MAXimum?

Function

Queries the maximum value of all positive peak deviation measurement made during the multi-measurement period.

When multi-measurement is not enabled, the result is the same as average positive peak deviation.

Query

Range: -20 to 20 kHz, 9.91 E+37

Requirement

Test Application Revision: B.09 and above

Lab Application Revision: B.03 and above

Programming Example

OUTPUT 714;"FETCh:STONe:DEViation:PPEak:MAXimum?"
!Returns maximum positive peak deviation measurement made during multi-measurment period.

FETCh:STONe:DEViation:PPEak:SDEViation?

Function

 Queries the standard deviation of all positive peak deviation measurements made during the multi-measurement period.

When multi-measurement is not enabled, the result is the same as average positive peak deviation.

Query

Range: -20 to 20 kHz, 9.91 E+37

Requirement

Test Application Revision: B.09 and above

Lab Application Revision: B.03 and above

Programming Example

OUTPUT 714;"FETCh:STONe:DEViation:PPEak:SDEViation?"
!Returns standard deviation of all positive peak deviation measurement made during the multi-measurement period.

FETCh:STONe:DEViation:NPEak[:AVERage]?

Function

Queries the negative peak frequency deviation of carrier caused by the signaling tone generated by the mobile station.

When multi-measurement is enabled, the average negative peak frequency deviation of carrier from all the measurements is returned.

Query

Range: -20 kHz to 20 kHz, 9.91 E+37

Requirement

Test Application Revision: B.09 and above

Lab Application Revision: B.03 and above

Programming Example

OUTPUT 714;"FETCh:STONe:DEViation:NPEak?"
!Returns negative peak deviation of carrier.

FETCh:STONe:DEViation:NPEak:ALL?

Function

Queries the negative peak deviation of Signaling Tone measurements.

Measurement results are returned in the following order: minimum negative peak deviation, maximum negative peak deviation, average negative peak deviation, standard deviation of negative peak deviation.

When multi-measurement is not enable, the minimum negative peak deviation, maximum negative peak deviation and standard deviation of negative peak deviation are the same as average negative peak deviation.

Query

Minimum, maximum, average negative peak deviation and standard deviation of negative peak deviation

  • Range: -20 to 20 kHz, 9.91 E+37
Requirement

Test Application Revision: B.09 and above

Lab Application Revision: B.03 and above

Programming Example

OUTPUT 714;"FETCh:STONe:DEViation:NPEak:ALL?"
!Returns mininum, maximum, average, and standard deviation of negative peak deviation.

FETCh:STONe:DEViation:NPEak:MINimum?

Function

Queries the minimum value of all negative peak deviation measurements made during the multi-measurement period.

When multi-measurement is not enabled, the result is the same as average negative peak deviation.

Query

Range: -20 to 20 kHz, 9.91 E+37

Requirement

Test Application Revision: B.09 and above

Lab Application Revision: B.03 and above

Programming Example

OUTPUT 714;"FETCh:STONe:DEViation:NPEak:MINimum?"
!Returns mininum negative peak deviation made during the multi-measurement period.

FETCh:STONe:DEViation:NPEak:MAXimum?

Function

Queries the maximum value of all negative peak deviation measurements made during the multi-measurement period.

When multi-measurement is not enabled, the result is the same as average negative peak deviation.

Query

Range: -20 to 20 kHz, 9.91 E+37
Requirement

Test Application Revision: B.09 and above

Lab Application Revision: B.03 and above

Programming Example

OUTPUT 714;"FETCh:STONe:DEViation:NPEak:MAXimum?"
!Returns maximum negative peak deviation measurement made during multi-measurment period.

FETCh:STONe:DEViation:NPEak:SDEViation?

Function

 Queries the standard deviation of all negative peak deviation measurements made during the multi-measurement period.

When multi-measurement is not enabled, the result is the same as average negative peak deviation.

Query

Range: -20 to 20 kHz, 9.91 E+37

Requirement

Test Application Revision: B.09 and above

Lab Application Revision: B.03 and above

Programming Example

OUTPUT 714;"FETCh:STONe:DEViation:NPEak:SDEViation?"
!Returns standard deviation of negative peak deviation measurement made during multi-measurment period.

FETCh:STONe:FREQuency[:AVERage]?

Function

Queries the frequency of signaling tone generated by the mobile station.

When multi-measurement is enabled, the average frequency from all measurements made during the multi-measurement period is returned.

Query

Average frequency

  • Range: 0 to 20,000 Hz, 9.91 E+37

Requirement

Test Application Revision: B.09 and above

Lab Application Revision: B.03 and above

Programming Example

OUTPUT 714;"FETCh:STONe:FREQuency?"
!Returns frequency of the signaling tone.

FETCh:STONe:FREQuency:ALL?

Function

Queries the frequency of Signaling Tone measurements.

The measurement results are returned in the following order: minimum frequency, maximum frequency, average frequency, standard deviation of frequency.

When multi-measurement is not enable, the minimum frequency, maximum frequency and standard deviation of frequency are the same as the average frequency.

Query

Minimum, maximum, and average frequency and standard deviation of frequency

  • Range: 0 to 20,000 Hz, 9.91 E+37
Requirement

Test Application Revision: B.09 and above

Lab Application Revision: B.03 and above

Programming Example

OUTPUT 714;"FETCh:STONe:FREQuency:ALL?"
!Returns mininum, maximum, average, and standard deviation frequency.

FETCh:STONe:FREQuency:MINinum?

Function

Queries the minimum frequency value of all the measurements made during the multi-measurement period.

When multi-measurement is not enabled, the result is the same as average frequency.

Query

Range: 0 to 20,000 Hz, 9.91 E+37

Requirement

Test Application Revision: B.09 and above

Lab Application Revision: B.03 and above

Programming Example

OUTPUT 714;"FETCh:STONe:FREQuency:MINimum?"
!Returns mininum frequency measurement made during multi-measurement period.

FETCh:STONe:FREQuency:MAXimum?

Function

Queries the maximum frequency value of all the measurements made during the multi-measurement period.

When multi-measurement is not enabled, the result is the same as average frequency.

Query

Range: 0 to 20,000 Hz, 9.91 E+37

Requirement

Test Application Revision: B.09 and above

Lab Application Revision: B.03 and above

Programming Example

OUTPUT 714;"FETCh:STONe:FREQuency:MAXimum?"
!Returns maximum frequency measurement made during multi-measurement period.

FETCh:STONe:FREQuency:SDEViation?

Function

Queries the standard deviation of frequency in all the measurements made during the multi-measurement period.

When multi-measurement is not enabled, the result is the same as average frequency.

Query

Range: 0 to 20,000 Hz, 9.91 E+37

Requirement

Test Application Revision: B.09 and above

Lab Application Revision: B.03 and above

Programming Example

OUTPUT 714;"FETCh:STONe:FREQuency:SDEViation?"
!Returns standard deviation of frequency measurement made during multi-measurement period.

FETCh:STONe:FERRor[:AVERage]?

Function

Queries the frequency error of the signaling tone generated by the mobile station relative to the ideal 10 kHz tone frequency.

When multi-measurement is enabled, the average frequency error from all the measurements made during the multi-measurement period is returned.

Query

Average frequency error

  • Range: 0 to 20,000 Hz, 9.91 E+37

Requirement

Test Application Revision: B.09 and above

Lab Application Revision: B.03 and above

Programming Example

OUTPUT 714;"FETCh:STONe:FRRRor?"
!Returns frequency error of signaling tone.

FETCh:STONe:FERRor:ALL?

Function

Queries the frequency error of all the measurements made during the multi-measurement period.

The results are returned in the following order: minimum frequency error, maximum frequency error, average frequency error and standard deviation of frequency error.

When multi-measurement is not enabled, the minimum frequency error, maximum frequency error, average frequency error and standard deviation of frequency error are the same as the average frequency error.

Query

Minimum, maximum, and average frequency error and standard deviation of frequency:

  • Range: 0 to 20,000 Hz, 9.91 E+37

Requirement

Test Application Revision: B.09 and above

Lab Application Revision: B.03 and above

Programming Example

OUTPUT 714;"FETCh:STONe:FERRor:ALL?"
!Returns mininum, maximum, average, and standard deviation of frequency error.

FETCh:STONe:FERRor:MINinum?

Function

Queries the minimum frequency error of all the measurements made during the multi-measurement period.

When multi-measurement is not enabled, the result is the same as the average frequency error.

Query

Range: 0 to 20,000 Hz, 9.91 E+37

Requirement

Test Application Revision: B.09 and above

Lab Application Revision: B.03 and above

Programming Example

OUTPUT 714;"FETCh:STONe:FERRor:MINimum?"
!Returns mininum frequency error during multi-measurement period.

FETCh:STONe:FERRor:MAXimum?

Function

Queries the maximum frequency error of all the measurements made during the multi-measurement period.

When multi-measurement is not enabled, the result is the same as the average frequency error.

Query

Range: 0 to 20,000 Hz, 9.91 E+37

Requirement

Test Application Revision: B.09 and above

Lab Application Revision: B.03 and above

Programming Example

OUTPUT 714;"FETCh:STONe:FERRor:MAXimum?"
!Returns maximum frequency error during multi-measurement period.

FETCh:STONe:FERRor:SDEViation?

Function

Queries the standard deviation of frequency errors in all the measurements made during the multi-measurement period.

When multi-measurement is not enabled, the result is the same as the average frequency error.

Query

Range: 0 to 20,000 Hz, 9.91 E+37

Requirement

Test Application Revision: B.09 and above

Lab Application Revision: B.03 and above

Programming Example

OUTPUT 714;"FETCh:STONe:FERRor:SDEViation?"
!Returns standard deviation of frequency error during multi-measurement period.

FETCh:STONe:ICOunt?

Function

Queries the intermediate count of measurements completed in a multi-measurement.

Query

Range: 0 to 999

Requirement

Test Application Revision: B.09 and above

Lab Application Revision: B.03 and above

Programming Example

OUTPUT 714;"FETCh:STONe:ICOunt?"
!Returns the number of measurements completed during the multi-measurement period.

FETCh:STONe:INTegrity?

Function

Queries the measurement integrity indicator for the last Signaling Tone measurement completed.

Zero indicates a normal measurement. See Integrity Indicator for information about non-zero integrity results.

Query

Range: 0 through 25

Requirement

Test Application Revision: B.09 and above

Lab Application Revision: B.03 and above

Programming Example

OUTPUT 714;"FETCh:STONe:INTegrity?"
!Query the integrity indicator for the signaling tone result.


FETCh:TFERror

FETCh:TFERror

Last updated: June 7, 2007

GPIB Command Conventions

  • FETCh:TFERror[:ALL]?
  • FETCh:TFERror:ICOunt?

FETCh:TFERror[:ALL]?

Function

Queries the TDSO frame error rate measurement results.

This measurement returns results in the following order: integrity, frame error ratio (in percent), received good frames, received blank frames, transmitted good frames, transmitted blank frames, frame error rate confidence (in percent).

Query

Integrity

  • Range: 0 to 16 see Integrity Indicator

  • Resolution: 1

TDSO frame error ratio (Ratio)

  • Range: 0.00 to 100.00%, 9.91 E+37

Received good frames (RX Good)

  • Range: 0 to 999936, 9.91 E+37

Received blank frames (RX Blank)

  • Range: 0 to 999936, 9.91 E+37

Transmitted good frames (TX Good)

  • Range: 0 to 999936, 9.91 E+37

Transmitted blank frames (TX Blank)

  • Range: 0 to 999936, 9.91 E+37

Frame error rate confidence (in percent)

  • Range: 0.00 to 100.00%, 9.91 E+37

  • Resolution: 0.01%

Programming Example

OUTPUT 714;"FETCH:TFERROR?" !Fetches all of the TDSO FER results.

FETCh:TFERror:ICOunt?

Function

Queries the intermediate count of transmitted frames.

To set up the number of transmitted frames, see SETup:TFERror:COUNt .

Query

Range: 0 to 999936

Programming Example

OUTPUT 714;"FETCH:TFERROR:ICOUNT?"


FETCh:TROPower

FETCh:TROPower

Last updated: June 7, 2007

GPIB Command Conventions

  • FETCh:TROPower[:ALL]?
  • FETCh:TROPower:MASK[:FAIL]?
  • FETCh:TROPower:TRACe?

FETCh:TROPower[:ALL]?

Function

Queries the time response of open loop power control measurement results.

This measurement returns results in the following order: integrity, time response of open loop power pass/fail result.

Query

Integrity

  • Range: 0 to 23 see Integrity Indicator

  • Resolution: 1

Tme response of open loop power pass/fail result

  • Range: 0 to 1 (0 = passed, 1 = failed), 9.91 E+37 (undefined)

  • Resolution: 1

Requirements

 Test Application Revision: B.04

Programming Example

OUTPUT 714;"FETCH:TROPOWER?"

FETCh:TROPower:MASK[:FAIL]?

Function

Queries the pass/fail results of the time response of open loop power control measurement. If any measurement data points fail to meet the requirements of the mask shown on the test set's display, the measurement will fail.

Query

 Range: 0 to 1 (0 = passed, 1 = failed), 9.91 E+37 (undefined)
Resolution: 1

Requirements

 Test Application Revision: B.04

Programming Example

OUTPUT 714;"FETCH:TROPOWER:MASK:FAIL?"

FETCh:TROPower:TRACe?

Function

Queries the time response of open loop power control trace.

A total of 371 comma-separated values are returned. If valid measurement results are available, each comma-separated measurement value will be 16 characters in length and represent the change (delta) of power level in units of dB. If no trace is present, each comma-separated value is 7 characters in length (9.91E37).

The first value corresponds to t = 0 ms. The last value corresponds to t = 100 ms. This implies that the time between values is 100 ms ÷ 370 (approximately 270.270 µs).

Returned values are in dB.

Query

Range: 2967 to 6306 characters, representing 371 values.

Requirements

 Test Application Revision: B.04

Programming Example

OUTPUT 714;"FETCH:TROPOWER:TRACE?"


FETCh:WDDeviation

FETCh:WDDeviation

Last updated: June 7, 2007

GPIB Command Conventions

  • FETCh:WDDeviation[:ALL]?
  • FETCh:WDDeviation:DEViation:MAXimum:PPEak?
  • FETCh:WDDeviation:DEViation:MAXimum:NPEak?
  • FETCh:WDDeviation:DEViation:SETTled:PPEak?
  • FETCh:WDDeviation:DEViation:SETTled:NPEak?
  • FETCh:WDDeviation:INTegrity?

FETCh:WDDeviation[:ALL]?

Function

Queries the wideband data measurement.

Measurement results are returned in the following order: integrity, maximum positive peak frequency deviation, maximum negative peak frequency deviation, settled positive peak frequency deviation and settled negative peak frequency deviation.

If the measurement gets more than one wideband data burst, it measures the first one.

Query

Integrity

  • Range: 0 to 25 see Integrity Indicator

  • Resolution: 1

Maximum positive peak frequency deviation

  • Range: 0 to 20 kHz, 9.91 E+37

Maximum negative peak frequency deviation

  • Range: 0 to 20 kHz, 9.91 E+37

Settled positive peak frequency deviation

  • Range: 0 to 20 kHz, 9.91 E+37

Settled negative peak frequency deviation

  • Range: 0 to 20 kHz, 9.91 E+37

Requirement

Test Application Revision: B.09 and above

Lab Application Revision: B.03 and above

Programming Example

OUTPUT 714;"FETCh:WDDeviation?"
!Returns integrity, maximum positive peak frequency deviation, maximum negative peak frequency deviation, settled positive peak frequency deviation and settled negative peak frequency deviation.

FETCh:WDDeviation:DEViation:MAXimum:PPEak?

Function

Queries the maximum positive peak frequency deviation of the carrier over the entire wideband data burst.

If the measurement gets more than one wideband data burst, it measures the first one.

Query

Range: 0 to 20 kHz, 9.91 E+37

Requirement

Test Application Revision: B.09 and above

Lab Application Revision: B.03 and above

Programming Example

OUTPUT 714;"FETCh:WDDeviation:DEViation:MAXimum:PPEak?"

FETCh:WDDeviation:DEViation:MAXimum:NPEak?

Function

Queries the maximum negative peak deviation of carrier over the entire wideband data burst.

If the measurement gets more than one wideband data burst, it measures the first one.

Query

  • Range: 0 to 20 kHz, 9.91 E+37

Requirement

Test Application Revision: B.09 and above

Lab Application Revision: B.03 and above

Programming Example

OUTPUT 714;"FETCh:WDDeviation:DEViation:MAXimum:NPEak?"
!Returns maximum negative peak deviation of carrier.

FETCh:WDDeviation:DEViation:SETTled:PPEak?

Function

Queries the positive peak deviation of carrier over the wideband data burst, not including any peak found during the first 20 milliseconds of the wideband data burst.

If the measurement gets more than one wideband data burst, it measures the first one.

Query

Range: 0 to 20 kHz, 9.91 E+37

Requirement

Test Application Revision: B.09 and above

Lab Application Revision: B.03 and above

Programming Example

OUTPUT 714;"FETCh:WDDeviation:DEViation:SETTLled:PPEak?"

FETCh:WDDeviation:DEViation:SETTled:NPEak?

Function

Queries the negative peak deviation of carrier over the wideband data burst, not including any peak found during the first 20 milliseconds of the wideband data burst.

If the measurement gets more than one wideband data burst, it measures the first one.

Query

Range: 0 to 20 kHz, 9.91 E+37

Requirement

Test Application Revision: B.09 and above

Lab Application Revision: B.03 and above

Programming Example

OUTPUT 714;"FETCh:WDDeviation:DEViation:SETTLED:NPEak?"

FETCh:WDDeviation:INTegrity?

Function

Queries the measurement integrity indicator for the last Wideband Data Deviation measurement completed.

Zero indicates a normal measurement. See Integrity Indicator for information about non-zero integrity results.

Query

Range: 0 to 25

Requirement

Test Application Revision: B.09 and above

Lab Application Revision: B.03 and above

Programming Example

OUTPUT 714;"FETCh:WDDeviation:INTegrity?"
!Query the integrity indicator for the wideband data deviation result.


FETCh:WQUality

FETCh:WQUality

Last updated: June 7, 2007

GPIB Command Conventions

  • FETCh:WQUality[:ALL]?
  • FETCh:WQUality:ICOunt?
  • FETCh:WQUality:CDPower:PILot[:REVerse]?
  • FETCh:WQUality:CDPower:CCHannel:DEDicated[:REVerse]?
  • FETCh:WQUality:CDPower:FCHannel[:REVerse]?
  • FETCh:WQUality:CDPower:SCHannel1[:REVerse]?
  • FETCh:WQUality:CDPower:SCHannel2[:REVerse]?
  • FETCh:WQUality:CDPower:IQINactive[:FAIL]?
  • FETCh:WQUality:CDPower:ICHannel[:ALL]?
  • FETCh:WQUality:CDPower:ICHannel:BIN? <bin num>
  • FETCh:WQUality:CDPower:ICHannel:COUNt[:BIN]?
  • FETCh:WQUality:CDPower:QCHannel[:ALL]?
  • FETCh:WQUality:CDPower:QCHannel:BIN? <bin num>
  • FETCh:WQUality:CDPower:QCHannel:COUNt[:BIN]?
  • FETCh:WQUality:CDPNoise:IQNoise[:FAIL]?
  • FETCh:WQUality:CDPNoise:ICHannel[:ALL]?
  • FETCh:WQUality:CDPNoise:ICHannel:BIN? <bin num>
  • FETCh:WQUality:CDPNoise:ICHannel:COUNt[:BIN]?
  • FETCh:WQUality:CDPNoise:QCHannel[:ALL]?
  • FETCh:WQUality:CDPNoise:QCHannel:BIN? <bin num>
  • FETCh:WQUality:CDPNoise:QCHannel:COUNt[:BIN]?

FETCh:WQUality[:ALL]?

Function

Queries the waveform quality/code domain power measurements.

Measurement results are returned in the following order: integrity, rho, frequency error, time error, carrier feedthrough, phase error, magnitude error, and error vector magnitude (EVM).

If the multi-measurement state is on, each result represents the average of a number of waveform quality/code domain power measurements. Multi-measurement state, by default, is off. To set up multi-measurements, see SETup:WQUality:COUNt[:SNUMber] .

Query

Integrity

  • Range: 0 to 16

  • Resolution: 1

Rho

  • Range: 0.000 to 1.000, 9.91 E+37

  • Resolution: 0.001

Frequency Error

  • Range: -9999.0 to 9999.0 Hz, 9.91 E+37

  • Resolution: 0.1 Hz

Time Error

  • Range: -99.99 E-6 to 99.99 E-6 s, 9.91 E+37

  • Resolution: 0.01 E-6 s

Carrier Feedthrough

  • Range: -100 to 0.0 dB, 9.91 E+37

  • Resolution: 0.1

Phase Error

  • Range: 0.00 to 359.99 degrees

  • Resolution: 0.01

Magnitude Error

  • Range: 0 to 100%, 9.91 E+37

  • Resolution: 0.01

Error Vector Magnitude (EVM)

  • Range: 0 to 100%

  • Resolution: 0.01%

Programming Example

OUTPUT 714;"FETCH:WQUALITY:ALL?"
!Returns integrity, rho, frequency error, time error, carrier feedthrough, phase error,
!magnitude error, EVM.

FETCh:WQUality:ICOunt?

Function

Queries the intermediate count of measurements completed in a multi-measurement.

Query

Range: 0 to 999

Programming Example

OUTPUT 714;"FETCH:WQUALITY:ICOUNT?"

FETCh:WQUality:CDPower:PILot[:REVerse]?

Function

This command provides a method for obtaining reverse pilot channel only code domain power, without the need for specifying a bin number.

This query returns 6 comma separated values.

See Obtaining code channel information programmatically by code channel name for more information.

Query

Range:

I channel or Q channel: 0=I, 1=Q; 9.91 E +37
Walsh code: 0 to 15; 9.91 E+37
Spread Factor: 2, 4, 8, 16; 9.91 E+37
Code Domain Power (spread factor 16)
Total Code Domain Power (summation of spread factor 16 code domain power measurements useful for reverse supplemental channels at higher data rates): 0.0 to -40.0; 9.91 E+37
Total Code Domain Power Relative to Reverse Pilot (relative to total reverse channel pilot): +15 to -8; 9.91 E+37

Programming Example

OUTPUT 714;"FETCH:WQUALITY:CDPOWER:PILOT?" Queries the reverse pilot code domain power information.

FETCh:WQUality:CDPower:CCHannel:DEDicated[:REVerse]?

Function

This command provides a direct method for obtaining reverse dedicated control channel only code domain power and code domain power relative to the reverse pilot channel, without the need for specifying a bin number.

This query returns 6 comma separated values.

See Obtaining code channel information programmatically by code channel name for more information.

Query

Range:

I channel or Q channel: 0=I, 1=Q; 9.91 E +37
Walsh code: 0 to 15; 9.91 E+37
Spread Factor: 2, 4, 8, 16; 9.91 E+37
Code Domain Power (spread factor 16)
Total Code Domain Power (summation of spread factor 16 code domain power measurements useful for reverse supplemental channels at higher data rates): 0.0 to -40.0; 9.91 E+37
Total Code Domain Power Relative to Reverse Pilot (relative to total reverse channel pilot): +15 to -8; 9.91 E+37

Programming Example

OUTPUT 714;"FETCH:WQUALITY:CDPOWER:CCHANNEL:DEDICATED:?" Queries the reverse dedicated control channel code domain power information.

FETCh:WQUality:CDPower:FCHannel[:REVerse]?

Function

This command provides a direct method for obtaining reverse fundamental channel only code domain power and code domain power relative to the reverse pilot channel, without the need for specifying a bin number.

This query returns 6 comma separated values.

See Obtaining code channel information programmatically by code channel name for more information.

Query

Range:

I channel or Q channel: 0=I, 1=Q; 9.91 E +37
Walsh code: 0 to 15; 9.91 E+37
Spread Factor: 2, 4, 8, 16; 9.91 E+37
Code Domain Power (spread factor 16)
Total Code Domain Power (summation of spread factor 16 code domain power measurements useful for reverse supplemental channels at higher data rates): 0.0 to -40.0; 9.91 E+37
Total Code Domain Power Relative to Reverse Pilot (relative to total reverse channel pilot): +15 to -8; 9.91 E+37

Programming Example

OUTPUT 714;"FETCH:WQUALITY:CDPOWER:FCHANNEL?" Queries the reverse fundamental channel code domain power information.

FETCh:WQUality:CDPower:SCHannel1[:REVerse]?

Function

This command provides a direct method for obtaining reverse supplemental channel one only total code domain power and total code domain power relative to the reverse pilot channel, without the need for specifying a bin number.

This query returns 6 comma separated values.

See Obtaining code channel information programmatically by code channel name for more information.

Query

Range:

I channel or Q channel: 0=I, 1=Q; 9.91 E +37
Walsh code: 0 to 15; 9.91 E+37
Spread Factor: 2, 4, 8, 16; 9.91 E+37
Code Domain Power (spread factor 16)
Total Code Domain Power (summation of spread factor 16 code domain power measurements useful for reverse supplemental channels at higher data rates): 0.0 to -40.0; 9.91 E+37
Total Code Domain Power Relative to Reverse Pilot (relative to total reverse channel pilot): +15 to -8; 9.91 E+37

Programming Example

OUTPUT 714;"FETCH:WQUALITY:CDPOWER:SCHANNEL1?" Queries the reverse supplemental channel code domain power information.

FETCh:WQUality:CDPower:SCHannel2[:REVerse]?

Function

This command provides a direct method for obtaining reverse supplemental channel two only total code domain power and total code domain power relative to the reverse pilot channel, without the need for specifying a bin number.

This query returns 6 comma separated values.

See Obtaining code channel information programmatically by code channel name for more information.

Query

Range:

I channel or Q channel: 0=I, 1=Q; 9.91 E +37
Walsh code: 0 to 15; 9.91 E+37
Spread Factor: 2, 4, 8, 16; 9.91 E+37
Code Domain Power (spread factor 16)
Total Code Domain Power (summation of spread factor 16 code domain power measurements useful for reverse supplemental channels at higher data rates): 0.0 to -40.0; 9.91 E+37
Total Code Domain Power Relative to Reverse Pilot (relative to total reverse channel pilot): +15 to -8; 9.91 E+37

Programming Example

OUTPUT 714;"FETCH:WQUALITY:CDPOWER:SCHANNEL2?" Queries the reverse supplemental channel code domain power information.

FETCh:WQUality:CDPower:IQINactive[:FAIL]?

Function

Queries the code domain power measurement's pass/fail result indicating whether the
power level in the inactive code channels exceeded the level set using the SETup:WQUality:CDPower:IQINactive[:LIMit] command.

Query

Range: 0|1, 9.91 E+37

0 = passed, 1 = failed, 9.91 E+37 = undefined

Programming Example

OUTPUT 714;"FETCH:WQUALITY:CDPOWER:IQINACTIVE:FAIL?"

FETCh:WQUality:CDPower:ICHannel[:ALL]?

Function

Queries the I-channel code domain power measurement results for up to 16 measurement graph bins (bars).

This query returns a string consisting of 64 comma-separated values. These represent 4 values for each of 16 bins (maximum). See Bin Numbering System for more information.

Since measurements will commonly have no more than 16 bins, higher numbered bins frequently return 9.91 E+37 (NAN) results.

Query

"FETCh:WQUality:CDPower:ICHannel:ALL?" returns: 1 (active) or 0 (inactive), Walsh code, spread factor, and power for bin 0. The integer value following power for bin 0 will be the beginning of bin 1; 1 (active) or 0 (inactive), Walsh code, spread factor, and power for bin 1. This pattern will repeat until the values for the last bin (bin 15) have been returned.

Programming Example

OUTPUT 714;"FETCH:WQUALITY:CDPOWER:ICHANNEL:ALL?"

FETCh:WQUality:CDPower:ICHannel:BIN? <bin num>

Function

Queries the measurement results for a specific bin (bar) on the I-channel code domain power graph. Bins are numbered beginning with 0 on the left and ending with the last bar on the right side of the graph. See Bin Numbering System for more information.

To determine the current total number of bins, which will provide the range of <bin num>, use the FETCh:WQUality:CDPower:ICHannel:COUNt[:BIN]? command.
Setting <bin num> range: 0 to 15

Query

Returns a string of 4 comma separated values for the specified bin: 1 (active) or 0 (inactive), Walsh code, spread factor, and power.

Programming Example

OUTPUT 714;"FETCH:WQUALITY:CDPOWER:ICHANNEL:BIN? 13"

!Queries the I-channel code domain power level in bin 13.

FETCh:WQUality:CDPower:ICHannel:COUNt[:BIN]?

Function

This query indicates how many bins on the I-channel code domain power graph contain measurement data. For example, if 13 is returned, bins 0 through 12 contain measurement data and bins 13 through 15 contain 9.91 E+37 results.

Query

Range: 0 to 16

Programming Example

OUTPUT 714;"FETCH:WQUALITY:CDPOWER:ICHANNEL:COUNT:BIN?"

FETCh:WQUality:CDPower:QCHannel[:ALL]?

Function

Queries the Q-channel code domain power measurement results for up to 16 measurement graph bins (bars).

This query returns a string consisting of 64 comma-separated values. These represent 4 values for each of 16 bins (maximum). See Bin Numbering System for more information.

Since measurements will commonly have no more than 16 bins, higher numbered bins frequently return 9.91 E+37 (NAN) results.

Query

"FETCh:WQUality:CDPower:QCHannel:ALL?" returns: 1 (active) or 0 (inactive), Walsh code, spread factor, and power for bin 0. The integer value following power for bin 0 will be the beginning of bin 1; 1 (active) or 0 (inactive), Walsh code, spread factor, power for bin 1. This pattern will repeat until the values for the last bin (bin 15) have been returned.

Programming Example

OUTPUT 714;"FETCH:WQUALITY:CDPOWER:QCHANNEL:ALL?"

FETCh:WQUality:CDPower:QCHannel:BIN? <bin num>

Function

Queries the measurement results for a specific bin (bar) on the Q-channel code domain power graph. Bins are numbered beginning with 0 on the left and ending with the last bar on the right side of the graph. See Bin Numbering System for more information.

To determine the current total number of bins, which will provide the range of <bin num>, use the FETCh:WQUality:CDPower:QCHannel:COUNt[:BIN]? command.

Query

Returns a string of 4 comma separated values for the specified bin: 1 (active) or 0 (inactive), Walsh code, spread factor, and power.

Programming Example

OUTPUT 714;"FETCH:WQUALITY:CDPOWER:QCHANNEL:BIN? 13"

!Queries the Q-channel power in bin 13.

FETCh:WQUality:CDPower:QCHannel:COUNt[:BIN]?

Function

This query indicates how many bins on the Q-channel code domain power graph contain measurement data. For example, if 13 is returned, bins 0 through 12 contain measurement data and bins 13 through 15 contain 9.91 E+37 results.

Query

Range: 0 to 16

Programming Example

OUTPUT 714;"FETCH:WQUALITY:CDPOWER:QCHANNEL:COUNT:BIN?"

FETCh:WQUality:CDPNoise:IQNoise[:FAIL]?

Function

Queries the code domain power + noise measurement pass/fail indicator indicating whether the
noise power level exceeded the level set using the SETup:WQUality:CDPNoise:IQNoise[:LIMit] command.

0 = passed, 1 = failed, 9.91 E+37 = undefined

Query

Range: 0|1|9.91 E+37

Programming Example

OUTPUT 714;"FETCH:WQUALITY:CDPNOISE:IQNOISE:FAIL?"

FETCh:WQUality:CDPNoise:ICHannel[:ALL]?

Function

Queries the I-channel code domain power + noise measurement results for up to 16 measurement graph bins (bars).

This query returns a string consisting of 64 comma-separated values. These represent 4 values for each of 16 bins (maximum). See Bin Numbering System for more information.

Since measurements will commonly have no more than 16 bins, higher numbered bins frequently return 9.91 E+37 (NAN) results.

Query

"FETCh:WQUality:CDPNoise:ICHannel:ALL?" returns: Walsh code, spread factor, noise power, and power for bin 0. The integer value following power for bin 0 will be the beginning of bin 1; Walsh code, spread factor, noise power, and power for bin 1. This pattern will repeat until the values for the last bin (bin 15) have been returned.

Programming Example

OUTPUT 714;"FETCH:WQUALITY:CDPNOISE:ICHANNEL:ALL?"

FETCh:WQUality:CDPNoise:ICHannel:BIN? <bin num>

Function

Queries the measurement results for a specific bin (bar) on the I-channel code domain power +noise graph. Bins are numbered beginning with 0 on the left and ending with the last bar on the right side of the graph. See Bin Numbering System for more information.

To determine the current total number of bins, which will provide the range of <bin num>, use the FETCh:WQUality:CDPNoise:ICHannel:COUNt[:BIN]? command.

Query

Returns a string of 4 comma separated values for the specified bin: Walsh code, spread factor, noise power, and power.

Programming Example

OUTPUT 714;"FETCH:WQUALITY:CDPNOISE:ICHANNEL:BIN? 13"

!Queries the I-channel code domain power + noise measurement results for bin 13.

FETCh:WQUality:CDPNoise:ICHannel:COUNt[:BIN]?

Function

This query indicates how many bins on the I-channel code domain power + noise graph contain measurement data. For example, if 13 is returned, bins 0 through 12 contain measurement data and bins 13 through 15 contain 9.91 E+37 results.

Query

Range: 0 to 16

Programming Example

OUTPUT 714;"FETCH:WQUALITY:CDPNOISE:ICHANNEL:COUNT:BIN?"

FETCh:WQUality:CDPNoise:QCHannel[:ALL]?

Function

Queries the Q-channel code domain power +noise measurement results for up to 16 measurement graph bins (bars).

This query returns 64 comma-separated values. These represent 4 values for each of 16 bins (maximum). See Bin Numbering System for more information.

Since measurements will commonly have no more than 16 bins, higher numbered bins frequently return 9.91 E+37 (NAN) results.

Query

"FETCh:WQUality:CDPNoise:QCHannel:ALL?" returns: Walsh code, spread factor, noise power, and power for bin 0. The integer value following power for bin 0 will be the beginning of bin 1; Walsh code, spread factor, noise power, and power for bin 1. This pattern will repeat until the values for the last bin (bin 15) have been returned.

Programming Example

OUTPUT 714;"FETCH:WQUALITY:CDPNOISE:QCHANNEL:ALL?"

FETCh:WQUality:CDPNoise:QCHannel:BIN? <bin num>

Function

Queries the measurement results for a specific bin (bar) on the Q-channel code domain power +noise graph. Bins are numbered beginning with 0 on the left and ending with the last bar on the right side of the graph. See Bin Numbering System for more information.

To determine the current total number of bins, which will provide the range of <bin num>, use the FETCh:WQUality:CDPNoise:QCHannel:COUNt[:BIN]? command.

Query

Returns a string of 4 comma separated values for the specified bin: Walsh code, spread factor, noise power, and power.

Programming Example

OUTPUT 714;"FETCH:WQUALITY:CDPNOISE:QCHANNEL:BIN? 13"

!Queries the Q-channel power in bin 13.

FETCh:WQUality:CDPNoise:QCHannel:COUNt[:BIN]?

Function

This query indicates how many bins on the Q-channel code domain power + noise graph contain measurement data. For example, if 13 is returned, bins 0 through 12 contain measurement data and bins 13 through 15 contain 9.91 E+37 results.

Query

Range: 0 to 16

Programming Example

OUTPUT 714;"FETCH:WQUALITY:CDPNOISE:QCHANNEL:COUNT:BIN?"


INITiate

INITiate

Last updated: June 8, 2007

GPIB Command Conventions

  • INITiate<:measurement mnemonic>[:ON]
  • INITiate<:measurement mnemonic>:OFF
  • INITiate:CFDTune:ARMed?
  • INITiate:COUNt?
  • INITiate:DONE?
  • INITiate:DONE:CLEar
  • INITiate:DONE:FLAG[:ALL]
  • INITiate:DONE:FLAG<:measurement mnemonic>
  • INITiate:ON?

INITiate<:measurement mnemonic>[:ON]

Function

These commands initiate (start) the specified measurements:

  • AFANalyzer - Audio Frequency Analyzer measurement

  • ATXPower - Analog Transmitter Power

  • CAPPower - Access Probe Power measurement

  • CCTPhase - Code Channel Time / Phase error measurement

  • CFDTune - Fast Device Tune measurement

  • CFERror - Frame Error Rate measurement

  • CMAudio - Multi-Tone Audio measurement

  • CMMPower - Maximum/Minimum Power measurement

  • CPOWer - Channel Power measurement

  • CTDPower - TX Dynamic Power measurement

  • CTXSpurious - TX Spurious Emissions measurement

  • DAPower - Digital Average Power measurement

  • DTMF - Dual Tone Multi-Frequency measurement

  • FM - Frequency Modulation measurement

  • FSTability - Frequency Stability measurement

  • GAPPower - Graphical Access Probe Power measurement (only applicable to the lab application)

  • GPOWer - Gated Power measurement

  • HWQuality - Handoff Waveform Quality measurement

  • SAUDio - Swept Audio measurement

  • SMONitor - Spectrum Monitor measurement

  • STONe - Signaling Tone measurement

  • TFERror - TDSO Frame Error Rate measurement

  • TROPower - Time Response of Open Loop Power Control measurement

  • WDDeviation - Wideband Data Deviation measurement

  • WQUality - Waveform Quality measurement

The INITiate command is associated with the SETup command, and the FETCh? command, see SETup Subsystem and FETCh? Subsystem .

One or more measurements can be initiated with the same program line (see Concurrent Measurements and the Programming Example below).

This command is also used to activate a measurement. See INITiate Programming Examples (how INIT commands are used) .

Requirement

Test Application Revision: B.07.15 and above added CMMPower and CTDPower
Lab Application Revision: B.01.16 and above added CMMPower and CTDPower

Test Application Revision: B.08 and above added CMAudio
Lab Application Revision: B.02 and above added CMAudio

Test Application Revision: B.09 and above added DTMF, STONe and WDDeviatoin
Lab Application Revision: B.03 and above added DTMF, STONe and WDDeviatoin

Test Application Revision: B.11 and above added CFDT
Lab Application Revision: B.04 and above added CFDT

Programming Example

OUTPUT 714;"INITiate:CPOWer;WQUality"
!Initiates a channel power and a waveform quality measurement.

INITiate<:measurement mnemonic>:OFF

Function

Deactivates the selected measurement. See INITiate<:measurement mnemonic>[:ON] for a list of measurements.

Only one measurement can be deactivated at a time. To stop one or more measurements and leave them in the active state, use ABORt . See Measurement States for details.

Requirement

Test Application Revision: B.07.15 and above added CMMPower and CTDPower
Lab Application Revision: B.01.16 and above added CMMPower and CTDPower

Test Application Revision: B.08 and above added CMAudio
Lab Application Revision: B.02 and above added CMAudio

Test Application Revision: B.09 and above added DTMF, STONe and WDDeviatoin
Lab Application Revision: B.03 and above added DTMF, STONe and WDDeviatoin

Programming Example

OUTPUT 714;"INITiate:CPOWer:OFF"
!Deactivates the channel power measurement.

INITiate:CFDTune:ARMed?

Function

 Queries the arm state of the fast device tune measurement. This command returns a one if the fast device tune measurement is successfully initiated, the MS Tx and Rx Freqency/Power Series is successfully built and the test set is ready for receiving an RF rise trigger from the AT. Otherwise, a zero is returned.

Query

Range: 1 | 0

Requirement

Test Application Revision: B.11 and above.
Lab Application Revision: B.04 and above.

Programming Example

OUTPUT 714;"INITiate:CFDT:ARMed?"
!Queries

INITiate:COUNt?

Function

Queries the number of measurements that have been initiated (are active). See Measurement States .

Query

Range: 0 to 10

Programming Example

OUTPUT 714;"INITiate:COUNt?"
!Queries the number of currently active measurements.

INITiate:DONE?

Function

Queries (one at a time) which measurements, if any, are finished or have timed-out.

See Measurement Event Synchronization for how to use this command.

See Measurement States to understand the test set's measurement states.

See INITiate:DONE:FLAG<:measurement mnemonic> for include or exclude commands.
Query

Range:

  • AFAN - Audio Frequency Analyzer measurement

  • ATXP - Analog Transmitter Power

  • CAPP - Access Probe Power measurement

  • CCTP - Code Channel Time/Phase error measurement

  • CFDT - Fast Device Tune measurement

  • CFER - Frame Error Rate measurement

  • CMA - Multi-Tone Audio measurement

  • CMMP - Maximum/Minimum Power measurement

  • CPOW - Channel Power measurement

  • CTDP - TX Dynamic Power measurement

  • CTXS - TX Spurious Emissions measurement

  • DAP - Digital Average Power measurement

  • DTMF - Dual Tone Multi-Frequency measurement

  • FM - Frequency Modulation measurement

  • FST - Frequency Stability measurement

  • GAPP - Graphical Access Probe Power measurement (only applicable to the lab application)

  • GPOW - Gated Power measurement

  • HWQ - Handoff Waveform Quality measurement

  • SAUD - Swept Audio measurement

  • SMON - Spectrum Monitor measurement

  • STON - Signaling Tone measurement

  • TFER - TDSO Frame Error Rate measurement

  • TROP - Time Response of Open Loop Power Control measurement

  • WDDeviation - Wideband Data Deviation measurement

  • WQU - Waveform Quality measurement

  • NONE - there are no measurements in the measuring state.

  • WAIT - there are one or more measurements in the measuring state, and none are ready to be fetched.

Requirement

Test Application Revision: B.07.15 and above added CMMPower and CTDPower
Lab Application Revision: B.01.16 and above added CMMPower and CTDPower

Test Application Revision: B.08 and above added CMAudio
Lab Application Revision: B.02 and above added CMAudio

Test Application Revision: B.09 and above added DTMF, STONe and WDDeviatoin
Lab Application Revision: B.03 and above added DTMF, STONe and WDDeviatoin

INITiate:DONE:CLEar

Function

Clears the done flag from all measurements. See INITiate:DONE? and INITiate:DONE:FLAG[:ALL] .

Requirement

Test Application Revision: B.07.15 and above added CMMPower and CTDPower
Lab Application Revision: B.01.16 and above added CMMPower and CTDPower

Test Application Revision: B.08 and above added CMAudio
Lab Application Revision: B.02 and above added CMAudio

Test Application Revision: B.09 and above added DTMF, STONe and WDDeviatoin
Lab Application Revision: B.03 and above added DTMF, STONe and WDDeviatoin

Programming Example

OUTPUT 714;"INITiate:DONE:CLEar" !Clears the done flag.

INITiate:DONE:FLAG[:ALL]

Function

Specifies that all measurements are either included or excluded when the INITitate:DONE? query is sent.

If a measurement trigger arm is left in continuous mode, the done flag for that measurement will toggle between DONE and WAIT. The INITiate:DONE? query will probably not be able to catch the measurement at the instant it is done; therefore, the measurement will never appear to be done. If a measurement's triggering must be continuously armed, you should exclude the measurement using INITiate:DONE:FLAG<:measurement mnemonic> .

Use INITitate:DONE:FLAG:ALL EXCLude to exclude all measurements.

Once INITiate:DONE:FLAG has been set to EXCLude for a measurement, the user must send the INCLude command for that measurement in order to query that measurement with the INITiate:DONE? query. The test set will not reset any excluded measurement with any type of preset.

Setting

Range: INCLude|EXCLude
*RST Setting

INCLude

Requirement

Test Application Revision: B.07.15 and above added CMMPower and CTDPower
Lab Application Revision: B.01.16 and above added CMMPower and CTDPower

Test Application Revision: B.08 and above added CMAudio
Lab Application Revision: B.02 and above added CMAudio

Test Application Revision: B.09 and above added DTMF, STONe and WDDeviatoin
Lab Application Revision: B.03 and above added DTMF, STONe and WDDeviatoin

Programming Example

OUTPUT 714;"INITiate:DONE:FLAG INCLude"
!Includes all measurements in the INITiate:DONE? query.

INITiate:DONE:FLAG<:measurement mnemonic>

Function

Specifies if a measurement done flag is considered (using the INCLude or EXCLude settings) when the INITiate:DONE? query is sent. See INITiate<:measurement mnemonic>[:ON] for a list of measurment mnemonics.

If more than one measurement is active, and one or more measurement trigger arm states is continuous, the INITiate:DONE? query may not be effective. The best solution is to change the arm state of all measurements to single using the SETup[:ALL]:CONTinuous<:OFF|:ON> command. However, if a measurement must be continuously triggered, you should exclude the measurement using the EXCLude setting provided by this command if you want to use INITiate:DONE? to query measurement done status.

The test set will not reset any excluded measurement to included with any type of preset.

Setting

Range: INCLude|EXCLude

Query

Range: INCL|EXCL

Requirement

Test Application Revision: B.07.15 and above added CMMPower and CTDPower
Lab Application Revision: B.01.16 and above added CMMPower and CTDPower

Test Application Revision: B.08 and above added CMAudio
Lab Application Revision: B.02 and above added CMAudio

Test Application Revision: B.09 and above added DTMF, STONe and WDDeviatoin
Lab Application Revision: B.03 and above added DTMF, STONe and WDDeviatoin

Test Application Revision: B.11 and above added CFDT
Lab Application Revision: B.04 and above added CFDT

Programming Example

OUTPUT 714;"INITIATE:DONE:FLAG:DAP EXCLUDE"
!Excludes the digital average power measurement from responding to the INITiate:DONE? query.

INITiate:ON?

Function

Queries the measurements that are on. Returns a comma separated list of measurement mnemonics.

Query

Range:

  • AFAN - Audio Frequency Analyzer measurement

  • ATXP - Analog Transmitter Power

  • CAPP - Access Probe Power measurement

  • CCTP - Code Channel Time/Phase error measurement

  • CFDT - Fast Device Tune measurement

  • CFER - Frame Error Rate measurement

  • CMA - Multi-Tone Audio measurement

  • CMMP - Maximum/Minimum Power measurement

  • CPOW - Channel Power measurement

  • CTDP - TX Dynamic Power measurement

  • CTXS - TX Spurious Emissions measurement

  • CTDP - TX Dynamic Power measurement

  • DAP - Digital Average Power measurement

  • DTMF - Dual Tone Multi-Frequency measurement

  • FM - Frequency Modulation measurement

  • FST - Frequency Stability measurement

  • GAPP - Graphical Access Probe Power measurement (only applicable to the lab application)

  • GPOW - Gated Power measurement

  • HWQ - Handoff Waveform Quality measurement

  • SAUD - Swept Audio measurement

  • SMON - Spectrum Monitor measurement

  • STON - Signaling Tone measurement

  • TFER - TDSO Frame Error Rate measurement

  • TROP - Time Response of Open Loop Power Control measurement

  • WDDeviation - Wideband Data Deviation measurement

  • WQU - Waveform Quality measurement

  • NONE - no measurements are on

Requirement

Test Application Revision: B.07.15 and above added CMMPower and CTDPower
Lab Application Revision: B.01.16 and above added CMMPower and CTDPower

Test Application Revision: B.08 and above added CMAudio
Lab Application Revision: B.02 and above added CMAudio

Test Application Revision: B.09 and above added DTMF, STONe and WDDeviatoin
Lab Application Revision: B.03 and above added DTMF, STONe and WDDeviatoin

Programming Example

OUTPUT 714;"INITiate:ON?" !Queries which measurements are on.


INITiate Subsystem

INITiate Subsystem

Last updated: October 28, 2004

Syntax Diagrams and Command Descriptions

INITiate

Description

INITiate Command Functions

The INITiate subsystem is used to:

  • Start (activate) individual or multiple (concurrent) measurements.

  • Turn individual measurements off.

  • Determine the number of measurements currently active (INIT:COUNT?).

  • Determine the names of the measurements currently active (INIT:ON?).

  • Determine which measurements are finished (INIT:DONE?).

What Happens When a Measurement is INITiated?

When a measurement is started using INITiate commands, a new measurement cycle is started. If the selected measurement is currently in a measurement cycle, it is aborted. If a timeout is specified, the timeout period begins when a measurement is initiated.

NOTE
The INITiate subsystem is derived from SCPI, but has some modifications to make it more compatible with the manual operation of the test set. Most notably, the choice of single or continuous measurement triggering is made using the SETup subsystem.

INITiate Programming Examples (how INIT commands are used)

The INITiate command is used to start measurements.

INITiate commands allow multiple measurements to be started without waiting for other measurement processes to complete. For example, the following program example starts the Digital Average Power and Waveform Quality measurements, and then uses the INITiate:DONE? command in a loop to query the completion status of these measurements. See Measurement Event Synchronization .

As each measurements completed, the FETCh command can be used to acquire the results, and the results entered into variables in the controlling application.

This program ends when the INITiate:DONE? command returns the string "NONE" indicating that all initiated measurements have gone through the measuring state. See Measurement States .

NOTE
The INIT:DONE? command is only useful when performing concurrent testing. When initiating only one measurement at a time, simply send the INITiate command immediately followed by the FETCh command to retrieve the results.

NOTE
Trigger arming for each measurement is controlled in the SETup subsystem. The choices are single or continuous. The best practice (during remote operation) is to use single measurement mode. This simplifies the tasks of starting concurrent measurements, then using the INIT subsystem commands to determine which measurements are ready to be FETChed.

10       OUTPUT 714;"SETup:ALL:CONTinuous:OFF"
20       ! select single trigger mode for all measurements.
30       OUTPUT 714;"INITiate:DAPower;WQUality"
40       ! start digital average power and waveform quality measurements.
50       LOOP
60           OUTPUT 714;"INITiate:DONE?"
70           ! query to find out if any measurements are done.
80           ENTER 714;Meas_complete$
90           SELECT Meas_complete$
100           CASE "DAP"
110           ! test for the string "DAP" indicating
120           ! digital average power measurement is done.
130               OUTPUT 714;"FETCh:DAPower:POWer?"
140               ! query digital average power measurement.
150               ENTER 714;Dapower
160           CASE "WQU"
170           ! test for the string "WQU" indicating
180           ! that the waveform quality measurement is done.
190               OUTPUT 714;"FETCh:WQU:RHO?"
200               ! query rho.
210               ENTER 714;Rho
220           END SELECT
230       EXIT IF Meas_complete$="NONE"
240       END LOOP
250       PRINT Dapower
260       PRINT Rho
270 END


cdma2000/IS-95/AMPS Listing of Commands

cdma2000/IS-95/AMPS Listing of Commands

This section lists all of the available GPIB commands for the cdma2000/IS-95/AMPS applications.

It is recommended that you print this topic because it provides a useful syntax reference for all of the available cdma2000/IS-95/AMPS commands.

The GPIB commands in this topic are categorized by subsystem:

  • ABORt Subsystem
  • AFGenerator Subsystem
  • CALCulate Subsystem
  • CALibration Subsystem
  • CALL Subsystem
  • DISPlay Subsystem
  • FETCh Subsystem
  • INITiate Subsystem
  • READ Subsystem
  • RFANalyzer Subsystem
  • RFGenerator Subsystem
  • SETup Subsystem
  • STATus Subsystem
  • SYSTem Subsystem

ABORt Subsystem

  • ABORt[:ALL]
  • ABORt<:measurement mnemonic>

AFGenerator Subsystem

  • AFGenerator:COUPling
  • AFGenerator:FREQuency
  • AFGenerator:PULSe[:STATe]
  • AFGenerator:VOLTage[:SAMPlitude]
  • AFGenerator:VOLTage:AMPlitude
  • AFGenerator:VOLTage:STATe

CALCulate Subsystem

  • CALCulate:SMONitor:MARKer:ALL:STATe
  • CALCulate:SMONitor:MARKer[<n>] :AMPLitude?
  • CALCulate:SMONitor:MARKer[<n>]:FREQuency
  • CALCulate:SMONitor:MARKer[<n>] :MODE
  • CALCulate:SMONitor:MARKer:PEAK:EXCursion[:LEVel]
  • CALCulate:SMONitor:MARKer[<n>] :PEAK:MAXimum
  • CALCulate:SMONitor:MARKer:PEAK:THReshold[:LEVel]
  • CALCulate:SMONitor:MARKer[<n>] [:SET]:EXPected:POWer
  • CALCulate:SMONitor:MARKer[<n>] [:SET]:EXPected:FREQuency
  • CALCulate:SMONitor:MARKer[<n>]:STATe
  • CALCulate:SMONitor:MARKer[<n>]:TIME

CALibration Subsystem

  • CALibration:BMOFfset?
  • CALibration:CPOWer?
  • CALibration:DAPower?
  • CALibration:IQ[1]?
  • CALibration:IQ2?
  • CALibration:DATE
  • CALibration:SMONitor

CALL Subsystem

  • CALL:ACC[:CHANnel][:SELected]
  • CALL:ACC[:CHANnel]:CELLular
  • CALL[:CELL]:APARameter:POWer:INITial
  • CALL[:CELL]:APARameter:POWer:NOMinal[:OFFset]
  • CALL[:CELL]:APARameter:POWer:NOMinal:EXTended
  • CALL[:CELL]:APARameter:POWer:STEP[:LEVel]
  • CALL[:CELL]:APARameter:POWer:STEP:COUNt
  • CALL[:CELL]:APARameter:PREamble
  • CALL[:CELL]:APARameter:SEQuence:REQuest[:MAXimum]
  • CALL[:CELL]:APARameter:SEQuence:RESPonse[:MAXimum]
  • CALL:AVCTest:AVC:SATone:STATe
  • CALL:AWGNoise[:INTernal]:POWer[:SAMPlitude]<[:SELected]|:DIGital2000|:DIGital95>
  • CALL:AWGNoise[:INTernal]:POWer:AMPLitude<[:SELected]|:DIGital2000|:DIGital95>
  • CALL:AWGNoise[:INTernal]:POWer:STATe<[:SELected]|:DIGital2000|:DIGital95>
  • CALL[:CELL]:BAND<[:SELected]|:DIGital2000|:DIGital95>
  • CALL[:CELL]:BCCHannel[:SLEVel]<[:SELected]|:DIGital2000>
  • CALL[:CELL]:BCCHannel:DRATe
  • CALL[:CELL]:BCCHannel:LEVel<[:SELected]|:DIGital2000>
  • CALL[:CELL]:BCCHannel:STATe<[:SELected]|:DIGital2000>
  • CALL[:CELL]:BIDentity
  • CALL[:CELL]:CCCHannel[:SLEVel]<[:SELected]|:DIGital2000>
  • CALL[:CELL]:CCCHannel:DRATe
  • CALL[:CELL]:CCCHannel:LEVel<[:SELected]|:DIGital2000>
  • CALL[:CELL]:CCCHannel:STATe<[:SELected]|:DIGital2000>
  • CALL:CCHannel:AUDit:STATe
  • CALL:CELL2:CLPControl:REVerse:MODE
  • CALL:CELL2:DELay
  • CALL:CELL2:FCHannel[:SLEVel][:SELected]
  • CALL:CELL2:FCHannel:LEVel[:SELected]
  • CALL:CELL2:FCHannel:STATe[:SELected]
  • CALL:CELL2:FCHannel:WALSh
  • CALL:CELL2:OCNSource:LEVel[:SELected]?
  • CALL:CELL2:OCNSource:STATe[:SELected]?
  • CALL:CELL2:OCNSource:WALSh[:SELected]
  • CALL:CELL2:PILOT[:SLEVel][:SELected]
  • CALL:CELL2:PILOT:LEVel[:SELected]
  • CALL:CELL2:PILOT:STATe[:SELected]
  • CALL:CELL2:PNOFfest
  • CALL:CELL2:POWer[:SAMPlitude][:SELected]
  • CALL:CELL2:POWer:AMPLitude[:SELected]
  • CALL:CELL2:POWer:STATe[:SELected]
  • CALL:CELL2:TRAFfic[:SLEVel]<[:SELected]|DIGital95>
  • CALL:CELL2:TRAFfic:LEVel<[:SELected]|DIGital95>
  • CALL:CELL2:TRAFfic:STATe<[:SELected]|DIGital95>
  • CALL:CELL2:TRAFfic:WALSh
  • CALL:CHANnel[:SELected][:SELected]
  • CALL:CIDentity
  • CALL[:CELL[1]]:CLPControl:REVerse:MODE<[:SELected]|:TA2000>
  • CALL[:CELL[1]]:CLPControl:REVerse:TRANsient:MODE
  • CALL[:CELL[1]]:CLPControl:REVerse:TRANsient:SPRamp
  • CALL[:CELL[1]]:CLPControl:REVerse:TRANsient:STARt
  • CALL[:CELL]:CLPControl:REVerse:STEP
  • CALL:CONNected[:STATe]?
  • CALL:CONNected:ARM[:IMMediate]
  • CALL:CONNected:ARM:STATe?
  • CALL:CONNected:DROP:TIMer[:STATe]<[:SELected]|:TA2000>
  • CALL:CONNected:LIMit[:STATe]<[:SELected]|:TA2000>
  • CALL:CONNected:TIMeout
  • CALL[:CELL]:CONTrol:DOWNlink:FREQuency:AUTO
  • CALL:COUNt:CLEar:MS[:ALL]
  • CALL:COUNt:CLEar:MS:IP
  • CALL:COUNt:CLEar:MS:RLP
  • CALL:COUNt:MS:IP[:ALL]?
  • CALL:COUNt:MS:IP:RX?
  • CALL:COUNt:MS:IP:TX?
  • CALL:COUNt:MS:RLP:RX[:TOTal]?
  • CALL:COUNt:MS:RLP:RX:ACK?
  • CALL:COUNt:MS:RLP:RX:DATA:NEW?
  • CALL:COUNt:MS:RLP:RX:DATA:REXMitted?
  • CALL:COUNt:MS:RLP:RX:FILL?
  • CALL:COUNt:MS:RLP:RX:IDLE?
  • CALL:COUNt:MS:RLP:RX:NAK?
  • CALL:COUNt:MS:RLP:RX:NAKKed?
  • CALL:COUNt:MS:RLP:RX:SACK?
  • CALL:COUNt:MS:RLP:RX:SYNC?
  • CALL:COUNt:MS:RLP:TX[:TOTal]?
  • CALL:COUNt:MS:RLP:TX:ACK?
  • CALL:COUNt:MS:RLP:TX:DATA:NEW?
  • CALL:COUNt:MS:RLP:TX:DATA:REXMitted?
  • CALL:COUNt:MS:RLP:TX:ERRor?
  • CALL:COUNt:MS:RLP:TX:FILL?
  • CALL:COUNt:MS:RLP:TX:IDLE?
  • CALL:COUNt:MS:RLP:TX:NAK?
  • CALL:COUNt:MS:RLP:TX:NAKKed?
  • CALL:COUNt:MS:RLP:TX:SACK?
  • CALL:COUNt:MS:RLP:TX:SYNC?
  • CALL:COUNt:MS:RLP:TX:UNKNown?
  • CALL:COUNt:DTMonitor:CLEar
  • CALL:COUNt:DTMonitor<:OTATx|:OTARx|:IPTX|:IPRX>:DRATe?
  • CALL:COUNt:DTMonitor<:OTATx|:OTARx|:IPTX|:IPRX>:DISPlay:STATe
  • CALL:COUNt:DTMonitor<:OTATx|:OTARx|:IPTX|:IPRX>:TRACe?
  • CALL:COUNt:DTMonitor<:OTATx|:OTARx|:IPTX|:IPRX>:TRACe:HISTory:UNUMber?
  • CALL:COUNt:DTMonitor[:ALL]:TRACe:HISTory?
  • CALL:COUNt:DTMonitor[:ALL]:DISPlay:SPAN:TIME
  • CALL:COUNt:DTMonitor[:ALL]:DISPlay:DRATe<:STARt|:STOP>
  • CALL:CPNumber:INCLusion
  • CALL:CPNumber[1][:SELected]
  • CALL:CPNumber[1]:PLAN
  • CALL:CPNumber[1]:PRESentation[:INDicator]
  • CALL:CPNumber[1]:SCReening[:INDicator]
  • CALL:CPNumber[1]:TA2000
  • CALL:CPNumber[1]:TYPE
  • CALL:CPNumber2[:SELected]
  • CALL:CPNumber2:PLAN
  • CALL:CPNumber2:PRESentation[:INDicator]
  • CALL:CPNumber2:SCReening[:INDicator]
  • CALL:CPNumber2:TA2000
  • CALL:CPNumber2:TYPE
  • CALL[:CELL]:CSTime:DATE
  • CALL[:CELL]:CSTime:DSTime
  • CALL[:CELL]:CSTime:LOCal:LEAP
  • CALL[:CELL]:CSTime:LOCal:OFFSet:[SELected]
  • CALL[:CELL]:CSTime:LOCal:OFFSet:TA2000
  • CALL[:CELL]:CSTime:TIME
  • CALL:D2KTest:EIRPower[:MAXimum]
  • CALL:D2KTest:ESNumber:HEX
  • CALL:D2KTest:QPCHannel:INDicator[:PAGing]
  • CALL:DATA:PING[:ALL]?
  • CALL:DATA:PING:ICOunt?
  • CALL:DATA:PING:PACKets:RX?
  • CALL:DATA:PING:PACKets:TX?
  • CALL:DATA:PING:PLOSs?
  • CALL:DATA:PING:SETup:ALTernate:IP:ADDRess
  • CALL:DATA:PING:SETup:COUNt
  • CALL:DATA:PING:SETup:DEVice
  • CALL:DATA:PING:SETup:PACKet[:SIZE]
  • CALL:DATA:PING:SETup:TIMeout
  • CALL:DATA:PING:STARt
  • CALL:DATA:PING:STOP
  • CALL:DATA:PING:TIME[:AVERage]?
  • CALL:DATA:PING:TIME:MAXimum?
  • CALL:DATA:PING:TIME:MINimum?
  • CALL:DATA:PDSNode:EXTernal:IP:ADDRess
  • CALL:DATA:PDSNode:EXTernal:STATe
  • CALL:DATA:PDSNode:EXTernal:TCP:PORT
  • CALL:DATA:PDSNode:EXTernal:TIMeout[:CONNect]
  • CALL:DCONnected[:STATe]
  • CALL:DCONnected:ARM[:IMMediate]
  • CALL:DCONnected:ARM:STATe?
  • CALL:DCONnected:TIMeout
  • CALL:DORMant[:STATe]?
  • CALL:END
  • CALL[:CELL]:ESCape[:MODE]
  • CALL[:CELL[1]]:FCHannel[:FORWard][:SLEVel]<[:SELected]|DIGital2000>
  • CALL[:CELL[1]]:FCHannel[:FORWard]:LEVel<[:SELected]|DIGital2000>
  • CALL[:CELL[1]]:FCHannel[:FORWard]:STATe<[:SELected]|DIGital2000>
  • CALL[:CELL[1]]:FCHannel[:FORWard]:WALSh
  • CALL[:CELL[1]]:FCHannel[:FORWard]:SOURce
  • CALL[:CELL[1]]:FCHannel[:FORWard]:SOURce:ECHO
  • CALL[:CELL[1]]:FCHannel:REVerse:GATing
  • CALL:FM:EXTernal:STATe
  • CALL:FM:INTernal[:SDEViation]
  • CALL:FM:INTernal:DEViation
  • CALL:FM:INTernal:FREQuency
  • CALL:FM:INTernal:STATe
  • CALL[:CELL]:FPControl:EIBCount[:ALL]?
  • CALL[:CELL]:FPControl:EIBCount:CLEar
  • CALL[:CELL]:FPControl:EIBCount:STARt
  • CALL[:CELL]:FPControl:EIBCount:STOP
  • CALL[:CELL]:FPControl:FCHannel:FERate:TARGet
  • CALL[:CELL]:FPControl:FCHannel:LEVel:MAXimuml
  • CALL[:CELL]:FPControl:FCHannel:SETPoint:INITial
  • CALL[:CELL]:FPControl:FCHannel:SETPoint:MAXimum
  • CALL[:CELL]:FPControl:FCHannel:SETPoint:MINimum
  • CALL[:CELL]:FPControl:MODE
  • CALL[:CELL]:FPControl:OLReport:CLEar
  • CALL[:CELL]:FPControl:OLReport:FCHannel:SETPoint:CURRent?
  • CALL[:CELL]:FPControl:OLReport:REQuest
  • CALL[:CELL]:FPControl:STEP
  • CALL:FUNCtion:DATA:DORMant
  • CALL:HANDoff[:IMMediate]
  • CALL[:CELL]:MCCode<[:SELected]|:TA2000>
  • CALL[:CELL]:MEIDentifier:SUPPort[:ENABle]
  • CALL[:CELL]:MNCode
  • CALL:MS:ANALog:ALERt[:IMMediate]
  • CALL:MS:ANALog:ALERt:SEQuential
  • CALL:MS:ANALog:ALERt:WAIT
  • CALL:MS:ANALog:ALERt:DONE?
  • CALL:MS:ANALog:ALERt:OPComplete?
  • CALL:MS:ANALog:MAINtenance[:IMMediate]
  • CALL:MS:ANALog:MAINtenance:SEQuential
  • CALL:MS:ANALog:MAINtenance:WAIT
  • CALL:MS:ANALog:MAINtenance:DONE?
  • CALL:MS:ANALog:MAINtenance:OPComplete?
  • CALL:MS:ANALog:TXLevel[:IMMediate]
  • CALL:MS:FERate:REPort:BAD?
  • CALL:MS:FERate:REPort:CLEar
  • CALL:MS:FERate:REPort:DELay
  • CALL:MS:FERate:REPort:INTerval
  • CALL:MS:FERate:REPort:PERiod[:STATe]
  • CALL:MS:FERate:REPort:RATio?
  • CALL:MS:FERate:REPort:THReshold[:STATe]
  • CALL:MS:FERate:REPort:THReshold:BAD
  • CALL:MS:FERate:REPort:TOTal?
  • CALL:MS:IP:ADDRess
  • CALL:MS:REPorted:PILot:STRength:REQuest[:IMMediate]
  • CALL:MS:REPorted:PILot:STRength:REQuest:TIME?
  • CALL:MS:REPorted:PILot:STRength:REPort[:ALL]?
  • CALL:MS:REPorted:PILot:STRength:REPort:CLEar
  • CALL:MS:REPorted:CAPability:CCHannel:DEDicated[:SUPPort]?
  • CALL:MS:REPorted:CAPability:CCHannel:DEDicated:FRAMe[:SIZE]?
  • CALL:MS:REPorted:CAPability:CCHannel:DEDicated:FORWard:RCONfig?
  • CALL:MS:REPorted:CAPability:CCHannel:DEDicated:REVerse:RCONfig?
  • CALL:MS:REPorted:CAPability:FCHannel[:SUPPort]?
  • CALL:MS:REPorted:CAPability:FCHannel:FRAMe:MS5[:SUPPort]?
  • CALL:MS:REPorted:CAPability:FCHannel:FORWard:RCONfig?
  • CALL:MS:REPorted:CAPability:FCHannel:REVerse:RCONfig?
  • CALL:MS:REPorted:CAPability:QUERy
  • CALL:MS:REPorted:CAPability:SCHannel:FORWard[:SUPPort]?
  • CALL:MS:REPorted:CAPability:SCHannel:FORWard:CONVolution[:SUPPort]?
  • CALL:MS:REPorted:CAPability:SCHannel:FORWard:CONVolution:DRATe1[:MAXimum]?
  • CALL:MS:REPorted:CAPability:SCHannel:FORWard:CONVolution:DRATe2[:MAXimum]?
  • CALL:MS:REPorted:CAPability:SCHannel:FORWard:COUNt?
  • CALL:MS:REPorted:CAPability:SCHannel:FORWard:RCONfig?
  • CALL:MS:REPorted:CAPability:SCHannel:FORWard:TURBo[:SUPPort]?
  • CALL:MS:REPorted:CAPability:SCHannel:FORWard:TURBo:DRATe1[:MAXimum]?
  • CALL:MS:REPorted:CAPability:SCHannel:FORWard:TURBo:DRATe2[:MAXimum]?
  • CALL:MS:REPorted:CAPability:SCHannel:REVerse[:SUPPort]?
  • CALL:MS:REPorted:CAPability:SCHannel:REVerse:CONVolution[:SUPPort]?
  • CALL:MS:REPorted:CAPability:SCHannel:REVerse:CONVolution:DRATe1[:MAXimum]?
  • CALL:MS:REPorted:CAPability:SCHannel:REVerse:CONVolution:DRATe2[:MAXimum]?
  • CALL:MS:REPorted:CAPability:SCHannel:REVerse:COUNt?
  • CALL:MS:REPorted:CAPability:SCHannel:REVerse:RCONfig?
  • CALL:MS:REPorted:CAPability:SCHannel:REVerse:TURBo[:SUPPort]?
  • CALL:MS:REPorted:CAPability:SCHannel:REVerse:TURBo:DRATe1[:MAXimum]?
  • CALL:MS:REPorted:CAPability:SCHannel:REVerse:TURBo:DRATe2[:MAXimum]?
  • CALL:MS:REPorted:CLEar[:ALL]
  • CALL:MS:REPorted:CPCLass?
  • CALL:MS:REPorted:CTXType?
  • CALL:MS:REPorted:DUAL[:MODE]?
  • CALL:MS:REPorted:EIRPower[:MAXimum]?
  • CALL:MS:REPorted:EIRPower:DEFault
  • CALL:MS:REPorted:ESNumber[:DECimal]?
  • CALL:MS:REPorted:ESNumber:HEX?
  • CALL:MS:REPorted:MCCode?
  • CALL:MS:REPorted:MEIDentifier:[:DECimal]?
  • CALL:MS:REPorted:MEIDentifier:HEX?
  • CALL:MS:REPorted:MEIDentifier:QUERy
  • CALL:MS:REPorted:MEIDentifier:SUPPorted?
  • CALL:MS:REPorted:MIN1:HEX?
  • CALL:MS:REPorted:MIN2:HEX?
  • CALL:MS:REPorted:MNCode?
  • CALL:MS:REPorted:MSINumber?
  • CALL:MS:REPorted:ONUMber?
  • CALL:MS:REPorted:OPERating:MODE?
  • CALL:MS:REPorted:PILot:STRength:REQuest[:IMMediate]
  • CALL:MS:REPorted:PILot:STRength:REQuest:TIME?
  • CALL:MS:REPorted:PILot:STRength:REPort[:ALL]?
  • CALL:MS:REPorted:PILot:STRength:REPort:CLEar
  • CALL:MS:REPorted:QPCHannel[:SUPPort]?
  • CALL:MS:REPorted:RCONfig:ENHanced[:SUPPort]?
  • CALL:MS:REPorted:REGistration[:TYPE]?
  • CALL:MS:REPorted:REQuest[:ENAble]
  • CALL:MS:REPorted:REVision:ANALog?
  • CALL:MS:REPorted:SCINdex?
  • CALL:MS:REPorted:SCLass?
  • CALL:MS:REPorted:TXType?
  • CALL[:CELL]:NIDentity
  • CALL[:CELL[1]]:OCNSource:LEVel[:SELected]?
  • CALL[:CELL[1]]:OCNSource:STATe[:SELected]?
  • CALL[:CELL[1]]:OCNSource:WALSh[:SELected]
  • CALL[:CELL]:OPERating:MODE
  • CALL:ORIGinate
  • CALL:ORIGinate:DONE?
  • CALL:ORIGinate:OPComplete?
  • CALL:ORIGinate:SEQuential
  • CALL:ORIGinate:WAIT
  • CALL:PAGing[:SLEVel][:SELected]
  • CALL:PAGing:DRATe
  • CALL:PAGing:IMSI:TYPE
  • CALL:PAGing:IMSI:MCC
  • CALL:PAGing:IMSI:MNC
  • CALL:PAGing:IMSI:MSIN
  • CALL:PAGing:LEVel[:SELected]
  • CALL:PAGing:PNUMber
  • CALL:PAGing:SCINdex[:MAXimum]
  • CALL:PAGing:STATe[:SELected]
  • CALL:PAGing:MERRor:PROCedure:PARameter:CLEar
  • CALL:PAGing:MERRor:PROCedure:STARt
  • CALL:PAGing:MERRor:PROCedure:STOP
  • CALL[:CELL]:PARameter:EACCess:DRATe[:SUPPorted]
  • CALL[:CELL]:PARameter:EACCess:ICORrection[:MAXimum]
  • CALL[:CELL]:PARameter:EACCess:ICORrection:THReshold
  • CALL[:CELL]:PARameter:EACCess:POWer:INITial
  • CALL[:CELL]:PARameter:EACCess:POWer:NOMinal
  • CALL[:CELL]:PARameter:EACCess:POWer:STEP[:LEVel]
  • CALL[:CELL]:PARameter:EACCess:POWer:STEP:COUNt
  • CALL[:CELL]:PARameter:EACCess:RLGain:CTPilot
  • CALL[:CELL[1]]:PILOT[:SLEVel][:SELected]
  • CALL[:CELL[1]]:PILOT:LEVel[:SELected]
  • CALL:PILOT:STATe[:SELected]
  • CALL[:CELL]:PLCMask:TYPE
  • CALL[:CELL[1]]:PNOFfest
  • CALL[:CELL[1]]:POWer[:SAMPlitude][:SELected]
  • CALL[:CELL[1]]:POWer:AMPLitude[:SELected]
  • CALL[:CELL[1]]:POWer:STATe[:SELected]
  • CALL:PLOGging:STARt
  • CALL:PLOGging:STOP
  • CALL:PLOGging:STATus? or CALL:PLOGging:STATe?
  • CALL:PLOGging:CONNected?
  • CALL:PLOGging:ACTive?
  • CALL:PLOGging:DONE?
  • CALL[:CELL]:PROTocol[:SELected]
  • CALL[:CELL]:PROTocol:DIGital95
  • CALL[:CELL]:PROTocol:DIGital2000
  • CALL[:CELL]:PROTocol:CCHannel:CONFigure
  • CALL:QPCHannel:DRATe
  • CALL: QPCHannel:LEVel[:RTCell][:SELected]?
  • CALL: QPCHannel[:SLEVel]:RTPilot[:SELected]
  • CALL:QPCHannel:LEVel:RTPilot[:SELected]
  • CALL:QPCHannel:STATe[:SELected]
  • CALL[:CELL]:RCONfig
  • CALL:REGister[:IMMediate]
  • CALL:REGister[:IMMediate]:DONE?
  • CALL:REGister[:IMMediate]:OPComplete?
  • CALL:REGister[:IMMediate]:SEQuential
  • CALL:REGister[:IMMediate]:WAIT
  • CALL:REGister:PUP[:STATe]
  • CALL:REGister:TIMer[:SRPeriod]
  • CALL:REGister:TIMer:RPERiod
  • CALL:REGister:TIMer:STATe
  • CALL[:CELL]:RFGenerator:FREQuency
  • CALL[:CELL]:RLGain[:TTPilot]
  • CALL:RTVocoder:DECoder:HEADroom?
  • CALL:RTVocoder:ENCoder:DRATe
  • CALL:RTVocoder:ENCoder:DRATe:MODE
  • CALL:RTVocoder:ENCoder:HEADroom?
  • CALL:RTVocoder:INPut:VOLTage[:EXPected]
  • CALL:RTVocoder:OUTPut:VOLTage[:MAXimum]
  • CALL:SCHannel[:FORWard][:SLEVel][:SELected]
  • CALL:SCHannel[:FORWard]:LEVel[:SELected]
  • CALL:SCHannel[:FORWard]:STATe[:SELected]
  • CALL:SCHannel[:FORWard]:DRATe[:SELected]
  • CALL:SCHannel[:FORWard]:DRATe:RCONfig3
  • CALL:SCHannel[:FORWard]:DRATe:RCONfig4
  • CALL:SCHannel[:FORWard]:DRATe:RCONfig5
  • CALL:SCHannel[:FORWard]:ENCoder
  • CALL:SCHannel:REVerse:DRATe:MAXimum
  • CALL:SCHannel:REVerse:DRATe[:SELected]
  • CALL:SCHannel:REVerse:DRATe:RCONfig3
  • CALL:SCHannel:REVerse:DRATe:RCONfig4
  • CALL:SCHannel:REVerse:DRATe:RCONfig5
  • CALL:SCHannel:REVerse:ENCoder
  • CALL:SCHannel:TDSOption:DSOurce
  • CALL:SCHannel:TDSOption:FPATtern
  • CALL:SECurity:AUTHenticate:CLEar[:ALL]
  • CALL:SECurity:AUTHenticate:GCHallenge:CHIStory:EXPected?
  • CALL:SECurity:AUTHenticate:GCHallenge:CHIStory:RECeived?
  • CALL:SECurity:AUTHenticate:GCHallenge:CHIStory:RESult?
  • CALL:SECurity:AUTHenticate:GCHallenge:CRANdom:EXPected?
  • CALL:SECurity:AUTHenticate:GCHallenge:CRANdom:RECeived?
  • CALL:SECurity:AUTHenticate:GCHallenge:CRANdom:RESult?
  • CALL:SECurity:AUTHenticate:GCHallenge:ENABle
  • CALL:SECurity:AUTHenticate:GCHallenge:MODE:EXPected?
  • CALL:SECurity:AUTHenticate:GCHallenge:MODE:RECeived?
  • CALL:SECurity:AUTHenticate:GCHallenge:MODE:RESult?
  • CALL:SECurity:AUTHenticate:GCHallenge:RANDom
  • CALL:SECurity:AUTHenticate:GCHallenge:RESPonse:EXPected?
  • CALL:SECurity:AUTHenticate:GCHallenge:RESPonse:RECeived?
  • CALL:SECurity:AUTHenticate:GCHallenge:RESPonse:RESult?
  • CALL:SECurity:AUTHenticate:GCHallenge:RESult?
  • CALL:SECurity:AUTHenticate:GCHallenge:TYPE?
  • CALL:SECurity:AUTHenticate:SSDA:ZERO?
  • CALL:SECurity:AUTHenticate:SUPDate:AKEY
  • CALL:SECurity:AUTHenticate:SUPDate:CDIGits?
  • CALL:SECurity:AUTHenticate:SUPDate:RANDom
  • CALL:SECurity:AUTHenticate:SUPDate:RESult?
  • CALL:SECurity:AUTHenticate:SUPDate:STARt
  • CALL:SECurity:AUTHenticate:SUPDate:TYPE?
  • CALL:SECurity:AUTHenticate:UCHallenge:RANDom
  • CALL:SECurity:AUTHenticate:UCHallenge:RESPonse:EXPected?
  • CALL:SECurity:AUTHenticate:UCHallenge:RESPonse:RECeived?
  • CALL:SECurity:AUTHenticate:UCHallenge:RESPonse:RESult?
  • CALL:SECurity:AUTHenticate:UCHallenge:RESult?
  • CALL:SECurity:AUTHenticate:UCHallenge:STARt
  • CALL:SECurity:AUTHenticate:UCHallenge:TYPE?
  • CALL:SETup:AVC[:CHANnel][:SELected]
  • CALL:SETup:AVC[:CHANnel]:CELLular
  • CALL:SETup:AVC:SATone[:CCODe]
  • CALL:SETup:BAND:[:SELected]
  • CALL:SETup:CHANnel[:SELected][:SELected]
  • CALL:SETup:HANDoff[:IMMediate]
  • CALL:SETup:MS:ANALog:TXLevel[:SELected]
  • CALL:SETup:MS:ANALog:TXLevel:CELLular
  • CALL:SETup:SHANdoff:ENABle
  • CALL:SETup:SHANdoff:TYPe
  • CALL:SETup:SYSTem[:TYPE]<[:SELected]|[:TA2000]>
  • CALL[:CELL]:SIDentity
  • CALL:SMService:ARM[:IMMediate]
  • CALL:SMService:ARM:STATe?
  • CALL:SMService:ARM:TIMeout
  • CALL:SMService:BSENt[:STATe]?
  • CALL:SMService:CLEar
  • CALL:SMService:END
  • CALL:SMService:HTTProtocol:INPut
  • CALL:SMService:HTTProtocol:OUTPut
  • CALL:SMService:IDLE[:STATe]?
  • CALL:SMService:MSACk[:STATe]?
  • CALL:SMService:MSNack[:STATe]?
  • CALL:SMService:RECeived[:STATe]?
  • CALL:SMService:SEND
  • CALL:SMService:STATus[:STATe]?
  • CALL:SMService:MORiginated:CBNumber:ASCii?
  • CALL:SMService:MORiginated:CBNumber:ENCoding?
  • CALL:SMService:MORiginated:CBNumber:HEX?
  • CALL:SMService:MORiginated:COUNt?
  • CALL:SMService:MORiginated:DADDress:ASCii?
  • CALL:SMService:MORiginated:DADDress:ENCoding?
  • CALL:SMService:MORiginated:DADDress:HEX?
  • CALL:SMService:MORiginated:DROP:TIMer[:STATe]
  • CALL:SMService:MORiginated:MESSage:ASCii?
  • CALL:SMService:MORiginated:MESSage:ENCoding?
  • CALL:SMService:MORiginated:MESSage:HEX?
  • CALL:SMService:MORiginated:MESSage:LENGth?
  • CALL:SMService:MORiginated:PRIority?
  • CALL:SMService:MORiginated:PROTocol
  • CALL:SMService:MORiginated:TELeservice?
  • CALL:SMService:MTERminated:ALERt
  • CALL:SMService:MTERminated:CBNumber
  • CALL:SMService:MTERminated:SOURce
  • CALL:SMService:MTERminated:MDMode
  • CALL:SMService:MTERminated:MDMode:INCLusion
  • CALL:SMService:MTERminated:MESSage:ASCii
  • CALL:SMService:MTERminated:MESSage:ENCoding
  • CALL:SMService:MTERminated:MESSage:HEX
  • CALL:SMService:MTERminated:MESSage:LENGth?
  • CALL:SMService:MTERminated:MESSage:REPeat
  • CALL:SMService:MTERminated:MESSage:UDATa
  • CALL:SMService:MTERminated:MSACk:CCODe[:INDex]?
  • CALL:SMService:MTERminated:MSACk:CCODe:STRing?
  • CALL:SMService:MTERminated:PRIority
  • CALL:SMService:MTERminated:PRIVacy
  • CALL:SMService:MTERminated:SCATegory
  • CALL:SMService:MTERminated:SERVice
  • CALL:SMService:MTERminated:TELeservice
  • CALL:SMService:MTERminated:VMNotify:COUNt
  • CALL[:CELL]:SOPTion[:SELected][:SELected]
  • CALL[:CELL]:SOPTion:LOOPback:DSOurce:RESet[:STATe]
  • CALL[:CELL]:SOPTion:SO33:CHANnel:CONFigure
  • CALL[:CELL[1]]:SPARameter:TADD
  • CALL[:CELL[1]]:SPARameter:TDRop
  • CALL[:CELL[1]]:SPARameter:TCOMp
  • CALL[:CELL[1]]:SPARameter:TTDRop
  • CALL[:CELL[1]]:SPARameter:SOFT[:SLOPe]
  • CALL[:CELL[1]]:SPARameter:ADD[:INTercept]
  • CALL[:CELL[1]]:SPARameter:DROP[:INTercept]
  • CALL:SSERvice:WAITing:CPNumber[1]:CONNect
  • CALL:SSERvice:WAITing:CPNumber[1]:DCONnect
  • CALL:SSERvice:WAITing:CPNumber[1]:STATus[:STATe]?
  • CALL:SSERvice:WAITing:CPNumber2:CONNect
  • CALL:SSERvice:WAITing:CPNumber2:DCONnect
  • CALL:SSERvice:WAITing:CPNumber2:STATus[:STATe]?
  • CALL:STATus[:STATe][:VOICe]?
  • CALL:STATus[:STATe]:DATA?
  • CALL:STATus:AVC:[:CHANnel]?
  • CALL:STATus:AVC:SATone[:CCODe]?
  • CALL:STATus:CELL:SYSTem[:TYPE]?
  • CALL:STATus:CLPControl[:CELL[1]]:REVerse:TRANsient:STATe?
  • CALL:STATus:LOOPback?
  • CALL:STATus:MS:ANALog:TXLevel?
  • CALL:STATus:MSPeed[:CPOWer]?
  • CALL:STATus:SHANdoff?
  • CALL:STATus:AWGNoise[:INTernal]:POWer[:AMPLitude][:SELected]?
  • CALL:STATus:AWGNoise[:INTernal]:POWer:STATe[:SELected]?
  • CALL:STATus:CELL[1]:POWer:[AMPLitude][:SELected]?
  • CALL:STATus:CELL[1]:POWer:STATe[:SELected]?
  • CALL:STATus:CELL2:POWer:[AMPLitude][:SELected]?
  • CALL:STATus:CELL2:POWer:STATe[:SELected]?
  • CALL:STATus:BCCHannel[:LEVel]<[:SELected]|:DIGital2000>?
  • CALL:STATus:BCCHannel:STATe<[:SELected]|:DIGital2000>?
  • CALL:STATus:BCCHannel:EBNTotal?
  • CALL:STATus:CCCHannel[:LEVel]<[:SELected]|:DIGital2000>?
  • CALL:STATus:CCCHannel:STATe<[:SELected]|:DIGital2000>?
  • CALL:STATus:CCCHannel:EBNTotal?
  • CALL:STATus:CSTime:LOCal:DATE?
  • CALL:STATus:CSTime:LOCal:TIME?
  • CALL:STATus:FPControl:FCHannel:LEVel:MAXimum?
  • CALL:STATus:FCHannel[:CELL[1]][:LEVel][:SELected]?
  • CALL:STATus:FCHannel[:CELL[1]]:STATe[:SELected]?
  • CALL:STATus:FCHannel:CELL2:LEVel[:SELected]?
  • CALL:STATus:FCHannel:CELL2:STATe[:SELected]?
  • CALL:STATus:OCNSource[:CELL[1]][:LEVel][:SELected]?
  • CALL:STATus:OCNSource[:CELL[1]]:STATe[:SELected]?
  • CALL:STATus:OCNSource:CELL2:LEVel[:SELected]?
  • CALL:STATus:OCNSource:CELL2:STATe[:SELected]?
  • CALL:STATus:PAGing[:LEVel][:SELected]?
  • CALL:STATus:PAGing:STATe[:SELected]?
  • CALL:STATus:PAGing:EBNTotal?
  • CALL:STATus:PAGing:MERRor:MESSages?
  • CALL:STATus:PAGing:MERRor:PROCedure:WARNing?
  • CALL:STATus:PAGing:MERRor:RATio[:SLOTed]?
  • CALL:STATus:PAGing:MERRor:TIME?
  • CALL:STATus:PAGing:IMSI:S1?
  • CALL:STATus:PAGing:IMSI:S2?
  • CALL:STATus:PILot[:CELL[1]][:LEVel][:RTCell][:SELected]?
  • CALL:STATus:PILot[:CELL[1]][:LEVel]:RTTotal[:SELected]?
  • CALL:STATus:PILot[:CELL[1]]:STATe[:SELected]?
  • CALL:STATus:PILot[:CELL[1]]:STRength[:SELected]?
  • CALL:STATus:PILot:CELL2[:LEVel:][:RTCell][:SELected]?
  • CALL:STATus:PILot:CELL2[:LEVel]:RTTotal[:SELected]?
  • CALL:STATus:PILot:CELL2:STATe[:SELected]?
  • CALL:STATus:PILot:CELL2:STRength[:SELected]?
  • CALL:STATus:QPCHannel:EBNTotal?
  • CALL:STATus:QPCHannel[:LEVel][:RTCell][:SELected]?
  • CALL:STATus:QPCHannel[:LEVel]:RTPilot[:SELected]?
  • CALL:STATus:QPCHannel:STATe[:SELected]?
  • CALL:STATus:SCHannel[:LEVel][:SELected]?
  • CALL:STATus:SCHannel[:FORWard]:EBNTotal?
  • CALL:STATus:SCHannel[:FORWard]:STATe[:SELected]?
  • CALL:STATus:SCHannel[:FORWard]:SYNChronized?
  • CALL:STATus:SCHannel:FORWard:ASSigned?
  • CALL:STATus:SCHannel:FORWard:ENCoder?
  • CALL:STATus:SCHannel:REVerse:ASSigned?
  • CALL:STATus:SCHannel:REVerse:ENCoder?
  • CALL:STATus:SYNC[:LEVel][:SELected]?
  • CALL:STATus:SYNC:STATe[:SELected]?
  • CALL:STATus:TOTal:POWer[:AMPLitude][:SELected]?
  • CALL:STATus:TOTal:POWer:STATe[:SELected]?
  • CALL:STATus:TRAFfic[:CELL[1]][:LEVel][:SELected]?
  • CALL:STATus:TRAFfic[:CELL[1]]: EBNTotal?
  • CALL:STATus:TRAFfic[:CELL[1]]:STATe[:SELected]?
  • CALL:STATus:TRAFfic:CELL2:LEVel[:SELected]?
  • CALL:STATus:TRAFfic:CELL2:STATe[:SELected]?
  • CALL:SYNC[:SLEVel][:SELected]
  • CALL:SYNC:LEVel[:SELected]
  • CALL:SYNC:STATe[:SELected]
  • CALL[:CELL]:SYSTem[:TYPE]
  • CALL:TOTal:POWer[:AMPLitude][:SELected]?
  • CALL:TOTal:POWer:STATe[:SELected]?
  • CALL[:CELL[1]]:TRAFfic[:FORWard][:SLEVel]<[:SELected]|DIGital95>
  • CALL[:CELL[1]]:TRAFfic[:FORWard]:LEVel<[:SELected]|DIGital95>
  • CALL[:CELL[1]]:TRAFfic[:FORWard]:STATe<[:SELected]|DIGital95>
  • CALL[:CELL[1]]:TRAFfic[:FORWard]:WALSh
  • CALL[:CELL[1]]:TRAFfic[:FORWard]:DRATe
  • CALL[:CELL[1]]:TRAFfic[:FORWard]:SOURce
  • CALL[:CELL[1]]:TRAFfic[:FORWard]:SOURce:ECHO
  • CALL[:CELL[1]]:TRAFfic[:FORWard]:FPATtern:BAD
  • CALL[:CELL[1]]:TRAFfic[:FORWard]:FPATtern:GOOD
  • CALL[:CELL[1]]:TRAFfic[:FORWard]:FPATtern:STATe
  • CALL[:CELL[1]]:TRAFfic[:FORWard]:FPATtern:SFQuality
  • CALL:TRIGger[:OUTPut]:TYPE<[:SELected]|:TA2000>
  • CALL[:CELL[1]]:WAVeform:TYPE:CW

DISPlay Subsystem

  • DISPlay:BRIGhtness
  • DISPlay:MESSage:MASKable:STATe
  • DISPlay:MODE
  • DISPlay:WINDow:ERRor:CLEar
  • DISPlay:OPERator:MESSage

FETCh Subsystem

  • FETCh:AFANalyzer[:ALL]?
  • FETCh:AFANalyzer:DISTortion[:AVERage]?
  • FETCh:AFANalyzer:DISTortion:ALL?
  • FETCh:AFANalyzer:DISTortion:MINimum?
  • FETCh:AFANalyzer:DISTortion:MAXimum?
  • FETCh:AFANalyzer:DISTortion:MINimum?
  • FETCh:AFANalyzer:DISTortion:SDEViation?
  • FETCh:AFANalyzer:FREQuency[:AVERage]?
  • FETCh:AFANalyzer:FREQuency:ALL?
  • FETCh:AFANalyzer:FREQuency:MAXimum?
  • FETCh:AFANalyzer:FREQuency:MINimum?
  • FETCh:AFANalyzer:FREQuency:SDEViation?
  • FETCh:AFANalyzer:ICOunt?
  • FETCh:AFANalyzer:INTegrity?
  • FETCh:AFANalyzer:SINAD[:AVERage]?
  • FETCh:AFANalyzer:SINAD:ALL?
  • FETCh:AFANalyzer:SINAD:MAXimum?
  • FETCh:AFANalyzer:SINAD:MINimum?
  • FETCh:AFANalyzer:SINAD:SDEViation?
  • FETCh:AFANalyzer:VOLTage[:AVERage]?
  • FETCh:AFANalyzer:VOLTage:ALL?
  • FETCh:AFANalyzer:VOLTage:MAXimum?
  • FETCh:AFANalyzer:VOLTage:MINimum?
  • FETCh:AFANalyzer:VOLTage:SDEViation?
  • FETCh:ATXPower[:ALL]?
  • FETCh:ATXPower:ICOunt?
  • FETCh:ATXPower:INTegrity?
  • FETCh:ATXPower:POWer[:AVERage]?
  • FETCh:ATXPower:POWer:ALL?
  • FETCh:ATXPower:POWer:MAXimum?
  • FETCh:ATXPower:POWer:MINimum?
  • FETCh:ATXPower:POWer:SDEViation?
  • FETCh:CAPPower[:ALL]?
  • FETCh:CAPPower:INTegrity?
  • FETCh:CCTPhase[:ALL]?
  • FETCh:CCTPhase:ICOunt?
  • FETCh:CCTPhase:CDTPhase[:ALL]?
  • FETCh:CCTPhase:CDTPhase:BIN?
  • FETCh:CCTPhase:CDTPhase:COUNt[:BIN]?
  • FETCh:CFDTune[:ALL]?
  • FETCh:CFDTune:INTegrity?
  • FETCh:CFERror[:ALL]?
  • FETCh:CFERror:EBNTotal[:AVERage]?
  • FETCh:CFERror:EBNTotal:MAXimum?
  • FETCh:CFERror:EBNTotal:MINimum?
  • FETCh:CFERror:EBNTotal:FAIL?
  • FETCh:CFERror:ERASures:FORWard?
  • FETCh:CFERror:ERASures:REVerse?
  • FETCh:CFERror:ERRors[:MS]?
  • FETCh:CMAudio[:ALL]?
  • FETCh:CMAudio:DISTortion[:AVERage]?
  • FETCh:CMAudio:FREQuency[:AVERage]?
  • FETCh:CMAudio:ICOunt?
  • FETCh:CMAudio:INTegrity?
  • FETCh:CMAudio:LEVel?
  • FETCh:CMAudio:LEVel:LIMit:FAIL?
  • FETCh:CMAudio<:SINad|:SNDRatio>[:AVERage]?
  • FETCh:CMAudio:VOLTage[:AVERage]?
  • FETCh:CMMPower[:ALL]?
  • FETCh:CMMPower:INTegrity?
  • FETCh:CMMPower:INTegrity:MAXPower?
  • FETCh:CMMPower:INTegrity:MINPower?
  • FETCh:CMMPower:MAXPower?
  • FETCh:CMMPower:MINPower?
  • FETCh:CPOWer[:ALL]?
  • FETCh:CPOWer:ICOunt?
  • FETCh:CPOWer:INTegrity?
  • FETCh:CPOWer:MAXimum?
  • FETCh:CPOWer:MINimum?
  • FETCh:CTDPower[:ALL]?
  • FETCh:CTDPower:COUNt[:STEP]?
  • FETCh:CTDPower:INTegrity?
  • FETCh:CTXSpurious[:ALL]?
  • FETCh:CTXSpurious:ICOunt?
  • FETCh:CTXSpurious:MASK[:FAIL]?
  • FETCh:DAPower[:ALL]?
  • FETCh:DAPower:ICOunt?
  • FETCh:DAPower:INTegrity?
  • FETCh:DTMF[:ALL]?
  • FETCh:DTMF:CHARacter? <num value>
  • FETCh:DTMF:COUNt[:CHARacter]?
  • FETCh:DTMF:INTegrity?
  • FETCh:FM[:ALL]?
  • FETCh:FM:DEViation[:AVERage]?
  • FETCh:FM:DEViation:ALL?
  • FETCh:FM:DEViation:MAXimum?
  • FETCh:FM:DEViation:MINimum?
  • FETCh:FM:DEViation:SDEViation?
  • FETCh:FM:DISTortion[:AVERage]?
  • FETCh:FM:DISTortion:ALL?
  • FETCh:FM:DISTortion:MAXimum?
  • FETCh:FM:DISTortion:MINimum?
  • FETCh:FM:DISTortion:SDEViation?
  • FETCh:FM:FREQuency[:AVERage]?
  • FETCh:FM:FREQuency:ALL?
  • FETCh:FM:FREQuency:MAXimum?
  • FETCh:FM:FREQuency:MINinum?
  • FETCh:FM:FREQuency:SDEViation?
  • FETCh:FM:ICOunt?
  • FETCh:FM:INTegrity?
  • FETCh:FSTability[:ALL]?
  • FETCh:FSTability:FERRor[:WORSt]?
  • FETCh:FSTability:FERRor:ALL?
  • FETCh:FSTability:FERRor:AVERage?
  • FETCh:FSTability:FERRor:MAXimum?
  • FETCh:FSTability:FERRor:MINimum?
  • FETCh:FSTability:FREQuency[:AVERage]?
  • FETCh:FSTability:FREQuency:ALL?
  • FETCh:FSTability:FREQuency:MAXimum?
  • FETCh:FSTability:FREQuency:MINimum?
  • FETCh:FSTability:FREQuency:SDEViation?
  • FETCh:FSTability:ICOunt?
  • FETCh:FSTability:INTegrity?
  • FETCh:GAPPower[:ALL][:RANGe20]?
  • FETCh:GAPPower[:ALL]:RANGe60?
  • FETCh:GAPPower:ICOunt?
  • FETCh:GAPPower:INTegrity?
  • FETCh:GAPPower:INTegrity20?
  • FETCh:GAPPower:INTegrity60?
  • FETCh:GAPPower:RTPRevious[:RANGe19]?
  • FETCh:GAPPower:RTPRevious:RANGe59?
  • FETCh:GAPPower:TIME[:RANGe19]?
  • FETCh:GAPPower:TIME:RANGe59?
  • FETCh:GPOWer[:ALL]?
  • FETCh:GPOWer:ICOunt?
  • FETCh:GPOWer:MASK[:FAIL]?
  • FETCh:GPOWer:MASK:OFFSet?
  • FETCh:GPOWer:TRACe?
  • FETCh:HWQuality[:ALL]?
  • FETCh:SAUDio[:ALL]?
  • FETCh:SAUDio:DISTortion[:AVERage]?
  • FETCh:SAUDio:DISTortion:MAXimum?
  • FETCh:SAUDio:DISTortion:MINimum?
  • FETCh:SAUDio:DISTortion:SDEViation?
  • FETCh:SAUDio:ICOunt?
  • FETCh:SAUDio:INTegrity?
  • FETCh:SAUDio:SINAD[:AVERage]?
  • FETCh:SAUDio:SINAD:MAXimum?
  • FETCh:SAUDio:SINAD:MINimum?
  • FETCh:SAUDio:SINAD:SDEViation?
  • FETCh:SAUDio:VOLTage[:AVERage]?
  • FETCh:SAUDio:VOLTage:MAXimum?
  • FETCh:SAUDio:VOLTage:MINimum?
  • FETCh:SAUDio:VOLTage:SDEViation?
  • FETCh:SMONitor[:ALL]?
  • FETCh:SMONitor:INTegrity?
  • FETCh:SMONitor:TRACe?
  • FETCh:STONe[:ALL]?
  • FETCh:STONe:DEViation:PPEak[:AVERage]?
  • FETCh:STONe:DEViation:PPEak:ALL?
  • FETCh:STONe:DEViation:PPEak:MINimum?
  • FETCh:STONe:DEViation:PPEak:MAXimum?
  • FETCh:STONe:DEViation:PPEak:SDEViation?
  • FETCh:STONe:DEViation:NPEak[:AVERage]?
  • FETCh:STONe:DEViation:NPEak:ALL?
  • FETCh:STONe:DEViation:NPEak:MINimum?
  • FETCh:STONe:DEViation:NPEak:MAXimum?
  • FETCh:STONe:DEViation:NPEak:SDEViation?
  • FETCh:STONe:FREQuency[:AVERage]?
  • FETCh:STONe:FREQuency:ALL?
  • FETCh:STONe:FREQuency:MINinum?
  • FETCh:STONe:FREQuency:MAXimum?
  • FETCh:STONe:FREQuency:SDEViation?
  • FETCh:STONe:FERRor[:AVERage]?
  • FETCh:STONe:FERRor:ALL?
  • FETCh:STONe:FERRor:MINinum?
  • FETCh:STONe:FERRor:MAXimum?
  • FETCh:STONe:FERRor:SDEViation?
  • FETCh:STONe:ICOunt?
  • FETCh:STONe:INTegrity?
  • FETCh:TFERror[:ALL]?
  • FETCh:TFERror:ICOunt?
  • FETCh:TROPower[:ALL]?
  • FETCh:TROPower:MASK[:FAIL]?
  • FETCh:TROPower:TRACe?
  • FETCh:WDDeviation[:ALL]?
  • FETCh:WDDeviation:DEViation:MAXimum:PPEak?
  • FETCh:WDDeviation:DEViation:MAXimum:NPEak?
  • FETCh:WDDeviation:DEViation:SETTled:PPEak?
  • FETCh:WDDeviation:DEViation:SETTled:NPEak?
  • FETCh:WDDeviation:INTegrity?
  • FETCh:WQUality[:ALL]?
  • FETCh:WQUality:ICOunt?
  • FETCh:WQUality:CDPower:PILot[:REVerse]?
  • FETCh:WQUality:CDPower:CCHannel:DEDicated[:REVerse]?
  • FETCh:WQUality:CDPower:FCHannel[:REVerse]?
  • FETCh:WQUality:CDPower:SCHannel1[:REVerse]?
  • FETCh:WQUality:CDPower:SCHannel2[:REVerse]?
  • FETCh:WQUality:CDPower:IQINactive[:FAIL]?
  • FETCh:WQUality:CDPower:ICHannel[:ALL]?
  • FETCh:WQUality:CDPower:ICHannel:BIN? <bin num>
  • FETCh:WQUality:CDPower:ICHannel:COUNt[:BIN]?
  • FETCh:WQUality:CDPower:QCHannel[:ALL]?
  • FETCh:WQUality:CDPower:QCHannel:BIN? <bin num>
  • FETCh:WQUality:CDPower:QCHannel:COUNt[:BIN]?
  • FETCh:WQUality:CDPNoise:IQNoise[:FAIL]?
  • FETCh:WQUality:CDPNoise:ICHannel[:ALL]?
  • FETCh:WQUality:CDPNoise:ICHannel:BIN? <bin num>
  • FETCh:WQUality:CDPNoise:ICHannel:COUNt[:BIN]?
  • FETCh:WQUality:CDPNoise:QCHannel[:ALL]?
  • FETCh:WQUality:CDPNoise:QCHannel:BIN? <bin num>
  • FETCh:WQUality:CDPNoise:QCHannel:COUNt[:BIN]?

INITiate Subsystem

  • INITiate<:measurement mnemonic>[:ON]
  • INITiate<:measurement mnemonic>:OFF
  • INITiate:CFDTune:ARMed?
  • INITiate:COUNt?
  • INITiate:DONE?
  • INITiate:DONE:CLEar
  • INITiate:DONE:FLAG[:ALL]
  • INITiate:DONE:FLAG<:measurement mnemonic>
  • INITiate:ON?

READ Subsystem

  • READ:AFANalyzer[:ALL]?
  • READ:ATXPower[:ALL]?
  • READ:CAPPower[:ALL]?
  • READ:CCTPhase[:ALL]?
  • READ:CFDTune[:ALL]?
  • READ:CFERror[:ALL]?
  • READ:CMAudio[:ALL]?
  • READ:CMMPower[:ALL]?
  • READ:CPOWer[:ALL]?
  • READ:CTDPower[:ALL]?
  • READ:CTXS purious[:ALL]?
  • READ:DAPower[:ALL]?
  • READ:DTMF[:ALL]?
  • READ:FM[:ALL]?
  • READ:GAPPower[:ALL][:RANGe20]?
  • READ:GAPPower[:ALL]:RANGe60?
  • READ:FSTability[:ALL]?
  • READ:GPOWer[:ALL]?
  • READ:HWQuality[:ALL]?
  • READ:SAUDio[:ALL]?
  • READ:STONe[:ALL]?
  • READ:SMONitor:TRACe?
  • READ:TFERror[:ALL]?
  • READ:TROPower[:ALL]?
  • READ:WDDeviation[:ALL]?
  • READ:WQUality[:ALL]?

RFANalyzer Subsystem

  • RFANalyzer:AUTO:POWer[:SELected]?
  • RFANalyzer:CONTrol:MEASurement:FREQuency:AUTO
  • RFANalyzer:CONTrol:POWer:AUTO
  • RFANalyzer:CONTrol:UPLink:FREQuency:AUTO
  • RFANalyzer:CW:EXPected:POWer
  • RFANalyzer:MANual:POWer[:SELected]
  • RFANalyzer:MANual:ANALog:POWer[:SELected]
  • RFANalyzer:MANual:ANALog:POWer:CELLular
  • RFANalyzer:MANual:MEASurement[:MFRequency]
  • RFANalyzer:MANual:MEASurement:FREQuency
  • RFANalyzer:MANual:UPLink[:MFRequency]
  • RFANalyzer:MANual:UPLink:FREQuency

RFGenerator Subsystem

  • RFGenerator:OUTPut[:DESTination]

SETup Subsystem

  • SETup[:ALL]:CONTinuous<:OFF|:ON>
  • SETup:AFANalyzer:CONTinuous
  • SETup:AFANalyzer:COUNt[:SNUMber]
  • SETup:AFANalyzer:COUNt:NUMBer
  • SETup:AFANalyzer:COUNt:STATe
  • SETup:AFANalyzer:DEMPhasis:STATe
  • SETup:AFANalyzer:DETector[:TYPE]
  • SETup:AFANalyzer:EXPandor[:SRLevel]
  • SETup:AFANalyzer:EXPandor:RLEVel
  • SETup:AFANalyzer:EXPandor:STATe
  • SETup:AFANalyzer:FILTer[:TYPE]
  • SETup:AFANalyzer:FILTer:TBPass[:FREQuency]
  • SETup:AFANalyzer:FREQuency:STATe
  • SETup:AFANalyzer:PEAK:VOLTage
  • SETup:AFANalyzer:SDIStortion:FREQuency
  • SETup:AFANalyzer:SDIStortion:STATe
  • SETup:AFANalyzer:TIMeout[:STIMe]
  • SETup:AFANalyzer:TIMeout:STATe
  • SETup:AFANalyzer:TIMeout:TIME
  • SETup:ATXPower:CONTinuous
  • SETup:ATXPower:COUNt[:SNUMber]
  • SETup:ATXPower:COUNt:NUMBer
  • SETup:ATXPower:COUNt:STATe
  • SETup:ATXPower:TIMeout[:STIMe]
  • SETup:ATXPower:TIMeout:STATe
  • SETup:ATXPower:TIMeout:TIME
  • SETup:CAPPower:CONTinuous
  • SETup:CAPPower:TIMeout[:STIMe]
  • SETup:CAPPower:TIMeout:STATe
  • SETup:CAPPower:TIMeout:TIME
  • SETup:CCTPhase:CONTinuous
  • SETup:CCTPhase:COUNt[:SNUMber]
  • SETup:CCTPhase:COUNt:NUMBer
  • SETup:CCTPhase:COUNt:STATe
  • SETup:CCTPhase:PERRor[:LIMit]
  • SETup:CCTPhase:TERRor[:LIMit]
  • SETup:CCTPhase:TIMeout[:STIMe]
  • SETup:CCTPhase:TIMeout:STATe
  • SETup:CCTPhase:TIMeout:TIME
  • SETup:CFDTune:FREQuency:STEP:COUNt
  • SETup:CFDTune:MS:RX:FREQuency:STEP[:VALues]
  • SETup:CFDTune:MS:RX:FREQuency:STEP:STARt:[INDex]
  • SETup:CFDTunee:MS:RX:POWer:STEP[:LEVels]
  • SETup:CFDTune:MS:RX:POWer:STEP:STARt:[INDex]
  • SETup:CFDTune:MS:TX:FREQuency:STEP[:VALues]
  • SETup:CFDTune:MS:TX:FREQuency:STEP:STARt:[INDex]
  • SETup:CFDTune:MS:TX:POWer:STEP[:LEVels]
  • SETup:CFDTune:MS:TX:POWer:STEP:STARt:[INDex]
  • SETup:CFDTune:POWer:STEP:COUNt
  • SETup:CFDTune:TIMeout[:STIMe]
  • SETup:CFDTune:TIMeout:STATe
  • SETup:CFDTune:TIMeout:TIME
  • SETup:CFERror:CONFidence[:SLEVel]
  • SETup:CFERror:CONFidence:STATe
  • SETup:CFERror:CONFidence:LEVel
  • SETup:CFERror:CONFidence:REQuirement[:RATio]
  • SETup:CFERror:CONTinuous
  • SETup:CFERror:COUNt[:MAXimum]
  • SETup:CFERror:COUNt:MINimum
  • SETup:CFERror:EBNTotal[:LIMit]
  • SETup:CFERror:TIMeout[:STIMe]
  • SETup:CFERror:TIMeout:STATe
  • SETup:CFERror:TIMeout:TIME
  • SETup:CMAudio:ANALyzer:DOWNlink:SETTling
  • SETup:CMAudio:ANALyzer:FREQuency:ALL[:SVALue]
  • SETup:CMAudio:ANALyzer:FREQuency:ALL:GENerator
  • SETup:CMAudio:CONTinuous
  • SETup:CMAudio:COUNt[:SNUMber]
  • SETup:CMAudio:COUNt:NUMBer
  • SETup:CMAudio:COUNt:STATe
  • SETup:CMAudio:GENerator:FREQuency:DOWNlink:ALL[:SVALue]?
  • SETup:CMAudio:GENerator:FREQuency:DOWNlink:PRESet
  • SETup:CMAudio:GENerator:FREQuency:Uplink:ALL[:SVALue]
  • SETup:CMAudio:GENerator:FREQuency:Uplink:PRESet
  • SETup:CMAudio:GENerator:LEVel:DOWNlink:ALL[:SAMPlitude]?
  • SETup:CMAudio:GENerator:LEVel:DOWNlink:ALL:TOTal[:SAMPlitude]
  • SETup:CMAudio:GENerator:LEVel:DOWNlink:ALL:TOTal:AMPlitude
  • SETup:CMAudio:GENerator:LEVel:DOWNlink:ALL:TOTal:STATe?
  • SETup:CMAudio:GENerator:LEVel:UPLink:ALL[:SAMPlitude]
  • SETup:CMAudio:GENerator:LEVel:UPLink:ALL:TOTal[:SAMPlitude]
  • SETup:CMAudio:GENerator:LEVel:UPLink:ALL:TOTal:AMPLitude
  • SETup:CMAudio:GENerator:LEVel:UPLink:ALL:TOTal:STATe
  • SETup:CMAudio:LEVel:ALL:LIMit:LOWer
  • SETup:CMAudio:LEVel:ALL:LIMit:UPPer
  • SETup:CMAudio:MEASurement:MODE
  • SETup:CMAudio:PEAK:VOLTage
  • SETup:CMAudio:REFerence:ABSolute:LEVel:DOWNlink
  • SETup:CMAudio:REFerence:ABSolute:LEVel:UPLink
  • SETup:CMAudio:REFerence:MODE
  • SETup:CMAudio:REFerence:RELative:TONE
  • SETup:CMAudio:SDIStortion:SBWidth:UPLink
  • SETup:CMAudio:SDIStortion:STATe
  • SETup:CMAudio:SETTling[:TIME]
  • SETup:CMAudio:TIMeout[:STIMe]
  • SETup:CMAudio:TIMeout:STATe
  • SETup:CMAudio:TIMeout:TIME
  • SETup:CMMPower:POWer:AMPLitude:MAXimum
  • SETup:CMMPower:POWer:AMPLitude:MINimum
  • SETup:CMMPower:PILot:LEVel:MAXimum
  • SETup:CMMPower:PILot:LEVel:MINimum
  • SETup:CMMPower:RFANalyzer:AUTO:MINimum
  • SETup:CMMPower:RFANalyzer:POWer:MINimum
  • SETup:CMMPower:TRAFfic:LEVel:MAXimum
  • SETup:CMMPower:TRAFfic:LEVel:MINimum
  • SETup:CMMPower:TIMeout[:STIMe]
  • SETup:CMMPower:TIMeout:STATe
  • SETup:CMMPower:TIMeout:TIME
  • SETup:CPOWer:CONTinuous
  • SETup:CPOWer:COUNt[:SNUMber]
  • SETup:CPOWer:COUNt:NUMBer
  • SETup:CPOWer:COUNt:STATe
  • SETup:CPOWer:MSPeed
  • SETup:CPOWer:TIMeout[:STIMe]
  • SETup:CPOWer:TIMeout:STATe
  • SETup:CPOWer:TIMeout:TIME
  • SETup:CTDPower:STEP[:LEVel]
  • SETup:CTDPower:STEP:COUNt
  • SETup:CTDPower:STEP:TIME
  • SETup:CTDPower:TIMeout[:STIMe]
  • SETup:CTDPower:TIMeout:STATe
  • SETup:CTDPower:TIMeout:TIME
  • SETup:CTXSpurious:CONTinuous
  • SETup:CTXSpurious:COUNt[:SNUMber]
  • SETup:CTXSpurious:COUNt:NUMBer
  • SETup:CTXSpurious:COUNt:STATe
  • SETup:CTXSpurious:MASK:AUTO
  • SETup:CTXSpurious:MASK:MANual:ADJacent[:LIMit]
  • SETup:CTXSpurious:MASK:MANual:ALTernate[:LIMit]
  • SETup:CTXSpurious:TIMeout[:STIMe]
  • SETup:CTXSpurious:TIMeout:STATe
  • SETup:CTXSpurious:TIMeout:TIME
  • SETup:DAPower:CONTinuous
  • SETup:DAPower:COUNt[:SNUMber]
  • SETup:DAPower:COUNt:NUMBer
  • SETup:DAPower:COUNt:STATe
  • SETup:DAPower:TIMeout[:STIMe]
  • SETup:DAPower:TIMeout:STATe
  • SETup:DAPower:TIMeout:TIME
  • SETup:DTMF:CONTinuous
  • SETup:DTMF:DETector[:TYPE]
  • SETup:DTMF:GTIMe
  • SETup:DTMF:TIMeout[:STIMe]
  • SETup:DTMF:TIMeout:STATe
  • SETup:DTMF:TIMeout:TIME
  • SETup:FM:CONTinuous
  • SETup:FM:COUNt[:SNUMber]
  • SETup:FM:COUNt:NUMBer
  • SETup:FM:COUNt:STATe
  • SETup:FM:DEMPhasis:STATe
  • SETup:FM:DETector[:TYPE]
  • SETup:FM:DISTortion:FREQuency
  • SETup:FM:DISTortion:STATe
  • SETup:FM:EXPandor:STATe
  • SETup:FM:FILTer[:TYPE]
  • SETup:FM:FILTer:TBPass[:FREQuency]
  • SETup:FM:FREQuency:STATe
  • SETup:FM:GTIMe
  • SETup:FM:TIMeout[:STIMe]
  • SETup:FM:TIMeout:STATe
  • SETup:FM:TIMeout:TIME
  • SETup:FSTability:CONTinuous
  • SETup:FSTability:COUNt[:SNUMber]
  • SETup:FSTability:COUNt:NUMBer
  • SETup:FSTability:COUNt:STATe
  • SETup:FSTability:TIMeout[:STIMe]
  • SETup:FSTability:TIMeout:STATe
  • SETup:FSTability:TIMeout:TIME
  • SETup:GPOWer:CONTinuous
  • SETup:GPOWer:COUNt[:SNUMber]
  • SETup:GPOWer:COUNt:NUMBer
  • SETup:GPOWer:COUNt:STATe
  • SETup:GPOWer:TIMeout[:STIMe]
  • SETup:GPOWer:TIMeout:STATe
  • SETup:GPOWer:TIMeout:TIME
  • SETup:HWQuality:TIMeout[:STIMe]
  • SETup:HWQuality:TIMeout:STATe
  • SETup:HWQuality:TIMeout:TIME
  • SETup:SAUDio:CONTinuous
  • SETup:SAUDio:COUNt[:SNUMber]
  • SETup:SAUDio:COUNt:NUMBer
  • SETup:SAUDio:COUNt:STATe
  • SETup:SAUDio:COUPling
  • SETup:SAUDio:DETector[:TYPE]
  • SETup:SAUDio:FILTer[:TYPE]
  • SETup:SAUDio:FREQuency[:VALue]?
  • SETup:SAUDio:FREQuency:POINts
  • SETup:SAUDio:FREQuency:STARt
  • SETup:SAUDio:FREQuency:STOP
  • SETup:SAUDio:ICOunt:MAXimum?
  • SETup:SAUDio:PEAK:VOLTage
  • SETup:SAUDio:SETTling[:TIMe]
  • SETup:SAUDio:SDIStortion:STATe
  • SETup:SAUDio:TIMeout[:STIMe]
  • SETup:SAUDio:TIMeout:TIME
  • SETup:SAUDio:TIMeout:STATe
  • SETup:SAUDio:VOLTage:AMPLitude
  • SETup:SMONitor:AMPLitude:PDIVision
  • SETup:SMONitor:AMPLitude:RLEVel:AUTO
  • SETup:SMONitor:AMPLitude:RLEVel:MANual
  • SETup:SMONitor:BANDwidth|BWIDth[:RESolution]?
  • SETup:SMONitor:BANDwidth|BWIDth:AUTO
  • SETup:SMONitor:BANDwidth|BWIDth:MANual
  • SETup:SMONitor:BANDwidth|BWIDth:ZSPan[:RESolution]
  • SETup:SMONitor:COUNt[:SNUMber]
  • SETup:SMONitor:COUNt:NUMber
  • SETup:SMONitor:COUNt:STATe
  • SETup:SMONitor:CONTinous
  • SETup:SMONitor:DETector[:TYPE]
  • SETup:SMONitor:FREQuency:SPAN
  • SETup:SMONitor:TIME:OFFSet
  • SETup:SMONitor:TIME:SPAN
  • SETup:SMONitor:TIMeout[:STIMe]
  • SETup:SMONitor:TIMeout:STATe
  • SETup:SMONitor:TIMeout:TIME
  • SETup:SMONitor:TRACe:MODE
  • SETup:SMONitor:TRiGger:DELay
  • SETup:SMONitor:TRiGger:SOURce
  • SETup:STONe:CONTinuous
  • SETup:STONe:COUNt[:SNUMber]
  • SETup:STONe:COUNt:NUMBer
  • SETup:STONe:COUNt:STATe
  • SETup:STONe:TIMeout[:STIMe]
  • SETup:STONe:TIMeout:STATe
  • SETup:STONe:TIMeout:TIME
  • SETup:TFERror:CONFidence:REQuirement[:RATio]
  • SETup:TFERror:CONTinuous
  • SETup:TFERror:COUNt
  • SETup:TFERror:TIMeout[:STIMe]
  • SETup:TFERror:TIMeout:STATe
  • SETup:TFERror:TIMeout:TIME
  • SETup:TROPower:STEP
  • SETup:TROPower:TIMeout[:STIMe]
  • SETup:TROPower:TIMeout:STATe
  • SETup:TROPower:TIMeout:TIME
  • SETup:WDDeviation:CONTinuous
  • SETup:WDDeviation:GTIMe
  • SETup:WDDeviation:TIMeout[:STIMe]
  • SETup:WDDeviation:TIMeout:STATe
  • SETup:WDDeviation:TIMeout:TIME
  • SETup:WQUality:CDPower:IQINactive[:LIMit]
  • SETup:WQUality:CDPNoise:IQNoise[:LIMit]
  • SETup:WQUality:CONTinuous
  • SETup:WQUality:COUNt[:SNUMber]
  • SETup:WQUality:COUNt:NUMBer
  • SETup:WQUality:COUNt:STATe
  • SETup:WQUality:TIMeout[:STIMe]
  • SETup:WQUality:TIMeout:STATe
  • SETup:WQUality:TIMeout:TIME

STATus Subsystem

  • STATus:OPERation Condition Register Bit Assignments
  • STATus:OPERation:CALL Condition Register Bit Assignment
  • STATus:OPERation:CALL:CDMA Condition Register Bit Assignment
  • STATus:OPERation:CALL:COMMon Condition Register Bit Assignment
  • STATus:OPERation:CALL:COMMon:DATA Condition Register Bit Assignment
  • STATus:OPERation:CALL:AMPS Register Bit Assignment
  • STATus:OPERation:CALL:DIGital95 Register Bit Assignment
  • STATus:OPERation:CALL:DIGital2000 Register Bit Assignment
  • STATus:OPERation:CALL:TA2000 Register Bit Assignment
  • STATus:OPERation:FEATures Register Bit Assignments
  • STATus:OPERation:FEATures:COMMon Register Bit Assignments
  • STATus:OPERation:FEATures:COMMon:SMService Register Bit Assignments
  • STATus:OPERation:HARDware Condition Register Bit Assignments
  • STATus:OPERation:KEYPressed Register Bit Assignments
  • STATus:OPERation:NMRReady Register Bit Assignments
  • STATus:OPERation:NMRReady:AMPS Condition Register Bit Assignment
  • STATus:OPERation:NMRReady:CDMA Register Bit Assignments
  • STATus:OPERation:NMRReady:COMMon Register Bit Assignments
  • STATus:OPERation:NMRReady:DIGital2000 Register Bit Assignments
  • STATus:PRESet
  • STATus:QUEStionable Condition Register Bit Assignment
  • STATus:QUEStionable:CALL Condition Register Bit Assignment
  • STATus:QUEStionable:CALL:CDMA Condition Register Bit Assignment
  • STATus:QUEStionable:CALL:TA2000 Condition Register Bit Assignment
  • STATus:QUEStionable:ERRors Condition Register Bit Assignment
  • STATus:QUEStionable:ERRors:AMPS Condition Register Bit Assignment
  • STATus:QUEStionable:ERRors:CDMA Register Bit Assignments
  • STATus:QUEStionable:ERRors:COMMon Register Bit Assignments
  • STATus:QUEStionable:ERRors:DIGital2000Condition Register Bit Assignment
  • STATus:QUEStionable:ERRors:DIGital95 Condition Register Bit Assignment
  • STATus:QUEStionable:ERRors:TA2000 Register Bit Assignments
  • STATus:QUEStionable:HARDware Condition Register Bit Assignment

SYSTem Subsystem

  • SYSTem:APPLication[:CURRent][:NAME]?
  • SYSTem:APPLication[:CURRent]:REVision?
  • SYSTem:APPLication:CATalog[:NAME]?
  • SYSTem:APPLication:CATalog[:NAME]:COUNt?
  • SYSTem:APPLication:CATalog:FORMat?
  • SYSTem:APPLication:CATalog:FORMat:COUNt?
  • SYSTem:APPLication:CATalog:LICense?<sp>'<application name>','<revision>'
  • SYSTem:APPLication:CATalog:LICense:APPLication:ALL?
  • SYSTem:APPLication:CATalog:LICense:APPLication:COUNt?
  • SYSTem:APPLication:CATalog:REVision?<sp>'<application name>'
  • SYSTem:APPLication:CATalog:REVision:COUNt?<sp>'<application name>'
  • SYSTem:APPLication:FORMat[:NAME]
  • SYSTem:APPLication:FORMat:LICense?<sp>'<format name>'
  • SYSTem:APPLication:SELect[:NAME]
  • SYSTem:APPLication:SELect:REVision
  • SYSTem:APPLication:SELect:REVision?<sp>'<application name>'
  • SYSTem:AUDio:OUTPut:SOURce
  • SYSTem:AUDio:OUTPut:FMDemod:BPFilter:STATe
  • SYSTem:AUDio:OUTPut:FMDemod:EXPandor:STATe
  • SYSTem:AUDio:OUTPut:FMDemod:DEEMphasis:STATe
  • SYSTem:BEEPer:STATe
  • SYSTem:COMMunicate:GPIB:[:SELF]:ADDRess
  • SYSTem:COMMunicate:GPIB:DEBug[:STATe]
  • SYSTem:COMMunicate:LAN[:SELF]:ADDRess
  • SYSTem:COMMunicate:LAN[:SELF]:DGATeway
  • SYSTem:COMMunicate:LAN[:SELF]:SMASk
  • SYSTem:COMMunicate:LAN:EXTernal:ADDRess
  • SYSTem:COMMunicate:LAN:EXTernal:SYNChronize
  • SYSTem:COMMunicate:LAN:EXTernal:SYNChronize:INDication:CLEar
  • SYSTem:CONFigure:INFormation:HARDware:VERBose?
  • SYSTem:CORRection:[:SGAin]
  • SYSTem:CORRection:FREQuency
  • SYSTem:CORRection:GAIN
  • SYSTem:CORRection:POINts
  • SYSTem:CORRection:SFRequency
  • SYSTem:CORRection:STATe
  • SYSTem:CURRent:TA:MODel?
  • SYSTem:CURRent:TA:NAME?
  • SYSTem:CURRent:TA:REVision?
  • SYSTem:DATE
  • SYSTem:ERRor?
  • SYSTem:FATal:ERRor:RESTart
  • SYSTem:INSTrument:THERmal:POWer:NULL:ADJust?
  • SYSTem:LOG:UI:COUNt?
  • SYSTem:LOG:UI:CLEAR
  • SYSTem:LOG:UI:GPIB[:STATe]
  • SYSTem:LOG:UI:REPort?
  • SYSTem:MEASurement:RESet
  • SYSTem:PRESet[1] (not recommended for use)
  • SYSTem:PRESet2
  • SYSTem:PRESet3
  • SYSTem:REGister:SAVe
  • SYSTem:REGister:RECall
  • SYSTem:REGister:DELete
  • SYSTem:ROSCillator[:TIMebase]?
  • SYSTem:ROSCillator:LOCKed?
  • SYSTem:SYNChronized
  • SYSTem:STATus:COMMunicate:LAN:EXTernal:SYNChronize:INDication?
  • SYSTem:TIME
  • SYSTem:TZONe
  • SYSTem:UTC[:TIME]
  • SYSTem:UTC:DATE


READ

READ

Last updated: June 7, 2007

GPIB Command Conventions

  • READ:AFANalyzer[:ALL]?
  • READ:ATXPower[:ALL]?
  • READ:CAPPower[:ALL]?
  • READ:CCTPhase[:ALL]?
  • READ:CFDTune[:ALL]?
  • READ:CFERror[:ALL]?
  • READ:CMAudio[:ALL]?
  • READ:CMMPower[:ALL]?
  • READ:CPOWer[:ALL]?
  • READ:CTDPower[:ALL]?
  • READ:CTXS purious[:ALL]?
  • READ:DAPower[:ALL]?
  • READ:DTMF[:ALL]?
  • READ:FM[:ALL]?
  • READ:GAPPower[:ALL][:RANGe20]?
  • READ:GAPPower[:ALL]:RANGe60?
  • READ:FSTability[:ALL]?
  • READ:GPOWer[:ALL]?
  • READ:HWQuality[:ALL]?
  • READ:SAUDio[:ALL]?
  • READ:STONe[:ALL]?
  • READ:SMONitor:TRACe?
  • READ:TFERror[:ALL]?
  • READ:TROPower[:ALL]?
  • READ:WDDeviation[:ALL]?
  • READ:WQUality[:ALL]?

READ:AFANalyzer[:ALL]?

Function

Initiates and fetches an audio frequency analyzer measurement as a sequential operation.

Measurement results are returned in the following order: integrity, average audio level, average SINAD, average audio distortion.
Query

Integrity

  • Range: 0 to 31 see Integrity Indicator

  • Resolution: 1

Average audio level

  • Range: 0 to 20 volts, 9.91 E+37
  • Resolution: the lesser of 4 significant digits or 10 uV.

Average SINAD

  • Range: -99.00 to 99.00 dB, 9.91 E+37
  • Resolution: 0.01 dB

Average audio distortion

  • Range: 0.00 to 99.00%, 9.91 E+37
  • Resolution: 0.01%

READ:ATXPower[:ALL]?

Function

Initiates and fetches an analog transmitter power measurement as a sequential operation.

Measurement results are returned in the following order: integrity, average analog power.
Query

Integrity

  • Range: 0 to 31 see Integrity Indicator

  • Resolution: 1

Average analog transmitter power

  • Range: -100.00 to 100.00 dBm, 9.91 E+37
  • Resolution: 0.01 dB

READ:CAPPower[:ALL]?

Function

Initiates and fetches an access probe power measurement as a sequential operation.

Measurement results are returned in the following order: integrity, access probe power.
Query

Integrity

  • Range: 0 to 31 see Integrity Indicator

  • Resolution: 1

Access probe power

  • Range: -100.00 to 100.00 dBm, 9.91 E+37
  • Resolution: 0.01 dB

READ:CCTPhase[:ALL]?

Function

Initiates and fetches a code channel time and phase error measurement as a sequential operation.

Measurement results are returned in the following order: integrity, time error pass/fail indication, phase error pass/fail indication.
Query

Integrity

  • Range: 0 to 31 see Integrity Indicator

  • Resolution: 1

Time error pass/fail indicator:

  • Range: 0 (pass), 1 (fail), 9.91 E+37

Phase error pass/fail indicator:

  • Range: 0 (pass), 1 (fail), 9.91 E+37

READ:CFDTune[:ALL]?

Function

Queries the fast device tune (FDT) measurement results.

Results are returned in the following order:

  • Integrity
  • Number of Frequency Steps
  • Number of Power Steps
  • Number of MS TX power steps measured (in most cases, it equals Number of Frequency Steps multiplied by Number of Power Steps )
  • Comma-separated list of 400 MS Tx Power results. 400 results are always returned; if the test set measured fewer than 400 power steps from the mobile, the remaining values are NANs (9.91E+37). The power results for the first frequency in the MS TX Frequency Sequence are returned first, then the power results for the second frequency in the MS TX Frequency Sequence, etc., followed by NANs if fewer than 400 points were measured.

See Fast Device Tune Measurement Results .
Query

Integrity

  • Range: 0 to 31 see Integrity Indicator

  • Resolution: 1

Frequency Step Count

  • Range: 1 to 20, 9.91 E+37 (NAN)

  • Resolution: 1

Power Step Count

  • Range: 1 to 20, 9.91 E+37 (NAN)

  • Resolution: 1

Number of Steps in MS Tx Power Results

  • Range: 1 to 400, 9.91 E+37 (NAN)

  • Resolution: 1

MS Tx Power Results Array

  • Range: -100.00 to +100.00 dBm, 9.91 E+37 (NAN)

  • Resolution: 0.01 dBm

Requirements

Test Application Revision: B.11 and above, with the required feature license

Lab Application Revision: B.04 and above

READ:CFERror[:ALL]?

Function

Initiates and fetches the FER (frame error rate) measurements as a sequential operation.

FER measurement results are returned in the following order: integrity, confidence limit pass/fail result, frame error ratio, frame error count, frames tested.
Query

Integrity

  • Range: 0 to 31 see Integrity Indicator

  • Resolution: 1

Confidence limit pass/fail result

  • Range: 0 to 2 (0 = passed, 1 = failed, 2 = max frames), 9.91 E+37

Frame error ratio

  • Range: 0.00 to 100.00, 9.91 E+37

  • Resolution: 0.01 %

Frame error count

  • Range: 0 to 10,000,000, 9.91 E+37

  • Resolution: 1 frame

Frames tested

  • Range: 0 to 10,000,000, 9.91 E+37

  • Resolution: 1 frame

READ:CMAudio[:ALL]?

Function

Initiates and fetches a multi-tone audio measurement as a sequential operation.

Measurement results are returned in the following order: integrity, and a comma separated list of all multi-tone audio measured levels for all 20 audio tones (in dB unit).

For the levels, the query will return NAN (9.91E+37) for any audio tone that is turned off. For downlink audio measurements, the audio tones are turned off and on by SETup:CMAudio:GENerator:FREQuency:DOWNlink:PRESet . For uplink audio measurements, the audio tones can be turned off and on by SETup:CMAudio:GENerator:FREQuency:Uplink:PRESet , SETup:CMAudio:GENerator:FREQuency:Uplink:ALL[:SVALue] , or SETup:CMAudio:GENerator:LEVel:UPLink:ALL[:SAMPlitude] .

Query

Integrity

  • Range: 0 to 31 see Integrity Indicator

  • Resolution: 1

Multi-Tone Audio measured level

  • Range: -100 to +100 dB (for each tone)
  • Resolution: 0.1 dB

Requirements

Test Application Revision: B.08 and above.

Lab Application Revision: B.02 and above.

READ:CMMPower[:ALL]?

Function

Initiates and fetches the maximum/minimum power measurement as a sequential operation.

Measurement results are returned in the following order: integrity, maximum power result, minimum power result.
Query

Integrity

  • Range: 0 to 31 see Integrity Indicator

  • Resolution: 1

Maximum power

  • Range: -100.00 to 100.00 dBm, 9.91 E+37
  • Resolution: 0.01 dB

Minimum power

  • Range: -100.00 to 100.00 dBm, 9.91 E+37
  • Resolution: 0.01 dB

Requirements

Test Application Revision: B.07 and above.

Lab Application Revision: B.01 and above.

READ:CPOWer[:ALL]?

Function

Initiates and fetches a channel power measurement as a sequential operation.

Measurement results are returned in the following order: integrity, average channel power.

If the multi-measurement state is on, the result represents the average of a number of channel power measurements. Multi-measurement state, by default, is off. To set up multi-measurements, see SETup:CPOWer:COUNt[:SNUMber] .

Query

Integrity

  • Range: 0 to 31 see Integrity Indicator

  • Resolution: 1

Channel power

  • Range: -100.00 to 100.00 dBm, 9.91 E+37
  • Resolution: 0.01 dB

READ:CTDPower[:ALL]?

Function

Initiates and fetches Tx dynamic power measurement as a sequential operation.

This query returns 101 comma-separated values, in the order of an integrity value followed by 100 power results. If the dynamic power measurement consists of less than 100 measurement steps (determined by FETCh:CTDPower:COUNt[:STEP]? ), the query results will be padded with NAN's (9.91 E+37), which means no results were available.

Query

Integrity

  • Range: 0 to 31 see Integrity Indicator

  • Resolution: 1

Channel power

  • Range: -100.00 to 100.00 dBm, 9.91 E+37
  • Resolution: 0.01 dB

Requirements

Test Application Revision: B.07 and above.

Lab Application Revision: B.01 and above.

READ:CTXS purious[:ALL]?

Function

Initiates and fetches the TX spurious emission measurement as a sequential operation.

FER measurement results are returned in the following order: integrity,TX spurious emission pass/fail result, lower adjacent channel (-0.885 or -1.25 MHz) average spurious emissions, upper adjacent channel (+0.885 or +1.25 MHz) average spurious emissions, lower alternate channel (-1.98 MHz) average spurious emissions, upper alternate channel (+1.98 MHz) average spurious emissions.
Query

Integrity

  • Range: 0 to 31 see Integrity Indicator

  • Resolution: 1

TX spurious emissions pass/fail result

  • Range: 0 to 1 (0 = passed, 1 = failed), 9.91 E+37

Lower adjacent channel spurious emissions

  • Range: 0.00 to -70.00 dBc, 9.91 E+37

  • Resolution: 0.01 dBc

Upper adjacent channel spurious emissions

  • Range: 0.00 to -70.00 dBc, 9.91 E+37

  • Resolution: 0.01 dBc

Lower alternate channel spurious emissions

  • Range: 0.00 to -70.00 dBc, 9.91 E+37

  • Resolution: 0.01 dBc

Upper alternate channel spurious emissions

  • Range: 0.00 to -70.00 dBc, 9.91 E+37

  • Resolution: 0.01 dBc

READ:DAPower[:ALL]?

Function

Initiates and fetches a digital average power measurement as a sequential operation.

Measurement results are returned in the following order: integrity, digital average transmit power.

If the multi-measurement state is on, the result represents the average of a number of digital average power measurements. Multi-measurement state, by default, is off. To set up multi-measurements, see SETup:DAPower:COUNt[:SNUMber] .

Query

Integrity

  • Range: 0 to 31 see Integrity Indicator

  • Resolution: 1

Digital average power:

  • Range: -100.00 to 100.00 dBm, 9.91 E+37
  • Resolution: 0.01 dB

READ:DTMF[:ALL]?

Function

Initiates and fetches the a DTMF measurement as a sequential operation.

Measurement results are returned in the following order: integrity, number of characters, then 16 sets of 9 comma-separated values in the following order: character n symbol, character n low tone frequency, character n low tone frequency error, character n low tone phase deviation, character n high tone frequency, character n high tone frequency error, Character n high tone phase deviation, character n on time, character n off time. n is from 0 to 15.

Query

Integrity

  • Range: 0 to 31 see Integrity Indicator

  • Resolution: 1

Number of characters

  • Range: 0 to 16

  • Resolution: 1

Character n Symbol

  • Range: 0 to 15, 9.91 E+37

    The result is a numeric real result corresponding to actual character result 0 to 9, A, B, C, D, * and #.

Character n Low Tone Frequency

  • Range: 0 Hz to 999 Hz, 9.91 E+37

Character n Low Tone Frequency Error

  • Range: -99 Hz to 99 Hz, 9.91 E+37

Character n Low Tone Phase Deviation

  • Range: 0 to 9 Radians, 9.91 E+37

Character n High Tone Frequency

  • Range: 0 to 2,000 Hz, 9.91 E+37

Character n High Tone Frequency Error

  • Range: -99 to 99 Hz, 9.91 E+37

Character n High Tone Phase Deviation

  • Range: 0 to 9 Radians, 9.91 E+37

Character n On Time

  • Range: 0 to 6,000 ms, 9.91 E+37

Character n Off Time

  • Range: 0 to 6,000 ms, 9.91 E+37

Requirements

Test Application Revision: B.09 or above

Lab Application Revision: B.03 or above

READ:FM[:ALL]?

Function

Initiates and fetches an FM measurement as a sequential operation.

Measurement results are returned in the following order: integrity, average frequency deviation, average distortion.

The distortion measurement must be enabled before a measurement result (other than 9.91E+37) is reported. See SETup:AFANalyzer:SDIStortion:STATe .
Query

Integrity

  • Range: 0 to 31 see Integrity Indicator

  • Resolution: 1

Average FM frequency deviation

  • Range: 0.000 to 99.000 kHz, 9.91 E+37
  • Resolution: 0.001 Hz

Average FM distortion

  • Range :0.0 to 100.0%, 9.91 E+37
  • Resolution: 0.1%

Average FM frequency

  • Range: 0.0 to 99999.0 Hz, 9.91 E+37

  • Resolution: 0.1 Hz

READ:GAPPower[:ALL][:RANGe20]?

Function

Initiates and fetches a graphical access probe power measurement cycle as a sequential operation.

This measurement returns results in the following order: integrity, followed by a comma-separated list of 20 access probe power results.

If the graphical access probe power measurement consisted of less than 20 access probes, the query results will be padded with NAN's (9.91 E37) to make the number of measurements equal 20.

If the test set does not receive the expected number of access probes and no timeouts have been set up this command will hang indefinitely.
Query

Integrity

  • Range: 0 to 31 (see Integrity Indicator )

    Resolution: 1

Access probes

  • Range: -100 to 100 dBm, 9.91 E+37

  • Resolution: 0.0000001 dBm

Requirements

Lab Application Revision: A.01 and above

READ:GAPPower[:ALL]:RANGe60?

Function

Initiates and fetches a graphical access probe power measurement cycle as a sequential operation.

This measurement returns results in the following order: integrity, followed by a comma-separated list of 60 access probe power results.

If the graphical access probe power measurement consisted of less than 60 access probes, the query results will be padded with NAN's (9.91 E37) to make the number of measurements equal 60.

If the test set does not receive the expected number of access probes and no timeouts have been set up this command will hang indefinitely.
Query

Integrity

  • Range: 0 to 31 (see Integrity Indicator )

    Resolution: 1

Access probes

  • Range: -100 to 100 dBm, 9.91 E+37

  • Resolution: 0.0000001 dBm

Requirements

Lab Application Revision: A.02 and above

READ:FSTability[:ALL]?

Function

Initiates and fetches a frequency stability measurement as a sequential operation.

Measurement results are returned in the following order: integrity, worst-case frequency error, average frequency.
Query

Integrity

  • Range: 0 to 31 see Integrity Indicator

  • Resolution: 1

Worst-case frequency error

  • Range: -500.00 to 500.00 parts per million (ppm), 9.91 E+37
  • Resolution: 0.01

Average frequency

  • Range: 100 E+6 to 3 E+9 Hz, 9.91 E+37
  • Resolution: 1 Hz

READ:GPOWer[:ALL]?

Function

Initiates and fetches a gated power measurement as a sequential operation.

Measurement results are returned in the following order: integrity, gated power pass/fail indication.
Query

Integrity

  • Range: 0 to 31 see Integrity Indicator

  • Resolution: 1

Pass/fail indicator:

  • Range: 0 (pass), 1 (fail), 9.91 E+37

READ:HWQuality[:ALL]?

Function

Initiates and fetches the handoff waveform quality measurements as a sequential operation.

Measurement results are returned in the following order: integrity, rho, frequency error, time error, carrier feedthrough, phase error, magnitude error.
Query

Integrity

  • Range: 0 to 31

  • Resolution: 1

Rho

  • Range: 0.000 to 1.000, 9.91 E+37

  • Resolution: 0.001

Frequency Error

  • Range: -9999.0 to 9999.0 Hz, 9.91 E+37

  • Resolution: 0.1 Hz

Time Error

  • Range: -99.99 E-6 to 99.99 E-6 s, 9.91 E+37

  • Resolution: 0.01 E-6 s

Carrier Feedthrough

  • Range: -100 to 0.0 dB, 9.91 E+37

  • Resolution: 0.1

Phase Error

  • Range: 0.00 to 359.99 degrees

  • Resolution: 0.01

Magnitude Error

  • Range: 0 to 100%, 9.91 E+37

  • Resolution: 0.01

READ:SAUDio[:ALL]?

Function

Initiates and fetches a swept audio measurement as a sequential operation.

Measurement results are returned in the following order: integrity, and a comma separated list of average audio level and average audio distortion for each frequency point in the sweep.

For frequencies about 10 kHz, the measurement will return 9.91 E+37.

Query

Integrity

  • Range: 0 to 31 see Integrity Indicator

  • Resolution: 1

Average Audio Level

  • Range: 1 mV to 20 V, 9.91 E+37
  • Resolution: the lesser of 4 significant digits or 10 uV

Average Audio Distortion

  • Range: 0 to 99.9%, 9.91E+37
  • Resolution: 0.1

READ:STONe[:ALL]?

Function

Initiates and fetches the signaling tone measurements as a sequential operation.

Measurement results are returned in the following order: integrity, positive peak deviation, negative peak deviation, frequency error and frequency.

When multi-measurement is enabled, the average positive peak deviation, average negative peak deviation, average frequency error and average frequency from all the measurements are returned.

Query

Integrity

  • Range: 0 to 31 see Integrity Indicator

  • Resolution: 1

Average positive peak deviation

  • Range: -20 to 20 kHz, 9.91 E+37

Average negative peak deviation

  • Range: -20 to 20 kHz, 9.91 E+37

Average frequency error

  • Range: -10,000 Hz to 10,000 Hz, 9.91 E+37

Average frequency

  • Range: 0 to 20,000 Hz, 9.91 E+37

Requirements

Test Application Revision: B.09 or above

Lab Application Revision: B.03 or above

READ:SMONitor:TRACe?

Function

Queries (initiates and fetches) one spectrum monitor measurement as a sequential operation.

Returns a comma separated list of 401 points representing the amplitude results of the trace data.

Query

Range:

  • For spans of 125 kHz and 500 kHz

    • frequency of point: within the current span (relative to the center frequency)
    • amplitude of point: -50 to +55 dB

  • For all other spans

    • frequency of point: within the current span (relative to the center frequency)
    • amplitude of point: (reference level - 60 dB) to +55 dB

READ:TFERror[:ALL]?

Function

Initiates and fetches the TDSO FER (test data service option (SO32) frame error rate) measurements as a sequential operation.

FER measurement results are returned in the following order: integrity, frame error rate (%), received good frames, received blank frames, transmitted good frames, transmitted blank frames, frame error rate confidence (%).
Query

Integrity

  • Range: 0 to 31 see Integrity Indicator

  • Resolution: 1

Frame error rate

  • Range: 0.00 to 100.00, 9.91 E+37

  • Resolution: 0.01 %

Received good frames

  • Range: 0 to 999936, 9.91 E+37

Transmitted blank frames

  • Range: 0 to 999936, 9.91 E+37

Received good frames

  • Range: 0 to 999936, 9.91 E+37

Transmitted blank frames

  • Range: 0 to 999936, 9.91 E+37

Frame error rate confidence

  • Range: 0.00 to 100.00, 9.91 E+37

  • Resolution: 0.01 %

READ:TROPower[:ALL]?

Function

Initiates and fetches a time response of open loop power control measurement as a sequential operation.

Measurement results are returned in the following order: integrity, time response of open loop power control pass/fail result. For the pass/fail result, 0 = pass, 1 = fail, 9.91 E+37 = undefined.

Query

Integrity

  • Range: 0 to 31 see Integrity Indicator

  • Resolution: 1

Time Response of Open Loop Power Control

  • Range: 0, 1, 9.91 E+37

READ:WDDeviation[:ALL]?

Function

Initiates and fetches the Wideband Data Deviation measurement as a sequential operation.

Measurement results are returned in the following order: integrity, maximum positive peak frequency deviation, maximum negative peak frequency deviation, settled positive peak frequency deviation, settled negative peak frequency deviation.

If the measurement gets more than one wideband data burst, it measures the first one.

Query

Integrity

  • Range: 0 to 31 see Integrity Indicator

  • Resolution: 1

Maximum positive peak frequency deviation

  • Range: 0 to 20 kHz, 9.91 E+37

Minimum negative peak frequency deviation

  • Range: 0 to 20 kHz, 9.91 E+37

Settled positive peak frequency deviation

  • Range: 0 Hz to 20 kHz, 9.91 E+37

Settled negative peak frequency deviation

  • Range: 0 to 20 kHz, 9.91 E+37

Requirements

Test Application Revision: B.09 or above

Lab Application Revision: B.03 or above

READ:WQUality[:ALL]?

Function

Initiates and fetches the waveform quality measurements as a sequential operation.

Measurement results are returned in the following order: integrity, rho, frequency error, time error, carrier feedthrough, phase error, magnitude error, EVM.

If the multi-measurement state is on, each result represents the average of a number of waveform quality measurements. Multi-measurement state, by default, is off. To set up multi-measurements, see SETup:WQUality:COUNt[:SNUMber] .

Query

Integrity

  • Range: 0 to 31
  • Resolution: 1

Rho

  • Range: 0.000 to 1.000, 9.91 E+37
  • Resolution: 0.001

Frequency Error

  • Range: -9999.0 to 9999.0 Hz, 9.91 E+37
  • Resolution: 0.1 Hz

Time Error

  • Range: -99.99 E-6 to 99.99 E-6 s, 9.91 E+37

  • Resolution: 0.01 E-6 s

Carrier Feedthrough

  • Range: -100.0 to 0.0 dB, 9.91 E+37
  • Resolution: 0.1 dB

Phase Error

  • Range: 0.00 to 359.99 degrees
  • Resolution: 0.01 degrees

Magnitude Error

  • Range: 0.00 to 100.00%, 9.91 E+37
  • Resolution: 0.01%

Error Vector Magnitude (EVM)

  • Range: 0.00 to 100.00%
  • Resolution: 0.01%


READ? Subsystem

READ? Subsystem

Last updated: October 28, 2004

Syntax Diagram and Command Descriptions

READ

Description

The READ? command provides a sequential method to make measurements and retrieve the results. READ? will hang the GPIB bus until the measurement is completed, or until the timeout value has been exceeded. Associated SETup commands (for each measurement) are used with the READ? command to retrieve desired measurement results in a sequential manner.

Sending a READ? command is equivalent to an INITiate/FETCh cycle for a measurement. A READ? command executes an abort action on that measurement followed by an INITiate and a FETCH?.

READ? commands can be mixed with FETCH? queries in order to make combinations of sequential and overlapped operations. One measurement can be issued a READ? command (sequential), and the next measurement can be issued INITiate/FETCh? commands (overlapped), if necessary.

The advantage of using the READ? commands to obtain measurement results, as opposed to the INITiate/FETCh method is:

  • It is simpler. Fewer commands are required to obtain measurement results.

Some disadvantages of using READ? over INITiate and FETCh are:

  • The test set does not process any additional GPIB commands until the requested measurement results are available.
  • The sequential nature of the READ? command does not allow the user to make concurrent measurements. Concurrent measurements require the overlapped commands INITiate, DONE? and FETCh? .
  • The READ? command does not provide measurement results such as statistics that are available using the INITiate/FETCh method.
  • The READ? commands have pre-defined measurement results. If additional results are needed from a measurement they may be obtained with a FETCh? query.

NOTE
Trigger arming for each measurement is controlled in the SETup subsystem. Best practice during remote operation is to set trigger arm to single (Continuous Off).

Program Example - READ:DAPower?

OUTPUT 714;"READ:DAPower?" !Starts digital average power measurement. As soon as the
                           !measurement cycle has completed, the test set
                           !provides the digital average power measurement results to the
                           !controlling application.
ENTER 714;Integrity, Digital_power !Enters the integity indicator and
                                      !digital average power measurement values into
                                      !controlling application.


RFANalyzer

RFANalyzer

Last updated: June 7, 2007

GPIB Command Conventions

  • RFANalyzer:AUTO:POWer[:SELected]?
  • RFANalyzer:CONTrol:MEASurement:FREQuency:AUTO
  • RFANalyzer:CONTrol:POWer:AUTO
  • RFANalyzer:CONTrol:UPLink:FREQuency:AUTO
  • RFANalyzer:CW:EXPected:POWer
  • RFANalyzer:MANual:POWer[:SELected]
  • RFANalyzer:MANual:ANALog:POWer[:SELected]
  • RFANalyzer:MANual:ANALog:POWer:CELLular
  • RFANalyzer:MANual:MEASurement[:MFRequency]
  • RFANalyzer:MANual:MEASurement:FREQuency
  • RFANalyzer:MANual:UPLink[:MFRequency]
  • RFANalyzer:MANual:UPLink:FREQuency

RFANalyzer:AUTO:POWer[:SELected]?

Function

Queries the expected input power when the test set's power detector control mode is set to automatic.

The optional [:SELected] keyword in this command specifies that the expected input power setting being queried applies to the current system type.

The test set's power control mode is set by the RFANalyzer:CONTrol:POWer:AUTO command.

Query

Range: -69 dBm to +30 dBm

Resolution: 0.01 dBm
*RST setting

-21 dBm

Programming Example

OUTPUT 714;"RFANalyzer:AUTO:POWER:SELECTED?"

!Queries the expected input power for the currently selected system type when the power detector is
!set to automatic control mode.

RFANalyzer:CONTrol:MEASurement:FREQuency:AUTO

Function

Turns on/off the auto Meas Frequency feature which determines the measurement downconverter signal path frequency control mode. (See Block Diagram .)

ON = automatic

OFF = manual

Setting

 Range: 1|ON|0|OFF

Query

Range: 1|0
*RST setting 1 (on)

Programming Example

OUTPUT 714;"RFANalyzer:CONTrol:MEASurement:FREQuency:AUTO OFF"
!Enables manual control of the measurement signal path tune frequency.

RFANalyzer:CONTrol:POWer:AUTO

Function

Sets/queries the test set's receiver input power control mode.

ON = automatic

OFF = manual

Setting

Range: 1|ON|0|OFF

Query

Range: 1|0
*RST setting 1 (on)

Programming Example

OUTPUT 714;"RFANALYZER:CONTROL:POWER:AUTO OFF"

!Enables manual control of the expected input power level.

RFANalyzer:CONTrol:UPLink:FREQuency:AUTO

Function

Sets/queries the test set's demodulation signal path tune frequency control mode.

ON = automatic

OFF = manual.

Setting

Range: 1|ON|0|OFF

Query

Range: 1|0
*RST setting 1 (on)

Programming Example

OUTPUT 714;"RFANALYZER:CONTROL:UPLINK:FREQUENCY:AUTO OFF" !Enables manual control of the demodulation signal path tune frequency.

RFANalyzer:CW:EXPected:POWer

Function

Sets/queries the expected CW receiver input power. This setting is only used when the Operating Mode is set to CW. (See CALL:OPERating .)

Setting

Range: -80 dBm to +93 dBm (interacts with the Amplitude Offset setting to determine the available range)

Query

Same as settings.
*RST setting +13 dBm

Programming Example

OUTPUT 714;"RFANALYZER:CW:EXPECTED:POWER -20"

RFANalyzer:MANual:POWer[:SELected]

Function

Sets/queries the receiver expected input power when the test set's receiver input power control mode is set to manual by the RFANalyzer:CONTrol:POWer:AUTO command. See Receiver Control for details on manual receiver control.

The optional [:SELected] keyword in this command specifies that the expected input power setting being queried applies to the current system type.

The test set's measuring receiver will consider any amplitude offsets that are defined along with this setting to calculate input power range settings.

Setting

Range: -129 dBm to +80 dBm (This is the range of settings accepted, the actual hardware range of the detector is -79 dBm to 30 dBm with Amplitude Offset = 0)

Resolution: 0.01 dBm

Query

 Same as setting.
*RST setting 0 dBm

Programming Example

OUTPUT 714;"RFANALYZER:MANUAL:POWER:SELECTED 24 DBM" !Sets the manual power control mode expected input power level for the currently selected system type to 24 dBm.

RFANalyzer:MANual:ANALog:POWer[:SELected]

Function

Sets/queries the expected power when the mobile is on an analog voice channel. The selected band is currently limited to the cellular band (800 MHz).

Setting

Range: -80 dBm to +93 dBm (interacts with the Amplitude Offset setting to determine the available range)

Resolution: 0.01 dB

Query

Range: -80 dBm to +93 dBm

Resolution: 0.01 dBm
*RST setting +13 dBm

Programming Example

OUTPUT 714;"RFANalyzer:MANual:ANALog:POWer:SELECTED 24 DBM"

RFANalyzer:MANual:ANALog:POWer:CELLular

Function

Sets/queries the expected power when the mobile is on a cellular band (800 MHz) analog voice channel.

Setting

Range: -80 dBm to +93 dBm (interacts with the Amplitude Offset setting to determine the available range)

Resolution: 0.01 dBm

Query

 Range: -80 dBm to +93 dBm
*RST setting +13 dBm

Programming Example

OUTPUT 714;"RFANalyzer:MANual:ANALog:POWer:CELLular 24 DBM"

RFANalyzer:MANual:MEASurement[:MFRequency]

Function

The setting form of this command performs two functions: (1) sets the Meas Frequency of the test set's measurement signal path, and (2) selects manual (auto off) tune mode for the test set's measurement signal path. (See Block Diagram .)

The query form of this command returns the tune frequency of the test set's measurement signal path.

The tune mode for the test set's measurement signal path can be returned to auto using the RFANalyzer:CONTrol:MEASurement:FREQuency:AUTO command.

Setting

Range: 292.5 MHz to 2700 MHz

Resolution: 0.1 Hz

Query

 Range: 292.5 MHz to 2700 MHz
*RST setting 896 MHz

Programming Example

OUTPUT 714;"RFANALYZER:MANUAL:MEASUREMENT:MFREQUENCY 942.6 MHZ"
!Enables manual control of the measurement signal path tune frequency and sets the tune frequency to 942.6 MHz.

RFANalyzer:MANual:MEASurement:FREQuency

Function

Sets/queries Meas Frequency, the measurement downconverter signal path frequency control mode. (See Block Diagram .)

This setting is applied when manual mode is selected (see RFANalyzer:CONTrol:MEASurement:FREQuency:AUTO ).

Setting

Range: 292.5 MHz to 2700 MHz

Resolution: 0.1 Hz

Query

 Range: 292.5 MHz to 2700 MHz
*RST setting 896 MHz

Programming Example

OUTPUT 714;"RFANALYZER:MANUAL:MEASUREMENT:FREQUENCY 942.6 MHZ"
!Sets the measurement signal path tune frequency to 942.6 MHz when manual control mode is used.

RFANalyzer:MANual:UPLink[:MFRequency]

Function

The setting form of this command performs two functions: (1) sets the tune frequency of the test set's demodulation signal path, and (2) selects manual tune mode for the test set's demodulation signal path.

The query form of this command returns the tune frequency of the test set's demodulation signal path.

The tune mode for the test set's demodulation path can be returned to auto using the RFANalyzer:CONTrol:UPLink:FREQuency:AUTO command.

Setting

Range: 292.5 MHz to 2700 MHz

Resolution: 0.1 Hz

Query

 Range: 292.5 MHz to 2700 MHz
*RST setting 896 MHz

Programming Example

OUTPUT 714;"RFANALYZER:MANUAL:UPLINK:MFREQUENCY 1955.030 MHZ"

!Enables manual control of the demodulation signal path tune frequency and sets the tune frequency
!to 1955.030 MHz.

RFANalyzer:MANual:UPLink:FREQuency

Function

Sets/queries the tune frequency of the test set's demodulation signal path.

This setting is applied when manual mode is selected (see RFANalyzer:CONTrol:UPLink:FREQuency:AUTO ).

Setting

Range: 292.5 MHz to 2700 MHz

Resolution: 0.1 Hz

Query

Range: 292.5 MHz to 2700 MHz
*RST setting 896 MHz

Programming Example

OUTPUT 714;"RFANALYZER:MANUAL:UPLINK:FREQUENCY 942.6 MHZ"
!Sets the test set's demodulation signal path tune frequency to 942.6 MHz.


RFANalyzer Subsystem

RFANalyzer Subsystem

Last updated: October 28, 2004

Description

The RFANalyzer command subsystem performs "lower-level" functions that control the test set's measuring receiver. The measuring receiver includes three separate signal paths:

  • Power detector
  • Demodulation
  • Measurement

Refer to the Block Diagram for a description of the signal paths.

The RFANalyzer commands allow manual settings to the tune frequency or expected power level to each of these paths if it is necessary to override automatic settings.

Syntax Diagrams and Command Descriptions

RFANalyzer


RFGenerator: OUTPut

RFGenerator: OUTPut

Last updated: June 7, 2007

GPIB Command Conventions

  • RFGenerator:OUTPut[:DESTination]

RFGenerator:OUTPut[:DESTination]

Function

Sets/queries the RF output port destination: RF IN/OUT (IO) or RF OUT ONLY (OUT).

If the correct hardware is not installed when trying to change to the RF OUT ONLY port, the test set displays the following error: Hardware error; RFIO version does not support RF out only selection.

The query form will always return a value, regardless of the hardware version.

Setting

Range: IO|OUT

Query

Range: IO|OUT

*RST Setting

IO

Requirements

Test Application Revision: B.03.00 and above

Hardware: RF Input/Output module with second RF output connector, modified front panel.

Programming Example

OUTPUT 714;"RFGENERATOR:OUTPUT:DESTINATION OUT"
!Sets the RF generator's output destination to the RF Out Only port.


RFGenerator Subsystem

RFGenerator Subsystem

Last updated: October 28, 2004

Description

The RFGenerator subsystem selects the RF generator output port on test sets equipped with both the RF IN/OUT port and the RF OUT ONLY port. If the test set does not have the RF OUT ONLY port, an error message is generated when attempting to switch output ports.

The RF OUT ONLY port may not be used with some test applications or lab applications. In that case, a message is displayed that tells you that the port could not be switched.

Syntax Diagrams and Command Descriptions

RFGenerator: OUTPut


SETup:AFANalyzer

SETup:AFANalyzer

Last updated: June 7, 2007

GPIB Command Conventions

  • SETup:AFANalyzer:CONTinuous
  • SETup:AFANalyzer:COUNt[:SNUMber]
  • SETup:AFANalyzer:COUNt:NUMBer
  • SETup:AFANalyzer:COUNt:STATe
  • SETup:AFANalyzer:DEMPhasis:STATe
  • SETup:AFANalyzer:DETector[:TYPE]
  • SETup:AFANalyzer:EXPandor[:SRLevel]
  • SETup:AFANalyzer:EXPandor:RLEVel
  • SETup:AFANalyzer:EXPandor:STATe
  • SETup:AFANalyzer:FILTer[:TYPE]
  • SETup:AFANalyzer:FILTer:TBPass[:FREQuency]
  • SETup:AFANalyzer:FREQuency:STATe
  • SETup:AFANalyzer:PEAK:VOLTage
  • SETup:AFANalyzer:SDIStortion:FREQuency
  • SETup:AFANalyzer:SDIStortion:STATe
  • SETup:AFANalyzer:TIMeout[:STIMe]
  • SETup:AFANalyzer:TIMeout:STATe
  • SETup:AFANalyzer:TIMeout:TIME

SETup:AFANalyzer:CONTinuous

Function

Sets/queries the trigger arm state for the AF analyzer measurement. Determines whether measurement will make one measurement then stop (0|OFF (single)), or automatically rearm upon completion of one measurement and repeat the process (1|ON (continuous)).

Setting

Range: 1|ON|0|OFF

Query

Range: 1|0

*RST Setting

0 (off)

Programming Example

OUTPUT 714;"SETUP:AFANALYZER:CONTINUOUS OFF"
!Sets measurement to single trigger mode.

SETup:AFANalyzer:COUNt[:SNUMber]

Function

Sets/queries the number of AF analyzer measurements to be made in a multi-measurement setup. This command sets the count, and automatically sets the multi-measurement STATe command to 1 (on).

Setting

Range: 1 to 999

Query

Range: 1 to 999

*RST Setting

 Off (10 when STATe = On)

Programming Example

OUTPUT 714;"SETUP:AFANALYZER:COUNT:SNUMBER 5"
!Turns on multi-measurements and sets the number of measurements to 5.

SETup:AFANalyzer:COUNt:NUMBer

Function

Sets/queries the number of AF analyzer measurements to be made when multi-measurement state is ON.

Setting

Range: 1 to 999

Query

Range: 1 to 999

*RST Setting

 10

Programming Example

OUTPUT 714;"SETUP:AFANALYZER:COUNT:NUMBER 5"
!Sets the number of measurements to 5 when the multi-measurement state is set to ON.

SETup:AFANalyzer:COUNt:STATe

Function

Sets/queries the multi-measurement state of the AF analyzer measurement.

Setting

Range: 1|ON|0|OFF

Query

Range: 1|0

*RST Setting

0 (off)

Programming Example

OUTPUT 714;"SETUP:AFANALYZER:COUNT:STATE ON" !Turns on multi-measurements.

SETup:AFANalyzer:DEMPhasis:STATe

Function

Sets/queries whether 750 us de-emphasis is enabled.

Setting

Range: 1|ON|0|OFF

Query

Range: 1|0

*RST Setting

0 (off)

Programming Example

OUTPUT 714;"SETUP:AFANALYZER:DEMPHASIS:STATE ON"

SETup:AFANalyzer:DETector[:TYPE]

Function

Sets/queries the detector type for audio level measurements.

Setting

Range: RMS|PEAK

Query

Range: RMS|PEAK

*RST setting

RMS

Programming Example

OUTPUT 714;"SETUP:AFANALYZER:DETECTOR:TYPE PEAK"

SETup:AFANalyzer:EXPandor[:SRLevel]

Function

Sets/queries the expandor's reference level and automatically sets the expandor's state to ON.

Setting

Range: 10 mV to 10 V

Resolution: 1 mV

Query

Range: 10 mV to 10 V

*RST setting

1 V

Programming Example

OUTPUT 714;"SETUP:AFANALYZER:EXPANDOR:SRLEVEL 5V"
!Sets expandor state to on and level to 5 V.

SETup:AFANalyzer:EXPandor:RLEVel

Function

Sets/queries the expandor's reference level to be used when the expandor's state is set to ON.

Setting

Range: 10 mV to 10 V

Resolution: 1 mV

Query

Range: 10 mV to 10 V

*RST setting

1 V

Programming Example

OUTPUT 714;"SETUP:AFANALYZER:EXPANDOR:RLEVEL 5V" !Sets expandor reference level to 5 V.

SETup:AFANalyzer:EXPandor:STATe

Function

Sets/queries whether the expandor is enabled.

Setting

Range: 1|ON|0|OFF

Query

Range: 1|0

*RST setting

0 (off)

Programming Example

OUTPUT 714;"SETUP:AFANALYZER:EXPANDOR:STATE ON"

SETup:AFANalyzer:FILTer[:TYPE]

Function

Sets/queries the filter type for audio measurements.

Setting

Range: NONE|TBPass|CMESsage|BPASs50|BPASs300

Query

Range: NONE|TBP|CMES|BPAS50|BPAS300

*RST setting

NONE

Programming Example

OUTPUT 714;"SETUP:AFANALYZER:FILTER:TYPE BPASS50"
!Selects the 50 Hz to 15 kHz bandpass filter.

SETup:AFANalyzer:FILTer:TBPass[:FREQuency]

Function

Sets/queries the center frequency for the 100 Hz tunable bandpass filter (TBPass).

Setting

Range: 300.0 to 20000 Hz

Resolution: 0.1

Query

Range: 300.0 to 20000 Hz

*RST setting

1000

Programming Example

10 OUTPUT 714;"SETUP:AFANALYZER:FILTER:TBPASS:FREQUENCY 300HZ"

SETup:AFANalyzer:FREQuency:STATe

Function

Sets/queries whether the audio frequency measurement is enabled.

Setting

Range: 1|ON|0|OFF

Query

Range: 1|0

*RST setting

0 (off)

Programming Example

OUTPUT 714;"SETUP:AFANALYZER:FREQUENCY:STATE ON"

SETup:AFANalyzer:PEAK:VOLTage

Function

Sets/queries the expected peak voltage for audio measurements.

Setting

Range: 0.001 to 20 Vpk

Resolution: 0.001

Query

Range: 0.001 to 20 Vpk

*RST setting

20

Programming Example

10 OUTPUT 714;SETUP:AFANALYZER:PEAK:VOLTAGE 10V"

SETup:AFANalyzer:SDIStortion:FREQuency

Function

Sets/queries the fundamental frequency setting for the SINAD/distortion measurement.

Setting

Range: 100.0 to 10000 Hz

Resolution: 0.1

Query

Range: 100.0 to 10000 Hz

*RST setting

1000

Programming Example

10 OUTPUT 714;SETUP:AFANALYZER:SDISTORTION:FREQUENCY 300HZ"

SETup:AFANalyzer:SDIStortion:STATe

Function

Sets/queries whether the SINAD/distortion measurement is enabled.

Setting

Range: 1|0N|0|OFF

Query

Range: 1|0

*RST setting

0 (off)

Programming Example

10 OUTPUT 714;SETUP:AFANALYZER:SDISTORTION:STATE ON"

SETup:AFANalyzer:TIMeout[:STIMe]

Function

Sets/queries the AF analyzer measurement's timeout setting and automatically sets the timeout state to ON.

Setting

Range: 1 to 999 seconds

Resolution: 1 second

Query

Range: 1 to 999

*RST Setting

10 seconds, on

Programming Example

OUTPUT 714;"SETUP:AFANALYZER:TIMEOUT:STIME 5S"
!Sets timeout state to ON and sets the timeout time to 5 seconds.

SETup:AFANalyzer:TIMeout:STATe

Function

Sets/queries the AF analyzer measurement's timeout state.

Setting

Range: 1|ON|0|OFF

Query

Range: 1|0

*RST Setting

0 (off)

Programming Example

OUTPUT 714;"SETUP:AFANALYZER:TIMEOUT:STATE ON"

SETup:AFANalyzer:TIMeout:TIME

Function

Sets/queries the AF analyzer measurement's timeout setting to be used when the timeout state is set to ON.

Setting

Range: 1 to 999 seconds

Resolution: 1 second

Query

Range: 1 to 999

*RST Setting

10 seconds

Programming Example

OUTPUT 714;"SETUP:AFANALYZER:TIMEOUT:TIME 5S"


SETup:CONTinuous

SETup:CONTinuous

Last updated: June 7, 2007

GPIB Command Conventions

  • SETup[:ALL]:CONTinuous<:OFF|:ON>

SETup[:ALL]:CONTinuous<:OFF|:ON>

Function

Sets the trigger arm state for all measurements. Determines whether all measurements will make one measurement then stop (OFF (single)), or automatically rearm upon completion of one measurement and repeat the process (ON (continuous)). See Trigger Arm (Single or Continuous) Description .

This setting overrides previously set trigger arm settings for individual measurements (see SETup Subsystem ).

Programming Example

OUTPUT 714;"SETup:CONTinuous:OFF"
!Sets all measurements to single trigger mode.


SETup:ATXPower

SETup:ATXPower

Last updated: June 7, 2007

GPIB Command Conventions

  • SETup:ATXPower:CONTinuous
  • SETup:ATXPower:COUNt[:SNUMber]
  • SETup:ATXPower:COUNt:NUMBer
  • SETup:ATXPower:COUNt:STATe
  • SETup:ATXPower:TIMeout[:STIMe]
  • SETup:ATXPower:TIMeout:STATe
  • SETup:ATXPower:TIMeout:TIME

SETup:ATXPower:CONTinuous

Function

Sets/queries the trigger arm state for the analog transmitter power measurement. Determines whether measurement will make one measurement then stop (0|OFF (single)), or automatically rearm upon completion of one measurement and repeat the process (1|ON (continuous)).

Setting

Range: 1|ON|0|OFF

Query

Range: 1|0

*RST Setting

0 (off)

Programming Example

OUTPUT 714;"SETUP:ATXPOWER:CONTINUOUS ON" !Sets measurement to continuous trigger mode.

SETup:ATXPower:COUNt[:SNUMber]

Function

Sets/queries the number of analog transmitter power measurements to be made in a mulit-measurement setup. This command sets the count, and automatically sets the multi-measurement STATe command to 1 (on).

Setting

Range: 1 to 999

Query

Range: 1 to 999

*RST Setting

10, on

Programming Example

OUTPUT 714;"SETUP:ATXPOWER:COUNT:SNUMBER 5"
!Turns on multi-measurements and sets the number of measurements to 5.

SETup:ATXPower:COUNt:NUMBer

Function

Sets/queries the number of analog transmitter power measurements to be made when mulit-measurement state is ON.

Setting

Range: 1 to 999

Query

Range: 1 to 999

*RST Setting

 10

Programming Example

OUTPUT 714;"SETUP:ATXPOWER:COUNT:NUMBER 5"
!Sets the number of measurements to 5 when the multi-measurement state is set to ON.

SETup:ATXPower:COUNt:STATe

Function

Sets/queries the multi-measurement state of the analog transmitter power measurement.

Setting

Range: 1|ON|0|OFF

Query

Range: 1|0

*RST Setting

0 (off)

Programming Example

OUTPUT 714;"SETUP:ATXPOWER:COUNT:STATE ON" !Turns on multi-measurements.

SETup:ATXPower:TIMeout[:STIMe]

Function

Sets/queries the analog transmitter power measurement's timeout setting and automatically sets the timeout state to ON.

Setting

Range: 0.1 to 999 seconds

Resolution: 0.1 second

Query

Range: 0.1 to 999

*RST Setting

10 seconds, on

Programming Example

OUTPUT 714;"SETUP:ATXPOWER:TIMEOUT:STIME 5S"
!Sets timeout state to ON and sets the timeout time to 5 seconds.

SETup:ATXPower:TIMeout:STATe

Function

Sets/queries the analog transmitter power measurement's timeout state.

Setting

Range: 1|ON|0|OFF

Query

Range: 1|0

*RST Setting

0 (off)

Programming Example

OUTPUT 714;"SETUP:ATXPOWER:TIMEOUT:STATE ON"

SETup:ATXPower:TIMeout:TIME

Function

Sets/queries the analog transmitter power measurement's timeout setting to be used when the timeout state is set to ON.

Setting

Range: 0.1 to 999 seconds

Resolution: 0.1 second

Query

Range: 0.1 to 999

*RST Setting

10 seconds

Programming Example

OUTPUT 714;"SETUP:ATXPOWER:TIMEOUT:TIME 5S"


SETup:CAPPower

SETup:CAPPower

Last updated: June 7, 2007

GPIB Command Conventions

  • SETup:CAPPower:CONTinuous
  • SETup:CAPPower:TIMeout[:STIMe]
  • SETup:CAPPower:TIMeout:STATe
  • SETup:CAPPower:TIMeout:TIME

SETup:CAPPower:CONTinuous

Function

Sets/queries the trigger arm state for the access probe power measurement. The trigger arm state determines whether the access probe power measurement will be made on the first access probe in an access probe sequence then stop (0|OFF (single)), or automatically re-arm and make measurements on each of the following access probes (1|ON (continuous)).

Setting

Range: 1|ON|0|OFF

Query

Range: 1|0

*RST Setting

0 (off)

Programming Example

OUTPUT 714;"SETUP:CAPPOWER:CONTINUOUS OFF"
!Sets measurement to single trigger mode.

SETup:CAPPower:TIMeout[:STIMe]

Function

The setting form of this command performs two functions: (1) sets the access probe power measurement's timeout (see Timeouts ) value, and (2) sets the access probe power measurement's timeout STATe to 1 (on).

The query form returns the access probe power measurement's timeout value.

Setting

Range: 0.1 to 999.9 seconds

Resolution: 0.1 second

Query

Range: 0.1 to 999.9

*RST Setting

10 seconds, on

Programming Example

OUTPUT 714;"SETUP:CAPPOWER:TIMEOUT:STIME 5"
!Sets timeout state to ON and sets the timeout time to 5 seconds.

SETup:CAPPower:TIMeout:STATe

Function

Sets/queries the access probe power measurement's timeout (see Timeouts ) state.

Setting

Range: 1|ON|0|OFF

Query

Range: 1|0

*RST Setting

0 (off)

Programming Example

OUTPUT 714;"SETUP:CAPPOWER:TIMEOUT:STATE ON"

SETup:CAPPower:TIMeout:TIME

Function

Sets/queries the access probe power measurement's timeout (see Timeouts ) setting to be used when the timeout state is set to ON.

Setting

Range: 0.1 to 999.9 seconds

Resolution: 0.1 second

Query

Range: 0.1 to 999.9

*RST Setting

10 seconds

Programming Example

OUTPUT 714;"SETUP:CAPPOWER:TIMEOUT:TIME 5"


SETup:CCTPhase

SETup:CCTPhase

Last updated: June 7, 2007

GPIB Command Conventions

  • SETup:CAPPower:CONTinuous
  • SETup:CAPPower:TIMeout[:STIMe]
  • SETup:CAPPower:TIMeout:STATe
  • SETup:CAPPower:TIMeout:TIME
  • SETup:CCTPhase:CONTinuous
  • SETup:CCTPhase:COUNt[:SNUMber]
  • SETup:CCTPhase:COUNt:NUMBer
  • SETup:CCTPhase:COUNt:STATe
  • SETup:CCTPhase:PERRor[:LIMit]
  • SETup:CCTPhase:TERRor[:LIMit]
  • SETup:CCTPhase:TIMeout[:STIMe]
  • SETup:CCTPhase:TIMeout:STATe
  • SETup:CCTPhase:TIMeout:TIME

SETup:CCTPhase:CONTinuous

Function

Sets/queries the trigger arm state for the code channel timing and phase error measurements. The trigger arm state determines whether the code channel timing and phase error measurements will be made once then stop (0|OFF (single)), or automatically re-arm upon completion of one measurement and repeat the process (1|ON (continuous)).

Setting

Range: 1|ON|0|OFF

Query

Range: 1|0

*RST Setting

0 (off)

Programming Example

OUTPUT 714;"SETUP:CCTPHASE:CONTINUOUS OFF"
!Sets measurement to single trigger mode.

SETup:CCTPhase:COUNt[:SNUMber]

Function

The setting form of this command performs two functions: (1) sets the number of code channel timing and phase error measurements to be made in a multi-measurement, and (2) sets the multi-measurement STATe command to 1 (on).

The query form returns the number of code channel timing and phase error multi-measurements to be made when mulit-measurement state is ON.

Setting

Range: 1 to 999

Query

Range: 1 to 999

*RST Setting

 Off (10 when STATe = On)

Programming Example

OUTPUT 714;"SETUP:CCTPHASE:COUNT:SNUMBER 5"
!Turns on multi-measurements and sets the number of measurements to 5.

SETup:CCTPhase:COUNt:NUMBer

Function

Sets/queries the number of code channel timing and phase error measurements to be made when the mulit-measurement state is ON.

Setting

Range: 1 to 999

Query

Range: 1 to 999

*RST Setting

 10

Programming Example

OUTPUT 714;"SETUP:CCTPHASE:COUNT:NUMBER 5"
!Sets the number of code channel timing and phase error multi-measurements to 5.

SETup:CCTPhase:COUNt:STATe

Function

Sets/queries the code channel timing and phase error multi-measurement state.

Setting

Range: 1|ON|0|OFF

Query

Range: 1|0

*RST Setting

0 (off)

Programming Example

OUTPUT 714;"SETUP:CCTPHASE:COUNT:STATE ON" !Turns on code channel timing and phase error multi-measurements.

SETup:CCTPhase:PERRor[:LIMit]

Function

Sets/queries the code channel phase error limit.

Setting

Range: 0 to 1.00 radian

Resolution: 0.01 radian

Query

Range: 0 to 1.00 radian

*RST Setting

 0.15 radian

Programming Example

OUTPUT 714;"SETUP:CCTPHASE:PERROR 0.25"

SETup:CCTPhase:TERRor[:LIMit]

Function

Sets/queries the code channel timing error limit.

Setting

Range: 0 to 100.0 ns

Resolution: 0.1 ns

Query

Range: 0 to 100.0 ns

*RST Setting

 10.0 ns

Programming Example

OUTPUT 714;"SETUP:CCTPHASE:TERROR 25"

SETup:CCTPhase:TIMeout[:STIMe]

Function

The setting form of this command performs two functions: (1) sets the code channel timing and phase error measurements' timeout (see Timeouts ) value, and (2) sets the code channel timing and phase error measurements' timeout STATe to 1 (on).

The query form returns the code channel timing and phase error measurements' timeout value.

Setting

Range: 0.1 to 999.9 seconds

Resolution: 0.1 second

Query

Range: 0.1 to 999.9

*RST Setting

10 seconds, on

Programming Example

OUTPUT 714;"SETUP:CCTPHASE:TIMEOUT:STIME 5 S"
!Sets timeout state to ON and sets the timeout time to 5 seconds.

SETup:CCTPhase:TIMeout:STATe

Function

Sets/queries the code channel timing and phase error measurements's timeout (see Timeouts ) state.

Setting

Range: 1|ON|0|OFF

Query

Range: 1|0

*RST Setting

0 (off)

Programming Example

OUTPUT 714;"SETUP:CCTPHASE:TIMEOUT:STATE ON"
!Sets the timeout state to ON.

SETup:CCTPhase:TIMeout:TIME

Function

Sets/queries the code channel timing and phase error measurements' timeout (see Timeouts ) setting to be used when the timeout state is set to ON.

Setting

Range: 0.1 to 999.9 seconds

Resolution: 0.1 second

Query

Range: 0.1 to 999.9

*RST Setting

10 seconds

Programming Example

OUTPUT 714;"SETUP:CCTPHASE:TIMEOUT:TIME 5 S"
!Sets the timeout time to five seconds.


SETup:CFDTune

SETup:CFDTune

Last updated: June 20, 2007

GPIB Command Conventions

  • SETup:CFDTune:FREQuency:STEP:COUNt
  • SETup:CFDTune:MS:RX:FREQuency:STEP[:VALues]
  • SETup:CFDTune:MS:RX:FREQuency:STEP:STARt:[INDex]
  • SETup:CFDTunee:MS:RX:POWer:STEP[:LEVels]
  • SETup:CFDTune:MS:RX:POWer:STEP:STARt:[INDex]
  • SETup:CFDTune:MS:TX:FREQuency:STEP[:VALues]
  • SETup:CFDTune:MS:TX:FREQuency:STEP:STARt:[INDex]
  • SETup:CFDTune:MS:TX:POWer:STEP[:LEVels]
  • SETup:CFDTune:MS:TX:POWer:STEP:STARt:[INDex]
  • SETup:CFDTune:POWer:STEP:COUNt
  • SETup:CFDTune:TIMeout[:STIMe]
  • SETup:CFDTune:TIMeout:STATe
  • SETup:CFDTune:TIMeout:TIME

SETup:CFDTune:FREQuency:STEP:COUNt

Function

Sets/queries the Number of Frequency Steps .

Setting

Range: 1 to 20

Resolution: 1

Query

Range: 1 to 20

*RST Setting

5

Requirement

Test Application Revision: B.11 and above, with the required feature license

Lab Application Revision: B.04 and above

Programming Example

OUTPUT 714;"SETup:CDFTune:FREQuency:STEP:COUNt 10"
!Sets the number of frequency steps to 10.

SETup:CFDTune:MS:RX:FREQuency:STEP[:VALues]

Function

Sets/queries the MS RX Frequency Step Values .

If you set fewer than 40 values, the remaining values are set to NAN (9.91E+37).

Setting

Range:

Although you can enter any frequencies between 421 and 2170 MHz, when running the Fast Device Tune measurement in the cdma2000 application/format, you can only test frequencies within a single cdma2000 frequency band range:

  • 420 to 493.48 MHz (Band: NMT-450)
  • 832 to 960 MHz (Bands: US Cellular, Japan CDMA, China Cellular, and Secondary 800)
  • 1840 to 1870 MHz (Band: Korean PCS)
  • 2110 to 2170 MHz (Band: IMT-2000)
  • 1930 to 1995 MHz (Bands: US PCS and US PCS 1900)
  • 2110 to 2155 MHz (Band: AWS)

Resolution: 1 Hz

Query

 Same as setting

*RST Setting

872.0MHz, 872.2MHz, 872.4MHz, 872.6MHz, 872.8MHz, 873.0MHz, 873.2MHz, 873.4MHz, 873.6MHz, 873.8MHz, 874.0MHz, 874.2MHz, 874.4MHz, 874.6MHz, 874.8MHz, 875.0MHz, 875.2MHz, 875.4MHz, 875.4MHz, 875.6MHz, 875.8MHz, 1933.0MHz, 1933.2MHz, 1933.4MHz, 1933.6MHz, 1933.8MHz, 1934.0MHz, 1934.2MHz, 1934.4MHz, 1934.6MHz, 1934.8MHz, 1935.0MHz, 1935.2MHz, 1935.4MHz, 1935.6MHz, 1935.8MHz, 1936.0MHz, 1936.2MHz, 1936.4MHz, 1936.6MHz, 1936.8MHz

Requirement

Test Application Revision: B.11 and above, with the required feature license

Lab Application Revision: B.04 and above

Programming Example

OUTPUT 714;"SETup:CFDTune:MS:RX:FREQuency:STEP 1932 MHz, 1933 MHz, 1934 MHz, 1935 MHz"
! Sets MS RX Frequency Step Values to 1932 MHz, 1933 MHz, 1934 MHz, 1935 MHz.

SETup:CFDTune:MS:RX:FREQuency:STEP:STARt:[INDex]

Function

 Sets/queries the MS RX Frequency Step Start Index .

Setting

Range: 0 to 39

Resolution: 1

Query

 Same as setting

*RST Setting

0

Requirement

Test Application Revision: B.11 and above, with the required feature license

Lab Application Revision: B.04 and above

Programming Example

OUTPUT 714;"SETup:CDFTune:MS:RX:FREQuency:STEP:STARt 6"
!Sets the MS RX Frequency Step Start Index to 6.

SETup:CFDTunee:MS:RX:POWer:STEP[:LEVels]

Function

Sets/queries the MS RX Power Step Levels .

If you set fewer than 40 values, the remaining values are set to NAN (9.91E+37).

Setting

Range:

Although you can enter any power levels between -165 and 37 dBm, when running the Fast Device Tune measurement in the cdma2000 application/format, the test set can only transmit test power levels in the range of -115 to -13 dBm ( RF IN/OUT ) or -115 to -5 dBm ( RF OUT ONLY ). These ranges assume an amplitude offset of 0; the allowable ranges change as you change amplitude offsets,, see Cell Power, AWGN Power and Total RF Power Ranges ).

Resolution: 0.01

Query

 Same as setting

*RST Setting

 -15.0dBm, -20.0dBm, -25.0dBm, -30.0dBm, -35.0dBm, -40.0dBm, -45.0dBm, -50.0dBm, -55.0dBm, -60.0dBm, -65.0dBm, -70.0dBm, -75.0dBm, -80.0dBm, -85.0dBm, -85.0dBm, -85.0dBm, -85.0dBm, -85.0dBm, -85.0dBm, -85.0dBm, -85.0dBm, -85.0dBm, -85.0dBm, -85.0dBm, -85.0dBm, -85.0dBm, -85.0dBm, -85.0dBm, -85.0dBm, -85.0dBm, -85.0dBm, -85.0dBm, -85.0dBm, -85.0dBm, -85.0dBm, -85.0dBm, -85.0dBm, -85.0dBm, -85.0dBm

Requirement

Test Application Revision: B.11 and above, with the required feature license

Lab Application Revision: B.04 and above

Test Application Revision B.12 and Lab Application B.05, added support for RF OUT ONLY port.

Programming Example

OUTPUT 714;"SETup:CFDTune:MS:RX:POWer:STEP -16, -20, -30, -40, -50,-60, -70, -80, -90, -100"
! Sets MS RX Power Step Levels to -16, -20, -30, -40, -50,-60, -70, -80, -90, -100 dBm.

SETup:CFDTune:MS:RX:POWer:STEP:STARt:[INDex]

Function

 Sets/queries the MS RX Power Step Start Index .

Setting

Range: 0 to 39

Resolution: 1

Query

 Same as setting

*RST Setting

0

Requirement

Test Application Revision: B.11 and above, with the required feature license

Lab Application Revision: B.04 and above

Programming Example

OUTPUT 714;"SETup:CDFTune:MS:RX:POWer:STEP:STARt 6"
!Sets the MS RX Power Step Start Index to 6.

SETup:CFDTune:MS:TX:FREQuency:STEP[:VALues]

Function

Sets/queries the MS TX Frequency Step Values .

If you set fewer than 40 values, the remaining values are set to NAN (9.91E+37).

Setting

Range:

Although you can enter any frequencies between 411 and 1980 MHz, when running the Fast Device Tune measurement in the cdma2000 application/format, you can only test frequencies within a single cdma2000 frequency band range:

  • 410 to 483.48 MHz (Band: NMT-450)
  • 806 to 925 MHz (Bands: US Cellular, Japan CDMA, China Cellular, and Secondary 800)
  • 1750 to 1780 MHz (Band: Korean PCS)
  • 1920 to 1980 MHz (Band: IMT-2000)
  • 1850 to 1915 MHz (Bands: US PCS and US PCS 1900)
  • 1710 to 1755 MHz (Band: AWS)

Resolution: 1 Hz

Query

 Same as setting

*RST Setting

827.0MHz, 827.2MHz, 827.4MHz, 827.6MHz, 827.8MHz, 828.0MHz, 828.2MHz, 828.4MHz, 828.6MHz, 828.8MHz, 829.0MHz, 829.2MHz, 829.4MHz, 829.6MHz, 829.8MHz, 830.0MHz, 830.2MHz, 830.4MHz, 830.6MHz, 830.8MHz, 1853.0MHz, 1853.2MHz, 1853.4MHz, 1853.6MHz, 1853.8MHz, 1854.0MHz, 1854.2MHz, 1854.4MHz, 1854.6MHz, 1854.8MHz, 1855.0MHz, 1855.2MHz, 1855.4MHz, 1855.6MHz, 1855.8MHz, 1856.0MHz, 1856.2MHz, 1856.4MHz, 1856.6MHz, 1856.8MHz

Requirement

Test Application Revision: B.11 and above, with the required feature license

Lab Application Revision: B.04 and above

Programming Example

OUTPUT 714;"SETup:CFDTune:MS:TX:FREQuency:STEP 1852 MHz, 1853 MHz, 1854 MHz, 1855 MHz"
! Sets MS TX Frequency Step Values to 1852 MHz, 1853 MHz, 1854 MHz, 1855 MHz.

SETup:CFDTune:MS:TX:FREQuency:STEP:STARt:[INDex]

Function

 Sets/queries the MS TX Frequency Step Start Index .

Setting

Range: 0 to 39

Resolution: 1

Query

 Same as setting

*RST Setting

0

Requirement

Test Application Revision: B.11 and above, with the required feature license

Lab Application Revision: B.04 and above

Programming Example

OUTPUT 714;"SETup:CDFTune:MS:TX:FREQuency:STEP:STARt 6"
!Sets the MS TX Frequency Step Start Index to 6.

SETup:CFDTune:MS:TX:POWer:STEP[:LEVels]

Function

Sets/queries the MS TX Power Step Levels .

If you set fewer than 40 values, the remaining values are set to NAN (9.91E+37).

Setting

Range:

Although you can enter any power levels between -129 and +80 dBm (because this measurement is common to the W-CDMA/HSDPA, 1xEV-DO and cdma2000 formats), when running the Fast Device Tune measurement in the cdma2000 application/format, you can only measure power levels in the range of -79 to +30 dBm and the measurement is only specified for power levels in the range of -61 to +30 dBm (these ranges assume an amplitude offset of 0; the ranges change as you change amplitude offsets, see Amplitude Offset ).

Resolution: 0.01

Query

 Same as setting

*RST Setting

 12.0dBm, 7.0dBm, 2.0dBm, -8.0dBm, -13.0dBm, -18.0dBm, -23.0dBm, -28.0dBm, -33.0dBm, -38.0dBm, -43.0dBm, -48.0dBm, -53.0dBm, -58.0dBm, -63.0dBm, -63.0dBm, -63.0dBm, -63.0dBm, -63.0dBm, -63.0dBm, -63.0dBm, -63.0dBm, -63.0dBm, -63.0dBm, -63.0dBm, -63.0dBm, -63.0dBm, -63.0dBm, -63.0dBm, -63.0dBm, -63.0dBm, -63.0dBm, -63.0dBm, -63.0dBm, -63.0dBm, -63.0dBm, -63.0dBm, -63.0dBm, -63.0dBm, -63.0dBm

Requirement

Test Application Revision: B.11 and above, with the required feature license

Lab Application Revision: B.04 and above

Programming Example

OUTPUT 714;"SETup:CDFTune:MS:RX:POWer:STEP 20, 16, 12, 8, 4, 0, -4, -8, -12, -16, -20, -30, -40, -50"
!Sets Rx Power Step Sequency values to 20, 16, 12, 8, 4, 0, -4, -8, -12, -16, -20, -30, -40, -50.

SETup:CFDTune:MS:TX:POWer:STEP:STARt:[INDex]

Function

 Sets/queries the MS TX Power Step Start Index .

Setting

Range: 0 to 39

Resolution: 1

Query

 Same as setting

*RST Setting

0

Requirement

Test Application Revision: B.11 and above, with the required feature license

Lab Application Revision: B.04 and above

Programming Example

OUTPUT 714;"SETup:CDFTune:MS:TX:POWer:STEP:STARt 6"
!Sets the MS TX Power Step Start Index to 6.

SETup:CFDTune:POWer:STEP:COUNt

Function

Sets/queries the Number of Power Steps .

Setting

Range: 1 to 20

Resolution: 1

Query

Range: 1 to 20

*RST Setting

10

Requirement

Test Application Revision: B.11 and above, with the required feature license

Lab Application Revision: B.04 and above

Programming Example

OUTPUT 714;"SETup:CDFTune:POWer:STEP:COUNt 15"
!Sets the number of power steps to 15.

SETup:CFDTune:TIMeout[:STIMe]

Function

The setting form of this command performs two functions: (1) sets the Fast Device Tune measurement's timeout (see Timeouts ) value, and (2) sets the Fast Device Tune measurement's timeout state to 1 (on).

The query form returns the Fast Device Tune measurement's timeout value.

See Fast Device Tune Measurement Parameters .

Setting

Range: 0.1 to 999 seconds

Resolution: 0.1 second

Query

Range: 0.1 to 999

*RST Setting

10 seconds, off

Requirement

Test Application Revision: B.11 and above, with the required feature license

Lab Application Revision: B.04 and above

Programming Example

OUTPUT 714;"SETup:CDFTune:TIMeout 5S"
!Sets timeout state to ON and sets the timeout time to 5 seconds.

SETup:CFDTune:TIMeout:STATe

Function

 Sets/queries Fast Device Tune measurement's timeout state (see Timeouts ).

Setting

Range: 1|ON|0|OFF

Query

Range: 1|0

*RST Setting

0 (off)

Requirement

Test Application Revision: B.11 and above, with the required feature license

Lab Application Revision: B.04 and above

Programming Example

OUTPUT 714;"SETup:CDFTune:TIMeout:STATe ON"

SETup:CFDTune:TIMeout:TIME

Function

 Sets/queries Fast Device Tune measurement's timeout (see Timeouts ) setting to be used when the timeout state is set to ON.

Setting

Range: 0.1 to 999 seconds

Resolution: 0.1 second

Query

Range: 0.1 to 999

*RST Setting

10 seconds

Requirement

Test Application Revision: B.11 and above, with the required feature license

Lab Application Revision: B.04 and above

Programming Example

OUTPUT 714;"SETup:CDFTune:TIMeout:TIME 5S"


SETup:CFERror

SETup:CFERror

Last updated: June 7, 2007

GPIB Command Conventions

  • SETup:CFERror:CONFidence[:SLEVel]
  • SETup:CFERror:CONFidence:STATe
  • SETup:CFERror:CONFidence:LEVel
  • SETup:CFERror:CONFidence:REQuirement[:RATio]
  • SETup:CFERror:CONTinuous
  • SETup:CFERror:COUNt[:MAXimum]
  • SETup:CFERror:COUNt:MINimum
  • SETup:CFERror:EBNTotal[:LIMit]
  • SETup:CFERror:TIMeout[:STIMe]
  • SETup:CFERror:TIMeout:STATe
  • SETup:CFERror:TIMeout:TIME

SETup:CFERror:CONFidence[:SLEVel]

Function

The setting form of this command performs two functions: (1) sets the FER (frame error rate) measurement's confidence level, and (2) sets the FER measurement's confidence level state to 1 (on).

The query form of this command returns the FER measurement's confidence level setting.

See FER Measurement Parameters .

Setting

Range: 80 to 99.99 percent

Resolution: 0.01 percent

Query

same as setting

*RST Setting

95 percent, on

Programming Example

OUTPUT 714;"SETUP:CFERROR:CONFIDENCE 95"

!sets the FER confidence level to 95 percent

SETup:CFERror:CONFidence:STATe

Function

Sets/queries whether the confidence level will be used during FER measurement.

See FER Measurement Parameters .

Setting

Range: 1|ON|0|OFF

Query

Range: 1|0

*RST Setting

1 (on)

Programming Example

OUTPUT 714;"SETUP:CFERROR:CONFIDENCE:STATE ON"

SETup:CFERror:CONFidence:LEVel

Function

Sets/queries the FER (frame error rate) measurement's confidence level to be used when the confidence level state is set to on.

See FER Measurement Parameters .

Setting

Range: 80 to 99.99 percent

Query

Range: 80 to 99.99 percent

*RST Setting

 95 percent

Programming Example

OUTPUT 714;"SETUP:CFERROR:CONFIDENCE:LEVEL 95"

!Sets the confidence level to 95%.

SETup:CFERror:CONFidence:REQuirement[:RATio]

Function

Sets/queries the FER (frame error rate) measurement's FER requirement. This value specifies the percentage of frame errors used in determining confidence limit pass/fail results.

See FER Measurement Parameters .

Setting

Range: 0.10 to 30.0 percent

Query

Range: 0.10 to 30.0 percent

*RST Setting

 1.00 percent

Requirements

Test Application Revision: B.08 and above: Setting/query range is changed from the range of 0.1% to 15% to the range of 0.1% to 30%
Lab Application Revision: B.02 and above: Setting/query range is changed from the range of 0.1% to 15% to the range of 0.1% to 30%

Programming Example

OUTPUT 714;"SETUP:CFERROR:CONFIDENCE:REQUIREMENT 2"

!sets the confidence limit requirement to 2%.

SETup:CFERror:CONTinuous

Function

Sets/queries the trigger arm state for the FER (frame error rate) measurement. The trigger arm state determines whether the waveform quality measurement will be made once then stop (0|OFF (single)), or automatically rearm upon completion of one measurement and repeat the process (1|ON (continuous)).

Setting

Range: 1|ON|0|OFF

Query

Range: 1|0

*RST Setting

0 (off)

Programming Example

OUTPUT 714;"SETUP:CFERROR:CONTINUOUS OFF"
!Sets the FER measurement to single trigger mode.

SETup:CFERror:COUNt[:MAXimum]

Function

Sets/queries the maximum number of frames to be tested during FER measurements.

See FER Measurement Parameters .

Setting

Range: 25 to 10,000,000

Query

Range: 25 to 10,000,000

*RST Setting

 10,000

Programming Example

OUTPUT 714;"SETUP:CFERror:COUNT 10000"
!sets the maximum frames to be tested to 10000.

SETup:CFERror:COUNt:MINimum

Function

Sets/queries the minimum number of frames to be tested before applying the confidence algorithm when the confidence level state is on.

See FER Measurement Parameters .

Setting

Range: 0 to 10,000,000

Query

Range: 0 to 10,000,000

*RST Setting

 0

Requirements

Test Application Revision: B.08 and above
Lab Application Revision: B.02 and above

Programming Example

OUTPUT 714;"SETup:CFERror:COUNt:MINimum 200"
!sets the minimum frames to be tested to 200.

SETup:CFERror:EBNTotal[:LIMit]

Function

Sets/queries the Eb/Nt limit that must not be exceeded for a Eb/Nt Pass result ( FETCh:CFERror:EBNTotal:FAIL? ) to be returned. It applies only when the FPC mode 000 is enabled on the test set using the CALL[:CELL]:FPControl:MODE .

See FER Measurement Parameters .

Setting

Range: -30.00 to 42.00 dB

Resolution: 0.01

Query

same as setting

*RST Setting

 6.5 dB

Requirements

Lab Application Revision: B.02 and above

Programming Example

OUTPUT 714;"SETup:CFERror:EBNTotal 7"
!sets the Eb/Nt limit to 7 dB.

SETup:CFERror:TIMeout[:STIMe]

Function

The setting form of this command performs two functions: (1) sets the FER (frame error rate) measurement's timeout value, and (2) sets the FER measurement's timeout STATe to 1 (on).

The query form returns the FER measurement's timeout value.

Setting

Range: 1 to 200,000 seconds

Resolution: 1 second

Query

Range: 1 to 200,000

*RST Setting

200 seconds, off

Programming Example

OUTPUT 714;"SETUP:CFERROR:TIMEOUT:STIME 200S"
!Sets timeout state to ON and sets the timeout time to 200 seconds.

SETup:CFERror:TIMeout:STATe

Function

Sets/queries the FER (frame error rate) measurement's timeout state.

Setting

Range: 1|ON|0|OFF

Query

Range: 1|0

*RST Setting

0 (off)

Programming Example

OUTPUT 714;"SETUP:CFERROR:TIMEOUT:STATE ON"

SETup:CFERror:TIMeout:TIME

Function

Sets/queries the FER (frame error rate) measurement's timeout setting to be used when the timeout state is set to ON.

Setting

Range: 1 to 200,000 seconds

Resolution: 1 second

Query

Range: 1 to 200,000

*RST Setting

200 seconds

Programming Example

OUTPUT 714;"SETUP:CFERROR:TIMEOUT:TIME 200S"


SETup:CPOWer

SETup:CPOWer

Last updated: June 7, 2007

GPIB Command Conventions

  • SETup:CPOWer:CONTinuous
  • SETup:CPOWer:COUNt[:SNUMber]
  • SETup:CPOWer:COUNt:NUMBer
  • SETup:CPOWer:COUNt:STATe
  • SETup:CPOWer:MSPeed
  • SETup:CPOWer:TIMeout[:STIMe]
  • SETup:CPOWer:TIMeout:STATe
  • SETup:CPOWer:TIMeout:TIME

SETup:CPOWer:CONTinuous

Function

Sets/queries the trigger arm state for the channel power measurement. The trigger arm state determines whether the channel power measurement will be made once then stop (0|OFF (single)), or automatically re-arm upon completion of one measurement and repeat the process (1|ON (continuous)).

Setting

Range: 1|ON|0|OFF

Query

Range: 1|0

*RST Setting

0 (off)

Programming Example

OUTPUT 714;"SETUP:CPOWER:CONTINUOUS OFF"
!Sets measurement to single trigger mode.

SETup:CPOWer:COUNt[:SNUMber]

Function

The setting form of this command performs two functions: (1) sets the number of channel power measurements to be made in a multi-measurement, and (2) sets the multi-measurement STATe command to 1 (on).

The query form returns the number of channel power multi-measurements to be made when mulit-measurement state is ON.

Setting

Range: 1 to 999

Query

Range: 1 to 999

*RST Setting

 Off (10 when STATe = On)

Programming Example

OUTPUT 714;"SETUP:CPOWER:COUNT:SNUMBER 5"
!Turns on multi-measurements and sets the number of measurements to 5.

SETup:CPOWer:COUNt:NUMBer

Function

Sets/queries the number of channel power measurements to be made when the mulit-measurement state is ON.

Setting

Range: 1 to 999

Query

Range: 1 to 999

*RST Setting

 10

Programming Example

OUTPUT 714;"SETUP:CPOWER:COUNT:NUMBER 5"
!Sets the number of channel power multi-measurements to 5.

SETup:CPOWer:COUNt:STATe

Function

Sets/queries the channel power multi-measurement state.

Setting

Range: 1|ON|0|OFF

Query

Range: 1|0

*RST Setting

0 (off)

Programming Example

OUTPUT 714;"SETUP:CPOWER:COUNT:STATE ON"
!Turns on channel power multi-measurements.

SETup:CPOWer:MSPeed

Function

Sets/queries the channel power measurement speed. See Measurement Speed .

Setting

Range: NORMal|FAST|VFASt

Query

Range: NORM|FAST|VFAS

*RST Setting

 NORM

Requirements

Test Application Revision: B.07 and above: Added VFASt
Lab Application Revision: B.01 and above: Added VFASt

Programming Example

OUTPUT 714;"SETUP:CPOWER:MSPEED FAST"
!Sets up fast channel power measurements.

SETup:CPOWer:TIMeout[:STIMe]

Function

The setting form of this command performs two functions: (1) sets the channel power measurement's timeout (see Timeouts ) value, and (2) sets the channel power measurement's timeout STATe to 1 (on).

The query form returns the channel power measurement's timeout value.

Setting

Range: 0.1 to 999.9 seconds

Resolution: 0.1 second

Query

Range: 0.1 to 999.9

*RST Setting

10 seconds, on

Programming Example

OUTPUT 714;"SETUP:CPOWER:TIMEOUT:STIME 5 S"
!Sets timeout state to ON and sets the timeout time to 5 seconds.

SETup:CPOWer:TIMeout:STATe

Function

Sets/queries the channel power measurement's timeout (see Timeouts ) state.

Setting

Range: 1|ON|0|OFF

Query

Range: 1|0

*RST Setting

0 (off)

Programming Example

OUTPUT 714;"SETUP:CPOWER:TIMEOUT:STATE ON"

SETup:CPOWer:TIMeout:TIME

Function

Sets/queries the channel power measurement's timeout (see Timeouts ) setting to be used when the timeout state is set to ON.

Setting

Range: 0.1 to 999.9 seconds

Resolution: 0.1 second

Query

Range: 0.1 to 999.9

*RST Setting

10 seconds

Programming Example

OUTPUT 714;"SETUP:CPOWER:TIMEOUT:TIME 5 S"


SETup:CTXSpurious

SETup:CTXSpurious

Last updated: June 7, 2007

GPIB Command Conventions

  • SETup:CTXSpurious:CONTinuous
  • SETup:CTXSpurious:COUNt[:SNUMber]
  • SETup:CTXSpurious:COUNt:NUMBer
  • SETup:CTXSpurious:COUNt:STATe
  • SETup:CTXSpurious:MASK:AUTO
  • SETup:CTXSpurious:MASK:MANual:ADJacent[:LIMit]
  • SETup:CTXSpurious:MASK:MANual:ALTernate[:LIMit]
  • SETup:CTXSpurious:TIMeout[:STIMe]
  • SETup:CTXSpurious:TIMeout:STATe
  • SETup:CTXSpurious:TIMeout:TIME

SETup:CTXSpurious:CONTinuous

Function

Sets/queries the trigger arm state for the tx spurious emissions measurement. The trigger arm state determines whether the tx spurious emissions measurement will be made once then stop (0|OFF (single)), or automatically re-arm upon completion of one measurement and repeat the process (1|ON (continuous)).

Setting

Range: 1|ON|0|OFF

Query

Range: 1|0

*RST Setting

0 (off)

Programming Example

OUTPUT 714;"SETUP:CTXSPURIOUS:CONTINUOUS OFF"
!Sets measurement to single trigger mode.

SETup:CTXSpurious:COUNt[:SNUMber]

Function

The setting form of this command performs two functions: (1) sets the number of tx spurious emissions measurements to be made in a multi-measurement, and (2) sets the multi-measurement STATe command to 1 (on).

The query form returns the number of tx spurious emissions multi-measurements to be made when mulit-measurement state is ON.

Setting

Range: 1 to 999

Query

Range: 1 to 999

*RST Setting

 Off (10 when STATe = On)

Programming Example

OUTPUT 714;"SETUP:CTXSPURIOUS:COUNT:SNUMBER 5"
!Turns on multi-measurements and sets the number of measurements to 5.

SETup:CTXSpurious:COUNt:NUMBer

Function

Sets/queries the number of tx spurious emissions measurements to be made when the mulit-measurement state is ON.

Setting

Range: 1 to 999

Query

Range: 1 to 999

*RST Setting

 10

Programming Example

OUTPUT 714;"SETUP:CTXSPURIOUS:COUNT:NUMBER 5"
!Sets the number of tx spurious emissions multi-measurements to 5.

SETup:CTXSpurious:COUNt:STATe

Function

Sets/queries the tx spurious emissions multi-measurement state.

Setting

Range: 1|ON|0|OFF

Query

Range: 1|0

*RST Setting

0 (off)

Programming Example

OUTPUT 714;"SETUP:CTXSPURIOUS:COUNT:STATE ON" !Turns on tx spurious emissions multi-measurements.

SETup:CTXSpurious:MASK:AUTO

Function

Sets/queries the tx spurious emissions measurment limit mask.

ON (1) sets the mask limits to default values based on the mobile's characteristics. OFF (0) allows you to set arbitrary limits (see SETup:CTXSpurious:MASK:MANual:ADJacent[:LIMit] and SETup:CTXSpurious:MASK:MANual:ALTernate[:LIMit] ).

Setting

Range: 1|ON|0|OFF

Query

Range: 1|0

*RST Setting

0 (off)

Requirements

Test Application Revision: B.04

Programming Example

OUTPUT 714;"SETUP:CTXSPURIOUS:MASK:AUTO ON"

SETup:CTXSpurious:MASK:MANual:ADJacent[:LIMit]

Function

Sets/queries the tx spurious emissions manually set measurment limit mask. This limit is activated when SETup:CTXSpurious:MASK:AUTO is set to OFF (0).

Setting

Range: -10 to -65 dB

Query

Range: -10 to -65 dB

*RST Setting

-42

Requirements

Test Application Revision: B.04

Programming Example

OUTPUT 714;"SETUP:CTXSPURIOUS:MASK:MANUAL:ADJACENT -45"

SETup:CTXSpurious:MASK:MANual:ALTernate[:LIMit]

Function

Sets/queries the tx spurious emissions manually set measurment limit mask. This limit is activated when SETup:CTXSpurious:MASK:AUTO is set to OFF (0).

Setting

Range: -10 to -65 dB

Query

Range: -10 to -65 dB

*RST Setting

 -50

Requirements

Test Application Revision: B.04

Programming Example

OUTPUT 714;"SETUP:CTXSPURIOUS:MASK:MANUAL:ALTERNATE -55".

SETup:CTXSpurious:TIMeout[:STIMe]

Function

The setting form of this command performs two functions: (1) sets the tx spurious emissions measurement's timeout (see Timeouts ) value, and (2) sets the tx spurious emissions measurement's timeout STATe to 1 (on).

The query form returns the tx spurious emissions measurement's timeout value.

Setting

Range: 0.1 to 999.9 seconds

Resolution: 0.1 second

Query

Range: 0.1 to 999.9

*RST Setting

10 seconds, on

Programming Example

OUTPUT 714;"SETUP:CTXSPURIOUS:TIMEOUT:STIME 5 S"
!Sets timeout state to ON and sets the timeout time to 5 seconds.

SETup:CTXSpurious:TIMeout:STATe

Function

Sets/queries the tx spurious emissions measurement's timeout (see Timeouts ) state.

Setting

Range: 1|ON|0|OFF

Query

Range: 1|0

*RST Setting

0 (off)

Programming Example

OUTPUT 714;"SETUP:CTXSPURIOUS:TIMEOUT:STATE ON"

SETup:CTXSpurious:TIMeout:TIME

Function

Sets/queries the tx spurious emissions measurement's timeout (see Timeouts ) setting to be used when the timeout state is set to ON.

Setting

Range: 0.1 to 999.9 seconds

Resolution: 0.1 second

Query

Range: 0.1 to 999.9

*RST Setting

10 seconds

Programming Example

OUTPUT 714;"SETUP:CTXSPURIOUS:TIMEOUT:TIME 5 S"


SETup:DAPower

SETup:DAPower

Last updated: June 7, 2007

GPIB Command Conventions

  • SETup:DAPower:CONTinuous
  • SETup:DAPower:COUNt[:SNUMber]
  • SETup:DAPower:COUNt:NUMBer
  • SETup:DAPower:COUNt:STATe
  • SETup:DAPower:TIMeout[:STIMe]
  • SETup:DAPower:TIMeout:STATe
  • SETup:DAPower:TIMeout:TIME

SETup:DAPower:CONTinuous

Function

Sets/queries the trigger arm state for the digital average power measurement. The trigger arm state determines whether the digital average measurement will be made once then stop (0|OFF (single)), or automatically rearm upon completion of one measurement and repeat the process (1|ON (continuous)).

Setting

Range: 1|ON|0|OFF

Query

Range: 1|0

*RST Setting

0 (off)

Programming Example

OUTPUT 714;"SETUP:DAPOWER:CONTINUOUS ON"
!Sets measurement to single trigger mode.

SETup:DAPower:COUNt[:SNUMber]

Function

The setting form of this command performs two functions: (1) sets the number of digital average power measurements to be made in a multi-measurement, and (2) sets the multi-measurement STATe command to 1 (on).

The query form returns the number of digital average power multi-measurements to be made when mulit-measurement state is ON.

Setting

Range: 1 to 999

Query

Range: 1 to 999

*RST Setting

 Off (10 when STATe = On)

Programming Example

OUTPUT 714;"SETUP:DAPOWER:COUNT:SNUMBER 5"
!Turns on multi-measurements and sets the number of measurements to 5.

SETup:DAPower:COUNt:NUMBer

Function

Sets/queries the number of digital average power measurements to be made when the multi-measurement state is ON.

Setting

Range: 1 to 999

Query

Range: 1 to 999

*RST Setting

 10

Programming Example

OUTPUT 714;"SETUP:DAPOWER:COUNT:NUMBER 5"
!Sets the number of measurements to 5 when the multi-measurement state is set to ON.

SETup:DAPower:COUNt:STATe

Function

Sets/queries the multi-measurement state of the digital average power measurement.

Setting

Range: 1|ON|0|OFF

Query

Range: 1|0

*RST Setting

0 (off)

Programming Example

OUTPUT 714;"SETUP:DAPOWER:COUNT:STATE ON" !Turns on multi-measurements.

SETup:DAPower:TIMeout[:STIMe]

Function

The setting form of this command performs two functions: (1) sets the digital average power measurement's timeout value, and (2) sets the digital average power measurement's timeout STATe to 1 (on).

The query form returns the channel power measurement's timeout value.

Setting

Range: 1 to 999 seconds

Resolution: 1 second

Query

Range: 1 to 999

*RST Setting

10 seconds, on

Programming Example

OUTPUT 714;"SETUP:DAPOWER:TIMEOUT:STIME 5S"
!Sets timeout state to ON and sets the timeout time to 5 seconds.

SETup:DAPower:TIMeout:STATe

Function

Sets/queries the digital average power measurement's timeout state.

Setting

Range: 1|ON|0|OFF

Query

Range: 1|0

*RST Setting

0 (off)

Programming Example

OUTPUT 714;"SETUP:DAPOWER:TIMEOUT:STATE ON"

SETup:DAPower:TIMeout:TIME

Function

Sets/queries the digital average power measurement's timeout setting to be used when the timeout state is set to ON.

Setting

Range: 1 to 999 seconds

Resolution: 1 second

Query

Range: 1 to 999

*RST Setting

10 seconds

Programming Example

OUTPUT 714;"SETUP:DAPOWER:TIMEOUT:TIME 5S"


SETup Subsystem

SETup Subsystem

Last updated: July 4, 2006

Description

The SETup subsystem is used to configure the test set for each measurement. Typical settings include:

  • Multi-Measurement Count, how many measurements will be made each time a measurement is initiated.
  • Trigger Arm, determines if a measurement will make one measurement then return to idle (single), or automatically rearm on completion of a measurement and repeat the process (continuous).
  • Trigger Source, how a measurement is triggered.
  • Trigger Delay, controls the delay time between the trigger and the start of sampling.
  • Measurement Timeout, length of time before a measurement times out.

NOTE
Trigger arming for each measurement is controlled in the SETup subsystem. The choices are single or continuous. In most cases, it is a best practice (during remote operation) to use "single" measurement mode. This simplifies the tasks of starting concurrent measurements, using the INIT subsystem commands to determine which measurements are ready to be fetched, then using the FETCh subsystem to obtain results. The command "SETup:CONTinuous:OFF sets all measurements to "single" trigger mode.

Syntax Diagrams and Command Descriptions

SETup:CONTinuous
SETup:AFANalyzer (Audio Frequency Analyzer measurements)
SETup:ATXPower (Analog Transmitter Power measurements)
SETup:CAPPower (Access Probe Power measurements)
SETup:CCTPhase (Code Channel Time/Phase Error measurements)

SETup:CFDTune (Fast Device Tune measurements) ( only applicable to the lab application or feature-licensed test application )

SETup:CFERror (Frame Error Rate measurements)
SETup:CMAudio (Multi-Tone Audio measurements)
SETup:CMMPower (Maximum/Minimum Power measurements)
SETup:CPOWer (Channel Power measurements)
SETup:CTDPower (TX Dynamic Power measurements)
SETup:CTXSpurious (TX Spurious Emissions measurements)
SETup:DAPower (Digital Average Power measurements)

SETup:DTMF (Dual Tone Multiple Frequency measurements)
SETup:FM (Frequency Modulation measurements)

SETup:FSTability (Frequency Stability measurements)

SETup:GAPPower (Graphic Access Probe Power measurements) ( Lab Application Only )

SETup:GPOWer (Gated Power measurements)
SETup:HWQuality (Handoff Waveform Quality measurements)
SETup:SAUDio (Swept Audio measurements)

SETup:SMONitor (Spectrum Monitor measurements)

SETup:STONe (Signaling Tone measurements)
SETup:TFERror (TDSO Frame Error Rate measurements)
SETup:TROPower (Time Response of Open Loop Power Control measurements)

SETup:WDDeviation (Wideband Data Measurements)
SETup:WQUality (Waveform Quality/Code Domain Power measurements)


SETup:CTDPower

SETup:CTDPower

Last updated: June 7, 2007

GPIB Command Conventions

  • SETup:CTDPower:STEP[:LEVel]
  • SETup:CTDPower:STEP:COUNt
  • SETup:CTDPower:STEP:TIME
  • SETup:CTDPower:TIMeout[:STIMe]
  • SETup:CTDPower:TIMeout:STATe
  • SETup:CTDPower:TIMeout:TIME

SETup:CTDPower:STEP[:LEVel]

Function

Sets/queries the power step size by which the test set will expect the mobile station to change its output power at each step.

See TX Dynamic Power Measurement Parameters .

Setting

Range: - 90 to -0.01 dB

Query

Range: -90 to -0.01 dB

*RST Setting

 - 4 dB

Requirements

Test Application Revision: B.07 and above.

Lab Application Revision: B.01 and above.

Programming Example

OUTPUT 714;"SETUP:CTDPOWER:STEP:LEVEL -5 DB"
!Sets the power step size for the measurement.

SETup:CTDPower:STEP:COUNt

Function

Sets/queries the number of power steps that the test set should expect the mobile station to transmit. The number of measurement steps actually made will be the number of setting plus one which can be queried with FETCh:CTDPower:COUNt[:STEP]? .

See TX Dynamic Power Measurement Parameters .

Setting

Range: 0 to 99

Query

Range: 0 to 99

*RST Setting

 19

Requirements

Test Application Revision: B.07 and above.

Lab Application Revision: B.01 and above.

Programming Example

OUTPUT 714;"SETUP:CTDPOWER:STEP:COUNT 5"
!Sets the number of steps to be 5.

SETup:CTDPower:STEP:TIME

Function

Sets/queries the period (in milliseconds) that the mobile station will wait between changes in its output power during the test. The test set will use this setting to determine the timing of the power measurements for the successive steps. You must set the mobile station to hold each step power constant for this amount of time.

See TX Dynamic Power Measurement Parameters .

Setting

Range: MS20|MS40|MS80

Query

Range: MS20|MS40|MS80

*RST Setting

 MS20

Requirements

Test Application Revision: B.07and above.

Lab Application Revision: B.01and above.

Programming Example

OUTPUT 714;"SETUP:CTDPOWER:STEP:TIME MS40"
!Set the period to be 40 ms.

SETup:CTDPower:TIMeout[:STIMe]

Function

The setting form of this command performs two functions: (1) sets the TX dynamic power measurement's timeout (see Timeouts ) value, and (2) sets the TX dynamic power measurement's timeout state to 1 (on).

The query form returns the channel power measurement's timeout value.

Setting

Range: 0.1 to 999.9 seconds

Resolution: 0.1 second

Query

Range: 0.1 to 999.9

*RST Setting

10 seconds

Requirements

Test Application Revision: B.07and above.

Lab Application Revision: B.01and above.

Programming Example

OUTPUT 714;"SETUP:CTDPOWER:TIMEOUT:STIME 5 S"
!Sets timeout state to ON and sets the timeout time to 5 seconds.

SETup:CTDPower:TIMeout:STATe

Function

Sets/queries TX dynamic power measurement's timeout state (see Timeouts ).

Setting

Range: 1|ON|0|OFF

Query

Range: 1|0

*RST Setting

0 (off)

Requirements

Test Application Revision: B.07and above.

Lab Application Revision: B.01and above.

Programming Example

OUTPUT 714;"SETUP:CTDPOWER:TIMEOUT:STATE ON"

SETup:CTDPower:TIMeout:TIME

Function

Sets/queries TX dynamic power measurement's timeout (see Timeouts ) setting to be used when the timeout state is set to ON.

Setting

Range: 0.1 to 999.9 seconds

Resolution: 0.1 second

Query

Range: 0.1 to 999.9

*RST Setting

10 seconds

Requirements

Test Application Revision: B.07and above.

Lab Application Revision: B.01and above.

Programming Example

OUTPUT 714;"SETUP:CTDPOWER:TIMEOUT:TIME 5 S"


SETup:DTMF

SETup:DTMF

Last updated: June 7, 2007

GPIB Command Conventions

  • SETup:DTMF:CONTinuous
  • SETup:DTMF:DETector[:TYPE]
  • SETup:DTMF:GTIMe
  • SETup:DTMF:TIMeout[:STIMe]
  • SETup:DTMF:TIMeout:STATe
  • SETup:DTMF:TIMeout:TIME

SETup:DTMF:CONTinuous

Function

Sets/queries the trigger arm state for the DTMF measurement. Determines whether the measurement makes one measurement then stops (0|OFF (single)), or automatically rearms upon completion of one measurement and repeat the process (1|ON (continuous)).

Setting

Range: 1|ON|0|OFF

Query

Range: 1|0

*RST Setting

0 (off)

Requirement

Test Application Revision: B.09 and above

Lab Application Revision: B.03 and above

Programming Example

OUTPUT 714;"SETup:DTMF:CONTinuous ON"
!Sets measurement to continuous trigger mode.

SETup:DTMF:DETector[:TYPE]

Function

Sets/queries the detector type for DTMF measurements.

Setting

Range: RMS|PPEak|NPEak|PNPMaximum|PNPDivide2

Query

Range: RMS|PPE|NPE|PNPM|PNPD2

*RST setting

PNPM

Requirement

Test Application Revision: B.09 and above

Lab Application Revision: B.03 and above

Programming Example

10 OUTPUT 714;"SETup:DTMF:DETector PPE"
!Set the type of dector to be peak+

SETup:DTMF:GTIMe

Function

Sets/queries the gate time for DTMF measurements. When the gate time is reached, the sample is processed to find DTMF characters.

Setting

Range: 0.1 to 6.0 seconds

Resolution: 0.1 second

Step Size: 1.0 second

Query

Range: 0.1 to 6.0 seconds

*RST Setting

2.0 seconds

Requirement

Test Application Revision: B.09 and above

Lab Application Revision: B.03 and above

Programming Example

OUTPUT 714;"SETup:DTMF:GTIMe 5S"

SETup:DTMF:TIMeout[:STIMe]

Function

Sets/queries the DTMF measurement's timeout setting and automatically sets the timeout state to ON.

Setting

Range: 0.1 to 999 seconds

Resolution: 0.1 second

Query

Range: 0.1 to 999

*RST Setting

10 seconds, off

Requirement

Test Application Revision: B.09 and above

Lab Application Revision: B.03 and above

Programming Example

OUTPUT 714;"SETup:DTMF:TIMeout:STIMe 5S"
!Sets timeout state to ON and sets the timeout time to 5 seconds.

SETup:DTMF:TIMeout:STATe

Function

Sets/queries the DTMF measurement's timeout state.

Setting

Range: 1|ON|0|OFF

Query

Range: 1|0

*RST Setting

0 (off)

Requirement

Test Application Revision: B.09 and above

Lab Application Revision: B.03 and above

Programming Example

OUTPUT 714;"SETup:DTMF:TIMeout:STATe ON"

SETup:DTMF:TIMeout:TIME

Function

Sets/queries the DTMF measurement's timeout setting to be used when the timeout state is set to ON.

Setting

Range: 0.1 to 999 seconds

Resolution: 0.1 second

Query

Range: 0.1 to 999

*RST Setting

10 seconds

Requirement

Test Application Revision: B.09 and above

Lab Application Revision: B.03 and above

Programming Example

OUTPUT 714;"SETup:DTMF:TIMeout:TIME 5S"


SETup:FM

SETup:FM

Last updated: June 7, 2007

GPIB Command Conventions

  • SETup:FM:CONTinuous
  • SETup:FM:COUNt[:SNUMber]
  • SETup:FM:COUNt:NUMBer
  • SETup:FM:COUNt:STATe
  • SETup:FM:DEMPhasis:STATe
  • SETup:FM:DETector[:TYPE]
  • SETup:FM:DISTortion:FREQuency
  • SETup:FM:DISTortion:STATe
  • SETup:FM:EXPandor:STATe
  • SETup:FM:FILTer[:TYPE]
  • SETup:FM:FILTer:TBPass[:FREQuency]
  • SETup:FM:FREQuency:STATe
  • SETup:FM:GTIMe
  • SETup:FM:TIMeout[:STIMe]
  • SETup:FM:TIMeout:STATe
  • SETup:FM:TIMeout:TIME

SETup:FM:CONTinuous

Function

Sets/queries the trigger arm state for the FM measurement. Determines whether measurement will make one measurement then stop (0|OFF (single)), or automatically rearm upon completion of one measurement and repeat the process (1|ON (continuous)).

Setting

Range: 1|ON|0|OFF

Query

Range: 1|0

*RST Setting

0 (off)

Programming Example

OUTPUT 714;"SETup:FM:CONTinuous ON"
!Sets measurement to continuous trigger mode.

SETup:FM:COUNt[:SNUMber]

Function

Sets/queries the number of FM measurements to be made in a mulit-measurement setup. This command sets the count, and automatically sets the multi-measurement STATe command to 1 (on).

Setting

Range: 1 to 999

Query

Range: 1 to 999

*RST Setting

10, off

Programming Example

OUTPUT 714;"SETup:FM:COUNt 5"
!Turns on multi-measurements and sets the number of measurements to 5.

SETup:FM:COUNt:NUMBer

Function

Sets/queries the number of FM measurements to be made when mulit-measurement state is ON.

Setting

Range: 1 to 999

Query

Range: 1 to 999

*RST Setting

 10

Programming Example

OUTPUT 714;"SETup:FM:COUNt:NUMBer 5"
!Sets the number of measurements to 5 when the multi-measurement state is set to ON.

SETup:FM:COUNt:STATe

Function

Sets/queries the multi-measurement state of the FM measurement.

Setting

Range: 1|ON|0|OFF

Query

Range: 1|0

*RST Setting

0 (off)

Programming Example

OUTPUT 714;"SETup:FM:COUNt:STATe ON"
!Turns on multi-measurements.

SETup:FM:DEMPhasis:STATe

Function

Sets/queries whether 750 us de-emphasis is enabled.

Setting

Range: 1|ON|0|OFF

Query

Range: 1|0

*RST Setting

0 (off)

Programming Example

10 OUTPUT 714;"SETup:FM:DEMPhasis:STATe ON"

SETup:FM:DETector[:TYPE]

Function

Sets/queries the detector type for FM measurements.

Setting

Range: RMS|PPEak|NPEak|PNPMaximum|PNPDivide2

Query

Range: RMS|PPE|NPE|PNPM|PNPD2

*RST setting

RMS

Requirement

The parameters: PNPMaximum and PNPDivide2 are provided in the following applications:

Test Application Revision: B.09 and above

Lab Application Revision: B.03 and above

Programming Example

10 OUTPUT 714;"SETup:FM:DETector PPE"
!Set the detector type to be Peak+

SETup:FM:DISTortion:FREQuency

Function

Sets/queries the FM distortion fundamental frequency.

Setting

Range: 100 to 10000 Hz

Resolution: 1 Hz

Query

Range: 100 to 10000 Hz

*RST setting

1004 Hz

Programming Example

10 OUTPUT 714;"SETup:FM:DISortion:FREQuency 300HZ"

SETup:FM:DISTortion:STATe

Function

Sets/queris whether the FM distortion measurement is enabled.

Setting

Range: 1|0N|0|OFF

Query

Range: 1|0

*RST setting

0 (off)

Programming Example

10 OUTPUT 714;"SETup:FM:SDISTortion:STATe ON"

SETup:FM:EXPandor:STATe

Function

Sets/queries whether the expandor is enabled.

Setting

Range: 1|ON|0|OFF

Query

Range: 1|0

*RST setting

0 (off)

Programming Example

10 OUTPUT 714;"SETup:FM:EXPandor:STATe ON"

SETup:FM:FILTer[:TYPE]

Function

Sets/queries the filter type for FM measurements.

Setting

Range: NONE|TBPass|CMESsage|BPASs50|BPASs300|BPASs3000

Query

Range: NONE|TBP|CMES|BPAS50|BPAS300|BPAS3000

*RST setting

NONE

Programming Example

10 OUTPUT 714;"SETup:FM:FILTer BPAS50"
!Selects the 50 Hz to 15 kHz bandpass filter.

SETup:FM:FILTer:TBPass[:FREQuency]

Function

Sets/queries the center frequency for the 100 Hz tunable bandpass filter (TBPass).

Setting

Range: 300.0 to 15000 Hz

Resolution: 0.1 Hz

Query

Range: 300.0 to 15000 Hz

*RST setting

1000 Hz

Programming Example

10 OUTPUT 714;"SETup:FM:FILTer:TBPass 300HZ"

SETup:FM:FREQuency:STATe

Function

Sets/queries whether the FM modulation frequency measurement is enabled.

Setting

Range: 1|ON|0|OFF

Query

Range: 1|0

*RST setting

0 (off)

Programming Example

OUTPUT 714;"SETup:FM:FREQuency:STATe ON"

SETup:FM:GTIMe

Function

Sets/queries the gate time for FM module frequency measurements.

Setting

Range: 0.05 to 6.05 seconds

Resolution: 0.1 second

Step Size: 1.0 second

Query

Range: 0.05 to 6.05 seconds

*RST Setting

0.05 seconds

Requirement

Test Application Revision: B.09 and above

Lab Application Revision: B.03 and above

Programming Example

OUTPUT 714;"SETup:FM:GTIMe 5S"

SETup:FM:TIMeout[:STIMe]

Function

Sets/queries the FM measurement's timeout setting and automatically sets the timeout state to ON.

Setting

Range: 0.1 to 999 seconds

Resolution: 0.1 second

Query

Range: 0.1 to 999

*RST Setting

10 seconds, on

Programming Example

OUTPUT 714;"SETup:FM:TIMeout 5S"
!Sets timeout state to ON and sets the timeout time to 5 seconds.

SETup:FM:TIMeout:STATe

Function

Sets/queries the FM measurement's timeout state.

Setting

Range: 1|ON|0|OFF

Query

Range: 1|0

*RST Setting

0 (off)

Programming Example

OUTPUT 714;"SETup:FM:TIMeout:STATe ON"

SETup:FM:TIMeout:TIME

Function

Sets/queries the FM measurement's timeout setting to be used when the timeout state is set to ON.

Setting

Range: 0.1 to 999 seconds

Resolution: 0.1 second

Query

Range: 0.1 to 999

*RST Setting

10 seconds

Programming Example

OUTPUT 714;"SETup:FM:TIMeout:TIME 5S"


SETup:FSTability

SETup:FSTability

Last updated: June 7, 2007

GPIB Command Conventions

  • SETup:FSTability:CONTinuous
  • SETup:FSTability:COUNt[:SNUMber]
  • SETup:FSTability:COUNt:NUMBer
  • SETup:FSTability:COUNt:STATe
  • SETup:FSTability:TIMeout[:STIMe]
  • SETup:FSTability:TIMeout:STATe
  • SETup:FSTability:TIMeout:TIME

SETup:FSTability:CONTinuous

Function

Sets/queries the trigger arm state for the frequency stability measurement. Determines whether measurement will make one measurement then stop (0|OFF (single)), or automatically rearm upon completion of one measurement and repeat the process (1|ON (continuous)).

Setting

Range: 1|ON|0|OFF

Query

Range: 1|0

*RST Setting

0 (off)

Programming Example

OUTPUT 714;"SETUP:FSTABILITY:CONTINUOUS ON"
!Sets measurement to continuous trigger mode.

SETup:FSTability:COUNt[:SNUMber]

Function

Sets/queries the number of frequency stability measurements to be made in a mulit-measurement setup. This command sets the count, and automatically sets the multi-measurement STATe command to 1 (on).

Setting

Range: 1 to 999

Query

Range: 1 to 999

*RST Setting

10, on

Programming Example

OUTPUT 714;"SETUP:FSTABILITY:COUNT:SNUMBER 5"
!Turns on multi-measurements and sets the number of measurements to 5.

SETup:FSTability:COUNt:NUMBer

Function

Sets/queries the number of frequency stability measurements to be made when mulit-measurement state is ON.

Setting

Range: 1 to 999

Query

Range: 1 to 999

*RST Setting

 10

Programming Example

OUTPUT 714;"SETUP:FSTABILITY:COUNT:NUMBER 5"
!Sets the number of measurements to 5 when the multi-measurement state is set to ON.

SETup:FSTability:COUNt:STATe

Function

Sets/queries the multi-measurement state of the frequency stability measurement.

Setting

Range: 1|ON|0|OFF

Query

Range: 1|0

*RST Setting

0 (off)

Programming Example

OUTPUT 714;"SETUP:FSTABILITY:COUNT:STATE ON" !Turns on multi-measurements.

SETup:FSTability:TIMeout[:STIMe]

Function

Sets/queries the frequency stability measurement's timeout setting and automatically sets the timeout state to ON.

Setting

Range: 0.1 to 999 seconds

Resolution: 0.1 second

Query

Range: 0.1 to 999

*RST Setting

10 seconds, on

Programming Example

OUTPUT 714;"SETUP:FSTABILITY:TIMEOUT:STIME 5S"
!Sets timeout state to ON and sets the timeout time to 5 seconds.

SETup:FSTability:TIMeout:STATe

Function

Sets/queries the frequency stability measurement's timeout state.

Setting

Range: 1|ON|0|OFF

Query

Range: 1|0

*RST Setting

0 (off)

Programming Example

OUTPUT 714;"SETUP:FSTABILITY:TIMEOUT:STATE ON"

SETup:FSTability:TIMeout:TIME

Function

Sets/queries the frequency stability measurement's timeout setting.

Setting

Range: 0.1 to 999 seconds

Resolution: 0.1 second

Query

Range: 0.1 to 999 seconds

Resolution: 0.1 second

*RST Setting

10 seconds, on

Programming Example

OUTPUT 714;"SETUP:FSTABILITY:TIMEOUT:TIME 5S"


SETup:GPOWer

SETup:GPOWer

Last updated: June 7, 2007

GPIB Command Conventions

  • SETup:GPOWer:CONTinuous
  • SETup:GPOWer:COUNt[:SNUMber]
  • SETup:GPOWer:COUNt:NUMBer
  • SETup:GPOWer:COUNt:STATe
  • SETup:GPOWer:TIMeout[:STIMe]
  • SETup:GPOWer:TIMeout:STATe
  • SETup:GPOWer:TIMeout:TIME

SETup:GPOWer:CONTinuous

Function

Sets/queries the trigger arm state for the gated power measurement. The trigger arm state determines whether the gated power measurement will be made once then stop (0|OFF (single)), or automatically re-arm upon completion of one measurement and repeat the process (1|ON (continuous)).

Setting

Range: 1|ON|0|OFF

Query

Range: 1|0

*RST Setting

0 (off)

Programming Example

OUTPUT 714;"SETUP:GPOWER:CONTINUOUS OFF"
!Sets measurement to single trigger mode.

SETup:GPOWer:COUNt[:SNUMber]

Function

The setting form of this command performs two functions: (1) sets the number of gated power measurements to be made in a multi-measurement, and (2) sets the multi-measurement STATe command to 1 (on).

The query form returns the number of gated power multi-measurements to be made when mulit-measurement state is ON.

Setting

Range: 1 to 999

Query

Range: 1 to 999

*RST Setting

 Off (10 when STATe = On)

Programming Example

OUTPUT 714;"SETUP:GPOWER:COUNT:SNUMBER 5"
!Turns on multi-measurements and sets the number of measurements to 5.

SETup:GPOWer:COUNt:NUMBer

Function

Sets/queries the number of gated power measurements to be made when the mulit-measurement state is ON.

Setting

Range: 1 to 999

Query

Range: 1 to 999

*RST Setting

 10

Programming Example

OUTPUT 714;"SETUP:GPOWER:COUNT:NUMBER 5"
!Sets the number of gated power multi-measurements to 5.

SETup:GPOWer:COUNt:STATe

Function

Sets/queries the gated power multi-measurement state.

Setting

Range: 1|ON|0|OFF

Query

Range: 1|0

*RST Setting

0 (off)

Programming Example

OUTPUT 714;"SETUP:GPOWER:COUNT:STATE ON" !Turns on gated power multi-measurements.

SETup:GPOWer:TIMeout[:STIMe]

Function

The setting form of this command performs two functions: (1) sets the gated power measurement's timeout (see Timeouts ) value, and (2) sets the gated power measurement's timeout STATe to 1 (on).

The query form returns the gated power measurement's timeout value.

Setting

Range: 0.1 to 999.9 seconds

Resolution: 0.1 second

Query

Range: 0.1 to 999.9

*RST Setting

10 seconds, on

Programming Example

OUTPUT 714;"SETUP:GPOWER:TIMEOUT:STIME 5 S"
!Sets timeout state to ON and sets the timeout time to 5 seconds.

SETup:GPOWer:TIMeout:STATe

Function

Sets/queries the gated power measurement's timeout (see Timeouts ) state.

Setting

Range: 1|ON|0|OFF

Query

Range: 1|0

*RST Setting

0 (off)

Programming Example

OUTPUT 714;"SETUP:GPOWER:TIMEOUT:STATE ON"

SETup:GPOWer:TIMeout:TIME

Function

Sets/queries the gated power measurement's timeout (see Timeouts ) setting to be used when the timeout state is set to ON.

Setting

Range: 0.1 to 999.9 seconds

Resolution: 0.1 second

Query

Range: 0.1 to 999.9

*RST Setting

10 seconds

Programming Example

OUTPUT 714;"SETUP:GPOWER:TIMEOUT:TIME 5 S"


SETup:HWQuality

SETup:HWQuality

Last updated: June 7, 2007

GPIB Command Conventions

  • SETup:HWQuality:TIMeout[:STIMe]
  • SETup:HWQuality:TIMeout:STATe
  • SETup:HWQuality:TIMeout:TIME

SETup:HWQuality:TIMeout[:STIMe]

Function

Sets the handoff waveform quality measurement's timeout value, and sets the waveform quality measurement's timeout state to 1 (on).

The query form returns the waveform quality measurement's timeout value.

Setting

Range: 1 to 999 seconds

Resolution: 1 second

Query

Range: 1 to 999

*RST Setting

10 seconds, on

Programming Example

OUTPUT 714;"SETUP:HWQUALITY:TIMEOUT:STIME 5 S"
!Sets timeout state to ON and sets the timeout time to 5 seconds.

SETup:HWQuality:TIMeout:STATe

Function

Sets/queries the handoff waveform quality measurement's timeout state.

Setting

Range: 1|ON|0|OFF

Query

Range: 1|0

*RST Setting

0 (off)

Programming Example

OUTPUT 714;"SETUP:HWQUALITY:TIMEOUT:STATE ON"

SETup:HWQuality:TIMeout:TIME

Function

Sets/queries the handoff waveform quality measurement's timeout setting to be used when the timeout state is set to ON.

Setting

Range: 1 to 999 seconds

Resolution: 1 second

Query

Range: 1 to 999

*RST Setting

10 seconds

Programming Example

OUTPUT 714;"SETUP:HWQUALITY:TIMEOUT:TIME 5 S"


SETup:CMMPower

SETup:CMMPower

Last updated: June 7, 2007

GPIB Command Conventions

  • SETup:CMMPower:POWer:AMPLitude:MAXimum
  • SETup:CMMPower:POWer:AMPLitude:MINimum
  • SETup:CMMPower:PILot:LEVel:MAXimum
  • SETup:CMMPower:PILot:LEVel:MINimum
  • SETup:CMMPower:RFANalyzer:AUTO:MINimum
  • SETup:CMMPower:RFANalyzer:POWer:MINimum
  • SETup:CMMPower:TRAFfic:LEVel:MAXimum
  • SETup:CMMPower:TRAFfic:LEVel:MINimum
  • SETup:CMMPower:TIMeout[:STIMe]
  • SETup:CMMPower:TIMeout:STATe
  • SETup:CMMPower:TIMeout:TIME

SETup:CMMPower:POWer:AMPLitude:MAXimum

Function

Sets/queries Cell Power for the maximum power measurement. When the measurement is finished, the test set returns to its pre-measurement settings ( CALL[:CELL[1]]:POWer[:SAMPlitude][:SELected] ).

See Maximum/Minimum Power Measurement Parameters .

Setting

Range: -170 dBm/1.23MHz to +37dBm/1.23MHz

Resolution: 0.01 dB

Query

Range: -170 dBm/1.23MHz to +37dBm/1.23MHz

Resolution: 0.01 dB

*RST Setting

- 104 dBm / 1.23 MHz

Requirements

Test Application Revision: B.07 and above

Lab Application Revision: B.01 and above

Programming Example

OUTPUT 714;"SETup:CMMPower:POWer:AMPLitude:MAXimum -20"
!Sets Cell Power for the maximum power measurement to -20 dBm/1.23 MHZ.

SETup:CMMPower:POWer:AMPLitude:MINimum

Function

Sets/queries Cell Power for the minimum power measurement. When the measurement is finished, the test set returns to its pre-measurement settings ( CALL[:CELL[1]]:POWer[:SAMPlitude][:SELected] ).

See Maximum/Minimum Power Measurement Parameters .

Setting

Range: -170 dBm/1.23MHz to +37 dBm/1.23MHz

Resolution: 0.01 dB

Query

Range: -170 dBm/1.23MHz to +37 dBm/1.23MHz

Resolution: 0.01 dB

*RST Setting

 - 25 dBm /1.23 MHz

Requirements

Test Application Revision: B.07 and above

Lab Application Revision: B.01 and above

Programming Example

OUTPUT 714;"SETup:CMMPower:POWer:AMPLitude:MINimum -50"
!Sets Cell Power for the minimum power measurement to -50 dBM/1.23 MHZ.

SETup:CMMPower:PILot:LEVel:MAXimum

Function

Sets/queries Pilot Level for the maximum power measurement. When the measurement is finished, the test set returns to its pre-measurement settings ( CALL[:CELL[1]]:PILOT[:SLEVel][:SELected] ).

See Maximum/Minimum Power Measurement Parameters .

Setting

Range: 0 to -20 dB

Resolution: 0.0001 dB

Query

Range: 0 to -20 dB

Resolution: 0.0001 dB

*RST Setting

- 7 dB

Requirements

Test Application Revision: B.07 and above

Lab Application Revision: B.01 and above

Programming Example

OUTPUT 714;"SETup:CMMPowerr:PILot:LEVel:MAXimum -7"
!Sets pilot level for the maximum power measurement to -7 dB.

SETup:CMMPower:PILot:LEVel:MINimum

Function

Sets/queries Pilot Level for the minimum power measurement. When the measurement is finished, the test set returns to its pre-measurement settings ( CALL[:CELL[1]]:PILOT[:SLEVel][:SELected] ).

See Maximum/Minimum Power Measurement Parameters .

Setting

Range: 0 to -20 dB

Resolution: 0.0001 dB

Query

Range: 0 to -20 dB

Resolution: 0.0001 dB

*RST setting

 - 7 dB

Requirements

Test Application Revision: B.07 and above

Lab Application Revision: B.01 and above

Programming Example

OUTPUT 714;"SETup:CMMPowerr:PILot:LEVel:MINimum -7"
!Sets pilot level for the minimum power measurement to -7 dB.

SETup:CMMPower:RFANalyzer:AUTO:MINimum

Function

Sets/queries the receiver power control mode for the minimum power measurement. When the measurement is finished, the test set returns to its pre-measurement settings (see Receiver Control ).

See Maximum/Minimum Power Measurement Parameters .

Setting

 Range: ON|1|OFF|0

Query

Range: 1 |0

*RST setting

1 (Auto)

Requirements

Test Application Revision: B.07 and above

Lab Application Revision: B.01 and above

Programming Example

OUTPUT 714;"SETup:CMMPower:RFANalyzer:AUTO:MINimum OFF"
!Sets the receiver power control mode for the minimum power
!measurement to be manual.

SETup:CMMPower:RFANalyzer:POWer:MINimum

Function

Sets/queries the manual receiver power for the minimum power measurement when the receiver power control mode has been set to off (Manual) by SETup:CMMPower:RFANalyzer:AUTO:MINimum .

When the measurement is finished, the test set returns to its pre-measurement settings (see Receiver Control ).

See Maximum/Minimum Power Measurement Parameters .

Setting

Range: -129 dBm to + 80 dBm

Resolution: 0.01 db

Query

Range: -129 dBm to + 80 dBm

Resolution: 0.01 dB

*RST setting

 - 50 dBm

Requirements

Test Application Revision: B.07 and above

Lab Application Revision: B.01 and above

Programming Example

OUTPUT 714;"SETup:CMMPower:RFANalyzer:Power:MINimum -30"
!Sets the manual receiver power for the minimum power measurement to -30 dBm.

SETup:CMMPower:TRAFfic:LEVel:MAXimum

Function

Sets/queries F-FCH (IS-2000 system) or Traffic Level (IS-95 system) for the maximum power measurement.

When the measurement is finished, the test set returns to its pre-measurement settings (see CALL[:CELL[1]]:TRAFfic[:FORWard][:SLEVel]<[:SELected]|DIGital95> or CALL[:CELL[1]]:FCHannel[:FORWard][:SLEVel]<[:SELected]|DIGital2000> ).

See Maximum/Minimum Power Measurement Parameters .

Setting

Range: 0 to -30 dB

Resolution: 0.0001 dB

Query

Range: 0 to -30 dB

Resolution: 0.0001 dB

*RST Setting

 - 7.4 dB

Requirements

Test Application Revision: B.07 and above

Lab Application Revision: B.01 and above

Programming Example

OUTPUT 714;"SETup:CMMPower:TRAFfic:LEVel:MAXimum -15"
!Sets the F-FCH/Traffic Level for the maximum power measurement to -15 dB.

SETup:CMMPower:TRAFfic:LEVel:MINimum

Function

Sets/queries F-FCH (IS-2000 system) or Traffic Level (IS-95 system) for the minimum power measurement.

When the measurement is finished, the test set returns to its pre-measurement settings (see CALL[:CELL[1]]:TRAFfic[:FORWard][:SLEVel]<[:SELected]|DIGital95> or CALL[:CELL[1]]:FCHannel[:FORWard][:SLEVel]<[:SELected]|DIGital2000> ).

See Maximum/Minimum Power Measurement Parameters .

Setting

Range: 0 to -30 dB

Resolution: 0.0001 dB

Query

Range: 0 to -30 dB

Resolution: 0.0001 dB

*RST Setting

 - 7.4 dB

Requirements

Test Application Revision: B.07 and above

Lab Application Revision: B.01 and above

Programming Example

OUTPUT 714;"SETup:CMMPower:TRAFfic:LEVel:MINimum -15"
!Sets the F-FCH/Traffic Level for the minimum power measurement to -15 dB.

SETup:CMMPower:TIMeout[:STIMe]

Function

The setting form of this command performs two functions: (1) sets the maximum/minimum power measurement's timeout value, and (2) sets the maximum/minimum power measurement's timeout STATe to 1 (on).

The query form returns the maximum/minimum power measurement's timeout value.

Setting

Range: 1 to 999 seconds

Resolution: 1 second

Query

Range: 1 to 999

*RST Setting

10 seconds

Requirements

Test Application Revision: B.07 and above

Lab Application Revision: B.01 and above

Programming Example

OUTPUT 714;"SETup:CMMPower:TIMeout 5S"
!Sets timeout state to ON and the timeout time to 5 seconds
!for the maximum/minimum power measurement.

SETup:CMMPower:TIMeout:STATe

Function

Sets/queries the maximum/minimum power measurement's timeout state.

Setting

Range: 1|ON|0|OFF

Query

Range: 1|0

*RST Setting

0 (off)

Programming Example

OUTPUT 714;"SSETup:CMMPower:TIMeout:STATe ON"
!Sets timeout state for the maximum/minimum power measurement to ON.

SETup:CMMPower:TIMeout:TIME

Function

Sets/queries the maximum/minimum power measurement's timeout time to be used when the timeout state is set to ON.

Setting

Range: 1 to 999 seconds

Resolution: 1 second

Query

Range: 1 to 999

*RST Setting

10 seconds

Requirements

Test Application Revision: B.07 and above

Lab Application Revision: B.01 and above

Programming Example

OUTPUT 714;"SETup:CMMPower:TIMeout:TIME 5S"
!Sets the timeout time for the maximum/minimum power measurement to 5 seconds.


SETup:CMAudio

SETup:CMAudio

Last updated: June 7, 2007

GPIB Command Conventions

  • SETup:CMAudio:ANALyzer:DOWNlink:SETTling
  • SETup:CMAudio:ANALyzer:FREQuency:ALL[:SVALue]
  • SETup:CMAudio:ANALyzer:FREQuency:ALL:GENerator
  • SETup:CMAudio:CONTinuous
  • SETup:CMAudio:COUNt[:SNUMber]
  • SETup:CMAudio:COUNt:NUMBer
  • SETup:CMAudio:COUNt:STATe
  • SETup:CMAudio:GENerator:FREQuency:DOWNlink:ALL[:SVALue]?
  • SETup:CMAudio:GENerator:FREQuency:DOWNlink:PRESet
  • SETup:CMAudio:GENerator:FREQuency:Uplink:ALL[:SVALue]
  • SETup:CMAudio:GENerator:FREQuency:Uplink:PRESet
  • SETup:CMAudio:GENerator:LEVel:DOWNlink:ALL[:SAMPlitude]?
  • SETup:CMAudio:GENerator:LEVel:DOWNlink:ALL:TOTal[:SAMPlitude]
  • SETup:CMAudio:GENerator:LEVel:DOWNlink:ALL:TOTal:AMPlitude
  • SETup:CMAudio:GENerator:LEVel:DOWNlink:ALL:TOTal:STATe?
  • SETup:CMAudio:GENerator:LEVel:UPLink:ALL[:SAMPlitude]
  • SETup:CMAudio:GENerator:LEVel:UPLink:ALL:TOTal[:SAMPlitude]
  • SETup:CMAudio:GENerator:LEVel:UPLink:ALL:TOTal:AMPLitude
  • SETup:CMAudio:GENerator:LEVel:UPLink:ALL:TOTal:STATe
  • SETup:CMAudio:LEVel:ALL:LIMit:LOWer
  • SETup:CMAudio:LEVel:ALL:LIMit:UPPer
  • SETup:CMAudio:MEASurement:MODE
  • SETup:CMAudio:PEAK:VOLTage
  • SETup:CMAudio:REFerence:ABSolute:LEVel:DOWNlink
  • SETup:CMAudio:REFerence:ABSolute:LEVel:UPLink
  • SETup:CMAudio:REFerence:MODE
  • SETup:CMAudio:REFerence:RELative:TONE
  • SETup:CMAudio:SDIStortion:SBWidth:UPLink
  • SETup:CMAudio:SDIStortion:STATe
  • SETup:CMAudio:SETTling[:TIME]
  • SETup:CMAudio:TIMeout[:STIMe]
  • SETup:CMAudio:TIMeout:STATe
  • SETup:CMAudio:TIMeout:TIME

SETup:CMAudio:ANALyzer:DOWNlink:SETTling

Function

 Sets/queries the time (in frames) that the downlink multi-tone audio measurement should be held off to ensure that transients have settled in the vocoders in the test set's transmitter and the mobile station's receiver. See Multi-Tone Audio Setup for details.
Setting Range: 0 to 100 (frames)
Resolution: 1

Query

 same as setting

*RST setting

 30 (frames)

Requirement

 Test Application Revision: B.08 and above
Lab Application Revision: B.02 and above

Programming Example

OUTPUT 714;"SETup:CMAudio:ANALyzer:DOWNlink:SETTling 50"
!Sets the audio analyzer settling time to 50 frames
!after changing downlink generator parameter.

SETup:CMAudio:ANALyzer:FREQuency:ALL[:SVALue]

Function

Sets/queries multi-tone audio analyzer frequencies/states for each of the 20 tones in the form of a comma-separated list of 20 values. A value (in units of Hz by default) must be entered for each of the 20 tones. An entry of 0 in the list indicates that the state of that tone is set to Off.

The multi-tone audio analyzer frequencies/states can not be set when the SETup:CMAudio:ANALyzer:FREQuency:ALL:GENerator is set to ON.
Setting

Range: 10 to 4000 Hz (only spec'd to 3000 Hz) and 0 (indicating that tone is turned off)
Resolution: 10 Hz

Query

Same as above settings

*RST setting

 100 Hz increments starting at 300 Hz for the first tone

Requirement

 Test Application Revision: B.08 and above
Lab Application Revision: B.02 and above

Programming Example

OUTPUT 714;"SETup:CMAudio:ANALyzer:FREQuency:ALL 350, 400, 450, 500, 550, 600, 650, 700, 750, 800, 850, 900, 950, 1000, 1050, 1100, 1150, 1200, 1250, 0"
!Sets multi-tone audio analyzer frequencies for tones 1 to 19 and turns
!their states to On, and turns off tone 20.

SETup:CMAudio:ANALyzer:FREQuency:ALL:GENerator

Function

Sets/queries whether to use the specified uplink or downlink audio generator frequencies/states for the multi-tone audio analyzer frequencies/states.

When this setting is On, the analyzer sets its frequencies/states according to the downlink audio generator frequency settings ( SETup:CMAudio:GENerator:FREQuency:DOWNlink:PRESet ) for the downlink measurements (when SETup:CMAudio:MEASurement:MODE is set to DOWNlink), or according to the uplink audio generator frequency settings ( SETup:CMAudio:GENerator:FREQuency:Uplink:ALL[:SVALue] or SETup:CMAudio:GENerator:FREQuency:Uplink:PRESet ) for the uplink measurements (when SETup:CMAudio:MEASurement:MODE is set to UPLink). It is useful if you want to measure the same frequencies that are generating.

When this setting is 'Off', the analyzer will use the frequency list specified by SETup:CMAudio:ANALyzer:FREQuency:ALL[:SVALue] for the multi-tone audio measurements.
Setting

Range: 1|ON|0|OFF

Query

 Range: 0|1

*RST setting

 1 (ON)

Requirement

 Test Application Revision: B.08 and above
Lab Application Revision: B.02 and above

Programming Example

OUTPUT 714;"SETup:CMAudio:ANALyzer:FREQuency:ALL:GENerator OFF"
!Removes coupling between generator and analyzer frequency values and states.

SETup:CMAudio:CONTinuous

Function

Sets/queries the trigger arm state for multi-tone audio measurements. The trigger arm state determines whether the multi-tone audio measurement will be made once then stop (0|OFF (single)), or automatically re-arm upon completion of one measurement and repeat the process (1|ON (continuous)).

This setting overrides previously set trigger arm settings for all measurements (see SETup[:ALL]:CONTinuous<:OFF|:ON> ).
Setting

Range: 1|ON|0|OFF

Query

 Range: 0|1

*RST setting

 0 (OFF)

Requirement

 Test Application Revision: B.08 and above
Lab Application Revision: B.02 and above

Programming Example

OUTPUT 714;"SETup:CMAudio:CONTinuous OFF"
!Selects single trigger mode.

SETup:CMAudio:COUNt[:SNUMber]

Function

 Sets/queries the number of multi-tone audio measurements the test set will make in a multi-measurement and sets the multi-measurement state to ON.
Setting

Range: 1 to 999
Resolution: 1

Query

same as settings
*RST setting 10

Requirement

 Test Application Revision: B.08 and above
Lab Application Revision: B.02 and above

Programming Example

OUTPUT 714;"SETup:CMAudio:COUNt 5"
!Sets measurement count number to 5 and the state to on.

SETup:CMAudio:COUNt:NUMBer

Function

 Sets/queries the number of multi-tone audio measurements the test set will make when the SETup:CMAudio:COUNt:STATe is ON.
Setting

Range: 1 to 999
Resolution: 1

Query

 same as setting

*RST setting

 10

Requirement

 Test Application Revision: B.08 and above
Lab Application Revision: B.02 and above

Programming Example

OUTPUT 714;"SETup:CMAudio:COUNt:NUMBer 10"
!Sets the measurement count number to 10.

SETup:CMAudio:COUNt:STATe

Function

 Sets/queries the multi-tone audio multi-measurement state.
Setting Range: 1|ON|0| OFF

Query

 Range: 1|0

*RST setting

 0 (OFF)

Requirement

 Test Application Revision: B.08 and above
Lab Application Revision: B.02 and above

Programming Example

OUTPUT 714;"SETup:CMAudio:COUNt:STATe ON"
!Turns the multi-measurement state on.

SETup:CMAudio:GENerator:FREQuency:DOWNlink:ALL[:SVALue]?

Function

Queries the downlink audio generator frequencies/states for each of the 20 tones to be used in a downlink measurement (see SETup:CMAudio:MEASurement:MODE ). This query returns a comma-separated list of 20 values in Hz. A value of 0 indicates that the corresponding tone state is set to Off.

To set the audio frequencies for the downlink audio generator, use SETup:CMAudio:GENerator:FREQuency:DOWNlink:PRESet .

Query

Range:

  • 10 to 4000 Hz (only spec'd to 3000 Hz)
  • 0 (indicating the tone is off)
Resolution: 10 Hz

*RST setting

 same as Narrow preset (see SETup:CMAudio:GENerator:FREQuency:DOWNlink:PRESet )

Requirement

 Test Application Revision: B.08 and above
Lab Application Revision: B.02 and above

Programming Example

OUTPUT 714;"SETup:CMAudio:GENerator:FREQuency:DOWNlink:ALL?"
!Queries audio frequencies for each of the 20 tones for the downlink audio generator.

SETup:CMAudio:GENerator:FREQuency:DOWNlink:PRESet

Function

Sets/queries the downlink audio generator frequencies/states for each of the 20 tones from a preset selected. It is used in a downlink measurement (see SETup:CMAudio:MEASurement:MODE ).

The state of the frequency and level for any given tone is coupled. Setting the tone's frequency state will simultaneously set the tone's level state ( SETup:CMAudio:GENerator:LEVel:DOWNlink:ALL[:SAMPlitude]? ) to the same value.
Setting

Range: NONE|NARRow|NORMal|WIDE|SIN300|SIN600|SIN800|SIN1000|SIN1200
|SIN1600|SIN2000|SIN2400|SIN2800|SIN3000|AOFF

  • NONE: no preset state or generator frequency settings do not match one of the preset states
  • NARRow: sets the tones <N=1 to 12> to (100*N+200) Hz, and tones <N=13 to 20> to (200*N - 1000) Hz
  • NORMal: sets the first tone to 300 Hz, tones <N=2 to 5> to (200*N+200) Hz, and tones <N=6 to 9> to (400*N - 800) Hz, tone <N=10> to 3000 Hz, and turns all others off
  • WIDE: sets the tones <N=1 to 10> to (100*N) Hz, tones <N=11 to 14> to (200*N - 1000) Hz, tones <N=15 to 17> to (400*N - 4000) Hz, and tones <N=18 to 20> to (300*N - 2400) Hz
  • SIN300: sets the first tone to 300 Hz and turns all others off
  • SIN600: sets the first tone to 600 Hz and turns all others off
  • SIN800: sets the first tone to 800 Hz and turns all others off
  • SIN1000: sets the first tone to 1000 Hz and turns all others off
  • SIN1200: sets the first tone to 1200 Hz and turns all others off
  • SIN1600: sets the first tone to 1600 Hz and turns all others off
  • SIN2000: sets the first tone to 2000 Hz and turns all others off
  • SIN2400: sets the first tone to 2400 Hz and turns all others off
  • SIN2800: sets the first tone to 2800 Hz and turns all others off
  • SIN3000: sets the first tone to 3000 Hz and turns all others off
  • AOFF: turns all tones off

Query

 Range: NONE|NARRow|NORMal|WIDE|SIN300|SIN600|SIN800|SIN1000
|SIN1200|SIN1600|SIN2000|SIN2400|SIN2800|SIN3000|AOFF

*RST setting

 NARRow

Requirement

 Test Application Revision: B.08 and above
Lab Application Revision: B.02 and above

Programming Example

OUTPUT 714;"SETup:CMAudio:GENerator:FREQuency:DOWNlink:PRESet NARRow"
!Sets audio tones' frequencies generated by downlink audio generator
!based on the NARRow preset.

SETup:CMAudio:GENerator:FREQuency:Uplink:ALL[:SVALue]

Function

Sets/queries the individual audio frequencies/states for each of the 20 tones for the uplink audio generator to be used in an uplink measurement (see SETup:CMAudio:MEASurement:MODE ).

It is specified in the form of a comma-separated list of 20 values. A value (in units of Hz) must be entered for each of the 20 tones. An entry of 0 in the list indicates that the state of that tone is set to Off. You can also specify the uplink audio generator frequencies/states from a preset by SETup:CMAudio:GENerator:FREQuency:Uplink:PRESet .

The state of the frequency and level for any given tone is coupled. Setting the tone's level state (by SETup:CMAudio:GENerator:LEVel:UPLink:ALL[:SAMPlitude] ) will simultaneously set the tone's frequency state to the same value, and vice versa.
Setting

Range:

  • 10 to 4000 Hz (only spec'd to 3000 Hz)
  • 0 (indicating that the tone is turned off)
Resolution: 10 Hz

Query

same as setting

*RST setting

 same as Narrow preset (see SETup:CMAudio:GENerator:FREQuency:Uplink:PRESet )

Requirement

 Test Application Revision: B.08 and above
Lab Application Revision: B.02 and above

Programming Example

OUTPUT 714;"SETup:CMAudio:GENerator:FREQuency:Uplink:ALL 350, 400, 450, 500, 550, 600, 650, 700, 750, 800, 850, 900, 950, 1000, 1050, 1100, 1150, 1200, 1250, 1300"
!Sets uplink audio generator frequencies for the 20 tones
!and turns their states to ON.

SETup:CMAudio:GENerator:FREQuency:Uplink:PRESet

Function

Sets/queries the uplink audio generator frequencies/states for each of the 20 tones from the preset selected. It will be used in an uplink measurement (see SETup:CMAudio:MEASurement:MODE ).

You can also specify the uplink audio generator's individual frequencies/states by SETup:CMAudio:GENerator:FREQuency:Uplink:ALL[:SVALue] , which will cause this setting to NONE.

The state of the frequency and level for any given tone is coupled. Setting the tone's level state (by SETup:CMAudio:GENerator:LEVel:UPLink:ALL[:SAMPlitude] ) will simultaneously set the tone's frequency state to the same value, and vice versa.

After a preset selection is made, if any of the uplink audio generator frequencies or states are changed by SETup:CMAudio:GENerator:FREQuency:Uplink:ALL[:SVALue] or SETup:CMAudio:GENerator:LEVel:UPLink:ALL[:SAMPlitude] , the uplink audio generator preset frequency will be reset to its default value of NONE. The query of the preset value will return NONE even if settings to the generator's individual frequencies and states to conditions identical to a preset have been made.
Setting

Range: NONE|NARRow|NORMal|WIDE|SIN300|SIN600|SIN800|SIN1000
|SIN1200|SIN1600|SIN2000|SIN2400|SIN2800|SIN3000|AOFF

  • NONE: no preset state or generator frequency settings do not match one of the preset states
  • NARRow: sets the tones <N=1 to 12> to (100*N+200) Hz, and tones <N=13 to 20> to (200*N - 1000) Hz
  • NORMal: sets the first tone to 300 Hz, tones <N=2 to 5> to (200*N+200) Hz, and tones <N=6 to 9> to (400*N - 800) Hz, tone <N=10> to 3000 Hz, and turns all others off
  • WIDE: sets the tones <N=1 to 10> to (100*N) Hz, tones <N=11 to 14> to (200*N - 1000) Hz, tones <N=15 to 17> to (400*N - 4000) Hz, and tones <N=18 to 20> to (300*N - 2400) Hz
  • SIN300: sets the first tone to 300 Hz and turns all others off
  • SIN600: sets the first tone to 600 Hz and turns all others off
  • SIN800: sets the first tone to 800 Hz and turns all others off
  • SIN1000: sets the first tone to 1000 Hz and turns all others off
  • SIN1200: sets the first tone to 1200 Hz and turns all others off
  • SIN1600: sets the first tone to 1600 Hz and turns all others off
  • SIN2000: sets the first tone to 2000 Hz and turns all others off
  • SIN2400: sets the first tone to 2400 Hz and turns all others off
  • SIN2800: sets the first tone to 2800 Hz and turns all others off
  • SIN3000: sets the first tone to 3000 Hz and turns all others off
  • AOFF: turns all tones off

Query

 Range: NONE|NARRow|NORMal|WIDE|SIN300|SIN600|SIN800|SIN1000
|SIN1200|SIN1600|SIN2000|SIN2400|SIN2800|SIN3000|AOFF

*RST setting

 NARRow

Requirement

 Test Application Revision: B.08 and above
Lab Application Revision: B.02 and above

Programming Example

OUTPUT 714;"SETup:CMAudio:GENerator:FREQuency:UPLink:PRESet NARRow"
!Sets audio frequencies/states from the NARRow preset
!for the uplink audio generator.

SETup:CMAudio:GENerator:LEVel:DOWNlink:ALL[:SAMPlitude]?

Function

Queries the individual audio levels/states for each of the 20 tones for the downlink audio generator. It is used in a downlink measurement (see SETup:CMAudio:MEASurement:MODE ). This query returns a comma-separated list of 20 values, in percentage. A value of -1.0 indicates that the corresponding tone state is set to Off which is determined by SETup:CMAudio:GENerator:FREQuency:DOWNlink:PRESet .

The level of each tone whose state is on is determined by the total level setting SETup:CMAudio:GENerator:LEVel:DOWNlink:ALL:TOTal[:SAMPlitude] . You can not directly set the individual tone levels for the downlink audio generator.

Query

Range: 0 to 50% and -1.0 (indicating the tone is turned off)
Resolution: 0.1%

*RST setting

 2.2%

Requirement

 Test Application Revision: B.08 and above
Lab Application Revision: B.02 and above

Programming Example

OUTPUT 714;"SETup:CMAudio:GENerator:LEVel:DOWNlink:ALL?"
!Returns individual audio levels for each of the 20 tones for the downlink audio generator.

SETup:CMAudio:GENerator:LEVel:DOWNlink:ALL:TOTal[:SAMPlitude]

Function

Sets/queries the multi-tone audio total level and turns the total level state to ON for the downlink audio generator. It is used in a downlink measurement (see SETup:CMAudio:MEASurement:MODE ). The total level determines the individual tone's level, which will be equally distributed among the tones whose states are on (the tone's state is determined by the SETup:CMAudio:GENerator:FREQuency:DOWNlink:PRESet ). Each tone level is calculated as: [sqrt (total level 2 / number of tones on)]. For example, if you specify the total to be 10% and all 20 tone states are on, 2.2% is assigned to each tone.

This setting is used when the total level state for the downlink audio generator is On. To query the total level state for the downlink audio generator, use SETup:CMAudio:GENerator:LEVel:DOWNlink:ALL:TOTal:STATe? .
Setting

Range: 10 to 50% (in 20% increment)
Resolution: 0.1%

Query

 Range: 10%, 30%, 50%

*RST setting

 10%

Requirement

 Test Application Revision: B.08 and above
Lab Application Revision: B.02 and above

Programming Example

OUTPUT 714;"SETup:CMAudio:GENerator:LEVel:DOWNlink:ALL:TOTal 10"
!Sets the downlink audio generator's total level to 10% and turns its
!state to on.

SETup:CMAudio:GENerator:LEVel:DOWNlink:ALL:TOTal:AMPlitude

Function

Sets/queries the multi-tone audio total level for the downlink audio generator to be used in a downlink measurement (see SETup:CMAudio:MEASurement:MODE ). The total level will be equally distributed among the tones whose states are on (determined by the SETup:CMAudio:GENerator:FREQuency:DOWNlink:PRESet ) and each tone level is calculated as: [sqrt (total level 2 / number of tones on)]. For example, if you specify the total to be 10% and all 20 tone states are on, 2.2% is assigned to each tone. You can not directly set the individual tone levels for the downlink audio generator.

This setting is used when the total level state for the downlink audio generator is On. To query the total level state for the downlink audio generator, use SETup:CMAudio:GENerator:LEVel:DOWNlink:ALL:TOTal:STATe? .
Setting

Range: 10 to 50 %
Resolution: 0.1 %

Query

 Same as the above settings

*RST setting

 10%

Requirement

 Test Application Revision: B.08 and above
Lab Application Revision: B.02 and above

Programming Example

OUTPUT 714;"SETup:CMAudio:GENerator:LEVel:DOWNlink:ALL:TOTal 10"
!Sets the downlink audio generator's total level to 10%.

SETup:CMAudio:GENerator:LEVel:DOWNlink:ALL:TOTal:STATe?

Function

Queries the multi-tone audio total level state for control of the downlink audio generator output levels. It is used in a downlink measurement (see SETup:CMAudio:MEASurement:MODE ). It is always returns 1 (ON) since the downlink audio generator output level is controlled only by the total level.To set the multi-tone audio total level for the downlink audio generator, use SETup:CMAudio:GENerator:LEVel:DOWNlink:ALL:TOTal[:SAMPlitude] or SETup:CMAudio:GENerator:LEVel:DOWNlink:ALL:TOTal:AMPlitude .

Query

 0|1

*RST setting

 1 (ON)

Requirement

 Test Application Revision: B.08 and above
Lab Application Revision: B.02 and above

Programming Example

OUTPUT 714;"SETup:CMAudio:GENerator:LEVel:DOWNlink:ALL:TOTal:STATe?"
!Queries the multitone audio total level state
!for the downlink audio generator.

SETup:CMAudio:GENerator:LEVel:UPLink:ALL[:SAMPlitude]

Function

Sets/queries the individual audio levels/states for each of the 20 tones for the uplink audio generator. It is used in an uplink measurement (see SETup:CMAudio:MEASurement:MODE ). It is specified in the form of a comma-separated list of 20 values (in units of Vrms). A value must be entered for each of the 20 tones. An entry of -1.0 in the list indicates that the state of that tone is set to Off.

The state of the frequency and level for any given tone is coupled. Setting the tone's frequency state (by SETup:CMAudio:GENerator:FREQuency:Uplink:ALL[:SVALue] or SETup:CMAudio:GENerator:FREQuency:Uplink:PRESet ) will simultaneously set the tone's level state to the same value, and vice versa.

This setting is not used if the total level state is set to on by SETup:CMAudio:GENerator:LEVel:UPLink:ALL:TOTal:STATe .
Setting

Range:

  • 0 to 5.04 V rms (0 to 7.14 V peak) (If more than one tone is turned on, the total can not exceed 5.04 V rms)
  • -1 (indicating that tone is turned off)
Resolution: 0.1 mV

Query

same as setting

*RST setting

 80 mV

Requirement

 Test Application Revision: B.08 and above
Lab Application Revision: B.02 and above

Programming Example

OUTPUT 714;"SETup:CMAudio:GENerator:LEVel:UPLink:ALL 50, 60, 70, 80, 80, 80, 80, 80, 70, 70, 70, 60, 60, 50, 50, 50, 50, 50, 50, 50"
!Specifies individual tone levels for each of the 20 tones
!and turns their states to ON.

SETup:CMAudio:GENerator:LEVel:UPLink:ALL:TOTal[:SAMPlitude]

Function

 Sets/queries the multi-tone audio total level (in units of Vrms) and turns the total level state to on for the uplink audio generator to be used in an uplink measurement (see SETup:CMAudio:MEASurement:MODE ). The total level will be equally distributed among the tones whose states are on and each tone level is calculated as: [sqrt (total level 2 / number of tones on)]. For example, if you specify the total to be 1 V and all 20 tone states are on, 224 mV is assigned to each tone.
Setting

Range: 0 to 5.04 V rms (0 to 7.14 V peak)
Resolution: 0.1 mV

Query

same as setting

*RST setting

 360 mV

Requirement

 Test Application Revision: B.08 and above
Lab Application Revision: B.02 and above

Programming Example

OUTPUT 714;"SETup:CMAudio:GENerator:LEVel:UPLink:ALL:TOTal 1"
!Sets the uplink audio generator's total level to 1V rms
!and turns its state to on.

SETup:CMAudio:GENerator:LEVel:UPLink:ALL:TOTal:AMPLitude

Function

Sets the multi-tone audio total levels (in units of Vrms) for each of the 20 tones for the uplink audio generator to be used in an uplink measurement (see SETup:CMAudio:MEASurement:MODE ). The total level will be equally distributed among the tones whose states are on and each tone level (on) is calculated as: [sqrt (total level 2 / number of tones on)]. For example, if you specify the total to be 1 V and all 20 tone states are on, 224 mV is assigned to each tone.

This setting is not used until the total level state is set to on by SETup:CMAudio:GENerator:LEVel:UPLink:ALL:TOTal:STATe .

You can set the total level and turn on its state with one command: SETup:CMAudio:GENerator:LEVel:UPLink:ALL:TOTal[:SAMPlitude] .

Setting

Range: 0 to 5.04 V rms (0 to 7.14 V peak)
Resolution: 0.1 mV

Query

Same as the above settings

*RST setting

 360 mV

Requirement

 Test Application Revision: B.08 and above
Lab Application Revision: B.02 and above

Programming Example

OUTPUT 714;"SETup:CMAudio:GENerator:LEVel:UPLink:ALL:TOTal:AMPLitude 1"
!Sets the uplink audio generator's total level to 1V rms.

SETup:CMAudio:GENerator:LEVel:UPLink:ALL:TOTal:STATe

Function

Sets/queries the multi-tone audio total level state for control of the uplink audio generator output levels. It is used in an uplink measurement (see SETup:CMAudio:MEASurement:MODE ).The uplink audio generator output levels is controlled by the total level settings ( SETup:CMAudio:GENerator:LEVel:UPLink:ALL:TOTal:AMPLitude ) when the state is set to on, or controlled by the individual audio level settings ( SETup:CMAudio:GENerator:LEVel:UPLink:ALL[:SAMPlitude] ) when the state is set to off.
Setting

0|OFF|1|ON

Query

 0|1

*RST setting

 1 (ON)

Requirement

 Test Application Revision: B.08 and above
Lab Application Revision: B.02 and above

Programming Example

OUTPUT 714;"SETup:CMAudio:GENerator:LEVel:UPLink:ALL:TOTal:STATe OFF"
!Sets uplink audio generator's total level state to off.

SETup:CMAudio:LEVel:ALL:LIMit:LOWer

Function

Sets/queries the audio tone mask level lower limits for each of the 20 tones in the form of a comma-separated list of 20 values. A value must be entered for each of the 20 tones.

If any tone's measured level is less than the value of its lower limit or greater than the value of its upper limit ( SETup:CMAudio:LEVel:ALL:LIMit:UPPer ), a fail result is returned for the measurement (see FETCh:CMAudio:LEVel:LIMit:FAIL? ).
Setting

Range: - 100 to 100 dB
Resolution: 1 dB

Query

Same as the above settings

*RST setting

 - 100 dB

Requirement

 Test Application Revision: B.08 and above
Lab Application Revision: B.02 and above

Programming Example

OUTPUT 714;"SETup:CMAudio:LEVel:ALL:LIMit:LOWer -25,-25,-25,-50,-50,-50,-75,-75,-75,-100,-100,-100,-100,-100,-75,-75,-75,-50,-50,-50"
!Sets the audio tone mask level lower limits for each of the 20 tones.

SETup:CMAudio:LEVel:ALL:LIMit:UPPer

Function

Sets/queries the audio tone mask level upper limits for each of the 20 tones in the form of a comma-separated list of 20 values. A value must be entered for each of the 20 tones.

If any tone's measured level is less than the value of its lower limit ( SETup:CMAudio:LEVel:ALL:LIMit:LOWer ) or greater than the value of its upper limit, a fail result is returned for the measurement (see FETCh:CMAudio:LEVel:LIMit:FAIL? ).
Setting

Range: - 100 to 100 dB
Resolution: 1 dB

Query

Same as the above settings

*RST setting

 100 dB

Requirement

 Test Application Revision: B.08 and above
Lab Application Revision: B.02 and above

Programming Example

OUTPUT 714;"SETup:CMAudio:LEVel:ALL:LIMit:UPPer 25,25,25,50,50,50,75,75,75,100,100,100,100,100,75,75,75,50,50,50"
!Sets the audio tone mask level upper limits for each of the 20 tones.

SETup:CMAudio:MEASurement:MODE

Function

Sets/queries the measurement mode used by the multi-tone audio measurements. Selecting Uplink mode indicates that the multi-tone audio analyzer will measure the analog signal decoded from the reverse traffic channel. Selecting Downlink mode indicates that the multi-tone audio analyzer will measure the analog signal presented at the AUDIO IN port on the test set's front panel. See How is a multi-tone audio measurement made? for details.

Setting UPLink|DOWNlink

Query

 UPL| DOWN

*RST setting

 DOWNlink

Requirement

 Test Application Revision: B.08 and above
Lab Application Revision: B.02 and above

Programming Example

OUTPUT 714;"SETup:CMAudio:MEASurement:MODE UPL"
!Sets the multi-tone audio measurement mode to uplink audio.

SETup:CMAudio:PEAK:VOLTage

Function

 Sets/queries the expected peak voltage (clipping level) presented at the AUDIO IN port of the test set when making the multi-tone audio downlink measurement (see SETup:CMAudio:MEASurement:MODE ). The units (V, MV) are optional, if no units are specified then units default to V.
Setting Range: 1 mV to 20 V peak
Resolution: 1 mV

Query

 Same as the above settings

*RST setting

 1.0 V

Requirement

 Test Application Revision: B.08 and above
Lab Application Revision: B.02 and above

Programming Example

OUTPUT 714;"SETup:CMAudio:PEAK:VOLTage 5"
!Sets the expected AUDIO IN peak voltage to 5V.

SETup:CMAudio:REFerence:ABSolute:LEVel:DOWNlink

Function

 Sets/queries the reference level to be used when making absolute measurements (set by SETup:CMAudio:REFerence:MODE ) on the downlink (set by SETup:CMAudio:MEASurement:MODE ).
Setting Range: 0.1 mV to 5.0 V rms
Resolution: 0.1 mV

Query

 Same as the above settings

*RST setting

 1 V

Requirement

 Test Application Revision: B.08 and above
Lab Application Revision: B.02 and above

Programming Example

OUTPUT 714;"SETup:CMAudio:REFerence:ABSolute:LEVel:DOWNlink 1.2"
!Sets the reference level for downlink absolute measurements to 1.2 V.

SETup:CMAudio:REFerence:ABSolute:LEVel:UPLink

Function

 Sets/queries the reference level (in percentage of the full DAC range) to be used when making absolute measurements (set by SETup:CMAudio:REFerence:MODE ) on the uplink (set by SETup:CMAudio:MEASurement:MODE .
Setting Range: 0.1% to 100%
Resolution: 0.1%

Query

 Same as the above settings

*RST setting

 10%

Requirement

 Test Application Revision: B.08 and above
Lab Application Revision: B.02 and above

Programming Example

OUTPUT 714;"SETup:CMAudio:REFerence:ABSolute:LEVel:UPLink 3.5"
!Sets the reference level for uplink absolute measurements to 3.5%.

SETup:CMAudio:REFerence:MODE

Function

 Sets/queries the reference mode to be used for multi-tone audio level measurements. If it is set to RELative, the SETup:CMAudio:REFerence:RELative:TONE is used to specify a reference tone. If it is set to ABSolute, the SETup:CMAudio:REFerence:ABSolute:LEVel:DOWNlink or SETup:CMAudio:REFerence:ABSolute:LEVel:UPLink will be used to specify a reference level for a downlink or uplink measurement.
Setting ABSolute | RELative

Query

 ABS | REL

*RST setting

 ABSolute

Requirement

 Test Application Revision: B.08 and above
Lab Application Revision: B.02 and above

Programming Example

OUTPUT 714;"SETup:CMAudio:REFerence:MODE RELative"
!Sets the reference mode to relative.

SETup:CMAudio:REFerence:RELative:TONE

Function

 Sets/queries the audio tone to be used as the reference when making multi-tone audio level measurements in relative reference mode. The reference must be set to relative (see SETup:CMAudio:REFerence:MODE ) for this setting to be used.
Setting Range: 1 to 20
Resolution: 1

Query

 Range: 1 to 20
Resolution: 1

*RST setting

 6

Requirement

 Test Application Revision: B.08 and above
Lab Application Revision: B.02 and above

Programming Example

OUTPUT 714;"SETup:CMAudio:REFerence:RELative:TONE 3"
!Sets the reference audio tone for relative measurements to the third tone.

SETup:CMAudio:SDIStortion:SBWidth:UPLink

Function

Sets/queries the signal bandwidth (fixed or in percentage of the Audio Tone 1 uplink frequency) to be used when making SINAD/Distortion measurement on the uplink.

  • Fixed - 100Hz
  • Narrow - 20% of the Audio Tone 1 uplink frequency
  • Medium - 40% of the Audio Tone 1 uplink frequency
  • Wide - 60% of the Audio Tone 1 uplink frequency
Setting FIXed | NARRow| MEDIum| WIDe

Query

 FIX | NARR|MED|WID

*RST setting

 FIX

Requirement

 Test Application Revision: B.13 and above
Lab Application Revision: B.06 and above

Programming Example

OUTPUT 714;"SETup:CMAudio:SDIStortion:SBWidth:UPLink NARR"
!Sets the signal bandwidth to 20% of the Audio Tone 1 uplink frequency.

SETup:CMAudio:SDIStortion:STATe

Function

 Sets/queries whether to enable the SINAD/Distortion measurement. When it is enabled (On), Audio level, SINAD, and distortion results are available and displayed (see Multi-Tone Audio Measurement Results for details).
Setting 0 | OFF | 1 | ON

Query

 0 | 1

*RST setting

 0 (OFF)

Requirement

 Test Application Revision: B.08 and above
Lab Application Revision: B.02 and above

Programming Example

OUTPUT 714;"SETup:CMAudio:SDIStortion ON"
!Enables SINAD/distortion measurement.

SETup:CMAudio:SETTling[:TIME]

Function

 Sets/queries the amount of time the multi-tone audio measurement waits to start the measurement after each measurement request. This setting applies to both the uplink and downlink measurement mode. A setting of 0.0 seconds will let the multi-tone audio measurement run at maximum speed.
Setting Range: 0 to 1 s
Resolution: 10 ms

Query

 Range: 0 to 1 s
Resolution: 10 ms

*RST setting

 0.0 s

Requirement

 Test Application Revision: B.08 and above
Lab Application Revision: B.02 and above

Programming Example

OUTPUT 714;"SETup:CMAudio:SETTling 300MS"
!Sets the settling time to 300 milliseconds.

SETup:CMAudio:TIMeout[:STIMe]

Function

 Sets/queries the multi-tone audio measurement timeout value in seconds and sets the timeout state to ON.
Setting Range: 0.1 to 999 seconds
Resolution: 0.1 seconds

Query

 Range: 0.1 to 999 seconds
Resolution: 0.1 seconds

*RST setting

 10 seconds

Requirement

 Test Application Revision: B.08 and above
Lab Application Revision: B.02 and above

Programming Example

OUTPUT 714;"SETup:CMAudio:TIMeout 2"
!Sets the measurement timeout to 2 seconds and
!turns measurment timeout on for the multi-tone audio measurement.

SETup:CMAudio:TIMeout:STATe

Function

 Sets/queries the multi-tone audio measurement timeout state.
Setting 0 | OFF | 1 | ON

Query

 0 | 1

*RST setting

 0 (OFF)

Requirement

 Test Application Revision: B.08 and above
Lab Application Revision: B.02 and above

Programming Example

OUTPUT 714;"SETup:CMAudio:TIMeout:STATe 1" !Turns measurment timeout on for the multi-tone audio measurement.

SETup:CMAudio:TIMeout:TIME

Function

 Sets/queries the multi-tone audio measurement timeout value in seconds.
Setting Range: 0.1 to 999 seconds
Resolution: 0.1 seconds

Query

 Range: 0.1 to 999 seconds
Resolution: 0.1 seconds

*RST setting

 10 seconds

Requirement

 Test Application Revision: B.08 and above
Lab Application Revision: B.02 and above

Programming Example

OUTPUT 714;"SETup:CMAudio:TIMeout:TIME 2"
!Sets the measurement timeout to 2 seconds
!for the multi-tone audio measurement.


SETup:SAUDio

SETup:SAUDio

Last updated: June 7, 2007

GPIB Command Conventions

  • SETup:SAUDio:CONTinuous
  • SETup:SAUDio:COUNt[:SNUMber]
  • SETup:SAUDio:COUNt:NUMBer
  • SETup:SAUDio:COUNt:STATe
  • SETup:SAUDio:COUPling
  • SETup:SAUDio:DETector[:TYPE]
  • SETup:SAUDio:FILTer[:TYPE]
  • SETup:SAUDio:FREQuency[:VALue]?
  • SETup:SAUDio:FREQuency:POINts
  • SETup:SAUDio:FREQuency:STARt
  • SETup:SAUDio:FREQuency:STOP
  • SETup:SAUDio:ICOunt:MAXimum?
  • SETup:SAUDio:PEAK:VOLTage
  • SETup:SAUDio:SETTling[:TIMe]
  • SETup:SAUDio:SDIStortion:STATe
  • SETup:SAUDio:TIMeout[:STIMe]
  • SETup:SAUDio:TIMeout:TIME
  • SETup:SAUDio:TIMeout:STATe
  • SETup:SAUDio:VOLTage:AMPLitude

SETup:SAUDio:CONTinuous

Function

Sets/queries the trigger arm state for the swept audio measurement. Determines whether measurement will make one measurement then stop (0|OFF (single)), or automatically rearm upon completion of one measurement and repeat the process (1|ON (continuous)).

Setting

Range: 1|ON|0|OFF

Query

Range: 1|0

*RST Setting

0 (off)

Programming Example

OUTPUT 714;"SETUP:SAUDIO:CONTINUOUS ON" !Turns on continuous triggering.

SETup:SAUDio:COUNt[:SNUMber]

Function

Sets/queries the number of audio measurements to perform at each measurement point in a single multi-measurement sweep. This command sets the count, and automatically sets the multi-measurement STATe command to 1 (on).

Setting

Range: 1 to 999

Query

Range: 1 to 999

*RST Setting

 10

Programming Example

OUTPUT 714;"SETUP:SAUDIO:COUNT:SNUMBER 5" !Turns on multi-measurements and makes 5 measurements at each frequency point in the sweep.

SETup:SAUDio:COUNt:NUMBer

Function

Sets/queries the number of audio measurements to perform at each measurement point in a single multi-measurement sweep when the SETup:SAUDio:COUNt:STATe is set to 1 (on).

Setting

Range: 1 to 999

Query

Range: 1 to 999

*RST Setting

10

Programming Example

OUTPUT 714;"SETUP:SAUDIO:COUNT:NUMBER 5" !Makes 5 measurements at each frequency point in the sweep.

SETup:SAUDio:COUNt:STATe

Function

Selects/queries the swept audio measurement's multi-measurement count state.

Setting

Range: 1|ON|0|OFF

Query

Range: 1|0

*RST Setting

0 (off)

Programming Example

OUTPUT 714;"SETUP:SAUDIO:COUNT:STATE ON" !Turns on multi-measurement for the swept audio measurement.

SETup:SAUDio:COUPling

Function

Sets/queries the audio generator's coupling to the AUDIO OUT port.

Setting

Range: AC|DC

Query

Range: AC|DC

*RST Setting

 DC

Programming Example

OUTPUT 714;"SETUP:SAUDIO:COUPLING AC" !Select AC coupling to the AUDIO OUT port.

SETup:SAUDio:DETector[:TYPE]

Function

Sets/queries the type of level detector used in swept audio measurements.

Setting

Range: RMS|PEAK

Query

Range: RMS|PEAK

*RST Setting

 RMS

Programming Example

OUTPUT 714;"SETUP:SAUDIO:DETECTOR:TYPE PEAK" !Select the peak detector for the AF analzyer.

SETup:SAUDio:FILTer[:TYPE]

Function

Sets/queries the type of filter on the sampled data, before any measurements are performed.

The filter choices are: none, TBPass (100 Hz bandwidth bandpass), CMESsage (C-Message), BPASs50 (50 Hz to 15 kHz bandpass), BPASs300 (300 Hz to 15 kHz bandpass)

Setting

Range: NONE|TBPass|CMESsage|BPASs50|BPASs300

Query

Range: NONE|TBP|CMES|BPAS50|BPAS300

*RST Setting

None

Programming Example

OUTPUT 714;"SETUP:SAUDIO:FILTER:TYPE TBPASS" !Selects the 100 Hz bandpass filter.

SETup:SAUDio:FREQuency[:VALue]?

Function

Returns a comma-separated list of the generated frequency for each frequency point (see SETup:SAUDio:FREQuency:POINts ).

When you specify the start frequency, stop frequency, and the number of measurement points, the test set calculates the intermediate frequencies that are generated. You cannot directly set the intermediate frequencies using this command, you can only query them.

Query

Range: up to 60 comma separated values

Programming Example

OUTPUT 714;"SETUP:SAUDIO:FREQUENCY:VALUE?" !Queries the list of generated frequencies.

SETup:SAUDio:FREQuency:POINts

Function

Sets/queries the number of evenly-spaced frequency points in the sweep. If this value is set to 1, only the start frequency is used in the sweep.

Setting

Range: 1 to 60

Query

Range: 1 to 60

*RST Setting

5

Programming Example

OUTPUT 714;"SETUP:SAUDIO:FREQUENCY:POINTS 20" !Make audio measurements at 20 frequency points in the sweep.

SETup:SAUDio:FREQuency:STARt

Function

Sets/queries the frequency at which to begin the sweep. The default units are Hz.

It is possible to set the start frequency higher than the stop frequency. If this is done, the sweep starts at the higher frequency and stops at the lower frequency.

Setting

Range: 300.0 to 15000.0 Hz

Query

Range: 300.0 to 15000.0 Hz

*RST Setting

300 Hz

Programming Example

OUTPUT 714;"SETUP:SAUDIO:FREQUENCY:START 450HZ" !Start the frequency sweep at 450 Hz.

SETup:SAUDio:FREQuency:STOP

Function

Sets/queries the frequency at which to end the sweep. The default units are Hz.

It is possible to set the stop frequency lower than the start frequency. If this is done, the sweep starts at the higher frequency and stops at the lower frequency.

Setting

Range: 300.0 to 15000.0 Hz

Query

Range: 300.0 to 15000.0 Hz

*RST Setting

 3000 Hz

Programming Example

OUTPUT 714;"SETUP:SAUDIO:FREQUENCY:STOP 1500HZ" !Stop the frequency sweep at 1500 Hz.

SETup:SAUDio:ICOunt:MAXimum?

Function

Queries the total multi-measurement count. This is equal to the number of frequency points in the sweep multiplied by the multi-measurement count set for the swept audio measurement.

Query

Range: 1 to 59940 (60 measurement points multiplied by 999 multi-measurements)

*RST Setting

 5

Programming Example

OUTPUT 714;"SETUP:SAUDIO:ICOUNT:MAXIMUM?" !Queries the total number of measurements made.

SETup:SAUDio:PEAK:VOLTage

Function

Sets/queries the expected peak voltage of the swept audio measurement. This determines the range and resolution of the sampled votage values.

Setting

Range: 1 mV to 20 V

Resolution: 1 mV

Query

Range: 1 mV to 20 V

*RST Setting

20 V peak

Programming Example

OUTPUT 714;"SETUP:SAUDIO:PEAK:VOLTAGE 5V"

SETup:SAUDio:SETTling[:TIMe]

Function

Sets/queries how long swept audio measurements wait to start an audio measurement after setting the audio source's frequency. A setting of 0.0 seconds let's swept audio measurements run at maximum speed.

Settling time may be needed when testing a device that has a time delay through the audio path. Path delays can cause the audio generator's signal to change frequencies before the output signal can be analyzed at that frequency. Specifying a settling time ensures that the audio generator stays at each frequency point long enough for the audio analyzer to correctly measure the device's audio output.

Setting

Range: 0.0 to 999 ms

Resolution: 1 ms

Query

Range: 0.0 to 999 ms

*RST Setting

0 ms

Programming Example

OUTPUT 714;"SETUP:SAUDIO:SETTLING:TIME 20MS"

SETup:SAUDio:SDIStortion:STATe

Function

Sets/queries whether SINAD and distortion measurments are enabled. Turning on SINAD/Distortion measurements will cause the swept audio measurement to run significantly slower because of added sampling and calculation times.

Setting

Range: 1|ON|0|OFF

Query

Range: 1|0

*RST Setting

0 (off)

Programming Example

OUTPUT 714;"SETUP:SAUDIO:SDISTORTION:STATE ON"

SETup:SAUDio:TIMeout[:STIMe]

Function

 Selects/queries the timeout value in seconds that is used for swept audio measurements and sets the timeout state to ON. Units (S|MS) are optional, if no units are specified then units default to S (seconds).

Setting

Range: 0.1 to 999 seconds
Resolution: 0.1 seconds

Query

Range: 0.1 to 999 seconds

*RST Setting

 10 seconds

Programming Example

OUTPUT 714;"SETUP:SAUDIO:TIMEOUT:STIME 10" !Enables timeouts and sets the value to 10 seconds.

SETup:SAUDio:TIMeout:TIME

Function

 Selects/queries the timeout value in seconds that is used for swept audio measurements when the timeout state is set to ON. Units (S|MS) are optional, if no units are specified then units default to S (seconds).

Setting

Range: 0.1 to 999 seconds
Resolution: 0.1 seconds

Query

Range: 0.1 to 999 seconds

*RST Setting

 10 seconds

Programming Example

OUTPUT 714;"SETUP:SAUDIO:TIMEout:TIME 10" !Sets the timeout value to 10 seconds.

SETup:SAUDio:TIMeout:STATe

Function

 Selects/queries the swept audio measurement timeout state. Timeout is set using the SETup:SAUDio:TIMeout:TIME command.

Setting

Range: 1|ON|0|OFF

Query

Range: 1|0

*RST Setting

0 (off)

Programming Example

OUTPUT 714;"SETUP:SAUDIO:TIMEOUT:STATE ON" !Enables timeouts for swept audio measurements.

SETup:SAUDio:VOLTage:AMPLitude

Function

Sets/queries the output level (peak voltage) of the audio generator when it is turned on. This command does not turn on the audio generator.

Setting

Range: 0.0 to 9.0 V peak (R L > 600 ohms)

Resolution:

  • < 0.5 mV peak (less than or equal to 1 V peak output)
  • < 5 mV peak (greater than 1 V peak output)

Query

Range: 0.0 to 9.0 V peak (R L > 600 ohms)

*RST Setting

0.0 V peak

Programming Example

OUTPUT 714;"SETUP:SAUDIO:VOLTAGE:AMPLITUDE 1V" !Set the audio generator's output to 1Vpeak.


SETup:SMONitor

SETup:SMONitor

Last updated: June 7, 2007

GPIB Command Conventions

  • SETup:SMONitor:AMPLitude:PDIVision
  • SETup:SMONitor:AMPLitude:RLEVel:AUTO
  • SETup:SMONitor:AMPLitude:RLEVel:MANual
  • SETup:SMONitor:BANDwidth|BWIDth[:RESolution]?
  • SETup:SMONitor:BANDwidth|BWIDth:AUTO
  • SETup:SMONitor:BANDwidth|BWIDth:MANual
  • SETup:SMONitor:BANDwidth|BWIDth:ZSPan[:RESolution]
  • SETup:SMONitor:COUNt[:SNUMber]
  • SETup:SMONitor:COUNt:NUMber
  • SETup:SMONitor:COUNt:STATe
  • SETup:SMONitor:CONTinous
  • SETup:SMONitor:DETector[:TYPE]
  • SETup:SMONitor:FREQuency:SPAN
  • SETup:SMONitor:TIME:OFFSet
  • SETup:SMONitor:TIME:SPAN
  • SETup:SMONitor:TIMeout[:STIMe]
  • SETup:SMONitor:TIMeout:STATe
  • SETup:SMONitor:TIMeout:TIME
  • SETup:SMONitor:TRACe:MODE
  • SETup:SMONitor:TRiGger:DELay
  • SETup:SMONitor:TRiGger:SOURce

SETup:SMONitor:AMPLitude:PDIVision

Function

This command sets the scale of the spectrum monitor's display in dB per division (dB/div).
Setting

Range: 0.1 to 20 dB

Resolution: 0.1

Query

Range: 0.1 to 20 dBResolution: 0.1
*RST Setting

10 dB

Programming Example

OUTPUT 714;"SETup:SMONitor:AMPLitude:PDIVision 1DB"

!Sets scale of the spectrum monitor's display to 1 dB per division.

SETup:SMONitor:AMPLitude:RLEVel:AUTO

Function

This command allows you to set whether or not the spectrum monitor's reference level is selected automatically by the test set.
Setting

Range: 1|ON|0|OFF

Query

Range: 1|0
*RST Setting

OFF

Programming Example

OUTPUT 714;"SETup:SMONitor:AMPLitude:RLEVel:AUTO ON"

!Sets spectrum monitor's reference level to set automatically.

SETup:SMONitor:AMPLitude:RLEVel:MANual

Function

This command allows you to set the spectrum monitors actual reference level in dBm. The range settings are coupled to the amplitude offset value for the current value of the expected frequency (set using SYSTem:CORRection:[:SGAin] ). Changing the amplitude offset value does not change the reference value, unless the new value for the amplitude offset forces the current value of the reference level to exceed the range limits. If this happens the reference level is set to its limit.
Setting

Range: (-50 dBm + Amplitude Offset) to +37 dBm

Resolution: 0.1 dB

Query

Range: (-50 dBm + Amplitude Offset) to +37 dBmResolution: 0.1 dB
*RST Setting

+37 dB + Amplitude Offset

Programming Example

OUTPUT 714;"SETup:SMONitor:AMPLitude:RLEVel:MANual -20DBM"

!Sets spectrum monitor's reference level to -20 dBm.

SETup:SMONitor:BANDwidth|BWIDth[:RESolution]?

Function

This command queries the resolution bandwidth being used by the spectrum monitor measurement. It is returned in the unit of Hz.

Query

Range: 1 kHz to 5MHz

*RST Setting 30000 Hz

Programming Example

OUTPUT 714;"SETup:SMONitor:BAND?"

!Returns spectrum monitor's resolution bandwidth.

SETup:SMONitor:BANDwidth|BWIDth:AUTO

Function

This command sets/queries the Spectrum Monitor Resolution Bandwidth Coupling State. When the state of this parameter is ON the Resolution Bandwidth is determined by the Frequency Span setting ( SETup:SMONitor:FREQuency:SPAN ). When this parameter is set to OFF the Frequency Span and the Resolution Bandwidth parameters are decoupled and can be set separately to any valid Frequency Span and Resolution Bandwidth. See Resolution Bandwidth and Frequency Span for the complete list of valid settings for Frequency Span and Resolution Bandwidth.

The command to set the Frequency Span is SETup:SMONitor:FREQuency:SPAN

The command to set the resolution bandwidth is SETup:SMONitor:BANDwidth|BWIDth:MANual .

Requirements

Test Application Revision:B.09 and above

Lab Application Revision: A.01 and above

Setting

Range: 1|ON|0|OFF

Query

Range: 1|0
*RST Setting 1

Programming Example

OUTPUT 714;"SETup:SMONitor:BAND:AUTO 0"

!Turns Spectrum Monitor Resolution Bandwidth Coupling parameter OFF.

SETup:SMONitor:BANDwidth|BWIDth:MANual

Function

This command sets/queries the value of the resolution bandwidth when SETup:SMONitor:BANDwidth|BWIDth:AUTO is set to OFF. When SETup:SMONitor:BANDwidth|BWIDth:AUTO is set to ON, the resolution bandwidth is determined by the Frequency Span setting ( SETup:SMONitor:FREQuency:SPAN ) and can be queried using the SETup:SMONitor:BANDwidth|BWIDth[:RESolution]? command.

When using this command the values in the Frequency Span and Resolution Bandwidth columns of Resolution Bandwidth and Frequency Span are no longer coupled. Therefore, the Frequency Span and the Resolution Bandwidth parameters can be set to any value in the Frequency Span and Resolution Bandwidth columns, respectively.

This command also sets the Spectrum Monitor Reference Level Coupling State to OFF (see SETup:SMONitor:AMPLitude:RLEVel:AUTO ).

The units (HZ|KHZ|MHZ) are optional, if no units are specified then the default is HZ.

Requirements

Test Application Revision: B.09 and above
Lab Application Revision: A.01 and above

Setting

Range: A value in the range 300 Hz to 5 MHz can be entered, however the value is rounded to a valid entry. The decision point for rounding up or down is the halfway point between the first valid entry below the setting and the first valid entry above the setting. The valid entries include: 300 Hz, 1 kHz, 3 kHz, 10 kHz, 30 kHz, 100 kHz, 300 kHz, 1 MHz, 5 MHz.

Query

300 Hz, 1 kHz, 3 kHz, 10 kHz, 30 kHz, 100 kHz, 300 kHz, 1 MHz, 5 MHz.
*RST Setting 30 kHz

Programming Example

OUTPUT 714;"SETup:SMONitor:BANDwidth:MANual 600 khz"

!Sets the Resolution Bandwidth to 300 kHz because the first valid entry below the setting is 300 kHz !and the first valid entry above the setting is 1 MHz. The middle point between the two valid values is !650 kHz and since 600 kHz is below 650 kHz, the test set rounds 600 kHz to 300 kHz.

SETup:SMONitor:BANDwidth|BWIDth:ZSPan[:RESolution]

Function

This command sets/queries the resolution bandwidth when the spectrum monitor is operating in zero span mode. To change the spectrum monitor to zero span mode, use the command SETup:SMONitor:FREQuency:SPAN , to set the frequency span to 0 Hz.

To measure the total power of a signal you must select a resolution bandwidth greater than or equal to the signal bandwidth. To resolve two spectral components the resolution bandwidth must be less than the difference between them.

The units (HZ|KHZ|MHZ) are optional, if no units are specified then the default is HZ.

Any setting you enter is rounded to the nearest of the three settings.
Setting

Range: 100 kHz|300 kHz|1 MHz

Query

Range: 100 kHz|300 kHz|1 MHz

*RST Setting 300 kHz

Programming Example

OUTPUT 714;"SETup:SMONitor:BAND:ZSPan 100 KHZ"

!Sets spectrum monitor's zero span resolution bandwidth to 100 kHz.

SETup:SMONitor:COUNt[:SNUMber]

Function

This command sets/queries the averaging count and turns on averaging.

Setting

Range: 1 to 999

Query

Range: 1 to 999
*RST Setting

100

Programming Example

OUTPUT 714;"SETup:SMONitor:COUNt 200"

!Sets the averaging count to 200 and sets the averaging the state to on.

SETup:SMONitor:COUNt:NUMber

Function

This command sets/queries the averaging count used when the averaging is turned on.
Setting

Range: 1 to 999

Query

Range: 1 to 999
*RST Setting

100

Programming Example

OUTPUT 714;"SETup:SMONitor:COUNt:NUMBer 200" !Sets the averaging count to 200.

SETup:SMONitor:COUNt:STATe

Function

This command sets/queries the averaging state.
Setting

Range: 1|ON|0|OFF

Query

Range: 1|0
*RST Setting

OFF

Programming Example

OUTPUT 714;"SETup:SMONitor:COUNt:STATe 1" !Turns on averaging.

SETup:SMONitor:CONTinous

Function

This command arms triggering for a measurement sweep. Trigger arming can be single (OFF) or continuous (ON). With single triggering, the measurement sweep starts when an INITiate or READ command is received. With continuous triggering, measurement sweeps initiate immediately and continuously.

The *RST (remote full preset) default setting is single triggering. At power-on or after a front-panel preset, the default setting is continuous triggering.
Setting

Range: ON|1|OFF|0

Query

Range: 1|0
*RST Setting OFF

Programming Example

OUTPUT 714;"SETup:SMONitor:CONTinuous ON" ! Sets the trigger mode to continuous.

SETup:SMONitor:DETector[:TYPE]

Function

 This command sets/queries the Spectrum Monitor Detection Method. There are three detection methods available in the test set's Spectrum Monitor: Peak Detection, Sample Detection, and RMS Detection. See Detection Method for more information.

Requirements

Test Application Revision: B.03 and above
Lab Application Revision: A.01 and above
Setting

Range: PEAK|SAMPle|RMS

Query

Range: PEAK|SAMP|RMS
*RST Setting PEAK

Programming Example

OUTPUT 714;"SETup:SMONitor:DETector RMS"
! Sets Detection Method to RMS.

SETup:SMONitor:FREQuency:SPAN

Function

This command sets/queries the spectrum monitor's frequency span.

Setting

Range:

  • A value in the range 125 kHz to 100 MHz can be entered, however the value is rounded to the nearest of: 125 kHz, 500 kHz, 1.25 MHz, 2.5 MHz, 4 MHz, 5 MHz, 10 MHz, 12 MHz, 20 MHz, 40 MHz,
    80 MHz, 100 MHz
  • 0 Hz (indicates the spectrum monitor is operating in zero span mode. To set the resolution bandwidth when the spectrum monitor is operating in zero span mode, use SETup:SMONitor:BANDwidth|BWIDth:ZSPan[:RESolution] )
Query

Range: Same as setting range.
*RST Setting 5 MHz

Programming Example

OUTPUT 714;"SETup:SMONitor:FREQuency:SPAN 10MHZ" ! Sets the frequency span to 10 MHz.

SETup:SMONitor:TIME:OFFSet

Function

 This command sets/queries the time offset. You can specify the time window for viewing the signal using this command and the SETup:SMONitor:TIME:SPAN . The measurement is made for the duration of the time span, beginning at the time defined by the trigger event plus the trigger delay plus the time offset. The units (S|MS|US|NS) are optional, if no units are specified then the default is S.
Setting

Range: 0 us to 10 s

Resolution: 0.1 us
Query

Range: 0 us to 10 s

Resolution: 0.1 us
*RST Setting 0 us

Programming Example

OUTPUT 714;"SETup:SMONitor:TIME:OFFSet 25 MS"
! Sets the spectrum monitor's time offset to 25 millisecond.

SETup:SMONitor:TIME:SPAN

Function

 This command sets/queries the span of the time display. The units (S|MS|US) are optional, if no units are specified then the default is S.
Setting

Range: 50 us to 70 ms

Resolution: 0.250 us
Query

Range: 50 us to 70 ms

Resolution: 0.250 us
*RST Setting 10 ms

Programming Example

OUTPUT 714;"SETup:SMONitor:TIME:SPAN 30MS"
! Sets the spectrum monitor's time span to 30 millisecond.

SETup:SMONitor:TIMeout[:STIMe]

Function

This command sets/queries the spectrum monitor's timeout interval and turns on the timeout state. The units (S|MS|US) are optional, if no units are specified then the default is S.
Setting

Range: 1 to 999 seconds

Resolution: 0.1 second
Query

Range: 1 to 999 seconds

Resolution: 0.1 second
*RST Setting 10 s

Programming Example

OUTPUT 714;"SETup:SMONitor:TIMeout:STIMe 12S"
! Turns on the timeout timer and sets the timer to expire in 12 seconds.

SETup:SMONitor:TIMeout:STATe

Function

This command sets/queries the state of the spectrum monitor's timeout timer.
Setting

Range: 1|ON|0|OFF
Query

Range: 1|0
*RST Setting OFF

Programming Example

OUTPUT 714;"SETup:SMONitor:TIMeout:STATe 1" ! Turns on the timeout timer.

SETup:SMONitor:TIMeout:TIME

Function

This command sets/queries the spectrum monitor's timeout interval. The units (S|MS|US) are optional, if no units are specified then the default is S.
Setting

Range: 1 to 999 seconds

Resolution: 0.1 seconds
Query

Range: 1 to 999 seconds

Resolution: 0.1 seconds
*RST Setting 10 seconds

Programming Example

OUTPUT 714;"SETup:SMONitor:TIMeout:TIME 20S"
! Generates a timeout error if no results are reported within 20 seconds.

SETup:SMONitor:TRACe:MODE

Function

This command sets/queries the trace update parameter.

  • WRITe (Clear-write) erases any data previously stored in the selected trace.
  • MAXHold (maximum hold) maintains the maximum level for each trace point of the selected trace and updates each trace point if a new maximum level is detected in successive sweeps.
  • MINHold (minimum hold) maintains the minimum level for each trace point of the selected trace and updates each trace point if a new minimum level is detected in successive sweeps.

If you change the center, start, or the frequency span, or the resolution bandwidth, the MAXHold and MINHold traces are restarted. These traces are not restarted if you change only the reference level or the scale.
Setting

Range: WRITe|MAXHold|MINHold
Query

Range: WRIT|MAXH|MINH
*RST Setting WRITe

Programming Example

OUTPUT 714;"SETup:SMONitor:TRACe:MODE MAXH"
! Sets the update method to maximim hold.

SETup:SMONitor:TRiGger:DELay

Function

This command sets/queries the trigger delay. This command allows you to add a time delay following the trigger event before samples are taken. The delay can be positive or negative. The units (S|MS|US) are optional, if no units are specified then the default is S.
Setting

Range: -50 ms to +50 ms

Resolution: 5 significant digits or 100 ns, whichever is greater
Query

Range: -50 ms to +50 ms

Resolution: 5 significant digits or 100 ns, whichever is greater
*RST Setting 350 us

Programming Example

OUTPUT 714;"SETup:SMONitor:TRIGger:DELay 1MS" ! Sets the trigger delay to 1 millisecond.

SETup:SMONitor:TRiGger:SOURce

Function

This command sets the trigger source. Immediate triggering happens as soon as the measurement is armed. RF rise triggering is initiated by the rising edge of an RF burst. With protocol triggering, sampling is initiated by a signaling event such as the start of a burst. An external trigger is used when set to external.
Setting

Range: IMMediate|PROTocol|RISE|EXTernal
Query

Range: IMM|PROT|RISE|EXT
*RST Setting IMMediate

Programming Example

OUTPUT 714;"SETup:SMONitor:TRIGger:SOURce RISE"
! Sets the measurement to trigger on the rising edge of an RF burst.


SETup:STONe

SETup:STONe

Last updated: June 7, 2007

GPIB Command Conventions

  • SETup:STONe:CONTinuous
  • SETup:STONe:COUNt[:SNUMber]
  • SETup:STONe:COUNt:NUMBer
  • SETup:STONe:COUNt:STATe
  • SETup:STONe:TIMeout[:STIMe]
  • SETup:STONe:TIMeout:STATe
  • SETup:STONe:TIMeout:TIME

SETup:STONe:CONTinuous

Function

Sets/queries the trigger arm state for the Signaling Tone measurement. Determines whether measurement makes one measurement then stop (0|OFF (single)), or automatically rearms upon completion of one measurement and repeats the process (1|ON (continuous)).

Setting

Range: 1|ON|0|OFF

Query

Range: 1|0

*RST Setting

0 (off)

Requirement

Test Application Revision: B.09 and above

Lab Application Revision: B.03 and above

Programming Example

OUTPUT 714;"SETup:STONe:CONTinuous ON"
!Sets measurement to continuous trigger mode.

SETup:STONe:COUNt[:SNUMber]

Function

Sets/queries the number of Signaling Tone measurements to be made in a mulit-measurement setup. This command sets the count, and automatically sets the multi-measurement STATe command to 1 (on).

Setting

Range: 1 to 999

Query

Range: 1 to 999

*RST Setting

10, off

Requirement

Test Application Revision: B.09 and above

Lab Application Revision: B.03 and above

Programming Example

OUTPUT 714;"SETup:STONe:COUNt 5"
!Turns on multi-measurements and sets the number of measurements to 5.

SETup:STONe:COUNt:NUMBer

Function

Sets/queries the number of Signaling Tone measurements to be made when mulit-measurement state is ON.

Setting

Range: 1 to 999

Query

Range: 1 to 999

*RST Setting

 10

Requirement

Test Application Revision: B.09 and above

Lab Application Revision: B.03 and above

Programming Example

OUTPUT 714;"SETup:STONe:COUNt:NUMBer 5"
!Sets the number of measurements to 5 when the multi-measurement state is set to ON.

SETup:STONe:COUNt:STATe

Function

Sets/queries the multi-measurement state of the Signaling Tone measurement.

Setting

Range: 1|ON|0|OFF

Query

Range: 1|0

*RST Setting

0 (off)

Requirement

Test Application Revision: B.09 and above

Lab Application Revision: B.03 and above

Programming Example

OUTPUT 714;"SETup:STONe:COUNt:STATe ON"
!Turns on multi-measurements.

SETup:STONe:TIMeout[:STIMe]

Function

Sets/queries the Signaling Tone measurement's timeout setting and automatically sets the timeout state to ON.

Setting

Range: 0.1 to 999 seconds

Resolution: 0.1 second

Query

Range: 0.1 to 999

*RST Setting

10 seconds, off

Requirement

Test Application Revision: B.09 and above

Lab Application Revision: B.03 and above

Programming Example

OUTPUT 714;"SETup:STONe:TIMeout 5S"
!Sets timeout state to ON and sets the timeout time to 5 seconds.

SETup:STONe:TIMeout:STATe

Function

Sets/queries the Signaling Tone measurement's timeout state.

Setting

Range: 1|ON|0|OFF

Query

Range: 1|0

*RST Setting

0 (off)

Requirement

Test Application Revision: B.09 and above

Lab Application Revision: B.03 and above

Programming Example

OUTPUT 714;"SETup:STONE:TIMeout:STATe ON"

SETup:STONe:TIMeout:TIME

Function

Sets/queries the Signaling Tone measurement's timeout setting to be used when the timeout state is set to ON.

Setting

Range: 0.1 to 999 seconds

Resolution: 0.1 second

Query

Range: 0.1 to 999

*RST Setting

10 seconds

Requirement

Test Application Revision: B.09 and above

Lab Application Revision: B.03 and above

Programming Example

OUTPUT 714;"SETup:STONe:TIMeout:TIME 5S"


SETup:TFERror

SETup:TFERror

Last updated: June 7, 2007

GPIB Command Conventions

  • SETup:TFERror:CONFidence:REQuirement[:RATio]
  • SETup:TFERror:CONTinuous
  • SETup:TFERror:COUNt
  • SETup:TFERror:TIMeout[:STIMe]
  • SETup:TFERror:TIMeout:STATe
  • SETup:TFERror:TIMeout:TIME

SETup:TFERror:CONFidence:REQuirement[:RATio]

Function

Sets/queries the test data service option frame error rate (TDSO FER) confidence requirement.

Setting

Range: 0.10 to 15.00 percent

Resolution: 0.01 percent

Query

Range: 0.10 to 15.00 percent

Resolution: 0.01 percent

*RST Setting

1.00

Programming Example

OUTPUT 714;"SETUP:TFERROR:CONFIDENCE:REQUIREMENT:RATIO 0.50"

SETup:TFERror:CONTinuous

Function

Sets/queries the trigger arm state for the test data service option frame error rate (TDSO FER) measurement. The trigger arm state determines whether the TDSO FER measurement will be made once then stop (0|OFF (single)), or automatically re-arm upon completion of one measurement and repeat the process (1|ON (continuous)).

Setting

Range: 1|ON|0|OFF

Query

Range: 1|0

*RST Setting

0 (off)

Programming Example

OUTPUT 714;"SETUP:TFERROR:CONTINUOUS OFF"
!Sets measurement to single trigger mode.

SETup:TFERror:COUNt

Function

Sets/queries the the number of frames to be counted during a test data service option frame error rate (TDSO FER) measurement.

Setting

Range: 512 to 999,936

Resolution: integer multiples of 512

Query

Range: 512 to 999,936

Resolution: integer multiples of 512

*RST Setting

 512

Programming Example

OUTPUT 714;"SETUP:TFERROR:COUNT 1536"

SETup:TFERror:TIMeout[:STIMe]

Function

The setting form of this command performs two functions: (1) sets the TDSO frame error rate measurement's timeout (see Timeouts ) value, and (2) sets the TDSO frame error rate measurement's timeout STATe to 1 (on).

The query form returns the TDSO frame error rate measurement's timeout value.

Setting

Range: 0.1 to 200000.0 seconds

Resolution: 0.1 second

Query

Range: 0.1 to 200000.0

*RST Setting

200 seconds, off

Programming Example

OUTPUT 714;"SETUP:TFERROR:TIMEOUT:STIME 120 S"
!Sets timeout state to ON and sets the timeout time to 120 seconds.

SETup:TFERror:TIMeout:STATe

Function

Sets/queries the test data service option (TDSO) frame error rate measurement's timeout (see Timeouts ) state.

Setting

Range: 1|ON|0|OFF

Query

Range: 1|0

*RST Setting

0 (off)

Programming Example

OUTPUT 714;"SETUP:TFERROR:TIMEOUT:STATE ON"

SETup:TFERror:TIMeout:TIME

Function

Sets/queries the test data service option (TDSO) frame error rate measurement's timeout (see Timeouts ) setting to be used when the timeout state is set to ON.

Setting

Range: 0.1 to 200000.0 seconds

Resolution: 0.1 second

Query

Range: 0.1 to 200000.0 seconds

*RST Setting

200 seconds

Programming Example

OUTPUT 714;"SETUP:TFERROR:TIMEOUT:TIME 120 S"


SETup:TROPower

SETup:TROPower

Last updated: June 7, 2007

GPIB Command Conventions

  • SETup:TROPower:STEP
  • SETup:TROPower:TIMeout[:STIMe]
  • SETup:TROPower:TIMeout:STATe
  • SETup:TROPower:TIMeout:TIME

SETup:TROPower:STEP

Function

 Sets the direction of the test set's cell power change. The mobile's output power is expected to change in the opposite direction as the 20 dB test set cell power change.

Setting

Range: UP20|DOWN20

*RST Setting

 UP20

Requirements

 Test Application Revision: B.04

Programming Example

OUTPUT 714;"SETUP:TROPOWER:STEP UP20"

SETup:TROPower:TIMeout[:STIMe]

Function

Sets the time response of open loop power control measurement's timeout value, and sets the measurement's timeout STATe to 1 (on).

Setting

Range: 0.1 to 999.9 seconds

Resolution: 0.1 second

Query

Range: 0.1 to 999.9 seconds

*RST Setting

10 seconds, off

Requirements

 Test Application Revision: B.04

Programming Example

OUTPUT 714;"SETUP:TROPOWER:TIMEOUT:STIME 20S"
!Sets timeout state to ON and sets the timeout time to 20 seconds.

SETup:TROPower:TIMeout:STATe

Function

Sets/queries the time response of open loop power control measurement's timeout state.

Setting

Range: 1|ON|0|OFF

Query

Range: 1|0

*RST Setting

0 (off)

Requirements

 Test Application Revision: B.04

Programming Example

OUTPUT 714;"SETUP:TROPOWER:TIMEOUT:STATE ON"
! sets the timeout state to on.

SETup:TROPower:TIMeout:TIME

Function

Sets/queries the time response of open loop power control measurement's timeout setting to be used when the timeout state is set to ON.

Setting

Range: 0.1 to 999.9 seconds

Resolution: 1 second

Query

Range: 0.1 to 999.9 seconds

*RST Setting

10 seconds

Requirements

 Test Application Revision: B.04

Programming Example

OUTPUT 714;"SETUP:TROPOWER:TIMEOUT:TIME 20S"
! sets the timeout time to 20 seconds.


SETup:WDDeviation

SETup:WDDeviation

Last updated: June 7, 2007

GPIB Command Conventions

  • SETup:WDDeviation:CONTinuous
  • SETup:WDDeviation:GTIMe
  • SETup:WDDeviation:TIMeout[:STIMe]
  • SETup:WDDeviation:TIMeout:STATe
  • SETup:WDDeviation:TIMeout:TIME

SETup:WDDeviation:CONTinuous

Function

Sets/queries the trigger arm state for the Wideband Data Deviation measurement. Determines whether measurement makes one measurement then stop (0|OFF (single)), or automatically rearms upon completion of one measurement and repeats the process (1|ON (continuous)).

Setting

Range: 1|ON|0|OFF

Query

Range: 1|0

*RST Setting

0 (off)

Requirement

Test Application Revision: B.09 and above

Lab Application Revision: B.03 and above

Programming Example

OUTPUT 714;"SETup:WDDeviation:CONTinuous ON"
!Sets measurement to continuous trigger mode.

SETup:WDDeviation:GTIMe

Function

Sets/queries the gate time for Wideband Data Deviation measurements.

Setting

Range: 0.1 to 6.0 seconds

Resolution: 0.1 second

Step Size: 1.0 second

Query

Range: 0.1 to 6.0 seconds

*RST Setting

2.0 seconds

Requirement

Test Application Revision: B.09 and above

Lab Application Revision: B.03 and above

Programming Example

OUTPUT 714;"SETup:WDDeviation:GTIMe 5S"

SETup:WDDeviation:TIMeout[:STIMe]

Function

Sets/queries the Wideband Data Deviation measurement's timeout setting and automatically sets the timeout state to ON.

Setting

Range: 0.1 to 999 seconds

Resolution: 0.1 second

Query

Range: 0.1 to 999

*RST Setting

10 seconds, off

Requirement

Test Application Revision: B.09 and above

Lab Application Revision: B.03 and above

Programming Example

OUTPUT 714;"SETup:WDDeviation:TIMeout 5S"
!Sets timeout state to ON and sets the timeout time to 5 seconds.

SETup:WDDeviation:TIMeout:STATe

Function

Sets/queries the Wideband Data Deviation measurement's timeout state.

Setting

Range: 1|ON|0|OFF

Query

Range: 1|0

*RST Setting

0 (off)

Requirement

Test Application Revision: B.09 and above

Lab Application Revision: B.03 and above

Programming Example

OUTPUT 714;"SETup:WDDeviation:TIMeout:STATe ON"

SETup:WDDeviation:TIMeout:TIME

Function

Sets/queries the Wideband Data Deviation measurement's timeout setting to be used when the timeout state is set to ON.

Setting

Range: 0.1 to 999 seconds

Resolution: 0.1 second

Query

Range: 0.1 to 999

*RST Setting

10 seconds

Requirement

Test Application Revision: B.09 and above

Lab Application Revision: B.03 and above

Programming Example

OUTPUT 714;"SETup:WDDeviation:TIMeout:TIME 5S"


SETup:WQUality

SETup:WQUality

Last updated: June 7, 2007

GPIB Command Conventions

  • SETup:WQUality:CDPower:IQINactive[:LIMit]
  • SETup:WQUality:CDPNoise:IQNoise[:LIMit]
  • SETup:WQUality:CONTinuous
  • SETup:WQUality:COUNt[:SNUMber]
  • SETup:WQUality:COUNt:NUMBer
  • SETup:WQUality:COUNt:STATe
  • SETup:WQUality:TIMeout[:STIMe]
  • SETup:WQUality:TIMeout:STATe
  • SETup:WQUality:TIMeout:TIME

SETup:WQUality:CDPower:IQINactive[:LIMit]

Function

Sets/queries the pass/fail limit for inactive channel power on the Code Domain Power measurement .

Setting

Range: -100 to 0 dB

Query

Range: -100 to 0 dB

*RST Setting

-23 dB

Programming Example

OUTPUT 714;"SETUP:WQUALITY:CDPOWER:IQINACTIVE:LIMIT -26 DB"
!Sets code domain power measurement's pass/fail limit.

SETup:WQUality:CDPNoise:IQNoise[:LIMit]

Function

Sets/queries the pass/fail limit for noise energy measured by the Code Domain Power + Noise measurement.

Setting

Range: -100 to 0 dB

Query

Range: -100 to 0 dB

*RST Setting

-23 dB

Programming Example

OUTPUT 714;"SETUP:WQUALITY:CDPNOISE:IQNOISE:LIMIT?"
!Queries the code domain power plus noise measurement's pass/fail limit.

SETup:WQUality:CONTinuous

Function

Sets/queries the trigger arm state for the waveform quality measurement. The trigger arm state determines whether the waveform quality measurement will be made once then stop (0|OFF (single)), or automatically rearm upon completion of one measurement and repeat the process (1|ON (continuous)).

Setting

Range: 1|ON|0|OFF

Query

Range: 1|0

*RST Setting

0 (off)

Programming Example

OUTPUT 714;"SETUP:WQUALITY:CONTINUOUS OFF"
!Sets measurement to single trigger mode.

SETup:WQUality:COUNt[:SNUMber]

Function

The setting form of this command performs two functions: (1) sets the number of waveform quality measurements to be made in a multi-measurement, and (2) sets the multi-measurement STATe command to 1 (on).

The query form returns the number of waveform quality multi-measurements to be made when multi-measurement state is ON.

Setting

Range: 1 to 999

Query

Range: 1 to 999

*RST Setting

 Off (10 when STATe = On)

Programming Example

OUTPUT 714;"SETUP:WQUALITY:COUNT:SNUMBER 5"
!Turns on multi-measurements and sets the number of measurements to 5.

SETup:WQUality:COUNt:NUMBer

Function

Sets/queries the number of waveform quality measurements to be made when the multi-measurement state is ON.

Setting

Range: 1 to 999

Query

Range: 1 to 999

*RST Setting

 10

Programming Example

OUTPUT 714;"SETUP:WQUALITY:COUNT:NUMBER 5"
!Sets the number of measurements to 5 when the multi-measurement state is set to ON.

SETup:WQUality:COUNt:STATe

Function

Sets/queries the multi-measurement state of the waveform quality measurement.

Setting

Range: 1|ON|0|OFF

Query

Range: 1|0

*RST Setting

0 (off)

Programming Example

OUTPUT 714;"SETUP:WQUALITY:COUNT:STATE ON" !Turns on multi-measurements.

SETup:WQUality:TIMeout[:STIMe]

Function

The setting form of this command performs two functions: (1) sets the waveform quality measurement's timeout value, and (2) sets the waveform quality measurement's timeout STATe to 1 (on).

The query form returns the waveform quality measurement's timeout value.

Setting

Range: 1 to 999 seconds

Resolution: 1 second

Query

Range: 1 to 999

*RST Setting

10 seconds, on

Programming Example

OUTPUT 714;"SETUP:WQUALITY:TIMEOUT:STIME 5S"
!Sets timeout state to ON and sets the timeout time to 5 seconds.

SETup:WQUality:TIMeout:STATe

Function

Sets/queries the waveform quality measurement's timeout state.

Setting

Range: 1|ON|0|OFF

Query

Range: 1|0

*RST Setting

0 (off)

Programming Example

OUTPUT 714;"SETUP:WQUALITY:TIMEOUT:STATE ON"

SETup:WQUality:TIMeout:TIME

Function

Sets/queries the waveform quality measurement's timeout setting to be used when the timeout state is set to ON.

Setting

Range: 1 to 999 seconds

Resolution: 1 second

Query

Range: 1 to 999

*RST Setting

10 seconds

Programming Example

OUTPUT 714;"SETUP:WQUALITY:TIMEOUT:TIME 5S"


STATus Subsystem

STATus Subsystem

Last updated: October 28, 2004

Description

The STATus subsystem is used to communicate current test set status information to the controlling application program.

Syntax Diagrams and Command Descriptions

STATus:OPERation

STATus:PRESet

STATus:QUEStionable

Status Byte Register
Standard Event Status Register

Related Topics

Status Subsystem Overview


STATus:OPERation

STATus:OPERation

Last updated: June 7, 2007

GPIB Command Conventions

  • STATus:OPERation Condition Register Bit Assignments
  • STATus:OPERation:CALL Condition Register Bit Assignment
  • STATus:OPERation:CALL:CDMA Condition Register Bit Assignment
  • STATus:OPERation:CALL:COMMon Condition Register Bit Assignment
  • STATus:OPERation:CALL:COMMon:DATA Condition Register Bit Assignment
  • STATus:OPERation:CALL:AMPS Register Bit Assignment
  • STATus:OPERation:CALL:DIGital95 Register Bit Assignment
  • STATus:OPERation:CALL:DIGital2000 Register Bit Assignment
  • STATus:OPERation:CALL:TA2000 Register Bit Assignment
  • STATus:OPERation:FEATures Register Bit Assignments
  • STATus:OPERation:FEATures:COMMon Register Bit Assignments
  • STATus:OPERation:FEATures:COMMon:SMService Register Bit Assignments
  • STATus:OPERation:HARDware Condition Register Bit Assignments
  • STATus:OPERation:KEYPressed Register Bit Assignments
  • STATus:OPERation:NMRReady Register Bit Assignments
  • STATus:OPERation:NMRReady:AMPS Condition Register Bit Assignment
  • STATus:OPERation:NMRReady:CDMA Register Bit Assignments
  • STATus:OPERation:NMRReady:COMMon Register Bit Assignments
  • STATus:OPERation:NMRReady:DIGital2000 Register Bit Assignments

STATus:OPERation Condition Register Bit Assignments

The OPERation status register set contains bits which give an indication of conditions that are part of the test set's normal operation.

Bit Number | Binary Weighting | Condition | Description
15 | 32768 | Not Used. Defined by SCPI. | This bit is always 0.
14 | 16384 | KEYPressed Summary. | This bit is the summary bit for the STATus:OPERation:KEYPressed register.
13 | 8192 | Reserved for future use. | This bit is always 0.
12 | 4096 | SYSTem:SYNChronized | This condition bit is "pulsed" by the SYSTem:SYNChronized command. This will allow the status system to indicate that the input buffer is synchronized to the point where this command is parsed and that all prior sequential commands are completed and all prior overlapped commands have started.
11 | 2048 | HARDware Summary | This bit is the summary bit for the STATus:OPERation:HARDware register.
10 | 1024 | CALL Summary | This bit is the summary message bit for the STATus:OPERation:CALL register.
9 | 512 | NMRReady (New Measurement Result Ready) Summary | This bit is the summary message bit for the STATus:OPERation:NMRReady register.
8 | 256 | Reserved for future use. | This bit is always 0.
7 | 128 | Reserved for future use. | This bit is always 0.
6 | 64 | Reserved for future use. | This bit is always 0.
5 | 32 | Reserved for future use. | This bit is always 0.
4 | 16 | Reserved for future use. | This bit is always 0.
3 | 8 | Reserved for future use. | This bit is always 0.
2 | 4 | Reserved for future use. | This bit is always 0.
1 | 2 | Reserved for future use. | This bit is always 0.
0 | 1 | Extension Bit | This bit is always 0.

Program Examples - STATus:OPERation

OUTPUT 714;"STATUS:OPERATION:EVENT?" !Queries the Operation Event Register.
OUTPUT 714;"STATUS:OPERATION:CONDITION?" !Queries the Operation Condition Register.
OUTPUT 714;"STATUS:OPERATION:ENABLE 1024" !Sets the Operation Enable Register for bit 10.
OUTPUT 714;"STATUS:OPERATION:NTR 1024" !Sets the Operation Negative Transition
                                       !Register for bit 10.
OUTPUT 714;"STATUS:OPERATION:PTR 512" !Sets the Operation Event Positive Transition
                                      !Register for bit 9.

STATus:OPERation:CALL Condition Register Bit Assignment

The STATus:OPERation:CALL register bits will be used to indicate status of processes that occur during normal call processing operations.

Bit Number | Binary Weighting | Condition | Description
15 | 32768 | Not Used. Defined by SCPI. | This bit is always 0.
14 | 16384 | DIGital856 Summary bit. | This bit is the summary bit for the STATus:OPERation:CALL:DIGital856 register.
13 | 8192 | TA856 Summary bit. | This bit is the summary bit for the STATus:OPERation:CALL:TA856 register.
12 | 4096 | GPRS Summary bit. | This bit is the summary bit for the STATus:OPERation:CALL:GPRS register.
11 | 2048 | WCDMa Summary bit. | This bit is the summary bit for the STATus:OPERation:CALL:WCDMa register.
10 | 1024 | FDD Summary bit. | This bit is the summary bit for the STATus:OPERation:CALL:FDD register.
9 | 512 | TA2000 Summary bit | This bit is the summary message bit for the STATus:OPERation:CALL:TA2000 register.
8 | 256 | CDMA Summary bit | This bit is the summary message bit for the STATus:OPERation:CALL:CDMA register.
7 | 128 | DIGital2000 Summary bit | This bit is the summary message bit for the STATus:OPERation:CALL:DIGital2000 register.
6 | 64 | DIGital95 Summary bit | This bit is the summary message bit for the STATus:OPERation:CALL:DIGital95 register.
5 | 32 | TA136 Summary bit | This bit is the summary message bit for the STATus:OPERation:CALL:TA136 register.
4 | 16 | DIGital136 Summary bit | This bit is the summary message bit for the STATus:OPERation:CALL:DIGITAL136 register.
3 | 8 | AMPS Summary bit | This bit is the summary message bit for the STATus:OPERation:CALL:AMPS register.
2 | 4 | GSM Summary bit | This bit is the summary message bit for the STATus:OPERation:CALL:GSM register.
1 | 2 | COMMon Summary bit | This bit is the summary message bit for the STATus:OPERation:CALL:COMMon register.
0 | 1 | Extension Bit | This bit is always 0.

Program Examples - STATus:OPERation:CALL

OUTPUT 714;"STATUS:OPERATION:CALL:EVENT?" !Queries the Operation Call Event !Register.
OUTPUT 714;"STATUS:OPERATION:CALL:CONDITION?" !Queries the Operation Call Condition Register.
OUTPUT 714;"STATUS:OPERATION:CALL:ENABLE 4"
    !Sets the Operation Call Enable Register for bit 2.
OUTPUT 714;"STATUS:OPERATION:CALL:NTR 4" !Sets the Negative Transition Register for bit 2.
OUTPUT 714;"STATUS:OPERATION:CALL:PTR 256" !Sets the Positive Transition Register for bit 8.

STATus:OPERation:CALL:CDMA Condition Register Bit Assignment

The STATus:OPERation:CALL:CDMA register bits will be used to indicate status of processes that occur during CDMA call processing operations.

Bit Number | Binary Weighting | Condition | Description
15 | 32768 | Not Used. Defined by SCPI. | This bit is always 0.
14 | 16384 | Reserved for future use. | This bit is always 0.
13 | 8192 | Reserved for future use. | This bit is always 0.
12 | 4096 | Reserved for future use. | This bit is always 0.
11 | 2048 | Reserved for future use. | This bit is always 0.
10 | 1024 | Reserved for future use. | This bit is always 0.
9 | 512 | Reserved for future use. | This bit is always 0.
8 | 256 | Reserved for future use. | This bit is always 0.
7 | 128 | Reserved for future use. | This bit is always 0.
6 | 64 | Authentication Data Burst | This bit is a 1 when the Global Challenge is for a Data Burst Message. See CALL:SECurity:AUTHenticate:GCHallenge:TYPE?
5 | 32 | Authentication Page Response. | This bit is a 1 when the Global Challenge is for a Page Response. See CALL:SECurity:AUTHenticate:GCHallenge:TYPE?
4 | 16 | Authentication Registration. | This bit is a 1 when the Global Challenge is for a Registration. See CALL:SECurity:AUTHenticate:GCHallenge:TYPE?
3 | 8 | Authentication Origination. | This bit is a 1 when the Global Challenge type is for an Origination. See CALL:SECurity:AUTHenticate:GCHallenge:TYPE?
2 | 4 | Global Challenge Pass/Fail. | This bit is a 1 when the Global Challenge authentication passes. See CALL:SECurity:AUTHenticate:GCHallenge:RESult? .
1 | 2 | SSD_A = 0. | This bit is a 1 when the the SSD_A=0 is True. See CALL:SECurity:AUTHenticate:SSDA:ZERO? .
0 | 1 | Extension Bit | This bit is always 0.

Program Examples - STATus:OPERation:CALL:CDMA

OUTPUT 714;"STATUS:OPERATION:CALL:CDMA:EVENT?"
    !Queries the Operation Call CDMA Event Register.
OUTPUT 714;"STATUS:OPERATION:CALL:CDMA:CONDITION?"
    !Queries the Operation Call CDMA Condition Register.
OUTPUT 714;"STATUS:OPERATION:CALL:CDMA:ENABLE 2"
    !Sets the Operation Call CDMA Enable Register for bit 1.
OUTPUT 714;"STATUS:OPERATION:CALL:CDMA:NTR 4"
    !Sets the CDMA Negative Transition Register for bit 2.
OUTPUT 714;"STATUS:OPERATION:CALL:CDMA:PTR 256"
    !Sets the CDMA Positive Transition 	Register for bit 8.

STATus:OPERation:CALL:COMMon Condition Register Bit Assignment

The STATus:OPERation:CALL:COMMon register bits will be used to indicate status of processes that occur during normal call processing operations.

Bit Number

Binary Weighting

Condition

Description

15

32768

Not Used. Defined by SCPI.

This bit is always 0.

14

16384

Data Summary

 This bit is the summary bit for the STATus:OPERation:CALL:COMMON:DATA register.

13

8192

 Call Control Status Access Probe

This bit is a 1 when the test set is in the call control status access probe state.

12

4096

Call Control Status Set Up Request

This bit is a 1 when the test set is in the call control status set up request state.

11

2048

Call Control Status Releasing

This bit is a 1 when the test set is in the call control status releasing state.

10

1024

Call Control Status Paging

This bit is a 1 when the test set is in the call control status paging state.

9

512

Registering (BS initiated)

This bit is set to a 1 when the Base Station initiates registration.

8

256

Reserved for future use.

This bit is always 0.

7

128

BS Originating

This bit is a 1 when:

  • Active Cell mode - the call processing state leaves the idle state

  • Test mode - the test set has noted a base station origination.

6

64

 Call Control Status Changing

This bit is a 1 when the test set is in the call control status changing state.

5

32

Call Control Status Handover/Handoff

This bit is a 1 when the test set is in the call control handover or handoff state.

4

16

Call Control Status Registering

This bit will be a 1 when the test set is in the call control status registering state.

3

8

Call Control Status is "Alerting"

This bit is a 1 when the test set is in the call alerting state (ringing).

2

4

Call Control Status is "Connected"

This bit is a 1 when the test set is in the call connected state.

1

2

Call Control Status is "Idle"

This bit is a 1 when the test set is in the call idle state.

0

1

Extension Bit

This bit is always 0.

Program Examples - STATus:OPERation:CALL:COMMon

OUTPUT 714;"STATUS:OPERATION:CALL:COMMON:EVENT?" !Queries the Operation Call Common Event
                                          !Register.
OUTPUT 714;"STATUS:OPERATION:CALL:COMMON:CONDITION?" !Queries the Operation Call Common
                                              !Condition Register.
OUTPUT 714;"STATUS:OPERATION:CALL:COMMON:ENABLE 8" !Sets the Operation Call Common Enable
                                            !Register for bit 3.
OUTPUT 714;"STATUS:OPERATION:CALL:COMMON:NTR 8" !Sets the Negative Transition
                                         !Register for bit 3.
OUTPUT 714;"STATUS:OPERATION:CALL:COMMON:PTR 256" !Sets the Positive Transition
                                           !Register for bit 8.

STATus:OPERation:CALL:COMMon:DATA Condition Register Bit Assignment

The STATus:OPERation:CALL:COMMon:DATA register bits are used to indicate status of processes that occur during normal data connection processing operations.

Bit Number

Binary Weighting

Condition

Description

15

32768

Not Used. Defined by SCPI.

This bit is always 0.

14

16384

Reserved for future use.

This bit is always 0.

13

8192

Reserved for future use.

This bit is always 0.

12

4096

Reserved for future use.

This bit is always 0.

11

2048

Reserved for future use.

This bit is always 0.

10

1024

Data Connection Status Dormant

This bit is a 1 when the data connection status is dormant. See Packet Data Connection Processing States .

9

512

Data Connection Status Session Open

This bit is a 1 when the data connection session is open.

8

256

 Data Connection Status PDP Active This bit is a 1 when the PDP is active, zero when inactive.

7

128

Starting Data Connection

This bit is a 1 when:

  • Active Cell mode - the data connection status leaves the idle state

  • Test mode - the test set has noted a base station origination.

6

64

Data Connection Status Changing

This bit is set to a 1 when the data connection status change detector has been armed.

5

32

 Data Connection Status Off This bit is set to 1 when the test set is in the call control status handover/handoff state.

4

16

 Data Connection Status Data Connected

This bit is set to 1 when data connection status data is in the connected state. See Packet Data Connection Processing States .

3

8

Data Connection Status Transferring

This bit is set to 1 when the data connection status is Transferring.

2

4

Data Connection Status Attached

This bit is set to 1 when the data connection status is Attached.

1

2

Data Connection Status Idle

This bit is set to 1 when the data connection status is Idle. See Packet Data Connection Processing States .

0

1

Extension Bit

This bit will always be 0.

Program Examples STATus:OPERation:CALL:COMMon:DATA

OUTPUT 714;"STATUS:OPERATION:CALL:COMMON:DATA:EVENT?" !Queries and clears the Operation
                                                      !Call Common Data Event Register
OUTPUT 714;"STATUS:OPERATION:CALL:COMMON:DATA:CONDITION?" !Queries and clears the Operation
                                                          !Call Common Data Condition
                                                          !Register
OUTPUT 714;"STATUS:OPERATION:CALL:COMMON:DATA:ENABLE 128" !Sets the Operation Call Common
                                                          !Data Enable Register for bit 7
OUTPUT 714;"STATUS:OPERATION:CALL:COMMON:NTRANSITION 2" !Sets the Operation Call Common
                                                        !Data Negative Transition Filter
                                                        !Register for bit 1
OUTPUT 714;"STATUS:OPERATION:CALL:COMMON:PTRANSITION 2" !Set the Operation Call Common
                                                        !Data Positive Transition Filter
                                                        !Register for bit 1

STATus:OPERation:CALL:AMPS Register Bit Assignment

The STATus:OPERation:CALL:AMPS register bits will be used to indicate status of processes that occur during AMPS call processing operations.

Bit Number | Binary Weighting | Condition | Description
15 | 32768 | Not Used. Defined by SCPI. | This bit is always 0.
14 | 16384 | Reserved for future use. | This bit is always 0.
13 | 8192 | Reserved for future use. | This bit is always 0.
12 | 4096 | Reserved for future use. | This bit is always 0.
11 | 2048 | Reserved for future use. | This bit is always 0.
10 | 1024 | Reserved for future use. | This bit is always 0.
9 | 512 | Reserved for future use. | This bit is always 0.
8 | 256 | Reserved for future use. | This bit is always 0.
7 | 128 | Reserved for future use. | This bit is always 0.
6 | 64 | Reserved for future use. | This bit is always 0.
5 | 32 | Reserved for future use. | This bit is always 0.
4 | 16 | Reserved for future use. | This bit is always 0.
3 | 8 | Reserved for future use. | This bit is always 0.
2 | 4 | Call Control Status Alerting, with Alerting Mode. | This bit is a 1 when the Call Control Status is Alerting, with Alerting Mode.
1 | 2 | Call Control Status Alerting, with Maintenance Mode or with Maintenance Mode and then Alerting Mode. | This bit is a 1 when the Call Control Status is Alerting, with Maintenance Mode or with Maintenance Mode and then Alerting Mode.
0 | 1 | Extension Bit | This bit is always 0.

Program Examples - STATus:OPERation:CALL:AMPS

OUTPUT 714;"STATUS:OPERATION:CALL:AMPS:EVENT?"
    !Queries the Operation Call AMPS Event Register.
OUTPUT 714;"STATUS:OPERATION:CALL:AMPS:CONDITION?"
    !Queries the Operation Call AMPSCondition Register.
OUTPUT 714;"STATUS:OPERATION:CALL:AMPS:ENABLE 2"
    !Sets the Operation Call AMPS Enable Register for bit 1.
OUTPUT 714;"STATUS:OPERATION:CALL:AMPS:NTR 4"
    !Sets the AMPS Negative Transition Register for bit 2.
OUTPUT 714;"STATUS:OPERATION:CALL:AMPS:PTR 256"
    !Sets the AMPS Positive Transition 	Register for bit 8.

STATus:OPERation:CALL:DIGital95 Register Bit Assignment

The STATus:OPERation:CALL:DIGital95 register bits will be used to indicate status of processes that occur during DIGital95 call processing operations.

Bit Number | Binary Weighting | Condition | Description
15 | 32768 | Not Used. Defined by SCPI. | This bit is always 0.
14 | 16384 | Reserved for future use. | This bit is always 0.
13 | 8192 | Reserved for future use. | This bit is always 0.
12 | 4096 | Reserved for future use. | This bit is always 0.
11 | 2048 | Reserved for future use. | This bit is always 0.
10 | 1024 | Reserved for future use. | This bit is always 0.
9 | 512 | Reserved for future use. | This bit is always 0.
8 | 256 | Reserved for future use. | This bit is always 0.
7 | 128 | Reserved for future use. | This bit is always 0.
6 | 64 | Reserved for future use. | This bit is always 0.
5 | 32 | Reserved for future use. | This bit is always 0.
4 | 16 | Reserved for future use. | This bit is always 0.
3 | 8 | Reserved for future use. | This bit is always 0.
2 | 4 | Reserved for future use. | This bit is always 0.
1 | 2 | Reserved for future use. | This bit is always 0.
0 | 1 | Extension Bit | This bit is always 0.

Program Examples - STATus:OPERation:CALL:DIGital95

OUTPUT 714;"STATUS:OPERATION:CALL:DIGital95:EVENT?"
    !Queries the Operation Call DIGital95 Event Register.
OUTPUT 714;"STATUS:OPERATION:CALL:DIGital95:CONDITION?"
    !Queries the Operation Call DIGital95Condition Register.
OUTPUT 714;"STATUS:OPERATION:CALL:DIGital95:ENABLE 2"
    !Sets the Operation Call DIGital95 Enable Register for bit 1.
OUTPUT 714;"STATUS:OPERATION:CALL:DIGital95:NTR 4"
    !Sets the DIGital95 Negative Transition Register for bit 2.
OUTPUT 714;"STATUS:OPERATION:CALL:DIGital95:PTR 256"
    !Sets the DIGital95 Positive Transition 	Register for bit 8.

STATus:OPERation:CALL:DIGital2000 Register Bit Assignment

The STATus:OPERation:CALL:DIGital2000 register bits will be used to indicate status of processes that occur during DIGital2000 call processing operations.

Bit Number | Binary Weighting | Condition | Description
15 | 32768 | Not Used. Defined by SCPI. | This bit is always 0.
14 | 16384 | Reserved for future use. | This bit is always 0.
13 | 8192 | Reserved for future use. | This bit is always 0.
12 | 4096 | Reserved for future use. | This bit is always 0.
11 | 2048 | Reserved for future use. | This bit is always 0.
10 | 1024 | Reserved for future use. | This bit is always 0.
9 | 512 | Reserved for future use. | This bit is always 0.
8 | 256 | Reserved for future use. | This bit is always 0.
7 | 128 | Reserved for future use. | This bit is always 0.
6 | 64 | Reserved for future use. | This bit is always 0.
5 | 32 | Reserved for future use. | This bit is always 0.
4 | 16 | Reserved for future use. | This bit is always 0.
3 | 8 | Reserved for future use. | This bit is always 0.
2 | 4 | Reserved for future use. | This bit is always 0.
1 | 2 | F-SCH Synchronized. | 1 indicates that a 10.24 second sync frame boundary has been encountered and a valid TDSO FER measurement can now be initiated.
0 | 1 | Extension Bit | This bit is always 0.

Program Examples - STATus:OPERation:CALL:DIGital2000

OUTPUT 714;"STATUS:OPERATION:CALL:DIGITAL2000:EVENT?"
    !Queries the Operation Call DIGital2000 Event Register.
OUTPUT 714;"STATUS:OPERATION:CALL:DIGITAL2000:CONDITION?"
    !Queries the Operation Call DIGital2000Condition Register.
OUTPUT 714;"STATUS:OPERATION:CALL:DIGITAL2000:ENABLE 2"
    !Sets the Operation Call DIGital2000 Enable Register for bit 1.
OUTPUT 714;"STATUS:OPERATION:CALL:DIGITAL2000:NTR 4"
    !Sets the DIGital2000 Negative Transition Register for bit 2.
OUTPUT 714;"STATUS:OPERATION:CALL:DIGITAL2000:PTR 256"
    !Sets the DIGital2000 Positive Transition 	Register for bit 8.

STATus:OPERation:CALL:TA2000 Register Bit Assignment

The STATus:OPERation:CALL:TA2000 register bits will be used to indicate status of processes that occur during TA2000 call processing operations.

Bit Number | Binary Weighting | Condition | Description
15 | 32768 | Not Used. Defined by SCPI. | This bit is always 0.
14 | 16384 | Reserved for future use. | This bit is always 0.
13 | 8192 | Reserved for future use. | This bit is always 0.
12 | 4096 | Reserved for future use. | This bit is always 0.
11 | 2048 | Reserved for future use. | This bit is always 0.
10 | 1024 | Reserved for future use. | This bit is always 0.
9 | 512 | Reserved for future use. | This bit is always 0.
8 | 256 | Reserved for future use. | This bit is always 0.
7 | 128 | Reserved for future use. | This bit is always 0.
6 | 64 | Reserved for future use. | This bit is always 0.
5 | 32 | Reserved for future use. | This bit is always 0.
4 | 16 | Reserved for future use. | This bit is always 0.
3 | 8 | Reserved for future use. | This bit is always 0.
2 | 4 | Reserved for future use. | This bit is always 0.
1 | 2 | Reserved for future use. | This bit is always 0.
0 | 1 | Extension Bit | This bit is always 0.

Program Examples - STATus:OPERation:CALL:TA2000

OUTPUT 714;"STATUS:OPERATION:CALL:TA2000:EVENT?"
    !Queries the Operation Call TA2000 Event Register.
OUTPUT 714;"STATUS:OPERATION:CALL:TA2000:CONDITION?"
    !Queries the Operation Call TA2000Condition Register.
OUTPUT 714;"STATUS:OPERATION:CALL:TA2000:ENABLE 2"
    !Sets the Operation Call TA2000 Enable Register for bit 1.
OUTPUT 714;"STATUS:OPERATION:CALL:TA2000:NTR 4"
    !Sets the TA2000 Negative Transition Register for bit 2.
OUTPUT 714;"STATUS:OPERATION:CALL:TA2000:PTR 256"
    !Sets the TA2000 Positive Transition 	Register for bit 8.

STATus:OPERation:FEATures Register Bit Assignments

The STATus:OPERation:FEATures register bits are used to access miscellaneous Features Registers.

Bit Number | Binary Weighting | Condition | Description
15 | 32768 | Not Used. Defined by SCPI. | This bit is always 0.
14 | 16384 | Reserved for future use. | This bit is always 0.
13 | 8192 | Reserved for future use. | This bit is always 0.
12 | 4096 | Reserved for future use. | This bit is always 0.
11 | 2048 | Reserved for future use. | This bit is always 0.
10 | 1024 | Reserved for future use. | This bit is always 0.
9 | 512 | Reserved for future use. | This bit is always 0.
8 | 256 | Reserved for future use. | This bit is always 0.
7 | 128 | Reserved for future use. | This bit is always 0.
6 | 64 | Reserved for future use. | This bit is always 0.
5 | 32 | Reserved for future use. | This bit is always 0.
4 | 16 | Reserved for future use. | This bit is always 0.
3 | 8 | Reserved for future use. | This bit is always 0.
2 | 4 | Reserved for future use. | This bit is always 0.
1 | 2 | COMMon Summary Bit | This bit is the summary bit for the STATus:OPERation:FEATures:COMMon register. (see STATus:OPERation:FEATures:COMMon Register Bit Assignments )
0 | 1 | Extension Bit | This bit is always 0.

Program Examples - STATus:OPERation:FEATures

OUTPUT 714;"STATUS:OPERATION:FEATures:EVENT?"
    !Queries the Operation FEATures Event Register.
OUTPUT 714;"STATUS:OPERATION:FEATures:CONDITION?"
    !Queries the Operation FEATures Condition Register.
OUTPUT 714;"STATUS:OPERATION:FEATures:ENABLE 2"
    !Sets Operation FEATures Enable register for bit 1.
OUTPUT 714;"STATUS:OPERATION:FEATures:NTR 2"
    !Sets the Operation FEATures Negative Transition Register for bit 1.
OUTPUT 714;"STATUS:OPERATION:FEATures:PTR 4"
    !Sets the Operation FEATures Positive Transition Register for bit 2

STATus:OPERation:FEATures:COMMon Register Bit Assignments

The STATus:OPERation:FEATures:COMMon register bits indicate the status of processes that occur during SMS operations.

Bit Number | Binary Weighting | Condition | Description
15 | 32768 | Not Used. Defined by SCPI. | This bit is always 0.
14 | 16384 | DIGital856 Summary bit | This bit is the summary bit for the STATus:OPERation:FEATures:SMService:DIGital856 register.
13 | 8192 | TA856 Summary bit | This bit is the summary bit for the STATus:OPERation:FEATures:SMService:TA856 register.
12 | 4096 | GPRS Summary bit | This bit is the summary bit for the STATus:OPERation:FEATures:SMService:GPRS register.
11 | 2048 | WCDMa Summary bit | This bit is the summary bit for the STATus:OPERation:FEATures:SMService:WCDMa register.
10 | 1024 | FDD Summary bit | This bit is the summary bit for the STATus:OPERation:FEATures:SMService:FDD register.
9 | 512 | TA2000 Summary bit | This bit is the summary message bit for the STATus:OPERation:FEATures:SMService:TA2000 register.
8 | 256 | CDMA Summary bit | This bit is the summary message bit for the STATus:OPERation:FEATures:SMService:CDMA register.
7 | 128 | DIGital2000 Summary bit | This bit is the summary message bit for the STATus:OPERation:FEATures:SMService:DIGital2000 register.
6 | 64 | DIGital95 Summary bit | This bit is the summary message bit for the STATus:OPERation:FEATures:SMService:DIGital95 register.
5 | 32 | TA136 Summary bit | This bit is the summary message bit for the STATus:OPERation:FEATures:SMService:TA136 register.
4 | 16 | DIGITAL136 Summary bit | This bit is the summary message bit for the STATus:OPERation:FEATures:SMService:DIGITAL136 register.
3 | 8 | AMPS Summary bit | This bit is the summary message bit for the STATus:OPERation:FEATures:SMService:AMPS register.
2 | 4 | GSM Summary bit | This bit is the summary message bit for the STATus:OPERation:FEATures:SMService:GSM register.
1 | 2 | SMService Summary bit | This bit is the summary message bit for the STATus:OPERation:FEATures:COMMon:SMService register. (see STATus:OPERation:FEATures:COMMon:SMService Register Bit Assignments )
0 | 1 | Extension Bit | This bit is always 0.

Program Examples - STATus:OPERation:FEATures:COMMon

OUTPUT 714;"STATUS:OPERATION:FEATures:COMMon:EVENT?"
    !Queries the Operation FEATures SMService Event Register.
OUTPUT 714;"STATUS:OPERATION:FEATures:COMMon:CONDITION?"
    !Queries the Operation FEATures SMService Condition Register.
OUTPUT 714;"STATUS:OPERATION:FEATures:COMMon:ENABLE 2"
    !Sets Operation FEATures SMService Enable register for bit 1.
OUTPUT 714;"STATUS:OPERATION:FEATures:COMMon:NTR 2"
    !Sets the Operation FEATures SMService Negative Transition Register for bit 1.
OUTPUT 714;"STATUS:OPERATION:FEATures:COMMon:PTR 4"
    !Sets the Operation FEATures SMService Positive Transition Register for bit 2

STATus:OPERation:FEATures:COMMon:SMService Register Bit Assignments

The STATus:OPERation:FEATures:COMMon:SMService register bits indicate the status of processes that occur during SMS operations.

Bit Number | Binary Weighting | Condition | Description
15 | 32768 | Not Used. Defined by SCPI. | This bit is always 0.
14 | 16384 | Mobile-Originated Queue Overflow | This bit is a 1 when the Mobile-originated queue overflows. It's only for GPRS .
13 | 8192 | SMS Change Arm in use | This bit is a 1 when the SMS status change detector is armed, and is a 0 when disarmed. See SMS Status Change Detector .
12 | 4096 | SMS Send in progress | This bit is a 1 when the test set is in the Sending state (see SMS Status Description ).
11 | 2048 | Reserved for future use. | This bit is always 0.
10 | 1024 | Reserved for future use. | This bit is always 0.
9 | 512 | Reserved for future use. | This bit is always 0.
8 | 512 | Reserved for future use. | This bit is always 0.
7 | 128 | Mobile-Originated Message Received | This bit is a 1 when the test set's SMS operation is in the Received state (see SMS Status Description ).
6 | 64 | Reserved for future use. | This bit is always 0.
5 | 32 | Mobile-Terminated Message Rejected | This bit is a 1 when the test set's SMS operation is in the Rejected state. It's only for GPRS .
4 | 16 | Mobile-Terminated Broadcast Message Sent | This bit is a 1 when the test set's SMS operation is in the Broadcast Sent state (see SMS Status Description ).
3 | 8 | Mobile-Terminated Message Not Acknowledged | This bit is a 1 when the test set's SMS operation is in the MS Not Acknowledged state (see SMS Status Description ).
2 | 4 | Mobile-Terminated Message Acknowledged | This bit is a 1 when the test set's SMS operation is in the MS Ack state (see SMS Status Description .
1 | 2 | SMS Status Idle | This bit is a 1 when the test set's SMS operation is in the Idle state (see SMS Status Description ).
0 | 1 | Extension Bit | This bit is always 0.

Program Examples - STATus:OPERation:FEATures:COMMon:SMService

OUTPUT 714;"STATUS:OPERATION:FEATures:COMMon:SMService:EVENT?"
    !Queries the Operation FEATures SMService COMMon Event Register.
OUTPUT 714;"STATUS:OPERATION:FEATures:COMMon:SMService:CONDITION?"
    !Queries the Operation FEATures SMService COMMon Condition Register.
OUTPUT 714;"STATUS:OPERATION:FEATures:COMMon:SMService:ENABLE 2"
    !Sets Operation FEATures SMService COMMon Enable register for bit 1.
OUTPUT 714;"STATUS:OPERATION:FEATures:COMMon:SMService:NTR 2"
    !Sets the Operation FEATures SMService COMMon Negative Transition Register for bit 1.
OUTPUT 714;"STATUS:OPERATION:FEATures:COMMon:SMService:PTR 4"
    !Sets the Operation FEATures SMService COMMon Positive Transition Register for bit 2

STATus:OPERation:HARDware Condition Register Bit Assignments

The STATus:OPERation:HARDware register bits indicate when a softkey on the test set's front panel has been pressed while the test set is in remote operating mode.

Bit Number | Binary Weighting | Condition | Description
15 | 32768 | Not Used. Defined by SCPI. | This bit is always 0.
14 | 16384 | Reserved for future use. | This bit is always 0.
13 | 8192 | Reserved for future use. | This bit is always 0.
12 | 4096 | Reserved for future use. | This bit is always 0.
11 | 2048 | Reserved for future use. | This bit is always 0.
10 | 1024 | Reserved for future use. | This bit is always 0.
9 | 512 | Reserved for future use. | This bit is always 0.
8 | 256 | Reserved for future use. | This bit is always 0.
7 | 128 | Reserved for future use. | This bit is always 0.
6 | 64 | Reserved for future use. | This bit is always 0.
5 | 32 | Reserved for future use. | This bit is always 0.
4 | 16 | Reserved for future use. | This bit is always 0.
3 | 8 | Reserved for future use. | This bit is always 0.
2 | 4 | Reserved for future use. | This bit is always 0.
1 | 2 | External Timebase in use | This bit is a 1 if a suitable external timebase is connected to the test set's 10 MHz REF IN connector on the rear panel of the test set.
0 | 1 | Extension Bit | This bit is always 0.

Program Examples - STATus:OPERation:HARDware

OUTPUT 714;"STATUS:OPERATION:HARDware:EVENT?"
    !Queries the HARDware Event Register.
OUTPUT 714;"STATUS:OPERATION:HARDware:CONDITION?"
    !Queries the HARDware Condition Register.
OUTPUT 714;"STATUS:OPERATION:HARDware:ENABLE 16"
    !Sets HARDware Enable register for bit 4.
OUTPUT 714;"STATUS:OPERATION:HARDware:NTR 2"
    !Sets the HARDware Negative Transition Register for bit 1.
OUTPUT 714;"STATUS:OPERATION:HARDware:PTR 4"
    !Sets the HARDware Positive Transition Register for bit 2

STATus:OPERation:KEYPressed Register Bit Assignments

The STATus:OPERation:KEYPressed register bits indicate when a softkey on the test set's front panel has been pressed while the test set is in remote operating mode.

Bit Number | Binary Weighting | Condition | Description
15 | 32768 | Not Used. Defined by SCPI. | This bit is always 0.
14 | 16384 | Reserved for future use. | This bit is always 0.
13 | 8192 | Reserved for future use. | This bit is always 0.
12 | 4096 | Reserved for future use. | This bit is always 0.
11 | 2048 | F12 softkey | This bit is a 1 when the test set's F12 softkey has been pressed.
10 | 1024 | F11 softkey | This bit is a 1 when the test set's F11 softkey has been pressed.
9 | 512 | F10 softkey | This bit is a 1 when the test set's F10 softkey has been pressed.
8 | 256 | F9 softkey | This bit is a 1 when the test set's F9 softkey has been pressed.
7 | 128 | F8 softkey | This bit is a 1 when the test set's F8 softkey has been pressed.
6 | 64 | F7 softkey | This bit is a 1 when the test set's F7 softkey has been pressed.
5 | 32 | F6 softkey | This bit is a 1 when the test set's F6 softkey has been pressed.
4 | 16 | F5 softkey | This bit is a 1 when the test set's F5 softkey has been pressed.
3 | 8 | F4 softkey | This bit is a 1 when the test set's F4 softkey has been pressed.
2 | 4 | F3 softkey | This bit is a 1 when the test set's F3 softkey has been pressed.
1 | 2 | F2 softkey | This bit is a 1 when the test set's F2 softkey has been pressed.
0 | 1 | F1 softkey | This bit is a 1 when the test set's F1 softkey has been pressed.

Program Examples - STATus:OPERation:KEYPressed

OUTPUT 714;"STATUS:OPERATION:KEYPRESSED:EVENT?"
    !Queries the Keypressed Event Register.
OUTPUT 714;"STATUS:OPERATION:KEYPRESSED:CONDITION?"
    !Queries the Keypressed Condition Register.
OUTPUT 714;"STATUS:OPERATION:KEYPRESSED:ENABLE 16"
    !Sets Keypressed Enable register for bit 4.
OUTPUT 714;"STATUS:OPERATION:KEYPRESSED:NTR 2"
    !Sets the Keypressed Negative Transition Register for bit 1.
OUTPUT 714;"STATUS:OPERATION:KEYPRESSED:PTR 4"
    !Sets the Keypressed Positive Transition Register for bit 2

STATus:OPERation:NMRReady Register Bit Assignments

The STATus:OPERation:NMRReady register bits indicate when a measurement has been completed and new measurement results are available.

Bit Number | Binary Weighting | Condition | Description
15 | 32768 | Not Used. Defined by SCPI. | This bit is always 0.
14 | 16384 | DIGital856 | This bit is the summary bit for the STATus:OPERation:NMRReady:DIGital856 register.
13 | 8192 | TA856 | This bit is the summary bit for the STATus:OPERation:NMRReady:TA856 register.
12 | 4096 | GPRS | This bit is the summary bit for the STATus:OPERation:NMRReady:GPRS register.
11 | 2048 | WCDMa | This bit is the summary bit for the STATus:OPERation:NMRReady:WCDMa register.
10 | 1024 | FDD | This bit is the summary bit for the STATus:OPERation:NMRReady:FDD register.
9 | 512 | TA2000 Summary bit | This bit is the summary message bit for the STATus:OPERation:NMRReady:TA2000 register.
8 | 256 | CDMA Summary bit | This bit is the summary message bit for the STATus:OPERation:NMRReady:CDMA register.
7 | 128 | DIGital2000 Summary bit | This bit is the summary message bit for the STATus:OPERation:NMRReady:DIGital2000 register.
6 | 64 | DIGital95 Summary bit | This bit is the summary message bit for the STATus:OPERation:NMRReady:DIGital95 register.
5 | 32 | TA136 Summary bit | This bit is the summary message bit for the STATus:OPERation:NMRReady:TA136 register.
4 | 16 | DIGITAL136 Summary bit | This bit is the summary message bit for the STATus:OPERation:NMRReady:DIGITAL136 register.
3 | 8 | AMPS Summary bit | This bit is the summary message bit for the STATus:OPERation:NMRReady:AMPS register.
2 | 4 | GSM Summary bit | This bit is the summary message bit for the STATus:OPERation:NMRReady:GSM register.
1 | 2 | COMMON Summary bit | This bit is the summary message bit for the STATus:OPERation:NMRReady:COMMon register.
0 | 1 | Extension Bit | This bit is always 0.

Program Examples - STATus:OPERation:NMRReady

OUTPUT 714;"STATUS:OPERATION:NMRREADY:EVENT?" !Queries the New Measurement
                                              !Results Ready Event Register.
OUTPUT 714;"STATUS:OPERATION:NMRREADY:CONDITION?" !Queries the New Measurement
                                                  !Results Ready
                                                  !Condition Register.
OUTPUT 714;"STATUS:OPERATION:NMRREADY:ENABLE 16" !Sets New Measurement Results
                                                 !Ready Enable Regigter
                                                 !for bit 4.
OUTPUT 714;"STATUS:OPERATION:NMRREADY:NTR 2" !Sets the New Measurement Results
                                             !Ready Negative Transition
                                             !Register for bit 1.
OUTPUT 714;"STATUS:OPERATION:NMRREADY:PTR 4" !Sets the New Measurement
                                             !Results Ready Positive
                                             !Transition Register
                                             !for bit 2

STATus:OPERation:NMRReady:AMPS Condition Register Bit Assignment

The STATus:OPERation:NMRReady:AMPS register bits indicate when a measurement has been completed and new measurement results are available.

Bit Number | Binary Weighting | Condition | Description
15 | 32768 | Not Used. Defined by SCPI. | This bit is always 0.
14 | 16384 | Reserved for future use. | This bit is always 0.
13 | 8192 | Reserved for future use. | This bit is always 0.
12 | 4096 | Reserved for future use. | This bit is always 0.
11 | 2048 | Reserved for future use. | This bit is always 0.
10 | 1024 | Reserved for future use. | This bit is always 0.
9 | 512 | Reserved for future use. | This bit is always 0.
8 | 256 | Reserved for future use. | This bit is always 0.
7 | 128 | Reserved for future use. | This bit is always 0.
6 | 64 | Reserved for future use. | This bit is always 0.
5 | 32 | Reserved for future use. | This bit is always 0.
4 | 16 | Reserved for future use. | This bit is always 0.
3 | 8 | FM New Measurement Result Ready | This is a 1 if the measurement has been completed and has produced new results.
2 | 4 | FSTABility New Measurement Result Ready | This is a 1 if the measurement has been completed and has produced new results.
1 | 2 | ATXPower New Measurement Result Ready | This is a 1 if the measurement has been completed and has produced new results.
0 | 1 | Extension Bit | This bit is always 0.

Program Examples - STATus:OPERation:NMRReady:AMPS

OUTPUT 714;"STATUS:OPERATION:NMRREADY:AMPS:EVENT?" !Queries the New Measurement
                                              !Results Ready AMPS Event Register.
OUTPUT 714;"STATUS:OPERATION:NMRREADY:AMPS:CONDITION?" !Queries the New Measurement
                                                  !Results Ready AMPS Condition Register.
OUTPUT 714;"STATUS:OPERATION:NMRREADY:AMPS:ENABLE 8" !Sets New Measurement Results
                                                 !Ready AMPS Enable Regigter for bit 3.
OUTPUT 714;"STATUS:OPERATION:NMRREADY:AMPS:NTR 2" !Sets the New Measurement Results
                                             !Ready AMPS Negative Transition
                                             !Register for bit 1.
OUTPUT 714;"STATUS:OPERATION:NMRREADY:AMPS:PTR 4" !Sets the New Measurement
                                             !Results Ready AMPS Positive
                                             !Transition Register for bit 2

STATus:OPERation:NMRReady:CDMA Register Bit Assignments

The STATus:OPERation:NMRReady:CDMA register bits indicate when a measurement has been completed and new measurement results are available.

Bit Number

Binary Weighting

Condition

Description

15

32768

Not Used. Defined by SCPI.

This bit is always 0.

14

16384

Reserved for future use.

This bit is always 0.

13

8192

CFDTune New Measurement Result Ready.

This bit is a 1 if the Fast Device Tune measurement has completed and has produced new results.

This bit is a zero at power on, after a preset and while a measurement is in Measuring States. See Triggering of Measurements .

12

4096

CMAudio New Measurement Result Ready

This bit is a 1 if the Multi-Tone Audio measurement has completed and has produced new results.

This bit is a zero at power on, after a preset and while a measurement is in Measuring States. See Triggering of Measurements .

11

2048

CMMPower New Measurement Result Ready

This bit is a 1 if the Maximum/Minimum Power measurement has completed and has produced new results.

This bit is a zero at power on, after a preset and while a measurement is in Measuring States. See Triggering of Measurements .

10

1024

CTDPower New Measurement Result Ready

This bit is a 1 if the Tx Dynamic Power measurement has completed and has produced new results.

This bit is a zero at power on, after a preset and while a measurement is in Measuring States. See Triggering of Measurements .

9

512

GAPP New Measurement Result Ready

This bit is a 1 if the Graphical Access Probe Power measurement has completed and has produced new results.

This bit is a zero at power on, after a preset and while a measurement is in Measuring States. See Triggering of Measurements .

8

256

CTXSpurious New Measurement Result Ready

This bit is a 1 if the measurement has been completed and has produced new results.

This bit is a zero at power on, after a preset and while a measurement is in Measuring States. See Triggering of Measurements .

7

128

GPOWer New Measurement Result Ready

This bit is a 1 if the measurement has been completed and has produced new results.

This bit is a zero at power on, after a preset and while a measurement is in Measuring States. See Triggering of Measurements .

6

64

TROPower New Measurement Result Ready

This bit is a 1 if the measurement has been completed and has produced new results.

This bit is a zero at power on, after a preset and while a measurement is in Measuring States. See Triggering of Measurements .

5

32

CAPPower New Measurement Result Ready

This bit is a 1 if the measurement has been completed and has produced new results.

This bit is a zero at power on, after a preset and while a measurement is in Measuring States. See Triggering of Measurements .

4

16

CFERror New Measurement Result Ready

This bit is a 1 if the measurement has been completed and has produced new results.

This bit is a zero at power on, after a preset and while a measurement is in Measuring States. See Triggering of Measurements .

3

8

CPOWer New Measurement Result Ready

This bit is a 1 if the measurement has been completed and has produced new results.

This bit is a zero at power on, after a preset and while a measurement is in Measuring States. See Triggering of Measurements .

2

4

WQUality New Measurement Result Ready

This bit is a 1 if the measurement has been completed and has produced new results.

This bit is a zero at power on, after a preset and while a measurement is in Measuring States. See Triggering of Measurements .

1

2

DAPower New Measurement Result Ready

This bit is a 1 if the measurement has been completed and has produced new results.

This bit is a zero at power on, after a preset and while a measurement is in Measuring States. See Triggering of Measurements .

0

1

Extension Bit

This bit is always 0.

Program Examples - STATus:OPERation:NMRReady:CDMA

OUTPUT 714;"STATUS:OPERATION:NMRREADY:CDMA:EVENT?" !Queries the New Measurement
                                              !Results Ready CDMA Event Register.
OUTPUT 714;"STATUS:OPERATION:NMRREADY:CDMA:CONDITION?" !Queries the New Measurement
                                                  !Results Ready CDMA
                                                  !Condition Register.
OUTPUT 714;"STATUS:OPERATION:NMRREADY:CDMA:ENABLE 8" !Sets New Measurement Results
                                                 !Ready CDMA Enable Regigter
                                                 !for bit 3.
OUTPUT 714;"STATUS:OPERATION:NMRREADY:CDMA:NTR 2" !Sets the New Measurement Results
                                             !Ready CDMA Negative Transition
                                             !Register for bit 1.
OUTPUT 714;"STATUS:OPERATION:NMRREADY:CDMA:PTR 4" !Sets the New Measurement
                                             !Results Ready CDMA Positive
                                             !Transition Register
                                             !for bit 2

STATus:OPERation:NMRReady:COMMon Register Bit Assignments

The STATus:OPERation:NMRReady:COMMon register bits indicate when a measurement has been completed and new measurement results are available.

Bit Number | Binary Weighting | Condition | Description
15 | 32768 | Not Used. Defined by SCPI. | This bit is always 0.
14 | 16384 | Reserved for future use. | This bit is always 0.
13 | 8192 | Reserved for future use. | This bit is always 0.
12 | 4096 | Reserved for future use. | This bit is always 0.
11 | 2048 | Reserved for future use. | This bit is always 0.
10 | 1024 | Reserved for future use. | This bit is always 0.
9 | 512 | Reserved for future use. | This bit is always 0.
8 | 256 | Reserved for future use. | This bit is always 0.
7 | 128 | Reserved for future use. | This bit is always 0.
6 | 64 | Reserved for future use. | This bit is always 0.
5 | 32 | Reserved for future use. | This bit is always 0.
4 | 16 | Reserved for future use. | This bit is always 0.
3 | 8 | Spectrum Monitor New Measurement Result Ready | This bit is a 1 if the measurement has been completed and has produced new results. This bit is a zero at power on, after a preset and while a measurement is in Measuring States. See Triggering of Measurements .
2 | 4 | Reserved for future use. | This bit is always 0.
1 | 2 | Audio Analyzer New Measurement Result Ready | This bit is a 1 if the measurement has been completed and has produced new results. This bit is a zero at power on, after a preset and while a measurement is in Measuring States. See Triggering of Measurements .
0 | 1 | Extension Bit | This bit is always 0.

Program Examples - STATus:OPERation:NMRReady:COMMon

OUTPUT 714;"STATUS:OPERATION:NMRREADY:COMMON:EVENT?" !Queries the New Measurement
                                              !Results Ready Common Event Register.
OUTPUT 714;"STATUS:OPERATION:NMRREADY:COMMON:CONDITION?" !Queries the New Measurement
                                                  !Results Ready Common
                                                  !Condition Register.
OUTPUT 714;"STATUS:OPERATION:NMRREADY:COMMON:ENABLE 2" !Sets New Measurement Results
                                                 !Ready Common Enable Register
                                                 !for bit 1.

OUTPUT 714;"STATUS:OPERATION:NMRREADY:COMMON:NTR 2" !Sets the New Measurement Results
                                             !Ready Common Negative Transition
                                             !Register for bit 1.
OUTPUT 714;"STATUS:OPERATION:NMRREADY:COMMON:PTR 2" !Sets the New Measurement
                                             !Results Ready Common Positive
                                             !Transition Register
                                             !for bit 1

STATus:OPERation:NMRReady:DIGital2000 Register Bit Assignments

The STATus:OPERation:NMRReady:DIGital2000 register bits indicate when a measurement has been completed and new measurement results are available.

Bit Number | Binary Weighting | Condition | Description
15 | 32768 | Not Used. Defined by SCPI. | This bit is always 0.
14 | 16384 | Reserved for future use. | This bit is always 0.
13 | 8192 | Reserved for future use. | This bit is always 0.
12 | 4096 | Reserved for future use. | This bit is always 0.
11 | 2048 | Reserved for future use. | This bit is always 0.
10 | 1024 | Reserved for future use. | This bit is always 0.
9 | 512 | Reserved for future use. | This bit is always 0.
8 | 256 | Reserved for future use. | This bit is always 0.
7 | 128 | Reserved for future use. | This bit is always 0.
6 | 64 | Reserved for future use. | This bit is always 0.
5 | 32 | Reserved for future use. | This bit is always 0.
4 | 16 | Reserved for future use. | This bit is always 0.
3 | 8 | TFERror New Measurement Result Ready. | This bit is a 1 if the measurement has been completed and has produced new results. This bit is a zero at power on, after a preset and while a measurement is in Measuring States. See Triggering of Measurements .
2 | 4 | CCTPhase New Measurement Result Ready. | This bit is a 1 if the measurement has been completed and has produced new results. This bit is a zero at power on, after a preset and while a measurement is in Measuring States. See Triggering of Measurements .
1 | 2 | HWQuality New Measurement Result Ready. | This bit is a 1 if the measurement has been completed and has produced new results. This bit is a zero at power on, after a preset and while a measurement is in Measuring States. See Triggering of Measurements .
0 | 1 | Extension Bit | This bit is always 0.

Program Examples - STATus:OPERation:NMRReady:DIGital2000

OUTPUT 714;"STATUS:OPERATION:NMRREADY:DIGITAL2000:EVENT?" !Queries the New Measurement
                                              !Results Ready DIG2000 Event Register.
OUTPUT 714;"STATUS:OPERATION:NMRREADY:DIGITAL2000:CONDITION?" !Queries the New
                                                  !Measurement Results Ready DIG2000
                                                  !Condition Register.
OUTPUT 714;"STATUS:OPERATION:NMRREADY:DIGITAL2000:ENABLE 8" !Sets New Measurement Results
                                                 !Ready DIG2000 Enable Register
                                                 !for bit 3.
OUTPUT 714;"STATUS:OPERATION:NMRREADY:DIGITAL2000:NTR 2" !Sets the New Measurement Results
                                             !Ready DIG2000 Negative Transition
                                             !Register for bit 1.
OUTPUT 714;"STATUS:OPERATION:NMRREADY:DIGITAL2000:PTR 4" !Sets the New Measurement
                                             !Results Ready DIG2000 Positive
                                             !Transition Register
                                             !for bit 2


STATus:PRESet

STATus:PRESet

Last updated: June 7, 2007

GPIB Command Conventions

  • STATus:PRESet

STATus:PRESet

Function

Presets the status subsystem.

Presetting the status subsystem performs the following functions:

  • All enable registers are set to 0 (not enabled)
  • All Positive Transition Registers (PTR's) are set to 1 (positive transitions enabled).
  • All Negative Transition Registers (NTR's) are set to 0 (negative transitions disabled).


STATus:QUEStionable

STATus:QUEStionable

Last updated: June 7, 2007

GPIB Command Conventions

  • STATus:QUEStionable Condition Register Bit Assignment
  • STATus:QUEStionable:CALL Condition Register Bit Assignment
  • STATus:QUEStionable:CALL:CDMA Condition Register Bit Assignment
  • STATus:QUEStionable:CALL:TA2000 Condition Register Bit Assignment
  • STATus:QUEStionable:ERRors Condition Register Bit Assignment
  • STATus:QUEStionable:ERRors:AMPS Condition Register Bit Assignment
  • STATus:QUEStionable:ERRors:CDMA Register Bit Assignments
  • STATus:QUEStionable:ERRors:COMMon Register Bit Assignments
  • STATus:QUEStionable:ERRors:DIGital2000Condition Register Bit Assignment
  • STATus:QUEStionable:ERRors:DIGital95 Condition Register Bit Assignment
  • STATus:QUEStionable:ERRors:TA2000 Register Bit Assignments
  • STATus:QUEStionable:HARDware Condition Register Bit Assignment

STATus:QUEStionable Condition Register Bit Assignment

The STATus:QUEStionable register contains bits which give an indication that the data currently being acquired or generated is of questionable quality due to some condition affecting the functionality associated with that bit.

Bit Number | Binary Weighting | Condition | Description
15 | 32768 | Not Used. Defined by SCPI. | This bit is always 0.
14 | 16384 | Reserved for future use. | This bit is always 0
13 | 8192 | Reserved for future use. | This bit is always 0.
12 | 4096 | Reserved for future use. | This bit is always 0.
11 | 2048 | QUEStionable:HARDware summary | This bit is the summary message bit for the STATus:QUEStionable:HARDware register.
10 | 1024 | QUEStionable:CALL summary | This bit is the summary message bit for the STATus:QUEStionable:CALL register.
9 | 512 | Reserved for future use. | This bit is always 0.
8 | 256 | Reserved for future use. | This bit is always 0.
7 | 128 | Reserved for future use. | This bit is always 0.
6 | 64 | Reserved for future use. | This bit is always 0.
5 | 32 | Reserved for future use. | This bit is always 0.
4 | 16 | Reserved for future use. | This bit is always 0.
3 | 8 | Reserved for future use. | This bit is always 0.
2 | 4 | Reserved for future use. | This bit is always 0.
1 | 2 | QUEStionable:ERRors summary | This bit is the summary message bit for the STATus:QUEStionable:ERRors register.
0 | 1 | Reserved for future use. | This bit is always 0.

Program Example - STATus:QUEStionable Register Bit Assignments

OUTPUT 714;"STATUS:QUESTIONABLE:EVENT?" !Queries and clears the Questionable Event
                                        !Register
OUTPUT 714;"STATUS:QUESTIONABLE:CONDITION?" !Queries and clears the Questionable Condition
                                            !Register
OUTPUT 714;"STATUS:QUESTIONABLE:ENABLE 1024" !Sets the Questionable Enable Register
                                             !for bit 10
OUTPUT 714;"STATUS:QUESTIONABLE:NTRANSITION 2" !Sets the Questionable Negative
                                               !Transition Filter Register for bit 1
OUTPUT 714;"STATUS:QUESTIONABLE:PTRANSITION 2" !Sets the Questionable Positive
                                               !Transition Filter Register for bit 1

STATus:QUEStionable:CALL Condition Register Bit Assignment

The STATus:QUEStionable:CALL registers will contain information about which event(s) occurred during call processing that indicate what call processing procedure failed

Bit Number | Binary Weighting | Condition | Description
15 | 32768 | Not Used. Defined by SCPI. | This bit is always 0.
14 | 16384 | Reserved for future use. | This bit is always 0.
13 | 8192 | Reserved for future use. | This bit is always 0.
12 | 4096 | Reserved for future use. | This bit is always 0.
11 | 2048 | Reserved for future use. | This bit is always 0.
10 | 1024 | Reserved for future use. | This bit is always 0.
9 | 512 | TA2000 Summary bit | This bit is the summary message bit for the STATus:QUEStionable:CALL:TA2000 register.
8 | 256 | CDMA Summary bit | This bit is the summary message bit for the STATus:QUEStionable:CALL:CDMA register.
7 | 128 | DIGital2000 Summary bit | This bit is the summary message bit for the STATus:QUEStionable:ERRors:CALL:DIGital2000 register.
6 | 64 | DIGital95 Summary bit | This bit is the summary message bit for the STATus:QUEStionable:ERRors:CALL:DIGital95 register.
5 | 32 | TA136 Summary bit | This bit is the summary message bit for the STATus:QUEStionable:CALL:TA136 register.
4 | 16 | DIGital136 Summary bit | This bit is the summary message bit for the STATus:QUEStionable:CALL:DIGital136 register.
3 | 8 | AMPS Summary bit | This bit is the summary message bit for the STATus:QUEStionable:CALL:AMPS register.
2 | 4 | GSM Summary bit | This bit is the summary message bit for the STATus:QUEStionable:CALL:GSM register.
1 | 2 | COMMon Summary bit | This bit is the summary message bit for the STATus:QUEStionable:CALL:COMMon register.
0 | 1 | Extension Bit | This bit is always 0.

Program Example - STATus:QUEStionable:CALL Condition Register Bit Assignment

OUTPUT 714;"STATUS:QUESTIONABLE:CALL:EVENT?" !Queries and clears the Questionable
                                             !Call Event Register
OUTPUT 714;"STATUS:QUESTIONABLE:CALL:CONDITION?" !Queries and clears the Questionable
                                                 !Call Condition Register
OUTPUT 714;"STATUS:QUESTIONABLE:CALL:ENABLE 1024" !Sets the Questionable
                                                  !Call Enable Register for bit 10
OUTPUT 714;"STATUS:QUESTIONABLE:CALL:NTRANSITION 2" !Sets the Questionable Call
                                                    !Negative Transition Filter Register
                                                    !for bit 1
OUTPUT 714;"STATUS:QUESTIONABLE:CALL:PTRANSITION 2" !Sets the Questionable Call
                                                    !Positive Transition Filter Register
                                                    !for bit 1

STATus:QUEStionable:CALL:CDMA Condition Register Bit Assignment

The STATus:QUEStionable:CALL:CDMA registers will contain information about which event(s) occurred during call processing that indicate what call processing procedure failed

Bit Number | Binary Weighting | Condition | Description
15 | 32768 | Not Used. Defined by SCPI. | This bit is always 0.
14 | 16384 | MUI Maskable Message. |
13 | 8192 | Reserved for future use. | This bit is always 0.
12 | 4096 | Reserved for future use. | This bit is always 0.
11 | 2048 | Reserved for future use. | This bit is always 0.
10 | 1024 | Reserved for future use. | This bit is always 0
9 | 512 | Reserved for future use. | This bit is always 0.
8 | 256 | Reserved for future use. | This bit is always 0.
7 | 128 | Reserved for future use. | This bit is always 0.
6 | 64 | Reserved for future use. | This bit is always 0.
5 | 32 | Reserved for future use. | This bit is always 0.
4 | 16 | Call drop timer timed out. | This bit is a 1 after 250 consecutive bad frames are counted indicating that the reverse link is lost
3 | 8 | Service connect completion not received. | This bit is a 1 when the test set has not received a message from the MS that it has completed the change to a new Service Option or Radio Configuration.
2 | 4 | Service Option or Radio Configuration rejected by MS. | This bit is a 1 when the MS receives a Service Option or a Radio Configuration that it does not support.
1 | 2 | Traffic channel preamble not received. | This bit is a 1 if no preamble was received from the MS.
0 | 1 | Extension Bit. | This bit is always 0.

Program Example - STATus:QUEStionable:CALL:CDMA Register Bit Assignment

OUTPUT 714;"STATUS:QUESTIONABLE:CALL:CDMA:EVENT?"
    !Queries and clears the Questionable Call CDMA Event Register
OUTPUT 714;"STATUS:QUESTIONABLE:CALL:CDMA:CONDITION?"
    !Queries and clears the Questionable Call CDMA Condition Register
OUTPUT 714;"STATUS:QUESTIONABLE:CALL:CDMA:ENABLE 1024"
    !Sets the Questionable Call CDMA Enable Register for bit 10
OUTPUT 714;"STATUS:QUESTIONABLE:CALL:CDMA:NTRANSITION 2"
    !Sets the Questionable Call CDMA Negative Transition Filter Register !for bit 1
OUTPUT 714;"STATUS:QUESTIONABLE:CALL:CDMA:PTRANSITION 2"
    !Sets the Questionable Call CDMA Positive Transition Filter Registerfor bit 1

STATus:QUEStionable:CALL:TA2000 Condition Register Bit Assignment

The STATus:QUEStionable:CALL:TA2000 registers will contain information about which event(s) occurred during call processing that indicate what call processing procedure failed

Bit Number | Binary Weighting | Condition | Description
15 | 32768 | Not Used. Defined by SCPI. | This bit is always 0.
14 | 16384 | MUI Maskable Message. |
13 | 8192 | Reserved for future use. | This bit is always 0.
12 | 4096 | Reserved for future use. | This bit is always 0.
11 | 2048 | Reserved for future use. | This bit is always 0.
10 | 1024 | Reserved for future use. | This bit is always 0.
9 | 512 | Reserved for future use. | This bit is always 0.
8 | 256 | Reserved for future use. | This bit is always 0.
7 | 128 | Reserved for future use. | This bit is always 0.
6 | 64 | Reserved for future use. | This bit is always 0.
5 | 32 | Reserved for future use. | This bit is always 0.
4 | 16 | MS reject order received | This bit is a 1 if the Service Option or Radio Configuration change was rejected by the MS while connected.
3 | 8 | Carrier not detected on new channel | This bit is a 1 when no power is detected by the test set after a handoff or when making a call.
2 | 4 | Handoff completion not received | This bit is a 1 if the test set does not receive a handoff completion message from the MS.
1 | 2 | Release order not received | This bit is a 1 if the MS does not send the call release to the test set.
0 | 1 | Extension Bit | This bit is always 0.

Program Example - STATus:QUEStionable:CALL:TA2000 Register Bit Assignment

OUTPUT 714;"STATUS:QUESTIONABLE:CALL:TA2000:EVENT?"
    !Queries and clears the Questionable Call Event Register
OUTPUT 714;"STATUS:QUESTIONABLE:CALL:TA2000:CONDITION?"
    !Queries and clears the Questionable Call Condition Register
OUTPUT 714;"STATUS:QUESTIONABLE:CALL:TA2000:ENABLE 1024"
    !Sets the Questionable Call Enable Register for bit 10
OUTPUT 714;"STATUS:QUESTIONABLE:CALL:TA2000:NTRANSITION 2"
    !Sets the Questionable Call Negative Transition Filter Register for bit 1
OUTPUT 714;"STATUS:QUESTIONABLE:CALL:TA2000:PTRANSITION 2"
    !Sets the Questionable Call Positive Transition Filter Register for bit 1

STATus:QUEStionable:ERRors Condition Register Bit Assignment

The STATus:QUEStionable:ERRors register bits will be used to indicate information about test set device-specific errors (positive error numbers).

Bit Number | Binary Weighting | Condition | Description
15 | 32768 | Not Used. Defined by SCPI. | This bit is always 0.
14 | 16384 | Reserved for future use. | This bit is always 0.
13 | 8192 | Reserved for future use. | This bit is always 0.
12 | 4096 | Reserved for future use. | This bit is always 0.
11 | 2048 | Reserved for future use. | This bit is always 0.
10 | 1024 | Reserved for future use. | This bit is always 0.
9 | 512 | TA2000 Summary bit | This bit is the summary message bit for the STATus:QUEStionable:ERRors:TA2000 register.
8 | 256 | CDMA Summary bit | This bit is the summary message bit for the STATus:QUEStionable:ERRors:CDMA register.
7 | 128 | DIGital2000 Summary bit | This bit is the summary message bit for the STATus:QUEStionable:ERRors:DIGital2000 register.
6 | 64 | DIGital95 Summary bit | This bit is the summary message bit for the STATus:QUEStionable:ERRors:DIGital95 register.
5 | 32 | TA136 Summary bit | This bit is the summary message bit for the STATus:QUEStionable:ERRors:TA136 register.
4 | 16 | DIGital136 Summary bit | This bit is the summary message bit for the STATus:QUEStionable:ERRors:DIGital136 register.
3 | 8 | AMPS Summary bit | This bit is the summary message bit for the STATus:QUEStionable:ERRors:AMPS register.
2 | 4 | GSM Summary bit | This bit is the summary message bit for the STATus:QUEStionable:ERRors:GSM register.
1 | 2 | COMMon Summary bit | This bit is the summary message bit for the STATus:QUEStionable:CALL:ERRors register.
0 | 1 | Extension Bit | This bit is always 0.

Program Example - STATus:QUEStionable:ERRors Register Bit Assignments

OUTPUT 714;"STATUS:QUESTIONABLE:ERRORS:EVENT?" !Queries and clears the Questionable
                                               !Errors Event Register
OUTPUT 714;"STATUS:QUESTIONABLE:ERRORS:CONDITION?" !Queries and clears the Questionable
                                                   !Errors Condition Register
OUTPUT 714;"STATUS:QUESTIONABLE:ERRORS:ENABLE 1024" !Sets the Questionable
                                                    !Errors Enable
                                                    !Register for bit 10
OUTPUT 714;"STATUS:QUESTIONABLE:ERRORS:NTRANSITION 2" !Sets the Questionable Errors
                                                      !Negative Transition Filter Register
                                                      !for bit 1
OUTPUT 714;"STATUS:QUESTIONABLE:ERRORS:PTRANSITION 2" !Sets the Questionable Errors
                                                      !Positive Transition Filter Register
                                                      !for bit 1

STATus:QUEStionable:ERRors:AMPS Condition Register Bit Assignment

The STATus:QUEStionable:ERRors:AMPS register bits will be used to indicate information about AMPS related test set device-specific errors (positive error numbers).

Bit Number | Binary Weighting | Condition | Description
15 | 32768 | Not Used. Defined by SCPI. | This bit is always 0.
14 | 16384 | MUI Maskable Messages | This bit is a 1 when a Maskable Message has occurred. Maskable Messages are not displayed on the test set display.
13 | 8192 | Reserved for future use. | This bit is always 0.
12 | 4096 | Reserved for future use. | This bit is always 0.
11 | 2048 | Reserved for future use. | This bit is always 0.
10 | 1024 | Reserved for future use. | This bit is always 0.
9 | 512 | +900 Errors | The condition bit is pulsed to a 1 and immediately back to 0 if an error in the +900 to +999 range occurs. After setting the Positive Transition Filter and the Negative Transition Filter you can query the Event Register to find out which of these errors occurred.
8 | 256 | +800 Errors | The condition bit is pulsed to a 1 and immediately back to 0 if an error in the +800 to +899 range occurs. After setting the Positive Transition Filter and the Negative Transition Filter you can query the Event Register to find out which of these errors occurred.
7 | 128 | +700 Errors | The condition bit is pulsed to a 1 and immediately back to 0 if an error in the +700 to +799 range occurs. After setting the Positive Transition Filter and the Negative Transition Filter you can query the Event Register to find out which of these errors occurred.
6 | 64 | +600 Errors | The condition bit is pulsed to a 1 and immediately back to 0 if an error in the +600 to +699 range occurs. After setting the Positive Transition Filter and the Negative Transition Filter you can query the Event Register to find out which of these errors occurred.
5 | 32 | +500 Errors | The condition bit is pulsed to a 1 and immediately back to 0 if an error in the +500 to +599 range occurs. After setting the Positive Transition Filter and the Negative Transition Filter you can query the Event Register to find out which of these errors occurred.
4 | 16 | +400 Errors | The condition bit is pulsed to a 1 and immediately back to 0 if an error in the +400 to +499 range occurs. After setting the Positive Transition Filter and the Negative Transition Filter you can query the Event Register to find out which of these errors occurred.
3 | 8 | +300 Errors | The condition bit is pulsed to a 1 and immediately back to 0 if an error in the +300 to +399 range occurs. After setting the Positive Transition Filter and the Negative Transition Filter you can query the Event Register to find out which of these errors occurred.
2 | 4 | +200 Errors | The condition bit is pulsed to a 1 and immediately back to 0 if an error in the +200 to +299 range occurs. After setting the Positive Transition Filter and the Negative Transition Filter you can query the Event Register to find out which of these errors occurred.
1 | 2 | +100 Errors | The condition is be pulsed to a 1 and immediately back to 0 if an error in the +100 to +199 range occurs. After setting the Positive Transition Filter and the Negative Transition Filter you can query the Event Register to find out which of these errors occurred.
0 | 1 | Extension Bit | This bit is always 0.

Program Example - STATus:QUEStionable:ERRors:AMPS Condition Register Bit Assignment

OUTPUT 714;"STATUS:QUESTIONABLE:ERRORS:AMPS:EVENT?" !Queries and clears the Questionable
                                                    !Errors AMPS Event Register
OUTPUT 714;"STATUS:QUESTIONABLE:ERRORS:AMPS:CONDITION?" !Queries and clears the Questionable
                                                        !Errors AMPS Condition Register
OUTPUT 714;"STATUS:QUESTIONABLE:ERRORS:AMPS:ENABLE 1024" !Sets the Questionable
                                                         !Errors AMPS Enable
                                                         !Register for bit 10
OUTPUT 714;"STATUS:QUESTIONABLE:ERRORS:AMPS:NTRANSITION 2" !Sets the Questionable Errors
                                                           !AMPS Negative Transition
                                                           !Filter Register for bit 1
OUTPUT 714;"STATUS:QUESTIONABLE:ERRORS:AMPS:PTRANSITION 2" !Sets the Questionable Errors
                                                           !AMPS Positive Tranasition
                                                           !Filter Register for bit 1

STATus:QUEStionable:ERRors:CDMA Register Bit Assignments

The STATus:QUEStionable:ERRors:CDMA register bits will be used to indicate information about CDMA related test set device-specific errors (positive error numbers).

Bit Number | Binary Weighting | Condition | Description
15 | 32768 | Not Used. Defined by SCPI. | This bit is always 0.
14 | 16384 | MUI Maskable Message. |
13 | 8192 | Reserved for future use. | This bit is always 0.
12 | 4096 | Reserved for future use. | This bit is always 0.
11 | 2048 | Reserved for future use. | This bit is always 0.
10 | 1024 | Reserved for future use. | This bit is always 0.
9 | 512 | +900 Errors | The condition bit is pulsed to a 1 and immediately back to 0 if an error in the +900 to +999 range occurs. After setting the Positive Transition Filter and the Negative Transition Filter you can query the Event Register to find out which of these errors occurred.
8 | 256 | +800 Errors | The condition bit is pulsed to a 1 and immediately back to 0 if an error in the +800 to +899 range occurs. After setting the Positive Transition Filter and the Negative Transition Filter you can query the Event Register to find out which of these errors occurred.
7 | 128 | +700 Errors | The condition bit will be pulsed to a 1 and immediately back to 0 if an error in the +700 to +799 range occurs. After setting the Positive Transition Filter and the Negative Transition Filter you may query the Event Register to find out which of these errors occurred.
6 | 64 | +600 Errors | The condition bit is pulsed to a 1 and immediately back to 0 if an error in the +600 to +699 range occurs. After setting the Positive Transition Filter and the Negative Transition Filter you can query the Event Register to find out which of these errors occurred.
5 | 32 | +500 Errors | The condition bit is pulsed to a 1 and immediately back to 0 if an error in the +500 to +599 range occurs. After setting the Positive Transition Filter and the Negative Transition Filter you can query the Event Register to find out which of these errors occurred.
4 | 16 | +400 Errors | The condition bit is pulsed to a 1 and immediately back to 0 if an error in the +400 to +499 range occurs. After setting the Positive Transition Filter and the Negative Transition Filter you can query the Event Register to find out which of these errors occurred.
3 | 8 | +300 Errors | The condition bit is pulsed to a 1 and immediately back to 0 if an error in the +300 to +399 range occurs. After setting the Positive Transition Filter and the Negative Transition Filter you can query the Event Register to find out which of these errors occurred.
2 | 4 | +200 Errors | The condition bit is pulsed to a 1 and immediately back to 0 if an error in the +200 to +299 range occurs. After setting the Positive Transition Filter and the Negative Transition Filter you can query the Event Register to find out which of these errors occurred.
1 | 2 | +100 Errors | The condition bit is pulsed to a 1 and immediately back to 0 if an error in the +100 to +199 range occurs. After setting the Positive Transition Filter and the Negative Transition Filter you can query the Event Register to find out which of these errors occurred.
0 | 1 | Extension Bit | This bit is always 0.

Program Example - STATus:QUEStionable:ERRors:CDMA Condition Register Bit Assignment

OUTPUT 714;"STATUS:QUESTIONABLE:ERRORS:CDMA:EVENT?" !Queries and clears the Questionable
                                                    !Errors CDMA Event Register
OUTPUT 714;"STATUS:QUESTIONABLE:ERRORS:CDMA:CONDITION?" !Queries and clears the Questionable
                                                        !Errors CDMA Condition Register
OUTPUT 714;"STATUS:QUESTIONABLE:ERRORS:CDMA:ENABLE 1024" !Sets the Questionable
                                                         !Errors CDMA Enable
                                                         !Register for bit 10
OUTPUT 714;"STATUS:QUESTIONABLE:ERRORS:CDMA:NTRANSITION 2" !Sets the Questionable Errors
                                                           !CDMA Negative Transition
                                                           !Filter Register for bit 1
OUTPUT 714;"STATUS:QUESTIONABLE:ERRORS:CDMA:PTRANSITION 2" !Sets the Questionable Errors
                                                           !CDMA Positive Tranasition
                                                           !Filter Register for bit 1

STATus:QUEStionable:ERRors:COMMon Register Bit Assignments

The STATus:QUEStionable:ERRors:COMMon register bits will be used to indicate information about the COMMon test set device-specific errors (positive error numbers).

Bit Number | Binary Weighting | Condition | Description
15 | 32768 | Not Used. Defined by SCPI. | This bit is always 0.
14 | 16384 | Reserved for future use. | This bit is always 0.
13 | 8192 | Reserved for future use. | This bit is always 0.
12 | 4096 | Reserved for future use. | This bit is always 0.
11 | 2048 | Reserved for future use. | This bit is always 0.
10 | 1024 | Reserved for future use. | This bit is always 0.
9 | 512 | +900 Errors | The condition bit is pulsed to a 1 and immediately back to 0 if an error in the +900 to +999 range occurs. After setting the Positive Transition Filter and the Negative Transition Filter you can query the Event Register to find out which of these errors occurred.
8 | 256 | +800 Errors | The condition bit is pulsed to a 1 and immediately back to 0 if an error in the +800 to +899 range occurs. After setting the Positive Transition Filter and the Negative Transition Filter you can query the Event Register to find out which of these errors occurred.
7 | 128 | +700 Errors | The condition bit is pulsed to a 1 and immediately back to 0 if an error in the +700 to +799 range occurs. After setting the Positive Transition Filter and the Negative Transition Filter you can query the Event Register to find out which of these errors occurred.
6 | 64 | +600 Errors | The condition bit is pulsed to a 1 and immediately back to 0 if an error in the +600 to +699 range occurs. After setting the Positive Transition Filter and the Negative Transition Filter you can query the Event Register to find out which of these errors occurred.
5 | 32 | +500 Errors | The condition bit is pulsed to a 1 and immediately back to 0 if an error in the +500 to +599 range occurs. After setting the Positive Transition Filter and the Negative Transition Filter you can query the Event Register to find out which of these errors occurred.
4 | 16 | +400 Errors | The condition bit is pulsed to a 1 and immediately back to 0 if an error in the +400 to +499 range occurs. After setting the Positive Transition Filter and the Negative Transition Filter you can query the Event Register to find out which of these errors occurred.
3 | 8 | +300 Errors | The condition bit is pulsed to a 1 and immediately back to 0 if an error in the +300 to +399 range occurs. After setting the Positive Transition Filter and the Negative Transition Filter you can query the Event Register to find out which of these errors occurred.
2 | 4 | +200 Errors | The condition bit is pulsed to a 1 and immediately back to 0 if an error in the +200 to +299 range occurs. After setting the Positive Transition Filter and the Negative Transition Filter you can query the Event Register to find out which of these errors occurred.
1 | 2 | +100 Errors | The condition bit is pulsed to a 1 and immediately back to 0 if an error in the +100 to +199 range occurs. After setting the Positive Transition Filter and the Negative Transition Filter you can query the Event Register to find out which of these errors occurred.
0 | 1 | Extension Bit | This bit is always 0.

Program Example - STATus:QUEStionable:ERRors:COMMon Register Bit Assignments

OUTPUT 714;"STATUS:QUESTIONABLE:ERRORS:COMMON:EVENT?" !Queries and clears the Questionable
                                                      !Errors Common Event Register
OUTPUT 714;"STATUS:QUESTIONABLE:ERRORS:COMMON:CONDITION?" !Queries the and clears the
                                                          !Questionable Errors
                                                          !Common Condition Register
OUTPUT 714;"STATUS:QUESTIONABLE:ERRORS:COMMON:ENABLE 1024" !Sets the Questionable
                                                           !Errors Common Enable
                                                           !Register for bit 10
OUTPUT 714;"STATUS:QUESTIONABLE:ERRORS:COMMON:NTRANSITION 2" !Sets the Questionable Errors
                                                             !Common Negative Transition
                                                             !Register for bit 1
OUTPUT 714;"STATUS:QUESTIONABLE:ERRORS:COMMON:PTRANSITION 2" !Sets the Questionable Errors
                                                             !Common Positive Tranasition
                                                             !Register for bit 1

STATus:QUEStionable:ERRors:DIGital2000Condition Register Bit Assignment

The STATus:QUEStionable:ERRors:DIGital2000 register bits will be used to indicate information about DIGital2000 related test set device-specific errors (positive error numbers).

Bit Number | Binary Weighting | Condition | Description
15 | 32768 | Not Used. Defined by SCPI. | This bit is always 0.
14 | 16384 | MUI Maskable Message. |
13 | 8192 | Reserved for future use. | This bit is always 0.
12 | 4096 | Reserved for future use. | This bit is always 0.
11 | 2048 | Reserved for future use. | This bit is always 0.
10 | 1024 | Reserved for future use. | This bit is always 0.
9 | 512 | +900 Errors | The condition bit is pulsed to a 1 and immediately back to 0 if an error in the +900 to +999 range occurs. After setting the Positive Transition Filter and the Negative Transition Filter you can query the Event Register to find out which of these errors occurred.
8 | 256 | +800 Errors | The condition bit is pulsed to a 1 and immediately back to 0 if an error in the +800 to +899 range occurs. After setting the Positive Transition Filter and the Negative Transition Filter you can query the Event Register to find out which of these errors occurred.
7 | 128 | +700 Errors | The condition bit is pulsed to a 1 and immediately back to 0 if an error in the +700 to +799 range occurs. After setting the Positive Transition Filter and the Negative Transition Filter you can query the Event Register to find out which of these errors occurred.
6 | 64 | +600 Errors | The condition bit is pulsed to a 1 and immediately back to 0 if an error in the +600 to +699 range occurs. After setting the Positive Transition Filter and the Negative Transition Filter you can query the Event Register to find out which of these errors occurred.
5 | 32 | +500 Errors | The condition bit is pulsed to a 1 and immediately back to 0 if an error in the +500 to +599 range occurs. After setting the Positive Transition Filter and the Negative Transition Filter you can query the Event Register to find out which of these errors occurred.
4 | 16 | +400 Errors | The condition bit is pulsed to a 1 and immediately back to 0 if an error in the +400 to +499 range occurs. After setting the Positive Transition Filter and the Negative Transition Filter you can query the Event Register to find out which of these errors occurred.
3 | 8 | +300 Errors | The condition bit is pulsed to a 1 and immediately back to 0 if an error in the +300 to +399 range occurs. After setting the Positive Transition Filter and the Negative Transition Filter you can query the Event Register to find out which of these errors occurred.
2 | 4 | +200 Errors | The condition bit is pulsed to a 1 and immediately back to 0 if an error in the +200 to +299 range occurs. After setting the Positive Transition Filter and the Negative Transition Filter you can query the Event Register to find out which of these errors occurred.
1 | 2 | +100 Errors | The condition bit is pulsed to a 1 and immediately back to 0 if an error in the +100 to +199 range occurs. After setting the Positive Transition Filter and the Negative Transition Filter you can query the Event Register to find out which of these errors occurred.
0 | 1 | Extension Bit | This bit will always be 0.

Program Example - STATus:QUEStionable:ERRors:DIGital2000 Condition Register Bit Assignment

OUTPUT 714;"STATUS:QUESTIONABLE:ERRORS:DIGITAL2000:EVENT?" !Queries and clears the
                                                     !Questionable Errors
                                                     !DIGITAL2000 Event Register
OUTPUT 714;"STATUS:QUESTIONABLE:ERRORS:DIGITAL2000:CONDITION?" !Queries and clears the
                                                         !Qestionable Errors
                                                         !DIGITAL2000 Condition Register
OUTPUT 714;"STATUS:QUESTIONABLE:ERRORS:DIGITAL2000:ENABLE 1024" !Sets the Questionable
                                                          !Errors DIGITAL2000 Enable
                                                          !Register for bit 10
OUTPUT 714;"STATUS:QUESTIONABLE:ERRORS:DIGITAL2000:NTRANSITION 2" !Sets the Questionable
                                                            !Errors DIGITAL2000 Negative
                                                            !Transition Filter
                                                            !Register for bit 1
OUTPUT 714;"STATUS:QUESTIONABLE:ERRORS:DIGITAL2000:PTRANSITION 2" !Sets the Questionable
                                                            !Errors DIGITAL2000 Positive
                                                            !Transition Filter
                                                            !Register for bit 1

STATus:QUEStionable:ERRors:DIGital95 Condition Register Bit Assignment

The STATus:QUEStionable:ERRors:DIGital95 register bits will be used to indicate information about DIGital95 related test set device-specific errors (positive error numbers).

Bit Number | Binary Weighting | Condition | Description
15 | 32768 | Not Used. Defined by SCPI. | This bit is always 0.
14 | 16384 | MUI Maskable Message. |
13 | 8192 | Reserved for future use. | This bit is always 0.
12 | 4096 | Reserved for future use. | This bit is always 0.
11 | 2048 | Reserved for future use. | This bit is always 0.
10 | 1024 | Reserved for future use. | This bit is always 0.
9 | 512 | +900 Errors | The condition bit is pulsed to a 1 and immediately back to 0 if an error in the +900 to +999 range occurs. After setting the Positive Transition Filter and the Negative Transition Filter you can query the Event Register to find out which of these errors occurred.
8 | 256 | +800 Errors | The condition bit is pulsed to a 1 and immediately back to 0 if an error in the +800 to +899 range occurs. After setting the Positive Transition Filter and the Negative Transition Filter you can query the Event Register to find out which of these errors occurred.
7 | 128 | +700 Errors | The condition bit is pulsed to a 1 and immediately back to 0 if an error in the +700 to +799 range occurs. After setting the Positive Transition Filter and the Negative Transition Filter you can query the Event Register to find out which of these errors occurred.
6 | 64 | +600 Errors | The condition bit is pulsed to a 1 and immediately back to 0 if an error in the +600 to +699 range occurs. After setting the Positive Transition Filter and the Negative Transition Filter you can query the Event Register to find out which of these errors occurred.
5 | 32 | +500 Errors | The condition bit is pulsed to a 1 and immediately back to 0 if an error in the +500 to +599 range occurs. After setting the Positive Transition Filter and the Negative Transition Filter you can query the Event Register to find out which of these errors occurred.
4 | 16 | +400 Errors | The condition bit is pulsed to a 1 and immediately back to 0 if an error in the +400 to +499 range occurs. After setting the Positive Transition Filter and the Negative Transition Filter you can query the Event Register to find out which of these errors occurred.
3 | 8 | +300 Errors | The condition bit is pulsed to a 1 and immediately back to 0 if an error in the +300 to +399 range occurs. After setting the Positive Transition Filter and the Negative Transition Filter you can query the Event Register to find out which of these errors occurred.
2 | 4 | +200 Errors | The condition bit is pulsed to a 1 and immediately back to 0 if an error in the +200 to +299 range occurs. After setting the Positive Transition Filter and the Negative Transition Filter you can query the Event Register to find out which of these errors occurred.
1 | 2 | +100 Errors | The condition bit is pulsed to a 1 and immediately back to 0 if an error in the +100 to +199 range occurs. After setting the Positive Transition Filter and the Negative Transition Filter you can query the Event Register to find out which of these errors occurred.
0 | 1 | Extension Bit | This bit will always be 0.

Program Example - STATus:QUEStionable:ERRors:DIGital95 Condition Register Bit Assignment

OUTPUT 714;"STATUS:QUESTIONABLE:ERRORS:DIGITAL95:EVENT?" !Queries and clears the
                                                     !Questionable Errors
                                                     !DIGITAL95 Event Register
OUTPUT 714;"STATUS:QUESTIONABLE:ERRORS:DIGITAL95:CONDITION?" !Queries and clears the
                                                         !Qestionable Errors
                                                         !DIGITAL95 Condition Register
OUTPUT 714;"STATUS:QUESTIONABLE:ERRORS:DIGITAL95:ENABLE 1024" !Sets the Questionable
                                                          !Errors DIGITAL95 Enable
                                                          !Register for bit 10
OUTPUT 714;"STATUS:QUESTIONABLE:ERRORS:DIGITAL95:NTRANSITION 2" !Sets the Questionable
                                                            !Errors DIGITAL95 Negative
                                                            !Transition Filter
                                                            !Register for bit 1
OUTPUT 714;"STATUS:QUESTIONABLE:ERRORS:DIGITAL95:PTRANSITION 2" !Sets the Questionable
                                                            !Errors DIGITAL95 Positive
                                                            !Transition Filter
                                                            !Register for bit 1

STATus:QUEStionable:ERRors:TA2000 Register Bit Assignments

The STATus:QUEStionable:ERRors:TA2000 register bits will be used to indicate information about TA2000 related test set device-specific errors (positive error numbers).

Bit Number | Binary Weighting | Condition | Description
15 | 32768 | Not Used. Defined by SCPI. | This bit is always 0.
14 | 16384 | MUI Maskable Message. |
13 | 8192 | Reserved for future use. | This bit is always 0.
12 | 4096 | Reserved for future use. | This bit is always 0.
11 | 2048 | Reserved for future use. | This bit is always 0.
10 | 1024 | Reserved for future use. | This bit is always 0.
9 | 512 | +900 Errors | The condition bit is pulsed to a 1 and immediately back to 0 if an error in the +900 to +999 range occurs. After setting the Positive Transition Filter and the Negative Transition Filter you can query the Event Register to find out which of these errors occurred.
8 | 256 | +800 Errors | The condition bit is pulsed to a 1 and immediately back to 0 if an error in the +800 to +899 range occurs. After setting the Positive Transition Filter and the Negative Transition Filter you can query the Event Register to find out which of these errors occurred.
7 | 128 | +700 Errors | The condition bit is pulsed to a 1 and immediately back to 0 if an error in the +700 to +799 range occurs. After setting the Positive Transition Filter and the Negative Transition Filter you can query the Event Register to find out which of these errors occurred.
6 | 64 | +600 Errors | The condition bit is pulsed to a 1 and immediately back to 0 if an error in the +600 to +699 range occurs. After setting the Positive Transition Filter and the Negative Transition Filter you can query the Event Register to find out which of these errors occurred.
5 | 32 | +500 Errors | The condition bit is pulsed to a 1 and immediately back to 0 if an error in the +500 to +599 range occurs. After setting the Positive Transition Filter and the Negative Transition Filter you can query the Event Register to find out which of these errors occurred.
4 | 16 | +400 Errors | The condition bit is pulsed to a 1 and immediately back to 0 if an error in the +400 to +499 range occurs. Query the Event Register to find out if one of these errors occurred.
3 | 8 | +300 Errors | The condition bit is pulsed to a 1 and immediately back to 0 if an error in the +300 to +399 range occurs. After setting the Positive Transition Filter and the Negative Transition Filter you can query the Event Register to find out which of these errors occurred.
2 | 4 | +200 Errors | The condition bit is pulsed to a 1 and immediately back to 0 if an error in the +200 to +299 range occurs. After setting the Positive Transition Filter and the Negative Transition Filter you can query the Event Register to find out which of these errors occurred.
1 | 2 | +100 Errors | The condition bit is pulsed to a 1 and immediately back to 0 if an error in the +100 to +199 range occurs. After setting the Positive Transition Filter and the Negative Transition Filter you can query the Event Register to find out which of these errors occurred.
0 | 1 | Extension Bit | This bit is always 0.

Program Example - STATus:QUEStionable:ERRors:TA2000 Condition Register Bit Assignment

OUTPUT 714;"STATUS:QUESTIONABLE:ERRORS:TA2000:EVENT?" !Queries and clears the
                                                          !Questionable Errors
                                                          !TA2000 Event Register
OUTPUT 714;"STATUS:QUESTIONABLE:ERRORS:TA2000:CONDITION?" !Queries and clears the
                                                              !Qestionable Errors
                                                              !TA2000 Condition Register
OUTPUT 714;"STATUS:QUESTIONABLE:ERRORS:TA2000:ENABLE 1024" !Sets the Questionable
                                                               !Errors TA2000 Enable
                                                               !Register for bit 10
OUTPUT 714;"STATUS:QUESTIONABLE:ERRORS:TA2000:NTRANSITION 2" !Sets the Questionable
                                                                 !Errors TA2000 Negative
                                                                 !Transition Filter
                                                                 !Register for bit 1
OUTPUT 714;"STATUS:QUESTIONABLE:ERRORS:TA2000:PTRANSITION 2" !Sets the Questionable
                                                                 !Errors TA2000 Positive
                                                                 !Transition Filter
                                                                 !Register for bit 1

STATus:QUEStionable:HARDware Condition Register Bit Assignment

The STATus:QUEStionable:HARDware register bits give an indication that the data/signals currently being acquired or generated are of questionable quality.

Bit Number | Binary Weighting | Condition | Description
15 | 32768 | Not Used. Defined by SCPI. | This bit is always 0.
14 | 16384 | Reserved for future use. | This bit is always 0.
13 | 8192 | Reserved for future use. | This bit is always 0.
12 | 4096 | Reserved for future use. | This bit will always be 0.
11 | 2048 | Reserved for future use. | This bit will always be 0.
10 | 1024 | Reserved for future use. | This bit will always be 0.
9 | 512 | Reserved for future use. | This bit will always be 0.
8 | 256 | Reserved for future use. | This bit will always be 0.
7 | 128 | Reserved for future use. | This bit will always be 0.
6 | 64 | Reserved for future use. | This bit will always be 0.
5 | 32 | Reserved for future use. | This bit will always be 0.
4 | 16 | Power-up Self Test(s) Failed | This bit will be a 1 if the power-up self tests failed.
3 | 8 | Reserved for future use. | This bit will always be 0.
2 | 4 | Reserved for future use. | This bit will always be 0.
1 | 2 | Reserved for future use. | This bit will always be 0.
0 | 1 | Extension Bit. | This bit will always be 0.

Program Example - STATus:QUEStionable:HARDware Condition Register Bit Assignment

OUTPUT 714;"STATUS:QUESTIONABLE:HARDWARE:EVENT?" !Queries and clears the Questionable
                                                 !Hardware Event Register
OUTPUT 714;"STATUS:QUESTIONABLE:HARDWARE:CONDITION?" !Queries and clears the Questionable
                                                     !Hardware Condition Register
OUTPUT 714;"STATUS:QUESTIONABLE:HARDWARE:ENABLE 1024" !Sets the Questionable
                                                      !Hardware Enable
                                                      !Register for bit 10
OUTPUT 714;"STATUS:QUESTIONABLE:HARDWARE:NTRANSITION 2" !Sets the Questionable
                                                        !Hardware Negative Transition Filter
                                                        !Register for bit 1
OUTPUT 714;"STATUS:QUESTIONABLE:HARDWARE:PTRANSITION 2" !Sets the Questionable
                                                        !Hardware Positive Transition Filter
                                                        !Register for bit 1


Status Byte Register

Status Byte Register

Last updated: June 11, 2007

  • *STB?

*STB?

NOTE
The Status Byte Register can also be read with a serial poll. For example, the command "Status_byte = SPOLL(714)" would perform a serial poll of the Status Byte Register, returning and releasing RQS (bit 6).

Status Byte Register Bit Assignments

Bit Number | Binary Weighting | Label | Description
7 | 128 | STATus: OPERation | Summarizes the STATus: OPERationStatus Register, which fans out to theNMRReady and CALL Status Registers.
6 | 64 | RQS (SRQ TRUE?)/Master Summary Status | RQS is read by a serial poll (SPOLL)Master Summary Status is read by a *STB? query - defined by IEEE 488.2
5 | 32 | Standard Event Status Register | Summarizes the Standard Event Status Register
4 | 16 | Message Available | SCPI - Defined
3 | 8 | STATus: QUEStionableStatus Register | Summary Message comes from theSTATus: QUEStionable Status Register,which fans out to the CALL andHARDware Status Registers
2 | 4 | Error/ Event Queue | SCPI - Defined
1 | 2 | Reserved |
0 | 1 | Reserved |

Program Example - Status Byte Register Bit Assignments

OUTPUT 714;"*STB?" !Queries the Status Byte.


Standard Event Status Register

Standard Event Status Register

Last updated: June 11, 2007

*ESR?

*ESE?

*ESE

GPIB Command Conventions

Standard Event Status Register Bit Assignment

Bit Number

Binary Weighting

Condition

Description

15

32768

Reserved by IEEE.

This bit will always be 0.

14

16384

Reserved by IEEE.

This bit will always be 0.

13

8192

Reserved by IEEE.

This bit will always be 0.

12

4096

Reserved by IEEE.

This bit will always be 0.

11

2048

Reserved by IEEE.

This bit will always be 0.

10

1024

Reserved by IEEE.

This bit will always be 0.

9

512

Reserved by IEEE.

This bit will always be 0.

8

256

Reserved by IEEE.

This bit will always be 0.

7

128

Power On

This bit is set to 1 if the power supply has been turned off and on since the last time this register was read or otherwise cleared. Defined in "IEEE Std. 488.2-1992",11.5.1.1.2

6

64

Reserved for future use.

This bit will always be 0.

5

32

Command Error

This bit is set to 1 if the test set detects an error while trying to process a command. The following events cause a command error:

  • An IEEE 488.2 syntax error. The test set received a message that did not follow the syntax defined by the standard.

  • A semantic error. For example the test set received an incorrectly spelled command.

  • The test set received a group execution trigger (GET) inside a program message

4

16

Execution Error

This bit is set to 1 if the test set detects an error while trying to execute a command. The following events cause a execution error:

  • A <PROGRAM DATA> element received in a command is outside the legal range for the test set, or it is inconsistent with the operation of the test set.

  • The test set could not execute a valid command due to some test set hardware/firmware condition.

3

8

Device Dependent Error

This bit is set to 1 if a test set operation does not execute properly due to an internal condition (such as, overrange). This bit indicates that the error was not a command, query, or execution error.

2

4

Query Error

This bit is set to 1 if an error has occurred while trying to read the test set's output queue. The following events cause a query error:

  • An attempt is made to read data from the output queue when no data is present or is pending.

  • Data in the output queue has been lost. An example of this would be an output queue overflow.

1

2

Reserved for future use.

This bit will always be 0.

0

1

Operation Complete

This bit is set to 1 when the test set has completed all pending operations and is ready to accept new commands. This bit is only generated in response to the *OPC IEEE 488.2 common command.

Program Example - Standard Event Status Register

OUTPUT 714;"*ESR?" !Queries (reads) the Standard Event Status Register.


GPIB Command Conventions

GPIB Command Conventions

Last updated: June 6, 2007

Description

Command Description

The uppercase letters of a mnemonic represent the short form of the mnemonic, whereas the long form of a mnemonic is the short form followed by the lowercase letters. The test set accepts either the long form or the short form of the mnemonic.

The mnemonics that are inside square brackets are optional. That is, a command operates the same whether or not the mnemonic in square brackets is used in the command.

A vertical bar, |, implies choices. When mnemonics are listed in parentheses separated by vertical bars ( | ), you must choose one of the mnemonics inside the parentheses.

Complex Command Description

Complex commands are valuable because they set the state of the parameter and a value for that parameter. For example, a command that contains the mnemonic [:SAMPlitude] is a complex command that sets the state to ON as well as the amplitude. You can use parameters such as amplitude, frequency, gain, number, time, and value as a complex command. Refer to the specific command for the parameter that applies.

Data Type Description

num value

Integer, float or scientific values.

For example,

CALL:POWer -55.5

CALL:POWer -5.55E+001

CALL:CHANnel 525

string

Characters. The string will often need to be enclosed in single or double quotes, depending upon your programming environment.

For example,

CALL:CIDentity "#0123456789*"

CALL:UPLink:PRAChannel:ASUBchannels '111111111111'

The string returned by the test set is enclosed by double quotes.
choice1|choice2|choice3

Specific character choices.

For example,

CALL:OPERating:MODE D2KTest

SYSTem:COMMunicate:GPIB:DEBug ON

Unit Type Description

Some commands have optional units of measurement. These are displayed in square brackets. If no units are specified in the command then the default unit in bold font below is used. The test set accepts the specified unit either with or without a space inserted between the <num value> and the unit (for example, both 10S and 10 S are valid). The following table summarizes the units available.

Description

Optional Units

Example

Amplitude (linear)

V |MV

To set the spectrum monitor's timeout interval to 20 seconds, use any of the following formats:

SETup:SMONitor:TIMeout:TIME 20
SETup:SMONitor:TIMeout:TIME 20S
SETup:SMONitor:TIMeout:TIME 20 S

Power (logarithmic)

DBM |DBW

Level (relative)

DB

Frequency

HZ |KHZ|MHZ|GHZ

Time

S |MS|US|NS

Percentage

PCT

[:SELected] Mnemonic

The [:SELected] Mnemonic is an optional mnemonic that implies a current selection on the test set. Often there are other mnemonics that can be used in place of the [:SELected] mnemonic to configure a setting that is not the currently selected configuration on the test set. The mnemonics that can replace the [:SELected] mnemonic are listed in parentheses separated by vertical bars ( | ) in the description table title. An example of a command that contains the [:SELected] mnemonic is shown in the following table.

Related Topics

Dealing With Semicolon Separated Response Data Lists


SYSTem:APPLication

SYSTem:APPLication

Last updated: June 7, 2007

GPIB Command Conventions

  • SYSTem:APPLication[:CURRent][:NAME]?
  • SYSTem:APPLication[:CURRent]:REVision?
  • SYSTem:APPLication:CATalog[:NAME]?
  • SYSTem:APPLication:CATalog[:NAME]:COUNt?
  • SYSTem:APPLication:CATalog:FORMat?
  • SYSTem:APPLication:CATalog:FORMat:COUNt?
  • SYSTem:APPLication:CATalog:LICense?<sp>'<application name>','<revision>'
  • SYSTem:APPLication:CATalog:LICense:APPLication:ALL?
  • SYSTem:APPLication:CATalog:LICense:APPLication:COUNt?
  • SYSTem:APPLication:CATalog:REVision?<sp>'<application name>'
  • SYSTem:APPLication:CATalog:REVision:COUNt?<sp>'<application name>'
  • SYSTem:APPLication:FORMat[:NAME]
  • SYSTem:APPLication:FORMat:LICense?<sp>'<format name>'
  • SYSTem:APPLication:SELect[:NAME]
  • SYSTem:APPLication:SELect:REVision
  • SYSTem:APPLication:SELect:REVision?<sp>'<application name>'

SYSTem:APPLication[:CURRent][:NAME]?

Function

Queries the name of the currently running application.

To query the revision of the currently running application, see SYSTem:APPLication[:CURRent]:REVision? .

To switch applications, see SYSTem:APPLication:SELect[:NAME] and SYSTem:APPLication:SELect:REVision .

Query

Range: See SYSTem:APPLication:CATalog[:NAME]? .

Requirements

Test or Lab Application Revision: A.01 and above

Programming Example

OUTPUT 714;"SYSTem:APPLication?"

SYSTem:APPLication[:CURRent]:REVision?

Function

Queries the revision of the currently running application.

To query the name of the currently running application, see SYSTem:APPLication[:CURRent][:NAME]? .

To switch to a different revision of an application, see SYSTem:APPLication:SELect[:NAME] and SYSTem:APPLication:SELect:REVision .

Query

Range: 0 to 20 characters from the set .0123456789aAbBcCdDeEfF, enclosed by double quotes. For example, "A.01.01"

Requirements

Test or Lab Application Revision: A.01 and above

Programming Example

OUTPUT 714;"SYSTem:APPLication:REVision?"

SYSTem:APPLication:CATalog[:NAME]?

Function

Queries the names of the applications stored on the test set.

This query returns a comma-separated list of double-quoted strings (one for each application stored on the test set).

To query the number of applications stored on the test set, see SYSTem:APPLication:CATalog[:NAME]:COUNt? .

To switch applications, see SYSTem:APPLication:SELect[:NAME] and SYSTem:APPLication:SELect:REVision .

Query

Range: One or more of the following strings, separated by commas -

  • "1xEV-DO FTM Terminal Test"
  • "1xEV-DO Lab App"
  • "1xEV-DO Lab App B"
  • "1xEV-DO Lab App T"
  • "1xEV-DO Lab App U"
  • "1xEV-DO Terminal Test"
  • "AMPS/136 Mobile Test"
  • "CDMA 2000 Lab App"
  • "CDMA 2000 Lab App B"
  • "CDMA 2000 Lab App T"
  • "CDMA 2000 Mobile Test"
  • "CDMA 2000_1xEV-DO"
  • "EGPRS Lab App"
  • "Fast Switch Test App"
  • "GPRS Lab Application"
  • "GPRS Lab App B"
  • "GPRS Mobile Test"
  • "GSM Mobile Test"
  • "GSM/GPRS Lab App C"
  • "GSM/GPRS Lab App D"
  • "GSM/GPRS Lab App E"
  • "GSM/GPRS Lab App F"
  • "GSM/GPRS Lab App T"
  • "GSM/GPRS Lab App U"
  • "GSM/GPRS Mobile Test"
  • "GSM/GPRS RF Modem"
  • "GSM/GPRS_AMPS/136"
  • "GSM/GPRS_AMPS/136_WCDMA"
  • "GSM/GPRS_CDMA 2000"
  • "GSM/GPRS_WCDMA Lab App"
  • "GSM/GPRS_WCDMA Lab App B"
  • "GSM/GPRS_WCDMA Lab App C"
  • "GSM/GPRS_WCDMA Lab App D"
  • "GSM/GPRS_WCDMA Lab App E"

Query

(continued)
  • "GSM/GPRS_WCDMA Lab App T"
  • "GSM/GPRS_WCDMA Lab App U"
  • "WCDMA Lab App"
  • "WCDMA Lab App B"
  • "WCDMA Lab App C"
  • "WCDMA Lab App D"
  • "WCDMA Lab App E"
  • "WCDMA Lab App T"
  • "WCDMA Lab App U"
  • "WCDMA Mobile Test"

Requirements

Test or Lab Application Revision: A.01 and above

Programming Example

OUTPUT 714;"SYSTem:APPLication:CATalog?"

SYSTem:APPLication:CATalog[:NAME]:COUNt?

Function

Queries the total number of applications stored on the test set.

To query the names of the applications stored on the test set, see SYSTem:APPLication:CATalog[:NAME]? .

Query

Range: 0 through 30

Resolution: 1

Requirements

Test or Lab Application Revision: A.01 and above

Programming Example

OUTPUT 714;"SYSTem:APPLication:CATalog:COUNt?"

SYSTem:APPLication:CATalog:FORMat?

Function

Queries the names of the formats in the current application.

This query returns a comma-separated list of double-quoted strings (one for each format in the application).

To query the number of formats in the current application, see SYSTem:APPLication:CATalog:FORMat:COUNt? .

To switch formats in a fast switching application, see SYSTem:APPLication:FORMat[:NAME] .

Query

Range: One or more of the following strings separated by commas -

  • "1xEV-DO"
  • "AMPS/136"
  • "GSM/GPRS" (Note: this query return represents GSM, GPRS and EGPRS formats)
  • "IS-2000/IS-95/AMPS"
  • "IS-856"
  • "WCDMA"

Requirements

Test or Lab Application Revision: A.01 and above

Programming Example

OUTPUT 714;"SYSTem:APPLication:CATalog:FORMat?"

SYSTem:APPLication:CATalog:FORMat:COUNt?

Function

Queries the number of formats in the current application.

To query the names of the formats in the current application, see SYSTem:APPLication:CATalog:FORMat? .

Query

Range: 0 to 30

Resolution: 1

Requirements

Test or Lab Application Revision: A.01 and above

Programming Example

OUTPUT 714;"SYSTem:APPLication:CATalog:FORMat:COUNt?"

SYSTem:APPLication:CATalog:LICense?<sp>'<application name>','<revision>'

Function

Queries the license status for the specified application/revision. The application/revision does not have to be installed in the test set.

The query must include a parameter for the application name and revision, enclosed by single quotes and separated by a comma. For application names and revisions, see SYSTem:APPLication:CATalog[:NAME]? and SYSTem:APPLication:CATalog:REVision?<sp>'<application name>' . Note that the application name and revision parameters are not case-sensitive.

Query

Range: LIC|NLIC|PART|UNKN

  • "LIC" indicates this is a licensed application/revision.
  • "NLIC" indicates this is not a licensed application/revision.
  • "PART" indicates that not all of the formats in this application/revision are licensed. (To determine the license status of each format, see SYSTem:APPLication:FORMat:LICense?<sp>'<format name>' .)
  • "UNKN" indicates that license status is unknown.

Requirements

Test or Lab Application Revision: A.01 and above

Programming Example

OUTPUT 714;"SYSTem:APPLication:CATalog:LICense? 'CDMA 2000 Mobile Test','B.07.00'"

SYSTem:APPLication:CATalog:LICense:APPLication:ALL?

Function

Queries the names of the applications, formats and features that are licensed for the test set. The applications, formats and features do not have to be installed in the test set to be returned by this query.

This query returns a comma-separated list of double-quoted strings (two for each application, one for each format or feature).

To query the number of licensed applications, formats and features for the test set, see SYSTem:APPLication:CATalog:LICense:APPLication:COUNt? .

Query

Range: One or more of the following strings, separated by commas.

Applications -

  • "E1960A","GSM Mobile Test"
  • "E1961A","AMPS/136 TA"
  • "E1962B","CDMA 2000 TA"
  • "E1963A","WCDMA TA"
  • "E1964A","GPRS Mobile Test"
  • "E1966A","1xEV-DO TA"
  • "E1968A","GSM/GPRS Mobile Test"
  • "E1976A","1xEV-DO FTM TA"
  • "E1985A","GSM/GPRS_AMPS/136"
  • "E1985B","GSM/GPRS_AMPS/136_WCDMA"
  • "E1985C","GSM/GPRS_CDMA 2000"
  • "E1985E","CDMA 2000_1xEV-DO"
  • "E1987A","Fast Switch Test App"
  • "E6590A","GSM/GPRS RF Modem"
  • "E6701A","GPRS LA"
  • "E6701B","GPRS LA rev B"
  • "E6701C","GSM/GPRS LA rev C"
  • "E6701D","GSM/GPRS LA rev D"
  • "E6701E","GSM/GPRS LA rev E"
  • "E6701F","GSM/GPRS LA rev F"
  • "E6701T","GSM/GPRS LA rev T"
  • "E6701U","GSM/GPRS LA rev U"
  • "E6702A","CDMA2000 LA"
  • "E6702B","CDMA2000 LA rev B"
  • "E6702T","CDMA2000 LA rev T"
  • "E6703A","WCDMA LA"
  • "E6703B","WCDMA LA rev B"
  • "E6703C","WCDMA LA rev C"
  • "E6703D","WCDMA LA rev D"
  • "E6703E","WCDMA LA rev E"
  • "E6703T","WCDMA LA rev T"
  • "E6703U","WCDMA LA rev U"
  • "E6704A","EGPRS LA"
Query (continued)
  • "E6706A","1xEV-DO Lab App"
  • "E6706B","1xEV-DO LA rev B"
  • "E6706T","1xEV-DO LA rev T"
  • "E6706U","1xEV-DO LA rev U"
  • "E6785A","GSM/GPRS_WCDMA Lab App"
  • "E6785B","GSM/GPRS_WCDMA LA rev B"
  • "E6785C","GSM/GPRS_WCDMA LA rev C"
  • "E6785D","GSM/GPRS_WCDMA LA rev D"
  • "E6785T","GSM/GPRS_WCDMA LA rev T"

Formats -

  • "E1968A-101","GSM TA"
  • "E1968A-102","GPRS TA"
  • "E1968A-103","EGPRS TA"
  • "E1968A-201","GSM/GPRS TA"
  • "E1968A-202","GSM/GPRS/EGPRS TA"
  • "E6590A-101","GSM/GPRS"
  • "E6590A-102","EGPRS"
  • "E6590A-103","RF Modem"

Features -

  • "E1962B-401","CDMA2000 RelA"
  • "E1962B-402","AMPS Enhancement"
  • "E1962B-403","CDMA2000 Authenticat"
  • "E1963A-401","WCDMA Video Call"
  • "E1963A-403","HSDPA Test Modes"
  • "E1966A-102","1xEV-DO RelA"
  • "E1968A-410","Phase & Ampl vs Time"
  • "E1976A-102","1xEV-DO RelA FTM"
  • "E1999A-201","Fast Device Tune"
  • "E1999A-401","GSM Fast Device Tune"
  • "E6706A-102","1xEV-DO Rel A ETAP"
  • "E6706T-102","1xEV-DO Rel A ETAP"

Requirements

Test Application Revision: B.08 and above

Lab Application Revision: B.02 and above

Programming Example

OUTPUT 714;"SYSTem:APPLication:CATalog:LICense:APPLication:ALL?"

SYSTem:APPLication:CATalog:LICense:APPLication:COUNt?

Function

Queries the number of applications, formats and features that are licensed for the test set. The applications, formats and features do not have to be installed in the test set to be included in the query result.

To query the names of the licensed applications, formats and features for the test set, see SYSTem:APPLication:CATalog:LICense:APPLication:ALL? .

Query

Range: 0 to 300

Resolution: 1

Requirements

Test Application Revision: B.08 and above

Lab Application Revision: B.02 and above

Programming Example

OUTPUT 714;"SYSTem:APPLication:CATalog:LICense:APPLication:COUNt?"

SYSTem:APPLication:CATalog:REVision?<sp>'<application name>'

Function

Queries the revisions stored on the test set for the specified application.

The query must include a parameter for the application name enclosed by single quotes. For application names, see SYSTem:APPLication:CATalog[:NAME]? . Note that the application name parameter is not case-sensitive.

This query returns a comma-separated list of double-quoted strings (one for each revision of the application).

Note, if you have several revisions of the application stored on the test set, you may need to increase your GPIB controller's timeout time to avoid a timeout condition.

To query the number of revisions stored on the test set for the specified application, see SYSTem:APPLication:CATalog:REVision:COUNt?<sp>'<application name>' .

To switch to a different revision of an application, see SYSTem:APPLication:SELect[:NAME] and SYSTem:APPLication:SELect:REVision .

Query

 Range: Comma-separated list of 0 to 20 characters from the set .0123456789aAbBcCdDeEfF, enclosed by double quotes. For example, "A.01.01","A.02.01"

Requirements

Test or Lab Application Revision: A.01 and above

Programming Example

OUTPUT 714;"SYSTem:APPLication:CATalog:REVision? 'CDMA 2000 MOBILE TEST'"

SYSTem:APPLication:CATalog:REVision:COUNt?<sp>'<application name>'

Function

Queries the number of revisions stored on the test set for the specified application.

The query must include a parameter for the application name enclosed by single quotes. For application names, see SYSTem:APPLication:CATalog[:NAME]? . Note that the application name parameter is not case-sensitive.

To query the revision numbers stored on the test set for the specified application, see SYSTem:APPLication:CATalog:REVision?<sp>'<application name>' .

Query

Range: 0 to 30

Requirements

Test or Lab Application Revision: A.01 and above

Programming Example

OUTPUT 714;"SYSTem:APPLication:CATalog:REVision:COUNt? 'CDMA 2000 MOBILE TEST'"

SYSTem:APPLication:FORMat[:NAME]

Function

Switches to the specified format (in the current application). Only fast switching applications include more than one format. To determine what formats are available in the current application, see SYSTem:APPLication:CATalog:FORMat? . To determine the license status of a format, see SYSTem:APPLication:FORMat:LICense?<sp>'<format name>' .

Queries the name of the currently active format in the current application.

Setting

Range: See SYSTem:APPLication:CATalog:FORMat?

Query

Range: same as setting

Requirements

Test or Lab Application Revision: A.01 and above

Programming Example

OUTPUT 714;"SYSTem:APPLication:FORMat 'IS-2000/IS-95/AMPS'"

OUTPUT 714;"SYSTem:APPLication:FORMat?"

SYSTem:APPLication:FORMat:LICense?<sp>'<format name>'

Function

Queries the license status of the specified format in the current application.

The query must include a parameter for the format name enclosed by single quotes. For format names, see SYSTem:APPLication:CATalog:FORMat? . Note that the format name parameter is not case-sensitive.

Query

Range: LIC|NLIC|UNKN

  • "LIC" indicates this is a licensed format.
  • "NLIC" indicates this is not a licensed format.
  • "UNKN" indicates that the license status is unknown.

Requirements

Test or Lab Application Revision: A.01 and above

Programming Example

OUTPUT 714;"SYSTem:APPLication:FORMat:LICense? 'IS-2000/IS-95/AMPS'"

SYSTem:APPLication:SELect[:NAME]

Function

Switches to the specified application (this includes a reboot of the test set). To determine what applications are stored on the test set, see SYSTem:APPLication:CATalog[:NAME]? . The revision that is switched to is determined by SYSTem:APPLication:SELect:REVision . To determine the license status of the application/revision, see SYSTem:APPLication:CATalog:LICense?<sp>'<application name>','<revision>' .

Queries the name of the application that will be loaded after the next reboot of the test set.

Setting

Range: See SYSTem:APPLication:CATalog[:NAME]? .

Query

Range: See SYSTem:APPLication:CATalog[:NAME]? .

Requirements

Test or Lab Application Revision: A.01 and above

Programming Example

OUTPUT 714;"SYSTem:APPLication:SELect 'CDMA 2000 MOBILE TEST'"

OUTPUT 714;"SYSTem:APPLication:SELect?"

SYSTem:APPLication:SELect:REVision

Function

Sets the revision that will be loaded when the application is switched to using the SYSTem:APPLication:SELect[:NAME] command.

To determine what application is to be switched to, see SYSTem:APPLication:SELect[:NAME] . To determine what revisions are stored on the test set for the specified application, see SYSTem:APPLication:CATalog:REVision?<sp>'<application name>' . To determine the license status of a revision, see SYSTem:APPLication:CATalog:LICense?<sp>'<application name>','<revision>' .

To query the revision that will be loaded when an application is switched to, see SYSTem:APPLication:SELect:REVision?<sp>'<application name>' .

NOTE
GSM Mobile Test revisions prior to A.04.00 did not have application switching and provide no way to return to revisions that have switching. If you switch to a GSM Mobile Test application revision prior to A.04.00, the only way to return to a newer revision is by downloading it using the process for upgrading firmware.

Setting

Range: see SYSTem:APPLication:CATalog[:NAME]? and SYSTem:APPLication:CATalog:REVision?<sp>'<application name>' .

Requirements

Test or Lab Application Revision: A.01 and above

Programming Example

OUTPUT 714;"SYSTem:APPLication:SELect:REVision 'CDMA 2000 Mobile Test','B.06.30'"

SYSTem:APPLication:SELect:REVision?<sp>'<application name>'

Function

Queries the revision that will be loaded when the specified application is switched to using the SYSTem:APPLication:SELect[:NAME] command.

The query must include a parameter for the application name enclosed by single quotes. For application names, see SYSTem:APPLication:CATalog[:NAME]? . Note that the application name parameter is not case-sensitive.

To set the revision that will be loaded when the specified application is switched to, see SYSTem:APPLication:SELect:REVision .

NOTE
GSM Mobile Test revisions prior to A.04.00 did not have application switching and provide no way to return to revisions that have switching. If you switch to a GSM Mobile Test application revision prior to A.04.00, the only way to return to a newer revision is by downloading it using the process for upgrading firmware.

Query

 Range: 0 to 20 characters from the set .0123456789aAbBcCdDeEfF, enclosed by double quotes. For example, "A.01.01"

Requirements

Test or Lab Application Revision: A.01 and above

Programming Example

OUTPUT 714;"SYSTem:APPLication:SELect:REVision? `CDMA 2000 MOBILE TEST'"

Related Topics

Test Application Switching


SYSTem:AUDio

SYSTem:AUDio

Last updated: June 7, 2007

GPIB Command Conventions

  • SYSTem:AUDio:OUTPut:SOURce
  • SYSTem:AUDio:OUTPut:FMDemod:BPFilter:STATe
  • SYSTem:AUDio:OUTPut:FMDemod:EXPandor:STATe
  • SYSTem:AUDio:OUTPut:FMDemod:DEEMphasis:STATe

SYSTem:AUDio:OUTPut:SOURce

Function

Set/queries whether the audio generator signal or the FM demodulation signal is selected to be routed to the AUDIO OUT port of the test set's front panel.

When audio generator is selected for output at the front-panel AUDIO OUT port, use AFGenerator Subsystem to control the audio generator.

NOTE
The selection of FM Demod signal is useful only in AMPS system. A bandpass filter, expander circuit, and deemphasis circuit can be individually inserted or bypassed in the FM Demod signal path. Use the command SYSTem:AUDio:OUTPut:FMDemod:BPFilter:STATe to insert the bandpass filter. Use the command SYSTem:AUDio:OUTPut:FMDemod:EXPandor:STATe to insert the expandor circuit. Use the command SYSTem:AUDio:OUTPut:FMDemod:DEEMphasis:STATe to insert the deemphasis filter.

NOTE
There will be no guaranteed performance for the signal present at the Audio Out port when FM Demod is selected for output.

Requirements

 Test Application Revision: B.06.00 or above

Setting

AFGenerator|FMDemod

Query

AFG|FMD

*RST Setting

AFG

Programming Example

OUTPUT 714;"SYSTem:AUDio:OUTPut:SOURce FMDemod"

!Selects FM Demod signal for output at the front panel AUDIO OUT port.

SYSTem:AUDio:OUTPut:FMDemod:BPFilter:STATe

Function

Sets/queries whether the fixed bandpass filter is inserted or bypassed in the FM Demod signal path. It is useful only when FM Demod signal is selected for output at the front-panel AUDIO OUT port (see SYSTem:AUDio:OUTPut:SOURce ).

When the state is ON, a 300 Hz to 3 KHz bandpass filter is inserted in the audio signal path. When the state is OFF, the bandpass filter is bypassed in the audio signal path

Requirements

 Test Application Revision: B.06.00 or above
Setting | Range: 0|OFF|1|ON

Query

Range: 0|1
*RST setting | 0 (OFF)

Programming Example

OUTPUT 714;"SYSTem:AUDio:OUTPut:FMDemod:BPFilter:STATe ON"

!Sets the bandpass filter state to ON.

SYSTem:AUDio:OUTPut:FMDemod:EXPandor:STATe

Function

Sets/queries whether the expandor filter is inserted or bypassed in the FM Demod signal path. It is useful only when FM Demod signal is selected for output at the front-panel AUDIO OUT port (see SYSTem:AUDio:OUTPut:SOURce ).

When the state is ON, the expandor filter is inserted in the audio signal path. When the state is OFF, the expandor filter is bypassed in the audio signal path.

Requirements

 Test Application Revision: B.06.00 or above
Setting | Range: 0|OFF|1|ON

Query

Range: 0|1
*RST setting | 0 (OFF)

Programming Example

OUTPUT 714;"SYSTem:AUDio:OUTPut:FMDemod:EXPandor:STATe ON" !Sets the expandor filter state to ON.

SYSTem:AUDio:OUTPut:FMDemod:DEEMphasis:STATe

Function

Sets/queries whether the deemphasis filter is inserted or bypassed in the FM Demod signal path. It is useful only when FM Demod signal is selected for output at the front-panel AUDIO OUT port (see SYSTem:AUDio:OUTPut:SOURce ).

When the state is ON, the deemphasis filter is inserted in the audio signal path. When the state is OFF, the deemphasis filter is bypassed in the audio signal path.

Requirements

 Test Application Revision: B.06.00 or above
Setting | Range: 0|OFF|1|ON

Query

Range: 0|1
*RST setting | 0 (OFF)

Programming Example

OUTPUT 714;"SYSTem:AUDio:OUTPut:FMDemod:DEEMphasis:STATe ON"

!Sets the deemphasis filter state to ON.


SYSTem:BEEPer

SYSTem:BEEPer

Last updated: June 7, 2007

  • SYSTem:BEEPer:STATe

GPIB Command Conventions

SYSTem:BEEPer:STATe

Function

Sets/queries the beeper state of the test set.

Setting

0|OFF | 1|ON

Query

0|1

*RST Setting

1 (on)

Related Topics

Test Set Beeper

Programming Example

OUTPUT 714;"SYSTEM:BEEPER:STATE OFF" !Sets beeper state to off.


SYSTem:COMMunicate

SYSTem:COMMunicate

Last updated: June 26, 2007

GPIB Command Conventions

  • SYSTem:COMMunicate:GPIB:[:SELF]:ADDRess
  • SYSTem:COMMunicate:GPIB:DEBug[:STATe]
  • SYSTem:COMMunicate:LAN[:SELF]:ADDRess
  • SYSTem:COMMunicate:LAN[:SELF]:DGATeway
  • SYSTem:COMMunicate:LAN[:SELF]:SMASk
  • SYSTem:COMMunicate:LAN:EXTernal:ADDRess
  • SYSTem:COMMunicate:LAN:EXTernal:SYNChronize
  • SYSTem:COMMunicate:LAN:EXTernal:SYNChronize:INDication:CLEar

SYSTem:COMMunicate:GPIB:[:SELF]:ADDRess

Function

 Sets/queries the test set's GPIB address.

Setting

Range: 0 to 30

Resolution: 1

Query

Range: 0 to 30

Resolution: 1

Factory setting

14 (this parameter is not affected by any reset operation and can only be changed by direct user access)

Programming Example

OUTPUT 714;"SYSTEM:COMMUNICATE:GPIB:SELF:ADDRESS 14" !Sets the GPIB address to 14.

SYSTem:COMMunicate:GPIB:DEBug[:STATe]

Function

Sets/queries the test set's SCPI debugger state.

When the state is on; enhanced error messages (displayed when GPIB commands with syntax errors are detected) will be displayed on the test set display. Also, all GPIB commands will be displayed in red characters at the bottom left area of the test set's display.

The error message is printed along with the syntax. <ERR> is displayed at the end of the incorrect node. Non-printable characters will be replaced with the $ symbol.

See Error Messages for a list of the errors.

The debugger state should be used only during GPIB code development. Test times may be longer than necessary if the debugger state is left on.

Setting

 Range: 0|OFF | 1|ON
Query 0|1

*RST setting

0|off

Programming Example

OUTPUT 714;"SYSTEM:COMMUNICATE:GPIB:DEBUG:STATE ON" !Sets the GPIB debugger state on.

SYSTem:COMMunicate:LAN[:SELF]:ADDRess

Function

Sets/queries the test set's LAN IP address. The value of A is used to determine the subnet mask, see SYSTem:COMMunicate:LAN[:SELF]:SMASk .

If the LAN address is changed the subnet mask should be checked to insure that it is set to the proper class for that LAN address.

Setting

Range: 15 characters formatted as follows: A.B.C.D. The range of values for A= 0 to 126 and 128 to 223. The range of values for B,C, D = 0 to 255 (no embedded spaces).

Query

Range: 15 characters formatted as follows: A.B.C.D. The range of values for A= 0 to 126 and 128 to 223. The range of values for B,C, D = 0 to 255 (no embedded spaces).

Factory setting

0.0.0.0 (this parameter is not affected by any reset operation and can only be changed by direct user access)

Programming Example

OUTPUT 714;"SYSTEM:COMMUNICATE:LAN:SELF:ADDRESS '130.015.156.255'"
!Sets the LAN IP address.

SYSTem:COMMunicate:LAN[:SELF]:DGATeway

Function

Sets/queries the LAN IP router/gateway address for the test set.

Setting

Range: 15 characters formatted as follows: A.B.C.D where A= 0 to 223 B,C,D = 0 to 255 (no embedded spaces), blank field

Query

Range: 15 characters formatted as follows: A.B.C.D where A,B,C,D = 0 to 255 (no embedded spaces). blank field

Factory setting

blank field, (this parameter is not affected by any reset operation)

Programming Example

OUTPUT 714;"SYSTEM:COMMUNICATE:LAN:SELF:DGATEWAY '130.2.6.200'"

SYSTem:COMMunicate:LAN[:SELF]:SMASk

Function

Sets/queries the subnet mask of the test set based on the LAN IP address selected. The subnet mask changes according to the value of A used for the LAN IP address.

If A is less than 127, the default subnet mask is 255.0.0.0.

If A is greater than 127 and less or equal to 191, the default subnet mask is 222.255.0.0.

If A is grater than 191, the default subnet mask is 255.255.255.0.

If the LAN address is changed the default subnet mask should be checked to insure that it is set to the proper class for that LAN address.

Setting

Range: 15 characters formatted as follows: A.B.C.D where A, B, C, D are between = 0 to 255 (no embedded spaces)

Query

Range: 15 characters formatted as follows: A.B.C.D where A,B,C,D are between = 0 to 255 (no embedded spaces)

Factory setting

0.0.0.0 (this parameter is not affected by any reset operation and can only be changed by direct user access)

Programming Example

OUTPUT 714;"SYSTEM:COMMUNICATE:LAN:SELF:SMASK '130.2.6.200'"

SYSTem:COMMunicate:LAN:EXTernal:ADDRess

Function

Sets/queries the IP address of the designated Sync Sever on the Sync Clients in the multi-unit synchronization procedure.

Setting

Range: 15 characters formatted as follows: A.B.C.D. The range of values for A= 0 to 126 and 128 to 223. The range of values for B,C, D = 0 to 255 (no embedded spaces).

Query

Range: same as setting.

Factory setting

0.0.0.0 (this parameter is not affected by *RST and can only be changed by direct user access)

Requirement

Lab Application revision: B.03 and above
Test Application revision: B.13 and above

Programming Example

OUTPUT 714;"SYSTEM:COMMUNICATE:LAN:EXTERNAL:ADDRESS '255.2.6.200'"

SYSTem:COMMunicate:LAN:EXTernal:SYNChronize

Function

Sets to synchronize the Sync Client's CDMA system time to the same value as that in the Sync Server.

Requirement

Lab Application revision: B.03 and above
Test Application revision: B.13 and above

Programming Example

OUTPUT 714;"SYSTEM:COMMUNICATE:LAN:EXTERNAL:SYNCHRONIZE"

SYSTem:COMMunicate:LAN:EXTernal:SYNChronize:INDication:CLEar

Function

Sets to clear all of indications associated with the synchronization. The test set specifies the following results to the default value

  • CDMA system time synchronization server event indication
  • CDMA system time synchronization client event indication
  • CDMA system time synchronization annunciator

This action doesn't affect the current synchronization status between two test sets.

Requirement

Lab Application revision: B.03 and above
Test Application revision: B.13 and above

Programming Example

OUTPUT 714;"SYSTEM:COMMUNICATE:LAN:EXTERNAL:SYNCHRONIZE:INDICATION:CLEAR"

Related Topics

Configuring the Test Set's LAN


SYSTem:CONFigure

SYSTem:CONFigure

Last updated: June 7, 2007

GPIB Command Conventions

  • SYSTem:CONFigure:INFormation:HARDware:VERBose?

SYSTem:CONFigure:INFormation:HARDware:VERBose?

Function

Query the manufacturer, model number, model number of the test application running, serial number, revision, board ID, and cal file information. The information provided by the query represents the configuration that existed when the test set was powered up.

*RST Setting

Resets have no effect on this information. The information is gathered during the power up cycle.

Related topics

Hardware Configuration Report

Programming Example

OUTPUT 714;"SYSTEM:CONFIGURE:INFORMATION:HARDWARE:VERBOSE?" !Queries system hardware.


SYSTem:CORRection

SYSTem:CORRection

Last updated: June 7, 2007

GPIB Command Conventions

  • SYSTem:CORRection:[:SGAin]
  • SYSTem:CORRection:FREQuency
  • SYSTem:CORRection:GAIN
  • SYSTem:CORRection:POINts
  • SYSTem:CORRection:SFRequency
  • SYSTem:CORRection:STATe

SYSTem:CORRection:[:SGAin]

Function

Sets/queries up to 20 comma-separated amplitude offset values in dB. This command sets the state to On.

See Amplitude Offset .

The units, dB, are optional. If no units are specified then units default to dB.

Sending a null list (no values) sets the state of all offsets to Off.

Setting

Range: 0 to 20 values between -100 to +100

Resolution: 0.01

Query

Range: 1 to 20 values between -100 to +100, and NAN (9.91E+37)

Resolution: 0.01

Factory Setting

Offsets 1 through 20, are set to 0.00 dB, state is set to Off

Programming Example

OUTPUT 714;"SYSTEM:CORRECTION:SGAIN -2.55,-3.12,-3.68,-4.23,-4.74,-5.3"
!A complex command that sets up to 20 comma separated offsets
!and sets the state to On for the frequencies, offsets and
!RF IN/OUT Amplitude Offset State

OUTPUT 714;"SYSTEM:CORRECTION:SGAIN"
!Sets the state for all frequencies and offsets to Off

SYSTem:CORRection:FREQuency

Function

Sets/queries up to 20 comma-separated frequency values in MHz. Each frequency value corresponds with a gain setting. See SYSTem:CORRection:GAIN .

The units, (GHz, MHz, kHz, Hz) are optional. If no units are specified, units default to Hz.

See Amplitude Offset .

Sending a null list (no values) sets the state of all frequencies to Off.

Setting

Range: 0 to 20 comma separated values ranging from 292.5 MHz to 2700 MHz

Resolution: 1 Hz

Query

Range: 1 to 20 comma separated values ranging from 292.5 MHz to 2700 MHz, and NAN (9.91E+37)

Resolution: 1 HZ

Factory Setting
  1. 800.00 MHz Off
  2. 810.00 MHz Off
  3. 820.00 MHz Off
  4. 830.00 MHz Off
  5. 840.00 MHz Off
  6. 850.00 MHz Off
  7. 860.00 MHz Off
  8. 870.00 MHz Off
  9. 880.00 MHz Off
  10. 890.00 MHz Off
  11. 900.00 MHz Off
  12. 910.00 MHz Off
  13. 920.00 MHz Off
  14. 930.00 MHz Off
  15. 940.00 MHz Off
  16. 950.00 MHz Off
  17. 960.00 MHz Off
  18. 970.00 MHz Off
  19. 980.00 MHz Off
  20. 990.00 MHz Off

Programming Example

OUTPUT 714;"SYSTEM:CORRECTION:FREQUENCY 1784.8 MHZ,1879.8 MHZ"
!Sets up to 20 comma separated frequencies

OUTPUT 714;"SYSTEM:CORRECTION:FREQUENCY"
!Sets the state for all frequencies and offsets to Off

SYSTem:CORRection:GAIN

Function

Sets/queries the up to 20 comma separated offset gain values in units of dB. Each gain value corresponds with a frequency setting. See SYSTem:CORRection:FREQuency .

See Amplitude Offset .

The units, dB, are optional. If no units are specified, units default to dB.

Sending a null list (no values) sets the state of all offsets to Off.

Setting

Range: 0 to 20 values between -100 to +100

Resolution: 0.01

Query

Range: 1 to 20 values between -100 to +100, and NAN (9.91E+37)

Resolution: 0.01

Factory Setting

Offsets 1 through 20, are set to 0.00 dB, state is set to off

Programming Example

OUTPUT 714;"SYSTEM:CORRECTION:GAIN -3.12,-3.68,-4.23"
!Sets up to 20 comma separated offset values.

OUTPUT 714;"SYSTEM:CORRECTION:GAIN"
!Sets the state for all frequencies and offsets to Off.

SYSTem:CORRection:POINts

Function

Query returns the number of offsets that are in their On state when the RF IN/OUT Amplitude Offset State is also set to On.

See Amplitude Offset .

Query

Range: 1 to 20, and NAN (9.91E+37)

Resolution: 1

Programming Example

OUTPUT 714;"SYSTEM:CORRECTION:POINTS?"

!Returns the number of frequencies and offsets with their state set to On.

SYSTem:CORRection:SFRequency

Function

Sets/queries up to 20 comma separated frequency values in MHz. This command sets the state to On.

The units (GHz, MHz, kHz, Hz) are optional. If no units are specified, units default to MHz.

See Amplitude Offset .

Sending a null list (no values) sets the state of all frequencies to Off.

Setting

Range: 0 to 20 comma separated values from 292.5 MHz to 2700 MHz

Resolution: 1 Hz

Query

Range: 1 to 20 comma separated values from 292.5 MHz to 2700 MHz, and NAN (9.91E+37)

Resolution: 1 HZ

Factory Setting
  1. 800.00 MHz Off
  2. 810.00 MHz Off
  3. 820.00 MHz Off
  4. 830.00 MHz Off
  5. 840.00 MHz Off
  6. 850.00 MHz Off
  7. 860.00 MHz Off
  8. 870.00 MHz Off
  9. 880.00 MHz Off
  10. 890.00 MHz Off
  11. 900.00 MHz Off
  12. 910.00 MHz Off
  13. 920.00 MHz Off
  14. 930.00 MHz Off
  15. 940.00 MHz Off
  16. 950.00 MHz Off
  17. 960.00 MHz Off
  18. 970.00 MHz Off
  19. 980.00 MHz Off
  20. 990.00 MHz Off

Programming Example

OUTPUT 714;"SYSTEM:CORRECTION:SFREQUENCY 1710.2 MHZ,1805.2 MHZ,1784.8 MHZ,1879.8 MHZ"
!Sets up to 20 comma separated frequencies and sets the state to On for the frequency,
!offset, and RF IN/OUT Amplitude Offset State

OUTPUT 714;"SYSTEM:CORRECTION:SFREQUENCY"
!Sets the state for all frequencies and offsets to Off

SYSTem:CORRection:STATe

Function

Sets/queries the RF IN/OUT Amplitude Offset State. The state must be On before any of the offsets are active regardless of the state for any of the frequencies or offsets.

When the RF IN/OUT Amplitude Offset State is On, the Instrument Status Area will indicate "Offset" regardless of the state for any of the frequencies or offsets.

Setting any of the frequency or offset states to On will set the RF IN/OUT Amplitude Offset State to On.

See Amplitude Offset .

Setting

0|OFF | 1|ON

Query

0|1

Factory Setting

0 (off)

Programming Example

OUTPUT 714;"SYSTEM:CORRECTION:STATE ON" !Sets the RF IN/OUT
                                        !Amplitude Offset State to On


SYSTem:CURRent:TA

SYSTem:CURRent:TA

Last updated: June 7, 2007

GPIB Command Conventions

  • SYSTem:CURRent:TA:MODel?
  • SYSTem:CURRent:TA:NAME?
  • SYSTem:CURRent:TA:REVision?

SYSTem:CURRent:TA:MODel?

Function | Queries the model number of the test application running. Printable ASCII characters up to a 15 character string.
Query | Range: ASCII codes 32 - 126 decimal excluding comma and semicolon
*RST Setting | non volatile, read from the test set's hard disk

SYSTem:CURRent:TA:NAME?

Function | Queries the name of the test application running. Printable ASCII characters up to a 25 character string. This command is not recommended see SYSTem:APPLication[:CURRent][:NAME]? .
Query | Range: ASCII codes 32 - 126 decimal excluding comma and semicolon
*RST Setting | non volatile, read from the test set's hard disk

SYSTem:CURRent:TA:REVision?

Function | Queries the coordinated codeware revision for the test application running. Printable ASCII characters up to a 20 character string. This command is not recommended see SYSTem:APPLication[:CURRent]:REVision? .
Query | Range: ASCII codes 32 - 126 decimal excluding comma and semicolon
*RST Setting | non volatile, read from the test set's hard disk.


SYSTem:DATE

SYSTem:DATE

Last updated: June 7, 2007

GPIB Command Conventions

  • SYSTem:DATE

SYSTem:DATE

Function

Sets/queries the date.

Setting

Range:

  • <year> 2000 to 2099
  • <month> 1 to 12 (the number 1 corresponds to January)
  • <day> 1 to the number of days in the month specified by the <month> parameter

Query

Range:

  • <year> 2000 to 2099
  • <month> 1 to 12 (the number 1 corresponds to January)
  • <day> 1 to the number of days in the month specified by the <month> parameter

*RST Setting

 This feature is not affected by instrument preset

Requirements

 Test Application Revision: B.03.00 and above

Programming Example

OUTPUT 714;"SYSTEM:DATE 2001,9,27" !Sets the date to September 27,2001.

OUTPUT 714;"SYSTEM:DATE? !Returns "+2001,+9,+27" if the date has been set to September 27,2001.

Related Topics

SYSTem:UTC:DATE


SYSTem Subsystem

SYSTem Subsystem

Last updated: June 19, 2007

Description

The SYSTem subsystem collects the functions that are not related to test set performance. Examples include functions for performing general housekeeping and functions related to setting global configurations, such as TIME or CORRection (amplitude offset).

Syntax Diagrams and Command Descriptions

SYSTem:APPLication

SYSTem:AUDio
SYSTem:BEEPer
SYSTem:COMMunicate
SYSTem:CONFigure
SYSTem:CORRection
SYSTem:CURRent:TA
SYSTem:DATE
SYSTem:ERRor?

SYSTem:FATal

SYSTem:INSTrument

SYSTem:LOG

SYSTem:MEASurement
SYSTem:PRESet

SYSTem:REGister

SYSTem:ROSCillator
SYSTem:SYNChronized

SYSTem:STATus

SYSTem:TIME
SYSTem:TZONe
SYSTem:UTC


SYSTem:ERRor?

SYSTem:ERRor?

Last updated: June 7, 2007

GPIB Command Conventions

  • SYSTem:ERRor?

SYSTem:ERRor?

Function

Queries the contents of the error/event queue. The error/event queue may contain one or more messages with an error or event description. See Error Messages .

Manual users may view the message log from the SYSTEM CONFIG screen. See Error Message Log . The contents of the error/event queue and the message log may not match. For example, manual user errors (see Manual User Error Messages ) are not returned with SYSTem:ERRor? query command. They are viewed from the message log.
Query

Error/Event Queue

  • Range: 0 to 100 messages up to 255 characters in length

Programming Example

OUTPUT 714;"SYSTEM:ERROR?" !Query the contents of the Error/Event Queue


SYSTem:FATal

SYSTem:FATal

Last updated: June 7, 2007

GPIB Command Conventions

  • SYSTem:FATal:ERRor:RESTart

SYSTem:FATal:ERRor:RESTart

Function

This command sets/queries the state of the Restart on Fatal Error parameter. See Restart on Fatal Error for more information.

Error messages that are created when a fatal error occurs are entered in the error/event queue that can be queried with the command SYSTem:ERRor? .

This is a nonvolatile setting, that is the instrument does not require a power supply to retain the setting its memory.

Requirements

Test Application Revision: A.03 and above
Lab Application Revision: A.01 and above

Setting

Range: ON|1|OFF|0

Query

Range: 1|0

*RST Setting

 0

Programming Example

OUTPUT 714;"SYSTem:FATal:ERRor:RESTart ON"
!Commands the instrument to restart if a fatal error occurs.


SYSTem:INSTrument

SYSTem:INSTrument

Last updated: June 8, 2007

GPIB Command Conventions

  • SYSTem:INSTrument:THERmal:POWer:NULL:ADJust?

SYSTem:INSTrument:THERmal:POWer:NULL:ADJust?

Function

Starts the Thermal Power Null Adjustment .

IMPORTANT
Ensure that your test set has warmed up at least 30 minutes and that no power is present at the front panel RF connectors before performing any calibrations.

When this adjustment has completed, a value is returned to indicate the success or failure of the adjustment. 0 indicates the adjustment completed successfully, 1 indicates that it failed.

Query

 Range: 0 (success), 1 (failure)

Requirements

Test Application Revision: A.06 and above

Lab Application Revision: A.03 and above

Programming Example

OUTPUT 714;"SYSTem:INSTrument:THERmal:POWer:NULL:ADJust?"
! Starts the Thermal Power Null Adjustment and returns a value indicating success or failure.


SYSTem:LOG

SYSTem:LOG

Last updated: July 27, 2007

GPIB Command Conventions

  • SYSTem:LOG:UI:COUNt?


SYSTem:MEASurement

SYSTem:MEASurement

Last updated: June 7, 2007

GPIB Command Conventions

  • SYSTem:MEASurement:RESet

SYSTem:MEASurement:RESet

Function | Aborts all measurements. If continous triggering is enabled, measurements will begin a new measurement cycle.
Setting | Measurement results are set to their default values when measurement reset occurs.


SYSTem:PRESet

SYSTem:PRESet

Last updated: June 7, 2007

GPIB Command Conventions

  • SYSTem:PRESet[1] (not recommended for use)
  • SYSTem:PRESet2
  • SYSTem:PRESet3

SYSTem:PRESet[1] ( not recommended for use )

Function

Not recommended for use at this time. See SYSTem:PRESet3 for a recommended partial preset.

Performs a partial preset. This command is intended to be used when changing from remote operation to manual operation and a partial preset is needed.

Any call in process is disconnected and all measurements are aborted and inactivated. Measurement parameters are not changed.

A partial preset will not modify any measurement settings including trigger arm. See Trigger Arm (Single or Continuous) Description .
Related Topics

See Partial Preset for more details

Programming Example

OUTPUT 714;"SYSTEM:PRESET" !Partial preset when changing from remote to manual operation.

SYSTem:PRESet2

Function

Performs a full preset of the test set. This is the remote equivalent of pressing the SHIFT Preset keys on the front panel of the test set.

All parameters are set to their default values. All measurements are aborted the trigger arm is set to continuous. See Trigger Arm (Single or Continuous) Description .

The *RST command will set the trigger arm to single.
Related Topics See Full Preset for details about the *RST full preset.

Programming Example

OUTPUT 714;"SYSTEM:PRESET2" !Full preset, trigger arm set to continuous.

SYSTem:PRESet3

Function

Performs a partial preset. This is the recommended command for users when a partial preset is needed during remote operation of the test set.

Any call in process is disconnected and all measurements are aborted and inactivated. Measurement parameters are not changed.

A partial preset will not modify any measurement settings including trigger arm.

Related Topics

See Partial Preset for more details.

Programming Example

OUTPUT 714;"SYSTEM:PRESET3" !Partial preset when in remote operation.


SYSTem:REGister

SYSTem:REGister

Last updated: June 7, 2007

GPIB Command Conventions

  • SYSTem:REGister:SAVe
  • SYSTem:REGister:RECall
  • SYSTem:REGister:DELete

SYSTem:REGister:SAVe

Function

Saves the current test set settings to one of five available registers.

If this command is used to save to a register that is already full, the old contents of the register will be overwritten.

Setting

1|2|3|4|5

Query

No query

*RST Setting

 Not applicable

Requirements

Test Application Revision: B.06.00 or above

Programming Example

OUTPUT 714;"SYSTem:REGister:SAVe 1" !Saves the current test set configuration to save register 1.

SYSTem:REGister:RECall

Function

Recalls a saved register from one of five registers.

If this command is used to recall a register that is empty, an error message will be displayed.

Setting

1|2|3|4|5

Query

No query

*RST Setting

 Not applicable

Requirements

Test Application Revision: B.06.00 or above

Programming Example

OUTPUT 714;"SYSTem:REGister:RECall 1" !Recalls register 1.

SYSTem:REGister:DELete

Function

Deletes any contents saved in the selected register.

Setting

1|2|3|4|5

Query

No query

*RST Setting

 Not applicable

Requirements

Test Application Revision: B.06.00 or above

Programming Example

OUTPUT 714;"SYSTem:REGister:DELete 1" !Deletes register 1.

Related Topics

Save and Recall Registers


SYSTem:ROSCillator

SYSTem:ROSCillator

Last updated: June 7, 2007

GPIB Command Conventions

  • SYSTem:ROSCillator[:TIMebase]?
  • SYSTem:ROSCillator:LOCKed?

SYSTem:ROSCillator[:TIMebase]?

Function

Queries the timebase source.

If an external timebase is used, it must have these characteritics:

  • an output level of 0 to +13 dBm

  • frequency of 10 MHz

Query

Range:

INT = internal source

EXT = external source

SYSTem:ROSCillator:LOCKed?

Function | Queries the timebase to find out if it is locked or unlocked. Returns 0 or 1.
Query | Range: 0 = unlocked 1 = locked


SYSTem:SYNChronized

SYSTem:SYNChronized

Last updated: June 7, 2007

GPIB Command Conventions

  • SYSTem:SYNChronized

SYSTem:SYNChronized

Function | Sets/queries the test set to see that all prior sequential commands have completed or that all prior overlapped commands have started, indicating that the input buffer is synchronized.
Setting | Bit 12 of the status operation condition register is pulsed.
Query | Range: 1


SYSTem:TIME

SYSTem:TIME

Last updated: June 7, 2007

GPIB Command Conventions

  • SYSTem:TIME

SYSTem:TIME

Function

Sets/queries the local time of day.

UTC time will track changes made directly to local time settings. Also, if new settings are made to UTC time, local time will track UCT time.

Changes to time zone will cause changes to local time, but will not directly affect UTC time.

Setting

Range:

  • <hour> 0 to 23
  • <minute> 0 to 59
  • <second> 0 to 59

NOTE
The resolution of local time setting is minutes. A number within the parameter range must be entered for <second> but it will not affect the minute setting.

Query

Range:

  • <hour> 0 to 23
  • <minute> 0 to 59
  • <second> 0 to 59

    • NOTE
    The resolution of the local time setting is minutes. The value returned for <second> will not provide useful information.

*RST Setting

 This feature is not affected by instrument preset.

Requirements

 Test Application Revision: B.03.00 and above

Programming Example

OUTPUT 714;"SYSTEM:TIME 7,30,0" !Sets local time to 7:30

OUTPUT 714;"SYSTEM:TIME?" !Returns "+7,+30,+0" if local time has been set to 7:30.

Related Topics

SYSTem:UTC[:TIME]


SYSTem:TZONe

SYSTem:TZONe

Last updated: June 7, 2007

GPIB Command Conventions

  • SYSTem:TZONe

SYSTem:TZONe

Function

Sets/queries the time zone.

Changes to time zone will cause changes to local time, but will not directly affect UTC time.

Setting

Range:

  • <hour> -12 to +15
  • <minute> 0 to 59

Query

Range:

  • <hour> -12 to +15
  • <minute> 0 to 59

*RST Setting

 This feature is not affected by instrument preset

Requirements

 Test Application Revision: B.03.00 and above

Programming Example

OUTPUT 714;"SYSTEM:TZONe 8,0" !Sets time zone to 8 hours and 0 minutes.

OUTPUT 714;"SYSTEM:TZONe?" !Returns "+8,+0" if time zone has been set to 8 hours.

Related Topics

SYSTem:TIME


SYSTem:UTC

SYSTem:UTC

Last updated: June 7, 2007

GPIB Command Conventions

  • SYSTem:UTC[:TIME]
  • SYSTem:UTC:DATE

SYSTem:UTC[:TIME]

Function

Sets/queries the Universal Coordinated Time (UTC) time of day. (UTC is also known as UCT, Zulu, and Greenwich Mean Time.)

Local time will track UTC time settings. Also, if new settings are made to local time, UTC time will track local time.

Setting

Range:

  • <hour> 0 to 23
  • <minute> 0 to 59
  • <second> 0 to 59

NOTE
The resolution of the UTC time setting is minutes. A number within the parameter range must be entered for <second> but it will not affect the minute setting.

Query

Range:

  • <hour> 0 to 23
  • <minute> 0 to 59
  • <second> 0 to 59

    • NOTE
    The resolution of the UTC time setting is minutes. The value returned for <second> will not provide useful information.

*RST Setting

 This feature is not affected by instrument preset

Requirements

 Test Application Revision: A.05.05 and above

Programming Example

OUTPUT 714;"SYSTEM:UTC:TIME 7,30,0" !Sets UCT time to 7:30

OUTPUT 714;"SYSTEM:UTC:TIME?" !Returns "+7,+30,+0" if UTC time has been set to 7:30.

SYSTem:UTC:DATE

Function

Sets/queries the Universal Coordinated Time (UTC) date. (UTC is also known as UCT, Zulu, and Greenwich Mean Time.)

Setting

Range:

  • <year> 2000 to 2099
  • <month> 1 to 12 (the number 1 corresponds to January)
  • <day> 1 to the number of days in the month specified by the <month> parameter

Query

Range:

  • <year> 2000 to 2099
  • <month> 1 to 12 (the number 1 corresponds to January)
  • <day> 1 to the number of days in the month specified by the <month> parameter

*RST Setting

 This feature is not affected by instrument preset

Requirements

 Test Application Revision: B.03.00 and above

Programming Example

OUTPUT 714;"SYSTEM:UTC:DATE 2001,9,27" !Sets the UTC date to September 27,2001.

OUTPUT 714;"SYSTEM:UTC:DATE? !Returns "+2001,+9,+27" if the UTC date has been set to September 27,2001.

Related Topics

SYSTem:DATE


Performing Specific Measurements and TIA/EIA-98-E Tests Manually

Performing Specific Measurements and TIA/EIA-98-E Tests Manually

Last updated: December 20, 2004

  • Measuring Access Probe Power
    • Testing 4.4.1 Range of Open Loop Output Power
    • Testing 4.4.3 Access Probe Output Power
  • Measuring Channel Power
    • Testing 4.4.6 Minimum Controlled Output Power
  • Measuring Code Channel Time/Phase Error
    • Testing 4.3.2 Reverse Pilot Channel to Code Channel Time Tolerance
    • Testing 4.3.3 Reverse Pilot Channel to Code Channel Phase Tolerance
  • Measuring Digital Average Power
    • Testing 4.4.5 Maximum RF Output Power
  • Measuring Frame Error Rate (FER)
    • Testing 3.4.1 Demodulation of Forward Traffic Channel in AWGN
    • Testing 3.5.1 Receiver Sensitivity and Dynamic Range
  • Measuring Gated Power
    • Testing 4.4.7 Standby Output Power and Gated Output Power
  • Measuring Handoff Waveform Quality
  • Measuring Maximum/Minimum Power
    • Testing 4.4.5 Maximum RF Output Power and 4.4.6 Minimum Controlled Output Power
  • Measuring a Multi-tone Digital Audio
    • General Procedure for Downlink Measurement
    • General Procedure for Uplink Measurement
  • Measuring SINAD Sensitivity (for AMPS test per TIA/EIA-690 standard)
  • Measuring TDSO (Test Data Service Option) Frame Error Rate (FER)
    • Testing 3.4.1 Demodulation of Forward Traffic Channel in AWGN
  • Measuring Time Response of Open Loop Power Control (TROLPC)
    • Testing 4.4.2 Time Response of Open Loop Power Control
  • Measuring TX Dynamic Power
  • Measuring TX Spurious Emissions
    • Testing 4.5.1 Conducted Spurious Emissions
  • Measuring Waveform Quality/Code Domain Power
    • Testing 4.1 Frequency Accuracy
    • Testing 4.3.1 Time Reference
    • Testing 4.3.4 Waveform Quality and Frequency Accuracy
    • Testing 4.3.5 Code Domain Power
    • Testing 4.4.9 Code Channel to Reverse Pilot Output Power Accuracy
  • Example Usage of Reverse CLPC Transient Mode
    • Testing 4.4.4 Range of Closed Loop Power Control
  • Measuring Paging Channel Message Error Rate (MER) ( Lab Application Only )
    • Testing 3.3.2 Demodulation of Slotted Mode Paging Channel
  • How Do I Perform a Graphical Access Probe Power Measurement? (Lab Application only)
  • How Do I Use R-FCH Gating for Talk Time Testing? (Lab Application only)


Access Probe Power Measurement Description

Access Probe Power Measurement Description

Last updated: October 28, 2004

  • How is an Access Probe Power measurement made?
  • Access Probe Power Measurement Parameters
  • Access Probe Power Measurement Results
  • Input Signal Requirements
  • Key TIA/EIA-98-E Tests Performed Using the Access Probe Power Measurement
  • Calibrating the Access Probe Power Measurement

How is an Access Probe Power measurement made?

The test set's access probe power measurement is a channel power measurement (see Channel Power Measurement Description ) triggered by a rise in RF power detected on the test set's RF input. When an input signal appears that is within +/- 9 dB of the expected power for an access probe, the measurement is triggered. To prevent the measurement from triggering on noise, the signal level must be at least -45 dBm/1.23 MHz.

The access probe power measurement captures an access probe and digitizes the waveform. It then uses DSP to determine the average power level (within the 1.23 MHz measurement bandwidth) of the first 1.25 ms of the probe.

When the test set is making access probe power measurements in the continuous trigger arm state, it will display the power level of the most recently measured access probe.

Considerations when making Access Probe Power measurements

IMPORTANT
If the access probe power measurement is on and waiting to measure a probe, all other measurements (except digital average power) will not be able to execute. It is therefore recommended that you turn off the access probe power measurement before attempting any other measurements.

Access probe sequences are transmitted by the mobile station during registrations or mobile station originated calls. Access probe sequences consist of a series of RF power "steps" which increase in power according to the step size setting until the maximum number of steps is reached or the call processing event completes, for example when the call connects.

Changing the number of steps and step size will affect the power level displayed if more than one access probe is transmitted by the mobile station. However, the number of access probes transmitted depends on whether or not the test set responds by acknowledging the access request, thereby ending the access attempt. To view the full access probe sequence, you must prevent the test set from responding to the mobile station access probe request by turning the Call Limit Mode on (key F10 in Call Parms, 2 of 3 screen). For the GPIB command syntax, see CALL:CONNected:LIMit[:STATe]<[:SELected]|:TA2000> .

It is recommended that you always turn the Call Limit Mode on when measuring access probe power. The easiest way to induce access probes from the mobile station is to page the mobile station. If you do not have call limit mode set to on, the call connection will complete, which clears the access probe power result from the measurement screen. Set call limit mode back to off when you have finished measuring access probe power.

When the mobile station performs any type of registration, an access probe power measurement will likely be triggered. To control the mobile station's registrations, access the Registration Parameters menu (see D. Registration Parameters ). For GPIB syntax information on the registrations, see CALL:REGister .

Access Probe Power Measurement Parameters

The parameters shown in the Access Probe Power Setup menu are different according to the current access channel configured:

  • When the current access channel is R-ACH (see Control Channel Configuration ), the parameters such as Nominal Power, Nominal Power Extended, Initial Power, Power Step, Number of Steps, Maximum Response Sequence and Preamble Size will be displayed. See Setting Access Parameters for details on these parameters:
  • When the current access channel is R-EACH, the parameters such as EACH Nominal Power, EACH Initial Power, EACH Power Step, EACH Number of Steps and Maximum Response Sequence will be displayed. See Setting Enhanced Access Parameters for details on these parameters.
  • Trigger Arm - (see Trigger Arm (Single or Continuous) Description ). When the test set is making access probe power measurements in the continuous trigger arm state, it will display the power level of the most recent access probe power measurement. To measure only the first access probe and prevent triggering on subsequent access probes, set Trigger Arm to Single . You must then press the START SINGLE hardkey to arm the measurement.
  • Timeout Time/State - (see Timeouts ).

Access Probe Power Measurement Results

  • Integrity Indicator - (see Integrity Indicator ).
  • Access Probe Power (in dBm/1.23 MHz): The average power level of the first 1.25 ms of the captured access probe.
  • Expected Mobile Power - the Expected Mobile Power (see Expected Power ) is also displayed on the measurement screen when the test set is configured as:
    • receiver power control is set to auto (see Automatic Receiver Control ), and
    • the R-EACH Rate Supported is not set to support multiple rates (that is, All Rates, 20 ms ) when current access channel is using R-EACH (see Control Channel Configuration ).

A typical measurement result is shown below:

Input Signal Requirements

The access probe power measurement meets or exceeds specifications when the following input signal requirements are met:

  • The frequency of the signal being measured must be within the range of 412 MHz to 483 MHz, 800 MHz to 960 MHz, or 1.7 GHz to 2.0 GHz, and be within 100 kHz of the expected frequency.
  • The average power level of the signal at the RF IN/OUT connector must be between -61 dBm to +37 dBm. The test set can autorange to a signal that is within +/- 9 dB of the expected input level (see RFANalyzer:AUTO:POWer[:SELected]? ).

Key TIA/EIA-98-E Tests Performed Using the Access Probe Power Measurement

  • Testing 4.4.1 Range of Open Loop Output Power
  • Testing 4.4.3 Access Probe Output Power

Calibrating the Access Probe Power Measurement

The access probe power measurement is automatically calibrated during a channel power calibration. Follow the channel power calibration schedule and the access probe power measurement will be properly calibrated. Refer to Calibrating the Test Set for a description of channel power calibration.

Related Topics

Measuring Access Probe Power

Programming an Access Probe Power Measurement

Access Probe Power Troubleshooting

Test Adherence to Standards

Channel Power Measurement Description

Graphical Access Probe Power Measurement Description ( lab application only )


Test Adherence to Standards

Test Adherence to Standards

Last updated: June 18, 2007

Unless specially indicated, the capabilities shown in the tables apply to both the E1962B and the E6702A/B applications.

  • Support of TIA/EIA-98-E Standards (for IS-95/IS-2000) shows the minimum performance tests for CDMA mobile stations as given in TIA/EIA-98-E test standard (C.S0011 test standard is identical to TIA/EIA-98-E).
  • Support of TIA-1035 Standards (for IS-95/IS-2000) shows the minimum signaling conformance test for CDMA mobile stations as given in TIA-1035 test standard (C.S0043-0 test standard is identical to TIA-1035).
  • Support of TIA/EIA-690 Standards (for AMPS) shows the minimum performance tests for AMPS mobile stations as given in TIA/EIA-690 standard.
Support of TIA/EIA-98-E Standards (for IS-95/IS-2000)

TIA/EIA-98-E

Supported by E1962B or E6702A/B

1.3 Fundamental Channel Test Mode 1 (F/R RC1)

 Yes. Supports SO2 and SO55 on Traffic Channel.

1.3 Fundamental Channel Test Mode 2 (F/R RC2)

 Yes. Supports SO9 and SO55 on Traffic Channel.

1.3 Fundamental Channel Test Mode 3 (F/R RC3)

 Yes. Supports SO2 and SO55 on F-FCH & R-FCH.

1.3 Supplemental Channel Test Mode 3 (Forward RC3)

 Yes. Supports SO32 (TDSO) on F-SCH.

1.3 Supplemental Channel Test Mode 4 (F-RC4 & R-RC3)

 Yes. Supports SO2 and SO55 on F-FCH & R-FCH.

1.3 Supplemental Channel Test Mode 4 (Forward RC4)

 Yes. Supports SO32 (TDSO) on F-SCH.

1.3 Fundamental Channel Test Mode 5 (F-RC5 & R-RC4)

 Yes. Supports SO9 and SO55 on F-FCH & R-FCH.

1.3 Supplemental Channel Test Mode 5 (Forward RC5)

 Yes. Supports SO32 (TDSO) on F-SCH.

3.1 Frequency Requirements

Yes. Supports Band Class 0, 1, 3, 4, 5, 6 ,10, 14 & 15.

3.2.1.1 Idle Handoff in Non-slotted Mode (Test 1)

 No.

3.2.1.1 Idle Handoff in Non-slotted Mode (Test 2)

 No.

3.2.1.2 Idle Handoff in Slotted Mode on Paging Channel

 No.

3.2.1.3 Idle Handoff in Slotted Mode on Forward Common Control Channel

No.

3.2.1.4 Idle Handoff to another frequency

No.

3.2.2.1 Neighbor Set Pilot Detection & Incorrect Detection in Soft Handoff

Yes. Only available with the E6702A/B lab application.

Requires automation to achieve proper timing. See How Do I Make Soft/Softer Handoff Tests Regarding T_Add? .

3.2.2.2 Candidate Set Pilot Detection & Incorrect Detection in Soft Handoff

Yes. Only available with the E6702A/B lab application.

Requires automation to achieve proper timing. See How Do I Make Soft/Softer Handoff Tests Regarding T_Comp? .

3.2.2.3 Active Set Pilot Loss Detection in Soft Handoff

Yes. Only available with the E6702A/B lab application.

Requires automation to achieve proper timing. See How Do I Make Soft/Softer Handoff Tests Regarding T_Drop/T_TDrop? .

3.2.3.1 Access Probe Handoff

No.

3.2.3.2 Access Handoff

No.

3.3.1 Demodulation of Non-Slotted Paging Channel with AWGN

No.

3.3.2 Demodulation of slotted Paging Channel with AWGN

Yes. Only available with the E6702B lab application.

See Measuring Paging Channel Message Error Rate (MER) .

3.3.3 Demodulation of Broadcast Control Channel in AWGN

 No. Possible future enhancement.

3.3.4 Demodulation of Broadcast Control Channel in Multipath Fading Channel.

 No. Possible future enhancement.

3.3.5 Demodulation of forward Common Control Channel

 No. Possible future enhancement.

3.3.6 Reception of Common Power Control Channel and Common Assignment Channel

No. Possible future enhancement.

3.3.6.2.1 Spreading Rate 1 Forward Common Power Control Channel and Common Assignment Channel with Rate = 1/4

No. Possible future enhancement.

3.3.6.2.2 Spreading Rate 1 Forward Common Power Control Channel and Common Assignment Channel with Rate = 1/2

No. Possible future enhancement.

3.3.6.2.3 Spreading Rate 1 Forward Common Power Control Channel and Common Assignment Channel with Rate = 1/2

No. Possible future enhancement.

3.4.1 Demodulation of Forward Fundamental Channel with AWGN

Yes.

For F-FCH test, use loopback service options SO2, SO9, or SO55. See Frame Error Rate (FER) Measurement Description .

For F-SCH test, use SO32 (TDSO - Test Data Service Option). See TDSO Frame Error Rate Measurement Description .

3.4.2 Demodulation of Forward Fundamental Channel with Fading

Yes. Only available with the E6702B lab application. Requires external fader and AWGN generator*** to perform the test.

3.4.3 Demodulation of Forward Fundamental Channel During Soft Handoff

Yes. Only available with the E6702A/B lab application.

Requires external fader and AWGN generator*** to perform the test.

3.4.4 Decision of Power Control Bit for Channels Belonging to Different Power Control Sets During Soft Handoff - Test 1 and Test 2

Yes. Only available with the E6702A/B lab application.

The test can be functionally performed. See How Do I Test Mobile Station (MS) Closed Loop Power Control (CLPC) Behavior in Soft/Softer Handoff? .

3.4.5 Decision of Power Control Bit for Channels Belonging to the Same Power Control Set

Yes. Only available with the E6702A/B lab application.

The test can be functionally performed. See How Do I Test Mobile Station (MS) Closed Loop Power Control (CLPC) Behavior in Soft/Softer Handoff? .

3.4.6 Demodulation of Power Control Subchannel During Soft Handoff

Yes. Only available with the E6702A/B lab application.

The test can be functionally performed. See General Procedures for Soft/Softer Handoff Tests to establish a soft handoff and see Channel Power Measurement Description to measure the output power.

3.4.7 Demodulation of Forward Traffic Channel in Multipath Fading Channel with Closed Loop Power Control (FPC_MODE=000)

Yes. Only available with the E6702B lab application.

Requires external fader and AWGN generator*** to perform the test. See How Do I Perform FPC Test (FPC Mode 000)? .

3.4.8 Demodulation of Forward Traffic Channel During Soft Handoff with Closed Loop Power Control (FPC_MODE=000)

 No.

3.4.9 Demodulation of Forward Traffic Channel in Multipath Fading Channel with Closed Loop Power Control (FPC_MODE=000 or 100)

Partially. Supports for FPC_MODE=000 and only available with the E6702B lab application.

Requires external fader and AWGN generator*** to perform the test. See How Do I Perform FPC Test (FPC Mode 000)? .

3.4.10 Demodulation of Forward Traffic Channel in Multipath Fading Channel with Closed Loop Power Control (FPC_MODE=000) and Transmit Diversity (OTD or STS)

 No. Possible future enhancement.

3.4.11 Demodulation of Power Control Subchannel During Reverse Pilot Channel Gating

 No. Possible future enhancement.

3.4.12 Demodulation of Power Control Subchannel During Reverse Fundamental Channel Gating

 No. Possible future enhancement.

3.4.13 Behavior of the Quality Indicator Bit of the Forward Dedicated Control Channel

 No. Possible future enhancement.

3.5.1 Receiver Sensitivity and Dynamic Range

Yes. See Frame Error Rate (FER) Measurement Description .

3.5.2 Single Tone Desensitization Tests 1 and 2

Yes. Requires an external CW signal generator*.

3.5.3 Intermodulation Spurious Response Attenuation Tests 1 and 2

Yes. Requires two external CW signal generators*.

3.5.4 Adjacent Channel Selectivity

Yes. Requires an external CDMA signal generator*.

3.5.5 Receiver Blocking Characteristics (Band Class 6)

Yes. Requires an external CW signal generator*.

3.6.1 Conducted Spurious Emissions

No. Use external spectrum analyzer** to make the test.

3.6.2 Radiated Spurious Emissions

No. Use external spectrum analyzer** to make the test.

3.7.1 Supervision Paging Channel

Partially. The test set does not provide timing measurements.

3.7.2 Supervision Forward Channel - Test 1 and Test 2

 No. The test set has no provision for sending corrupted frames as required in this test.

4.1 Transmit Frequency Accuracy

Yes, uses the rho or EVM measurement method.

See Waveform Quality/Code Domain Measurement Description .

4.2.1 CDMA to CDMA Hard Handoff

Partially. The test set performs F1 to F2 Hard handoffs, but cannot make the required timing measurement.

4.2.2 Transmit Power after Hard Handoff

 No.

4.2.3 Candidate Frequency Single Search

 No.

4.3.1 Time Reference

Yes, uses the rho or EVM measurement method.

See Waveform Quality/Code Domain Measurement Description .

4.3.1 Time Reference Slew Rate

Partially, requires an external fader & external timing measurement device.

See Waveform Quality/Code Domain Measurement Description .

4.3.2 Reverse Pilot Channel to Code Channel Time Tolerance

Yes.

See Code Channel Time/Phase Error Measurement Description .

4.3.3 Reverse Pilot Channel to Code Channel Phase Tolerance

Yes.

See Code Channel Time/Phase Error Measurement Description .

4.3.4 Waveform Quality and Frequency Accuracy

Yes, uses the rho or EVM measurement method.

The test set also measures multi-coded waveform quality, a non-standard but more useful measurement.

See Waveform Quality/Code Domain Measurement Description .

4.3.5 Code Domain Power

Yes.

See Waveform Quality/Code Domain Measurement Description .

4.4.1 Range of Open Loop Output Power

Yes. Both Access Channel and Enhanced Access Channel are supported.

See Access Probe Power Measurement Description or Graphical Access Probe Power Measurement Description (only available in lab application).

4.4.2 Time Response of Open Loop Power Control

Yes.

See Time Response of Open Loop Power Control (TROLPC) Measurement Description .

4.4.3 Access Probe Output Power

Yes. Both Access Channel and Enhanced Access Channel are supported.

See Access Probe Power Measurement Description or Graphical Access Probe Power Measurement Description (only available in lab application).

4.4.4 Range of Closed Loop Power Control

Partially. The test set can verify the control range in dB.See Testing 4.4.4 Range of Closed Loop Power Control

The test set can not make timing measurements. Test 2 not supported. Use an external spectrum analyzer** to make the test.

4.4.5 Maximum RF Output Power

Yes.

Uses either Digital Average Power Measurement Description or Maximum/Minimum Power Measurement Description to make the test.

4.4.6 Minimum Controlled Output Power

Yes.

Uses either Channel Power Measurement Description or Maximum/Minimum Power Measurement Description to make the test.

4.4.7 Standby Output Power and Gated Output Power

Partially. Supports graphical gated power measurement but can not measure standby output power.

See Gated Power Measurement Description .

4.4.8 Power up Function Output Power

 No.

4.4.9 Code Channel to Reverse Pilot Output Power Accuracy

Yes. See Waveform Quality/Code Domain Measurement Description .

4.4.10 Reverse Pilot Channel Phase Discontinuity

No. The test set provides call setup.

Use external spectrum analyzer** to make the measurement.

4.4.11 Reverse Traffic Channel Output Power During Changes in Data Rate

 No.

4.5.1 Conducted Spurious Emissions

Yes.

See Tx Spurious Emissions Measurement Description .

4.5.2 Radiated Spurious Emissions

No. Requires external spectrum analyzer**.

4.5.3 Occupied Bandwidth (Band classes 3 & 6 only)

No. Requires external spectrum analyzer**.

* Such as the E4438C ESG Vector Signal Generator.

** Such as the E4445A PSA Spectrum Analyzer.

*** Such as the E5515C Fading Solution. See Digital Bus Information for reference information.

Support of TIA-1035 Standards (for IS-95/IS-2000)
TIA-1035 | Supported by E1962B or E6702A/B
9.8 WLL Call Waiting Indicator Support | Yes. Supports Mobile Station Test.
Support of TIA/EIA-690 Standards (for AMPS)
TIA/EIA-690 | Supported by E1962B/E6702A/B
AMPS RECEIVER TESTS
2.1.1 Frequency Coverage | Yes.
2.1.1 Type of Modulation | Yes.
2.2.2.1 Electrical Audio Frequency Response | Yes.
2.2.2.2 Audio Muting | Yes.
2.2.2.3 Expandor | Yes.
2.2.2.4 Hum and Noise | Yes.
2.2.2.5 Audio Distortion | Yes.
2.2.2.6 Receive Audio Frequency Response | Yes, but requires an external "artificial ear" acoustic coupler to measure mobile speaker sound pressure level. The test set can set up the call and provide proper signal to the mobile station.
2.2.3 Demodulated Data and Control Signals | No.
2.2.3.1 Manchester Decoding | No.
2.2.3.2 Supervisory Audio Tone (SAT) Decoding | No.
2.3.1 RF Sensitivity | Yes.
2.3.2 Adjacent and Alternate Channel Desensitization | Yes. The test set can perform the necessary call processing and SINAD measurements, but requires a single external CW signal generator* to perform per the standard.
2.3.3 Intermodulation Spurious Response Attenuation | Yes. The test set can perform the necessary call processing and SINAD measurements, but requires two external CW signal generator* to perform per the standard.
2.3.4 Protection Against Spurious Response Interference | Yes. The test set can perform the necessary call processing and SINAD measurements, but requires a single external CW signal generator* to perform per the standard.
2.3.5 Bit Error Rate | No.
2.4 Conducted Spurious Emissions | No, requires an external spectrum analyzer**.
2.5 Radiated Spurious Emissions | No, requires an external spectrum analyzer**.
2.6 Received Signal Strength Indicator (RSSI) | Partially, requires access to the RSSI signal in the mobile station.
AMPS TRANSMITTER TESTS
3.1.1 Frequency Coverage | Yes. 500 MHz to 1000 MHz frequency coverage.
3.1.2 Frequency Stability | Yes. Standard timebase is accurate to 0.1 ppm per year.
3.1.3 Carrier Switching Time | No, requires an external spectrum analyzer** with zero span capability.
3.1.3 Carrier Switching Time | No, requires an external spectrum analyzer** with zero span capability.
3.1.4 Channel Switching Time | No, requires an external spectrum analyzer** with zero span capability.
3.2.1 RF Power Output | Yes. Uses Internal Power Meter down to -10 dBm.
3.2.2 RF Power Transition Time | No, requires an external spectrum analyzer** with zero span capability.
3.2.3 Carrier-On State | No.
3.3.1 Modulation Type and Modulation Stability | Yes.
3.3.2.1 Compressor | Yes.
3.3.2.2 Transmit Electrical Audio Response | Yes.
3.3.2.3 Modulation Deviation Limiting | Partially. The test set can perform the steady state measurement, but cannot perform the instantaneous peak measurement.
3.3.2.4 Audio Voice Path Muting | Yes.
3.3.2.5 Transmit Audio Frequency Response | Yes, but requires an acoustic coupler.
3.3.2.6 Transmit Audio Sensitivity | Yes, but requires an acoustic coupler.
3.3.3 Wideband Data | No.
3.3.4 Supervisory Audio Tone (SAT) | Yes.
3.3.5 Signaling Tone (ST) | Partially, requires an automated control program to capture ST deviation.
3.3.6 FM Hum and Noise | Yes.
3.3.7 Residual Amplitude Modulation (AM) | No.
3.3.8 Modulation Distortion and Noise | Yes.
3.4.1 Spectrum Noise Suppression - Broadband | No.
3.4.2 Harmonic and Spurious Emissions (Conducted) - Discrete | No, requires an external spectrum analyzer**.
3.4.3 Harmonic and Spurious Emissions (Radiated) - Discrete | No, requires an external spectrum analyzer**.

* Such as the E4438C ESG Vector Signal Generator.

** Such as the E4445A PSA Spectrum Analyzer.


Audio Frequency Measurement Description

Audio Frequency Measurement Description

Last updated: October 28, 2004

How is an Audio Frequency measurement made?

Audio Frequency measures the frequency of the signal applied to the front-panel AUDIO IN connectors, and is one of the Audio Analyzer measurements. Audio frequency can be measured for signals in the frequency range of 100 Hz to 15 kHz, at levels from 7.1 mV peak to 20V peak, and with a signal-to-noise ratio of 30 dB or greater.

The audio frequency measurement is made after any filtering and processing are selected for the Audio Analyzer.

Considerations When Making Manual Audio Frequency Measurements

When manually controlling the test set from the front panel, all measurements default to using continuous triggering. If you make digital measurements on a DTC using RF Rise or Protocol triggering, and then hand off to an AVC and select an analog measurement, the analog measurement may not trigger and display a result. This is because the digital measurement is still waiting for a burst transmission to trigger it (which it won't get from an analog signal) and therefore the measurements "freeze". To prevent this from happening when making analog measurements, either turn off the digital measurements or set their trigger source to Immediate.

Related Topics

Programming an Audio Frequency Measurement


Audio Level Measurement Description

Audio Level Measurement Description

Last updated: October 28, 2004

How is an Audio Level measurement made?

Audio Level measures the AC voltage of the signal applied to the front-panel AUDIO IN connectors, and is one of the Audio Analyzer measurements. Audio Level can be measured for signals in the frequency range of
100 Hz to 20 kHz, at levels from 1 mV peak to 20V peak . The measurement is made after any filtering is applied, and can be made using an rms or peak detector. The type of detector being used for the measurement is displayed next to the measurement value.

When measuring very low voltages, it may be helpful to use the Audio Analyzer's adjustable bandpass filter and the rms detector to reduce noise components.

For information on using the Audio Analyzer, see Audio Analyzer Measurement Description .

This measurement is not affected by the Amplitude Offset setting.

Considerations When Making Manual Audio Level Measurements

When manually controlling the test set from the front panel, all measurements default to using continuous triggering. If you make digital measurements on a DTC using RF Rise or Protocol triggering, and then hand off to an AVC and select an analog measurement, the analog measurement may not trigger and display a result. This is because the digital measurement is still waiting for a burst transmission to trigger it (which it won't get from an analog signal) and therefore the measurements "freeze". To prevent this from happening when making analog measurements, either turn off the digital measurements or set their trigger source to Immediate.

Related Topics

Programming an Audio Level Measurement


Audio Analyzer Block Diagram

Audio Analyzer Block Diagram

Last updated: October 28, 2004

Related Topics

Audio Analyzer Measurement Description


Audio Analyzer Measurement Description

Audio Analyzer Measurement Description

Last updated: October 28, 2004

How is an analog audio measurement made?

The Audio Analyzer can measure Audio Level (V), SINAD (dB), Distortion (%), and Audio Frequency. Measurements are made through the test set's front panel AUDIO IN connectors. When measuring a mobile's audio output, the audio signal may come from either an acoustic coupler or from a test interface connection to the mobile's audio circuitry.

See Audio Analyzer Block Diagram .

The AUDIO IN connectors feed the inputs to a floating-input differential amplifier, with each input having an impedance of about 100,000 ohms to chassis ground. For best noise immunity, connect the audio signal and its ground reference to the two input ports through shielded coaxial cables, or input the signal to the AUDIO IN HI connector and ground the AUDIO IN LO connector's center contact.

None of the analog audio measurement results are affected by the Amplitude Offset setting.

SINAD/Distortion State

Select On or Off to enable or disable the SINAD and Distortion measurements. When On, these measurement results are displayed below the Audio Level measurement and the SINAD/Distortion Fundamental Frequency must be entered to specify the audio frequency for the measurement (range: 100 Hz to 10 kHz). When Off, four dashes are displayed in place of the measurement results.

Audio Frequency State

Select On or Off to enable or disable the Audio Frequency measurement.

Filter Type

  • None - no filtering is provided (default).
  • 100 Hz BW Band Pass Filter (Tunable) - The 100 Hz BW BPF Center Frequency setting is available when this filter is selected, and can be set in the range of 300 Hz to 15 kHz.
  • C-Message
  • 50 Hz to 15 kHz
  • 300 Hz to 15 kHz

Detector Type

Select either Peak or RMS (default) for making and displaying an Audio Level measurement (does not affect other measurements). The type of detector selected is displayed next to the Audio Level measurement results. A 1-volt rms sinewave input signal would measure 1.414 V Peak when the Peak detector is used. A 1-volt peak input signal would measure 0.707 V RMS when the RMS detector is used.

Expected Peak Voltage

The Expected Amplitude sets the analog audio clipping level and must be set. This voltage is always the absolute peak audio input signal voltage expected at the AUDIO IN connectors, and must be in the range of 7.07 mV peak (5 mVrms) to 20 V peak . Remember, measuring a 1-volt rms sinewave input signal would require a 1.414 V peak expected voltage value to avoid clipping (over-driving) the input.

De-Emphasis State

Set to On or Off (default) to enable or disable 750 microsecond de-emphasis.

Expandor Reference Level

Set value from 10 mV/kHz to 10 V/kHz, or Off (default). Entering a numeric value automatically turns the state to On. Entering Off disables the expandor (state = off).

Trigger Source

Audio Analyzer measurements use immediate triggering and are continuously re-triggered by the analyzer any time the Trigger Arm parameter is set to Continuous. Trigger timing is independent of any mobile protocol signaling.

Considerations When Making Manual Audio Analyzer Measurements

When manually controlling the test set from the front panel, all measurements default to using continuous triggering. If you make digital measurements on a DTC using RF Rise or Protocol triggering, and then hand off to an AVC and select an analog measurement, the analog measurement may not trigger and display a result. This is because the digital measurement is still waiting for a burst transmission to trigger it (which it won't get from an analog signal) and therefore the measurements "freeze". To prevent this from happening when making analog measurements, either turn off the digital measurements or set their trigger source to Immediate.

Related Topics

Audio Analyzer Block Diagram

AFANalyzer Troubleshooting

Audio Level Measurement Description

Audio Frequency Measurement Description

SINAD Measurement Description

Distortion Measurement Description

Programming an Audio Frequency Measurement

Programming an Audio Level Measurement

Programming an SINAD Measurement

Programming a Distortion Measurement

Statistical Measurement Results (Multi-measurements)


Distortion Measurement Description

Distortion Measurement Description

Last updated: October 28, 2004

How is a Distortion measurement made?

Distortion is an audio quality measurement that compares the audio signal level from the mobile at a specified (desired) frequency to the level of signals present at other frequencies. The audio signals from the mobile are typically demodulated tones sent over an analog voice channel (AVC).

The test set makes two measurements to determine distortion. First, the test set measures the total audio signal level into the Audio Analyzer. Next, a precise notch filter is then used to remove the signal at the specified frequency. The remaining signal level indicates the level of unwanted signals (distortion). Distortion is expressed as a percentage of the total audio signal.

Distortion can be measured in the range of 100 Hz to 10 kHz. For information on using the Audio Analyzer, see Audio Analyzer Measurement Description .

The distortion measurement can be used to perform the audio harmonic distortion test. In this test, two audio signals are used: a 1004 Hz tone and the 6000 Hz SAT. The 1004 Hz tone is notched out to make the measurement. See IS-137A, section 2.2.2.5 for more information.

Considerations When Making Manual Distortion Measurements

When manually controlling the test set from the front panel, all measurements default to using continuous triggering. If you make digital measurements on a DTC using RF Rise or Protocol triggering, and then hand off to an AVC and select an analog measurement, the analog measurement may not trigger and display a result. This is because the digital measurement is still waiting for a burst transmission to trigger it (which it won't get from an analog signal) and therefore the measurements "freeze". To prevent this from happening when making analog measurements, either turn off the digital measurements or set their trigger source to Immediate.

Related Topics

Audio Analyzer Measurement Description


SINAD Measurement Description

SINAD Measurement Description

Last updated: October 28, 2004

How is a SINAD measurement made?

SINAD is a receiver audio quality measurement for mobiles on an analog voice channel (AVC). It is the ratio of Signal+Noise+Distortion divided by Noise+Distortion, expressed in dB. SINAD is measured using the test set's Audio Analyzer. SINAD can be measured in the range of 100 Hz to 10 kHz. For information on using the Audio Analyzer, see Audio Analyzer Measurement Description .

The SINAD measurement is used to determine receiver RF sensitivity. SINAD is usually measured either of two ways:

  • Reduce the Cell Power from the test set until 12 dB SINAD is displayed (re-triggering for each measurement), or
  • Set the Cell Power from the test set to a specified low level and verify SINAD reading is no less than 12 dB.

See IS-137A, section 2.3.1.1, for more information.

Difference in Agilent 8960 Series 10 and 8920B Test Set SINAD Measurements

If you have previously used the Agilent 8920B RF Communications Test Set to measure SINAD, you may notice that the Agilent 8960 Series 10 test set's SINAD value may be lower by up to 0.8 dB when measuring 12 dB SINAD. This is due to the more precise digital notch filter used by the 8960, causing a more accurate noise measurement to be made. The 8920B uses an analog filter that does not have as tight a filter notch as the 8960.

Considerations When Making Manual SINAD Measurements

When manually controlling the test set from the front panel, all measurements default to using continuous triggering. If you make digital measurements on a DTC using RF Rise or Protocol triggering, and then hand off to an AVC and select an analog measurement, the analog measurement may not trigger and display a result. This is because the digital measurement is still waiting for a burst transmission to trigger it (which it won't get from an analog signal) and therefore the measurements "freeze". To prevent this from happening when making analog measurements, either turn off the digital measurements or set their trigger source to Immediate.

Related Topics

Measuring SINAD Sensitivity

Programming an SINAD Measurement

Audio Analyzer Measurement Description

AFANalyzer Troubleshooting

Test Adherence to Standards


Analog Transmit Power Measurement Description

Analog Transmit Power Measurement Description

Last updated: October 28, 2004

How is an Analog Transmit Power measurement made?

Analog Transmit Power measures the mean power from the mobile at the test set's RF IN/OUT port when transmitting an analog carrier. The test set correctly measures the level with or without frequency modulation (FM) present to make AMPS power measurements. Tests can be made with the mobile in the analog test mode or when connected on an active voice channel. See IS-137A, section 3.2.1.1, Analog RF Power.

The trigger source for this measurement is always immediate.

Input Signal Requirements

The Analog Transmit Power measurement meets or exceeds specifications when the following requirements are met:

  • The frequency of the signal being measured must be in the range of 800 MHz to 960 MHz or 1.7 GHz to 2.0 GHz, and within 100 kHz of the expected frequency.
  • The signal level into the test set's RF IN/OUT connector must be in the range of -25 dBm to +43 dBm peak, and within 3 dBm of the expected input power to meet specifications. Results are provided for signals within +5 dB to -10 dB of the expected power, but performance is not warranted.

See Active Cell Operating Mode , and Receiver Control for information on setting the expected input frequency and power level.

Considerations When Making Manual Analog Transmit Power Measurements

When manually controlling the test set from the front panel, all measurements default to using continuous triggering. If you make digital measurements on a DTC using RF Rise or Protocol triggering, and then hand off to an AVC and select an analog measurement, the analog measurement may not trigger and display a result. This is because the digital measurement is still waiting for a burst transmission to trigger it (which it won't get from an analog signal) and therefore the measurements "freeze". To prevent this from happening when making analog measurements, either turn off the digital measurements or set their trigger source to Immediate.

Related Topics

Analog Transmit Power Troubleshooting

Programming an Analog Transmit Power Measurement

Test Adherence to Standards

Statistical Measurement Results

Triggering of Measurements

Timeouts


Calibrating the Test Set

Calibrating the Test Set

Last updated: June 20, 2007

Description

  • Calibration Process Requirements
  • Recommended Calibration Intervals
  • Calibration Descriptions
    • IQ Calibrations
    • Burst Mod Offset 1 Calibration
    • Thermal Power Null Adjustment
    • Digital Average Power Calibration
    • Spectrum Monitor Calibration
    • Channel Power Calibration
    • Calibrate Measurements

Various calibration routines must be run periodically to ensure measurement accuracy, source accuracy and allow the most robust demodulation of the device-under-test's signal. This document describes the various calibrations available in the test set and when they should be performed.

Calibration Process Requirements

IMPORTANT
Before performing any calibrations on your test set:

  • Ensure that the calibration is necessary - running calibrations more often than necessary wastes your time and effort, and if the calibration is performed incorrectly, could actually result in degraded test set performance.
  • Ensure that the test set is in its ambient operating environment - in other words, ensure that the test set has warmed up (at least 30 minutes) and is in a location similar to the one it will be used in. For example, if you are going to be using the test set in a racked test system, then you must calibrate the test set while it is in that test system, and all of the equipment has reached a stable operating temperature.
  • Ensure that no power is present at the front panel RF connectors - remove any cables or connectors from the RF IN/OUT and RF OUT ONLY connectors. If you are operating in a high RF environment, it is recommended that you also terminate the RF connectors with a 50 Ohm load.

Recommended Calibration Intervals

This section indicates when the test set calibrations should be performed. Procedures are given for test sets that include Option 003: Flexible Radio Link and test sets that do not. Refer to Calibration Descriptions for details about the calibrations and how to perform them.

  • Once every year you must perform a full calibration by following steps 1-7 of the Calibration Procedure for Test Sets with Option 003 (or steps 1-2 of the Calibration Procedure for Test Sets without Option 003 if your test set does not include option 003).
  • You must also perform steps 1-7 of the Calibration Procedure for Test Sets with Option 003 (or steps 1-2 of the Calibration Procedure for Test Sets without Option 003 if your test set does not include option 003) if any of the following events occur:
    • When you receive the test set, before using it for the first time (regardless of whether the test set is new, being returned from service, or on loan from a colleague).
    • After adding a new application or format to the test set.
      Note: Upgrading firmware already present in the test set does not typically require running the calibration procedures. However, when upgrading firmware, it is advisable to check the release notes for any major feature changes that require re-calibration of the test set.
    • After you perform any kind of repair or service on your test set.
  • It is recommended that once every month you perform steps 4-7 of the Calibration Procedure for Test Sets with Option 003 (or step 2 of the Calibration Procedure for Test Sets without Option 003 if your test set does not include option 003).
  • You must also perform steps 4-7 of the Calibration Procedure for Test Sets with Option 003 (or step 2 of the Calibration Procedure for Test Sets without Option 003 if your test set does not include option 003) if any of the following events occur:
    • The operating environment for your test set changes significantly (for example, the temperature changes by more than 10 degrees C or the test set is moved from a racked test system to a bench top).
    • A measurement returns integrity indicator 19 ( Uncalibrated Due to Temperature ).

IMPORTANT
Ensure that your test set has warmed up at least 30 minutes and that no power is present at the front panel RF connectors before performing any calibrations.

Calibration Procedure for Test Sets with Option 003

Calibration Procedure for Test Sets without Option 003

Calibration Descriptions

If any of the following calibrations fail, ensure that you have followed the Calibration Process Requirements and have performed the calibrations in the order prescribed by Recommended Calibration Intervals . If the calibration still fails, contact your local Agilent Sales Representative for assistance.

IQ Calibrations

When performed from a GSM/GPRS/EGPRS or AMPS/136 application or format, the First IQ Modulator calibration sends a signal from the Baseband Generator 1 module to the RF Source 1 module to optimize the phase accuracy of RF Source 1 as a function of frequency. The optimization data is then stored in the test set and accessed whenever the RF Source frequency is set. The Second IQ Modulator calibration performs a similar procedure for RF Source 2 (RF Source 2 is only present if the test set includes option 002: RF Source 2).

When performed from a W-CDMA/HSDPA, cdma2000/IS-95/AMPS or 1xEV-DO application or format (which require option 003: Flexible Radio Link), the IQ calibrations perform the same phase optimizations explained above. Additionally, a signal is sent from the Flexible Radio Link Subsystem to the RF sources to calibrate phase accuracy for those alternative paths as well. This additional calibration data is written to the same calibration data file as above, but in a different area of the calibration table.

The IQ calibrations ensure that the test set accurately generates IQ-modulated signals. If the test set's IQ modulators have not been properly calibrated, the test set's output power (when producing an IQ-modulated signal) will be inaccurate, which may result in degraded receiver test results.

If you perform the IQ calibrations from a W-CDMA/HSDPA, cdma2000/IS-95/AMPS or 1xEV-DO application or format, you do not need to perform them from any other application or format. However, note that if you perform the IQ calibrations from a GSM/GPRS/EGPRS or AMPS/136 application/format, you must still perform them once from a W-CDMA/HSDPA, cdma2000/IS-95/AMPS or 1xEV-DO application or format.

The IQ calibrations do not need to be run frequently. See Recommended Calibration Intervals .

To initiate the IQ calibrations from the front panel, press SYSTEM CONFIG , press the right More ( 1 of 2 ) key, select Service ( F7 ), then select Cal. first IQ Modulator or Cal. second IQ Modulator . To initiate the IQ calibrations from a remote program, use the CALibration:IQ[1]|2? queries.

Each IQ calibration takes 5-6 minutes to execute.

Burst Mod Offset 1 Calibration

This calibration is only applicable to W-CDMA/HSDPA, cdma2000/IS-95/AMPS, and 1xEV-DO applications and formats. This calibration is only required when using the test set to generate an AM or DSB-SC test signal (select ( F9 ) Test Signal when in CW Operating Mode ). These test signals are used for calibrating Zero Intermediate Frequency (Zero IF) devices which utilize Qualcomm's radioOne™ architecture.

You do not have to perform the Burst Mod Offset 1 calibration for each application/format in your test set; performing it from one application/format provides calibration data to all relevant applications and formats.

The Burst Mod Offset 1 calibration does not need to be run frequently. See Recommended Calibration Intervals .

The Burst Mod Offset 1 calibration calibrates the noise and signal level of RF Source 1 (as a function of frequency) to most accurately produce the AM and DSB-SC test signals required for Zero IF device calibration. The calibration is performed by generating the modulated test signals and adjusting RF Source 1 to optimize gain and minimize the noise floor. The optimization data is then stored in the test set and accessed whenever the RF Source frequency is set.

To initiate the Burst Mod Offset 1 calibration from the front panel, press SYSTEM CONFIG , press the right More ( 1 of 2 ) key, select Service ( F7 ), then select Cal. Burst Mod Offset 1 . To initiate the Burst Mod Offset 1 calibration from a remote program, use the CALibration:BMOFfset? query.

The Burst Mod Offset 1 calibration takes less than 1 minute to execute.

Thermal Power Null Adjustment

The Thermal Power Null Adjustment is only applicable to the cdma2000/IS-95/AMPS, 1xEV-DO and W-CDMA/HSDPA applications/formats.

The Thermal Power Detector is calibrated at the factory and temperature controlled for stability. However, it is still possible for the auto-null circuit within the detector to drift over time. The Thermal Power Null Adjustment re-centers the auto-null circuit to provide optimum accuracy for the affected measurements.

You only need to perform the Thermal Power Null Adjustment once to re-center the auto-null circuit (you do not have to perform it from each application/format in your test set).

NOTE
Older application releases loaded on your test set may not include the Thermal Power Null Adjustment feature. Any applications that do not include the Thermal Power Null Adjustment feature (in the Utilities menu of the System Config screen) do not use the re-centering data and thus do not achieve the accuracy optimization that results from re-centering the auto-null circuit. You must upgrade those applications if you wish to achieve the accuracy optimization that results from running the Thermal Power Null Adjustment .

The Thermal Power Null Adjustment does not need to be run frequently. See Recommended Calibration Intervals .

This adjustment affects the Thermal Power (W-CDMA/HSDPA) measurement, as well as all measurements that are calibrated by the Digital Average Power Calibration (cdma2000/IS-95/AMPS, 1xEV-DO) and Calibrate Measurements (W-CDMA/HSDPA) routine.

To initiate the Thermal Power Null Adjustment from the front panel, press SYSTEM CONFIG , press the right More ( 1 of 2 ) key, and select Thermal Power Null Adjust ( F9 ). To initiate the Thermal Power Null Adjustment from a remote program, use the SYSTem:INSTrument:THERmal:POWer:NULL:ADJust? query.

The Thermal Power Null Adjustment takes between 30 seconds and 3 minutes.

The Thermal Power Null Adjustment can also be used to help verify your test set. See "Verifying the Test Set" in the Related Topics below.

Digital Average Power Calibration

The Digital Average Power calibration is only applicable to the cdma2000/IS-95/AMPS and 1xEV-DO applications/formats.

You do not have to perform the Digital Average Power calibration for each application/format in your test set; performing it from one application/format provides calibration data to all relevant applications and formats.

The Digital Average Power calibration does not need to be run frequently. See Recommended Calibration Intervals .

IMPORTANT
You must cycle the test set's power after the Digital Average Power calibration is complete in order to complete the calibration (the calibration data is not available to the test set until it has been restarted).

The Digital Average Power calibration generates calibration data for the Fast Power Detector for use by cdma2000/IS-95/AMPS and 1xEV-DO applications and formats. This calibration improves the accuracy of the Fast Power Detector when used to measure IS-95 and reverse RC-1 and RC-2 signals.

The calibration generates a CW signal at a given power level, measures it using the Fast Power Detector, generates a CDMA-modulated signal at the same power level, measures it using the Fast Power Detector and notes the difference. The calibration then generates a CW signal at a given power level, measures it using the Thermal Power Detector, generates a CDMA-modulated signal at the same power level, measures it using the Thermal Power Detector and notes the difference. Calibration data is then created by comparing these results. This is repeated for several power levels.

The Digital Average Power calibration provides calibration data for the following measurements:

  • Digital Average Power
  • Maximum/Minimum Power

To initiate the Digital Average Power calibration from the front panel, press Measurement selection , select Digital Average Power , then select Calibrate Digital Avg Pwr (F4) . To initiate the Digital Average Power calibration from a remote program, use the CALibration:DAPower? query.

The Digital Average Power calibration takes approximately 9 minutes to execute.

Spectrum Monitor Calibration

Performing the Spectrum Monitor calibration from one application/format does not provide calibration data to all relevant applications and formats. The calibration data files are shared as follows:

  • cdma2000/IS-95/AMPS and 1xEV-DO share the same Spectrum Monitor calibration data file.
  • W-CDMA/HSDPA has its own Spectrum Monitor calibration data file.
  • GSM/GPRS/EGPRS and AMPS/136 share the same Spectrum Monitor calibration data file.

Thus, if you perform the Spectrum Monitor calibration from a 1xEV-DO application/format, you do not need to perform it from a cdma2000/IS-95/AMPS application/format. However you do still need to perform it from a W-CDMA/HSDPA application/format and then again from either a GSM/GPRS/EGPRS or AMPS/136 application/format.

The Spectrum Monitor calibration should be run monthly, or whenever the test set's operating environment changes. See Recommended Calibration Intervals .

Performing the Spectrum Monitor calibration from a cdma2000/IS-95/AMPS or 1xEV-DO application/format executes the same routine as performing the Channel Power Calibration .

Performing the Spectrum Monitor calibration from a W-CDMA/HSDPA application/format executes the same routine as performing the Calibrate Measurements routine.

Performing the Spectrum Monitor calibration from a GSM/GPRS/EGPRS or AMPS/136 application/format calibrates the IF signal path in the Measurement Downconverter, using a CW signal.

To initiate the Spectrum Monitor calibration from the front panel, press Instrument selection , select Spectrum Monitor , select Trigger Setup ( F4 ), then select Calibrate Measurement ( F11 ). To initiate the Spectrum Monitor calibration from a remote program, use the CALibration:SMONitor? query.

The Spectrum Monitor calibration takes between 45 seconds and 3 minutes to execute, depending upon which application/format it is executed from.

Channel Power Calibration

The Channel Power calibration is applicable to the cdma2000/IS-95/AMPS and 1xEV-DO applications/formats.

You do not have to perform the Channel Power calibration for each application/format in your test set; performing it from one application/format provides calibration data to all relevant applications and formats.

The Channel Power calibration should be run monthly, or whenever the test set's operating environment changes. See Recommended Calibration Intervals .

The Channel Power calibration calibrates the signal paths through the Measurement Downconverter and Demod Downconverter using both a CW signal and a modulated signal. The calibration is performed by comparing measured signals through the MDC and DDC to measurements made using the Fast Power Detector (which is calibrated at the factory and temperature controlled for stability). During the Calibrate Measurements calibration, the internal temperature of the test set is measured and stored with the calibration data. If the internal temperature of the test set drifts by more than +/- 10 C since the last calibration, measurements utilizing this calibration will return integrity indicator 19 ( Uncalibrated Due to Temperature ).

The Channel Power calibration provides calibration data for the following measurements:

  • Access Probe Power
  • Channel Power
  • Code Channel Time/Phase Error
  • Fast Device Tune ( lab application or feature-licensed test application only )
  • Gated Power
  • Graphical Access Probe Power ( lab application only )
  • Handoff Waveform Quality
  • Maximum/Minimum Power
  • Time Response of Open Loop Power Control
  • TX Dynamic Power
  • TX Spurious Emissions
  • Waveform Quality + Code Domain
  • Spectrum Monitor

Performing the Channel Power calibration executes the same routine as performing the Spectrum Monitor Calibration from a cdma2000/IS-95/AMPS or 1xEV-DO application/format.

To initiate the Channel Power calibration from the front panel, initiate any of the measurements listed above and select Calibrate Channel Power (F4) . To initiate the Channel Power calibration from a remote program, use the CALibration:CPOWer? query.

The Channel Power calibration takes approximately 2 minutes to execute.

Calibrate Measurements

The Calibrate Measurements routine is only applicable to W-CDMA/HSDPA applications/formats.

The Calibrate Measurements routine should be run monthly, or whenever the test set's operating environment changes. See Recommended Calibration Intervals .

The Calibrate Measurements routine calibrates the signal paths through the Measurement Downconverter and Demod Downconverter using both a CW signal and a modulated signal. The calibration is performed by comparing measured signals through the MDC and DDC to measurements made using the Fast Power Detector (for CW signals) and the Thermal Power Detector (for modulated signals). Both of these detectors are calibrated at the factory and temperature controlled for stability. During the Calibrate Measurements calibration, the internal temperature of the test set is measured and stored with the calibration data. If the internal temperature of the test set drifts by more than +/- 10 C since the last calibration, measurements utilizing this calibration will return integrity indicator 19 ( Uncalibrated Due to Temperature ).

The Calibrate Measurements routine provides calibration data for the following measurements:

  • Adjacent Channel Leakage Ratio
  • Channel Power
  • Change of TFC ( lab application only )
  • Code Domain
  • Dynamic Power Analysis
  • Extended Range Dynamic Power
  • Fast Device Tune ( lab application or feature-licensed test application only )
  • Inner Loop Power
  • IQ Tuning
  • Occupied Bandwidth
  • Phase Discontinuity
  • PRACH Preamble Analysis ( lab application only )
  • PRACH Transmit On/Off Power
  • Spectrum Emission Mask
  • Spectrum Monitor
  • TX Dynamic Power
  • Waveform Quality

Performing the Calibrate Measurements routine executes the same routine as performing the Spectrum Monitor Calibration from a W-CDMA/HSDPA application/format.

To initiate the Calibrate Measurements routine from the front panel, initiate any of the measurements listed above and select Calibrate Measurements (F4) . To initiate the Calibrate Measurements routine from a remote program, use the CALibration:MEASurements? query.

The Calibrate Measurements routine takes approximately 3 minutes to execute.

Calibration Links

CALibration Subsystem

CALibration

CW Operating Mode

Block Diagram

SYSTem:INSTrument


Code Channel Time/Phase Error Measurement Description

Code Channel Time/Phase Error Measurement Description

Last updated: October 28, 2004

  • How is a Code Channel Time/Phase Error measurement made?
  • Code Channel Time/Phase Measurement Graphical Display
  • Measurement Behavior
  • Input Signal Requirements
  • Key TIA/EIA-98-E Tests Using Code Channel Time/Phase Error Measurement
  • Calibrating the Code Channel Time/Phase Error Measurement

NOTE
If the Code Channel Time/Phase Error measurement is running at the time the power control transient transmission starts (see Starting the Reverse CLPC Transient ) the measurement will be closed and its operation aborted. Moreover, the Code Channel Time/Phase Error measurements will not be able to start (become initiated) while the transient transmission is in progress.

How is a Code Channel Time/Phase Error measurement made?

This measurement is designed to analyze signals that contain a reverse pilot channel. A call must be connected with one of the following radio configurations selected:

  • Fwd3, Rvs3
  • Fwd4, Rvs3
  • Fwd5, Rvs4

Each code channel timing and phase measurement tests the time and phase alignment of each code channel relative to the reverse channel pilot signal. The time error returns any offset, in nanoseconds, that is detected between the coding of each Walsh channel and the reverse channel pilot. The phase error measurement determines whether there is any phase difference that would cause a rotation in the I/Q constellation away from the decision points. See I/Q Constellation Showing Phase Error .

I/Q Constellation Showing Phase Error

Code channel time/phase error measurements are made by sampling the down-converted input signal, then applying DSP (Digital Signal Processing) techniques to determine the original data input to the mobile station transmitter's Walsh spreading function for each channel. The DSP then generates a representation of what the "ideal" signal would be given the coding and data in use at the time of transmission. The ideal waveform is then compared with the waveform being measured to determine code channel time error and phase error.

Code Channel Time/Phase Error Measurement Results lists the code channel time and phase measurement results:

Code Channel Time/Phase Error Measurement Results
Code Channel Time/Phase Error
Code Channel Time
Code Channel Phase

Code Channel Time/Phase Measurement Graphical Display

The Code Channel measurement displays the timing and phase error of reverse code channels. A marker can be positioned at any of the 16 Walsh code channels along the graph's horizontal axis. The Marker position field setting applies to both the Time and the Phase error graphs.

Code Channel Time/Phase Error shows an example display for the Code Channel Time/Phase Error measurement.

Code Channel Time/Phase Error

NOTE
If the amount of timing or phase error is negligible, the red error bars may momentarily disappear.

The IS-2000 system achieves high data rates by allowing supplemental channels to occupy multiple code channels. Each marker position displays one spread factor 16 code channel. To facilitate the display of high data rate channels occupying more than one marker positions in one contiguous (wide) bar, the Walsh code sequence along the graph's x-axis is displayed in "bit reversed" order to the marker position numbers 0 to 15. See Walsh Numbering on Code Channel Timing and Phase Graphs .

An example of bit reversal is shown in Walsh Channel Bit Reversal Marker Position 13 has a binary coded decimal value of 1101. If you reverse that sequence, the result is 1011. When 1011 is converted back to a decimal value, the result is Walsh code 11.

Walsh Channel Bit Reversal

Walsh Numbering on Code Channel Timing and Phase Graphs
Marker Position Number | 0 | 1 | 2 | 3 | 4 | 5 | 6 | 7 | 8 | 9 | 10 | 11 | 12 | 13 | 14 | 15
Walsh Code Channel (with spreading factor = 16) | 0 | 8 | 4 | 12 | 2 | 10 | 6 | 14 | 1 | 9 | 5 | 13 | 3 | 11 | 7 | 15

The timing and phase graphs, because of the bit-reversed order, can display channels with a spreading factor less than 16, such as the R-SCH (Reverse Supplemental Channel), using one bin 1 .

For example, Code Channel Timing Graph With R-SCH shows four active code channels displayed in four bins. In bin four, Walsh code channels 1, 3, 5, 7, 9, 11, 13, and 15 are all included in a single channel. If the Walsh numbering on the test set's display were sequential, then this channel would have to be displayed as eight bars, each separated by one Walsh code.

Code Channel Timing Graph With R-SCH

Measurement Behavior

Bin 0 corresponding with Walsh 0 will always return zero for Time Error zero and phase error because all other measurements are relative to the pilot channel, which is located at Walsh 0, bin 0.

Input Signal Requirements

The Code Channel Timing and Phase measurement meets or exceeds specifications when the following requirements are met:

  • The frequency of the signal being measured must be in the range of 412 MHz to 483 MHz, 800 MHz to 960 MHz, or 1.7 GHz to 2.0 GHz, and within 100 kHz of the expected frequency.
  • The signal level into the test set's RF IN/OUT connector must be in the range of -25 dBm to +37 dBm. The test set can autorange to a signal that is within +/- 9 dB of the expected input level (see RFANalyzer:AUTO:POWer[:SELected]? ).

Key TIA/EIA-98-E Tests Using Code Channel Time/Phase Error Measurement

  • Testing 4.3.2 Reverse Pilot Channel to Code Channel Time Tolerance
  • Testing 4.3.3 Reverse Pilot Channel to Code Channel Phase Tolerance

Calibrating the Code Channel Time/Phase Error Measurement

The code channel time/phase error measurement is automatically calibrated during a channel power calibration. Follow the channel power calibration schedule and the code channel time/phase error measurement will be properly calibrated. Refer to Calibrating the Test Set for a description of channel power calibration.

Related Topics

Measuring Code Channel Time/Phase Error

Programming a Code Channel Time/Phase Measurement

Code Channel Time/Phase Error Measurement Troubleshooting

Test Adherence to Standards

1.

Bins are the bars that appear on the graph. When high data rate channels such as the F-SCH channel are transmitted from the mobile station, wider bins are displayed. The wider bins represent code channels that occupy multiple orthogonal channels.


Fast Device Tune Measurement Description

Fast Device Tune Measurement Description

Last updated: June 20, 2007

This section is only applicable to the lab application and to a test application with the required feature license.

  • How is a Fast Device Tune Measurement Made?
  • Fast Device Tune Measurement Parameters
    • Configuring the MS TX Frequency/Power Series
    • Configuring the MS RX Frequency/Power Series
    • Triggering the Fast Device Tune Measurement
    • Required Initial Conditions
  • Fast Device Tune Measurement Results
  • Fast Device Tune Input Signal Requirements
  • Calibrating the Fast Device Tune Measurement

How is a Fast Device Tune Measurement Made?

The Fast Device Tune measurement allows you to simultaneously calibrate your mobile station's transmitter (TX) output power and receiver (RX) input level across level and frequency in a single sweep (per frequency band range). The measurement is not performed with a call established between the test set and mobile station (MS). Rather, you must place your MS into a test mode which forces it to transmit a predefined series of power steps at various frequencies, and forces it to simultaneously tune its receiver to perform measurements of the test set's signal (to determine RSSI, for example) at various frequencies and power levels.

Example MS TX and MS RX Frequency/Power Series for Fast Device Tune Measurement

Before initiating the measurement, you must specify the power sequence that the MS will transmit (MS TX Power Sequence), and the frequencies at which the MS will transmit the power sequence (MS TX Frequency Sequence). You must also specify the power sequence you want the test set to transmit (MS RX Power Sequence), and the frequencies at which you want the test set to transmit the power sequence (MS RX Frequency Sequence).

Configuring the MS TX Frequency/Power Series

The MS TX Power Sequence may include up to 20 steps (of 20 ms duration) that span some or all of the measurement's input range (the levels can step up or down with varying magnitudes of change, as long as the first step in the sequence provides a 20 dB rise to trigger the measurement). The MS TX Frequency Sequence may include up to 20 frequencies (within one frequency band range).

The test set can measure a total of 400 power points in one measurement cycle (20 power values at 20 different frequencies). However, the measurement allows you to enter up to 40 MS TX Power Step Levels and 40 MS TX Frequency Step Values (indexed from 0 to 39). You must then use the MS TX Power Step Start Index and Number of Power Steps settings to specify which power steps comprise the MS TX Power Sequence, and the MS TX Frequency Step Start Index and Number of Frequency Steps settings to specify which frequency steps comprise the MS TX Frequency Sequence. See Frequency/Power Series Example for an example illustrating how to utilize this flexibility.

The test set uses the values in the MS TX Power Sequence and the MS TX Frequency Sequence to build the MS TX Frequency/Power Series, which drives how the test set's receiver is tuned throughout the measurement cycle. To build the MS TX Frequency/Power Series, the test set simply repeats the MS TX Power Sequence at each of the frequencies in the MS TX Frequency Sequence, and inserts a frequency re-tune step in between each repetition of the power sequence (to allow the test set and MS to re-tune to the new frequency; no measurements are performed by the test set during the frequency re-tune steps). During the frequency re-tune steps, the test set tunes its receiver to the power and frequency values required for the first step in the next power sequence. The frequency re-tune steps are the same step length as the power sequence steps (20 ms).

Before initiating the measurement, you must ensure that your MS is set to transmit the MS TX Frequency/Power Series you've set in the test set, including the frequency re-tune steps.

Configuring the MS RX Frequency/Power Series

While the test set is measuring the MS TX Power Sequence, it also transmits a MS RX Power Sequence for the MS to measure. This MS RX Power Sequence must include the same number of power steps as the MS TX Power Sequence (up to 20 steps of 20 ms duration). These steps can be at any power level in the test set's cell power (see Cell Power, AWGN Power and Total RF Power Ranges ) output range.

The test set transmits its MS RX Power Sequence at each of the frequencies in the MS RX Frequency Sequence. The MS RX Frequency Sequence may include up to 20 frequencies within one frequency band range (which does not have to be the same frequency band range as the MS TX Frequency Sequence). The number of frequencies in the MS RX Frequency Sequence must match the number of frequency steps in the MS TX Frequency Sequence.

If you do not want the MS to measure test set power at as many power levels or frequencies as you want the test set to measure from the MS, simply place "dummy" power levels or frequencies at the end of the MS RX Power Sequence and MS RX Frequency Sequence (for example, simply repeat the final power level or frequency). You can then ignore the mobile station's measurement results for these "dummy" points. Likewise, if you need more measurement points in the MS RX Frequency/Power Series than in the MS TX Frequency/Power Series, you can place "dummy" power levels and frequencies in the MS TX Frequency/Power Series, but note that the test set will still measure and report power for these "dummy" points. You must simply ignore these results.

As with the MS TX Frequency/Power Series, the test set can transmit a total of 400 power points in one measurement cycle (20 power values at 20 different frequencies), but the measurement allows you to enter up to 40 MS RX Power Step Levels and 40 MS RX Frequency Step Values (indexed from 0 to 39). You must then use the MS RX Power Step Start Index and Number of Power Steps settings to specify which power steps comprise the MS RX Power Sequence, and the MS RX Frequency Step Start Index and Number of Frequency Steps settings to specify which frequency steps comprise the MS RX Frequency Sequence. See Frequency/Power Series Example for an example illustrating how to utilize this flexibility.

As with the MS TX Frequency/Power Series, the test set uses the values in the MS RX Power Sequence and the MS RX Frequency Sequence to build the MS RX Frequency/Power Series, which drives how the test set's generator is tuned throughout the measurement cycle. To build the MS RX Frequency/Power Series, the test set simply repeats the MS RX Power Sequence at each of the frequencies in the MS RX Frequency Sequence, and inserts a frequency re-tune step in between each repetition of the power sequence (to allow the test set and MS to re-tune to the new frequency; the MS should not perform any measurements on the test set's signal during this time, or if a measurement is performed, you should ignore the measurement results). During the frequency re-tune steps, the test set moves its generator to the power and frequency values required for the first step in the next power sequence. The frequency re-tune steps are the same step length as the power sequence steps (20 ms).

Before initiating the measurement, you must ensure that your MS is set to measure the MS RX Frequency/Power Series you've set in the test set, and that its tuning profile includes the frequency re-tune steps. Your mobile station should be configured to measure the test set's signal 5 ms after the start of each step, to allow the test set's source to settle.

Frequency/Power Series Example

The test set can measure/transmit 400 power points in one measurement cycle (20 power values at 20 different frequencies). However, you can enter up to 40 power values and 40 frequencies for both the MS TX and MS RX sequences. This flexibility is present to make it more efficient for you to test different power sequences over different sets of frequencies or, more commonly, to test the same power sequence over different bands. You must load in the superset of power levels and frequency values once. Then for each measurement cycle, you simply change the start index and number of steps as needed and initiate the measurement.

For example, to measure a MS TX sequence of 14 power step levels in both the US Cellular and US PCS frequency bands:

  • MS transmit power levels (dBm): 20, 16, 12, 8, 4, 0,-4, -8, -12, -16, -20, -30, -40, -50
  • US Cellular band, frequencies (MHz): 826.2, 829.2, 835.2, 838.2, 841.2, 847.2
  • US PCS band, frequencies (MHz): 1852.5, 1856.5, 1860.5, 1864.5, 1870.5, 1874.5, 1878.5, 1882.5, 1886.5, 1890.5, 1894.5, 1898.5, 1902.5

and to transmit a MS RX sequence of 8 power step levels for the mobile station to measure:

  • Test set transmit power levels (dBm): -90, -80, -70, -60, -50, -40, -30, -20
  • US Cellular band, frequencies (MHz): 871.2, 874.2, 880.2, 883.2, 886.2, 892.2
  • US PCS band, frequencies (MHz): 1932.5, 1936.5, 1940.5, 1944.5 1950.5, 1954.5, 1958.5, 1962.5, 1966.5, 1970.5, 1974.5, 1978.5, 1982.5

for multiple US Cellular/US PCS mobile stations, set the following:

  1. MS TX Power Step Levels = 20, 16, 12, 8, 4, 0,-4, -8, -12, -16, -20, -30, -40, -50
    MS RX Power Step Levels = -90, -80, -70, -60, -50, -40, -30, -20, -75, -75, -75, -75, -75, -75 (note that the last six values "-75" are "dummy" values required so that there are an equal number of power steps in the MS TX and MS RX sequences)
    MS TX Frequency Step Values = 826.2, 829.2, 835.2, 838.2, 841.2, 847.2, 1852.5, 1856.5, 1860.5, 1864.5, 1870.5, 1874.5, 1878.5, 1882.5, 1886.5, 1890.5, 1894.5, 1898.5, 1902.5
    MS RX Frequency Step Values = 871.2, 874.2, 880.2, 883.2, 886.2, 892.2, 1932.5, 1936.5, 1940.5, 1944.5 1950.5, 1954.5, 1958.5, 1962.5, 1966.5, 1970.5, 1974.5, 1978.5, 1982.5
  2. MS TX Power Step Start Index = 0
    MS RX Power Step Start Index = 0
    Number of Power Steps = 14
  3. Mobile station #1:
    • MS TX Frequency Step Start Index = 0
      MS RX Frequency Step Start Index = 0
      Number of Frequency Steps = 6
      Initiate the measurement, query INITiate:CFDTune:ARMed?, fetch the results
    • MS TX Frequency Step Start Index = 6
      MS RX Frequency Step Start Index = 6
      Number of Frequency Steps = 13
      Initiate the measurement, query INITiate:CFDTune:ARMed?, fetch the results
  4. Mobile station #2: repeat step 3
  5. Mobile station #3: repeat step 3
  6. ...

Triggering the Fast Device Tune Measurement

The MS must trigger the measurement with a positive change in power of at least 20 dB (the mobile station's power must rise from 20 dB below the level of the first step in the MS TX Power Sequence to within 9 dB of the level of the first step).

To ensure successful triggering, it is recommended that you do the following:

  1. Order the MS to transmit continuously at >20 dB below the power level of the first step in the MS TX Power Sequence.
    Note: If your MS TX Power Sequence starts at a power level that is less than 20 dB above the minimum transmit power of your MS, then you must include a trigger pulse as the first step in the MS TX Power Sequence. The power level of this trigger pulse will be measured by the test set as one of the steps in the sequence.
  2. Initiate the Fast Device Tune measurement (this prepares the test set's hardware to execute the frequency/power series you've specified and arms the measurement's RF rise trigger).
  3. Send the INITiate:CFDTune:ARMed? query and wait for it to return a value of 1 , indicating that the measurement is armed and ready to be triggered (or wait ~2 seconds if running the measurement from the front panel).
  4. Order the MS to begin transmission of its MS TX Frequency/Power Series (the MS should then increase its output power by more than 20 dB to reach the first step in the series, which triggers the measurement with an RF rise).

Once triggered, the Fast Device Tune measurement performs a series of channel power measurements, one near the center of each step of the MS TX Power Sequence (while simultaneously transmitting the MS RX Power Sequence you've specified), then repeats the measurements at the next specified MS TX frequency (while simultaneously transmitting the MS RX Power Sequence at the next specified MS RX frequency). The test set tunes its receiver for each step according to the power levels you've specified for the MS TX Power Sequence. The MS must step its power according to the MS TX Power Sequence (and be within +/- 9 dB of the expected power level for each step) and hold its power constant for the duration of the measurement interval (312.5 us, 7 ms after the start of each step). After completing a measurement at each step of the MS TX Frequency/Power Series, the measurement returns power results for all of the measured steps.

Required Initial Conditions

  • Operating Mode must be set to IS-2000 Test .
  • Rcvr Power Ctrl must be set to Manual and Meas Frequency must be set to manual control (See Manual Receiver Control in IS-2000 Test Operating Mode ).
    To set Meas Frequency to manual control from the front panel, press the OFF/MANUAL key. This sets Meas Frequency to the last frequency value that this parameter was set to. The Fast Device Tune measurement ignores the specific value that Meas Frequency is set to, so it can be set to any supported input frequency; the measurement simply requires that Meas Frequency be in manual control mode
  • RF Gen Freq Ctrl must be set to Manual . See Manual Receiver Control in IS-2000 Test Operating Mode .
  • WAGN Power must be Off . If in the Lab Application , also make sure no external fading is applied (see Digital Bus Information ).
  • You must configure the MS TX Frequency/Power Series to match the pattern of power levels to be transmitted by the MS and configure the MS RX Frequency/Power Series to match the pattern of power levels to be measured by the MS.

Operating Considerations

The Fast Device Tune measurement must re-range and re-trigger for every step in the MS TX Power Sequence. To ensure that this process is not interrupted by other operations, it is recommended that you not send any GPIB commands to the test set or press any front panel keys until the measurement has completed. If the measurement misses a trigger, it aborts and returns Integrity Indicator 30 : Missed Trigger .

No other measurements can be running when a Fast Device Tune measurement is performed. If any measurements are running when a Fast Device Tune measurement is initiated, they are closed and a message is displayed to indicate that they were closed. Likewise, if any other measurements are initiated while a Fast Device Tune measurement is running, the Fast Device Tune measurement is closed and a message is displayed.

Measurement results (and the RF generator output level) are affected by any RF IN/OUT Amplitude Offsets that are entered (see Amplitude Offset ).

Fast Device Tune Measurement Parameters

Fast Device Tune Setup

  • Measurement Timeout

    See Timeouts . Ensure that you set the Measurement Timeout to a value great enough to allow you to command the MS to transmit its MS TX Frequency/Power Series and for the test set to measure the MS TX Frequency/Power Series. For example, measuring the maximum allowable number of 400 power points can take more than 10 seconds (400 steps plus the 19 re-tune steps: 419 x 20 ms = 8.4 seconds, plus ~ 2 seconds required for the measurement to prepare for triggering).

    GPIB command: SETup:CFDTune:TIMeout[:STIMe]

  • MS TX Power Step Start Index

    Indicates which of the MS TX Power Step Levels is the first step in the MS TX Power Sequence.

    This parameter can be set to any integer value between 0 and 39. However, MS TX Power Step Start Index + Number of Power Steps must not exceed 40.

    Also, you must ensure that the range of values selected by MS TX Power Step Start Index and Number of Power Steps do not include any NANs (9.91E+37) or values that are outside of the input range for the current application format (considering the amplitude offset settings).

    GPIB command: SETup:CFDTune:MS:TX:POWer:STEP:STARt:[INDex]

  • MS TX Frequency Step Start Index

    Indicates which of the MS TX Frequency Step Values is the first frequency in the MS TX Frequency Sequence.

    This parameter can be set to any integer value between 0 and 39. However, MS TX Frequency Step Start Index + Number of Frequency Steps must not exceed 40.

    Also, the frequencies indicated by MS TX Frequency Step Start Index and Number of Frequency Steps must be within one frequency band range (and must not include any NANs (9.91E+37)).

    GPIB command: SETup:CFDTune:MS:TX:FREQuency:STEP:STARt:[INDex]

  • MS RX Power Step Start Index

    Indicates which of the MS RX Power Step Levels is the first step in the MS RX Power Sequence.

    This parameter can be set to any integer value between 0 and 39. However, MS RX Power Step Start Index + Number of Power Steps must not exceed 40.

    Also, you must ensure that the range of values selected by MS RX Power Step Start Index and Number of Power Steps do not include any NANs (9.91E+37) or values that are outside of the output range for the current application format (considering the amplitude offset settings).

    GPIB command: SETup:CFDTune:MS:RX:POWer:STEP:STARt:[INDex]

  • MS RX Frequency Step Start Index

    Indicates which of the MS RX Frequency Step Values is the first frequency in the MS RX Frequency Sequence.

    This parameter can be set to any integer value between 0 and 39. However, MS RX Frequency Step Start Index + Number of Frequency Steps must not exceed 40.

    Also, the frequencies indicated by MS RX Frequency Step Start Index and Number of Frequency Steps must be within one frequency band range (and must not include any NANs (9.91E+37)).

    GPIB command: SETup:CFDTune:MS:RX:FREQuency:STEP:STARt:[INDex]

  • Number of Power Steps

    Indicates how many (consecutive) MS TX Power Step Levels are used for the MS TX Power Sequence, and how many (consecutive) MS RX Power Step Levels are used for the MS RX Power Sequence.

    This parameter can be set to any integer value between 1 and 20, but MS TX Power Step Start Index + Number of Power Steps and MS RX Power Step Start Index + Number of Power Steps must not exceed 40.

    Also, you must ensure that the range of power values selected by MS TX Power Step Start Index, MS RX Power Step Start Index and Number of Power Steps do not include any NANs (9.91E+37) or values that are outside of the input or output ranges for the current application format (considering the amplitude offset settings).

    GPIB command: SETup:CFDTune:POWer:STEP:COUNt

  • Number of Frequency Steps

    Indicates how many (consecutive) MS TX Frequency Step Values are used for the MS TX Frequency Sequence, and how many (consecutive) MS RX Frequency Step Values are used for the MS RX Frequency Sequence.

    This parameter can be set to any integer value between 1 and 20, but MS TX Frequency Step Start Index + Number of Frequency Steps and MS RX Frequency Step Start Index + Number of Frequency Steps must not exceed 40.

    Note that the frequencies indicated by MS TX Frequency Step Start Index and Number of Frequency Steps must be within one frequency band range. Likewise, the frequencies indicated by MS RX Frequency Step Start Index and Number of Frequency Steps must be within one frequency band range, but do not have to be in the same frequency band range as the MS TX Frequency Sequence. Ensure that none of the frequency values you've selected are NANs (9.91E+37)).

    GPIB command: SETup:CFDTune:FREQuency:STEP:COUNt

Fast Device Tune MS TX/RX Parameters

  • MS TX Power Step Levels

    You can specify up to 40 mobile station output power levels (indexed from 0 up to 39). You must use the MS TX Power Step Start Index and Number of Power Steps settings to specify which of these (consecutive) power levels (up to 20) are used for the MS TX Power Sequence.

    Although you can enter any power levels between -129 and +80 dBm (because this measurement is common to the W-CDMA/HSDPA, 1xEV-DO and cdma2000 formats), when running the Fast Device Tune measurement in the cdma2000 application/format, you can only measure power levels in the range of -79 to +30 dBm and the measurement is only specified for power levels in the range of -61 to +30 dBm (these ranges assume an amplitude offset of 0; the ranges change as you change amplitude offsets, see Amplitude Offset ).

    GPIB command: SETup:CFDTune:MS:TX:POWer:STEP[:LEVels]

  • MS TX Frequency Step Values

    You can specify up to 40 mobile station uplink frequencies (indexed from 0 up to 39). You must use the MS TX Frequency Step Start Index and Number of Frequency Steps settings to specify which of these (consecutive) frequencies (up to 20) are used for the MS TX Frequency Sequence.

    Although you can enter any frequencies between 411 and 1980 MHz, when running the Fast Device Tune measurement in the cdma2000 application/format, you can only test frequencies within a single cdma2000 frequency band range:

    • 410 to 483.48 MHz (Band: NMT-450)
    • 806 to 925 MHz (Bands: US Cellular, Japan CDMA, China Cellular, and Secondary 800)
    • 1750 to 1780 MHz (Band: Korean PCS)
    • 1920 to 1980 MHz (Band: IMT-2000)
    • 1850 to 1915 MHa (Bands: US PCS and US PCS 1900)
    • 1710 to 1755 MHz (Band: AWS)

    GPIB command: SETup:CFDTune:MS:TX:FREQuency:STEP[:VALues]

  • MS RX Power Step Levels

    You can specify up to 40 test set output power levels (indexed from 0 up to 39). You must use the MS RX Power Step Start Index and Number of Power Steps settings to specify which of these (consecutive) power levels (up to 20) are used for the MS RX Power Sequence.

    Although you can enter any power levels between -165 and 37 dBm, when running the Fast Device Tune measurement in the cdma2000 application/format, the test set can only transmit test power levels in the range of -120 to -13 dBm ( RF IN/OUT ) or -115 to -5 dBm ( RF OUT ONLY ) (this range assumes an amplitude offset of 0; the allowable range changes as you change amplitude offsets, see Cell Power, AWGN Power and Total RF Power Ranges ).

    GPIB command: SETup:CFDTunee:MS:RX:POWer:STEP[:LEVels]

  • MS RX Frequency Step Values

    You can specify up to 40 test set downlink frequencies (indexed from 0 up to 39). You must use the MS RX Frequency Step Start Index and Number of Frequency Steps settings to specify which of these (consecutive) frequencies (up to 20) are used for the MS RX Frequency Sequence.

    Although you can enter any frequencies between 421 and 2170 MHz, when running the Fast Device Tune measurement in the cdma2000 application/format, you can only test frequencies within a single cdma2000 frequency band range:

    • 420 to 493.48 MHz (Band: NMT-450)
    • 832 to 960 MHz (Bands: US Cellular, Japan CDMA, China Cellular, and Secondary 800)
    • 1840 to 1870 MHz (Band: Korean PCS)
    • 2110 to 2170 MHz (Band: IMT-2000)
    • 1930 to 1995 (Bands: US PCS and US PCS 1900)
    • 2110 to 2155 (Band: AWS)

    GPIB command: SETup:CFDTune:MS:RX:FREQuency:STEP[:VALues]

Fast Device Tune Measurement Results

The Fast Device Tune measurement results are currently only available via GPIB command (see FETCh:CFDTune[:ALL]? ). Measurement results are not available on the front panel screen.

  • Integrity Indicator
  • Power

    The test set performs a channel power measurement near the center of each step (7 ms after the start of the step), with a measurement interval of 312.5 us (1/4 timeslot). Power (dBm/1.23 MHz) is returned for each step in the MS TX Frequency/Power Series (except for the frequency re-tune steps). The total number of results returned by the measurement is always 400 ( Number of Power Steps x Number of Frequency Steps power result values are returned, followed by 9.91E+37 (NAN) for all remaining values up to 400). The power results for the first frequency in the MS TX Frequency Sequence are returned first, then the power results for the second frequency in the MS TX Frequency Sequence, etc., followed by NANs if fewer than 400 points were measured.

Note that the test set does not report the mobile station's measurement results (for example, RSSI). You must capture the mobile station's measurement results so that you can compare its measurements with the test set's actual transmission levels.

Fast Device Tune Input Signal Requirements

The Fast Device Tune measurement meets specifications when the following input signal requirements are met:

  • Frequency: 411 to 420 MHz, 450 to 484 MHz, 824 to 934 MHz, 1750 to 1780 MHz, 1850 to 1980 MHz
  • Input level: -61 dBm to +30 dBm (the measurement can accept power within the range of -79 dBm to +30 dBm)

Calibrating the Fast Device Tune Measurement

You must calibrate this measurement using the Calibrate Measurements procedure (see Calibrating the Test Set ).

Related Topics

Manual Operation: How Do I Make a Fast Device Tune Measurement?

Programming a Fast Device Tune Measurement

Fast Device Tune Troubleshooting

Channel Power Measurement Description

Receiver Control


Channel Power Measurement Description

Channel Power Measurement Description

Last updated: June 12, 2007

  • How is a Channel Power measurement made?
  • Channel Power Measurement Parameters
  • Channel Power Measurement Results
  • Input Signal Requirements
  • Key TIA/EIA-98-E Tests Performed Using the Channel Power Measurement
  • Calibrating the Channel Power Measurement

How is a Channel Power measurement made?

Channel power measurements are used to determine the power contained in a 1.2288 MHz bandwidth of a CDMA channel. The input signal is downconverted and sampled using the test set's DSP (see Block Diagram ). The DSP then searches the sampled data to find those portions of the data record in which the input signal was non-gated. Using the portion of the samples representing the non-gated signal the DSP calculates the power within a 1.23 MHz measurement bandwidth. The result is cross correlated with the digital average power to derive an absolute power which is represented in the measurement's result (dBm/1.23 MHz).

Channel Power Measurement Parameters

  • Multi-Measurement Count

    When ON, this enables averaging of multiple channel power results. For example, when multi-measurement count is set to 3, three channel power measurements are made sequentially and the results of all measurements are averaged to determine the final result. (See Statistical Measurement Results ).

  • Trigger Arm - (see Trigger Arm (Single or Continuous) Description ).
  • Measurement Speed - (see Measurement Speed ).
  • Timeout Time/State - (see Timeouts ).

Measurement Speed

The test set provides three channel power measurement speed selections: Normal, Fast and Very Fast (see also SETup:CPOWer:MSPeed ). These selections provide additional information for the test set to select a trigger source, sample record length, power search algorithm, and processing time, all of which will influence the time required to perform the measurement.

Normal speed channel power measurements are made by sampling 10 ms of the input signal triggered by the 20 ms frame clock. The DSP then locates within the sample record the power control groups in which the input signal appears to be non-gated. In a CDMA system there will be at least one non-gated power control group within each half frame (10 ms).

A Fast speed channel power measurement assumes that an non-gated input signal is being measured. The trigger for the measurement is the 20 ms frame clock but the sample record is only 1.25 ms or a single power control group in length. There is no search since it is assumed that the input signal is always non-gated.

The Very Fast speed channel power measurement also assumes the measurement of an non-gated signal. It is triggered immediately upon receipt of the measurement request. There is no synchronization with the frame clock. The input signal is then sampled for 0.3125 ms or one quarter of a power control group.

The actual measurement speed used by the test set may be different than the current measurement speed selection. This is primarily because the triggering and search algorithms needed for measuring channel power on gated input signals is only available when using the Normal measurement speed. If Fast or Very Fast measurement speeds are selected when the channel configuration is such that a gated signal could reasonably be expected from the mobile station the Normal measurement speed algorithm will be applied even though a different measurement speed is selected. This provides the highest confidence that the measurement result will be accurate even though it might take longer than expected to obtain the result.

Impact of the Test Set Configurations on R-FCH Gating Transmission shows the actual measurement speed applied for the different test set configurations.

Impact of the Test Set Configurations on R-FCH Gating Transmission

System Type

Operating Mode

Radio Config 1

Service Option 2

Traffic Data Rate 3

R-FCH Gating Mode 4

Expected
R-FCH Gating

Actual Measurement Speed

IS-95

Active Cell

Not applicable

SO1, SO3, SO17, SO68, or SO32768

Not applicable

Not applicable

 Sometimes gated 5

Always Normal

SO2, SO9
(loopback)

Half, Quarter, Eighth, or Random

Always gated (Half, Quarter, Eighth) or sometimes gated (Random)

Always Normal

Full

Non-gated

Same as the specified speed.

IS-2000

Active Cell

(Fwd1, Rvs1), (Fwd2, Rvs2)

SO1, SO3, SO17, SO68, or SO32768

Not applicable

Not applicable

Sometimes gated 5

Always Normal

SO2, SO9, or SO55
(loopback)

Half, Quarter, Eighth, or Random

Always gated (Half, Quarter, Eighth) or sometimes gated (Random)

Always Normal

Full

Non-gated

Same as the specified speed.

(Fwd3, Rvs3)
(Fwd4, Rvs3)
(Fwd5, Rvs4)

SO2, SO9, or SO55
(loopback)

Eighth or Random

 On

Always gated (Eighth) or sometimes gated (Random)

Always Normal
Off

Non-gated

Same as the specified speed

Full, Half, Quarter,

Not applicable

Non-gated

Same as the specified speed.

SOs other than loopback

Not applicable

 On

Sometimes gated 5

Always Normal
Off

Non-gated

Same as the specified speed

Test Mode

(Fwd1, Rvs1), (Fwd2, Rvs2)

Not applicable

Half, Quarter, or Eighth

Not applicable

Always gated

Always Normal

Full

Non-gated

Same as the specified speed.

(Fwd3, Rvs3)
(Fwd4, Rvs3)
(Fwd5, Rvs4)

Not applicable

Non-gated

Same as the specified speed.
  1. See Radio Configuration for details.
  2. See Service Option for details.
  3. It is only applied to loopback service option. See Traffic Data Rate for details.
  4. It is only available in the lab application and in IS-2000 system, (Fwd3, Rvs3) and above. See R-FCH Gating for details.
  5. Sometimes gated indicates that the test set does not control the rate on the reverse link and therefore can not guarantee if the R-FCH/R-PICH will be gated.

NOTE
It is recommended to turn off other measurements if you expects to make the fast/very fast channel power measurements take as little time as possible. Turning on other measurements at the same time causes your measurements to run slower than expected. See Concurrent Measurements .

Channel Power Measurement Results

  • Integrity Indicator - (see Integrity Indicator ).
  • Channel Power (in dBm/1.23 MHz) - If Multi-Measurement Count is on, average, maximum and minimum channel power results are displayed on the measurement screen and available by remote program query ( FETCh:CPOWer ).
  • Measurement Speed - (see Measurement Speed )
  • Expected Mobile Power - the Expected Mobile Power (see Expected Power ) is also displayed on the measurement screen when the test set is configured as:
    • receiver power control is set to auto (see Automatic Receiver Control ).
    • the test set does not make the R-FCH data rate assumption (see Reverse Traffic Channel Data Rate Determination ) when calculating the expected mobile power. That is, the test set is in a loopback call (SO2, SO9, or SO55, see Service Option ) with the Traffic Data Rate set to other than Random .

A typical measurement result is shown below:

Input Signal Requirements

The channel power measurement meets or exceeds specifications when the following input signal requirements are met:

  • The frequency of the signal being measured must be within the range of 412 MHz to 483 MHz, 800 MHz to 960 MHz, or 1.7 GHz to 2.0 GHz, and be within 100 kHz of the expected frequency.
  • The signal level into the test set's RF IN/OUT connector must be between -61 dBm to +37 dBm. The test set can autorange to a signal that is within +/- 9 dB of the expected input level (see RFANalyzer:AUTO:POWer[:SELected]? ).

Key TIA/EIA-98-E Tests Performed Using the Channel Power Measurement

  • Testing 4.4.6 Minimum Controlled Output Power

Calibrating the Channel Power Measurement

Refer to Calibrating the Test Set for a description of channel power calibration.

Related Topics

Measuring Channel Power

Programming a Channel Power Measurement

Channel Power Measurement Troubleshooting

Test Adherence to Standards

Reverse CLPC Transient Modes


Tx Spurious Emissions Measurement Description

Tx Spurious Emissions Measurement Description

Last updated: October 29, 2004

  • How is a Tx Spurious Emissions measurement made?
  • TX Spurious Emissions Measurement Parameters
  • TX Spurious Emissions Measurement Results
  • Input Signal Requirements
  • Key TIA/EIA-98-E Tests Using the Tx Spurious Emissions Measurement
  • Calibrating the Tx Spurious Emissions Measurement

How is a Tx Spurious Emissions measurement made?

TX Spurious Emissions is a measure of the mobile station's transmission at frequencies outside its assigned channel. This measurement is made while the mobile station is a loopback call connection at full data rate transmission (see Operating Considerations ).

The test set's TX Spurious Emissions measurement is made by first making a channel power measurement centered on the assigned channel, to determine carrier power. The test set then measures the power at four frequencies offset from the center of the assigned channel. The test set measures the average power present at each frequency offset, over a power control group, within a 30 kHz filter centered on the offset frequency. The test set then reports the power of each frequency offset relative to the carrier power (the result is given in dBc). A graphical view or a numeric view can be displayed.

The four frequency offsets at which power is measured depends upon the mobile station's band class:

  • Frequency offsets for band classes 1, 4, and 6:
    • ± 885 kHz (lower and upper adjacent channels)
    • ± 1.98 MHz (lower and upper alternate channels)
  • Frequency offsets for band classes 0, 3, 5, and 9:
    • ± 1.25 MHz (lower and upper adjacent channels)
    • ± 1.98 MHz (lower and upper alternate channels)

Tx Spurious Emissions measurements are triggered by a 20 ms clock derived from signaling protocol.

Operating Considerations

See Tx Spurious Emissions Measurement Troubleshooting .

TX Spurious Emissions Measurement Parameters

  • Mask Control: When set to auto, the pass/fail limits for the spurious emissions at the adjacent and alternate channels are set as specified by TIA/EIA-98-E 4.5.1. When set to manual, you can set the pass/fail limits for the measurement. Separate pass/fail limits are provided for the adjacent and alternate channel measurements.
  • Adjacent Limit (in dBc): Sets the pass/fail limit for the adjacent channel measurement (range is -65 to -10 dBc).
  • Alternate Limit (in dBc): Sets the pass/fail limit for the alternate channel measurement (range is -65 to -10 dBc).
  • Multi-Measurement Count - When ON, this enables averaging of the TX spurious emissions results. (See Statistical Measurement Results ).
  • Trigger Arm - (see Trigger Arm (Single or Continuous) Description ).
  • Timeout Time/State - (see Timeouts ).

TX Spurious Emissions Measurement Results

  • Integrity Indicator - (see Integrity Indicator ).
  • Pass/Fail Result: An overall pass/fail indicator is displayed on the measurement screen and is available via GPIB commands (see FETCh:CTXSpurious:MASK[:FAIL]? ). The pass/fail result indicates whether the spurious emissions for all adjacent and alternate channels are within limits.
  • Spurious Emissions for Adjacent and Alternate Channels: The test set returns the spurious emissions levels for all adjacent and alternate channels. These spurious emissions levels are available from the measurement screen marker and via GPIB commands (see FETCh:CTXSpurious[:ALL]? ).

The TX Spurious Emissions Measurement Screen

The TX Spurious Emissions measurement screen can display numeric results or a graphical display.

  • The y-axis on the graphical display is fixed at -80 dBc/30 kHz to 0 dBc/30 kHz.
  • The x-axis on the graphical display is fixed at -2.5 MHz to 2.5 MHz relative to the carrier frequency.
  • Pass/fail limit lines are shown in green on the graphical display. These lines are set based on Mask Control and Adjacent/Alternate Limit (see TX Spurious Emissions Measurement Parameters ). If spurious emissions at any adjacent or alternate channel exceed a limit line, the word Fail appears on the display.
  • The carrier is displayed in the center of the display as a solid yellow bar. The spurious emissions power at the four frequency offsets is displayed as yellow bars.
  • The marker can be positioned on each of the four frequency offsets. The spurious emissions for that frequency offset is then displayed.

Input Signal Requirements

The Tx Spurious Emissions measurement meets or exceeds specifications when the following requirements are met:

  • The frequency of the signal being measured must be in the range of 411 MHz to 484 MHz, 804 MHz to 934 MHz, 1.75 GHz to 1.78 GHz, or 1.85 GHz to 1.98 GHz, and be within 100 kHz of the expected frequency.
  • The signal level into the test set's RF IN/OUT connector must be in the range of 0 dBm to +30 dBm. The test set can autorange to a signal that is within +/- 9 dB of the expected input level (see RFANalyzer:AUTO:POWer[:SELected]? ).

Key TIA/EIA-98-E Tests Using the Tx Spurious Emissions Measurement

  • Testing 4.5.1 Conducted Spurious Emissions

Calibrating the Tx Spurious Emissions Measurement

The Tx Spurious Emissions measurement is automatically calibrated during a channel power calibration. Follow the channel power calibration schedule and the Tx Spurious Emissions measurement will be properly calibrated. Refer to Calibrating the Test Set for a description of channel power calibration.

Related Topics

Measuring TX Spurious Emissions


Digital Average Power Measurement Description

Digital Average Power Measurement Description

Last updated: October 28, 2004

  • How is a Digital Average Power Measurement Made?
  • Digital Average Power Measurement Parameters
  • Digital Average Power Measurement Results
  • Input Signal Requirements
  • Key TIA/EIA-98-E Tests Using the Digital Average Power Measurement
  • Calibrating the Digital Average Power Measurement

How is a Digital Average Power Measurement Made?

Digital average power measurements are broadband power measurements made directly on the RF input (the signal is not downconverted in frequency, see Block Diagram ). The input waveform is detected by a peak detector with sufficient AM bandwidth to track the instantaneous power changes of a CDMA signal. The test set's digital signal processor (DSP) then determines the average power (true rms power level) of the signal over a 10 ms (one-half of a frame) measurement period.

This measurement uses autoranging based on the open loop power control response of the mobile station to set up the receiver signal path attenuation. Triggering is handled by internal mechanisms and no external triggering is available.

This measurement can be made on signals that are power-gated or signals that are not power-gated. It is not necessary to specify whether the input signal is power-gated. If the input signal is power-gated, only the active power control groups will be measured.

NOTE
For the lab application, the digital average power measurement result is not accurate for gated MS transmissions in radio configurations greater than 2 (see R-FCH Gating ), which the integrity indicator returns the value of 16.

The digital average power measurement has greater than 2 GHZ bandwidth. For this reason, significant signal energy outside the IS-2000 SR1 (1.25 MHz) signal bandwidth will increase the measured value.

Digital Average Power Measurement Parameters

  • Multi-Measurement Count - (See Statistical Measurement Results ).
  • Trigger Arm - (see Trigger Arm (Single or Continuous) Description ).
  • Timeout Time/State - (see Timeouts ).

Digital Average Power Measurement Results

  • Integrity Indicator - (see Integrity Indicator ).
  • Digital Average Power (in dBm)
  • Expected Mobile Power - the Expected Mobile Power (see Expected Power ) is also displayed on the measurement screen when the test set is configured as:
    • receiver power control is set to auto (see Automatic Receiver Control ).
    • the test set does not make the R-FCH data rate assumption (see Reverse Traffic Channel Data Rate Determination ) when calculating the expected mobile power. That is, the test set is in a loopback call (SO2, SO9, or SO55, see Service Option ) with the Traffic Data Rate set to other than Random .

A typical measurement result is shown below:

Input Signal Requirements

The digital average power measurement meets or exceeds specifications when the following requirements are met:

  • The frequency of the signal being measured must be in the range of 412 MHz to 483 MHz, 800 MHz to 960 MHz, or 1.7 GHz to 2.0 GHz.
  • The signal level into the test set's RF IN/OUT connector must be between +37 dBm and -30 dBm. The test set can autorange to a signal that is within +/- 9 dB of the expected input level (see RFANalyzer:AUTO:POWer[:SELected]? ).

Key TIA/EIA-98-E Tests Using the Digital Average Power Measurement

  • Testing 4.4.5 Maximum RF Output Power

Calibrating the Digital Average Power Measurement

Refer to Calibrating the Test Set for a description of digital average power calibration.

Related Topics

Measuring Digital Average Power

Programming a Digital Average Power Measurement

Digital Average Power Troubleshooting

Channel Power Measurement Description

Test Adherence to Standards

CALibration Subsystem


TX Dynamic Power Measurement Description

TX Dynamic Power Measurement Description

Last updated: June 20, 2006

  • How is a TX Dynamic Power Measurement Made?
  • TX Dynamic Power Measurement Parameters
  • TX Dynamic Power Measurement Results
  • Input Signal Requirements
  • Calibrating the TX Dynamic Power Measurement

How is a TX Dynamic Power Measurement Made?

The TX dynamic power measurement is a series of channel power measurements in Very Fast speed (see Measurement Speed ), one at each step of the power sequence. It provides a fast power calibration method that covers the typical 90dB (from -60dBm to +30dBm) dynamic range of a CDMA mobile station (MS). It's available in the Active Cell and the IS-2000 Test operating modes (see Selecting an Operating Mode ).

Before starting the TX dynamic power measurement, you must set your MS in a test mode to control the MS to transmit a power sequence with successive down steps of fixed size and duration. You also must set the test set's receiver using manual control, with the power set to match the initial transmit power of the MS's power sequence, and with the frequency set to match the MS's transmit frequency (see Receiver Control ).

An example MS output power sequence for TX Dynamic Power Measurement is shown in the figure below.

MS Output Power Profile for TX Dynamic Power Measurement

The TX dynamic power measurement is firstly triggered by an RF rise impulse (a positive change in power from 20 dB below the initial transmit power) from the MS.

To ensure that the measurements always sample the stable portions of the data record, the test set measures the MS's initial transmit power (step 0) at 6 ms, or 16 ms, or 36 ms after receiving the RF rise trigger (corresponding to the Power Step Time set to 20ms, 40ms or 80ms).Then the test set retunes the expected power range of receiver based on the power measured in the prior step and the Power Step Size setting so that the test set can measure those mobile stations, which do not transmit the power sequence as expected, without aborting the measurement. Each subsequent channel power is automatically measured every 20, 40, or 80 ms (depending on the Power Step Time setting). The test set expects the MS to hold its power constant during each power step. After the measurement is completed, the test set returns all measured results.

Operating Considerations

  • Don't change any test set settings until the measurement is complete since it may cause the measurement to abort due to the missed trigger.
  • Don't start the power control transient transmission (see Starting the Reverse CLPC Transient ) when the TX dynamic power measurement is running. Otherwise, the measurement will be closed and its operation is aborted. Moreover, the TX dynamic power measurement will not be able to start (become initiated) while the transient transmission is in progress.
  • The TX dynamic power measurement is not available in a multi-measurement mode.
  • The TX dynamic power measurement is expected to only be used when Call Connection status is Idle since the MS must be in a test mode, otherwise it may not produce meaningful results.
  • The TX dynamic power measurement does not run concurrently with any other measurements. When TX dynamic power measurement is initiated, any other measurements running are closed and a message is displayed to indicate the close. Likewise, when any other measurements are initiated, the TX dynamic power measurement running is closed and a message is displayed.

TX Dynamic Power Measurement Parameters

  • Power Step Size

    Sets the power change that the test set expects the MS to transmit between steps. It should match the value of the power step size of the MS's test mode

    GPIB Command: SETup:CTDPower:STEP[:LEVel]

  • Number of Power Steps

    Sets the number of power steps that the test set expects the MS to transmit. It should match the value of the number of power steps of the MS's test mode. The actual measurement steps will be the number of this setting plus one.

    GPIB Command: SETup:CTDPower:STEP:COUNt

  • Power Step Time

    Sets the period (in milliseconds) that the test set will wait to trigger the power measurement for the next step. It determines the successive trigger for the measurement. You must set the MS to hold each step power constant for this amount of time.

    GPIB Command: SETup:CTDPower:STEP:TIME

  • Timeout Time/State - (see Timeouts ).

TX Dynamic Power Measurement Results

  • Integrity Indicator

    GPIB Command: Integrity Indicator

  • Power Results

    The TX dynamic power measurement result is displayed in both a tabular and a bar graph format. See X Dynamic Power Measurement Display .

    GPIB Command: FETCh:CTDPower[:ALL]?

X Dynamic Power Measurement Display

Graphical Display

The graphical display shows the measurement result for each step with a graphical "Bar". The x-axis graph represents the number of the power steps and y-axis represents the absolute power of the measurement step in units of dBm/1.23 MH. Up to 100 steps of the measurement results can be displayed on the graph. The view window can be adjusted to include a view of the entire 100 power step range, or reduced to include only the measurement steps of particular interest by the Graph Control softkeys (see Measuring TX Dynamic Power ).

NOTE
The number of displayed bars equals Number of Power Steps plus one. For example, when Number of Power Steps is set to 3, the display shows 4 yellow bars in one measurement.

  • Marker ( F1 ) - sets a marker position across the current span of the graph. The measurement result that corresponds with the marker position is highlighted in the table below the graphical display. This setting also controls the table scrolling.
  • Start Step ( F3 ) - sets the first measurement step displayed on the graph. It is used to adjust the view window together with the Span ( F4 ).
  • Span ( F4 ) - sets the number of measurement steps displayed on the graph. It is used to adjust the view window together with the Start Step ( F3 ).
  • Default Scale ( F5 ) - sets the Graph Marker, Start Step, and Span to their default values.

Tabular Display

A table below the graphical display lists the absolute power of each step measurement in units of dBm/1.23 MHz. The table has the capacity to display 40 steps of measurement results. To scroll through the table adjust the setting in Marker field.

Input Signal Requirements

The TX dynamic power measurement meets specifications when the following input signal requirements are met:

  • The frequency of the signal being measured must be within the range of 412 MHz to 483 MHz, 800 MHz to 960 MHz, or 1.7 GHz to 2.0 GHz, and be within 100 kHz of the expected frequency.
  • The signal level into the test set's RF IN/OUT connector must be between -61 dBm to +37 dBm. The test set can autorange to a signal that is within +/- 9 dB of the expected input level (see RFANalyzer:AUTO:POWer[:SELected]? ).

Calibrating the TX Dynamic Power Measurement

The TX dynamic power measurement is automatically calibrated during a channel power calibration. Follow the channel power calibration schedule and the TX dynamic power measurement will be properly calibrated. Refer to Calibrating the Test Set for a description of channel power calibration.

Related Topics

Measuring TX Dynamic Power

Programming a TX Dynamic Power Measurement

TX Dynamic Power Measurement Troubleshooting

Channel Power Measurement Description

Receiver Control


DTMF Measurement Description

DTMF Measurement Description

Last updated: June 20, 2006

  • How is a DTMF measurement made?
  • DTMF Measurement Parameters
  • DTMF Measurement Results
  • Input Signaling Requirements
  • Key TIA/EIA-690 Test Using the DTMF Measurement

How is a DTMF measurement made?

The DTMF (Dual Tone Multiple Frequency) measurement detects dual tone multi-frequency signals generated by the mobile station.

The DTMF signals indicate which symbol was pressed on the mobile station's keypad. The set of valid symbols is 0-9, *, #, A, B, C and D. Each DTMF signals consists of two tones that are generated together. One tone is from a set of lower frequencies (697 Hz, 770 Hz, 852 Hz, 941 Hz) and the other one is from a set of upper frequencies (1209 Hz, 1336 Hz, 1477 Hz, 1633 Hz). The specific DTMF frequencies that are associated with valid symbols are shown in the following table.

DTMF Frequencies Matrix
 | 1209 Hz | 1336 Hz | 1477 Hz | 1633 Hz
697 Hz | 1 | 2 | 3 | A
770 Hz | 4 | 5 | 6 | B
852 Hz | 7 | 8 | 9 | C
941 Hz | * | 0 | # | D

NOTE
The far right column, 1633 Hz, is not defined in the Test Standard EIA/TIA-690, but in a common-used set of symbols that is defined in the Bell Standard. It is included in this measurement for compatibility with the Bell Standard.

When the measurement is initiated, the test set monitors the carrier for the period defined by the gate time. When the period is reached, the captured signal is processed. The DTMF measurement measures the frequency and frequency error of each tone in the DTMF symbol and the phase deviation caused by each tone in the DTMF symbol. The length of time that each DTMF symbol, the time between symbols and the detected DTMF symbols are reported.

Operating Consideration

This measurement is available in Active Cell operating mode, AVC Test operating mode and CW operating mode.

DTMF Measurement Parameters

The DTMF measurement setup menu provides control over the following parameters

  • Gate Time (See SETup:DTMF:GTIMe ) - Sets the length of time that the DTMF measurement samples the signals under test.
  • Detector Type (See SETup:DTMF:DETector[:TYPE] ) - Sets the type of detector to use when making DTMF measurements: RMS, Peak+, Peak-, Peak+/- Max and Peak +/- /2.
    • The Peak+ and Peak- detectors measure the greatest positive or negative frequency excursion in carrier frequency during the sample.
    • The RMS detector measures the root mean squared value. This setting does not affect the distortion measurement.
    • The Peak+/- Max detector measures both greatest positive and negative peaks and take the absolute value of each, then return the greater one.
    • The Peak+/- /2 detector measures both greatest positive and negative peaks and take the absolute value of each, then returns average value.
  • Trigger Arm (See Trigger Arm (Single or Continuous) Description ).
  • Measurement Timeout (see Timeouts ).

DTMF Measurement Results

  • Integrity Indicator (See Integrity Indicator ).

For all 16 characters, the following results are returned for each character (See FETCh:DTMF:CHARacter? <num value> )

  • Symbol Result - Indicate the character sent by the mobile station.
  • Low Tone Frequency Result - Indicate the measured frequency of lower tone of DTMF signal.
  • Low Tone Frequency Error Result - Indicate frequency error, which is the difference between the measured frequency and the expected frequency, of the lower tone of DTMF signal.
  • Low Tone Phase Deviation Result - Indicate the radian deviation caused by the lower tone of the DTMF signal.
  • High Tone Frequency Result - Indicate the measured frequency of upper tone of DTMF signal.
  • High Tone Frequency Error Result - Indicate the radian deviation caused by the upper tone of the DTMF signal.
  • High Tone Phase Deviation Result - Indicate the radian deviation caused by the upper tone of the DTMF signal.
  • On Time Result - Indicate the amount of time during which the DTMF signal is On
  • Off Time Result - Indicate the amount of time during which the DTMF signal is Off

A typical measurement result is shown below.

Input Signaling Requirements

The test set measures the low group and high group tones within the frequency ranges defined in the following table.

DTMF Measurement Expected Frequency Ranges
Expected DTMF frequency (Hz) | Measurable Lower Limit (Hz) | Measurable Upper Limit (Hz)
Lower Tone
697 | >=663 | <733
770 | >=733 | <810
852 | >=810 | <895
941 | >=895 | <989
Upper Tone
1209 | >=1150 | <1271
1336 | >=1271 | <1405
1477 | >=1405 | <1553
1633 | >=1553 | <1717

The duration of DTMF symbols must be at least 45 ms and the time between symbols must be at least 10 ms.

The DTMF measurement meets or exceeds specifications when the following input signal requirements are met:

  • The input signal is an RF carrier that is frequency modulated to include a DTMF symbol. The input signal must be within +/- 2.5 kHz of the test set' s expected frequency.
  • The deviation that is caused by a SAT or ST tones or by a wideband data burst is not included in the deviation result. The ratio of the input signal' s deviation to residual FM must be greater than 30 dB.

Key TIA/EIA-690 Test Using the DTMF Measurement

See Measuring DTMF Testing 10.1 Dual Tone Multifrequency (DTMF) Signaling

Related Topics

Measuring DTMF


Frame Error Rate (FER) Measurement Description

Frame Error Rate (FER) Measurement Description

Last updated: December 21, 2004

  • How is an FER measurement made?
    • Confidence Level Testing
    • FER Measurement Specific to the Lab Application
  • FER Measurement Parameters
  • FER Measurement Results
  • Input Signal Requirements
  • Key TIA/EIA-98-E Tests Using FER

How is an FER measurement made?

Frame Error Rate (FER) measurement is used to test the performance of a mobile station's receiver. FER measurements can only be made on the forward traffic channel (F-Traffic) for IS-95 system or forward fundamental channel (F-FCH) for IS-2000 system and a call must be connected with a loopback service option (such as SO2, SO9, or SO55). The forward supplemental channel (F-SCH) for IS-2000 system is measured using TDSO FER measurement (see TDSO Frame Error Rate Measurement Description ).

During an FER measurement, the test set sends a sequence of frames to the mobile station. Each frame contains CRC (Cyclic Redundancy Code) bits, which provide frame quality indicator and allow the mobile station to verify that it has correctly decoded a frame.

The mobile station is put into a loopback service option and makes its best attempt to decode each received frame sent from the test set. Once the mobile station determines the CAT_TYPE that specifies whether the frame received is a good frame, bad frame, frame erasure, or a frame blanked by signaling, the mobile station encodes and re-transmits the frame, with the first two bits replaced with the CAT_TYPE information, back to the test set. The test set compares each received frame to the corresponding frame that was sent and validates the CAT_TYPE information, then determines the measurement results (see FER Measurement Results ).

The test set keeps a running count of the measured frames and the number of frames that contain bit errors.

Intermediate measurement results are periodically available on the front panel display, but are not available programmatically through the GPIB interface.

Confidence Level Testing

Confidence level testing is a feature of FER measurements that applies statistical analysis to FER measurements so that pass/fail test results can be obtained in the shortest possible time.

When confidence level is on, a minimum number of frames as specified must be measured before confidence algorithm can begin (For fading tests, the minimum test duration is required to meet the power measurement uncertainty requirement of 0.2 dB). After the measurement is initiated and the specified minimum frames have been tested, given an FER requirement and confidence level settings, a calculation is made to determine the minimum number of remaining frames necessary for a valid statistical analysis. At that time it is also determined what the maximum number of bad frames received would be necessary to fail the test. If the pre-calculated maximum number of bad frames is received before the minimum remaining frames is measured, the FER measurement will ends with a fail indication.

When confidence level is on, the FER measurement will keep track of the number of frames measured, the number of frame errors, and perform a statistical analysis of the probability that the value entered in the FER requirement field will (or will not) be exceeded. The confidence level parameter is typically set at 95%. With that setting, the FER measurement returns a Pass confidence result before the maximum frame count is reached if statistically there is a 95% probability that the percentage of frame errors counted will not exceed the specified FER requirement value if the measurement is allowed to reach the maximum frame count. The FER measurement returns a Fail confidence result before the maximum frame count is reached if statistically there is a 95% probability that the percentage of frame errors counted will exceed the specified FER requirement value if the measurement is allowed to reach the maximum frame count. If the number of frame errors counted does not allow a reliable prediction of Pass or Fail confidence result, the measurement continues until the number of frames tested equals the specified maximum frame count. "Max frames" and the FER percentage results are then returned.

If confidence level is off, the measurement always runs until the number of frames tested equals the specified maximum frame count. "Max frames" and the FER percentage result are then returned.

FER Measurement Specific to the Lab Application

The lab application can perform mobile station tests that require faded signals. This setup requires a rear panel digital bus connection to an external PC running Baseband Studio software. See Digital Bus Information for details.

Whenever the test set is configured to generate faded forward channel signals with AWGN, an external AWGN value is displayed on the FER measurement screen.

When working in forward power control (FPC) mode 000, the mobile station uses the 800 bps primary reverse power control subchannel to control the F-Traffic/F-FCH power level. The performance of forward power control is measured by the differences between the mobile station received FER and the assigned target FER while not exceeding the required Eb/Nt limit. For more information on how FPC works, see Forward Power Control Overview .

When the FPC mode 000-Primary 800 is enabled on the test set (see FPC Mode ), the mobile station can direct the test set to change F-Traffic/F-FCH level to achieve a certain FER. If the F-Traffic/F-FCH level reaches a very high value, Eb/Nt may exceed the Eb/Nt limit as specified by the test standard but the FER confidence result is Pass. To solve this problem, the test set will calculate the average Eb/Nt, maximum Eb/Nt and minimum Eb/Nt of the F-FCH during the FER measurement and determine the Eb/Nt Pass/Fail result when the measurement completes. If the average Eb/Nt is no greater than the specified Eb/Nt Limit, the Eb/Nt Pass result is returned to indicate that the mobile station has passed the Eb/Nt limit for the FER test. Providing the Eb/Nt Pass/Fail result in addition to the FER confidence Pass/Fail result can help you identify which one leads to the final FER failure. All these results are displayed on the FER measurement screen (see FER Measurement Results Specific to Lab Application ).

NOTE
The initial stage of the FER measurement algorithm is to determine the loopback delay through the mobile station. This synchronization stage requires that a small number of consecutive frames matching those sent by the test set be looped through the mobile station and received at the test set.

In the lab application, when the F-FCH/Traffic Frame Pattern State is set to On and the F-FCH/Traffic Frame Pattern Good Frames is set to a value less than three the FER measurement may not be able to synchronize with the mobile station. An error message will be generated if the F-FCH/Traffic Frame Pattern State is set to On, the F-FCH/Traffic Pattern Good Frames is set to a value less than three, and the FER measurement is running.

FER Measurement Parameters

  • Confidence State - Controls whether the confidence level will be used during the FER measurement. See Confidence Level Testing for details.
  • Confidence Level - Sets the confidence level (range is 80% to 99.99%) that is used to reduce the test time for the specified FER Requirement. See Confidence Level Testing for details.
  • FER Requirement - Sets the percentage of frame errors (range is 0.1% to 30%) that must not be exceeded for a confidence Pass result to be returned. When the Confidence Level is on, the FER Requirement is used to determine how many frames to test before making pass/fail results available. See Confidence Level Testing for details.
  • Maximum Frame Count - Sets the maximum number of frames (range is 25 to 10,000,000 frames) to be tested during the FER measurement.
  • Minimum Frame Count - Sets the minimum number of frames (range is 0 to 10,000,000 frames) to be tested before applying the confidence algorithm when the Confidence State is on. It does not apply when Confidence State is off. See Confidence Level Testing for details. Values for minimum frame count are specified in the standard for the faded tests.
  • F-FCH/Traffic Level - See Configuring Forward Channel Power Levels and Walsh Codes .
  • Eb/Nt Limit ( for lab application only ) - Sets the Eb/Nt limit (range is -30 to 42 dB) that must not be exceeded for a Eb/Nt Pass result to be returned. This setting applies only when the FPC mode 000 is enabled on the test set. See FER Measurement Specific to the Lab Application .
  • Trigger Arm - (See Trigger Arm (Single or Continuous) Description ).
  • Timeout Time/State - (See Timeouts ).

FER Measurement Results

  • Integrity Indicator - (see Integrity Indicator )
  • Confidence Pass/Fail - indicates whether the measurement achieved confidence of failure or success, or whether maximum frame count was reached. See Confidence Level Testing .
  • FER - the ratio of Total Frame Errors to Frames Tested expressed as a percentage.
  • Total Frame Errors - the total number of frames found in error including Mobile Errors, Forward Erasures and Reverse Erasures.
  • Forward Erasures - the number of frames that the mobile station could not decode. These frames are reported as CAT_TYPE 11 by the mobile station.
  • Reverse Erasures - the number of frames that the test set could not decode. This is caused by poor transmitted signal quality from the mobile station.
  • Mobile Errors - errors detected by the test set via a bit-by-bit comparison of transmitted frames and the frames looped back from the mobile station. These frames can be the mobile reported bad frames (CAT_TYPE 10) which are indeed bad frames after test set's validation, or the mobile reported good frames (CAT_TYPE 00) but actually validated by the test set as bad frame.
  • Frames Tested - the number of frames actually tested. If the Confidence Level is off, the Frames Tested equals the specified Max Frame Count when the FER measurement completes.
  • Max Frame Count - the maximum number of frames to be tested.
  • Eb/Nt - the ratio of energy per bit of the F-Traffic/F-FCH to noise power spectral density. It is displayed when AWGN power is on.

A typical display is shown below:

FER Measurement Results Specific to Lab Application

In addition to the measurement results listed above, the FER measurements also provides the following results in the Lab Application :

  • Ext AWGN Power (dBm/1.23 MHz) - an external AWGN value is displayed whenever the test set is configured to generate faded forward channel signals with AWGN. This setup requires a rear panel digital bus connection to an external PC running Baseband Studio software. See Digital Bus Information for details.

When the test set is configured to work in FPC mode '000' (see FER Measurement Specific to the Lab Application ), the following additional results are available:

  • Eb/Nt Pass/Fail - indicates whether the measurement passed or failed the specified Eb/Nt Limit during the FER measurement. If the average Eb/Nt is no greater than the specified Eb/Nt Limit, the Eb/Nt Pass result is returned to indicate that the mobile station has passed the Eb/Nt limit for the FER test. Providing the Eb/Nt Pass/Fail result in addition to the FER confidence Pass/Fail result can help you identify which one leads to the final FER failure.
  • Average Eb/Nt - indicates the average Eb/Nt of the F-FCH during the FER measurement in FPC mode 000. This result is updated every 50 frames (~ 1 second) on the front panel display to indicate the most recent 50 frames average Eb/Nt result. When the measurement completes, the total average Eb/Nt during the FER measurement is returned.
  • Maximum Eb/Nt - indicates the maximum Eb/Nt of the F-FCH during the FER measurement in FPC mode 000.
  • Minimum Eb/Nt - indicates the minimum Eb/Nt of the F-FCH during the FER measurement in FPC mode 000.

A typical display for FER measurement in FPC mode 000 is shown below:

Input Signal Requirements

The FER measurement meets or exceeds specifications when the following requirements are met:

  • The frequency of the signal being measured must be in the range of 412 MHz to 483 MHz, 800 MHz to 960 MHz, or 1.7 GHz to 2.0 GHz, and within 100 kHz of the expected frequency.
  • The signal level into the test set's RF IN/OUT connector must be in the range of -25 dBm to +37 dBm, and within +/- 9 dB of the expected input power (see RFANalyzer:AUTO:POWer[:SELected]? to meet specifications.

Key TIA/EIA-98-E Tests Using FER

  • Testing 3.4.1 Demodulation of Forward Traffic Channel in AWGN
  • Testing 3.5.1 Receiver Sensitivity and Dynamic Range
  • The standard fading tests can be made when the test set is configured to work with the N5115A fading solution. For details, refer to:

    E5515C Fading Solution Application Guide

    It can be downloaded at http://cp.literature.agilent.com/litweb/pdf/1000-1894.pdf .

Related Topics

Measuring Frame Error Rate (FER)


Frequency Modulation (FM) Measurement Description

Frequency Modulation (FM) Measurement Description

Last updated: August 12, 2005

Description

How is a frequency modulation measurement made?

The Analog Frequency Modulation measurement measures the frequency deviation and, if enabled, the total harmonic distortion and modulation frequency, for frequency modulated analog signals (such as AMPS transmitters). Measurements are performed after any filtering, de-emphasis, and expansion are performed (selected by the user in the setup parameters).

The FM deviation and distortion measurements are not affected by a static (constant) frequency error on the input signal as long as the input signal is within 2.5 kHz of the expected frequency.

This measurement is not used for digital signals.

Operating Consideration

The distortion value is not returned if the Distortion State is set to OFF. The modulation frequency value is not returned if the Modulation Frequency State is set to OFF.

Triggering is always immediate for this measurement. Trigger Delay and other trigger sources are not used.

When manually controlling the test set from the front panel, all measurements default to using continuous triggering. If you make digital measurements on a DTC using RF Rise or Protocol triggering, and then hand off to an AVC and select an analog measurement, the analog measurement may not trigger and display a result. This is because the digital measurement is still waiting for a burst transmission to trigger it (which it won't get from an analog signal) and therefore the measurements "freeze". To prevent this from happening when making analog measurements, either turn off the digital measurements or set their trigger source to Immediate.

Frequency Modulation Measurement Parameters

  • Multi-Measurement Count (See Statistical Measurement Results ) - Select On to enable averaging of multiple signaling tone measurement results.
  • Distortion State (See SETup:FM:DISTortion:STATe ) - Select On to enable the Distortion State.
  • Distortion Fundamental Frequency (See SETup:FM:DISTortion:FREQuency ) - The Distortion Fundamental Frequency value specifies the demodulated audio frequency to use when making a distortion measurement, and must be entered to make a valid measurement. However, specifying the fundamental frequency does not affect the measurement state.
  • Modulation Frequency State (See SETup:FM:FREQuency:STATe ) - The modulation frequency measurement is enabled and disabled using the Mod Freq State setting. The modulation frequency measurement is made after any filtering is applied, and can be used to make measurements such as SAT frequency.
  • Filter Type ( SETup:FM:FILTer[:TYPE] ) - The following filter are avaialble to make measurements on the demodulated FM (baseband) signal.
    • None - no filtering is provided (default)
    • 50 Hz to 15 kHz
    • 300 Hz to 15 kHz
    • 100 Hz BW Band Pass Filter (Tunable)
    • C-Message
    • 50 Hz to 3 kHz
  • 100 Hz BW BPF Center Frequency ( SETup:FM:FILTer:TBPass[:FREQuency] ) - The setting is available when this filter is selected, and can be set in the range of 300 Hz to 15 kHz
  • Detector Type ( SETup:FM:DETector[:TYPE] ) - Select the type of detector to use when making FM deviation measurements: RMS, Peak+, Peak-, Peak +/- Max and Peak +/- /2.
    • The Peak+ and Peak- detectors measure the greatest positive or negative frequency excursion in carrier frequency during the sample.
    • The RMS detector measures the root mean squared value. This setting does not affect the distortion measurement.
    • The Peak+/- Max detector measures both greatest positive and negative peaks and take the absolute value of each, then return the greater one.
    • The Peak+/- /2 detector measures both greatest positive and negative peaks and take the absolute value of each, then returns average value.
  • De-emhasis State ( SETup:FM:DEMPhasis:STATe ) - Select On or Off to enable or disable (respectively) 750 ms de-emphasis
  • Expandor State ( SETup:FM:EXPandor:STATe ) - Select On to compensate for signal compression on the mobile station's transmitted signal.
  • Gate Time (See SETup:FM:GTIMe ) - Sets the length of gate time that the FM measurement samples the signals under test.
  • Trigger Arm (See Triggering of Measurements )
  • Measurement Timeout (see Timeouts )

Related Topics

Programming a Frequency Modulation (FM) Measurement

Measuring Frequency Modulation

Frequency Modulation (FM) Troubleshooting

Statistical Measurement Results

Timeouts

Triggering of Measurements

Test Adherence to Standards


Frequency Stability Measurement Description

Frequency Stability Measurement Description

Last updated: October 29, 2004

Description

How is a Frequency Stability measurement made?

The Frequency Stability measurement displays the frequency of an RF signal applied to the test set's front panel RF IN/OUT input port. After each measurement the input signal's absolute RF freqency is displayed with 1000 Hz resolution on the test set's front panel and 1 Hz resolution when queried over the GPIB.

The absolute RF signal frequency obtained during each Frequency Stability measurement is compared to the expected (measurement downconverter) frequency of the test set's measuring receiver. The difference between the expected frequency and the measured frequency is displayed as frequency error with 1 Hz resolution.

Frequency Stability Measurement

If the device under test is a mobile station on a call, the expected frequency can be automatically set by the base station emulator (using the RF Channel setting).

If the device under test is not on a call, the expected frequency must be set by manually controlling the receiver (manual measurement frequency).

Operating Considerations

Front Panel Access

Frequency Stability measurements are accessed manually by pressing the front-panel Measurement selection key.

NOTE
In some test set applications it is necessary to select an analog System Type (for example, AMPS) or an analog Operating Mode (for example, AVC Test or CW) to access the Frequency Stability measurement.

Input Signal Requirements

The Frequency Stability measurement is designed to measure non-bursted analog signals. For example, this measurement can be made on an AMPS cellular mobile station while it is on an active AVC (analog voice channel) with or without SAT or other frequency modulation. It is not desiged to measure AM (amplitude modulated) signals.

When a mobile station is on a call, the test set has the ability to predict the power level and frequency that is present on the RF input and automatically adjust attenuator and measurement downconverter settings. However, for test operating modes or CW (continuous wave) the test set is not functioning as a base station emulator. In the absence of call control, it is likely that the test set's receiver will need to be manually tuned to the input signal.

To meet Frequency Stability measurement performance specifications, the input signal must be:

  • Within the frequency interval 293 MHz to 2.7 GHz.
  • Within 200 kHz of the expected frequency.
  • Greater than -30 dBm.
  • Within 3 dB of the expected power.
  • Within an FM index of three (if FM is applied).
  • Within 100 Hz and 15 kHz modulating frequency (if FM is applied).

Multi-measurement Use

When multi-measurement count is turned on during a Frequency Stability measurement, the test set returns statistical data acquired over a number of measurements, including the worst case frequency error, in ppm (parts per million).

Frequency Stability Measurement With Multi-measurements

Related Topics

Programming a Frequency Stability Measurement


Gated Power Measurement Description

Gated Power Measurement Description

Last updated: June 20, 2006

  • What is a Gated Power Measurement?
  • How is a Gated Power Measurement Made?
  • Input Signal Requirements
  • Key TIA/EIA-98-E Tests Using the Gated Power Measurement
  • Calibrating the Gated Power Measurement

What is a Gated Power Measurement?

Gated power measurements provide a graphical representation of the time response of the mobile station average transmitter power during periods when the power is gated on. During power gated transmission, power from the mobile station is delivered in bursts. A measurement mask delineates the boundaries that the signal's amplitude trace must conform to.

A measurement progress report, showing the number of measurements in a multi-measurement, is displayed on the test set's screen in an "n/m" format. The number of measurements completed, n , increases from zero to the total number of measurements which need to be made, m . The default settings for gated power measurements include multi-measurement on with a 100 measurement count.

Two views of the power versus time graph are available after the test set analyzes measurement data. The two views are:

  • Rise/Fall View
  • Full/Zoom View

Rise/Fall View

The rise (part of Rise/Fall View) trace zooms in on the rising edge of the burst, from -15 uS to +10 uS relative to the beginning of the burst. The beginning of the burst corresponds with the gated-on power control group clock edge.

NOTE
Traffic channel frames are subdivided into sixteen 1.25 millisecond segments, called power control groups. When the traffic data rate is set to half, quarter, or eighth, the mobile station transmits only during randomly selected power control groups. These are referred to as "gated-on" power control groups.

The fall (part of Rise/Fall) trace zooms in on the falling edge of the burst, from 1237 to 1262 uS after the beginning of the burst.

Full/Zoom View

The full (part of Full/Zoomed) trace encompasses the entire burst with decreased resolution as compared with the rise and fall. This trace spans the time period from -15 uS to 1262 uS relative the beginning of the burst.

The zoom (part of Full/Zoomed) trace details the area selected by the Zoom Position field and highlighted by a vertical bar displayed on the full trace. This vertical bar can be positioned in any one of 14 locations along the entire length of the zoom burst. (The extreme left and right zoom positions equate to the rise and fall views.)

A marker displaying the power level (from +10 to -45 dB) at each time increment is provided for all traces except for the full view. If a gated power measurement fails, the marker will be automatically positioned at the first fail point.

How is a Gated Power Measurement Made?

Each gated power measurement is triggered internally by the test set. During the gated power measurement, a DSP (Digital Signal Processor) samples the signal and returns 5,625 amplitude versus time data points. Data points return power levels, relative to the average power during the middle of the burst, that correspond with time intervals before, during, and after the burst.

The gated power measurement analyzes the rising and falling edges of the burst to determine where the -3 dB points are. Using the -3 dB points to determine the center of the burst, the test set positions the measurement mask (green lines on the display) to align in time with the center of the burst.

Since the middle portion of the burst is compressed in time, the scaling is different when compared to the rising or falling portions. The following formulas can be used to calculate the time associated with each data point from 0 to 5,264 as returned by the FETCh:GPOWer:TRACe? command:

Time Association For Data Points 0 through 370

where t1 is the sampling period for each data point, and p is the data point of interest (from 0 to 5,264).

Time Association For Data Points 371 through 4893

where t1 is the sampling period for each data point, and p is the data point of interest (from 0 to 5,264).

Time Association For Data Points 4894 through 5264

where t1 is the sampling period for each data point, and p is the data point of interest (from 0 to 5,264).

NOTE
Data point 222 corresponds with time 0 on the gated power graph.

On the test set's display, data points are graphed as follows:

  • For the rising trace, data points 0 through 370 (the first 371) are displayed with each data point occupying one display pixel.
  • For the falling trace, data points 4894 through 5264 (the last 371) are displayed with each data point occupying one display pixel.
  • For the Full/Zoomed trace spanning the entire 1277 uS measurement period, averaging over groups of data points will be performed to include all 5,264 data points using the display's 371 pixels.

  • For the Full/Zoomed trace that zooms in on the area highlighted by the vertical bar, the correlation between data points and pixels is as follows:

    • For the first or last zoomed segment the correlation between data points and display pixels will be identical to the Rise/Fall traces, with the first or last 371 data points displayed on 371 pixels.
    • For all of the middle 12 zoomed segments, the time period (when compared with rise/fall graphs) will be compressed in time. Each data point will span a time period four times longer than the rise/fall data points. This will result in about one fourth the display resolution when compared with the rise/fall traces.
    Graticule Line Labeling for all Zoomed Traces

    Zoom Position

    DSP Output Range (points)

    Count of Data Points

             µ s

    Graticule Line 0

             µ s

    Graticule Line 2

    µ s

    Graticule Line 4

    µ s

    Graticule Line 6

    µ s

    Graticule Line 8

    µ s

    Graticule Line 10

    0

             0-370 371 -15 -10 -5 0 5 10
    1 371 to 747 377 10 31 51 71 92 112
    2 748 to 1124

    377

    112

    133

    153

    174

    194

    214
    3

    1125 to 1501

    377

    215

    235

    255

    276

    296

    317

    4

    1502 to 1878

    377

             317

    337

    358

    378

    399

    419

    5

    1879 to 2255

    377

    419

    440

    460

    480

    501

    521

    6

    2256 to 2632

    377

    521

    542

    562

    583

    603

    623

    7

    2633 to 3008

    376

    624

    644

    664

    685

    705

    726

    8

    3009 to 3385

    377

    726

    746

    767

    787

    808

    828

    9

    3386 to 3762

    377

    828

    849

    869

    889

    910

    930

    10

    3763 to 4139

    377

    930

    951

    971

    992

    1012

    1032

    11

    4140 to 4516

    377

    1033

             1053

    1073

    1094

    1114

    1135

    12

    4517 to 4893

    377

    1135

    1155

    1176

    1196

    1216

    1237

    13

    4894 to 5264

    371

    1237

    1242

    1247

    1252

    1257

    1262

Gated Power Measurement Considerations

The following settings are required for the gated power measurement:

  • Operating Mode must be Active Cell
  • System Type must be IS-95 or IS-2000 with Radio Config set to (Fwd1, Rvs1) or (Fwd2, Rvs2)
  • FCH Service Option Setup must be set to SO2 or SO9 (loopback service option)
  • Traffic Data Rate must be set to Eighth.

Gated Power measurements can not be made concurrently with any other measurement, and no other measurement can be made while a gated power measurement is in progress.

The pass/fail result indicates whether or not the trace conformed to the mask.

To make the test run faster, reduce the number of averages (multi-measurement count). The default is 100.

Most failures occur during the rising or falling portions of the burst.

Gated power measurements are expressed in dB, relative to the average of the power levels across the number of 1.25 mS burst specified in the multi-measurement count.

Input Signal Requirements

The gated power measurement meets or exceeds specifications when the following input signal requirements are met:

  • The frequency of the signal being measured must be within the range of 411 MHz to 484 MHz, 804 MHz to 934 MHz, 1.75 GHz to 1.78 GHz, or 1.85 GHz to 1.98 GHz, and be within 100 kHz of the expected frequency.
  • The average power level of the signal at the RF IN/OUT connector must be between -20 dBm to +30 dBm. The test set can autorange to a signal that is within +/- 9 dB of the expected input level (see RFANalyzer:AUTO:POWer[:SELected]? ).

Key TIA/EIA-98-E Tests Using the Gated Power Measurement

  • Testing 4.4.7 Standby Output Power and Gated Output Power

Calibrating the Gated Power Measurement

The gated power measurement is automatically calibrated during a channel power calibration. Follow the channel power calibration schedule and the gated power measurement will be properly calibrated. Refer to Calibrating the Test Set for a description of channel power calibration.

Related Topics

Measuring Gated Power


Handoff Waveform Quality Measurement Description

Handoff Waveform Quality Measurement Description

Last updated: October 28, 2004

NOTE
If the Handoff Waveform Quality measurement is running at the time the power control transient transmission starts (see Starting the Reverse CLPC Transient ) the measurement will be closed and its operation aborted. Moreover, the Handoff Waveform Quality measurements will not be able to start (become initiated) while the transient transmission is in progress.

How is a Handoff Waveform Quality measurement made?

Handoff waveform quality measurements test a transmitter's modulation accuracy during transmission of a single code channel, the reverse Pilot Channel. The handoff involves changing the current PN (pseudo-noise) offset to force the mobile station to transmit a preamble on the Pilot Channel only. Reverse link power control is changed to alternating up/down bits and waveform quality is measured. After the measurement, the PN offset is returned to the original setting and the power control is returned to the original setting.

Each handoff waveform quality measurement returns a number of measurements which include rho, the percentage of signal energy that correlates with a perfect IS-2000 signal after time offset and frequency error have been removed.

This measurement is designed to analyze signals that are made up of multiple code channels, as in the case of radio configurations three and above.

Waveform quality measurements are made by sampling the down-converted input signal, then applying DSP (Digital Signal Processing) techniques to determine the original data input to the mobile station transmitter's Walsh spreading function for each channel. The DSP then generates a representation of what the "ideal" signal would be given the coding and data in use at the time of transmission. The ideal waveform is then compared with the waveform being measured to determine the waveform quality.

Handoff Waveform Quality measurement results lists the Handoff Waveform Quality measurements:

Handoff Waveform Quality measurement results
Handoff Waveform Quality
Rho
Frequency Error
Timing Error
Carrier Feedthrough
Phase Error
Magnitude Error

Measurement Behavior

The handoff waveform quality measurement does not provide the Multi-Measurement Count feature in the setup menu.

Handoff waveform quality measurements are always triggered singly (press the START SINGLE key to initiate a measurement from the front panel).

Measurement Requirements

Setup:

The following settings are required for the handoff waveform quality measurement:

  • Operating Mode must be Active Cell
  • System Type must be IS-2000 with Radio Config set to (Fwd3, Rvs3) or (Fwd4, Rvs3)
  • A call must be connected

Input Signal:

The handoff waveform quality measurement meets or exceeds specifications when the following input signal requirements are met:

  • The frequency of the signal being measured must be in the range of 412 MHz to 483 MHz, 800 MHz to 960 MHz, or 1.7 GHz to 2.0 GHz, and within 100 kHz of the expected frequency.
  • The signal level into the test set's RF IN/OUT connector must be in the range of -25 dBm to +37 dBm, and within +/- 9 dB of the expected input power (see RFANalyzer:AUTO:POWer[:SELected]? ) to meet specifications.

Key TIA/EIA-98-E Tests Using the Handoff Waveform Quality Measurement

See Measuring Handoff Waveform Quality

Calibrating the Handoff Waveform Quality Measurement

The handoff waveform quality measurement is automatically calibrated during a channel power calibration. Follow the channel power calibration schedule and the handoff waveform quality measurement will be properly calibrated. Refer to Calibrating the Test Set for a description of channel power calibration.

Related Topics

Measuring Handoff Waveform Quality


Instrument Configuration Measurement Matrix

Instrument Configuration Measurement Matrix

Last updated: October 28, 2004

The following table shows which measurements are available for the various instrument configurations.

Instrument Configuration Measurement List
 | Active Cell |  |  |  | IS-2000 Test |  | AVC Test | CW Mode | Cell Off
 | IS-2000 |  | IS-95 | AMPS | RC3, RC4, RC5 | RC1, RC2
 | RC3, RC4, RC5 | RC1, RC2
Access Probe Power | X | X |  |  |  |  |  |  |
Channel Power | X | X |  |  | X | X |  |  |
Code Channel Time and Phase | X |  |  |  | X |  |  |  |
Digital Average Power | X | X |  |  | X | X |  |  |
Frame Error Rate | X | X |  |  |  |  |  |  |
Gated Power |  | X |  |  |  | X |  |  |
Graphic Access Probe Power ( Lab Application only ) | X | X |  |  |  |  |  |  |
Handoff Waveform Quality | X |  |  |  |  |  |  |  |
Multi-Tone Audio | X | X |  |  |  |  |  |  |
Maximum/Minimum Power | X | X |  |  |  |  |  |  |
TDSO Frame Error Rate | X |  |  |  |  |  |  |  |
Time Response of Open Loop Power | X | X |  |  | X | X |  |  |
TX Dynamic Power | X | X |  |  | X | X |  |  |
TX Spurious Emissions | X | X |  |  | X | X |  |  |
Waveform Quality, Code Domain | X | X1 |  |  | X | X1 |  |  |
Analog TX Power |  |  |  | X |  |  | X | X |
Frequency Stability |  |  |  | X |  |  | X | X |
FM: deviation, distortion, frequency |  |  |  | X |  |  | X | X |
Audio:2 level, SINAD, frequency, distortion, swept audio | X | X |  | X | X | X | X | X | X
  1. Code domain is not available in RC1, RC2, or IS-95, but it is displayed on the instrument's display for these configurations.
  2. These are instrument selection measurements. They are supported in all states.


Maximum/Minimum Power Measurement Description

Maximum/Minimum Power Measurement Description

Last updated: October 28, 2004

  • How is a Maximum/Minimum Power Measurement Made?
  • Maximum/Minimum Power Measurement Parameters
  • Maximum/Minimum Power Measurement Results
  • Input Signal Requirements
  • Key TIA/EIA-98-E Tests Performed Using the Maximum/Minimum Power Measurement
  • Calibrating the Maximum/Minimum Power Measurement

How is a Maximum/Minimum Power Measurement Made?

The Maximum/Minimum Power measurement, which is actually a firmware routine programmed into the test set, provides an automated way of measuring both the maximum and minimum output power of a CDMA mobile station. It is implemented using a combination of the capabilities of the Average Power measurement (see Digital Average Power Measurement Description ) and the Channel Power measurement (see Channel Power Measurement Description ). The Average Power measurement is used to measure the maximum power of the mobile station, and the Channel Power measurement is used to measure the minimum controlled output power of the mobile station. Both open loop and closed loop power control drive the mobile station's power level up and down. Two power measurement results will be displayed when the measurement is complete.

Maximum/Minimum Power Measurement Parameters

  • Measurement Timeout - (see Timeouts ).

Maximum Power Setup:

  • Max Power Meas Cell Power(dBm/1.23 MHz) - (see SETup:CMMPower:POWer:AMPLitude:MAXimum ).
  • Max Power Meas F-FCH/Traffic Level - (see SETup:CMMPower:TRAFfic:LEVel:MAXimum ).
  • Max Power Meas Pilot Level - (see SETup:CMMPower:PILot:LEVel:MAXimum ).
  • The test set will automatically send continuous '0' power control bits (All Up bits) during the maximum power measurement.

Minimum Power Setup:

  • Min Power Meas Cell Power (dBm /1.23 MHz) - (see SETup:CMMPower:TRAFfic:LEVel:MINimum ).
  • Min Power Meas F-FCH / Traffic Level - (see SETup:CMMPower:TRAFfic:LEVel:MINimum ).
  • Min Power Meas Pilot Level - (see SETup:CMMPower:PILot:LEVel:MINimum ).
  • Min Power Meas Receiver Power Control - (see SETup:CMMPower:RFANalyzer:AUTO:MINimum ).
  • Min Power Meas Receiver Power - (see SETup:CMMPower:RFANalyzer:POWer:MINimum ).
  • The test set will automatically send continuous '1' power control bits (All Down bits) during the minimum power measurement.
  • The test set will automatically set the Call Drop Timer to Off during the minimum power measurement.

NOTE
The test set will temporarily use the parameters set from the Maximum Power Setup menu ( Maximum Power Setup: ) for the maximum power measurement, use the parameters set from the Minimum Power Setup menu ( Minimum Power Setup: ) for the minimum power measurement. When the measurement is finished, the test set returns to its pre-measurement settings (including Cell Power, F-FCH/Traffic Level, Pilot Level, Receiver Power Control, Reverse Power Control mode, and Call Drop Timer) which are set from the Call Parms menu (see How Do I Change Call Parameters? ).

Maximum/Minimum Power Measurement Results

  • Integrity Indicator - (see Integrity Indicator and FETCh:CMMPower[:ALL]? ).
  • Maximum Power Result (dBm) - (see FETCh:CMMPower:MAXPower? )
  • Minimum Power Result (dBm/1.23MHz) - (see FETCh:CMMPower:MINPower? )

A typical measurement result is shown below:

Input Signal Requirements

The Maximum/Minimum power measurement meets specifications when the following input signal requirements are met:

  • The frequency of the signal being measured must be within the range of 412 MHz to 483 MHz, 800 MHz to 960 MHz, or 1.7 GHz to 2.0 GHz, and be within 100 kHz of the expected frequency.
  • The signal level into the test set's RF IN/OUT connector must be between -61 dBm to +37 dBm. The test set can autorange to a signal that is within +/- 9 dB of the expected input level (see RFANalyzer:AUTO:POWer[:SELected]? ).

Key TIA/EIA-98-E Tests Performed Using the Maximum/Minimum Power Measurement

  • Testing 4.4.5 Maximum RF Output Power and 4.4.6 Minimum Controlled Output Power

Calibrating the Maximum/Minimum Power Measurement

The maximum power measurement is automatically calibrated during a digital average power calibration. The minimum power measurement is automatically calibrated during a channel power calibration.

To properly calibrate the maximum/minimum power measurement, you need to perform the digital average power calibration first, then make the channel power calibration. Refer to Calibrating the Test Set for details of digital average power calibration and channel power calibration.

Related Topics

Measuring Maximum/Minimum Power

Programming a Maximum/Minimum Power Measurement

Maximum/Minimum Power Measurement Troubleshooting

Channel Power Measurement Description

Digital Average Power Measurement Description


Multi-Tone Audio Measurement Description

Multi-Tone Audio Measurement Description

Last updated: June 13, 2007

  • How is a multi-tone audio measurement made?
  • Multi-Tone Audio Measurement Parameters
  • Multi-Tone Audio Measurement Results

NOTE
The Multi-Tone Audio measurement can not be concurrent with the Audio Analyzer instrument nor with the Swept Audio measurement. Hence starting the multi-tone audio measurement will turn off any other measurement that is active, and vice versa.

How is a multi-tone audio measurement made?

You can use the multi-tone audio measurements (available for IS-95 and IS-2000 system) to verify the connectivity and performance of the analog audio signal handling components of a mobile station (such as speaker, microphone, headset, etc.).

There are two modes provided for this measurement. The downlink measurement mode (see Downlink Audio Mode ) is intended to test the audio reproduction abilities of the mobile station. The uplink measurement mode (see Uplink Audio Mode ) is intended to test the audio capture and encoding functions of the mobile station. The test set provides two independent multi-tone audio generators (one for downlink tests and another for uplink tests) and a multi-tone audio analyzer.

  • Downlink Audio Generator

    The Downlink Audio Generator is used to in downlink measurement mode and provides a multi-tone audio signal that may be encoded and transmitted on the F-FCH/F-Traffic channel to the mobile station. The downlink generator provides up to 20 sinusoidal tones which are summed to form the audio signal. Presets are provided for convenience in rapidly setting the audio generator to commonly used configurations. The downlink audio generator total level is settable and is distributed evenly across all the tones that are currently enabled. See Multi-Tone Audio Generator Parms for details.

  • Uplink Audio Generator

    The Uplink Audio Generator is provided for use with the multi-tone audio measurement in uplink mode. The generator produces an analog signal that is routed to the test set's Audio Out port. The uplink audio generator provides up to 20 sinusoidal tones which are summed to form the audio signal. Presets are provided for convenience in rapidly setting the audio generator to commonly used configurations. The frequency, level, and state of each of the tones is individually settable. If the total level of the generator is set the level is distributed evenly among the tones that are turned 'On'. See Multi-Tone Audio Generator Parms for details.

  • Audio Analyzer

    During the downlink measurement mode, the audio analyzer examines the analog signal at the test set's AUDIO IN port. While in the uplink measurement mode, the audio analyzer reconstructs and analyzes a digital representation of the analog signal transmitted from the mobile station on the R-FCH/R-Traffic channel. You can choose to have the audio analyzer tuned to the same frequencies as the audio generator, or you can configure the audio analyzer independently for your test situations. See Multi-Tone Audio Analyzer Parms for details.

Downlink Audio Mode

The downlink audio mode (selected from Multi-Tone Audio Setup menu) is intended to test the audio reproduction abilities of the mobile station (such as decoder, speaker, etc.). You should select a voice service option (SO1, SO3, SO17, SO68, or SO32768) (see Service Option ) and set the Voice SO Mode to Multi-Tone (see Voice SO Mode ) to perform the downlink multi-tone audio measurement. This causes downlink audio generator tones to be encoded and gets placed on the F-Traffic/F-FCH channel.

A Simplified Diagram for Speaker Test with Downlink Audio Mode shows an example of the speaker test. The tones generated from the Downlink Audio Generator of the test set are encoded into the digitized speech frame and sent to the mobile station over the RF link. The mobile station decodes the received speech frame into an analog signal and sends it to the speaker. The audio signal travels through an acoustic coupler (or a test interface connection) to the AUDIO IN port of the test set, where frequency response is computed by the multi-tone audio analyzer. Measurement results, such as audio level, frequency response, and distortion (if a single tone present) results are available. See Multi-Tone Audio Measurement Results .

A Simplified Diagram for Speaker Test with Downlink Audio Mode

Requirements when making a downlink multi-tone audio measurement

The frequencies and states of the tones in the downlink audio generator are only settable through a set of presets. The tones' levels are controlled by a total output level with the power evenly distributed among all of tones specified by preset. See Multi-Tone Audio Generator Parms .

The Expected Audio In Peak Voltage (accessed from Multi-Tone Audio Setup menu) should be set appropriately to avoid over or under range errors. Note that measuring a 1-volt rms sinewave input signal would require a 1.414 V peak expected voltage value to avoid clipping (over-driving) the input.

Uplink Audio Mode

The uplink measurement mode (selected from Multi-Tone Audio Setup menu) is intended to test the audio capture and encoding functions of the mobile station (such as the microphone, encoders, etc.). You should select a voice service option (such as SO1, SO3, SO17, SO68, or SO32768) (see Service Option ) and set the voice SO mode to Null Frames (see Voice SO Mode ) to perform the uplink multi-tone audio measurements. Setting the voice SO mode to Null Frames ensures minimal energy signal sent on the downlink, which would reduce the leakage in the mobile station to interfere with the test.

A Simplified Diagram for Microphone Test with Uplink Measurement Mode shows an example of microphone test. The tones generated from the Uplink Audio Generator of the test set are sent to the AUDIO OUT port. An acoustic coupler (or a test interface connection) is used to connect the AUDIO OUT port to the mobile station's microphone. The mobile station encodes the audio signal into digitized speech frames and transmits it back to the test set via the RF link. The test set decodes the received speech frames and sends it to the multi-tone audio analyzer, where frequency response is computed. Measurement results, such as audio level, frequency response, and distortion (if a single tone present) results are available.

A Simplified Diagram for Microphone Test with Uplink Measurement Mode

Requirements when making an uplink multi-tone audio measurement

You can specify the frequencies and states for each of the 20 tones that may be generated by the uplink audio generator either individually or as a group from one of the presets. The output levels for each of the 20 tones are individually settable. If the total level of the generator is set the level is distributed evenly among the tones that are turned 'On'. See Multi-Tone Audio Generator Parms .

SINAD/Distortion Measurements

When the SINAD/Distortion (on Audio Tone 1) State is set to On (see Multi-Tone Audio Setup ), the test set returns the SINAD, Distortion, Audio Level, and Audio Frequency results for the first audio tone. See Multi-Tone Audio Measurement Results .

In this mode, it is also possible for you to measure a distortion level when no tone is being generated. This allows you to detect spurs from the mobile station.

Difference between Multi-tone Audio and Audio Analyzer SINAD/Distortion measurement:

The primary difference is that the Multi-Tone Audio measurement allows you to make these measurements on audio signals that are sent to the test set over RF or to the AUDIO IN connectors. The Audio Analyzer measurement only allows measurements to be made on the signal applied to the AUDIO IN connectors (see Audio Analyzer Measurement Description ).

Multi-Tone Audio Measurement Parameters

There are four groups of parameters associated with the multi-tone audio measurements:

  • Multi-Tone Audio Setup
  • Multi-Tone Audio Generator Parms
  • Multi-Tone Audio Analyzer Parms
  • Multi-Tone Audio Level Limits

Multi-Tone Audio Setup

  • Multi-Measurement Count ( SETup:CMAudio:COUNt[:SNUMber] ) - See Statistical Measurement Results .
  • Measurement Mode ( SETup:CMAudio:MEASurement:MODE ) - Controls whether audio measurements are made on the downlink or uplink. See Downlink Audio Mode and Uplink Audio Mode .
  • Analyzer 0dB Reference Mode ( SETup:CMAudio:REFerence:MODE )- Controls the reference mode to be used when making audio level measurements. If Relative is selected, the Analyzer Reference Tone is used to specify a tone as the reference. If Absolute is selected, the Analyzer Downlink Reference Level or the Analyzer Uplink Reference Level is used to specify a reference level.
  • Analyzer Reference Tone ( SETup:CMAudio:REFerence:RELative:TONE ) - Specifies which tone (1 to 20) is to be used as the reference when making relative measurements. The Analyzer 0dB Reference Mode must be set to Relative for this parameter to be active.
  • Analyzer Downlink Reference Level ( SETup:CMAudio:REFerence:ABSolute:LEVel:DOWNlink ) - Specifies the reference level used when making absolute measurements on the downlink. The Analyzer 0dB Reference Mode must be set to Absolute and the Measurement Mode must be set to Downlink Audio for this parameter to be active.
  • Analyzer Uplink Reference Level ( SETup:CMAudio:REFerence:ABSolute:LEVel:UPLink ) - Specifies the reference level (in percentage of the full DAC range) to be used when making absolute measurements on the uplink. The Analyzer 0dB Reference Mode must be set to Absolute and the Measurement Mode must be set to Uplink Audio for this parameter to be active.
  • Expected Audio In Peak Voltage ( SETup:CMAudio:PEAK:VOLTage ) - Specifies the absolute peak voltage of the audio signal expected at the AUDIO IN port of the test set. The Measurement Mode must be set to Downlink Audio for this parameter to be active. It must be in the range of 1 mV peak to 20 V peak . Note that measuring a 1 V rms sinewave input signal would require a 1.414 V peak expected voltage value to avoid clipping (over-driving) the input.
  • Device Settling Time ( SETup:CMAudio:SETTling[:TIME] ) - Specifies how long the multi-tone audio measurement will wait to start the measurement after each measurement request. This setting applies to both the uplink and downlink measurement mode. A setting of 0.0 seconds will let the multi-tone audio measurement run at maximum speed. Note that this setting provides a variable delay for the settling of audio transients, but will decrease the measurement speed since this delay is applied to each measurement including those measurements in which a generator transient is not expected to be present.

    It is recommended that you set the Device Settling Time to approximately 600ms to allow for the settling of audio transients when operating in the uplink measurement mode. For the downlink measurement mode, set the Device Settling Time to zero and use the setting of the Downlink Encoder Settling.
  • SINAD/Distortion (on Audio Tone 1) State ( SETup:CMAudio:SDIStortion:STATe ) - Selects On or Off to enable or disable the SINAD and Distortion measurements. When it is enabled (On), the Distortion, SINAD, Audio Level, and Frequency results for the first audio tone are available and displayed on the measurement result screen replacing the default bar graph results of frequency response. See Multi-Tone Audio Measurement Results .

    NOTE
    The SINAD and Distortion measurements are made on the first audio tone. It is recommended that you set the downlink or uplink audio generator to produce single tone (see Multi-Tone Audio Generator Parms ) when making the SINAD and Distortion measurements. If multi-tone is selected, all other tones will be measured as noise resulting in bad SINAD and Distortion results.

  • Downlink Encoder Settling ( SETup:CMAudio:ANALyzer:DOWNlink:SETTling ) - Specifies the time (in frames) that the downlink multi-tone audio measurement should be held off to ensure that transients have settled in the vocoders in the test set's transmitter and the mobile station's receiver. The hold-off period begins with any change to the downlink generator parameters. This settling time is only applied in downlink measurement mode when a call is connected and the Voice SO Mode is set to Multi-Tone.

    It is recommended that you use the Downlink Encoder Settling setting for the downlink mode measurement and set the Device Settling Time to zero.
  • Trigger Arm ( SETup:CMAudio:CONTinuous ) - See Trigger Arm (Single or Continuous) Description .
  • Measurement Timeout ( SETup:CMAudio:COUNt[:SNUMber] ) - See Timeouts .

  • Expected Uplink Signal Bandwidth - Specifies the signal bandwidth (fixed or in percentage of the Audio Tone 1 uplink frequency) to be used when making SINAD/Distortion measurement on the uplink.

    • Fixed - 100Hz
    • Narrow - 20% of the Audio Tone 1 uplink frequency
    • Medium - 40% of the Audio Tone 1 uplink frequency
    • Wide - 60% of the Audio Tone 1 uplink frequency

Multi-Tone Audio Generator Parms

The Downlink Frequencies ( F1 ) is used to configure the tones' frequencies/states generated by Downlink Audio Generator :

  • Preset Frequencies To - Allows you to configure all of the 20 available tones' frequencies/states based on the selected preset. See SETup:CMAudio:GENerator:FREQuency:DOWNlink:PRESet for details on the preset configurations.

The Downlink Levels ( F3 ) is used to configure the tones' power levels generated by Downlink Audio Generator :

  • Multi-Tone Audio Total Level - Sets the total audio output level (in percentage of the full DAC range) to be distributed evenly among the tones whose states are on. The range of this setting is from 10% to 50% in 20% increment. See also SETup:CMAudio:GENerator:LEVel:DOWNlink:ALL:TOTal[:SAMPlitude] .

The Uplink Frequencies ( F2 ) is used to configure the tones' frequencies/states generated by Uplink Audio Generator :

  • Preset Frequencies To - Allows you to configure all of the 20 available tones' frequencies/states based on the selected preset. See also SETup:CMAudio:GENerator:FREQuency:Uplink:PRESet .
  • Audio Tone <n> Frequency - Allows you to specify the frequencies for each of the 20 available tones individually as required for your test situation. Making any change to these settings will automatically set the Preset Frequencies To to None . See also SETup:CMAudio:GENerator:FREQuency:Uplink:ALL[:SVALue] .

The Uplink Levels ( F4 ) is used to configure the tones' power levels generated by Uplink Audio Generator :

  • Multi-Tone Audio Total Level - Sets the total average audio output level (in RMS) to be distributed evenly among the tones whose states are on. See also SETup:CMAudio:GENerator:LEVel:UPLink:ALL:TOTal[:SAMPlitude] . When this parameter is set to Off, you can turn on each audio tone individually and specify the level associated with it by Audio Tone <n> Level settings.
  • Audio Tone <n> Level - Allows you to specify the levels for all of the 20 available tones individually as required for your test situation. The Multi-Tone Audio Total Level must be set to Off for these parameters to be active. See also SETup:CMAudio:GENerator:LEVel:UPLink:ALL[:SAMPlitude] .

NOTE
For Uplink Audio Generator , any tone's state can be turned on or off via frequency or level settings. For example, if you set Audio Tone 2 Frequency on MTA Uplink Frequencies menu to Off , then the Audio Tone 2 Level on the MTA Uplink Levels menu will show Off too, and vice versa.

Multi-Tone Audio Analyzer Parms

When the MTAudio Analyzer Frequencies ( F4 ) is selected, the following parameters are available for controlling the Audio Analyzer :

  • Use Multi-Tone Generator Frequencies - Controls the frequencies coupling between the audio generator and the audio analyzer. See also SETup:CMAudio:ANALyzer:FREQuency:ALL:GENerator .
    • If it is set to On , the analyzer frequencies/states will use the frequencies/states specified for downlink audio generator (see Multi-Tone Audio Generator Parms ) when the Downlink Audio measurement mode is selected (see Multi-Tone Audio Setup ) or will use the frequencies/states specified for uplink audio generator (see Multi-Tone Audio Generator Parms ) when the Uplink Audio measurement mode is selected (see Multi-Tone Audio Setup ).
    • If it is set to Off , you must specify the frequencies for the analyzer to use by the settings of the Audio Tone <n> Frequency .
  • Audio Tone <n> Frequency - Allows you to specify the analyzer frequencies for all of the 20 available tones individually as required for your test situation. The Use Multi-Tone Generator Frequencies must be set to Off for these parameters to be active. See also SETup:CMAudio:ANALyzer:FREQuency:ALL[:SVALue] .

Multi-Tone Audio Level Limits

  • Allows you to specify the upper and lower limits for each of 20 audio tones. These settings are used to determine if the measured audio levels for each tone pass or fail. The fail indicator is set for a given tone if its measured level is less than the value of the lower limit or greater than the value of the upper limit. See also SETup:CMAudio:LEVel:ALL:LIMit:LOWer and SETup:CMAudio:LEVel:ALL:LIMit:UPPer .

Multi-Tone Audio Measurement Results

Depending upon the setting of the SINAD/Distortion (on Audio Tone 1) State (see Multi-Tone Audio Setup ), different results are available for the multi-tone audio measurements.

  • For multi-tone audio measurement results when the SINAD/Distortion (on Audio Tone 1) State is set to Off (default value), see Bar Graph Measurement Results .
  • For multi-tone audio measurement results when the SINAD/Distortion (on Audio Tone 1) State is set to On , see SINAD/Distortion Measurement Results

Bar Graph Measurement Results

When the SINAD/Distortion (on Audio Tone 1) State is Off (default value), a bar graph (see Bar Graph for Multi-Tone Audio Measurement Results ) will be displayed to provide the following results.

  • Integrity Indicator ( FETCh:CMAudio:INTegrity? ) - See Integrity Indicator .
  • Multi-Tone Audio Levels - The measurement reports the average level for all of the 20 available tones that are turned on. The results are displayed in a bar graph on the measurement screen (see Bar Graph for Multi-Tone Audio Measurement Results ) The measured level for each of the 20 tones can be queried with FETCh:CMAudio:LEVel? .
  • Multi-Tone Audio Pass/Fail Result - Indicates a pass or fail for all of the 20 available tones that are turned on. If any tone is outside of its specified level limits (see Multi-Tone Audio Level Limits ), a Fail result occurs resulting in the corresponding bar for the failed tone displayed in red. If the audio tone is within the valid mask, then the bar will displayed in yellow. You can query the overall pass/fail result with FETCh:CMAudio:LEVel:LIMit:FAIL? .

Bar Graph for Multi-Tone Audio Measurement Results

You can control the graph view by the softkeys accessed from Graph Control ( F6 ):

  • The y-axis on the graphical display is scaled as 10 divisions (4dB/div) and defaults to be ranged from -30 dB to 10 dB. You can view the levels of particular interest such as above +10 dB or below -30 dB by adjusting the scale with the Graph Reference ( F2 ) and Span ( F3 ) softkeys.
  • The x-axis on the graphical display is labeled with the bar numbers 1 to 20 corresponding to the audio tones 1 to 20.
  • The power level measured for each tone that is on is displayed as a bar. The color of the bar may be yellow, red, or blue.
    • Pass/fail limit lines for each tone are superimposed on the graph in green line. These lines are set from the Multi-Tone Audio Level Limits menu (see Multi-Tone Audio Level Limits ). If the measured level for any given tone is outside its limit lines, the corresponding bar is in red. If the measured level for any given tone is within its limit line, the corresponding bar is in yellow.
    • When the Analyzer 0dB Reference Mode is set to Relative (see Multi-Tone Audio Setup ), the tone whose state is on if specified as a reference tone by Analyzer Reference Tone will be displayed as blue bar.
  • The marker can be positioned on any of the 20 tone bars by the Marker Position ( F1 ). The frequency/level settings for that tone, as well as the measured level are then displayed at the top of the graph.

SINAD/Distortion Measurement Results

NOTE
The SINAD and Distortion measurements are made on the first audio tone. It is recommended that you set the downlink or uplink audio generator to produce single tone (see Multi-Tone Audio Generator Parms ) when making the SINAD and Distortion measurements. If multi-tone is selected, all other tones will be measured as noise resulting in bad SINAD and Distortion results.

When the SINAD/Distortion (on Audio Tone 1) State is set to On , the Distortion, SINAD, Audio Level, and Frequency results for the first audio tone will be displayed (see SINAD/Distortion Results for Audio Tone 1 )

  • Distortion - The measured distortion of audio tone one. The SINAD/Distortion state must be turned on for this measurement result to be available (see SINAD/Distortion Results for Audio Tone 1 ). You can also get the results by sending FETCh:CMAudio:DISTortion[:AVERage]? .
  • SINAD - The measured SINAD for audio tone one. The SINAD/Distortion state must be turned on for this measurement result to be available (see SINAD/Distortion Results for Audio Tone 1 ). You can also get the results by sending FETCh:CMAudio<:SINad|:SNDRatio>[:AVERage]? .
  • Audio Level - The measured audio level for audio tone one. The SINAD/Distortion state must be turned on for this measurement result to be available (see SINAD/Distortion Results for Audio Tone 1 ). You can also get the results by sending FETCh:CMAudio:VOLTage[:AVERage]? .
  • Frequency - The measured frequency for audio tone one. The SINAD/Distortion state must be turned on for this measurement result to be available (see SINAD/Distortion Results for Audio Tone 1 ). You can also get the results by sending FETCh:CMAudio:FREQuency[:AVERage]? .

SINAD/Distortion Results for Audio Tone 1

Related Topics

Measuring a Multi-tone Digital Audio


Terminologies on the Test Set Adherence to Standard

Terminologies on the Test Set Adherence to Standard

Last updated: October 28, 2004

This table lists the parameters required to be set in most standard tests. It is to help you quickly find the menus/softkeys on the test set's front panel to configure the parameters as specified in the standard.

Test Parameters
Parameters in Standard | Equivalent Settings on the Test Set
Ioc (dBm/1.23 MHz) | AWGN Power (see How Do I Change AWGN Power Levels? )
Î or (dBm/1.23 MHz) | Cell Power ( F7 on the Call Parms 1 of 3 ) (see How Do I Change Call Parameters? )
Ior/Ioc (dB) | Ior/Ioc is the ratio of Cell Power to AWGN. See Configuring Cell Power and AWGN Power Levels . It is not directly settable. Normally, the Ioc has been specified. You need to set Cell Power to the value of (Ioc + Ior/Ioc) to achieve this setting.
Pilot Ec/Ior (dB) Sync Ec/Ior (dB) Paging Ec/Ior (dB) QPCH Ec/Ior (dB) BCCH Ec/Ior (dB) FCCCH Ec/Ior (dB) FCH Ec/Ior (dB) SCH Ec/Ior (dB) | Cell F-Pilot Level Cell F-Sync Level Cell F-Paging Level Cell F-QPCH Level Cell F-BCCH Level Cell F-CCCH Level Cell F-FCH/Traffic Level Cell F-SCH Level (see How Do I Change Generator Information? and Configuring Forward Channel Power Levels and Walsh Codes )
Traffic Ec/Ior (dB) | Cell F-FCH/Traffic Level (see How Do I Change Generator Information? )
Eb/Nt (dB) | It is not directly settable. It is calculated according to other specified parameters. See TIA-EIA/98-E test standard for details on calculation equations for the specific code channels.

Example Settings

The following table is an example settings as specified in the standard. It also shows how to set on the test set to achieve the specified values. The Ioc, Traffic Ec/Ior, and Pilot Ec/Ior are all directly settable on the test set. For Ior/Ioc, which is the ratio of cell power to AWGN, you need to adjust Cell 1 Power (for Channel 1) and Cell 2 Power (for Channel 2) to achieve the correct levels relative to AWGN.

Test Parameters for Candidate Set Pilot Detection
Parameters in Standard | Units | Test 1 | Equivalent Settings on the Test Set
Ior/Ioc | dB | -3.1 | Set Cell Power to - 58.1 dBm/1.23 MHz (Ioc + Ior/Ioc)
Pilot Ec/Ior | dB | -7 | Set Cell F-Pilot Level to -7 dB
Traffic Ec/Ior | dB | -7 | Set Cell F-FCH/Traffic Level to -7 dB
Ioc | dBm/1.23 MHz | -55 | Set AWGN Power to -55 dBm/1.23 MHz.

Related Topics

Configuring Cell Power and AWGN Power Levels


Spectrum Monitor Description

Spectrum Monitor Description

Last updated: June 20, 2006

How is the spectrum monitor (SMON) used?

The Spectrum Monitor (SMON) can be used to locate, identify and measure transmitted signals from a device under test. The Spectrum Monitor can be used while a call is in progress.

The Spectrum Monitor is intended to be used for indication only. The Spectrum Monitor does not have the same level accuracy specifications as other measurements provided by the test set, and should therefore not be used when parametric accuracy is required (for example, calibration of a mobile). It is recommended that you use the other wireless format-specific measurements when you require accurate parametric measurements.

From the test set's front panel, the Spectrum Monitor can be accessed by pressing the Instrument Selection key, then selecting Spectrum Monitor . If you require more details on manual operation of the Spectrum Monitor, see How Do I Use the Spectrum Monitor? .

The Spectrum Monitor has the following two modes of operation:

  • Swept mode, in which the X axis represents frequency , and the Y axis represents absolute amplitude.
  • Zero span mode, in which the X axis represents time and the Y axis represents absolute amplitude.

You can use the markers on the Spectrum Monitor's graphical display to set the expected frequency and power levels that are used by the test or lab application for parametric measurements.

The center frequency used by the Spectrum Monitor is initially set at the expected frequency maintained by the test set's base station emulator. The expected frequency range is 292.5 MHz to 2700 MHz.

The range of frequencies which the spectrum monitor is calibrated to measure is determined by the range of traffic band frequencies supported by the specific test or lab application that is currently running. For example, if you are using the GSM Test Application, any of the frequencies used by the GSM traffic bands are available for you to monitor accurately. You can view signals which fall outside of any of the frequencies used by GSM, but the Spectrum Monitor will not be calibrated.

Detection Method

Frequency binning is used when the Spectrum Monitor divides the frequency span by the number of display points such that each bin contains a segment of the frequency span. Within each frequency bin, a single value representing each frequency bin is displayed on the test set's screen. The algorithm used to find the value that represents each frequency bin is determined by the detection method. There are three detection methods available in the test set's Spectrum Monitor:

  • Peak Detection

    The largest spectral component in the frequency bin is used to represent each bin.

  • Sample Detection

    The last spectral component in the frequency bin is used to represent each bin.

  • RMS Detection

    The sum of the power across the frequency bin is used to represent each bin.

The command to change the detection method is SETup:SMONitor:DETector[:TYPE] .

Resolution Bandwidth and Frequency Span

The resolution bandwidth can be used to resolve two or more closely spaced signals as long as the resolution bandwidth is less than the difference between the spectral components. A resolution bandwidth greater than or equal to the signal bandwidth can be used to measure the total power of a signal.

Refer to Frequency Span, Resolution Bandwidth and Dynamic Range below. When the Resolution Bandwidth Coupling State is OFF, the Frequency Span and the Resolution Bandwidth can be set to any value in their respective columns, and Resolution Bandwidth setting determines the Displayed Dynamic Range. When the Resolution Bandwidth Coupling State is On, the Resolution Bandwidth and Displayed Dynamic Range settings are coupled with the Frequency Span setting. For example, if the Frequency Span is 100 MHz, the test set automatically sets the Resolution Bandwidth to 5 MHz and the Displayed Dynamic Range to 55 dB.

Frequency Span, Resolution Bandwidth and Dynamic Range
Frequency Span | Resolution Bandwidth | Displayed Dynamic Range
100 MHz | 5 MHz | 50 dB
80 MHz | 1 MHz | 55 dB
40 MHz | 300 kHz | 60 dB
20 MHz | 100 kHz | 65 dB
12 MHz | 100 kHz | 65 dB
10 MHz | 100 kHz | 65 dB
5 MHz | 30 kHz | 70 dB
4 MHz | 30 kHz | 70 dB
2.5 MHz | 10 kHz | 75 dB
1.25 MHz | 3 kHz | 80 dB
500 kHz | 1 kHz | 80 dB
125 kHz | 300 Hz | 80 dB
0 Hz (zero span mode) | 100 kHz | 65 dB
 | 300 kHz | 60 dB
 | 1 MHz | 55 dB

The command to set the Resolution Bandwidth Coupling State is SETup:SMONitor:BANDwidth|BWIDth:AUTO .

The command to set the Resolution Bandwidth is SETup:SMONitor:BANDwidth|BWIDth:MANual , and the command to set the Frequency Span is SETup:SMONitor:FREQuency:SPAN .

Single or Multi-Measurements

The Spectrum Monitor can return either single or averaged results.

  • If you set the averaging state OFF then the trace represents a single measurement sweep.

  • If you set the averaging state ON, and the averaging count number to a value greater than one, then the trace represents the rolling average of the specified number of sweeps.

Input Signal Requirements

The Spectrum Monitor will complete and meet its accuracy specifications under the following input signal conditions.

  • The signal is within 40 dB of the reference level.
  • The measurement frequency is within the traffic band frequencies supported by the specific lab or test application that is currently running, and the expected frequency is tuned to the carrier.

Trigger Source

Triggering choices available for the Spectrum Monitor are Protocol, Immediate, RF Rise, and External.

For more information on measurement triggering, refer to Triggering of Measurements .

Calibrating the Spectrum Monitor

See Calibrating the Test Set .

Related Topics

How Do I Use the Spectrum Monitor?


Signaling Tone Measurement Description

Signaling Tone Measurement Description

Last updated: June 20, 2006

  • How is a Signaling Tone measurement made?
  • Signaling Tone Measurement Parameters
  • Signaling Tone Measurement Results
  • Input Signaling Requirements
  • Key TIA/EIA-690 Tests Performed using the Signal Tone Measurement

How is a Signaling Tone measurement made?

Signaling Tone is a 10 kHz tone that is generated by a mobile station and transmitted on the reverse analog voice channel to the test set. The signal tone is used to confirm orders, signal flash requests and signal release requests.

When the signaling tone measurement is initiated, the test set detects and measures the signaling tone. If the signaling tone is detected, the frequency of the signaling tone, the positive peak frequency deviation and the negative frequency deviation of carrier are measured and the frequency error that is the difference between the measured frequency and 10 kHz is calculated. If the signaling tone is not detected, the measurement is attempted anyway and the results are reported.

Operating Consideration

This measurement is available in Active Cell operating mode, AVC Test operating mode and CW operating mode.

When in Active Cell, test set is set to send Maintenance Order Message or Alert message to the mobile station to turn on the signaling tone.

Signaling Tone Measurement Parameters

The signaling tone measurement setup menu provides control over the following parameters

  • Multi-Measurement Count (See Statistical Measurement Results ) - Select On to enable averaging of multiple signaling tone measurement results.
  • Trigger Arm (See Trigger Arm (Single or Continuous) Description )
  • Measurement Timeout (see Timeouts )

Signaling Tone Measurement Results

In single measurement, the measurement results are

  • Integrity Indicator (See Integrity Indicator )
  • Positive Peak Carrier Frequency Deviation (See FETCh:STONe:DEViation:PPEak:ALL? ) - If Multi-Measurement Count is On , the average, maximum, minimum and standard deviation positive peak carrier frequency deviations are available. If Multi-Measurement Count is Off , maximum, minimum and standard deviation positive peak carrier frequency deviations are the same as average positive peak carrier frequency deviation.
  • Negative Peak Carrier Frequency Deviation (See FETCh:STONe:DEViation:NPEak:ALL? ) - If Multi-Measurement Count is On , the average, maximum, minimum and standard deviation negative peak carrier frequency deviations are available. If Multi-Measurement Count is Off , maximum, minimum and standard deviation negative peak carrier frequency deviations are the same as average negative peak carrier frequency deviation.
  • Frequency (See FETCh:STONe:FREQuency:ALL? ) - If Multi-Measurement Count is On , the average, maximum, minimum and standard deviation frequencies are available. If Multi-Measurement Count is Off , maximum, minimum and standard deviation frequencies are the same as average frequency.
  • Frequency Error (See FETCh:STONe:FERRor:ALL? ) - If Multi-Measurement Count is On , the average, maximum, minimum and standard deviation frequency errors are available. If Multi-Measurement Count is Off , maximum, minimum and standard deviation frequency errors are the same as average frequency errors.

A typical single measurement result is shown below

A typical multi-measurement result is shown below

Input Signaling Requirements

The signaling tone measurement meets specifications when the following input signal requirements are met:

  • The input signal must be within +/- 50 Hz of the test set' s expected frequency, 10 kHz.
  • The input signal at the RF IN/OUT connection must have analog TX power of at least -15 dBm.
  • The ratio of the input signal's deviation to residual FM must be greater than 30 dB.

Key TIA/EIA-690 Tests Performed using the Signal Tone Measurement

  • See Testing 3.3.5 Signaling Tone

Related Topics

Measuring Signaling Tone

Programming a Signaling Tone Measurement

Signaling Tone Troubleshooting

Statistical Measurement Results

Triggering of Measurements

Test Adherence to Standards


Swept Audio Measurements Description

Swept Audio Measurements Description

Last updated: October 28, 2004

Description

How are swept audio measurements made?

Swept audio measurements synchronize the frequencies of the test set's audio generator and audio analyzer instruments to automatically make measurements at up to 60 frequency points. Audio level, SINAD, and distortion measurements can be performed at each measurement point in the sweep.

This measurement only generates and analyzes audio signals; no modulation of the RF generator, or demodulation by the receiver, is performed. A representation of this operation is shown below.

Swept Audio Measurements Block Diagram

To perform the swept audio measurements, you must route audio generator signal to the AUDIO OUT port (not the FM Demod signal). See Interactions with the Audio Analyzer and Audio Generator Instruments . The audio signal from the device under test is sent to the audio analyzer through the AUDIO IN ports.

The start and stop frequencies for the sweep define the frequency range. The user specifies the number of measurement points, which are evenly spaced through the specified frequency range.

Measurement settling time can be set to specify how long the audio signal is generated at each frequency before a measurement is made by the audio analyzer. This is used to account for settling time in the device being tested and any signal delay through the device. Increasing the settling time increases the sweep time.

If the 100 Hz BW bandpass filter is selected, the center frequency of the filter is synchronized to the audio generator and audio analyzer frequencies.

Typical applications include measuring the audio distortion of a mobile station across several frequencies and measuring the frequency response of an audio filter or amplifier.

This is not a measurement procedure specified in the EIA/TIA standards.

Operating Considerations

Front Panel Access

Swept Audio measurements are accessed manually by pressing the front-panel Instrument selection key.

Multi-measurement Use

When multi-measurements are used with the swept audio measurement, the AF analyzer makes the number of measurements specified at each point in the sweep. For example, if five measurement points are specified, and the multi-measurement count is set to 20, a total of 100 measurements are performed during the sweep.

Interactions with the Audio Analyzer and Audio Generator Instruments

To route Audio Generator signal to the front panel AUDIO OUT port, use the "SYSTem:AUDio:OUTPut:SOURce" command or press the System Config hardkey, then select Audio Out Port ( F1 ) on the System Config Screen (2 of 2).

The Swept Audio measurement and the Audio Analyzer instrument cannot be used at the same time to make audio measurements. If you enable either function while the other function is already enabled, the first function is turned off and a message is displayed that informs you of this situation.

Selecting the Swept Audio measurement will automatically adjust Audio Generator instrument settings. These settings will not be restored to their original values when the Swept Audio measurement is closed.

The amplitude of the Audio Generator instrument can be changed while the Swept Audio measurement is enabled. However, trying to change the Audio Generator instrument's frequency while using swept audio measurements is not allowed, and causes an error message to be displayed.

Specifying a Specific Measurement Frequency Point Within a Sweep

If you need to make sure that a measurement is performed at a specific frequency within the sweep, you can use the following algorithms to calculate the values to enter:

For example if you wanted to make a measurement at 1004 Hz (F) during a sweep of 15 points (P) that begins at 300 Hz (S) and ends after 3 kHz (Emin), the first algorithm tells you that 1004 Hz occurs at the fourth point in the sweep (n). Use the second algorithm to calculate the actual stop frequency (E) you would enter for that sweep (3585.333 Hz).

Related Topics

Programming a Swept Audio Measurement

Swept Audio Measurement Troubleshooting

Audio Analyzer Measurement Description

Audio Level Measurement Description

Distortion Measurement Description

SINAD Measurement Description

Test Adherence to Standards


TDSO Frame Error Rate Measurement Description

TDSO Frame Error Rate Measurement Description

Last updated: October 28, 2004

  • What is a TDSO (Test Data Service Option) FER (Frame Error Rate) measurement?
  • How is a TDSO FER Measurement Made?
  • Operating Considerations
  • Key TIA/EIA-98-E Tests Using TDSO FER

What is a TDSO (Test Data Service Option) FER (Frame Error Rate) measurement?

TDSO FER measurements are used to test the performance of a mobile station receiver while a supplemental (high speed data) channel is connected and TDSO (Service Option 32) is selected ( Service Option ).

This measurement provides a report from the mobile station indicating the status of traffic frames received during high speed data transfer on the F-SCH (forward supplemental channel). There are two choices available for TDSO FER testing:

  • SO 32 (+ F-SCH)
    When this service option is selected, the supplemental channel is transmitted in the forward direction only.
  • SO 32 (+ SCH)
    When this service option is selected, the supplemental channel is transmitted in both the forward and reverse channels.

Since the measurement values displayed are obtained from the mobile station, there are no multi-measurement results available, such as measurement averaging.

How is a TDSO FER Measurement Made?

The test set automatically attempts a TDSO FER measurement when the measurement is selected and a call is connected using Service Options SO32 (+F-SCH) or SO32 (+ SCH). See CALL:SOPTion .

See CALL:SOPTion . To establish a call with Service Option 32 you must select Radio Config (Fwd3, Rvs3) or Radio Config (Fwd4, Rvs3). A mobile station originated call can be made or you can press the Originate Call (F3) key. A TDSO FER display is shown below in TDSO FER Display with 512 frames selected.

TDSO FER Display

The time period required for TDSO FER measurements depends on the timing of the call connection.

All traffic channels and the F-SCH are subdivided into segments of 10.24 seconds each. TDSO FER testing begins when the first frame (called a sync frame) in the first full segment is received by the mobile station. For example, TDSO FER With Frame Count Set to 512 Frames shows two full F-SCH segments. In this example, the SO 32 call is connected half way through the first segment. Approximately 5.12 s later the mobile station receives the first sync frame from the test set and is able to compute the PRBS data pattern the test set is about to send.

The time period between the successful negotiation of an SO32 connection and the start of the FER Count Period is based on the current long code state, and will range from 0 seconds to 10.24 seconds.

The mobile station also resets its frame counters upon receiving the first sync frame.

TDSO FER With Frame Count Set to 512 Frames

During the second sync frame interval, the mobile station keeps a running count of:

  • Good Frames Received
  • Bad Frames Received
  • Blank Frames Received
  • Bad Frames Instead of Blank Frames Received
  • Total Bad Frames Received

Also during the second frame interval, the test set keeps a running count of:

  • Good Frames Transmitted
  • Blank Frames Transmitted

At the end of the second frame interval, the test set retrieves frame count data from the mobile station and calculates percent FER based on the following formula:

Operating Considerations

A call must be setup using SO32 (+F-SCH) or SO32 (+ SCH) and that call must be currently connected to make TDSO FER measurements.

The measurement setup menu allows for specifying the FER confidence requirement. The FER confidence requirement establishes a target FER rate. To meet standard minimum specifications, a specified FER percentage must be attained with a confidence level of 95%. The TDSO FER measurement returns the confidence level based on the actual average FER result obtained over the fixed frame count length. If the confidence level is less than 95% for the specified FER confidence requirement, the test has not passed minimum standards.

The supplemental channel information menu provides channel setup parameters including the supplemental channel data rate, encoder type, and power level. Standards specify data rates and Eb/Nt. Eb/Nt can be set by adjusting F-SCH and AWGN level.

If trigger arm is set to Single, the first TDSO FER measurement will be displayed and then the test set will wait until it is triggered by a GPIB command or the START SINGLE key before the next sync frame is staged.

If "No F-SCH" is displayed in the bottom right portion of the display, the supplemental channel is not connected. If "No Sync" is displayed, the sync channel has not been sent to the mobile station yet.

Interim results are displayed when the frame count is greater than 512 and the test set is able to retrieve mobile station counter values after intermediate sync frames.

Integrity indicators (see Integrity Indicator ) do not apply to this measurement.

Key TIA/EIA-98-E Tests Using TDSO FER

  • Testing 3.4.1 Demodulation of Forward Traffic Channel in AWGN

Related Topics

Measuring TDSO (Test Data Service Option) Frame Error Rate (FER)

Programming a TDSO Frame Error Rate Measurement

TDSO Frame Error Rate Troubleshooting

Test Adherence to Standards

Configuring the TDSO Supplemental Channel Information


Time Response of Open Loop Power Control (TROLPC) Measurement Description

Time Response of Open Loop Power Control (TROLPC) Measurement Description

Last updated: October 28, 2004

  • How is a TROLPC measurement made?
  • TROLPC Measurement Parameters
  • TROLPC Measurement Results
  • Input Signal Requirements
  • Key TIA/EIA-98-E Tests Using the TROLPC Measurement
  • Calibrating the TROLPC Measurement

How is a TROLPC measurement made?

The TROLPC measurement is a power versus time measurement that analyzes the output power of a mobile station for the 100 ms period following an abrupt (step) change (+/- 20 dB) in output power from the test set.

This measurement is made while the mobile station is in a loopback connection at full data rate transmission (see Operating Considerations ).

When you initiate the test set's TROLPC measurement, cell power either increases or decreases by 20 dB depending upon whether you initiate an up or down step change. When the cell power changes, the mobile station reacts by decreasing or increasing its power, according to the open loop equation. The test set automatically sends alternating up and down closed loop power control bits while the measurement is executing (that is, the the Rvs Power Ctrl (reverse power control) mode is temporarily set to Alternating (up/down) bits), so the mobile station's response is determined solely by the open loop equation, and not influenced by closed loop power control. (On the TROLPC graph, the alternating power control bits appear only as "ripple" on the measured trace.)

Two softkey selections are provided for triggering TROLPC measurements:

  • Start Meas Up (increases power from the test set)
  • Start Meas Down (decreases power from the test set).

When the F2 ( Start Meas Up ) or F3 ( Start Meas Down ) softkey is selected, the Cell Power ( F7 ) setting will automatically step up or down 20 dB. The START SINGLE hardkey will also begin a TROLPC measurement, defaulting to the last measurement choice of stepping up or down 20 dB.

As soon as the new cell power level is received by the mobile station, the test set begins measuring the mobile station output power and continues to measure power for the 100 ms period following the change in cell power . The test set measures power at 371 data points over the 100 ms following the step change in cell power. The test set will automatically range its measuring receiver to the expected value from the mobile station as the test is performed.

After the TROLPC measurement has completed, the test set returns closed loop power control to the mode it was set to before the measurement was initiated.

TROLPC test results include a pass/fail indication determined by the mobile station's conformance to test standard amplitude mask limits. If a TROLPC test fails, the display will show the first point that the trace crossed the amplitude mask. See TROLPC Measurement Results )

Operating Considerations

See Time Response of Open Loop Power Control (TROLPC) Troubleshooting .

TROLPC Measurement Parameters

  • F-FCH/Traffic Level - (see Configuring the Forward Fundamental/Traffic Channel (F-FCH/Traffic) ).
  • Timeout Time/State - (see Timeouts ).

TROLPC Measurement Results

  • Integrity Indicator - (see Integrity Indicator ).
  • The TROLPC Measurement Screen
  • Pass/Fail Limits (Amplitude Mask)

The TROLPC Measurement Screen

By standard definition the TROLPC test process consists of a series of measurements. Before these measurements are made, the Cell Power parameter is set to -60 dBm/1.23 MHz. Then, to test the mobile station over the operating range of interest, the following sequence of tests is performed:

  1. Start Meas Up (Cell Power transitions to -40 dBm/1.23 MHz)
  2. Start Meas Down (Cell Power transitions to -60 dBm/1.23 MHz)
  3. Start Meas Down (Cell Power transitions to -80 dBm/1.23 MHz)
  4. Start Meas Up (Cell Power transitions to -60 dBm/1.23 MHz)

Refer to Time Response of Open Loop Power Control for an example of the display after performing step 1 from the sequence above.

Time Response of Open Loop Power Control

Note the following:

  • The y-axis on the graphical display is fixed from -5 to 30 dB. There are no polarity indicators on the y-axis in accordance with the test standard specifications. All changes in mobile station output power are displayed as absolute values.
  • The x-axis on the graphical display is fixed from 0 ms to 100 ms.
  • The directions of Cell Power and mobile power level changes are displayed in text above the grid.
  • The amplitude mask is displayed as green lines on the display.
  • A marker is provided to display measurement levels across the 100 ms time interval.
  • An overall pass/fail indicator is displayed and is available via GPIB commands (see FETCh:TROPower ). If a TROLPC test fails, the display will show the first point that the trace crossed the amplitude mask
  • No statistical (multi-measurement) results are provided for this measurement.

Pass/Fail Limits (Amplitude Mask)

Pass/Fail limits are determined by comparing the mobile station response with an amplitude mask derived from the test standard TIA/EIA IS-98D, 4.4.2 Time Response of Open Loop Power Control. When analyzing the results of time response to open loop power control programmatically, a comparison between the trace (see FETCh:TROPower:TRACe? ) and the mask can be made using the following formula:

For computing the upper pass/fail limit line:

The upper pass/fail limit line is made up of three line segments. In the following formulas, p is mobile station power delta, in dB, and t is equal to time in milliseconds. Note: These formulas are derived from test standard TIA-EIA IS-98D and apply to a cell power step size of 20 dB only.

Upper limit line segment 1:

Upper limit line segment 2:

Upper limit line segment 3:

For computing the lower pass/fail limit line:

The lower pass/fail limit line is made up of one line segment and a curve. In the following formulas, let t1 equal:

Calculating the value of t1 :

Lower limit line segment 1:

Lower limit line segment 2:

Input Signal Requirements

The TROLP measurement meets or exceeds specifications when the following requirements are met:

  • The frequency of the signal being measured must be in the range of 412 MHz to 483 MHz, 800 MHz to 960 MHz, or 1.7 GHz to 2.0 GHz, and within 100 kHz of the expected frequency.
  • The signal level into the test set's RF IN/OUT connector must be in the range of -25 dBm to +37 dBm, and within 9 dBm of the expected input power (see RFANalyzer:AUTO:POWer[:SELected]? ) to meet specifications.

Key TIA/EIA-98-E Tests Using the TROLPC Measurement

  • Testing 4.4.2 Time Response of Open Loop Power Control

Calibrating the TROLPC Measurement

The TROLPC measurement is automatically calibrated during a channel power calibration. Follow the channel power calibration schedule and the TROLPC measurement will be properly calibrated. Refer to Calibrating the Test Set for a description of channel power calibration.

Related Topics

Measuring Time Response of Open Loop Power Control (TROLPC)


Wideband Data Deviation Measurement Description

Wideband Data Deviation Measurement Description

Last updated: June 20, 2006

  • How is a Wideband Data Deviation measurement made?
  • Wideband Data Deviation Measurement Parameters
  • Wideband Data Deviation Measurement Results
  • Input Signaling Requirements
  • Key TIA/EIA-690 Test Performed Using the Wideband Data Deviation measurement

How is a Wideband Data Deviation measurement made?

Wideband data is 10 kbps Manchester-encoded data that is used for cellular system signaling and control. The wideband data stream is used to modulate the 8 kHz transmitter carrier using direct binary frequency shift keying (FSK).

Wideband Data Deviation measurement measures the frequency deviation of an RF carrier that is modulated by a wideband data burst. When the wideband data measurement is initiated, the test set samples the input signal for the time period specified by the gate time. When the sample is complete, the measurement analyzes the sample' s frequency deviation and attempts to find the wideband data burst. If the wideband data burst is detected, the frequency deviation of the wideband data is measured and the positive and negative peaks are reported.

NOTE
The wideband data deviation measurement returns the peak deviation of the entire wideband data burst. A "settled" result that does not contain any peaks from the first 20 ms of the burst is also provided.

Operating Consideration

This measurement is available in Active Cell operating mode, AVC Test operating mode and CW operating mode.

When in Active Cell, the test set sends the Analog MS TX Level Order Message by changing the Analog MS TX Level setting to trigger the wideband data burst.

  • If no wideband data burst is detected, an integrity error is generated and other results are 9.91E+37.
  • If more than one wideband data burst is detected, only the first complete burst is analyzed.
  • If incomplete wideband data burst that occurs partly outside the gate time is detected, the burst is not analyzed at all.

Wideband Data Deviation Measurement Parameters

The Wideband Data Deviation measurement setup menu provides control over the following parameters.

  • Gate Time (See SETup:WDDeviation:GTIMe ) - Sets the length of time that the wideband data deviation measurement samples the signal under test.
  • Trigger Arm (See Trigger Arm (Single or Continuous) Description )
  • Measurement Timeout (see Timeouts )

Wideband Data Deviation Measurement Results

  • Maximum Positive Peak Carrier Frequency Deviation (See FETCh:WDDeviation:DEViation:MAXimum:PPEak? )
  • Maximum Negative Peak Carrier Frequency Deviation (See FETCh:WDDeviation:DEViation:MAXimum:NPEak? )
  • Settled Positive Peak Carrier Frequency Deviation (See FETCh:WDDeviation:DEViation:SETTled:PPEak? )
  • Settled Negative Peak Carrier Frequency Deviation (See FETCh:WDDeviation:DEViation:SETTled:NPEak? )
  • Integrity Indicator (See Integrity Indicator )

A typical measurement result is shown below

Input Signaling Requirements

  • The input signal is a RF carrier that is direct binary FSK modulated by a 10 kbps data burst. The input signal must be within +/- 2.5 kHz of the test set' s expected frequency, 8 kHz.
  • The ratio of the input signal' s deviation to residual FM must be greater than 30 dB. The test set can measure the frequency deviation of the carrier in the range from 25 Hz to 50 kHz.
  • To achieve accurate result, the burst must occur completely within the gate time.

Key TIA/EIA-690 Test Performed Using the Wideband Data Deviation measurement

  • See Testing 3.3.3 Wideband Data

Related Topics

Programming a Wideband Data Deviation Measurement


Waveform Quality/Code Domain Measurement Description

Waveform Quality/Code Domain Measurement Description

Last updated: October 28, 2004

  • How is a Waveform Quality/Code Domain Power measurement made?
  • The Code Domain Power Graphical Display
  • How Spread Factors Affect the Code Domain Display
  • Obtaining Code Domain Power Results Programmatically
  • Relationship Between Spread Factors and Walsh Code Space
  • Input Signal Requirements
  • Key TIA/EIA-98-E Tests Using the Waveform Quality + Code Domain Measurement
  • Calibrating the Waveform Quality + Code Domain Measurement

NOTE
Channel Power Calibration should be performed if the test set is being used for the first time or the operating environment has changed significantly since the last calibration was performed. See CALibration Subsystem for details.

NOTE
If the Waveform Quality/Code Domain measurement is running at the time the power control transient transmission starts (see Starting the Reverse CLPC Transient ) the measurement will be closed and its operation aborted. Moreover, the Waveform Quality/Code Domain measurements will not be able to start (become initiated) while the transient transmission is in progress.

How is a Waveform Quality/Code Domain Power measurement made?

Each waveform quality measurement returns a number of measurements which includes:

  • Rho, the percentage of signal energy that correlates with a perfect IS-2000 signal after time offset and frequency error have been removed.
  • Code domain power (including the power and noise levels of each code channel transmitted by the mobile station).
  • Walsh code of each active code channel.
  • Spread factor of each active code channel.
  • Code domain power and noise (the sum total of power and noise of each code channel transmitted by the mobile station).

Any time a call is connected, waveform quality measurements can be made. Any combination of service option, radio configuration, or data rate can be measured.

Waveform quality measurements are made by sampling the down-converted input signal, then applying DSP (Digital Signal Processing) techniques to determine the original data input to the mobile station transmitter's Walsh spreading function for each channel. The DSP then generates a representation of what the "ideal" signal would be given the coding and data in use at the time of transmission. The ideal waveform is then compared with the waveform being measured to determine the waveform quality.

Waveform Quality/Code Domain Power Measurement Results lists the Waveform Quality/Code Domain Power measurement results:

Waveform Quality/Code Domain Power Measurement Results
Waveform Quality | Code Domain Power
Rho | Code Domain Power (I-Channel)
Frequency Error | Code Domain Power (Q-Channel)
Timing Error | Code Domain Power + Noise (I-Channel)
Carrier Feedthrough | Code Domain Power + Noise (Q-Channel)
Phase Error |
Magnitude Error |
Error Vector Magnitude (EVM) |

Multi-measurements (with statistical measurement results) are available for the Waveform Quality: Numeric Rho measurement. These include:

  • Minimum <Waveform Quality result>
  • Maximum <Waveform Quality result>
  • Average <Waveform Quality result>

See Statistical Measurement Results .

The Code Domain Power Graphical Display

IMPORTANT
When making Code Domain Power measurements on the reverse supplemental channel, the data source PRBS (pseudo-random bit sequence) must be selected. See How Do I Change TDSO Supplemental Channel Information? .

The Code Domain Power measurement displays the power and noise levels of reverse code channels. A marker can be positioned at any of the 16 Walsh code numbers. For example, Reverse Pilot Channel on I Channel shows the marker at marker position 0, which corresponds with Walsh code 0. The red bar represents the power level of the reverse pilot channel, which is always found on Walsh code 0 of the I channel graph.

Reverse Pilot Channel on I Channel

The Marker position field setting applies to both the I and the Q graphs. For example, the reverse fundamental channel is always located at Walsh code 4 of the Q channel graph. This channel corresponds with marker position 2, as shown in Reverse Fundamental Channel on Q Channel .

Reverse Fundamental Channel on Q Channel

The power levels of reverse supplemental channels (R-SCH1 and R-SCH2) sometimes occupy more than one marker position. The number of marker positions the supplemental channels occupy is determined by data rate. Because of the order of Walsh codes along the horizontal axis, code channels that display higher data rate Walsh code channels combine together to form one contiguous (wide) bar. For example, Reverse Supplemental Channel on Q Channel shows a supplemental channel occupying marker positions 4, 5, 6 and 7. This supplemental channel was transmitting data at 76.8 kbps.

Reverse Supplemental Channel on Q Channel

How Spread Factors Affect the Code Domain Display

The cdma2000 system achieves high data rates by allowing supplemental channels to occupy variable amounts of Walsh code space depending on the channel's data rate. The lowest ratio of occupied to available code space is 1/16, and these channels are said to have a spread factor of 16.

Each marker position displays the power or noise of one spread factor 16 code channel. If the supplemental channel being measured has a spread factor of less than 16, more than one marker position will be occupied, as shown in Spread Factor of Supplemental Channel Data Rates

Spread Factor of Supplemental Channel Data Rates
Data Rate | Spread Factor | Number of Occupied Marker Positions | Length of Walsh Codes
19.2 kbps | 16 | 1 | 16 bits
38.4 kbps | 8 | 2 | 8 bits
76.8 kbps | 4 | 4 | 4 bits
153.6 kbps | 2 | 8 | 2 bits

Because each marker position displays only the power or noise of a spread factor 16 code channel, a method for calculating power in channels with spread factors of 8, 4, or 2 must be applied. See Computing supplemental channel power .

Computing supplemental channel power

Each marker position displays the power or noise of one spread factor 16 code channel. When measuring the code channel power of a supplemental channel occupying more than one marker position, the total power in the code channel must be calculated according to Supplemental Channel Power Calculation Add the value listed in the "Value to Add to R-SCH Power" column to the reported power value from the display.

Supplemental Channel Power Calculation
R-SCH Data Rate | R-SCH Spread Factor | Combined Number of Spread Factor 16 Marker Positions in the R-SCH | R-SCH Power at Each Marker Position | Value to Add to R-SCH Power
153.6 kbps | 2 | 8 | 1/8 of total power | +9.03 dB
76.8 kbps | 4 | 4 | 1/4 of total power` | +6.02 dB
38.4 kbps | 8 | 2 | 1/2 of total power | +3.01 dB
19.2 kbps | 16 | 1 | All of power | 0.00 dB

For example, Total Supplement Channel Power shows the marker positioned on a 76.8 kbps supplemental channel and the marker value for the Q channel is -7.14 dB. Adding +6.02 dB to this value results in a total power of -1.12. Notice that a table is provided below the I and Q graphs that computes and displays total power for the supplemental channel (R-SCH1).

Total Supplement Channel Power

Obtaining Code Domain Power Results Programmatically

Obtaining code channel information programmatically by code channel name

One way to obtain code channel measurement results is to use commands that refer to code channels by name. These commands are:

  • FETCh:WQUality:CDPower:PILot[:REVerse]?
  • FETCh:WQUality:CDPower:FCHannel[:REVerse]?
  • FETCh:WQUality:CDPower:CCHannel:DEDicated[:REVerse]?
  • FETCh:WQUality:CDPower:SCHannel1[:REVerse]?
  • FETCh:WQUality:CDPower:SCHannel2[:REVerse]?

Each of these code domain power queries returns the difference between the total code channel power and the reverse pilot channel level along with other values. Limits for this value are specified in the Code Channel to Reverse Pilot Channel Output Power Accuracy test in test standard TIA/EIA 98-E.

Obtaining code channel information programmatically by I/Q channel and bin number

One command provides a method for querying the pass/fail status of code domain power in the inactive code channels. This command is:

  • FETCh:WQUality:CDPower:IQINactive[:FAIL]?

Limits for this value are specified in the Code Domain Power test in test standard TIA/EIA 98-E. Pass/fail limits are set up using the SETup:WQUality:CDPower:IQINactive[:LIMit] command.

Code channel measurement results can be obtained using commands that refer to code channels collectively by I channel and Q channel designation. These commands are:

  • FETCh:WQUality:CDPower:ICHannel[:ALL]?
  • FETCh:WQUality:CDPower:QCHannel[:ALL]?

Each of these commands returns information for all code channels in either the I or Q channel, but the information is segmented into units referred as "bins" as shown in Bin Numbering System .

Bin Numbering System

Bins are dynamically allocated to code channels depending on which code channels are active and the code channel spread factors. For example, if no code channels have spread factors less than 16, 16 bins will be assigned values. Code channel information can be obtained bin-by bin using the following commands:

Bins that are not active, like bins 0, 1, and 3 and 5 through 12 in the example above only contain noise power (yellow bars). Since this example has a supplemental channel that occupies four Marker Positions, and only one bin is needed to carry this code channel's information, the commands listed above will only return 13 out of a possible 16 bins of information. In the comma-separated string returned by these commands, the final three segments will consist of +9.91 E+37 (NAN).

Code channel information can be obtained bin-by bin using the following commands:

  • FETCh:WQUality:CDPower:ICHannel:BIN? <bin num>
  • FETCh:WQUality:CDPower:QCHannel:BIN? <bin num>

Relationship Between Spread Factors and Walsh Code Space

In Walsh Code Spread Factors , the highlighted bit sequences show the code space that Walsh 2 (W2) with a spread factor of four occupies. Following the tree from the highlighted bit sequence on the left side the following Walsh codes are all occupied by Walsh code 2 (W2) with a spread factor of four:

  • Walsh code W2 with a spread factor 4
  • Walsh code W2 with a spread factor 8
  • Walsh code W6 with a spread factor 8
  • Walsh code W2 with a spread factor 16
  • Walsh code W10 with a spread factor 16
  • Walsh code W6 with a spread factor 16
  • Walsh code W14 with a spread factor 16

Walsh Code Spread Factors

Note in Spread Factor 4 Code Space , the R-SCH on Walsh code 2 occupies four graphical elements, which amounts to 1/4 of the available code space.

Spread Factor 4 Code Space

Bit reversal

Note the order of the spread factor 16 Walsh codes are shown in 16 Bit Walsh Code Order . This order is derived from applying bit reversal to the decimal numbers 0 to 15. Consider Marker Position 13, which corresponds with Walsh code 11.

16 Bit Walsh Code Order

Marker Position 13 evaluates to a binary coded decimal value of 1101. If you reverse that bit sequence, the resulting pattern is 1011. When 1011 is converted back to a decimal value, the result is Walsh code 11, as shown in Walsh Channel Bit Reversal . This numbering system allows supplemental channels with higher data rates to be displayed as one contiguous block.

Walsh Channel Bit Reversal

Input Signal Requirements

The Waveform Quality measurement meets or exceeds specifications when the following requirements are met:

  • The frequency of the signal being measured must be in the range of 412 MHz to 483 MHz, 800 MHz to 960 MHz, or 1.7 GHz to 2.0 GHz, and within 100 kHz of the expected frequency.
  • The signal level into the test set's RF IN/OUT connector must be in the range of -25 dBm to +37 dBm, and within 9 dBm of the expected input power (see RFANalyzer:AUTO:POWer[:SELected]? ) to meet specifications.

  • To correctly detect reverse supplemental code channel power, PRBS must be selected in the Data Source field (from the F-SCH Parameters menu). When PRBS is selected for the forward supplemental channel, it will also be applied to the reverse supplemental channel. See Configuring the TDSO Supplemental Channel Information .

    If PRBS data is not selected, the code domain power results will not display distinct code channels with the expected spreading factors.

Key TIA/EIA-98-E Tests Using the Waveform Quality + Code Domain Measurement

Testing 4.1 Frequency Accuracy

Testing 4.3.1 Time Reference

Testing 4.3.4 Waveform Quality and Frequency Accuracy

Testing 4.3.5 Code Domain Power

Testing 4.4.9 Code Channel to Reverse Pilot Output Power Accuracy

Calibrating the Waveform Quality + Code Domain Measurement

The Waveform Quality + Code Domain measurement is automatically calibrated during a channel power calibration. Follow the channel power calibration schedule and the Waveform Quality + Code Domain measurement will be properly calibrated. Refer to Calibrating the Test Set for a description of channel power calibration.

Related Topics

Measuring Waveform Quality/Code Domain Power

Programming a Waveform Quality/Code Domain Measurement

Waveform Quality Measurement Troubleshooting

Test Adherence to Standards

Configuring the TDSO Supplemental Channel Information


cdma2000_muiguide_ch_appendix

Appendix

This Appendix includes some general setup procedures that are required to perform the tests, and other helpful information.

The contents are:

  • Test Adherence to Standards
  • Terminologies on the Test Set Adherence to Standard
  • How Do I Set Up a Call?
  • How Do I Make Measurements on a Mobile Station?
  • How Do I Change Call Parameters?
  • How Do I Change Cell Information?
  • How Do I Change Generator Information?
  • How Do I Change AWGN Power Levels?
  • How Do I Use the Spectrum Monitor?
  • Calibrating the Test Set


Introduction

Introduction

Last updated: June 20, 2006

The intent of this guide is to help you quickly learn how to use the E1962B cdma2000 Test Application to manually make mobile station receiver and transmitter tests as specified in the TIA/EIA-98-E standard.

  • See Making TIA/EIA-98-E Tests .

The Appendix includes additional information to help you perform the TIA/EIA-98-E tests:

  • Test Adherence to Standards table that shows which tests are supported by the test set
  • Parameters Adherence to Standard table which provides the mapping of the parameters as specified in the standard to the settings on the test set's front panel
  • General procedures that are required to setup the measurements
  • Calibration procedures that must be performed periodically when testing mobile stations with the test set

The scope of this guide does not cover the numerous features and capabilities of the test set. For details, refer to the E1962B Online User's Guide which is available at:

  • http://www.agilent.com/find/e1962b, or
  • User Documentation CD-ROM shipped with your application.


cdma2000_muiguide_ch_make_meas

Making TIA/EIA-98-E Tests

This chapter demonstrates the step-by-step procedures for making the tests specified in the TIA/EIA-98-E standard. The procedures for each test are based on one set of settings as specified for the test. However, the general setup procedures are the same for other sets of settings. To learn more about which tests are supported by the test set, see Test Adherence to Standards .

  • Measuring Access Probe Power
    • Testing 4.4.1 Range of Open Loop Output Power
    • Testing 4.4.3 Access Probe Output Power
  • Measuring Channel Power
    • Testing 4.4.6 Minimum Controlled Output Power
  • Measuring Code Channel Time/Phase Error
    • Testing 4.3.2 Reverse Pilot Channel to Code Channel Time Tolerance
    • Testing 4.3.3 Reverse Pilot Channel to Code Channel Phase Tolerance
  • Measuring Digital Average Power
    • Testing 4.4.5 Maximum RF Output Power
  • Measuring Frame Error Rate (FER)
    • Testing 3.4.1 Demodulation of Forward Traffic Channel in AWGN
    • Testing 3.5.1 Receiver Sensitivity and Dynamic Range
  • Measuring Gated Power
    • Testing 4.4.7 Standby Output Power and Gated Output Power
  • Measuring Handoff Waveform Quality
  • Measuring Maximum/Minimum Power
    • Testing 4.4.5 Maximum RF Output Power and 4.4.6 Minimum Controlled Output Power
  • Measuring SINAD Sensitivity (for AMPS test per TIA/EIA-690 standard)
  • Measuring TDSO (Test Data Service Option) Frame Error Rate (FER)
    • Testing 3.4.1 Demodulation of Forward Traffic Channel in AWGN
  • Measuring Time Response of Open Loop Power Control (TROLPC)
    • Testing 4.4.2 Time Response of Open Loop Power Control
  • Measuring TX Spurious Emissions
    • Testing 4.5.1 Conducted Spurious Emissions
  • Measuring Waveform Quality/Code Domain Power
    • Testing 4.1 Frequency Accuracy
    • Testing 4.3.1 Time Reference
    • Testing 4.3.4 Waveform Quality and Frequency Accuracy
    • Testing 4.3.5 Code Domain Power
    • Testing 4.4.9 Code Channel to Reverse Pilot Output Power Accuracy
  • Example Usage of Reverse CLPC Transient Mode
    • Testing 4.4.4 Range of Closed Loop Power Control


Programming an Access Probe Power Measurement

Programming an Access Probe Power Measurement

Last updated: October 28, 2004

This section provides an example of how to make access probe power measurements via GPIB.

The following program example assumes that the mobile station's antenna output is connected to the RF IN/OUT connector, and the mobile station has found service.

The basic procedure to measure access probe power remotely is:

  1. Turn the access probe power measurement timeout timer on using the SETup:CAPPower:TIMeout:STATe command. If the timeout timer is not turned on, and an access probe is not received, the measurement will hang on the FETCh? command indefinitely. Use the "FETCh:CAPPower[:ALL]?" command to obtain the measurement results.
  2. Turn on the mobile station and perform a registration (wait for power-on or send CALL:REGister[:IMMediate] ).
  3. Turn off timer-based registrations (see CALL:REGister:TIMer:STATe ).
  4. Set the trigger arm state to single (see SETup:CAPPower:CONTinuous ).

NOTE
Continuous trigger arming can also be used to measure access probe power sequences, however single triggering allows program counters to synchronize with mobile station transmitted power steps. This is important if you want measurement triggering to stop when an access probe sequence has completed.

  1. Turn call limit on (see CALL:CONNected:LIMit[:STATe]<[:SELected]|:TA2000> ).
  2. Set up initial power, step size, number of steps, and the maximum number of access probes for requests and responses (see CALL:APARameter ).
  3. Perform a page or mobile station originated call.
  4. Initiate the access probe power measurement using the INITiate<:measurement mnemonic>[:ON] . The <measurement mnemonic> for access probe power measurements is CAPP.
  5. Use the FETCh:CAPPower[:ALL]? command to obtain the measurement results.
  6. Repeat steps 8 and 9 for each power step.

IMPORTANT
Return the trigger arm to single state before attempting a different measurement or attempting any call processing procedure.

Programming Example

10 !RE-SAVE "c:\roadhog\programs\acc_probe.txt"
20    !This program measures an access probe sequence
30    !See "Access Probe Output Power" in TIA/EIA-98-E for specifications and standards
40    CLEAR SCREEN
50    A=714
60    !***Specify call parameters***
70    Systype$="DIGITAL2000"
80    Band$="USCELLULAR"
90    Channel=384
100   Sid=1
110   Nid=1
120   Radio_config$="F3R3"
130   Service_opt$="SO2"
140   !
150   !***Specify test parameters***
160   Loss_frequency$="836 MHZ,881 MHZ"
170   Expected_loss$="-2,-2"
180   Acc_prb_steps=3
190   Acc_prb_size=4
200   Ior=-90
210   Pilot=-7
220   Paging_ch=-12
230   Sync=-16
240   Traffic=-15.5
250   !
260   ON TIMEOUT 7,20 CALL Timeout
270   OUTPUT A;"SETUP:CAPP:TIMEOUT:STIME 3 S"
280   OUTPUT A;"SYST:COMM:GPIB:DEB:STAT ON"
290   !
300   !***Set up path loss***
310   OUTPUT A;"SYSTEM:CORRECTION:SFREQUENCY ";Loss_frequency$
320   OUTPUT A;"SYSTEM:CORRECTION:SGAIN ";Expected_loss$
330   !
340   !***Set up access/paging parameters***
350   OUTPUT A;"CALL:OPER:MODE CALL"
360   OUTPUT A;"CALL:BAND ";Band$
370   OUTPUT A;"CALL:CHAN ";Channel
380   OUTPUT A;"CALL:POW -50"
390   OUTPUT A;"CALL:SID ";Sid
400   OUTPUT A;"CALL:NID ";Nid
410   OUTPUT A;"CALL:RCON ";Radio_config$
420   OUTPUT A;"CALL:SOPTION ";Service_opt$
430   OUTPUT A;"CALL:PROT PREV6"
440   OUTPUT A;"CALL:PAG ";Paging_ch
450   OUTPUT A;"CALL:PAG:DRAT FULL"
460   OUTPUT A;"CALL:PIL ";Pilot
470   OUTPUT A;"CALL:SYNC ";Sync
480   OUTPUT A;"CALL:FCH ";Traffic
490   !
500   PRINT "Turn on mobile station...press continue when it has found service and registered"
510   PAUSE
520   CLEAR SCREEN
530   OUTPUT A;"CALL:REGISTER:TIMER:STATE OFF"
540   WAIT 2
550   !
560   !***Set up measurement parameters***
570   OUTPUT A;"SETUP:CAPP:CONTINUOUS OFF"
580   OUTPUT A;"CALL:CONNECTED:LIMIT 1"
590   OUTPUT A;"CALL:APARAMETER:POWER:STEP ";Acc_prb_size
600   OUTPUT A;"CALL:APARAMETER:POWER:STEP:COUNT ";Acc_prb_steps
610   !
620   !***Page the mobile station***
630   DISP "Paging mobile station..."
640   OUTPUT A;"CALL:ORIG"
650   DISP "Measuring Access probe power"
660   !
670   !***Obtain measurement results***
680   FOR I=1 TO Acc_prb_steps
690     OUTPUT A;"INITIATE:CAPP"
750     OUTPUT A;"FETCH:CAPP?"
760     ENTER A;Acp_integ,Acp
770     PRINT "Access probe ";I;" integrity = ";Acp_integ
780     PRINT "Access probe ";I;" power = ";Acp
790   NEXT I
800   DISP "Access probe measurements completed"
810   DISP "Test complete"
811   !
820   !***Return to default call processing states***
830   OUTPUT A;"CALL:END"
840   OUTPUT A;"CALL:CONNECTED:LIMIT 0"
850   OUTPUT A;"CALL:REGISTER:TIMER:STATE ON"
860   END
861   !
870 Timeout: SUB Timeout
880     PRINT "Program timed out"
890     CLEAR 7
900     CLEAR 714
910   SUBEND

Returned Values

This query returns an integrity indicator followed by a channel power measurement result (if results are available).

Related Topics

Access Probe Power Measurement Description

Measuring Access Probe Power

Access Probe Power Troubleshooting

Control Program Example

CALL:APARameter

SETup:CAPPower

FETCh:CAPPower

INITiate

READ

ABORt


Programming an Audio Frequency Measurement

Programming an Audio Frequency Measurement

Last updated: October 28, 2004

This section provides an example of how to make an audio frequency measurement with the Audio Analyzer (AFANalyzer) via GPIB.

The following procedure assumes that an audio source is connected to the AUDIO IN connectors. See Audio Analyzer Measurement Description .

  1. Configure audio analyzer measurement parameters using the SETup subsystem. When more than one audio frequency signal may be present, use the 100 Hz bandpass filter to isolate the desired signal for measurement (see the Programming Example below).
  2. Start the audio analyzer measurement using the INITiate subsystem.
  3. Use the FETCh? subsystem to obtain audio analyzer measurement results.

Programming Example

10  OUTPUT 714;"SETup:AFANalyzer:CONTinuous OFF" !Set the audio analyzer
20                                           !measurements to single trigger mode.
30 ! OUTPUT 714;"SETup:AFANalyzer:PEAK:VOLTage 3V" !Set the Expected peak voltage
40                                                !for the audio input level in Vpeak.
50  OUTPUT 714;"SETup:AFANalyzer:FREQuency:STATe ON" !Enable audio frequency meausurement.
60  OUTPUT 714;"SETup:AFANalyzer:FILTer TBPass" !Select the 100 Hz bandpass filter.
70  OUTPUT 714;"SETup:AFANalyzer:FILTer:TBPass 6000 Hz" !Set the 100 Hz bandpass
80     !filter's center frequency to 6 kHz (example; to measure SAT frequency).
90  OUTPUT 714;"SETup:AFANalyzer:TIMeout 3S" !Set a timeout value of 3 seconds
100                                      !in case the measurement cannot be made.
110 OUTPUT 714;"INITiate:AFANalyzer" !Start the AF Analyzer measurement.
120 OUTPUT 714;"FETCh:AFANalyzer:FREQuency?" !Fetch the Audio Frequency  result.
130 ENTER 714;Audio_frequency !Enter the returned value into a variable.
140 END

Related Topics

Audio Frequency Measurement Description

AFANalyzer Troubleshooting

Audio Analyzer Measurement Description

INITiate

SETup:AFANalyzer

FETCh:AFANalyzer


Programming an Audio Level Measurement

Programming an Audio Level Measurement

Last updated: October 28, 2004

This section provides an example of how to make an audio level measurement with the Audio Analyzer (AFANalyzer) via GPIB.

The following procedure assumes that an audio source is connected to the AUDIO IN connectors. See Audio Analyzer Measurement Description .

  1. Configure audio analyzer measurement parameters using the SETup subsystem. Even though default settings exist for each parameter, it is a good idea to deliberately set each parameter to make sure the setting is correct for the specific audio analyzer measurement you are making.
  2. Start the audio analyzer measurement using the INITiate subsystem.
  3. Use the FETCh? subsystem to obtain audio analyzer measurement results.

Programming Example

10  OUTPUT 714;"SETup:AFANalyzer:CONTinuous OFF" !Set the audio analyzer
20                                           !measurements to single trigger mode.
30  OUTPUT 714;"SETup:AFANalyzer:PEAK:VOLTage 3V" !Set the Expected Amplitude level for
40                                                !audio input voltage in Vpeak.
50  OUTPUT 714;"SETup:AFANalyzer:SDIStortion:STATe OFF" !Turn off the SINAD and
60                                                  !distortion measurements since
70                                                  !they are not being used.
80  OUTPUT 714;"SETup:AFANalyzer:FILTer NONE" !Bypass all audio filters.
90  OUTPUT 714;"SETup:AFANalyzer:DEMPhasis:STATe OFF" !Turn off de-emphasis.
100 OUTPUT 714;"SETup:AFANalyzer:EXPandor:STATe OFF" !Turn off the expandor.
110 OUTPUT 714;"SETup:AFANalyzer:DETector RMS" !Specify the RMS detector for the
120                                            !audio measurement.
130 OUTPUT 714;"SETup:AFANalyzer:TIMeout 3S" !Set a timeout value of 3 seconds
140                                      !in case the measurement cannot be made.
150 OUTPUT 714;"INITiate:AFANalyzer" !Start the AF Analyzer measurement.
160 OUTPUT 714;"FETCh:AFANalyzer:VOLTage?" !Fetch the Audio Level result.
170 ENTER 714;Audio_level  !Enter the returned value into a variable.
180 END

Returned Values

The results returned by this program are:

  • Integrity returns the measurement integrity indicator (0 means a successful measurement with no errors). See Integrity Indicator .
  • Audio_level returns the analog audio level in volts rms.

Related Topics

Audio Analyzer Measurement Description

AFANalyzer Troubleshooting

INITiate

SETup:AFANalyzer

FETCh:AFANalyzer


Programming a Distortion Measurement

Programming a Distortion Measurement

Last updated: October 28, 2004

This section provides an example of how to make distortion measurements via GPIB. It is patterned after TIA/EIA IS-137, Audio Harmonic Distortion (section 2.2.2.5).

SINAD and Distortion measurements are affected by the same STATe and INITiate commands, so both measurements are enabled and triggered at the same time. However, measurement results are queried separately. See Audio Analyzer Measurement Description .

The following procedure assumes that the mobile's audio output is connected to the AUDIO IN connectors and the mobile is on an analog voice channel (AVC). The AVC is being modulated with a 1004 Hz tone at ۲ kHz peak deviation, and a 6000 Hz SAT at ۬ kHz peak deviation. It is also assumed that the Cell Power from the test set is set to -50 dBm (IS-137 standard).

  1. Configure audio analyzer measurement parameters using the SETup subsystem.
  2. Start the audio analyzer measurement using the INITiate subsystem.
  3. Use the FETCh? subsystem to obtain audio analyzer measurement results.

Programming Example

10  OUTPUT 714;"SETup:AFANalyzer:CONTinuous OFF" !Set the audio analyzer
20                                           !measurements to single trigger mode.
30  OUTPUT 714;"SETup:AFANalyzer:PEAK:VOLTage 3V" !Set the Expected Amplitude level for
40                                                !audio input voltage in Vpeak.
50  OUTPUT 714;"SETup:AFANalyzer:SDIStortion:STATe ON" !Turn on the SINAD and
60                                                  !distortion measurements.
70  OUTPUT 714;"SETup:AFANalyzer:SDIStortion:FREQuency 1004 HZ" !Specify the audio
80                                      !frequency to use for the measurements.
90  OUTPUT 714;"SETup:AFANalyzer:FILTer CMessage" !Select the c-message filter.
100 OUTPUT 714;"SETup:AFANalyzer:DEMPhasis:STATe OFF" !Turn off de-emphasis.
110 OUTPUT 714;"SETup:AFANalyzer:EXPandor:STATe OFF" !Turn off the expandor.
120 OUTPUT 714;"SETup:AFANalyzer:TIMeout 3S" !Set a timeout value of 3 seconds
130                                      !in case the measurement cannot be made.
140 OUTPUT 714;"INITiate:AFANalyzer" !Start the AF Analyzer measurement.
150 OUTPUT 714;"FETCh:AFANalyzer:INTegrity?" !Query the integrity indicator to
160                           !verify that a reliable measurement was made.
170 ENTER 714;Integrity  !Enter the returned value into a variable for comparison
180                      !with possible integrity indicator values (not shown here).
190 IF Integrity=0 THEN  !Only fetch measurement result if integrity indicator is 0.
200 OUTPUT 714;"FETCh:AFANalyzer:DISTortion?" ! Fetch the Distortion result.
210 ENTER 714;Distortion !Enter the returned value into a variable.
220 END IF
230 END

Returned Values

The results returned by this program are:

  • Integrity returns the measurement integrity indicator; 0 means a successful measurement with no errors. See Integrity Indicator .
  • Distortion returns the Distortion measurement value in percent (%).

Related Topics

Audio Analyzer Measurement Description

AFANalyzer Troubleshooting

Distortion Measurement Description

INITiate

SETup:AFANalyzer

FETCh:AFANalyzer


Programming an SINAD Measurement

Programming an SINAD Measurement

Last updated: October 28, 2004

This section provides an example of how to make SINAD measurement via GPIB. It is patterned after TIA/EIA IS-137, Analog RF Sensitivity (section 2.3.1.1).

SINAD and Distortion measurements are affected by the same STATe and INITiate commands, so both measurements are enabled and triggered at the same time. However, measurement results are queried separately. See Audio Analyzer Measurement Description .

The following procedure assumes that the mobile's audio output is connected to the AUDIO IN connectors and the mobile is on an analog voice channel (AVC) that is being modulated with a 1004 Hz tone at ۲ kHz peak deviation. It is also assumed that the Cell Power from the test set is set to a minimum usable level (typically about -116 dBm).

  1. Configure audio analyzer measurement parameters using the SETup subsystem.
  2. Start the audio analyzer measurement using the INITiate subsystem.
  3. Use the FETCh? subsystem to obtain audio analyzer measurement results.

Programming Example

10  OUTPUT 714;"SETup:AFANalyzer:CONTinuous OFF" !Set the audio analyzer
20                                           !measurements to single trigger mode.
30  OUTPUT 714;"SETup:AFANalyzer:PEAK:VOLTage 3V" !Set the Expected Amplitude level for
40                                                !audio input voltage in Vpeak.
50  OUTPUT 714;"SETup:AFANalyzer:SDIStortion:STATe ON" !Turn on the SINAD and
60                                                  !distortion measurements.
70  OUTPUT 714;"SETup:AFANalyzer:SDIStortion:FREQuency 1004 HZ" !Specify the audio
80                                      !frequency to use for the measurements.
90  OUTPUT 714;"SETup:AFANalyzer:FILTer CMESsage" !Select the c-message filter.
100 OUTPUT 714;"SETup:AFANalyzer:DEMPhasis:STATe OFF" !Turn off de-emphasis.
110 OUTPUT 714;"SETup:AFANalyzer:EXPandor:STATe OFF" !Turn off the expandor.
120 OUTPUT 714;"SETup:AFANalyzer:TIMeout 3S" !Set a timeout value of 3 seconds
130                                      !in case the measurement cannot be made.
140 OUTPUT 714;"INITiate:AFANalyzer" !Start the AF Analyzer measurement.
150 OUTPUT 714;"FETCh:AFANalyzer:INTegrity?" !Query the integrity indicator to
160                           !verify that a reliable measurement was made.
170 ENTER 714;Integrity  !Enter the returned value into a variable for comparison
180                      !with possible integrity indicator values (not shown here).
190 IF Integrity=0 THEN !Only fetch measurement result if integrity indicator is 0.
200 OUTPUT 714;"FETCh:AFANalyzer:SINAD?" !Fetch the SINAD result.
210 ENTER 714;Sinad  !Enter the returned value into a variable.
220 END IF
230 END

Returned Values

The results returned by this program are:

  • Integrity returns the integrity indicator (0 means a successful measurement with no errors). See Integrity Indicator .
  • SINAD returns the SINAD value in dB.

Related Topics

SINAD Measurement Description

Audio Analyzer Measurement Description

Measuring SINAD Sensitivity

AFANalyzer Troubleshooting

INITiate

SETup:AFANalyzer

FETCh:AFANalyzer


Programming an Analog Transmit Power Measurement

Programming an Analog Transmit Power Measurement

Last updated: October 28, 2004

This section provides an example of how to make Analog Transmit Power (ATXP) measurements via GPIB.

The following program example assumes that the mobile's antenna output is connected to the RF IN/OUT connector, and the mobile is on an analog voice channel (AVC). For information on configuring the test set to get the mobile on an active call, see Establishing an Active Link with the Mobile Station .

The basic procedure to test Analog Transmit Power is as follows:

  1. Enter the expected power level.
  2. Define the Analog Transmit Power Setup parameters as desired for triggering, measurement timeout, and multi-measurements.
  3. Use the INITiate:ATXPower command to trigger the measurement.
  4. Use the FETCh? command to obtain the measurement results.

Programming Example

10  !Set the expected power level.
20  OUTPUT 714;"SETup:ATXPower:CONTinuous Off" !Set the analog transmit power
30                                           !measurement to single trigger mode.
40  OUTPUT 714;"SETup:ATXPower:TIMeout 1S" !Set a timeout value of 1 second
50                                       !in case the measurement cannot be made.
60  OUTPUT 714;"SETup:ATXPower:COUNt:NUMBer 5" !Set multi-measurements to 5.
70  OUTPUT 714;"INITiate:ATXPower" !Start the measurement.
80  OUTPUT 714;"FETCh:ATXPower?" !Query the returned integrity indicator and the
90                               !Average analog transmit power measurement.
100 ENTER 714;Integrity,Atxpower  !Enter the returned values into variables.
110 IF Integrity=0 THEN  !See if the integrity value = 0 (valid measurement).
120 ELSE
130 PRINT "Measurement problem; check for signal level over/under range condition."
140 END IF
150 END

Returned Values

The measurements returned by this program are:

  • Integrity returns the measurement integrity indicator (see Integrity Indicator ); 0 means a successful measurement with no errors.
  • Atxpower returns the Average Analog Transmit Power measurement value in dBm.

Related Topics

Analog Transmit Power Measurement Description

Analog Transmit Power Troubleshooting

INITiate

SETup:ATXPower

Amplitude Offset

FETCh:ATXPower

Receiver Control


Programming a Code Channel Time/Phase Measurement

Programming a Code Channel Time/Phase Measurement

Last updated: October 28, 2004

This section provides an example of how to make a code channel time/phase measurement via GPIB.

The following program example assumes that the mobile station's antenna output is connected to the RF IN/OUT connector, and the mobile station has found service.

The basic procedure to measure waveform quality is:

  1. Make a call (radio configuration three or above).
  2. Configure the code channel time/phase measurement setup parameters using the SETup:CCTPhase subsystem.
  3. Start the code channel time/phase measurement using the INITiate subsystem.
  4. Use the FETCh:CCTPhase command to obtain pass/fail measurement results.

Programming Example

10    RE-SAVE "c:\roadhog\programs\code_chan.txt"
20    !This program measures handoff waveform quality
30    !Refer to "Reverse Pilot Channel to Code Channel Time Tolerance" and
40    !"Reverse Pilot Channel to Code Channel Time Tolerance" for standards and specifications
50    CLEAR SCREEN
60    A=714
70    !***Specify call parameters***
80    Systype$="DIGITAL2000" !Cell System Type must be DIGITAL2000
90    Band$="USCELLULAR" !Cell band
100   Channel=384 !RF Channel
110   Sid=1 !System Identification
120   Nid=1 !Network Identification
130   Radio_config$="F3R3" !for code channel time/phase error, radio configuration must be
F3R3, F4R3, or F5R4
140   !
150   !***Specify test parameters***
160   Loss_frequency$="851 MHZ,896 MHZ" !Reverse channel, forward channel frequencies for
amplitude offset (path loss)
170   Expected_loss$="-2,-2" !Path loss at reverse channel, forward channel frequencies
180   !
190   ON TIMEOUT 7,20 CALL Timeout ! Calls "Timeout" routine
200   OUTPUT A;"SETUP:CCTPhase:TIMEOUT:STIME 10 S" !Sets waveform quality measurement timeout
to 10 seconds
210   OUTPUT A;"SYST:COMM:GPIB:DEB:STAT ON"!Turns debug state on
220   !
230   !***Set up call parameters***
240   OUTPUT A;"CALL:OPER:MODE CALL" !Sets Operating Mode to Active Cell
250   OUTPUT A;"CALL:SYSTEM ";Systype$ !Sets System Type
260   OUTPUT A;"CALL:BAND ";Band$ !Sets Cell Band for selected System Type
270   OUTPUT A;"CALL:CHAN ";Channel !Sets RF Channel for selected System Type and Cell Band
280   OUTPUT A;"CALL:POW -50" !Sets and turns on Cell Power
290   OUTPUT A;"CALL:SID ";Sid! Sets System Identification
300   OUTPUT A;"CALL:NID ";Nid! Sets Network Identification
310   OUTPUT A;"CALL:RCON ";Radio_config$!Sets Radio configuration
320   OUTPUT A;"CALL:PROT PREV6" !Sets Protocol Revision for the selected System Type
330   !
340   PRINT "Turn on mobile station...press continue when it has found service and registered"
350   PAUSE
360   CLEAR SCREEN
370   OUTPUT A;"CALL:REGISTER:TIMER:STATE OFF" !Turns off timer-based registrations
380   WAIT 2 ! Waits for any timer-based registrations to clear out
390   !
400   !***Page the mobile station***
410   DISP "Paging mobile station..."
430   OUTPUT A;"CALL:ORIG" !Pages the mobile station
440   OUTPUT A;"CALL:CONNECTED:STATE?" !Queries for connected/idle state...hangs until state
change detector is disarmed
450   ENTER A;Call_connected
460   IF NOT Call_connected THEN
470     DISP "Call attempt failed"
480     STOP
490   ELSE
500     DISP "Call connected"
510   END IF
520   !
530   !***Set up measurement parameters***
540   OUTPUT A;"SETUP:CCTPhase:CONTINUOUS OFF" !Sets trigger arm state to single
550   OUTPUT A;"SETUP:CCTPhase:TERROR:LIMit 10ns" !Sets the time error pass/fail limit to 10
ns
560   OUTPUT A;"SETUP:CCTPhase:PERRor:LIMit 0.15rad" !Sets the phase error pass/fail limit to
0.15 radians
570   !
580   !***Obtain and display code channel time/phase pass/fail results***
590   WAIT 1
600   OUTPUT A;"INITIATE:CCTPhase" !Initiates a code channel time/phase error measurement
610   OUTPUT A;"FETCh:CCTPhase?" !Queries the test set for waveform quality measurement
results
620   ENTER A;Integrity,Time_err,Phase_err
630   PRINT "Integrity indicator = ";Integrity
640   IF Time_err THEN
650     PRINT "Time error test failed"
660   ELSE
670     PRINT "Time error test passed"
680   END IF
690   IF Phase_err THEN
700     PRINT "Phase error test failed"
710   ELSE
720     PRINT "Phase error test passed"
730   END IF
740   !
750   DISP "Test complete"
760   !
770   !***Return to idle call processing state***
780   OUTPUT A;"CALL:END"
790   END
800 Timeout: SUB Timeout     ! Global timeout handler (from Step 1)
810     PRINT "Program timed out"
820     CLEAR 7
830     CLEAR 714
840   SUBEND

Related Topics

Code Channel Time/Phase Error Measurement Description

Measuring Code Channel Time/Phase Error

Code Channel Time/Phase Error Measurement Troubleshooting

Control Program Example

SETup:CCTPhase

FETCh:CCTPhase

INITiate

READ

ABORt


Programming a Fast Device Tune Measurement

Programming a Fast Device Tune Measurement

Last updated: July 4, 2006

This section is only applicable to the lab application and to a test application with the required feature license.

This section provides an example of how to make a Fast Device Tune (FDT) measurement via GPIB.

The following program example assumes that the mobile station (MS) is connected to the test set's RF IN/OUT connector.

The basic procedure to make the FDT measurement is as follows:

  1. Set the test set's initial conditions required for FDT measurement (refer to Set_init_cond subroutine):
    set the operating mode to IS-2000 Test mode, measurement frequency to manual mode, receiver power to manual mode, and RF generator frequency control to manual mode.
  2. Set the MS Rx Frequency/Power series (10 power step levels at 4 frequency points) on the test set to match your MS's configuration (refer to Set_msrx_series subroutine). See SETup:CFDTune for details on the commands.
  3. Set the MS Tx Frequency/Power series (10 power step levels at 4 frequency points) on the test set to match your MS's configuration (refer to Set_mstx_series subroutine). See SETup:CFDTune for details on the commands.
  4. Verify that your MS is placed into the test mode and has properly configured for calibration.
  5. Order the MS to transmit continuously at >20 dB below the power level of the first step in the MS TX Power Sequence.
    Note: If your MS TX Power Sequence starts at a power level that is less than 20 dB above the minimum transmit power of your MS, then you must include a trigger pulse as the first step in the MS TX Power Sequence. The power level of this trigger pulse will be measured by the test set as one of the steps in the sequence.
  6. Initiate (arm) the FDT measurement using the INITiate<:measurement mnemonic>[:ON] (this prepares the test set's hardware to execute the frequency/power series you've specified and arms the measurement's RF rise trigger).
  7. Send the INITiate:CFDTung:ARMed? query and wait for it to return a value of 1 , indicating that the measurement is armed and ready to be triggered.
  8. Order your MS to begin transmission of its MS TX Frequency/Power Series (the MS should then increase its output power by more than 20 dB to reach the first step in the series, which triggers the measurement with an RF rise).
  9. Once triggered, the FDT measurement performs a series of channel power measurements at each step of the MS TX Frequency/Power Series. When finished, use the FETCh:CFDTune commands to obtain power results for all of the measured steps.

Programming Example

10 ! ====================================================================
20 ! This program is intended to control the cdma2000 Fast Devie Tune
30 ! measurement for use with the Qualcomm 6500 MS.
40 ! ====================================================================
50 !
60 ! *** Initialize Program Variables ***
70 !
80 OPTION BASE 0
90 Testset=714
100 CLEAR SCREEN
110 CLEAR 7
120 CLEAR Testset
130 PRINT "*** Fast Device Tune (CFDT) Measurement Program for 1xEV-DO***"
140 PRINT
150 !
160 !***Set up GPIB timeout***
170 ON TIMEOUT 7,32 CALL Timeout
180 ! Call "Timeout" routine after 32 seconds of GP-IB hang-up
190 !
200 ! *** Variable declarations for the FDT measurements ***
210 DIM Mstx_pow$[8000]
220 !
230 ALLOCATE REAL Mstx_pow_res(0:399)
240 Sz=16*(20+19)   !ASCII Arrays = 16*(20+19) elements
250 ALLOCATE Freq_rx$[Sz],Pow_rx$[Sz],Freq_tx$[Sz],Pow_tx$[Sz]
260 !
270 Op_mode$="D2KT"   !Operation mode.
280 Meas_timeout=15  !Measurement timeout.
290 !
300 Num_freq_steps=4  !Number of Rx and Tx Frequency Steps
310 Num_pow_steps=10   !Number of Rx and Tx Power Steps
320 !
330 Str_ind_freq_rx=0        !Start Index of Rx Frequencies to be hopped
340 Str_ind_pow_rx=0         !Start Index of Rx Power series
350 Freq_rx$="872E6, 873E6, 874E6, 875E6"
351 !Forward Channel Frequencies in Band Class 0 (US Cellular)
360 Pow_rx$="-15,-20,-25,-60,-35,-40,-45,-50,-55,-60"
370 !
380 Str_ind_freq_tx=0        !Start Index of Tx Frequency series
390 Str_ind_pow_tx=0         !Start Index of Tx Power series
400 Freq_tx$="827.2E6, 828E6, 829E6, 830E6"
401 !Reverse Channel Frequencies in Band Class 0 (US Cellular)
410 Pow_tx$="0,-5,-10,-15,-20,-25,-30,-35,-40,-45"
420 !
430 !Uncomment the pass loss varables and set the value as needed.
440 !Loss_frequency$=" 8.3652E+8,8.60E+8" !Set frequencies for path loss.
450 !Expected_loss$=" -1.5,-1.5" !Set path loss at frequencies specified
460 !
470 !************************************
480 !***Simple Test Executive
490 !************************************
500 !
510 GOSUB Preset_test_set
520 !End any current connection and preset test set
530 !GOSUB Set_path_loss
540 !If needed, uncomment this line and set the pass loss required for your test.
550 GOSUB Set_init_cond
560 !Set initial conditions required for the FDT test
570 GOSUB Set_msrx_series
580 !Set up the MS Rx Freq/Power Series
590 GOSUB Set_mstx_series
600 !Set up the MS Tx Freq/Power Series
610 GOSUB Check_ms_config
620 !Check MS settings matching what you've set on the test set
630 GOSUB Fdt_meas
640 !Make the Fast Device Tune measurement.
650 GOTO End_program
660   !
670 !
680 !**************************************************************************
690 ! BEGINNING OF SUBROUTINES
700 !**************************************************************************
710 !
720 !
730  Preset_test_set:     !
740     !*******************************************************************
750     ! Subroutine: Preset the test set (Step 1: Set Up the Test Set)
760     !*******************************************************************
770       !
780 OUTPUT Testset;"*RST"
790     ! Full preset test set
800 OUTPUT Testset;"*OPC?"
810 ENTER Testset;Opc$
820 RETURN
830      !
840  Set_path_loss: !
850  !*******************************************************************
860  ! Subroutine: Set path loss values
870  !*******************************************************************
880       !
890 OUTPUT Testset;"SYST:CORR:FREQ";Loss_frequency$
900     ! Set the frequencies for amplitude offset
910 OUTPUT Testset;"SYST:CORR";Expected_loss$
920     ! Set the amplitude offsets for above frequencies
930 RETURN
940       !
950  Set_init_cond: !
960  !*******************************************************************
970  ! Subroutine: Set initial conditions required for the FDT Test
980  !*******************************************************************
990        !
1000     !GOSUB Set_path_loss !Set pass loss as required for your test
1010     !If needed, uncomment above line
1020 OUTPUT Testset;"CALL:OPER:MODE ";Op_mode$
1030     !Set Operating Mode to cdma2000 Test Mode
1040 OUTPUT Testset;"SET:CFDT:TIM "&VAL$(Meas_timeout)
1050     !Set measurement timeout.
1060 OUTPUT Testset;"CALL:CONT:DOWN:FREQ:AUTO OFF"
1070     !Set RF generator frequency control to manual mode.
1080 OUTPUT Testset;"RFAN:CONT:MEAS:FREQ:AUTO OFF"
1090     !Set receiver measurement frequency control to manual mode.
1100 OUTPUT Testset;"RFAN:CONT:POW:AUTO OFF"
1110     !Set receiver power control to manual mode.
1120 RETURN
1130 !
1140  Set_msrx_series: !
1150      !*******************************************************************
1160      ! Subroutine: Set up the MS Rx Freq/Power Series
1170      !*******************************************************************
1180     !
1190 PRINT "*** Set the number of Tx/Rx Frequency and Power Steps ***"
1200 OUTPUT Testset;"SET:CFDT:FREQ:STEP:COUN ";Num_freq_steps
1210 OUTPUT Testset;"SET:CFDT:POW:STEP:COUN ";Num_pow_steps
1220 PRINT "Number of Tx/Rx Frequency Steps =";Num_freq_steps
1230 PRINT "Number of Tx/Rx Power Steps =";Num_pow_steps
1240 PRINT
1250 PRINT "*** Set MS Rx Freq/Power Series ***"
1260 Stp_ind_freq_rx=Str_ind_freq_rx+Num_freq_steps
1270     !Compute Stop Index of Frequency steps
1280 Stp_ind_pow_rx=Str_ind_pow_rx+Num_pow_steps
1290     ! Compute Stop Index of Power steps
1300     !
1310     ! Check for Mx Rx Test Freq/Power Indicies Out of Range
1320 IF (Stp_ind_freq_rx<40 AND Stp_ind_pow_rx<40) THEN
1330      ! Set MS Rx Frequency and Power Start Indicies
1340 OUTPUT Testset;"SET:CFDT:MS:RX:FREQ:STEP:STAR:IND ";Str_ind_freq_rx
1350 OUTPUT Testset;"SET:CFDT:MS:RX:POW:STEP:STAR:IND ";Str_ind_pow_rx
1360 PRINT "MS Rx Test Start Freq Index = ";Str_ind_freq_rx
1370 PRINT "MS Rx Test Start Power Index = ";Str_ind_pow_rx
1380 ELSE
1390   PRINT
1400   PRINT "Error-The number of freq steps or power steps Out of Range (>40)"
1410   PRINT
1420   PRINT "Program Stopped"
1430   STOP
1440 END IF
1450       !
1460     !*** Set MS Rx Freq/Power Values ***
1470 OUTPUT Testset;"SET:CFDT:MS:RX:FREQ:STEP ";Freq_rx$
1480 PRINT "MS Rx Test Freq Seires = ";Freq_rx$
1490 OUTPUT Testset;"SET:CFDT:MS:RX:POW:STEP ";Pow_rx$
1500 PRINT "MS Rx Test Power Series = ";Pow_rx$
1510 PRINT
1520     !
1530 RETURN
1540     !
1550  Set_mstx_series:  !
1560   !*******************************************************************
1570   ! Subroutine: Set up the MS Tx Freq/Power Series
1580   !*******************************************************************
1590 PRINT "*** Set MS Tx Freq/Power Series ***"
1600 Stp_ind_freq_tx=Str_ind_freq_tx+Num_freq_steps
1610     !Compute Stop Index of Frequency steps
1620 Stp_ind_pow_tx=Str_ind_pow_tx+Num_pow_steps
1630     ! Compute Stop Index of Power steps
1640     !
1650     ! Check for Mx Tx Test Freq/Power Indicies Out of Range
1660 IF (Stp_ind_freq_tx<40 AND Stp_ind_pow_tx<40) THEN
1670         ! Set MS Tx Frequency and Power Start Indicies
1680 OUTPUT Testset;"SET:CFDT:MS:TX:FREQ:STEP:STAR:IND ";Str_ind_freq_tx
1690 OUTPUT Testset;"SET:CFDT:MS:TX:POW:STEP:STAR:IND ";Str_ind_pow_tx
1700 PRINT "MS Tx Test Start Freq Index =";Str_ind_freq_tx
1710 PRINT "MS Tx Test Start Power Index =";Str_ind_pow_tx
1720 ELSE
1730 PRINT
1740 PRINT "Error-The number of freq steps or power steps Out of Range (>40)"
1750 PRINT
1760 PRINT "Program Stopped"
1770 STOP
1780 END IF
1790       !
1800      !*** Set MS Tx Freq/Power Values ***
1810      !
1820 OUTPUT Testset;"SET:CFDT:MS:TX:FREQ:STEP ";Freq_tx$
1830 PRINT "MS Tx Test Freq Series = ";Freq_tx$
1840 OUTPUT Testset;"SET:CFDT:MS:TX:POW:STEP ";Pow_tx$
1850 PRINT "MS Tx Test Power Series = ";Pow_tx$
1860 PRINT
1870     !
1880 RETURN
1890 !
1900  Check_ms_config:     !
1910     !*******************************************************************
1920     ! Subroutine: Check MS Configuration Matching Test Set's
1930     !*******************************************************************
1940 PRINT "************** NOTE *****************************************"
1950 PRINT "Make sure that your MS is placed into a test mode, and is properly"
1960 PRINT "configured to measure the MS Rx Freq/Power series and transmit"
1970 PRINT "the MS Tx Freq/Power series you've set in the test set."
1980 PRINT
1990 PRINT "Order your MS to transmit continuously at >20 dB below the power level"
2000 PRINT "of the first step in MS Tx Power Series, for at least 1 ms"
2010 PRINT "*************************************************************"
2020 PRINT
2030 LINPUT "Press ENTER when finished",Keyboard$
2040 RETURN
2050       !
2060  Fdt_meas:!
2070   !*******************************************************************
2080   ! Subroutine: Perform FDT Measurement
2090  !*******************************************************************
2100 !
2110 OUTPUT Testset;"INIT:CFDT"
2120 !Arm the FDT measurement and start to build the MS Tx and Rx Freq/Power Series.
2130 OUTPUT Testset;"INIT:CFDT:ARMed?"
2140 !Queries that the MS Tx and Rx Freq/Power Series is successfully built
2150 !and the test set is ready for test.
2160 ENTER Testset;Meas_arm
2170 IF Meas_arm THEN
2180   PRINT "Command the MS to trigger the measurement (20 dB RF rise)..."
2181   PRINT
2190   LINPUT "Press ENTER when finished",Keyboard$
2200   LOOP
2210       OUTPUT Testset;"INITiate:DONE?"
2220       !Query to find out if FDT measurement is done.
2230       ENTER Testset;Meas_done$
2240       SELECT Meas_done$
2250         CASE "CFDT"
2260         ! test for the string "CFDT" indicating
2270         ! Fast Device Tune measurement is done.
2280         !***Obtain measurement results***
2290         OUTPUT Testset;"FETC:CFDT?"
2300         ENTER Testset;Integrity,Freq_step_cnt,Pow_step_cnt,Num_meas,Mstx_pow$
2310       END SELECT
2320       EXIT IF Meas_done$="NONE"
2321       ! Exit loop when the measurement completes
2330   END LOOP
2331   ! If Meas_done$="WAIT" then loop continues until "NONE"
2340 ELSE
2350   PRINT "The test set is not properly armed. Please check the MS Tx and"
2360   PRINT "Rx Freq/Power Series Setups."
2370   GOTO End_program
2380 END IF
2390      !
2400 PRINT "*** Print MS Tx Measurement Results ***"
2410 PRINT
2420 PRINT "Integrity = ";Integrity
2430 PRINT "Number of Freq Steps = ";Freq_step_cnt
2440 PRINT "Number of Power Steps = ";Pow_step_cnt
2450 PRINT "Total Number of Meas Results = ";Num_meas
2460 PRINT
2470     !
2480     !Convert ASCII Arra to Real Array
2490 FOR N=1 TO Num_meas
2500   Dynamic_mkr=((N-1)*17)
2510   !Set up a marker that will jump to each comma in the ascii string
2520   Mstx_pow_res(N)=VAL(Mstx_pow$[Dynamic_mkr+1,Dynamic_mkr+16])
2530   !Convert ascii to a numeric value
2540 NEXT N
2550       !
2560     ! PRINT "MS Tx Power Results:"
2570 PRINT "Freq Step #   Power Step #  Meas Power[dBm/1.23MHz]"
2580 PRINT
2590 FOR N_freq=0 TO Freq_step_cnt-1
2600   FOR N_pow=0 TO Pow_step_cnt-1
2610    PRINT N_freq+1," ",N_pow+1," ",Mstx_pow_res(N_freq*Pow_step_cnt+N_pow+1)
2620   NEXT N_pow
2630 PRINT
2640 NEXT N_freq
2650   !
2660 RETURN
2670  !
2680  End_program:!
2690     !*******************************************************************
2700     ! Subroutine: End of all testing clean up
2710     !*******************************************************************
2720       !
2730 OUTPUT Testset;"*RST"
2740 !Full preset test set
2750 OUTPUT Testset;"*OPC?"
2760 ENTER Testset;Opc$
2770 DEALLOCATE Mstx_pow_res(*),Freq_rx$,Pow_rx$,Freq_tx$,Pow_tx$
2780 PRINT
2790 PRINT "End of Program"
2800 END
2810 !
2820 !**************************************************************************
2830 ! SUB-PROGRAM SECTION
2840 !**************************************************************************
2850       !
2860  Timeout: SUB Timeout       ! Global timeout handler
2870    PRINT
2880    PRINT "Program timed out, check setup"
2890    CLEAR 7
2900    CLEAR Testset
2910    STOP
2920 SUBEND
2930 !

The measurement results include an integrity indicator, number of the frequency steps (Freq_step_cnt), number of the power steps at each frequency (Pow_step_cnt), total number of the measured power steps (Num_meas should equal to Freq_step_cnt * Pow_step_cnt), followed by Num_meas of power results transmitted by the MS.

A sample output from this program example is shown below:

Related Topics

Fast Device Tune Measurement Description


Programming a Channel Power Measurement

Programming a Channel Power Measurement

Last updated: October 28, 2004

This section provides an example of how to make a channel power measurement via GPIB.

The following program example assumes that the mobile station's antenna output is connected to the RF IN/OUT connector, and the mobile station has found service.

For information on configuring the test set for a call, see Step 4: Make a connection .

The basic procedure to measure channel power is as follows:

  1. Make a call.
  2. Configure the channel power setup parameters using the SETup:CPOWer subsystem.
  3. Use open and/or closed loop power control to set the mobile station power level.
  4. Start the channel power measurement using the INITiate subsystem.
  5. Use the FETCh:CPOWer command to obtain the measurement results.

Programming Example

10    RE-SAVE "c:\roadhog\programs\chan_pwr.txt"
20    !This program measures Channel Power
30    !Refer to "Minimum Controlled Output Power" in TIA/EIA-98-D for standards and
specifications
40    CLEAR SCREEN
50    A=714
60    !
70    !***Specify call parameters***
80    Systype$="DIGITAL2000" !Cell system type
90    Band$="USCELLULAR" !Cell band
100   Channel=384 !RF channel
110   Sid=1 !System Identification
120   Nid=1 !Network Identification
130   Radio_config$="F3R3" !Radio configuration
140   Service_opt$="SO2" !Service Option
150   !
160   !***Specify test parameters***
170   Loss_frequency$="836 MHZ,881 MHZ" !Reverse channel, forward channel frequencies for
amplitude offset (path loss)
180   Expected_loss$="-3,-3" !Path loss at reverse channel, forward channel frequencies
190   Ior=-25 !Cell Power
200   Pilot=-7 !Pilot channel power level
210   Traffic=-7.4 !Traffic channel power level
220   !
230   ON TIMEOUT 7,20 CALL Timeout !Calls "Timeout" routine
240   OUTPUT A;"SYST:COMM:GPIB:DEB:STAT ON" !Turns GPIB debug state on
250   OUTPUT A;"SETUP:CPOWER:TIMEOUT:STIME 10 S" !Sets channel power timeout to 10 seconds
260   !
270   !***Set up path loss***
280   OUTPUT A;"SYSTEM:CORRECTION:SFREQUENCY ";Loss_frequency$ !Enters frequencies in
Amplitude Offset table
290   OUTPUT A;"SYSTEM:CORRECTION:SGAIN ";Expected_loss$       !Enters loss values in
Amplitude Offset table
300   !
310   !***Set up call parameters***
320   OUTPUT A;"CALL:OPER:MODE CALL" !Sets Operating Mode to Active Cell
330   OUTPUT A;"CALL:SYSTEM ";Systype$ !Sets System Type
340   OUTPUT A;"CALL:BAND ";Band$ !Sets Cell band for selected System Type
350   OUTPUT A;"CALL:CHANNEL ";Channel !Sets Channel for selected System Type and Cell Band
360   OUTPUT A;"CALL:POW -50" ! Sets and turns on Cell Power for selected System Type
370   OUTPUT A;"CALL:SID ";Sid ! Sets System Identification
380   OUTPUT A;"CALL:NID ";Nid !Sets Network Identification
390   OUTPUT A;"CALL:RCON ";Radio_config$ !Sets Radio Configuration
400   OUTPUT A;"CALL:SOPTION ";Service_opt$ !Sets service option for the selected System Type
and Radio Configuration
410   OUTPUT A;"CALL:PROT PREV6" !Sets Protocol Revision for the selected System Type
420   OUTPUT A;"CALL:PAG:DRAT FULL" !Sets F-Paging data rate to full rate
430   OUTPUT A;"CALL:PIL -7"   !Sets pilot to default
440   OUTPUT A;"CALL:SYNC -16" !Sets sync to default
450   OUTPUT A;"CALL:PAG -12"  !Sets paging to default
460   OUTPUT A;"CALL:FCH -15.6"!Sets traffic to default
470   !
480   PRINT "Turn on mobile station...press continue when it has found service and registered"
490   PAUSE
500   CLEAR SCREEN
510   OUTPUT A;"CALL:REGISTER:TIMER:STATE OFF" !turns off timer-based registration
520   WAIT 2 !Waits 2 seconds for any timer-based registrations in progress to complete
530   !
540   !***Page the mobile station***
550   DISP "Paging mobile station..."
560   OUTPUT A;"CALL:ORIG" !Pages the mobile station
570   OUTPUT A;"CALL:CONNECTED:STATE?" !Queries for connected/idle state...hangs until state
change detector is disarmed
580   ENTER A;Call_connected
590   IF NOT Call_connected THEN
600     DISP "Call attempt failed"
610     STOP
620   ELSE
630     DISP "Call connected"
640   END IF
650   !
660   !***Set up measurement parameters***
670   OUTPUT A;"SETUP:CPOWER:CONTINUOUS OFF" !Sets trigger arm state to single
680   OUTPUT A;"CALL:CONNECTED:DROP:TIMER:STATE 0" !Turns off call drop timer
690   OUTPUT A;"CALL:POW ";Ior !Sets and turns on Cell Power for selected System Type
700   OUTPUT A;"CALL:CLPCONTROL:REVERSE:MODE DOWN" !Starts transmission of All Down (1) power
control bits
710   OUTPUT A;"CALL:PIL ";Pilot !Sets pilot channel level
720   OUTPUT A;"CALL:FCH ";Traffic !Sets traffic channel level
730   !
740   !***Obtain measurement results***
750   WAIT 1 !Settling time
760   OUTPUT A;"INITIATE:CPOWER" !Initiates a channel power measurement
820   OUTPUT A;"FETCh:CPOWER?"
830   ENTER A;Integrity,Channel_power
840   DISP "Test complete"
850   !
860   !***Display measurement results
870   PRINT "Integrity indicator = ";Integrity
880   PRINT "Minimum power = ";Channel_power;" dBm/1.23 MHz"
890   !
900   !***Return to default call processing states***
910   OUTPUT A;"CALL:CLPCONTROL:REVERSE:MODE ACTIVE" !Returns to active power control bits
920   OUTPUT A;"CALL:CONNECTED:DROP:TIMER:STATE 1" !Returns call drop timer to ON
930   OUTPUT A;"CALL:REGISTER:TIMER:STATE ON" !Returns timer-based registration to ON
940   OUTPUT A;"CALL:POW -50" ! Returns cell power to -50 dBm/1.23 MHz
950   !
960   DISP "Test complete"
970   OUTPUT A;"CALL:END" !Ends the call
980   END
990 Timeout: SUB Timeout     ! Global timeout handler
1000    PRINT "Program timed out"
1010    CLEAR 7
1020    CLEAR 714
1030  SUBEND

Returned Values

This query returns an integrity indicator followed by a channel power measurement result (if results are available).

Related Topics

Channel Power Measurement Description

Programming a Channel Power Measurement

Channel Power Measurement Troubleshooting

Digital Average Power Measurement Description

Control Program Example

CALibration Subsystem

READ? Subsystem

SETup:CPOWer

INITiate

FETCh:CPOWer


Programming a Tx Spurious Emissions Measurement

Programming a Tx Spurious Emissions Measurement

Last updated: October 28, 2004

This section provides an example of how to make transmitter spurious emissions measurements via GPIB.

The following program example assumes that the mobile station's antenna output is connected to the RF IN/OUT connector, and the mobile station has found service.

The basic procedure to measure spurious emissions remotely is:

  1. Turn on the mobile station and perform a registration (wait for power-on or send CALL:REGister[:IMMediate] ).
  2. Turn off timer-based registrations (see CALL:REGister:TIMer:STATe ).
  3. Set up nominal power, initial power, step size, number of steps, and the maximum number of access probes for responses ( see CALL:APARameter ).
  4. Set the trigger arm state to single (see SETup:CTXSpurious:CONTinuous ).
  5. Perform a page or mobile station originated call.
  1. Initiate the spurious emissions measurement using the INITiate<:measurement mnemonic>[:ON] . The <measurement mnemonic> for the cdma2000 transmitter spurious emissions measurement is CTXS.
  2. Use the FETCh:CTXSpurious[:ALL]? command to obtain the measurement results.

Programming Example

10    RE-SAVE "c:\roadhog\programs\tx_spurious.txt"
20    !This program measures conducted spurious emissions from the mobile station
30    !See "Conducted Spurious Emissions" in TIA/EIA-98-D for specifications and standards
40    CLEAR SCREEN
50    A=714
60    !***Specify call parameters***
70    Systype$="DIGITAL2000"
80    Band$="USCELLULAR"
90    Channel=384
100   Sid=1
110   Nid=1
120   Radio_config$="F3R3" !The test standard requires measurements at each radio config
130   Service_opt$="SO2"
140   !
150   !***Specify test parameters***
160   Loss_frequency$="836 MHZ,881 MHZ"
170   Expected_loss$="-2,-2"
180   Nom_pwr=7
190   Init_pwr=15
200   Acc_prb_steps=7
210   Num_step=7
220   Max_rsp_seq=15
230   Acc_prb_size=4
240   Ior=-90
250   Pilot=-7.4
260   Paging_ch=-12
270   Sync=-16
280   Traffic=-15.5
290   !
300   ON TIMEOUT 7,20 CALL Timeout
310   OUTPUT A;"SETUP:CTXSpurious:TIMEOUT:STIME 3 S"
320   OUTPUT A;"SYST:COMM:GPIB:DEB:STAT ON"
330   !
340   !***Set up path loss***
350   OUTPUT A;"SYSTEM:CORRECTION:SFREQUENCY ";Loss_frequency$
360   OUTPUT A;"SYSTEM:CORRECTION:SGAIN ";Expected_loss$
370   !
380   !***Set up access/paging parameters***
390   OUTPUT A;"CALL:OPER:MODE CALL"
400   OUTPUT A;"CALL:BAND ";Band$
410   OUTPUT A;"CALL:CHAN ";Channel
420   OUTPUT A;"CALL:POW -50"
430   OUTPUT A;"CALL:SID ";Sid
440   OUTPUT A;"CALL:NID ";Nid
450   OUTPUT A;"CALL:RCON ";Radio_config$
460   OUTPUT A;"CALL:SOPTION ";Service_opt$
470   OUTPUT A;"CALL:PROT PREV6"
480   OUTPUT A;"CALL:PAG ";Paging_ch
490   OUTPUT A;"CALL:PAG:DRAT FULL"
500   OUTPUT A;"CALL:PIL ";Pilot
510   OUTPUT A;"CALL:SYNC ";Sync
520   OUTPUT A;"CALL:FCH ";Traffic
530   !
540   PRINT "Turn on mobile station...press continue when it has found service and registered"
550   PAUSE
560   CLEAR SCREEN
570   OUTPUT A;"CALL:REGISTER:TIMER:STATE OFF"
580   WAIT 2
590   !
600   !***Set up measurement parameters***
610   OUTPUT A;"SETUP:CTXSpurious:CONTINUOUS OFF"
620   OUTPUT A;"CALL:APAR:POW:NOM ";Nom_pwr
630   OUTPUT A;"CALL:APAR:POW:INIT ";Init_pwr
640   OUTPUT A;"CALL:APARAMETER:POWER:STEP ";Acc_prb_size
650   OUTPUT A;"CALL:APAR:POW:STEP:COUNT ";Num_step
660   OUTPUT A;"CALL:APARAMETER:POWER:STEP:COUNT ";Acc_prb_steps
670   OUTPUT A;"CALL:APAR:SEQ:RESP:MAX ";Max_rsp_seq
680   !
690   !***Make a call***
700   DISP "Paging mobile station..."
710   OUTPUT A;"CALL:ORIG"
720   OUTPUT A;"CALL:CONNECTED:STATE?"
730   ENTER A;Call_connected
740   IF NOT Call_connected THEN
750     DISP "Call attempt failed"
760     STOP
770   ELSE
780     DISP "Call connected"
790   END IF
800   !
810   !***Send all up power control bits***
820   OUTPUT A;"CALL:CLPC:REVERSE:MODE UP"
821   !
830   DISP "Measuring Tx Spurious Emissions"
840   !
850   !***Obtain measurement results***
860   OUTPUT A;"INITIATE:CTXSpurious"
870   OUTPUT A;"FETCH:CTXSpurious?"
880   ENTER A;Integ,Passfail,Lower_adj,Upper_adj,Lower_alt,Upper_alt
890   PRINT "Integrity indicator = ";Integ
900   IF Passfail THEN
910     PRINT "Test failed"
920   ELSE
930     PRINT "Test passed"
940   END IF
960   PRINT "Lower adjacent channel power = ";Lower_adj
970   PRINT "Upper adjacent channel power = ";Upper_adj
980   PRINT "Lower alternate power = ";Lower_adj
990   PRINT "Upper alternate power = ";Upper_adj
1000  DISP "Test complete"
1010  !
1020  !***Return to default call processing states***
1030  OUTPUT A;"CALL:CLPC:REVERSE:MODE ACTIVE" !Returns to active power control bits
1040  OUTPUT A;"CALL:END"
1050  OUTPUT A;"CALL:REGISTER:TIMER:STATE ON"
1060  END
1070  !
1080 Timeout: SUB Timeout
1090    PRINT "Program timed out"
1100    CLEAR 7
1110    CLEAR 714
1120  SUBEND

Returned Values

This query returns an integrity indicator followed by a channel power measurement result (if results are available).

Related Topics

Tx Spurious Emissions Measurement Description

Measuring TX Spurious Emissions

Tx Spurious Emissions Measurement Troubleshooting

Control Program Example

SETup:CTXSpurious

FETCh:CTXSpurious

INITiate

READ

ABORt


Programming a Digital Average Power Measurement

Programming a Digital Average Power Measurement

Last updated: October 28, 2004

This section provides an example of how to make a digital average power measurement via GPIB.

The following program example assumes that the mobile station's antenna output is connected to the RF IN/OUT connector, and the mobile station has found service.

For information on configuring the test set for a call, see Step 4: Make a connection .

The basic procedure to measure digital average power is as follows:

  1. Make a call.
  2. Configure the digital average power setup parameters using the SETup:DAPower subsystem.
  3. Start the digital average power measurement using the INITiate subsystem.
  4. Use the FETCh:DAPower command to obtain the measurement results.

Programming Example

10    RE-SAVE "c:\roadhog\programs\avg_pwr.txt"
20    !This program measures average power
30    !Refer to "Maximum RF Output Power" in TIA/EIA-98-D for standards and specifications
40    CLEAR SCREEN
50    A=714
60    !
70    !***Specify call parameters***
80    Systype$="DIGITAL2000" !Cell System Type
90    Band$="USCellular" !Cell band
100   Channel=384 !RF channel
110   Sid=1 !System Identification
120   Nid=1 !Network Identification
130   Radio_config$="F3R3" !Radio Configuration
140   Service_opt$="SO2" !Service Option
150   !
160   !***Specify test parameters***
170   Loss_frequency$="836 MHZ,881 MHZ" !Reverse channel, forward channel frequencies for
amplitude offset (path loss)
180   Expected_loss$="-1,-1" !Path loss at reverse channel, forward channel frequencies
190   Ior=-104 !Cell Power
200   Pilot=-7 !Pilot channel power level
210   Traffic=-7.4 !Traffic channel power level
220   !
230   ON TIMEOUT 7,20 CALL Timeout ! Calls "Timeout" routine
240   OUTPUT A;"SETUP:DAPOWER:TIMEOUT:STIME 10 S" !***Sets average power measurement timeout to 10 seconds***
250   OUTPUT A;"SYST:COMM:GPIB:DEB:STAT ON"!***Turn debug state on***
260   !
270   !***Set up path loss***
280   OUTPUT A;"SYSTEM:CORRECTION:SFREQUENCY ";Loss_frequency$ !Enters frequencies in Amplitude Offset table
290   OUTPUT A;"SYSTEM:CORRECTION:SGAIN ";Expected_loss$ !Enters loss values in Amplitude
Offset table
300   !
310   !***Set up call parameters***
320   OUTPUT A;"CALL:OPER:MODE CALL" !***Sets Operating Mode to Active Cell***
330   OUTPUT A;"CALL:SYSTEM ";Systype$ !Sets System Type
340   OUTPUT A;"CALL:BAND ";Band$ !Sets Cell band for selected System Type
350   OUTPUT A;"CALL:CHAN ";Channel !Sets Channel for selected System Type and Cell Band
360   OUTPUT A;"CALL:POW -50" ! Sets and turns on Cell Power for selected System Type
370   OUTPUT A;"CALL:SID ";Sid ! Sets System Identification
380   OUTPUT A;"CALL:NID ";Nid ! Sets Network Identification
390   OUTPUT A;"CALL:RCON ";Radio_config$ !Sets Radio configuration
400   OUTPUT A;"CALL:SOPTION ";Service_opt$ !Sets service option for the selected System Type
and Radio Configuration
410   OUTPUT A;"CALL:PROT:DIG2000 PREV6" ! Sets Protocol Revision for the selected System Type
420   OUTPUT A;"CALL:PAG:DRAT FULL" !Sets F-Paging data rate to full rate
430   OUTPUT A;"CALL:PIL -7"   !Sets pilot to default
440   OUTPUT A;"CALL:SYNC -16" !Sets sync to default
450   OUTPUT A;"CALL:PAG -12"  !Sets paging to default
460   OUTPUT A;"CALL:FCH -15.6"!Sets traffic to default
470   !
480   PRINT "Turn on mobile station...press continue when it has found service and registered"
490   PAUSE
500   CLEAR SCREEN
510   OUTPUT A;"CALL:REGISTER:TIMER:STATE OFF" !Turns timer-based registration off
520   WAIT 2 !Waits 2 seconds for timer-based registrations in progress to clear out
530   !
540   !***Page the mobile station***
550   DISP "Paging mobile station..."
560   OUTPUT A;"CALL:ORIG" !Pages the mobile station
570   OUTPUT A;"CALL:CONNECTED:STATE?" !Queries for connected/idle state...hangs until state
change detector is disarmed
580   ENTER A;Call_connected
590   IF NOT Call_connected THEN
600     DISP "Call attempt failed"
610     STOP
620   ELSE
630     DISP "Call connected"
640   END IF
650   !
660   !***Set up measurement parameters***
670   OUTPUT A;"SETUP:DAPOWER:CONTINUOUS OFF" !Sets trigger arm state to single
680   OUTPUT A;"CALL:POW ";Ior !Sets Cell Power for the selected System Type
690   OUTPUT A;"CALL:CLPCONTROL:REVERSE:MODE UP" !Starts transmission of All Up (0) power
control bits
700   OUTPUT A;"CALL:PIL ";Pilot !Sets pilot channel level
710   OUTPUT A;"CALL:FCH ";Traffic !Sets traffic channel level
720   !
730   !***Obtain measurement results***
740   WAIT 1 !Settling time
750   OUTPUT A;"INITIATE:DAPOWER" !Initiates an Average Power measurement
810   OUTPUT A;"FETCh:DAPOWER?"
820   ENTER A;Integrity,Avg_power_dbm
830   Avg_power_dbw=Avg_power_dbm-30
840   !
850   !***Display measurements if the mobile station did not drop the call***
860   OUTPUT A;"CALL:STATUS?"
870   ENTER A;Call_status$
880   IF Call_status$="CONN" THEN
890     PRINT "Integrity indicator = ";Integrity
900     PRINT "Maximum power = ";Avg_power_dbm;"dBm";", ";Avg_power_dbw;"dBW"
910   ELSE
920     PRINT "Mobile station dropped call, invalid results"
930   END IF
940   !
950   !***Return to default call processing states***
960   OUTPUT A;"CALL:CLPCONTROL:REVERSE:MODE ACTIVE" ! Returns to active power control bits
970   OUTPUT A;"CALL:POW:DIG2000 -50" ! Returns cell power to -50 dBm/1.23 MHz
980   !
990   DISP "Test complete"
1000  OUTPUT A;"CALL:END"
1010  END
1020 Timeout: SUB Timeout
1030    PRINT "Program timed out"
1040    CLEAR 7
1050    CLEAR 714
1060  SUBEND

Returned Values

This program returns an integrity indicator followed by a digital average power measurement result (if results are available).

Related Topics

Digital Average Power Measurement Description

Measuring Digital Average Power

Digital Average Power Troubleshooting

Control Program Example

CALibration Subsystem

READ? Subsystem

SETup:DAPower

INITiate

FETCh:DAPower


Programming a TX Dynamic Power Measurement

Programming a TX Dynamic Power Measurement

Last updated: October 28, 2004

This section provides an example of how to make a TX dynamic power measurement via GPIB.

The following program example assumes that the mobile station's antenna output is connected to the RF IN/OUT connector.

Since the measurement is expected to be used only when Call Connection status is Idle, no Call Connection is needed.

The basic procedure to measure TX dynamic power is as follows:

  1. Place your MS in the test mode required for performing TX dynamic power.
  2. Set the TX dynamic power setup parameters to match your MS's test mode using the SETup:CTDPower commands.
  3. Arm the TX dynamic power measurement using the INITiate<:measurement mnemonic>[:ON] command.
  4. Via the MS test mode interface, command your MS to generate the RF Rise impulse to trigger the measurement.
  5. When the measurement is finished, use the FETCh:CTDPower or READ:CTDPower[:ALL]? commands to obtain the measurement results.

NOTE
The buffer size for the measurement results should be set above 1445 characters. If the results are printed in format display, you should assign larger buffer size. See example below.

Programming Example

10       CLEAR SCREEN
20       DIM Dypow_res$[3400]
30       DIM Dynamic_val(200)
40       !
50       !The size of buffer which contains the return value
60       !should be set above 1445. It is suggested to be 1450.
70       !The buffer size is suggested to be set above 3400 if
80       !the results are displayed with print format as shown below.
90       Testset=714
100       !
110       ON TIMEOUT 7,20 CALL Timeout
120       !Calls "Timeout" routine
130       OUTPUT Testset;"SYST:COMM:GPIB:DEB:STAT ON"
140       !Turns GPIB debug state on
150       !
160       PRINT "***Set up measurement parameters***"
170       !
180       OUTPUT Testset;"SETUP:CTDPOWER:TIMEOUT:STIME 20 S"
190       !Sets measurment timeout to 20 seconds
200       !
210       !***Set up measurement parameters***
220       OUTPUT Testset;"RFAN:CONT:POW:AUTO OFF"
230       !Sets the receiver power control to manual mode
240       OUTPUT Testset;"RFAN:MAN:POW:SEL 0 dBm"
250       !Sets the receiver power to the initial power (max power)
260       !at which the MS will transmit.
260       OUTPUT Testset;"RFAN:MAN:MEAS:MFR 851 MHZ"
270       !Sets the frequecy at which the MS will transmit
280       OUTPUT Testset;"SETUP:CTDP:STEP:LEV -1.0 dB"
290       !Set the dynamic power measurement step size to -1.0 dB
300       OUTPUT Testset;"SETUP:CTDP:STEP:COUN 29"
310       !Set the dynamic power measurement number of Steps
320       !to 30.
330       !
340       PRINT "***Arm the TX dynamic power measurement***"
350       OUTPUT Testset;"INITIATE:CTDPOWER:ON"
360       !Initiate TX dynamic power measurement
370       !
380       PRINT "***Command the MS to trigger the measurement***"
390       !
400       !***Obtain measurement results***
410       PRINT "***Obtain measurement results***"
420       OUTPUT Testset;"FETCH:CTDPOWER:COUNT:STEP?"
430       ENTER Testset;Numofstep
440       OUTPUT Testset;"FETCh:CTDPOWER?"
450       ENTER Testset;Integrity,Dypow_res$
460       !***Display measurement results
470       PRINT "Integrity indicator = ";Integrity
480       PRINT "The number of Step = ";Numofstep
490       FOR I=1 TO Numofstep
500         Dynamic_mkr=((I-1)*17)
510         !Set up a marker that will jump to each comma in the ascii string
520         Dynamic_val(I)=VAL(Dypow_res$[Dynamic_mkr+1;Dynamic_mkr+16])
530         !Convert ascii to a numeric value
540         PRINT "Dynamic ";I-1;" measurement is ";Dynamic_val(I);" dBm/1.23 MHz"
550       NEXT I
560      !
570       END
580  Timeout: SUB Timeout            ! Global timeout handler
590         PRINT "Program timed out"
600         CLEAR 7
610         CLEAR 714
620       SUBEND

The measurement results include an integrity indicator followed by power results for each measurement steps.

Related Topics

TX Dynamic Power Measurement Description

Manual Operation: Measuring TX Dynamic Power


Programming a DTMF Measurement

Programming a DTMF Measurement

Last updated: June 20, 2006

General Programing Procedure

  1. Make a call.
  2. Configure the DTMF setup parameters using SETup:DTMF subsystem.
  3. Start the DTMF measurement using INITiate subsystem.
  4. Press the keypads on the mobile station to generate DTMF signals.
  5. Use the FETCh:DTMF command to obtain the measurement results.

Programming Example

1        ! This program measures the DTMF
6        CLEAR SCREEN
7        DIM Res$[3400]
8        ! E5515C GPIB Address
9        Testset=714
11       Systype$="AMPS"
12       !System Identification
13       Sid=1
14       ! Calls "Timeout" routine
15       ON TIMEOUT 7,20 CALL Timeout
16       !
17       ! *** Specify call parameters ***
18       OUTPUT Testset;"SYST:COMM:GPIB:DEB:STAT ON"
19       OUTPUT Testset;"SYST:CORR:STAT OFF"
20       ! Operating Mode is set to be Active Cell
21       OUTPUT Testset;"CALL:OPER:MODE CALL"
22       ! System Type is set to be AMPS
23       OUTPUT Testset;"CALL:SYST ";Systype$
24       ! Set System Identification
25       OUTPUT Testset;"CALL:SID:AMPS";Sid
26       !
64       PRINT "Turn on mobile station"
65       PRINT "Press Continue when it has registred"
66       PAUSE
67       !
68       ! *** Paging the mobile station ***
69       PRINT "Paging mobile station..."
70       PRINT "Answer the mobile station when you are ready."
71       OUTPUT Testset;"CALL:ORIG"
72       !Queries for connected/idle state
73       OUTPUT Testset;"CALL:CONN:STAT?"
74       ENTER Testset;Call_connected
75       IF NOT Call_connected THEN
76          DISP "Call attempt failed"
77          STOP
78       ELSE
79          DISP "Call connected"
80       END IF
81       PRINT "Connection established, test in progress"
82       !
83       ! *** Setup DTMF measurement parameters ***
84       ! Set Single measurement
85       OUTPUT Testset;"SET:DTMF:CONT OFF"
86       OUTPUT Testset;"SET:DTMF:GTIM 5"
89       !
90       ! *** Start DTMF measurement ***
91       OUTPUT Testset;"INIT:DTMF:ON"
92       PRINT "Please press keys (1..9,*,#,A,B,C,D) on the mobile station"
98       WAIT 10
99       ! *** Obtain measurement results ***
100      OUTPUT Testset;"FETCH:DTMF:ALL?"
101      WAIT 2
110      ENTER Testset;Integrity,Num_char,Res$
112      OUTPUT Testset;"FETCH:DTMF:COUN?"
113      ENTER Testset;Num
116      PRINT "Integrity Indicator = ";Integrity
117      PRINT "Character number = ";Num_char
123      !
124      End=-1
127      FOR I=1 TO 16
129         FOR J=1 TO 9
130          ! Get the start postion of the one value
131          ! of 16 sets of 9 comma-separated value
132          Start=End+2
133          IF (I=16 AND J=9) THEN
134          ! Get the last value of the 16 sets of
135          ! 9 comma-separated value
136            End=Start+LEN(Res$[Start])-1
137          ELSE
138          ! Get the end postion of the one value
139          ! of 16 sets of 9 comma-separated value
140            End=Start+POS(Res$[Start],",")-2
141          END IF
142          SELECT J
143          CASE 1
144            PRINT "Symbol ";I;Res$[Start,End]
145          CASE 2
146            PRINT "Symbol ";I;" Low Tone Fre.=";Res$[Start,End]
147          CASE 3
148            PRINT "Symbol ";I;" Low Tone Fre. Error=";Res$[Start,End]
149          CASE 4
150            PRINT "Symbol ";I;" Low Tone Phase dev.=";Res$[Start,End]
151          CASE 5
152            PRINT "Symbol ";I;" High Tone Fre.=";Res$[Start,End]
153          CASE 6
154            PRINT "Symbol ";I;" High Tone Fre. Error=";Res$[Start,End]
155          CASE 7
156            PRINT "Symbol ";I;" High Tone Phase dev.=";Res$[Start,End]
157          CASE 8
158            PRINT "Symbol ";I;" On Time=";Res$[Start,End]
159          CASE 9
160            PRINT "Symbol ";I;" Off Time=";Res$[Start,End]
161          END SELECT
162         NEXT J
163      NEXT I
164      DISP "DTMF Test complete"
165      OUTPUT Testset;"INIT:DTMF:OFF"
166      OUTPUT Testset;"CALL:END"
167      ! *** Display the measurement results ***
168  END
178  ! Global timeout handler
185  Timeout: SUB Timeout
187                  PRINT "Program timed out"
188                  CLEAR 7
189                  CLEAR 714
190           SUBEND

Returned Values

The results returned by this program are:

  • Integrity returns the measurement integrity indicator (see Integrity Indicator ); 0 means a successful measurement with no errors.
  • Num_Char returns the number of DTMF characters.
  • Res$ returns the set of results for each symbol that is sent from the mobile station. It includes the symbol result, the frequency of lower tone in Hz, the frequency error of lower tone in Hz, the phase deviation of lower tone in Radian, the frequency of upper tone in Hz, the frequency error of upper tone, the phase deviation of upper tone in Radian, the length of time that the DTMF symbol is broadcast in milliseconds, the length of time that no DTMF symbol is broadcast in milliseconds.

Related Topics

DTMF Measurement Description

Measuring DTMF

DTMF Troubleshooting

INITiate

SETup:DTMF

FETCh:DTMF


Programming an FER (Frame Error Rate) Measurement

Programming an FER (Frame Error Rate) Measurement

Last updated: October 28, 2004

This section provides an example of how to make an FER measurement via GPIB.

The following program example assumes that the mobile station's antenna output is connected to the RF IN/OUT connector, and the mobile station has found service.

For information on configuring the test set for a call, see Step 4: Make a connection .

The basic procedure to test FER is as follows:

  1. Make a SO (service option) 2, 9, or 55 call (see CALL:SOPTion ).
  2. Configure the FER Setup parameters using the SETup:CFERror subsystem.
  3. Start the FER measurement using the INITiate subsystem.
  4. Use the FETCh:CFERror command to obtain the measurement results.

Programming Example

11   !RE-SAVE "c:\roadhog\programs\fer.txt"
20   !This program measures frame error rate.
30   !See "Receiver Sensitivity and Dynamic Range" in TIA/EIA-98-D for
40   !Specifications and Standards.
50   CLEAR SCREEN
60   A=714
70   !***Specify call parameters***
80   Systype$="DIGITAL2000"  !Cell System Type
90   Band$="USCELLULAR"      !Cell band
100  Channel=384   !RF Channel
110  Sid=1         !System Identification
120  Nid=1         !Network Identification
130  Radio_config$="F3R3"  !Radio Configuration
140  Service_opt$="SO2"    !Service Option
150          !
160  !***Specify test parameters***
170  !Reverse channel, forward channel frequencies for amplitude offset (path loss)
172  Loss_frequency$="836 MHZ,881 MHZ"
182  !Path loss at reverse channel, forward channel frequencies
190  Expected_loss$="-2,-2"
200  Ior=-104         !Cell power
210  Pilot=-7         !Pilot channel power level
220  Traffic=-15.5    !Traffic channel power level
230          !
240  ON TIMEOUT 7,20 CALL Timeout !Calls "Timeout" routine
250  OUTPUT A;"SETUP:CFER:TIMEOUT:STIME 10 S" !Sets FER measurement timeout to 10 seconds
260  OUTPUT A;"SYST:COMM:GPIB:DEB:STAT ON"    !Turns debug state on
270          !
280  !***Set up path loss***
282  !Enters frequencies in Amplitude Offset table
290  OUTPUT A;"SYSTEM:CORRECTION:SFREQUENCY ";Loss_frequency$
300  !Enters loss values in Amplitude offset table
310  OUTPUT A;"SYSTEM:CORRECTION:SGAIN ";Expected_loss$
320         !
340  !***Set up call parameters***
350  OUTPUT A;"CALL:OPER:MODE CALL" !Sets Operating Mode to Active Cell
360  OUTPUT A;"CALL:SYSTEM ";Systype$ !Sets System Type
370  OUTPUT A;"CALL:BAND ";Band$      !Sets Cell Band for selected System Type
380  OUTPUT A;"CALL:CHAN ";Channel !Sets Channel for selected System Type and Cell Band
390  OUTPUT A;"CALL:POWER -50" !Sets and turns on Cell Power for selected System Type
400  OUTPUT A;"CALL:SID ";Sid        ! Sets System Identification
410  OUTPUT A;"CALL:NID ";Nid        ! Sets Network Identification
420  OUTPUT A;"CALL:RCON ";Radio_config$  !Sets Radio Configuration
430  OUTPUT A;"CALL:SOPTION ";Service_opt$  !Sets service option for selected System Type
440                                         !and Radio Configuration
450  OUTPUT A;"CALL:PROT PREV6" !Sets Protocol Revision for the selected System Type
460  OUTPUT A;"CALL:PAG:DRAT FULL" !Sets Paging channel data rate to full rate
470  OUTPUT A;"CALL:PIL -7"     !Sets Pilot to default
480  OUTPUT A;"CALL:SYNC -16"   !Sets Sync to default
490  OUTPUT A;"CALL:PAG -12"    !Sets Paging to default
500  OUTPUT A;"CALL:FCH -15.6"  !Sets Traffic to default
510          !
520  PRINT "Turn on mobile station...press continue when it has found service and registered"
530  PAUSE
540  CLEAR SCREEN
550  OUTPUT A;"CALL:REG:TIMER:STATE 0"  !Turns timer-based registrations off
560  WAIT 2   !Waits 2 seconds for any timer-based registrations to clear out
570          !
580  !***Page the mobile station***
590  DISP "Paging mobile station..."
600  OUTPUT A;"CALL:ORIG"  !Pages the mobile station
610  OUTPUT A;"CALL:CONNECTED:STATE?" !Queries for connected/idle state...hangs until state
620                                   !change detector is disarmed
630  ENTER A;Call_connected
640  IF NOT Call_connected THEN
650    DISP "Call attempt failed"
660    STOP
670  ELSE
680    DISP "Call connected"
690  END IF
700          !
710  !***Set up measurement parameters***
720  OUTPUT A;"SETUP:CFERROR:CONTINUOUS OFF" !Sets trigger arm state to single
730  OUTPUT A;"CALL:POW ";Ior  ! Sets Cell Power for the selected System Type
740  OUTPUT A;"CALL:PIL ";Pilot !Sets Pilot channel level
750  OUTPUT A;"CALL:FCH ";Traffic !Sets Traffic channel level
760          !
770  !***Obtain measurement results***
780  OUTPUT A;"INITIATE:CFERROR" !Initiates a frame error rate measurement
790  DISP "Measuring FER"
800  OUTPUT A;"FETCH:CFERROR?" !Queries the test set for frame error rate measurement results
810  ENTER A;Integrity,Fer_test,Fer_ratio,Fer_count,Frames_tested
820          !
830  SELECT Fer_test  !Assign pass/fail results to a string
840  CASE 0
850    Pass_fail$="PASSED"
860  CASE 1
870    Pass_fail$="FAILED"
880  CASE 2
890    Pass_fail$="MAXIMUM NUMBER OF FRAMES WERE TESTED"
900  CASE 3
910    Pass_fail$="UNKNOWN"
920  END SELECT
930          !
940  PRINT "Integrity indicator = ";Integrity
950  PRINT "FER test results = ";Pass_fail$,"FER ratio = ";Fer_ratio
960  PRINT "FER count = ";Fer_count,"Number of frames tested = ";Frames_tested
970          !
980  OUTPUT A;"FETC:CFER:ERAS:FORW?"   ! Fetch forward erasure
990  ENTER A;For_eras
1000 PRINT "FER forward erasure data = ";For_eras;
1010         !
1020 OUTPUT A;"FETC:CFER:ERAS:REV?"  ! Fetch reverse erasure
1030 ENTER A;Rev_eras
1040 PRINT "FER reverse erasure data = ";Rev_eras
1050         !
1060 OUTPUT A;"FETC:CFER:ERR?"   ! Fetch mobile error
1070 ENTER A;Mob_err
1080 PRINT "FER mobile errors = ";Mob_err
1090 DISP "Test complete"
1100 !***Return to default call processing states***
1110 OUTPUT A;"CALL:POW:DIG2000 -50"    ! Returns cell power to -50 dBm/1.23 MHz
1120 OUTPUT A;"CALL:REG:TIMER:STATE ON"  !Returns timer-based registration to ON
1130          !
1140 OUTPUT A;"CALL:END"          !Ends the call
1150 END
1160  Timeout: SUB Timeout          ! Global timeout handler
1170    PRINT "Program timed out"
1180    CLEAR 7
1190    CLEAR 714
1200  SUBEND

Related Topics

Measuring Frame Error Rate (FER)

Frame Error Rate (FER) Measurement Description

Frame Error Rate Measurement Troubleshooting

Programming a TDSO Frame Error Rate Measurement

Control Program Example

READ? Subsystem

SETup:CFERror

INITiate

FETCh:CFERror


Programming a Frequency Modulation (FM) Measurement

Programming a Frequency Modulation (FM) Measurement

Last updated: August 12, 2005

The following program example assumes that the mobile's antenna output is connected to the RF IN/OUT connector, and the mobile is on an analog voice channel (AVC).

The test set uses the AVC Channel (CALL:SET:AVC) and MS TX Level (CALL:SET:MS:ANALog:TXLevel) settings of the base station emulator for the expected frequency and power level. To manually set the expected frequency and power, see Receiver Control .

General Programming Procedure

  1. Enter the expected frequency and power.
  2. Configure the Frequency Modulation setup parameters using SETup:FM subsystem.
  3. Start the measurement using the INITiate subsystem.
  4. Obtain the measurement results using the FETCh:FM subsystem to obtain the measurement results.

Programming Example

10  !Set the expected frequency and power.
20  OUTPUT 714;"SETup:FM:COUNt 5" !Set multi-measurements to 5.
30  OUTPUT 714;"SETup:FM:DISTortion:STATe ON" !Enable the distorion measurement.
40  OUTPUT 714;"SETup:FM:DISTortion:FREQuency 1004 HZ" !Set the distortion measurement
50                                                    !Fundamental Frequency (1004 HZ).
60  OUTPUT 714;"SETup:FM:FREQ:STATe ON" !Turn on the modulation frequency measurement.
70  OUTPUT 714;"SETup:FM:FILTer CMESsage" !Select the C-Message filter.
80  OUTPUT 714;"SETup:FM:DETEctor PPEak" !Select the Peak + detector.
90  OUTPUT 714;"SETup:FM:DEMPhasis:STATe OFF" !Make sure de-emphasis is off.
100 OUTPUT 714;"SETup:FM:EXPandor:STATe OFF" !Make sure the expandor is off.
110 OUTPUT 714;"SETup:FM:CONTinuous OFF" !Set the FM measurement to single trigger mode.
120 OUTPUT 714;"SETup:FM:TIMeout 1 S" !Set a timeout value of 1 second
130                                   !in case the measurement cannot be made.
140 OUTPUT 714;"INITiate:FM" !Start the measurement.
150 OUTPUT 714;"FETCh:FM?" !Query the returned integrity indicator and the
160        !average FM deviation and average FM distortion results.
170 ENTER 714;Integrity,Fm_dev,Fm_dist,Fm_freq !Enter the returned values into variables.
180 IF Integrity=0 THEN  !See if the integrity value = 0 (valid measurement).
190 ELSE
200 PRINT "Measurement problem; check for signal level over/under range condition."
210 END IF
220 END

Returned Values

The measurements returned by this program are:

  • Integrity returns the measurement integrity indicator (see Integrity Indicator ); 0 means a successful measurement with no errors.
  • FM_dev returns the average FM deviation in kHz. FM_dist returns the average FM distortion in percent (%). FM_freq returns the average modulation frequency in Hz.

Related Topics

Frequency Modulation (FM) Measurement Description

Frequency Modulation (FM) Troubleshooting

INITiate

SETup:FM

FETCh:FM

Receiver Control


Programming a Frequency Stability Measurement

Programming a Frequency Stability Measurement

Last updated: October 29, 2004

This section provides an example of how to make analog frequency stability measurements via GPIB.

The following program example assumes that a signal within the measurements range is connected to the RF IN/OUT connector (see Input Signal Requirements ).

The basic procedure to test Frequency Stability is as follows:

  1. Set the operating mode to CW (see CALL:OPERating ).
  2. Enter the expected power (see RFANalyzer:CW:EXPected:POWer ).
  3. Enter the expected frequency (see RFANalyzer:MANual:MEASurement[:MFRequency] ).
  4. Define the Frequency Stability Setup parameters as desired for measurement timeout and multi-measurements (see SETup:FSTability ).
  5. Use the INITiate command to start the measurement.
  6. Use the FETCh:FSTability command to obtain the measurement results.

Programming Example

10  !Set the expected frequency and power.
20  OUTPUT 714;"SETup:FSTability:CONTinuous OFF" !Set the frequency stability
30                                           !measurement to single trigger mode.
40  OUTPUT 714;"SETup:FSTability:TIMeout 1 S" !Set a timeout value of 1 second
50                                       !in case the measurement cannot be made.
60  OUTPUT 714;"SETup:FSTability:COUNt 5" !Set multi-measurements to 5.
70  OUTPUT 714;"INITiate:FSTability" !Start the measurement.
80  OUTPUT 714;"FETCh:FSTability?" !Query the returned integrity indicator and the
90         !Worst Case Frequency Error and average Frequency measurements.
100 ENTER 714;Integrity,Freq_error,Frequency  !Enter the returned values into variables.
110 IF Integrity=0 THEN  !See if the integrity value = 0 (valid measurement).
120 ELSE
130 PRINT "Measurement problem; check for signal level over/under range condition."
140 END IF
150 END

Returned Values

The measurements returned by this program are:

  • Integrity returns the measurement integrity indicator; 0 means a successful measurement with no errors.
  • Freq_error returns the worst case frequency error in parts per million (PPM). Frequency returns the average frequency.

Related Topics

Frequency Stability Measurement Description

Frequency Stability Measurement Troubleshooting

READ? Subsystem

SETup:FSTability

INITiate

FETCh:FSTability


Dealing With Semicolon Separated Response Data Lists

Dealing With Semicolon Separated Response Data Lists

Last updated: October 28, 2004

Description

In accordance with IEEE 488.2-1992 Section 8.4.1 the test set uses the semicolon (;) as the response message unit separator (RMUS). The RMUS separates sequential response message unit elements from one another when multiple response message unit elements are sent in a response message. This condition would occur when combining multiple queries into a single GPIB transaction.

Query Response Data Types Used By Test Set

The test set can return the following data types in response to queries:

  • character data (char): ASCII characters A-Z (65-90 decimal), underscore (95 decimal), digits (48-57 decimal).

  • string data: ASCII characters enclosed in quotes (for example, "5551212" or "PGSM")

  • numeric response data (nr1): numeric data in the form +/- dddddddd

  • numeric response data (nr3): numeric data in the form +/- ddd.ddd E +/- dddd

Semicolon Separated Response Data Lists Containing Mixed Data Types

Problems can occur when trying to enter semicolon separated response data lists containing mixed data types.

For example: If the following command string is sent to the test set, the test set will respond by constructing a response message which contains multiple response message unit elements (that is, one response message unit element for each query item contained in the command string). Some response message unit elements are string data type, some are character data type and some are nr3 data type.

OUTPUT 714;"CALL:MS:REP:IMSI?;PCL?;REV?;SBAN?;ONUM?;MCC?;MNC?;LAC?"

An example response message generated by the test set in response to the above OUTPUT statement would be:

"001012345678901";+4.00000000E+000;PHAS1;"PGSM";"5551212";9.91E37;9.91E37;9.91E37

Constructing the following data entry statement will account for multiple responses from the query:

ENTER 714;Imsi$,Pcl,Rev$,Sban$,Onum$,Mcc,Mnc,Lac

In the Basic programming environment the above ENTER statement will fail with an `Insufficient data for ENTER' error. Some programming languages, Basic for example, cannot use the semicolon character as a data item terminator for string variables. In this example Basic will attempt to enter data into Imsi$ until it sees a LF (line feed) data item terminator. The test set does not send the LF until all the data has been sent. Consequently when Basic sees the LF it terminates entry of data into Imsi$ and starts to look for data to enter into Pcl. Since the test set is no longer sending any data the error message `Insufficient data for ENTER' is generated.

One possible workaround is to enter all the data into a single string variable, replace all semicolons with line feeds and then enter the data from the string into the individual data items. For example:

DIM Response$[500]
!
!
OUTPUT 714;"CALL:MS:REP:IMSI?;PCL?;REV?;SBAN?;ONUM?;MCC?;MNC?;LAC?"
ENTER 714;Response$
Semicolon=POS(Response$,";")
WHILE Semicolon
Response$[Semicolon,Semicolon]=CHR$(10)
Semicolon=POS(Response$,";")
END WHILE
ENTER Response$;Imsi$,Pcl,Rev$,Sban$,Onum$,Mcc,Mnc,La

Semicolon Separated Response Data Lists Containing Only Numeric Data Types

Semicolon separated response data lists containing only numeric data types do not present the types of problem associated with semicolon separated response data lists containing mixed data types. The number building routines in most languages will use any non-numeric character (that is, anything other than +/- 0123456789 E .) as the data item terminator. Consequently when the number building routines encounter the semicolon the data item is terminated. The following example illustrates this:

OUTPUT 714;"FETCH:TXP:INT?;POW:MIN?;MAX?"
ENTER 714;Integrity,Min_power,Max_power


Concurrent Measurements

Concurrent Measurements

Last updated: July 4, 2006

Description

A number of measurements can be initiated (with the INITiate command) while other measurements are being made, and the test set will perform as many operations simultaneously as its architecture allows. This technique is referred to as concurrency. Performing measurements concurrently can greatly improve test throughput.

Operating Considerations

The test set has three parallel signal paths to improve measurement throughput.

  • Demodulation downconverter path.
  • Measurement downconverter path.
  • Power detector path.

Since measurements are DSP (digital signal processor) based, and there are four A/D converters available to digitize or "sample" the input signal for analysis by the DSP, the test set will always have the capability to perform one transmitter measurement, one receiver measurement, and maintain the radio link concurrently. The test set's ability to perform multiple transmitter, or multiple receiver tests concurrently will depend on the availability of resources within the test set and availability of the signal to be tested.

Related Topics

Block Diagram


Integrity Indicator

Integrity Indicator

Last updated: July 31, 2006

Description

The test set can evaluate its own performance and make a determination as to the validity of a measurement result. The test set evaluates the conditions surrounding a measurement and reports to the user its evaluation of these conditions in a parameter called the measurement integrity indicator. A measurement integrity indicator value is returned for every completed measurement. It is recommended that the user take advantage of this feature in every measurement.

The returned value defines whether or not a problem was encountered by the measurement process. It is not, however, guaranteed to be the only or root cause of the measurement problem. This is because some of the conditions surrounding a measurement may interact, and the test set may have insufficient information to determine the root cause of the measurement problem. However, in most cases, the value returned is the most likely cause of the problem.

Not all of the integrity indicator values are available for each measurement or test application, if a value doesn't apply it will not be available.

Integrity Indicator Values

NOTE
GSM, GPRS and EGPRS measurements return integrity indicators (8, 9, 11) when the measurement synchronization is set to midamble.

Integrity Indicator Number

Integrity Indicator Message

0

Normal: Indicates the measurement completed successfully without error and the result is accurate.

1

No Result Available: Indicates that there is no measurement result and returns NAN (not a number).

2

Measurement Timeout: Indicates that a measurement has timed out. The measurement timeout state must be set to ON.

3

Hardware Not Installed: Indicates that a piece of hardware is not installed in the test set, or the hardware has failed in a way which leads the instrument controller to believe it isn't installed.

4

Hardware Error: Indicates that a hardware failure has occurred. These include failures such as a phase lock loop out-of-lock, defective DSP samplers, or power detectors that can not be calibrated.

5

Over Range: Indicates that the input signal is over range. The amplitude of the device-under test's (DUT's) signal is causing the voltage at a DSP sampler to be above its maximum input level or the frequency is too high or the voltage measured is beyond the maximum voltmeter range, either positive or negative.

6

Under Range: Indicates that the input signal is under range. The amplitude of the DUT's signal is not high enough for the DSP sampler to produce accurate results with the measurement algorithm.

7

Burst Short: Indicates that the burst duration is too short, or part of the burst was not sampled due to improper triggering.

8

Trigger Early or Fall Early: Indicates that the DUT's burst amplitude fell prematurely or, due to an early trigger (early relative to a transmitted burst) the measurement sampling operation terminated before the falling edge of the burst.

9

Trigger Late or Rise Late: Indicates that either the rising edge of the DUT's burst was late or, due to a late trigger (late relative to a transmitted burst) the measurement sampling operation didn't start until after the rising edge of the transmitted burst.

10

Signal Too Noisy: Indicates that the measurement algorithm has found the signal measured to be too noisy to provide accurate results.

11

Sync Not Found: For the GSM/GPRS/EGPRS power versus time measurement, indicates that the midamble was not found therefore the measurement was not synchronized. For the W-CDMA BER and BLER measurements, indicates that the test set has lost synchronization with the UE.

12

Oven Out of Range: Indicates that a temperature controlled oven (other than the internal timebase oven) is outside of its operating range. The power meter's oven is checked and its condition reported with this value. (The internal timebase generates a temporary error message (out of lock) that is sent to the system error queue and the display. This is not an integrity indicator value, it is an error message.)

13

Unidentified Error: Indicates errors which are not covered by the other integrity values. Examples include: parameter errors, algorithm memory errors (too many measurements), measurements unavailable (unable to control), autorange unable to converge, default calibration data used.
14

PCM Full Scale Warning: Indicates that the PCM signal has reached plus or minus full scale. The measurement made will be accurate on the PCM signal but would typically indicate an overdriven or oscillating element in the DUT.
15

Questionable Result for Phase 1 Mobile: Indicates that the user attempted to make an FBER measurement in a phase 1 system. FBER is only possible in a phase 2 GSM system. This indicator is available only when the selected broadcast band is PGSM.

16

Questionable Result:
1. Indicates that the channel mode was NOT set to Full Rate Speech while a Decoded Audio measurement was active. Decoded Audio is only supported for FS Speech.
2. For the cdma2000 lab application, this integrity indicator is used to indicate that the Digital Average Power measurement result is questionable if the reverse channel is in 1/8 rate gated transmission in radio configuration 3 and above or the test set can not determine whether the reverse channel is in gated transmission (for example, while in a voice call).
3. For the GPRS Bit Error and GPRS Block Error measurements, this integrity indicator is returned when the Connection Type is set to an invalid parameter, i.e. SRB Loopback.

17

Can not Correlate: Indicates that the test sets internally generated reference signal does not correlate with the received signal.

Some conditions that could cause this integrity indicator result include the following:

  • an input signal that is corrupted
  • the input signal is extremely distorted
  • the input signal is off by more than 10 ms.
  • the frequency of the input signal deviates more than allowed
  • something is wrong with the long-code mask coming from the mobile ID

18

Frequency Out Of Range: Indicates that a Channel Power Measurement was attempted at a frequency for which there is no calibration data. The test set display will indicate 4 dashes.

19

Uncalibrated Due To Temperature: Indicates that the ambient temperature changes more than 10 degrees C since latest calibration, when attempting a Channel Power Measurement.

20

 Potential Receiver Saturation: Indicates that an input signal immediately prior to the measured input was high enough to potentially saturate the receiver hardware.

21

Parameter Error: Indicates that a measurement setup parameter has been set in a way that gives invalid measurement results.

22

Unsupported Configuration: Indicates that some parameter, other than a measurement setup parameter has been set so that it causes an invalid measurement result. Typically this would be a base station emulator parameter.

23

Call Processing Operation Failed: Indicates that a call processing operation, (base station emulator) needed in the course of making the measurement could not complete.

24

Calibration Error

25

 Burst Not Found
26 | Missing Loopback Packets or AT Buffer Overflow: Indicates that Loopback Packets are missing, or the Access Terminal had an overflow. This integrity indicator was added for the 1xEV-DO Packet Error Rate measurement.

27

No AT Loopback Packets: Indicates that no Loopback Packets from the Access Terminal were detected for a period of several seconds. This integrity indicator was added to provide an early termination criteria for the 1xEV-DO Packet Error Rate measurement.

28

 Questionable MS-to-Cell Data: Indicates that a condition exists on the uplink or reverse channel that has caused the measurement results to be in question. In the case of the WCDMA Loopback BER measurement, an example condition that could cause this integrity indicator would be detection of a CRC error in an uplink transport block.
30 | Trigger Missed: Indicates one or more triggers were missed during the measurement. In the case of the CDMA TX dynamic power measurement, an example condition that may cause this integrity indicator would be GPIB or LAN activities occur during the measurement. This integrity indicator was added to prevent the CDMA TX dynamic power measurement from hanging forever and provide an early termination criteria for the measurement.

31

Dual Measurement Request: Indicates that a request has been received for a measurement type that is already running.

32

Measurement Not Licensed: Indicates that the required feature license for the measurement is not present. See

http://www.agilent.com/find/8960upgrades

for details on hardware and software requirements to run a specific feature.

Example Program

10  OUTPUT 714;"INITiate:DAPower" !Start Digital Average measurement
20  OUTPUT 714;"FETCH:DAPower?" !Request measurement results.
30  ENTER 714;Integrity,Tx_power !Read measurement results.
40  IF Integrity = 0 THEN !Permits measurement to be printed if integrity indicator
50                        !indicates a successful measurement
60  PRINT "Analog TX Power =";Tx_power!if 0 then measurement was successful
70  ELSE
80  PRINT "Measurement integrity questionable, integrity value = ";Integrity !If
90                                                                           !integrity
100                                                                          !not zero
110                                                                          !then print
120                                                                          !integrity
130                                                                          !value.
140 END IF
150 END

Related Topics

Reading Error Messages


Timeouts

Timeouts

Last updated: July 4, 2006

Description

The primary use of measurement timeouts is to regain control of the test set's GPIB in cases where the bus could potentially "hang."

The time normally required for a measurement to complete may vary greatly depending on the individual measurement, its settings, it's multiple measurement count value, and so forth. Because of this, you may need to set the timeout longer than the default for measurements where a large number of multiple measurements are requested or where measurement triggers may be infrequent.

Be careful when setting a timeout that is shorter than the default. It is possible to specify a timeout that is so short the measurement does not even have a chance to begin. Measurement timeouts should always be at least several seconds long.

Timeout units default to S (seconds). The seconds suffix is an optional part of the command. If you want MS (milliseconds), US (microseconds) or NS (nanoseconds), you must specify these units in the suffix.

Timeout Values

All measurements in the CDMA 2000 Mobile Test application default to a timeout value of 10 seconds, except FER. The FER measurement timeout default is 200 seconds.

Related Topics

Integrity Indicator


Step 1: Set Up the Test Set

Step 1: Set Up the Test Set

Last updated: October 28, 2004

The following information provides additional details on Step 1 of the Programming Flowchart. This information is applicable to all test applications.

Description

In this step you initialize the test set and set up the general operating conditions.

Contents

  • Initialize the Test Set
  • Set Up General Operating Conditions

Initialize the Test Set

  • Fully Preset the Test Set

    It is important to get the test set to a known state before each production session.

    Sending the *RST command fully presets the test set, which ends all call processing and measurement processes and restores all values to defaults.

  • Clear the Error Queue

    Before each production session, it is useful to clear the error queue of any old messages. That way, you know that any messages logged are relevant to the current production session.

    Sending the *CLS command clears the error queue.

Set Up General Operating Conditions

  • Turn Debugger On

    While developing your code, it is very useful to enable the GPIB debugger using the
    SYST:COMM:GPIB:DEB ON command. When the debugger is on, the test set alerts you when you send an incorrect command, and it also tells you which symbol or letter in the command is incorrect.

NOTE
You should turn the debugger off once you have finished development and your code is stable.

  • Set Operating Mode

    The test set contains a base station emulator (BSE), whose primary purpose is to provide enough call processing to allow parametric measurements of a mobile station's RF signal.

    An important characteristic of the test set's base station emulator is its operating mode. The operating mode sets the way in which the base station emulator interacts with the mobile station.

    Active cell mode is used when emulating a normal cell. Active cell mode allows active signaling between the mobile station and BSE. The mobile station camps to the BSE signal, and an actual call is established.

    In test mode, the mobile station synchronizes to the BSE signal and transmits an appropriate signal which the test set analyzes.

    The test set's operating mode is set using the following command:

    Command to Set the Test Set's Operating Mode

    Command

             Example

    CALL:OPER:MODE <operating mode>

    CALL:OPER:MODE CALL

  • Set Amplitude Offsets

    To achieve accurate measurement results, it is important to account for losses in the cabling and fixturing between the mobile station and test set. You must determine what the losses are for your test setup and then specify the appropriate frequency-dependent amplitude offset values.

    You can specify amplitude offsets for up to 20 frequencies using the following commands:

    Commands to Set Amplitude Offsets

    Command

             Example

    SYST:CORR:FREQ <freq1>, <freq2>, <freq3>

    SYST:CORR:FREQ 800MHz, 1800MHz,
    1900MHz

    SYST:CORR[:SGAin] <offset1>,
    <offset2>, <offset3>

             SYST:CORR -0.7, -1.0, -1.2

  • Set Display Mode

    To achieve a slightly faster test execution speed, you can disable the front panel display on the test set using the DISP:MODE FAST command.


Step 2: Configure Test Set and Mobile Station Parameters

Step 2: Configure Test Set and Mobile Station Parameters

Last updated: October 28, 2004

The following information provides additional details on Step 2 of the Programming Flowchart. This information is applicable to all test applications.

Description

In this step you configure the parameters that allow a connection to be made between the test set and mobile station. This mainly involves setting up channels and power levels.

Contents

  • Set Up Channels
  • Set Cell Power
  • Set Mobile Station Transmit Power
  • Set Up Additional Connection Parameters

Set Up Channels

For many technologies, setting up channels involves specifying the channel associated with every band and channel type (for example, analog or digital), and then setting the active band and channel type. For some technologies, such as W-CDMA, you simply specify the downlink and uplink UARFCNs (channels).

  • Specify Channel Numbers

    All of the test set's test applications can test in more than one frequency band (for example, US Cellular, US PCS, or Korean PCS). To produce the most efficient code, you should configure the channel information for each band in advance. Then, to move to a new band during testing, you only need to send the command to change bands. You do not need to also specify the channel of the new band. This reduces test time.

    To set up the channel number for the various bands, use one of the following commands (depending upon which test application you are using):

    Commands to Set the Channel for a Band

    Command

             Example Technology

    CALL:<channel mnemonic>:<band mnemonic>
    <num value>

    CALL:TCH:EGSM 124

             GSM/GPRS/EGPRS

    CALL:SET:<channel type mnemonic>:<band
    mnemonic> <num value>

    CALL:SET:DTC:PCS 777

             AMPS/136

    CALL:CHAN:<channel type mnemonic>:<band
    mnemonic> <num value>

    CALL:CHAN:DIG2000:K
    PCS 384

             cdma2000/IS-95/AMPS

    This practice also applies to test applications which test both analog and digital channel types. In this case you should specify the channel for the analog and digital channel types in advance. Then, switching between them requires only one command to initiate the change, and not an additional change to specify the channel of the new channel type.

    If you specify channels in advance as described, the only time you need to specify a channel during testing is if you move to a new channel within the same band and channel type.

  • Set Active Band and Mode

    Once you have specified the channel information for each band and channel type, you must set the active band using one of the following commands (depending upon which test application you are using):

    Commands to Set the Active Band

    Command

             Example Technology

    CALL:<channel mnemonic>:BAND <band mnemonic>

    CALL:TCH:BAND
    EGSM

             GSM/GPRS/EGPRS

    CALL:SET:<channel type mnemonic>:BAND <band
    mnemonic>

             CALL:SET:DTC:BAND
    PCS     		AMPS/136
    CALL:BAND:<channel mnemonic> <band mnemonic>

    CALL:BAND:DIG2000
    KPCS

             cdma2000/IS-95/AMPS

    If the test application you are using supports testing of both analog and digital channel types, then you must also set the channel type using the following command:

    Command to Set the Active Channel Type

    Command

             Example

    CALL:<channel mnemonic>:TYPE <channel type
    mnemonic>

    CALL:TCH:TYPE
    DTC

  • Active Cell and Test Mode Considerations

    The function of the CALL commands differ depending upon whether you are in active cell or test mode.

    In active cell mode, when you use the CALL commands to set the channel numbers, the test set's output frequency and receiver frequency are set. A message is also sent to the mobile station to set its frequency.

    However, in test mode, since the BSE does not send call processing information to the mobile station, the CALL commands only configure the test set's output frequency and receiver frequency. You need to also send the appropriate test mode commands to the mobile station to set it to the correct frequency.

    In test mode, instead of using the CALL commands to configure the test set's frequencies, you may prefer to manually control the RF generator and RF analyzer using the CALL:RFG and RFAN commands, respectively. In either case, you must still send the appropriate test mode commands to the mobile station to move it to the proper frequency.

Set Cell Power

To set the output power of the test set, use the following command:

Command to Set Cell Power
Command | Example
CALL:POW <num value> | CALL:POW -75

  • Active Cell and Test Mode Considerations

    You can use the CALL:POW command to set the cell power in both active cell and test mode. However, in test mode you may prefer to manually control the output power of the test set using the CALL:RFG commands.

Set Mobile Station Transmit Power

In active cell mode, use one of the following commands to set the mobile station transmit power level (depending upon which test application you are using):

Commands to Set Mobile Station Transmit Power
Command | Example | Technology
CALL:MS:TXL:<band mnemonic> <num value> | CALL:MS:TXL:DCS <num value> | GSM
CALL:SET:MS:<channel type mnemonic>:TXL:<band mnemonic> <num value> | CALL:SET:MS:DIG:TXL:PCS <num value> | AMPS/136
CALL:<channel mnemonic>:MS:TXL:<band mnemonic>:BURS <num value> | CALL:PDTCH:MS:TXL:DCS: BURS <num value> | GPRS/EGPRS

In addition to setting the mobile station transmit level, these commands also automatically configure the test set's receiver at the expected input level, whether in active cell or test mode. However, in test mode, you must also send the appropriate test mode commands to the mobile station to command it to output at the correct level. This is due to the fact that the BSE is not transmitting call processing commands to the mobile station.

  • Manually Setting Expected Power

    Sending the CALL commands in Commands to Set Mobile Station Transmit Power automatically sets the expected input level of the test set's receiver. However, there is another option for setting the receiver's input level in both active cell and test mode. It is often beneficial to manually set the expected input power level using the RFAN commands, rather than using the CALL commands.

    When you set the expected power manually, you tell the test set exactly what power level to expect. Whereas the CALL commands simply tell the test set the range of input level to expect, based on the definition of the mobile station power level (for example, an AMPS/136 mobile station transmitting at power level 3 has an output level in the range of +20 dBm to +26 dBm).

Set Up Additional Connection Parameters

Depending upon the test application you are using, there may be other connection parameters to specify, such as timeslot, timing advance, vocoder, or data rates and types.

In active cell mode, you may also choose to set up network parameters, such as base station identifier numbers (for example, SID) and color codes.

All of these parameters are configured using the CALL subsystem.


Step 3: Set Measurement Parameters

Step 3: Set Measurement Parameters

Last updated: October 29, 2004

The following information provides additional details on Step 3 of the Programming Flowchart. This information is applicable to all test applications.

Description

In this step you set up the conditions under which the measurements operate. You do this by configuring measurement parameters.

Contents

  • Measurement Parameters Overview
  • Generic Measurement Parameters
  • Measurement-Specific Measurement Parameters

Measurement Parameters Overview

There are two different types of measurement parameters:

  • Generic Measurement Parameters
  • Measurement-Specific Measurement Parameters

The SETup subsystem is used to configure measurement parameters. Each individual measurement parameter can be set and queried using the associated SETup subsystem command. The general hierarchy of the SETup subsystem command structure is as follows:

SETup:<measurement mnemonic>:<measurement parameter> <parameter setting/value>

NOTE
Not all measurements use all measurement parameters. Refer to the GPIB syntax listing for the detailed list of measurement parameters for individual measurements.

Generic Measurement Parameters

There are three types of generic measurement parameters:

  • Measurement Count (used by most measurements)
    Measurement Count State
    Measurement Count Number

  • Measurement Timeout (used by all measurements)
    Measurement Timeout State
    Measurement Timeout Time

  • Measurement Trigger (used by most measurements)
    Trigger Arm (used by all measurements)
    Trigger Source (not applicable to analog measurements)
    Trigger Delay (not applicable to analog measurements)

Measurement Count Parameters

The measurement count parameters control measurement averaging. The STATe command turns averaging on or off, and the NUMBer command determines the number of averages. The SNUMber command is a complex command which allows you to turn averaging on and set the number of averages in one command.

Statistical Measurement Results Parameters
Parameter | Command Syntax
Measurement Count State | SETup:<meas-mnemonic>:COUNt:STATe <ON|1|OFF|0>
Measurement Count Number | SETup:<meas-mnemonic>:COUNt:NUMBer <numeric value>
Measurement Count Number and State | SETup:<meas-mnemonic>:COUNt[:SNUMber] <numeric value>
Programming Example:

OUTPUT Test_set;"SET:DTXP:COUN 10"

sets the multi-measurement count state to ON and set the number of averages to 10 for the digital transmit power measurement.

Measurement Timeout Parameters

Measurement timeout parameters control the maximum time that a measurement executes. TIMe sets the amount of time and STATe determines if the timeout is in use. The STIMe command is a complex command which enables you to set both parameters in one command.

Measurement Timeout Parameters
Parameters | Command Syntax
Measurement Timeout Time and State | SETup:<meas-mnemonic>:TIMeout[:STIMe] <numeric value>[<suffix>]
Measurement Timeout State | SETup:<meas-mnemonic>:TIMeout:STATe <ON|1|OFF|0>
Measurement Timeout Time | SETup:<meas-mnemonic>:TIMeout:TIME <numeric value>[<suffix>]
Programming Example:

OUTPUT Test_set;"SET:DTXP:TIM 10"

sets the measurement timeout state to ON and set the measurement timeout time to 10 seconds for the digital transmit power measurement.

Measurement Trigger Parameters

There are three measurement trigger parameters. They control the arming of a measurement, the source of the trigger, and the trigger's delay.

  • The trigger arm parameter determines whether the test set makes one measurement and then stops (single), or automatically re-arms upon completion of one measurement and repeats the process (continuous). The recommended setting when writing a control program is single (CONTinuous OFF).

  • The trigger source parameter selects the source of the measurement trigger signal. The recommended Trigger Source setting when writing a control program is AUTO.

NOTE
Trigger source is always IMMediate for analog measurements and cannot be changed by the user.

  • The trigger delay parameter controls the delay between the trigger event (the point in time at which the trigger signal is received) and the start of sampling. Negative values indicate that the sampling should occur prior to the trigger event.

NOTE
Trigger delay is not applicable to analog measurements.

Measurement Trigger Parameters
Parameter | Command Syntax
Trigger Arm | SETup:<meas-mnemonic>:CONTinuous <ON|1|OFF|0>
Trigger Source | SETup:<meas-mnemonic>:TRIGger:SOURce <AUTO|IMMediate|PROTocol|RISE>
Trigger Delay | SETup:<meas-mnemonic>:TRIGger:DELay <numeric value>[<suffix>]

NOTE
You can set the Trigger Arm for all measurements to single (CONTinuous OFF) using the following command syntax:

SETup[:ALL]:CONTinuous:OFF

Programming Example:

OUTPUT Test_set;"SET:CONT:OFF"

sets the trigger arm to single for all measurements.

Programming Example:

OUTPUT Test_set;"SET:DTXP:TRIG:SOUR AUTO"

sets the trigger source to AUTO for the digital transmit power measurement.

Programming Example:

OUTPUT Test_set;"SET:DTXP:TRIG:DEL 10 US"

sets the trigger delay to 10 microseconds for the digital transmit power measurement.

Measurement-Specific Measurement Parameters

Measurement-specific measurement parameters set up operating conditions for a specific measurement. For example:

  • Setting the channel power measurement speed in IS-2000
  • Setting ORFS frequency offsets in GPRS
  • Setting number of bits for the FBER measurement in GSM

Refer to the GPIB syntax listing for the detailed list of measurement parameters for individual measurements.

Programming Example:

OUTPUT Test_set;"SET:CPOW:MSP FAST"

sets the IS-2000 channel power measurement speed to fast.

Programming Example:

OUTPUT Test_set;"SET:ORFS:SWIT:FREQ 400 KHZ"

sets the first ORFS offset to 400 kHz.

Programming Example:

OUTPUT Test_set;"SET:FBER:COUN 10000"

sets the number of fast BER bits to test to 10,000 bits.

Program Example Setting Both Generic and Measurement-Specific Measurement Parameters

! Set trigger arm to single for all measurements:
!
OUTPUT Test_set;"SET:CONT:OFF"
!
! *****************************************************
! Configure Modulation Accuracy Measurement:
!
OUTPUT Test_set;"SET:MACC:COUN 5"
! Example of using a complex command to set both the
! measurement count state and number at the same time.
!
OUTPUT Test_set;"SET:MACC:TRIG:SOUR AUTO"
! Sets trigger source to auto.
!
OUTPUT Test_set;"SET:MACC:TIM 15"
! Sets timeout state to ON and time to 15 sec.
!
OUTPUT Test_set;"SET:MACC:EVM10:STAT ON"
! Turns the EVM10 State ON
!
! ******************************************************
! Configure Digital TX Power Measurement:
!
OUTPUT Test_set;"SET:DTXP:COUN 5"
OUTPUT Test_set;"SET:DTXP:TRIG:SOUR AUTO"
OUTPUT Test_set;"SET:DTXP:TIM 5"
!
! ******************************************************
! Configure Frequency Stability Measurement:
!
OUTPUT Test_set;"SET:FST:COUN 3"
OUTPUT Test_set;"SET:FST:TIM 10"
!
! ******************************************************
! Configure Analog TX Power Measurement:
!
OUTPUT Test_set;"SET:ATXP:COUN 5"
OUTPUT Test_set;"SET:ATXP:TRIG:SOUR AUTO"
OUTPUT Test_set;"SET:ATXP:TIM 15"


Step 4: Make Connection

Step 4: Make Connection

Last updated: October 28, 2004

The following information provides additional details on Step 4 of the Programming Flowchart. This information is applicable to all test applications.

Description

In this step you make a connection between the mobile station and test set. How you do this depends upon whether you are in active cell or test mode. In active cell mode you establish a phone call between the test set and mobile station. In test mode, you command the mobile station to synchronize to the test set's signal and begin transmitting back an appropriate signal.

Contents

  • Establish a Call in Active Cell Mode
  • Make a Test Mode Connection

Establish a Call in Active Cell Mode

To test a mobile station in active cell mode, you must first establish a call between the test set and mobile station. Your control program must issue the commands necessary to initiate the call connection process, either to the test set (for a base station originated call) or to the mobile station (for a mobile station originated call). Your control program must then determine when the call has successfully connected so that it can proceed to testing. The control program must also determine if the call has not been successfully connected so that it can take appropriate action.

Call States

At any instant in time a call can be in a stable state such as the idle or the connected state, or in one of many transitory states such as alerting, handoff, registering, releasing or paging. These are referred to as transitory states because the amount of time which the call can spend in any of these states is limited by the mobile station's protocol. The call is not allowed to stay in a transitory state indefinitely.

NOTE
If repeat paging or repeat registration are on, it is possible for the call process to stay in one of the transitory states beyond the time specified by the mobile station's protocol timers.

Call Connection Synchronization Commands

The test set has a set of commands designed specifically for call connection and release synchronization.

Call Connection Synchronization Commands
Synchronization Command | Command Syntax
Call-Connected-State Query | CALL:CONNected[:STATe]?
Call-State-Change Detector Arm | CALL:CONNected:ARM[:IMMediate]
Call-State-Change Detector Timeout | CALL:CONNected:TIMeout

  • Call-Connected-State Query

    The CALL:CONN? query allows the control program to determine if a call is in the connected state or in the idle state.

    Responses Returned by the CALL:CONN? Query
    Response | Meaning
    1 | The call is in the connected state.
    0 | The call is in the idle state.

    If the call is in one of the transitory states, the query waits until the call reaches the idle state or connected state before returning a value.

  • Call-State-Change Detector Arm Command

    The test set has a call-state-change detector which can be used to temporarily hold the response to a CALL:CONN? query until the call state has moved from idle to connected or vice versa.

    Without the call-state-change detector, the CALL:CONN? query only hangs if the call is in a transitory state. Otherwise, it immediately returns a 1 or 0. Therefore, if a call connection process is started and the CALL:CONN? query is sent before the call state has transitioned from idle to one of the transitory states, the query immediately returns a 0. This indicates that the call is in the idle state (and therefore that the connection attempt failed). In reality, the call likely connected, but not until after the CALL:CONN? query immediately returned a 0.

    When the call-state-change detector is armed during a connection attempt, if the CALL:CONN? query is sent while the call state is still idle, the query waits until the state changes to connected, and then returns a 1.

    The CALL:CONNected:ARM[:IMMediate] command is used to arm this call-state-change detector.

  • Call-State-Change Detector Timeout Command

    If the call-state-change detector is armed and a call connection is attempted but the call state never changes from the idle state, the CALL:CONN? query hangs the bus. This easily happens if the mobile is badly broken, the mobile is not connected to the test set, or no one pushes the send button on the mobile.

    The CALL:CONNected:TIMeout command is used to set the timeout value for the call-state-change detector.

    The timeout timer is started whenever the call-state-change detector is armed, and should be set to the maximum amount of time the control program should wait between arming the detector and the beginning of the connection process (when the call state moves from the idle state). If the timer expires before the call state has moved from the idle or connected state, the call-state-change detector is disarmed, which releases the CALL:CONN? query if it is currently hanging.

Process for Making a Base Station Originated Call

Process for Making a Base Station Originated Call

NOTE
It is not necessary for you to send the CALL:CONN:TIM and CALL:CONN:ARM commands as they are automatically sent by the test set during a base station originated call or base station release.

Programming Example

OUTPUT Test_set;"CALL:PAG:PNUM `0000574016'"! Set paging number
OUTPUT Test_set;"CALL:PAG:REP ON" ! Set paging repeat state
OUTPUT Test_set;"CALL:ORIG" ! Start a base station originated call
OUTPUT Test_set;"CALL:CONN?"  ! Hanging GPIB query
ENTER Test_set;Call_connected      ! Program hangs here until
                                   ! origination passes or fails
IF NOT Call_connected THEN
   OUTPUT Test_set;"CALL:END"
! <put error handler here>
END IF
! Call is connected so proceed with control program

Process for Making a Mobile Station Originated Call

Process for Making a Mobile Station Originated Call

NOTE
The test set cannot originate a call from the mobile station. You must physically dial a number on the mobile station and press send, or send commands to a test bus built into the mobile station. For mobile station originated calls where the call is originated by physically dialing a number (as opposed to using a test bus) ensure that the call-state-change detector timeout time is long enough to allow the number to be dialed.

Programming Example

OUTPUT Test_set;"CALL:CONN:TIM 10"         ! Set timeout time to 10 seconds
OUTPUT Test_set;"CALL:CONN:ARM"            ! Arm the change detector
DISP "Initiate a call from the mobile"
OUTPUT Test_set;"CALL:CONN?"          ! Initiate a call connected state query
ENTER Test_set;Call_connected              ! Program hangs here until
                                           ! origination passes or fails
IF NOT Call_connected THEN
   OUTPUT Test_set;"CALL:END"
! <put error handler here>
END IF
! Call is connected.  Proceed with the control program.

Make a Test Mode Connection

To make a connection between the test set and mobile station in test mode, you must send the appropriate test mode commands to the mobile station to command it to synchronize to the test set's signal and begin transmitting.

You may also want to make a quick power measurement to ensure that the connection has been made.


Step 5: INITiate and FETCh Measurements

Step 5: INITiate and FETCh Measurements

Last updated: June 20, 2006

The following information provides additional details on Step 5 of the Programming Flowchart. This information is applicable to all test applications.

Description

This step involves making measurements on the mobile station.

The test set has multiple signal paths and processors, which means you can make measurements concurrently and reduce test time. Making concurrent measurements involves starting a group of measurements, fetching the results of the measurements as they complete, and then verifying that the results are valid.

In this step you may also choose to make measurements in a more sequential way.

Contents

  • Concurrent Measurement Process
  • Alternative Measurement Process

Concurrent Measurement Process

Process for Making Concurrent Measurements

Start a Set of Concurrent Measurements

The INITiate command is used to start measurements. Each individual measurement can be started using the INITiate command. For starting measurements, the syntax of the INITiate command is as follows:

INITiate:<measurement mnemonic>[:ON]

More than one measurement can be started using a single INITiate command. For example:

OUTPUT Test_set;"INIT:TXP;PFER"

starts the transmit power measurement and the phase and frequency error measurement. These measurements then run concurrently.

Determine if a Measurement Is Done

Use the INITiate:DONE? query command to determine which measurement has completed.

This command is a query only and returns only one response per query. The responses returned and their meanings are shown in the following table:

Responses Returned from INITiate:DONE? Query
Response String | Meaning
<MEASUREMENT1 mnemonic> | MEASUREMENT1 is done.
<MEASUREMENT2 mnemonic> | MEASUREMENT2 is done.
WAIT | There are one or more measurements that are in progress, but none of those measurements are done yet.
NONE | No measurements are in progress.

Once a measurement is reported as being complete via the INITiate:DONE? query it is removed from the done list (it is not reported again). To use the INITiate:DONE? query properly, your control program should immediately fetch a measurement's results once it is reported as being complete.

Obtain a Set of Measurement Results

In order to minimize bus traffic and reduce test time, the test set's measurements are designed to return multiple measured values in response to a single measurement request.

For example, if a transmit power measurement with averaging is initiated there are five measurement results available. These are:

  1. Measurement integrity value
  2. Average value
  3. Minimum value
  4. Maximum value
  5. Standard deviation value

The test set can return the measurement results in a variety of formats to suit your needs using the FETCh? subsystem. The general structure of the FETCh? command is as follows:

FETCh:<measurement mnemonic>:<result format>?

For example, the transmitter power measurement results can be returned as:

Example FETCh? Result Formats
Command | Results Returned
FETC:TXP? | Measurement integrity and average value
FETC:TXP:POW:ALL? | Minimum, maximum, average and standard deviation values
FETC:TXP:POW:AVER? | Average value only
FETC:TXP:POW:MIN? | Minimum value only
FETC:TXP:POW:MAX? | Maximum value only
FETC:TXP:POW:SDEV? | Standard deviation value only
FETC:TXP:INT? | Measurement integrity value only
Concurrent Measurement Process Programming Example

! Start a Set of Concurrent Measurements:
!
OUTPUT Test_set;"INIT:TXP;PFER"
!
! Determine if a Measurement Is Done:
!
LOOP
  OUTPUT Test_set;"INIT:DONE?"
  ENTER Test_set;Meas_done$
!
! Obtain a Set of Measurement Results:
!
  SELECT Meas_done$
    CASE "TXP"
      OUTPUT Test_set;"FETC:TXP:POW?"
      ENTER Test_set;Avg_tx_power
    CASE "PFER"
      OUTPUT Test_set;"FETC:PFER:RMS?"
      ENTER Test_set;Max_rms_phas_er
  END SELECT
EXIT IF Meas_done$="NONE"
END LOOP

Validate Measurement Results

Validating measurement results is extremely important. The test set returns a result if it is capable of making a measurement, even if this result is obtained under adverse conditions.

The measurement integrity indicator is a measurement result and therefore is queried using the FETCh subsystem. A value of 0 indicates that the measurement is valid. A value other than 0 indicates that an error occurred during the measurement process.

Example Integrity Indicators
Value Returned | Description (message also appears on test set)
0 | Normal
1 | No Result Available
2 | Measurement Timeout
5 | Over Range
6 | Under Range
Programming Example

OUTPUT Test_set;"FETC:DTXP?"
ENTER Test_set;Integrity,Avg_dig_pow
IF Integrity=0 THEN
   PRINT "AVG DIG POW= ";Avg_dig_pow
ELSE
   PRINT "DTXP Measurement Error"
   PRINT "DTXP Measurement Integrity is ";Integrity
END IF

Alternative Measurement Process

You may choose to test in a sequential way rather than use the concurrent measurement process.

For instance, instead of using the INIT:DONE? query to determine when a measurement is complete, you may choose to initiate a set of measurements and then simply fetch them sequentially.

Programming Example

OUTPUT Test_set; "INIT:DTXP;MACC"
OUTPUT Test_set; "FETC:DTXP:POW?"
ENTER Test_set;Avg_dig_pow
OUTPUT Test_set; "FETC:MACC:EVM[1]?"
ENTER Test_set;Max_EVM1

In this example, the test set starts both measurements at the same time. However, if the MACC measurement finishes first, the results are not fetched until the DTXP measurement finishes. Therefore, this process requires that you understand the order in which measurements will complete in order to optimize your testing speed.


Step 6: Reconfigure Test Set and Mobile Station Connection Parameters

Step 6: Reconfigure Test Set and Mobile Station Connection Parameters

Last updated: October 28, 2004

The following information provides additional details on Step 6 of the Programming Flowchart. This information is applicable to all test applications.

Description

After performing a set of measurements on the mobile station using the configuration established in step 2, you may want to change this configuration and test the mobile station again. This step involves changing testing conditions such as channel, mobile station transmit power level, or cell power.

Contents

  • Change Channels
  • Change Other Connection Parameters

Change Channels

In a manufacturing environment it is common to test a mobile station on more than one channel. Some or all of the tests may be performed on multiple channels, to verify the mobile station's performance in a range of operating frequencies.

Perform a Handoff (Handover) in Active Cell Mode

If you are operating in active cell mode, to change channels you perform a handoff (handover) to the new channel. The control program sends the commands to initiate the handoff (handover), and then determines whether the transition was successfully completed. This is accomplished using the CALL:STATus? query.

The CALL:STATus? query immediately returns the state of the call at the time the query is received.

Example Responses Returned from the CALL:STAT? Query
Response | Meaning
IDLE | The call is in the Idle state
ALER | The call is in the Alerting transitory state.
HAND | The call is in the Handoff transitory state.
PAG | The call is in the Paging transitory state.
CONN | The call is in the Connected state.

After issuing the commands to perform a handoff (handover), you should send the CALL:STAT? query to verify that the call is still connected before resuming testing.

Process for Performing a Handoff (Handover)

Test Mode Considerations

In test mode, you can either change the test set's frequencies by using the handoff (handover) commands, or directly control the RF generator and RF analyzer.

In either case, you must also send the appropriate test mode commands to the mobile station to move it to the new channel.

Change Other Connection Parameters

You may also choose to change the mobile station transmit power level or cell power, or other connection parameters such as timeslot or timing advance.


Step 7: End Connection

Step 7: End Connection

Last updated: October 28, 2004

The following information provides additional details on Step 7 of the Programming Flowchart. This information is applicable to all test applications.

Description

In this step you release the call (in active cell mode) or end the mobile station transmission (in test mode).

Contents

  • Release the Call in Active Cell Mode
  • End the Mobile Station Test Mode Transmission
  • Partially Preset the Test Set

Release the Call in Active Cell Mode

In active cell mode, you can release the call with the mobile station in one of two ways:

  • Release from the Base Station

  • Release from the Mobile Station

Releasing an Active Call from the Base Station

Process for Releasing an Active Call from the Base Station
Programming Example

OUTPUT Test_set;"CALL:END"        ! Initiate a base station release.
OUTPUT Test_set;"CALL:CONN?" 	 	! Send call connected state query.
ENTER Test_set;Call_connected     ! Program hangs here until state
                                  ! change or timer expires.
IF Call_connected THEN            ! Check if disconnection successful
! <put error handler here>
END IF
! Call is disconnected so proceed with control program

Releasing an Active Call from the Mobile Station

Process for Terminating an Active Call from the Mobile Station

NOTE
The test set cannot initiate a call disconnection from the mobile station. You must manually push the end button on the mobile station or send commands to a test bus built into the mobile station. For a mobile station release where the call is terminated by physically pushing a button on the phone (as opposed to using a test bus) ensure that the call-state-change-detector timeout time is long enough to allow the end button to be pushed.

Programming Example

OUTPUT Test_set;"CALL:CONN:TIM 5" !Set timeout time to 5 seconds.
OUTPUT Test_set;"CALL:CONN:ARM"   !Arm the change detector.
DISP "Terminate the call from the mobile station."
OUTPUT Test_set;"CALL:CONN?" !Initiate call connected state query.
ENTER Test_set;Call_connected     !Program hangs here until state
                                  !change or timer expires.
IF Call_connected THEN            !Check if disconnection successful.
! <put error handler here>
END IF
! Call is disconnected so proceed with control program

End the Mobile Station Test Mode Transmission

In test mode, you must send the necessary test mode commands to end the mobile station transmission.

Partially Preset the Test Set

At this point, it is good practice to partially preset the test set by sending the SYST:PRES3 command. This command stops all measurement and call processing processes, but does not reset all values to default.


cdma2000_prog_getting_started_flowchart_ac

Programming: Getting Started Guide for cdma2000 Mobile Test

Introduction

Last updated: June 20, 2006

The Getting Started Guide is organized around the basic set of tasks a control program normally performs when testing a mobile station in a manufacturing environment.

Click on any step in the flowchart below to learn more about how to program the Agilent Technologies 8960 to perform these tasks.

Programming Flowchart

  • Step 1: Set up the Test Set
  • Step 2: Configure Test Set and Mobile Station Parameters
  • Step 3: Set Measurement Parameters
  • Step 4: Make a connection
  • Step 5: INITiate and FETCh Measurements
  • Step 6: Reconfigure Test Set and Mobile Station Connection Parameters
  • Step 7: End the Connection

You can also use the buttons on each page to navigate between steps, return to the flowchart, or to find more detailed information about each step.

Conventions used in this Getting Started Guide

Throughout this Getting Started Guide the term "test set" refers to an Agilent Technologies 8960 Series 10 wireless communications test set with the E1962B cdma2000 mobile test application installed.

The variable Test_set used in the steps of the Getting Started Guide refers to the test set's GPIB address.

About the Programming Examples Presented in this Guide

Programming Language:

Programming examples presented in this guide are written in the HP BASIC , also known as RMB or Rocky Mountain BASIC, and C programming languages. The use of HP BASIC is not an endorsement of the HP BASIC product.

Line Numbers

All of the programming examples in the guide with line numbers are sections from a control program example available on-line for you to download.

Code that is not part of the download control program example does not have line numbers. This code may represent an alternate method of performing the task or may illustrate a feature not used by the control program example.

Syntax used in Programming Examples:

  • The programming examples use the shortened form of the command syntax to minimize GPIB bus transactions. The shortened form of a command is defined by use of capital letters in the command syntax. For the command syntax:

 RFANalyzer:CONTrol:MEASurement:FREQuency:AUTO?

    the shortened form would be:

 RFAN:CONT:MEAS:FREQ:AUTO?
  • The programming examples do not include optional nodes. Optional nodes in the command syntax are defined by enclosing the node inside the [ ] brackets. For example, the command syntax:

 CALL[:CELL]:POWer[:SAMPlitude] -80dBm

    appears in the programming examples as:

 CALL:POW -80dBm

  • Programming examples make extensive use of compound commands using the ; and the ;: separators. Refer to the on-line information for the definition and use of these command separators.

Complex Commands

Complex commands are used to configure the state and assign values to parameters simultaneously. Complex commands can be used to save programming steps and minimize GPIB bus transactions.

  • The syntax below turns the state of the parameter on.

    OUTPUT Test_set;"SET:CPOW:TIM:STAT ON"

  • The syntax below is used to assign a value to the parameter.

    OUTPUT Test_set;"SET:CPOW:TIM:TIME 10 S"

  • Both of the above actions can be accomplished with one syntax command:

    OUTPUT Test_set;"SET:CPOW:TIM:STIM 10 S"

    The command above sets the parameter state to ON and the value of the parameter to 10 seconds. Note that in this example the optional command mnemonic :STIMe has been included to clarify that this complex command was used to set both the state and the value.

  • This command can be shortened further by removing the optional command mnemonic :STIMe, as shown below.

    OUTPUT Test_set;"SET:CPOW:TIM 10 S"

    This is the format that will be used throughout this guide.


Step 1: Set up the Test Set

Step 1: Set up the Test Set

Last updated: October 28, 2004

This step explains how to:

  • Fully Preset the Test Set
  • Declare Variables, Set Path Losses and Timeouts, Activate GPIB Debugger

Fully Preset the Test Set

To set up the test set, you begin by sending the *RST and *OPC commands along with a global timeout. The *RST command is used to perform a full reset of the test set, returning it to a known state. The *OPC command clears all status registers to assure accurate query functionality.

31       CLEAR SCREEN
40       Testset=714
41 !
42  !*****************************************************************
43  ! PRESET TEST SET
44  !*****************************************************************
45 !
46       OUTPUT Testset;"*RST"
47       OUTPUT Testset;"*OPC?"
48       ENTER Testset;Opc$
49          !

Declare Variables, Set Path Losses and Timeouts, Activate GPIB Debugger

Another useful tool that you may want to turn on at this time is the system command GPIB debugger. When on, error messages appear on the test set's screen when the test set receives an unknown GPIB command.

51  !*****************************************************************
52  ! VARIABLE DECLARATIONS FOR CALL SET UP - MOBILE SPECIFIC
53  !*****************************************************************
54   !
61       Systype$="DIGITAL2000"
70       Band$="USCELLULAR"
80       Channel=384
81       Handoffchan=500
90       Sid=1
100      Nid=1
110      Radio_config$="F3R3"
120      Service_opt$="SO2"
142 !
143  !*****************************************************************
144  ! SET PATH LOSS VALUES
145  !*****************************************************************
146 !
150       Loss_frequency$=" 851 MHZ,896 MHZ"
160       Expected_loss$=" -2,-2"
170       OUTPUT Testset;"SYST:CORR:FREQ";Loss_frequency$
180       OUTPUT Testset;"SYST:CORR";Expected_loss$
200   !
210  !*****************************************************************
211  ! SET UP TIMEOUTS
212  !*****************************************************************
213 !
214       ON TIMEOUT 7,20 CALL Timeout
220 !
233  !*****************************************************************
234  ! TURN ON 8960 GP-IB DEBUGGER - COMMENT OUT WHEN DONE DEBUGGING PROGRAM
235  !*****************************************************************
236 !
237       OUTPUT Testset;"SYST:COMM:GPIB:DEB:STAT ON"


Step 2: Configure Test Set and Mobile Station Parameters

Step 2: Configure Test Set and Mobile Station Parameters

Last updated: October 28, 2004

Configure the Test Set Parameters

The programming example below illustrates several cell configurations along with specifications to the setup of the generated code channels.

252  !*****************************************************************
253  ! SET UP CALL PARAMETERS
254  !*****************************************************************
255 !
256       DISP "Setting up Test Set Parameters"
257       OUTPUT Testset;"DISP:MODE FAST"
258       OUTPUT Testset;"CALL:OPER:MODE CALL"
270       OUTPUT Testset;"CALL:SYST ";Systype$
280       OUTPUT Testset;"CALL:BAND ";Band$
290       OUTPUT Testset;"CALL:CHAN ";Channel
300       OUTPUT Testset;"CALL:POW -50"
310       OUTPUT Testset;"CALL:SID ";Sid
320       OUTPUT Testset;"CALL:NID ";Nid
330       OUTPUT Testset;"CALL:RCON ";Radio_config$
340       OUTPUT Testset;"CALL:SOPT ";Service_opt$
350       OUTPUT Testset;"CALL:PROT PREV6"
360       OUTPUT Testset;"CALL:PAG:DRAT FULL"
370       OUTPUT Testset;"CALL:PIL -7"
380       OUTPUT Testset;"CALL:SYNC -16"
390       OUTPUT Testset;"CALL:PAG -12"
400       OUTPUT Testset;"CALL:FCH -15.6"
401       !
402       OUTPUT Testset;"SYST:SYNC?"
403       ENTER Testset;Syst_sync$
420

Configure the Mobile Station Parameters

There are no mobile station parameters configured in this program example.


Step 3: Set Measurement Parameters

Step 3: Set Measurement Parameters

Last updated: October 29, 2004

This step gives an example of how you can configure measurement parameters. For more information about measurement parameters, refer to the Step 3: Set Measurement Parameters .

10 OUTPUT Testset;"SET:CONT OFF"
20 OUTPUT Testset;"SET:WQU:TIM:STIM 10"
30 OUTPUT Testset;"SET:DAP:TIM:STIM 5"
40 OUTPUT Testset;"SET:CPOW:TIM:STIM 5"
50 !


Step 4: Make a connection

Step 4: Make a connection

Last updated: October 28, 2004

Select an example

The mobile station (MS) must be connected with the test set in order to perform measurements. The origination of this connection can either be the mobile station or the test set. Use one of two sections of code below to fit your testing need.

Test Set initiated connection

The following code queries the test set for the connection status and then stops the program if a connection is not established. A hard handoff is also performed.

513  !*****************************************************************
514  ! CONNECT CALL
515  !*****************************************************************
516 !
526   !***Page the mobile station***
527   !
528       DISP "Paging mobile station..."
529       OUTPUT Testset;"CALL:ORIG"
530       OUTPUT Testset;"CALL:CONN:STAT?"
531       ENTER Testset;Call_connected
532       IF NOT Call_connected THEN
540           PRINT "Call attempt failed"
550           STOP
560       ELSE
570           PRINT "Call connected"
571           PRINT
580       END IF
581       Tot_timer=TIMEDATE

Mobile Station initiated connection

In this case, there is no need to use a timeout or arm the state change detector. These two functions occur automatically when attempting a test set originated call.

1 PRINT "Originate a call on the mobile now."
10 OUTPUT Testset;"CALL:CONN:ARM" !Arm the Call-State-Change Detector
20 OUTPUT Testset;"CALL:CONN?" !Query state
30 ENTER Testset;Callstate
40 IF NOT Callstae THEN
41     PRINT "Call Attempt Failed"
42     STOP
43 ELSE
44     PRINT "Call Connected"
45 END IF
50 !


Step 5: INITiate and FETCh Measurements

Step 5: INITiate and FETCh Measurements

Last updated: October 28, 2004

INITiate measurements and FETCh results

Below are examples of performing tests and retrieving their results. Refer to the Step 5: INITiate and FETCh Measurements for more information about the different measurement results that are available and how to fetch them.

785  !***********************
786  ! WAVEFORM QUALITY TEST*
787  !***********************
788 !
789   !***Specify test parameters for waveform quality test***
790 !
791       Ior=-75
792       Pilot=-7
793       Traffic=-7.4
794 !
796   !***Set up measurement parameters***
797 !
799       OUTPUT Testset;"CALL:POW ";Ior
800       OUTPUT Testset;"CALL:PIL ";Pilot
810       OUTPUT Testset;"CALL:FCH ";Traffic
820   !
830   !***Obtain and display measurement results***
831 !
840       OUTPUT Testset;"SYST:SYNC?"
841       ENTER Testset;Syst_sync$
842       !
843       Wqu_timer=TIMEDATE
850       OUTPUT Testset;"INIT:WQU"
860       LOOP
870           OUTPUT Testset;"INIT:DONE?"
880           ENTER Testset;Meas_done$
890       EXIT IF Meas_done$="WQU"
900       END LOOP
910       OUTPUT Testset;"FETC:WQU?"
920       ENTER Testset;Integrity,Rho,Freq_error,Time_error,Carr_feed,Phase_err,Mag_err,Evm
921 !
930 !***Print Waveform Quality Results
931 !
932       DISP "Waveform Quality Test complete"
933       PRINT "Waveform Quality Test Results:"
934 !
935       PRINT "     Integrity indicator =    ",Integrity
940       Print_results("Rho = ",Rho,"")
941       Print_results("Frequency error = ",Freq_error,"Hz")
942       Print_results("Time error = ",Time_error,"us")
943       Print_results("Carrier feedthrough = ",Carr_feed,"dBc")
950       Print_results("Phase error = ",Phase_err,"deg")
951       Print_results("Magnitude error = ",Mag_err,"%")
952       Print_results("Error vector magnitude = ",Evm,"%")
953       PRINT
980       Wqu_time=PROUND(TIMEDATE-Wqu_timer,-2)
981       Print_results("WQU Test Time= ",Wqu_time,"secs")
982       PRINT
983       !
984       !
985  !***********************
986  ! FRAME ERROR RATE TEST*
987  !***********************
988 !
989   !***Set up measurement parameters***
990   !
991       Ior=-70
993       Pilot=-7
994       Traffic=-15.6
995 !
997       OUTPUT Testset;"CALL:POW ";Ior
998       OUTPUT Testset;"CALL:PIL ";Pilot
999       OUTPUT Testset;"CALL:FCH ";Traffic
1000   !
1001   !***Obtain measurement results***
1002       Fer_timer=TIMEDATE
1003       OUTPUT Testset;"INIT:CFER"
1004       DISP "Measuring FER"
1005       LOOP
1006           OUTPUT Testset;"INIT:DONE?"
1007           ENTER Testset;Meas_done$
1008       EXIT IF Meas_done$="CFER"
1009       END LOOP
1010       OUTPUT Testset;"FETC:CFER?"
1012       ENTER Testset;Integrity,Fer_test,Fer_ratio,Fer_count,Frames_tested
1013   !
1014       SELECT Fer_test
1015       CASE 0
1016           Pass_fail$="PASSED"
1017       CASE 1
1018           Pass_fail$="FAILED"
1019       CASE 2
1020           Pass_fail$="MAXIMUM NUMBER OF FRAMES WERE TESTED"
1021       CASE 3
1022           Pass_fail$="UNKNOWN"
1023       END SELECT
1024       !
1025   !***Print FER Results***
1026 !
1027       DISP "FER Test complete"
1028       !
1029       PRINT "Frame Error Rate Test Results:"
1030 !
1031       PRINT "     Integrity indicator =    ",Integrity
1032       Print_res_str("FER Test Results",Pass_fail$)
1033       Print_results("FER Ratio",Fer_ratio,"%")
1034       Print_results("FER Errors Count",Fer_count,"frames")
1035       Print_results("Frames Tested",Frames_tested,"")
1036       PRINT
1037       !
1039       Fer_time=PROUND(TIMEDATE-Fer_timer,-2)
1040       Print_results("FER Test Time= ",Fer_time,"secs")
1041       PRINT
1042       !
1043  !***************
1044  !Max Power Test*
1045  !***************
1046 !
1047   !***Set up measurement parameters***
1048   !
1049       Ior=-70
1051       Pilot=-7
1052       Traffic=-7.4
1053 !
1055       OUTPUT Testset;"CALL:POW ";Ior
1056       OUTPUT Testset;"CALL:PIL ";Pilot
1057       OUTPUT Testset;"CALL:FCH ";Traffic
1058       OUTPUT Testset;"CALL:CLPC:REV:MODE UP"
1060   !***Obtain measurement results***
1061   !
1062       WAIT 1!Settling time
1063       Max_timer=TIMEDATE
1064       OUTPUT Testset;"INIT:DAP"
1065       LOOP
1066           OUTPUT Testset;"INIT:DONE?"
1067           ENTER Testset;Meas_done$
1068       EXIT IF Meas_done$="DAP"
1069       END LOOP
1070       OUTPUT Testset;"FETC:DAP?"
1071       ENTER Testset;Integrity,Avg_power_dbm
1072       !
1073       Avg_power_dbw=Avg_power_dbm-30
1074   !
1075   !***Display measurements if the mobile station did not drop the call***
1076   !
1077       OUTPUT Testset;"CALL:STAT?"
1078       ENTER Testset;Call_status$
1079       IF Call_status$<>"CONN" THEN
1080           PRINT "Mobile station dropped call, invalid results"
1081       END IF
1082       !
1083   !***Print Max Power Test Results
1084   !
1085       DISP "Max Power Test complete"
1086       PRINT "Max Power Test Results:"
1087 !
1088 !
1089       PRINT "     Integrity indicator =    ",Integrity
1090       Print_results("Maximum Power dBm:",Avg_power_dbm,"dBm")
1091       Print_results("Maximum Power dBW:",Avg_power_dbw,"dBW")
1095       PRINT
1097      !
1098       Max_time=PROUND(TIMEDATE-Max_timer,-2)
1099       Print_results("Max Power Test Time= ",Max_time,"secs")
1100       PRINT
1101       !
1102   !***Post Test clean up***
1103   !
1104       OUTPUT Testset;"CALL:CLPC:REV:MODE ACT"
1105 !
1106  !*******************
1107  !Minimum Power Test*
1108  !*******************
1109 !
1110 !
1111   !***Set up measurement parameters***
1112   !
1113       Ior=-25
1114       Pilot=-7
1115       Traffic=-7.4
1116 !
1118       OUTPUT Testset;"CALL:CONN:DROP:TIM 0"
1119       OUTPUT Testset;"CALL:POW ";Ior
1120       OUTPUT Testset;"CALL:PIL ";Pilot
1121       OUTPUT Testset;"CALL:FCH ";Traffic
1122       OUTPUT Testset;"CALL:CLPC:REV:MODE DOWN"
1124   !
1125   !***Obtain measurement results***
1126   !
1127       WAIT 1
1128       Min_timer=TIMEDATE
1129       OUTPUT Testset;"INIT:CPOW"
1130       LOOP
1131           OUTPUT Testset;"INIT:DONE?"
1132           ENTER Testset;Meas_done$
1133       EXIT IF Meas_done$="CPOW"
1134       END LOOP
1135       !
1136       OUTPUT Testset;"FETC:CPOW?"
1137       ENTER Testset;Integrity,Channel_power
1138           !
1139                !
1140            IF Integrity=6 THEN
1142                OUTPUT Testset;"RFAN:CONT:POW:AUTO OFF"
1143                OUTPUT Testset;"RFAN:MAN:POW ";INT(Channel_power);" DBM"
1145            END IF
1146       EXIT IF Meas_done$="CPOW" AND Integrity=0
1147       END LOOP
1148       !
1149         !
1150    ***Print measurement results
1151       !
1152       DISP "Min Power Test complete"
1153       PRINT "Min Power Test Results:"
1154       PRINT "     Integrity indicator =    ",Integrity
1156       Print_results("Maximum Power dBm:",Channel_power,"dBm/1.23 MHz")
1157       PRINT
1158       Min_time=PROUND(TIMEDATE-Min_timer,-2)
1161       Print_results("Min Power Test Time= ",Min_time,"secs")
1162       PRINT
1163       !
1164   !***Post Minimum Power Test Cleanup***
1165   !
1166       OUTPUT Testset;"CALL:CLPC:REV:MODE ACT"
1167       OUTPUT Testset;"CALL:CONN:DROP:TIM:STAT 1"
1168       OUTPUT Testset;"RFAN:CONT:POW:AUTO ON"


Step 6: Reconfigure Test Set and Mobile Station Connection Parameters

Step 6: Reconfigure Test Set and Mobile Station Connection Parameters

Last updated: October 28, 2004

Reconfigure the Test Set

The example below contains the code appropriate for handing the call off to a different channel.

600    !***Set up a hard handoff***
610       OUTPUT Testset;"CALL:SET:BAND USC"
620       OUTPUT Testset;"CALL:SET:CHAN ";Handoffchan
630 !
640    !***Perform a hard handoff***
650       OUTPUT Testset;"CALL:HAND"
660       OUTPUT Testset;"CALL:CONN:STAT?"
670       ENTER Testset;Call_connected
680       IF NOT Call_connected THEN
690           DISP "Handoff attempt failed, program stopped"
700           STOP
710       ELSE
720           PRINT "Handoff completed"
730           DISP "Call connected"
731           PRINT
740       END IF
784   !

Reconfigure the MS

There are no MS parameters reconfigured in this program example.


Step 7: End the Connection

Step 7: End the Connection

Last updated: October 28, 2004

End the Connection

The CALL:END command ends the mobile connection. Subroutines which are called in the program are also shown.

1172  !****************************
1173  ! End of All Testing
1174  !****************************
1175 !
1176 !***End Call and Return to default call processing settings***
1177 !
1178       OUTPUT Testset;"CALL:POW:DIG2000 -50"
1179       OUTPUT Testset;"CALL:END"
1180       OUTPUT Testset;"CALL:STAT:STAT?"
1181       ENTER Testset;Call_status$
1182       PRINT "Call Ended, Status:",Call_status$
1183       Tot_time=PROUND(TIMEDATE-Tot_timer,-2)
1184       PRINT
1185       Print_results("Test Time= ",Tot_time,"secs")
1186       PRINT
1187       !
1188   !***End Program***
1189  End_program: ! Secondary timeout handler
1190               DISP "End of Program"
1191               END
1192  !
1193  !********************
1194  ! Subroutine Section*
1195  !********************
1196  !
1197  Timeout: SUB Timeout
1198           PRINT "Program timed out"
1199           CLEAR 7
1200           CLEAR 714
1201           STOP
1202       SUBEND
1203  Print_results: SUB Print_results(Meas_name$,Res1,Units$)
1204 !
1205           PRINT USING "5X,20A,5X,M4D.2D,1X,5A";Meas_name$;Res1;Units$
1206 !
1404       SUBEND
1414  Print_res_str: SUB Print_res_str(String_name$,Results$)
1415 !
1424           PRINT USING "5X,20A,5X,20A";String_name$;Results$
1425 !
1444       SUBEND


Programming a Gated Power Measurement

Programming a Gated Power Measurement

Last updated: October 28, 2004

This section provides an example of how to make a gated power measurement via GPIB.

The basic procedure to measure gated power is as follows:

  1. Make a call using IS-95 or IS-2000 system type with F1R1 (radio configuration 1) or F2R2 (radio configuration 2). See CALL[:CELL]:RCONfig .
  2. Select a loopback service option (SO2, SO9, or SO55) .
  3. Select eighth rate data (see CALL[:CELL[1]]:TRAFfic[:FORWard]:DRATe ).
  4. Configure the gated power measurement setup parameters using the SETup:GPOWer subsystem.
  5. Start the waveform quality measurement using the INITiate subsystem.
  6. Use the FETCh:GPOWer command to obtain gated power measurement results.

NOTE
Gated power measurement display trace data is available using the FETCh:GPOWer:TRACe? command.

Programming Example

10    RE-SAVE "c:\roadhog\programs\gated_power.txt"
20    !This program measures gated power
30    !See "Standby Output Power and Gated Output Power" in TIA/EIA-98-D for specifications
and standards
40    CLEAR SCREEN
50    A=714
60    !***Specify call parameters***
70    Systype$="DIGITAL2000" !Cell System Type
80    Band$="USC" !Frequency Band
90    Channel=384 !RF Channel
100   Sid=1 !System Identification
110   Nid=1 !Network Identification
120   Radio_config$="F2R2" !Radio Configuration 1 or 2 is required for Gated Power
measurements
130   Service_opt$="SO9" !Service Option
150   !
160   !***Specify test parameters***
170   Loss_frequency$="1900 MHZ,1945 MHZ" !Reverse channel, forward channel frequencies for
amplitude offset (path loss)
180   Expected_loss$="-2,-2" !Path loss at reverse channel, forward channel frequencies
190   Ior=-75 !Cell power for gated power testing
200   Pilot=-7 !Pilot channel power level for gated power testing
210   Traffic=-7.4 !Traffic channel power level for gated power testing
220   Data_pnt=300
230   !
240   ON TIMEOUT 7,20 CALL Timeout ! Calls "Timeout" routine
250   OUTPUT A;"SETUP:CFER:TIMEOUT:STIME 10 S" !Sets FER measurement timeout to 10 seconds
260   OUTPUT A;"SYST:COMM:GPIB:DEB:STAT ON" !Turns debug state on
270   !
280   !***Set up path loss***
290   OUTPUT A;"SYSTEM:CORRECTION:SFREQUENCY ";Loss_frequency$ !Enters frequencies in
Amplitude Offset table
300   OUTPUT A;"SYSTEM:CORRECTION:SGAIN ";Expected_loss$ !Enters loss values in Amplitude
Offset table
310   !
320   !***Set up call parameters***
330   OUTPUT A;"CALL:OPER:MODE CALL" !Sets Operating Mode to Active Cell
340   OUTPUT A;"CALL:SYSTEM ";Systype$ !Sets System Type
350   OUTPUT A;"CALL:BAND ";Band$ !Sets Cell Band for selected System Type
360   OUTPUT A;"CALL:CHAN ";Channel ! Sets Channel for selected System Type and Cell Band
370   OUTPUT A;"CALL:POWER -50" !Sets and turns on Cell Power for call setup
380   OUTPUT A;"CALL:SID ";Sid! Sets System Identification
390   OUTPUT A;"CALL:NID ";Nid! Sets Network Identification
400   OUTPUT A;"CALL:RCON ";Radio_config$ !Sets Radio Configuration
410   OUTPUT A;"CALL:SOPTION ";Service_opt$ !Sets service option for selected System Type and
Radio Configuration
420   OUTPUT A;"CALL:PROT PREV6" !Sets Protocol Revision for the selected System Type
430   OUTPUT A;"CALL:PAG:DRAT FULL" !Sets Paging channel data rate to full rate
440   OUTPUT A;"CALL:TRAFFIC:DRATE EIGHTH" !Sets traffic/fundamental channel data rate to
eighth
450   OUTPUT A;"CALL:PIL -7"    !Sets Pilot to default
460   OUTPUT A;"CALL:SYNC -16"  !Sets Sync to default
470   OUTPUT A;"CALL:PAG -12"   !Sets Paging to default
480   OUTPUT A;"CALL:FCH -15.6" !Sets Traffic to default
490   !
500   PRINT "Turn on mobile station...press continue when it has found service and registered"
510   PAUSE
520   CLEAR SCREEN
530   OUTPUT A;"CALL:REG:TIMER:STATE OFF" !Turns timer-based registrations off
540   WAIT 2 !Waits 2 seconds for any timer-based registrations to clear out
550   !
560   !***Page the mobile station***
570   DISP "Paging mobile station..."
580   OUTPUT A;"CALL:ORIG" !Pages the mobile station
590   OUTPUT A;"CALL:CONNECTED:STATE?" !Queries for connected/idle state...hangs until state
change detector is disarmed
600   ENTER A;Call_connected
610   IF NOT Call_connected THEN
620     DISP "Call attempt failed"
630     STOP
640   ELSE
650     DISP "Call connected"
660   END IF
670   !
680   !***Set up measurement parameters***
690   OUTPUT A;"SETUP:GPOWER:CONTINUOUS OFF" !Sets trigger arm state to single
700   OUTPUT A;"CALL:POW ";Ior ! Sets Cell Power for gated power measurement
710   OUTPUT A;"CALL:PIL ";Pilot !Sets Pilot channel level
720   OUTPUT A;"CALL:FCH ";Traffic !Sets Traffic channel level
730   !
740   !***Obtain pass/fail measurement results***
750   OUTPUT A;"INITIATE:GPOWER" !Initiates a gated power measurement
760   DISP "Measuring gated power"
770   OUTPUT A;"FETCh:GPOWER?" !Queries the test set for gated power measurement results
780   DISP "Gated Power measurement completed"
790   ENTER A;Integrity,Passfail
800   SELECT Passfail !Assign pass/fail results to a string
810   CASE 0
820     Pass_fail$="PASSED"
830   CASE 1
840     Pass_fail$="FAILED"
850   END SELECT
860   PRINT "Integrity indicator = ";Integrity
870   PRINT "Gated power test results = ";Pass_fail$
880   !
990   OUTPUT A;"CALL:END" !Ends the call
1000  END
1010 Timeout: SUB Timeout    ! Global timeout handler
1020    PRINT "Program timed out"
1030    CLEAR 7
1040    CLEAR 714
1050  SUBEND

Related Topics

Gated Power Measurement Description

Measuring Gated Power

Gated Power Measurement Troubleshooting

Control Program Example

SETup:GPOWer

FETCh:GPOWer

INITiate

READ

ABORt


Programming a Handoff Waveform Quality Measurement

Programming a Handoff Waveform Quality Measurement

Last updated: October 28, 2004

This section provides an example of how to make a handoff waveform quality measurement via GPIB.

The following program example assumes that the mobile station's antenna output is connected to the RF IN/OUT connector, and the mobile station has found service.

The basic procedure to measure handoff waveform quality is as follows:

  1. Make a call using Radio Configuration 3 (F3R3) and above.
  2. Configure the handoff waveform quality measurement setup parameters using the SETup:HWQuality subsystem.
  3. Start the handoff waveform quality measurement using the INITiate subsystem.
  4. Use the FETCh:HWQuality command to obtain handoff waveform quality measurement results.

Programming Example

10    !This program measures handoff waveform quality
20    !Refer to "Waveform Quality and Frequency Accuracy" in EIA/TIA-IS-98D
30    !for standards and specifications
40    CLEAR SCREEN
50    A=714
60    !***Specify call parameters***
70    Systype$="DIGITAL2000" !Cell System Type
80    Band$="USCELLULAR" !Cell band
90    Channel=29 !RF Channel
100   Sid=2236 !System Identification
110   Nid=65535 !Network Identification
120   Radio_config$="F3R3" !For handoff waveform quality,
130                        !radio configuration must be F3R3 or F4R3
140   Service_opt$="SO2"   !Loopback service option
150   !
160   !***Specify test parameters***
170   !Reverse channel, forward channel
180   !frequencies for amplitude offset (path loss)
190   Loss_frequency$="851 MHZ,896 MHZ"
200   !
210   !Path loss at reverse channel, forward channel frequencies
220   Expected_loss$="-2,-2"
230   Ior=-50!Cell power
240   Pilot=-7 !Pilot channel power level
250   Traffic=-7.4 !Traffic channel power level
260   !
270   ON TIMEOUT 7,20 CALL Timeout ! Calls "Timeout" routine
280   !Sets waveform quality measurement timeout to 10 seconds
290   OUTPUT A;"SETUP:WQU:TIMEOUT:STIME 10 S"
300   OUTPUT A;"SYST:COMM:GPIB:DEB:STAT ON"!Turns debug state on
310   !
320   !***Set up call parameters***
330   OUTPUT A;"CALL:OPER:MODE CALL" !Sets Operating Mode to Active Cell
340   OUTPUT A;"CALL:SYSTEM ";Systype$ !Sets System Type
350   OUTPUT A;"CALL:BAND ";Band$ !Sets Cell Band for selected System Type
360   !Sets RF Channel for selected System Type and Cell Band
370   OUTPUT A;"CALL:CHAN ";Channel
380   OUTPUT A;"CALL:POW -35" !Sets and turns on Cell Power
390   OUTPUT A;"CALL:SID ";Sid! Sets System Identification
400   OUTPUT A;"CALL:NID ";Nid! Sets Network Identification
410   OUTPUT A;"CALL:RCON ";Radio_config$!Sets Radio configuration
420   !Set service option for selected System Type and Radio Configuration
430   OUTPUT A;"CALL:SOPTION ";Service_opt$
440   !Sets Protocol Revision for the selected System Type
450   OUTPUT A;"CALL:PROT PREV6"
460   OUTPUT A;"CALL:PAG:DRAT FULL" !Sets Paging data rate to full rate
470   OUTPUT A;"CALL:PIL -7"    !Sets pilot to default
480   OUTPUT A;"CALL:SYNC -16"  !Sets sync to default
490   OUTPUT A;"CALL:PAG -12"   !Sets paging to default
500   OUTPUT A;"CALL:FCH -15.6" !Sets traffic to default
510   !
520   PRINT "Turn on mobile station."
530   PRINT "Press continue when it has found service and registered"
540   PAUSE
550   CLEAR SCREEN
560   !Turn off timer-based registrations
570   OUTPUT A;"CALL:REGISTER:TIMER:STATE OFF"
580   WAIT 2 ! Waits for any timer-based registrations to clear out
590   !
600   !***Page the mobile station***
610   DISP "Paging mobile station..."
620   OUTPUT A;"CALL:ORIG" !Pages the mobile station
630   !Queries for connected/idle state.
640   !Hangs until state change detector is disarmed
650   OUTPUT A;"CALL:CONNECTED:STATE?"
660   ENTER A;Call_connected
670   IF NOT Call_connected THEN
680     DISP "Call attempt failed"
690     STOP
700   ELSE
710     DISP "Call connected"
720   END IF
730   !
740   !***Set up measurement parameters***
750   !Sets trigger arm state to single
760   OUTPUT A;"SETUP:WQUALITY:CONTINUOUS OFF"
770   !Sets Cell Power for the selected System Type
780   OUTPUT A;"CALL:POW ";Ior
790   !Alternating up/down power control bits
800   OUTPUT A;"CALL:CLPCONTROL:REVERSE:MODE ALT"
810   OUTPUT A;"CALL:PIL ";Pilot !Sets Pilot channel level
820   OUTPUT A;"CALL:FCH ";Traffic !Sets Fundamental (Traffic) channel level
830   OUTPUT A;"SETUP:WQUALITY:CDPOWER:IQINactive:LIMIT -23"
840   !
850   !***Obtain and display handoff waveform quality measurement results***
860   WAIT 1
870   OUTPUT A;"INITIATE:HWQUALITY" !Initiates a Waveform Quality measurement
880   !Queries the test set for waveform quality measurement results
890   OUTPUT A;"FETCh:HWQUALITY?"
900   ENTER A;Integrity,Rho,Freq_error,Time_error,Carr_feed,Phase_err,Mag_err
910   PRINT "Integrity indicator = ";Integrity
920   PRINT "Rho = ";Rho
930   PRINT "Frequency error = ";Freq_error
940   PRINT "Time error = ";Time_error
950   PRINT "Carrier feedthrough = ";Carr_feed
960   PRINT "Phase error = ";Phase_err
970   PRINT "Magnitude error = ";Mag_err
980   !
990   DISP "Test complete"
1000  !
1010  !***Return to default call processing settings***
1020  !Return to active power control bits
1030  OUTPUT A;"CALL:CLPCONTROL:REVERSE:MODE ACTIVE"
1040  OUTPUT A;"CALL:POW:DIG2000 -50"! Returns cell power to -50 dBm/1.23 MHz
1050  OUTPUT A;"CALL:END"
1060  END
1070 Timeout: SUB Timeout    ! Global timeout handler (from Step 1)
1080    PRINT "Program timed out"
1090    CLEAR 7
1100    CLEAR 714
1110  SUBEND

Related Topics

Handoff Waveform Quality Measurement Description

Measuring Handoff Waveform Quality

Handoff Waveform Quality Measurement Troubleshooting

Control Program Example

SETup:HWQuality

FETCh:HWQuality

INITiate

READ

ABORt


Invalid Measurement Results

Invalid Measurement Results

Last updated: October 28, 2004

Description

Invalid measurement results are returned by the test set when conditions such as signal level are not within the present measurement range. Three different invalid measurement results are provided in order to help you understand the condition that caused the invalid result.

  • 9.9E+37 = INFinity (Infinity)
  • -9.9E+37 = NINF (Negative Infinity)
  • 9.91E+37 = NAN (Not A Number)

9.9E+37 (INFinity)

9.9E+37 is returned by the test set when the measurement is out of range and results are far above the present measurement range.

-9.9E+37 (NINFinity)

-9.91E+37 is returned by the test set when the measurement is out of range and results are far below the present measurement range.

9.91E+37 (NAN)

9.91E+37 is returned by the test set when the measurement is out of range but it can not be determined if measurement results are far above, or far below the measurement range.

If a measurement exceeds its measurement timeout value before a valid result is determined, 9.91E+37 is returned.

FETCH? and READ? Invalid Results

When a FETCH? or READ? query is performed on a measurement with invalid results, the integrity indicator returns a value of 1, indicating No Result Available.

Manual Users Invalid Results

Manual users will generally see four dashes , "----" on the test set display. When the measurement timeout value has been exceeded, "Measurement Timeout" is displayed as well as the four dashes.


Measurement Progress Report

Measurement Progress Report

Last updated: October 28, 2004

Description

The measurement progress report is a query of how far along a multi-measurement cycle has progressed. When the multi-measurement count is greater than one, the measurement progress report will indicate the number of measurements that have completed. The returned value will be the last update and not the actual number, because the value is updated periodically and not for each multi-measurement cycle. Every measurement has the measurement progress report available.

Example

OUTPUT 714;"FETCH:DAPOWER:ICOUNT?" !Returns the approximate number of
                                  !multi-measurement cycles completed during a
                                  !multi-measurement count cycle

Related Topics

Statistical Measurement Results


Measurement Event Synchronization

Measurement Event Synchronization

Last updated: October 28, 2004

Description

Measurement event synchronization saves time by controlling the communication between the controller, the test set, and the mobile station, so that no device does something before it is supposed to (which can cause errors or do something well after it could have). Because some measurements can run concurrently, it is necessary that the control program know when individual measurement results are available.

Measurement event synchronization is accomplished using the INITiate subsystem's command INITiate:DONE? or the STATus:OPERation:NMRReady status registers.

INITiate:DONE?

The INITiate:DONE? query returns a string that indicates which, if any, measurements have completed since the last INITiate command was received. This query is useful when performing measurements concurrently, and is generally used within a loop, with a loop exit when all measurements have been obtained.The INITiate:DONE? query returns a measurement name, "WAIT," or "NONE" after each pass through the loop. See INITiate:DONE? and INITiate Programming Examples (how INIT commands are used) for more details about this query.

NOTE
The INIT:DONE? command is only useful when performing concurrent testing. When initiating only one measurement at a time, simply send the INITiate command immediately followed by the FETCh command to retrieve the results.

STATUS:OPERATION:NMRREADY

The STATus:OPERation:NMRReady command allows the program to immediately branch to the next operation or command without continuing through a loop as in INITiate:DONE?. See STATus:OPERation:NMRReady Register Bit Assignments for more details about this command.

You must enable the following so that as soon as the enabled NMRReady bit is true the program moves on.

  • Positive or negative transition filter. See Transition Filters .
  • STATus:OPERation:NMRReady bit for the measurement desired.
  • STATus:OPERation bit (512 for NMRReady). See Status Subsystem Overview .
  • Service Request Enabling (*SRE 128 for NMRReady). See Status Subsystem Overview .

The STATus:OPERation:NMRReady Register Bit Assignments status register provides status reporting on the cdma2000 measurements.

NOTE
The following program uses the E1960A GSM Mobile Test Application Bit Error Rate measurement for the example. Refer to STATus:OPERation:NMRReady Register Bit Assignments for bit assignments for other Test Applications.

Generating a Service Request (SRQ) Interrupt - Bit Error Rate NMRR

The following example illustrates the use of the STATus subsystem to generate a service request when a BERR measurement has completed. This code assumes a call is already connected and the BERR measurement is setup (mobile station must be in loopback type A or B).

10  OUTPUT 714;"STATUS:OPERATION:NMRREADY:PTR 256" !Enable positive transition
20                                                 !filter on fast BER bit.
30  OUTPUT 714;"STATUS:OPERATION:NMRREADY:ENABLE 256" !Enable the fast BER Bit to
40                                                    !generate a summary message.
50  OUTPUT 714;"STATUS:OPERATION:ENABLE 512" !Enable the Operation summary bit to
60                                           !generate a summary message.
70  OUTPUT 714;"*SRE 128" !Enable the service request enable register to generate SRQ.
80  OUTPUT 714;"*CLS" !Clear all status data structures.
90  ON INTR 7,15 CALL Meas_complete !Define interrupt-initiated branch with a priority
100                                 !of 15 (highest)
110 ENABLE INTR 7;2 !Enable interrupt on interface card 7 with a bit mask
120                 !(for interface's interrupt-enable register) of 2.
130 OUTPUT 714;"SETUP:FBER:CONTINUOUS OFF;:INITIATE:FBERROR" !Initiate a single
140                                                          !fast BER test.
150 LOOP
160 DISP "Waiting for BERR test to complete"
170 WAIT .1 !"Dummy" loop
180 END LOOP
190 !Instead of a "dummy" loop, controlling application could be performing setups,
200 !making measurements, etc.
210 END
220 SUB Meas_complete
230 DISP "BER test complete, OK to FETCh results now"
240 Clear_interrupt=SPOLL(714) !Clear the RQS message in the status byte register.
250 STOP
260 SUBEND

Operating Considerations

Only one indicator is returned per query.

All active measurements must be set to single trigger mode. This ensures that when a measurement completes it remains in the "DONE" state rather than restarting. Sending the "*RST" command at the beginning of your test code or using the "SETup:CONTinuous:OFF" command during measurement setup are ways to set trigger to single for all measurements.

Related Topics

Test System Synchronization Overview


Programming a Maximum/Minimum Power Measurement

Programming a Maximum/Minimum Power Measurement

Last updated: October 28, 2004

This section provides an example program of how to use the maximum/minimum power measurement via GPIB.

The following program example assumes that the mobile station's antenna output is connected to the RF IN/OUT connector, and the mobile station has found service.

The basic procedure to make the maximum/minimum power measurement is as follows:

  1. Make a call. For information on configuring the test set for a call, see Step 4: Make a connection .
  2. Set up the access parameters as needed using the CALL:APARameter commands
  3. Configure the maximum/minimum power setup parameters using the SETup:CMMPower subsystem.
  4. Start the maximum/minimum power measurement using the INITiate subsystem.
  5. Use the FETCh:CMMPower command to obtain the measurement results.

Programming Example

10 Mm_pow: !
20      PRINT "Configure  maximum and minimum power measurement parameters"
30      ! Configure the parameters if neccessary              !
40      ! Here give an example to follow, the value should be adjusted according the
50      ! mobile phone actual parameters. If nothing is changed, the default value will
60      ! be used. No GPIB command will be called.
70      OUTPUT Testset;"SETUP:CMMPower:PILot:LEVel:MAXimum 7 DB"
80      PRINT "Start measure the Maximum / Minmum Power measurement"
90      !***Obtain measurement results***
100     !
110     OUTPUT Testset;"INITIATE:CMMPOWER"  !Initiates a channel power measurement1
120     OUTPUT Testset;"FETCh:CMMPOWER?"
130     ENTER Testset;Integrity,Max_pow,Min_pow
140     DISP "Test complete"
150     !***Display measurement results
160     Print_results("Integrity indicator = ",Integrity,"")
170     Print_results("Maximum Power dBm:",Max_pow,"dBm")
180     Print_results("Minimum Power dBm:",Min_pow,"dBm/1.23 MHz")
190     DISP "Test complete"
200     OUTPUT Testset;"CALL:END"               !Ends the call
210     RETURN
220     Print_results: SUB Print_results(Meas_name$,Res1,Units$)
230     PRINT USING "5X,20A,5X,M4D.2D,1X,15A";Meas_name$;Res1;Units$
240     SUBEND

Returned Values

This query returns an integrity indicator followed by the maximum power result and the minimum power result.

Related Topics

Maximum/Minimum Power Measurement Description


Programming a Multi-Tone Audio Measurement

Programming a Multi-Tone Audio Measurement

Last updated: July 28, 2005

  • General Programming Procedure
  • Programming Example for a Downlink Multi-Tone Audio Measurement
  • Programming Example for an Uplink Multi-Tone Audio Measurement

General Programming Procedure

  1. Make the proper hardware connection.
  2. Set up the call parameters and establish a voice call (such as SO1, SO3, SO17, or SO32769).
  3. Set the Voice SO Mode to MULTitone for downlink test or NFRames for uplink test using CALL[:CELL[1]]:FCHannel[:FORWard]:SOURce (for IS-2000 system) or CALL[:CELL[1]]:TRAFfic[:FORWard]:SOURce (for IS-95 system).
  4. Set up the measurement parameters as required (such as multi-tone audio measurement mode, multi-tone audio generator's frequencies/levels, etc.) using the SETup:CMAudio commands.
  5. Initiate the multi-tone audio measurement using the INITiate<:measurement mnemonic>[:ON] . The <measurement mnemonic> for multi-tone audio measurements is CMAudio.
  6. Use the FETCh:CMAudio commands to obtain the measurement results.

Programming Example for a Downlink Multi-Tone Audio Measurement

This example is to test the mobile station's speaker quality using the Multi-Tone Audio measurements in Downlink mode.

The following procedure assumes that the mobile station's antenna output is connected to the test set's front-panel RF IN/OUT connector. The analog audio from the mobile phone speaker is fed back to the test set's AUDIO IN port. The mobile station supports SO17 service option.

10 !The simple test executive allows you to do downlink multitone     measurement20 ! 36       COM Testset37 !40       Testset=714! Set "Testset" to equal GPIB address of 896041       !42       CLEAR SCREEN60       !61  !**************************************************************62  ! SET UP GPIB TIMEOUT63  !**************************************************************64  !65   ON TIMEOUT 7,30 CALL Timeout! Calls "Timeout" routine73  !76  !**************************************************************77  ! VARIABLE DECLARATIONS FOR CALL SET UP - MOBILE SPECIFIC78  !**************************************************************79       Systype$="DIGITAL2000"!Cell System Type80       Band$="USPCs"  !PCS band81       Channel=525    !RF Channelfor call setup82       Sid=2          !System Identification84       Nid=1          !Network Identification85       Radio_config$="F2R2"!Radio Configuration86       Service_opt$="SO17"!Voice Service Option87                                 !138  !*************************************************************139  ! Test Executive140  !*************************************************************141 !142       GOSUB Preset_test_set143       GOSUB Set_call_parms146       GOSUB Register151       GOSUB Connect155       GOSUB Multitone_down157       GOTO End_program!Jumps to end of program222 !223 !**************************************************************224 ! PRESET TEST SET225 !**************************************************************226  Preset_test_set:!227       !228       PRINT "Reset 8960"229       OUTPUT Testset;"*RST"!RESET TEST SET230       OUTPUT Testset;"*OPC?"231       ENTER Testset;Opc$232       RETURN233 !247 !***************************************************************253 ! SET UP CALL PARAMETERS254 !***************************************************************255  Set_call_parms:!256 !257       PRINT "Setup Network/Basestation Parameter"270       OUTPUT Testset;"CALL:SYSTEM ";Systype$!Sets System Type280       OUTPUT Testset;"CALL:BAND ";Band$            !Sets Cell Band for selected System Type290       OUTPUT Testset;"CALL:CHAN ";Channel            !Sets RF Channel for selected System Type and Cell Band300       OUTPUT Testset;"CALL:POW -55"!Sets and turns on Cell Power310       OUTPUT Testset;"CALL:SID ";Sid!Sets System Identification320       OUTPUT Testset;"CALL:NID ";Nid!Sets Network Identification330       OUTPUT Testset;"CALL:CELL:RCONFIG ";Radio_config$341       OUTPUT Testset;"CALL:SOPTION ";Service_opt$            !Sets service option for selected System Type              and Radio Configuration350       OUTPUT Testset;"CALL:PAG:DRAT FULL"            !Sets Paging data rate to full rate370       OUTPUT Testset;"CALL:PIL -7"!Sets pilot to default380       OUTPUT Testset;"CALL:SYNC -16"!Sets sync to default390       OUTPUT Testset;"CALL:PAG -12"!Sets paging to default400       RETURN                     !Sub-routine return420 !434 !***************************************************************435 ! REGISTER MOBILE436 !***************************************************************437  Register:!438 !439       PRINT "Pls. Power On MS, Then Press F2 Continue"441       PAUSE442       PRINT "Register MS on 8960"443       OUTPUT Testset;"CALL:MS:REPORTED:CLEAR:ALL"            !Clear MS reported database444       OUTPUT Testset;"CALL:REG"445       Reg_timer=TIMEDATE446       LOOP                        448           OUTPUT Testset;"CALL:MS:REP:ESN:HEX?"449           ENTER Testset;Esn$450           Reg_time=TIMEDATE-Reg_timer469       EXIT IF LEN(Esn$)>3 OR Reg_time>30470       END LOOP472       IF Reg_time>30 THEN        473           PRINT "Registration Timed Out, Check Phone Setup"474           GOTO End_program475       END IF477       PRINT "Mobile Registration Complete"478       PRINT482 !483  !**************************************************************484  ! PRINT MOBILE REGISTRATION INFO485  !**************************************************************486 !487  !Read registration information488 !489       OUTPUT Testset;"CALL:MS:REP:ESN:HEX?"490       ENTER Testset;Esn$491       OUTPUT Testset;"CALL:MS:REP:MCC?"492       ENTER Testset;Mcc$493       OUTPUT Testset;"CALL:MS:REP:MNC?"494       ENTER Testset;Mnc$495       OUTPUT Testset;"CALL:MS:REP:MSIN?"496       ENTER Testset;Msin$497       OUTPUT Testset;"CALL:MS:REP:BCLASS?"498       ENTER Testset;Bclass$499       OUTPUT Testset;"CALL:MS:REP:EIRP?"500       ENTER Testset;Eirp$501       OUTPUT Testset;"CALL:MS:REP:OPER:MODE?"502       ENTER Testset;Opmode$503       OUTPUT Testset;"CALL:MS:REP:PREV?"504       ENTER Testset;Prev$507       PRINT "Mobile Registration Information:"508       PRINT509       Print_res_str("Mobile ESN:",Esn$)510       Print_res_str("Mobile MCC:",Mcc$)511       Print_res_str("Mobile MNC:",Mnc$)512       Print_res_str("Mobile MSIN:",Msin$)513       Print_res_str("Mobile BAND CLASS:",Bclass$)514       Print_res_str("Mobile EIRP:",Eirp$)515       Print_res_str("Mobile OP MODE:",Opmode$)516       Print_res_str("Mobile P_REV:",Prev$)518       PRINT519 !520       RETURN522 !703  !**************************************************************704  ! CONNECT CALL705  !**************************************************************706  Connect:!707 !708   !***Page the mobile station***709       !710       Connect_tries=0711       PRINT "Paging mobile station..."714       LOOP715       !716           OUTPUT Testset;"CALL:ORIG"!Pages the mobile station717           OUTPUT Testset;"CALL:CONNECTED:STATE?"                 !Queries for connected/idle state718           ENTER Testset;Call_connected719           Connect_tries=Connect_tries+1720           IF NOT Call_connected THEN721              WAIT .2723           END IF724       EXIT IF Call_connected OR Connect_tries=50                !try 3 times to connect725       END LOOP726       IF NOT Call_connected THEN727           PRINT "Call attempt failed"728           GOTO End_program729       ELSE730           PRINT "Call connected"731           Current_chan=Primary_channel732       END IF733       PRINT736       RETURN737 !747  !*************************************************************748  ! Multitone_down: Downlink Audio measurement mode is used to 749  !    test the analog signals presented at the AUDIO IN port of 750  !    the test set so that the connectivity and performance of 751  !    the analog signal handling components of the mobile 752  !    station(such as speaker, decoder, etc.) can be verified752  !*************************************************************753  Multitone_down:!754  !755       DIM Mta_lev$[1000]                         !Define an arry to hold multitone measurement results756       OUTPUT Testset;"CALL:FCHannel:SOURce MULTitone"            !Set up the Voice SO Mode required for the              downlink measurement.757       !*** multi-tone audio measurement setup ***758       !1. Set up audio generator parameters for downlink test759       OUTPUT Testset;"SETup:CMAudio:GENerator:FREQuency:            DOWNlink:PRESet NARRow"!Set up downlink frequency760       OUTPUT Testset;"SETup:CMAudio:GENerator:LEVel:            DOWNlink:ALL:TOTal 30"!Set up downlink level761       !2. Set up audio analyzer parameters for downlink test.762       OUTPUT Testset;"SETup:CMAudio:ANALyzer:FREQuency:all:            GENerator ON"!Set up audio analyzer frequency to on763       !3. Set up multitone measurement limit lower/upper level764       OUTPUT Testset;"SETup:CMAudio:LEVel:ALL:LIMit:LOWer -25,-25,            -25,-50,-50,-50,-75,-75,-75,-100,-100,-100,-100,-100,-75,            -75,-75,-50,-50,-50"765       OUTPUT Testset;"SETup:CMAudio:LEVel:ALL:LIMit:UPPer 25,25,            25,50,50,50,75,75,75,100,100,100,100,100,75,75,75,50,50,            50"766       !4. Set up multitone measurement767       OUTPUT Testset;"SETup:CMAudio:COUNt 10"                              !Set the Multi-Measurement Count to 10768       OUTPUT Testset;"SETup:CMAudio:MEASurement:MODE DOWNlink"             !Set the Measurement Mode to Downlink Audio769       OUTPUT Testset;"SETup:CMAudio:REFerence:MODE ABSolute"               !Set the Analyzer 0dB Reference Mode to Absolute770       OUTPUT Testset;"SETup:CMAudio:REFerence:ABSolute:LEVel:            DOWNLINK 150 mV"            !Set the Analyzer Downlink Reference Level to 150 mV771       OUTPUT Testset;"SETup:CMAudio:PEAK:VOLTage 800 mV"                   !Set the Expected Audio In Peak Voltage to 800 mV772       OUTPUT Testset;"SETup:CMAudio:CONTinuous OFF"                        !Set the Trigger Arm to Single773       !774       !Measure downlink multitone775       PRINT "MultiTone Audio Downlink Test Result"776       OUTPUT Testset;"INITiate:CMAudio"782       OUTPUT Testset;"FETCh:CMAudio:INTegrity?"783       ENTER Testset;Integrity784       OUTPUT Testset;"FETCh:CMAudio:LEVel?"785       ENTER Testset;Mta_lev$786       OUTPUT Testset;"FETCh:CMAudio:LEVel:LIMit:FAIL?"787       ENTER Testset;Result788       Print_results("Integrity indicator = ",Integrity,"")789       FOR I=1 TO 20790           Comma=1+(I-1)*17791           Print_results("Tone "&VAL$(I),                VAL(Mta_lev$[Comma;16]),"dB")792       NEXT I793       PRINT "Downlink Multitone Test Result vs.            Lower/Upper Limit(0=Pass, 1=Fail):  ";Result794       RETURN795 !2120  !**************************************************************2121  ! End of All Testing Cleanup2122  !**************************************************************2123  End_program:!2124 !2128       OUTPUT Testset;"CALL:END"2129       PRINT "End of Program"2138       END2139 !2140  !**************************************************************2141  ! Sub-program Section2142  !**************************************************************2143     !2144  Timeout: SUB Timeout! Global timeout handler (from Step 1)2145           COM Testset2146           PRINT "Program timed out"2147           CLEAR 72148           CLEAR Testset2149           STOP2150       SUBEND2151  !2152  Print_results: SUB Print_results(Meas_name$,Res1,Units$)2153 !2154           PRINT USING "5X,50A,5X,M8D.4D,1X,15A";                 Meas_name$;Res1;Units$2155 !2156       SUBEND2157       !2158  Print_res_str: SUB Print_res_str(String_name$,Results$)2159  !2160           PRINT USING "5X,30A,5X,20A";String_name$;Results$2161 !2162       SUBEND2164 !

Programming Example for an Uplink Multi-Tone Audio Measurement

This example is to test the mobile station's microphone quality using the Multi-Tone Audio measurements in uplink mode.

The program example assumes that the mobile station's antenna output is connected to the test set's front-panel RF IN/OUT connector. The analog audio sent from AUDIO OUT port of the test set's front-panel is fed to the mobile phone's microphone. The mobile station supports SO17 service option.

10 !The simple test executive allows you to do uplink multitone     measurement35 !36   COM Testset37 !40   Testset=714! Set "Testset" to equal GPIB address of 896041       !42   CLEAR SCREEN60   OUTPUT Testset;"SYST:LOG:UI:GPIB:STAT ON"61  !***************************************************************62  ! SET UP GPIB TIMEOUT63  !***************************************************************64 !65  ON TIMEOUT 7,30 CALL Timeout! Calls "Timeout" routine73  !76  !***************************************************************77  ! VARIABLE DECLARATIONS FOR CALL SET UP - MOBILE SPECIFIC78  !***************************************************************79   Systype$="DIGITAL2000"!Cell System Type80   Band$="USPCs"!PCS band81   Channel=525!RF Channelfor call setup82   Sid=2     !System Identification84   Nid=1     !Network Identification85   Radio_config$="F2R2"!Radio Configuration86   Service_opt$="SO17"!Voice Service Option87                                 !138  !**************************************************************139  ! Test Executive140  !**************************************************************141 !142  GOSUB Preset_test_set143  GOSUB Set_call_parms146  GOSUB Register151  GOSUB Connect155  GOSUB Multitone_up157  GOTO End_program!Jumps to end of program222 !223 !***************************************************************224 ! PRESET TEST SET225 !***************************************************************226  Preset_test_set:!227       !228  PRINT "Reset 8960"229  OUTPUT Testset;"*RST"!RESET TEST SET230  OUTPUT Testset;"*OPC?"231  ENTER Testset;Opc$232  RETURN233 !247 !***************************************************************253 ! SET UP CALL PARAMETERS254 !***************************************************************255  Set_call_parms:!256 !257  PRINT "Setup Network/Basestation Parameter"270  OUTPUT Testset;"CALL:SYSTEM ";Systype$!Sets System Type280  OUTPUT Testset;"CALL:BAND ";Band$       !Sets Cell Band for selected System Type290  OUTPUT Testset;"CALL:CHAN ";Channel       !Sets RF Channel for selected System Type and Cell Band300  OUTPUT Testset;"CALL:POW -55"!Sets and turns on Cell Power310  OUTPUT Testset;"CALL:SID ";Sid!Sets System Identification320  OUTPUT Testset;"CALL:NID ";Nid!Sets Network Identification330  OUTPUT Testset;"CALL:CELL:RCONFIG ";Radio_config$341  OUTPUT Testset;"CALL:SOPTION ";Service_opt$       !Sets service option for selected System Type and         Radio Configuration350  OUTPUT Testset;"CALL:PAG:DRAT FULL"       !Sets Paging data rate to full rate370  OUTPUT Testset;"CALL:PIL -7"!Sets pilot to default380  OUTPUT Testset;"CALL:SYNC -16"!Sets sync to default390  OUTPUT Testset;"CALL:PAG -12"!Sets paging to default400  RETURN              !Sub-routine return420 !434 !***************************************************************435 ! REGISTER MOBILE436 !***************************************************************437  Register:!438 !439  PRINT "Pls. Power On MS, Then Press F2 Continue"441  PAUSE442  PRINT "Register MS on 8960"443  OUTPUT Testset;"CALL:MS:REPORTED:CLEAR:ALL"       !Clear MS reported database444  OUTPUT Testset;"CALL:REG"445  Reg_timer=TIMEDATE446  LOOP                 448      OUTPUT Testset;"CALL:MS:REP:ESN:HEX?"449      ENTER Testset;Esn$450      Reg_time=TIMEDATE-Reg_timer469  EXIT IF LEN(Esn$)>3 OR Reg_time>30470  END LOOP472  IF Reg_time>30 THEN 473      PRINT "Registration Timed Out, Check Phone Setup"474      GOTO End_program475  END IF477  PRINT "Mobile Registration Complete"478  PRINT482 !483  !***************************************************************484  ! PRINT MOBILE REGISTRATION INFO485  !***************************************************************486 !487  !Read registration information488 !489  OUTPUT Testset;"CALL:MS:REP:ESN:HEX?"490  ENTER Testset;Esn$491  OUTPUT Testset;"CALL:MS:REP:MCC?"492  ENTER Testset;Mcc$493  OUTPUT Testset;"CALL:MS:REP:MNC?"494  ENTER Testset;Mnc$495  OUTPUT Testset;"CALL:MS:REP:MSIN?"496  ENTER Testset;Msin$497  OUTPUT Testset;"CALL:MS:REP:BCLASS?"498  ENTER Testset;Bclass$499  OUTPUT Testset;"CALL:MS:REP:EIRP?"500  ENTER Testset;Eirp$501  OUTPUT Testset;"CALL:MS:REP:OPER:MODE?"502  ENTER Testset;Opmode$503  OUTPUT Testset;"CALL:MS:REP:PREV?"504  ENTER Testset;Prev$507  PRINT "Mobile Registration Information:"508  PRINT509  Print_res_str("Mobile ESN:",Esn$)510  Print_res_str("Mobile MCC:",Mcc$)511  Print_res_str("Mobile MNC:",Mnc$)512  Print_res_str("Mobile MSIN:",Msin$)513  Print_res_str("Mobile BAND CLASS:",Bclass$)514  Print_res_str("Mobile EIRP:",Eirp$)515  Print_res_str("Mobile OP MODE:",Opmode$)516  Print_res_str("Mobile P_REV:",Prev$)518  PRINT519 !520  RETURN522 !703  !**************************************************************704  ! CONNECT CALL705  !**************************************************************706  Connect:!707 !708   !***Page the mobile station***709       !710  Connect_tries=0711  PRINT "Paging mobile station..."714  LOOP715       !716      OUTPUT Testset;"CALL:ORIG"!Pages the mobile station717      OUTPUT Testset;"CALL:CONNECTED:STATE?"           !Queries for connected/idle state718      ENTER Testset;Call_connected719      Connect_tries=Connect_tries+1720      IF NOT Call_connected THEN721         WAIT .2723      END IF724  EXIT IF Call_connected OR Connect_tries=50725  END LOOP726  IF NOT Call_connected THEN727      PRINT "Call attempt failed"728      GOTO End_program729  ELSE730      PRINT "Call connected"731      Current_chan=Primary_channel732  END IF733  PRINT736  RETURN737 !747  !**************************************************************748  ! Mutitone_up: Uplink Audio measurement mode is used to test 749  !     the analog signals by decoding the speech frames 750  !      received from the R-Traffic/R-FCH channel over the RF 751  !      link so that the connectivity and performance of the 752  !      analog signal handling compo752  !**************************************************************753  Multitone_up:!754  !755  DIM Mta_lev$[1000]            !Define an arry to hold multitone measurement results758  OUTPUT Testset;"CALL:FCHannel:SOURce NFRames"      !Set up the Voice SO Mode required for the uplink measurement.759       !*** multi-tone audio measurement setup ***760       !1. Set up audio generator parameters for uplink test762  OUTPUT Testset;"SETup:CMAudio:GENerator:FREQuency:       UPLink:PRESet NARRow"!Set up uplink frequency763  OUTPUT Testset;"SETup:CMAudio:GENerator:LEVel:       UPLink:ALL:TOTal 1"!Set up uplink level to 1V764       !2. Set up audio analyzer parameters for uplink test.765  OUTPUT Testset;"SETup:CMAudio:ANALyzer:FREQuency:all:       GENerator ON"!Set up audio analyzer frequency to on766       !3. Set up multitone measurement limit lower and upper level767  OUTPUT Testset;"SETup:CMAudio:LEVel:ALL:LIMit:LOWer -25,-25,-25,       -50,-50,-50,-75,-75,-75,-100,-100,-100,-100,-100,-75,-75,-75,       -50,-50,-50"768  OUTPUT Testset;"SETup:CMAudio:LEVel:ALL:LIMit:UPPer 25,25,25,       50,50,50,75,75,75,100,100,100,100,100,75,75,75,50,50,50"769       !4. Set up multitone measurement770  OUTPUT Testset;"SETup:CMAudio:COUNt 10"                     !Set the Multi-Measurement Count to 10771  OUTPUT Testset;"SETup:CMAudio:MEASurement:MODE UPLink"          !Set the Measurement Mode to Uplink Audio772  OUTPUT Testset;"SETup:CMAudio:REFerence:MODE ABSolute"          !Set the Analyzer 0dB Reference Mode to Absolute773  OUTPUT Testset;"SETup:CMAudio:REFerence:ABSolute:       LEVel:UPLink 50"          !Set the Analyzer Uplink Reference Level to 50%774  OUTPUT Testset;"SETup:CMAudio:SETTling 600 ms"              !Set device settling time to 600 ms775  OUTPUT Testset;"SETup:CMAudio:CONTinuous OFF"               !Set the Trigger Arm to Single779        !Measure uplink multitone780  PRINT "MultiTone Audio Uplink Test Result"781  OUTPUT Testset;"INITiate:CMAudio"785  OUTPUT Testset;"FETCh:CMAudio:INTegrity?"790  ENTER Testset;Integrity791  OUTPUT Testset;"FETCh:CMAudio:LEVel?"800  ENTER Testset;Mta_lev$805  OUTPUT Testset;"FETCh:CMAudio:LEVel:LIMit:FAIL?"810  ENTER Testset;Result811  Print_results("Integrity indicator = ",Integrity,"")812  FOR I=1 TO 20813      Comma=1+(I-1)*17814      Print_results("Tone "&VAL$(I),            VAL(Mta_lev$[Comma;16]),"dB")815  NEXT I816  PRINT "Uplink Multitone Test Result vs.         Lower/Upper Limit(0=Pass, 1=Fail):  ";Result817  RETURN818 !2120  !*************************************************************2121  ! End of All Testing Cleanup2122  !*************************************************************2123  End_program:!2124 !2128 OUTPUT Testset;"CALL:END"2129 PRINT "End of Program"2138 END2139 !2140  !*************************************************************2141  ! Sub-program Section2142  !*************************************************************2143     !2144  Timeout: SUB Timeout! Global timeout handler (from Step 1)2145     COM Testset2146     PRINT "Program timed out"2147     CLEAR 72148     CLEAR Testset2149     STOP2150 SUBEND2151  !2152  Print_results: SUB Print_results(Meas_name$,Res1,Units$)2153 !2154     PRINT USING "5X,50A,5X,M8D.4D,1X,15A";             Meas_name$;Res1;Units$2155 !2156 SUBEND2157       !2158  Print_res_str: SUB Print_res_str(String_name$,Results$)2159  !2160     PRINT USING "5X,30A,5X,20A";String_name$;Results$2161 !2162 SUBEND2164 !

Related Topics

Multi-Tone Audio Measurement Description


Control Program Example

Control Program Example

Last updated: October 28, 2004

HP BASIC

For your convenience we have combined the programming examples shown in the Getting Started Guide into one program. This program, written using HP BASIC, is a fully functional cdma2000 control program. You can use this as a starting point for developing your own program. Click on the link below to view this program.

  • Getting Started Guide Control Program Example for cdma2000

We have also included a comprehensive example of programming IS-95 mobile station testing. This program is presented in a test executive format. Click on the link below to view this program.

  • Getting Started Guide Control Program Example for IS-95


Test System Synchronization

Test System Synchronization

Last updated: October 28, 2004

  • Test System Synchronization Overview
  • Call Processing Event Synchronization
  • Call Processing State Synchronization
  • Measurement Event Synchronization
  • SMS (Short Message Service) State Synchronization


Obtaining Measurement Results

Obtaining Measurement Results

Last updated: October 28, 2004

  • Statistical Measurement Results
  • Timeouts
  • Triggering of Measurements
  • Integrity Indicator
  • Measurement Progress Report
  • Concurrent Measurements
  • Invalid Measurement Results
  • Dealing With Semicolon Separated Response Data Lists


Programming the Spectrum Monitor

Programming the Spectrum Monitor

Last updated: April 21, 2005

This section provides an example of how to use the Spectrum Monitor via the GPIB.

The following procedure assumes that the mobile station's antenna output is connected to the RF IN/OUT connector, and that the mobile station is transmitting a forward channel signal.

  1. Configure the Spectrum Monitor parameters using the SETup subsystem.
  2. Start the Spectrum Monitor using the INITiate subsystem.
  3. Use the INITiate:DONE? command to determine if Spectrum Monitor results are available.
  4. Use the FETCh? commands to obtain Spectrum Monitor results.
  5. Use the CALCulate commands to set and query the Spectrum Monitor markers.

Programming Example

10       REAL Amplitudes(400)
20       ! Set up array to hold 401 amplitude results (trace data)
30       OUTPUT 714;"SETUP:SMONITOR:CONTINUOUS OFF"!Configures the Spectrum Monitor to
40                                                !single trigger mode.
50       OUTPUT 714;"SETUP:SMONITOR:COUNT:NUMBER 20"!Configures a multi-measurement
60                                                  !of 20.
70       OUTPUT 714;"SETUP:SMONITOR:TRIGGER:SOURCE IMMEDIATE"!Configure trigger source
80                                                     !to immediate.
90       OUTPUT 714;"SETUP:SMONITOR:FREQUENCY:SPAN 20 MHz"!Set frequency span
100       OUTPUT 714;"SETUP:SMONITOR:BWIDth:MANUAL 300 KHZ"!Decouples the frequency span
110                     ! and the resolution bandwidth, and sets the resolution bandwidth.
120       OUTPUT 714;"INITIATE:SMONITOR"!Start the Spectrum Monitor
130     !
140       OUTPUT 714;"FETCH:SMONITOR:INTEGRITY?"!Fetch SMON Integrity
150       ENTER 714;Integrity
160       PRINT "Spectrum Monitor Integrity: ";Integrity
170       IF Integrity=0 THEN                  !Fetch results if SMON
180           OUTPUT 714;"FETCH:SMONITOR:TRACE?"!has valid integrity.
190           ENTER 714;Integrity,Amplitudes(*)!Load valid results into array
200           PRINT "Trace Data Amplitude Results (dB):"
210           PRINT "--------------------------------------------------"
220           PRINT Amplitudes(*) !Prints the 401 stored data points.
230           PRINT "--------------------------------------------------"
240       ELSE
250           PRINT "Bad Integrity value =";Integrity
260           STOP
270       END IF
280     ! Move the marker to the signal peak and query the frequency and level
290       OUTPUT 714;"CALCULATE:SMONITOR:MARKER1:PEAK:MAXIMUM"
300       OUTPUT 714;"CALCULATE:SMONITOR:MARKER1:FREQUENCY?"
310       ENTER 714;Peak_frequency
320       PRINT "Maximum Peak Frequency (MHz): ";Peak_frequency
330       OUTPUT 714;"CALCULATE:SMONITOR:MARKER1:AMPLITUDE?"
340       ENTER 714;Peak_amplitude
350       PRINT "Maximum Peak Amplitude (dBm): ";Peak_amplitude
360       END

Returned Values

The results returned by this program are:

  • Integrity returns the Spectrum Monitor Integrity Indicator (0 means that the Spectrum Monitor completed with no errors).
  • Amplitudes() returns 401 points representing the amplitude results (in dBm) of the trace data.
  • Peak_frequency returns the frequency in MHz at marker 1. In this case, marker 1 is positioned at the highest peak value.
  • Peak_amplitude returns the amplitude in dBm at marker 1. In this case, marker 1 is positioned at the highest peak value.

Related Topics

Spectrum Monitor Description

SETup:SMONitor

INITiate

FETCh:SMONitor

CALCulate:SMONitor


Statistical Measurement Results

Statistical Measurement Results

Last updated: October 28, 2004

Description

Most measurements have a setup window that provides for the entry of a multi-measurement count value. This specifies how many measurements the test set will perform to obtain a set of values from which to calculate the following statistical measurement results:

  • Average (arithmetic mean) of measurement set
  • Minimum value from measurement set
  • Maximum value from measurement set
  • Standard Deviation of measurement set

Operating Considerations

The advantages of using the multi-measurement feature to obtain statistical measurement data include: reduced time associated with GPIB bus traffic, and reduced time configuring hardware. This is because the number of measurements specified in the multi-measurement count value are performed during one measurement cycle.

Programming Example

OUTPUT 714;"SETUP:DAPOWER:COUNt 10" 	!Enters a Digital Average Power count
                                      !of 10, and turns the Digital Average Power
                                      !multi-measurement state on.

Related Topics

Measurement Progress Report


Status Subsystem Overview

Status Subsystem Overview

Last updated: July 31, 2006

The following pages present an overview of the entire status subsystem, including test applications which may or may not be loaded in your test set.

Description

Overview of STATus Reporting Structure

Status Reporting Structure For STATus QUEStionable Registers

Status Reporting Structure For STATus OPERation Registers

Status Reporting Structures for the COMMon Registers

Status Reporting Structure for the SMService Register

Status Reporting Structure for the GSM Registers

Status Reporting Structure For the GPRS Registers

Status Reporting Structure for the AMPS Registers

Status Reporting Structure for the DIGital136 Registers

Status Reporting Structures for the TA136 Registers

Status Reporting Structure for the DIGital95 Registers

Status Reporting Structure for the DIGital 2000 Registers

Status Reporting Structure for the CDMA Registers

Status Reporting Structure for the TA 2000 Registers

Status Reporting Structure for the FDD Registers

Status Reporting Structure for the WCDMA Registers

Status Reporting Structure For the TA856 Registers

Status Reporting Structure for the DIGital856 Registers

Status Data Structure - Register Model

The generalized status register model consists of a Condition Register, Transition Filters, an Event Register, an Enable Register, and a Summary Message Bit.

Condition Register

A condition is a test set state that is either TRUE or FALSE (a GPIB command error has occurred or a GPIB command error has not occurred). Each bit in a Condition Register is assigned to a particular test set state. A Condition Register continuously monitors the hardware and firmware states assigned to it. There is no latching or buffering of any bits in a Condition Register; it is updated in real time. Condition Registers are read-only. Condition Registers in the test set are 16 bits long and may contain unused bits. All unused bits return a zero value when read.

Transition Filters

In the test set, the Transition Filters are implemented as two registers: a 16-bit positive transition (PTR) register and a 16-bit negative transition (NTR) register.

For each bit in the Condition Register, a Transition Filter bit determines the state transitions which will set a corresponding bit in the Event Register. Transition Filters may be set to pass positive transitions (PTR), negative transitions (NTR) or either (PTR or NTR). A positive transition refers to a condition bit which has changed from 0 to 1. A negative transition refers to a condition bit which has changed from 1 to 0.

A positive transition of a bit in the Condition register will be latched in the Event Register if the corresponding bit in the positive transition filter is set to 1. A positive transition of a bit in the Condition register will not be latched in the Event Register if the corresponding bit in the positive transition filter is set to 0.

A negative transition of a bit in the Condition register will be latched in the Event Register if the corresponding bit in the negative transition filter is set to 1. A negative transition of a bit in the Condition register will not be latched in the Event Register if the corresponding bit in the negative transition filter is set to 0. Either transition (PTR or NTR) of a bit in the Condition Register will be latched in the Event Register if the corresponding bit in both transition filters is set to 1. No transitions (PTR or NTR) of a bit in the Condition Register will be latched in the Event Register if the corresponding bit in both transition filters is set to 0.

Transition Filters are read-write.

Transition Filters are unaffected by a *CLS (clear status) command.

Transitions Filters are set to pass positive transitions (all 16 bits of the PTR register are set to 1 and all 16 bits of the NTR register are set to 0) at power on or after receiving the *RST (reset) command.

Event Register

The Event Register captures bit-state transitions in the Condition Register as defined by the Transition Filters. Each bit in the Event Register corresponds to a bit in the Condition Register. Bits in the Event Register are latched, and, once set, they remain set until cleared by a query of the Event Register or a *CLS (clear status) command. This guarantees that the application can't miss a bit-state transition in the Condition Register. There is no buffering; so while an event bit is set, subsequent transitions in the Condition Register corresponding to that bit are ignored. Event Registers are read-only. Event Registers in the test set are 16 bits long and may contain unused bits. All unused bits return a zero value when read.

Event Enable Register

The Event Enable Register defines which bits in the Event Register will be used to generate the Summary Message. Each bit in the Enable Register has a corresponding bit in the Event Register. The test set logically ANDs corresponding bits in the Event and Enable registers and then performs an inclusive OR on all the resulting bits to generate the Summary Message. By using the enable bits the application program can direct the test set to set the Summary Message to the 1 or TRUE state for a single event or an inclusive OR of any group of events. Enable Registers are read-write. Enable Registers in the test set are 16 bits long and may contain unused bits which correspond to unused bits in the associated Event Register. All unused bits return a zero value when read and are ignored when written to. Enable Registers are unaffected by a *CLS (clear status) command or queries.

Standard Event Status Register Model

Summary Message Bit

The Summary Message is a single-bit message which indicates whether or not one or more of the enabled events have occurred since the last reading or clearing of the Event Register. The test set logically ANDs corresponding bits in the Event and Enable registers and then performs an inclusive OR on all the resulting bits to generate the Summary Message. By use of the enable bits, the application program can direct the test set to set the Summary Message to the 1, or TRUE, state for a single event or an inclusive OR of any group of events.

The Summary Message is TRUE, logic 1, if the register contains some information and an enabled event in the Event Register is set TRUE.

The Summary Message is FALSE, logic 0, if the queue is empty and no enabled events are TRUE. Registers can be cleared by reading all the information from the queue. Registers can also be cleared using the *CLS (clear status) command.

Service Request Enabling Register Model

Status Byte Register

The Status Byte Register is an 8 bit register that provides single bit summary messages, each summary message summarizes and overlaying status data structure. Summary messages always track the current status of the associated status data structure. Service request enabling determines if one or more of the summary messages will generate a message. Device status reporting is defined in IEEE 488.2-1992, 11.1.

The Status Byte Register contains the STB and RQS (or MSS) messages from the test set. The Status Byte Register can be read with either a serial poll or the *STB? common query. The value for bit 6 is dependent on which method used.

When reading with a serial poll the status byte and the RQS message are returned as a single data byte. The RQS message indicates if the SRQ is TRUE. The Status Byte Register is not affected by a serial poll, the RQS is set to FALSE when polled.

The *STB? query allows you to read the status byte and the MSS. The response represents the sum of the binary weighted values of the Status Byte Register from bit 0-5 and 7.

The Master Summary Status (MSS) message from bit 6 indicates when there is at least one reason for requesting service.

The Message Available (MAV) summary message from bit 4 is TRUE when there is a message is in the output queue.

The Status Byte Register is cleared with the *CLS common command. The output queue and the MAV are not affected by the *CLS command.

Service Request Enable Register

The Service Request Enable Register is an 8 bit register that enables corresponding summary messages in the Status Byte Register. Enabling the service request with the *SRE command allows you to choose which bits in the Status Byte Register will trigger a service request.

The Service Request Enable Register is read with the *SRE? query. The returned value is the sum of the binary weighted values of the Service Request Enable Register, with a range of 0 through 63 or 128 through 191.

The value of the unused bit 6 will always be zero.

System Synchronization Bit

Bit 12 of the status operation condition register is "pulsed" when the SYSTem:SYNChronized command is sent. This allows the status system to indicate that:

  • the input buffer is synchronized to the point where this command is parsed
  • all prior sequential commands are completed
  • all prior overlapped commands have started

Related Topics

STATus Subsystem


Programming a Signaling Tone Measurement

Programming a Signaling Tone Measurement

Last updated: June 20, 2006

General Programming Procedure

  1. Make a call.
  2. Configure the Signaling Tone setup parameters using SETup:STONe subsystem.
  3. Trigger the Signaling Tone using CALL:MS:ANALog:MAINtenance[:IMMediate] or CALL:MS:ANALog:ALERt[:IMMediate] .
  4. Start the signaling tone measurement and obtain the measurement result using READ:STONe[:ALL]? subsystem.

Programming Example

1        ! This program measures the signaling tone
3        !
6        CLEAR SCREEN
7        ! E5515C GPIB Address
8        Testset=714
9        ! System type
11       Systype$="AMPS"
12       ! System identification
13       Sid=1
14       !
15       ! Calls "Timeout" routine
16       ON TIMEOUT 7,20 CALL Timeout
17       !
18       ! *** Specify call parameters ***
19       OUTPUT Testset;"SYST:COMM:GPIB:DEB:STAT ON"
20       ! Sets Operating Mode to be Active Cell
21       OUTPUT Testset;"CALL:OPER:MODE CALL"
22       ! Set System Type to be AMPS
23       OUTPUT Testset;"CALL:SYST ";Systype$
24       ! Set System Identification
25       OUTPUT Testset;"CALL:SID:AMPS";Sid
64       !
68       ! *** Make a call by paging the mobile station ***
69       PRINT "Turn on mobile station..."
70       PRINT "Press continue when it has found service and registred"
71       PAUSE
72       PRINT "Paging mobile station..."
73       PRINT "Answer the mobile station when you are ready"
74       ! Originate the call
75       OUTPUT Testset;"CALL:ORIG"
76       ! Query for connected/idle state
77       OUTPUT Testset;"CALL:CONN:STAT?"
78       ENTER Testset;Call_connected
79       IF NOT Call_connected THEN
80          DISP "Call attempt failed"
81          STOP
82       ELSE
83          DISP "Call connected"
84       END IF
85       PRINT "Connection is established, test is in progress"
86       !
87       ! *** Configure signaling tone measurement parameters ***
88       ! Set trigger arm state to be single
89       OUTPUT Testset;"SET:STON:CONT OFF"
90       ! Turn on multi measurement
91       OUTPUT Testset;"SET:STON:COUN:STAT ON"
92       ! Set the number of measurements to 30
93       OUTPUT Testset;"SET:STON:COUN:NUMB 30"
95       !
96       ! *** Start the signaling tone measurement ***
98       ! Send the maintainence order message to mobile station
99       OUTPUT Testset;"CALL:MS:ANAL:MAIN"
100      !
101      ! *** Obtain the signaling tone measurement results ***
103      ! Start the measurement and get the measurement results
104      OUTPUT Testset;"READ:STON:ALL?"
105      ENTER Testset;Integrity,Ppeak_dev,Npeak_dev,Freq_err,Freq
106      DISP "Signaling Tone Test complete"
109      ! Turn off the measurement
110      OUTPUT Testset;"INIT:STON:OFF"
111      ! End the call
112      OUTPUT Testset;"CALL:END"
113      !
114      ! *** Display the measurement results ***
115      PRINT "STONE =";Ppeak_dev;Npeak_dev;Freq_err;Freq;
116      PRINT "Integrity Indicator";Integrity
117      PRINT "Stone Positive Peak Deviation = ";Ppeak_dev
118      PRINT "Stone Negative Peak Deviation = ";Npeak_dev
119      PRINT "Stone Frequency Error = ";Freq_err
120      PRINT "Stone Frequency = ";Freq
121  END
122  !
132  ! Global timeout handler
185  Timeout: SUB Timeout
187             PRINT "Program timed out"
188             CLEAR 7
189             CLEAR 714
190           SUBEND

Returned Values

The measurements returned by this program are:

  • Integrity returns the measurement integrity indicator (see Integrity Indicator ); 0 means a successful measurement with no errors.
  • Ppeak_dev returns the average positive peak frequency deviation of carrier in kHz.
  • Npeak_dev returns the average negative peak frequency deviation of carrier in kHz.
  • Freq_err returns the average frequency error of carrier in Hz.
  • Freq returns the average frequency of carrier in Hz.

Related Topics

Signaling Tone Measurement Description

Signaling Tone Troubleshooting

INITiate

SETup:STONe

FETCh:STONe


Programming a Swept Audio Measurement

Programming a Swept Audio Measurement

Last updated: October 28, 2004

This section provides an example of how to make swept audio measurements via the GPIB.

The following example assumes that some device under test is connected between the test set's AUDIO OUT and AUDIO IN ports. The default audio level measurement, and the optional SINAD and distortion measurements, are performed at each frequency point in the sweep.

  1. Configure the swept audio measurement using the SETup subsystem.
  2. Start the measurement using the INITiate subsystem.
  3. Use the FETCh subsystem to obtain the audio analyzer's results for all points in the sweep.

Programming Example

10    OUTPUT 714;"SETup:SAUDio:FREQuency:STARt 300 Hz" !Start the frequency
20                                         !sweep at 300 Hz.
30    OUTPUT 714;"SETup:SAUDio:FREQuency:STOP 4 kHz" !Stop the frequency
40                                         !sweep at 4 kHz.
50    OUTPUT 714;"SETup:SAUDio:FREQuency:POINts 5"  !Make measurements at 5 frequencies
60                       !spaced evenly between the start and stop frequencies.
70    OUTPUT 714;"SETup:SAUDio:SETTling 1.5 ms" !Set a settling time of
80                                          !1.5 milliseconds.
90    OUTPUT 714;"SETup:SAUDio:VOLTage:AMPLitude 1 V" !SET the audio generator
100                                         !voltage to 1 volt peak.
110   OUTPUT 714;"SETup:SAUDio:DETector PEAK" !Select the peak detector for
120                                         !the audio analyzer.
130   OUTPUT 714;"SETup:SAUDio:FILTer TBPass" !Select the AF analyzer's 100 Hz bandwidth
140    !band pass filter for making the measurements. The center frequency for the filter
150                                !automatically tracks the AF generator's frequency.
160   OUTPUT 714;"SETup:SAUDio:PEAK:VOLTage 1 V" !Set the expected peak voltage
170                                         !at the AUDIO IN port.
180   OUTPUT 714;"SETup:SAUDio:SDIStortion:STATe ON" !Turn on the SINAD
190                                         !and distortion measurements.
200   OUTPUT 714;"SETup:SAUDio:CONTinuous OFF" !Set the swept audio
210                                         !measurement to single trigger mode.
220   OUTPUT 714;"SETup:SAUDio:TIMeout 5 S" !Set a measurement timeout of
230                                      !5 seconds in case the measurement cannot be made.
240   OUTPUT 714;"INITiate:SAUDio"          !Start the swept audio measurements.
250   OUTPUT 714;"FETCh:SAUDio?"            !Query the audio level and distortion results.
260   ENTER 714;Integrity,Lev1,Dist1,Lev2,Dist2,Lev3,Dist3,Lev4,Dist4,Lev5,Dist5 !Enter the
270                        !returned integrity value, and the level and distortion values
280                        !for each of the five measurement points, into variables.
290   OUTPUT 714;"FETCh:SAUDio:SINAD?"       !Query the SINAD results.
300   ENTER 714;Sinad1,Sinad2,Sinad3,Sinad4,Sinad5 !Enter the 5 returned SINAD values
310                                          !into variables.
320   END

Returned Values

The results returned by this program are:

  • Integrity returns the measurement integrity indicator (see Integrity Indicator ); 0 means a successful measurement with no errors.
  • Lev1 through Lev5 return the audio level (voltage) at each of the five measurement points. In this example, the value is returned in volts peak because the peak detector was specified.
  • Dist1 through Dist5 return the distortion value at each of the five measurement points.
  • Sinad1 through Sinad5 return the SINAD value at each of the five measurement points.

The example program uses the single FETCh:SAUDio[:ALL]? query to return the integrity value, the audio level (voltage) values, and the distortion values, at one time. These values can also be queried separately if required. The SINAD value is always queried separately.

Related Topics

Swept Audio Measurements Description

Swept Audio Measurement Troubleshooting

INITiate

SETup:SAUDio

FETCh:SAUDio


Call Processing Event Synchronization

Call Processing Event Synchronization

Last updated: June 21, 2006

Description

Using the call processing subsystem overlapped command synchronization commands, you can query the test set to find out when an overlapped command operation is done (:DONE?, :OPC?), force the test set to not execute any more commands until an overlapped command operation has completed (:WAIT), or simply force an overlapped command to behave as a sequential command (:SEQ).

Pending Operation Flags

Associated with each overlapped command, the test set maintains a binary indicator known as a pending operation flag. A pending operation flag is set true when the operation started by the overlapped command is executing, and is set false when the operation is no longer executing.

NOTE
In addition to the call processing subsystem overlapped commands, the test set also provides the measurement-related INITiate <measurement> overlapped commands.

Call Processing Subsystem Overlapped Command Synchronization Commands

Overlapped Commands
Command Purpose Of Command

Example

:DONE?

Returns a 0 if the associated command's pending operation flag is true, or a 1 if it is false.

10 OUTPUT 714;"CALL:TCH 65"
20 OUTPUT 714;"SETUP:TXP:CONT OFF"
30 OUTPUT 714;"SETUP:PFER:CONT OFF"
40 REPEAT
50 OUTPUT 714;"CALL:TCH:DONE?"
60 ENTER 714;Process_done
70 UNTIL Process_done
80 OUTPUT 714;INIT:TXP;PFER"
90 END

The example shown is from the E1960A GSM test application. Commands the test set to perform a traffic channel handover and execute two setup commands. After the two setup commands have finished, the :DONE? command is used to find out if the handover is finished

:SEQuential

Forces an overlapped command to execute in a sequential manner. No subsequent commands will be executed until the pending operation flag for this operation is false.

OUTPUT 714;"CALL:TCH:SEQ 65"

The example shown is from the E1960A GSM test application. Commands the test set to perform a traffic channel handover and to not execute any more commands until the pending operation flag associated with the CALL:TCH command is false.

:WAIT

Forces the test set to wait until the associated command's pending operation flag is false before executing any more commands.

10 OUTPUT 714;"CALL:TCH 65"
20 OUTPUT 714;"SETUP:TXP:CONT OFF"
30 OUTPUT 714;"SETUP:PFER:CONT OFF"
40 OUTPUT 714;"CALL:TCH:WAIT"
50 OUTPUT 714;"INIT:TXP;PFER"
60 END

The example shown is from the E1960A GSM test application. Commands the test set to perform a traffic channel handover and execute two setup commands. After the two setup commands have finished, the :WAIT command is sent to prevent the test set from executing the INITiate command until the handover is finished.

:OPComplete?

Places a 1 in the test set's output queue when the associated command's pending operation flag goes false. Controlling program hangs on this query until the 1 is retrieved.

10 OUTPUT 714;"CALL:TCH 65"
20 OUTPUT 714;"SETUP:TXP:CONT OFF"
30 OUTPUT 714;"SETUP:PFER:CONT OFF"
40 OUTPUT 714;"CALL:TCH:OPC?"
50 ENTER 714;Op_complete
60 OUTPUT 714;"INIT:TXP;PFER"
70 END

The example shown is from the E1960A GSM test application. Commands the test set to perform a traffic channel handover and execute two setup commands. After the two setup commands have finished, the :OPC? command is sent to hang program execution until a 1 is put in the test set's output queue, satisfying the ENTER statement and allowing program execution to continue with the INITiate command.

Operating Considerations

When using the call processing subsystem overlapped command synchronization commands, check the conditions that set the operation's pending operation flag (POF) false to avoid unexpected results.

Call Processing Subsystem Overlapped Commands

Overlapped Commands
Call Processing Command | Purpose Of Command | Pending Operation Flag (POF) is false when
CALL:ORIGinate | Performs a base station call origination. | The call processing state has stabilized in a terminal state (that is, idle or connected) when the operating mode is active cell. See Call Processing States Description and SMS Status Description .
CALL:REGister | Performs a zone-based (forced) registration. | The call processing state transitions to 'Registering'. See Call Processing States Description .
CALL:CONNected:ARM[:IMMediate] | Arms the call control status change detector. | The call control status change detector has been disarmed. See Call State Change Detector .
CALL:DCONnected:ARM[:IMMediate] | Arms the data connection status change detector. | The data connection state change detector has been disarmed. See Call State Change Detector .
CALL:SMService:SEND | Attempts to send an SMS message to the mobile station. | The SMS state has stabilized in a terminal state other than `Received'. See SMS Status Description .
CALL:SMService:ARM[:IMMediate] | Arms the SMS status change detector. | The SMS status change detector has been disarmed. See SMS Status Change Detector .

Related Topics

Test System Synchronization Overview


Call Processing State Synchronization

Call Processing State Synchronization

Last updated: October 28, 2004

One of the most important and difficult aspects of synchronizing the external controller, test set and DUT is synchronizing the movement between call processing states. There are several specialized commands available to help you determine the state of the call processing, and verify that call processing events were successful.

Call Processing State Query Summary
Query | Description | Suggested Usage
CALL:STATus[:STATe][:VOICe]? | Queries the current call processing state. Immediately returns the state: IDLE|PAG|CALL|CONN|APR|REL|HAND|REG. See Call Processing States Description . | Use after a handoff to verify the call processing state is still "connected".
CALL:CONNected[:STATe]? | Queries whether the call state is idle or connected. Immediately returns 1 or 0, or waits for a state change if the Call State Change Detector is armed. See Connected/Idle Query . | Use with the Call State Change Detector to verify that your attempt to establish a call was successful.
CALL:DCONnected[:STATe] | Queries whether the test data connection (with service option set to SOFS32 or SOS32, see CALL:SOPTion ) is in idle or connected state. Immediately returns 1 or 0, or waits for a state change if the Call State Change Detector is armed. See Connected/Idle Query . | Use with the Call State Change Detector to verify that your attempt to establish a call with service option 32 was successful.

Call Processing States Description

The CALL:STATus[:STATe][:VOICe]? query returns the current call processing states. These states may also be displayed on the front panel screen (see Instrument Status Area ). The possible states include transitory states and terminal states.

Transitory States

The following call processing states are transitory states that the test set remain in momentarily during transitions to a terminal state.

  • PAG - Paging is returned when the test set is in the process of paging the MS.
  • CALL - Call is returned when an alert message is sent to the MS during a call setup due to a page.
  • APR - Access probe is returned when the test set has received an access probe.
  • REL - Releasing is returned when the test set is in the process of releasing the MS from a call using over the air signalling as part of a MS or BS originated release procedure.
  • HAND - Handoff is returned when the test set is in the process of handing off the MS.
  • REG - Registering is returned when the test set is in the process of performing a registration with the MS.

Terminal States

The following call processing states are terminal states that the test set is stabilized in for a substantial length of time.

  • IDLE - Idle is returned when the test set is not on a call.
  • CONN - Connected is returned when the test set and the MS are connected on a call.

Connected/Idle Query

The CALL:CONNected[:STATe]? query is used to verify which terminal call state (idle or connected) that the test set is in. It's most useful in conjunction with the Call State Change Detector . See Example 1: Mobile Station Originated Call - Arming the Change Detector .

  • If the call state change detector is not armed and the call processing is in a terminal state, the query immediately returns 0 (Idle state) or 1 (Connected state).
  • If the call state change detector is armed or the call processing is in a transitory state, the query hangs until the change detector is disarmed and the call state reaches a terminal state. The query returns 1 or 0 as soon as a terminal state is reached.

For test data connection (with service option set to SOS32 or SOFS32, see CALL:SOPTion ), use CALL:DCONnected[:STATe] to verify whehter the test data connection is in connected state.

Call State Change Detector

The call state change detector is useful when you expect a change in the call processing state, and want to know when it is complete. The change detector is used in conjunction with the Connected/Idle Query .

The call state change detector is automatically armed by the test set when call processing operations originating from the test set are requested by CALL:ORIGinate , CALL:REGister and CALL:END . You do not need to explicitly arm the call state change detector. See Example 2: Base Station Originated Call - Using the Connected/Idle Query .

NOTE

During SMS operation, the CALL:ORIGinate may affect both call state change detector and SMS Status Change Detector . Moreover, the call state change detector will be rearmed immediately after the call status change detector is disarmed. See Arming the SMS State Change Detector .

You only need to arm the change detector (using CALL:CONNected:ARM[:IMMediate] ) to hold off the call terminal state queries when you are originating a call or disconnecting a call from the mobile station. See Example 1: Mobile Station Originated Call - Arming the Change Detector .

For mobile originated test data connection (with service option set to SOS32 or SOFS32, see CALL:SOPTion ), use CALL:DCONnected:ARM[:IMMediate] to arm the data connection status change detector.

The call state change detector becomes disarmed when any of the following conditions have been met:

  • the call processing state has changed to either connected or idle, or

  • the attempt to connect or disconnect a call has failed, and one of the test set's Fixed Timers has timed out, or

  • no call processing state changes occurred within the time period specified by the Call State Change Detector Timeout .

Call State Change Detector Timeout

The call state change detector includes a timeout to limit the amount of time that the test set will wait for a change in the call processing state. This can prevent the call processing state from staying in a transitory state forever. The timer begins when the change detector is armed or rearmed when already armed. The duration of this timeout is user-settable, but the user setting (using the CALL:CONNected:TIMeout ) is only applied during mobile station originated call processing operations and should be greater than the maximum amount of time the control program needs to wait between arming the call state change detector and the call processing operation starting. If the timer expires, the change detector is disarmed, and the CALL:CONNected[:STATe]? query return a 1 for connected or a 0 for idle. For test set originated call processing operations, the timeout is automatically set to 60 seconds by the test set.

For mobile originated test data connection (with service option set to SOS32 or SOFS32, see CALL:SOPTion ), use CALL:DCONnected:TIMeout to set the timeout of the data connection status change detector.

Example 1: Mobile Station Originated Call - Arming the Change Detector

The following example illustrates the use of the call state change detector along with the connected/idle query to synchronize a controlling application with a call processing state change during a mobile station originated call.

When the CALL:CONNECTED:ARM command is received by the test set, the detector becomes armed and configures the test set to hold off on returning a result for the CALL:CONNECTED:STATE? query until the detector is disarmed by one of the three events described above.

10    OUTPUT 714;"CALL:CONNECTED:TIMEOUT 10S" ! Sets the time out
20                                            ! time to 10 seconds.
30    OUTPUT 714;"CALL:CONNECTED:ARM" ! Arm the change detector.
40    DISP "Make a mobile station orginated call. Continue when done."
50    PAUSE
60    OUTPUT 714;"CALL:CONNECTED:STATE?" ! The connected/idle query.
70    ENTER 714;Call_connected
80    IF Call_connected=1 THEN
90      DISP "Call is connected."
100     WAIT 2
110   ELSE
120     DISP "Call is not connected."
130     WAIT 2
140   END IF
150   END

Example 2: Base Station Originated Call - Using the Connected/Idle Query

The following example illustrates the use of the connected/idle query for a base station originated call. This code originates a call, then waits for the connected/idle query to return a result.

Note that this code does not include the CALL:CONNECTED:TIME (timeout timer) or the CALL:CONNECTED:ARM (change detector arm) commands. These commands are unnecessary since the change detector is armed automatically by the CALL:ORIGINATE command, and the timeout timer value is never applicable since a base station originated call guarantees a state change.

10    OUTPUT 714;"CALL:ORIGINATE" ! Begin the BS originated call.
20    OUTPUT 714;"CALL:CONNECTED:STATE?" ! The connect/idle query.
30    ENTER 714;Call_connected ! Program will hang here until state
40                             ! change or protocol timer expires.
50    !************************************************************
60    ! If mobile is not set to auto-answer, answer the call.
70    !************************************************************
80    IF NOT Call_connected THEN
90      DISP "CALL NOT CONNECTED."
100   ELSE
110     DISP "CALL IS CONNECTED."
120   END IF
130   END

Related Topics

Test System Synchronization Overview


Test System Synchronization Overview

Test System Synchronization Overview

Last updated: June 21, 2006

Description

Typical test systems include an external controller with a GPIB connection to the test set, an RF (and possible AF) connection between the test set and a mobile station under test, and a serial connection between the mobile station and the external controller.

Synchronizing an external controller with the test set and a mobile station under test ensures that no device does something before it is supposed to, which can cause errors, or does something well after it could have, which wastes time.

Test System

Sequential versus overlapped commands

The test set uses both sequential and overlapped commands:

  • Sequential commands must finish executing before the next command starts to execute.
  • Overlapped commands do not finish executing before the next command starts to execute.

Overlapped commands are more difficult to synchronize because an overlapped operation that started several commands earlier may still be executing as subsequent commands are being parsed out from the input buffer and executed. This can present a problem unless the external controller is properly synchronized to the test set's execution of commands. Overlapped commands allow the test set to use its internal resources as efficiently as possible.

Methods for synchronization

The test set's GPIB command set supports the following methods to achieve synchronization for overlapped commands. In some cases, combinations of these methods will provide the best results:

Methods one and two do not require the external controller to query the test set, nor to perform any branching or decision-making associated with information acquired from the test set.

Methods three through six rely on responses from the test set to an external controller, indicating that some event has occurred. The external controller can then make decisions based on these responses to control the flow of commands to the test set and other devices in the test system.

  1. Force the test set to execute overlapped commands sequentially.
  2. Force the test set to wait until an overlapped command is done executing before executing any more commands.
  3. Query the test set to determine when a command has finished executing.
  4. Query the test set to determine when all commands sent to it have at least begun executing.
  5. Query the test set to determine the current call or data connection processing state.
  6. Program the test set to generate a service request when an operation has completed or the test set is in a certain state.

Commands used for synchronization:

  • :SEQ
    This specialized command can be appended to call processing overlapped commands to support synchronization method one.
    See Call Processing Subsystem Overlapped Commands .

  • :WAIT
    This specialized command can be appended to call processing overlapped commands to support synchronization method two.
    See Call Processing Subsystem Overlapped Commands .

  • :DONE? and :OPC?
    These specialized commands can be appended to call processing overlapped commands to support synchronization method three. See Call Processing Subsystem Overlapped Commands .

  • INITiate:DONE?
    This specialized command causes the test set to return a mnemonic indicating if a measurement is done. If not, the returned mnemonic will indicate if the measurement is still executing. This command supports synchronization method three. See INITiate:DONE? and Measurement Event Synchronization .

  • CALL:STATus[:STATe]?
    This command queries the test set's current call processing state. This command supports synchronization method five. See CALL:STATus[:STATe][:VOICe]? and Call Processing State Synchronization .

  • CALL:CONNected[:STATe]?
    This command determines the connected/idle state of a call. A feature called the change detector provides the user with a way to hold off the response to this query until a call processing state transition has taken place. This command supports synchronization method five. See CALL:CONNected[:STATe]? and Call Processing State Synchronization .

  • CALL:DCONNected[:STATe]?
    This command determines the connected/idle state of a data connection. A feature called the change detector provides the user with a way to hold off the response to this query until a data connection state transition has taken place. This command supports synchronization method five. See CALL:DCONnected[:STATe] and Call Processing State Synchronization .

  • CALL:SMService:STATus:[:STATe]?
    This command queries the test set's current SMS processing state. This command supports synchronization method five. See CALL:SMService:STATus[:STATe]? and SMS (Short Message Service) State Synchronization .

  • CALL:SMService:IDLE:STATe?, CALL:SMService:MSACk:STATe?, CALL:SMService:MSNack:STATe?, CALL:SMService:RECeived:STATe?, CALL:SMService:BSENt:STATe?
    These commands determine the idle/mobile acknowledged/mobile not-acknowledged/received/broadcast sent state of the SMS processing. A feature called the change detector provides the user with a way to hold off the response to these queries until an SMS processing state transition has taken place. These commands support synchronization method five. See CALL:SMService:IDLE[:STATe]? , CALL:SMService:MSACk[:STATe]? , CALL:SMService:MSNack[:STATe]? , CALL:SMService:RECeived[:STATe]? , CALL:SMService:BSENt[:STATe]? , and SMS (Short Message Service) State Synchronization .

  • SYSTem:SYNChronized
    This specialized command puts a 1 in the test set's output queue, the test set responds to the query by sending a 1 to the external controller indicating that all prior sequential commands have completed, and all prior overlapped commands have at least begun execution. The condition bit is set then cleared. This command supports synchronization four and six. See SYSTem:SYNChronized and STATus:OPERation Condition Register Bit Assignments .

  • STATUS:<register>
    Status bits in the STATus:OPERation:CALL Condition Register Bit Assignment register are provided to indicate the test set's call processing state. These bits support synchronization methods five and six.
    Status bits in the STATus:OPERation:FEATures Register Bit Assignments register are provided to indicate the test set's SMS processing state. These bits support synchronization methods five and six.
    Status bits in the STATus:OPERation:NMRReady Register Bit Assignments are provided to indicate when a measurement is ready to be fetched. These bits support synchronization method three and six.
    Many other status bits are provided in the GPIB status subsystem that are useful for synchronization. See STATus Subsystem .

  • *OPC , *OPC? , and *WAI (not recommended)
    Note: These commands look at all of the test set's operations collectively. Because multiple processes are likely to be executing at the same time, it is recommended that the other commands above be used instead.

Related Topics

Call Processing State Synchronization


Programming a TDSO Frame Error Rate Measurement

Programming a TDSO Frame Error Rate Measurement

Last updated: October 28, 2004

This section provides an example of how to make a TDSO (Test Data Service Option) FER measurement via the GPIB.

The following program example assumes that the mobile station's antenna output is connected to the RF IN/OUT connector, and the mobile station has found service.

The basic procedure to test TDSO FER is as follows:

  1. Make a SO 32 (F-SCH) call (see CALL:SOPTion ).
  2. Configure the TDSO FER Setup parameters using the SETup:TFERror subsystem.
  3. Start the TDSO FER measurement using the INITiate subsystem.
  4. Use the FETCh:TFERror command to obtain the measurement results.

Programming Example

10    RE-SAVE "c:\roadhog\programs\tdso_fer.txt"
20    !This program measures tdso (test data service option) frame error rate
30    !See "Receiver Sensitivity and Dynamic Range" in TIA/EIA-98-D for specifications and
standards
40    CLEAR SCREEN
50    A=714
60    !***Specify call parameters***
70    Systype$="DIGITAL2000" !Cell System Type
80    Band$="USPC" !US PCS band
90    Channel=1125 !RF Channel
100   Sid=1 !System Identification
110   Nid=1 !Network Identification
120   Radio_config$="F3R3" !Radio Configuration
130   Service_opt$="SOFS32" !Service Option SO32 (+F-SCH). This service option must be
selected
140   !before bringing up a call for testing tdso fer
141   !
150   !***Specify test parameters***
160   Loss_frequency$="836 MHZ,881 MHZ" !Reverse channel, forward channel frequencies for
amplitude offset (path loss)
170   Expected_loss$="-2,-2" !Path loss at reverse channel, forward channel frequencies
180   Ior=-60 !Cell power
190   Pilot=-7 !Pilot channel power level
200   Traffic=-15.5 !Traffic channel power level
201   Confidence=2 !Confidence requirement ratio
210   !
220   ON TIMEOUT 7,30 CALL Timeout ! Calls "Timeout" routine
240   OUTPUT A;"SYST:COMM:GPIB:DEB:STAT ON" !Turns debug state on
250   !
260   !***Set up path loss***
270   OUTPUT A;"SYSTEM:CORRECTION:SFREQUENCY ";Loss_frequency$ !Enters frequencies in
Amplitude Offset table
280   OUTPUT A;"SYSTEM:CORRECTION:SGAIN ";Expected_loss$ !Enters loss values in Amplitude
Offset table
290   !
300   !***Set up call parameters***
310   OUTPUT A;"CALL:OPER:MODE CALL" !Sets Operating Mode to Active Cell
320   OUTPUT A;"CALL:SYSTEM ";Systype$ !Sets System Type
330   OUTPUT A;"CALL:BAND ";Band$ !Sets Cell Band for selected System Type
340   OUTPUT A;"CALL:CHAN ";Channel ! Sets Channel for selected System Type and Cell Band
350   OUTPUT A;"CALL:POWER -50" !Sets and turns on Cell Power for selected System Type
360   OUTPUT A;"CALL:SID ";Sid! Sets System Identification
370   OUTPUT A;"CALL:NID ";Nid! Sets Network Identification
380   OUTPUT A;"CALL:RCON ";Radio_config$ !Sets Radio Configuration
390   OUTPUT A;"CALL:SOPTION ";Service_opt$ !Sets service option for selected System Type and
Radio Configuration
400   OUTPUT A;"CALL:PROT PREV6" !Sets Protocol Revision for the selected System Type
410   OUTPUT A;"CALL:PAG:DRAT FULL" !Sets Paging channel data rate to full rate
420   OUTPUT A;"CALL:PIL -7"    !Sets Pilot to default
430   OUTPUT A;"CALL:SYNC -16"  !Sets Sync to default
440   OUTPUT A;"CALL:PAG -12"   !Sets Paging to default
450   OUTPUT A;"CALL:FCH -15.6" !Sets Traffic to default
460   !
470   PRINT "Turn on mobile station...press continue when it has found service and registered"
480   PAUSE
490   CLEAR SCREEN
500   OUTPUT A;"CALL:REG:TIMER:STATE 0" !Turns timer-based registrations off
510   WAIT 2 !Waits 2 seconds for any timer-based registrations to clear out
520   !
530   !***Page the mobile station***
540   DISP "Paging mobile station..."
550   OUTPUT A;"CALL:ORIG" !Pages the mobile station
560   OUTPUT A;"CALL:CONNECTED:STATE?" !Queries for connected/idle state...hangs until state
change detector is disarmed
570   ENTER A;Call_connected
580   IF NOT Call_connected THEN
590     DISP "Call attempt failed"
600     STOP
610   ELSE
620     DISP "Call connected"
630   END IF
640   !
650   !***Set up measurement parameters***
660   OUTPUT A;"SETUP:TFERROR:CONTINUOUS OFF" !Sets trigger arm state to single
670   OUTPUT A;"CALL:POW ";Ior ! Sets Cell Power for the selected System Type
680   OUTPUT A;"CALL:PIL ";Pilot !Sets Pilot channel level
690   OUTPUT A;"CALL:FCH ";Traffic !Sets Traffic channel level
691   OUTPUT A;"SETUP:TFERROR:CONFIDENCE:REQUIREMENT:RATIO ";Confidence
700   !
710   !***Obtain measurement results***
720   OUTPUT A;"INITIATE:TFERROR" !Initiates a frame error rate measurement
730   DISP "Measuring TDSO FER"
731   LOOP
732   WAIT 1
740   OUTPUT A;"INIT:DONE?"
760   ENTER A;Tfer_done$
770   EXIT IF Tfer_done$="TFER"
780   END LOOP
800   OUTPUT A;"FETCh:TFERROR?" !Queries the test set for frame error rate measurement results
805   DISP "FER test completed"
810   ENTER A;Integrity,Fer,Rx_good,Rx_blank,Tx_good,Tx_blank,Conf
820   !
940   PRINT "Integrity indicator = ";Integrity
950   PRINT "TDSO FER test results = ";Fer
960   PRINT "Number of received good frames = ";Rx_good
961   PRINT "Number of received blank frames = ";Rx_blank
962   PRINT "Number of transmitted good frames = ";Tx_good
963   PRINT "Number of transmitted blank frames = ";Tx_blank
964   PRINT "Confidence result = ";Conf
970   DISP "Test complete"
980   !***Return to default call processing states***
990   OUTPUT A;"CALL:POW:DIG2000 -50" ! Returns cell power to -50 dBm/1.23 MHz
1000  OUTPUT A;"CALL:REG:TIMER:STATE ON" !Returns timer-based registration to ON
1010  !
1020  OUTPUT A;"CALL:END" !Ends the call
1030  END
1040 Timeout: SUB Timeout    ! Global timeout handler
1050    PRINT "Program timed out"
1060    CLEAR 7
1070    CLEAR 714
1080  SUBEND

Related Topics

TDSO Frame Error Rate Measurement Description

Measuring TDSO (Test Data Service Option) Frame Error Rate (FER)

TDSO Frame Error Rate Troubleshooting

Control Program Example

SETup:TFERror

FETCh:TFERror

INITiate

READ

ABORt

CALL:SOPTion


Triggering of Measurements

Triggering of Measurements

Last updated: October 28, 2004

Description

  • Trigger Source Description
  • Triggering Process Description
  • Trigger Arm (Single or Continuous) Description
  • Trigger Delay Description
  • Trigger Qualifier Description

Trigger Source Description

A measurement trigger causes hardware (for example, a sampler) to capture data which is used by a measurement algorithm to produce a measurement result. Not all of the trigger source choices are available in every measurement, or every test application.

RF Rise Trigger Source:

When RF rise triggering is selected, a measurement dependent threshold is used to define the trigger point on the envelope of the signal being measured. The envelope amplitude must fall below this threshold and remain there for a measurement-dependent period of time before the trigger is armed. After the trigger is armed, a trigger will occur as the envelope amplitude increases and passes through the threshold.

Protocol Trigger Source:

When protocol triggering is selected, a data capture is triggered by a protocol generated signal. The test set's protocol engine knows when the DUT's signal should be present and generates a trigger signal for use by the measurement to trigger the data capture.

External Trigger Source:

When external triggering is selected, the user supplies an external trigger signal via the rear panel TRIG IN connector in order to trigger data capture. The trigger will occur on the rising edge of this signal.

Immediate Trigger Source:

When immediate triggering selected, the trigger occurs as soon as any pre-trigger samples required by the measurement algorithm are taken. Data capture is triggered when the measurement is initiated.

Auto Trigger Source:

When auto triggering is selected, the test set automatically chooses the best trigger source for that measurement. This trigger source setting is convenient because the measurement trigger doesn't need to be changed when switching parameters. Auto trigger source is the best choice for most users.

Triggering Process Description

The triggering process controls the present and future states of the test set during the measurement cycle. Triggers are set up using the SETup commands and can be set up when a measurement is in the inactive state. A measurement is activated (selected) with an INITiate command. If a measurement is initiated while in its measurement cycle, it will terminate that measurement and restart it. The active state is not a single state but a collection of any state other than the inactive state. Deactivating (de-selecting) the measurement is accomplished through an INITiate:<MEAS>:OFF command.

Manually, a measurement is activated by selecting it from the Measurement Selection menu. A measurement is deactivated by pressing the Measurement Selection key, scrolling to measurement in the Measurement Selection menu, and then pressing F4 (Close Measurement) .

The Test Set's Measurement States

Measurement States

The following examples describe states of the test set under various conditions. Refer to The Test Set's Measurement States .

Inactive State

If the test set has just been powered on, or any form of preset has been performed, then the measurement state is inactive.

Wait for Trigger State

If a measurement has been initiated with the INITiate command but has not been triggered, or a measurement has been selected from the Measurement Selection menu but has not been triggered, then the measurement state is wait for trigger.

Measuring and Idle States (Trigger Arm Single)

If the trigger arm is set to single, the trigger source is available, and the trigger qualifier (optional) is satisfied, the measurement state transitions to measuring and measurement results are now available to the user. The state then transitions to idle (awaiting another INITiate).

Measuring State (Trigger Arm Continuous)

If the trigger arm is set to continuous, the trigger source is available, and the trigger qualifier (optional) is satisfied, the measurement state transitions to measuring and measurement results are now available to the user. The measurement is continually triggered until the measurement is deactivated. Measurement results are only available after the measurement completes and before it rearms. The measurement is deactivated using the INITiate:<MEAS>:OFF. or Close Measurement .

Trigger Arm (Single or Continuous) Description

Trigger arm determines if a measurement will make one measurement then return to idle (single), or automatically rearm on completion of a measurement and repeat the process (continuous).

NOTE
When operating the test set remotely, the recommended setting for the trigger arm parameter is single. This ensures proper operation of the INIT:DONE? query which is used to control the retrieval of measurement results when measurements are initiated concurrently.

When a continuously armed measurement gets a result, it is available to any currently pending (waiting, hanging) FETCh? query. Then another measurement cycle is started immediately. At this point the results are no longer valid. The INIT:DONE? query is used to determine when there is a completed measurement with valid results that can be fetched. If you look for a continuously armed measurement with valid results that can be fetched using INIT:DONE? then you are unlikely to get anything but WAIT. Each time the Test Set is queried, it is 99% likely to be making another measurement. Even if it did return a measurement name, by the time the control program determines which FETCh? query to send, it is too late to fetch the results and the FETCh? query just hangs until the next measurement cycle is done, nullifying the efficiency provided by the INIT:DONE? query.

Pressing the Start Single key on the front panel will cause all currently active measurements with trigger arm set to single to arm and make the measurement.

Pressing Shift, Start Single (Stop) causes all measurements with trigger arm set to single to abort the measurement.

It is unnecessary for you to arm a measurement if the trigger arm is set to continuous. When in continuous mode, the measurement is automatically rearmed after completing a measurement.

Trigger Arm Default Settings
Action | Trigger Arm Default Setting
Power up of test set | Continuous
Manual Full Preset | Continuous
*RST (Remote) Full Preset | Single
Partial Preset | No change

Trigger Delay Description

Trigger delay controls the delay time between the trigger and the start of sampling. Resolution is 1 nanosecond per measurement and the units are in seconds. A negative value indicates the sampling should occur prior to the trigger. The default is zero seconds which is preferred for most measurements.

Trigger Qualifier Description

When the trigger qualifier is on, the test set samples the input signal when a trigger is received. It then determines if the input signal was valid by looking at its power level. If the power level during sampling did not meet the requirements of a valid signal, the state returns to wait for trigger without processing the samples. Trigger qualifier is available for GSM/GPRS TX Power and Phase Frequency Error measurements only.

If a valid signal is present, then it is qualified, and the samples are processed.

Related Topics

Integrity Indicator


Programming a TROLP Measurement

Programming a TROLP Measurement

Last updated: October 28, 2004

This section provides an example of how to make a TROLP (test standard TIA/EIA-IS-98D Time Response of Open Loop Power Control) measurement via the GPIB.

The following program example assumes that a mobile station's antenna output is connected to the RF IN/OUT connector, and that the mobile station call parameters are specified in the first section of code.

The basic procedure to test TROLP is as follows:

  1. Make a loopback (SO2, SO9, SO55) call using the CALL:SOPTion commands.
  2. Close any measurements that are currently open.
  3. Set Cell Power (Ior) to -60 dBm/1.23 MHz using the CALL:POWer commands.
  4. Select up or down cell power level step using the SETup:TROPower subsystem.
  5. Start the TROLP measurement using the INITiate subsystem.
  6. Use the FETCh:TROPower command to obtain pass/fail measurement results.
  7. Repeat steps 4 through 6 as needed to test TROLP as outlined in the test standard.

NOTE
Gated power measurement trace data is available using the FETCh:TROPower:TRACe? command.

Programming Example

10    RE-SAVE "c:\roadhog\programs\trolp.txt"
20    !This program measures time response to open loop power control
30    !See "Time Response of Open Loop Power Control" in TIA/EIA-98-D for specifications
40    CLEAR SCREEN
50    A=714
60    !***Specify call parameters***
70    Systype$="DIGITAL2000" !Cell System Type
80    Band$="USC" !Frequency Band
90    Channel=384 !RF Channel
100   Sid=1 !System Identification
110   Nid=1 !Network Identification
120   Radio_config$="F3R3" !This example will test radio configuration 3 only
130   Service_opt$="SO2" !Service Option
150   !
160   !***Specify test parameters***
170   Loss_frequency$="1900 MHZ,1945 MHZ" !frequencies for amplitude offset (path loss)
180   Expected_loss$="-10,-10" !Path loss at reverse channel, forward channel frequencies
190   Ior=-60 !Starting cell power for TROLP testing
200   Pilot=-7 !Pilot channel power level for TROLP testing
210   Traffic=-7.4 !Traffic channel power level for TROLP testing
220   !
230   !
240   ON TIMEOUT 7,20 CALL Timeout ! Calls "Timeout" routine
250   OUTPUT A;"SETUP:TROP:TIMEOUT:STIME 10 S" !Sets TROLP measurement timeout to 10 seconds
260   OUTPUT A;"SYST:COMM:GPIB:DEB:STAT ON" !Turns debug state on
270   !
280   !***Set up path loss***
290   OUTPUT A;"SYSTEM:CORRECTION:SFREQUENCY ";Loss_frequency$ ! Amplitude Offset table
300   OUTPUT A;"SYSTEM:CORRECTION:SGAIN ";Expected_loss$ ! Amplitude Offset table
310   !
320   !***Set up call parameters***
330   OUTPUT A;"CALL:OPER:MODE CALL" !Sets Operating Mode to Active Cell
340   OUTPUT A;"CALL:SYSTEM ";Systype$ !Sets System Type
350   OUTPUT A;"CALL:BAND ";Band$ !Sets Cell Band for selected System Type
360   OUTPUT A;"CALL:CHAN ";Channel ! Sets Channel for selected System Type and Cell Band
370   OUTPUT A;"CALL:POWER -50" !Sets and turns on Cell Power for call setup
380   OUTPUT A;"CALL:SID ";Sid! Sets System Identification
390   OUTPUT A;"CALL:NID ";Nid! Sets Network Identification
400   OUTPUT A;"CALL:RCON ";Radio_config$ !Sets Radio Configuration
410   OUTPUT A;"CALL:SOPTION ";Service_opt$ !service option for System Type and 	Radio Config
420   OUTPUT A;"CALL:PROT PREV6" !Sets Protocol Revision for the selected System Type
430   OUTPUT A;"CALL:PAG:DRAT FULL" !Sets Paging channel data rate to full rate
450   OUTPUT A;"CALL:PIL -7"    !Sets Pilot to default
460   OUTPUT A;"CALL:SYNC -16"  !Sets Sync to default
470   OUTPUT A;"CALL:PAG -12"   !Sets Paging to default
480   OUTPUT A;"CALL:FCH -15.6" !Sets Traffic to default
490   !
500   PRINT "Turn on mobile station...press continue when it has found service and registered"
510   PAUSE
520   CLEAR SCREEN
530   OUTPUT A;"CALL:REG:TIMER:STATE OFF" !Turns timer-based registrations off
540   WAIT 2 !Waits 2 seconds for any timer-based registrations to clear out
550   !
560   !***Page the mobile station***
570   DISP "Paging mobile station..."
580   OUTPUT A;"CALL:ORIG" !Pages the mobile station
590   OUTPUT A;"CALL:CONNECTED:STATE?" !Queries for connected/idle state
600   ENTER A;Call_connected
610   IF NOT Call_connected THEN
620     DISP "Call attempt failed"
630     STOP
640   ELSE
650     DISP "Call connected"
660   END IF
670   !
680   !***Set up measurement parameters***
681   OUTPUT A;"CALL:POW ";Ior ! Sets Cell Power for TROLP measurement
682   OUTPUT A;"CALL:PIL ";Pilot !Sets Pilot channel level
683   OUTPUT A;"CALL:FCH ";Traffic !Sets Traffic channel level
684   !
685   GOSUB Start_meas_down !Steps Ior down 20 dB
686   GOSUB Start_meas_up !Steps Ior up 20 dB
687   GOSUB Start_meas_up !Steps Ior up 20 dB
688   GOSUB Start_meas_down !Steps Ior down 20 dB
689   GOTO End_program
691 Start_meas_down:  ! Subroutine to measure -20 dB step in cell power
692   !***Obtain pass/fail measurement results for 20 dB step down in cell power***
693   OUTPUT A;"SETUP:TROP:STEP DOWN20"
694   OUTPUT A;"INITIATE:TROP" !Initiates a time response of open loop power control
695   DISP "Measuring mobile station response to open loop power control"
696   OUTPUT A;"FETCh:TROP?" !Queries the test set for TROLP measurement results
697   DISP "Time response of open loop power control measurement completed"
698   ENTER A;Integrity,Passfail
699   SELECT Passfail !Assign pass/fail results to a string
700   CASE 0
701     Pass_fail$="PASSED"
702   CASE 1
703     Pass_fail$="FAILED"
704   END SELECT
705   PRINT "Integrity indicator = ";Integrity
706   PRINT "+20 dB step results = ";Pass_fail$
707   RETURN
709   !
710 Start_meas_up:  ! Subroutine to measure +20 dB step in cell power
890   !***Obtain pass/fail measurement results for 20 dB step up in cell power***
891   OUTPUT A;"SETUP:TROP:STEP UP20"
892   OUTPUT A;"INITIATE:TROP" !Initiates a time response of open loop power control
893   DISP "Measuring mobile station response to open loop power control"
894   OUTPUT A;"FETCh:TROP?" !Queries the test set for TROLP measurement results
895   DISP "Time response to open loop power control measurement completed"
896   ENTER A;Integrity,Passfail
897   SELECT Passfail !Assign pass/fail results to a string
898   CASE 0
899     Pass_fail$="PASSED"
900   CASE 1
901     Pass_fail$="FAILED"
902   END SELECT
903   PRINT "Integrity indicator = ";Integrity
904   PRINT "-20 dB step results = ";Pass_fail$
905   RETURN
907   !
917 End_program:  !
990   OUTPUT A;"CALL:END" !Ends the call
1000  END
1010 Timeout: SUB Timeout    ! Global timeout handler
1020    PRINT "Program timed out"
1030    CLEAR 7
1040    CLEAR 714
1050  SUBEND

Related Topics

Time Response of Open Loop Power Control (TROLPC) Measurement Description

Measuring Time Response of Open Loop Power Control (TROLPC)

Time Response of Open Loop Power Control (TROLPC) Troubleshooting

Control Program Example

SETup:TROPower

INITiate

FETCh:TROPower

READ

ABORt


Programming a Wideband Data Deviation Measurement

Programming a Wideband Data Deviation Measurement

General Programming Procedure

  1. Make a call
  2. Configure the Wideband Data Deviation setup parameters using SETup:WDDeviation subsystem.
  3. Start the wideband data deviation measurement using INITiate subsystem.
  4. Change the Analogue MS TX Level value using CALL:MS:ANALog:TXLevel[:IMMediate] .
  5. Use the FETCh:WDDeviation command to obtain the measurement results.

Programming Example

1        ! This program measures the Wideband Data Deviation
3        !
6        CLEAR SCREEN
7        ! E5515C GPIB Address
8        Testset=714
11       Systype$="AMPS"
12       !System Identification
13       Sid=1
14       !
15       ! Calls "Timeout" routine
17       ON TIMEOUT 7,20 CALL Timeout
18       !
19       ! *** Specify call parameters ***
20       OUTPUT Testset;"SYST:COMM:GPIB:DEB:STAT ON"
21       OUTPUT Testset;"SYST:CORR:STAT OFF"
22       ! Sets Operating Mode to be Active Cell
23       OUTPUT Testset;"CALL:OPER:MODE CALL"
24       ! System Type is set to be AMPS
25       OUTPUT Testset;"CALL:SYST ";Systype$
26       ! Set System Identification
27       OUTPUT Testset;"CALL:SID:AMPS";Sid
28       ! Set analog MS TX Level
29       OUTPUT Testset;"CALL:MS:ANAL:TXL 6"
30       !
64       PRINT "Turn on mobile station..."
65       PRINT "Press continue when it has found service and registred"
66       PAUSE
67       !
68       ! *** Paging the mobile station ***
69       PRINT "Paging mobile station..."
70       PRINT "Answer the mobile station when you are ready"
71       OUTPUT Testset;"CALL:ORIG"
72        !Query for connected/idle state
73       OUTPUT Testset;"CALL:CONN:STAT?"
74       ENTER Testset;Call_connected
75       IF NOT Call_connected THEN
76          DISP "Call attempt failed"
77          STOP
78       ELSE
79          DISP "Call connected"
80       END IF
81       PRINT "Connection established, test in progress"
82       !
83       ! *** Setup Wideband data  measurement parameters ***
84       ! Single measurement
85       OUTPUT Testset;"SET:WDD:CONT OFF"
86       OUTPUT Testset;"SET:WDD:GTIM 3"
88       !
96       ! *** Obtain measurement results ***
97       OUTPUT Testset;"INIT:WDD"
98       WAIT 1
99       ! Change Analog MS TX Level value to
100      ! trigger the test set to send Analog MS TX Level Order Message
101      OUTPUT Testset;"CALL:MS:ANAL:TXL 7"
102      WAIT 2
103      OUTPUT Testset;"FETC:WDD:ALL?"
105      ENTER Testset;Integrity,Maxppd,Maxnpd,Settleppd,Settlenpd
106      DISP "Wideband Data Test complete"
107      OUTPUT Testset;"INIT:WDD:OFF"
108      OUTPUT Testset;"CALL:END"
109      ! *** Display the measurement results ***
110      !
111      PRINT "Integrity Indicator = ";Integrity
112      PRINT "Wideband data Max Positive Peak Deviation = ";Maxppd
113      PRINT "Wideband data Max Positive Peak Deviation = ";Maxnpd
114      PRINT "Wideband data Settled Positive Peak Deviation = ";Settleppd
115      PRINT "Wideband data Settled Positive Peak Deviation = ";Settlenpd
121  END
122  !
123  ! Global timeout handler
185  Timeout: SUB Timeout
187                  PRINT "Program timed out"
188                  CLEAR 7
189                  CLEAR 714
190           SUBEND

Returned Values

The measurements returned by this program are:

  • Integrity returns the measurement integrity indicator (see Integrity Indicator ); 0 means a successful measurement with no errors.
  • Maxppd returns the maximum positive peak deviation of carrier over the entire wideband data burst in kHz.
  • Maxnpd returns the maximum negative peak deviation of carrier of the entire wideband data burst in kHz.
  • Settleppd returns the positive peak deviation of carrier over the wideband data burst, not including any peaks found during the first 20 milliseconds of the wideband data burst.
  • Settlenpd returns the negative peak deviation of carrier over the wideband data burst, not including any peaks found during the first 20 milliseconds of the wideband data burst

Related Topics

Wideband Data Deviation Measurement Description

Wideband Data Deviation Troubleshooting

INITiate

SETup:WDDeviation

FETCh:WDDeviation


Programming a Waveform Quality/Code Domain Measurement

Programming a Waveform Quality/Code Domain Measurement

Last updated: October 28, 2004

This section provides an example of how to make a waveform quality measurement via GPIB.

The following program example assumes that the mobile station's antenna output is connected to the RF IN/OUT connector, and the mobile station has found service.

The basic procedure to measure waveform quality is as follows:

  1. Make a call.
  2. Configure the waveform quality measurement setup parameters using the SETup:WQUality subsystem.
  3. Start the waveform quality measurement using the INITiate subsystem.
  4. Use the FETCh:WQUality command to obtain waveform quality measurement results.
  5. Use the FETCh:WQUality:CDPower:ICHannel[:ALL]? or FETCh:WQUality:CDPower:QCHannel[:ALL]? commands to obtain code domain power measurement results.

Programming Example

10    RE-SAVE "c:\roadhog\programs\wqu.txt"
20    !This program measures waveform quality
30    !Refer to "Waveform Quality and Frequency Accuracy" in EIA/TIA-IS-98D for standards and
specifications
40    CLEAR SCREEN
50    A=714
60    !***Specify call parameters***
70    Systype$="DIGITAL2000" !Cell System Type
80    Band$="USCELLULAR" !Cell band
90    Channel=384 !RF Channel
100   Sid=1 !System Identification
110   Nid=1 !Network Identification
120   Radio_config$="F3R3" !Radio Configuration
130   Service_opt$="SO2"   !Loopback service option
140   !
150   !***Specify test parameters***
160   Loss_frequency$="851 MHZ,896 MHZ" !Reverse channel, forward channel frequencies for
amplitude offset (path loss)
170   Expected_loss$="-2,-2" !Path loss at reverse channel, forward channel frequencies
180   Ior=-50!Cell power
190   Pilot=-7 !Pilot channel power level
200   Traffic=-7.4 !Traffic channel power level
210   !
220   ON TIMEOUT 7,20 CALL Timeout ! Calls "Timeout" routine
230   OUTPUT A;"SETUP:WQU:TIMEOUT:STIME 10 S" !Sets waveform quality measurement timeout to 10
seconds
240   OUTPUT A;"SYST:COMM:GPIB:DEB:STAT ON"!Turns debug state on
250   !
260   !***Set up call parameters***
270   OUTPUT A;"CALL:OPER:MODE CALL" !Sets Operating Mode to Active Cell
280   OUTPUT A;"CALL:SYSTEM ";Systype$ !Sets System Type
290   OUTPUT A;"CALL:BAND ";Band$ !Sets Cell Band for selected System Type
300   OUTPUT A;"CALL:CHAN ";Channel !Sets RF Channel for selected System Type and Cell Band
310   OUTPUT A;"CALL:POW -35" !Sets and turns on Cell Power
320   OUTPUT A;"CALL:SID ";Sid! Sets System Identification
330   OUTPUT A;"CALL:NID ";Nid! Sets Network Identification
340   OUTPUT A;"CALL:RCON ";Radio_config$!Sets Radio configuration
350   OUTPUT A;"CALL:SOPTION ";Service_opt$ !Sets service option for selected System Type and
Radio Configuration
360   OUTPUT A;"CALL:PROT PREV6" !Sets Protocol Revision for the selected System Type
370   OUTPUT A;"CALL:PAG:DRAT FULL" !Sets Paging data rate to full rate
380   OUTPUT A;"CALL:PIL -7"    !Sets pilot to default
390   OUTPUT A;"CALL:SYNC -16"  !Sets sync to default
400   OUTPUT A;"CALL:PAG -12"   !Sets paging to default
410   OUTPUT A;"CALL:FCH -15.6" !Sets traffic to default
420   !
430   PRINT "Turn on mobile station...press continue when it has found service and registered"
440   PAUSE
450   CLEAR SCREEN
460   OUTPUT A;"CALL:REGISTER:TIMER:STATE OFF" !Turns off timer-based registrations
470   WAIT 2 ! Waits for any timer-based registrations to clear out
480   !
490   !***Page the mobile station***
500   DISP "Paging mobile station..."
510   OUTPUT A;"CALL:ORIG" !Pages the mobile station520   OUTPUT A;"CALL:CONNECTED:STATE?" !Queries for connected/idle state...hangs until state change detector is disarmed
530   ENTER A;Call_connected
540   IF NOT Call_connected THEN
550     DISP "Call attempt failed"
560     STOP
570   ELSE
580     DISP "Call connected"
590   END IF
600   !
610   !***Set up measurement parameters***
620   OUTPUT A;"SETUP:WQUALITY:CONTINUOUS OFF" !Sets trigger arm state to single
630   OUTPUT A;"CALL:POW ";Ior !Sets Cell Power for the selected System Type
640   OUTPUT A;"CALL:CLPCONTROL:REVERSE:MODE ALT" !Alternating up/down power control bits
650   OUTPUT A;"CALL:PIL ";Pilot !Sets Pilot channel level
660   OUTPUT A;"CALL:FCH ";Traffic !Sets Fundamental (Traffic) channel level
661   OUTPUT A;"SETUP:WQUALITY:CDPOWER:IQINactive:LIMIT -23"
670   !
680   !***Obtain and display waveform quality measurement results***
690   WAIT 1
700   OUTPUT A;"INITIATE:WQUALITY" !Initiates a Waveform Quality measurement
760   OUTPUT A;"FETCh:WQUALITY?" !Queries the test set for waveform quality measurement
results
770   ENTER A;Integrity,Rho,Freq_error,Time_error,Carr_feed,Phase_err,Mag_err,Evm
780   PRINT "Integrity indicator = ";Integrity
790   PRINT "Rho = ";Rho,"Frequency error = ";Freq_error,"Time error = ";Time_error,"Carrier
feedthrough = ";Carr_feed
800   PRINT "Phase error = ";Phase_err,"Magnitude error = ";Mag_err,"Error vector magnitude =
";Evm
801   !
802   !***Obtain and display code domain power pass/fail measurement results***
803   OUTPUT A;"FETCh:WQUality:CDPower:IQINactive?"
804   ENTER A;Iq_passfail
805   SELECT Iq_passfail
806   CASE 0
807     PRINT "Code domain power passed"
808   CASE 1
809     PRINT "Code domain power failed"
811   END SELECT
813   !***Obtain and display code domain power measurement results (I-channel)***
814   DIM Ichannel$[1000]
815   OUTPUT A;"FETCh:WQUALITY:CDPower:ICH?"
816   ENTER A;Ichannel$
830   INTEGER I,Comma,Nextcomma !I represents the 16 bins, Comma is the current substring position
840   Comma=1 !Initialize Comma to the first character of the Ichannel$ ascii character string
860   PRINT "I-Channel active/inactive = ";Ichannel$[Comma;16]
870   Comma=Comma+17
890   PRINT "I-channel bin 0 walsh channel number = ";Ichannel$[Comma;16]
891   Comma=Comma+17
900   PRINT "I-channel bin 0 spread factor = ";Ichannel$[Comma;16]
905   Comma=Comma+17
910   PRINT "I-channel bin 0 power level = ";Ichannel$[Comma;16]
920   DISP "Test complete"
930   !
940   !***Return to default call processing settings***
950   OUTPUT A;"CALL:CLPCONTROL:REVERSE:MODE ACTIVE" !Return to active power control bits
960   OUTPUT A;"CALL:POW:DIG2000 -50" ! Returns cell power to -50 dBm/1.23 MHz
970   OUTPUT A;"CALL:END"
980   END
990 Timeout: SUB Timeout     ! Global timeout handler (from Step 1)
1000    PRINT "Program timed out"
1010    CLEAR 7
1020    CLEAR 714
1030  SUBEND

Related Topics

Waveform Quality/Code Domain Measurement Description

Measuring Waveform Quality/Code Domain Power

Waveform Quality Measurement Troubleshooting

Control Program Example

SETup:WQUality

FETCh:WQUality

INITiate

READ

ABORt


E1962B and E6702B Applications: GPIB Command Revision Information

E1962B and E6702B Applications: GPIB Command Revision Information

Last updated: June 13, 2007

The table below indicates new and revised GPIB commands for the cdma2000 test and lab applications at each release.

  • GPIB Changes for E1962B B.13, E6702B B.06 - July 2007
  • GPIB Changes for E1962B B.12, E6702B B.05 - December 2006
  • GPIB Changes for E1962B B.11.06, E6702B B.04.16 - July 2006
  • GPIB Changes for E1962B B.10, E6702B B.03.10 - December 2005
  • GPIB Changes for E6702B B.03 - August 2005
  • GPIB Changes for E1962B B.09.14 - April 2005
  • GPIB Changes for E1962B B.08, E6702B B.02 - December 2004
GPIB Changes for E1962B B.13, E6702B B.06 - July 2007
GPIB Command | New | Revised | Test Application | Lab Application
CALL:BAND |  | X | X | X
CALL:CHANnel[:SELected]:NMT450 (see CALL:CHANnel ) |  | X | X | X
CALL:CHANnel:DIGital2000:NMT450 (see CALL:CHANnel ) |  | X | X | X
CALL:CHANnel:DIGital95:NMT450 (see CALL:CHANnel ) |  | X | X | X
CALL:SETup:BAND[:SELected] (see CALL:SETup ) |  | X | X | X
CALL:SETup:BAND:DIGital2000 (see CALL:SETup ) |  | X | X | X
CALL:SETup:BAND:DIGital95 (see CALL:SETup ) |  | X | X | X
CALL:SETup:CHANnel[:SELected]:NMT450 (see CALL:SETup ) |  | X | X | X
CALL:SETup:CHANnel:DIGital2000:NMT450 (see CALL:SETup ) |  | X | X | X
CALL:SETup:CHANnel:DIGital95:NMT450 (see CALL:SETup ) |  | X | X | X
CALL[:CELL]:SOPTion[:SELected][:SELected] |  | X | X | X
CALL[:CELL]:SOPTion:LOOPback:DSOurce:RESet[:STATe] | X |  | X | X
SETup:CMAudio:SDIStortion:SBWidth:UPLink | X |  | X | X
SYSTem:APPLication:CATalog[:NAME]? |  | X | X | X
SYSTem:APPLication:CATalog:LICense:APPLication:ALL? |  | X | X | X
GPIB Changes for E1962B B.12, E6702B B.05 - December 2006
GPIB Command | New | Revised | Test Application | Lab Application
CALL:BAND |  | X | X | X
CALL:CHANnel[:SELected]:AWService (see CALL:CHANnel ) | X |  | X | X
CALL:CHANnel:DIGital2000:AWService (see CALL:CHANnel ) | X |  | X | X
CALL:CHANnel:DIGital95:AWService (see CALL:CHANnel ) | X |  | X | X
CALL:MS:REPorted:BCLass? |  | X | X | X
CALL:SCHannel:REVerse:DRATe:RCONfig5 | X |  |  | X
CALL:SETup:BAND[:SELected] (see CALL:SETup ) |  | X | X | X
CALL:SETup:BAND:DIGital2000 (see CALL:SETup ) |  | X | X | X
CALL:SETup:BAND:DIGital95 (see CALL:SETup ) |  | X | X | X
CALL:SETup:CHANnel[:SELected]:AWService (see CALL:SETup ) | X |  | X | X
CALL:SETup:CHANnel:DIGital2000:AWService (see CALL:SETup ) | X |  | X | X
CALL:SETup:CHANnel:DIGital95:AWService (see CALL:SETup ) | X |  | X | X
CALL[:CELL]:SOPTion:SO33:CHANnel:CONFigure | X |  |  | X
CALL:STATus:SCHannel:FORWard:ASSigned? | X |  |  | X
CALL:STATus:SCHannel:FORWard:ENCoder? | X |  |  | X
CALL:STATus:SCHannel:REVerse:ASSigned? | X |  |  | X
CALL:STATus:SCHannel:REVerse:ENCoder? | X |  |  | X
SYSTem:APPLication:CATalog[:NAME]? |  | X | X | X
SYSTem:APPLication:CATalog:LICense:APPLication:ALL? |  | X | X | X
GPIB Changes for E1962B B.11.06, E6702B B.04.16 - July 2006
GPIB Command | New | Revised | Test Application | Lab Application
ABORt:CFDTune (see ABORt ) | X |  | X* | X
CALL:BAND |  | X | X | X
CALL:CHANnel[:SELected]:USPCs1900 (see CALL:CHANnel ) | X |  | X | X
CALL:CHANnel:DIGital2000:USPCs1900 (see CALL:CHANnel ) | X |  | X | X
CALL:CHANnel:DIGital95:USPCs1900 (see CALL:CHANnel ) | X |  | X | X
CALL:CPNumber2:PLAN | X |  |  | X
CALL:CPNumber2:PRESentation[:INDicator] | X |  |  | X
CALL:CPNumber2:SCReening[:INDicator] | X |  |  | X
CALL:CPNumber2:TA2000 | X |  |  | X
CALL:CPNumber2:TYPE | X |  |  | X
CALL:SETup:BAND[:SELected] (see CALL:SETup ) |  | X | X | X
CALL:SETup:BAND:DIGital2000 (see CALL:SETup ) |  | X | X | X
CALL:SETup:BAND:DIGital95 (see CALL:SETup ) |  | X | X | X
CALL:SETup:CHANnel[:SELected]:USPCs1900 (see CALL:SETup ) | X |  | X | X
CALL:SETup:CHANnel:DIGital2000:USPCs1900 (see CALL:SETup ) | X |  | X | X
CALL:SETup:CHANnel:DIGital95:USPCs1900 (see CALL:SETup ) | X |  | X | X
CALL:SMService:HTTProtocol:INPut | X |  |  | X
CALL:SMService:HTTProtocol:OUTPut | X |  |  | X
CALL:SMService:MTERminated:MDMode | X |  |  | X
CALL:SMService:MTERminated:MDMode:INCLusion | X |  |  | X
CALL:SMService:MTERminated:TELeservice |  | X |  | X
CALL:SSERvice:WAITing:CPNumber[1]:CONNect | X |  |  | X
CALL:SSERvice:WAITing:CPNumber[1]:DCONnect | X |  |  | X
CALL:SSERvice:WAITing:CPNumber[1]:STATus[:STATe]? | X |  |  | X
CALL:SSERvice:WAITing:CPNumber2:CONNect | X |  |  | X
CALL:SSERvice:WAITing:CPNumber2:DCONnect | X |  |  | X
CALL:SSERvice:WAITing:CPNumber2:STATus[:STATe]? | X |  |  | X
FETCh:CFDTune[:ALL]? | X |  | X* | X
FETCh:CFDTune:INTegrity? | X |  | X* | X
INITiate:CFDTune[:ON] (see INITiate ) | X |  | X* | X
INITiate:CFDTune:ARMed? | X |  | X* | X
INITiate:CFDTune:OFF (see INITiate ) | X |  | X* | X
INITiate:DONE:FLAG:CFDTune (see INITiate ) | X |  | X* | X
READ:CFDTune[:ALL]? | X |  | X* | X
SETup:CFDTune:FREQuency:STEP:COUNt | X |  | X* | X
SETup:CFDTune:MS:RX:FREQuency:STEP[:VALues] | X |  | X* | X
SETup:CFDTune:MS:RX:FREQuency:STEP:STARt:[INDex] | X |  | X* | X
SETup:CFDTunee:MS:RX:POWer:STEP[:LEVels] | X |  | X* | X
SETup:CFDTune:MS:RX:POWer:STEP:STARt:[INDex] | X |  | X* | X
SETup:CFDTune:MS:TX:FREQuency:STEP[:VALues] | X |  | X* | X
SETup:CFDTune:MS:TX:FREQuency:STEP:STARt:[INDex] | X |  | X* | X
SETup:CFDTune:MS:TX:POWer:STEP[:LEVels] | X |  | X* | X
SETup:CFDTune:MS:TX:POWer:STEP:STARt:[INDex] | X |  | X* | X
SETup:CFDTune:POWer:STEP:COUNt | X |  | X* | X
SETup:CFDTune:TIMeout[:STIMe] | X |  | X* | X
SETup:CFDTune:TIMeout:STATe | X |  | X* | X
SETup:CFDTune:TIMeout:TIME | X |  | X* | X
SYSTem:APPLication:CATalog[:NAME]? (see SYSTem:APPLication ) |  | X | X | X
SYSTem:APPLication:CATalog:LICense:APPLication:ALL? (see SYSTem:APPLication ) |  | X | X | X
SYSTem:INSTrument | X |  | X | X

* Only applicable to the lab application or feature-licensed test application.

GPIB Changes for E1962B B.10, E6702B B.03.10 - December 2005
GPIB Command | New | Revised | Test Application | Lab Application
CALL[:CELL]:BIDentity | X |  | X | X
CALL[:CELL]:CSTime:DATE | X |  | X | X**
CALL[:CELL]:CSTime:DSTime | X |  | X | X**
CALL[:CELL]:CSTime:LOCal:LEAP | X |  | X | X**
CALL[:CELL]:CSTime:LOCal:OFFSet:[SELected] | X |  | X | X**
CALL[:CELL]:CSTime:LOCal:OFFSet:TA2000 | X |  | X | X**
CALL[:CELL]:CSTime:TIME | X |  | X | X**
CALL[:CELL]:MEIDentifier:SUPPort[:ENABle] | X |  | X | X
CALL[:CELL]:PLCMask:TYPE | X |  | X | X
CALL[:CELL[1]]:FCHannel[:FORWard]:SOURce |  | X | X | X
CALL[:CELL[1]]:TRAFfic[:FORWard]:SOURce |  | X | X | X
CALL:CHANnel[:SELected][:SELected] |  | X | X | X
CALL:DATA:PDSNode:EXTernal:TIMeout[:CONNect] |  | X |  | X
CALL:RTVocoder:DECoder:HEADroom? | X |  | X | X
CALL:RTVocoder:ENCoder:DRATe | X |  | X | X
CALL:RTVocoder:ENCoder:DRATe:MODE | X |  | X | X
CALL:RTVocoder:ENCoder:HEADroom? | X |  | X | X
CALL:RTVocoder:INPut:VOLTage[:EXPected] | X |  | X | X
CALL:RTVocoder:OUTPut:VOLTage[:MAXimum] | X |  | X | X
CALL:MS:REPorted:MEIDentifier:[:DECimal]? | X |  | X | X
CALL:MS:REPorted:MEIDentifier:HEX? | X |  | X | X
CALL:MS:REPorted:MEIDentifier:QUERy | X |  | X | X
CALL:MS:REPorted:MEIDentifier:SUPPorted? | X |  | X | X
CALL:SECurity:AUTHenticate:CLEar[:ALL] | X |  | X * | X
CALL:SECurity:AUTHenticate:GCHallenge:CHIStory:EXPected? | X |  | X * | X
CALL:SECurity:AUTHenticate:GCHallenge:CHIStory:RECeived? | X |  | X * | X
CALL:SECurity:AUTHenticate:GCHallenge:CHIStory:RESult? | X |  | X * | X
CALL:SECurity:AUTHenticate:GCHallenge:CRANdom:EXPected? | X |  | X * | X
CALL:SECurity:AUTHenticate:GCHallenge:CRANdom:RECeived? | X |  | X * | X
CALL:SECurity:AUTHenticate:GCHallenge:CRANdom:RESult? | X |  | X * | X
CALL:SECurity:AUTHenticate:GCHallenge:ENABle | X |  | X * | X
CALL:SECurity:AUTHenticate:GCHallenge:MODE:EXPected? | X |  | X * | X
CALL:SECurity:AUTHenticate:GCHallenge:MODE:RECeived? | X |  | X * | X
CALL:SECurity:AUTHenticate:GCHallenge:MODE:RESult? | X |  | X * | X
CALL:SECurity:AUTHenticate:GCHallenge:RANDom | X |  | X * | X
CALL:SECurity:AUTHenticate:GCHallenge:RESPonse:EXPected? | X |  | X * | X
CALL:SECurity:AUTHenticate:GCHallenge:RESPonse:RECeived? | X |  | X * | X
CALL:SECurity:AUTHenticate:GCHallenge:RESPonse:RESult? | X |  | X * | X
CALL:SECurity:AUTHenticate:GCHallenge:RESult? | X |  | X * | X
CALL:SECurity:AUTHenticate:GCHallenge:TYPE? | X |  | X * | X
CALL:SECurity:AUTHenticate:SSDA:ZERO? | X |  | X * | X
CALL:SECurity:AUTHenticate:SUPDate:AKEY | X |  | X * | X
CALL:SECurity:AUTHenticate:SUPDate:CDIGits? | X |  | X * | X
CALL:SECurity:AUTHenticate:SUPDate:RANDom | X |  | X * | X
CALL:SECurity:AUTHenticate:SUPDate:RESult? | X |  | X * | X
CALL:SECurity:AUTHenticate:SUPDate:STARt | X |  | X * | X
CALL:SECurity:AUTHenticate:SUPDate:TYPE? | X |  | X * | X
CALL:SECurity:AUTHenticate:UCHallenge:RANDom | X |  | X * | X
CALL:SECurity:AUTHenticate:UCHallenge:RESPonse:EXPected? | X |  | X * | X
CALL:SECurity:AUTHenticate:UCHallenge:RESPonse:RECeived? | X |  | X * | X
CALL:SECurity:AUTHenticate:UCHallenge:RESPonse:RESult? | X |  | X * | X
CALL:SECurity:AUTHenticate:UCHallenge:RESult? | X |  | X * | X
CALL:SECurity:AUTHenticate:UCHallenge:STARt | X |  | X * | X
CALL:SECurity:AUTHenticate:UCHallenge:TYPE? | X |  | X * | X
CALL:SETup:CHANnel[:SELected][:SELected] |  | X | X | X
CALL:STATus:CSTime:LOCal:DATE? | X |  | X | X**
CALL:STATus:CSTime:LOCal:TIME? | X |  | X | X**
CALL:STATus:PAGing:IMSI:S1? | X |  | X | X
CALL:STATus:PAGing:IMSI:S2? | X |  | X | X

* Requires CDMA 2000 Authentication feature license opt 403. To find out how to acquire the required feature license, visit:http://www.agilent.com/find/8960upgrades

** These commands have been available in the pre-release E6702B B.03 in August 2005.

GPIB Changes for E6702B B.03 - August 2005
GPIB Command | New | Revised | Test Application | Lab Application
CALL[:CELL]:CSTime:DATE | X |  |  | X
CALL[:CELL]:CSTime:DSTime | X |  |  | X
CALL[:CELL]:CSTime:LOCal:LEAP | X |  |  | X
CALL[:CELL]:CSTime:LOCal:OFFSet:[SELected] | X |  |  | X
CALL[:CELL]:CSTime:LOCal:OFFSet:TA2000 | X |  |  | X
CALL[:CELL]:CSTime:TIME | X |  |  | X
CALL:STATus:CSTime:LOCal:DATE? | X |  |  | X
CALL:STATus:CSTime:LOCal:TIME? | X |  |  | X
SYSTem:STATus:COMMunicate:LAN:EXTernal:SYNChronize:INDication? | X |  |  | X
SYSTem:COMMunicate:LAN:EXTernal:ADDRess | X |  |  | X
SYSTem:COMMunicate:LAN:EXTernal:SYNChronize | X |  |  | X
SYSTem:COMMunicate:LAN:EXTernal:SYNChronize:INDication:CLEar | X |  |  | X
GPIB Changes for E1962B B.09.14 - April 2005
GPIB Command | New | Revised | Test Application | Lab Application
SETup:FM:GTIMe | X |  | X |
SETup:FM:FILTer[:TYPE] |  | X | X |
SETup:FM:DETector[:TYPE] |  | X | X |
SETup:SMONitor:BANDwidth|BWIDth:AUTO | X |  | X |
SETup:SMONitor:BANDwidth|BWIDth:MANual | X |  | X |
SETup:SMONitor:DETector[:TYPE] | X |  | X |
SYSTem:FATal:ERRor:RESTart | X |  |  |
GPIB Changes for E1962B B.08, E6702B B.02 - December 2004
GPIB Command | New | Revised | Test Application | Lab Application
CALL[:CELL]:BCCHannel[:SLEVel]<[:SELected]|:DIGital2000> | X |  | X * | X
CALL[:CELL]:BCCHannel:DRATe | X |  | X * | X
CALL[:CELL]:BCCHannel:LEVel<[:SELected]|:DIGital2000> | X |  | X * | X
CALL[:CELL]:BCCHannel:STATe<[:SELected]|:DIGital2000> | X |  | X * | X
CALL[:CELL]:CCCHannel[:SLEVel]<[:SELected]|:DIGital2000> | X |  | X * | X
CALL[:CELL]:CCCHannel:DRATe | X |  | X * | X
CALL[:CELL]:CCCHannel:LEVel<[:SELected]|:DIGital2000> | X |  | X * | X
CALL[:CELL]:CCCHannel:STATe<[:SELected]|:DIGital2000> | X |  | X * | X
CALL[:CELL]:FPControl:EIBCount[:ALL]? | X |  |  | X
CALL[:CELL]:FPControl:EIBCount:CLEar | X |  |  | X
CALL[:CELL]:FPControl:EIBCount:STARt | X |  |  | X
CALL[:CELL]:FPControl:EIBCount:STOP | X |  |  | X
CALL[:CELL]:FPControl:FCHannel:FERate:TARGet | X |  |  | X
CALL[:CELL]:FPControl:FCHannel:LEVel:MAXimuml | X |  |  | X
CALL[:CELL]:FPControl:FCHannel:SETPoint:INITial | X |  |  | X
CALL[:CELL]:FPControl:FCHannel:SETPoint:MAXimum | X |  |  | X
CALL[:CELL]:FPControl:FCHannel:SETPoint:MINimum | X |  |  | X
CALL[:CELL]:FPControl:MODE | X |  |  | X
CALL[:CELL]:FPControl:OLReport:CLEar | X |  |  | X
CALL[:CELL]:FPControl:OLReport:FCHannel:SETPoint:CURRent? | X |  |  | X
CALL[:CELL]:FPControl:OLReport:REQuest | X |  |  | X
CALL[:CELL]:FPControl:STEP | X |  |  | X
CALL[:CELL]:PARameter:EACCess:DRATe[:SUPPorted] | X |  | X * | X
CALL[:CELL]:PARameter:EACCess:ICORrection[:MAXimum] | X |  | X * | X
CALL[:CELL]:PARameter:EACCess:ICORrection:THReshold | X |  | X * | X
CALL[:CELL]:PARameter:EACCess:POWer:INITial | X |  | X * | X
CALL[:CELL]:PARameter:EACCess:POWer:NOMinal | X |  | X * | X
CALL[:CELL]:PARameter:EACCess:POWer:STEP[:LEVel] | X |  | X * | X
CALL[:CELL]:PARameter:EACCess:POWer:STEP:COUNt | X |  | X * | X
CALL[:CELL]:PARameter:EACCess:RLGain:CTPilot | X |  | X * | X
CALL[:CELL]:PROTocol[:SELected] |  | X | X * | X
CALL[:CELL]:PROTocol:DIGital2000 |  | X | X * | X
CALL[:CELL]:PROTocol:CCHannel:CONFigure | X |  | X * | X
CALL[:CELL[1]]:FCHannel[:FORWard]:SOURce |  | X | X | X
CALL[:CELL[1]]:FCHannel:REVerse:GATing | X |  |  | X
CALL[:CELL[1]]:TRAFfic[:FORWard]:DRATe |  | X |  | X
CALL[:CELL[1]]:TRAFfic[:FORWard]:SOURce |  | X | X | X
CALL[:CELL[1]]:TRAFfic[:FORWard]:FPATtern:BAD | X |  |  | X
CALL[:CELL[1]]:TRAFfic[:FORWard]:FPATtern:GOOD | X |  |  | X
CALL[:CELL[1]]:TRAFfic[:FORWard]:FPATtern:STATe | X |  |  | X
CALL[:CELL[1]]:TRAFfic[:FORWard]:FPATtern:SFQuality | X |  |  | X
CALL:DATA:PDSNode:EXTernal:TIMeout[:CONNect] | X |  |  | X
CALL:DORMant[:STATe]? | X |  |  | X
CALL:FUNCtion:DATA:DORMant | X |  |  | X
CALL:MS:FERate:REPort:BAD? | X |  |  | X
CALL:MS:FERate:REPort:CLEar | X |  |  | X
CALL:MS:FERate:REPort:DELay | X |  |  | X
CALL:MS:FERate:REPort:INTerval | X |  |  | X
CALL:MS:FERate:REPort:PERiod[:STATe] | X |  |  | X
CALL:MS:FERate:REPort:RATio? | X |  |  | X
CALL:MS:FERate:REPort:THReshold[:STATe] | X |  |  | X
CALL:MS:FERate:REPort:THReshold:BAD | X |  |  | X
CALL:MS:FERate:REPort:TOTal? | X |  |  | X
CALL:SCHannel:REVerse:DRATe:MAXimum | X |  | X | X
CALL:STATus[:STATe]:DATA? |  | X |  | X
CALL:STATus:BCCHannel[:LEVel]<[:SELected]|:DIGital2000>? | X |  | X * | X
CALL:STATus:BCCHannel:STATe<[:SELected]|:DIGital2000>? | X |  | X * | X
CALL:STATus:BCCHannel:EBNTotal? | X |  |  | X
CALL:STATus:CCCHannel[:LEVel]<[:SELected]|:DIGital2000>? | X |  | X * | X
CALL:STATus:CCCHannel:STATe<[:SELected]|:DIGital2000>? | X |  | X * | X
CALL:STATus:CCCHannel:EBNTotal? | X |  |  | X
CALL:STATus:FPControl:FCHannel:LEVel:MAXimum? | X |  |  | X
FETCh:CFERror:EBNTotal[:AVERage]? | X |  |  | X
FETCh:CFERror:EBNTotal:MAXimum? | X |  |  | X
FETCh:CFERror:EBNTotal:MINimum? | X |  |  | X
FETCh:CFERror:EBNTotal:FAIL? | X |  |  | X
FETCh:CMAudio[:ALL]? | X |  | X | X
FETCh:CMAudio:DISTortion[:AVERage]? | X |  | X | X
FETCh:CMAudio:FREQuency[:AVERage]? | X |  | X | X
FETCh:CMAudio:ICOunt? | X |  | X | X
FETCh:CMAudio:INTegrity? | X |  | X | X
FETCh:CMAudio:LEVel? | X |  | X | X
FETCh:CMAudio:LEVel:LIMit:FAIL? | X |  | X | X
FETCh:CMAudio<:SINad|:SNDRatio>[:AVERage]? | X |  | X | X
FETCh:CMAudio:VOLTage[:AVERage]? | X |  | X | X
INITiate<:measurement mnemonic>[:ON] |  | X | X | X
INITiate<:measurement mnemonic>:OFF |  | X | X | X
INITiate:DONE? |  | X | X | X
INITiate:DONE:FLAG<:measurement mnemonic> |  | X | X | X
INITiate:ON? |  | X | X | X
READ:CMAudio[:ALL]? | X |  | X | X
SETup:CFERror:CONFidence:REQuirement[:RATio] |  | X | X | X
SETup:CFERror:COUNt:MINimum | X |  | X | X
SETup:CFERror:EBNTotal[:LIMit] | X |  |  | X
SETup:CMAudio:ANALyzer:DOWNlink:SETTling | X |  | X | X
SETup:CMAudio:ANALyzer:FREQuency:ALL[:SVALue] | X |  | X | X
SETup:CMAudio:ANALyzer:FREQuency:ALL:GENerator | X |  | X | X
SETup:CMAudio:CONTinuous | X |  | X | X
SETup:CMAudio:COUNt[:SNUMber] | X |  | X | X
SETup:CMAudio:COUNt:NUMBer | X |  | X | X
SETup:CMAudio:COUNt:STATe | X |  | X | X
SETup:CMAudio:GENerator:FREQuency:DOWNlink:ALL[:SVALue]? | X |  | X | X
SETup:CMAudio:GENerator:FREQuency:DOWNlink:PRESet | X |  | X | X
SETup:CMAudio:GENerator:FREQuency:Uplink:ALL[:SVALue] | X |  | X | X
SETup:CMAudio:GENerator:FREQuency:Uplink:PRESet | X |  | X | X
SETup:CMAudio:GENerator:LEVel:DOWNlink:ALL[:SAMPlitude]? | X |  | X | X
SETup:CMAudio:GENerator:LEVel:DOWNlink:ALL:TOTal[:SAMPlitude] | X |  | X | X
SETup:CMAudio:GENerator:LEVel:DOWNlink:ALL:TOTal:AMPlitude | X |  | X | X
SETup:CMAudio:GENerator:LEVel:DOWNlink:ALL:TOTal:STATe? | X |  | X | X
SETup:CMAudio:GENerator:LEVel:UPLink:ALL[:SAMPlitude] | X |  | X | X
SETup:CMAudio:GENerator:LEVel:UPLink:ALL:TOTal[:SAMPlitude] | X |  | X | X
SETup:CMAudio:GENerator:LEVel:UPLink:ALL:TOTal:AMPLitude | X |  | X | X
SETup:CMAudio:GENerator:LEVel:UPLink:ALL:TOTal:STATe | X |  | X | X
SETup:CMAudio:GENerator:LEVel:UPLink:ALL:TOTal:STATe | X |  | X | X
SETup:CMAudio:LEVel:ALL:LIMit:LOWer | X |  | X | X
SETup:CMAudio:LEVel:ALL:LIMit:UPPer | X |  | X | X
SETup:CMAudio:MEASurement:MODE | X |  | X | X
SETup:CMAudio:PEAK:VOLTage | X |  | X | X
SETup:CMAudio:REFerence:ABSolute:LEVel:DOWNlink | X |  | X | X
SETup:CMAudio:REFerence:ABSolute:LEVel:UPLink | X |  | X | X
SETup:CMAudio:REFerence:MODE | X |  | X | X
SETup:CMAudio:REFerence:RELative:TONE | X |  | X | X
SETup:CMAudio:SDIStortion:STATe | X |  | X | X
SETup:CMAudio:SETTling[:TIME] | X |  | X | X
SETup:CMAudio:TIMeout[:STIMe] | X |  | X | X
SETup:CMAudio:TIMeout:STATe | X |  | X | X
SETup:CMAudio:TIMeout:TIME | X |  | X | X
SYSTem:APPLication:CATalog:LICense:APPLication:ALL? | X |  | X | X
SYSTem:APPLication:CATalog:LICense:APPLication:COUNt? | X |  | X | X

* Requires CDMA 2000 Release A feature license. To find out how to acquire the required feature license, visit:


E1962B cdma2000/IS-95/AMPS Test Application Revision Information

E1962B cdma2000/IS-95/AMPS Test Application Revision Information

Last updated: August 24, 2007

This document describes the features in the Agilent Technologies E1962B CDMA2000 Mobile Test Application releases. This document contains the original features, as well as enhancements that have been added over time.

CAUTION
You may need to upgrade the hardware in your test set before installing the application firmware described here. If you install application firmware on a test set with incompatible hardware, the following may occur:

  • Your test set may lock up (see Test Set Lockup During Power Up Sequence ).
  • The application may not run.
  • Some features in the application may be inaccessible, or may not perform to specifications.

To determine if a hardware upgrade is required for your testing needs, please review the hardware requirement information at:

http://www.agilent.com/find/8960upgrades

Select the appropriate link below to view the required release.

  • B.13.08 Release - July 2007
  • B.12.21 Release - May 2007
  • B.12.17 Release - March 2007
  • B.12.12 Release - December 2006
  • B.11.06 Release - July 2006
  • B.10.11 Release - January 2006
  • B.09.14 Release - April 2005
  • B.08.20 Release - December 2004
  • B.07.28 Release - April 2004
  • B.07.15 release - December 2003
  • B.06.42 release - June 2003
  • B.06.30 release - February 2003
  • B.05.20 release - June 2002
  • B.04.20 release - March 2002
  • B.03.12 release - November 2001
  • B.02.11 release - September 2001
  • B.01.15 release - March 2001

B.13.08 Release - July 2007

The most current documentation for the cdma2000 applications is the Online User's Guide located at:

http://wireless.agilent.com/rfcomms/refdocs/cdma2k/

Summary of GPIB command changes for this release: GPIB Changes for E1962B B.13, E6702B B.06 - July 2007

Hardware Requirements

http://www.agilent.com/find/8960upgrades

Base Station Emulation

  • NMT-450 Band

    NMT-450 Band (Band Class 5) has been revised to support new frequency. See CALL:BAND and CALL:SETup:BAND:[:SELected] .

  • Add the following three features in cdma2000 Test Application as licensed features:

    • Digital Bus ( Digital Bus Information )
    • Multi-Unit Synchronization ( Performing Multi-Unit Synchronization )
    • Protocol Logging ( Protocol Logging )

  • Support for SO68 and a new vocoder called EVRC-B. See Service Option for details.

Enhancements

  • Add a new setting (Expected Uplink Signal Bandwidth) in the Multi-Tone Audio Measurement to enhance the performance of SINAD/Distortion measurement. See Multi-Tone Audio Setup for details.
  • Revises the CDMA MS Tx/Rx frequency limit for Fast Device Tune measurement due to recent frequency expansion. See Fast Device Tune MS TX/RX Parameters for details.

B.12.21 Release - May 2007

This is a maintenance release to resolve known issues. The features offered in this release are identical to those offered in the B.12.17 Release - March 2007 .

B.12.17 Release - March 2007

The most current documentation for the cdma2000 applications is the Online User's Guide located at:

http://wireless.agilent.com/rfcomms/refdocs/cdma2k/

Summary of GPIB command changes for this release: GPIB Changes for E1962B B.12, E6702B B.05 - December 2006

NOTE
After installing this firmware release, you must run the Digital Average Power calibration. Ensure that your test set has warmed up at least 30 minutes and that no power is present at the front panel RF connectors before performing any calibrations.

Hardware Requirements

http://www.agilent.com/find/8960upgrades

Base Station Emulation

  • AWS Band

    AWS Band (Band Class 15) has been added to the list of supported bands. See CALL:BAND and CALL:SETup:BAND:[:SELected] .

Enhancements

  • The Fast Device Tune measurement is now supported on the RF OUT ONLY port, and includes a complete front panel user interface. See How Do I Make a Fast Device Tune Measurement? .

B.12.12 Release - December 2006

Release has been delayed, please use previous release.

B.11.06 Release - July 2006

A downloadable version of the Online User's Guide (CHM Help File) that is specific to this release is available at:

http://www.home.agilent.com/upload/cmc_upload/All/E1962B_B11_E6702B_B04_E6702T_T00_Ref_Guide.chm

Summary of GPIB command changes for this release: GPIB Changes for E1962B B.11.06, E6702B B.04.16 - July 2006

Hardware Requirements

http://www.agilent.com/find/8960upgrades

Base Station Emulation

  • US PCS 1900 MHz Band

    US PCS 1900 MHz Band (Band Class 14) has been added to the list of supported bands. See CALL:BAND and CALL:SETup:BAND:[:SELected] .

Measurement

  • Added a new Fast Device Tune measurement ( An additional feature license is required to enable this functionality in a licensed test application. See www.agilent.com/find/8960upgrades for more information )

    The Fast Device Tune measurement allows you to simultaneously calibrate your mobile station's transmitter (TX) output power and receiver (RX) input level across level and frequency in a single sweep (per frequency band range). See Fast Device Tune Measurement Description for details.

B.10.11 Release - January 2006

A downloadable version of the Online User's Guide (CHM Help File) that is specific to this release is available at:

http://www.home.agilent.com/upload/cmc_upload/All/E1962B_B10_E6702B_B0310_Ref_Guide.chm

Summary of GPIB command changes for this release: GPIB Changes for E1962B B.10, E6702B B.03.10 - December 2005

Hardware Requirements

http://www.agilent.com/find/8960upgrades

Base Station Emulation

  • Support for Authentication ( An additional feature license is required to enable this functionality in a licensed test application. See http://www.agilent.com/find/8960upgrades for more information )

    The test set supports the Global Challenge, Unique Challenge and SSD Update authentication procedures for the purpose of confirming the identity of the mobile station. A successful outcome of the authentication process occurs only when it can be demonstrated that the mobile station and base station possess identical sets of Shared Secret Data (SSD). See Performing Authentications for details.

  • Support for Real-Time Vocoder

    In real-time vocoder mode, the test set real-timely encodes the analog audio signal applied at the test set's AUDIO IN connector using the appropriate vocoder algorithm and then sends the encoded audio frames to the mobile station on the F-Traffic/F-FCH. Also, the test set can simultaneously decodes the encoded audio frames that is received on the R-Traffic/R-FCH using the appropriate vocoder algorithm and then converts to an analog signal output at the test set's AUDIO OUT connector. See Real-Time Vocoder for details.

  • Support for MEID/Enhanced PLCM

    The test set supports to test an MEID-equipped mobile station. Mobile Equipment Identifier (MEID) is a newly designed way to uniquely identify the mobile stations (MS) due to ESN exhaustion. See MEID / Enhanced PLCM for details.

  • User-settable CDMA System Time

    The test set can emulates the base station to allows you to set the CDMA system time parameters that are sent to the mobile station. The mobile station uses them to calculate time-based data applications. The settable system time is also used in multiple test sets synchronization. See Setting CDMA System Time Parameters for details.

  • User-settable Base ID

    The base station identification (Base ID) is now a settable parameter instead of a fixed setting. See Setting Cell Parameters .

  • Frequency Range of US Cellular Band Changes

    The forward link frequency range of US Cellular cell band is changed from 869 - 894 MHz to 860 - 894 MHz and the reverse link frequency range of US Cellular cell band is changed from 824 - 849 MHz to 815 to 849 MHz. See Cell Band .

  • Channel Range of US Cellular Band Changes

    The channel range of US Cellular cell band is extended to include the channels of 1024 - 1323. See RF Channel Number .

Transmitter Measurements

  • Three new AMPS measurements enhancements (have specifications)

    • DTMF Measurement Description
    • Signaling Tone Measurement Description
    • Wideband Data Deviation Measurement Description

B.09.14 Release - April 2005

A downloadable version of the Online User's Guide (CHM Help File) that is specific to this release is available at:

http://www.home.agilent.com/upload/cmc_upload/All/E1962B_E6702B_Ref_Guide.chm

NOTE
To properly view the CHM Help File, you must Save it to your desktop. For Windows XP, you must also then right-click on the file and select Properties >> Unblock .

Summary of GPIB command changes for this release: GPIB Changes for E1962B B.09.14 - April 2005

Hardware Requirements

http://www.agilent.com/find/8960upgrades

Transmitter Measurements

  • Tx Dynamic Power Measurement EnhancementsBefore performing each power step measurement in a power sequence, the test set automatically retunes the expected power range of the receiver based on the power measured in prior step and the power step size setting. This change improves the test set ability to measure those mobile stations, which do not transmit the power sequence as expected, without aborting the measurement. See TX Dynamic Power Measurement Description for details.
  • Spectrum Monitor Enhancements

    Span and resolution bandwidth can now be set independently, new Detection Method. See Resolution Bandwidth and Frequency Span and Detection Method for details.

  • Three new AMPS measurements (no specifications)

    • DTMF Measurement Description
    • Signaling Tone Measurement Description
    • Wideband Data Deviation Measurement Description

Other Features

  • New Restart on Fatal Error setting.
  • Improves the speed performance when switching test signals in the following scenarios:
    • When the Test Signal is switched among CW, AM and DSB-SC in CW mode. The time of switching is shorten to about 10% of the time in previous versions.
    • Operating Mode is switched between Active Cell and CW when the Test Signal has been set to AM or DSB-SC. The time of switching is shorten to about 5% of the time in previous version.

    The improvement can be seen manually or automatically (See GPIB Commands ).

B.08.20 Release - December 2004

Summary of GPIB command changes for this release: GPIB Changes for E1962B B.08, E6702B B.02 - December 2004

A downloadable version of the Online User's Guide (CHM Help File) that is specific to this release is available at:

http://www.home.agilent.com/upload/cmc_upload/All/E1962B_E6702B_Ref_Guide.chm

Hardware Requirements

http://www.agilent.com/find/8960upgrades

Base Station Emulation

  • Support for protocol revision 7 and new control channels such as F-BCCH, F-CCCH and R-EACH. See Protocol Revisions and Setting Control Channel Parameters for details.

    NOTE
    This feature is available in a lab application (E6702B revision B.02 and above) but requires an additional feature license (CDMA 2000 Release A) in a test application. To find out how to acquire the required feature license, visit:

    http://www.agilent.com/find/8960upgrades

  • A new value, Random - 40% Voice Activity , is added to the Traffic Data Rate selection menu.
  • Two new values, Multi-Tone and Null Frames , are added to the Voice SO Mode selection menu.
  • A new setting, R-SCH Service Configuration Max Rate , is added to the R-SCH Parameters menu. See Configuring the TDSO Supplemental Channel Information for details.
  • The Paging Data Rate , F-QPCH State , F-QPCH Relative to Pilot Level , and F-QPCH Data Rate settings are moved from Cell Parameters menu to the new Control Channel Parameters menu. See Setting Control Channel Parameters .

Measurements

  • Multi-Tone Audio Measurement - This new added measurement available for both IS-95 system and IS-2000 system can be used to verify the connectivity and performance of the analog audio signal handling components of a mobile station (such as speaker, microphone, etc.). See Multi-Tone Audio Measurement Description for details.
  • Changes to the Frame Error Rate Measurement include:
    • A new setting, Minimum Frame Count , is added to the Frame Error Rate Setup menu. See FER Measurement Parameters for details.
    • The value of the FER Requirement setting is extended from the range of 0.1% to 15% to the range of 0.1% to 30%.

Others

  • Adds a new calibration - Burst Mod Offset 1. It is used when the test set is configured to generate test signals (such as AM or DSB-SC) for mobile stations' Zero Intermediate Frequency (Zero IF) calibration. See Burst Mod Offset 1 Calibration for details.
  • The system time broadcast by the test set has been modified from April 10,1992 to a more current value, April 10, 2004 to assist in application testing.

B.07.28 Release - April 2004

The functionality present in this release is identical to that in the B.07.15 release (see B.07.15 release - December 2003 ).

Hardware Requirements

http://www.agilent.com/find/8960upgrades

Resolved Known Issues

  • Service Option 33 data call without supplemental channel may not connect.

See 8960 Known Issues for more information

http://www.agilent.com/find/8960upgrades

B.07.15 release - December 2003

This firmware release adds the following new features for IS-95/cdma2000 system:

Hardware Requirements

http://www.agilent.com/find/8960upgrades

Transmitter Measurements

  • Maximum/Minimum Power Measurement - This new measurement provides an automated way of measuring both the maximum and minimum output power of a CDMA mobile station. See Maximum/Minimum Power Measurement Description for details.
  • TX Dynamic Power Measurement - This new measurement provides a fast calibration method that covers the typical 90 dB (from -60 dBm to +30 dBm) dynamic range of a CDMA mobile station (MS). See TX Dynamic Power Measurement Description for details.
  • Channel Power Measurement Enhancement - A new measurement speed, Very Fast, is added to the channel power measurement. The very fast speed channel power measurement is triggered immediately upon receipt of the measurement request. The input signal is then sampled for 0.3125 ms or one quarter of a power control group. See Measurement Speed .

Base Station Emulation

  • Closed Loop Power Control Transient Mode - This new feature supports for user-defined power control bits, You can control the test set to transmit the number of up power control bits, the number of down power control bits, etc. See Reverse CLPC Transient Modes for details.

B.06.42 release - June 2003

This firmware release adds two new measurement results for the Channel Power measurement which was introduced at the B.01 release.

Hardware Requirements

http://www.agilent.com/find/8960upgrades

Transmitter Measurements

  • Channel Power - When Multi-Measurement Count is on, two new measurement results are available, Maximum and Minimum Channel Power. See Channel Power Measurement Results .

    GPIB commands:

    • FETCh:CPOWer:MAXimum?
    • FETCh:CPOWer:MINimum?

B.06.30 release - February 2003

This firmware release adds the following new features for AMPS/IS-95/cdma2000 systems:

  • cdma2000 Features
  • IS-95 Features
  • AMPS Features
  • Other Features

Hardware Requirements

http://www.agilent.com/find/8960upgrades

cdma2000 Features

The following sections provide descriptions of cdma2000 features introduced with the B.06 release.

Transmitter tests

  • Code Domain Power Pass/Fail criteria

    The Code Domain Power measurement's pass/fail criteria have been modified to be compliant with the TIA/EIA-98-E specifications for waveform quality. The test was compliant with TIA/EIA-98-D specifications in earlier releases. See Waveform Quality/Code Domain Measurement Description

  • Spectrum Monitor Measurement

    The Spectrum Monitor measurement feature has been added. This allows you to find, identify and measure transmitted signals from your mobile phone. It can also be used for spur measurements in the transmit band. See Spectrum Monitor Description .

Receiver Tests

The FER (Frame Error Rate) measurement adds three new measurement results provided to identify the types of frame errors counted by the FER measurement (see Frame Error Rate (FER) Measurement Description ). The three types of errors now identified are:

  • Forward Erasures. The number of frames the cdma2000 device was not able to decode.
  • Mobile Errors. The number of frames that the cdma2000 device sent to the test set that the test set was able to decode but that contained errors.
  • Reverse Erasures. The number of frames that the cdma2000 device sent to the test set but the test set was not able to decode.

Base Station Emulation

  • Default SCH data pattern changed from fixed data pattern to PRBS

    Changing the pattern to PRBS improves the ability to accurately determine the spreading rate for the SCH since code domain measurements on SO32 calls can not determine the actual spread rate of the signal when using a fixed data pattern. The PRBS setting appears to be far more useful in a wider variety of test cases and so the default for this setting has been changed to the more useful case. See CALL:SCHannel:TDSOption:DSOurce and Configuring the TDSO Supplemental Channel Information .

  • Mobile Station's ESN in decimal format

    The mobile station's ESN can be displayed in decimal format. See CALL:MS:REPorted:ESNumber[:DECimal]? and Performing a Registration .

  • Status Request Query On/Off control

    During registration and call setup the test set will normally issue a series of status requests to obtain the band class, max EIRP, and other capabilities from the mobile station. These requests can be disabled in order to decrease the time required to establish a connection with the mobile station. See CALL:MS:REPorted:REQuest[:ENAble] and Paging IMSI Setup .

    Note that in most cases when the Status Requests are disabled, you must supply a value for MAX_EIRP in order for the test set and the mobile station to remain connected when the mobile station transmits near its maximum output power. See CALL:MS:REPorted:EIRPower:DEFault .

  • Power up registration On/Off control

    The test set can disable requests for power-up registrations. See CALL:REGister:PUP[:STATe] and Setting Registration Parameters .

  • Variable echo delay settings

    When the test set is connected to a mobile station in a voice echo mode the delay between the incoming voice and when that data is returned to the mobile station is adjustable. See CALL[:CELL[1]]:FCHannel[:FORWard]:SOURce:ECHO and Configuring the Forward Fundamental/Traffic Channel (F-FCH/Traffic) .

  • Audio tones for digital voice services

    Pre-vocoded audio tones are available for selection as an audio source when a non loopback service option is connected. See CALL[:CELL[1]]:FCHannel[:FORWard]:SOURce and Configuring the Forward Fundamental/Traffic Channel (F-FCH/Traffic)

IS-95 Features

The following sections provide descriptions of IS-95 features introduced with the B.06 release.

Transmitter tests

  • Code Domain Power Pass/Fail criteria

    The Code Domain Power measurement's pass/fail criteria have been modified to be compliant with the TIA/EIA-98-E specifications for waveform quality. The test was compliant with TIA/EIA-98-D specifications in earlier releases. See Waveform Quality/Code Domain Measurement Description .

  • Spectrum Monitor Measurement

    The Spectrum Monitor measurement feature has been added. This allows you to find, identify and measure transmitted signals from your mobile phone. It can also be used for spur measurements in the transmit band. See Spectrum Monitor Description .

Receiver Tests

The FER (Frame Error Rate) measurement adds three new measurement results provided to identify the types of frame errors counted by the FER measurement (see Frame Error Rate (FER) Measurement Description ). The three types of errors now identified are:

  • Forward Erasures. The number of frames the cdma2000 device was not able to decode.
  • Mobile Errors. The number of frames that the cdma2000 device sent to the test set that the test set was able to decode but that contained errors.
  • Reverse Erasures. The number of frames that the cdma2000 device sent to the test set but the test set was not able to decode.

Base Station Emulation

  • Mobile Station's ESN in decimal format

    The mobile station's ESN can be displayed in decimal format in the Mobile Station Information window. See CALL:MS:REPorted:ESNumber[:DECimal]? and Performing a Registration .

  • Status Request Query On/Off control

    During registration and call setup the test set will normally issue a series of status requests to obtain the band class, max EIRP, and other capabilities from the mobile station. These requests can be disabled in order to decrease the time required to establish a connection with the mobile station. See CALL:MS:REPorted:REQuest[:ENAble] and Paging IMSI Setup .

    Note that in most cases when the Status Requests are disabled, you must supply a value for MAX_EIRP in order for the test set and the mobile station to remain connected when the mobile station transmits near its maximum output power. See CALL:MS:REPorted:EIRPower:DEFault .

  • Power up registration On/Off control

    The test set can disable requests for power-up registrations. See CALL:REGister:PUP[:STATe] and Setting Registration Parameters .

  • Variable echo delay settings

    When the test set is connected to a mobile station in a voice echo mode the delay between the incoming voice and when that data is returned to the mobile station is adjustable. See CALL[:CELL[1]]:TRAFfic[:FORWard]:SOURce:ECHO and Configuring the Forward Fundamental/Traffic Channel (F-FCH/Traffic) .

  • Audio tones for digital voice services

    Pre-vocoded audio tones are available for selection as an audio source when a non loopback service option is connected. See CALL[:CELL[1]]:TRAFfic[:FORWard]:SOURce and Configuring the Forward Fundamental/Traffic Channel (F-FCH/Traffic) .

AMPS Features

The following sections provide descriptions of AMPS features introduced with the B.06 release.

Transmitter tests

  • Spectrum Monitor Measurement

    The Spectrum Monitor measurement feature has been added. This allows you to find, identify and measure transmitted signals from your mobile phone. It can also be used for spur measurements in the transmit band. See Spectrum Monitor Description .

Base Station Emulation

  • Mobile Station's ESN in decimal format

    The mobile station's ESN can be displayed in decimal format in the Mobile Station Information window. See CALL:MS:REPorted:ESNumber[:DECimal]? .

  • Analog FM Demod

    The Audio Out connector on the test set's front panel can now be configured to carry one of two signals. It is normally configured to carry the output from the built in audio generator. It can now be configured to carry the analog FM Demod signal. When the analog FM signal is selected to route to the Audio Out connector, a fixed BW bandpass, expandor, and de-emphasis filters are available to operate on the demodulated signal. See SYSTem:AUDio and Configuring the Test Set's AUDIO OUT port .

Other Features

  • Save/Recall

    This function allows you to store the test set's current settings to a register and retrieve them later, eliminating the task of reconfiguring the test set. See Save and Recall Registers .

  • GPIB syntax help mode

    This feature allows you to display GPIB commands on the test set's front panel display by pressing a command function's front panel button or soft key. See Help Mode .

  • New CW test signals (AM or DSB-SC)

    The test set provides two new test signals (AM or DSB-SC) for output. An example usage of the test signals is for calibrating mobile stations that use Qualcomm's radioOne architecture. See CW Operating Mode .

B.05.20 release - June 2002

This firmware release adds no new features. The Time Response of Open Loop Power Control measurement, which was introduced at the B.04 release with relaxed specifications, has now been fully qualified and meets published specifications.

Hardware Requirements

http://www.agilent.com/find/8960upgrades

B.04.20 release - March 2002

This firmware release adds the following new features:

  • cdma2000 Features
  • IS-95 Features
  • AMPS Features

Hardware Requirements

http://www.agilent.com/find/8960upgrades

cdma2000 Features

The following sections provide descriptions of cdma2000 features introduced with the B.04 release.

Transmitter tests

  • Front panel display graphics for Time Response of Open Loop Power Control (TIA/EIA-98-D 4.4.2 Time Response of Open Loop Power Control).

    This measurement is a graphic view of the mobile station under test's output power after a step increase or step decrease in cell power from the test set. The graph displays mobile station power over a 100 ms period with pass/fail results determined by the measured signal's conformance to mask limits derived from the test standard. See Time Response of Open Loop Power Control (TROLPC) Measurement Description .

  • Code Domain Power code channel table

    The graphical code domain power measurement now includes a table of code channel power values that simplifies testing a mobile station's conformance to TIA/EIA-98-D 4.4.9.2.2 Code Channel Output Power for the Reverse Traffic Channel . The new table provides specific code channel power relative to the reverse pilot channel in units of dB. Also displayed in the table are Walsh number, spread factor, code channel power relative to mean output of the mobile station, and total code channel power relative to the mean output of the mobile station. See Waveform Quality/Code Domain Measurement Description .

  • Adjustable limits on the Tx Spurious Emissions display (TIA/EIA-98-D 4.5.1 Conducted Spurious Emissions)

    The Tx Spurious Emissions measurement displays pass/fail results based on a mask defined by test standards. This mask automatically displays power limits derived from two adjacent frequency offsets and two alternate frequency offsets. An adjustable mask control feature is now provided that allows two mask parameters to be adjusted, one for the adjacent frequency pass/fail limits and one for the alternate frequency pass/fail limits. See Tx Spurious Emissions Measurement Description .

  • Waveform Quality (rho) statistical measurement results (TIA/EIA-98-D 4.3.4 Waveform Quality and Frequency Accuracy)

    The Waveform Quality measurement Numeric Rho view is now displayed in a table when Multi-Measurement Count is on. Minimum, Maximum, and Average for the number of measurements requested is displayed in the table. Standard deviation is available using GPIB commands. See Waveform Quality/Code Domain Measurement Description and Statistical Measurement Results .

IS-95 Features

There are no new IS-95 features in this release.

AMPS Features

There are no new AMPS features in this release.

B.03.12 release - November 2001

This firmware release adds the following new features:

  • cdma2000 Features
  • IS-95 Features
  • AMPS Features
  • Other Features

Hardware Requirements

http://www.agilent.com/find/8960upgrades

cdma2000 Features

The following sections provide descriptions of cdma2000 features introduced with the B.03 release.

Transmitter tests

  • Reverse Supplemental Channel (SO32 (+SCH))

    This implementation of TDSO service option 32 (SO32 (+SCH)) assigns the mobile station to both forward and reverse supplemental channels. There is no measurement selection or standard tests associated with the reverse supplemental channel.

    The implementation of TDSO service option 32 that was introduced at B.02 (SO32(+ F-SCH)) provided non-loopback frame error rate measurements on the forward supplemental channel. When SO32 (+SCH) is selected, frame error rate measurements on the forward supplemental channel are still available. See CALL[:CELL]:SOPTion[:SELected][:SELected] and TDSO Frame Error Rate Measurement Description .

  • Front panel display graphics for Gated Power Rise/Fall measurements. (TIA/EIA-98-D test 4.4.7 Standby Output Power and Gated Output Power.)

    Beginning with release B.02 the graphical Gated Power measurement included a "Full" and "Zoom" view of the mobile station's signal during the gated on period. The gated power measurement now includes expanded views of the rising portion and falling portion of the mobile station's transmitter power during gated operation. Gated power occurs only when the mobile station is operating in IS-95 mode or IS-2000 mode with radio configuration 1 or 2 selected and eighth rate data is selected. See Gated Power Measurement Description .

    NOTE
    The Gated Output Power portion of this test is performed by the test set. The test set does not have capability to perform Standby Output Power.

Receiver Tests

  • PRBS (Pseudo random bit sequence) for TDSO (service option 32) frame error rate tests.

    PRBS is an acronym for pseudo random bit sequence. PRBS is a new data pattern available for TDSO frame error rate tests. When making code domain measurements with a supplemental channel service option PRBS data is required. See CALL:SCHannel:TDSOption:DSOurce .

    When a test data service option is selected, the test set sends data bits to the mobile station on the forward supplemental channel. The mobile station demodulates the forward supplemental channel data and reports frame errors to the test set on the reverse fundamental channel. (See TDSO Frame Error Rate Measurement Description for additional details.)

Base Station Emulation

  • Secondary 800 MHz Band

    Secondary 800 MHz Band (Band Class 10) has been added to the list of supported bands. See CALL:BAND and CALL:SETup:BAND:[:SELected] .

IS-95 Features

There are no new IS-95 features in this release.

AMPS Features

There are no new AMPS features in this release.

Other Features

  • System Time and Date

    The test set now provides settings for local and universal time and date. See Configuring System Time and Date .

  • RF Out Only front panel connector

    A type-N RF connector on the test set's front panel provides an optional path for the forward channel or analog signal. See RFGenerator:OUTPut[:DESTination] and RF OUT ONLY .

B.02.11 release - September 2001

This firmware release adds IS-95 and AMPS system types as well as many cdma2000 features. This firmware release will run on an E5515C chassis with Option 003 (Option 002 is recommended). If you wish to run this firmware on an E5515B or E5515T chassis, contact your local sales representative.

  • cdma2000 Features
  • IS-95 Features
  • AMPS Features
  • Other Features

Hardware Requirements

http://www.agilent.com/find/8960upgrades

cdma2000 Features

The following sections provide descriptions of cdma2000 features introduced with the B.02 release.

Transmitter tests

  • Code Channel Timing and Phase (TIA/EIA-98-D test 4.3.2 Reverse Pilot Channel to Code Channel Time Tolerance, and 4.3.3 Reverse Pilot Channel to Code Channel Phase Tolerance)

    These tests assess any differences in timing or phase between active reverse code channels and the reverse pilot channel. (See Code Channel Time/Phase Error Measurement Description .)

  • Gated Power (TIA/EIA-98-D test 4.4.7 Standby Output Power and Gated Output Power)

    This test (which is similar to the GSM power versus time measurement) verifies that mobile station transmitters conform to gated output power test limits. Transmitter output power is gated when operating in IS-95 or cdma2000 radio configuration one or two modes with partial (eighth) rate data selected. (See Gated Power Measurement Description .)

    NOTE
    The Gated Output Power portion of this test is performed by the test set. The test set does not have capability to perform Standby Output Power.

  • Tx Spurious Emissions (TIA/EIA-98-D test 4.5.1 Conducted Spurious Emissions)

    This test provides a collection of signal energy measurements at only the alternate and adjacent frequency offsets specified by test standards to ensure that mobile stations do not transmit excessive signal energy outside of their transmit channels. (See Tx Spurious Emissions Measurement Description .) Measurements at 12.5

  • Handoff Waveform Quality (performed at the explicit action time of the Universal Handoff Direction Message) (TIA/EIA-98-D test 4.3.4 Waveform Quality and Frequency Accuracy)

    This measurement has been added to provide a collection of waveform quality measurements acquired during mobile station transmission of a single code channel. This measurement can be performed only during a handoff, as specified in the TIA/EIA-98-D test standard. (See Handoff Waveform Quality Measurement Description .)

    The Handoff Waveform Quality measurement provides the same suite of measurement results as the multi-code waveform quality measurement (see Waveform Quality/Code Domain Measurement Description ), excluding EVM (Error Vector Magnitude) and code domain power measurements.

Receiver Tests

  • Service Option 32 TDSO (F-SCH FER) (TIA/EIA-98-D test 3.4.1 Demodulation of Forward Traffic Channel with AWGN). Supports the following radio configurations:

    • Radio Configuration 3 (Forward 3, Reverse 3) at data rates from 9.6 to 153.6 kbps.
    • Radio Configuration 4 (Forward 4, Reverse 3) at data rates from 9.6 to 307.2 kbps.

    TDSO Frame Error Rate measurements provide a test of the mobile station receiver's ability to demodulate the forward supplemental channel. To obtain test results, the test set signals the mobile station under test to count errors that occur while the mobile station is demodulating fixed pattern data sent from the test set. Only convolutional encoding is supported. The test set then displays FER results received from the mobile station. (See TDSO Frame Error Rate Measurement Description .)

Base Station Emulation

  • Intersystem Handoffs. The following handoffs between CDMA and AMPS systems can now be performed:

    • cdma2000 to AMPS.
      Handoffs to AMPS allow user-specified voice channel, transmit level, and SAT color code
    • cdma2000 to IS-95.
      Handoffs to IS-95 allow user-specified band, handoff channel, and IS-95 protocol. (Handoffs to IS-95 require the call to be in loopback service options SO2 or SO9 with full data rate selected.)
    • IS-95 to AMPS.
      Handoffs to AMPS allow user-specified voice channel, transmit level, and SAT color code.

IS-95 Features

The following sections provide descriptions of IS-95 features introduced with the B.02 release.

Transmitter tests ( similar to cdma2000 )

  • Access Probe Power
  • Channel Power
  • Digital Average Power
  • Waveform Quality
  • Tx Spurious Emissions
  • Gated Power

Receiver tests

  • Frame Error Rate

Base Station Emulation ( similar to cdma2000 )

  • Registration

    Supported IS-95 registration procedures are the same as cdma2000 (zone based, timer based, power up, mobile station originated calls, and base station pages).

  • One-Button Page
  • Autoanswer MS Origination
  • Hard Handoff (Band and Channel)
  • RF Generator
    • AWGN
    • Cell Power (Ior) (similar to cdma2000)
    • Pilot, Sync, Paging, Traffic, and OCNS channels (similar to cdma2000 radio configurations (Fwd1,Rvs1), (Fwd2,Rvs2))
  • Protocol Revisions
    • TSB-74 (Protocol Revision 3)
    • J-STD-008 (Protocol Revision 1)
    • 95-B (Protocol Revision 4)
    • ARIB T-53 (Protocol Revision 3)
    • Korean PCS (Protocol Revision 1)
  • Service Options
    • Echo (SO1, SO3, SO17, SO32768)
    • Loopback (SO2, SO9)
  • Cell Bands
    • US Cellular (band class 0)
    • US PCS (band class 1)
    • Korean PCS (band class 4)
    • Japan CDMA (band class 3)
    • NMT-450 (band class 5)

AMPS Features

The following sections provide descriptions of AMPS features introduced with the B.02 release.

Transmitter tests

  • Frequency Modulation
    • FM Deviation
    • Distortion
    • Modulation Frequency
  • Frequency Stability
    • Frequency Error
    • Frequency
  • Analog Transmit Power

Instruments

  • Swept Audio
    • Audio generator
    • Audio analyzer
    • SINAD meter
    • Distortion meter
  • Audio Generator
    • Amplitude measurements
    • Frequency measurements
  • Audio Analyzer
    • Audio level measurements
    • Audio frequency measurements
    • SINAD measurements
    • Distortion measurements

Base Station Emulation

  • Call Setup
  • Registrations
  • Handoffs to Analog Voice Channel, Mobile Station Transmit Level
  • SAT Color Code

Other Features

  • The ability to print test set screens over a LAN connection to a PC web browser and save directly as.GIF (see Printing Screens ).

B.01.15 release - March 2001

These are the original features of the Agilent E1962B.

Hardware Requirements

http://www.agilent.com/find/8960upgrades

Transmitter Measurements

  • Channel Power
  • Average Power
    • Peak Detector
    • Thermal Detector
  • Access Probe Power
  • Modulation Quality
    • Rho
    • Frequency Error
    • Time Error
  • Modulation Quality
    • Multi-Code Rho
    • Frequency Error
    • Time Error
    • EVM
    • Code Domain Power

Receiver Measurements

  • Sensitivity
  • Dynamic Range
  • Access Probe Power
  • Demodulation of FCH with AWGN
  • Loopback Support with Service Option 002, 009, and 055

IS-2000 Functionality

  • Call Processing
    • Registration
    • One-Button Page
    • Autoanswer MS Origination
    • Hard Handoff (Band and Channel)
  • RF Generator
    • Pilot, Sync, Paging, Quick Paging, FCH, OCNS, and AWGN Channels
  • Radio Configuration Support
    • Forward RC1 + Reverse RC1
    • Forward RC2 + Reverse RC2
    • Forward RC3 + Reverse RC3
    • Forward RC4 + Reverse RC3
    • Forward RC5 + Reverse RC4


Access Probe Power Troubleshooting

Access Probe Power Troubleshooting

Last updated: October 28, 2004

Possible Setup Issues

IMPORTANT
If the Access Probe Power measurement is currently selected and the Trigger Arm setting is Continuous, some measurements (i.e. Channel Power, Waveform Quality + Code Domain Power, TX Spurious Emissions and Code Channel Time/Phase Error measurements) can not complete properly. Use the SETup:CAPPower:CONTinuous command to set the trigger arm state to single and retry the measurement.

During remote operation of this measurement, you should configure the Trigger Arm to Single. See SETup:CAPPower:CONTinuous . If single triggering is used during manual operation, press the START SINGLE key to trigger each measurement.

The input signal must conform to Input Signal Requirements .

Access probe power measurement results are affected by the Amplitude Offset value. Use the SYSTem:CORRection:GAIN command to determine offset values.

Access probe power measurements are triggered by a rise in RF power that crosses approximately -55 dBm. See Access Probe Power Measurement Description for details.

Interpreting Integrity Indicator values

See Integrity Indicator .

If over range (5) is returned the input power has exceeded the test set's internal sampler maximum value during some part of the sampling or the input power has exceeded the calibrated range of the test set's power detector.

If under range (6) is returned the measurement result is below the expected input power level. Under range is also indicated if the input power is below the calibrated range of the test set's power detector.

If the signal has both over range and under range conditions, only the over range (5) will be indicated.

Related Topics

Troubleshooting Setting Power Levels


AFANalyzer Troubleshooting

AFANalyzer Troubleshooting

Last updated: October 28, 2004

Possible Setup Issues

During remote operation of the Audio Analyzer, you should always set the Trigger Arm to Single. The length of time required to return a measurement over GPIB using continuous triggering varies, but is always longer than when using single triggering. Continuous triggering can also cause problems when the INITiate:DONE? query is used.

If digital measurements are active, turn them off or set their trigger source to Immediate. See Triggering of Measurements .

The Detector Type selected (peak or rms) also sets how Audio Level measurements are displayed; as a peak value or an rms value. When comparing returned values over GPIB to your specifications, be sure to take into account the type of detector being used.

The Expected Peak Voltage is always set in V peak , regardless of the Detector Type selected, and cannot exceed 20 V peak (14.1 V rms ).

For accurate measurements, always set all Audio Analyzer setup parameters to their proper settings for the measurement being made. The SINAD and Distortion measurements typically use different settings than the Audio Level measurement. See Audio Analyzer Measurement Description and Audio Analyzer Block Diagram .

For very low level audio signals, use the 100 Hz BW BPF filter to reduce the affects of noise (see Audio Level Measurement Description ).

For accurate Audio Frequency measurements where more than one signal may be present, use the 100 Hz BW BPF filter to isolate the desired signal (see Audio Level Measurement Description ).

Interpreting Integrity Indicator Values

See Integrity Indicator .

If over range (5) is returned, the input level is greater than 4.9 dB above the Expected Peak Amplitude value or the maximum input level of 20 volts peak.

If under range (6) is returned, the input level is lower than 8 dB below the Expected Peak Amplitude value.

If the signal has both over range and under range conditions, only the over range condition (5) is indicated.


Analog Transmit Power Troubleshooting

Analog Transmit Power Troubleshooting

Last updated: October 28, 2004

Possible Setup Issues

During remote operation of the Analog Transmit Power measurement, you should configure the Trigger Arm to Single. See SETup:ATXPower . If single triggering is used during manual operation, press the START SINGLE key to trigger each measurement.

If digital measurements are active, turn them off or set their trigger source to Immediate. See Triggering of Measurements .

The measurement results are altered by the Amplitude Offset value. See Amplitude Offset .

The expected signal amplitude and channel number (or frequency) must be specified for accurate measurements. See Active Cell Operating Mode , AVC Test Operating Mode , and Receiver Control for information on setting the expected input frequency and power level.

The trigger source is always immediate for the Analog Transmit Power measurement. No synchronization or external signals are required.

Over range and under range conditions may occur when testing a power class 4 mobile at power levels 0 or 1, or when testing a power class 1 mobile at power levels 8, 9, and 10 (digital mode only). See Under Range/Over Range Errors for an explanation of why this occurs and what to do about it.

Interpreting Integrity Indicator values

See Integrity Indicator .

If over range (5) is returned; the input power has exceeded the test set's internal sampler maximum value by at least 3 dB during some part of the sampling or the input power has exceeded the calibrated range of the test set's power detector for the expected power setting.

If under range (6) is returned; the Analog Transmit Power result is more than 10 dB below the expected input power level. Under range is also indicated if the input power is more than 2 dB below the calibrated range of the test set's power detector (-30 dBm).

If the signal has both over range and under range conditions only the over range (5) will be indicated.


Authentication Troubleshooting

Authentication Troubleshooting

Last updated: June 20, 2006

This section is only applicable to the lab application and to a test application with the required feature license.

Possible Setup Issues

  • When a mobile station performs the global challenge at the first time since the test set is powered On or fully preset, the Call History (COUNT) result fails because the Expected Call History (COUNT) doesn't equal to the Received Call History (COUNT) due to the expected COUNT value unavailable. The expected COUNT value is available and set to the same value of received COUNT after the first authentication. See Global Challenge Information for details.
  • It is possible that the test set and the mobile station use the different RAND values in a Global Challenge since the mobile station may send access channel messages with specified RANDC before the test set sends an Access Parameter Message or ANSI-41 RAND Message . In this case, the Global Challenge fails. To avoid this issue, it is recommended to implement SSD Update first.
  • The authentication result does not impact the normal call processing (registration, call connection). For example, a call can be connected even if the Global Challenge or Unique Challenge authentication fails. Please note that this behavior is different from the standard, but provides more flexibility to perform other MS tests in the event that the authentication test fails.

Related Topics

Authentication Overview


Code Channel Time/Phase Error Measurement Troubleshooting

Code Channel Time/Phase Error Measurement Troubleshooting

Last updated: June 20, 2006

Possible Setup Issues

IMPORTANT
If the Access Probe Power measurement is currently selected and the Trigger Arm setting is Continuous, all other measurements are disabled. Use the SETup:CCTPhase:CONTinuous command to set the trigger arm state to single and retry this measurement.

This measurement is designed to analyze signals that contain a reverse pilot channel. A call must be connected with one of the following radio configurations selected:

  • Fwd3, Rvs3
  • Fwd4, Rvs3
  • Fwd5, Rvs4

During remote operation of this measurement, you should configure the Trigger Arm to Single. See SETup:CCTPhase . If single triggering is used during manual operation, press the START SINGLE key to trigger each measurement.

The input signal must conform to Input Signal Requirements .

The test set receiver's expected signal amplitude and channel number (or frequency) must be set up correctly for accurate measurements. This is normally done automatically (see Active Cell Operating Mode ) but can also be done manually (see Receiver Control ).

When this measurement is running, changing PLCM Type causes the measurement aborted and restarted. See PLCM Type for details.

Interpreting Integrity Indicator values

See Integrity Indicator .

If over range (5) is returned the input power has exceeded the test set's internal sampler maximum value during some part of the sampling or the input power has exceeded the calibrated range of the test set's power detector.

If under range (6) is returned the measurement result is below the expected input power level. Under range is also indicated if the input power is below the calibrated range of the test set's power detector.

If the signal has both over range and under range conditions, only the over range (5) will be indicated.

An integrity indicator of 17 (Can not correlate), indicates that the received signal did not correlate with an internally generated reference signal.

Related Topics

Code Channel Time/Phase Error Measurement Description


Fast Device Tune Troubleshooting

Fast Device Tune Troubleshooting

Last updated: November 13, 2006

This section is only applicable to the lab application and to a test application with the required feature license.

Possible Setup Issues

  • The measurement is not performed with a call established between the test set and mobile station (MS). Rather, you must place your MS into a test mode which forces it to transmit a predefined series of power steps at various frequencies, and forces it to simultaneously tune its receiver to perform measurements of the test set's signal (to determine RSSI, for example) at various frequencies and power levels. Note that the test set does not report the mobile station's measurement results (for example, RSSI). You must capture the mobile station's measurement results so that you can compare its measurements with the test set's actual transmission levels.
  • During front panel operation of this measurement, you must press the START SINGLE key to initiate the measurement.
  • Ensure that you have met the Fast Device Tune Input Signal Requirements .
  • Before performing a fast device tune measurement, ensure that the measurement has been properly calibrated (see Calibrating the Test Set ).
  • The MS RX Power Sequence must include the same number of power steps as the MS TX Power Sequence, and the number of frequencies in the MS RX Frequency Sequence must match the number of frequency steps in the MS TX Frequency Sequence. If you do not want the MS to measure test set power at as many power levels or frequencies as you want the test set to measure from the MS, simply place "dummy" power levels or frequencies at the end of the MS RX Power Sequence and MS RX Frequency Sequence (for example, simply repeat the final power level or frequency). You can then ignore the mobile station's measurement results for these "dummy" points. Likewise, if you need more measurement points in the MS RX Frequency/Power Series than in the MS TX Frequency/Power Series, you can place "dummy" power levels and frequencies in the MS TX Frequency/Power Series, but note that the test set will still measure and report power for these "dummy" points. You must simply ignore these results.
  • To ensure successful triggering of the measurement, follow the instructions at Triggering the Fast Device Tune Measurement .
  • If you are running the measurement from the front panel, you must wait 2 seconds after initiating the measurement before instructing your mobile station to trigger the test set (if using the measurement remotely, you can use the INITiate:CFDTune:ARMed? query to determine that the measurement is ready; a separate wait statement is not required). To ensure that the test set triggered on the first transmission from the mobile, verify that the "Number of MS TX Power Steps Measured" returned by the FETCh:CFDTune[:ALL]? commands is equal to Number of Frequency Steps multiplied by Number of Power Steps .
  • Required initial conditions:
    • Operating Mode must be set to IS-2000 Test .
    • Rcvr Power Ctrl must be set to Manual and Meas Frequency must be set to manual control (See Manual Receiver Control in IS-2000 Test Operating Mode ).
      To set Meas Frequency to manual control from the front panel, press the OFF/MANUAL key. This sets Meas Frequency to the last frequency value that this parameter was set to. The Fast Device Tune measurement ignores the specific value that Meas Frequency is set to, so it can be set to any supported input frequency; the measurement simply requires that Meas Frequency be in manual control mode
    • RF Gen Freq Ctrl must be set to Manual . See Manual Receiver Control in IS-2000 Test Operating Mode .
    • AWGN Power must be Off . If in the Lab Application , also make sure no external fading is applied (see Digital Bus Information ).
    • You must configure the MS TX Frequency/Power Series to match the pattern of power levels to be transmitted by the MS and configure the MS RX Frequency/Power Series to match the pattern of power levels to be measured by the MS (and at the appropriate frequencies). Ensure that you have included the frequency retune steps in your mobile station's transmit/receive sequences (for example, the number of power steps you've configured your mobile to transmit should be equal to the Number of Power Steps setting + 1).
    • Your mobile station should be configured to measure the test set's signal 5 ms after the start of each step, to allow the test set's source to settle.
  • Ensure that you set the Measurement Timeout to a value great enough to allow you to command the MS to transmit its MS TX Frequency/Power Series and for the test set to measure the MS TX Frequency/Power Series. For example, measuring the maximum allowable number of 400 power points can take more than 10 seconds (400 steps plus the 19 re-tune steps: 419 x 20 ms = 8.4 seconds, plus ~ 2 seconds required for the measurement to prepare for triggering).
  • MS TX Power Step Start Index + Number of Power Steps and MS RX Power Step Start Index + Number of Power Steps must not exceed 40.
  • You must ensure that the range of power values selected by MS TX Power Step Start Index, MS RX Power Step Start Index and Number of Power Steps do not include any NANs (9.91E+37) or values that are outside of the input or output ranges for the current application format (considering the amplitude offset settings).
  • MS TX Frequency Step Start Index + Number of Frequency Steps and MS RX Frequency Step Start Index + Number of Frequency Steps must not exceed 40.
  • The frequencies indicated by MS TX Frequency Step Start Index and Number of Frequency Steps must be within one frequency band range. Likewise, the frequencies indicated by MS RX Frequency Step Start Index and Number of Frequency Steps must be within one frequency band range, but do not have to be in the same frequency band range as the MS TX Frequency Sequence. Ensure that none of the frequency values you've selected are NANs (9.91E+37)).
  • Note that if you specify fewer than 40 values for the following commands: SETup:CFDTune:MS:RX:FREQuency:STEP[:VALues] , SETup:CFDTunee:MS:RX:POWer:STEP[:LEVels] , SETup:CFDTune:MS:TX:FREQuency:STEP[:VALues] and SETup:CFDTune:MS:TX:POWer:STEP[:LEVels] , the remaining values are set to NAN (9.91E+37).
  • Although you can enter any power levels for MS TX Power Step Levels between -129 and +80 dBm (because this measurement is common to the W-CDMA/HSDPA, 1xEV-DO and cdma2000 formats), when running the Fast Device Tune measurement in the 1xEV-DO application/format, you can only measure power levels in the range of -79 to +30 dBm and the measurement is only specified for power levels in the range of -61 to +30 dBm (these ranges assume an amplitude offset of 0; the ranges change as you change amplitude offsets, see Amplitude Offset ).
  • Although you can enter any frequencies for MS TX Frequency Step Values between 411 and 1980 MHz, when running the Fast Device Tune measurement in the 1xEV-DO application/format, you can only test frequencies within a single 1xEV-DO frequency band range:
    • 411 to 479 MHz (Band: NMT-450)
    • 806 to 924 MHz (Bands: US Cellular, Japan CDMA, China Cellular, and Secondary 800)
    • 1750 to 1780 MHz (Band: Korean PCS)
    • 1920 to 1980 MHz (Band: IMT-2000)
    • 1850 to 1915 (Bands: US PCS and US PCS 1900)
  • Although you can enter any power levels for MS RX Power Step Levels between -165 and 37 dBm, when running the Fast Device Tune measurement in the cdma2000 application/format, the test set can only transmit test power levels in the range of -115 to -13 dBm (RF IN/OUT) or -115 to -5 dBm (RF OUT ONLY). These ranges assume an amplitude offset of 0; the allowable ranges change as you change amplitude offsets, see Cell Power, AWGN Power and Total RF Power Ranges .
  • Although you can enter any frequencies for MS RX Frequency Step Values between 421 and 2170 MHz, when running the Fast Device Tune measurement in the cdma2000 application/format, you can only test frequencies within a single cdma2000 frequency band range:
    • 421 to 489 MHz (Band: NMT-450)
    • 800 to 960 MHz (Bands: US Cellular, Japan CDMA, China Cellular, and Secondary 800)
    • 1840 to 1870 MHz (Band: Korean PCS)
    • 2110 to 2170 MHz (Band: IMT-2000)
    • 1930 to 1995 (Bands: US PCS and US PCS 1900)

Other Considerations

  • The Fast Device Tune measurement must re-range and re-trigger for every step in the MS TX Power Sequence. To ensure that this process is not interrupted by other operations, it is recommended that you not send any GPIB commands to the test set or press any front panel keys until the measurement has completed. If the measurement misses a trigger, it aborts and returns Integrity Indicator 30 : Missed Trigger .
  • No other measurements can be running when a Fast Device Tune measurement is performed. If any measurements are running when a Fast Device Tune measurement is initiated, they are closed and a message is displayed to indicate that they were closed. Likewise, if any other measurements are initiated while a Fast Device Tune measurement is running, the Fast Device Tune measurement is closed and a message is displayed.
  • Measurement results (and the RF generator output level) are affected by any RF IN/OUT Amplitude Offsets that are entered (see Amplitude Offset ).
  • The Fast Device Tune measurement results are currently only available via GPIB command (see FETCh:CFDTune[:ALL]? ). Measurement results are not available on the front panel screen.

Related Topics

Fast Device Tune Measurement Description


Channel Power Measurement Troubleshooting

Channel Power Measurement Troubleshooting

Last updated: October 28, 2004

Possible Setup Issues

NOTE
If the access probe power measurement is on and waiting to measure a probe, all other measurements (except digital average power) will not be able to execute. It is therefore recommended that you turn off the access probe power measurement before attempting any other measurement.

  • The test set receiver's expected signal amplitude and frequency must be set up correctly for accurate measurements. This is normally done automatically and the expected power is shown on the Channel Power measurement screen (see Channel Power Measurement Results ).

    If you are manually controlling the test set's receiver (see Receiver Control ), be certain that you have entered the correct frequency and power values for your test setup.
  • The actual measurement speed used by the test set may be different than the current measurement speed selection. This is primarily because the triggering and search algorithms needed for measuring channel power on gated input signals is only available when using the Normal measurement speed. If Fast or Very Fast measurement speeds are selected when the channel configuration is such that a gated signal could reasonably be expected from the mobile station the Normal measurement speed algorithm will be applied even though a different measurement speed is selected. This provides the highest confidence that the measurement result will be accurate even though it might take longer than expected to obtain the result. See Measurement Speed for details.
  • To help avoid over range or under range integrity indicators, correct for system path loss (see Amplitude Offset ).
  • If you are manually controlling the test set's receiver, be certain that you have entered the correct frequency and power values for your test setup (see Receiver Control ).
  • Calibrating the Channel Power Measurement
  • During remote operation of this measurement, you should configure the Trigger Arm to Single. See SETup:CPOWer:CONTinuous or SETup[:ALL]:CONTinuous<:OFF|:ON> . If single triggering is used during manual operation, press the START SINGLE key to trigger each measurement. See Triggering of Measurements for details on trigger settings.

Troubleshooting Techniques

Check to see if an integrity indicator other than 0 (normal) was returned with a measurement result (see Integrity Indicator ).

  • If Over Range (5) is returned; the input power has exceeded +37 dBm or is greater than +9 dB above the expected power level of the receiver.
  • If Under Range (6) is returned; the input power is below -61 dBm or is less than -9 dB below the expected power level of the receiver.
  • If the signal has both over range and under range conditions, only the over range (5) will be indicated.
    Channel Power Under Range/Over Range Integrity Indicators

Other Considerations

  • To help avoid over range or under range integrity indicators, correct for system path loss (see Amplitude Offset ).
  • If you are manually controlling the test set's receiver, be certain that you have entered the correct frequency and power values for your test setup (see Receiver Control ).
  • Calibrating the Channel Power Measurement

Related Topics

Troubleshooting Setting Power Levels


Tx Spurious Emissions Measurement Troubleshooting

Tx Spurious Emissions Measurement Troubleshooting

Last updated: October 28, 2004

If the access probe power measurement is on and waiting to measure a probe, all other measurements (except digital average power) will not be able to execute. It is therefore recommended that you turn off the access probe power measurement before attempting any other measurements.

NOTE
For the lab application, the Tx Spurious Emissions measurement can not be initiated when the MS is in gated transmission on the R-FCH (see R-FCH Gating for details).

Possible Setup Issues

  • To obtain valid measurement results, the Tx Spurious Emissions measurement requires the MS is in a loopback call connection at full data rate transmission (see also Testing 4.5.1 Conducted Spurious Emissions ). The measurement still returns results which appear to be valid even when the MS is in gated transmission. You should make sure that the mobile station is configured properly to obtain the desired result.
  • During remote operation of this measurement, you should configure the Trigger Arm to Single. See SETup:CTXSpurious:CONTinuous . If single triggering is used during manual operation, press the START SINGLE key to trigger each measurement.

Troubleshooting Techniques

  • Check to see if an integrity indicator other than 0 (normal) was returned with a measurement result (see Integrity Indicator ).

Other Considerations

  • To avoid over range or under range integrity indicators, correct for system path loss (see Amplitude Offset ).
  • If you are manually controlling the test set's receiver, be certain that you have entered the correct frequency value for your test setup (see Receiver Control ).
  • Input Signal Requirements
  • Calibrating the Tx Spurious Emissions Measurement

Related Topics

Integrity Indicator


Digital Average Power Troubleshooting

Digital Average Power Troubleshooting

Last updated: October 28, 2004

Possible Setup Issues

NOTE
If the Access Probe Power measurement is currently selected and the Trigger Arm setting is Continuous, all other measurements are disabled. Use the SETup:CAPPower:CONTinuous command to set the trigger arm state to single and retry this measurement.

NOTE
For the lab application, when the R-FCH is gated or sometimes gated in radio configuration 3 and above (see R-FCH Gating ), initiating the Digital Average Power measurement will result in an error message indicating that the measurement result is not accurate for gated MS transmissions in radio configurations greater than 2. See Troubleshooting Techniques ).

  • The test set receiver's expected signal amplitude and frequency must be set up correctly for accurate measurements. This is normally done automatically and the expected power is shown on the Digital Average Power measurement screen (see Digital Average Power Measurement Results ).

    If you are manually controlling the test set's receiver (see Receiver Control ), be certain that you have entered the correct frequency and power values for your test setup.
  • During remote operation of this measurement, you should configure the Trigger Arm to Single. See SETup:DAPower . If single triggering is used during manual operation, press the START SINGLE key to trigger each measurement.
  • To avoid over range or under range integrity indicators, correct for system path loss (see Amplitude Offset ).
  • The input signal must conform to Input Signal Requirements .
  • Calibrating the Digital Average Power Measurement

Troubleshooting Techniques

  • Check to see if an integrity indicator other than 0 (normal) was returned with a measurement result (see Integrity Indicator ).

    If Questionable result (16) is returned the measurement result is not accurate. For the lab application, when the R-FCH is gated or sometimes gated in radio configuration 3 and above (see R-FCH Gating ), the Digital Average Power measurement can not accurately measure the R-FCH power.

    If over range (5) is returned the input power has exceeded the test set's internal sampler maximum value during some part of the sampling or the input power has exceeded the calibrated range of the test set's power detector.

    If under range (6) is returned the measurement result is below the expected input power level. Under range is also indicated if the input power is below the calibrated range of the test set's power detector.

    If the signal has both over range and under range conditions, only the over range (5) will be indicated.

Related Topics

Integrity Indicator


TX Dynamic Power Measurement Troubleshooting

TX Dynamic Power Measurement Troubleshooting

Last updated: October 28, 2004

IMPORTANT
The TX dynamic power measurement does not run concurrently with any other measurements. If any measurements are running, they are closed when TX dynamic power measurement is initiated, and a message is displayed indicating that a measurement has been closed. Activating another measurement inactivates the TX dynamic power measurement.

IMPORTANT
If the TX dynamic power measurement is running at the time the power control transient transmission starts (see Starting the Reverse CLPC Transient ) the measurement will be closed and its operation aborted. Moreover, the TX dynamic power measurement will not be able to start (become initiated) while the transient transmission is in progress.

Possible Setup Issues

  • The TX dynamic power measurement should be used when call connection status is Idle since mobile station must be in a test mode. Otherwise, the measurement may be hang (waiting for an RF Rise trigger from the mobile station) and the measurement results are invalid even if they are available when the measurement is armed.
  • The TX dynamic power measurement uses single trigger arm (see Triggering of Measurements for details). Use the INIT command or press the START SINGLE key to arm the TX dynamic power measurement.
  • When the TX dynamic power measurement is armed, it will hang until the test set receives an RF Rise impulse (>20 dB) trigger from the mobile station or the timeout period (if set to On, see TX Dynamic Power Measurement Parameters ) expires.
  • The TX dynamic power measurement requires receiver power control in manual mode. If Receiver Power Control is set to Auto (see Receiver Control ) when the measurement is armed, the measurement will not start and an error is returned to indicate the error condition. For manual receiver power control, be certain that you have entered the correct frequency and power values to match your mobile station's test mode.
  • When the TX dynamic power measurement is in progress, the measurement could be aborted due to one or more trigger missed. An example condition that may cause the trigger missed would be GPIB or LAN activities occur during the measurement.
  • For front panel graph control, the Start Step and the Span settings can not add up to more than 100. Otherwise, the new value will be rejected with an error indicating "Upper limit exceeded".

Troubleshooting Techniques

Check to see if an integrity indicator other than 0 (normal) was returned with a measurement result (see Integrity Indicator ).

  • If Trigger Missed (30) is returned, one or more triggers were missed during the measurement. It is to prevent the TX dynamic power measurement from hanging and provide an early termination for the measurement.
  • If Over Range (5) is returned; the input power has exceeded +37 dBm or is greater than +9 dB above the expected power level of the receiver.
  • If Under Range (6) is returned; the input power is below -61 dBm or is less than -9 dB below the expected power level of the receiver.
  • If the measurement has both over range and under range conditions, only the over range (5) will be indicated.
  • If the measurement has several errors, the error which has the highest priority will be indicated.

Other Considerations

  • To help avoid over range or under range integrity indicators, correct for system path loss (see Amplitude Offset ).
  • Calibrating the TX Dynamic Power Measurement

Related Topics

TX Dynamic Power Measurement Description

Manual Operation: Measuring TX Dynamic Power


DTMF Troubleshooting

DTMF Troubleshooting

Last updated: June 20, 2006

Possible Setup Issues

If the DTMF symbols are not captured correctly, the it is possible that the Trigger Arm setting of the measurement is Continuous and the gate time is small. It is recommended to set the trigger arm state to single and retry measurement.

If more than 16 DTMF symbols are transmitted, the DTMF measurement only provides results for the first 16 DTMF symbols detected.

If the input signal is not present or is less than the minimum required input signal, then the integrity is set to "Under Range" and all other results of the measurement are 9.91E+37.

If the input signal overdrives the receiver or is clipped by the receiver, then the integrity is set to "Over Range" and all other results of the measurement are 9.91E+37.

Interpreting Integrity Indicator values

See Integrity Indicator

  • If Over Range (5) is returned, it indicates that the input power has exceeded test set' s internal sampler maximum value by at least 6 dB during some part of the sampling or the input power has exceeded the calibrated range of the test set' s power detector for the expected power setting.
  • If Under Range (6) is returned, it indicates that the measured input power is more than 20 dB below the expected input power level. Under range also indicates that the input power is more than 2 dB below the calibrated range of the test set' s power detector (-30 dBm). If the expected input power setting is correctly set for signal level into the test set, an under range condition can still occur if the receiver has not been tuned to the signal' s frequency.
  • If Burst Not Found (25) is returned, it indicates that no valid DTMF character is measured.
  • If the measurement has several errors, the error that has the highest priority is indicated.

Related Topics

DTMF Measurement Description

Measuring DTMF

Programming a DTMF Measurement


Fixed Timer Messages

Fixed Timer Messages

Last updated: July 31, 2006

Description

This is the list of fixed timers with a brief explanation and their values. A timer expiry message appears in its own window, on the test set display. The user has no access to these values and can not change them. None of the fixed timers are active when operating mode is Test Mode.

Timer Name | Description | Value
T100 RADIO-LINK-TIMEOUT | Detects the presence of the radio link by detecting SACCH frames every 480 ms. | 4 SACCH multiframes. That is 1.92 seconds if the SACCH is completely absent.
T200 Data link timer | Used for re-transmission on the data link. The value varies depending on the message type. | 155 ms for FACCH
T301 Alerting (ringing) timer | Timer used to limit the amount of time a user has to answer a call. | 20 seconds
T303 Mobility Management connection timer | Time the network waits after sending a CM SERVICE REQUEST until receiving a response. This occurs before initiating call clearing procedures towards the MS. | 10 seconds
T305 Release timer | Time the network waits after transmitting a DISCONNECT message until receiving a RELEASE message. | 10 seconds
T306 In-band tones release timer | Time the network waits after transmitting a DISCONNECT message while in-band tones/announcements are provided, until receiving a RELEASE message. | 10 seconds
T308 Release timer | Time the network waits after sending a RELEASE message until receiving a RELEASE COMPLETE message. This occurs before re-transmitting the RELEASE or releasing the Mobility Management connection. | 10 seconds
T310 Call proceeding timer | Time the network waits after receiving a CALL CONFIRMED message until receiving a ALERTING, CONNECT, or DISCONNECT message before initiating clearing procedures towards the MS. | 10 seconds
T313 Connect acknowledge timer | Time the network waits after transmitting a CONNECT message until receiving the CONNECT ACKNOWLEDGE message before performing clearing procedures with the MS. | 10 seconds
T323 Modify complete timer | Time the network waits after sending a MODIFY message during call mode changes, until receiving a MODIFY COMPLETE or MODIFY REJECT message before initiating call clearing procedures. | 10 seconds
T3101 Immediate assignment timer | Time the network waits after sending the IMMEDIATE ASSIGNMENT or IMMEDIATE ASSIGNMENT EXTENDED message until the main signalling link is established before releasing the newly allocated channels. | 1 second
T3103 Handover timer | Time the network waits after transmitting a HANDOVER COMMAND message until receiving HANDOVER COMPLETE or HANDOVER FAILURE or the MS re-establishes the call before the old channels are released. If the timer expires and the network has not received a correctly decoded L2 (format A or B) or TCH frame, then the newly allocated channels are released. | 2 seconds
T3105 Physical information repetition timer | Time the network waits after sending the PHYSICAL INFORMATION message until receiving a correctly decoded L2 (format A or B) or TCH frame. This occur before re-transmitting the PHYSICAL INFORMATION message or releasing the newly allocated channels. | 50 ms
T3107 Channel assignment timer | Time the network waits after transmitting an ASSIGNMENT COMMAND message until receiving the ASSESSMENT FAILURE message or the MS re-establishes the call before releasing the old and the new channels. | 3 seconds
T3109 Signalling disconnection timer | Time the network waits after sending the CHANNEL RELEASE message before disconnecting the signalling link. | 5 seconds
T3111 Channel deactivation after disconnection timer | Time the network waits after disconnecting the signalling link before deactivating the channel. | 500 ms
T3113 Paging timer | Time the network waits after transmitting the PAGING REQUEST message until receiving the PAGING RESPONSE message. This occurs before re-transmitting the PAGING REQUEST (if the maximum number of re-transmissions have not been exceeded). | 5 seconds
T3212 Location update timer | The location update timer is set to zero, periodic location update by the MS are disabled. If the MS camps to the BCH and decodes a new MCC or MNC from the one it last camped on, it should perform a location update. | zero = infinite time
T3250 TMSI reallocation timer | Time the network waits after sending the TMSI REALLOCATION COMMAND until receiving TMSI REALLOCATION COMPLETE. This occurs before aborting the procedure and releasing the Radio Resource connection. | 5 seconds
T3260 Authentication response timer | Time the network waits after an AUTHENTICATION REQUEST until receiving AUTHENTICATION RESPONSE. This occurs before aborting the procedure and releasing the Radio Resource connection. | 5 seconds

Related Topics

Error Messages


Error Messages

Error Messages

Last updated: February 14, 2007

Error Message Lists

Fixed Timer Messages

Manual User Error Messages

-400 through -499 Error Message Descriptions

-300 through -399 Error Message Descriptions

-200 through -299 Error Message Descriptions

-100 through -199 Error Message Descriptions

+100 through +199 Error Message Descriptions

+200 through +299 Error Message Descriptions

+300 through +399 Link Control Device-Specific Error

+400 through +499 Error Message Descriptions

+500 through +599 Application Hardware Device-Specific Error

+600 through +699 Error Message Descriptions

+700 through +799 Error Message Descriptions

+800 through +899 Error Message Descriptions

Description

Reading Error Messages

When an error occurs, an error message is shown in a message window at the center of the test set's display. When an error message is displayed, an audio beep occurs; the beeper state of the test set can be set to on or off. Error messages can be cleared from the test set's display using the DISPlay:WINDow:ERRor:CLEar command, or *CLS. Pressing any functional front panel key, i.e. the LOCAL key, will also clear an error message from the test set's display.

Each error message that is generated is recorded in either the error/event queue or the message log or both.

The error/event queue is read remotely using the SYSTem:ERRor? query. The error/event queue is able to hold 100 messages. The SYSTem:ERRor? query returns one error message at a time. As an error message is queried, it is removed from the error queue. To read the entire error/event queue (and thus also clear the error queue) use the following program.

10 DIM Err_msg$[255]
20 REPEAT
30 OUTPUT 714;"SYSTEM:ERROR?"
40 ENTER 714; Err_num,Err_msg$
50 PRINT Err_num,Err_msg$
60 UNTIL Err_num = 0

You can also clear the error queue by sending *CLS or *RST or by cycling the test set's power.

The message log may be viewed on the test set's display by pressing the SYSTEM CONFIG screen's Message Log key. The message log can display up to 24 entries over two pages. To clear the message log, select Clear Message Log ( F10 ), or cycle the test set's power.

Because the error queue and Message Log can be cleared independently, their contents may differ.

Classes of Errors

Error messages are divided into classes, each class of error is handled differently by the test set. The message log is cleared when the test set is power cycled.

Measurement Integrity Indicators

These messages occur as a result of a measurement, they indicate the validity of the measurement. Measurement integrity indicators are read with the FETCh command.

Non-Persistent Errors

These messages are generated when a condition occurs that is incorrect, but has no serious or long lasting effect on the test set's operation. Examples could include an out of range value to a parameter, or an invalid GPIB mnemonic. The message window is cleared when any front panel key is pressed.

Persistent Errors

These errors are generated when a non-transitory error condition exists. Persistent errors occur when a hardware failure is found, or when damage or injury to a person or the test set may occur.

The test set displays these errors in the error message window and as a prompt at the bottom of the display screen where it remains until the error condition no longer exists.

Fatal Errors

When these errors occur no further operation of the test set is possible without cycling the power switch. Fatal errors are not saved in the error message log. The test set display will provide the user with information about what to do next and some details about what the test set was doing when the fatal error occurred.

Maskable Messages

These messages are intended to inform the user of a condition within the test set. They are generally meant to provide information to the user. The user will need to decide if this condition is undesirable and if they want the message to appear.

Maskable Message Display State

The Maskable Messages Display State found in the Instrument Setup menu gives users a way to block these messages and the associated beep from ever happening. When the state is Off these messages and their associated beep will be blocked. The Maskable Message Display State can be set manually or with the following GPIB command:

OUTPUT 714;"DISPLAY:MESSAGE:MASKABLE:STATE OFF"
! Prevents certain messages from appearing on the display.

Instrument Maskable Messages

  • Instrument warning: Audio Generator instrument has been closed.
  • Instrument warning: Audio Analyzer instrument has been closed.
  • Instrument warning: Analog Audio instrument has been closed.

Related Topics

SYSTem:ERRor?


Error Message Log

Error Message Log

Last updated: October 28, 2004

Description

When an error message is displayed, it is also logged in the error message log. This log is only accessible manually; it is not available through GPIB. The error message log can be displayed by pressing the F7 menu key from the SYSTEM CONFIG screen. Next Page and Previous Page controls are provided.

All errors and events that are generated are displayed in the error message log. When the log is full a new message is sent to the log and the oldest message is removed from the log. The log is cleared when the test set powers up or when you press F10 (Clear Error Message Log).

Related Topics

Error Messages


Manual User Error Messages

Manual User Error Messages

Last updated: June 20, 2006

Description

These messages are intended to be displayed on the manual user interface only, and are not entered into the Error/Event Queue.

Error Message | Description
The function you requested is not yet available. | The test set does not have this capability.
IQ Calibration completed successfully for modulator <N> | <N> is the IQ modulator number that you are attempting to calibrate, <N> is 1 or 2.
IQ Calibration failed for modulator <N> | <N> is the IQ modulator number that you are attempting to calibrate, <N> is 1 or 2.
The function you requested is not available in this TA. | This function is used in another Test Application.
IQ Calibration for modulator 1 in progress (10 minutes). Call processing disabled. | This error is cleared by either the; IQ Calibration completed successfully for modulator <N>, or IQ Calibration failed for modulator <N>.
IQ Calibration for modulator 2 in progress (6 minutes). Call processing disabled. | This error is cleared by either the; IQ Calibration completed successfully for modulator <N>, or IQ Calibration failed for modulator <N>.
Instrument warning: Audio generator instrument has been closed. | The audio generator instrument was closed automatically by the test set.
Measurement warning: Audio Analyzer instrument has been closed. | The audio analyzer instrument was closed automatically by the test set.
Measurement warning: Analog audio measurement has been closed. | Analog audio measurements have been closed by the test set.
Protocol warning: Setting change has terminated the link with the DUT | Some setting change has caused the call to disconnect.
Warning; Call processing disabled | The call processing functions are not active because the test set is performing calibration operations.
IQ first modulator calibration X% | IQ modulator calibration in progress, X represents the percent complete.
IQ second modulator calibration X% | IQ modulator calibration in progress, X represents the percent complete.

Device Specific MUI Errors

TA2000 MUI Errors
Error Message | Description
MUI100 "Call processing disabled" | This error, during calibration, is part of the test set's normal operation. If this error occurs during mobile station testing, an internal error has occurred in the test set's firmware.
CDMA MUI Errors
Error Message | Description
MUI200 "Call processing disabled" | This error, during calibration, is part of the test set's normal operation. If this error occurs during mobile station testing, an internal error has occurred in the test set's firmware.
MUI210 "Channel power calibration completed successfully" | This error message is displayed for information purposes only.
MUI211 "Channel power calibration failed due to temperature drift. Wait for temperature to stabilize" | This error message occurs when the internal temperature of the test set has drifted more that +/- 10 deg C since the last calibration. Normally, letting the test set fully warm up before calibrating will eliminate this problem.
MUI212 "Channel power calibration failed due to oven out of range" | The only user requirement for performing calibration is to make sure the test set is warmed up and to remove RF power to the front panel RF IN/OUT connector. If these requirements have been met and this message appears a test set failure condition exists.
MUI213 "Channel power calibration failed due to loopback switch problem" | The only user requirement for performing calibration is to make sure the test set is warmed up and to remove RF power to the front panel RF IN/OUT connector. If these requirements have been met and this message appears a test set failure condition exists.
MUI214 "Channel power calibration failed due to under range condition" | The only user requirement for performing calibration is to make sure the test set is warmed up and to remove RF power to the front panel RF IN/OUT connector. If these requirements have been met and this message appears a test set failure condition exists.
MUI215 "Channel power calibration failed due to over range condition" | The only user requirement for performing calibration is to make sure the test set is warmed up and to remove RF power to the front panel RF IN/OUT connector. If these requirements have been met and this message appears a test set failure condition exists.
MUI216 "Channel power calibration failed due to correlation problem" | The only user requirement for performing calibration is to make sure the test set is warmed up and to remove RF power to the front panel RF IN/OUT connector. If these requirements have been met and this message appears a test set failure condition exists.
MUI217 "Channel power calibration failed" | The only user requirement for performing calibration is to make sure the test set is warmed up and to remove RF power to the front panel RF IN/OUT connector. If these requirements have been met and this message appears a test set failure condition exists.
MUI218 "Channel power calibration in progress. Do not apply RF power during calibration." | This error message is displayed for information purposes only.
MUI219 "Channel power calibration<x>%." | This error message is displayed for information purposes only.
MUI220 "Channel power calibration failed due to source level problem." | This error message is displayed for information purposes only.
MUI221 "Channel power calibration failed due to IF filter coefficient problem." | This error message is displayed for information purposes only.
MUI222 "Channel power calibration failed due to IF frequency response problem." | This error message is displayed for information purposes only.
MUI223 "Channel power calibration failed due to waveform quality problem." | This error message is displayed for information purposes only.
MUI230 "Digital average power calibration completed successfully. Cycle power to continue." | This error message is displayed for information purposes only.
MUI231 "Digital average power calibration failed due to temperature drift. Wait for temperature to stabilize." | This error message occurs when the internal temperature of the test set has drifted more that +/- 10 deg C since the last calibration. Normally, letting the test set fully warm up before calibrating will eliminate this problem.
MUI232 "Digital average power calibration failed due to oven out of range | This error message occurs when the internal temperature of the test set has drifted more that +/- 10 deg C since the last calibration. Normally, letting the test set fully warm up before calibrating will eliminate this problem.
MUI233 "Digital average power calibration failed due to loopback switch problem | The only user requirement for performing calibration is to make sure the test set is warmed up and to remove RF power to the front panel RF IN/OUT connector. If these requirements have been met and this message appears a test set failure condition exists.
MUI234 "Digital average power calibration failed" | The only user requirement for performing calibration is to make sure the test set is warmed up and to remove RF power to the front panel RF IN/OUT connector. If these requirements have been met and this message appears a test set failure condition exists.
MUI235 "Digital average power calibration in progress. Do not apply RF power during calibration" | This error message is displayed for information purposes only.
MUI236 "Digital average power calibration <x>%." | This error message is displayed for information purposes only.
MUI241 "Digital average power measurement has been closed" | This error message is displayed for information purposes only.
MUI242 "Waveform quality measurement has been closed" | This error message is displayed for information purposes only.
MUI243 "Channel power measurement has been closed" | This error message is displayed for information purposes only.
MUI244 "Frame error rate measurement has been closed" | This error message is displayed for information purposes only.
MUI245 "Access probe power measurement has been closed" | This error message is displayed for information purposes only.
MUI246 "Time response of open loop power control measurement has been closed" | This error message is displayed for information purposes only.
MUI247 "Gated power measurement has been closed" | This error message is displayed for information purposes only.
MUI248 "Tx spurious emissions measurement has been closed" | This error message is displayed for information purposes only.
MUI249 "CDMA measurement warning; Graphical access probe power measurement has been closed." | This error message is displayed for information purposes only.
MUI250 "CDMA measurement warning; TX dynamic power measurement has been closed." | This error message is displayed for information purposes only.
MUI251 "CDMA measurement warning; Multi-tone audio measurement has been closed." | This error message is displayed for information purposes only.
MUI252 CDMA measurement warning; Fast Device Tune measurement has been closed |
MUI253 Frequency and Power Sequence tables built successfully |
MUI261 "CDMA measurement warning; TX spurious emissions measurement requires MS to transmit in non-gated mode. Verify loopback service option and full traffic data rate" | Select "Full" in the Traffic Data Rate field before attempting TX Spurious measurements.
MUI262 "CDMA measurement warning; Digital average power measurement is not accurate for gated MS transmissions in radio configurations greater than 2" | The test set can accurately measure gated MS transmissions in RC 1 and 2, but not in RC 3, 4 and 5. In RC 3, 4 and 5 it is sometimes impossible for the test set to know whether the MS is transmitting gated or not. So when this warning is seen, the user must decide whether or not their current setup leads to MS gated output or not. See R-FCH Gating .
Digital2000 MUI Errors
Error Message | Description
MUI300 "Digital2000 warning; Call processing disabled" | This error, during calibration, is part of the test set's normal operation. If this error occurs during mobile station testing, an internal error has occurred in the test set's firmware.
MUI341 "Digital2000 warning; Handoff waveform quality measurement has been closed" | This error message is displayed for information purposes only.
MUI342 "Digital2000 warning; Code channel time/phase measurement has been closed" | This error message is displayed for information purposes only.
MUI343 "Digital2000 warning; TDSO frame error rate measurement has been closed" | This error message is displayed for information purposes only.
Digital95 MUI Errors
Error Message | Description
MUI400 "Digital2000 warning; Call processing disabled" | This error, during calibration, is part of the test set's normal operation. If this error occurs during mobile station testing, an internal error has occurred in the test set's firmware.

Related Topics

Error Message Log


-100 through -199 Error Message Descriptions

-100 through -199 Error Message Descriptions

Last updated: April 21, 2005

Description

A command error indicates that the test set's GPIB parser has detected an IEEE 488.2 syntax error.

When one of these errors is generated, the command error bit in the event status register is set.

Error Message | Description
-100 Command error | This event bit (Bit 5) indicates a syntax error, or a semantic error, or a GET command was entered, see IEEE 488.2, 11.5.1.1.4.
-101 Invalid character | Indicates a syntactic elements contains a character which is invalid for that type.
-102 Syntax error | Indicates that an unrecognized command or data type was encountered. For example, a string was received when the device does not accept strings.
-103 Invalid separator | The parser was expecting a separator and encountered an illegal character. For example, the semicolon was omitted after a program message unit.
-104 Data type error | The parser recognized a data element different than one allowed. For example, numeric or string data was expected but block data was encountered.
-105 Get not allowed | Indicates a Group Execute Trigger was received within a program message. Correct the program so that the GET does not occur within the program code.
-108 Parameter not allowed | Indicates that more parameters were received than expected for the header. For example, *ESE common command only accepts one parameter, so *ESE 0,1 is not allowed.
-109 Missing parameter | Indicates that less parameters were received than required for the header. For example, *ESE requires one parameter, *ESE is not allowed.
-110 Command header error | Indicates an error was detected in the header. This error is used when the device cannot detect the more specific errors -111 through -119.
-111 Header separator error | Indicates that a character that is not a legal header separator was encountered while parsing the header.
-112 Program mnemonic too long | Indicates that the header contains more that twelve characters, see IEEE 488.2, 7.6.1.4.1.
-113 Undefined header | Indicates the header is syntactically correct, but it is undefined for this specific device. For example, *XYZ is not defined for any device.
-114 Header suffix out of range | Indicates the value of a header suffix attached to a program mnemonic makes the header invalid.
-120 Numeric data error | This error, as well as errors -121 through -129, are generated when parsing a data element which appears to be numeric, including non-decimal numeric types. This particular error is used if the device cannot detect a more specific error.
-121 Invalid character in number | Indicates an invalid character for the data type being parsed was encountered. For example, an alpha in a decimal numeric or a "9" in octal data.
-123 Exponent too large | Indicates the magnitude of an exponent was greater than 32000, see IEEE 488.2, 7.7.2.4.1.
-124 Too many digits | Indicates the mantissa of a decimal numeric data element contained more than 255 digits excluding leading zeros, see IEEE 488.2, 7.7.2.4.1.
-128 Numeric data not allowed | Indicates that a legal numeric data element was received, but the device does not accept one in this position for the header.
-130 Suffix error | This error, as well as errors -131 through -139, are generated when parsing a suffix. This particular error message is used if the device cannot detect a more specific error.
-131 Invalid suffix | Indicates the suffix does not follow the syntax described in IEEE 488.2, 7.7.3.2, or the suffix is inappropriate for this device.
-134 Suffix too long | Indicates the suffix contain more than 12 characters, see IEEE 488.2, 7.7.3.4.
-138 Suffix not allowed | Indicates that a suffix was encountered after a numeric element that does not allow suffixes.
-140 Character data error | This error, as well as errors -141 through -149, are generated when parsing a character data element. This particular error message is used if the device cannot detect a more specific error.
-141 Invalid character data | Indicates that the character data element contains an invalid character or the particular element received is not valid for the header.
-144 Character data too long | Indicates the character data element contains more than twelve characters, see IEEE 488.2, 7.7.1.4.
-148 Character not allowed | Indicates a legal character data element was encountered where prohibited by the device.
-150 String data error | This error, as well as errors -151 through -159, are generated when parsing a string data element. This particular error message is used if the device cannot detect a more specific error.
-151 Invalid string data | Indicates that a string data element was expected, but was invalid, see IEEE 488.2, 7.7.5.2. For example, an END message was received before the terminal quote character.
-158 String data not allowed | Indicates that a string data element was encountered but was not allowed by the device at this point in parsing.
-160 Block data error | This error, as well as errors -161 through -169, are generated when parsing a block data element. This particular error message is used if the device cannot detect a more specific error.
-161 Invalid block data | Indicates a block data element was expected, but was invalid, see IEEE 488.2, 7.7.6.2. For example, and END message was received before the end length was satisfied.
-168 Block data not allowed | Indicates a legal block data element was encountered, but not allowed by the device at this point in parsing.
-170 Expression error | This error, as well as errors -171 through -179, are generated when parsing an expression data element. This particular error message is used if the device cannot detect a more specific error.
-171 Invalid expression | Indicates the expression data element was invalid, see IEEE 488.2, 7.7.7.2. For example, unmatched parentheses or an illegal character.
-178 Expression data not allowed | Indicates a legal expression data was encountered, but was not allowed by the device at this point in parsing.
-180 Macro error | This error, as well as error -181 through -189, are generated when defining a macro or execution a macro. This particular error message is used if the device cannot detect a more specific error.
-181 Invalid output macro definition | Indicates that a macro parameter place holder was encountered outside of a macro definition.
-183 Invalid inside macro definition | Indicates that the program message unit sequence, sent with a *DDT or a *DMC command, is syntactically invalid, see IEEE 488.2, 10.7.6.3.
-184 Macro parameter error | Indicates that a command inside the macro definition had the wrong number or type of parameters.

Related Topics

Error Messages


-200 through -299 Error Message Descriptions

-200 through -299 Error Message Descriptions

Last updated: October 28, 2004

Description

These errors are generated when something occurs that is incorrect in the current state of the instrument. These errors may be generated by a user action from either the remote or the manual user interface.

Error Message | Description
-200 Execution error | This event bit (Bit 4) indicates a PROGRAM DATA element following a header was outside the legal input range or otherwise inconsistent with the device's capabilities, see IEEE 488.2, 11.5.1.1.5.
-203 Command protected | Indicates that a legal password-protected program command or query could not be executed because the command was disabled.
-220 Parameter error | Indicates that a program data element related error occurred.
-221 Setting conflict | Indicates that a legal program data element was parsed but could not be executed due to the current device state.
-222 Data out of range | Indicates that a legal program data element was parsed but could not be executed because the interpreted value was outside the legal range defined by the devices
-223 Too much data | Indicates that a legal program data element of block, expression, or string type was received that contained more data than the device could handle due to memory or related device-specific requirements.
-224 Illegal parameter value | Indicates that the value selected was not part of the list of values given.
-225 Out of memory | The device has insufficient memory to perform the requested operation.
-226 Lists not the same length | Attempted to use LIST structure having individual LIST's of unequal lengths.
-230 Data corrupt or stale | Indicates invalid data, a new reading started but not completed since the last access.
-231 Data questionable | Indicates that measurement accuracy is suspect.
-233 Invalid version | Indicates that a legal program data element was parsed but could not be executed because the version of the data is incorrect to the device. For example, a not supported file version, a not supported instrument version.
-240 Hardware error | Indicates that a legal program command or query could not be executed because of a hardware problem in the device.
-241 Hardware missing | Indicates that a legal program command or query could not be executed because of missing device hardware. For example, an option was not installed.
-250 Mass storage error | Indicates that a mass storage error occurred. The device cannot detect the more specific errors described for errors -251 through -259.
-251 Missing mass storage | Indicates that a legal program command or query could not be executed because of missing mass storage.
-252 Missing media | Indicates that a legal program command or query could not be executed because of missing media. For example, no disk.
-253 Corrupt media | Indicates that a legal program command or query could not be executed because of corrupt media. For example, bad disk or wrong format.
-254 Media full | Indicates that a legal program command or query could not be executed because the media is full. For example, there is no room left on the disk.
-255 Directory full | Indicates that a legal program command or query could not be executed because the media directory was full.
-256 File name not found | Indicates that a legal program command or query could not be executed because the file name was not found on the media.
-257 File name error | Indicates that a legal program command or query could not be executed because the file name on the device media was in error. For example, an attempt was made to read or copy a nonexistent file.
-258 Media protected | Indicates that a legal program command or query could not be executed because the media was protected. For example, the write-protect switch on a memory card was set.
-270 Macro error | Indicates that a macro related execution error occurred.
-271 Macro syntax error | Indicates that a syntactically legal macro program data sequence, according to IEEE 488.2, 10.7.2, could not be executed due to a syntax error within the macro definition.
-272 Macro execution error | Indicates that a syntactically legal macro program data sequence could not be executed due to some error in the macro definition, see IEEE 488.2, 10.7.6.3.
-273 Illegal macro label | Indicates that the macro label was not accepted, it did not agree with the definition in IEEE 488.2, 10.7.3
-274 Macro parameter error | Indicates that the macro definition improperly used a macro parameter placeholder, see IEEE 4882, 10.7.3.
-275 Macro definition too long | Indicates that a syntactically legal macro program data sequence could not be executed because the string of block contents were too long for the device to handle, IEEE 488.2, 10.7.6.1.
-276 Macro recursion error | Indicates that a syntactically legal macro program data sequence count not be executed because it would be recursive, see IEEE 488.2, 10.7.6.6.
-277 Macro redefinition not allowed | Indicates that redefining an existing macro label, see IEEE 488.2, 10.7.6.4.
-278 Macro header not found | Indicates that a legal macro label in the *GMS?, see IEEE 488.2, 10.13, could not be executed because the header was not previously defined.

Related Topics

Error Messages


-300 through -399 Error Message Descriptions

-300 through -399 Error Message Descriptions

Last updated: October 28, 2004

Description

A device-specific error indicates that the instrument has detected an error that occurred because some operations did not properly complete, possibly due to an abnormal hardware or firmware condition. For example, an attempt by the user to set an out of range value will generate a device specific error. When one of these errors is generated, the device specific error bit in the event status register is set.

Error Message | Description
-300 Device specific error | This event bit (Bit 3) indicates that a device operation did not properly complete due to some condition, such as overrange see IEEE 488.2, 11.5.1.1.6.
-311 Memory error | Indicates some physical fault in the devices memory, such as a parity error.
-312 PUD memory lost | Indicates protected user data saved by the *PUD command has been lost, see IEEE 488.2, 10.27.
-313 Calibration memory lost | Indicates that nonvolatile calibration data used by the *CAL? command has been lost, see IEEE 488.2, 10.2.
-314 Save/recall memory lost | Indicates that the nonvolatile data saved by the *SAV command has been lost, see IEEE 488.2, 10.33.
-315 Configuration memory lost | Indicates that nonvolatile configuration data saved by the device has been lost.
-320 Storage fault | Indicates that the firmware detected a fault when using data storage. This is not an indication of physical damage or failure of any mass storage element.
-321 Out of memory | An internal operation needed more memory than was available
-330 Self test failed | Indicates a problem with the device that is not covered by a specific error message. The device may require service.
-340 Calibration failed | Indicates a problem during calibration of the device that is not covered by a specific error.
-350 Queue overflow | Indicates that there is no room in the queue and an error occurred but was not recorded. This code is entered into the queue in lieu of the code that caused the error.
-360 Communication error | This is the generic communication error for devices that cannot detect the more specific errors described for error -361 through -363.
-361 Parity error in program message | Parity bit not correct when data received for example, on a serial port.
-362 Framing error in program message | A stop bit was not detected when data was received for example, on a serial port (for example, a baud rate mismatch).
-363 Input buffer overrun | Software or hardware input buffer on serial port overflows with data caused by improper or nonexistent pacing.

Related Topics

Error Messages


-400 through -499 Error Message Descriptions

-400 through -499 Error Message Descriptions

Last updated: October 28, 2004

Description

A Query error is generated either when data in the instrument's GPIB output queue has been lost, or when an attempt is being made to read data from the output queue when no output is present or pending.

Error Message | Description
-400 Query error | This event bit (Bit 2) indicates that an attempt to read data from the Output Queues when no output is present or pending, to data in the Output Queue has been lost see IEEE488.2, 11.5.1.1.7.
-410 Query INTERRUPTED | Indicates the test set has been interrupted by a new program message before it finishes sending a RESPONSE MESSAGE see IEEE 488.2, 6.3.2.3.
-420 Query UNTERMINATED | Indicates an incomplete Query in the program see IEEE 488.2, 6.3.2.2.
-430 Query DEADLOCKED | Indicates that the Input Buffer and Output Queue are full see IEEE 488.2, 6.3.1.7.
-440 Query UNTERMINATED after indefinite response | Indicates that a query was received in the same program message after a query requesting an indefinite response was executed see IEEE 488.2, 6.5.7.5.

Related Topics

Error Messages


+100 through +199 Error Message Descriptions

+100 through +199 Error Message Descriptions

Last updated: February 14, 2007

Description

A device-specific error indicates that the instrument has detected an error that occurred because some operations did not properly complete, possibly due to an abnormal hardware or firmware condition. For example, an attempt by the user to set an out of range value will generate a device specific error.

These are general errors generated by the core instrument. When one of these errors is generated, the `+100 errors' bit in the questionable error status register is set.

Error Message

Description

+101 Assert; Cycle power. Assert message<message1>

<message1> will appear as:

;P:DSP T:<task ID> E:<error code> C:<error classif.> F1:<flag 1> F2:<flag 2> if the DSP generated the assert.

;P:Protocol T:<task ID> L:<line number> F:<file name> if the Protocol processor generated the assert.

;P:Host T:<task ID> L:<line number> F:<file name> if the Host processor generated the assert.

+102 Exception; Cycle power. Exception message<message2>

<message2> will appear as: T:<task ID> or V:<vector number> or PC:<program counter> or DA:<data adrs reg value>.

Vector number, program counter and data address register values are hexadecimal format.

+103 Failure; No measurements or settings can be made

Indicates none of the VI's are operational because a serious problem exists.

+104 Failure; No settling operations will take place

Indicates none of the VI's are operational because a serious problem exists.

+105 Failure; No measurements or setting can be made for the function selected

Indicates none of the VI's are operational because a serious problem exists.

+110 Input pacing; Internal communication queue overflow likely

Indicates that GPIB commands are too fast for the device input queue and should be slowed.

+111 Input pacing; Internal communication queue overflow imminent. Pacing increased

Indicates that GPIB commands were too fast and the device input queue has not kept pace.

+112 Internal error; Protocol error <message3>

<message3> is an eight digit hexadecimal number that is the error code reported by protocol.

+113 Internal error; <VI NAME> forced inactive

Indicates that a VI is inactivated when not executed.

<VI NAME> includes: "IntVmVI","GprsBsEmulVI", "GsmComBsEmulVI","GSMFixedVI", "MiscVI", "GSMSacchMriVI", "IQSelfCalVI1", "IQSelfCalVI2", "TA RevisionVI", "TdmaTaBsEmulVI".

+114 Internal error; <VI NAME> not responding

Indicates that a VI has not been instantiated or the state is not available.

<VI NAME> includes: "IntVmVI","GprsBsEmulVI", "GsmComBsEmulVI", "GSMFixedVI", "MiscVI", "GSMSacchMriVI", "IQSelfCalVI1", "IQSelfCalVI2", "TA RevisionVI", "TdmaTaBsEmulVI", "RfHwAccessVI".

+115 Internal error; <VI NAME> inactive

Indicates that a VI has been made inactive.

<VI NAME> includes: "IntVmVI", "GSMFixedVI", "MiscVI", "GSMSacchMriVI", "IQSelfCalVI1", "IQSelfCalVI2", "TA RevisionVI".

+120 Warning; Receiver over range due to requested settings

Indicates the total received power (a combination of received power and amplitude offset) is above the range of the test set.

+121 Warning; Receiver under range due to requested settings

Indicates the total received power (a combination of received power and amplitude offset) is below the range of the test set.
+122 Warning; Reference out of lock

Indicates the test set's internal reference is out of lock.

+123 Warning; Duplicate RF IN/OUT Amplitude Offset Frequency entry. First frequency entry in RF IN/OUT Amplitude Offset table will be used.

Indicates that an amplitude offset value for that frequency has already been entered. The test set will use the amplitude offset value entered first.

+124 Warning; Source over range due to requested settings

The setting selected for total transmit power (a combination of cell power, AWGN power, amplitude offset) is above the test set's range.

+125 Warning; Source under range due to requested settings

The setting selected for total transmit power (a combination of cell power, AWGN power, amplitude offset) is below the test set's range.

+126 Warning; Data out of range error for system time, system date, time zone, UTC time or UTC date due to user input error or couplings between these settings

+127 Warning; Impairments backoff (IBO) over range due to settings made under external software control

+129 Configuration warning: License will expire soon

The temporary license is about to expire. This message will give the license number and the number of days before it is scheduled to expire.

+130 Configuration error; Unable to switch to indicated Test Application

The test application selected is not available for this test set.

+131 Configuration error; Current Test Application is not licensed (License = N). Select another Test Application

The test application selected is not licensed. Select another revision or test application that is licensed (License = L).

+132 Configuration error; Selected Test Application Format is not available.

Indicates that the fast switching operation will not activate a particular radio format. Check the revision number of the test application associated with the radio format, does the revision correspond with what the fast switching test application needs?
+133 Configuration error; Selected Test Application Format is not licensed, (License = N).

The radio format selected is not licensed. Select another revision or obtain a licensed revision of the test application test application that is licensed (License = L).

+134 Configuration error; Unable to switch to selected Test Application Format

The Test Application Format name used is correct but for some reason the test set can not switch to that format.

+137 Configuration error; The license has expired for the selected format

When a license expires you must switch applications by pressing the SYSTEM CONFIG key and then selecting Format Switch (F2) or Application Selection (F3).

+138 Configuration error; Selected format is not licensed due to unexpected system time change

 This message is displayed when a temporary license expires due to a change occurring to system time.

+139 Configuration error; Functionality is not available

+140 Operation rejected; Command is not supported in this operating mode

+141 Operation Rejected; A Measurement Is Currently Controlling This Setting. | An attempt has been made to access a setting that is being controlled by a measurement.

+142 Configuration error; Functionality not available

An attempt has been made to access lab application functions from a test application.

+143 Operation Rejected; Selected measurement is not available in the current measurement selection list

An attempt has been made to access a measurement that is not available in the current application.

+144 Operation rejected; PC connection not established

+145 Operation rejected; Feature is not licensed. See www.agilent.com/find/8960upgrades for additional information

The feature you are attempting to access is not licensed in your test set. Visit www.agilent.com/find/8960upgrades to find out how to acquire the required license.

+146 Operation rejected; External 8960 connection feature is not licensed. See www.agilent.com/find/8960upgrades for additional information

The external 8960 connection feature requires a license in a test application. Visit www.agilent.com/find/8960upgrades to find out how to acquire the required license.
+146 FDD operation rejected; HSDPA is not licensed. See www.agilent.com/find/8960upgrades for additional information | The HSDPA feature requires a license in a test application. Visit www.agilent.com/find/8960upgrades to find out how to acquire the required license.
+147 Help is enabled. Select a field to display the GPIB syntax. For additional help refer to www.agilent.com/find/8960 and select "8960 Online User's Guides".

+148 Operation rejected; Setting is currently under external control

+149 Warning; Running a partially qualified version of the application

+150 Operation rejected; LAN IP address 2 cannot be the same as the instrument LAN address

+151 Operation rejected; LAN IP address 2 must be on the same subnet as the instrument

+152 Warning; LAN IP address 2 cleared to 0.0.0.0 due to an instrument LAN address or subnet mask change

+160 Save/Recall error; File operation error

 Occurs if there is any disk read or write problems when trying to save, recall or delete a register.

+161 Save/Recall error; Recalling available (empty) register

 Occurs if an attempt is made to recall any register that has not been saved.
+162 Save/Recall error; Functionality is not yet available for current application. | Occurs when an attempt to save a save/recall register while using an application that has not implemented this feature.

+163 Save/Recall error; Functionality is not yet available for current application

+170 Warning; RF source 1 ALC mode set to closed due to requested setting

+171 Warning; 8960 has been restarted after a non-recoverable error occurred.

Occurs when the instrument has completed its power up sequence after restarting due to a fatal error.

Device Specific General Errors

Digital95 General Errors
Error Message | Description
+181 Digital95 setting deferred: Cell power and AWGN power >20 dB apart | A setting is deferred when that setting causes incompatibility between related settings. The test set will allow the entry of incompatible settings but the change will not affect signal levels until the incompatibility is resolved.
+182 Digital95 setting deferred: One or more cell 1 code channel levels >30 dB below total RF power | A setting is deferred when that setting causes incompatibility between related settings. The test set will allow the entry of incompatible settings but the change will not affect signal levels until the incompatibility is resolved.
+183 Digital95 setting deferred: Cell 1 code channel levels result in OCNS level > 0 dB | A setting is deferred when that setting causes incompatibility between related settings. The test set will allow the entry of incompatible settings but the change will not affect signal levels until the incompatibility is resolved.
+184 Digital95 setting(s) deferred; Cell 2 power and AWGN power > 20 dB apart | A setting is deferred when that setting causes incompatibility between related settings. The test set will allow the entry of incompatible settings but the change will not affect signal levels until the incompatibility is resolved.
+185 Digital95 setting(s) deferred; One or more cell 2 code channel levels > 30 dB below total RF power | A setting is deferred when that setting causes incompatibility between related settings. The test set will allow the entry of incompatible settings but the change will not affect signal levels until the incompatibility is resolved.
+186 Digital95 setting(s) deferred; Cell 2 code channel levels result in OCNS level > 0 dB | A setting is deferred when that setting causes incompatibility between related settings. The test set will allow the entry of incompatible settings but the change will not affect signal levels until the incompatibility is resolved.
+187 Digital95 setting(s) deferred; Cell 1 power and external AWGN power > 20 dB apart | A setting is deferred when that setting causes incompatibility between related settings. The test set will allow the entry of incompatible settings but the change will not affect signal levels until the incompatibility is resolved.
+188 Digital95 setting(s) deferred; Cell 2 power and external AWGN power > 20 dB apart | A setting is deferred when that setting causes incompatibility between related settings. The test set will allow the entry of incompatible settings but the change will not affect signal levels until the incompatibility is resolved.
+189 Digital95 setting(s) deferred; AWGN power and external AWGN power > 20 dB apart | A setting is deferred when that setting causes incompatibility between related settings. The test set will allow the entry of incompatible settings but the change will not affect signal levels until the incompatibility is resolved.
+190 Digital95 settings conflict: Cell 1 traffic level changed due to rate set change | Changing Radio Configuration or Service Option may cause this error message which indicates the test set will change Traffic Level to a setting compatible with the related changes to the radio configuration or service option.
+191 Digital95 settings conflict: Cell 1 traffic level changed due to traffic data rate change | Lowering Traffic Data Rate with the Traffic Level set too high, or increasing the Traffic level at low Traffic Data Rate (for example, eighth) can cause this error message. The test set will decrease Traffic Level to a setting compatible with the current Traffic Data Rate.
+192 Digital95 settings conflict; Cell 2 traffic level changed due to rate set change | Changing Radio Configuration or Service Option may cause this error message which indicates the test set will change Traffic Level to a setting compatible with the related changes to the radio configuration or service option.
+193 Digital95 settings conflict; Cell 2 traffic level changed due to traffic data rate change | Lowering Traffic Data Rate with the Traffic Level set too high, or increasing the Traffic level at low Traffic Data Rate (for example, eighth) can cause this error message. The test set will decreased Traffic Level to a setting compatible with the current Traffic Data Rate.
+194 Digital95 settings conflict; Voice service option audio changed to null frames due to lack of support for the multi-tone audio source in SO3. | The Enhance Variable Rate Codec (EVRC) is used when encoding and decoding analog (voice) signals for the traffic when service option 3 (SO3) is in use. The EVRC algorithm are protected and can not be legally used in our test set. This error is presented when the test set needs to execute the EVRC algorithms such as service option set to SO3 and Voice Service Option Audio set to Multi-Tone. In this condition, the test set sets the Voice Service Option Audio to Null Frames and presents this error message. Agilent Technologies continues to work with the licensors to reach favorable terms in which this restriction can be removed. See Voice SO Mode .
+198 Digital95 settings conflict; Voice service option mode change to null frames due to lack of support for the real-time vocoder audio source in SO3. | The EVRC algorithm are protected and can not be legally used in our test set. This error is presented when the test set needs to execute the EVRC algorithms such as service option set to SO3 and Voice Service Option set to Real-Timer Vocoder. See Voice SO Mode .
+199 Digital95 settings conflict; Voice service option mode cannot be set to real-time vocoder due to lack of hardware support. | This happens when the hardware in the test set doesn't support real-time vocoder while the Voice Service Option mode is set to Real-Time Vocoder. See Voice SO Mode .
Digital2000 General Errors
Error Message | Description
+180 Digital2000 setting(s) deferred; Forward power control Max F-FCH Level < F-FCH Level | A setting is deferred when that setting causes incompatibility between related settings. The test set will allow the entry of incompatible settings but the change will not affect signal levels until the incompatibility is resolved.
+181 Digital2000 setting deferred: Cell power and AWGN power >20 dB apart | A setting is deferred when that setting causes incompatibility between related settings. The test set will allow the entry of incompatible settings but the change will not affect signal levels until the incompatibility is resolved.
+182 Digital2000 setting deferred: One or more cell 1 code channel levels >30 dB below total RF power | A setting is deferred when that setting causes incompatibility between related settings. The test set will allow the entry of incompatible settings but the change will not affect signal levels until the incompatibility is resolved.
+183 Digital2000 setting deferred: Cell 1 code channel levels result in OCNS level > 0 dB | A setting is deferred when that setting causes incompatibility between related settings. The test set will allow the entry of incompatible settings but the change will not affect signal levels until the incompatibility is resolved.
+184 Digital2000 setting(s) deferred; Cell 2 power and AWGN power > 20 dB apart | A setting is deferred when that setting causes incompatibility between related settings. The test set will allow the entry of incompatible settings but the change will not affect signal levels until the incompatibility is resolved.
+185 Digital2000 setting(s) deferred; One or more cell 2 code channel levels > 30 dB below total RF power | A setting is deferred when that setting causes incompatibility between related settings. The test set will allow the entry of incompatible settings but the change will not affect signal levels until the incompatibility is resolved.
+186 Digital2000 setting(s) deferred; Cell 2 code channel levels result in OCNS level > 0 dB | A setting is deferred when that setting causes incompatibility between related settings. The test set will allow the entry of incompatible settings but the change will not affect signal levels until the incompatibility is resolved.
+187 Digital2000 setting(s) deferred; Cell 1 power and external AWGN power > 20 dB apart | A setting is deferred when that setting causes incompatibility between related settings. The test set will allow the entry of incompatible settings but the change will not affect signal levels until the incompatibility is resolved.
+188 Digital2000 setting(s) deferred; Cell 2 power and external AWGN power > 20 dB apart | A setting is deferred when that setting causes incompatibility between related settings. The test set will allow the entry of incompatible settings but the change will not affect signal levels until the incompatibility is resolved.
+189 Digital2000 setting(s) deferred; AWGN power and external AWGN power > 20 dB apart | A setting is deferred when that setting causes incompatibility between related settings. The test set will allow the entry of incompatible settings but the change will not affect signal levels until the incompatibility is resolved.
+190 Digital2000 settings conflict: Cell 1 F-FCH level changed due to rate set change | Changing Radio Configuration or Service Option may cause this error message which indicates the test set will change Traffic Level to a setting compatible with the related changes to the radio configuration or service option.
+191 Digital2000 settings conflict: Cell 1 F-FCH level changed due to traffic data rate change | Lowering Traffic Data Rate with the Traffic Level set too high, or increasing the Traffic level at low Traffic Data Rate (for example, eighth) can cause this error message. The test set will decrease Traffic Level to a setting compatible with the current Traffic Data Rate.
+192 Digital2000 settings conflict; Cell 2 F-FCH level changed due to rate set change | Changing Radio Configuration or Service Option may cause this error message which indicates the test set will change Traffic Level to a setting compatible with the related changes to the radio configuration or service option.
+193 Digital2000 settings conflict; Cell 2 F-FCH level changed due to traffic data rate change | Lowering Traffic Data Rate with the Traffic Level set too high, or increasing the Traffic level at low Traffic Data Rate (for example, eighth) can cause this error message. The test set will decreased Traffic Level to a setting compatible with the current Traffic Data Rate.
+194 Digital2000 settings conflict; Voice service option audio changed to null frames due to lack of support for the multi-tone audio source in SO3 | The Enhance Variable Rate Codec (EVRC) is used when encoding and decoding analog (voice) signals for the traffic when service option 3 (SO3) is in use. The EVRC algorithms are protected and can not be legally used in our test set. This error is presented when the test set need to execute the EVRC algorithms such as service option set to SO3 and Voice Service Option Audio set to Multi-Tone. In this condition, the test set sets the Voice Service Option Audio to Null Frames and presents this error message. Agilent Technologies continues to work with the licensors to reach favorable terms in which this restriction can be removed. See Voice SO Mode .
+195 Digital2000 settings conflict; Cell 1 maximum F-FCH level changed due to rate set change | Changing Radio Configuration or Service Option may cause this error message which indicates the test set will change Traffic Level to a setting compatible with the related changes to the radio configuration or service option.
+196 Digital2000 settings conflict; Cell 2 F-FCH level changed due to traffic data rate change | Lowering Traffic Data Rate with the Traffic Level set too high, or increasing the Traffic level at low Traffic Data Rate (for example, eighth) can cause this error message. The test set will decreased Traffic Level to a setting compatible with the current Traffic Data Rate.
+197 Digital2000 settings conflict; R-SCH data rate is greater than R-SCH service configuration max data rate | This happens when you set the R-SCH Data Rate to 153.6 kbps but the R-SCH R-SCH Service Configuration Max Data Rate is set to 8x.
+198 Digital95 settings conflict; Voice service option mode change to null frames due to lack of support for the real-time vocoder audio source in SO3. | The EVRC algorithm are protected and can not be legally used in our test set. This error is presented when the test set needs to execute the EVRC algorithms such as service option set to SO3 and Voice Service Option set to Real-Timer Vocoder. See Voice SO Mode .
+199 Digital95 settings conflict; Voice service option mode cannot be set to real-time vocoder due to lack of hardware support. | This happens when the hardware in the test set doesn't support real-time vocoder while the Voice Service Option mode is set to Real-Time Vocoder. See Voice SO Mode .

Related Topics

Error Messages


+200 through +299 Error Message Descriptions

+200 through +299 Error Message Descriptions

Last updated: June 18, 2007

Description

A device-specific error indicates that the instrument has detected an error that occurred because some operations did not properly complete, possibly due to an abnormal hardware or firmware condition. For example, an attempt by the user to set an out of range value will generate a device specific error. Errors are categorized as follows:

  • TA2000: errors with test application scope

  • CDMA: errors common to the IS-95 and IS-2000 System Types

  • Digital2000: errors applicable to only the IS-2000 System Type

  • Digital95: errors applicable to only the IS-95 System Type

When one of these errors is generated, the +200 errors bit in the questionable error status register is set.

TA2000 Call Processing Errors
Error Message | Description
+271 Release order not received | This error message is displayed for information purposes only.
+272 Handoff completion not received | This error message is displayed for information purposes only.
+273 Carrier not detected on new channel | This error message is associated with a dropped or released call.
+274 MS reject order received <reason> | This error message is displayed for information purposes only.
+275 Unexpected message received and ignored | This error message is displayed for information purposes only.
+277 call processing error; Operation rejected due to call status change in progress. | This error message is displayed for information purposes only.
CDMA Call Processing Errors
Error Message | Description
+230 "CDMA operation rejected; PN offset of different cells cannot be set to the same value" | This error message is displayed for information purposes only.
+231 "CDMA operation rejected; Start/stop MER/FER procedure ignored due to no call connected" | This error message is displayed for information purposes only.
+232 "CDMA operation rejected; Start paging MER procedure ignored due to no paging channel" | This error message is displayed for information purposes only.
+233 "CDMA operation rejected; Start control channel FER procedure ignored due to no control channel" | This error message is displayed for information purposes only.
+234 "CDMA operation rejected; Stop MER/FER procedure ignored due to no procedure in progress" | This error message is displayed for information purposes only.
+235 "CDMA operation rejected; Power control sub-channel transient queue full" | This error message is displayed for information purposes only.
+236 "CDMA operation rejected; Authentication is not licensed" | An additional feature license is required to enable the authentication functionality in a licensed test application.
+237 "CDMA operation rejected; Data out of range for CDMA system time or local time offset" | This error message is displayed for information purposes only.
+238 "CDMA operation rejected; Multi-Unit Sync feature is not licensed. See www.agilent.com/find/8960upgrades for additional information" | This error message is displayed for information purposes only.
+250 "CDMA call processing error; SSD update failed due to call status change in progress" | This error message is displayed for information purposes only.
+251 "CDMA call processing error; Unique challenge failed due to call status change in progress" | This error message is displayed for information purposes only.
+253 "CDMA call processing error; Operation not allowed due to incorrect operating mode or system type" | This error message is displayed for information purposes only.
+254 "CDMA call processing error; Operation not allowed due to call status not idle" | This error message is displayed for information purposes only.
+255 "CDMA call processing error; Synchronizing to external server failed due to no response from external server" | This error message is displayed for information purposes only.
+256 "CDMA call processing error; Synchronizing to external server failed due to unknown error on external server" | This error message is displayed for information purposes only.
+257 "CDMA call processing error; Synchronizing to external server failed due to incorrect operating mode or system type on external server" | This error message is displayed for information purposes only.
+258 "CDMA call processing error; Synchronizing to external server failed due to external trigger not set to 2s on external server" | This error message is displayed for information purposes only.
+259 "CDMA call processing error; Synchronizing to external server failed due to multi-unit synchronization feature not available on external server" | This error message is displayed for information purposes only.
+260 "CDMA call processing error; Synchronizing to external server failed due to unexpected response received" | This error message is displayed for information purposes only.
+261 "CDMA call processing error; Synchronizing to external server failed due to no trigger received from TRIG IN" | This error message is displayed for information purposes only.
+262 "CDMA call processing error; Enhanced origination message (EOM) is not supported" | This error message is displayed for information purposes only.
+263 CDMA call processing error; SSD update confirmation order not received in response to base station challenge response order | This error message is displayed for information purposes only.
+264 CDMA call processing error; SSD update failed due to SSD update rejection order received | This error message is displayed for information purposes only.
+265 CDMA call processing error; SSD update rejected by MS | This error message is displayed for information purposes only.
+266 CDMA call processing error; Base station challenge order not received in response to SSD update message (SSDUM) | This error message is displayed for information purposes only.
+267 CDMA call processing error; Unique challenge rejected by MS | This error message is displayed for information purposes only.
+268 CDMA call processing error; Authentication challenge response message (AUCRM) not received in response to authentication challenge message (AUCM) | This error message is displayed for information purposes only.
+269 CDMA call processing error; Parameter(s) in retrieve parameter message (RTPM) not supported by MS | This error message is displayed for information purposes only.
+270 CDMA call processing error; Traffic channel preamble not received | This error message is displayed for information purposes only.
+271 CDMA call processing error; MS ack of initial BS ack order not received | This error message is displayed for information purposes only.
+272 CDMA call processing error; MS ack order not received | This error message is displayed for information purposes only.
+273 CDMA call processing error; Service negotiation failed due to MS messaging | Some mobile stations do not support all service options provided for a given radio configuration. Use the FCH Service Option Setup (F12) key to select a different service option.
+274 CDMA call processing error; Service response not received | This error message is associated with a failed call attempt or dropped call.
+275 CDMA call processing error; Service request not received | This error message is associated with a failed call attempt or dropped call.
+276 CDMA call processing error; Service connect completion not received | This error message is associated with a failed call attempt or dropped call.
+277 CDMA call processing error; Call drop timer timed out | This error message is associated with a dropped call.
+278 CDMA call processing error; Status response not received | This error message is displayed for information purposes only.
+279 CDMA call processing error; Walsh code cannot be changed while a call is connected | This error message is displayed for information purposes only.
+280 CDMA call processing error; Set parameters message (STPM) rejected by MS | This error message is displayed for information purposes only.
+281 CDMA call processing error; Origination failed due to F-FCH/Traffic state off | This error message is associated with a failed call attempt.
+282 CDMA call processing error; Power control step size rejected | This error message is displayed for information purposes only.
+283 CDMA call processing error; Session timer timed out | This error message is displayed for information purposes only.
+284 CDMA call processing error; SMS message not received after MS origination in SMS service option | This error message is displayed for information purposes only.
+285 CDMA call processing error; SMS mobile originated message received in SMS service option without MS disconnect | This error message is displayed for information purposes only.
+286 CDMA call processing error; SMS receive messaging in progress | This error message is displayed for information purposes only.
+287 CDMA call processing error; SMS end does not apply to BS page. Use end call | This error message is displayed for information purposes only.
+288 CDMA call processing error; SMS send not allowed due to current call status | This error message is displayed for information purposes only.
+289 CDMA call processing error; SMS message padded with trailing zeros to define whole characters | This error message is displayed for information purposes only.
+290 CDMA call processing error; SMS send message truncated due to protocol; <size> characters sent | This error message is displayed for information purposes only.
+291 CDMA call processing error; SMS send timeout occurred waiting for MS ack | This error message is displayed for information purposes only.
+292 CDMA call processing error; SMS send message input character rejected due to SMS message at maximum length | This error message is displayed for information purposes only.
+293 CDMA call processing error; Parameter response message (PRSM) not received in response to retrieve parameter message (RTPM) | This error message is displayed for information purposes only.
+294 CDMA call processing error; R-FCH gating failed due to MS messaging | This error message is displayed for information purposes only.
+295 CDMA call processing error; R-FCH gating cannot be changed while a call is connected | This error message is displayed for information purposes only.
+296 CDMA call processing error; SMS mobile originated message received. Origination denied due to current SMS receive protocol (disabled) | This error message is displayed for information purposes only.
+297 CDMA call processing error; SMS mobile originated message received. SMS not supported by base station due to current SMS receive protocol (not supported) | This error message is displayed for information purposes only.
+298 CDMA call processing error; SMS mobile originated message received. SMS not supported by base station due to current SMS receive protocol (unknown destination address) | This error message is displayed for information purposes only.
+299 CDMA call processing error; SMS broadcast message not allowed on BCCH | This error message is displayed for information purposes only.
Digital2000 Call Processing Errors
Error Message | Description
+230 Digital2000 operation rejected; Command is not supported in this radio configuration | This error message is displayed for information purposes only.
+231 Digital2000 operation rejected; Invalid set of code channel levels due to control channel configuration | This error message is displayed for information purposes only.
+232 Digital2000 operation rejected; Invalid set of code channel levels due to protocol revision setting | This error message is displayed for information purposes only.
+233 Digital2000 operation rejected; Protocol revision 7 (Release A) is not licensed | This error message is displayed for information purposes only.
+234 Digital2000 operation rejected; Forward power control max F-FCH level is too high | This error message is displayed for information purposes only.
+235 Digital2000 operation rejected; Force dormant requires SO33 and an established data connection | This error message is displayed for information purposes only.
+236 Digitial2000 operation rejected; Start F-BCCH FER procedure ignored due to no F-BCCH | This error message is displayed for information purposes only.
+237 Digitial2000 operation rejected; Start F-CCCH FER procedure ignored due to no F-CCCH | This error message is displayed for information purposes only.
+243 Digital2000 operation rejected; MEID support cannot be changed while a call is connected | This error message is displayed for information purposes only.
+244 Digital2000 operation rejected; PLCM type cannot be changed while service option is SO32 | This error message is displayed for information purposes only.
+270 Digital2000 call processing error; F-SCH assign ignored due to F-SCH state off | This error message is displayed for information purposes only.
+271 Digital2000 call processing error; F-SCH assign ignored due to no call connected | This error message is displayed for information purposes only.
+272 Digital2000 call processing error; F-SCH assign ignored due to lack of support in current radio configuration | This error message is displayed for information purposes only.
+274 Digital2000 call processing error; F-SCH assign failed due to MS messaging | This error message is displayed for information purposes only.
+275 Radio configuration cannot be changed while a data connection is established | This error message is displayed for information purposes only.
+276 Digital2000 call processing error; F-FCH service option cannot be changed while a data connection is established | This error message is displayed for information purposes only.
+277 Digital2000 call processing error; SCH data rate cannot be changed while a data connection is established | This error message is displayed for information purposes only.
+278 Digital2000 call processing error; SCH encoder cannot be changed while a data connection is established | This error message is displayed for information purposes only.
+279 Digital2000 call processing error; SCH service option cannot be changed while a data connection is established | This error message is displayed for information purposes only.
+280 Digital2000 call processing error; Service option change to data service option not allowed while a call is connected | This error message is displayed for information purposes only.
+281 Digital2000 call processing error; Radio configuration change causing data service option not allowed while a call is connected | This error message is displayed for information purposes only.
+282 Digital2000 call processing error; F-SCH assign rejected | This error message is associated with a failed call attempt.
+283 Digital2000 call processing error; Service option control message not received | This error message is displayed for information purposes only.
+284 Digital2000 call processing error; F-SCH SO32 data change not allowed while a data connection is established | This error message is displayed for information purposes only.
+285 Digital2000 call processing error; Digital2000 call processing error; Service option change to SO33 not allowed if MS IP address is undefined | This error message is displayed for information purposes only.
+286 Digital2000 call processing error; Digital2000 call processing error; SCH data rate change failed due to MS messaging | This error message is displayed for information purposes only.
+287 Digital2000 call processing error; PDSN data connection could not be established | This error message is displayed for information purposes only.
+288 Digital2000 call processing error; Outer loop report not requested due to no call connected | This error message is displayed for information purposes only.
+289 Digital2000 call processing error; Outer loop report message not received in response to outer loop report request | This error message is displayed for information purposes only.
+290 Digital2000 call processing error; Force dormant failed due to MS messaging | This error message is displayed for information purposes only.
+291 Digital2000 call processing error; Power control message (PCNM) rejected by MS | This error message is displayed when the FPC Mode is changed in a connected call and the mobile station replies with a Mobile Station Reject Order . In this case, the call is still maintained and the previous value of the FPC Mode is kept.
+292 Digital2000 call processing error; MS ack order not received in response to power control message (PCNM) | This error message is displayed when the FPC Mode is changed in a connected call and the test set does not receive the MS ack order in a specified timeframe (~ 1 second). In this case, the call is still maintained and the previous value of the FPC Mode is kept.
+293 Digital2000 call processing error; R-SCH service configuration max data rate cannot be changed while a call is connected | This error message is displayed for information purposes only.
+294 Digital2000 call processing error; Call connection failed due to no mobile equipment identifier | This error message is displayed for information purposes only.
+295 Digital2000 call processing error; An ESN-equipped MS cannot be connected while MEID support is on | This error message is displayed for information purposes only.
+296 Digital2000 call processing error; Handoff failed due to no mobile equipment identifier | This error message is displayed for information purposes only.
+297 Digital2000 call processing error; Extended supplemental channel assignment message (ESCAM) rejected by MS | This error is intended to be used for SCH assignment rejection in 5.5 release for SO33 R-SCH Support feature, but it also covers the error when F/R-SCH data rate change is rejected by MS.
+298 Digital2000 call processing error; SCH assignment failed due to MS messaging | This error is generated when MS ACK order is not received in response to ESCAM when SO33 Physical Channel Configuration setting is changed during a data call.
+299 Digital2000 call processing error, R-SCH turbo encoder type is not supported in radio configuration (fwd5, rvs4) when R-SCH data rate is 230.4 kbps | This error is generated when the invalid combination occurs: RC5; R-SCH configuration is 230.4 kbps & Turbo encoding.

Related Topics

Error Messages


+300 through +399 Link Control Device-Specific Error

+300 through +399 Link Control Device-Specific Error

Last updated: October 28, 2004

These errors are generated when a problem occurs in maintaining the link between the test set and a DUT. These errors generally occur when a message is received from the DUT that is unexpected.

When one of these errors is generated, the `+300 errors' bit in the questionable error status register is set. Refer to Standard Event Status Register for information on this register.

No link control errors are currently defined for this test application .

Related Topics

Error Messages


+400 through +499 Error Message Descriptions

+400 through +499 Error Message Descriptions

Last updated: January 23, 2007

Description

These errors are generated when a problem occurs in one of the test set's hardware modules that is part of the test set's core instrument.

When one of these errors is generated, the `+400 errors' bit in the questionable error status register is set.

Error Message | Description
+400 Hardware failure; Hardware is not available |
+401 Hardware failure; Protocol processor hardware is not responding |
+402 Hardware failure; Demod receiver hardware is not responding |
+403 Hardware failure; Measurement receiver hardware is not responding |
+404 Hardware failure; RF source 1 hardware is not responding |
+405 Hardware failure; RF source 1 digital modulation hardware is not responding |
+406 Hardware failure; RF source 1 level hardware is not responding |
+407 Hardware failure; DSP demod control hardware is not responding |
+408 Hardware failure; 2nd demod receiver hardware is not responding |
+409 Hardware failure; Base station emulator trigger hardware is not responding |
+410 Hardware failure; Audio source hardware is not responding |
+411 Hardware failure; RF source 2 hardware is not responding |
+412 Hardware failure; Internal voltmeter hardware is not responding |
+413 Hardware failure; Fixed timebase input is not responding |
+414 Hardware failure; Fixed external reference output is not responding |
+415 Hardware failure; Instrument reference is not responding |
+416 Hardware failure; Bit clock A is not responding |
+417 Hardware failure; RF source 2 frequency hardware is not responding |
+418 Hardware failure; RF source 2 digital modulation hardware is not responding |
+419 Hardware failure; RF source 2 level hardware is not responding |
+420 Hardware failure; RF source hopping hardware is not responding |
+421 Hardware failure; Digital demod hopping hardware is not responding |
+422 Hardware failure; Misc VI hardware is not responding |
+423 Hardware failure; Unable to access networking information |
+424 Hardware failure; Bit clock B is not responding |
+425 Hardware failure; Invalid EEPROM checksum <EEPROM board ID> | See the list of EEPROM board ID names below.
+426 Hardware failure; Unable to write to EEPROM <EEPROM board ID> | See the list of EEPROM board ID names below.
+427 Hardware failure; Unable to read from EEPROM <EEPROM board ID> | See the list of EEPROM board ID names below.
+428 Hardware failure; Board not identified <board ID> | See the list of board ID names below.
+429 Hardware failure; Could not create board identification <board ID> | See the list of board ID names below.
+430 Hardware failure; Control version not compatible with FW <board ID> | See the list of board ID names below.
+431 Hardware failure; RF IO DAC cannot be calibrated due to present temperature |
+432 Hardware failure; RF hardware is not responding |
+433 Hardware failure; RF source FM hardware is not responding |
+434 Hardware failure; Audio source FM hardware is not responding |
+435 Hardware failure; Miscellaneous state hardware is not responding |
+436 Hardware failure; BSP access error |
+437 Hardware failure; LSS hardware is not responding |
+438 Hardware failure; RFIO hardware is not responding |
+460 Hardware failure; Hardware doesn't support requested operation. See www.agilent.com/find/8960upgrades for additional information | This error occurs when an action is attempted that is not possible with the test set's hardware. Visit www.agilent.com/find/8960upgrades to find out how to acquire the necessary hardware.
+461 Hardware failure; Link subsystem hardware is not responding. Call processing functionality not operational. | This error occurs any time the link subsystem is not operating correctly. The message is persistent to warn the user that any call processing operations will not work.
+462 Hardware error; Hardware not supported; <board ID><part_number> | This error appears when an operation was attempted that requires hardware that is not installed in the test set.
+463 Hardware error: RFIO version does not support loopback switching. |
+464 Hardware error: RFIO version does not support RF out only selection. | This error occurs when trying to select the RF OUT ONLY port when the test set has the RF I/O module that only has the RF IN/OUT port.
+465 Hardware error; RfSplitters version does not support RF out only selection |
+466 Hardware error; Missing or unsupported hardware. Module |
+467 Optional hardware error; Missing or unsupported optional hardware. Option |
+469 Hardware failure; Bbio VI hardware is not responding |
+470 Hardware error; Hardware doesn't support requested operation. Feature is not licensed. See www.agilent.com/find/8960upgrades for additional information | This error occurs you attempt to access a feature which is not licensed in the test set and is not possible with the test set's hardware. Visit www.agilent.com/find/8960upgrades to find out how to acquire the necessary hardware and license.

<board ID> names

3 GHZ ATTENUATOR 1| ;3GHZ ATTENUATOR 2| ;AUDIO BD| ;ROM BASEBAND GENERATOR 1| ;ROM BASEBAND GENERATOR 2| ;DEMOD DOWNCONVERTER| ;VECTOR OUTPUT BOARD 1| ;VECTOR OUTPUT BOARD 2| ;IVF MEASUREMENT| ;MEASUREMENT DOWCONVERTER| ;RF POWER DETECTORS| ;REFERENCE MODULE| ;SYNTH DOUBLER 1| ;SYNTH DOUBLER 2| ;TIMING REF| ;MOMENTUM INSTRUMENT| ;RF MOTHER BOARD| ;JUMPER BOARD| ;DIGITAL MOTHER BOARD| ;FLAT PANEL ADAPTER| ;REAR PANEL BOARD

<EEPROM board ID> names

Instrument Eeprom ID State| ;Atten 1 Eeprom ID State| ;Atten 2 Eeprom ID State| ;Audio Eeprom ID State| ;BaseBandGen 1 Eeprom ID State| ;BaseBandGen 2 Eeprom ID State| ;Demod DC Eeprom ID State| ;Digital Mother Board Eeprom ID State| ;IQ Output 1 Eeprom ID State| ;IQ Output 2 Eeprom ID State| ;IVF Meas Eeprom ID State| ; Jumper Board Eeprom ID State| ; Meas DC Eeprom ID State| ;RF Mother Board Eeprom ID State| ;RF Interface Eeprom ID State| ; Ref Mod Eeprom ID State| ;Sig Gen 1 Eeprom ID State| ; Sig Gen 2 Eeprom ID State| ;Time Ref Eeprom ID State| ;Display Interface Eeprom ID State| ;Rear Panel Eeprom ID State

Related Topics

Error Messages


+500 through +599 Application Hardware Device-Specific Error

+500 through +599 Application Hardware Device-Specific Error

Last updated: January 23, 2007

Description

These errors are generated when a problem occurs with a hardware module that is required for a particular application.When one of these errors is generated, the `+500 errors' bit in the questionable error status register is set.

+500 through +599 Error Messages
Error Message | Description
+501 Protocol logging failure; No observation points enabled | This error message is displayed for information purposes only.
+519 Configuration error; DUT IP addresses must be unique |
+520 Configuration error; DUT IP address must be on same subnet as instrument | This error message is generated if the DUT IP address is not on the same subnet as the instrument. This situation may arise because the instrument IP address was set after the DUT IP address, or the instrument subnet mask changed.
+521 Configuration error; DUT IP address cannot be the same as the instrument LAN address | This error message is generated if the DUT IP address and the instrument IP address are the same. This situation may arise because the instrument IP address was set after the DUT IP address.
+522 Configuration Error; Operation Rejected Due To Invalid IP Address | This error is returned when attempting to Connect to External 8960 if the Ext 8960 IP Addr is invalid.
+524 Operation rejected; External PDSN state can not be changed while data connection is dormant | This error message is displayed for information purposes only.
+525 Configuration error; External PDSN IP address must be on same subnet as instrument |
+526 Configuration error; External PDSN IP address cannot be the same as instrument LAN address | This error message is generated if the External PDSN IP address and the instrument IP address are the same.
+527 Operation rejected; External PDSN state change to on not allowed if external PDSN IP address is undefined | This error message is displayed for information purposes only.
+528 Operation rejected; External PDSN service not available; external PDSN state set to off | This error message is displayed for information purposes only
+529 Warning; External PDSN control connection dropped; external PDSN state set to off. | This error message is associated with a lost control connection between test set and MOB-IP-SIM.
+530 Operation rejected; External PDSN settings cannot be changed when external PDSN state is on. | This error message is displayed for information purposes only.
+531 Operation rejected; External PDSN state cannot be changed while a data connection is established. | This error message is displayed for information purposes only.
+532 Warning; External PDSN data connection dropped | This error message is associated with a lost data connection between MOB-IP-SIM and MS.
+533 Operation rejected; ping DUT functionality is not available while external PDSN state is on. | This error message is displayed for information purposes only.
+534 Operation Rejected; No Response From The External Device | This error is returned when attempting to Connect to External 8960 if the external 8960 does not respond to the connection request.
+535 Operation Rejected; The Device Rejected The Connection Request | This error is returned when attempting to Connect to External 8960 if the external 8960 rejects the connection request (this would happen, for example, if the external 8960 already has a connection to another 8960).
+536 Warning; Connection Is Already Established With The External Device | This error is returned when attempting to Connect to External 8960 if your test set is already connected to the external 8960.
+537 Operation Rejected; Change Allowed Only When A Connection To An External Device Does Not Exist | This error is returned when attempting to set the Ext 8960 IP Addr while External Device Conn Status is not Disconnected .
+538 Operation Rejected; External 8960 Test Set IP Address Cannot Be The Same As Instrument LAN IP Address | This error is returned when attempting to set the Ext 8960 IP Addr to the same value as LAN IP Address .
+539 Warning; Connection To The External Device Has Been Lost; check call status to determine if any active calls have been disconnected | This error occurs if the External Device Connection is broken (for example, if you disconnect the LAN cable from the test set).
+540 Operation Rejected; Cannot Process Request While Attempting To Connect To Or Disconnect From The External Device | This error is returned when attempting to Connect to External 8960 or Disconnect from External 8960 if the External Device Conn Status is Connecting or Disconnecting .
+541 Operation Rejected; External 8960 Test Set IP Address Cannot Be The Same As The DUT IP Address | This error is returned when attempting to set the Ext 8960 IP Addr to the same value as DUT IP Address .
+542 Operation Rejected; Service Not Available Without A Connection To An External Device | This error is returned when attempting to originate an end-to-end service without an External Device Connection in place.
+543 HTTP Client Error; failed to create socket |
+544 HTTP Client Error; failed to connect to the socket |
+545 HTTP Client Error; invalid IP address specified |
+546 HTTP Client Error; timeout |
+547 HTTP Client Error; could not access socket |
+548 HTTP Client Error; bad request URL |
+549 HTTP SMS request ignored; Illegal parameter in request | This error is generated in response to a request URL for a mobile terminated SMS arriving at the test set's HTTP interface containing a parameter that is not supported.
+550 HTTP SMS request ignored; Request parameter out of range | This error is generated in response to a request URL for a mobile terminated SMS arriving at the test set's HTTP interface containing a parameter value out of the supported range.
+551 HTTP SMS request ignored; Incompatible parameters in request | This error is generated in response to a request URL for a mobile terminated SMS arriving at the test set's HTTP interface containing parameters that can not be used together in the same request URL.
+552 HTTP SMS request ignored; Missing mandatory parameter in request | This error is generated in response to a request URL for a mobile terminated SMS arriving at the test set's HTTP interface that does not contain parameters required by the test set.
+553 HTTP SMS warning; Output message URL exceeded maximum length and has been truncated | This error is generated when the constructed URL received by the test set's HTTP interface for a mobile originated SMS message exceeds the maximum size of 1500 characters. This generally occurs if one or more tags have been duplicated in the output URL format string, causing the length restriction to be exceeded.
+560 Data out of range; Total Baseband Studio multi-path relative levels' sum invalid; no change |
+561 Operation failed; The external device connection request failed likely because there is a firmware incompatibility between the two connecting devices. See www.agilent.com/find/8960upgrades for additional information | The underlying architecture of the External Device Connection feature has changed over time. The two implementations are not compatible. To establish an External Device Connection between two test sets, the test sets must have compatible firmware (see www.agilent.com/find/8960upgrades for more information)
+562 Operation failed; The incoming request for an external device connection request failed likely because there is a firmware incompatibility between the two connecting devices. See www.agilent.com/find/8960upgrades for additional information | The underlying architecture of the External Device Connection feature has changed over time. The two implementations are not compatible. To establish an External Device Connection between two test sets, the test sets must have compatible firmware (see www.agilent.com/find/8960upgrades for more information)
+563 Operation rejected; Calling party number 1 and calling party number 2 can not be set to the same number. | This error is generated when calling party1 number is set to the same value as calling party 2 number.
+564 Operation rejected; Requested DUT IP address is currently in use | This error is generated if the DUT address is currently assigned to a mobile device for an active data session. The device may be directly connected to the local 8960, or may be connected to a remote 8960, with an external connection to the local 8960. Specifically this can occur if the data connection was first established on the local 8960, but a cell transition occurred (handover) while the two 8960s were externally connected.
+565 Operation aborted; Signal was lost between 8960s |
+566 Warning; Signal was lost between 8960s but the operation will still try to continue |

Related Topics

Error Messages


+600 through +699 Error Message Descriptions

+600 through +699 Error Message Descriptions

Last updated: January 23, 2007

Description

These errors are generated when a problem occurs that is specific to one of the test set's instruments. These errors are part of the test set's core. Note that these measurements may not be present in every test application and therefore, these errors may not be present in every test application. There is no plan at present to support test application specific instruments.

An instrument in this context refers to the measurement-like functionality such as the audio generator and not to the test set as a whole.

When one of these errors is generated, the `+600 errors' bit in the questionable error status register is set.

Error Message | Description
+601 Instrument failure; Audio generator hardware is not responding | Indicates a problem occurs when attempting to control the test set's audio generator.
+602 Data out of range; Spectrum Monitor; No peaks left |
+603 Data out of range; Spectrum Monitor; No peaks right |
+604 Data out of range; Spectrum Monitor; No peaks found |
+605 Operation rejected; Spectrum Monitor; Receiver power currently set to Auto |
+606 Operation rejected; Spectrum Monitor; Meas frequency currently set to Auto |
+607 Operation rejected; Spectrum Monitor; Marker Frequency out of Meas Frequency tune range |
+608 Operation rejected; Spectrum Monitor instrument is inactive |
+620 Data out of range; Total multi-tone audio downlink level upper limit exceeded; no change |
+621 Data out of range; Total multi-tone audio uplink level upper limit exceeded; no change |
+622 Warning; Multi-tone audio downlink level over range due to requested setting |
+623 Operation rejected; Multi-tone audio downlink levels cannot be set when total level state is on |
+624 Operation rejected; Multi-tone audio uplink levels cannot be set when total level state is on |
+625 Operation rejected; Multi-tone audio analyzer frequencies cannot be set when use generator frequencies state is on |

Related Topics

Error Messages


+700 through +799 Error Message Descriptions

+700 through +799 Error Message Descriptions

Last updated: June 20, 2006

Description

A device-specific error indicates that the instrument has detected an error that occurred because some operations did not properly complete, possibly due to an abnormal hardware or firmware condition. For example, an attempt by the user to set an out of range value will generate a device specific error. Errors are categorized as follows:

  • TA2000: errors common to the test application
  • CDMA: errors common to the IS-95 and IS-2000 system type
  • Digital2000: errors applicable to only the IS-2000 system type
  • Digital95: errors applicable to only the IS-95 system type

When one of these errors is generated, the +700 errors bit in the questionable error status register is set.

CDMA Measurement Errors
Error Message | Description
+701 "CDMA measurement failure; Digital average power measurement is not responding" | This error message indicates an internal software or hardware error.
+702 "CDMA measurement failure; Waveform quality measurement is not responding" | This error message indicates an internal software or hardware error.
+703 "CDMA measurement failure; Channel power measurement is not responding" | This error message indicates an internal software or hardware error.
+704 "CDMA measurement failure; Frame error rate measurement is not responding" | This error message indicates an internal software or hardware error.
+705 "CDMA measurement failure; Access probe power measurement is not responding" | This error message indicates an internal software or hardware error.
+706 "CDMA measurement failure; Time response of open loop power control measurement is not responding" | This error message indicates an internal software or hardware error.
+707 "CDMA measurement failure; Gated power measurement is not responding" | This error message indicates an internal software or hardware error.
+708 "CDMA measurement failure; Tx spurious emissions measurement is not responding" | This error message indicates an internal software or hardware error.
+709 "CDMA measurement failure; Graphical access probe power measurement is not responding" | This error message indicates an internal software or hardware error.
+710 "CDMA measurement failure; Tx dynamic power measurement is not responding" | This error message indicates an internal software or hardware error.
+713 CDMA measurement failure; Fast Device Tune measurement is not responding. |
+712 "CDMA measurement failure; Multi-tone audio measurement is not responding" | This error message indicates an internal software or hardware error.
+721 "CDMA measurement failure; Gated power measurement requires MS to transmit in eighth traffic data rate (gated mode). Verify loopback service option and eighth traffic data rate" | Select an IS-95 loopback service option using the Service Option (F12) key, or select an IS-2000 radio configuration 1 or 2 loopback service option using the FCH Service Option Setup (F12) key. Select "Eighth" in the Traffic Data Rate field before attempting Gated Power measurements.
+726 "CDMA measurement failure; Time response of open loop power control measurement requires MS to transmit in non-gated mode. Verify loopback service option and full traffic data rate" | Select an IS-95 loopback service option using the Service Option (F12) key, or select an IS-2000 radio configuration 1 or 2 loopback service option using the FCH Service Option Setup (F12) key. Select "FULL" in the Traffic Data Rate field.
+727 "CDMA measurement failure; Time response of open loop power control measurement requires receiver power control set to auto" | See Automatic Receiver Control to set receiver power control to auto.
+728 "CDMA measurement failure; Time response of open loop power control measurement requires receiver power to be within range before and after the measurement" | See Automatic Receiver Control .
+729 "CDMA measurement failure; Time response of open loop power control measurement requires cell power to be within range before and after the measurement" | See CALL[:CELL[1]]:POWer[:SAMPlitude][:SELected] for power range.
+730 "CDMA measurement failure; Time response of open loop power control measurement requires AWGN state off" | See CALL:AWGNoise[:INTernal]:POWer:STATe<[:SELected]|:DIGital2000|:DIGital95> .
+731 "CDMA measurement failure; Time response of open loop power control measurement requires cell 2 power state off" | See CALL:CELL2:POWer:STATe[:SELected] .
+736 "CDMA measurement failure; Graphical access probe power measurement requires call status idle" | See Graphical Access Probe Power Measurement Description .
+738 "CDMA measurement warning; Frame error rate measurement may be failed when F-FCH/traffic frame pattern good frames less than 3 and F-FCH/traffic frame pattern state is on" | See FER Measurement Specific to the Lab Application .
+741 "CDMA measurement failure; TX dynamic power measurement requires receiver power control set to manual" | See TX Dynamic Power Measurement Description .
+746 "CDMA measurement failure; Max/min power measurement requires cell power, pilot, and traffic/F-FCH states on" | See Maximum/Minimum Power Measurement Description .
+747 "CDMA measurement failure; Max/min power measurement requires AWGN state off" | See Maximum/Minimum Power Measurement Description .
+748 "CDMA measurement failure; Max/min power measurement requires cell 2 power state off" | See Maximum/Minimum Power Measurement Description .
+749 "CDMA measurement failure; Max/min power measurement max cell power, pilot level, and traffic/F-FCH level are incompatible" | See Maximum/Minimum Power Measurement Description .
+750 "CDMA measurement failure; Max/min power measurement min cell power, pilot level, and traffic/F-FCH level are incompatible" | See Maximum/Minimum Power Measurement Description .
+754 "Data out of range; Multi-tone audio downlink total level upper limit exceeded; no change" | See Multi-Tone Audio Measurement Description .
+755 "Data out of range; Multi-tone audio uplink total level upper limit exceeded; no change" | See Multi-Tone Audio Measurement Description .
+757 "CDMA measurement operation rejected; Multi-tone audio downlink levels cannot be set" | See Multi-Tone Audio Measurement Description .
+758 "CDMA measurement operation rejected; Multi-tone audio uplink levels cannot be set when total level state is on" | See Multi-Tone Audio Measurement Description .
+759 "CDMA measurement operation rejected; Multi-tone audio analyzer frequencies cannot be set when use generator frequencies state is on" | See Multi-Tone Audio Measurement Description .
+760 "CDMA measurement warning; Multi-tone audio downlink level over range due to requested setting" | See Multi-Tone Audio Measurement Description .
+761 "CDMA measurement warning; Multi-tone audio measurement not compatible with service option 3 (EVRC)" | See Multi-Tone Audio Measurement Description .
+780 CDMA measurement failure; Fast Device Tune measurement setup is not correct. Refer to your documentation CD or go to www.agilent.com/find/8960 for correct setup steps |
+781 CDMA operation rejected; Fast Device Tune feature is not licensed. See www.agilent.com/find/8960upgrades for additional information |
+782 CDMA measurement failure; Fast Device Tune measurement MS Tx/Rx frequency step sequence table start index + frequency step count must be less than or equal to 40 |
+783 CDMA measurement failure; Fast Device Tune measurement MS Tx/Rx power step sequence table start index + power step count must be less than or equal to 40 |
+784 CDMA measurement failure; Fast Device Tune measurement MS Tx/Rx frequency values in use must not be NAN |
+785 CDMA measurement failure; Fast Device Tune measurement MS Tx/Rx power levels in use must be not NAN |
+786 CDMA measurement failure; Fast Device Tune measurement MS Tx frequency values in use are not in the same band |
+787 CDMA measurement failure; Fast Device Tune measurement MS Rx frequency values in use are not in the same band |
+788 CDMA measurement failure; Fast Device Tune measurement MS Tx power levels in use are out of range |
+789 CDMA measurement failure; Fast Device Tune measurement MS Rx power levels in use are out of range. |
+790 CDMA measurement failure; Fast Device Tune measurement unable to build frequency and power sequence tables. Measurement is unavailable. Check the Message Log for error details |
+791 CDMA measurement failure; Fast Device Tune measurement only available after the frequency and power sequence tables have been successfully built using current settings |
+792 CDMA measurement failure; Fast Device Tune measurement first frequency in frequency sequence not in recognized frequency band |
Digital2000 Measurement Errors
Error Message | Description
+701 "Digital2000 measurement failure; Handoff waveform quality measurement is not responding" | This error message indicates an internal software or hardware error.
+702 "Digital2000 measurement failure; Code channel time/phase error measurement is not responding" | This error message indicates an internal software or hardware error.
+703 "Digital2000 measurement failure; TDSO frame error rate measurement is not responding" | This error message indicates an internal software or hardware error.
+721 "Digital2000 measurement failure; Handoff waveform quality measurement first PN offset handoff failure" | This error message indicates an internal software or hardware error.
+722 "Digital2000 measurement failure; Handoff waveform quality measurement second PN offset handoff failure" | This error message indicates an internal software or hardware error.

Related Topics

Error Messages


+800 through +899 Error Message Descriptions

+800 through +899 Error Message Descriptions

Last updated: December 17, 2004

Description

These errors are generated when a problem occurs that is specific to one of the test set's core measurements (such as analog audio).

When one of these errors is generated, the `+800 errors' bit in the questionable error status register is set.

Error Message | Description
+801 Measurement failure; Analog audio hardware is not responding | Indicates that a problem occurs when attempting to control the measurement's hardware.
+802 Measurement failure; Audio analyzer hardware is not responding | Indicates that a problem occurs when attempting to control the measurement's hardware.
+803 Measurement failure; Signal Finder hardware is not responding |
+805 Measurement failure; Multi-tone audio hardware is not responding |

Related Topics

Error Messages


Frame Error Rate Measurement Troubleshooting

Frame Error Rate Measurement Troubleshooting

Last updated: June 20, 2006

Possible Setup Issues

If the Access Probe Power measurement is currently selected and the Trigger Arm setting is Continuous, all other measurements are disabled. Use the SETup:CAPPower:CONTinuous command to set the trigger arm state to single and retry this measurement.

During remote operation of this measurement, you should configure the Trigger Arm to Single. See SETup:CFERror:CONTinuous . If single triggering is used during manual operation, press the START SINGLE key to trigger each measurement.

The test set receiver's expected signal amplitude and channel number (or frequency) must be set up correctly for accurate measurements. This is normally done automatically (see Active Cell Operating Mode ) but can also be done manually (see Receiver Control ).

A call must be connected with a loopback service option selected (see CALL:SOPTion ) to perform frame error rate measurements.

Frame error rate measurements require an accurate Amplitude Offset value because of the low levels transmitted during sensitivity measurements. Use the SYSTem:CORRection:GAIN command to set offset values.

When the frame error rate measurement is running, changing PLCM Type causes this measurement aborted and restarted. See PLCM Type for details.

For the lab application , when the F-FCH/Traffic Frame Pattern State is set to On and the F-FCH/Traffic Frame Pattern Good Frames is set to a value less than three the FER measurement may not be able to synchronize with the mobile station. An error message will be generated if the F-FCH/Traffic Frame Pattern State is set to On, the F-FCH/Traffic Pattern Good Frames is set to a value less than three, and the FER measurement is running. See FER Measurement Specific to the Lab Application

for details.

Interpreting Integrity Indicator values

See Integrity Indicator .

Related Topics

Frame Error Rate (FER) Measurement Description


Frequency Modulation (FM) Troubleshooting

Frequency Modulation (FM) Troubleshooting

Last updated: August 12, 2005

Possible Setup Issues

The Trigger Arm should always be set to Single for GPIB operation (not Continuous).

If digital measurements are active, turn them off or set their trigger source to Immediate. See Triggering of Measurements .

The distortion measurement is only returned if it has been enabled (SET:FM:DIST:STAT ON), otherwise the value 9.91E+37 is returned, signifying that a valid measurement was not made.

Distortion measurements require that the Distortion Fundamental Frequency to be specified (SET:FM:DIST:FREQ <value in Hz>).

The modulation frequency measurement is only returned if it has been enabled (SET:FM:FREQ:STAT ON), otherwise the value 9.91E+37 is returned, signifying that a valid measurement was not made.

Both FM distortion and audio distortion measurements are available in the test set. Make sure you are querying the FM Distortion measurement (FETCh:FM:DIST?) in your program and not the audio distortion measurement (FETCh:AFAN:DIST?) when making an FM distortion measurement.

Be sure to use the type of detector specified for deviation measurements in the applicable standard. For example, if the measurement specification is for peak deviation, be sure to use the Peak+ or Peak- detector instead of the RMS detector. If the signal being measured is noisy, you can use the RMS detector to make a more stable measurement and then multiply the result by 1.414 to arrive at the peak value.

All measurements are performed after any filtering, de-emphasis, and expansion are performed. When measuring SAT deviation and frequency, the Filter Type should normally be set to 100 Hz BW BPF and the 100 Hz BW BPF Center Frequency should be set to the SAT frequency. The C-message filter is often used for measurements made on signals with FM rates in the normal voice frequency range (such as the 1004 Hz tone used for distortion measurements).

This measurement can only be used for analog signals, such as an analog voice channel (AVC). You cannot use this measurement when the mobile is on a digital traffic channel (DTC).

The expected signal frequency (or AVC channel number) and input level must be specified in your program for accurate measurements. This is done either through the base station emulator settings, when the mobile is first put on an AVC, or by manually controlling the test set's measurement receiver. See Active Cell Operating Mode , Active Cell Operating Mode , and Receiver Control for information on setting the expected input frequency.

To meet performance specifications, the input signal must be in the frequency range of 800 MHz to 960 MHz or 1.70 GHz to 2.0 GHz, and be within 2.5 kHz of the expected input frequency, at a power level (at the RF IN/OUT connector) of -15 dBm to +40 dBm. The specified FM deviation range is 0 Hz to 16 kHz, at a modulation rate of 100 Hz to 15 kHz. FM Distortion is specified over the modulation rate range of 100 Hz to 10 kHz.

The trigger source is always immediate for this measurement. No trigger delay or protocol triggering is used.

Interpreting Integrity Indicator values

See Integrity Indicator .

If over range (5) is returned; the input power has exceeded the test set's internal sampler maximum value by at least 6 dB during some part of the sampling or the input power has exceeded the calibrated range of the test set's power detector for the expected power setting.

If under range (6) is returned; the measured input power is more than 20 dB below the expected input power level. Under range is also indicated if the input power is more than 2 dB below the calibrated range of the test set's power detector (-30 dBm). If the expected input power setting is correctly set for the signal level into the test set, an under range condition can still occur if the receiver has not been tuned to the signal's frequency.

If the signal has both over range and under range conditions only the over range (5) will be indicated.

Related Topics

Frequency Modulation (FM) Measurement Description

Measuring Frequency Modulation

Programming a Frequency Modulation (FM) Measurement


Frequency Stability Measurement Troubleshooting

Frequency Stability Measurement Troubleshooting

Last updated: October 29, 2004

Possible Setup Issues

IMPORTANT
If the Access Probe Power measurement is currently selected and the Trigger Arm setting is Continuous, all other measurements are disabled. Use the SETup:CAPPower:CONTinuous command to set the trigger arm state to single and retry this measurement.

During remote operation of this measurement, you should configure the Trigger Arm to Single. See SETup:FSTability:CONTinuous . If single triggering is used during manual operation, press the START SINGLE key to trigger each measurement.

This measurement is not designed to measure digital signals.

See Input Signal Requirements .

Interpreting Integrity Indicator values

See Integrity Indicator .

Related Topics

Frequency Stability Measurement Description


Gated Power Measurement Troubleshooting

Gated Power Measurement Troubleshooting

Last updated: October 28, 2004

Possible Setup Issues

If the Access Probe Power measurement is currently selected and the Trigger Arm setting is Continuous, all other measurements are disabled. Use the SETup:CAPPower:CONTinuous command to set the trigger arm state to single and retry this measurement.

During remote operation of this measurement, you should configure the Trigger Arm to Single. See SETup:GPOWer:CONTinuous . If single triggering is used during manual operation, press the START SINGLE key to trigger each measurement.

The test set receiver's expected signal amplitude and channel number (or frequency) must be set up correctly for accurate measurements. This is normally done automatically (see Active Cell Operating Mode ) but can also be done manually (see Receiver Control ) .

The following settings are required for the gated power measurement:

  • Operating Mode must be Active Cell
  • System Type must be IS-95 or IS-2000 with Radio Config set to (Fwd1, Rvs1) or (Fwd2, Rvs2)
  • FCH Service Option Setup must be set to SO2 or SO9 (loopback service option)
  • Traffic Data Rate must be set to Eighth.

The input signal must conform to Input Signal Requirements .

Related Topics

Integrity Indicator


Using GPIB Command Debug Mode

Using GPIB Command Debug Mode

Last updated: August 12, 2005

Description

It is recommended that you set the test set's operating environment to debug during GPIB code development. Test times may be longer than necessary if the debugger state is left on. When debug mode is on, the error message displayed on the test set's front panel when incorrect GPIB syntax is sent to the test set is enhanced with additional information to help you correct the syntax error.

To set the test set debug mode to "ON" use the following syntax:

SYSTem:COMMunicate:GPIB:DEBug ON

Related Topics

SYSTem:COMMunicate:GPIB:DEBug[:STATe]


Handoff Waveform Quality Measurement Troubleshooting

Handoff Waveform Quality Measurement Troubleshooting

Last updated: June 20, 2006

Possible Setup Issues

If a handoff waveform quality measurement is attempted while in active cell operating mode, a call must be connected so that long code information can be obtained from the mobile station and measurement triggers can be synchronized to the CDMA frame clock inside the test set.

A radio configuration 3 (F3R3) or radio configuration 4 (F4R3) call must be connected.

The START SINGLE key initiates a handoff waveform quality measurement from the front panel (see Measuring Handoff Waveform Quality for manual measurement instructions).

If the Access Probe Power measurement is currently selected and the Trigger Arm setting is Continuous, all other measurements are disabled. Use the SETup:CAPPower:CONTinuous command to set the trigger arm state to single and retry this measurement.

The test set receiver's expected signal amplitude and channel number (or frequency) must be set up correctly for accurate measurements. This is normally done automatically (see Active Cell Operating Mode ) but can also be done manually (see Receiver Control ).

When the handoff waveform quality measurement is running, changing PLCM Type causes the measurement aborted and restarted. See PLCM Type for details.

Interpreting Integrity Indicator values

An integrity indicator of 17 (Can not correlate), indicates that the received signal did not correlate with an internally generated reference signal. See Integrity Indicator .

Related Topics

Integrity Indicator


Maximum/Minimum Power Measurement Troubleshooting

Maximum/Minimum Power Measurement Troubleshooting

Last updated: October 28, 2004

IMPORTANT
The maximum/minimum power measurement does not run concurrently with any other measurements. If any measurements are running, they are closed when Maximum/Minimum power measurement is initiated, and a message is displayed indicating that a measurement has been closed. Activating another measurement inactivates the maximum/minimum power measurement.

The Maximum/Minimum power measurement uses single triggering. Press the START SINGLE key to trigger each measurement. See Triggering of Measurements for details on trigger settings.

Troubleshooting Techniques

Check to see if an integrity indicator other than 0 (normal) was returned with a measurement result (see Integrity Indicator ).

  • If Over Range (5) is returned; the input power has exceeded +37 dBm or is greater than +9 dB above the expected power level of the receiver.
  • If Under Range (6) is returned; the input power is below -61 dBm or is less than -9 dB below the expected power level of the receiver.
  • If the signal has both over range and under range conditions, only the over range (5) will be indicated.
    Under Range/Over Range Integrity Indicators

Other Considerations

  • To help avoid over range or under range integrity indicators, correct for system path loss (see Amplitude Offset ).
  • If you are manually controlling the test set's receiver, be certain that you have entered the correct frequency and power values for your test setup (see Receiver Control ).
  • Calibrating the Maximum/Minimum Power Measurement

Related Topics

Maximum/Minimum Power Measurement Description


Multi-Tone Audio Troubleshooting

Multi-Tone Audio Troubleshooting

Last updated: June 20, 2007

NOTE
The Multi-Tone Audio measurement can not be concurrent with the Audio Analyzer instrument nor with the Swept Audio measurement. Hence starting the multi-tone audio measurement will turn off any other measurement that is active, and vice versa.

NOTE
All of the measurements except for the multi-tone audio measurement become unavailable when the Voice SO Mode is set to Multi-Tone or Null Frame. This is because many of the DSP resources are consumed for producing the audio signal and running the vocoder so there are not enough left to perform other measurements.

Possible Setup Issues

During remote operation of this measurement, you should always set the Trigger Arm to Single. See SETup:CMAudio:CONTinuous . If single triggering is used during manual operation, press the START SINGLE key to trigger each measurement.

For accurate measurements, always set all the multi-tone audio measurement setup parameters to their proper settings for the measurement being made. Uplink, Downlink, and SINAD and Distortion measurements typically use different settings depending on the combination used.

  • You should select a voice service option (SO1, SO3, SO17, SO68, or SO32768) (see Service Option ) and set the Voice SO Mode to Multi-Tone (see Voice SO Mode ) to perform the downlink multi-tone audio measurement.
  • You should select a voice service option (such as SO1, SO3, SO17, SO68, or SO32768) (see Service Option ) and set the voice SO mode to Null Frames (see Voice SO Mode ) to perform the uplink multi-tone audio measurements.
  • See also Requirements when making a downlink multi-tone audio measurement and Requirements when making an uplink multi-tone audio measurement .
  • The SINAD and Distortion measurements are made on the first audio tone. It is recommended that you set the downlink or uplink audio generator to produce single tone (see Multi-Tone Audio Generator Parms ) when making the SINAD and Distortion measurements. If multi-tone is selected, all other tones will be measured as noise resulting in bad SINAD and Distortion results.

  • In the SINAD and Distortion measurement if you want to change the service option (SO1, SO3, SO17, SO68, or SO32768), after changing the service option, you should set the Multi-Tone Audio Total Level to 0 V first then reset the value you want. Otherwise so much noise will result in bad SINAD and Distortion results.

During downlink multi-tone audio measurement, if "Over Range" is displayed, it indicates that the measured audio signal at AUDIO IN port is far above the Expected Audio In Peak Voltage setting. You should increase the Expected Audio In Peak Voltage setting. If "Under Range" is displayed, it indicates that the measured audio signal at AUDIO IN port is far below the Expected Audio In Peak Voltage setting. You should decrease the Expected Audio In Peak Voltage setting. You can adjust the Expected Audio In Peak Voltage setting based on the value of Total Meas Audio Level which is shown in the Multi-Tone Audio Information table below the graph display.

When using an audio breakout on the mobile station, do not connect both the microphone input and the speaker out to the test set at the same time. This will impact measurement accuracy.

The mobile station's echo canceller implementation can impact measurement results. If possible, turn this off while making multi-tone audio measurements.

Other Techniques

Check to see if an integrity indicator other than 0 (normal) was returned with a measurement result (see Integrity Indicator ).

Related Topics

Multi-Tone Audio Measurement Description


Troubleshooting Setting Power Levels

Troubleshooting Setting Power Levels

Last updated: October 28, 2004

The test set's hardware has finite output power limitations. The output power is a combination of AWGN and cell power, which consists of code channels of varying power. The settable ranges for these power levels vary, and are often greater than what is allowed at any given time, due to the fact that the total output power is limited. A power level setting may be within the settable range but cause an error message to be displayed.

Possible Setup Issues

  • Dynamic range between Cell Power and AWGN Power
    The difference between cell power and AWGN power must not be greater than 20 dB when both powers are ON.
  • Dynamic range between Total RF Power and Relative Code Channel Power Levels
    Any code channel powers that are ON must not be greater than 30 dB below the Total RF Power. Note that OCNS level is not included in this error check and can be 40 dB below the cell power (at this level the OCNS is set to OFF).
  • Output Power considering Amplitude Offset
    The total RF power (cell power + AWGN power) and amplitude offset may not set the source outside its valid hardware range.

How Do the Amplitude Offset Settings Impact Mobile Station Tests?

The maximum amplitude offset allowed is +/-100 dB. However, the practical limit for external loss (negative amplitude offset) is set by the minimum channel power measurement and maximum signal generator output.

For example, the test set's signal generator can provide a maximum of -13 dBm /1.23MHz (CDMA modulated) and the channel power measurement minimum input is -69 dBm /1.23MHz. So the practical amplitude offset limit for performing TIA/EIA-98-E 4.4.6 Minimum Controlled Output Power (see Testing 4.4.6 Minimum Controlled Output Power ) and 3.5.1 Receiver Dynamic Range (see Testing 3.5.1 Receiver Sensitivity and Dynamic Range ) tests is -12 dB. This is dictated by the maximum RF Signal Generator output level of -13 dBm /1.23MHz with CDMA modulation (see Range of Power Levels ). The minimum power and dynamic range tests require a -25 dBm /1.23MHz CDMA modulated input to the mobile station's receiver, so the maximum external path loss for these tests is 12 dB (an amplitude offset of -12 dB).

CDMA tests that do not require a high forward link (signal generator) power or measuring a low mobile TX level can use higher amplitude offset values. The Demodulation of Forward Traffic Channel in AWGN test is a good example (see Testing 3.4.1 Demodulation of Forward Traffic Channel in AWGN ). In this case the test requires a -55 dBm /1.23MHz CDMA modulate signal and a -54 dBm /1.23MHz AWGN signal into the mobile station's receiver. The test set can provide a maximum of -13 dBm /1.23MHz CDMA modulated signal and a maximum of -20 dBm /1.23MHz AWGN signal (with overrange to -15 dBm with reduced unspecified performance). Therefore, the maximum external path loss for this test is 32 dB (an amplitude offset of -32 dB) since AWGN range is narrower (-34 dB, that is -54 dBm minus -20 dBm) than CDMA modulated signal (-42 dB, that is -55 dBm minus -13 dBm).

In summary, for all CDMA mobile tests the external path loss must not result in requiring more than -13 dBm/1.23MHz from the test set's signal generator or measuring less than -69 dBm /1.23MHz with the channel power measurement.

It is very important that the external path loss value be entered into the RF IN/OUT Amplitude Offset table on the system config screen (see Amplitude Offset ). If the external path loss is not entered into the table, the test set will not range properly and unstable performance will result.

Related Topics

Configuring Cell Power and AWGN Power Levels


Spectrum Monitor Troubleshooting

Spectrum Monitor Troubleshooting

Last updated: October 28, 2004

Possible Setup Issues

During remote operation of the Spectrum Monitor you should configure the trigger arm to single, see SETup:SMONitor .

If the trigger arm is not set to single, the Spectrum Monitor may not return a result. When trigger arm is continuous the Spectrum Monitor rearms itself and starts another measurement cycle, during remote operation the fetch query may not be synchronized to the measurement cycle, see Measurement States .

If trigger source immediate is used for burst modulated signals the results returned will be unreliable. Burst modulated signals should be measured with Trigger Source set to RF Rise or Auto. For RF Rise triggering to work correctly, the signal should be no less than 20 dB below the reference and greater than -20 dBm.

Interpreting Integrity Indicator values

See Integrity Indicator .


Signaling Tone Troubleshooting

Signaling Tone Troubleshooting

Last updated: June 20, 2006

Possible Setup Issues

If the input signal is not present or is less than the minimum required input signal, then the integrity is set to "Under Range" and all other results of the measurement are 9.91E+37.

If the signaling tone overdrides the receiver or is clipped by the receiver, then the integrity is set to "Over Range" and all other results of the measurement are 9.91E+37.

To meet performance specifications, the input signal must be within +/- 2.5 kHz of test set's expected frequency, 10 kHz. The input signal at the RF IN/OUT connection must have analog TX power of at least -15 dBm. The ratio of the input signal's deviation to residual FM must be greater than 30 dB.

If a Supervisory Audio Tone (SAT) is present, the deviation caused by SAT is not included in the deviation results.

Interpreting Integrity Indicator values

See Integrity Indicator

  • If Over Range (5) is returned, it indicates that the measured input power has exceeded test set' s internal sampler maximum value by at least 6 dB during some part of the sampling or the input power has exceeded the calibrated range of the test set' s power detector for the expected power setting.
  • If Under Range (6) is returned, it indicates that the measured input power is more than 20 dB below the expected input power level. Under range also indicates that the input power is more than 2 dB below the calibrated range of the test set' s power detector (-30 dBm). If the expected input power setting is correctly set for signal level into the test set, an under range condition can still occur if the receiver has not been tuned to the signal' s frequency.
  • If the measurement has several errors, the error that has the highest priority is indicated.

Related Topics

Signaling Tone Measurement Description

Measuring Signaling Tone

Programming a Signaling Tone Measurement


Swept Audio Measurement Troubleshooting

Swept Audio Measurement Troubleshooting

Last updated: October 28, 2004

Possible Setup Issues

During remote operation of the Swept Audio measurement, you should always set the Trigger Arm setting to Single. The length of time required to return a measurement over GPIB using continuous triggering varies, but is always longer than when using single triggering. Continuous triggering can also cause problems when the INITiate:DONE? query is used.

If digital measurements are active, turn them off or set their trigger source to Immediate. See Triggering of Measurements .

The Detector Type selected (peak or rms) also sets how Audio Level measurements are displayed; as a peak value or an rms value. When comparing returned values over GPIB to your specifications, be sure to take into account the type of detector being used.

The Expected Peak Voltage is always set in V peak , regardless of the Detector Type selected, and cannot exceed 20 V peak (14.1 V rms ).

For accurate measurements, always set the Detector Type, Filter Type, and other audio analyzer settings for the type of measurement being made. The SINAD and Distortion measurements typically use different settings than the Audio Level measurement. See Audio Analyzer Measurement Description and Audio Analyzer Block Diagram .

For very low level audio signals, or for measurements made in a noisy environment, use the 100 Hz BW BPF filter to reduce the affects of noise (see Audio Level Measurement Description ).

Interpreting Integrity Indicator Values

See Integrity Indicator .

If over range (5) is returned, the input level is greater than 4.9 dB above the Expected Peak Amplitude value or the maximum input level of 20 volts peak.

If under range (6) is returned, the input level is lower than 8 dB below the Expected Peak Amplitude value.

If the signal has both over range and under range conditions, only the over range condition (5) is indicated.


TDSO Frame Error Rate Troubleshooting

TDSO Frame Error Rate Troubleshooting

Last updated: October 28, 2004

TDSO Frame Error Rate (FER) Setup Issues

TDSO FER results may take up to 20.48 seconds to display

A call must be setup using one of the following service options:

  • SO32 (+F-SCH) or

  • SO32 (+ SCH)

If "No F-SCH" is displayed in the bottom right portion of the display, the supplemental channel is not connected.

The TDSO FER test returns the confidence level based on the average FER result obtained over the fixed frame count length. If the confidence level is less than 95% for the specified FER confidence requirement, the test has not passed minimum standards.

If the test set misses an FER results message from the mobile station, a GPIB query of that measurement will include the integrity indicator Call Processing Operation Failed.

Related Topics

TDSO Frame Error Rate Measurement Description


Test Set Lockup During Power Up Sequence

Test Set Lockup During Power Up Sequence

Last updated: February 3, 2005

Description

Loading application firmware onto your test set that is not compatible with your test set's hardware configuration can cause your test set to lock up when you attempt to switch to that application.

For information on application firmware and test set hardware compatibility, see:

http://www.agilent.com/find/8960upgrades

Test sets shipped after February, 2004 include a lockup recovery utility in the event that a test set lockup occurs. If you tried to switch to an incompatible application and your test set locked up during its power up sequence, turn the test set off. Turn the test set back on, and when the following text is displayed:

"Press `SYSTEM CONFIG' key to enter application selection utility."

press the SYSTEM CONFIG key.

If you press the SYSTEM CONFIG key within five seconds from the time this message is first displayed, a menu of installed applications will be displayed allowing you to select another application.

Select an application that is compatible with your test set's hardware by entering the appropriate number listed on the display using the DATA ENTRY keys.


Time Response of Open Loop Power Control (TROLPC) Troubleshooting

Time Response of Open Loop Power Control (TROLPC) Troubleshooting

Last updated: October 28, 2004

Possible Setup Issues

NOTE
No other measurements can be running while the TROLPC measurement is active. If any measurements are running, they are closed when TROLPC is initiated, and a message is displayed indicating that a measurement has been closed. Activating another measurement inactivates the TROLPC measurement.

NOTE
If the TROLP measurement is running at the time the power control transient transmission starts (see Starting the Reverse CLPC Transient ) the measurement will be closed and its operation aborted. Moreover, the TROLP measurements can not be initiated while the transient transmission is in progress.

NOTE
For the lab application, the TROLPC measurement can not be initiated when the mobile station is in gated transmission on the R-FCH (see Operating Considerations ).

The following settings are required for the TROLPC measurement:

  • A call must be connected in loopback service option with full data rate.
  • The Cell Power setting must allow for 20 dB of cell power adjustment before the step up or down occurs. The range of Cell Power adjustment is affected by amplitude offsets. See CALL[:CELL[1]]:POWer:AMPLitude[:SELected] for a description of Cell Power range issues.
  • Cell power must be at least 20 dB below the maximum cell power level to perform a TROLPC measurement with a +20 dB step change in cell power. Cell power must be at least 20 dB above the minimum cell power level to perform a TROLPC measurement with a -20 dB step change in cell power. The cell power range is affected by amplitude offsets (see Cell Power, AWGN Power and Total RF Power Ranges ).
  • AWGN power must be off (see Cell Power, AWGN Power and Total RF Power Ranges ).
  • Receiver power must be set to auto (see Receiver Control ).
  • During remote operation of this measurement, you must specify the cell power step change direction using the SETup:TROPower:STEP command, and then start the measurement using either the INITiate<:measurement mnemonic>[:ON] or READ:TROPower[:ALL]? command. During manual operation, you must select either Start Meas Up ( F2 ) or Start Meas Down ( F3 ), or press the START SINGLE key to trigger each measurement. Each time you start the measurement, one 20 dB step change is performed.

Troubleshooting Techniques

  • Check to see if an integrity indicator other than 0 (normal) was returned with a measurement result (see Integrity Indicator ).

    If over range (5) is returned the input power has exceeded the test set's internal sampler maximum value during some part of the sampling or the input power has exceeded the calibrated range of the test set's power detector.

    If under range (6) is returned the measurement result is below the expected input power level. Under range is also indicated if the input power is below the calibrated range of the test set's power detector.

    If the signal has both over range and under range conditions, only the over range (5) will be indicated.

Other Considerations

  • To avoid over range or under range integrity indicators, correct for system path loss (see Amplitude Offset ).
  • If you are manually controlling the test set's receiver, be certain that you have entered the correct frequency value for your test setup (see Receiver Control ).
  • Input Signal Requirements
  • Calibrating the TROLPC Measurement

Related Topics

Time Response of Open Loop Power Control (TROLPC) Measurement Description


User Interface (UI) Log

User Interface (UI) Log

Last updated: July 27, 2007

Description

To help you troubleshoot or optimize your GPIB control programs, you can configure the test set to capture GPIB interface traffic and store it in the UI (User Interface) Log. To enable GPIB logging, see Step 2: Turn On UI Log GPIB State .

The UI log buffer can store up to 51200 bytes of information. If the buffer is full, the oldest entry is removed from the top of the log and the newest entry is added to the end.

You can reset and access the UI Log through either the GPIB interface or a Web Browser.

The following procedures demonstrate how to reset and access the UI Log.

  • Step 1: Clear UI Log Data
  • Step 2: Turn On UI Log GPIB State
  • Step 3-1: Get UI Log Data
  • Step 3 - 2: Get Other UI Log Information (Optional)
  • Step 4: Save UI Log Data

Step 1: Clear UI Log Data

Before capturing new GPIB traffic, you can clear the residual information in UI Log storage. Two methods are valid to clear UI Log data storage in the test set:

  • Clear the UI Log via Local Area Network (LAN)

    • Connect your computer to the test set via LAN or directly via a LAN crossover cable.
    • Go to the URL of the test set using a web browser such as Internet Explorer.
      URL in Web Browser to Clear UI Log Data
      Command | Example
      http:// <test_set_ip_address> /uilogclear | http://111.222.333.444/uilogclear

    Clear UI Log Data

  • Clear the UI log via GPIB

    • Connect your computer to the test set via a GPIB interface.
    • Send the GPIB command in the following table to the test set and the log is cleared.

    SYSTem:LOG:UI:CLEAR

    GPIB Command to Clear the UI Log
    Command | Example
    SYSTem:LOG:UI:CLEAR | SYST:LOG:UI:CLEAR

Step 2: Turn On UI Log GPIB State

  • Send the GPIB command in the following table to the test set before you run your test program or send it from the point in your program where it is desired to start GPIB logging.

    NOTE
    The Log GPIB state is reset to OFF after cycling power. It is not reset by a full preset.

    SYSTem:LOG:UI:GPIB[:STATe]

    UI Log GPIB State Command
    Command Example

    SYSTem:LOG:UI:GPIB[:STATe] ON|OFF

    SYST:LOG:UI:GPIB:STAT ON

Step 3-1: Get UI Log Data

  • Go to the URL of the test set using your web browser to retrieve the GPIB log. The GPIB log is displayed in the browser window.

    NOTE
    You must ensure the computer is connected to the test set either via Ethernet LAN or a direct connection using a LAN crossover cable.

    URL in Web Browser to get the UI Log Data
    Command | Example
    http:// <test_set_LAN_IP_Address> /uilog | http://111.222.333.444/uilog
    Display UI Log Data in Web Browser

    NOTE
    In addition to GPIB traffic information, the UI Log also includes data regarding the key presses, knob turns and error messages that occur as you operate your test set from the front panel. Only the lines with the prefix "rem:" indicate the GPIB commands.

The UI Log display is not real time, therefore the latest UI log does not display automatically in the web browser. To capture multiple logs, click Refresh in the View menu.

Step 3 - 2: Get Other UI Log Information (Optional)

You can get more information about UI log data by sending the GPIB queries.

  • Query the number of lines containing GPIB commands in the UI Log

    The GPIB query in the following table returns the number of lines in the log since the last time the log was cleared.

    SYSTem:LOG:UI:COUNt?

    Query the number of lines in the UI Log
    Command Example

    SYSTem:LOG:UI:COUNt?

    SYST:LOG:UI:COUN?
  • Query the string at the specified line in the UI Log

    The GPIB query in the following table returns the string located at the line in the log that you specify. Note that issuing this command turns off GPIB logging. You must turn it back on using the SYSTem:LOG:UI:GPIB[:STATe] command to continue GPIB logging.

    SYSTem:LOG:UI:REPort?

    Query the string in the UI Log
    Command Example

    SYSTem:LOG:UI:REPort? <sp><number value>

    SYST:LOG:UI:REP? 11

Step 4: Save UI Log Data

To save the log in the Web Browser to a file:

  1. In the File menu, click Save As....
  2. In the Save as type: box, select Text File (*.txt).
  3. In the File name: box, type the file name.
  4. Click the Save button.

Related Topics

SYSTem:COMMunicate:GPIB:DEBug[:STATe]


Wideband Data Deviation Troubleshooting

Wideband Data Deviation Troubleshooting

Last updated: June 20, 2006

Possible Setup Issues

If only part of wideband data burst is sent or detected during the gate time, either because the measurement is triggered in the middle of the data or because the measurement ends in the middle of the data burst, that data burst will not be reported and will be treated as if it was not detected.

If the input signal is not present or is less than the minimum required input signal, then the integrity is set to "Under Range" and all other results of the measurement are 9.91E+37.

If the input signal overdrives the receiver or is clipped by the receiver, the integrity is set to "Over Range" and all other results of the measurement are 9.91E+37.

Interpreting Integrity Indicator values

See Integrity Indicator

  • If Over Range (5) is returned, it indicates that the input power has exceeded test set' s internal sampler maximum value by at least 6 dB during some part of the sampling or the input power has exceeded the calibrated range of the test set' s power detector for the expected power setting.
  • If Under Range (6) is returned, it indicates that the measured input power is more than 20 dB below the expected input power level. Under range also indicates that the input power is more than 2 dB below the calibrated range of the test set' s power detector (-30 dBm). If the expected input power setting is correctly set for signal level into the test set, an under range condition can still occur if the receiver has not been tuned to the signal' s frequency.
  • If Burst Not Found (25) is returned, it indicates that the wideband data burst is not captured during the gate time or only part of wideband data burst is detected.
  • If the measurement has several errors, the error that has the highest priority is indicated.

Related Topics

Wideband Data Deviation Measurement Description

Measuring Wideband Data Deviation

Programming a Wideband Data Deviation Measurement


Waveform Quality Measurement Troubleshooting

Waveform Quality Measurement Troubleshooting

Last updated: June 20, 2006

Possible Setup Issues

If the Access Probe Power measurement is currently selected and the Trigger Arm setting is Continuous, all other measurements are disabled. Use the SETup:CAPPower:CONTinuous command to set the trigger arm state to single and retry this measurement.

During remote operation of this measurement, you should configure the Trigger Arm to Single. See SETup:WQUality:CONTinuous . If single triggering is used during manual operation, press the START SINGLE key to trigger each measurement.

If a waveform quality measurement is attempted while in active cell operating mode, a call must be connected so that long code information can be obtained from the mobile station and measurement triggers can be synchronized to the CDMA frame clock inside the test set.

The test set receiver's expected signal amplitude and channel number (or frequency) must be set up correctly for accurate measurements. This is normally done automatically (see Active Cell Operating Mode ) but can also be done manually (see Receiver Control ).

When the waveform quality measurement is running, changing PLCM Type causes this measurement aborted and restarted. See PLCM Type for details.

Interpreting Integrity Indicator values

An integrity indicator of 17 (Can not correlate), indicates that the received signal did not correlate with an internally generated reference signal. See Integrity Indicator .

Related Topics

Waveform Quality/Code Domain Measurement Description


E6702T User Documentation

E6702T User Documentation

Last updated: December 8, 2006

The features and functionality present in the E6702T Special cdma2000 Lab Application are identical to those offered in the E6702B cdma Lab Application, with the exceptions described in this document. For information on how to use the features that are common to the E6702B and E6702T, see the cdma2000 online user's guide located at:

http://wireless.agilent.com/rfcomms/refdocs/cdma2k/default.php

The E6702T can only be loaded onto an E5515C with Special cdma2000 Lab Application Hardware (or a test set with the equivalent hardware upgrades). Contact your local Agilent Sales Representative for more information, or visit www.agilent.com/find/8960upgrades.

In a test set with Special cdma2000 Lab Application Hardware, the standard Protocol Processor is replaced with a High Date Rate Protocol Processor, and the test set's rear panel is modified to include a new LAN 2 PORT , which you must use for sending data to the test set (previously the LAN 1 PORT was used for this purpose).

LAN 2 PORT

The Special cdma2000 Lab Application Hardware required to run the E6702T includes a modified rear panel with a new LAN 2 PORT. To use the E6702T Data Channels functionality (to establish a Packet Data connection, for example), you must connect your data server to LAN 2 PORT, rather than to LAN 1 PORT as in the past. LAN 1 PORT is still used for all other LAN operations such as protocol logging, firmware downloads and screen captures.

The LAN 2 PORT connects directly to the test set's High Data Rate protocol processor, as shown in the block diagram below.

You must configure the address of the LAN 2 PORT using the LAN IP Address 2 (Data+) setting (see Configuring the Test Set's LAN for general information about LAN IP addresses). LAN IP Address 2 (Data+) must not be the identical to the LAN IP Address setting, and must be on the same subnet as the LAN IP Address setting. If LAN IP Address or Subnet Mask is changed such that LAN IP Address 2 (Data+) is identical to or is no longer on the same subnet as LAN IP Address , then LAN IP Address 2 (Data+) is set to 0.0.0.0 and a warning is posted.

LAN IP Address 2 (Data+) is accessible from the Instrument Setup menu on the System Config Screen . The GPIB command for LAN IP Address 2 (Data+) is SYSTem:COMMunicate:LAN[:SELF]:ADDRess2<sp><string> . See SYSTem:COMMunicate:GPIB:[:SELF]:ADDRess for range information.

Additional Information

  • The SYSTem:APPLication:CATalog[:NAME]? query includes "1xEV-DO Lab App T" , "CDMA 2000 Lab App T" , "GSM/GPRS Lab App T" , "GSM/GPRS_WCDMA Lab App T" and "WCDMA Lab App T" .
  • The SYSTem:APPLication:CATalog:LICense:APPLIcation:ALL? query includes "E6701T","GSM/GPRS LA rev T" , "E6702T","CDMA2000 LA rev T" , "E6703T","WCDMA LA rev T" , "E6706T","1xEV-DO LA rev T" , "E6706T-102","1xEV-DO Re A ETAP" and "E6785T","GSM/GPRS_WCDMA LA rev T" .
  • In the E6702T, the SYSTem:APPLication[:CURRent][:NAME]? query returns "cdma2000 Lab App T" .